DynamicNode

DynamicNodes von Tobias Kiertscher
[image]

DynamicNodes API
DynamicNode
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Namespaces

Namespace | Description
DynamicNode.Core | Dieser Namensraum enthält alle Typen für den DynamicNodes-System-Kern. Gute Klassen für einen Einstieg in die API sind Runtime, Graph, Node und StreamNode.
DynamicNode.Core.Nodes | Dieser Namensraum enthält alle konkreten Knoten-Implementierungen, die zum Systemkern gehören.
DynamicNode.Ext.Cockpit | Dieser Namensraum enthält eine Erweiterung, welche die Programmierung einer Cockpit-Benutzerschnittstelle mit Hilfe von Knoten ermöglicht. Die Knotenbibliothek, welche Knoten für Cockpit-Steuerelemente bereitstellt ist DNLibCockpit.
DynamicNode.Ext.Gui | Dieser Namensraum enthält Klassen für die Erweiterung der Benutzeroberfläche mit Hilfe von Scripten oder externen Assemblies. Die Erweiterungen der Benutzeroberfläche werden mit Hilfe von XML-Dateien (*.gui.xml) beschrieben. Es können statische .NET-Methoden oder PowerShell-Scripts als Befehle in der Benutzeroberfläche verfügbar gemacht werden. Mit Hilfe der Klassen in diesem Namensraum, kann die Benutzeroberfläche von DynamicNodes um Funktionen erweitert werden, ohne DynamicNodes neu zu kompilieren. Die wichtigste Klasse in diesem Namensraum ist CommandLoader<(Of <<'(TAppCore>)>>).
DynamicNode.Ext.Objects | Dieser Namensraum enthält Erweiterungen für das Kapseln von CLR-Elementen wie Methoden, Properties oder Events in einigen wenigen generischen Knoten. Die Knotenbibliothek, welche diese Funktionalität verfügbar macht ist DNLibObjects.
DynamicNode.Ext.Remoting | Dieser Namensraum enthält eine Standardimplementierung der Schnittstellen aus dem Namensraum DynamicNode.Remoting. Die Implementierung wird durch eine Anzahl an Proxy-Klassen realisiert, welche den Fernzugriff auf das Datenmodell einer Laufzeitumgebung gestatten.
DynamicNode.Ext.Visual | Dieser Namensraum enthält neben vielen Typen, welche für grafische Darstellung und Bearbeitung von Graphen verwendet werden können, eine Anzahl an Basisklassen für die Knotenentwicklung mit grafischer Unterstützung. Wichtige Typen in diesem Namensraum sind die Basisklassen für die Knotenentwicklung VisualNode und ProgressNode, die Erweiterungen der Datenstruktur von Graphen um visuelle Eigenschaften GraphVisualization, NodeVisualization, PortVisualization und Pin, und einige Typen für die Implementierung eines Editor GraphDocument, Painter, Editor und AbstractTool.
DynamicNode.Ext.Visual.Controls |
DynamicNode.Model | Dieser Namensraum enthält die Schnittstellen und Basisklassen für das Datenmodell der DynamicNodes-Laufzeitumgebung.
DynamicNode.Persistence | Dieser Namensraum enthält Typen mit allgemeinen Persistenz-Mechanismen für das DynamicNodes-System.
DynamicNode.Remoting | Dieser Namensraum enthält Schnittstellen und Typen für die Fernsteuerung einer DynamicNodes-Laufzeitumgebung über eine Netzwerkverbindung. Eine wichtige Klasse in diesem Namensraum ist die Server-Klasse, welche für eine Remote-Verbindung als Einsteigsklasse registriert werden kann. DynamicNodesServer
DynamicNode.Test | Dieser Namensraum enthält Typen für eine Testumgebung für Knotentypen. Die wichtigsten Typen in diesem Namensraum sind TestBench und ITestCase.
DynamicNode.Test.Cases | Dieser Namensraum enthält eine Anzahl von Testfällen für die Knoten-Typen-Testumgebung von DynamicNodes.
DynamicNode.Tools.Mathematics |
DynamicNode.Types.Base | Dieser Namensraum enthält ein Anzahl von Datentypen für die Datenverarbeitung in Flussgraphen. Dazu gehören u.a. mathematische Konstrukte wie Vektoren, Matrizen und Tupel.
DynamicNode.Types.Imaging | Dieser Namensraum enthält eine Anzahl von Datentypen für die Bildverarbeitung mit Flussgraphen.
DynamicNode.WinApp | Dieser Namensraum enthält die grafische Entwicklungsumgebung für das DynamicNodes-System. Die wichtigste Klasse in diesem Namensraum ist das Steuerelement DNApplicationControl. Mit diesem Steuerelement kann die Entwicklungsumgebung in andere Windows-Forms-Projekte eingebunden werden.
DynamicNode.WinApp.Tools |
DynamicNode.WinApp.Views |

Projekt-Website unter dynamicnodes.mastersign.de.

Senden Sie Kommentare zu diesem Feature an Tobias Kiertscher

Copyright © by Tobias Kiertscher 2007-2010


DynamicNode.Core Namespace

[image]

DynamicNodes API
DynamicNode.Core Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält alle Typen für den DynamicNodes-System-Kern.

Gute Klassen für einen Einstieg in die API sind Runtime, Graph, Node und StreamNode.

Classes

 | Class | Description
Public class | ConnectionEventArgs | Die Ereignisargumente, welche die Änderung einer Verbindung näher beschreiben.
Public class | ControlTrigger | Repräsentiert den Wert einer Steuermarke.
Public class | CoreTrace | Stellt statisch verfügbare Ablaufverfolgungsmethoden bereit.
Public class | CustomNodeFactoryVariation | Die Beschreibung einer Factory-Variation. Von dieser Klasse kann, abgeleitet werden.
Public class | DataTypeTools | Stellt statische Hilfsmethoden für den Umgang mit Datentypen zur Verfügung.
Public class | DefaultConfiguration | Die Standard-Implementierung von IConfiguration.
Public class | GenericDataTypeManager | Stellt für die Typen-Argumente eines generischen Datentyps Daten-Typ-Provider bereit.
Public class | GenericDataTypeManager..::..ExcludingConstraint | Eine Beschränkung, welche alle außer den übergebenen Typen zulässt.
Public class | GenericDataTypeManager..::..IncludingConstraint | Eine Beschränkung, welche nur die übergebenen Typen zulässt.
Public class | Graph | Die Standardimplementierung für eine Sammlung verbundener Knoten.
Public class | GraphEventArgs | Die Ereignisargumente, welche die Änderung eines Graphen näher beschreiben.
Public class | GraphFlagChangedEventArgs | Das Ereignis-Argument für die Änderungen eines Graphen-Flags.
Public class | InPort | Ein Eingang für einen Knoten.
Public class | InPortAttribute | Dieses Attribut kann benutzt werden um eine Eigenschaft als Eingangs-Port zu markieren. Falls eine Eigenschaft in einer von Node abgeleiteten Klasse mit InPortAttribute markiert ist, wird im Standardkonstruktor von Node automatisch ein Eingangs-Port erzeugt und mit der markierten Eigenschaft verknüpft.
Public class | InPortDataTypeGroup | Verwaltet eine Liste von Datentypen für mehrere Ports.
Public class | InPortDataTypeProvider | Stellt eine einfache Implementierung für IInPortDataTypeProvider zur Verfügung. Dieser Datentypen-Provider verwaltet eine Liste mit Datentypen welche von außen modifiziert werden kann. Wurde die Liste verändert, muss die Änderung mit CommitChanges()()()() bestätigt werden. Erst dann wird das Ereignis SupportedDataTypesChanged ausgelöst.
Public class | InPortDataTypeProviderBase | Stellt eine Basis-Implementierung für IInPortDataTypeProvider zur Verfügung.
Public class | InPortPersistenceExt | Eine Knoten-Erweiterung, welche die letzten Tokens eines unverbundenen Eingangs persistiert und restoriert.
Public class | InPortSingleDataTypeProvider | Stellt eine einfache Implementierung für IInPortDataTypeProvider zur Verfügung. Dieser Datentypen-Provider verwaltet einen einzelnen Datentyp. Wird dieser verändert, werden alle registrierten Eingänge informiert.
Public class | LogTools | Eine Sammlung von Funktionen, welche die Formatierung von System-Nachrichten erleichtern.
Public class | MappingOutPortDataTypeProvider | Ein Provider für den Datentyp eines Ausgangs, der den Datentyp in Abhängigkeit von einem Eingang und einem Dictionary ermittelt.
Public class | MessageBus | Der Standard-Nachrichten-Bus.
Public class | MessageWriter | Kann System-Nachrichten formatiert auf einen TextWriter ausgeben.
Public class | Node | Die Basis-Klasse für alle Knoten eines DynamicNode-Graphen.
Public class | NodeEventArgs | Die Ereignisargumente, welche die Änderung eines Knotens näher beschreiben.
Public class | NodeFactory | Verwaltet alle verfügbaren Knotentypen und bietet Methoden zum Instanzieren von neuen Knoten.
Public class | NodeFactory..::..NodeTypeWrapper | Kapselt die Beschreibung eines Knotentyps.
Public class | NodeInfoAttribute | Dieses Attribut wird verwendet um eine von Node abgeleitete Klasse mit Meta-Daten zu versehen. Diese Meta-Daten werden verwendet um eine Auswahl der verfügbaren Knoten-Typen in der Benutzeroberfläche zu ermöglichen, ohne einen Knoten zu instanzieren.
Public class | NodeInfoResourceClassAttribute | Mit diesem Assebmly-Attribut wird die Klasse benannt, welche den ResourceManager und die CultureInfo für das Laden von Knoten-Metadaten zur Verfügung stellt.
Public class | NodeLibDescriptorAttribute | Reichert eine Knotenbibliothek um Metainformationen an.
Public class | OutPort | Ein Ausgang für einen Knoten.
Public class | OutPortAttribute | Dieses Attribut kann benutzt werden um ein Feld mit dem Datentyp OutPortHandler<(Of <(<'T>)>)> als Ausgangs-Port zu markieren. Falls eine Eigenschaft in einer von Node abgeleiteten Klasse mit OutPortAttribute markiert ist, wird im Standardkonstruktor von Node automatisch ein Ausgangs-Port erzeugt und mit der markierten Eigenschaft verknüpft.
Public class | OutPortDataTypeProvider | Eine einfache Implementierung für IOutPortDataTypeProvider.
Public class | PoolThreadManager | Eine Implementierung von IThreadManager, welche die Funktionen der Klasse ThreadPool nutzt.
Public class | Port | Die abstrakte Basis-Klasse für Ein- und Ausgabe-Ports.
Public class | ResourceNodeInfoAttribute | Dieses Attribut wird verwendet um für eine von Node abgeleitete Klasse die Meta-Daten anzugeben. Im Unterscheid zu NodeInfoAttribute werden die Meta-Daten nicht als Konstanten angegeben, sondern aus einer Ressourcen-Bibliothek geladen. Dadurch wird es möglich, die Meta-Daten zu lokalisieren. Der Name des Knotens wird mit der ID <Klassenname>_Caption gesucht und die Beschreibung mit der ID <Klassenname>_Description. Die Gruppe wird mit der ID Group_<Gruppenname> gesucht. Diese Meta-Daten werden verwendet um eine Auswahl der verfügbaren Knoten-Typen in der Benutzeroberfläche zu ermöglichen, ohne einen Knoten zu instanzieren.
Public class | Runtime | Der Kern einer DynamicNode-Anwendung.
Public class | SerializedGraph | Repräsentiert einen serialisierten Graphen einschließlich dem Zustand aller Erweiterungen.
Public class | SerializedNode | Repräsentiert einen serialisierten Knoten einschließlich dem Zustand aller statischen Erweiterungen von Knoten und Anschlüssen.
Public class | SerializedNodeSet | Repräsentiert eine Gruppe von serialisierten Knoten (SerializedNode) einschließlich der Verbindungen die sich innerhalb der Gruppe befinden.
Public class | SerializedObject | Repräsentiert ein serialisiertes Objekt.
Protected class | SerializedObject..::..SerializationContext | Der XML-Serialisierungskontext.
Public class | StaticNodeInfoAttribute | Dieses Attribut wird verwendet um für eine von Node abgeleitete Klasse die Meta-Daten anzugeben. Im Unterscheid zu NodeInfoAttribute werden die Meta-Daten nicht als Konstanten angegeben, sondern eine öffentlich statisch Methode beschrieben, welche die Meta-Daten liefert. Dadurch wird es möglich, die Meta-Daten zu lokalisieren. Diese Meta-Daten werden verwendet um eine Auswahl der verfügbaren Knoten-Typen in der Benutzeroberfläche zu ermöglichen, ohne einen Knoten zu instanzieren.
Public class | Stream | Die Beschreibung einer Token-Sequenz. Kann als Basis-Klasse für spezialisierte Streams dienen.
Public class | StreamNode | Eine abstrakte Knoten-Basisklasse die optinale Synchronisationsmechanismen für Streams bietet.
Public class | SubGraphEventArgs | Die Ereignisargumente, einen Sub-Graphen referenzieren.
Public class | TaskEventArgs | Ereignisparameter für Task-Ereignisse.
Public class | TokenRejectionEventArgs | Die Ereignis-Argumente für Rejection. Diese Klasse ist nicht threadsicher!
Public class | TokenSet | Ein Set von Tokens, welche durch eine PortId identifiziert werden.
Public class | TokenSetRejectionEventArgs | Die Ereignis-Argumente für Rejection. Diese Klasse ist nicht threadsicher!
Public class | TokenSetSorter | Ein sortierender Puffer für TokenSets.
Public class | TokenSynchronizer | Synchronisiert eintreffende Tokens eines Knotens nach Index.
Public class | TriggerInPort | Dieser Eingang dient Knoten als Steuereingang für die Aktivierung. Am Beginn der Implementierung für die Work()()()()-Methode wird IsWorkingAllowed überprüft und sollte false zurückgegeben werden, wird die Arbeitsmethode unverzüglich verlassen.
Public class | TriggerOutPort | Dieser Ausgang dient Knoten für Benachrichtigungen über den Abschluss ihrer Arbeit.
Public class | XmlGraphStorage | Eine Implementierung von IGraphStorage, welche mit XML-Daten arbeitet.

Structures

 | Structure | Description
Public structure | Message | Eine DynamicNodes-System-Nachricht.
Public structure | Token | Die Datenstruktur für ein Token.

Interfaces

 | Interface | Description
Public interface | GenericDataTypeManager..::..IConstraint | Die Schnittstelle für eine Beschränkung für eine generisches Typen-Argument.
Public interface | IApplicationContext | Eine Schnittstelle für Anwendungen die DynamicNodes-Laufzeitumgebungen hosten.
Public interface | IAttachmentNode | Eine Knoten-Schnittstelle welche einen Anhang für den Graphen kapseln.
Public interface | IConfiguration | Die System-Konfiguration.
Public interface | ICustomNodeFactory | Eine Schnittstelle für benutzerdefinierte Knoten-Factories.
Public interface | IFlag | Die Schnittstelle für ein Graphen-Flag.
Public interface | IGraph | Jede Sammlung von verknüpften Knoten muss dieses Interface implementieren.
Public interface | IGraphStorage | Bietet die Möglichkeit, ein IGraph-Objekt zu speichern, oder zu rekonstruieren.
Public interface | IInPortDataTypeProvider | Eine Schnittstelle für Objekte die Datentypen für Eingänge bereitstellen.
Public interface | INode | Eine Schnittstelle für alle Knoten.
Public interface | IOutPortDataTypeProvider | Eine Schnittstelle für Objekte die einen Datentyp für Ausgänge bereitstellen.
Public interface | IPort | Die Schnittstelle für Ports an einem Knoten.
Public interface | IRuntime | Die Schnittstelle für ein Objekt, welches den Kern einer DynamicNodes-Anwendung bildet.
Public interface | ISingleThreadContext | Die Schnittstelle für Synchronisierungs-Kontexte. Wird für Technologien verwendet, deren Komponenten nur in einem Thread verwendet werden dürfen. Beispiele sind WindowsForms und WPF.
Public interface | IThreadManager | Das Interface eines Thread-Managers, der nebenläufige Aufgaben erzeugen, synchronisieren und abbrechen kann.
Public interface | ITypeConverter | Eine Schnittstelle für Datentyp-Konverter. Diese Schnittstelle wird durch den automatischen Datentyp-Konvertierungsmechanismus für Token-Werte verwendet. Durch diesen Mechanismus wird die Datentyp- Kompatibilität zwischen Knoten erhöht.

Delegates

 | Delegate | Description
Public delegate | CompatibilityChecker<(Of <(<'TPort>)>)> | Ein Delegate, mit dem die Kompatibilität zu einem Port überprüft werden kann.
Public delegate | ConnectionChangedHandler | Ein Handler zum Benachrichtigen von Änderungen der Verbindung eines Ports.
Public delegate | FireHandler | Ein Delegate für Handler, welche das Fired-Event eines Ausgangs konsumieren wollen.
Public delegate | MessageHandler | Eine DynamicNodes-System-Nachrichtenbehandlungsroutine.
Public delegate | OutPortHandler<(Of <(<'T>)>)> | Ein Delegate für das deklarative Erzeugen eines Ausgangs. Dazu muss ein öffentliches Feld mit diesem Delegate als Datentyp mit dem Attribut OutPortAttribute markiert werden. Der Datentyp des Ausgangs wird durch den Typparameter T definiert.
Public delegate | SimpleMethod | Ein einfaches parameterloses Delegate mit void als Rückgabewert.
Public delegate | TokenUpdateHandler | Ein Handler zum benachrichtigen von Veränderungen des Wertes eines Ports.

Enumerations

 | Enumeration | Description
Public enumeration | Affection | Eine Aufzählung der verschiedenen Ereignistypen, welche einen Knoten betreffen können.
Public enumeration | ConnectionEventTyp | Eine Aufzählung der verschiedenen Ereignistypen, welche eine Verbindung betreffen können.
Public enumeration | Parallelizing | Die Aufzählung aller möglichen Parallelisierungsformen von Knoten.
Public enumeration | SynchronizationMode | Gibt den Synchronisationsmodus für einen Knoten vor.
Public enumeration | TokenState | Beschreibt den Zustand eines Werts als Teil eines Tokens.


Affection Enumeration

[image]

DynamicNodes API
Affection Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Aufzählung der verschiedenen Ereignistypen, welche einen Knoten betreffen können.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public enum Affection
Visual Basic
Public Enumeration Affection
F#
type Affection

Members

Member name | Description
Added |
Removed |

See Also

DynamicNode.Core Namespace


CompatibilityChecker(TPort) Delegate

[image]

DynamicNodes API
CompatibilityChecker<(Of <(<'TPort>)>)> Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Delegate, mit dem die Kompatibilität zu einem Port überprüft werden kann.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public delegate bool CompatibilityChecker<TPort>(
    TPort p,
    out Type typeSelection
)
where TPort : Port
Visual Basic
Public Delegate Function CompatibilityChecker(Of TPort As Port) ( _
    p As TPort, _
    <OutAttribute> ByRef typeSelection As Type _
) As Boolean
F#
type CompatibilityChecker =
    delegate of
        p:'TPort *
        typeSelection:Type byref -> bool

Parameters

p
Type: TPort
Der Port.
typeSelection
Type: System..::..Type %
Wird mit dem ausgewählten Datentyp belegt, oder null, wenn der Rückgabewert false ist.

Type Parameters

TPort
Der Port-Typ für diesen Kompatibilitäts-Check.

Return Value

true, wenn der Port kompatibel ist, sonst false.

See Also

DynamicNode.Core Namespace


ConnectionChangedHandler Delegate

[image]

DynamicNodes API
ConnectionChangedHandler Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Handler zum Benachrichtigen von Änderungen der Verbindung eines Ports.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public delegate void ConnectionChangedHandler(
    Port port,
    int count
)
Visual Basic
Public Delegate Sub ConnectionChangedHandler ( _
    port As Port, _
    count As Integer _
)
F#
type ConnectionChangedHandler =
    delegate of
        port:Port *
        count:int -> unit

Parameters

port
Type: DynamicNode.Core..::..Port
count
Type: System..::..Int32

See Also

DynamicNode.Core Namespace


ConnectionEventArgs Class

[image]

DynamicNodes API
ConnectionEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignisargumente, welche die Änderung einer Verbindung näher beschreiben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class ConnectionEventArgs : EventArgs
Visual Basic
Public Class ConnectionEventArgs _
    Inherits EventArgs
F#
type ConnectionEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Core..::..ConnectionEventArgs

See Also

ConnectionEventArgs Members
DynamicNode.Core Namespace


ConnectionEventArgs Members

[image] [image]

DynamicNodes API
ConnectionEventArgs Members
ConnectionEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ConnectionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionEventArgs | Initialisiert eine NodeEventArgs-Instanz.

Properties

 | Name | Description
Public property | EventTyp | Gibt den Ereignistyp zurück.
Public property | InPort | Gibt den Eingangs-Port zurück, welcher von dem Ereignis betroffen ist.
Public property | OutPort | Gibt den Ausgangs-Port zurück, welcher von dem Ereignis betroffen ist.

See Also

ConnectionEventArgs Class
DynamicNode.Core Namespace


ConnectionEventArgs Constructor

[image]

DynamicNodes API
ConnectionEventArgs Constructor
ConnectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine NodeEventArgs-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public ConnectionEventArgs(
    InPort inPort,
    OutPort outPort,
    ConnectionEventTyp typ
)
Visual Basic
Public Sub New ( _
    inPort As InPort, _
    outPort As OutPort, _
    typ As ConnectionEventTyp _
)
F#
new :
        inPort:InPort *
        outPort:OutPort *
        typ:ConnectionEventTyp -> ConnectionEventArgs

Parameters

inPort
Type: DynamicNode.Core..::..InPort
Der betroffene Eingangsport.
outPort
Type: DynamicNode.Core..::..OutPort
Der betroffene Ausgangsport.
typ
Type: DynamicNode.Core..::..ConnectionEventTyp
Der Ereignistyp.

See Also

ConnectionEventArgs Class
DynamicNode.Core Namespace


ConnectionEventArgs Properties

[image] [image]

DynamicNodes API
ConnectionEventArgs Properties
ConnectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ConnectionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | EventTyp | Gibt den Ereignistyp zurück.
Public property | InPort | Gibt den Eingangs-Port zurück, welcher von dem Ereignis betroffen ist.
Public property | OutPort | Gibt den Ausgangs-Port zurück, welcher von dem Ereignis betroffen ist.

See Also

ConnectionEventArgs Class
DynamicNode.Core Namespace


EventTyp Property

[image]

DynamicNodes API
ConnectionEventArgs..::..EventTyp Property
ConnectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Ereignistyp zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public ConnectionEventTyp EventTyp { get; }
Visual Basic
Public ReadOnly Property EventTyp As ConnectionEventTyp
    Get
F#
member EventTyp : ConnectionEventTyp

Field Value

Der Ereignistyp.

See Also

ConnectionEventArgs Class
DynamicNode.Core Namespace


InPort Property

[image]

DynamicNodes API
ConnectionEventArgs..::..InPort Property
ConnectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Eingangs-Port zurück, welcher von dem Ereignis betroffen ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPort InPort { get; }
Visual Basic
Public ReadOnly Property InPort As InPort
    Get
F#
member InPort : InPort

Field Value

Der betroffene Eingangs-Port.

See Also

ConnectionEventArgs Class
DynamicNode.Core Namespace


OutPort Property

[image]

DynamicNodes API
ConnectionEventArgs..::..OutPort Property
ConnectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Ausgangs-Port zurück, welcher von dem Ereignis betroffen ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public OutPort OutPort { get; }
Visual Basic
Public ReadOnly Property OutPort As OutPort
    Get
F#
member OutPort : OutPort

Field Value

Der betroffene Ausgangs-Port.

See Also

ConnectionEventArgs Class
DynamicNode.Core Namespace


ConnectionEventTyp Enumeration

[image]

DynamicNodes API
ConnectionEventTyp Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Aufzählung der verschiedenen Ereignistypen, welche eine Verbindung betreffen können.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public enum ConnectionEventTyp
Visual Basic
Public Enumeration ConnectionEventTyp
F#
type ConnectionEventTyp

Members

Member name | Description
Created |
Destroyed |

See Also

DynamicNode.Core Namespace


ControlTrigger Class

[image]

DynamicNodes API
ControlTrigger Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Repräsentiert den Wert einer Steuermarke.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class ControlTrigger
Visual Basic
Public Class ControlTrigger
F#
type ControlTrigger =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..ControlTrigger

See Also

ControlTrigger Members
DynamicNode.Core Namespace


ControlTrigger Members

[image] [image]

DynamicNodes API
ControlTrigger Members
ControlTrigger Class Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ControlTrigger type exposes the following members.

Properties

Name | Description
Instance | Gibt die einzige Instanz des Steuer-Objekts zurück.

See Also

ControlTrigger Class
DynamicNode.Core Namespace


ControlTrigger Properties

[image] [image]

DynamicNodes API
ControlTrigger Properties
ControlTrigger Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ControlTrigger type exposes the following members.

Properties

Name | Description
Instance | Gibt die einzige Instanz des Steuer-Objekts zurück.

See Also

ControlTrigger Class
DynamicNode.Core Namespace


Instance Property

[image]

DynamicNodes API
ControlTrigger..::..Instance Property
ControlTrigger Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die einzige Instanz des Steuer-Objekts zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static ControlTrigger Instance { get; }
Visual Basic
Public Shared ReadOnly Property Instance As ControlTrigger
    Get
F#
static member Instance : ControlTrigger

See Also

ControlTrigger Class
DynamicNode.Core Namespace


CoreTrace Class

[image]

DynamicNodes API
CoreTrace Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt statisch verfügbare Ablaufverfolgungsmethoden bereit.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static class CoreTrace
Visual Basic
Public NotInheritable Class CoreTrace
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CoreTrace =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..CoreTrace

See Also

CoreTrace Members
DynamicNode.Core Namespace


CoreTrace Members

[image] [image]

DynamicNodes API
CoreTrace Members
CoreTrace Class Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CoreTrace type exposes the following members.

Methods

Name | Description
Error(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Error(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Error(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem.
ErrorF | Sendet einen formatierten Fehler an das Ablaufverfolgungssystem.
Info(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.
Info(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.
InfoF | Sendet eine formatierte, informative Meldung an das Ablaufverfolgungssystem.
Verbose(String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Verbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Verbose(String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Verbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
VerboseF(String, array<Object>[]()[][]) | Sendet eine formatierte Detailmeldung an das Ablaufverfolgungssystem.
VerboseF(Int32, String, array<Object>[]()[][]) | Sendet eine formatierte Detailmeldung an das Ablaufverfolgungssystem.
Warning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Warning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Warning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem.
WarningF | Sendet eine formatierte Warnung an das Ablaufverfolgungssystem.

Properties

Name | Description
TraceSource | Gibt die Ablaufverfolgungsquelle für Knoten zurück.

See Also

CoreTrace Class
DynamicNode.Core Namespace


CoreTrace Methods

[image] [image]

DynamicNodes API
CoreTrace Methods
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CoreTrace type exposes the following members.

Methods

Name | Description
Error(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Error(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Error(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem.
ErrorF | Sendet einen formatierten Fehler an das Ablaufverfolgungssystem.
Info(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.
Info(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.
InfoF | Sendet eine formatierte, informative Meldung an das Ablaufverfolgungssystem.
Verbose(String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Verbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Verbose(String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Verbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
VerboseF(String, array<Object>[]()[][]) | Sendet eine formatierte Detailmeldung an das Ablaufverfolgungssystem.
VerboseF(Int32, String, array<Object>[]()[][]) | Sendet eine formatierte Detailmeldung an das Ablaufverfolgungssystem.
Warning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Warning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Warning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem.
WarningF | Sendet eine formatierte Warnung an das Ablaufverfolgungssystem.

See Also

CoreTrace Class
DynamicNode.Core Namespace


Error Method

[image] [image]

DynamicNodes API
CoreTrace..::..Error Method
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Error(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Error(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Error(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem.

See Also

CoreTrace Class
CoreTrace Members
DynamicNode.Core Namespace


Error Method (Int32, String)

[image]

DynamicNodes API
CoreTrace..::..Error Method (Int32, String)
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet einen Fehler an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Error(
    int id,
    string text
)
Visual Basic
Public Shared Sub Error ( _
    id As Integer, _
    text As String _
)
F#
static member Error :
        id:int *
        text:string -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.

See Also

CoreTrace Class
Error Overload
DynamicNode.Core Namespace


Error Method (Int32, String, Exception)

[image]

DynamicNodes API
CoreTrace..::..Error Method (Int32, String, Exception)
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet einen Fehler an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Error(
    int id,
    string text,
    Exception e
)
Visual Basic
Public Shared Sub Error ( _
    id As Integer, _
    text As String, _
    e As Exception _
)
F#
static member Error :
        id:int *
        text:string *
        e:Exception -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.
e
Type: System..::..Exception
Die ursächliche Ausnahme.

See Also

CoreTrace Class
Error Overload
DynamicNode.Core Namespace


Error Method (Int32, String, Object[])

[image]

DynamicNodes API
CoreTrace..::..Error Method (Int32, String, array<Object>[]()[][])
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet einen Fehler an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Error(
    int id,
    string text,
    params Object[] data
)
Visual Basic
Public Shared Sub Error ( _
    id As Integer, _
    text As String, _
    ParamArray data As Object() _
)
F#
static member Error :
        id:int *
        text:string *
        data:Object[] -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Der Nachrichtentext.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Informationen. Bei allen übergebenen Objekten wird ToString()()()() verwendet, um sie darzustellen.

See Also

CoreTrace Class
Error Overload
DynamicNode.Core Namespace


ErrorF Method

[image]

DynamicNodes API
CoreTrace..::..ErrorF Method
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet einen formatierten Fehler an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void ErrorF(
    int id,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub ErrorF ( _
    id As Integer, _
    format As String, _
    ParamArray args As Object() _
)
F#
static member ErrorF :
        id:int *
        format:string *
        args:Object[] -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
format
Type: System..::..String
Die Formatierungszeichenfolge für den Nachrichtentext.
args
Type: array< System..::..Object >[]()[][]
Argumente für die Einbettung in die Formatierungszeichenfolge.

See Also

CoreTrace Class
DynamicNode.Core Namespace
String..::..Format(String, array<Object>[]()[][])


Info Method

[image] [image]

DynamicNodes API
CoreTrace..::..Info Method
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Info(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.
Info(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.

See Also

CoreTrace Class
CoreTrace Members
DynamicNode.Core Namespace


Info Method (Int32, String)

[image]

DynamicNodes API
CoreTrace..::..Info Method (Int32, String)
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine informative Meldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Info(
    int id,
    string text
)
Visual Basic
Public Shared Sub Info ( _
    id As Integer, _
    text As String _
)
F#
static member Info :
        id:int *
        text:string -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.

See Also

CoreTrace Class
Info Overload
DynamicNode.Core Namespace


Info Method (Int32, String, Object[])

[image]

DynamicNodes API
CoreTrace..::..Info Method (Int32, String, array<Object>[]()[][])
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine informative Meldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Info(
    int id,
    string text,
    params Object[] data
)
Visual Basic
Public Shared Sub Info ( _
    id As Integer, _
    text As String, _
    ParamArray data As Object() _
)
F#
static member Info :
        id:int *
        text:string *
        data:Object[] -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Nachricht.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Informationen. Bei allen übergebenen Objekten wird ToString()()()() verwendet, um sie darzustellen.

See Also

CoreTrace Class
Info Overload
DynamicNode.Core Namespace


InfoF Method

[image]

DynamicNodes API
CoreTrace..::..InfoF Method
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine formatierte, informative Meldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void InfoF(
    int id,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub InfoF ( _
    id As Integer, _
    format As String, _
    ParamArray args As Object() _
)
F#
static member InfoF :
        id:int *
        format:string *
        args:Object[] -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
format
Type: System..::..String
Die Formatierungszeichenfolge für den Nachrichtentext.
args
Type: array< System..::..Object >[]()[][]
Argumente für die Einbettung in die Formatierungszeichenfolge.

See Also

CoreTrace Class
DynamicNode.Core Namespace
String..::..Format(String, array<Object>[]()[][])


Verbose Method

[image] [image]

DynamicNodes API
CoreTrace..::..Verbose Method
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Verbose(String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Verbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Verbose(String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Verbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.

See Also

CoreTrace Class
CoreTrace Members
DynamicNode.Core Namespace


Verbose Method (String)

[image]

DynamicNodes API
CoreTrace..::..Verbose Method (String)
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Detailmeldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Verbose(
    string text
)
Visual Basic
Public Shared Sub Verbose ( _
    text As String _
)
F#
static member Verbose :
        text:string -> unit

Parameters

text
Type: System..::..String
Die Meldung.

See Also

CoreTrace Class
Verbose Overload
DynamicNode.Core Namespace


Verbose Method (Int32, String)

[image]

DynamicNodes API
CoreTrace..::..Verbose Method (Int32, String)
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Detailmeldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Verbose(
    int id,
    string text
)
Visual Basic
Public Shared Sub Verbose ( _
    id As Integer, _
    text As String _
)
F#
static member Verbose :
        id:int *
        text:string -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.

See Also

CoreTrace Class
Verbose Overload
DynamicNode.Core Namespace


Verbose Method (String, Object[])

[image]

DynamicNodes API
CoreTrace..::..Verbose Method (String, array<Object>[]()[][])
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Detailmeldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Verbose(
    string text,
    params Object[] data
)
Visual Basic
Public Shared Sub Verbose ( _
    text As String, _
    ParamArray data As Object() _
)
F#
static member Verbose :
        text:string *
        data:Object[] -> unit

Parameters

text
Type: System..::..String
Der Nachrichtentext.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Informationen. Bei allen übergebenen Objekten wird ToString()()()() verwendet, um sie darzustellen.

See Also

CoreTrace Class
Verbose Overload
DynamicNode.Core Namespace


Verbose Method (Int32, String, Object[])

[image]

DynamicNodes API
CoreTrace..::..Verbose Method (Int32, String, array<Object>[]()[][])
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Detailmeldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Verbose(
    int id,
    string text,
    params Object[] data
)
Visual Basic
Public Shared Sub Verbose ( _
    id As Integer, _
    text As String, _
    ParamArray data As Object() _
)
F#
static member Verbose :
        id:int *
        text:string *
        data:Object[] -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Der Nachrichtentext.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Informationen. Bei allen übergebenen Objekten wird ToString()()()() verwendet, um sie darzustellen.

See Also

CoreTrace Class
Verbose Overload
DynamicNode.Core Namespace


VerboseF Method

[image] [image]

DynamicNodes API
CoreTrace..::..VerboseF Method
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
VerboseF(String, array<Object>[]()[][]) | Sendet eine formatierte Detailmeldung an das Ablaufverfolgungssystem.
VerboseF(Int32, String, array<Object>[]()[][]) | Sendet eine formatierte Detailmeldung an das Ablaufverfolgungssystem.

See Also

CoreTrace Class
CoreTrace Members
DynamicNode.Core Namespace


VerboseF Method (String, Object[])

[image]

DynamicNodes API
CoreTrace..::..VerboseF Method (String, array<Object>[]()[][])
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine formatierte Detailmeldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void VerboseF(
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub VerboseF ( _
    format As String, _
    ParamArray args As Object() _
)
F#
static member VerboseF :
        format:string *
        args:Object[] -> unit

Parameters

format
Type: System..::..String
Die Formatierungszeichenfolge für den Nachrichtentext.
args
Type: array< System..::..Object >[]()[][]
Argumente für die Einbettung in die Formatierungszeichenfolge.

See Also

CoreTrace Class
VerboseF Overload
DynamicNode.Core Namespace
String..::..Format(String, array<Object>[]()[][])


VerboseF Method (Int32, String, Object[])

[image]

DynamicNodes API
CoreTrace..::..VerboseF Method (Int32, String, array<Object>[]()[][])
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine formatierte Detailmeldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void VerboseF(
    int id,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub VerboseF ( _
    id As Integer, _
    format As String, _
    ParamArray args As Object() _
)
F#
static member VerboseF :
        id:int *
        format:string *
        args:Object[] -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
format
Type: System..::..String
Die Formatierungszeichenfolge für den Nachrichtentext.
args
Type: array< System..::..Object >[]()[][]
Argumente für die Einbettung in die Formatierungszeichenfolge.

See Also

CoreTrace Class
VerboseF Overload
DynamicNode.Core Namespace
String..::..Format(String, array<Object>[]()[][])


Warning Method

[image] [image]

DynamicNodes API
CoreTrace..::..Warning Method
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Warning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Warning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Warning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem.

See Also

CoreTrace Class
CoreTrace Members
DynamicNode.Core Namespace


Warning Method (Int32, String)

[image]

DynamicNodes API
CoreTrace..::..Warning Method (Int32, String)
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Warnung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Warning(
    int id,
    string text
)
Visual Basic
Public Shared Sub Warning ( _
    id As Integer, _
    text As String _
)
F#
static member Warning :
        id:int *
        text:string -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.

See Also

CoreTrace Class
Warning Overload
DynamicNode.Core Namespace


Warning Method (Int32, String, Exception)

[image]

DynamicNodes API
CoreTrace..::..Warning Method (Int32, String, Exception)
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Warnung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Warning(
    int id,
    string text,
    Exception e
)
Visual Basic
Public Shared Sub Warning ( _
    id As Integer, _
    text As String, _
    e As Exception _
)
F#
static member Warning :
        id:int *
        text:string *
        e:Exception -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.
e
Type: System..::..Exception
Die ursächliche Ausnahme.

See Also

CoreTrace Class
Warning Overload
DynamicNode.Core Namespace


Warning Method (Int32, String, Object[])

[image]

DynamicNodes API
CoreTrace..::..Warning Method (Int32, String, array<Object>[]()[][])
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Warnung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Warning(
    int id,
    string text,
    params Object[] data
)
Visual Basic
Public Shared Sub Warning ( _
    id As Integer, _
    text As String, _
    ParamArray data As Object() _
)
F#
static member Warning :
        id:int *
        text:string *
        data:Object[] -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Nachricht.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Informationen. Bei allen übergebenen Objekten wird ToString()()()() verwendet, um sie darzustellen.

See Also

CoreTrace Class
Warning Overload
DynamicNode.Core Namespace


WarningF Method

[image]

DynamicNodes API
CoreTrace..::..WarningF Method
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine formatierte Warnung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void WarningF(
    int id,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub WarningF ( _
    id As Integer, _
    format As String, _
    ParamArray args As Object() _
)
F#
static member WarningF :
        id:int *
        format:string *
        args:Object[] -> unit

Parameters

id
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
format
Type: System..::..String
Die Formatierungszeichenfolge für den Nachrichtentext.
args
Type: array< System..::..Object >[]()[][]
Argumente für die Einbettung in die Formatierungszeichenfolge.

See Also

CoreTrace Class
DynamicNode.Core Namespace
String..::..Format(String, array<Object>[]()[][])


CoreTrace Properties

[image] [image]

DynamicNodes API
CoreTrace Properties
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CoreTrace type exposes the following members.

Properties

Name | Description
TraceSource | Gibt die Ablaufverfolgungsquelle für Knoten zurück.

See Also

CoreTrace Class
DynamicNode.Core Namespace


TraceSource Property

[image]

DynamicNodes API
CoreTrace..::..TraceSource Property
CoreTrace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ablaufverfolgungsquelle für Knoten zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TraceSource TraceSource { get; }
Visual Basic
Public Shared ReadOnly Property TraceSource As TraceSource
    Get
F#
static member TraceSource : TraceSource

See Also

CoreTrace Class
DynamicNode.Core Namespace


CustomNodeFactoryVariation Class

[image]

DynamicNodes API
CustomNodeFactoryVariation Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Beschreibung einer Factory-Variation. Von dieser Klasse kann, abgeleitet werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class CustomNodeFactoryVariation
Visual Basic
Public Class CustomNodeFactoryVariation
F#
type CustomNodeFactoryVariation =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..CustomNodeFactoryVariation

See Also

CustomNodeFactoryVariation Members
DynamicNode.Core Namespace


CustomNodeFactoryVariation Members

[image] [image]

DynamicNodes API
CustomNodeFactoryVariation Members
CustomNodeFactoryVariation Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CustomNodeFactoryVariation type exposes the following members.

Constructors

 | Name | Description
Public method | CustomNodeFactoryVariation | Initialisiert eine neue Instanz von CustomNodeFactoryVariation mit einer Beschriftung.

Properties

 | Name | Description
Public property | Caption | Die Beschriftung der Variation. Diese Beschriftung wird bei der Interaktion mit einem Programmierer angezeigt.

See Also

CustomNodeFactoryVariation Class
DynamicNode.Core Namespace


CustomNodeFactoryVariation Constructor

[image]

DynamicNodes API
CustomNodeFactoryVariation Constructor
CustomNodeFactoryVariation Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von CustomNodeFactoryVariation mit einer Beschriftung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public CustomNodeFactoryVariation(
    string caption
)
Visual Basic
Public Sub New ( _
    caption As String _
)
F#
new :
        caption:string -> CustomNodeFactoryVariation

Parameters

caption
Type: System..::..String
Eine Beschriftung der Variation.

See Also

CustomNodeFactoryVariation Class
DynamicNode.Core Namespace


CustomNodeFactoryVariation Properties

[image] [image]

DynamicNodes API
CustomNodeFactoryVariation Properties
CustomNodeFactoryVariation Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CustomNodeFactoryVariation type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Die Beschriftung der Variation. Diese Beschriftung wird bei der Interaktion mit einem Programmierer angezeigt.

See Also

CustomNodeFactoryVariation Class
DynamicNode.Core Namespace


Caption Property

[image]

DynamicNodes API
CustomNodeFactoryVariation..::..Caption Property
CustomNodeFactoryVariation Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Beschriftung der Variation. Diese Beschriftung wird bei der Interaktion mit einem Programmierer angezeigt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Caption { get; private set; }
Visual Basic
Public Property Caption As String
    Get
    Private Set
F#
member Caption : string with get, private set

See Also

CustomNodeFactoryVariation Class
DynamicNode.Core Namespace


DataTypeTools Class

[image]

DynamicNodes API
DataTypeTools Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt statische Hilfsmethoden für den Umgang mit Datentypen zur Verfügung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static class DataTypeTools
Visual Basic
Public NotInheritable Class DataTypeTools
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataTypeTools =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..DataTypeTools

See Also

DataTypeTools Members
DynamicNode.Core Namespace


DataTypeTools Members

[image] [image]

DynamicNodes API
DataTypeTools Members
DataTypeTools Class Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DataTypeTools type exposes the following members.

Methods

Name | Description
BuildTypeName | Erzeugt einen benutzerfreundlichen Namen für einen Datentypen.
DoConversion | Führt eine Umwandlung eines Objektes in einen Zieldatentyp durch. Dabei werden alle Konverter berücksichtigt, welche mit RegisterTypeConverter(ITypeConverter) im System registriert wurden.
IsAssignableWithConversion | Prüft ob einer Instanz vom Datentyp from eine Instanz vom Datentyp to zugewiesen werden kann, Dabei wird neben IsAssignableFrom(Type) eine mögliche Konvertierung mit DoConversion(Object, Type) überprüft.
MatchConnectionDataType | Prüft die Kompatibilität zwischen einem Ein- und einem Ausgangs-Port. Dabei wird die Kompatibilität der unterstützten Datentypen zueinander geprüft. Die Datentypen mit einem kleinen Index in der Liste der unterstützten Datentypen werden bevorzugt. Wenn der Ausgangs-Port bereits mit einem oder mehreren Eingangs-Ports verbunden ist, wird nur gegen den aktiven Datentyp geprüft.
RegisterTypeConverter | Registriert einen Datentypen-Konverter.
UnregisterAllTypeConverter | Deregistriert alle Datentypen-Konverter.
UnregisterTypeConverter | Deregistriert einen Datentype-Konverter.

Properties

Name | Description
CountTypeConverters | Gibt die Anzahl der registrierten Datentypen-Konverter zurück.

See Also

DataTypeTools Class
DynamicNode.Core Namespace


DataTypeTools Methods

[image] [image]

DynamicNodes API
DataTypeTools Methods
DataTypeTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DataTypeTools type exposes the following members.

Methods

Name | Description
BuildTypeName | Erzeugt einen benutzerfreundlichen Namen für einen Datentypen.
DoConversion | Führt eine Umwandlung eines Objektes in einen Zieldatentyp durch. Dabei werden alle Konverter berücksichtigt, welche mit RegisterTypeConverter(ITypeConverter) im System registriert wurden.
IsAssignableWithConversion | Prüft ob einer Instanz vom Datentyp from eine Instanz vom Datentyp to zugewiesen werden kann, Dabei wird neben IsAssignableFrom(Type) eine mögliche Konvertierung mit DoConversion(Object, Type) überprüft.
MatchConnectionDataType | Prüft die Kompatibilität zwischen einem Ein- und einem Ausgangs-Port. Dabei wird die Kompatibilität der unterstützten Datentypen zueinander geprüft. Die Datentypen mit einem kleinen Index in der Liste der unterstützten Datentypen werden bevorzugt. Wenn der Ausgangs-Port bereits mit einem oder mehreren Eingangs-Ports verbunden ist, wird nur gegen den aktiven Datentyp geprüft.
RegisterTypeConverter | Registriert einen Datentypen-Konverter.
UnregisterAllTypeConverter | Deregistriert alle Datentypen-Konverter.
UnregisterTypeConverter | Deregistriert einen Datentype-Konverter.

See Also

DataTypeTools Class
DynamicNode.Core Namespace


BuildTypeName Method

[image]

DynamicNodes API
DataTypeTools..::..BuildTypeName Method
DataTypeTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt einen benutzerfreundlichen Namen für einen Datentypen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string BuildTypeName(
    Type type
)
Visual Basic
Public Shared Function BuildTypeName ( _
    type As Type _
) As String
F#
static member BuildTypeName :
        type:Type -> string

Parameters

type
Type: System..::..Type
Ein Datentyp.

Return Value

Der Name eines Datentyps.

See Also

DataTypeTools Class
DynamicNode.Core Namespace


DoConversion Method

[image]

DynamicNodes API
DataTypeTools..::..DoConversion Method
DataTypeTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Umwandlung eines Objektes in einen Zieldatentyp durch. Dabei werden alle Konverter berücksichtigt, welche mit RegisterTypeConverter(ITypeConverter) im System registriert wurden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static Object DoConversion(
    Object o,
    Type targetType
)
Visual Basic
Public Shared Function DoConversion ( _
    o As Object, _
    targetType As Type _
) As Object
F#
static member DoConversion :
        o:Object *
        targetType:Type -> Object

Parameters

o
Type: System..::..Object
Ein Objekt.
targetType
Type: System..::..Type
Der Zieldatentyp.

Return Value

Das Ergebnis der Umwandlung.

See Also

DataTypeTools Class
DynamicNode.Core Namespace


IsAssignableWithConversion Method

[image]

DynamicNodes API
DataTypeTools..::..IsAssignableWithConversion Method
DataTypeTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob einer Instanz vom Datentyp from eine Instanz vom Datentyp to zugewiesen werden kann, Dabei wird neben IsAssignableFrom(Type) eine mögliche Konvertierung mit DoConversion(Object, Type) überprüft.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static bool IsAssignableWithConversion(
    Type to,
    Type from
)
Visual Basic
Public Shared Function IsAssignableWithConversion ( _
    to As Type, _
    from As Type _
) As Boolean
F#
static member IsAssignableWithConversion :
        to:Type *
        from:Type -> bool

Parameters

to
Type: System..::..Type
Der Zieldatentyp.
from
Type: System..::..Type
Der Ursprungsdatentyp.

Return Value

true, wenn eine Zuweisung mit Hilfe von DoConversion(Object, Type) möglich ist, sonst false.

See Also

DataTypeTools Class
DynamicNode.Core Namespace


MatchConnectionDataType Method

[image]

DynamicNodes API
DataTypeTools..::..MatchConnectionDataType Method
DataTypeTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Prüft die Kompatibilität zwischen einem Ein- und einem Ausgangs-Port. Dabei wird die Kompatibilität der unterstützten Datentypen zueinander geprüft.

Die Datentypen mit einem kleinen Index in der Liste der unterstützten Datentypen werden bevorzugt.

Wenn der Ausgangs-Port bereits mit einem oder mehreren Eingangs-Ports verbunden ist, wird nur gegen den aktiven Datentyp geprüft.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static bool MatchConnectionDataType(
    InPort inPort,
    OutPort outPort,
    out Type selectedType
)
Visual Basic
Public Shared Function MatchConnectionDataType ( _
    inPort As InPort, _
    outPort As OutPort, _
    <OutAttribute> ByRef selectedType As Type _
) As Boolean
F#
static member MatchConnectionDataType :
        inPort:InPort *
        outPort:OutPort *
        selectedType:Type byref -> bool

Parameters

inPort
Type: DynamicNode.Core..::..InPort
Der Eingangs-Port.
outPort
Type: DynamicNode.Core..::..OutPort
Der Ausgangs-Port.
selectedType
Type: System..::..Type %
Wird mit dem gewählten Datentyp, oder null belegt, wenn keine Verbindung möglich ist.

Return Value

true, wenn eine Verbindung möglich ist, sonst false.

See Also

DataTypeTools Class
DynamicNode.Core Namespace


RegisterTypeConverter Method

[image]

DynamicNodes API
DataTypeTools..::..RegisterTypeConverter Method
DataTypeTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert einen Datentypen-Konverter.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void RegisterTypeConverter(
    ITypeConverter typeConverter
)
Visual Basic
Public Shared Sub RegisterTypeConverter ( _
    typeConverter As ITypeConverter _
)
F#
static member RegisterTypeConverter :
        typeConverter:ITypeConverter -> unit

Parameters

typeConverter
Type: DynamicNode.Core..::..ITypeConverter
Ein Datentypen-Konverter.

Exceptions

Exception | Condition
System..::..ArgumentException | Falls der Datentyp-Konverter bereits registriert ist.

See Also

DataTypeTools Class
DynamicNode.Core Namespace


UnregisterAllTypeConverter Method

[image]

DynamicNodes API
DataTypeTools..::..UnregisterAllTypeConverter Method
DataTypeTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Deregistriert alle Datentypen-Konverter.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void UnregisterAllTypeConverter()
Visual Basic
Public Shared Sub UnregisterAllTypeConverter
F#
static member UnregisterAllTypeConverter : unit -> unit

See Also

DataTypeTools Class
DynamicNode.Core Namespace


UnregisterTypeConverter Method

[image]

DynamicNodes API
DataTypeTools..::..UnregisterTypeConverter Method
DataTypeTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Deregistriert einen Datentype-Konverter.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void UnregisterTypeConverter(
    ITypeConverter typeConverter
)
Visual Basic
Public Shared Sub UnregisterTypeConverter ( _
    typeConverter As ITypeConverter _
)
F#
static member UnregisterTypeConverter :
        typeConverter:ITypeConverter -> unit

Parameters

typeConverter
Type: DynamicNode.Core..::..ITypeConverter
Ein Datentypen-Konverter.

See Also

DataTypeTools Class
DynamicNode.Core Namespace


DataTypeTools Properties

[image] [image]

DynamicNodes API
DataTypeTools Properties
DataTypeTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DataTypeTools type exposes the following members.

Properties

Name | Description
CountTypeConverters | Gibt die Anzahl der registrierten Datentypen-Konverter zurück.

See Also

DataTypeTools Class
DynamicNode.Core Namespace


CountTypeConverters Property

[image]

DynamicNodes API
DataTypeTools..::..CountTypeConverters Property
DataTypeTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der registrierten Datentypen-Konverter zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static int CountTypeConverters { get; }
Visual Basic
Public Shared ReadOnly Property CountTypeConverters As Integer
    Get
F#
static member CountTypeConverters : int

Field Value

Die Anzahl der registrierten Datentypen-Konverter.

See Also

DataTypeTools Class
DynamicNode.Core Namespace


DefaultConfiguration Class

[image]

DynamicNodes API
DefaultConfiguration Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standard-Implementierung von IConfiguration.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class DefaultConfiguration : IConfiguration,
    IStorable
Visual Basic
Public Class DefaultConfiguration _
    Implements IConfiguration, IStorable
F#
type DefaultConfiguration =
    class
        interface IConfiguration
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..DefaultConfiguration

See Also

DefaultConfiguration Members
DynamicNode.Core Namespace


DefaultConfiguration Members

[image] [image]

DynamicNodes API
DefaultConfiguration Members
DefaultConfiguration Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DefaultConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultConfiguration | Initialisiert eine DefaultConfiguration-Instanz.

Methods

 | Name | Description
Public method | CheckFixConfiguration | Überprüft die invariablen Pfade.
Public method | CheckVariableConfiguration | Überprüft und erstellt wenn nötig die Pfade.
 | Dir | Gibt ein DirectoryInfo-Objekt für einen Pfad zurück oder null falls der Pfad ungültig ist. Falls ein Fehler auftritt wird eine Meldung über den Fehler ausgegeben.
 | GetCommandLineArguments | Spaltet die Befehlszeile in Argumente auf. Dabei wird das Einschließen von Argumenten in Doppelten und einfachen Anführungszeichen berücksichtigt.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.

Properties

 | Name | Description
Public property | HasWorkspace | Gibt einen Wert der angibt, ob die Konfigurtion ein Arbeitsverzeichnis besitzt.
Public property | HelpPath | Gibt das Hilfe-Verzeichnis oder null zurück.
Public property | ProjectsPath | Gibt das Standard-Verzeichnis für Projektdateien oder null zurück.
Public property | ScriptsPath | Gibt das Verzeichnis mit den Skripten oder null zurück.
Public property | SettingsPath | Gibt das Verzeichnis mit den Programmeinstellungen oder null zurück.
Public property | SystemModuleLibraryPath | Gibt das Verzeichnis für Systemmodule oder null zurück.
Public property | SystemNodeLibraryPath | Gibt das Verzeichnis mit den System-Knotenbibliotheken oder null zurück.
Public property | SystemPath | Gibt das Startverzeichnis der Laufzeitumgebung zurück.
Public property | SystemTemplateLibraryPath | Gibt das Verzeichnis für Systemvorlagen oder null zurück.
Public property | WorkspaceModuleLibraryPath | Gibt das Verzeichnis für Graph-Module oder null zurück.
Public property | WorkspaceNodeLibraryPath | Gibt das Verzeichnis mit den Benutzer-Knotenbibliotheken oder null zurück.
Public property | WorkspacePath | Gibt das Arbeitsverzeichnis für DynamicNodes im Benutzer-Kontext oder null zurück.
Public property | WorkspaceTemplateLibraryPath | Gibt das Verzeichnis für Benutzervorlagen oder null zurück.

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


DefaultConfiguration Constructor

[image]

DynamicNodes API
DefaultConfiguration Constructor
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine DefaultConfiguration-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public DefaultConfiguration(
    string systemPath,
    string workspacePath
)
Visual Basic
Public Sub New ( _
    systemPath As String, _
    workspacePath As String _
)
F#
new :
        systemPath:string *
        workspacePath:string -> DefaultConfiguration

Parameters

systemPath
Type: System..::..String
Der Pfad in dem die Laufzeitumgebung gestartet wird.
workspacePath
Type: System..::..String
Der Pfad in dem Benutzerdateien abgelegt werden können.

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


DefaultConfiguration Methods

[image] [image]

DynamicNodes API
DefaultConfiguration Methods
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DefaultConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CheckFixConfiguration | Überprüft die invariablen Pfade.
Public method | CheckVariableConfiguration | Überprüft und erstellt wenn nötig die Pfade.
 | Dir | Gibt ein DirectoryInfo-Objekt für einen Pfad zurück oder null falls der Pfad ungültig ist. Falls ein Fehler auftritt wird eine Meldung über den Fehler ausgegeben.
 | GetCommandLineArguments | Spaltet die Befehlszeile in Argumente auf. Dabei wird das Einschließen von Argumenten in Doppelten und einfachen Anführungszeichen berücksichtigt.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


CheckFixConfiguration Method

[image]

DynamicNodes API
DefaultConfiguration..::..CheckFixConfiguration Method
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft die invariablen Pfade.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void CheckFixConfiguration()
Visual Basic
Public Sub CheckFixConfiguration
F#
member CheckFixConfiguration : unit -> unit

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


CheckVariableConfiguration Method

[image]

DynamicNodes API
DefaultConfiguration..::..CheckVariableConfiguration Method
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft und erstellt wenn nötig die Pfade.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void CheckVariableConfiguration()
Visual Basic
Public Sub CheckVariableConfiguration
F#
member CheckVariableConfiguration : unit -> unit

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


Dir Method

[image]

DynamicNodes API
DefaultConfiguration..::..Dir Method
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein DirectoryInfo-Objekt für einen Pfad zurück oder null falls der Pfad ungültig ist. Falls ein Fehler auftritt wird eine Meldung über den Fehler ausgegeben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static DirectoryInfo Dir(
    string path
)
Visual Basic
Public Shared Function Dir ( _
    path As String _
) As DirectoryInfo
F#
static member Dir :
        path:string -> DirectoryInfo

Parameters

path
Type: System..::..String
Der Pfad des Verzeichnisses.

Return Value

Ein DirectoryInfo-Objekt.

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


GetCommandLineArguments Method

[image]

DynamicNodes API
DefaultConfiguration..::..GetCommandLineArguments Method
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Spaltet die Befehlszeile in Argumente auf. Dabei wird das Einschließen von Argumenten in Doppelten und einfachen Anführungszeichen berücksichtigt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string[] GetCommandLineArguments()
Visual Basic
Public Shared Function GetCommandLineArguments As String()
F#
static member GetCommandLineArguments : unit -> string[]

Return Value

Ein Array mit Befehlszeilenargumenten.

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
DefaultConfiguration..::..OnRestore Method
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
DefaultConfiguration..::..OnStore Method
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


DefaultConfiguration Properties

[image] [image]

DynamicNodes API
DefaultConfiguration Properties
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DefaultConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | HasWorkspace | Gibt einen Wert der angibt, ob die Konfigurtion ein Arbeitsverzeichnis besitzt.
Public property | HelpPath | Gibt das Hilfe-Verzeichnis oder null zurück.
Public property | ProjectsPath | Gibt das Standard-Verzeichnis für Projektdateien oder null zurück.
Public property | ScriptsPath | Gibt das Verzeichnis mit den Skripten oder null zurück.
Public property | SettingsPath | Gibt das Verzeichnis mit den Programmeinstellungen oder null zurück.
Public property | SystemModuleLibraryPath | Gibt das Verzeichnis für Systemmodule oder null zurück.
Public property | SystemNodeLibraryPath | Gibt das Verzeichnis mit den System-Knotenbibliotheken oder null zurück.
Public property | SystemPath | Gibt das Startverzeichnis der Laufzeitumgebung zurück.
Public property | SystemTemplateLibraryPath | Gibt das Verzeichnis für Systemvorlagen oder null zurück.
Public property | WorkspaceModuleLibraryPath | Gibt das Verzeichnis für Graph-Module oder null zurück.
Public property | WorkspaceNodeLibraryPath | Gibt das Verzeichnis mit den Benutzer-Knotenbibliotheken oder null zurück.
Public property | WorkspacePath | Gibt das Arbeitsverzeichnis für DynamicNodes im Benutzer-Kontext oder null zurück.
Public property | WorkspaceTemplateLibraryPath | Gibt das Verzeichnis für Benutzervorlagen oder null zurück.

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


HasWorkspace Property

[image]

DynamicNodes API
DefaultConfiguration..::..HasWorkspace Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert der angibt, ob die Konfigurtion ein Arbeitsverzeichnis besitzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool HasWorkspace { get; }
Visual Basic
Public ReadOnly Property HasWorkspace As Boolean
    Get
F#
abstract HasWorkspace : bool
override HasWorkspace : bool

Field Value

true, wenn diese Konfiguration ein Arbeitsverzeichnis besitzt, sonst false.

Implements

IConfiguration..::..HasWorkspace

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


HelpPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..HelpPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Hilfe-Verzeichnis oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string HelpPath { get; set; }
Visual Basic
Public Property HelpPath As String
    Get
    Set
F#
abstract HelpPath : string with get, set
override HelpPath : string with get, set

Field Value

Das Verzeichnis mit den Hilfe-Dateien oder null.

Implements

IConfiguration..::..HelpPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


ProjectsPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..ProjectsPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Standard-Verzeichnis für Projektdateien oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string ProjectsPath { get; set; }
Visual Basic
Public Property ProjectsPath As String
    Get
    Set
F#
abstract ProjectsPath : string with get, set
override ProjectsPath : string with get, set

Field Value

Das Standard-Verzeichnis für Projektdateien oder null.

Implements

IConfiguration..::..ProjectsPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


ScriptsPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..ScriptsPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis mit den Skripten oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string ScriptsPath { get; }
Visual Basic
Public ReadOnly Property ScriptsPath As String
    Get
F#
abstract ScriptsPath : string
override ScriptsPath : string

Field Value

Das Verzeichnis der Skripte oder null.

Implements

IConfiguration..::..ScriptsPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


SettingsPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..SettingsPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis mit den Programmeinstellungen oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string SettingsPath { get; }
Visual Basic
Public ReadOnly Property SettingsPath As String
    Get
F#
abstract SettingsPath : string
override SettingsPath : string

Field Value

Das Verzeichnis für Einstellungs-Dateien oder null.

Implements

IConfiguration..::..SettingsPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


SystemModuleLibraryPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..SystemModuleLibraryPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis für Systemmodule oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string SystemModuleLibraryPath { get; }
Visual Basic
Public ReadOnly Property SystemModuleLibraryPath As String
    Get
F#
abstract SystemModuleLibraryPath : string
override SystemModuleLibraryPath : string

Field Value

Das Verzeichnis der Systemmodulbibliothek oder null.

Implements

IConfiguration..::..SystemModuleLibraryPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


SystemNodeLibraryPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..SystemNodeLibraryPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis mit den System-Knotenbibliotheken oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string SystemNodeLibraryPath { get; }
Visual Basic
Public ReadOnly Property SystemNodeLibraryPath As String
    Get
F#
abstract SystemNodeLibraryPath : string
override SystemNodeLibraryPath : string

Field Value

Das Verzeichnis der System-Knotenbibliotheken oder null.

Implements

IConfiguration..::..SystemNodeLibraryPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


SystemPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..SystemPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Startverzeichnis der Laufzeitumgebung zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string SystemPath { get; }
Visual Basic
Public ReadOnly Property SystemPath As String
    Get
F#
abstract SystemPath : string
override SystemPath : string

Field Value

Das Startverzeichnis der Laufzeitumgebung.

Implements

IConfiguration..::..SystemPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


SystemTemplateLibraryPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..SystemTemplateLibraryPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis für Systemvorlagen oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string SystemTemplateLibraryPath { get; }
Visual Basic
Public ReadOnly Property SystemTemplateLibraryPath As String
    Get
F#
abstract SystemTemplateLibraryPath : string
override SystemTemplateLibraryPath : string

Field Value

Das Verzeichnis der Systemvorlagenbibliothek oder null.

Implements

IConfiguration..::..SystemTemplateLibraryPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


WorkspaceModuleLibraryPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..WorkspaceModuleLibraryPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis für Graph-Module oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string WorkspaceModuleLibraryPath { get; set; }
Visual Basic
Public Property WorkspaceModuleLibraryPath As String
    Get
    Set
F#
abstract WorkspaceModuleLibraryPath : string with get, set
override WorkspaceModuleLibraryPath : string with get, set

Field Value

Das Verzeichnis der Modul-Bibliothek oder null.

Implements

IConfiguration..::..WorkspaceModuleLibraryPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


WorkspaceNodeLibraryPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..WorkspaceNodeLibraryPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis mit den Benutzer-Knotenbibliotheken oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string WorkspaceNodeLibraryPath { get; set; }
Visual Basic
Public Property WorkspaceNodeLibraryPath As String
    Get
    Set
F#
abstract WorkspaceNodeLibraryPath : string with get, set
override WorkspaceNodeLibraryPath : string with get, set

Field Value

Das Verzeichnis der Benutzer-Knotenbibliotheken oder null.

Implements

IConfiguration..::..WorkspaceNodeLibraryPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


WorkspacePath Property

[image]

DynamicNodes API
DefaultConfiguration..::..WorkspacePath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Arbeitsverzeichnis für DynamicNodes im Benutzer-Kontext oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string WorkspacePath { get; }
Visual Basic
Public ReadOnly Property WorkspacePath As String
    Get
F#
abstract WorkspacePath : string
override WorkspacePath : string

Field Value

Das Arbeitsverzeichnis im Benutzer-Kontext oder null.

Implements

IConfiguration..::..WorkspacePath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


WorkspaceTemplateLibraryPath Property

[image]

DynamicNodes API
DefaultConfiguration..::..WorkspaceTemplateLibraryPath Property
DefaultConfiguration Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis für Benutzervorlagen oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string WorkspaceTemplateLibraryPath { get; set; }
Visual Basic
Public Property WorkspaceTemplateLibraryPath As String
    Get
    Set
F#
abstract WorkspaceTemplateLibraryPath : string with get, set
override WorkspaceTemplateLibraryPath : string with get, set

Field Value

Das Verzeichnis der Benutzervorlagenbibliothek oder null.

Implements

IConfiguration..::..WorkspaceTemplateLibraryPath

See Also

DefaultConfiguration Class
DynamicNode.Core Namespace


FireHandler Delegate

[image]

DynamicNodes API
FireHandler Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Delegate für Handler, welche das Fired-Event eines Ausgangs konsumieren wollen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public delegate void FireHandler(
    OutPort oP,
    Token token
)
Visual Basic
Public Delegate Sub FireHandler ( _
    oP As OutPort, _
    token As Token _
)
F#
type FireHandler =
    delegate of
        oP:OutPort *
        token:Token -> unit

Parameters

oP
Type: DynamicNode.Core..::..OutPort
token
Type: DynamicNode.Core..::..Token

See Also

DynamicNode.Core Namespace


GenericDataTypeManager Class

[image]

DynamicNodes API
GenericDataTypeManager Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt für die Typen-Argumente eines generischen Datentyps Daten-Typ-Provider bereit.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class GenericDataTypeManager : IExtension<INode>,
    IStorable
Visual Basic
Public Class GenericDataTypeManager _
    Implements IExtension(Of INode), IStorable
F#
type GenericDataTypeManager =
    class
        interface IExtension<INode>
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..GenericDataTypeManager

See Also

GenericDataTypeManager Members
DynamicNode.Core Namespace


GenericDataTypeManager Members

[image] [image]

DynamicNodes API
GenericDataTypeManager Members
GenericDataTypeManager Class Constructors Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GenericDataTypeManager type exposes the following members.

Constructors

 | Name | Description
Public method | GenericDataTypeManager | Initialisiert eine neue InPortDataTypeGroup-Instanz.

Methods

 | Name | Description
Public method | AddConstraint | Fügt eine Beschränkung für ein generisches Typenargument hinzu.
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | GetInPortProvider | Gibt einen Daten-Typ-Provider für einen Eingang zurück, der den Datentyp eines generischen Arguments bereitstellt.
Public method | GetOutPortProvider | Gibt einen Daten-Typ-Provider für einen Ausgang zurück, der den Datentyp eines generischen Arguments bereitstellt.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


GenericDataTypeManager Constructor

[image]

DynamicNodes API
GenericDataTypeManager Constructor
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue InPortDataTypeGroup-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public GenericDataTypeManager(
    InPort iP,
    Type genericType
)
Visual Basic
Public Sub New ( _
    iP As InPort, _
    genericType As Type _
)
F#
new :
        iP:InPort *
        genericType:Type -> GenericDataTypeManager

Parameters

iP
Type: DynamicNode.Core..::..InPort
Der Eingang mit einem generischen Datentyp.
genericType
Type: System..::..Type
Die generische Typen-Definition, welche die Kompatibilität des Eingangs vorgibt.

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


GenericDataTypeManager Fields

[image] [image]

DynamicNodes API
GenericDataTypeManager Fields
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GenericDataTypeManager type exposes the following members.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


EXT_ID Field

[image]

DynamicNodes API
GenericDataTypeManager..::..EXT_ID Field
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


GenericDataTypeManager Methods

[image] [image]

DynamicNodes API
GenericDataTypeManager Methods
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GenericDataTypeManager type exposes the following members.

Methods

 | Name | Description
Public method | AddConstraint | Fügt eine Beschränkung für ein generisches Typenargument hinzu.
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | GetInPortProvider | Gibt einen Daten-Typ-Provider für einen Eingang zurück, der den Datentyp eines generischen Arguments bereitstellt.
Public method | GetOutPortProvider | Gibt einen Daten-Typ-Provider für einen Ausgang zurück, der den Datentyp eines generischen Arguments bereitstellt.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


AddConstraint Method

[image]

DynamicNodes API
GenericDataTypeManager..::..AddConstraint Method
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt eine Beschränkung für ein generisches Typenargument hinzu.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AddConstraint(
    int genericArgumentIndex,
    GenericDataTypeManager..::..IConstraint constraint
)
Visual Basic
Public Sub AddConstraint ( _
    genericArgumentIndex As Integer, _
    constraint As GenericDataTypeManager..::..IConstraint _
)
F#
member AddConstraint :
        genericArgumentIndex:int *
        constraint:GenericDataTypeManager..::..IConstraint -> unit

Parameters

genericArgumentIndex
Type: System..::..Int32
Index of the generic argument.
constraint
Type: DynamicNode.Core..::..GenericDataTypeManager..::..IConstraint
The constraint.

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


AfterAttaching Method

[image]

DynamicNodes API
GenericDataTypeManager..::..AfterAttaching Method
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterAttaching(
    INode g
)
Visual Basic
Public Sub AfterAttaching ( _
    g As INode _
)
F#
abstract AfterAttaching :
        g:INode -> unit
override AfterAttaching :
        g:INode -> unit

Parameters

g
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


AfterDetaching Method

[image]

DynamicNodes API
GenericDataTypeManager..::..AfterDetaching Method
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterDetaching(
    INode o
)
Visual Basic
Public Sub AfterDetaching ( _
    o As INode _
)
F#
abstract AfterDetaching :
        o:INode -> unit
override AfterDetaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


AfterRestoring Method

[image]

DynamicNodes API
GenericDataTypeManager..::..AfterRestoring Method
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


GetInPortProvider Method

[image]

DynamicNodes API
GenericDataTypeManager..::..GetInPortProvider Method
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Daten-Typ-Provider für einen Eingang zurück, der den Datentyp eines generischen Arguments bereitstellt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IInPortDataTypeProvider GetInPortProvider(
    int genericArgumentIndex
)
Visual Basic
Public Function GetInPortProvider ( _
    genericArgumentIndex As Integer _
) As IInPortDataTypeProvider
F#
member GetInPortProvider :
        genericArgumentIndex:int -> IInPortDataTypeProvider

Parameters

genericArgumentIndex
Type: System..::..Int32
Index des generischen Arguments.

Return Value

Einen Daten-Typ-Provider für einen Eingang

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


GetOutPortProvider Method

[image]

DynamicNodes API
GenericDataTypeManager..::..GetOutPortProvider Method
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Daten-Typ-Provider für einen Ausgang zurück, der den Datentyp eines generischen Arguments bereitstellt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IOutPortDataTypeProvider GetOutPortProvider(
    int genericArgumentIndex
)
Visual Basic
Public Function GetOutPortProvider ( _
    genericArgumentIndex As Integer _
) As IOutPortDataTypeProvider
F#
member GetOutPortProvider :
        genericArgumentIndex:int -> IOutPortDataTypeProvider

Parameters

genericArgumentIndex
Type: System..::..Int32
Index des generischen Arguments.

Return Value

Einen Daten-Typ-Provider für einen Ausgang

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
GenericDataTypeManager..::..OnRestore Method
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschafts-Leser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
GenericDataTypeManager..::..OnStore Method
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschafts-Writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


GenericDataTypeManager Properties

[image] [image]

DynamicNodes API
GenericDataTypeManager Properties
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GenericDataTypeManager type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


Id Property

[image]

DynamicNodes API
GenericDataTypeManager..::..Id Property
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


IsUsingStorage Property

[image]

DynamicNodes API
GenericDataTypeManager..::..IsUsingStorage Property
GenericDataTypeManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

GenericDataTypeManager Class
DynamicNode.Core Namespace


GenericDataTypeManager.ExcludingConstraint Class

[image]

DynamicNodes API
GenericDataTypeManager..::..ExcludingConstraint Class
GenericDataTypeManager Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Beschränkung, welche alle außer den übergebenen Typen zulässt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class ExcludingConstraint : GenericDataTypeManager..::..IConstraint
Visual Basic
Public Class ExcludingConstraint _
    Implements GenericDataTypeManager..::..IConstraint
F#
type ExcludingConstraint =
    class
        interface GenericDataTypeManager..::..IConstraint
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..GenericDataTypeManager..::..ExcludingConstraint

See Also

GenericDataTypeManager..::..ExcludingConstraint Members
DynamicNode.Core Namespace


GenericDataTypeManager.ExcludingConstraint Members

[image] [image]

DynamicNodes API
GenericDataTypeManager..::..ExcludingConstraint Members
GenericDataTypeManager..::..ExcludingConstraint Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Stellt für die Typen-Argumente eines generischen Datentyps Daten-Typ-Provider bereit.

The GenericDataTypeManager..::..ExcludingConstraint type exposes the following members.

Constructors

 | Name | Description
Public method | GenericDataTypeManager..::..ExcludingConstraint | Initialisiert eine neue Instanz von GenericDataTypeManager..::..ExcludingConstraint.

Methods

 | Name | Description
Public method | IsAllowed | Prüft ob der gegebenen Type erlaubt ist.

See Also

GenericDataTypeManager..::..ExcludingConstraint Class
DynamicNode.Core Namespace


GenericDataTypeManager.ExcludingConstraint Constructor

[image]

DynamicNodes API
GenericDataTypeManager..::..ExcludingConstraint Constructor
GenericDataTypeManager..::..ExcludingConstraint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von GenericDataTypeManager..::..ExcludingConstraint.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public ExcludingConstraint(
    params Type[] disallowedTypes
)
Visual Basic
Public Sub New ( _
    ParamArray disallowedTypes As Type() _
)
F#
new :
        disallowedTypes:Type[] -> ExcludingConstraint

Parameters

disallowedTypes
Type: array< System..::..Type >[]()[][]
Alle Typen die erlaubt sind.

See Also

GenericDataTypeManager..::..ExcludingConstraint Class
DynamicNode.Core Namespace


GenericDataTypeManager.ExcludingConstraint Methods

[image] [image]

DynamicNodes API
GenericDataTypeManager..::..ExcludingConstraint Methods
GenericDataTypeManager..::..ExcludingConstraint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GenericDataTypeManager..::..ExcludingConstraint type exposes the following members.

Methods

 | Name | Description
Public method | IsAllowed | Prüft ob der gegebenen Type erlaubt ist.

See Also

GenericDataTypeManager..::..ExcludingConstraint Class
DynamicNode.Core Namespace


IsAllowed Method

[image]

DynamicNodes API
GenericDataTypeManager..::..ExcludingConstraint..::..IsAllowed Method
GenericDataTypeManager..::..ExcludingConstraint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob der gegebenen Type erlaubt ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsAllowed(
    Type type
)
Visual Basic
Public Function IsAllowed ( _
    type As Type _
) As Boolean
F#
abstract IsAllowed :
        type:Type -> bool
override IsAllowed :
        type:Type -> bool

Parameters

type
Type: System..::..Type
Der zu überprüfende Type.

Return Value

true, wenn der gegebene Type erlaubt ist, sonst false.

Implements

GenericDataTypeManager..::..IConstraint..::..IsAllowed(Type)

See Also

GenericDataTypeManager..::..ExcludingConstraint Class
DynamicNode.Core Namespace


GenericDataTypeManager.IConstraint Interface

[image]

DynamicNodes API
GenericDataTypeManager..::..IConstraint Interface
GenericDataTypeManager Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für eine Beschränkung für eine generisches Typen-Argument.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IConstraint
Visual Basic
Public Interface IConstraint
F#
type IConstraint =  interface end

See Also

GenericDataTypeManager..::..IConstraint Members
DynamicNode.Core Namespace


GenericDataTypeManager.IConstraint Members

[image] [image]

DynamicNodes API
GenericDataTypeManager..::..IConstraint Members
GenericDataTypeManager..::..IConstraint Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Stellt für die Typen-Argumente eines generischen Datentyps Daten-Typ-Provider bereit.

The GenericDataTypeManager..::..IConstraint type exposes the following members.

Methods

 | Name | Description
Public method | IsAllowed | Prüft ob der gegebenen Type erlaubt ist.

See Also

GenericDataTypeManager..::..IConstraint Interface
DynamicNode.Core Namespace


GenericDataTypeManager.IConstraint Methods

[image] [image]

DynamicNodes API
GenericDataTypeManager..::..IConstraint Methods
GenericDataTypeManager..::..IConstraint Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GenericDataTypeManager..::..IConstraint type exposes the following members.

Methods

 | Name | Description
Public method | IsAllowed | Prüft ob der gegebenen Type erlaubt ist.

See Also

GenericDataTypeManager..::..IConstraint Interface
DynamicNode.Core Namespace


IsAllowed Method

[image]

DynamicNodes API
GenericDataTypeManager..::..IConstraint..::..IsAllowed Method
GenericDataTypeManager..::..IConstraint Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob der gegebenen Type erlaubt ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsAllowed(
    Type type
)
Visual Basic
Function IsAllowed ( _
    type As Type _
) As Boolean
F#
abstract IsAllowed :
        type:Type -> bool

Parameters

type
Type: System..::..Type
Der zu überprüfende Type.

Return Value

true, wenn der gegebene Type erlaubt ist, sonst false.

See Also

GenericDataTypeManager..::..IConstraint Interface
DynamicNode.Core Namespace


GenericDataTypeManager.IncludingConstraint Class

[image]

DynamicNodes API
GenericDataTypeManager..::..IncludingConstraint Class
GenericDataTypeManager Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Beschränkung, welche nur die übergebenen Typen zulässt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class IncludingConstraint : GenericDataTypeManager..::..IConstraint
Visual Basic
Public Class IncludingConstraint _
    Implements GenericDataTypeManager..::..IConstraint
F#
type IncludingConstraint =
    class
        interface GenericDataTypeManager..::..IConstraint
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..GenericDataTypeManager..::..IncludingConstraint

See Also

GenericDataTypeManager..::..IncludingConstraint Members
DynamicNode.Core Namespace


GenericDataTypeManager.IncludingConstraint Members

[image] [image]

DynamicNodes API
GenericDataTypeManager..::..IncludingConstraint Members
GenericDataTypeManager..::..IncludingConstraint Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Stellt für die Typen-Argumente eines generischen Datentyps Daten-Typ-Provider bereit.

The GenericDataTypeManager..::..IncludingConstraint type exposes the following members.

Constructors

 | Name | Description
Public method | GenericDataTypeManager..::..IncludingConstraint | Initialisiert eine neue Instanz von GenericDataTypeManager..::..IncludingConstraint.

Methods

 | Name | Description
Public method | IsAllowed | Prüft ob der gegebenen Type erlaubt ist.

See Also

GenericDataTypeManager..::..IncludingConstraint Class
DynamicNode.Core Namespace


GenericDataTypeManager.IncludingConstraint Constructor

[image]

DynamicNodes API
GenericDataTypeManager..::..IncludingConstraint Constructor
GenericDataTypeManager..::..IncludingConstraint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von GenericDataTypeManager..::..IncludingConstraint.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IncludingConstraint(
    params Type[] allowedTypes
)
Visual Basic
Public Sub New ( _
    ParamArray allowedTypes As Type() _
)
F#
new :
        allowedTypes:Type[] -> IncludingConstraint

Parameters

allowedTypes
Type: array< System..::..Type >[]()[][]
Alle Typen die erlaubt sind.

See Also

GenericDataTypeManager..::..IncludingConstraint Class
DynamicNode.Core Namespace


GenericDataTypeManager.IncludingConstraint Methods

[image] [image]

DynamicNodes API
GenericDataTypeManager..::..IncludingConstraint Methods
GenericDataTypeManager..::..IncludingConstraint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GenericDataTypeManager..::..IncludingConstraint type exposes the following members.

Methods

 | Name | Description
Public method | IsAllowed | Prüft ob der gegebenen Type erlaubt ist.

See Also

GenericDataTypeManager..::..IncludingConstraint Class
DynamicNode.Core Namespace


IsAllowed Method

[image]

DynamicNodes API
GenericDataTypeManager..::..IncludingConstraint..::..IsAllowed Method
GenericDataTypeManager..::..IncludingConstraint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob der gegebenen Type erlaubt ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsAllowed(
    Type type
)
Visual Basic
Public Function IsAllowed ( _
    type As Type _
) As Boolean
F#
abstract IsAllowed :
        type:Type -> bool
override IsAllowed :
        type:Type -> bool

Parameters

type
Type: System..::..Type
Der zu überprüfende Type.

Return Value

true, wenn der gegebene Type erlaubt ist, sonst false.

Implements

GenericDataTypeManager..::..IConstraint..::..IsAllowed(Type)

See Also

GenericDataTypeManager..::..IncludingConstraint Class
DynamicNode.Core Namespace


Graph Class

[image]

DynamicNodes API
Graph Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardimplementierung für eine Sammlung verbundener Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class Graph : HierarchyObject<IRuntime, IGraph, INode>,
    IGraph, IChild<IRuntime, IGraph>, IParent<IGraph, INode>,
    IBaseObject, IIdentifiable, IStorable, IExtensible<IGraph>,
    IDisposable
Visual Basic
Public Class Graph _
    Inherits HierarchyObject(Of IRuntime, IGraph, INode) _
    Implements IGraph, IChild(Of IRuntime, IGraph),  _
    IParent(Of IGraph, INode), IBaseObject, IIdentifiable,  _
    IStorable, IExtensible(Of IGraph), IDisposable
F#
type Graph =
    class
        inherit HierarchyObject<IRuntime, IGraph, INode>
        interface IGraph
        interface IChild<IRuntime, IGraph>
        interface IParent<IGraph, INode>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
        interface IExtensible<IGraph>
        interface IDisposable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' IGraph >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' IGraph, INode >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IRuntime, IGraph, INode >)>)>
DynamicNode.Core..::..Graph

See Also

Graph Members
DynamicNode.Core Namespace


Graph Members

[image] [image]

DynamicNodes API
Graph Members
Graph Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Graph type exposes the following members.

Constructors

 | Name | Description
Public method | Graph | Initializes a new instance of the Graph class

Methods

 | Name | Description
Public method | ActivateNodes | Aktiviert alle Knoten, an deren Eingängen neue Tokens anliegen. Muss nur aufgerufen werden, nach dem ein Graph wiederhergestellt wurde um die mit OnRestore(IPropertyReader) erzeugten Tokens an den Eingängen zu verarbeiten.
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | AddNodeWithId | Fügt einen Knoten mit einer vorgegebenen ID hinzu. Diese Methode wird beim Rekonstruieren eines Graphen benötigt.
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..BeforeRemoveChild(TChild).)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche der Graph identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | NotifyGraphFlagChanged | Benachricht den Graphen über ein Flag dessen Zustand sich geändert hat.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnAttachExtension(IExtension<(Of <<'(TSelf>)>>), Boolean).)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildAdded(TChild).)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildRemoved(TChild).)
Public method | OnConnectionAffected | Diese Methode muss aufgerufen werden, wenn eine Verbindung erstellt oder zerstört wurde. Sie löst das ConnectionAffected-Ereignis aus.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnDetachExtension(IExtension<(Of <<'(TSelf>)>>)).)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Overrides Object..::..ToString()()()().)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

Properties

 | Name | Description
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | BlockActivations | Liest und schreibt ein Flag, welches angibt ob Aktivierungen von Knoten verhindert werden sollen.
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | GraphStateFlags | Gibt ein Wörterbuch mit den Flags des Graphen zurück. Flags werden durch Knoten der Klasse NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens. Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.
Public property | GraphStorage | Gibt den IGraphStorage zurück, mit dem der Graph verknüpft ist, oder legt ihn fest.
 | GraphTraceSource | Gibt die Ablaufverfolgungsquelle für Graphen zurück.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Overrides BaseObject..::..LocalTrace.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Overrides BaseObject..::..NameDefaultValue.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Runtime | Gibt das IRuntime-Objekt zurück, in dem der Graph arbeitet.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperInPorts | Gibt die Eingabe-Ports des Sub-Graphen zurück.
Public property | SuperOutPorts | Gibt die Ausgabe-Ports des Sub-Graphen zurück.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ConnectionAffected | Dieses Ereignis wird ausgelöst, wenn der Graph sich verändert hat und dabei eine Verbindung betroffen ist.
Public event | Death | Der letzte Knoten hat seine Aktivität beendet.
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | FlagChanged | Ein Graphen-Flag hat seinen Zustand geändert.
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | StartLife | Der erste Knoten wurde aktiv.

See Also

Graph Class
DynamicNode.Core Namespace


Graph Constructor

[image]

DynamicNodes API
Graph Constructor
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the Graph class

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Graph()
Visual Basic
Public Sub New
F#
new : unit -> Graph

See Also

Graph Class
DynamicNode.Core Namespace


Graph Methods

[image] [image]

DynamicNodes API
Graph Methods
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Graph type exposes the following members.

Methods

 | Name | Description
Public method | ActivateNodes | Aktiviert alle Knoten, an deren Eingängen neue Tokens anliegen. Muss nur aufgerufen werden, nach dem ein Graph wiederhergestellt wurde um die mit OnRestore(IPropertyReader) erzeugten Tokens an den Eingängen zu verarbeiten.
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | AddNodeWithId | Fügt einen Knoten mit einer vorgegebenen ID hinzu. Diese Methode wird beim Rekonstruieren eines Graphen benötigt.
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..BeforeRemoveChild(TChild).)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche der Graph identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | NotifyGraphFlagChanged | Benachricht den Graphen über ein Flag dessen Zustand sich geändert hat.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnAttachExtension(IExtension<(Of <<'(TSelf>)>>), Boolean).)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildAdded(TChild).)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildRemoved(TChild).)
Public method | OnConnectionAffected | Diese Methode muss aufgerufen werden, wenn eine Verbindung erstellt oder zerstört wurde. Sie löst das ConnectionAffected-Ereignis aus.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnDetachExtension(IExtension<(Of <<'(TSelf>)>>)).)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Overrides Object..::..ToString()()()().)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Graph Class
DynamicNode.Core Namespace


ActivateNodes Method

[image]

DynamicNodes API
Graph..::..ActivateNodes Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert alle Knoten, an deren Eingängen neue Tokens anliegen. Muss nur aufgerufen werden, nach dem ein Graph wiederhergestellt wurde um die mit OnRestore(IPropertyReader) erzeugten Tokens an den Eingängen zu verarbeiten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ActivateNodes()
Visual Basic
Public Sub ActivateNodes
F#
abstract ActivateNodes : unit -> unit
override ActivateNodes : unit -> unit

Implements

IGraph..::..ActivateNodes()()()()

See Also

Graph Class
DynamicNode.Core Namespace


AddNodeWithId Method

[image]

DynamicNodes API
Graph..::..AddNodeWithId Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt einen Knoten mit einer vorgegebenen ID hinzu. Diese Methode wird beim Rekonstruieren eines Graphen benötigt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AddNodeWithId(
    INode node,
    int id
)
Visual Basic
Public Sub AddNodeWithId ( _
    node As INode, _
    id As Integer _
)
F#
abstract AddNodeWithId :
        node:INode *
        id:int -> unit
override AddNodeWithId :
        node:INode *
        id:int -> unit

Parameters

node
Type: DynamicNode.Core..::..INode
Der Knoten.
id
Type: System..::..Int32
Die ID des Knotens.

Implements

IGraph..::..AddNodeWithId(INode, Int32)

See Also

Graph Class
DynamicNode.Core Namespace


BeforeRemoveChild Method

[image]

DynamicNodes API
Graph..::..BeforeRemoveChild Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override bool BeforeRemoveChild(
    INode childToRemove
)
Visual Basic
Protected Overrides Function BeforeRemoveChild ( _
    childToRemove As INode _
) As Boolean
F#
abstract BeforeRemoveChild :
        childToRemove:INode -> bool
override BeforeRemoveChild :
        childToRemove:INode -> bool

Parameters

childToRemove
Type: DynamicNode.Core..::..INode
Das zu entfernende Kindobjekt.

Return Value

true, wenn das Kindobjekt entfernt werden darf, sonst false.

Remarks

Die Standardimplementierung setzt die ID von Kindobjekten auf -1 wenn AutoChildId gleich true ist und gibt immer true zurück.

See Also

Graph Class
DynamicNode.Core Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
Graph..::..BeforeUseExtension Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

Graph Class
Graph Members
DynamicNode.Core Namespace


GetAddress Method

[image]

DynamicNodes API
Graph..::..GetAddress Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Zeichenfolge zurück, welche der Graph identifiziert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string GetAddress()
Visual Basic
Public Function GetAddress As String
F#
abstract GetAddress : unit -> string
override GetAddress : unit -> string

Return Value

Eine Graph-Adresse.

Implements

IGraph..::..GetAddress()()()()

See Also

Graph Class
DynamicNode.Core Namespace


NotifyGraphFlagChanged Method

[image]

DynamicNodes API
Graph..::..NotifyGraphFlagChanged Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Benachricht den Graphen über ein Flag dessen Zustand sich geändert hat.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void NotifyGraphFlagChanged(
    IFlag flag
)
Visual Basic
Public Sub NotifyGraphFlagChanged ( _
    flag As IFlag _
)
F#
abstract NotifyGraphFlagChanged :
        flag:IFlag -> unit
override NotifyGraphFlagChanged :
        flag:IFlag -> unit

Parameters

flag
Type: DynamicNode.Core..::..IFlag
Das Flag, das seinen Zustand geändert hat.

Implements

IGraph..::..NotifyGraphFlagChanged(IFlag)

See Also

Graph Class
DynamicNode.Core Namespace


OnAttachExtension Method

[image]

DynamicNodes API
Graph..::..OnAttachExtension Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnAttachExtension(
    IExtension<IGraph> extension,
    bool successful
)
Visual Basic
Protected Overrides Sub OnAttachExtension ( _
    extension As IExtension(Of IGraph), _
    successful As Boolean _
)
F#
abstract OnAttachExtension :
        extension:IExtension<IGraph> *
        successful:bool -> unit
override OnAttachExtension :
        extension:IExtension<IGraph> *
        successful:bool -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>
Die Erweiterung.
successful
Type: System..::..Boolean
true wenn die Erweiterung erfolgreich registriert werden konnte, andernfalls false.

See Also

Graph Class
DynamicNode.Core Namespace


OnChildAdded Method

[image]

DynamicNodes API
Graph..::..OnChildAdded Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnChildAdded(
    INode childToAdd
)
Visual Basic
Protected Overrides Sub OnChildAdded ( _
    childToAdd As INode _
)
F#
abstract OnChildAdded :
        childToAdd:INode -> unit
override OnChildAdded :
        childToAdd:INode -> unit

Parameters

childToAdd
Type: DynamicNode.Core..::..INode
Das hinzugefügte Kindobjekt.

See Also

Graph Class
DynamicNode.Core Namespace


OnChildRemoved Method

[image]

DynamicNodes API
Graph..::..OnChildRemoved Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnChildRemoved(
    INode childToRemove
)
Visual Basic
Protected Overrides Sub OnChildRemoved ( _
    childToRemove As INode _
)
F#
abstract OnChildRemoved :
        childToRemove:INode -> unit
override OnChildRemoved :
        childToRemove:INode -> unit

Parameters

childToRemove
Type: DynamicNode.Core..::..INode
Die entfernten Kindobjekte.

See Also

Graph Class
DynamicNode.Core Namespace


OnConnectionAffected Method

[image]

DynamicNodes API
Graph..::..OnConnectionAffected Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Diese Methode muss aufgerufen werden, wenn eine Verbindung erstellt oder zerstört wurde. Sie löst das ConnectionAffected-Ereignis aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnConnectionAffected(
    InPort iP,
    OutPort oP,
    ConnectionEventTyp typ
)
Visual Basic
Public Sub OnConnectionAffected ( _
    iP As InPort, _
    oP As OutPort, _
    typ As ConnectionEventTyp _
)
F#
abstract OnConnectionAffected :
        iP:InPort *
        oP:OutPort *
        typ:ConnectionEventTyp -> unit
override OnConnectionAffected :
        iP:InPort *
        oP:OutPort *
        typ:ConnectionEventTyp -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Der InPort der Verbindung.
oP
Type: DynamicNode.Core..::..OutPort
Der OutPort der Verbindung.
typ
Type: DynamicNode.Core..::..ConnectionEventTyp
Der Typ des Ereignisses.

Implements

IGraph..::..OnConnectionAffected(InPort, OutPort, ConnectionEventTyp)

See Also

Graph Class
DynamicNode.Core Namespace


OnDetachExtension Method

[image]

DynamicNodes API
Graph..::..OnDetachExtension Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn eine Erweiterung entfernt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnDetachExtension(
    IExtension<IGraph> extension
)
Visual Basic
Protected Overrides Sub OnDetachExtension ( _
    extension As IExtension(Of IGraph) _
)
F#
abstract OnDetachExtension :
        extension:IExtension<IGraph> -> unit
override OnDetachExtension :
        extension:IExtension<IGraph> -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>
Die Erweiterung.

See Also

Graph Class
DynamicNode.Core Namespace


ToString Method

[image]

DynamicNodes API
Graph..::..ToString Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen String zurück, der den aktuellen Object darstellt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Ein String, der den aktuellen Object darstellt.

See Also

Graph Class
DynamicNode.Core Namespace


TraceError Method

[image] [image]

DynamicNodes API
Graph..::..TraceError Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Graph Class
Graph Members
DynamicNode.Core Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
Graph..::..TraceInfo Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Graph Class
Graph Members
DynamicNode.Core Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
Graph..::..TraceVerbose Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Graph Class
Graph Members
DynamicNode.Core Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
Graph..::..TraceVerboseData Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Graph Class
Graph Members
DynamicNode.Core Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
Graph..::..TraceWarning Method
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Graph Class
Graph Members
DynamicNode.Core Namespace


Graph Properties

[image] [image]

DynamicNodes API
Graph Properties
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Graph type exposes the following members.

Properties

 | Name | Description
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | BlockActivations | Liest und schreibt ein Flag, welches angibt ob Aktivierungen von Knoten verhindert werden sollen.
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | GraphStateFlags | Gibt ein Wörterbuch mit den Flags des Graphen zurück. Flags werden durch Knoten der Klasse NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens. Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.
Public property | GraphStorage | Gibt den IGraphStorage zurück, mit dem der Graph verknüpft ist, oder legt ihn fest.
 | GraphTraceSource | Gibt die Ablaufverfolgungsquelle für Graphen zurück.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Overrides BaseObject..::..LocalTrace.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Overrides BaseObject..::..NameDefaultValue.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Runtime | Gibt das IRuntime-Objekt zurück, in dem der Graph arbeitet.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperInPorts | Gibt die Eingabe-Ports des Sub-Graphen zurück.
Public property | SuperOutPorts | Gibt die Ausgabe-Ports des Sub-Graphen zurück.

See Also

Graph Class
DynamicNode.Core Namespace


BlockActivations Property

[image]

DynamicNodes API
Graph..::..BlockActivations Property
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest und schreibt ein Flag, welches angibt ob Aktivierungen von Knoten verhindert werden sollen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool BlockActivations { get; set; }
Visual Basic
Public Property BlockActivations As Boolean
    Get
    Set
F#
abstract BlockActivations : bool with get, set
override BlockActivations : bool with get, set

Field Value

Return Value

true, wenn keine Aktivierungen erlaubt sind, für die Ausführung des Graphen false.

Implements

IGraph..::..BlockActivations

See Also

Graph Class
DynamicNode.Core Namespace


GraphStateFlags Property

[image]

DynamicNodes API
Graph..::..GraphStateFlags Property
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Gibt ein Wörterbuch mit den Flags des Graphen zurück.

Flags werden durch Knoten der Klasse NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens.

Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IDictionary<string, TokenState> GraphStateFlags { get; }
Visual Basic
Public ReadOnly Property GraphStateFlags As IDictionary(Of String, TokenState)
    Get
F#
abstract GraphStateFlags : IDictionary<string, TokenState>
override GraphStateFlags : IDictionary<string, TokenState>

Field Value

Die Flags des Graphen.

Implements

IGraph..::..GraphStateFlags

See Also

Graph Class
DynamicNode.Core Namespace


GraphStorage Property

[image]

DynamicNodes API
Graph..::..GraphStorage Property
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den IGraphStorage zurück, mit dem der Graph verknüpft ist, oder legt ihn fest.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IGraphStorage GraphStorage { get; set; }
Visual Basic
Public Property GraphStorage As IGraphStorage
    Get
    Set
F#
abstract GraphStorage : IGraphStorage with get, set
override GraphStorage : IGraphStorage with get, set

Field Value

Implements

IGraph..::..GraphStorage

See Also

Graph Class
DynamicNode.Core Namespace


GraphTraceSource Property

[image]

DynamicNodes API
Graph..::..GraphTraceSource Property
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ablaufverfolgungsquelle für Graphen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TraceSource GraphTraceSource { get; }
Visual Basic
Public Shared ReadOnly Property GraphTraceSource As TraceSource
    Get
F#
static member GraphTraceSource : TraceSource

See Also

Graph Class
DynamicNode.Core Namespace


Item Property

[image] [image]

DynamicNodes API
Graph..::..Item Property
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

Graph Class
Graph Members
DynamicNode.Core Namespace


LocalTrace Property

[image]

DynamicNodes API
Graph..::..LocalTrace Property
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override TraceSource LocalTrace { get; }
Visual Basic
Protected Overrides ReadOnly Property LocalTrace As TraceSource
    Get
F#
abstract LocalTrace : TraceSource
override LocalTrace : TraceSource

See Also

Graph Class
DynamicNode.Core Namespace


NameDefaultValue Property

[image]

DynamicNodes API
Graph..::..NameDefaultValue Property
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standardwert für die Eigenschaft Name zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override string NameDefaultValue { get; }
Visual Basic
Protected Overrides ReadOnly Property NameDefaultValue As String
    Get
F#
abstract NameDefaultValue : string
override NameDefaultValue : string

Field Value

Der Standardwert von Name.

See Also

Graph Class
DynamicNode.Core Namespace


Runtime Property

[image]

DynamicNodes API
Graph..::..Runtime Property
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das IRuntime-Objekt zurück, in dem der Graph arbeitet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IRuntime Runtime { get; }
Visual Basic
Public ReadOnly Property Runtime As IRuntime
    Get
F#
abstract Runtime : IRuntime
override Runtime : IRuntime

Field Value

Das IRuntime-Objekt, in dem der Graph arbeitet.

Implements

IGraph..::..Runtime

See Also

Graph Class
DynamicNode.Core Namespace


SuperInPorts Property

[image]

DynamicNodes API
Graph..::..SuperInPorts Property
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Eingabe-Ports des Sub-Graphen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IEnumerable<InPort> SuperInPorts { get; }
Visual Basic
Public ReadOnly Property SuperInPorts As IEnumerable(Of InPort)
    Get
F#
abstract SuperInPorts : IEnumerable<InPort>
override SuperInPorts : IEnumerable<InPort>

Field Value

Die Eingabe-Ports des Sub-Graphen.

Implements

IGraph..::..SuperInPorts

See Also

Graph Class
DynamicNode.Core Namespace


SuperOutPorts Property

[image]

DynamicNodes API
Graph..::..SuperOutPorts Property
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ausgabe-Ports des Sub-Graphen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IEnumerable<OutPort> SuperOutPorts { get; }
Visual Basic
Public ReadOnly Property SuperOutPorts As IEnumerable(Of OutPort)
    Get
F#
abstract SuperOutPorts : IEnumerable<OutPort>
override SuperOutPorts : IEnumerable<OutPort>

Field Value

Die Ausgabe-Ports des Sub-Graphen.

Implements

IGraph..::..SuperOutPorts

See Also

Graph Class
DynamicNode.Core Namespace


Graph Events

[image] [image]

DynamicNodes API
Graph Events
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Graph type exposes the following members.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ConnectionAffected | Dieses Ereignis wird ausgelöst, wenn der Graph sich verändert hat und dabei eine Verbindung betroffen ist.
Public event | Death | Der letzte Knoten hat seine Aktivität beendet.
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | FlagChanged | Ein Graphen-Flag hat seinen Zustand geändert.
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | StartLife | Der erste Knoten wurde aktiv.

See Also

Graph Class
DynamicNode.Core Namespace


ConnectionAffected Event

[image]

DynamicNodes API
Graph..::..ConnectionAffected Event
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Dieses Ereignis wird ausgelöst, wenn der Graph sich verändert hat und dabei eine Verbindung betroffen ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<ConnectionEventArgs> ConnectionAffected
Visual Basic
Public Event ConnectionAffected As EventHandler(Of ConnectionEventArgs)
F#
abstract ConnectionAffected : IEvent<EventHandler<ConnectionEventArgs>,
    ConnectionEventArgs>
override ConnectionAffected : IEvent<EventHandler<ConnectionEventArgs>,
    ConnectionEventArgs>

Implements

IGraph..::..ConnectionAffected

See Also

Graph Class
DynamicNode.Core Namespace


Death Event

[image]

DynamicNodes API
Graph..::..Death Event
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der letzte Knoten hat seine Aktivität beendet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler Death
Visual Basic
Public Event Death As EventHandler
F#
abstract Death : IEvent<EventHandler,
    EventArgs>
override Death : IEvent<EventHandler,
    EventArgs>

Implements

IGraph..::..Death

See Also

Graph Class
DynamicNode.Core Namespace


FlagChanged Event

[image]

DynamicNodes API
Graph..::..FlagChanged Event
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Graphen-Flag hat seinen Zustand geändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<GraphFlagChangedEventArgs> FlagChanged
Visual Basic
Public Event FlagChanged As EventHandler(Of GraphFlagChangedEventArgs)
F#
abstract FlagChanged : IEvent<EventHandler<GraphFlagChangedEventArgs>,
    GraphFlagChangedEventArgs>
override FlagChanged : IEvent<EventHandler<GraphFlagChangedEventArgs>,
    GraphFlagChangedEventArgs>

Implements

IGraph..::..FlagChanged

See Also

Graph Class
DynamicNode.Core Namespace


StartLife Event

[image]

DynamicNodes API
Graph..::..StartLife Event
Graph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der erste Knoten wurde aktiv.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler StartLife
Visual Basic
Public Event StartLife As EventHandler
F#
abstract StartLife : IEvent<EventHandler,
    EventArgs>
override StartLife : IEvent<EventHandler,
    EventArgs>

Implements

IGraph..::..StartLife

See Also

Graph Class
DynamicNode.Core Namespace


GraphEventArgs Class

[image]

DynamicNodes API
GraphEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignisargumente, welche die Änderung eines Graphen näher beschreiben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class GraphEventArgs : EventArgs
Visual Basic
Public Class GraphEventArgs _
    Inherits EventArgs
F#
type GraphEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Core..::..GraphEventArgs

See Also

GraphEventArgs Members
DynamicNode.Core Namespace


GraphEventArgs Members

[image] [image]

DynamicNodes API
GraphEventArgs Members
GraphEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GraphEventArgs | Initialisiert eine neue Instanz der Klasse GraphEventArgs.

Properties

 | Name | Description
Public property | Graph | Gibt das betroffene Graph zurück
Public property | Runtime | Gibt die auslösende Laufzeitumgebung zurück.
Public property | Typ | Gibt den Ereignis-Typ zurück.

See Also

GraphEventArgs Class
DynamicNode.Core Namespace


GraphEventArgs Constructor

[image]

DynamicNodes API
GraphEventArgs Constructor
GraphEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse GraphEventArgs.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public GraphEventArgs(
    IRuntime runtime,
    IGraph graph,
    Affection typ
)
Visual Basic
Public Sub New ( _
    runtime As IRuntime, _
    graph As IGraph, _
    typ As Affection _
)
F#
new :
        runtime:IRuntime *
        graph:IGraph *
        typ:Affection -> GraphEventArgs

Parameters

runtime
Type: DynamicNode.Core..::..IRuntime
Die auslösende Laufzeitumgebung.
graph
Type: DynamicNode.Core..::..IGraph
Das betroffene Graph.
typ
Type: DynamicNode.Core..::..Affection
Der Ereignis-Typ.

See Also

GraphEventArgs Class
DynamicNode.Core Namespace


GraphEventArgs Properties

[image] [image]

DynamicNodes API
GraphEventArgs Properties
GraphEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Graph | Gibt das betroffene Graph zurück
Public property | Runtime | Gibt die auslösende Laufzeitumgebung zurück.
Public property | Typ | Gibt den Ereignis-Typ zurück.

See Also

GraphEventArgs Class
DynamicNode.Core Namespace


Graph Property

[image]

DynamicNodes API
GraphEventArgs..::..Graph Property
GraphEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das betroffene Graph zurück

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IGraph Graph { get; }
Visual Basic
Public ReadOnly Property Graph As IGraph
    Get
F#
member Graph : IGraph

Field Value

Der Graph.

See Also

GraphEventArgs Class
DynamicNode.Core Namespace


Runtime Property

[image]

DynamicNodes API
GraphEventArgs..::..Runtime Property
GraphEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die auslösende Laufzeitumgebung zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IRuntime Runtime { get; }
Visual Basic
Public ReadOnly Property Runtime As IRuntime
    Get
F#
member Runtime : IRuntime

Field Value

Die Laufzeitumgebung.

See Also

GraphEventArgs Class
DynamicNode.Core Namespace


Typ Property

[image]

DynamicNodes API
GraphEventArgs..::..Typ Property
GraphEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Ereignis-Typ zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Affection Typ { get; }
Visual Basic
Public ReadOnly Property Typ As Affection
    Get
F#
member Typ : Affection

Field Value

Der Ereignis-Typ.

See Also

GraphEventArgs Class
DynamicNode.Core Namespace


GraphFlagChangedEventArgs Class

[image]

DynamicNodes API
GraphFlagChangedEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Ereignis-Argument für die Änderungen eines Graphen-Flags.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class GraphFlagChangedEventArgs : EventArgs
Visual Basic
Public Class GraphFlagChangedEventArgs _
    Inherits EventArgs
F#
type GraphFlagChangedEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Core..::..GraphFlagChangedEventArgs

See Also

GraphFlagChangedEventArgs Members
DynamicNode.Core Namespace


GraphFlagChangedEventArgs Members

[image] [image]

DynamicNodes API
GraphFlagChangedEventArgs Members
GraphFlagChangedEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphFlagChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GraphFlagChangedEventArgs | Initialisiert eine neue GraphFlagChangedEventArgs Instanz.

Properties

 | Name | Description
Public property | Name | Gibt den Namen des Graphen-FLags zurück dessen Zustand sich geändert hat.
Public property | State | Gibt den Status des Graphen-Flags zurück dessen Zustand sich geändert hat.

See Also

GraphFlagChangedEventArgs Class
DynamicNode.Core Namespace


GraphFlagChangedEventArgs Constructor

[image]

DynamicNodes API
GraphFlagChangedEventArgs Constructor
GraphFlagChangedEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue GraphFlagChangedEventArgs Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public GraphFlagChangedEventArgs(
    IFlag flag
)
Visual Basic
Public Sub New ( _
    flag As IFlag _
)
F#
new :
        flag:IFlag -> GraphFlagChangedEventArgs

Parameters

flag
Type: DynamicNode.Core..::..IFlag
Das Flag, dessen Zustand sich geändert hat.

See Also

GraphFlagChangedEventArgs Class
DynamicNode.Core Namespace


GraphFlagChangedEventArgs Properties

[image] [image]

DynamicNodes API
GraphFlagChangedEventArgs Properties
GraphFlagChangedEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphFlagChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gibt den Namen des Graphen-FLags zurück dessen Zustand sich geändert hat.
Public property | State | Gibt den Status des Graphen-Flags zurück dessen Zustand sich geändert hat.

See Also

GraphFlagChangedEventArgs Class
DynamicNode.Core Namespace


Name Property

[image]

DynamicNodes API
GraphFlagChangedEventArgs..::..Name Property
GraphFlagChangedEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Graphen-FLags zurück dessen Zustand sich geändert hat.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
member Name : string

Field Value

Der Name des Graphen-Flags.

See Also

GraphFlagChangedEventArgs Class
DynamicNode.Core Namespace


State Property

[image]

DynamicNodes API
GraphFlagChangedEventArgs..::..State Property
GraphFlagChangedEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Status des Graphen-Flags zurück dessen Zustand sich geändert hat.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenState State { get; }
Visual Basic
Public ReadOnly Property State As TokenState
    Get
F#
member State : TokenState

Field Value

Der Zustand des Graphen-Flags.

See Also

GraphFlagChangedEventArgs Class
DynamicNode.Core Namespace


IApplicationContext Interface

[image]

DynamicNodes API
IApplicationContext Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für Anwendungen die DynamicNodes-Laufzeitumgebungen hosten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IApplicationContext
Visual Basic
Public Interface IApplicationContext
F#
type IApplicationContext =  interface end

See Also

IApplicationContext Members
DynamicNode.Core Namespace


IApplicationContext Members

[image] [image]

DynamicNodes API
IApplicationContext Members
IApplicationContext Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IApplicationContext type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein Script in der Anwendung aus ud liefert die Ausgabe als String zurück.

See Also

IApplicationContext Interface
DynamicNode.Core Namespace


IApplicationContext Methods

[image] [image]

DynamicNodes API
IApplicationContext Methods
IApplicationContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IApplicationContext type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein Script in der Anwendung aus ud liefert die Ausgabe als String zurück.

See Also

IApplicationContext Interface
DynamicNode.Core Namespace


ExecuteScript Method

[image]

DynamicNodes API
IApplicationContext..::..ExecuteScript Method
IApplicationContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt ein Script in der Anwendung aus ud liefert die Ausgabe als String zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string ExecuteScript(
    string script
)
Visual Basic
Function ExecuteScript ( _
    script As String _
) As String
F#
abstract ExecuteScript :
        script:string -> string

Parameters

script
Type: System..::..String
Der Quelltext des Scripts.

Return Value

Die Ausgabe.

See Also

IApplicationContext Interface
DynamicNode.Core Namespace


IAttachmentNode Interface

[image]

DynamicNodes API
IAttachmentNode Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Knoten-Schnittstelle welche einen Anhang für den Graphen kapseln.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IAttachmentNode : INode,
    IChild<IGraph, INode>, IParent<INode, IPort>,
    IBaseObject, IIdentifiable, IStorable, IExtensible<INode>,
    IDisposable, IComparable<INode>
Visual Basic
Public Interface IAttachmentNode _
    Inherits INode, IChild(Of IGraph, INode),  _
    IParent(Of INode, IPort), IBaseObject, IIdentifiable,  _
    IStorable, IExtensible(Of INode), IDisposable, IComparable(Of INode)
F#
type IAttachmentNode =
    interface
        interface INode
        interface IChild<IGraph, INode>
        interface IParent<INode, IPort>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
        interface IExtensible<INode>
        interface IDisposable
        interface IComparable<INode>
    end

See Also

IAttachmentNode Members
DynamicNode.Core Namespace


IAttachmentNode Members

[image] [image]

DynamicNodes API
IAttachmentNode Members
IAttachmentNode Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IAttachmentNode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from INode.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from INode.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from INode.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from INode.)
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from INode.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from INode.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from INode.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from INode.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from INode.)
Public property | Attachment | Gibt den Anhang des Knotens zurück.
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from INode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört. (Inherited from INode.)
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from INode.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from INode.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public property | IsParallelizable | Liest einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from INode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from INode.)
Public property | Item | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from INode.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from INode.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from INode.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from INode.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from INode.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from INode.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from INode.)
Public event | BeforeActivation | Wird ausgelöst, wenn die Aktivierung beginnt. (Inherited from INode.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from INode.)
Public event | ChildAdded | Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wird. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)

See Also

IAttachmentNode Interface
DynamicNode.Core Namespace


IAttachmentNode Methods

[image] [image]

DynamicNodes API
IAttachmentNode Methods
IAttachmentNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IAttachmentNode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from INode.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from INode.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from INode.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from INode.)
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from INode.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from INode.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from INode.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from INode.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)

See Also

IAttachmentNode Interface
DynamicNode.Core Namespace


Duplicate Method

[image] [image]

DynamicNodes API
IAttachmentNode..::..Duplicate Method
IAttachmentNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from INode.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from INode.)

See Also

IAttachmentNode Interface
IAttachmentNode Members
DynamicNode.Core Namespace


IAttachmentNode Properties

[image] [image]

DynamicNodes API
IAttachmentNode Properties
IAttachmentNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IAttachmentNode type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from INode.)
Public property | Attachment | Gibt den Anhang des Knotens zurück.
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from INode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört. (Inherited from INode.)
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from INode.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from INode.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public property | IsParallelizable | Liest einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from INode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from INode.)
Public property | Item | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from INode.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from INode.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from INode.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from INode.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from INode.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from INode.)

See Also

IAttachmentNode Interface
DynamicNode.Core Namespace


Attachment Property

[image]

DynamicNodes API
IAttachmentNode..::..Attachment Property
IAttachmentNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Anhang des Knotens zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
Object Attachment { get; }
Visual Basic
ReadOnly Property Attachment As Object
    Get
F#
abstract Attachment : Object

Field Value

Anhang

See Also

IAttachmentNode Interface
DynamicNode.Core Namespace


IAttachmentNode Events

[image] [image]

DynamicNodes API
IAttachmentNode Events
IAttachmentNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IAttachmentNode type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from INode.)
Public event | BeforeActivation | Wird ausgelöst, wenn die Aktivierung beginnt. (Inherited from INode.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from INode.)
Public event | ChildAdded | Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wird. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)

See Also

IAttachmentNode Interface
DynamicNode.Core Namespace


IConfiguration Interface

[image]

DynamicNodes API
IConfiguration Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die System-Konfiguration.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IConfiguration : IStorable
Visual Basic
Public Interface IConfiguration _
    Inherits IStorable
F#
type IConfiguration =
    interface
        interface IStorable
    end

See Also

IConfiguration Members
DynamicNode.Core Namespace


IConfiguration Members

[image] [image]

DynamicNodes API
IConfiguration Members
IConfiguration Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)

Properties

 | Name | Description
Public property | HasWorkspace | Gibt einen Wert der angibt, ob die Konfigurtion ein Arbeitsverzeichnis besitzt.
Public property | HelpPath | Gibt das Hilfe-Verzeichnis oder null zurück.
Public property | ProjectsPath | Gibt das Standardverzeichnis für Projektdateien oder null zurück.
Public property | ScriptsPath | Gibt das Verzeichnis mit den Skripten oder null zurück.
Public property | SettingsPath | Gibt das Verzeichnis mit den Programmeinstellungen oder null zurück.
Public property | SystemModuleLibraryPath | Gibt das Verzeichnis für Systemmodule oder null zurück.
Public property | SystemNodeLibraryPath | Gibt das Verzeichnis mit den Systemknotenbibliotheken oder null zurück.
Public property | SystemPath | Gibt das Startverzeichnis der Laufzeitumgebung zurück.
Public property | SystemTemplateLibraryPath | Gibt das Verzeichnis für Systemvorlagen oder null zurück.
Public property | WorkspaceModuleLibraryPath | Gibt das Verzeichnis für Benutzermodule oder null zurück.
Public property | WorkspaceNodeLibraryPath | Gibt das Verzeichnis mit den Benutzerknotenbibliotheken oder null zurück.
Public property | WorkspacePath | Gibt das Arbeitsverzeichnis für DynamicNodes im Benutzerkontext oder null zurück.
Public property | WorkspaceTemplateLibraryPath | Gibt das Verzeichnis für Benutzervorlagen oder null zurück.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


IConfiguration Methods

[image] [image]

DynamicNodes API
IConfiguration Methods
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)

See Also

IConfiguration Interface
DynamicNode.Core Namespace


IConfiguration Properties

[image] [image]

DynamicNodes API
IConfiguration Properties
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | HasWorkspace | Gibt einen Wert der angibt, ob die Konfigurtion ein Arbeitsverzeichnis besitzt.
Public property | HelpPath | Gibt das Hilfe-Verzeichnis oder null zurück.
Public property | ProjectsPath | Gibt das Standardverzeichnis für Projektdateien oder null zurück.
Public property | ScriptsPath | Gibt das Verzeichnis mit den Skripten oder null zurück.
Public property | SettingsPath | Gibt das Verzeichnis mit den Programmeinstellungen oder null zurück.
Public property | SystemModuleLibraryPath | Gibt das Verzeichnis für Systemmodule oder null zurück.
Public property | SystemNodeLibraryPath | Gibt das Verzeichnis mit den Systemknotenbibliotheken oder null zurück.
Public property | SystemPath | Gibt das Startverzeichnis der Laufzeitumgebung zurück.
Public property | SystemTemplateLibraryPath | Gibt das Verzeichnis für Systemvorlagen oder null zurück.
Public property | WorkspaceModuleLibraryPath | Gibt das Verzeichnis für Benutzermodule oder null zurück.
Public property | WorkspaceNodeLibraryPath | Gibt das Verzeichnis mit den Benutzerknotenbibliotheken oder null zurück.
Public property | WorkspacePath | Gibt das Arbeitsverzeichnis für DynamicNodes im Benutzerkontext oder null zurück.
Public property | WorkspaceTemplateLibraryPath | Gibt das Verzeichnis für Benutzervorlagen oder null zurück.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


HasWorkspace Property

[image]

DynamicNodes API
IConfiguration..::..HasWorkspace Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert der angibt, ob die Konfigurtion ein Arbeitsverzeichnis besitzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool HasWorkspace { get; }
Visual Basic
ReadOnly Property HasWorkspace As Boolean
    Get
F#
abstract HasWorkspace : bool

Field Value

true, wenn diese Konfiguration ein Arbeitsverzeichnis besitzt, sonst false.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


HelpPath Property

[image]

DynamicNodes API
IConfiguration..::..HelpPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Hilfe-Verzeichnis oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string HelpPath { get; set; }
Visual Basic
Property HelpPath As String
    Get
    Set
F#
abstract HelpPath : string with get, set

Field Value

Das Verzeichnis mit den Hilfe-Dateien oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


ProjectsPath Property

[image]

DynamicNodes API
IConfiguration..::..ProjectsPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Standardverzeichnis für Projektdateien oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string ProjectsPath { get; set; }
Visual Basic
Property ProjectsPath As String
    Get
    Set
F#
abstract ProjectsPath : string with get, set

Field Value

Das Standardverzeichnis für Projektdateien oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


ScriptsPath Property

[image]

DynamicNodes API
IConfiguration..::..ScriptsPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis mit den Skripten oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string ScriptsPath { get; }
Visual Basic
ReadOnly Property ScriptsPath As String
    Get
F#
abstract ScriptsPath : string

Field Value

Das Verzeichnis der Skripte oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


SettingsPath Property

[image]

DynamicNodes API
IConfiguration..::..SettingsPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis mit den Programmeinstellungen oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string SettingsPath { get; }
Visual Basic
ReadOnly Property SettingsPath As String
    Get
F#
abstract SettingsPath : string

Field Value

Das Verzeichnis für Einstellungsdateien oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


SystemModuleLibraryPath Property

[image]

DynamicNodes API
IConfiguration..::..SystemModuleLibraryPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis für Systemmodule oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string SystemModuleLibraryPath { get; }
Visual Basic
ReadOnly Property SystemModuleLibraryPath As String
    Get
F#
abstract SystemModuleLibraryPath : string

Field Value

Das Verzeichnis der Systemmodulbibliothek oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


SystemNodeLibraryPath Property

[image]

DynamicNodes API
IConfiguration..::..SystemNodeLibraryPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis mit den Systemknotenbibliotheken oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string SystemNodeLibraryPath { get; }
Visual Basic
ReadOnly Property SystemNodeLibraryPath As String
    Get
F#
abstract SystemNodeLibraryPath : string

Field Value

Das Verzeichnis der Systemknotenbibliotheken oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


SystemPath Property

[image]

DynamicNodes API
IConfiguration..::..SystemPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Startverzeichnis der Laufzeitumgebung zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string SystemPath { get; }
Visual Basic
ReadOnly Property SystemPath As String
    Get
F#
abstract SystemPath : string

Field Value

Das Startverzeichnis der Laufzeitumgebung.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


SystemTemplateLibraryPath Property

[image]

DynamicNodes API
IConfiguration..::..SystemTemplateLibraryPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis für Systemvorlagen oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string SystemTemplateLibraryPath { get; }
Visual Basic
ReadOnly Property SystemTemplateLibraryPath As String
    Get
F#
abstract SystemTemplateLibraryPath : string

Field Value

Das Verzeichnis der Systemvorlagenbibliothek oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


WorkspaceModuleLibraryPath Property

[image]

DynamicNodes API
IConfiguration..::..WorkspaceModuleLibraryPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis für Benutzermodule oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string WorkspaceModuleLibraryPath { get; set; }
Visual Basic
Property WorkspaceModuleLibraryPath As String
    Get
    Set
F#
abstract WorkspaceModuleLibraryPath : string with get, set

Field Value

Das Verzeichnis der Benutzermodulbibliothek oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


WorkspaceNodeLibraryPath Property

[image]

DynamicNodes API
IConfiguration..::..WorkspaceNodeLibraryPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis mit den Benutzerknotenbibliotheken oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string WorkspaceNodeLibraryPath { get; set; }
Visual Basic
Property WorkspaceNodeLibraryPath As String
    Get
    Set
F#
abstract WorkspaceNodeLibraryPath : string with get, set

Field Value

Das Verzeichnis der Benutzerknotenbibliotheken oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


WorkspacePath Property

[image]

DynamicNodes API
IConfiguration..::..WorkspacePath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Arbeitsverzeichnis für DynamicNodes im Benutzerkontext oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string WorkspacePath { get; }
Visual Basic
ReadOnly Property WorkspacePath As String
    Get
F#
abstract WorkspacePath : string

Field Value

Das Arbeitsverzeichnis im Benutzerkontext oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


WorkspaceTemplateLibraryPath Property

[image]

DynamicNodes API
IConfiguration..::..WorkspaceTemplateLibraryPath Property
IConfiguration Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Verzeichnis für Benutzervorlagen oder null zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string WorkspaceTemplateLibraryPath { get; set; }
Visual Basic
Property WorkspaceTemplateLibraryPath As String
    Get
    Set
F#
abstract WorkspaceTemplateLibraryPath : string with get, set

Field Value

Das Verzeichnis der Benutzervorlagenbibliothek oder null.

See Also

IConfiguration Interface
DynamicNode.Core Namespace


ICustomNodeFactory Interface

[image]

DynamicNodes API
ICustomNodeFactory Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für benutzerdefinierte Knoten-Factories.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface ICustomNodeFactory
Visual Basic
Public Interface ICustomNodeFactory
F#
type ICustomNodeFactory =  interface end

See Also

ICustomNodeFactory Members
DynamicNode.Core Namespace


ICustomNodeFactory Members

[image] [image]

DynamicNodes API
ICustomNodeFactory Members
ICustomNodeFactory Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ICustomNodeFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateNode | Erzeugt einen neuen Knoten mit Hilfe einer Factory-Variation.
Public method | GetVariations | Gibt alle möglichen Variationen für diese Factory zurück. Die Factory muss mindestens eine Variation zur Verfügung stellen.

See Also

ICustomNodeFactory Interface
DynamicNode.Core Namespace


ICustomNodeFactory Methods

[image] [image]

DynamicNodes API
ICustomNodeFactory Methods
ICustomNodeFactory Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ICustomNodeFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateNode | Erzeugt einen neuen Knoten mit Hilfe einer Factory-Variation.
Public method | GetVariations | Gibt alle möglichen Variationen für diese Factory zurück. Die Factory muss mindestens eine Variation zur Verfügung stellen.

See Also

ICustomNodeFactory Interface
DynamicNode.Core Namespace


CreateNode Method

[image]

DynamicNodes API
ICustomNodeFactory..::..CreateNode Method
ICustomNodeFactory Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt einen neuen Knoten mit Hilfe einer Factory-Variation.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
INode CreateNode(
    CustomNodeFactoryVariation variation
)
Visual Basic
Function CreateNode ( _
    variation As CustomNodeFactoryVariation _
) As INode
F#
abstract CreateNode :
        variation:CustomNodeFactoryVariation -> INode

Parameters

variation
Type: DynamicNode.Core..::..CustomNodeFactoryVariation
Eine Factory-Variation.

Return Value

Der erzeugte Knoten.

See Also

ICustomNodeFactory Interface
DynamicNode.Core Namespace


GetVariations Method

[image]

DynamicNodes API
ICustomNodeFactory..::..GetVariations Method
ICustomNodeFactory Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle möglichen Variationen für diese Factory zurück. Die Factory muss mindestens eine Variation zur Verfügung stellen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IEnumerable<CustomNodeFactoryVariation> GetVariations()
Visual Basic
Function GetVariations As IEnumerable(Of CustomNodeFactoryVariation)
F#
abstract GetVariations : unit -> IEnumerable<CustomNodeFactoryVariation>

Return Value

Eine Aufzählung mit allen Variationen der Factory.

See Also

ICustomNodeFactory Interface
DynamicNode.Core Namespace


IFlag Interface

[image]

DynamicNodes API
IFlag Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für ein Graphen-Flag.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IFlag
Visual Basic
Public Interface IFlag
F#
type IFlag =  interface end

See Also

IFlag Members
DynamicNode.Core Namespace


IFlag Members

[image] [image]

DynamicNodes API
IFlag Members
IFlag Interface Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IFlag type exposes the following members.

Properties

 | Name | Description
Public property | FlagName | Gibt den Namen des Graphen-Flags zurück.
Public property | FlagState | Gibt den Zustand des Graphen-Flags zurück.

See Also

IFlag Interface
DynamicNode.Core Namespace


IFlag Properties

[image] [image]

DynamicNodes API
IFlag Properties
IFlag Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IFlag type exposes the following members.

Properties

 | Name | Description
Public property | FlagName | Gibt den Namen des Graphen-Flags zurück.
Public property | FlagState | Gibt den Zustand des Graphen-Flags zurück.

See Also

IFlag Interface
DynamicNode.Core Namespace


FlagName Property

[image]

DynamicNodes API
IFlag..::..FlagName Property
IFlag Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Graphen-Flags zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string FlagName { get; }
Visual Basic
ReadOnly Property FlagName As String
    Get
F#
abstract FlagName : string

Field Value

Der Namen des Graphen-Flags.

See Also

IFlag Interface
DynamicNode.Core Namespace


FlagState Property

[image]

DynamicNodes API
IFlag..::..FlagState Property
IFlag Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Zustand des Graphen-Flags zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
TokenState FlagState { get; }
Visual Basic
ReadOnly Property FlagState As TokenState
    Get
F#
abstract FlagState : TokenState

Field Value

Der Zustand des Graphen-Flags.

See Also

IFlag Interface
DynamicNode.Core Namespace


IGraph Interface

[image]

DynamicNodes API
IGraph Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Jede Sammlung von verknüpften Knoten muss dieses Interface implementieren.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IGraph : IChild<IRuntime, IGraph>,
    IParent<IGraph, INode>, IBaseObject, IIdentifiable,
    IStorable, IExtensible<IGraph>, IDisposable
Visual Basic
Public Interface IGraph _
    Inherits IChild(Of IRuntime, IGraph), IParent(Of IGraph, INode),  _
    IBaseObject, IIdentifiable, IStorable, IExtensible(Of IGraph),  _
    IDisposable
F#
type IGraph =
    interface
        interface IChild<IRuntime, IGraph>
        interface IParent<IGraph, INode>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
        interface IExtensible<IGraph>
        interface IDisposable
    end

Remarks

Dieses Interface ermöglicht das einheitliche Verwalten von unterschiedlichen Graphen.

See Also

IGraph Members
DynamicNode.Core Namespace
DynamicNode.Core..::..Graph


IGraph Members

[image] [image]

DynamicNodes API
IGraph Members
IGraph Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGraph type exposes the following members.

Methods

 | Name | Description
Public method | ActivateNodes | Aktiviert alle Knoten, an deren Eingängen neue Tokens anliegen. Muss nur aufgerufen werden, nach dem ein Graph wiederhergestellt wurde um die mit OnRestore(IPropertyReader) erzeugten Tokens an den Eingängen zu verarbeiten.
Public method | AddNodeWithId | Fügt einen Knoten mit einer vorgegebenen ID hinzu. Diese Methode wird beim Rekonstruieren eines Graphen benötigt.
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche der Graph identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyGraphFlagChanged | Benachricht den Graphen über ein Flag dessen Zustand sich geändert hat.
Public method | OnConnectionAffected | Löst das Ereignis ConnectionAffected aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)

Properties

 | Name | Description
Public property | BlockActivations | Liest und schreibt ein Flag, welches angibt ob Aktivierungen von Knoten verhindert werden sollen.
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | GraphStateFlags | Gibt ein Wörterbuch mit den Flags des Graphen zurück. Graphen-Flags werden durch Knoten der Klasse NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens. Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.
Public property | GraphStorage | Gibt den IGraphStorage zurück, mit dem der Graph verknüpft ist, oder legt ihn fest.
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public property | Item | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public property | Runtime | Gibt das IRuntime-Objekt zurück, in dem der Graph arbeitet.
Public property | SuperInPorts | Gibt alle Eingänge mit dem Super-Flag zurück.
Public property | SuperOutPorts | Gibt alle Ausgänge mit dem Super-Flag zurück.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | ConnectionAffected | Dieses Ereignis wird ausgelöst, wenn der Graph sich verändert hat und dabei eine Verbindung betroffen ist.
Public event | Death | Der letzte Knoten hat seine Aktivität beendet.
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public event | FlagChanged | Ein Graphen-Flag hat seinen Zustand geändert.
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wird. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public event | StartLife | Der erste Knoten wurde aktiv.

See Also

IGraph Interface
DynamicNode.Core Namespace


IGraph Methods

[image] [image]

DynamicNodes API
IGraph Methods
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGraph type exposes the following members.

Methods

 | Name | Description
Public method | ActivateNodes | Aktiviert alle Knoten, an deren Eingängen neue Tokens anliegen. Muss nur aufgerufen werden, nach dem ein Graph wiederhergestellt wurde um die mit OnRestore(IPropertyReader) erzeugten Tokens an den Eingängen zu verarbeiten.
Public method | AddNodeWithId | Fügt einen Knoten mit einer vorgegebenen ID hinzu. Diese Methode wird beim Rekonstruieren eines Graphen benötigt.
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche der Graph identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyGraphFlagChanged | Benachricht den Graphen über ein Flag dessen Zustand sich geändert hat.
Public method | OnConnectionAffected | Löst das Ereignis ConnectionAffected aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)

See Also

IGraph Interface
DynamicNode.Core Namespace


ActivateNodes Method

[image]

DynamicNodes API
IGraph..::..ActivateNodes Method
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert alle Knoten, an deren Eingängen neue Tokens anliegen. Muss nur aufgerufen werden, nach dem ein Graph wiederhergestellt wurde um die mit OnRestore(IPropertyReader) erzeugten Tokens an den Eingängen zu verarbeiten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void ActivateNodes()
Visual Basic
Sub ActivateNodes
F#
abstract ActivateNodes : unit -> unit

See Also

IGraph Interface
DynamicNode.Core Namespace


AddNodeWithId Method

[image]

DynamicNodes API
IGraph..::..AddNodeWithId Method
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt einen Knoten mit einer vorgegebenen ID hinzu. Diese Methode wird beim Rekonstruieren eines Graphen benötigt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void AddNodeWithId(
    INode node,
    int id
)
Visual Basic
Sub AddNodeWithId ( _
    node As INode, _
    id As Integer _
)
F#
abstract AddNodeWithId :
        node:INode *
        id:int -> unit

Parameters

node
Type: DynamicNode.Core..::..INode
Der Knoten.
id
Type: System..::..Int32
Die ID des Knotens.

See Also

IGraph Interface
DynamicNode.Core Namespace


GetAddress Method

[image]

DynamicNodes API
IGraph..::..GetAddress Method
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Zeichenfolge zurück, welche der Graph identifiziert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string GetAddress()
Visual Basic
Function GetAddress As String
F#
abstract GetAddress : unit -> string

Return Value

Eine Graph-Adresse.

See Also

IGraph Interface
DynamicNode.Core Namespace


NotifyGraphFlagChanged Method

[image]

DynamicNodes API
IGraph..::..NotifyGraphFlagChanged Method
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Benachricht den Graphen über ein Flag dessen Zustand sich geändert hat.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void NotifyGraphFlagChanged(
    IFlag flag
)
Visual Basic
Sub NotifyGraphFlagChanged ( _
    flag As IFlag _
)
F#
abstract NotifyGraphFlagChanged :
        flag:IFlag -> unit

Parameters

flag
Type: DynamicNode.Core..::..IFlag
Das Flag, das seinen Zustand geändert hat.

See Also

IGraph Interface
DynamicNode.Core Namespace


OnConnectionAffected Method

[image]

DynamicNodes API
IGraph..::..OnConnectionAffected Method
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis ConnectionAffected aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void OnConnectionAffected(
    InPort iP,
    OutPort oP,
    ConnectionEventTyp typ
)
Visual Basic
Sub OnConnectionAffected ( _
    iP As InPort, _
    oP As OutPort, _
    typ As ConnectionEventTyp _
)
F#
abstract OnConnectionAffected :
        iP:InPort *
        oP:OutPort *
        typ:ConnectionEventTyp -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Der betroffene Eingang.
oP
Type: DynamicNode.Core..::..OutPort
Der betroffene Ausgang.
typ
Type: DynamicNode.Core..::..ConnectionEventTyp
Der Typ der Änderung.

See Also

IGraph Interface
DynamicNode.Core Namespace


IGraph Properties

[image] [image]

DynamicNodes API
IGraph Properties
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGraph type exposes the following members.

Properties

 | Name | Description
Public property | BlockActivations | Liest und schreibt ein Flag, welches angibt ob Aktivierungen von Knoten verhindert werden sollen.
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | GraphStateFlags | Gibt ein Wörterbuch mit den Flags des Graphen zurück. Graphen-Flags werden durch Knoten der Klasse NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens. Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.
Public property | GraphStorage | Gibt den IGraphStorage zurück, mit dem der Graph verknüpft ist, oder legt ihn fest.
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public property | Item | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public property | Runtime | Gibt das IRuntime-Objekt zurück, in dem der Graph arbeitet.
Public property | SuperInPorts | Gibt alle Eingänge mit dem Super-Flag zurück.
Public property | SuperOutPorts | Gibt alle Ausgänge mit dem Super-Flag zurück.

See Also

IGraph Interface
DynamicNode.Core Namespace


BlockActivations Property

[image]

DynamicNodes API
IGraph..::..BlockActivations Property
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest und schreibt ein Flag, welches angibt ob Aktivierungen von Knoten verhindert werden sollen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool BlockActivations { get; set; }
Visual Basic
Property BlockActivations As Boolean
    Get
    Set
F#
abstract BlockActivations : bool with get, set

Field Value

true, wenn keine Aktivierungen erlaubt sind, für die Ausführung des Graphen false.

See Also

IGraph Interface
DynamicNode.Core Namespace


GraphStateFlags Property

[image]

DynamicNodes API
IGraph..::..GraphStateFlags Property
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Gibt ein Wörterbuch mit den Flags des Graphen zurück.

Graphen-Flags werden durch Knoten der Klasse NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens.

Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IDictionary<string, TokenState> GraphStateFlags { get; }
Visual Basic
ReadOnly Property GraphStateFlags As IDictionary(Of String, TokenState)
    Get
F#
abstract GraphStateFlags : IDictionary<string, TokenState>

Field Value

Die Flags des Graphen.

See Also

IGraph Interface
DynamicNode.Core Namespace


GraphStorage Property

[image]

DynamicNodes API
IGraph..::..GraphStorage Property
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den IGraphStorage zurück, mit dem der Graph verknüpft ist, oder legt ihn fest.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IGraphStorage GraphStorage { get; set; }
Visual Basic
Property GraphStorage As IGraphStorage
    Get
    Set
F#
abstract GraphStorage : IGraphStorage with get, set

Field Value

The graph storage.

See Also

IGraph Interface
DynamicNode.Core Namespace


Runtime Property

[image]

DynamicNodes API
IGraph..::..Runtime Property
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das IRuntime-Objekt zurück, in dem der Graph arbeitet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IRuntime Runtime { get; }
Visual Basic
ReadOnly Property Runtime As IRuntime
    Get
F#
abstract Runtime : IRuntime

Field Value

Das IRuntime-Objekt, in dem der Graph arbeitet.

See Also

IGraph Interface
DynamicNode.Core Namespace


SuperInPorts Property

[image]

DynamicNodes API
IGraph..::..SuperInPorts Property
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle Eingänge mit dem Super-Flag zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IEnumerable<InPort> SuperInPorts { get; }
Visual Basic
ReadOnly Property SuperInPorts As IEnumerable(Of InPort)
    Get
F#
abstract SuperInPorts : IEnumerable<InPort>

Field Value

Alle Super-Eingänge.

See Also

IGraph Interface
DynamicNode.Core Namespace


SuperOutPorts Property

[image]

DynamicNodes API
IGraph..::..SuperOutPorts Property
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle Ausgänge mit dem Super-Flag zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IEnumerable<OutPort> SuperOutPorts { get; }
Visual Basic
ReadOnly Property SuperOutPorts As IEnumerable(Of OutPort)
    Get
F#
abstract SuperOutPorts : IEnumerable<OutPort>

Field Value

Die Super-Ausgänge.

See Also

IGraph Interface
DynamicNode.Core Namespace


IGraph Events

[image] [image]

DynamicNodes API
IGraph Events
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGraph type exposes the following members.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | ConnectionAffected | Dieses Ereignis wird ausgelöst, wenn der Graph sich verändert hat und dabei eine Verbindung betroffen ist.
Public event | Death | Der letzte Knoten hat seine Aktivität beendet.
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public event | FlagChanged | Ein Graphen-Flag hat seinen Zustand geändert.
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wird. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public event | StartLife | Der erste Knoten wurde aktiv.

See Also

IGraph Interface
DynamicNode.Core Namespace


ConnectionAffected Event

[image]

DynamicNodes API
IGraph..::..ConnectionAffected Event
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Dieses Ereignis wird ausgelöst, wenn der Graph sich verändert hat und dabei eine Verbindung betroffen ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler<ConnectionEventArgs> ConnectionAffected
Visual Basic
Event ConnectionAffected As EventHandler(Of ConnectionEventArgs)
F#
abstract ConnectionAffected : IEvent<EventHandler<ConnectionEventArgs>,
    ConnectionEventArgs>

See Also

IGraph Interface
DynamicNode.Core Namespace


Death Event

[image]

DynamicNodes API
IGraph..::..Death Event
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der letzte Knoten hat seine Aktivität beendet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler Death
Visual Basic
Event Death As EventHandler
F#
abstract Death : IEvent<EventHandler,
    EventArgs>

See Also

IGraph Interface
DynamicNode.Core Namespace


FlagChanged Event

[image]

DynamicNodes API
IGraph..::..FlagChanged Event
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Graphen-Flag hat seinen Zustand geändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler<GraphFlagChangedEventArgs> FlagChanged
Visual Basic
Event FlagChanged As EventHandler(Of GraphFlagChangedEventArgs)
F#
abstract FlagChanged : IEvent<EventHandler<GraphFlagChangedEventArgs>,
    GraphFlagChangedEventArgs>

See Also

IGraph Interface
DynamicNode.Core Namespace


StartLife Event

[image]

DynamicNodes API
IGraph..::..StartLife Event
IGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der erste Knoten wurde aktiv.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler StartLife
Visual Basic
Event StartLife As EventHandler
F#
abstract StartLife : IEvent<EventHandler,
    EventArgs>

See Also

IGraph Interface
DynamicNode.Core Namespace


IGraphStorage Interface

[image]

DynamicNodes API
IGraphStorage Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bietet die Möglichkeit, ein IGraph-Objekt zu speichern, oder zu rekonstruieren.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IGraphStorage
Visual Basic
Public Interface IGraphStorage
F#
type IGraphStorage =  interface end

See Also

IGraphStorage Members
DynamicNode.Core Namespace


IGraphStorage Members

[image] [image]

DynamicNodes API
IGraphStorage Members
IGraphStorage Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGraphStorage type exposes the following members.

Methods

 | Name | Description
Public method | Restore | Erzeugt ein Knoten-Graph aus einer Datei.
Public method | RestoreGraphExtension | Stellt eine Graphen-Erweiterung wieder her.
Public method | RestoreNodeExtensions(IGraph, array<String>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
Public method | RestoreNodeExtensions(IGraph, array<Type>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
Public method | RestorePortExtensions(IGraph, array<String>[]()[][]) | Stellt Port-Erweiterungen wieder her.
Public method | RestorePortExtensions(IGraph, array<Type>[]()[][]) | Stellt Port-Erweiterungen wieder her.
Public method | Store | Speichert das übergebene IGraph.

See Also

IGraphStorage Interface
DynamicNode.Core Namespace


IGraphStorage Methods

[image] [image]

DynamicNodes API
IGraphStorage Methods
IGraphStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGraphStorage type exposes the following members.

Methods

 | Name | Description
Public method | Restore | Erzeugt ein Knoten-Graph aus einer Datei.
Public method | RestoreGraphExtension | Stellt eine Graphen-Erweiterung wieder her.
Public method | RestoreNodeExtensions(IGraph, array<String>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
Public method | RestoreNodeExtensions(IGraph, array<Type>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
Public method | RestorePortExtensions(IGraph, array<String>[]()[][]) | Stellt Port-Erweiterungen wieder her.
Public method | RestorePortExtensions(IGraph, array<Type>[]()[][]) | Stellt Port-Erweiterungen wieder her.
Public method | Store | Speichert das übergebene IGraph.

See Also

IGraphStorage Interface
DynamicNode.Core Namespace


Restore Method

[image]

DynamicNodes API
IGraphStorage..::..Restore Method
IGraphStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Knoten-Graph aus einer Datei.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IGraph Restore(
    params IExtension<IGraph>[] extensions
)
Visual Basic
Function Restore ( _
    ParamArray extensions As IExtension(Of IGraph)() _
) As IGraph
F#
abstract Restore :
        extensions:IExtension<IGraph>[] -> IGraph

Parameters

extensions
Type: array< DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>>[]()[][]
Alle Erweiterungen, die sofort an der Graph angefügt werden sollen.

Return Value

Der Graph.

See Also

IGraphStorage Interface
DynamicNode.Core Namespace


RestoreGraphExtension Method

[image]

DynamicNodes API
IGraphStorage..::..RestoreGraphExtension Method
IGraphStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt eine Graphen-Erweiterung wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void RestoreGraphExtension(
    IGraph graph,
    IExtension<IGraph> extension
)
Visual Basic
Sub RestoreGraphExtension ( _
    graph As IGraph, _
    extension As IExtension(Of IGraph) _
)
F#
abstract RestoreGraphExtension :
        graph:IGraph *
        extension:IExtension<IGraph> -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph an dem die Erweiterung arbeitet.
extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>
Die Erweiterung, deren Eigenschaften wieder hergestellt werden sollen.

See Also

IGraphStorage Interface
DynamicNode.Core Namespace


RestoreNodeExtensions Method

[image] [image]

DynamicNodes API
IGraphStorage..::..RestoreNodeExtensions Method
IGraphStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RestoreNodeExtensions(IGraph, array<String>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
Public method | RestoreNodeExtensions(IGraph, array<Type>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.

See Also

IGraphStorage Interface
IGraphStorage Members
DynamicNode.Core Namespace


RestoreNodeExtensions Method (IGraph, String[])

[image]

DynamicNodes API
IGraphStorage..::..RestoreNodeExtensions Method (IGraph, array<String>[]()[][])
IGraphStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Knoten-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void RestoreNodeExtensions(
    IGraph graph,
    params string[] nodeExtensionIds
)
Visual Basic
Sub RestoreNodeExtensions ( _
    graph As IGraph, _
    ParamArray nodeExtensionIds As String() _
)
F#
abstract RestoreNodeExtensions :
        graph:IGraph *
        nodeExtensionIds:string[] -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Knoten rekonstruiert werden sollen.
nodeExtensionIds
Type: array< System..::..String >[]()[][]
Die IDs der Erweiterungen, welche wieder hergestellt werden sollen.

See Also

IGraphStorage Interface
RestoreNodeExtensions Overload
DynamicNode.Core Namespace


RestoreNodeExtensions Method (IGraph, Type[])

[image]

DynamicNodes API
IGraphStorage..::..RestoreNodeExtensions Method (IGraph, array<Type>[]()[][])
IGraphStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Knoten-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void RestoreNodeExtensions(
    IGraph graph,
    params Type[] nodeExtensionTypes
)
Visual Basic
Sub RestoreNodeExtensions ( _
    graph As IGraph, _
    ParamArray nodeExtensionTypes As Type() _
)
F#
abstract RestoreNodeExtensions :
        graph:IGraph *
        nodeExtensionTypes:Type[] -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Knoten rekonstruiert werden sollen.
nodeExtensionTypes
Type: array< System..::..Type >[]()[][]
Die Typen der Erweiterungen, welche wieder hergestellt werden sollen.

See Also

IGraphStorage Interface
RestoreNodeExtensions Overload
DynamicNode.Core Namespace


RestorePortExtensions Method

[image] [image]

DynamicNodes API
IGraphStorage..::..RestorePortExtensions Method
IGraphStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RestorePortExtensions(IGraph, array<String>[]()[][]) | Stellt Port-Erweiterungen wieder her.
Public method | RestorePortExtensions(IGraph, array<Type>[]()[][]) | Stellt Port-Erweiterungen wieder her.

See Also

IGraphStorage Interface
IGraphStorage Members
DynamicNode.Core Namespace


RestorePortExtensions Method (IGraph, String[])

[image]

DynamicNodes API
IGraphStorage..::..RestorePortExtensions Method (IGraph, array<String>[]()[][])
IGraphStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Port-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void RestorePortExtensions(
    IGraph graph,
    params string[] portExtensionIds
)
Visual Basic
Sub RestorePortExtensions ( _
    graph As IGraph, _
    ParamArray portExtensionIds As String() _
)
F#
abstract RestorePortExtensions :
        graph:IGraph *
        portExtensionIds:string[] -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Ports rekonstruiert werden sollen.
portExtensionIds
Type: array< System..::..String >[]()[][]
Die IDs der Erweiterungen, welche wieder hergestellt werden sollen.

See Also

IGraphStorage Interface
RestorePortExtensions Overload
DynamicNode.Core Namespace


RestorePortExtensions Method (IGraph, Type[])

[image]

DynamicNodes API
IGraphStorage..::..RestorePortExtensions Method (IGraph, array<Type>[]()[][])
IGraphStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Port-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void RestorePortExtensions(
    IGraph graph,
    params Type[] portExtensionTypes
)
Visual Basic
Sub RestorePortExtensions ( _
    graph As IGraph, _
    ParamArray portExtensionTypes As Type() _
)
F#
abstract RestorePortExtensions :
        graph:IGraph *
        portExtensionTypes:Type[] -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Ports rekonstruiert werden sollen.
portExtensionTypes
Type: array< System..::..Type >[]()[][]
Die Typen der Erweiterungen, welche wieder hergestellt werden sollen.

See Also

IGraphStorage Interface
RestorePortExtensions Overload
DynamicNode.Core Namespace


Store Method

[image]

DynamicNodes API
IGraphStorage..::..Store Method
IGraphStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Speichert das übergebene IGraph.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void Store(
    IGraph graph
)
Visual Basic
Sub Store ( _
    graph As IGraph _
)
F#
abstract Store :
        graph:IGraph -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph.

See Also

IGraphStorage Interface
DynamicNode.Core Namespace


IInPortDataTypeProvider Interface

[image]

DynamicNodes API
IInPortDataTypeProvider Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für Objekte die Datentypen für Eingänge bereitstellen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IInPortDataTypeProvider
Visual Basic
Public Interface IInPortDataTypeProvider
F#
type IInPortDataTypeProvider =  interface end

See Also

IInPortDataTypeProvider Members
DynamicNode.Core Namespace


IInPortDataTypeProvider Members

[image] [image]

DynamicNodes API
IInPortDataTypeProvider Members
IInPortDataTypeProvider Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IInPortDataTypeProvider type exposes the following members.

Methods

 | Name | Description
Public method | RegisterInPort | Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen.
Public method | UnregisterInPort | Entfernt einen Eingang aus der Verwaltung.

Properties

 | Name | Description
Public property | SupportedDataTypes | Gibt die bereitgestellten Datentypen zurück.

Events

 | Name | Description
Public event | SupportedDataTypesChanged | Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert.

See Also

IInPortDataTypeProvider Interface
DynamicNode.Core Namespace


IInPortDataTypeProvider Methods

[image] [image]

DynamicNodes API
IInPortDataTypeProvider Methods
IInPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IInPortDataTypeProvider type exposes the following members.

Methods

 | Name | Description
Public method | RegisterInPort | Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen.
Public method | UnregisterInPort | Entfernt einen Eingang aus der Verwaltung.

See Also

IInPortDataTypeProvider Interface
DynamicNode.Core Namespace


RegisterInPort Method

[image]

DynamicNodes API
IInPortDataTypeProvider..::..RegisterInPort Method
IInPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void RegisterInPort(
    InPort iP
)
Visual Basic
Sub RegisterInPort ( _
    iP As InPort _
)
F#
abstract RegisterInPort :
        iP:InPort -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Der Eingang.

See Also

IInPortDataTypeProvider Interface
DynamicNode.Core Namespace


UnregisterInPort Method

[image]

DynamicNodes API
IInPortDataTypeProvider..::..UnregisterInPort Method
IInPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt einen Eingang aus der Verwaltung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void UnregisterInPort(
    InPort iP
)
Visual Basic
Sub UnregisterInPort ( _
    iP As InPort _
)
F#
abstract UnregisterInPort :
        iP:InPort -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Ein Eingang.

See Also

IInPortDataTypeProvider Interface
DynamicNode.Core Namespace


IInPortDataTypeProvider Properties

[image] [image]

DynamicNodes API
IInPortDataTypeProvider Properties
IInPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IInPortDataTypeProvider type exposes the following members.

Properties

 | Name | Description
Public property | SupportedDataTypes | Gibt die bereitgestellten Datentypen zurück.

See Also

IInPortDataTypeProvider Interface
DynamicNode.Core Namespace


SupportedDataTypes Property

[image]

DynamicNodes API
IInPortDataTypeProvider..::..SupportedDataTypes Property
IInPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die bereitgestellten Datentypen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
Type[] SupportedDataTypes { get; }
Visual Basic
ReadOnly Property SupportedDataTypes As Type()
    Get
F#
abstract SupportedDataTypes : Type[]

Field Value

Die aktuellen Datentyp-Liste als Array.

See Also

IInPortDataTypeProvider Interface
DynamicNode.Core Namespace


IInPortDataTypeProvider Events

[image] [image]

DynamicNodes API
IInPortDataTypeProvider Events
IInPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IInPortDataTypeProvider type exposes the following members.

Events

 | Name | Description
Public event | SupportedDataTypesChanged | Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert.

See Also

IInPortDataTypeProvider Interface
DynamicNode.Core Namespace


SupportedDataTypesChanged Event

[image]

DynamicNodes API
IInPortDataTypeProvider..::..SupportedDataTypesChanged Event
IInPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler SupportedDataTypesChanged
Visual Basic
Event SupportedDataTypesChanged As EventHandler
F#
abstract SupportedDataTypesChanged : IEvent<EventHandler,
    EventArgs>

See Also

IInPortDataTypeProvider Interface
DynamicNode.Core Namespace


INode Interface

[image]

DynamicNodes API
INode Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für alle Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface INode : IChild<IGraph, INode>,
    IParent<INode, IPort>, IBaseObject, IIdentifiable,
    IStorable, IExtensible<INode>, IDisposable, IComparable<INode>
Visual Basic
Public Interface INode _
    Inherits IChild(Of IGraph, INode), IParent(Of INode, IPort),  _
    IBaseObject, IIdentifiable, IStorable, IExtensible(Of INode),  _
    IDisposable, IComparable(Of INode)
F#
type INode =
    interface
        interface IChild<IGraph, INode>
        interface IParent<INode, IPort>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
        interface IExtensible<INode>
        interface IDisposable
        interface IComparable<INode>
    end

Remarks

Diese Schnittstelle sollte außerhalb der Laufzeitumgebung anstelle der Klasse Node verwendet werden, um eine besser Entkopplung zu erreichen.

See Also

INode Members
DynamicNode.Core Namespace


INode Members

[image] [image]

DynamicNodes API
INode Members
INode Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen.
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten.
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben.
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört.
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist.
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public property | IsParallelizable | Liest einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht.
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit.
Public property | Item | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück.
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird.
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist.
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück.
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet.
Public event | BeforeActivation | Wird ausgelöst, wenn die Aktivierung beginnt.
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird.
Public event | ChildAdded | Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wird. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)

See Also

INode Interface
DynamicNode.Core Namespace


INode Methods

[image] [image]

DynamicNodes API
INode Methods
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen.
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten.
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)

See Also

INode Interface
DynamicNode.Core Namespace


Activate Method

[image]

DynamicNodes API
INode..::..Activate Method
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert den Knoten von außen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void Activate()
Visual Basic
Sub Activate
F#
abstract Activate : unit -> unit

See Also

INode Interface
DynamicNode.Core Namespace


Duplicate Method

[image] [image]

DynamicNodes API
INode..::..Duplicate Method
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.

See Also

INode Interface
INode Members
DynamicNode.Core Namespace


Duplicate Method

[image]

DynamicNodes API
INode..::..Duplicate Method
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
INode Duplicate()
Visual Basic
Function Duplicate As INode
F#
abstract Duplicate : unit -> INode

Return Value

Ein Duplikat des aktuellen Knotens.

See Also

INode Interface
Duplicate Overload
DynamicNode.Core Namespace


Duplicate Method (IGraph)

[image]

DynamicNodes API
INode..::..Duplicate Method (IGraph)
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
INode Duplicate(
    IGraph parent
)
Visual Basic
Function Duplicate ( _
    parent As IGraph _
) As INode
F#
abstract Duplicate :
        parent:IGraph -> INode

Parameters

parent
Type: DynamicNode.Core..::..IGraph
Der Graph, in dem das Duplikat erstellt werden soll.

Return Value

Ein Duplikat des aktuellen Knotens.

See Also

INode Interface
Duplicate Overload
DynamicNode.Core Namespace


GetAddress Method

[image]

DynamicNodes API
INode..::..GetAddress Method
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string GetAddress()
Visual Basic
Function GetAddress As String
F#
abstract GetAddress : unit -> string

Return Value

Eine Knoten-Adresse.

See Also

INode Interface
DynamicNode.Core Namespace


Isolate Method

[image]

DynamicNodes API
INode..::..Isolate Method
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Trennt alle Verbindungen zu anderen Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void Isolate()
Visual Basic
Sub Isolate
F#
abstract Isolate : unit -> unit

See Also

INode Interface
DynamicNode.Core Namespace


OnCommand Method

[image]

DynamicNodes API
INode..::..OnCommand Method
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void OnCommand(
    string command
)
Visual Basic
Sub OnCommand ( _
    command As String _
)
F#
abstract OnCommand :
        command:string -> unit

Parameters

command
Type: System..::..String
Der Befehls-Code des Benutzerbefehls.

See Also

INode Interface
DynamicNode.Core Namespace


OnDefaultCommand Method

[image]

DynamicNodes API
INode..::..OnDefaultCommand Method
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void OnDefaultCommand()
Visual Basic
Sub OnDefaultCommand
F#
abstract OnDefaultCommand : unit -> unit

See Also

INode Interface
DynamicNode.Core Namespace


OnInitPortDefaults Method

[image]

DynamicNodes API
INode..::..OnInitPortDefaults Method
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void OnInitPortDefaults()
Visual Basic
Sub OnInitPortDefaults
F#
abstract OnInitPortDefaults : unit -> unit

See Also

INode Interface
DynamicNode.Core Namespace


INode Properties

[image] [image]

DynamicNodes API
INode Properties
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INode type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben.
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört.
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist.
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public property | IsParallelizable | Liest einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht.
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit.
Public property | Item | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück.
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird.
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist.
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück.
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück.

See Also

INode Interface
DynamicNode.Core Namespace


ActiveThread Property

[image]

DynamicNodes API
INode..::..ActiveThread Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
Thread ActiveThread { get; }
Visual Basic
ReadOnly Property ActiveThread As Thread
    Get
F#
abstract ActiveThread : Thread

Field Value

Der Thread, in dem der Knoten aktiv ist.

See Also

INode Interface
DynamicNode.Core Namespace


Commands Property

[image]

DynamicNodes API
INode..::..Commands Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IDictionary<string, string> Commands { get; }
Visual Basic
ReadOnly Property Commands As IDictionary(Of String, String)
    Get
F#
abstract Commands : IDictionary<string, string>

Field Value

Die Benutzerbefehle.

See Also

INode Interface
DynamicNode.Core Namespace


Graph Property

[image]

DynamicNodes API
INode..::..Graph Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Graphen zurück zu dem dieser Knoten gehört.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IGraph Graph { get; }
Visual Basic
ReadOnly Property Graph As IGraph
    Get
F#
abstract Graph : IGraph

Field Value

Der Graph.

See Also

INode Interface
DynamicNode.Core Namespace


IsActivationRequired Property

[image]

DynamicNodes API
INode..::..IsActivationRequired Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsActivationRequired { get; }
Visual Basic
ReadOnly Property IsActivationRequired As Boolean
    Get
F#
abstract IsActivationRequired : bool

Field Value

true wenn diese Instanz aktiviert werden sollte, sonst false.

See Also

INode Interface
DynamicNode.Core Namespace


IsActive Property

[image]

DynamicNodes API
INode..::..IsActive Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsActive { get; }
Visual Basic
ReadOnly Property IsActive As Boolean
    Get
F#
abstract IsActive : bool

Field Value

true, wenn dieser Knoten aktiv ist, sonst false.

See Also

INode Interface
DynamicNode.Core Namespace


IsParallelizable Property

[image]

DynamicNodes API
INode..::..IsParallelizable Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsParallelizable { get; }
Visual Basic
ReadOnly Property IsParallelizable As Boolean
    Get
F#
abstract IsParallelizable : bool

Field Value

true wenn dieser Knoten parallelisierbar ist, sonst false.

See Also

INode Interface
DynamicNode.Core Namespace


IsWorkAborted Property

[image]

DynamicNodes API
INode..::..IsWorkAborted Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsWorkAborted { get; set; }
Visual Basic
Property IsWorkAborted As Boolean
    Get
    Set
F#
abstract IsWorkAborted : bool with get, set

Field Value

true, wenn diese Instanz is work aborted, sonst false.

See Also

INode Interface
DynamicNode.Core Namespace


NodeInfo Property

[image]

DynamicNodes API
INode..::..NodeInfo Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
NodeInfoAttribute NodeInfo { get; }
Visual Basic
ReadOnly Property NodeInfo As NodeInfoAttribute
    Get
F#
abstract NodeInfo : NodeInfoAttribute

Field Value

Eine NodeInfoAttribute-Instanz oder null, falls die Klasse das Attribut nicht besitzt.

See Also

INode Interface
DynamicNode.Core Namespace


Parallelizing Property

[image]

DynamicNodes API
INode..::..Parallelizing Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
Parallelizing Parallelizing { get; set; }
Visual Basic
Property Parallelizing As Parallelizing
    Get
    Set
F#
abstract Parallelizing : Parallelizing with get, set

Field Value

Die Form der Parallelisierung.

See Also

INode Interface
DynamicNode.Core Namespace


SingleThreadContextId Property

[image]

DynamicNodes API
INode..::..SingleThreadContextId Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string SingleThreadContextId { get; set; }
Visual Basic
Property SingleThreadContextId As String
    Get
    Set
F#
abstract SingleThreadContextId : string with get, set

Field Value

Die ID für den Synchronisierungskontext

See Also

INode Interface
DynamicNode.Core Namespace


TypeCaption Property

[image]

DynamicNodes API
INode..::..TypeCaption Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung des Knoten-Typs zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string TypeCaption { get; }
Visual Basic
ReadOnly Property TypeCaption As String
    Get
F#
abstract TypeCaption : string

Field Value

Die Beschriftung des Knoten-Typs.

See Also

INode Interface
DynamicNode.Core Namespace


TypeDescription Property

[image]

DynamicNodes API
INode..::..TypeDescription Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Knoten-Typs zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string TypeDescription { get; }
Visual Basic
ReadOnly Property TypeDescription As String
    Get
F#
abstract TypeDescription : string

Field Value

Die Beschreibung des Knoten-Typs.

See Also

INode Interface
DynamicNode.Core Namespace


TypeGroup Property

[image]

DynamicNodes API
INode..::..TypeGroup Property
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Gruppe des Knoten-Typs zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string TypeGroup { get; }
Visual Basic
ReadOnly Property TypeGroup As String
    Get
F#
abstract TypeGroup : string

Field Value

Die Gruppe des Knoten-Typs.

See Also

INode Interface
DynamicNode.Core Namespace


INode Events

[image] [image]

DynamicNodes API
INode Events
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INode type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet.
Public event | BeforeActivation | Wird ausgelöst, wenn die Aktivierung beginnt.
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird.
Public event | ChildAdded | Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wird. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)

See Also

INode Interface
DynamicNode.Core Namespace


AfterActivation Event

[image]

DynamicNodes API
INode..::..AfterActivation Event
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die Aktivierung endet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler AfterActivation
Visual Basic
Event AfterActivation As EventHandler
F#
abstract AfterActivation : IEvent<EventHandler,
    EventArgs>

See Also

INode Interface
DynamicNode.Core Namespace


BeforeActivation Event

[image]

DynamicNodes API
INode..::..BeforeActivation Event
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die Aktivierung beginnt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler BeforeActivation
Visual Basic
Event BeforeActivation As EventHandler
F#
abstract BeforeActivation : IEvent<EventHandler,
    EventArgs>

See Also

INode Interface
DynamicNode.Core Namespace


BeforeReactivation Event

[image]

DynamicNodes API
INode..::..BeforeReactivation Event
INode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Knoten erneut aktiviert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler BeforeReactivation
Visual Basic
Event BeforeReactivation As EventHandler
F#
abstract BeforeReactivation : IEvent<EventHandler,
    EventArgs>

See Also

INode Interface
DynamicNode.Core Namespace


InPort Class

[image]

DynamicNodes API
InPort Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Eingang für einen Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class InPort : Port, IOutPortDataTypeProvider
Visual Basic
Public Class InPort _
    Inherits Port _
    Implements IOutPortDataTypeProvider
F#
type InPort =
    class
        inherit Port
        interface IOutPortDataTypeProvider
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' IPort >)>)>
DynamicNode.Model..::..ChildObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Core..::..Port
DynamicNode.Core..::..InPort
DynamicNode.Core.Nodes..::..NSubGraph..::..WrappingInPort
DynamicNode.Core..::..TriggerInPort

See Also

InPort Members
DynamicNode.Core Namespace


InPort Members

[image] [image]

DynamicNodes API
InPort Members
InPort Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPort type exposes the following members.

Constructors

 | Name | Description
Public method | InPort(INode, String) | Initialisiert eine generische InPort-Instanz. Dadurch dass keine Datentypen für diesen Eingang angegeben sind ist er untypisiert und nimmt alle Datentypen entgegen.
Public method | InPort(INode, String, IInPortDataTypeProvider) | Initialisiert eine Provider-abhängige InPort-Instanz.
Public method | InPort(INode, String, array<Type>[]()[][]) | Initialisiert eine typisierte InPort-Instanz.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Verbindet einen Ausgangs-Port mit diesem Eingangs-Port.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Ausgang, falls eine solche Verbindung besteht.
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben.
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben.
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Overrides Port..::..IsConnectableTo(IPort, Type%).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem die unterstützten Datentypen geändert wurden. Falls eine Verbindung besteht wird erneut geprüft welcher Datentyp optimal ist. Falls ein anderer Datentyp als der zur Zeit ausgewählte optimal ist, wird der optimale Datentyp ausgewählt. Falls die Verbindung ungültig ist, wird sie getrennt.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnCurrentTokenChanged | Wird aufgerufen, wenn das Ereignis CurrentTokenChanged ausgelöst werden soll.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Overrides Port..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Overrides Port..::..OnStore(IPropertyWriter).)
Protected method | OnSupportedDataTypeChanged | Wird aufgerufen wenn der für die aktuelle Verbindung ausgewählte Datentyp geändert wurde. Löst das Ereignis SupportedDataTypeChanged aus.
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | PrepareNextToken | Bereitet den Eingang auf die nächste Arbeitsphase des Knotens vor. Falls ein Queue vorhanden ist, wird dazu das nächste Token aus dem Queue geholt.
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Overrides Object..::..ToString()()()().)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Overrides Port..::..TryConnect(IPort).)
Public method | UpdateToken | Aktualisiert den Wert des Ports und setzt den Wert-Zustand auf Valid. Dabei wird das Ereignis TokenUpdate ausgelöst.

Properties

 | Name | Description
Public property | CanHaveQueue | Liest oder schreibt einen Wert, der angibt ob dieser Eingang eine Queue haben darf.
Public property | Capacity | Liest oder schreibt die Kapazität der evtl. vorhandenen Queue.
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Eingangs-Ports zu anderen Ausgangs-Ports angepasst werden kann.
Public property | ConnectedOutPort | Gibt den verbundenen Ausgangs-Port zurück der mit diesem Eingangs-Port verbunden ist, oder null, wenn keine Verbindung besteht.
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Overrides Port..::..ConnectionCount.)
Public property | CurrentToken | Gibt das Token zurück, welches für den aktuellen Arbeitsschritt verwendet werden soll.
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Eingang.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | HasQueue | Liest oder schreibt einen Wert der angibt ob diese Instanz eine Queue besitzt.
Public property | HasWaitingToken | Gibt einen Wert zurück, der angibt ob der nächste Aufruf von PrepareNextToken()()()() ein neues Token zur Verarbeitung bereitstellt oder nicht.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsConnected | Prüft, ob diese Instanz mit einem Ausgangs-Port verbunden ist.
Public property | IsCurrentTokenNew | Gibt einen Wert zurück der angibt, ob das aktuelle Token neu ist.
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsMandatory | Gibt einen Wert zurück oder legt ihn fest, der angibt ob der Eingang mit einem Token belegt werden muss, damit der Knoten arbeiten kann.
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedDataType | Gibt den für die aktuelle Verbindung ausgewählten Datentyp zurück, oder legt ihn fest.
Public property | SupportedTypes | Gibt eine Liste mit allen unterstützten Datentypen zurück. Falls ein Daten-Typ-Provider eingerichtet ist, wird dessen Liste zurückgegeben.
Public property | UpdateWithNotSetAtDisconnect | Liest oder schreibt einen Wert, der angibt ob der Eingang mit einem Token 'NotSet' belegt werden soll, sobald die Verbindung getrennt wird.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | CurrentTokenChanged | Wird ausgelöst, wenn das aktuelle Token zur Verarbeitung geändert wird.
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn der ausgewählte Datentyp für die Verbindung geändert wird.
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)

See Also

InPort Class
DynamicNode.Core Namespace


InPort Constructor

[image] [image]

DynamicNodes API
InPort Constructor
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | InPort(INode, String) | Initialisiert eine generische InPort-Instanz. Dadurch dass keine Datentypen für diesen Eingang angegeben sind ist er untypisiert und nimmt alle Datentypen entgegen.
Public method | InPort(INode, String, IInPortDataTypeProvider) | Initialisiert eine Provider-abhängige InPort-Instanz.
Public method | InPort(INode, String, array<Type>[]()[][]) | Initialisiert eine typisierte InPort-Instanz.

See Also

InPort Class
InPort Members
DynamicNode.Core Namespace


InPort Constructor (INode, String)

[image]

DynamicNodes API
InPort Constructor (INode, String)
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine generische InPort-Instanz. Dadurch dass keine Datentypen für diesen Eingang angegeben sind ist er untypisiert und nimmt alle Datentypen entgegen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPort(
    INode parent,
    string name
)
Visual Basic
Public Sub New ( _
    parent As INode, _
    name As String _
)
F#
new :
        parent:INode *
        name:string -> InPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten, für den der Ausgangs-Port erstellt wird, oder null, falls der Port noch keinem Knoten hinzugefügt werden soll.
name
Type: System..::..String
Der Name des Eingangs-Ports

See Also

InPort Class
InPort Overload
DynamicNode.Core Namespace


InPort Constructor (INode, String, IInPortDataTypeProvider)

[image]

DynamicNodes API
InPort Constructor (INode, String, IInPortDataTypeProvider)
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Provider-abhängige InPort-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPort(
    INode parent,
    string name,
    IInPortDataTypeProvider typeProvider
)
Visual Basic
Public Sub New ( _
    parent As INode, _
    name As String, _
    typeProvider As IInPortDataTypeProvider _
)
F#
new :
        parent:INode *
        name:string *
        typeProvider:IInPortDataTypeProvider -> InPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten, für den der Ausgangs-Port erstellt wird, oder null, falls der Port noch keinem Knoten hinzugefügt werden soll.
name
Type: System..::..String
Der Name des Eingangs-Ports
typeProvider
Type: DynamicNode.Core..::..IInPortDataTypeProvider
Ein Objekt, welches die unterstützten Datentypen bereitstellt.

See Also

InPort Class
InPort Overload
DynamicNode.Core Namespace


InPort Constructor (INode, String, Type[])

[image]

DynamicNodes API
InPort Constructor (INode, String, array<Type>[]()[][])
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine typisierte InPort-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPort(
    INode parent,
    string name,
    params Type[] dataTypes
)
Visual Basic
Public Sub New ( _
    parent As INode, _
    name As String, _
    ParamArray dataTypes As Type() _
)
F#
new :
        parent:INode *
        name:string *
        dataTypes:Type[] -> InPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten, für den der Ausgangs-Port erstellt wird, oder null, falls der Port noch keinem Knoten hinzugefügt werden soll.
name
Type: System..::..String
Der Name des Eingangs-Ports
dataTypes
Type: array< System..::..Type >[]()[][]
Die unterstützten Datentypen.

See Also

InPort Class
InPort Overload
DynamicNode.Core Namespace


InPort Methods

[image] [image]

DynamicNodes API
InPort Methods
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPort type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Verbindet einen Ausgangs-Port mit diesem Eingangs-Port.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Ausgang, falls eine solche Verbindung besteht.
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben.
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben.
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Overrides Port..::..IsConnectableTo(IPort, Type%).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem die unterstützten Datentypen geändert wurden. Falls eine Verbindung besteht wird erneut geprüft welcher Datentyp optimal ist. Falls ein anderer Datentyp als der zur Zeit ausgewählte optimal ist, wird der optimale Datentyp ausgewählt. Falls die Verbindung ungültig ist, wird sie getrennt.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnCurrentTokenChanged | Wird aufgerufen, wenn das Ereignis CurrentTokenChanged ausgelöst werden soll.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Overrides Port..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Overrides Port..::..OnStore(IPropertyWriter).)
Protected method | OnSupportedDataTypeChanged | Wird aufgerufen wenn der für die aktuelle Verbindung ausgewählte Datentyp geändert wurde. Löst das Ereignis SupportedDataTypeChanged aus.
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | PrepareNextToken | Bereitet den Eingang auf die nächste Arbeitsphase des Knotens vor. Falls ein Queue vorhanden ist, wird dazu das nächste Token aus dem Queue geholt.
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Overrides Object..::..ToString()()()().)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Overrides Port..::..TryConnect(IPort).)
Public method | UpdateToken | Aktualisiert den Wert des Ports und setzt den Wert-Zustand auf Valid. Dabei wird das Ereignis TokenUpdate ausgelöst.

See Also

InPort Class
DynamicNode.Core Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
InPort..::..BeforeUseExtension Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

InPort Class
InPort Members
DynamicNode.Core Namespace


Connect Method

[image]

DynamicNodes API
InPort..::..Connect Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verbindet einen Ausgangs-Port mit diesem Eingangs-Port.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void Connect(
    OutPort outPort,
    Type typeSelection
)
Visual Basic
Public Overridable Sub Connect ( _
    outPort As OutPort, _
    typeSelection As Type _
)
F#
abstract Connect :
        outPort:OutPort *
        typeSelection:Type -> unit
override Connect :
        outPort:OutPort *
        typeSelection:Type -> unit

Parameters

outPort
Type: DynamicNode.Core..::..OutPort
Ein Ausgangs-Port.
typeSelection
Type: System..::..Type
Der Datentyp, auf dem die Verbindung beruht.

Remarks

Ruft Connect(InPort, Type) auf.

See Also

InPort Class
DynamicNode.Core Namespace


Disconnect Method

[image]

DynamicNodes API
InPort..::..Disconnect Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Trennt die Verbindung zu einem Ausgang, falls eine solche Verbindung besteht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void Disconnect()
Visual Basic
Public Overridable Sub Disconnect
F#
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit

Remarks

Ruft Disconnect(InPort) auf.

See Also

InPort Class
DynamicNode.Core Namespace


GetCurrentValue Method

[image] [image]

DynamicNodes API
InPort..::..GetCurrentValue Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben.
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben.

See Also

InPort Class
InPort Members
DynamicNode.Core Namespace


GetCurrentValue(T) Method (T)

[image]

DynamicNodes API
InPort..::..GetCurrentValue<(Of <(<'T>)>)> Method (T)
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual T GetCurrentValue<T>(
    T def
)
Visual Basic
Public Overridable Function GetCurrentValue(Of T) ( _
    def As T _
) As T
F#
abstract GetCurrentValue :
        def:'T -> 'T
override GetCurrentValue :
        def:'T -> 'T

Parameters

def
Type: T
Der Standardwert.

Type Parameters

T
Der Typ des erwarteten Wertes.

Return Value

Ein sicherer Wert.

Exceptions

Exception | Condition
System..::..InvalidCastException | Wird geworfen, wenn der Token-Wert nicht in den Typ T umgewandelt werden kann.

See Also

InPort Class
GetCurrentValue Overload
DynamicNode.Core Namespace


GetCurrentValue(T) Method (T, Boolean)

[image]

DynamicNodes API
InPort..::..GetCurrentValue<(Of <(<'T>)>)> Method (T, Boolean)
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual T GetCurrentValue<T>(
    T def,
    bool mustBeValid
)
Visual Basic
Public Overridable Function GetCurrentValue(Of T) ( _
    def As T, _
    mustBeValid As Boolean _
) As T
F#
abstract GetCurrentValue :
        def:'T *
        mustBeValid:bool -> 'T
override GetCurrentValue :
        def:'T *
        mustBeValid:bool -> 'T

Parameters

def
Type: T
Der Standardwert.
mustBeValid
Type: System..::..Boolean
Wenn true übergeben wird, muss der aktuelle Token-Status Valid sein, damit der Token-Wert zurückgegeben werden darf.

Type Parameters

T
Der Typ des erwarteten Wertes.

Return Value

Ein sicherer Wert.

Exceptions

Exception | Condition
System..::..InvalidCastException | Wird geworfen, wenn der Token-Wert nicht in den Typ T umgewandelt werden kann.

See Also

InPort Class
GetCurrentValue Overload
DynamicNode.Core Namespace


IsConnectableTo Method

[image]

DynamicNodes API
InPort..::..IsConnectableTo Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob dieser Port mit einem anderem Port verbunden werden kann.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool IsConnectableTo(
    IPort port,
    out Type possibleTypeSelection
)
Visual Basic
Public Overrides Function IsConnectableTo ( _
    port As IPort, _
    <OutAttribute> ByRef possibleTypeSelection As Type _
) As Boolean
F#
abstract IsConnectableTo :
        port:IPort *
        possibleTypeSelection:Type byref -> bool
override IsConnectableTo :
        port:IPort *
        possibleTypeSelection:Type byref -> bool

Parameters

port
Type: DynamicNode.Core..::..IPort
Der andere Port.
possibleTypeSelection
Type: System..::..Type %
Wird mit dem ausgewählten Datentyp belegt, oder null, wenn der Rückgabewert false ist.

Return Value

true, wenn eine Verbindung mit dem anderen Port möglich ist, sonst false.

Implements

IPort..::..IsConnectableTo(IPort, Type%)

See Also

InPort Class
DynamicNode.Core Namespace


NotifyTypeSupportChanged Method

[image]

DynamicNodes API
InPort..::..NotifyTypeSupportChanged Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Muss aufgerufen werden, nachdem die unterstützten Datentypen geändert wurden.
Falls eine Verbindung besteht wird erneut geprüft welcher Datentyp optimal ist. Falls ein anderer Datentyp als der zur Zeit ausgewählte optimal ist, wird der optimale Datentyp ausgewählt. Falls die Verbindung ungültig ist, wird sie getrennt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void NotifyTypeSupportChanged()
Visual Basic
Public Overridable Sub NotifyTypeSupportChanged
F#
abstract NotifyTypeSupportChanged : unit -> unit
override NotifyTypeSupportChanged : unit -> unit

See Also

InPort Class
DynamicNode.Core Namespace


OnCurrentTokenChanged Method

[image]

DynamicNodes API
InPort..::..OnCurrentTokenChanged Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Ereignis CurrentTokenChanged ausgelöst werden soll.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnCurrentTokenChanged()
Visual Basic
Protected Sub OnCurrentTokenChanged
F#
member OnCurrentTokenChanged : unit -> unit

See Also

InPort Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
InPort..::..OnRestore Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overrides Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)

See Also

InPort Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
InPort..::..OnStore Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overrides Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)

See Also

InPort Class
DynamicNode.Core Namespace


OnSupportedDataTypeChanged Method

[image]

DynamicNodes API
InPort..::..OnSupportedDataTypeChanged Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der für die aktuelle Verbindung ausgewählte Datentyp geändert wurde. Löst das Ereignis SupportedDataTypeChanged aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnSupportedDataTypeChanged()
Visual Basic
Protected Sub OnSupportedDataTypeChanged
F#
member OnSupportedDataTypeChanged : unit -> unit

See Also

InPort Class
DynamicNode.Core Namespace


PrepareNextToken Method

[image]

DynamicNodes API
InPort..::..PrepareNextToken Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bereitet den Eingang auf die nächste Arbeitsphase des Knotens vor. Falls ein Queue vorhanden ist, wird dazu das nächste Token aus dem Queue geholt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void PrepareNextToken()
Visual Basic
Public Overridable Sub PrepareNextToken
F#
abstract PrepareNextToken : unit -> unit
override PrepareNextToken : unit -> unit

See Also

InPort Class
DynamicNode.Core Namespace


ToString Method

[image]

DynamicNodes API
InPort..::..ToString Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen String zurück, der den aktuellen Object darstellt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Ein String, der den aktuellen Object darstellt.

See Also

InPort Class
DynamicNode.Core Namespace


TraceError Method

[image] [image]

DynamicNodes API
InPort..::..TraceError Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

InPort Class
InPort Members
DynamicNode.Core Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
InPort..::..TraceInfo Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

InPort Class
InPort Members
DynamicNode.Core Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
InPort..::..TraceVerbose Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

InPort Class
InPort Members
DynamicNode.Core Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
InPort..::..TraceVerboseData Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

InPort Class
InPort Members
DynamicNode.Core Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
InPort..::..TraceWarning Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

InPort Class
InPort Members
DynamicNode.Core Namespace


TryConnect Method

[image]

DynamicNodes API
InPort..::..TryConnect Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool TryConnect(
    IPort port
)
Visual Basic
Public Overrides Function TryConnect ( _
    port As IPort _
) As Boolean
F#
abstract TryConnect :
        port:IPort -> bool
override TryConnect :
        port:IPort -> bool

Parameters

port
Type: DynamicNode.Core..::..IPort
Ein Anschluss.

Return Value

true, wenn die Verbindung aufgebaut werden konnte, sonst false.

Implements

IPort..::..TryConnect(IPort)

See Also

InPort Class
DynamicNode.Core Namespace


UpdateToken Method

[image]

DynamicNodes API
InPort..::..UpdateToken Method
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert den Wert des Ports und setzt den Wert-Zustand auf Valid. Dabei wird das Ereignis TokenUpdate ausgelöst.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void UpdateToken(
    Token token
)
Visual Basic
Public Overridable Sub UpdateToken ( _
    token As Token _
)
F#
abstract UpdateToken :
        token:Token -> unit
override UpdateToken :
        token:Token -> unit

Parameters

token
Type: DynamicNode.Core..::..Token
Das neue Token

See Also

InPort Class
DynamicNode.Core Namespace


InPort Properties

[image] [image]

DynamicNodes API
InPort Properties
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPort type exposes the following members.

Properties

 | Name | Description
Public property | CanHaveQueue | Liest oder schreibt einen Wert, der angibt ob dieser Eingang eine Queue haben darf.
Public property | Capacity | Liest oder schreibt die Kapazität der evtl. vorhandenen Queue.
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Eingangs-Ports zu anderen Ausgangs-Ports angepasst werden kann.
Public property | ConnectedOutPort | Gibt den verbundenen Ausgangs-Port zurück der mit diesem Eingangs-Port verbunden ist, oder null, wenn keine Verbindung besteht.
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Overrides Port..::..ConnectionCount.)
Public property | CurrentToken | Gibt das Token zurück, welches für den aktuellen Arbeitsschritt verwendet werden soll.
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Eingang.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | HasQueue | Liest oder schreibt einen Wert der angibt ob diese Instanz eine Queue besitzt.
Public property | HasWaitingToken | Gibt einen Wert zurück, der angibt ob der nächste Aufruf von PrepareNextToken()()()() ein neues Token zur Verarbeitung bereitstellt oder nicht.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsConnected | Prüft, ob diese Instanz mit einem Ausgangs-Port verbunden ist.
Public property | IsCurrentTokenNew | Gibt einen Wert zurück der angibt, ob das aktuelle Token neu ist.
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsMandatory | Gibt einen Wert zurück oder legt ihn fest, der angibt ob der Eingang mit einem Token belegt werden muss, damit der Knoten arbeiten kann.
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedDataType | Gibt den für die aktuelle Verbindung ausgewählten Datentyp zurück, oder legt ihn fest.
Public property | SupportedTypes | Gibt eine Liste mit allen unterstützten Datentypen zurück. Falls ein Daten-Typ-Provider eingerichtet ist, wird dessen Liste zurückgegeben.
Public property | UpdateWithNotSetAtDisconnect | Liest oder schreibt einen Wert, der angibt ob der Eingang mit einem Token 'NotSet' belegt werden soll, sobald die Verbindung getrennt wird.

See Also

InPort Class
DynamicNode.Core Namespace


CanHaveQueue Property

[image]

DynamicNodes API
InPort..::..CanHaveQueue Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob dieser Eingang eine Queue haben darf.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual bool CanHaveQueue { get; set; }
Visual Basic
Public Overridable Property CanHaveQueue As Boolean
    Get
    Set
F#
abstract CanHaveQueue : bool with get, set
override CanHaveQueue : bool with get, set

Field Value

true wenn dieser Eingang eine Queue besitzen darf, sonst false.

See Also

InPort Class
DynamicNode.Core Namespace


Capacity Property

[image]

DynamicNodes API
InPort..::..Capacity Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die Kapazität der evtl. vorhandenen Queue.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int Capacity { get; set; }
Visual Basic
Public Property Capacity As Integer
    Get
    Set
F#
member Capacity : int with get, set

Field Value

Die Kapazität der Queue.

See Also

InPort Class
DynamicNode.Core Namespace


CompatibilityChecker Property

[image]

DynamicNodes API
InPort..::..CompatibilityChecker Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Eingangs-Ports zu anderen Ausgangs-Ports angepasst werden kann.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual CompatibilityChecker<OutPort> CompatibilityChecker { get; set; }
Visual Basic
Public Overridable Property CompatibilityChecker As CompatibilityChecker(Of OutPort)
    Get
    Set
F#
abstract CompatibilityChecker : CompatibilityChecker<OutPort> with get, set
override CompatibilityChecker : CompatibilityChecker<OutPort> with get, set

Field Value

Der Kompatibilitäts-Checker.

See Also

InPort Class
DynamicNode.Core Namespace
InPort..::..CompatibilityChecker


ConnectedOutPort Property

[image]

DynamicNodes API
InPort..::..ConnectedOutPort Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den verbundenen Ausgangs-Port zurück der mit diesem Eingangs-Port verbunden ist, oder null, wenn keine Verbindung besteht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual OutPort ConnectedOutPort { get; }
Visual Basic
Public Overridable ReadOnly Property ConnectedOutPort As OutPort
    Get
F#
abstract ConnectedOutPort : OutPort
override ConnectedOutPort : OutPort

Field Value

Der verbundene Ausgangs-Port.

See Also

InPort Class
DynamicNode.Core Namespace


ConnectionCount Property

[image]

DynamicNodes API
InPort..::..ConnectionCount Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller Verbindungen mit diesem Port zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override int ConnectionCount { get; }
Visual Basic
Public Overrides ReadOnly Property ConnectionCount As Integer
    Get
F#
abstract ConnectionCount : int
override ConnectionCount : int

Field Value

Die Anzahl der Verbindungen.

Implements

IPort..::..ConnectionCount

See Also

InPort Class
DynamicNode.Core Namespace


CurrentToken Property

[image]

DynamicNodes API
InPort..::..CurrentToken Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Token zurück, welches für den aktuellen Arbeitsschritt verwendet werden soll.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual Token CurrentToken { get; private set; }
Visual Basic
Public Overridable Property CurrentToken As Token
    Get
    Private Set
F#
abstract CurrentToken : Token with get, private set
override CurrentToken : Token with get, private set

Field Value

Das aktuelle Token.

See Also

InPort Class
DynamicNode.Core Namespace


DataTypeProvider Property

[image]

DynamicNodes API
InPort..::..DataTypeProvider Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Daten-Typ-Provider für diesen Eingang.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IInPortDataTypeProvider DataTypeProvider { get; set; }
Visual Basic
Public Property DataTypeProvider As IInPortDataTypeProvider
    Get
    Set
F#
member DataTypeProvider : IInPortDataTypeProvider with get, set

Field Value

Der Daten-Typ-Provider.

See Also

InPort Class
DynamicNode.Core Namespace


HasQueue Property

[image]

DynamicNodes API
InPort..::..HasQueue Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert der angibt ob diese Instanz eine Queue besitzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual bool HasQueue { get; set; }
Visual Basic
Public Overridable Property HasQueue As Boolean
    Get
    Set
F#
abstract HasQueue : bool with get, set
override HasQueue : bool with get, set

Field Value

true wenn diese Instanz eine Queue besitzt, sonst false.

See Also

InPort Class
DynamicNode.Core Namespace


HasWaitingToken Property

[image]

DynamicNodes API
InPort..::..HasWaitingToken Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob der nächste Aufruf von PrepareNextToken()()()() ein neues Token zur Verarbeitung bereitstellt oder nicht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual bool HasWaitingToken { get; }
Visual Basic
Public Overridable ReadOnly Property HasWaitingToken As Boolean
    Get
F#
abstract HasWaitingToken : bool
override HasWaitingToken : bool

See Also

InPort Class
DynamicNode.Core Namespace


IsConnected Property

[image]

DynamicNodes API
InPort..::..IsConnected Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob diese Instanz mit einem Ausgangs-Port verbunden ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual bool IsConnected { get; }
Visual Basic
Public Overridable ReadOnly Property IsConnected As Boolean
    Get
F#
abstract IsConnected : bool
override IsConnected : bool

Field Value

true, wenn diese Instanz mit einem Ausgangs-Port verbunden ist, sonst false.

See Also

InPort Class
DynamicNode.Core Namespace


IsCurrentTokenNew Property

[image]

DynamicNodes API
InPort..::..IsCurrentTokenNew Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück der angibt, ob das aktuelle Token neu ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual bool IsCurrentTokenNew { get; }
Visual Basic
Public Overridable ReadOnly Property IsCurrentTokenNew As Boolean
    Get
F#
abstract IsCurrentTokenNew : bool
override IsCurrentTokenNew : bool

See Also

InPort Class
DynamicNode.Core Namespace


IsMandatory Property

[image]

DynamicNodes API
InPort..::..IsMandatory Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt ob der Eingang mit einem Token belegt werden muss, damit der Knoten arbeiten kann.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsMandatory { get; set; }
Visual Basic
Public Property IsMandatory As Boolean
    Get
    Set
F#
member IsMandatory : bool with get, set

Field Value

true, wenn es ein Pflicht-Eingang ist, sonst false.

See Also

InPort Class
DynamicNode.Core Namespace


SupportedDataType Property

[image]

DynamicNodes API
InPort..::..SupportedDataType Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den für die aktuelle Verbindung ausgewählten Datentyp zurück, oder legt ihn fest.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual Type SupportedDataType { get; internal set; }
Visual Basic
Public Overridable Property SupportedDataType As Type
    Get
    Friend Set
F#
abstract SupportedDataType : Type with get, internal set
override SupportedDataType : Type with get, internal set

Field Value

Der aktuelle Datentyp, oder null, wenn keine Verbindung besteht.

Implements

IOutPortDataTypeProvider..::..SupportedDataType

See Also

InPort Class
DynamicNode.Core Namespace


SupportedTypes Property

[image]

DynamicNodes API
InPort..::..SupportedTypes Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Liste mit allen unterstützten Datentypen zurück. Falls ein Daten-Typ-Provider eingerichtet ist, wird dessen Liste zurückgegeben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual Type[] SupportedTypes { get; }
Visual Basic
Public Overridable ReadOnly Property SupportedTypes As Type()
    Get
F#
abstract SupportedTypes : Type[]
override SupportedTypes : Type[]

Field Value

Alle unterstützten Datentypen.

See Also

InPort Class
DynamicNode.Core Namespace


UpdateWithNotSetAtDisconnect Property

[image]

DynamicNodes API
InPort..::..UpdateWithNotSetAtDisconnect Property
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob der Eingang mit einem Token 'NotSet' belegt werden soll, sobald die Verbindung getrennt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual bool UpdateWithNotSetAtDisconnect { get; set; }
Visual Basic
Public Overridable Property UpdateWithNotSetAtDisconnect As Boolean
    Get
    Set
F#
abstract UpdateWithNotSetAtDisconnect : bool with get, set
override UpdateWithNotSetAtDisconnect : bool with get, set

Field Value

true wenn der Eingang mit einem Token 'NotSet' belegt werden soll, sobald die Verbindung getrennt wird, sonst false.

See Also

InPort Class
DynamicNode.Core Namespace


InPort Events

[image] [image]

DynamicNodes API
InPort Events
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPort type exposes the following members.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | CurrentTokenChanged | Wird ausgelöst, wenn das aktuelle Token zur Verarbeitung geändert wird.
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn der ausgewählte Datentyp für die Verbindung geändert wird.
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)

See Also

InPort Class
DynamicNode.Core Namespace


CurrentTokenChanged Event

[image]

DynamicNodes API
InPort..::..CurrentTokenChanged Event
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn das aktuelle Token zur Verarbeitung geändert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler CurrentTokenChanged
Visual Basic
Public Event CurrentTokenChanged As EventHandler
F#
member CurrentTokenChanged : IEvent<EventHandler,
    EventArgs>

See Also

InPort Class
DynamicNode.Core Namespace


SupportedDataTypeChanged Event

[image]

DynamicNodes API
InPort..::..SupportedDataTypeChanged Event
InPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der ausgewählte Datentyp für die Verbindung geändert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler SupportedDataTypeChanged
Visual Basic
Public Event SupportedDataTypeChanged As EventHandler
F#
abstract SupportedDataTypeChanged : IEvent<EventHandler,
    EventArgs>
override SupportedDataTypeChanged : IEvent<EventHandler,
    EventArgs>

Implements

IOutPortDataTypeProvider..::..SupportedDataTypeChanged

See Also

InPort Class
DynamicNode.Core Namespace


InPortAttribute Class

[image]

DynamicNodes API
InPortAttribute Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Dieses Attribut kann benutzt werden um eine Eigenschaft als Eingangs-Port zu markieren. Falls eine Eigenschaft in einer von Node abgeleiteten Klasse mit InPortAttribute markiert ist, wird im Standardkonstruktor von Node automatisch ein Eingangs-Port erzeugt und mit der markierten Eigenschaft verknüpft.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class InPortAttribute : Attribute
Visual Basic
Public Class InPortAttribute _
    Inherits Attribute
F#
type InPortAttribute =
    class
        inherit Attribute
    end

Inheritance Hierarchy

System..::..Object
System..::..Attribute
DynamicNode.Core..::..InPortAttribute

See Also

InPortAttribute Members
DynamicNode.Core Namespace


InPortAttribute Members

[image] [image]

DynamicNodes API
InPortAttribute Members
InPortAttribute Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | InPortAttribute | Initialisiert eine InPortAttribute-Instanz.

Properties

 | Name | Description
Public property | Name | Gibt den Namen des Ports zurück.

See Also

InPortAttribute Class
DynamicNode.Core Namespace


InPortAttribute Constructor

[image]

DynamicNodes API
InPortAttribute Constructor
InPortAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine InPortAttribute-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPortAttribute(
    string portName
)
Visual Basic
Public Sub New ( _
    portName As String _
)
F#
new :
        portName:string -> InPortAttribute

Parameters

portName
Type: System..::..String
Die ID des Eingangs-Ports.

See Also

InPortAttribute Class
DynamicNode.Core Namespace


InPortAttribute Properties

[image] [image]

DynamicNodes API
InPortAttribute Properties
InPortAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gibt den Namen des Ports zurück.

See Also

InPortAttribute Class
DynamicNode.Core Namespace


Name Property

[image]

DynamicNodes API
InPortAttribute..::..Name Property
InPortAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Ports zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
member Name : string

Field Value

Der Name des Ports.

See Also

InPortAttribute Class
DynamicNode.Core Namespace


InPortDataTypeGroup Class

[image]

DynamicNodes API
InPortDataTypeGroup Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwaltet eine Liste von Datentypen für mehrere Ports.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class InPortDataTypeGroup : IExtension<INode>,
    IStorable, IInPortDataTypeProvider, IOutPortDataTypeProvider
Visual Basic
Public Class InPortDataTypeGroup _
    Implements IExtension(Of INode), IStorable,  _
    IInPortDataTypeProvider, IOutPortDataTypeProvider
F#
type InPortDataTypeGroup =
    class
        interface IExtension<INode>
        interface IStorable
        interface IInPortDataTypeProvider
        interface IOutPortDataTypeProvider
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..InPortDataTypeGroup

See Also

InPortDataTypeGroup Members
DynamicNode.Core Namespace


InPortDataTypeGroup Members

[image] [image]

DynamicNodes API
InPortDataTypeGroup Members
InPortDataTypeGroup Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeGroup type exposes the following members.

Constructors

 | Name | Description
Public method | InPortDataTypeGroup | Initialisiert eine neue InPortDataTypeGroup-Instanz.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Public method | RegisterInPort | Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen.
Public method | UnregisterInPort | Entfernt einen Eingang aus der Verwaltung.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | SupportedDataType | Gibt den bereitgestellten Datentyp zurück.
Public property | SupportedDataTypes | Gibt die bereitgestellten Datentypen zurück.

Events

 | Name | Description
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.
Public event | SupportedDataTypesChanged | Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert.

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


InPortDataTypeGroup Constructor

[image]

DynamicNodes API
InPortDataTypeGroup Constructor
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue InPortDataTypeGroup-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPortDataTypeGroup(
    params Type[] types
)
Visual Basic
Public Sub New ( _
    ParamArray types As Type() _
)
F#
new :
        types:Type[] -> InPortDataTypeGroup

Parameters

types
Type: array< System..::..Type >[]()[][]
Eine priorisierte Typenliste.

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


InPortDataTypeGroup Fields

[image] [image]

DynamicNodes API
InPortDataTypeGroup Fields
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeGroup type exposes the following members.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


EXT_ID Field

[image]

DynamicNodes API
InPortDataTypeGroup..::..EXT_ID Field
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


InPortDataTypeGroup Methods

[image] [image]

DynamicNodes API
InPortDataTypeGroup Methods
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeGroup type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Public method | RegisterInPort | Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen.
Public method | UnregisterInPort | Entfernt einen Eingang aus der Verwaltung.

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


AfterAttaching Method

[image]

DynamicNodes API
InPortDataTypeGroup..::..AfterAttaching Method
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterAttaching(
    INode g
)
Visual Basic
Public Sub AfterAttaching ( _
    g As INode _
)
F#
abstract AfterAttaching :
        g:INode -> unit
override AfterAttaching :
        g:INode -> unit

Parameters

g
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


AfterDetaching Method

[image]

DynamicNodes API
InPortDataTypeGroup..::..AfterDetaching Method
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterDetaching(
    INode o
)
Visual Basic
Public Sub AfterDetaching ( _
    o As INode _
)
F#
abstract AfterDetaching :
        o:INode -> unit
override AfterDetaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


AfterRestoring Method

[image]

DynamicNodes API
InPortDataTypeGroup..::..AfterRestoring Method
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
InPortDataTypeGroup..::..OnRestore Method
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschafts-Leser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
InPortDataTypeGroup..::..OnStore Method
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschafts-Writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


RegisterInPort Method

[image]

DynamicNodes API
InPortDataTypeGroup..::..RegisterInPort Method
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RegisterInPort(
    InPort iP
)
Visual Basic
Public Sub RegisterInPort ( _
    iP As InPort _
)
F#
abstract RegisterInPort :
        iP:InPort -> unit
override RegisterInPort :
        iP:InPort -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Der Eingang.

Implements

IInPortDataTypeProvider..::..RegisterInPort(InPort)

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


UnregisterInPort Method

[image]

DynamicNodes API
InPortDataTypeGroup..::..UnregisterInPort Method
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt einen Eingang aus der Verwaltung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UnregisterInPort(
    InPort iP
)
Visual Basic
Public Sub UnregisterInPort ( _
    iP As InPort _
)
F#
abstract UnregisterInPort :
        iP:InPort -> unit
override UnregisterInPort :
        iP:InPort -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Ein Eingang.

Implements

IInPortDataTypeProvider..::..UnregisterInPort(InPort)

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


InPortDataTypeGroup Properties

[image] [image]

DynamicNodes API
InPortDataTypeGroup Properties
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeGroup type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | SupportedDataType | Gibt den bereitgestellten Datentyp zurück.
Public property | SupportedDataTypes | Gibt die bereitgestellten Datentypen zurück.

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


Id Property

[image]

DynamicNodes API
InPortDataTypeGroup..::..Id Property
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


IsUsingStorage Property

[image]

DynamicNodes API
InPortDataTypeGroup..::..IsUsingStorage Property
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


SupportedDataType Property

[image]

DynamicNodes API
InPortDataTypeGroup..::..SupportedDataType Property
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den bereitgestellten Datentyp zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Type SupportedDataType { get; }
Visual Basic
Public ReadOnly Property SupportedDataType As Type
    Get
F#
abstract SupportedDataType : Type
override SupportedDataType : Type

Field Value

Der aktuelle Datentyp, oder null, wenn keiner bereitgestellt wird.

Implements

IOutPortDataTypeProvider..::..SupportedDataType

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


SupportedDataTypes Property

[image]

DynamicNodes API
InPortDataTypeGroup..::..SupportedDataTypes Property
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die bereitgestellten Datentypen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Type[] SupportedDataTypes { get; }
Visual Basic
Public ReadOnly Property SupportedDataTypes As Type()
    Get
F#
abstract SupportedDataTypes : Type[]
override SupportedDataTypes : Type[]

Field Value

Die aktuellen Datentyp-Liste als Array.

Implements

IInPortDataTypeProvider..::..SupportedDataTypes

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


InPortDataTypeGroup Events

[image] [image]

DynamicNodes API
InPortDataTypeGroup Events
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeGroup type exposes the following members.

Events

 | Name | Description
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.
Public event | SupportedDataTypesChanged | Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert.

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


SupportedDataTypeChanged Event

[image]

DynamicNodes API
InPortDataTypeGroup..::..SupportedDataTypeChanged Event
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler SupportedDataTypeChanged
Visual Basic
Public Event SupportedDataTypeChanged As EventHandler
F#
abstract SupportedDataTypeChanged : IEvent<EventHandler,
    EventArgs>
override SupportedDataTypeChanged : IEvent<EventHandler,
    EventArgs>

Implements

IOutPortDataTypeProvider..::..SupportedDataTypeChanged

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


SupportedDataTypesChanged Event

[image]

DynamicNodes API
InPortDataTypeGroup..::..SupportedDataTypesChanged Event
InPortDataTypeGroup Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler SupportedDataTypesChanged
Visual Basic
Public Event SupportedDataTypesChanged As EventHandler
F#
abstract SupportedDataTypesChanged : IEvent<EventHandler,
    EventArgs>
override SupportedDataTypesChanged : IEvent<EventHandler,
    EventArgs>

Implements

IInPortDataTypeProvider..::..SupportedDataTypesChanged

See Also

InPortDataTypeGroup Class
DynamicNode.Core Namespace


InPortDataTypeProvider Class

[image]

DynamicNodes API
InPortDataTypeProvider Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt eine einfache Implementierung für IInPortDataTypeProvider zur Verfügung. Dieser Datentypen-Provider verwaltet eine Liste mit Datentypen welche von außen modifiziert werden kann. Wurde die Liste verändert, muss die Änderung mit CommitChanges()()()() bestätigt werden. Erst dann wird das Ereignis SupportedDataTypesChanged ausgelöst.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class InPortDataTypeProvider : InPortDataTypeProviderBase,
    IExtension<INode>, IStorable
Visual Basic
Public Class InPortDataTypeProvider _
    Inherits InPortDataTypeProviderBase _
    Implements IExtension(Of INode), IStorable
F#
type InPortDataTypeProvider =
    class
        inherit InPortDataTypeProviderBase
        interface IExtension<INode>
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..InPortDataTypeProviderBase
DynamicNode.Core..::..InPortDataTypeProvider

See Also

InPortDataTypeProvider Members
DynamicNode.Core Namespace


InPortDataTypeProvider Members

[image] [image]

DynamicNodes API
InPortDataTypeProvider Members
InPortDataTypeProvider Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeProvider type exposes the following members.

Constructors

 | Name | Description
Public method | InPortDataTypeProvider()()()() | Initialisiert eine neue Instanz von InPortDataTypeProvider mit einer leeren Datentypenliste.
Public method | InPortDataTypeProvider(array<Type>[]()[][]) | Initialisiert eine neue Instanz von InPortDataTypeProvider.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | CommitChanges | Bestätigt die bisher vorgenommenen Änderungen an der Datentypenliste und informiert alle registrierten Eingänge.
Protected method | OnInPortRegistered | Wird aufgerufen, wenn ein Eingang registriert wurde. (Inherited from InPortDataTypeProviderBase.)
Protected method | OnInPortUnregistered | Wird aufgerufen, wenn ein Eingang deregistriert wurde. (Inherited from InPortDataTypeProviderBase.)
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Protected method | OnSupportedDataTypesChanged | Wird aufgerufen, wenn sich die Liste der unterstützten Typen geändert hat. Löst das Ereignis SupportedDataTypesChanged aus. (Inherited from InPortDataTypeProviderBase.)
Public method | RegisterInPort | Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen. (Inherited from InPortDataTypeProviderBase.)
Public method | RejectChanges | Macht die letzten, noch nicht bestätigten Änderungen an der Datentypenliste rückgängig.
Public method | UnregisterInPort | Entfernt einen Eingang aus der Verwaltung. (Inherited from InPortDataTypeProviderBase.)

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

Properties

 | Name | Description
Public property | DataTypeList | Gibt eine änderbare Liste mit Datentypen zurück. Nach dem Aufruf von CommitChanges()()()() wird diese Liste in den registrierten Eingängen als Kompatibilitätsliste verwendet.
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | SupportedDataTypes | Gibt die bereitgestellten Datentypen zurück. (Overrides InPortDataTypeProviderBase..::..SupportedDataTypes.)

Events

 | Name | Description
Public event | SupportedDataTypesChanged | Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert. (Inherited from InPortDataTypeProviderBase.)

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


InPortDataTypeProvider Constructor

[image] [image]

DynamicNodes API
InPortDataTypeProvider Constructor
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | InPortDataTypeProvider()()()() | Initialisiert eine neue Instanz von InPortDataTypeProvider mit einer leeren Datentypenliste.
Public method | InPortDataTypeProvider(array<Type>[]()[][]) | Initialisiert eine neue Instanz von InPortDataTypeProvider.

See Also

InPortDataTypeProvider Class
InPortDataTypeProvider Members
DynamicNode.Core Namespace


InPortDataTypeProvider Constructor

[image]

DynamicNodes API
InPortDataTypeProvider Constructor
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von InPortDataTypeProvider mit einer leeren Datentypenliste.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPortDataTypeProvider()
Visual Basic
Public Sub New
F#
new : unit -> InPortDataTypeProvider

See Also

InPortDataTypeProvider Class
InPortDataTypeProvider Overload
DynamicNode.Core Namespace


InPortDataTypeProvider Constructor (Type[])

[image]

DynamicNodes API
InPortDataTypeProvider Constructor (array<Type>[]()[][])
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von InPortDataTypeProvider.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPortDataTypeProvider(
    params Type[] types
)
Visual Basic
Public Sub New ( _
    ParamArray types As Type() _
)
F#
new :
        types:Type[] -> InPortDataTypeProvider

Parameters

types
Type: array< System..::..Type >[]()[][]
Die initialen Datentypen.

See Also

InPortDataTypeProvider Class
InPortDataTypeProvider Overload
DynamicNode.Core Namespace


InPortDataTypeProvider Fields

[image] [image]

DynamicNodes API
InPortDataTypeProvider Fields
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeProvider type exposes the following members.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


EXT_ID Field

[image]

DynamicNodes API
InPortDataTypeProvider..::..EXT_ID Field
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


InPortDataTypeProvider Methods

[image] [image]

DynamicNodes API
InPortDataTypeProvider Methods
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeProvider type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | CommitChanges | Bestätigt die bisher vorgenommenen Änderungen an der Datentypenliste und informiert alle registrierten Eingänge.
Protected method | OnInPortRegistered | Wird aufgerufen, wenn ein Eingang registriert wurde. (Inherited from InPortDataTypeProviderBase.)
Protected method | OnInPortUnregistered | Wird aufgerufen, wenn ein Eingang deregistriert wurde. (Inherited from InPortDataTypeProviderBase.)
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Protected method | OnSupportedDataTypesChanged | Wird aufgerufen, wenn sich die Liste der unterstützten Typen geändert hat. Löst das Ereignis SupportedDataTypesChanged aus. (Inherited from InPortDataTypeProviderBase.)
Public method | RegisterInPort | Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen. (Inherited from InPortDataTypeProviderBase.)
Public method | RejectChanges | Macht die letzten, noch nicht bestätigten Änderungen an der Datentypenliste rückgängig.
Public method | UnregisterInPort | Entfernt einen Eingang aus der Verwaltung. (Inherited from InPortDataTypeProviderBase.)

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


AfterAttaching Method

[image]

DynamicNodes API
InPortDataTypeProvider..::..AfterAttaching Method
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterAttaching(
    INode g
)
Visual Basic
Public Sub AfterAttaching ( _
    g As INode _
)
F#
abstract AfterAttaching :
        g:INode -> unit
override AfterAttaching :
        g:INode -> unit

Parameters

g
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


AfterDetaching Method

[image]

DynamicNodes API
InPortDataTypeProvider..::..AfterDetaching Method
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterDetaching(
    INode o
)
Visual Basic
Public Sub AfterDetaching ( _
    o As INode _
)
F#
abstract AfterDetaching :
        o:INode -> unit
override AfterDetaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


AfterRestoring Method

[image]

DynamicNodes API
InPortDataTypeProvider..::..AfterRestoring Method
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


CommitChanges Method

[image]

DynamicNodes API
InPortDataTypeProvider..::..CommitChanges Method
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bestätigt die bisher vorgenommenen Änderungen an der Datentypenliste und informiert alle registrierten Eingänge.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void CommitChanges()
Visual Basic
Public Sub CommitChanges
F#
member CommitChanges : unit -> unit

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
InPortDataTypeProvider..::..OnRestore Method
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschafts-Leser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
InPortDataTypeProvider..::..OnStore Method
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschafts-Writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


RejectChanges Method

[image]

DynamicNodes API
InPortDataTypeProvider..::..RejectChanges Method
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Macht die letzten, noch nicht bestätigten Änderungen an der Datentypenliste rückgängig.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RejectChanges()
Visual Basic
Public Sub RejectChanges
F#
member RejectChanges : unit -> unit

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


InPortDataTypeProvider Properties

[image] [image]

DynamicNodes API
InPortDataTypeProvider Properties
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeProvider type exposes the following members.

Properties

 | Name | Description
Public property | DataTypeList | Gibt eine änderbare Liste mit Datentypen zurück. Nach dem Aufruf von CommitChanges()()()() wird diese Liste in den registrierten Eingängen als Kompatibilitätsliste verwendet.
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | SupportedDataTypes | Gibt die bereitgestellten Datentypen zurück. (Overrides InPortDataTypeProviderBase..::..SupportedDataTypes.)

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


DataTypeList Property

[image]

DynamicNodes API
InPortDataTypeProvider..::..DataTypeList Property
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine änderbare Liste mit Datentypen zurück. Nach dem Aufruf von CommitChanges()()()() wird diese Liste in den registrierten Eingängen als Kompatibilitätsliste verwendet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IList<Type> DataTypeList { get; }
Visual Basic
Public ReadOnly Property DataTypeList As IList(Of Type)
    Get
F#
member DataTypeList : IList<Type>

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


Id Property

[image]

DynamicNodes API
InPortDataTypeProvider..::..Id Property
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


IsUsingStorage Property

[image]

DynamicNodes API
InPortDataTypeProvider..::..IsUsingStorage Property
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


SupportedDataTypes Property

[image]

DynamicNodes API
InPortDataTypeProvider..::..SupportedDataTypes Property
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die bereitgestellten Datentypen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override Type[] SupportedDataTypes { get; }
Visual Basic
Public Overrides ReadOnly Property SupportedDataTypes As Type()
    Get
F#
abstract SupportedDataTypes : Type[]
override SupportedDataTypes : Type[]

Field Value

Die aktuellen Datentyp-Liste als Array.

Implements

IInPortDataTypeProvider..::..SupportedDataTypes

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


InPortDataTypeProvider Events

[image] [image]

DynamicNodes API
InPortDataTypeProvider Events
InPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeProvider type exposes the following members.

Events

 | Name | Description
Public event | SupportedDataTypesChanged | Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert. (Inherited from InPortDataTypeProviderBase.)

See Also

InPortDataTypeProvider Class
DynamicNode.Core Namespace


InPortDataTypeProviderBase Class

[image]

DynamicNodes API
InPortDataTypeProviderBase Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt eine Basis-Implementierung für IInPortDataTypeProvider zur Verfügung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract class InPortDataTypeProviderBase : IInPortDataTypeProvider
Visual Basic
Public MustInherit Class InPortDataTypeProviderBase _
    Implements IInPortDataTypeProvider
F#
[<AbstractClassAttribute>]
type InPortDataTypeProviderBase =
    class
        interface IInPortDataTypeProvider
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..InPortDataTypeProviderBase
DynamicNode.Core..::..InPortDataTypeProvider
DynamicNode.Core..::..InPortSingleDataTypeProvider

See Also

InPortDataTypeProviderBase Members
DynamicNode.Core Namespace


InPortDataTypeProviderBase Members

[image] [image]

DynamicNodes API
InPortDataTypeProviderBase Members
InPortDataTypeProviderBase Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeProviderBase type exposes the following members.

Constructors

 | Name | Description
Protected method | InPortDataTypeProviderBase | Initializes a new instance of the InPortDataTypeProviderBase class

Methods

 | Name | Description
Protected method | OnInPortRegistered | Wird aufgerufen, wenn ein Eingang registriert wurde.
Protected method | OnInPortUnregistered | Wird aufgerufen, wenn ein Eingang deregistriert wurde.
Protected method | OnSupportedDataTypesChanged | Wird aufgerufen, wenn sich die Liste der unterstützten Typen geändert hat. Löst das Ereignis SupportedDataTypesChanged aus.
Public method | RegisterInPort | Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen.
Public method | UnregisterInPort | Entfernt einen Eingang aus der Verwaltung.

Properties

 | Name | Description
Public property | SupportedDataTypes | Gibt die bereitgestellten Datentypen zurück.

Events

 | Name | Description
Public event | SupportedDataTypesChanged | Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert.

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


InPortDataTypeProviderBase Constructor

[image]

DynamicNodes API
InPortDataTypeProviderBase Constructor
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the InPortDataTypeProviderBase class

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected InPortDataTypeProviderBase()
Visual Basic
Protected Sub New
F#
new : unit -> InPortDataTypeProviderBase

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


InPortDataTypeProviderBase Methods

[image] [image]

DynamicNodes API
InPortDataTypeProviderBase Methods
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeProviderBase type exposes the following members.

Methods

 | Name | Description
Protected method | OnInPortRegistered | Wird aufgerufen, wenn ein Eingang registriert wurde.
Protected method | OnInPortUnregistered | Wird aufgerufen, wenn ein Eingang deregistriert wurde.
Protected method | OnSupportedDataTypesChanged | Wird aufgerufen, wenn sich die Liste der unterstützten Typen geändert hat. Löst das Ereignis SupportedDataTypesChanged aus.
Public method | RegisterInPort | Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen.
Public method | UnregisterInPort | Entfernt einen Eingang aus der Verwaltung.

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


OnInPortRegistered Method

[image]

DynamicNodes API
InPortDataTypeProviderBase..::..OnInPortRegistered Method
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Eingang registriert wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnInPortRegistered(
    InPort iP
)
Visual Basic
Protected Overridable Sub OnInPortRegistered ( _
    iP As InPort _
)
F#
abstract OnInPortRegistered :
        iP:InPort -> unit
override OnInPortRegistered :
        iP:InPort -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Der Eingang.

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


OnInPortUnregistered Method

[image]

DynamicNodes API
InPortDataTypeProviderBase..::..OnInPortUnregistered Method
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Eingang deregistriert wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnInPortUnregistered(
    InPort iP
)
Visual Basic
Protected Overridable Sub OnInPortUnregistered ( _
    iP As InPort _
)
F#
abstract OnInPortUnregistered :
        iP:InPort -> unit
override OnInPortUnregistered :
        iP:InPort -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Der Eingang.

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


OnSupportedDataTypesChanged Method

[image]

DynamicNodes API
InPortDataTypeProviderBase..::..OnSupportedDataTypesChanged Method
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn sich die Liste der unterstützten Typen geändert hat. Löst das Ereignis SupportedDataTypesChanged aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnSupportedDataTypesChanged()
Visual Basic
Protected Sub OnSupportedDataTypesChanged
F#
member OnSupportedDataTypesChanged : unit -> unit

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


RegisterInPort Method

[image]

DynamicNodes API
InPortDataTypeProviderBase..::..RegisterInPort Method
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RegisterInPort(
    InPort iP
)
Visual Basic
Public Sub RegisterInPort ( _
    iP As InPort _
)
F#
abstract RegisterInPort :
        iP:InPort -> unit
override RegisterInPort :
        iP:InPort -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Der Eingang.

Implements

IInPortDataTypeProvider..::..RegisterInPort(InPort)

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


UnregisterInPort Method

[image]

DynamicNodes API
InPortDataTypeProviderBase..::..UnregisterInPort Method
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt einen Eingang aus der Verwaltung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UnregisterInPort(
    InPort iP
)
Visual Basic
Public Sub UnregisterInPort ( _
    iP As InPort _
)
F#
abstract UnregisterInPort :
        iP:InPort -> unit
override UnregisterInPort :
        iP:InPort -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Ein Eingang.

Implements

IInPortDataTypeProvider..::..UnregisterInPort(InPort)

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


InPortDataTypeProviderBase Properties

[image] [image]

DynamicNodes API
InPortDataTypeProviderBase Properties
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeProviderBase type exposes the following members.

Properties

 | Name | Description
Public property | SupportedDataTypes | Gibt die bereitgestellten Datentypen zurück.

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


SupportedDataTypes Property

[image]

DynamicNodes API
InPortDataTypeProviderBase..::..SupportedDataTypes Property
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die bereitgestellten Datentypen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract Type[] SupportedDataTypes { get; }
Visual Basic
Public MustOverride ReadOnly Property SupportedDataTypes As Type()
    Get
F#
abstract SupportedDataTypes : Type[]

Field Value

Die aktuellen Datentyp-Liste als Array.

Implements

IInPortDataTypeProvider..::..SupportedDataTypes

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


InPortDataTypeProviderBase Events

[image] [image]

DynamicNodes API
InPortDataTypeProviderBase Events
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortDataTypeProviderBase type exposes the following members.

Events

 | Name | Description
Public event | SupportedDataTypesChanged | Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert.

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


SupportedDataTypesChanged Event

[image]

DynamicNodes API
InPortDataTypeProviderBase..::..SupportedDataTypesChanged Event
InPortDataTypeProviderBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler SupportedDataTypesChanged
Visual Basic
Public Event SupportedDataTypesChanged As EventHandler
F#
abstract SupportedDataTypesChanged : IEvent<EventHandler,
    EventArgs>
override SupportedDataTypesChanged : IEvent<EventHandler,
    EventArgs>

Implements

IInPortDataTypeProvider..::..SupportedDataTypesChanged

See Also

InPortDataTypeProviderBase Class
DynamicNode.Core Namespace


InPortPersistenceExt Class

[image]

DynamicNodes API
InPortPersistenceExt Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Knoten-Erweiterung, welche die letzten Tokens eines unverbundenen Eingangs persistiert und restoriert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class InPortPersistenceExt : IExtension<INode>,
    IStorable
Visual Basic
Public Class InPortPersistenceExt _
    Implements IExtension(Of INode), IStorable
F#
type InPortPersistenceExt =
    class
        interface IExtension<INode>
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..InPortPersistenceExt

See Also

InPortPersistenceExt Members
DynamicNode.Core Namespace


InPortPersistenceExt Members

[image] [image]

DynamicNodes API
InPortPersistenceExt Members
InPortPersistenceExt Class Constructors Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortPersistenceExt type exposes the following members.

Constructors

 | Name | Description
Public method | InPortPersistenceExt | Initializes a new instance of the InPortPersistenceExt class

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | OnRestore | Wird aufgerufen wenn [restore].
Public method | OnStore | Wird aufgerufen wenn [store].

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


InPortPersistenceExt Constructor

[image]

DynamicNodes API
InPortPersistenceExt Constructor
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the InPortPersistenceExt class

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPortPersistenceExt()
Visual Basic
Public Sub New
F#
new : unit -> InPortPersistenceExt

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


InPortPersistenceExt Fields

[image] [image]

DynamicNodes API
InPortPersistenceExt Fields
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortPersistenceExt type exposes the following members.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


EXT_ID Field

[image]

DynamicNodes API
InPortPersistenceExt..::..EXT_ID Field
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


InPortPersistenceExt Methods

[image] [image]

DynamicNodes API
InPortPersistenceExt Methods
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortPersistenceExt type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | OnRestore | Wird aufgerufen wenn [restore].
Public method | OnStore | Wird aufgerufen wenn [store].

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


AfterAttaching Method

[image]

DynamicNodes API
InPortPersistenceExt..::..AfterAttaching Method
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterAttaching(
    INode g
)
Visual Basic
Public Sub AfterAttaching ( _
    g As INode _
)
F#
abstract AfterAttaching :
        g:INode -> unit
override AfterAttaching :
        g:INode -> unit

Parameters

g
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


AfterDetaching Method

[image]

DynamicNodes API
InPortPersistenceExt..::..AfterDetaching Method
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterDetaching(
    INode o
)
Visual Basic
Public Sub AfterDetaching ( _
    o As INode _
)
F#
abstract AfterDetaching :
        o:INode -> unit
override AfterDetaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


AfterRestoring Method

[image]

DynamicNodes API
InPortPersistenceExt..::..AfterRestoring Method
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
InPortPersistenceExt..::..OnRestore Method
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn [restore].

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader reader
)
Visual Basic
Public Sub OnRestore ( _
    reader As IPropertyReader _
)
F#
abstract OnRestore :
        reader:IPropertyReader -> unit
override OnRestore :
        reader:IPropertyReader -> unit

Parameters

reader
Type: DynamicNode.Persistence..::..IPropertyReader
The reader.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
InPortPersistenceExt..::..OnStore Method
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn [store].

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter writer
)
Visual Basic
Public Sub OnStore ( _
    writer As IPropertyWriter _
)
F#
abstract OnStore :
        writer:IPropertyWriter -> unit
override OnStore :
        writer:IPropertyWriter -> unit

Parameters

writer
Type: DynamicNode.Persistence..::..IPropertyWriter
The writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


InPortPersistenceExt Properties

[image] [image]

DynamicNodes API
InPortPersistenceExt Properties
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortPersistenceExt type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


Id Property

[image]

DynamicNodes API
InPortPersistenceExt..::..Id Property
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


IsUsingStorage Property

[image]

DynamicNodes API
InPortPersistenceExt..::..IsUsingStorage Property
InPortPersistenceExt Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

InPortPersistenceExt Class
DynamicNode.Core Namespace


InPortSingleDataTypeProvider Class

[image]

DynamicNodes API
InPortSingleDataTypeProvider Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt eine einfache Implementierung für IInPortDataTypeProvider zur Verfügung. Dieser Datentypen-Provider verwaltet einen einzelnen Datentyp. Wird dieser verändert, werden alle registrierten Eingänge informiert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class InPortSingleDataTypeProvider : InPortDataTypeProviderBase,
    IExtension<INode>, IStorable
Visual Basic
Public Class InPortSingleDataTypeProvider _
    Inherits InPortDataTypeProviderBase _
    Implements IExtension(Of INode), IStorable
F#
type InPortSingleDataTypeProvider =
    class
        inherit InPortDataTypeProviderBase
        interface IExtension<INode>
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..InPortDataTypeProviderBase
DynamicNode.Core..::..InPortSingleDataTypeProvider

See Also

InPortSingleDataTypeProvider Members
DynamicNode.Core Namespace


InPortSingleDataTypeProvider Members

[image] [image]

DynamicNodes API
InPortSingleDataTypeProvider Members
InPortSingleDataTypeProvider Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortSingleDataTypeProvider type exposes the following members.

Constructors

 | Name | Description
Public method | InPortSingleDataTypeProvider()()()() | Initialisiert eine neue Instanz von InPortSingleDataTypeProvider.
Public method | InPortSingleDataTypeProvider(Type) | Initialisiert eine neue Instanz von InPortSingleDataTypeProvider.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Protected method | OnInPortRegistered | Wird aufgerufen, wenn ein Eingang registriert wurde. (Inherited from InPortDataTypeProviderBase.)
Protected method | OnInPortUnregistered | Wird aufgerufen, wenn ein Eingang deregistriert wurde. (Inherited from InPortDataTypeProviderBase.)
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Protected method | OnSupportedDataTypesChanged | Wird aufgerufen, wenn sich die Liste der unterstützten Typen geändert hat. Löst das Ereignis SupportedDataTypesChanged aus. (Inherited from InPortDataTypeProviderBase.)
Public method | RegisterInPort | Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen. (Inherited from InPortDataTypeProviderBase.)
Public method | UnregisterInPort | Entfernt einen Eingang aus der Verwaltung. (Inherited from InPortDataTypeProviderBase.)

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | SupportedDataType | Der unterstütze Datentyp. Bei Änderung des Datentyps wird das Ereignis SupportedDataTypesChanged ausgelöst und damit alle registrierten Eingänge informiert. Wird null zugewiesen, gibt der Provider eine leere Typenliste zurück und die registrierten Eingänge werden generisch.
Public property | SupportedDataTypes | Gibt die bereitgestellten Datentypen zurück. (Overrides InPortDataTypeProviderBase..::..SupportedDataTypes.)

Events

 | Name | Description
Public event | SupportedDataTypesChanged | Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert. (Inherited from InPortDataTypeProviderBase.)

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


InPortSingleDataTypeProvider Constructor

[image] [image]

DynamicNodes API
InPortSingleDataTypeProvider Constructor
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | InPortSingleDataTypeProvider()()()() | Initialisiert eine neue Instanz von InPortSingleDataTypeProvider.
Public method | InPortSingleDataTypeProvider(Type) | Initialisiert eine neue Instanz von InPortSingleDataTypeProvider.

See Also

InPortSingleDataTypeProvider Class
InPortSingleDataTypeProvider Members
DynamicNode.Core Namespace


InPortSingleDataTypeProvider Constructor

[image]

DynamicNodes API
InPortSingleDataTypeProvider Constructor
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von InPortSingleDataTypeProvider.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPortSingleDataTypeProvider()
Visual Basic
Public Sub New
F#
new : unit -> InPortSingleDataTypeProvider

See Also

InPortSingleDataTypeProvider Class
InPortSingleDataTypeProvider Overload
DynamicNode.Core Namespace


InPortSingleDataTypeProvider Constructor (Type)

[image]

DynamicNodes API
InPortSingleDataTypeProvider Constructor (Type)
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von InPortSingleDataTypeProvider.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPortSingleDataTypeProvider(
    Type type
)
Visual Basic
Public Sub New ( _
    type As Type _
)
F#
new :
        type:Type -> InPortSingleDataTypeProvider

Parameters

type
Type: System..::..Type
Der initiale Datentyp.

See Also

InPortSingleDataTypeProvider Class
InPortSingleDataTypeProvider Overload
DynamicNode.Core Namespace


InPortSingleDataTypeProvider Fields

[image] [image]

DynamicNodes API
InPortSingleDataTypeProvider Fields
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortSingleDataTypeProvider type exposes the following members.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


EXT_ID Field

[image]

DynamicNodes API
InPortSingleDataTypeProvider..::..EXT_ID Field
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


InPortSingleDataTypeProvider Methods

[image] [image]

DynamicNodes API
InPortSingleDataTypeProvider Methods
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortSingleDataTypeProvider type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Protected method | OnInPortRegistered | Wird aufgerufen, wenn ein Eingang registriert wurde. (Inherited from InPortDataTypeProviderBase.)
Protected method | OnInPortUnregistered | Wird aufgerufen, wenn ein Eingang deregistriert wurde. (Inherited from InPortDataTypeProviderBase.)
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Protected method | OnSupportedDataTypesChanged | Wird aufgerufen, wenn sich die Liste der unterstützten Typen geändert hat. Löst das Ereignis SupportedDataTypesChanged aus. (Inherited from InPortDataTypeProviderBase.)
Public method | RegisterInPort | Fügt einen Eingang zur Verwaltung hinzu. Diese Methode wird vom Eingang aufgerufen. (Inherited from InPortDataTypeProviderBase.)
Public method | UnregisterInPort | Entfernt einen Eingang aus der Verwaltung. (Inherited from InPortDataTypeProviderBase.)

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


AfterAttaching Method

[image]

DynamicNodes API
InPortSingleDataTypeProvider..::..AfterAttaching Method
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterAttaching(
    INode g
)
Visual Basic
Public Sub AfterAttaching ( _
    g As INode _
)
F#
abstract AfterAttaching :
        g:INode -> unit
override AfterAttaching :
        g:INode -> unit

Parameters

g
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


AfterDetaching Method

[image]

DynamicNodes API
InPortSingleDataTypeProvider..::..AfterDetaching Method
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterDetaching(
    INode o
)
Visual Basic
Public Sub AfterDetaching ( _
    o As INode _
)
F#
abstract AfterDetaching :
        o:INode -> unit
override AfterDetaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


AfterRestoring Method

[image]

DynamicNodes API
InPortSingleDataTypeProvider..::..AfterRestoring Method
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
InPortSingleDataTypeProvider..::..OnRestore Method
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschafts-Leser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
InPortSingleDataTypeProvider..::..OnStore Method
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschafts-Writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


InPortSingleDataTypeProvider Properties

[image] [image]

DynamicNodes API
InPortSingleDataTypeProvider Properties
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortSingleDataTypeProvider type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | SupportedDataType | Der unterstütze Datentyp. Bei Änderung des Datentyps wird das Ereignis SupportedDataTypesChanged ausgelöst und damit alle registrierten Eingänge informiert. Wird null zugewiesen, gibt der Provider eine leere Typenliste zurück und die registrierten Eingänge werden generisch.
Public property | SupportedDataTypes | Gibt die bereitgestellten Datentypen zurück. (Overrides InPortDataTypeProviderBase..::..SupportedDataTypes.)

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


Id Property

[image]

DynamicNodes API
InPortSingleDataTypeProvider..::..Id Property
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


IsUsingStorage Property

[image]

DynamicNodes API
InPortSingleDataTypeProvider..::..IsUsingStorage Property
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


SupportedDataType Property

[image]

DynamicNodes API
InPortSingleDataTypeProvider..::..SupportedDataType Property
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der unterstütze Datentyp. Bei Änderung des Datentyps wird das Ereignis SupportedDataTypesChanged ausgelöst und damit alle registrierten Eingänge informiert. Wird null zugewiesen, gibt der Provider eine leere Typenliste zurück und die registrierten Eingänge werden generisch.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Type SupportedDataType { get; set; }
Visual Basic
Public Property SupportedDataType As Type
    Get
    Set
F#
member SupportedDataType : Type with get, set

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


SupportedDataTypes Property

[image]

DynamicNodes API
InPortSingleDataTypeProvider..::..SupportedDataTypes Property
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die bereitgestellten Datentypen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override Type[] SupportedDataTypes { get; }
Visual Basic
Public Overrides ReadOnly Property SupportedDataTypes As Type()
    Get
F#
abstract SupportedDataTypes : Type[]
override SupportedDataTypes : Type[]

Field Value

Die aktuellen Datentyp-Liste als Array.

Implements

IInPortDataTypeProvider..::..SupportedDataTypes

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


InPortSingleDataTypeProvider Events

[image] [image]

DynamicNodes API
InPortSingleDataTypeProvider Events
InPortSingleDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortSingleDataTypeProvider type exposes the following members.

Events

 | Name | Description
Public event | SupportedDataTypesChanged | Wird ausgelöst, wenn sich die bereitsgestellte Datentyp-Liste ändert. (Inherited from InPortDataTypeProviderBase.)

See Also

InPortSingleDataTypeProvider Class
DynamicNode.Core Namespace


IOutPortDataTypeProvider Interface

[image]

DynamicNodes API
IOutPortDataTypeProvider Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für Objekte die einen Datentyp für Ausgänge bereitstellen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IOutPortDataTypeProvider
Visual Basic
Public Interface IOutPortDataTypeProvider
F#
type IOutPortDataTypeProvider =  interface end

See Also

IOutPortDataTypeProvider Members
DynamicNode.Core Namespace


IOutPortDataTypeProvider Members

[image] [image]

DynamicNodes API
IOutPortDataTypeProvider Members
IOutPortDataTypeProvider Interface Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IOutPortDataTypeProvider type exposes the following members.

Properties

 | Name | Description
Public property | SupportedDataType | Gibt den bereitgestellten Datentyp zurück.

Events

 | Name | Description
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.

See Also

IOutPortDataTypeProvider Interface
DynamicNode.Core Namespace


IOutPortDataTypeProvider Properties

[image] [image]

DynamicNodes API
IOutPortDataTypeProvider Properties
IOutPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IOutPortDataTypeProvider type exposes the following members.

Properties

 | Name | Description
Public property | SupportedDataType | Gibt den bereitgestellten Datentyp zurück.

See Also

IOutPortDataTypeProvider Interface
DynamicNode.Core Namespace


SupportedDataType Property

[image]

DynamicNodes API
IOutPortDataTypeProvider..::..SupportedDataType Property
IOutPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den bereitgestellten Datentyp zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
Type SupportedDataType { get; }
Visual Basic
ReadOnly Property SupportedDataType As Type
    Get
F#
abstract SupportedDataType : Type

Field Value

Der aktuelle Datentyp, oder null, wenn keiner bereitgestellt wird.

See Also

IOutPortDataTypeProvider Interface
DynamicNode.Core Namespace


IOutPortDataTypeProvider Events

[image] [image]

DynamicNodes API
IOutPortDataTypeProvider Events
IOutPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IOutPortDataTypeProvider type exposes the following members.

Events

 | Name | Description
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.

See Also

IOutPortDataTypeProvider Interface
DynamicNode.Core Namespace


SupportedDataTypeChanged Event

[image]

DynamicNodes API
IOutPortDataTypeProvider..::..SupportedDataTypeChanged Event
IOutPortDataTypeProvider Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler SupportedDataTypeChanged
Visual Basic
Event SupportedDataTypeChanged As EventHandler
F#
abstract SupportedDataTypeChanged : IEvent<EventHandler,
    EventArgs>

See Also

IOutPortDataTypeProvider Interface
DynamicNode.Core Namespace


IPort Interface

[image]

DynamicNodes API
IPort Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für Ports an einem Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IPort : IChild<INode, IPort>,
    IBaseObject, IIdentifiable, IStorable, IExtensible<IPort>,
    IDisposable
Visual Basic
Public Interface IPort _
    Inherits IChild(Of INode, IPort), IBaseObject,  _
    IIdentifiable, IStorable, IExtensible(Of IPort), IDisposable
F#
type IPort =
    interface
        interface IChild<INode, IPort>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
        interface IExtensible<IPort>
        interface IDisposable
    end

See Also

IPort Members
DynamicNode.Core Namespace


IPort Members

[image] [image]

DynamicNodes API
IPort Members
IPort Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPort type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann.
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist.
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört.
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde.
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports.
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert.
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wird. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)

See Also

IPort Interface
DynamicNode.Core Namespace


IPort Methods

[image] [image]

DynamicNodes API
IPort Methods
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPort type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann.
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam.

See Also

IPort Interface
DynamicNode.Core Namespace


GetAddress Method

[image]

DynamicNodes API
IPort..::..GetAddress Method
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Zeichenfolge zurück, welche den Port identifiziert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string GetAddress()
Visual Basic
Function GetAddress As String
F#
abstract GetAddress : unit -> string

Return Value

Eine Port-Adresse.

See Also

IPort Interface
DynamicNode.Core Namespace


IsConnectableTo Method

[image]

DynamicNodes API
IPort..::..IsConnectableTo Method
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob dieser Port mit einem anderem Port verbunden werden kann.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsConnectableTo(
    IPort port,
    out Type possibleTypeSelection
)
Visual Basic
Function IsConnectableTo ( _
    port As IPort, _
    <OutAttribute> ByRef possibleTypeSelection As Type _
) As Boolean
F#
abstract IsConnectableTo :
        port:IPort *
        possibleTypeSelection:Type byref -> bool

Parameters

port
Type: DynamicNode.Core..::..IPort
Der andere Port.
possibleTypeSelection
Type: System..::..Type %
Wird mit dem ausgewählten Datentyp belegt, oder null, wenn der Rückgabewert false ist.

Return Value

true, wenn eine Verbindung mit dem anderen Port möglich ist, sonst false.

See Also

IPort Interface
DynamicNode.Core Namespace


TryConnect Method

[image]

DynamicNodes API
IPort..::..TryConnect Method
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool TryConnect(
    IPort port
)
Visual Basic
Function TryConnect ( _
    port As IPort _
) As Boolean
F#
abstract TryConnect :
        port:IPort -> bool

Parameters

port
Type: DynamicNode.Core..::..IPort
Ein Anschluss.

Return Value

true, wenn die Verbindung aufgebaut werden konnte, sonst false.

See Also

IPort Interface
DynamicNode.Core Namespace


IPort Properties

[image] [image]

DynamicNodes API
IPort Properties
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPort type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist.
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört.
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde.
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports.
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port.

See Also

IPort Interface
DynamicNode.Core Namespace


ConnectionCount Property

[image]

DynamicNodes API
IPort..::..ConnectionCount Property
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller Verbindungen mit diesem Port zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
int ConnectionCount { get; }
Visual Basic
ReadOnly Property ConnectionCount As Integer
    Get
F#
abstract ConnectionCount : int

Field Value

Die Anzahl der Verbindungen.

See Also

IPort Interface
DynamicNode.Core Namespace


IsSuperPort Property

[image]

DynamicNodes API
IPort..::..IsSuperPort Property
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an oder legt fest ob dieser Port ein Super-Port ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsSuperPort { get; set; }
Visual Basic
Property IsSuperPort As Boolean
    Get
    Set
F#
abstract IsSuperPort : bool with get, set

Field Value

true wenn die Instanz ein Super-Port ist, sonst false.

See Also

IPort Interface
DynamicNode.Core Namespace


Node Property

[image]

DynamicNodes API
IPort..::..Node Property
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Knoten zurück, zu dem dieser Port gehört.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
INode Node { get; }
Visual Basic
ReadOnly Property Node As INode
    Get
F#
abstract Node : INode

Field Value

Der Knoten, zu dem dieser Port gehört.

See Also

IPort Interface
DynamicNode.Core Namespace


ReadCopy Property

[image]

DynamicNodes API
IPort..::..ReadCopy Property
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
Token ReadCopy { get; }
Visual Basic
ReadOnly Property ReadCopy As Token
    Get
F#
abstract ReadCopy : Token

Field Value

Die Lese-Kopie des letzten Tokens.

See Also

IPort Interface
DynamicNode.Core Namespace


SuperName Property

[image]

DynamicNodes API
IPort..::..SuperName Property
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die Super-ID für Modul-Ports.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string SuperName { get; set; }
Visual Basic
Property SuperName As String
    Get
    Set
F#
abstract SuperName : string with get, set

Field Value

Die Super-ID.

See Also

IPort Interface
DynamicNode.Core Namespace


SuperSortIndex Property

[image]

DynamicNodes API
IPort..::..SuperSortIndex Property
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Sortier-Index für den Super-Port.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
int SuperSortIndex { get; set; }
Visual Basic
Property SuperSortIndex As Integer
    Get
    Set
F#
abstract SuperSortIndex : int with get, set

Field Value

Eine Ganzzahl, welche die Reihenfolge der Anschlüsse an einem Modul steuert.

See Also

IPort Interface
DynamicNode.Core Namespace


IPort Events

[image] [image]

DynamicNodes API
IPort Events
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPort type exposes the following members.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert.
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wird. (Inherited from IChild<(Of <(<'TParent, TSelf>)>)>.)

See Also

IPort Interface
DynamicNode.Core Namespace


ConnectionChange Event

[image]

DynamicNodes API
IPort..::..ConnectionChange Event
IPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event ConnectionChangedHandler ConnectionChange
Visual Basic
Event ConnectionChange As ConnectionChangedHandler
F#
abstract ConnectionChange : IEvent<ConnectionChangedHandler,
    EventArgs>

See Also

IPort Interface
DynamicNode.Core Namespace


IRuntime Interface

[image]

DynamicNodes API
IRuntime Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für ein Objekt, welches den Kern einer DynamicNodes-Anwendung bildet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IRuntime : IParent<IRuntime, IGraph>,
    IBaseObject, IIdentifiable, IStorable, IExtensible<IRuntime>,
    IDisposable
Visual Basic
Public Interface IRuntime _
    Inherits IParent(Of IRuntime, IGraph), IBaseObject,  _
    IIdentifiable, IStorable, IExtensible(Of IRuntime), IDisposable
F#
type IRuntime =
    interface
        interface IParent<IRuntime, IGraph>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
        interface IExtensible<IRuntime>
        interface IDisposable
    end

See Also

IRuntime Members
DynamicNode.Core Namespace


IRuntime Members

[image] [image]

DynamicNodes API
IRuntime Members
IRuntime Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRuntime type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche die Laufzeitumgebung innerhalb der Application-Domain eindeutig identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)

Properties

 | Name | Description
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Configuration | Gibt die IConfiguration zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public property | Item | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | MsgBus | Gibt den System-Nachrichten-Bus zurück.
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | NodeFactory | Gibt die NodeFactory zurück.
Public property | ThreadManager | Gibt den IThreadManager zurück.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public event | GraphAffected | Wird ausgelöst, wenn bei einer Änderung in der Laufzeitumgebung ein Graph betroffen ist.
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)

See Also

IRuntime Interface
DynamicNode.Core Namespace


IRuntime Methods

[image] [image]

DynamicNodes API
IRuntime Methods
IRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRuntime type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche die Laufzeitumgebung innerhalb der Application-Domain eindeutig identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)

See Also

IRuntime Interface
DynamicNode.Core Namespace


GetAddress Method

[image]

DynamicNodes API
IRuntime..::..GetAddress Method
IRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Zeichenfolge zurück, welche die Laufzeitumgebung innerhalb der Application-Domain eindeutig identifiziert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string GetAddress()
Visual Basic
Function GetAddress As String
F#
abstract GetAddress : unit -> string

Return Value

Eine Adresse.

See Also

IRuntime Interface
DynamicNode.Core Namespace


IRuntime Properties

[image] [image]

DynamicNodes API
IRuntime Properties
IRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRuntime type exposes the following members.

Properties

 | Name | Description
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | Configuration | Gibt die IConfiguration zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public property | Item | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public property | MsgBus | Gibt den System-Nachrichten-Bus zurück.
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | NodeFactory | Gibt die NodeFactory zurück.
Public property | ThreadManager | Gibt den IThreadManager zurück.

See Also

IRuntime Interface
DynamicNode.Core Namespace


Configuration Property

[image]

DynamicNodes API
IRuntime..::..Configuration Property
IRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die IConfiguration zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IConfiguration Configuration { get; }
Visual Basic
ReadOnly Property Configuration As IConfiguration
    Get
F#
abstract Configuration : IConfiguration

Field Value

Die DynamicNodes-System-Konfiguration.

See Also

IRuntime Interface
DynamicNode.Core Namespace


MsgBus Property

[image]

DynamicNodes API
IRuntime..::..MsgBus Property
IRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den System-Nachrichten-Bus zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
MessageBus MsgBus { get; }
Visual Basic
ReadOnly Property MsgBus As MessageBus
    Get
F#
abstract MsgBus : MessageBus

Field Value

Der System-Nachrichten-Bus.

See Also

IRuntime Interface
DynamicNode.Core Namespace


NodeFactory Property

[image]

DynamicNodes API
IRuntime..::..NodeFactory Property
IRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die NodeFactory zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
NodeFactory NodeFactory { get; }
Visual Basic
ReadOnly Property NodeFactory As NodeFactory
    Get
F#
abstract NodeFactory : NodeFactory

Field Value

Der Knoten-Erzeuger.

See Also

IRuntime Interface
DynamicNode.Core Namespace


ThreadManager Property

[image]

DynamicNodes API
IRuntime..::..ThreadManager Property
IRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den IThreadManager zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IThreadManager ThreadManager { get; }
Visual Basic
ReadOnly Property ThreadManager As IThreadManager
    Get
F#
abstract ThreadManager : IThreadManager

Field Value

Der Thread-Manager.

See Also

IRuntime Interface
DynamicNode.Core Namespace


IRuntime Events

[image] [image]

DynamicNodes API
IRuntime Events
IRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRuntime type exposes the following members.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from IParent<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from IExtensible<(Of <(<'T>)>)>.)
Public event | GraphAffected | Wird ausgelöst, wenn bei einer Änderung in der Laufzeitumgebung ein Graph betroffen ist.
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)

See Also

IRuntime Interface
DynamicNode.Core Namespace


GraphAffected Event

[image]

DynamicNodes API
IRuntime..::..GraphAffected Event
IRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn bei einer Änderung in der Laufzeitumgebung ein Graph betroffen ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler<GraphEventArgs> GraphAffected
Visual Basic
Event GraphAffected As EventHandler(Of GraphEventArgs)
F#
abstract GraphAffected : IEvent<EventHandler<GraphEventArgs>,
    GraphEventArgs>

See Also

IRuntime Interface
DynamicNode.Core Namespace


ISingleThreadContext Interface

[image]

DynamicNodes API
ISingleThreadContext Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für Synchronisierungs-Kontexte. Wird für Technologien verwendet, deren Komponenten nur in einem Thread verwendet werden dürfen. Beispiele sind WindowsForms und WPF.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface ISingleThreadContext
Visual Basic
Public Interface ISingleThreadContext
F#
type ISingleThreadContext =  interface end

See Also

ISingleThreadContext Members
DynamicNode.Core Namespace


ISingleThreadContext Members

[image] [image]

DynamicNodes API
ISingleThreadContext Members
ISingleThreadContext Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ISingleThreadContext type exposes the following members.

Methods

 | Name | Description
Public method | Close | Beendet den Synchronisierungskontext.
Public method | InvokeAsync | Führt eine Aufgabe in dem Synchronisierungskontext durch.

Properties

 | Name | Description
Public property | Id | Gibt die ID des Synchronisierungskontexts zurück.

See Also

ISingleThreadContext Interface
DynamicNode.Core Namespace


ISingleThreadContext Methods

[image] [image]

DynamicNodes API
ISingleThreadContext Methods
ISingleThreadContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ISingleThreadContext type exposes the following members.

Methods

 | Name | Description
Public method | Close | Beendet den Synchronisierungskontext.
Public method | InvokeAsync | Führt eine Aufgabe in dem Synchronisierungskontext durch.

See Also

ISingleThreadContext Interface
DynamicNode.Core Namespace


Close Method

[image]

DynamicNodes API
ISingleThreadContext..::..Close Method
ISingleThreadContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beendet den Synchronisierungskontext.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void Close()
Visual Basic
Sub Close
F#
abstract Close : unit -> unit

See Also

ISingleThreadContext Interface
DynamicNode.Core Namespace


InvokeAsync Method

[image]

DynamicNodes API
ISingleThreadContext..::..InvokeAsync Method
ISingleThreadContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Aufgabe in dem Synchronisierungskontext durch.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void InvokeAsync(
    ThreadStart task
)
Visual Basic
Sub InvokeAsync ( _
    task As ThreadStart _
)
F#
abstract InvokeAsync :
        task:ThreadStart -> unit

Parameters

task
Type: System.Threading..::..ThreadStart
Die Aufgabe.

See Also

ISingleThreadContext Interface
DynamicNode.Core Namespace


ISingleThreadContext Properties

[image] [image]

DynamicNodes API
ISingleThreadContext Properties
ISingleThreadContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ISingleThreadContext type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt die ID des Synchronisierungskontexts zurück.

See Also

ISingleThreadContext Interface
DynamicNode.Core Namespace


Id Property

[image]

DynamicNodes API
ISingleThreadContext..::..Id Property
ISingleThreadContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Synchronisierungskontexts zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string Id { get; }
Visual Basic
ReadOnly Property Id As String
    Get
F#
abstract Id : string

Field Value

Die ID des Synchronisierungskontexts.

See Also

ISingleThreadContext Interface
DynamicNode.Core Namespace


IThreadManager Interface

[image]

DynamicNodes API
IThreadManager Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Interface eines Thread-Managers, der nebenläufige Aufgaben erzeugen, synchronisieren und abbrechen kann.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IThreadManager : IStorable,
    IDisposable
Visual Basic
Public Interface IThreadManager _
    Inherits IStorable, IDisposable
F#
type IThreadManager =
    interface
        interface IStorable
        interface IDisposable
    end

See Also

IThreadManager Members
DynamicNode.Core Namespace


IThreadManager Members

[image] [image]

DynamicNodes API
IThreadManager Members
IThreadManager Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IThreadManager type exposes the following members.

Methods

 | Name | Description
Public method | AbortAllTasks | Bricht die Ausführung aller Aufgaben ab.
Public method | GetNewTaskId | Gibt eine neue eindeutige Task-ID zurück.
Public method | IsTaskRunning | Prüft, ob eine Aufgabe mit der übergebenen Task-ID ausgeführt wird oder auf ihre Ausführung wartet.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | RegisterSingleThreadContext | Registriert einen Synchronisierungskontext für die Ausführung von Aufgaben in Single-Thread-Objekt-Modellen.
Public method | RunTask | Führt ein ThreadStart-Delegate nebenläufig aus.
Public method | RunTaskSingleThreaded | Führt ein ThreadStart-Delegate mit einem einzigen Thread aus.
Public method | SupportsSingleThreadContext | Gibt true zurück, wenn es Synchronisierungskontext mit der übergebenen ID registriert wurde.

Properties

 | Name | Description
Public property | ActiveThreadCount | Gibt die Anzahl der aktiven Threads zurück.
Public property | MaxThreadCount | Liest oder schreibt die maximale Anzahl an nebenläufigen Threads.
Public property | UseMultiThreading | Liest oder Schreibt einen Wert, der angibt ob Parallelverarbeitung aktiv ist.

Events

 | Name | Description
Public event | TaskAbort | Wird ausgelöst, wenn eine Aufgabe abgebrochen wurde.
Public event | TaskEnd | Wird ausgelöst, wenn eine Aufgabe beendet wurde.
Public event | TaskStart | Wird ausgelöst, wenn eine Aufgabe gestartet wurde.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


IThreadManager Methods

[image] [image]

DynamicNodes API
IThreadManager Methods
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IThreadManager type exposes the following members.

Methods

 | Name | Description
Public method | AbortAllTasks | Bricht die Ausführung aller Aufgaben ab.
Public method | GetNewTaskId | Gibt eine neue eindeutige Task-ID zurück.
Public method | IsTaskRunning | Prüft, ob eine Aufgabe mit der übergebenen Task-ID ausgeführt wird oder auf ihre Ausführung wartet.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | RegisterSingleThreadContext | Registriert einen Synchronisierungskontext für die Ausführung von Aufgaben in Single-Thread-Objekt-Modellen.
Public method | RunTask | Führt ein ThreadStart-Delegate nebenläufig aus.
Public method | RunTaskSingleThreaded | Führt ein ThreadStart-Delegate mit einem einzigen Thread aus.
Public method | SupportsSingleThreadContext | Gibt true zurück, wenn es Synchronisierungskontext mit der übergebenen ID registriert wurde.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


AbortAllTasks Method

[image]

DynamicNodes API
IThreadManager..::..AbortAllTasks Method
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bricht die Ausführung aller Aufgaben ab.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void AbortAllTasks()
Visual Basic
Sub AbortAllTasks
F#
abstract AbortAllTasks : unit -> unit

See Also

IThreadManager Interface
DynamicNode.Core Namespace


GetNewTaskId Method

[image]

DynamicNodes API
IThreadManager..::..GetNewTaskId Method
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine neue eindeutige Task-ID zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string GetNewTaskId()
Visual Basic
Function GetNewTaskId As String
F#
abstract GetNewTaskId : unit -> string

Return Value

Eine Task-ID.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


IsTaskRunning Method

[image]

DynamicNodes API
IThreadManager..::..IsTaskRunning Method
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob eine Aufgabe mit der übergebenen Task-ID ausgeführt wird oder auf ihre Ausführung wartet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsTaskRunning(
    string taskId
)
Visual Basic
Function IsTaskRunning ( _
    taskId As String _
) As Boolean
F#
abstract IsTaskRunning :
        taskId:string -> bool

Parameters

taskId
Type: System..::..String
Die Task-ID.

Return Value

true wenn die Aufgabe wartet oder ausgeführt wird; sonst, false.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


RegisterSingleThreadContext Method

[image]

DynamicNodes API
IThreadManager..::..RegisterSingleThreadContext Method
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert einen Synchronisierungskontext für die Ausführung von Aufgaben in Single-Thread-Objekt-Modellen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void RegisterSingleThreadContext(
    ISingleThreadContext context
)
Visual Basic
Sub RegisterSingleThreadContext ( _
    context As ISingleThreadContext _
)
F#
abstract RegisterSingleThreadContext :
        context:ISingleThreadContext -> unit

Parameters

context
Type: DynamicNode.Core..::..ISingleThreadContext
Der Synchronisierungskontext.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


RunTask Method

[image]

DynamicNodes API
IThreadManager..::..RunTask Method
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Führt ein ThreadStart-Delegate nebenläufig aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void RunTask(
    string taskId,
    ThreadStart task
)
Visual Basic
Sub RunTask ( _
    taskId As String, _
    task As ThreadStart _
)
F#
abstract RunTask :
        taskId:string *
        task:ThreadStart -> unit

Parameters

taskId
Type: System..::..String
Die Task-ID zur Kennzeichnung der neuen Aufgabe.
task
Type: System.Threading..::..ThreadStart
Das Delegate, welches nebenläufig ausgeführt werden soll.

Remarks

Wenn ein Thread mit der übergebenen Task-ID gerade ausgeführt wird, oder auf seine Ausführung wartet, wird dieser abgebrochen, bzw. nicht gestartet.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


RunTaskSingleThreaded Method

[image]

DynamicNodes API
IThreadManager..::..RunTaskSingleThreaded Method
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt ein ThreadStart-Delegate mit einem einzigen Thread aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void RunTaskSingleThreaded(
    string taskId,
    string syncContext,
    ThreadStart task
)
Visual Basic
Sub RunTaskSingleThreaded ( _
    taskId As String, _
    syncContext As String, _
    task As ThreadStart _
)
F#
abstract RunTaskSingleThreaded :
        taskId:string *
        syncContext:string *
        task:ThreadStart -> unit

Parameters

taskId
Type: System..::..String
Die Task-ID zur Kennzeichnung der neuen Aufgabe.
syncContext
Type: System..::..String
Die ID des Synchronisierungskontextes.
task
Type: System.Threading..::..ThreadStart
Das Delegate, welches ausgeführt werden soll.

Remarks

Wenn eine Aufgabe mit der übergebenen Task-ID gerade ausgeführt wird, oder auf seine Ausführung wartet, wird dieser abgebrochen, bzw. nicht gestartet.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


SupportsSingleThreadContext Method

[image]

DynamicNodes API
IThreadManager..::..SupportsSingleThreadContext Method
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt true zurück, wenn es Synchronisierungskontext mit der übergebenen ID registriert wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool SupportsSingleThreadContext(
    string id
)
Visual Basic
Function SupportsSingleThreadContext ( _
    id As String _
) As Boolean
F#
abstract SupportsSingleThreadContext :
        id:string -> bool

Parameters

id
Type: System..::..String
Die ID des Synchronisierungskontextes.

Return Value

true, wenn der übergebene Sysnchronisierungskontext unterstützt wird, sonst false.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


IThreadManager Properties

[image] [image]

DynamicNodes API
IThreadManager Properties
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IThreadManager type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThreadCount | Gibt die Anzahl der aktiven Threads zurück.
Public property | MaxThreadCount | Liest oder schreibt die maximale Anzahl an nebenläufigen Threads.
Public property | UseMultiThreading | Liest oder Schreibt einen Wert, der angibt ob Parallelverarbeitung aktiv ist.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


ActiveThreadCount Property

[image]

DynamicNodes API
IThreadManager..::..ActiveThreadCount Property
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der aktiven Threads zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
int ActiveThreadCount { get; }
Visual Basic
ReadOnly Property ActiveThreadCount As Integer
    Get
F#
abstract ActiveThreadCount : int

Field Value

Anzahl der aktiven Threads

See Also

IThreadManager Interface
DynamicNode.Core Namespace


MaxThreadCount Property

[image]

DynamicNodes API
IThreadManager..::..MaxThreadCount Property
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die maximale Anzahl an nebenläufigen Threads.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
int MaxThreadCount { get; set; }
Visual Basic
Property MaxThreadCount As Integer
    Get
    Set
F#
abstract MaxThreadCount : int with get, set

Field Value

Die maximale Nebenläufigkeit.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


UseMultiThreading Property

[image]

DynamicNodes API
IThreadManager..::..UseMultiThreading Property
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder Schreibt einen Wert, der angibt ob Parallelverarbeitung aktiv ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool UseMultiThreading { get; set; }
Visual Basic
Property UseMultiThreading As Boolean
    Get
    Set
F#
abstract UseMultiThreading : bool with get, set

Field Value

true wenn Parallelverarbeitung aktiv ist; sonst, false.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


IThreadManager Events

[image] [image]

DynamicNodes API
IThreadManager Events
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IThreadManager type exposes the following members.

Events

 | Name | Description
Public event | TaskAbort | Wird ausgelöst, wenn eine Aufgabe abgebrochen wurde.
Public event | TaskEnd | Wird ausgelöst, wenn eine Aufgabe beendet wurde.
Public event | TaskStart | Wird ausgelöst, wenn eine Aufgabe gestartet wurde.

See Also

IThreadManager Interface
DynamicNode.Core Namespace


TaskAbort Event

[image]

DynamicNodes API
IThreadManager..::..TaskAbort Event
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine Aufgabe abgebrochen wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler<TaskEventArgs> TaskAbort
Visual Basic
Event TaskAbort As EventHandler(Of TaskEventArgs)
F#
abstract TaskAbort : IEvent<EventHandler<TaskEventArgs>,
    TaskEventArgs>

See Also

IThreadManager Interface
DynamicNode.Core Namespace


TaskEnd Event

[image]

DynamicNodes API
IThreadManager..::..TaskEnd Event
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine Aufgabe beendet wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler<TaskEventArgs> TaskEnd
Visual Basic
Event TaskEnd As EventHandler(Of TaskEventArgs)
F#
abstract TaskEnd : IEvent<EventHandler<TaskEventArgs>,
    TaskEventArgs>

See Also

IThreadManager Interface
DynamicNode.Core Namespace


TaskStart Event

[image]

DynamicNodes API
IThreadManager..::..TaskStart Event
IThreadManager Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine Aufgabe gestartet wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler<TaskEventArgs> TaskStart
Visual Basic
Event TaskStart As EventHandler(Of TaskEventArgs)
F#
abstract TaskStart : IEvent<EventHandler<TaskEventArgs>,
    TaskEventArgs>

See Also

IThreadManager Interface
DynamicNode.Core Namespace


ITypeConverter Interface

[image]

DynamicNodes API
ITypeConverter Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für Datentyp-Konverter. Diese Schnittstelle wird durch den automatischen Datentyp-Konvertierungsmechanismus für Token-Werte verwendet. Durch diesen Mechanismus wird die Datentyp- Kompatibilität zwischen Knoten erhöht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface ITypeConverter
Visual Basic
Public Interface ITypeConverter
F#
type ITypeConverter =  interface end

See Also

ITypeConverter Members
DynamicNode.Core Namespace


ITypeConverter Members

[image] [image]

DynamicNodes API
ITypeConverter Members
ITypeConverter Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ITypeConverter type exposes the following members.

Methods

 | Name | Description
Public method | CheckSupport | Prüft ob der Konverter eine Umwandlung von einen Datentyp in einen anderen unterstützt.
Public method | DoConversion | Führt eine Umwandlung eines Objektes in einen Zieldatentyp durch.

See Also

ITypeConverter Interface
DynamicNode.Core Namespace


ITypeConverter Methods

[image] [image]

DynamicNodes API
ITypeConverter Methods
ITypeConverter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ITypeConverter type exposes the following members.

Methods

 | Name | Description
Public method | CheckSupport | Prüft ob der Konverter eine Umwandlung von einen Datentyp in einen anderen unterstützt.
Public method | DoConversion | Führt eine Umwandlung eines Objektes in einen Zieldatentyp durch.

See Also

ITypeConverter Interface
DynamicNode.Core Namespace


CheckSupport Method

[image]

DynamicNodes API
ITypeConverter..::..CheckSupport Method
ITypeConverter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob der Konverter eine Umwandlung von einen Datentyp in einen anderen unterstützt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool CheckSupport(
    Type to,
    Type from
)
Visual Basic
Function CheckSupport ( _
    to As Type, _
    from As Type _
) As Boolean
F#
abstract CheckSupport :
        to:Type *
        from:Type -> bool

Parameters

to
Type: System..::..Type
Der Zieldatentyp.
from
Type: System..::..Type
Der Ursprungsdatentyp.

Return Value

Gibt true zurück, wenn dieser Konverter eine Umwandlung von from nach to unterstützt, sonst false.

See Also

ITypeConverter Interface
DynamicNode.Core Namespace


DoConversion Method

[image]

DynamicNodes API
ITypeConverter..::..DoConversion Method
ITypeConverter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Umwandlung eines Objektes in einen Zieldatentyp durch.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
Object DoConversion(
    Object o,
    Type to
)
Visual Basic
Function DoConversion ( _
    o As Object, _
    to As Type _
) As Object
F#
abstract DoConversion :
        o:Object *
        to:Type -> Object

Parameters

o
Type: System..::..Object
Ein Objekt.
to
Type: System..::..Type
Der Zieldatentyp.

Return Value

Das Ergebnis der Umwandlung.

Exceptions

Exception | Condition
System..::..NotSupportedException | Wenn die Umwandlung nicht unterstützt wird.

See Also

ITypeConverter Interface
DynamicNode.Core Namespace


LogTools Class

[image]

DynamicNodes API
LogTools Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Sammlung von Funktionen, welche die Formatierung von System-Nachrichten erleichtern.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static class LogTools
Visual Basic
Public NotInheritable Class LogTools
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LogTools =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..LogTools

See Also

LogTools Members
DynamicNode.Core Namespace


LogTools Members

[image] [image]

DynamicNodes API
LogTools Members
LogTools Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The LogTools type exposes the following members.

Methods

Name | Description
Format(Assembly) | Formatiert die Ausgabe eines Assembly als: Assembly: <assembly.FullName>
Format(IGraph) | Formatiert die Ausgabe eines Graphen als: Graph: <graph.ToString()>
Format(IExtension<(Of <<'(IGraph>)>>)) | Formatiert die Ausgabe einer Grapherweiterung als: Grapherweiterung: <ext.ToString()>
Format(INode) | Formatiert die Ausgabe eines Knotens als: Knoten: <node.ToString()>
Format(IExtension<(Of <<'(INode>)>>)) | Formatiert die Ausgabe einer Knotenerweiterung als: Knotenerweiterung: <ext.ToString()>
Location | Erzeugt eine Positionsbeschreibung der aufrufenden Methode im Quelltext.

See Also

LogTools Class
DynamicNode.Core Namespace


LogTools Methods

[image] [image]

DynamicNodes API
LogTools Methods
LogTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The LogTools type exposes the following members.

Methods

Name | Description
Format(Assembly) | Formatiert die Ausgabe eines Assembly als: Assembly: <assembly.FullName>
Format(IGraph) | Formatiert die Ausgabe eines Graphen als: Graph: <graph.ToString()>
Format(IExtension<(Of <<'(IGraph>)>>)) | Formatiert die Ausgabe einer Grapherweiterung als: Grapherweiterung: <ext.ToString()>
Format(INode) | Formatiert die Ausgabe eines Knotens als: Knoten: <node.ToString()>
Format(IExtension<(Of <<'(INode>)>>)) | Formatiert die Ausgabe einer Knotenerweiterung als: Knotenerweiterung: <ext.ToString()>
Location | Erzeugt eine Positionsbeschreibung der aufrufenden Methode im Quelltext.

See Also

LogTools Class
DynamicNode.Core Namespace


Format Method

[image] [image]

DynamicNodes API
LogTools..::..Format Method
LogTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Format(Assembly) | Formatiert die Ausgabe eines Assembly als: Assembly: <assembly.FullName>
Format(IGraph) | Formatiert die Ausgabe eines Graphen als: Graph: <graph.ToString()>
Format(IExtension<(Of <<'(IGraph>)>>)) | Formatiert die Ausgabe einer Grapherweiterung als: Grapherweiterung: <ext.ToString()>
Format(INode) | Formatiert die Ausgabe eines Knotens als: Knoten: <node.ToString()>
Format(IExtension<(Of <<'(INode>)>>)) | Formatiert die Ausgabe einer Knotenerweiterung als: Knotenerweiterung: <ext.ToString()>

See Also

LogTools Class
LogTools Members
DynamicNode.Core Namespace


Format Method (Assembly)

[image]

DynamicNodes API
LogTools..::..Format Method (Assembly)
LogTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Formatiert die Ausgabe eines Assembly als: Assembly: <assembly.FullName>

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string Format(
    Assembly assembly
)
Visual Basic
Public Shared Function Format ( _
    assembly As Assembly _
) As String
F#
static member Format :
        assembly:Assembly -> string

Parameters

assembly
Type: System.Reflection..::..Assembly
Ein Assembly, welches beschrieben werden soll.

Return Value

Eine Zeichenkette, welche das Assembly beschreibt.

See Also

LogTools Class
Format Overload
DynamicNode.Core Namespace


Format Method (IGraph)

[image]

DynamicNodes API
LogTools..::..Format Method (IGraph)
LogTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Formatiert die Ausgabe eines Graphen als: Graph: <graph.ToString()>

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string Format(
    IGraph graph
)
Visual Basic
Public Shared Function Format ( _
    graph As IGraph _
) As String
F#
static member Format :
        graph:IGraph -> string

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Ein Graph, welches beschrieben werden soll.

Return Value

Eine Zeichenkette, welche der Graph beschreibt.

See Also

LogTools Class
Format Overload
DynamicNode.Core Namespace


Format Method (IExtension(IGraph))

[image]

DynamicNodes API
LogTools..::..Format Method (IExtension<(Of <(<'IGraph>)>)>)
LogTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Formatiert die Ausgabe einer Grapherweiterung als: Grapherweiterung: <ext.ToString()>

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string Format(
    IExtension<IGraph> ext
)
Visual Basic
Public Shared Function Format ( _
    ext As IExtension(Of IGraph) _
) As String
F#
static member Format :
        ext:IExtension<IGraph> -> string

Parameters

ext
Type: DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>
Eine Erweiterung, welche beschrieben werden soll.

Return Value

Eine Zeichenkette, welche die Erweitreung beschreibt.

See Also

LogTools Class
Format Overload
DynamicNode.Core Namespace


Format Method (INode)

[image]

DynamicNodes API
LogTools..::..Format Method (INode)
LogTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Formatiert die Ausgabe eines Knotens als: Knoten: <node.ToString()>

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string Format(
    INode node
)
Visual Basic
Public Shared Function Format ( _
    node As INode _
) As String
F#
static member Format :
        node:INode -> string

Parameters

node
Type: DynamicNode.Core..::..INode
Ein Knoten, welcher beschrieben werden soll.

Return Value

Eine Zeichenkette, welche den Knoten beschreibt.

See Also

LogTools Class
Format Overload
DynamicNode.Core Namespace


Format Method (IExtension(INode))

[image]

DynamicNodes API
LogTools..::..Format Method (IExtension<(Of <(<'INode>)>)>)
LogTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Formatiert die Ausgabe einer Knotenerweiterung als: Knotenerweiterung: <ext.ToString()>

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string Format(
    IExtension<INode> ext
)
Visual Basic
Public Shared Function Format ( _
    ext As IExtension(Of INode) _
) As String
F#
static member Format :
        ext:IExtension<INode> -> string

Parameters

ext
Type: DynamicNode.Model..::..IExtension <(Of <(<' INode >)>)>
Eine Erweiterung, welche beschrieben werden soll.

Return Value

Eine Zeichenkette, welche die Erweitreung beschreibt.

See Also

LogTools Class
Format Overload
DynamicNode.Core Namespace


Location Method

[image]

DynamicNodes API
LogTools..::..Location Method
LogTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine Positionsbeschreibung der aufrufenden Methode im Quelltext.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string Location(
    int depth,
    bool lineNumber
)
Visual Basic
Public Shared Function Location ( _
    depth As Integer, _
    lineNumber As Boolean _
) As String
F#
static member Location :
        depth:int *
        lineNumber:bool -> string

Parameters

depth
Type: System..::..Int32
Die Anzahl der Stackrahmen, die ignoriert werden sollen.
lineNumber
Type: System..::..Boolean
Wenn true wird versucht die Zeilennummer zu ermitteln.

Return Value

Eine Zeichenkette, welche die Position im Quelltext beschreibt.

See Also

LogTools Class
DynamicNode.Core Namespace


MappingOutPortDataTypeProvider Class

[image]

DynamicNodes API
MappingOutPortDataTypeProvider Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Provider für den Datentyp eines Ausgangs, der den Datentyp in Abhängigkeit von einem Eingang und einem Dictionary ermittelt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class MappingOutPortDataTypeProvider : IOutPortDataTypeProvider
Visual Basic
Public Class MappingOutPortDataTypeProvider _
    Implements IOutPortDataTypeProvider
F#
type MappingOutPortDataTypeProvider =
    class
        interface IOutPortDataTypeProvider
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..MappingOutPortDataTypeProvider

See Also

MappingOutPortDataTypeProvider Members
DynamicNode.Core Namespace


MappingOutPortDataTypeProvider Members

[image] [image]

DynamicNodes API
MappingOutPortDataTypeProvider Members
MappingOutPortDataTypeProvider Class Constructors Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MappingOutPortDataTypeProvider type exposes the following members.

Constructors

 | Name | Description
Public method | MappingOutPortDataTypeProvider | Initialisiert eine Instanz der Klasse MappingOutPortDataTypeProvider.

Properties

 | Name | Description
Public property | SupportedDataType | Gibt den bereitgestellten Datentyp zurück.

Events

 | Name | Description
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.

See Also

MappingOutPortDataTypeProvider Class
DynamicNode.Core Namespace


MappingOutPortDataTypeProvider Constructor

[image]

DynamicNodes API
MappingOutPortDataTypeProvider Constructor
MappingOutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Instanz der Klasse MappingOutPortDataTypeProvider.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public MappingOutPortDataTypeProvider(
    InPort ip,
    IDictionary<Type, Type> mapping
)
Visual Basic
Public Sub New ( _
    ip As InPort, _
    mapping As IDictionary(Of Type, Type) _
)
F#
new :
        ip:InPort *
        mapping:IDictionary<Type, Type> -> MappingOutPortDataTypeProvider

Parameters

ip
Type: DynamicNode.Core..::..InPort
Der Eingang von dem der Typ für den Ausgang abgeleitet werden soll.
mapping
Type: System.Collections.Generic..::..IDictionary <(Of <(<' Type, Type >)>)>
Das Typen-Mapping vom Eingang auf den Ausgang.

See Also

MappingOutPortDataTypeProvider Class
DynamicNode.Core Namespace


MappingOutPortDataTypeProvider Properties

[image] [image]

DynamicNodes API
MappingOutPortDataTypeProvider Properties
MappingOutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MappingOutPortDataTypeProvider type exposes the following members.

Properties

 | Name | Description
Public property | SupportedDataType | Gibt den bereitgestellten Datentyp zurück.

See Also

MappingOutPortDataTypeProvider Class
DynamicNode.Core Namespace


SupportedDataType Property

[image]

DynamicNodes API
MappingOutPortDataTypeProvider..::..SupportedDataType Property
MappingOutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den bereitgestellten Datentyp zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Type SupportedDataType { get; private set; }
Visual Basic
Public Property SupportedDataType As Type
    Get
    Private Set
F#
abstract SupportedDataType : Type with get, private set
override SupportedDataType : Type with get, private set

Field Value

Der aktuelle Datentyp, oder null, wenn keiner bereitgestellt wird.

Implements

IOutPortDataTypeProvider..::..SupportedDataType

See Also

MappingOutPortDataTypeProvider Class
DynamicNode.Core Namespace


MappingOutPortDataTypeProvider Events

[image] [image]

DynamicNodes API
MappingOutPortDataTypeProvider Events
MappingOutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MappingOutPortDataTypeProvider type exposes the following members.

Events

 | Name | Description
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.

See Also

MappingOutPortDataTypeProvider Class
DynamicNode.Core Namespace


SupportedDataTypeChanged Event

[image]

DynamicNodes API
MappingOutPortDataTypeProvider..::..SupportedDataTypeChanged Event
MappingOutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler SupportedDataTypeChanged
Visual Basic
Public Event SupportedDataTypeChanged As EventHandler
F#
abstract SupportedDataTypeChanged : IEvent<EventHandler,
    EventArgs>
override SupportedDataTypeChanged : IEvent<EventHandler,
    EventArgs>

Implements

IOutPortDataTypeProvider..::..SupportedDataTypeChanged

See Also

MappingOutPortDataTypeProvider Class
DynamicNode.Core Namespace


Message Structure

[image]

DynamicNodes API
Message Structure
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine DynamicNodes-System-Nachricht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
[SerializableAttribute]
public struct Message
Visual Basic
<SerializableAttribute> _
Public Structure Message
F#
[<SealedAttribute>]
[<SerializableAttribute>]
type Message =  struct end

See Also

Message Members
DynamicNode.Core Namespace


Message Members

[image] [image]

DynamicNodes API
Message Members
Message Structure Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Message type exposes the following members.

Constructors

 | Name | Description
Public method | Message(TraceEventType, String, Int32, String) | Initialisiert eine Message-Instanz.
Public method | Message(TraceEventType, String, Int32, String, array<Object>[]()[][]) | Initialisiert eine Message-Instanz.
Public method | Message(TraceEventType, String, Int32, String, String, array<Object>[]()[][]) | Initialisiert eine Message-Instanz.

Properties

 | Name | Description
Public property | Data | Zusätzliche Objekte.
Public property | Id | Die Quelle der Nachricht.
Public property | Location | Der Nachrichtenursprung.
Public property | Source | Die Quelle der Nachricht.
Public property | Text | Der Nachrichtentext.
Public property | Time | Der Zeitpunkt in dem die Nachricht erzeugt wurde
Public property | Typ | Der Nachrichtentyp.

See Also

Message Structure
DynamicNode.Core Namespace


Message Constructor

[image] [image]

DynamicNodes API
Message Constructor
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Message(TraceEventType, String, Int32, String) | Initialisiert eine Message-Instanz.
Public method | Message(TraceEventType, String, Int32, String, array<Object>[]()[][]) | Initialisiert eine Message-Instanz.
Public method | Message(TraceEventType, String, Int32, String, String, array<Object>[]()[][]) | Initialisiert eine Message-Instanz.

See Also

Message Structure
Message Members
DynamicNode.Core Namespace


Message Constructor (TraceEventType, String, Int32, String)

[image]

DynamicNodes API
Message Constructor (TraceEventType, String, Int32, String)
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Message-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Message(
    TraceEventType typ,
    string source,
    int id,
    string text
)
Visual Basic
Public Sub New ( _
    typ As TraceEventType, _
    source As String, _
    id As Integer, _
    text As String _
)
F#
new :
        typ:TraceEventType *
        source:string *
        id:int *
        text:string -> Message

Parameters

typ
Type: System.Diagnostics..::..TraceEventType
Der Nachrichtentyp.
source
Type: System..::..String
Die Quelle der Nachricht.
id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Nachrichtentext.

See Also

Message Structure
Message Overload
DynamicNode.Core Namespace


Message Constructor (TraceEventType, String, Int32, String, Object[])

[image]

DynamicNodes API
Message Constructor (TraceEventType, String, Int32, String, array<Object>[]()[][])
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Message-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Message(
    TraceEventType typ,
    string source,
    int id,
    string text,
    params Object[] data
)
Visual Basic
Public Sub New ( _
    typ As TraceEventType, _
    source As String, _
    id As Integer, _
    text As String, _
    ParamArray data As Object() _
)
F#
new :
        typ:TraceEventType *
        source:string *
        id:int *
        text:string *
        data:Object[] -> Message

Parameters

typ
Type: System.Diagnostics..::..TraceEventType
Der Nachrichtentyp.
source
Type: System..::..String
Die Quelle der Nachricht.
id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Nachrichtentext.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Objekte, welche die Nachricht näher beschreiben.

See Also

Message Structure
Message Overload
DynamicNode.Core Namespace


Message Constructor (TraceEventType, String, Int32, String, String, Object[])

[image]

DynamicNodes API
Message Constructor (TraceEventType, String, Int32, String, String, array<Object>[]()[][])
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Message-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Message(
    TraceEventType typ,
    string source,
    int id,
    string text,
    string location,
    params Object[] data
)
Visual Basic
Public Sub New ( _
    typ As TraceEventType, _
    source As String, _
    id As Integer, _
    text As String, _
    location As String, _
    ParamArray data As Object() _
)
F#
new :
        typ:TraceEventType *
        source:string *
        id:int *
        text:string *
        location:string *
        data:Object[] -> Message

Parameters

typ
Type: System.Diagnostics..::..TraceEventType
Der Nachrichtentyp.
source
Type: System..::..String
Die Quelle der Nachricht.
id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Nachrichtentext.
location
Type: System..::..String
Der Ort des Fehlers.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Objekte, welche die Nachricht näher beschreiben.

See Also

Message Structure
Message Overload
DynamicNode.Core Namespace


Message Properties

[image] [image]

DynamicNodes API
Message Properties
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Message type exposes the following members.

Properties

 | Name | Description
Public property | Data | Zusätzliche Objekte.
Public property | Id | Die Quelle der Nachricht.
Public property | Location | Der Nachrichtenursprung.
Public property | Source | Die Quelle der Nachricht.
Public property | Text | Der Nachrichtentext.
Public property | Time | Der Zeitpunkt in dem die Nachricht erzeugt wurde
Public property | Typ | Der Nachrichtentyp.

See Also

Message Structure
DynamicNode.Core Namespace


Data Property

[image]

DynamicNodes API
Message..::..Data Property
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zusätzliche Objekte.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Object[] Data { get; }
Visual Basic
Public ReadOnly Property Data As Object()
    Get
F#
member Data : Object[]

See Also

Message Structure
DynamicNode.Core Namespace


Id Property

[image]

DynamicNodes API
Message..::..Id Property
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Quelle der Nachricht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
F#
member Id : int

See Also

Message Structure
DynamicNode.Core Namespace


Location Property

[image]

DynamicNodes API
Message..::..Location Property
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Nachrichtenursprung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Location { get; set; }
Visual Basic
Public Property Location As String
    Get
    Set
F#
member Location : string with get, set

See Also

Message Structure
DynamicNode.Core Namespace


Source Property

[image]

DynamicNodes API
Message..::..Source Property
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Quelle der Nachricht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Source { get; }
Visual Basic
Public ReadOnly Property Source As String
    Get
F#
member Source : string

See Also

Message Structure
DynamicNode.Core Namespace


Text Property

[image]

DynamicNodes API
Message..::..Text Property
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Nachrichtentext.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
F#
member Text : string

See Also

Message Structure
DynamicNode.Core Namespace


Time Property

[image]

DynamicNodes API
Message..::..Time Property
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Zeitpunkt in dem die Nachricht erzeugt wurde

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public DateTime Time { get; }
Visual Basic
Public ReadOnly Property Time As DateTime
    Get
F#
member Time : DateTime

See Also

Message Structure
DynamicNode.Core Namespace


Typ Property

[image]

DynamicNodes API
Message..::..Typ Property
Message Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Nachrichtentyp.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TraceEventType Typ { get; }
Visual Basic
Public ReadOnly Property Typ As TraceEventType
    Get
F#
member Typ : TraceEventType

See Also

Message Structure
DynamicNode.Core Namespace


MessageBus Class

[image]

DynamicNodes API
MessageBus Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Standard-Nachrichten-Bus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class MessageBus : IStorable, IDisposable
Visual Basic
Public Class MessageBus _
    Implements IStorable, IDisposable
F#
type MessageBus =
    class
        interface IStorable
        interface IDisposable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..MessageBus

See Also

MessageBus Members
DynamicNode.Core Namespace


MessageBus Members

[image] [image]

DynamicNodes API
MessageBus Members
MessageBus Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MessageBus type exposes the following members.

Constructors

 | Name | Description
Public method | MessageBus | Initialisiert eine neue Instanz von MessageBus.

Methods

 | Name | Description
Public method | AtachToTraceSource | Hängt den Nachrichtenbus an eine TraceSource an.
Public method | ClearHistory | Löscht die History der Nachrichten.
Public method | DetachFromTraceSource | Löst den Nachrichtenbus von einer TraceSource.
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.
Protected method | Finalize | Gibt Ressourcen frei, die vom Nachrichtenbus reserviert wurden, wenn der GC dieses Objekt zerstört. (Overrides Object..::..Finalize()()()().)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Public method | Send(Message) | Löst das Ereignis Message aus.
Public method | Send(TraceEventType, String, Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message aus.
Public method | SendError(Int32, String) | Löst das Ereignis Message mit einer Fehlernachricht aus.
Public method | SendError(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Fehlernachricht aus.
Public method | SendInfo(Int32, String) | Löst das Ereignis Message mit einer Information aus.
Public method | SendInfo(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Information aus.
Public method | SendVerbose(Int32, String) | Löst das Ereignis Message mit einer Detailmeldung aus.
Public method | SendVerbose(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Detailmeldung aus.
Public method | SendWarning(Int32, String) | Löst das Ereignis Message mit einer Warnung aus.
Public method | SendWarning(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Warnung aus.

Properties

 | Name | Description
 | DefaultInstance | Gibt den Standard-Nachrichtenbus von DynamicNodes zurück.
Public property | History | Gibt die History der Nachrichten zurück.
Public property | StoreHistory | Gibt einen Wert zurück, der angibt, ob die Nachrichten in einer History gespeichert werden sollen, oder liegt ihn fest.
Public property | TraceLocation | Gibt an, oder legt fest, ob die Ursprungsorte der Nachrichten ermittelt werden sollen.

Events

 | Name | Description
Public event | Message | Wird ausgelöst, wenn eine Nachricht über den Bus verteilt wird. (Wichtig: Das empfangene Delegat muss erwarten, dass verschiedene Threads dieses Ereignis auslösen. Falls WindowsForms-Steuerelemente aktualisiert werden sollen, müssen diese mit Invoke über den Erzeuger Thread aktualisiert werden.)

See Also

MessageBus Class
DynamicNode.Core Namespace


MessageBus Constructor

[image]

DynamicNodes API
MessageBus Constructor
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von MessageBus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public MessageBus(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
F#
new :
        name:string -> MessageBus

Parameters

name
Type: System..::..String
Der Name des Nachrichtenbusses.

See Also

MessageBus Class
DynamicNode.Core Namespace


MessageBus Methods

[image] [image]

DynamicNodes API
MessageBus Methods
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MessageBus type exposes the following members.

Methods

 | Name | Description
Public method | AtachToTraceSource | Hängt den Nachrichtenbus an eine TraceSource an.
Public method | ClearHistory | Löscht die History der Nachrichten.
Public method | DetachFromTraceSource | Löst den Nachrichtenbus von einer TraceSource.
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.
Protected method | Finalize | Gibt Ressourcen frei, die vom Nachrichtenbus reserviert wurden, wenn der GC dieses Objekt zerstört. (Overrides Object..::..Finalize()()()().)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Public method | Send(Message) | Löst das Ereignis Message aus.
Public method | Send(TraceEventType, String, Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message aus.
Public method | SendError(Int32, String) | Löst das Ereignis Message mit einer Fehlernachricht aus.
Public method | SendError(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Fehlernachricht aus.
Public method | SendInfo(Int32, String) | Löst das Ereignis Message mit einer Information aus.
Public method | SendInfo(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Information aus.
Public method | SendVerbose(Int32, String) | Löst das Ereignis Message mit einer Detailmeldung aus.
Public method | SendVerbose(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Detailmeldung aus.
Public method | SendWarning(Int32, String) | Löst das Ereignis Message mit einer Warnung aus.
Public method | SendWarning(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Warnung aus.

See Also

MessageBus Class
DynamicNode.Core Namespace


AtachToTraceSource Method

[image]

DynamicNodes API
MessageBus..::..AtachToTraceSource Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Hängt den Nachrichtenbus an eine TraceSource an.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AtachToTraceSource(
    TraceSource source
)
Visual Basic
Public Sub AtachToTraceSource ( _
    source As TraceSource _
)
F#
member AtachToTraceSource :
        source:TraceSource -> unit

Parameters

source
Type: System.Diagnostics..::..TraceSource
Die Ablaufverfolgunsgquelle, deren Nachrichten über den Nachrichtenbus verbreitet werden sollen.

See Also

MessageBus Class
DynamicNode.Core Namespace


ClearHistory Method

[image]

DynamicNodes API
MessageBus..::..ClearHistory Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löscht die History der Nachrichten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ClearHistory()
Visual Basic
Public Sub ClearHistory
F#
member ClearHistory : unit -> unit

See Also

MessageBus Class
DynamicNode.Core Namespace


DetachFromTraceSource Method

[image]

DynamicNodes API
MessageBus..::..DetachFromTraceSource Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst den Nachrichtenbus von einer TraceSource.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void DetachFromTraceSource(
    TraceSource source
)
Visual Basic
Public Sub DetachFromTraceSource ( _
    source As TraceSource _
)
F#
member DetachFromTraceSource :
        source:TraceSource -> unit

Parameters

source
Type: System.Diagnostics..::..TraceSource
Die Ablaufverfolgunsgquelle, deren Nachrichten nicht mehr über den Nachrichtenbus verbreitet werden sollen.

See Also

MessageBus Class
DynamicNode.Core Namespace


Dispose Method

[image]

DynamicNodes API
MessageBus..::..Dispose Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
F#
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposable..::..Dispose()()()()

See Also

MessageBus Class
DynamicNode.Core Namespace


Finalize Method

[image]

DynamicNodes API
MessageBus..::..Finalize Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt Ressourcen frei, die vom Nachrichtenbus reserviert wurden, wenn der GC dieses Objekt zerstört.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
F#
abstract Finalize : unit -> unit
override Finalize : unit -> unit

See Also

MessageBus Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
MessageBus..::..OnRestore Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

MessageBus Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
MessageBus..::..OnStore Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

MessageBus Class
DynamicNode.Core Namespace


Send Method

[image] [image]

DynamicNodes API
MessageBus..::..Send Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Send(Message) | Löst das Ereignis Message aus.
Public method | Send(TraceEventType, String, Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message aus.

See Also

MessageBus Class
MessageBus Members
DynamicNode.Core Namespace


Send Method (Message)

[image]

DynamicNodes API
MessageBus..::..Send Method (Message)
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Message aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Send(
    Message msg
)
Visual Basic
Public Sub Send ( _
    msg As Message _
)
F#
member Send :
        msg:Message -> unit

Parameters

msg
Type: DynamicNode.Core..::..Message
Die System-Nachricht.

See Also

MessageBus Class
Send Overload
DynamicNode.Core Namespace


Send Method (TraceEventType, String, Int32, String, Object[])

[image]

DynamicNodes API
MessageBus..::..Send Method (TraceEventType, String, Int32, String, array<Object>[]()[][])
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Message aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Send(
    TraceEventType typ,
    string source,
    int id,
    string text,
    params Object[] data
)
Visual Basic
Public Sub Send ( _
    typ As TraceEventType, _
    source As String, _
    id As Integer, _
    text As String, _
    ParamArray data As Object() _
)
F#
member Send :
        typ:TraceEventType *
        source:string *
        id:int *
        text:string *
        data:Object[] -> unit

Parameters

typ
Type: System.Diagnostics..::..TraceEventType
Der Typ der Nachricht.
source
Type: System..::..String
Die Quelle der Nachricht.
id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Text.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Objekte, welche die Nachricht näher beschreiben.

See Also

MessageBus Class
Send Overload
DynamicNode.Core Namespace


SendError Method

[image] [image]

DynamicNodes API
MessageBus..::..SendError Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | SendError(Int32, String) | Löst das Ereignis Message mit einer Fehlernachricht aus.
Public method | SendError(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Fehlernachricht aus.

See Also

MessageBus Class
MessageBus Members
DynamicNode.Core Namespace


SendError Method (Int32, String)

[image]

DynamicNodes API
MessageBus..::..SendError Method (Int32, String)
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Message mit einer Fehlernachricht aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void SendError(
    int id,
    string text
)
Visual Basic
Public Sub SendError ( _
    id As Integer, _
    text As String _
)
F#
member SendError :
        id:int *
        text:string -> unit

Parameters

id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Text.

See Also

MessageBus Class
SendError Overload
DynamicNode.Core Namespace


SendError Method (Int32, String, Object[])

[image]

DynamicNodes API
MessageBus..::..SendError Method (Int32, String, array<Object>[]()[][])
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Message mit einer Fehlernachricht aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void SendError(
    int id,
    string text,
    params Object[] data
)
Visual Basic
Public Sub SendError ( _
    id As Integer, _
    text As String, _
    ParamArray data As Object() _
)
F#
member SendError :
        id:int *
        text:string *
        data:Object[] -> unit

Parameters

id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Text.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Informationen.

See Also

MessageBus Class
SendError Overload
DynamicNode.Core Namespace


SendInfo Method

[image] [image]

DynamicNodes API
MessageBus..::..SendInfo Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | SendInfo(Int32, String) | Löst das Ereignis Message mit einer Information aus.
Public method | SendInfo(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Information aus.

See Also

MessageBus Class
MessageBus Members
DynamicNode.Core Namespace


SendInfo Method (Int32, String)

[image]

DynamicNodes API
MessageBus..::..SendInfo Method (Int32, String)
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Message mit einer Information aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void SendInfo(
    int id,
    string text
)
Visual Basic
Public Sub SendInfo ( _
    id As Integer, _
    text As String _
)
F#
member SendInfo :
        id:int *
        text:string -> unit

Parameters

id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Text.

See Also

MessageBus Class
SendInfo Overload
DynamicNode.Core Namespace


SendInfo Method (Int32, String, Object[])

[image]

DynamicNodes API
MessageBus..::..SendInfo Method (Int32, String, array<Object>[]()[][])
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Message mit einer Information aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void SendInfo(
    int id,
    string text,
    params Object[] data
)
Visual Basic
Public Sub SendInfo ( _
    id As Integer, _
    text As String, _
    ParamArray data As Object() _
)
F#
member SendInfo :
        id:int *
        text:string *
        data:Object[] -> unit

Parameters

id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Text.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Informationen.

See Also

MessageBus Class
SendInfo Overload
DynamicNode.Core Namespace


SendVerbose Method

[image] [image]

DynamicNodes API
MessageBus..::..SendVerbose Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | SendVerbose(Int32, String) | Löst das Ereignis Message mit einer Detailmeldung aus.
Public method | SendVerbose(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Detailmeldung aus.

See Also

MessageBus Class
MessageBus Members
DynamicNode.Core Namespace


SendVerbose Method (Int32, String)

[image]

DynamicNodes API
MessageBus..::..SendVerbose Method (Int32, String)
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Message mit einer Detailmeldung aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void SendVerbose(
    int id,
    string text
)
Visual Basic
Public Sub SendVerbose ( _
    id As Integer, _
    text As String _
)
F#
member SendVerbose :
        id:int *
        text:string -> unit

Parameters

id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Text.

See Also

MessageBus Class
SendVerbose Overload
DynamicNode.Core Namespace


SendVerbose Method (Int32, String, Object[])

[image]

DynamicNodes API
MessageBus..::..SendVerbose Method (Int32, String, array<Object>[]()[][])
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Message mit einer Detailmeldung aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void SendVerbose(
    int id,
    string text,
    params Object[] data
)
Visual Basic
Public Sub SendVerbose ( _
    id As Integer, _
    text As String, _
    ParamArray data As Object() _
)
F#
member SendVerbose :
        id:int *
        text:string *
        data:Object[] -> unit

Parameters

id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Text.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Informationen.

See Also

MessageBus Class
SendVerbose Overload
DynamicNode.Core Namespace


SendWarning Method

[image] [image]

DynamicNodes API
MessageBus..::..SendWarning Method
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | SendWarning(Int32, String) | Löst das Ereignis Message mit einer Warnung aus.
Public method | SendWarning(Int32, String, array<Object>[]()[][]) | Löst das Ereignis Message mit einer Warnung aus.

See Also

MessageBus Class
MessageBus Members
DynamicNode.Core Namespace


SendWarning Method (Int32, String)

[image]

DynamicNodes API
MessageBus..::..SendWarning Method (Int32, String)
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Message mit einer Warnung aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void SendWarning(
    int id,
    string text
)
Visual Basic
Public Sub SendWarning ( _
    id As Integer, _
    text As String _
)
F#
member SendWarning :
        id:int *
        text:string -> unit

Parameters

id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Text.

See Also

MessageBus Class
SendWarning Overload
DynamicNode.Core Namespace


SendWarning Method (Int32, String, Object[])

[image]

DynamicNodes API
MessageBus..::..SendWarning Method (Int32, String, array<Object>[]()[][])
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Message mit einer Warnung aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void SendWarning(
    int id,
    string text,
    params Object[] data
)
Visual Basic
Public Sub SendWarning ( _
    id As Integer, _
    text As String, _
    ParamArray data As Object() _
)
F#
member SendWarning :
        id:int *
        text:string *
        data:Object[] -> unit

Parameters

id
Type: System..::..Int32
Die numerische Kennung.
text
Type: System..::..String
Der Text.
data
Type: array< System..::..Object >[]()[][]
Zusätzliche Informationen.

See Also

MessageBus Class
SendWarning Overload
DynamicNode.Core Namespace


MessageBus Properties

[image] [image]

DynamicNodes API
MessageBus Properties
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MessageBus type exposes the following members.

Properties

 | Name | Description
 | DefaultInstance | Gibt den Standard-Nachrichtenbus von DynamicNodes zurück.
Public property | History | Gibt die History der Nachrichten zurück.
Public property | StoreHistory | Gibt einen Wert zurück, der angibt, ob die Nachrichten in einer History gespeichert werden sollen, oder liegt ihn fest.
Public property | TraceLocation | Gibt an, oder legt fest, ob die Ursprungsorte der Nachrichten ermittelt werden sollen.

See Also

MessageBus Class
DynamicNode.Core Namespace


DefaultInstance Property

[image]

DynamicNodes API
MessageBus..::..DefaultInstance Property
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standard-Nachrichtenbus von DynamicNodes zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static MessageBus DefaultInstance { get; }
Visual Basic
Public Shared ReadOnly Property DefaultInstance As MessageBus
    Get
F#
static member DefaultInstance : MessageBus

See Also

MessageBus Class
DynamicNode.Core Namespace


History Property

[image]

DynamicNodes API
MessageBus..::..History Property
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die History der Nachrichten zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IEnumerable<Message> History { get; }
Visual Basic
Public ReadOnly Property History As IEnumerable(Of Message)
    Get
F#
member History : IEnumerable<Message>

See Also

MessageBus Class
DynamicNode.Core Namespace


StoreHistory Property

[image]

DynamicNodes API
MessageBus..::..StoreHistory Property
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Nachrichten in einer History gespeichert werden sollen, oder liegt ihn fest.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool StoreHistory { get; set; }
Visual Basic
Public Property StoreHistory As Boolean
    Get
    Set
F#
member StoreHistory : bool with get, set

See Also

MessageBus Class
DynamicNode.Core Namespace


TraceLocation Property

[image]

DynamicNodes API
MessageBus..::..TraceLocation Property
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, oder legt fest, ob die Ursprungsorte der Nachrichten ermittelt werden sollen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool TraceLocation { get; set; }
Visual Basic
Public Property TraceLocation As Boolean
    Get
    Set
F#
member TraceLocation : bool with get, set

Field Value

true wenn ja; sonst, false.

See Also

MessageBus Class
DynamicNode.Core Namespace


MessageBus Events

[image] [image]

DynamicNodes API
MessageBus Events
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MessageBus type exposes the following members.

Events

 | Name | Description
Public event | Message | Wird ausgelöst, wenn eine Nachricht über den Bus verteilt wird. (Wichtig: Das empfangene Delegat muss erwarten, dass verschiedene Threads dieses Ereignis auslösen. Falls WindowsForms-Steuerelemente aktualisiert werden sollen, müssen diese mit Invoke über den Erzeuger Thread aktualisiert werden.)

See Also

MessageBus Class
DynamicNode.Core Namespace


Message Event

[image]

DynamicNodes API
MessageBus..::..Message Event
MessageBus Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine Nachricht über den Bus verteilt wird. (Wichtig: Das empfangene Delegat muss erwarten, dass verschiedene Threads dieses Ereignis auslösen. Falls WindowsForms-Steuerelemente aktualisiert werden sollen, müssen diese mit Invoke über den Erzeuger Thread aktualisiert werden.)

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event MessageHandler Message
Visual Basic
Public Event Message As MessageHandler
F#
member Message : IEvent<MessageHandler,
    EventArgs>

See Also

MessageBus Class
DynamicNode.Core Namespace


MessageHandler Delegate

[image]

DynamicNodes API
MessageHandler Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine DynamicNodes-System-Nachrichtenbehandlungsroutine.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public delegate void MessageHandler(
    Message msg
)
Visual Basic
Public Delegate Sub MessageHandler ( _
    msg As Message _
)
F#
type MessageHandler =
    delegate of
        msg:Message -> unit

Parameters

msg
Type: DynamicNode.Core..::..Message
Die Nachricht.

See Also

DynamicNode.Core Namespace


MessageWriter Class

[image]

DynamicNodes API
MessageWriter Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Kann System-Nachrichten formatiert auf einen TextWriter ausgeben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class MessageWriter
Visual Basic
Public Class MessageWriter
F#
type MessageWriter =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..MessageWriter

See Also

MessageWriter Members
DynamicNode.Core Namespace


MessageWriter Members

[image] [image]

DynamicNodes API
MessageWriter Members
MessageWriter Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MessageWriter type exposes the following members.

Constructors

 | Name | Description
Public method | MessageWriter()()()() | Initialisiert eine neue Instanz von MessageWriter.
Public method | MessageWriter(TextWriter) | Initialisiert eine neue Instanz von MessageWriter.

Methods

 | Name | Description
Public method | WriteMessage | Gibt eine Nachricht formatiert aus.

Properties

 | Name | Description
Public property | DateFormat | Liest oder schreibt das Datumsformat.
Public property | SuppressError | Gibt an, ob Fehlernachrichten unterdrückt werden sollen.
Public property | SuppressInformation | Gibt an, ob informative Nachrichten unterdrückt werden sollen.
Public property | SuppressVerbose | Gibt an, ob informative Nachrichten unterdrückt werden sollen.
Public property | SuppressWarning | Gibt an, ob Warnungen unterdrückt werden sollen.
Public property | WriteData | Gibt an, ob evtl. vorhandene Ausnahmen ausgegeben werden sollen.
Public property | WriteLocation | Gibt an, ob der Nachrichtenursprung ausgegeben werden soll.
Public property | WriteMessagText | Gibt an, ob der Nachrichtentext ausgegeben werden soll.
Public property | WriteTimeStamp | Gibt an, ob ein Zeitstempel ausgegeben werden soll.

See Also

MessageWriter Class
DynamicNode.Core Namespace


MessageWriter Constructor

[image] [image]

DynamicNodes API
MessageWriter Constructor
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | MessageWriter()()()() | Initialisiert eine neue Instanz von MessageWriter.
Public method | MessageWriter(TextWriter) | Initialisiert eine neue Instanz von MessageWriter.

See Also

MessageWriter Class
MessageWriter Members
DynamicNode.Core Namespace


MessageWriter Constructor

[image]

DynamicNodes API
MessageWriter Constructor
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von MessageWriter.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public MessageWriter()
Visual Basic
Public Sub New
F#
new : unit -> MessageWriter

See Also

MessageWriter Class
MessageWriter Overload
DynamicNode.Core Namespace


MessageWriter Constructor (TextWriter)

[image]

DynamicNodes API
MessageWriter Constructor (TextWriter)
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von MessageWriter.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public MessageWriter(
    TextWriter w
)
Visual Basic
Public Sub New ( _
    w As TextWriter _
)
F#
new :
        w:TextWriter -> MessageWriter

Parameters

w
Type: System.IO..::..TextWriter
Der Text-Writer für die Ausgabe.

See Also

MessageWriter Class
MessageWriter Overload
DynamicNode.Core Namespace


MessageWriter Methods

[image] [image]

DynamicNodes API
MessageWriter Methods
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MessageWriter type exposes the following members.

Methods

 | Name | Description
Public method | WriteMessage | Gibt eine Nachricht formatiert aus.

See Also

MessageWriter Class
DynamicNode.Core Namespace


WriteMessage Method

[image]

DynamicNodes API
MessageWriter..::..WriteMessage Method
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Nachricht formatiert aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteMessage(
    Message msg
)
Visual Basic
Public Sub WriteMessage ( _
    msg As Message _
)
F#
member WriteMessage :
        msg:Message -> unit

Parameters

msg
Type: DynamicNode.Core..::..Message
Die Nachricht.

See Also

MessageWriter Class
DynamicNode.Core Namespace


MessageWriter Properties

[image] [image]

DynamicNodes API
MessageWriter Properties
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MessageWriter type exposes the following members.

Properties

 | Name | Description
Public property | DateFormat | Liest oder schreibt das Datumsformat.
Public property | SuppressError | Gibt an, ob Fehlernachrichten unterdrückt werden sollen.
Public property | SuppressInformation | Gibt an, ob informative Nachrichten unterdrückt werden sollen.
Public property | SuppressVerbose | Gibt an, ob informative Nachrichten unterdrückt werden sollen.
Public property | SuppressWarning | Gibt an, ob Warnungen unterdrückt werden sollen.
Public property | WriteData | Gibt an, ob evtl. vorhandene Ausnahmen ausgegeben werden sollen.
Public property | WriteLocation | Gibt an, ob der Nachrichtenursprung ausgegeben werden soll.
Public property | WriteMessagText | Gibt an, ob der Nachrichtentext ausgegeben werden soll.
Public property | WriteTimeStamp | Gibt an, ob ein Zeitstempel ausgegeben werden soll.

See Also

MessageWriter Class
DynamicNode.Core Namespace


DateFormat Property

[image]

DynamicNodes API
MessageWriter..::..DateFormat Property
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt das Datumsformat.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string DateFormat { get; set; }
Visual Basic
Public Property DateFormat As String
    Get
    Set
F#
member DateFormat : string with get, set

Field Value

Das Datumsformat.

See Also

MessageWriter Class
DynamicNode.Core Namespace


SuppressError Property

[image]

DynamicNodes API
MessageWriter..::..SuppressError Property
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob Fehlernachrichten unterdrückt werden sollen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool SuppressError { get; set; }
Visual Basic
Public Property SuppressError As Boolean
    Get
    Set
F#
member SuppressError : bool with get, set

See Also

MessageWriter Class
DynamicNode.Core Namespace


SuppressInformation Property

[image]

DynamicNodes API
MessageWriter..::..SuppressInformation Property
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob informative Nachrichten unterdrückt werden sollen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool SuppressInformation { get; set; }
Visual Basic
Public Property SuppressInformation As Boolean
    Get
    Set
F#
member SuppressInformation : bool with get, set

See Also

MessageWriter Class
DynamicNode.Core Namespace


SuppressVerbose Property

[image]

DynamicNodes API
MessageWriter..::..SuppressVerbose Property
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob informative Nachrichten unterdrückt werden sollen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool SuppressVerbose { get; set; }
Visual Basic
Public Property SuppressVerbose As Boolean
    Get
    Set
F#
member SuppressVerbose : bool with get, set

See Also

MessageWriter Class
DynamicNode.Core Namespace


SuppressWarning Property

[image]

DynamicNodes API
MessageWriter..::..SuppressWarning Property
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob Warnungen unterdrückt werden sollen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool SuppressWarning { get; set; }
Visual Basic
Public Property SuppressWarning As Boolean
    Get
    Set
F#
member SuppressWarning : bool with get, set

See Also

MessageWriter Class
DynamicNode.Core Namespace


WriteData Property

[image]

DynamicNodes API
MessageWriter..::..WriteData Property
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob evtl. vorhandene Ausnahmen ausgegeben werden sollen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool WriteData { get; set; }
Visual Basic
Public Property WriteData As Boolean
    Get
    Set
F#
member WriteData : bool with get, set

See Also

MessageWriter Class
DynamicNode.Core Namespace


WriteLocation Property

[image]

DynamicNodes API
MessageWriter..::..WriteLocation Property
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob der Nachrichtenursprung ausgegeben werden soll.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool WriteLocation { get; set; }
Visual Basic
Public Property WriteLocation As Boolean
    Get
    Set
F#
member WriteLocation : bool with get, set

See Also

MessageWriter Class
DynamicNode.Core Namespace


WriteMessagText Property

[image]

DynamicNodes API
MessageWriter..::..WriteMessagText Property
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob der Nachrichtentext ausgegeben werden soll.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool WriteMessagText { get; set; }
Visual Basic
Public Property WriteMessagText As Boolean
    Get
    Set
F#
member WriteMessagText : bool with get, set

See Also

MessageWriter Class
DynamicNode.Core Namespace


WriteTimeStamp Property

[image]

DynamicNodes API
MessageWriter..::..WriteTimeStamp Property
MessageWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob ein Zeitstempel ausgegeben werden soll.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool WriteTimeStamp { get; set; }
Visual Basic
Public Property WriteTimeStamp As Boolean
    Get
    Set
F#
member WriteTimeStamp : bool with get, set

See Also

MessageWriter Class
DynamicNode.Core Namespace


Node Class

[image]

DynamicNodes API
Node Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basis-Klasse für alle Knoten eines DynamicNode-Graphen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract class Node : HierarchyObject<IGraph, INode, IPort>,
    INode, IChild<IGraph, INode>, IParent<INode, IPort>,
    IBaseObject, IIdentifiable, IStorable, IExtensible<INode>,
    IDisposable, IComparable<INode>
Visual Basic
Public MustInherit Class Node _
    Inherits HierarchyObject(Of IGraph, INode, IPort) _
    Implements INode, IChild(Of IGraph, INode),  _
    IParent(Of INode, IPort), IBaseObject, IIdentifiable,  _
    IStorable, IExtensible(Of INode), IDisposable, IComparable(Of INode)
F#
[<AbstractClassAttribute>]
type Node =
    class
        inherit HierarchyObject<IGraph, INode, IPort>
        interface INode
        interface IChild<IGraph, INode>
        interface IParent<INode, IPort>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
        interface IExtensible<INode>
        interface IDisposable
        interface IComparable<INode>
    end

Remarks

Diese Klasse bietet eine Verwaltung für Ein- und Ausgabeports, für Knotenbefehle und für Erweiterungen.

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core.Nodes..::..NFlag
DynamicNode.Core.Nodes..::..NSubGraph
DynamicNode.Core..::..StreamNode

See Also

Node Members
DynamicNode.Core Namespace


Node Members

[image] [image]

DynamicNodes API
Node Members
Node Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Node type exposes the following members.

Constructors

 | Name | Description
Protected method | Node | Initialisiert eine Node-Instanz.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen.
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten.
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen.
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten.
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus.
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus.
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildAdded(TChild).)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildRemoved(TChild).)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird.
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde.
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird.
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnStore(IPropertyWriter).)
 | Send<(Of <<'(T>)>>)(OutPortHandler<(Of <<'(T>)>>), T) | Sendet einen Ausgabewert über einen Ausgang. Als Markenstatus wird Valid verwendet.
 | Send<(Of <<'(T>)>>)(OutPortHandler<(Of <<'(T>)>>), T, TokenState) | Sendet einen Wert über einen Ausgang.
 | SendNotSet<(Of <<'(T>)>>) | Setzt einen Ausgang auf den Markenstatus NotSet.
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Overrides Object..::..ToString()()()().)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben.
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück.
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist.
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht.
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit.
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Overrides BaseObject..::..LocalTrace.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Overrides BaseObject..::..NameDefaultValue.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück.
 | NodeTraceSource | Gibt die Ablaufverfolgungsquelle für Knoten zurück.
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück.
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird.
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden.
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück.
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück.
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück.
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet.
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird.
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird.
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)

See Also

Node Class
DynamicNode.Core Namespace


Node Constructor

[image]

DynamicNodes API
Node Constructor
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Node-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected Node()
Visual Basic
Protected Sub New
F#
new : unit -> Node

See Also

Node Class
DynamicNode.Core Namespace


Node Methods

[image] [image]

DynamicNodes API
Node Methods
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Node type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen.
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten.
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen.
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten.
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus.
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus.
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildAdded(TChild).)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildRemoved(TChild).)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird.
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde.
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird.
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnStore(IPropertyWriter).)
 | Send<(Of <<'(T>)>>)(OutPortHandler<(Of <<'(T>)>>), T) | Sendet einen Ausgabewert über einen Ausgang. Als Markenstatus wird Valid verwendet.
 | Send<(Of <<'(T>)>>)(OutPortHandler<(Of <<'(T>)>>), T, TokenState) | Sendet einen Wert über einen Ausgang.
 | SendNotSet<(Of <<'(T>)>>) | Setzt einen Ausgang auf den Markenstatus NotSet.
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Overrides Object..::..ToString()()()().)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

See Also

Node Class
DynamicNode.Core Namespace


Activate Method

[image]

DynamicNodes API
Node..::..Activate Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert den Knoten von außen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Activate()
Visual Basic
Public Sub Activate
F#
abstract Activate : unit -> unit
override Activate : unit -> unit

Implements

INode..::..Activate()()()()

See Also

Node Class
DynamicNode.Core Namespace


AddCommand Method

[image]

DynamicNodes API
Node..::..AddCommand Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert einen Benutzerbefehl für diesen Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void AddCommand(
    string caption,
    string command
)
Visual Basic
Protected Sub AddCommand ( _
    caption As String, _
    command As String _
)
F#
member AddCommand :
        caption:string *
        command:string -> unit

Parameters

caption
Type: System..::..String
Die Beschriftung für diesen Befehl.
command
Type: System..::..String
Ein Befehls-Code.

See Also

Node Class
DynamicNode.Core Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
Node..::..BeforeUseExtension Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

Node Class
Node Members
DynamicNode.Core Namespace


CompareTo Method

[image]

DynamicNodes API
Node..::..CompareTo Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Vergleicht diesen Knoten mit einem anderen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int CompareTo(
    INode other
)
Visual Basic
Public Function CompareTo ( _
    other As INode _
) As Integer
F#
abstract CompareTo :
        other:INode -> int
override CompareTo :
        other:INode -> int

Parameters

other
Type: DynamicNode.Core..::..INode
Der andere Knoten.

Return Value

Einen 32-Bit vorzeichenbehafteten Integer, der angibt in welcher relativen Reihenfolge sich die verglichenen Objekte befinden. Der Rückgabewert hat die folgende Bedeutung: Ein Wert kleiner 0 bedeutet, dieses Objekt ist kleiner als other. Ein Wert gleich 0 bedeutet, dieses Objekt ist gleich other. Ein Wert größer als 0 bedeutet, dieses Objekt ist größer als other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

Node Class
DynamicNode.Core Namespace


Duplicate Method

[image] [image]

DynamicNodes API
Node..::..Duplicate Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.

See Also

Node Class
Node Members
DynamicNode.Core Namespace


Duplicate Method

[image]

DynamicNodes API
Node..::..Duplicate Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public INode Duplicate()
Visual Basic
Public Function Duplicate As INode
F#
abstract Duplicate : unit -> INode
override Duplicate : unit -> INode

Return Value

Ein Duplikat des aktuellen Knotens.

Implements

INode..::..Duplicate()()()()

See Also

Node Class
Duplicate Overload
DynamicNode.Core Namespace


Duplicate Method (IGraph)

[image]

DynamicNodes API
Node..::..Duplicate Method (IGraph)
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public INode Duplicate(
    IGraph parent
)
Visual Basic
Public Function Duplicate ( _
    parent As IGraph _
) As INode
F#
abstract Duplicate :
        parent:IGraph -> INode
override Duplicate :
        parent:IGraph -> INode

Parameters

parent
Type: DynamicNode.Core..::..IGraph
Der Graph, in dem das Duplikat erstellt werden soll.

Return Value

Ein Duplikat des aktuellen Knotens.

Implements

INode..::..Duplicate(IGraph)

See Also

Node Class
Duplicate Overload
DynamicNode.Core Namespace


GetAddress Method

[image]

DynamicNodes API
Node..::..GetAddress Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string GetAddress()
Visual Basic
Public Function GetAddress As String
F#
abstract GetAddress : unit -> string
override GetAddress : unit -> string

Return Value

Eine Knoten-Adresse.

Implements

INode..::..GetAddress()()()()

See Also

Node Class
DynamicNode.Core Namespace


Isolate Method

[image]

DynamicNodes API
Node..::..Isolate Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Trennt alle Verbindungen zu anderen Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Isolate()
Visual Basic
Public Sub Isolate
F#
abstract Isolate : unit -> unit
override Isolate : unit -> unit

Implements

INode..::..Isolate()()()()

See Also

Node Class
DynamicNode.Core Namespace


OnAfterActivation Method

[image]

DynamicNodes API
Node..::..OnAfterActivation Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnAfterActivation()
Visual Basic
Protected Sub OnAfterActivation
F#
member OnAfterActivation : unit -> unit

See Also

Node Class
DynamicNode.Core Namespace


OnBeforeActivation Method

[image]

DynamicNodes API
Node..::..OnBeforeActivation Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnBeforeActivation()
Visual Basic
Protected Sub OnBeforeActivation
F#
member OnBeforeActivation : unit -> unit

See Also

Node Class
DynamicNode.Core Namespace


OnBeforeReactivation Method

[image]

DynamicNodes API
Node..::..OnBeforeReactivation Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnBeforeReactivation()
Visual Basic
Protected Sub OnBeforeReactivation
F#
member OnBeforeReactivation : unit -> unit

See Also

Node Class
DynamicNode.Core Namespace


OnChildAdded Method

[image]

DynamicNodes API
Node..::..OnChildAdded Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnChildAdded(
    IPort childToAdd
)
Visual Basic
Protected Overrides Sub OnChildAdded ( _
    childToAdd As IPort _
)
F#
abstract OnChildAdded :
        childToAdd:IPort -> unit
override OnChildAdded :
        childToAdd:IPort -> unit

Parameters

childToAdd
Type: DynamicNode.Core..::..IPort
Das hinzugefügte Kindobjekt.

See Also

Node Class
DynamicNode.Core Namespace


OnChildRemoved Method

[image]

DynamicNodes API
Node..::..OnChildRemoved Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnChildRemoved(
    IPort childToRemove
)
Visual Basic
Protected Overrides Sub OnChildRemoved ( _
    childToRemove As IPort _
)
F#
abstract OnChildRemoved :
        childToRemove:IPort -> unit
override OnChildRemoved :
        childToRemove:IPort -> unit

Parameters

childToRemove
Type: DynamicNode.Core..::..IPort
Die entfernten Kindobjekte.

See Also

Node Class
DynamicNode.Core Namespace


OnCommand Method

[image]

DynamicNodes API
Node..::..OnCommand Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void OnCommand(
    string command
)
Visual Basic
Public Overridable Sub OnCommand ( _
    command As String _
)
F#
abstract OnCommand :
        command:string -> unit
override OnCommand :
        command:string -> unit

Parameters

command
Type: System..::..String
Der Befehls-Code des Benutzerbefehls.

Implements

INode..::..OnCommand(String)

Remarks

Diese Methode sollte von einer Klasse überschrieben werden, die einen oder mehrere Benutzerbefehle mit AddCommand(String, String) registriert hat.

See Also

Node Class
DynamicNode.Core Namespace


OnDefaultCommand Method

[image]

DynamicNodes API
Node..::..OnDefaultCommand Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void OnDefaultCommand()
Visual Basic
Public Overridable Sub OnDefaultCommand
F#
abstract OnDefaultCommand : unit -> unit
override OnDefaultCommand : unit -> unit

Implements

INode..::..OnDefaultCommand()()()()

Remarks

Diese Methode muss nicht überschrieben werden.

See Also

Node Class
DynamicNode.Core Namespace


OnGraphExtensionAttached Method

[image]

DynamicNodes API
Node..::..OnGraphExtensionAttached Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void OnGraphExtensionAttached(
    IExtension<IGraph> extension
)
Visual Basic
Public Overridable Sub OnGraphExtensionAttached ( _
    extension As IExtension(Of IGraph) _
)
F#
abstract OnGraphExtensionAttached :
        extension:IExtension<IGraph> -> unit
override OnGraphExtensionAttached :
        extension:IExtension<IGraph> -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>
Die angefügte Erweiterung

See Also

Node Class
DynamicNode.Core Namespace


OnGraphExtensionDetached Method

[image]

DynamicNodes API
Node..::..OnGraphExtensionDetached Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void OnGraphExtensionDetached(
    IExtension<IGraph> extension
)
Visual Basic
Public Overridable Sub OnGraphExtensionDetached ( _
    extension As IExtension(Of IGraph) _
)
F#
abstract OnGraphExtensionDetached :
        extension:IExtension<IGraph> -> unit
override OnGraphExtensionDetached :
        extension:IExtension<IGraph> -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>
Die angefügte Erweiterung

See Also

Node Class
DynamicNode.Core Namespace


OnInitPortDefaults Method

[image]

DynamicNodes API
Node..::..OnInitPortDefaults Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void OnInitPortDefaults()
Visual Basic
Public Overridable Sub OnInitPortDefaults
F#
abstract OnInitPortDefaults : unit -> unit
override OnInitPortDefaults : unit -> unit

Implements

INode..::..OnInitPortDefaults()()()()

See Also

Node Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
Node..::..OnRestore Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overrides Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der IPropertyReader mit dem benutzerdefinierte Eigenschaften des Knotens gelesen werden können.

Implements

IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)

Remarks

Diese Methode wird beim Laden eines Graphen aufgerufen bevor die Verbindungen zwischen den Knoten wiederhergstellt werden.

See Also

Node Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
Node..::..OnStore Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overrides Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der IPropertyWriter mit dem benutzerdefinierte Eigenschaften des Knotens gespeichert werden können.

Implements

IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)

See Also

Node Class
DynamicNode.Core Namespace


Send Method

[image] [image]

DynamicNodes API
Node..::..Send Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Send<(Of <<'(T>)>>)(OutPortHandler<(Of <<'(T>)>>), T) | Sendet einen Ausgabewert über einen Ausgang. Als Markenstatus wird Valid verwendet.
Send<(Of <<'(T>)>>)(OutPortHandler<(Of <<'(T>)>>), T, TokenState) | Sendet einen Wert über einen Ausgang.

See Also

Node Class
Node Members
DynamicNode.Core Namespace


Send(T) Method (OutPortHandler(T), T)

[image]

DynamicNodes API
Node..::..Send<(Of <(<'T>)>)> Method (OutPortHandler<(Of <(<'T>)>)>, T)
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet einen Ausgabewert über einen Ausgang. Als Markenstatus wird Valid verwendet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected static void Send<T>(
    OutPortHandler<T> handler,
    T value
)
Visual Basic
Protected Shared Sub Send(Of T) ( _
    handler As OutPortHandler(Of T), _
    value As T _
)
F#
static member Send :
        handler:OutPortHandler<'T> *
        value:'T -> unit

Parameters

handler
Type: DynamicNode.Core..::..OutPortHandler <(Of <(<'T>)>)>
Der Ausgangs-Handler.
value
Type: T
Der Wert, welcher über den Ausgang weitergeleitet werden soll.

Type Parameters

T
Der Datentyp des Ausgangs.

See Also

Node Class
Send Overload
DynamicNode.Core Namespace
Node..::..Send<(Of <<'(T>)>>)(OutPortHandler<(Of <<'(T>)>>), T, TokenState)


Send(T) Method (OutPortHandler(T), T, TokenState)

[image]

DynamicNodes API
Node..::..Send<(Of <(<'T>)>)> Method (OutPortHandler<(Of <(<'T>)>)>, T, TokenState)
Node Class Example See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet einen Wert über einen Ausgang.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected static void Send<T>(
    OutPortHandler<T> handler,
    T value,
    TokenState state
)
Visual Basic
Protected Shared Sub Send(Of T) ( _
    handler As OutPortHandler(Of T), _
    value As T, _
    state As TokenState _
)
F#
static member Send :
        handler:OutPortHandler<'T> *
        value:'T *
        state:TokenState -> unit

Parameters

handler
Type: DynamicNode.Core..::..OutPortHandler <(Of <(<'T>)>)>
Der Ausgangs-Handler.
value
Type: T
Der Wert, der über den Ausgang weitergeleitet werden soll.
state
Type: DynamicNode.Core..::..TokenState
Der Status des Wertes.

Type Parameters

T
Der Datentyp des Ausgangs.

Examples

CopyC#
 1public class MyNode : Node
 2{
 3    [InPort("value")]
 4    public double Value { get; set; }
 5
 6    [OutPort("result")]
 7    public OutPortHandler<double> Result;
 8
 9    public override Work()
10    {
11        if (Value > 0.0)
12        {
13            Send(Result, Math.Sqrt(Value), TokenState.Valid);
14        }
15        else
16        {
17            SendNotSet(Result):
18        }
19    }
20}

See Also

Node Class
Send Overload
DynamicNode.Core Namespace


SendNotSet(T) Method

[image]

DynamicNodes API
Node..::..SendNotSet<(Of <(<'T>)>)> Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Setzt einen Ausgang auf den Markenstatus NotSet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected static void SendNotSet<T>(
    OutPortHandler<T> handler
)
Visual Basic
Protected Shared Sub SendNotSet(Of T) ( _
    handler As OutPortHandler(Of T) _
)
F#
static member SendNotSet :
        handler:OutPortHandler<'T> -> unit

Parameters

handler
Type: DynamicNode.Core..::..OutPortHandler <(Of <(<'T>)>)>
Der Ausgangs-Handler.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:DynamicNode.Core.Node.SendNotSet``1(DynamicNode.Core.OutPortHandler{``0})"]

See Also

Node Class
DynamicNode.Core Namespace
Node..::..Send<(Of <<'(T>)>>)(OutPortHandler<(Of <<'(T>)>>), T, TokenState)


ToString Method

[image]

DynamicNodes API
Node..::..ToString Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen String zurück, der den aktuellen Object darstellt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Ein String, der den aktuellen Object darstellt.

See Also

Node Class
DynamicNode.Core Namespace


TraceError Method

[image] [image]

DynamicNodes API
Node..::..TraceError Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Node Class
Node Members
DynamicNode.Core Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
Node..::..TraceInfo Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Node Class
Node Members
DynamicNode.Core Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
Node..::..TraceVerbose Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Node Class
Node Members
DynamicNode.Core Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
Node..::..TraceVerboseData Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Node Class
Node Members
DynamicNode.Core Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
Node..::..TraceWarning Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Node Class
Node Members
DynamicNode.Core Namespace


Work Method

[image]

DynamicNodes API
Node..::..Work Method
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract void Work()
Visual Basic
Public MustOverride Sub Work
F#
abstract Work : unit -> unit

See Also

Node Class
DynamicNode.Core Namespace


Node Properties

[image] [image]

DynamicNodes API
Node Properties
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Node type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben.
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück.
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist.
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht.
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit.
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Overrides BaseObject..::..LocalTrace.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Overrides BaseObject..::..NameDefaultValue.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück.
 | NodeTraceSource | Gibt die Ablaufverfolgungsquelle für Knoten zurück.
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück.
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird.
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden.
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück.
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück.
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück.
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false

See Also

Node Class
DynamicNode.Core Namespace


ActiveThread Property

[image]

DynamicNodes API
Node..::..ActiveThread Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Thread ActiveThread { get; }
Visual Basic
Public ReadOnly Property ActiveThread As Thread
    Get
F#
abstract ActiveThread : Thread
override ActiveThread : Thread

Field Value

Implements

INode..::..ActiveThread

See Also

Node Class
DynamicNode.Core Namespace


Commands Property

[image]

DynamicNodes API
Node..::..Commands Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IDictionary<string, string> Commands { get; }
Visual Basic
Public ReadOnly Property Commands As IDictionary(Of String, String)
    Get
F#
abstract Commands : IDictionary<string, string>
override Commands : IDictionary<string, string>

Field Value

The commands.

Implements

INode..::..Commands

See Also

Node Class
DynamicNode.Core Namespace


Graph Property

[image]

DynamicNodes API
Node..::..Graph Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IGraph Graph { get; }
Visual Basic
Public ReadOnly Property Graph As IGraph
    Get
F#
abstract Graph : IGraph
override Graph : IGraph

Field Value

Der Graph.

Implements

INode..::..Graph

See Also

Node Class
DynamicNode.Core Namespace


InPorts Property

[image]

DynamicNodes API
Node..::..InPorts Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IEnumerable<InPort> InPorts { get; }
Visual Basic
Public ReadOnly Property InPorts As IEnumerable(Of InPort)
    Get
F#
member InPorts : IEnumerable<InPort>

Field Value

Eine Sammlung mit allen Eingabe-Ports.

See Also

Node Class
DynamicNode.Core Namespace


IsActivationRequired Property

[image]

DynamicNodes API
Node..::..IsActivationRequired Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual bool IsActivationRequired { get; }
Visual Basic
Public Overridable ReadOnly Property IsActivationRequired As Boolean
    Get
F#
abstract IsActivationRequired : bool
override IsActivationRequired : bool

Field Value

true wenn diese Instanz aktiviert werden sollte, sonst false.

Implements

INode..::..IsActivationRequired

See Also

Node Class
DynamicNode.Core Namespace


IsActive Property

[image]

DynamicNodes API
Node..::..IsActive Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As Boolean
    Get
F#
abstract IsActive : bool
override IsActive : bool

Implements

INode..::..IsActive

See Also

Node Class
DynamicNode.Core Namespace


IsParallelizable Property

[image]

DynamicNodes API
Node..::..IsParallelizable Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsParallelizable { get; protected set; }
Visual Basic
Public Property IsParallelizable As Boolean
    Get
    Protected Set
F#
abstract IsParallelizable : bool with get, set
override IsParallelizable : bool with get, set

Field Value

true wenn dieser Knoten parallelisierbar ist, sonst false.

Implements

INode..::..IsParallelizable

See Also

Node Class
DynamicNode.Core Namespace


IsWorkAborted Property

[image]

DynamicNodes API
Node..::..IsWorkAborted Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsWorkAborted { get; set; }
Visual Basic
Public Property IsWorkAborted As Boolean
    Get
    Set
F#
abstract IsWorkAborted : bool with get, set
override IsWorkAborted : bool with get, set

Implements

INode..::..IsWorkAborted

See Also

Node Class
DynamicNode.Core Namespace


Item Property

[image] [image]

DynamicNodes API
Node..::..Item Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

Node Class
Node Members
DynamicNode.Core Namespace


LocalTrace Property

[image]

DynamicNodes API
Node..::..LocalTrace Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override TraceSource LocalTrace { get; }
Visual Basic
Protected Overrides ReadOnly Property LocalTrace As TraceSource
    Get
F#
abstract LocalTrace : TraceSource
override LocalTrace : TraceSource

See Also

Node Class
DynamicNode.Core Namespace


NameDefaultValue Property

[image]

DynamicNodes API
Node..::..NameDefaultValue Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standardwert für die Eigenschaft Name zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override string NameDefaultValue { get; }
Visual Basic
Protected Overrides ReadOnly Property NameDefaultValue As String
    Get
F#
abstract NameDefaultValue : string
override NameDefaultValue : string

Field Value

Der Standardwert von Name.

See Also

Node Class
DynamicNode.Core Namespace


NodeInfo Property

[image]

DynamicNodes API
Node..::..NodeInfo Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeInfoAttribute NodeInfo { get; }
Visual Basic
Public ReadOnly Property NodeInfo As NodeInfoAttribute
    Get
F#
abstract NodeInfo : NodeInfoAttribute
override NodeInfo : NodeInfoAttribute

Field Value

Eine NodeInfoAttribute-Instanz oder null, falls die Klasse das Attribut nicht besitzt.

Implements

INode..::..NodeInfo

See Also

Node Class
DynamicNode.Core Namespace


NodeTraceSource Property

[image]

DynamicNodes API
Node..::..NodeTraceSource Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ablaufverfolgungsquelle für Knoten zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TraceSource NodeTraceSource { get; }
Visual Basic
Public Shared ReadOnly Property NodeTraceSource As TraceSource
    Get
F#
static member NodeTraceSource : TraceSource

See Also

Node Class
DynamicNode.Core Namespace


OutPorts Property

[image]

DynamicNodes API
Node..::..OutPorts Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IEnumerable<OutPort> OutPorts { get; }
Visual Basic
Public ReadOnly Property OutPorts As IEnumerable(Of OutPort)
    Get
F#
member OutPorts : IEnumerable<OutPort>

Field Value

Eine Sammlung mit allen Ausgabe-Ports.

See Also

Node Class
DynamicNode.Core Namespace


Parallelizing Property

[image]

DynamicNodes API
Node..::..Parallelizing Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Parallelizing Parallelizing { get; set; }
Visual Basic
Public Property Parallelizing As Parallelizing
    Get
    Set
F#
abstract Parallelizing : Parallelizing with get, set
override Parallelizing : Parallelizing with get, set

Field Value

Die Form der Parallelisierung.

Implements

INode..::..Parallelizing

See Also

Node Class
DynamicNode.Core Namespace


Reactivate Property

[image]

DynamicNodes API
Node..::..Reactivate Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool Reactivate { get; set; }
Visual Basic
Public Property Reactivate As Boolean
    Get
    Set
F#
member Reactivate : bool with get, set

Field Value

true wenn der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll, sonst false.

See Also

Node Class
DynamicNode.Core Namespace


SingleThreadContextId Property

[image]

DynamicNodes API
Node..::..SingleThreadContextId Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string SingleThreadContextId { get; set; }
Visual Basic
Public Property SingleThreadContextId As String
    Get
    Set
F#
abstract SingleThreadContextId : string with get, set
override SingleThreadContextId : string with get, set

Field Value

Die ID für den Synchronisierungskontext

Implements

INode..::..SingleThreadContextId

See Also

Node Class
DynamicNode.Core Namespace


ThreadManager Property

[image]

DynamicNodes API
Node..::..ThreadManager Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Manager für die Parallelverarbeitung zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IThreadManager ThreadManager { get; }
Visual Basic
Public ReadOnly Property ThreadManager As IThreadManager
    Get
F#
member ThreadManager : IThreadManager

Field Value

Der Manager für die Parallelverarbeitung.

See Also

Node Class
DynamicNode.Core Namespace


TypeCaption Property

[image]

DynamicNodes API
Node..::..TypeCaption Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung des Knoten-Typs zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string TypeCaption { get; }
Visual Basic
Public ReadOnly Property TypeCaption As String
    Get
F#
abstract TypeCaption : string
override TypeCaption : string

Field Value

Die Beschriftung des Knoten-Typs.

Implements

INode..::..TypeCaption

See Also

Node Class
DynamicNode.Core Namespace


TypeDescription Property

[image]

DynamicNodes API
Node..::..TypeDescription Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Knoten-Typs zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string TypeDescription { get; }
Visual Basic
Public ReadOnly Property TypeDescription As String
    Get
F#
abstract TypeDescription : string
override TypeDescription : string

Field Value

Die Beschreibung des Knoten-Typs.

Implements

INode..::..TypeDescription

See Also

Node Class
DynamicNode.Core Namespace


TypeGroup Property

[image]

DynamicNodes API
Node..::..TypeGroup Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Gruppe des Knoten-Typs zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string TypeGroup { get; }
Visual Basic
Public ReadOnly Property TypeGroup As String
    Get
F#
abstract TypeGroup : string
override TypeGroup : string

Field Value

Die Gruppe des Knoten-Typs.

Implements

INode..::..TypeGroup

See Also

Node Class
DynamicNode.Core Namespace


WasReactivated Property

[image]

DynamicNodes API
Node..::..WasReactivated Property
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected bool WasReactivated { get; }
Visual Basic
Protected ReadOnly Property WasReactivated As Boolean
    Get
F#
member WasReactivated : bool

See Also

Node Class
DynamicNode.Core Namespace


Node Events

[image] [image]

DynamicNodes API
Node Events
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Node type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet.
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird.
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird.
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)

See Also

Node Class
DynamicNode.Core Namespace


AfterActivation Event

[image]

DynamicNodes API
Node..::..AfterActivation Event
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die Aktivierung endet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler AfterActivation
Visual Basic
Public Event AfterActivation As EventHandler
F#
abstract AfterActivation : IEvent<EventHandler,
    EventArgs>
override AfterActivation : IEvent<EventHandler,
    EventArgs>

Implements

INode..::..AfterActivation

See Also

Node Class
DynamicNode.Core Namespace


BeforeActivation Event

[image]

DynamicNodes API
Node..::..BeforeActivation Event
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, bevor der Knoten aktiviert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler BeforeActivation
Visual Basic
Public Event BeforeActivation As EventHandler
F#
abstract BeforeActivation : IEvent<EventHandler,
    EventArgs>
override BeforeActivation : IEvent<EventHandler,
    EventArgs>

Implements

INode..::..BeforeActivation

See Also

Node Class
DynamicNode.Core Namespace


BeforeReactivation Event

[image]

DynamicNodes API
Node..::..BeforeReactivation Event
Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Knoten erneut aktiviert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler BeforeReactivation
Visual Basic
Public Event BeforeReactivation As EventHandler
F#
abstract BeforeReactivation : IEvent<EventHandler,
    EventArgs>
override BeforeReactivation : IEvent<EventHandler,
    EventArgs>

Implements

INode..::..BeforeReactivation

See Also

Node Class
DynamicNode.Core Namespace


NodeEventArgs Class

[image]

DynamicNodes API
NodeEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignisargumente, welche die Änderung eines Knotens näher beschreiben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class NodeEventArgs : EventArgs
Visual Basic
Public Class NodeEventArgs _
    Inherits EventArgs
F#
type NodeEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Core..::..NodeEventArgs

See Also

NodeEventArgs Members
DynamicNode.Core Namespace


NodeEventArgs Members

[image] [image]

DynamicNodes API
NodeEventArgs Members
NodeEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | NodeEventArgs | Initialisiert eine NodeEventArgs-Instanz.

Properties

 | Name | Description
Public property | Graph | Gibt den betroffenen Graphen zurück.
Public property | Node | Gibt den Knoten zurück, welcher von dem Ereignis betroffen ist.
Public property | Typ | Gibt den Ereignistyp zurück.

See Also

NodeEventArgs Class
DynamicNode.Core Namespace


NodeEventArgs Constructor

[image]

DynamicNodes API
NodeEventArgs Constructor
NodeEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine NodeEventArgs-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeEventArgs(
    IGraph graph,
    INode node,
    Affection typ
)
Visual Basic
Public Sub New ( _
    graph As IGraph, _
    node As INode, _
    typ As Affection _
)
F#
new :
        graph:IGraph *
        node:INode *
        typ:Affection -> NodeEventArgs

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Das auslösende Graph.
node
Type: DynamicNode.Core..::..INode
Der betroffene Knoten.
typ
Type: DynamicNode.Core..::..Affection
Der Ereignistyp.

See Also

NodeEventArgs Class
DynamicNode.Core Namespace


NodeEventArgs Properties

[image] [image]

DynamicNodes API
NodeEventArgs Properties
NodeEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Graph | Gibt den betroffenen Graphen zurück.
Public property | Node | Gibt den Knoten zurück, welcher von dem Ereignis betroffen ist.
Public property | Typ | Gibt den Ereignistyp zurück.

See Also

NodeEventArgs Class
DynamicNode.Core Namespace


Graph Property

[image]

DynamicNodes API
NodeEventArgs..::..Graph Property
NodeEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den betroffenen Graphen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IGraph Graph { get; }
Visual Basic
Public ReadOnly Property Graph As IGraph
    Get
F#
member Graph : IGraph

Field Value

Das betroffene Graph.

See Also

NodeEventArgs Class
DynamicNode.Core Namespace


Node Property

[image]

DynamicNodes API
NodeEventArgs..::..Node Property
NodeEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Knoten zurück, welcher von dem Ereignis betroffen ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public INode Node { get; }
Visual Basic
Public ReadOnly Property Node As INode
    Get
F#
member Node : INode

Field Value

Der betroffene Knoten.

See Also

NodeEventArgs Class
DynamicNode.Core Namespace


Typ Property

[image]

DynamicNodes API
NodeEventArgs..::..Typ Property
NodeEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Ereignistyp zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Affection Typ { get; }
Visual Basic
Public ReadOnly Property Typ As Affection
    Get
F#
member Typ : Affection

Field Value

Der Ereignistyp.

See Also

NodeEventArgs Class
DynamicNode.Core Namespace


NodeFactory Class

[image]

DynamicNodes API
NodeFactory Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwaltet alle verfügbaren Knotentypen und bietet Methoden zum Instanzieren von neuen Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class NodeFactory
Visual Basic
Public Class NodeFactory
F#
type NodeFactory =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..NodeFactory

See Also

NodeFactory Members
DynamicNode.Core Namespace


NodeFactory Members

[image] [image]

DynamicNodes API
NodeFactory Members
NodeFactory Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeFactory type exposes the following members.

Constructors

 | Name | Description
Public method | NodeFactory | Initialisiert eine NodeFactory-Instanz.

Methods

 | Name | Description
Public method | CreateNodeInstance | Instanziert einen Knoten mit Hilfe seiner Klasse.
Public method | LoadAssembly | Versucht ein Assembly zu laden.
Public method | LoadNode(String) | Versucht einen Knoten zu instanzieren.
Public method | LoadNode(Type) | Versucht einen Knoten zu instanzieren.
Public method | ReadFromXmlFile | Lädt die Registrierung aus einer XML-Datei.
Public method | RegisterAllAvailableNodes | Lädt alle Assemblies im Bibliothekspfad und durchsucht sie nach Klassen, die von Node abgeleitet sind. Alle diese Klassen, die sich parameterlos instanzieren lassen, werden registriert.
 | RegisterCustomFactory | Registriert eine benutzerdefinierte Knoten-Factory.
Public method | RegisterNode(Type) | Registriert einen Knotentyp mit Hilfe eines Type.
Public method | RegisterNode(String, String) | Registriert explizit einen Knoten mit Hilfe eines Assembly- und eines Typ-Namens.
 | UseCustomFactory | Gibt eine benutzerdefinierte Factory anhand ihrer ID zurück und entfernt sie aus der Liste der registrierten Factories.
Public method | WriteToXmlFile | Sichert die aktuelle Registrierung als XML-Datei.

Properties

 | Name | Description
Public property | GroupNames | Gibt ein Array mit den Gruppennamen aller registrierten Knoten zurück.
Public property | NodeIDs | Gibt ein Array mit den IDs aller registrierten Knoten zurück.
Public property | NodeIDsByGroup | Gibt ein Verzeichnis mit allen Gruppen und den zugehörigen Knoten zurück.
Public property | NodeTypeWrappers | Gibt ein Array mit den Typen aller registrierten Knoten zurück.

See Also

NodeFactory Class
DynamicNode.Core Namespace


NodeFactory Constructor

[image]

DynamicNodes API
NodeFactory Constructor
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine NodeFactory-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeFactory(
    IRuntime runtime
)
Visual Basic
Public Sub New ( _
    runtime As IRuntime _
)
F#
new :
        runtime:IRuntime -> NodeFactory

Parameters

runtime
Type: DynamicNode.Core..::..IRuntime
Die Laufzeitumgebung.

See Also

NodeFactory Class
DynamicNode.Core Namespace


NodeFactory Methods

[image] [image]

DynamicNodes API
NodeFactory Methods
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateNodeInstance | Instanziert einen Knoten mit Hilfe seiner Klasse.
Public method | LoadAssembly | Versucht ein Assembly zu laden.
Public method | LoadNode(String) | Versucht einen Knoten zu instanzieren.
Public method | LoadNode(Type) | Versucht einen Knoten zu instanzieren.
Public method | ReadFromXmlFile | Lädt die Registrierung aus einer XML-Datei.
Public method | RegisterAllAvailableNodes | Lädt alle Assemblies im Bibliothekspfad und durchsucht sie nach Klassen, die von Node abgeleitet sind. Alle diese Klassen, die sich parameterlos instanzieren lassen, werden registriert.
 | RegisterCustomFactory | Registriert eine benutzerdefinierte Knoten-Factory.
Public method | RegisterNode(Type) | Registriert einen Knotentyp mit Hilfe eines Type.
Public method | RegisterNode(String, String) | Registriert explizit einen Knoten mit Hilfe eines Assembly- und eines Typ-Namens.
 | UseCustomFactory | Gibt eine benutzerdefinierte Factory anhand ihrer ID zurück und entfernt sie aus der Liste der registrierten Factories.
Public method | WriteToXmlFile | Sichert die aktuelle Registrierung als XML-Datei.

See Also

NodeFactory Class
DynamicNode.Core Namespace


CreateNodeInstance Method

[image]

DynamicNodes API
NodeFactory..::..CreateNodeInstance Method
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Instanziert einen Knoten mit Hilfe seiner Klasse.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public INode CreateNodeInstance(
    Type nodeType
)
Visual Basic
Public Function CreateNodeInstance ( _
    nodeType As Type _
) As INode
F#
member CreateNodeInstance :
        nodeType:Type -> INode

Parameters

nodeType
Type: System..::..Type
Der Type des Knotentyps. Der übergebene Typ muss einen parameterlosen Konstruktor besitzen.

Return Value

Eine neue Knoten-Instanz vom Typ nodeType oder null, wenn der Knoten nicht erzeugt werden konnte.

See Also

NodeFactory Class
DynamicNode.Core Namespace


LoadAssembly Method

[image]

DynamicNodes API
NodeFactory..::..LoadAssembly Method
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht ein Assembly zu laden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Assembly LoadAssembly(
    string path,
    bool registerProbePath,
    bool traceSuccess
)
Visual Basic
Public Function LoadAssembly ( _
    path As String, _
    registerProbePath As Boolean, _
    traceSuccess As Boolean _
) As Assembly
F#
member LoadAssembly :
        path:string *
        registerProbePath:bool *
        traceSuccess:bool -> Assembly

Parameters

path
Type: System..::..String
Der Assembly-Pfad.
registerProbePath
Type: System..::..Boolean
Ein Wert der angibt, ob aus dem übergebenen Assembly-Pfad ein zusätzlicher Probing-Pfad für Abhängigkeiten abgeleitet und, falls vorhanden, registriert werden soll.
traceSuccess
Type: System..::..Boolean
Gibt an, ob bei erfolgreichem Laden eine Trace-Meldung erzeugt werden soll.

Return Value

Ein Assembly oder null, wenn das Assembly nicht geladen werden konnte.

See Also

NodeFactory Class
DynamicNode.Core Namespace


LoadNode Method

[image] [image]

DynamicNodes API
NodeFactory..::..LoadNode Method
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | LoadNode(String) | Versucht einen Knoten zu instanzieren.
Public method | LoadNode(Type) | Versucht einen Knoten zu instanzieren.

See Also

NodeFactory Class
NodeFactory Members
DynamicNode.Core Namespace


LoadNode Method (String)

[image]

DynamicNodes API
NodeFactory..::..LoadNode Method (String)
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht einen Knoten zu instanzieren.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public INode LoadNode(
    string type
)
Visual Basic
Public Function LoadNode ( _
    type As String _
) As INode
F#
member LoadNode :
        type:string -> INode

Parameters

type
Type: System..::..String
Der volle Typen-Name des Knotens.

Return Value

Eine neue Knoten-Instanz oder null wenn der Versuch fehlschlägt.

See Also

NodeFactory Class
LoadNode Overload
DynamicNode.Core Namespace


LoadNode Method (Type)

[image]

DynamicNodes API
NodeFactory..::..LoadNode Method (Type)
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht einen Knoten zu instanzieren.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public INode LoadNode(
    Type type
)
Visual Basic
Public Function LoadNode ( _
    type As Type _
) As INode
F#
member LoadNode :
        type:Type -> INode

Parameters

type
Type: System..::..Type
Der Knoten-Type.

Return Value

Eine neue Knoten-Instanz oder null wenn der Versuch fehlschlägt.

See Also

NodeFactory Class
LoadNode Overload
DynamicNode.Core Namespace


ReadFromXmlFile Method

[image]

DynamicNodes API
NodeFactory..::..ReadFromXmlFile Method
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Lädt die Registrierung aus einer XML-Datei.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ReadFromXmlFile(
    string file
)
Visual Basic
Public Sub ReadFromXmlFile ( _
    file As String _
)
F#
member ReadFromXmlFile :
        file:string -> unit

Parameters

file
Type: System..::..String
Die Quelldatei.

See Also

NodeFactory Class
DynamicNode.Core Namespace


RegisterAllAvailableNodes Method

[image]

DynamicNodes API
NodeFactory..::..RegisterAllAvailableNodes Method
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Lädt alle Assemblies im Bibliothekspfad und durchsucht sie nach Klassen, die von Node abgeleitet sind. Alle diese Klassen, die sich parameterlos instanzieren lassen, werden registriert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RegisterAllAvailableNodes(
    string[] addPaths,
    string[] addLibs,
    bool sysLibs,
    bool userLibs
)
Visual Basic
Public Sub RegisterAllAvailableNodes ( _
    addPaths As String(), _
    addLibs As String(), _
    sysLibs As Boolean, _
    userLibs As Boolean _
)
F#
member RegisterAllAvailableNodes :
        addPaths:string[] *
        addLibs:string[] *
        sysLibs:bool *
        userLibs:bool -> unit

Parameters

addPaths
Type: array< System..::..String >[]()[][]
Verzeichnise mit zusätzlichen Knotenbibliotheken.
addLibs
Type: array< System..::..String >[]()[][]
Pfade von einzelnen zusätzlichen Knotenbibliotheken.
sysLibs
Type: System..::..Boolean
Wenn true übergeben wird, werden die System-Knotenbibliotheken durchsucht, sonst werden keine Knoten aus den System-Knotenbibliotheken registriert.
userLibs
Type: System..::..Boolean
Wenn true übergeben wird, werden die Benutzer-Knotenbibliotheken durchsucht, sonst werden keine Knoten aus den Benutzer-Knotenbibliotheken registriert.

See Also

NodeFactory Class
DynamicNode.Core Namespace


RegisterCustomFactory Method

[image]

DynamicNodes API
NodeFactory..::..RegisterCustomFactory Method
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert eine benutzerdefinierte Knoten-Factory.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string RegisterCustomFactory(
    ICustomNodeFactory factory
)
Visual Basic
Public Shared Function RegisterCustomFactory ( _
    factory As ICustomNodeFactory _
) As String
F#
static member RegisterCustomFactory :
        factory:ICustomNodeFactory -> string

Parameters

factory
Type: DynamicNode.Core..::..ICustomNodeFactory
Die Factory.

Return Value

Ein Ticket zur späteren Verwendung der Factory.

See Also

NodeFactory Class
DynamicNode.Core Namespace


RegisterNode Method

[image] [image]

DynamicNodes API
NodeFactory..::..RegisterNode Method
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RegisterNode(Type) | Registriert einen Knotentyp mit Hilfe eines Type.
Public method | RegisterNode(String, String) | Registriert explizit einen Knoten mit Hilfe eines Assembly- und eines Typ-Namens.

See Also

NodeFactory Class
NodeFactory Members
DynamicNode.Core Namespace


RegisterNode Method (Type)

[image]

DynamicNodes API
NodeFactory..::..RegisterNode Method (Type)
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert einen Knotentyp mit Hilfe eines Type.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RegisterNode(
    Type type
)
Visual Basic
Public Sub RegisterNode ( _
    type As Type _
)
F#
member RegisterNode :
        type:Type -> unit

Parameters

type
Type: System..::..Type
Die Klasse des Knotentyps.

See Also

NodeFactory Class
RegisterNode Overload
DynamicNode.Core Namespace


RegisterNode Method (String, String)

[image]

DynamicNodes API
NodeFactory..::..RegisterNode Method (String, String)
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert explizit einen Knoten mit Hilfe eines Assembly- und eines Typ-Namens.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RegisterNode(
    string assembly,
    string typeName
)
Visual Basic
Public Sub RegisterNode ( _
    assembly As String, _
    typeName As String _
)
F#
member RegisterNode :
        assembly:string *
        typeName:string -> unit

Parameters

assembly
Type: System..::..String
Das Assembly.
typeName
Type: System..::..String
Der Typ-Name des Knotens.

See Also

NodeFactory Class
RegisterNode Overload
DynamicNode.Core Namespace


UseCustomFactory Method

[image]

DynamicNodes API
NodeFactory..::..UseCustomFactory Method
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine benutzerdefinierte Factory anhand ihrer ID zurück und entfernt sie aus der Liste der registrierten Factories.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static ICustomNodeFactory UseCustomFactory(
    string ticket
)
Visual Basic
Public Shared Function UseCustomFactory ( _
    ticket As String _
) As ICustomNodeFactory
F#
static member UseCustomFactory :
        ticket:string -> ICustomNodeFactory

Parameters

ticket
Type: System..::..String
Das Ticket für die Factory.

Return Value

Eine benutzerdefinierte Factory oder null, wenn unter dem Ticket keine Factory gefunden wurde.

See Also

NodeFactory Class
DynamicNode.Core Namespace


WriteToXmlFile Method

[image]

DynamicNodes API
NodeFactory..::..WriteToXmlFile Method
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die aktuelle Registrierung als XML-Datei.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteToXmlFile(
    string file
)
Visual Basic
Public Sub WriteToXmlFile ( _
    file As String _
)
F#
member WriteToXmlFile :
        file:string -> unit

Parameters

file
Type: System..::..String
Die Zieldatei.

See Also

NodeFactory Class
DynamicNode.Core Namespace


NodeFactory Properties

[image] [image]

DynamicNodes API
NodeFactory Properties
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeFactory type exposes the following members.

Properties

 | Name | Description
Public property | GroupNames | Gibt ein Array mit den Gruppennamen aller registrierten Knoten zurück.
Public property | NodeIDs | Gibt ein Array mit den IDs aller registrierten Knoten zurück.
Public property | NodeIDsByGroup | Gibt ein Verzeichnis mit allen Gruppen und den zugehörigen Knoten zurück.
Public property | NodeTypeWrappers | Gibt ein Array mit den Typen aller registrierten Knoten zurück.

See Also

NodeFactory Class
DynamicNode.Core Namespace


GroupNames Property

[image]

DynamicNodes API
NodeFactory..::..GroupNames Property
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit den Gruppennamen aller registrierten Knoten zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string[] GroupNames { get; }
Visual Basic
Public ReadOnly Property GroupNames As String()
    Get
F#
member GroupNames : string[]

Field Value

Alle Gruppennamen.

See Also

NodeFactory Class
DynamicNode.Core Namespace


NodeIDs Property

[image]

DynamicNodes API
NodeFactory..::..NodeIDs Property
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit den IDs aller registrierten Knoten zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string[] NodeIDs { get; }
Visual Basic
Public ReadOnly Property NodeIDs As String()
    Get
F#
member NodeIDs : string[]

Field Value

Alle Knotennamen.

See Also

NodeFactory Class
DynamicNode.Core Namespace


NodeIDsByGroup Property

[image]

DynamicNodes API
NodeFactory..::..NodeIDsByGroup Property
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Verzeichnis mit allen Gruppen und den zugehörigen Knoten zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IDictionary<string, List<Type>> NodeIDsByGroup { get; }
Visual Basic
Public ReadOnly Property NodeIDsByGroup As IDictionary(Of String, List(Of Type))
    Get
F#
member NodeIDsByGroup : IDictionary<string, List<Type>>

Field Value

Alle Knoten, nach Gruppennamen gruppiert.

See Also

NodeFactory Class
DynamicNode.Core Namespace


NodeTypeWrappers Property

[image]

DynamicNodes API
NodeFactory..::..NodeTypeWrappers Property
NodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit den Typen aller registrierten Knoten zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeFactory..::..NodeTypeWrapper[] NodeTypeWrappers { get; }
Visual Basic
Public ReadOnly Property NodeTypeWrappers As NodeFactory..::..NodeTypeWrapper()
    Get
F#
member NodeTypeWrappers : NodeFactory..::..NodeTypeWrapper[]

Field Value

Alle Knoten-Typen.

See Also

NodeFactory Class
DynamicNode.Core Namespace


NodeFactory.NodeTypeWrapper Class

[image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper Class
NodeFactory Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Kapselt die Beschreibung eines Knotentyps.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class NodeTypeWrapper
Visual Basic
Public Class NodeTypeWrapper
F#
type NodeTypeWrapper =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..NodeFactory..::..NodeTypeWrapper

See Also

NodeFactory..::..NodeTypeWrapper Members
DynamicNode.Core Namespace


NodeFactory.NodeTypeWrapper Members

[image] [image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper Members
NodeFactory..::..NodeTypeWrapper Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Verwaltet alle verfügbaren Knotentypen und bietet Methoden zum Instanzieren von neuen Knoten.

The NodeFactory..::..NodeTypeWrapper type exposes the following members.

Constructors

 | Name | Description
Public method | NodeFactory..::..NodeTypeWrapper | Initialisiert eine NodeTypeWrappers-Instanz.

Methods

 | Name | Description
Public method | Equals(String) | Überprüft, ob die Knotenbeschreibung übereinstimmt.
Public method | Equals(NodeFactory..::..NodeTypeWrapper) | Überprüft, ob die Knotenbeschreibung übereinstimmt.
Public method | ToString | Gibt ein String zurück, der den Knotentyp beschreibt. Dabei wird folgende Syntax verwendet: "Gruppe/Subgruppe:Knotenname". (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung des Knotentyps zurück.
Public property | Description | Gibt die Beschreibung des Knotentyps zurück.
Public property | Group | Gibt die Gruppe des Knotentyps zurück.
Public property | Type | Gibt den Type des Knotentyps zurück.

See Also

NodeFactory..::..NodeTypeWrapper Class
DynamicNode.Core Namespace


NodeFactory.NodeTypeWrapper Constructor

[image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper Constructor
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine NodeTypeWrappers-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeTypeWrapper(
    Type type
)
Visual Basic
Public Sub New ( _
    type As Type _
)
F#
new :
        type:Type -> NodeTypeWrapper

Parameters

type
Type: System..::..Type
Der Knotentyp als Type.

See Also

NodeFactory..::..NodeTypeWrapper Class
DynamicNode.Core Namespace


NodeFactory.NodeTypeWrapper Methods

[image] [image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper Methods
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeFactory..::..NodeTypeWrapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals(String) | Überprüft, ob die Knotenbeschreibung übereinstimmt.
Public method | Equals(NodeFactory..::..NodeTypeWrapper) | Überprüft, ob die Knotenbeschreibung übereinstimmt.
Public method | ToString | Gibt ein String zurück, der den Knotentyp beschreibt. Dabei wird folgende Syntax verwendet: "Gruppe/Subgruppe:Knotenname". (Overrides Object..::..ToString()()()().)

See Also

NodeFactory..::..NodeTypeWrapper Class
DynamicNode.Core Namespace


Equals Method

[image] [image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper..::..Equals Method
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Equals(String) | Überprüft, ob die Knotenbeschreibung übereinstimmt.
Public method | Equals(NodeFactory..::..NodeTypeWrapper) | Überprüft, ob die Knotenbeschreibung übereinstimmt.

See Also

NodeFactory..::..NodeTypeWrapper Class
NodeFactory..::..NodeTypeWrapper Members
DynamicNode.Core Namespace


Equals Method (String)

[image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper..::..Equals Method (String)
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob die Knotenbeschreibung übereinstimmt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool Equals(
    string typeName
)
Visual Basic
Public Function Equals ( _
    typeName As String _
) As Boolean
F#
member Equals :
        typeName:string -> bool

Parameters

typeName
Type: System..::..String
Der Type des zu vergleichenden Knotentyps.

Return Value

true, wenn der durch dieses Objekt beschriebene Knotentyp gleich typeName ist, sonst false.

See Also

NodeFactory..::..NodeTypeWrapper Class
Equals Overload
DynamicNode.Core Namespace


Equals Method (NodeFactory.NodeTypeWrapper)

[image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper..::..Equals Method (NodeFactory..::..NodeTypeWrapper)
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob die Knotenbeschreibung übereinstimmt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool Equals(
    NodeFactory..::..NodeTypeWrapper ntw
)
Visual Basic
Public Function Equals ( _
    ntw As NodeFactory..::..NodeTypeWrapper _
) As Boolean
F#
member Equals :
        ntw:NodeFactory..::..NodeTypeWrapper -> bool

Parameters

ntw
Type: DynamicNode.Core..::..NodeFactory..::..NodeTypeWrapper
Ein NodeFactory..::..NodeTypeWrapper.

Return Value

true wenn sowohl ntw, als auch dieser NodeFactory..::..NodeTypeWrapper den selben Knotentyp beschreiben.

See Also

NodeFactory..::..NodeTypeWrapper Class
Equals Overload
DynamicNode.Core Namespace


ToString Method

[image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper..::..ToString Method
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein String zurück, der den Knotentyp beschreibt. Dabei wird folgende Syntax verwendet: "Gruppe/Subgruppe:Knotenname".

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Einen String der den Knotentyp beschreibt.

See Also

NodeFactory..::..NodeTypeWrapper Class
DynamicNode.Core Namespace


NodeFactory.NodeTypeWrapper Properties

[image] [image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper Properties
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeFactory..::..NodeTypeWrapper type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung des Knotentyps zurück.
Public property | Description | Gibt die Beschreibung des Knotentyps zurück.
Public property | Group | Gibt die Gruppe des Knotentyps zurück.
Public property | Type | Gibt den Type des Knotentyps zurück.

See Also

NodeFactory..::..NodeTypeWrapper Class
DynamicNode.Core Namespace


Caption Property

[image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper..::..Caption Property
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung des Knotentyps zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Caption { get; }
Visual Basic
Public ReadOnly Property Caption As String
    Get
F#
member Caption : string

Field Value

Der Knotentypname.

See Also

NodeFactory..::..NodeTypeWrapper Class
DynamicNode.Core Namespace


Description Property

[image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper..::..Description Property
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Knotentyps zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
F#
member Description : string

Field Value

Die Knotentypenbeschreibung.

See Also

NodeFactory..::..NodeTypeWrapper Class
DynamicNode.Core Namespace


Group Property

[image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper..::..Group Property
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Gruppe des Knotentyps zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Group { get; }
Visual Basic
Public ReadOnly Property Group As String
    Get
F#
member Group : string

Field Value

Die Knotentypengruppe.

See Also

NodeFactory..::..NodeTypeWrapper Class
DynamicNode.Core Namespace


Type Property

[image]

DynamicNodes API
NodeFactory..::..NodeTypeWrapper..::..Type Property
NodeFactory..::..NodeTypeWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Type des Knotentyps zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Type Type { get; }
Visual Basic
Public ReadOnly Property Type As Type
    Get
F#
member Type : Type

Field Value

Die Klasse des Knotentyps.

See Also

NodeFactory..::..NodeTypeWrapper Class
DynamicNode.Core Namespace


NodeInfoAttribute Class

[image]

DynamicNodes API
NodeInfoAttribute Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Dieses Attribut wird verwendet um eine von Node abgeleitete Klasse mit Meta-Daten zu versehen. Diese Meta-Daten werden verwendet um eine Auswahl der verfügbaren Knoten-Typen in der Benutzeroberfläche zu ermöglichen, ohne einen Knoten zu instanzieren.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class NodeInfoAttribute : Attribute,
    IComparable<NodeInfoAttribute>
Visual Basic
Public Class NodeInfoAttribute _
    Inherits Attribute _
    Implements IComparable(Of NodeInfoAttribute)
F#
type NodeInfoAttribute =
    class
        inherit Attribute
        interface IComparable<NodeInfoAttribute>
    end

Remarks

Bei direkter Verwendung von NodeInfoAttribute, ist keine Lokalisierung möglich. Um mit Hilfe von lokalisierten Resourcen die Metadaten anzugeben, muss das Attribut StaticNodeInfoAttribute verwendet werden.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
DynamicNode.Core..::..NodeInfoAttribute

See Also

NodeInfoAttribute Members
DynamicNode.Core Namespace


NodeInfoAttribute Members

[image] [image]

DynamicNodes API
NodeInfoAttribute Members
NodeInfoAttribute Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeInfoAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | NodeInfoAttribute(String) | Initialisiert eine NodeInfoAttribute-Instanz. Als Knoten-Gruppe wird "Standard" verwendet.
Public method | NodeInfoAttribute(String, String) | Initialisiert eine NodeInfoAttribute-Instanz.
Public method | NodeInfoAttribute(String, String, String) | Initialisiert eine NodeInfoAttribute-Instanz.

Methods

 | Name | Description
Public method | CompareTo | Vergleicht diese Knoten-Info mit einer anderen.
 | FromNode | Ermittelt zu einem Knotentyp die Knoten-Info.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | Description | Gibt eine Kurzbeschreibung für diesen Knoten-Typ zurück.
Public property | Group | Gibt die Knoten-Gruppe zurück.

See Also

NodeInfoAttribute Class
DynamicNode.Core Namespace


NodeInfoAttribute Constructor

[image] [image]

DynamicNodes API
NodeInfoAttribute Constructor
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | NodeInfoAttribute(String) | Initialisiert eine NodeInfoAttribute-Instanz. Als Knoten-Gruppe wird "Standard" verwendet.
Public method | NodeInfoAttribute(String, String) | Initialisiert eine NodeInfoAttribute-Instanz.
Public method | NodeInfoAttribute(String, String, String) | Initialisiert eine NodeInfoAttribute-Instanz.

See Also

NodeInfoAttribute Class
NodeInfoAttribute Members
DynamicNode.Core Namespace


NodeInfoAttribute Constructor (String)

[image]

DynamicNodes API
NodeInfoAttribute Constructor (String)
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine NodeInfoAttribute-Instanz. Als Knoten-Gruppe wird "Standard" verwendet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeInfoAttribute(
    string caption
)
Visual Basic
Public Sub New ( _
    caption As String _
)
F#
new :
        caption:string -> NodeInfoAttribute

Parameters

caption
Type: System..::..String
Die Beschriftung des Knoten-Typs.

See Also

NodeInfoAttribute Class
NodeInfoAttribute Overload
DynamicNode.Core Namespace


NodeInfoAttribute Constructor (String, String)

[image]

DynamicNodes API
NodeInfoAttribute Constructor (String, String)
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine NodeInfoAttribute-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeInfoAttribute(
    string caption,
    string group
)
Visual Basic
Public Sub New ( _
    caption As String, _
    group As String _
)
F#
new :
        caption:string *
        group:string -> NodeInfoAttribute

Parameters

caption
Type: System..::..String
Die Beschriftung des Knoten-Typs.
group
Type: System..::..String
Die Knoten-Gruppe.

See Also

NodeInfoAttribute Class
NodeInfoAttribute Overload
DynamicNode.Core Namespace


NodeInfoAttribute Constructor (String, String, String)

[image]

DynamicNodes API
NodeInfoAttribute Constructor (String, String, String)
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine NodeInfoAttribute-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeInfoAttribute(
    string caption,
    string group,
    string description
)
Visual Basic
Public Sub New ( _
    caption As String, _
    group As String, _
    description As String _
)
F#
new :
        caption:string *
        group:string *
        description:string -> NodeInfoAttribute

Parameters

caption
Type: System..::..String
Die Beschriftung des Knoten-Typs.
group
Type: System..::..String
Die Knoten-Gruppe.
description
Type: System..::..String
Eine Kurz-Beschreibung des Knoten-Typs.

See Also

NodeInfoAttribute Class
NodeInfoAttribute Overload
DynamicNode.Core Namespace


NodeInfoAttribute Methods

[image] [image]

DynamicNodes API
NodeInfoAttribute Methods
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeInfoAttribute type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Vergleicht diese Knoten-Info mit einer anderen.
 | FromNode | Ermittelt zu einem Knotentyp die Knoten-Info.

See Also

NodeInfoAttribute Class
DynamicNode.Core Namespace


CompareTo Method

[image]

DynamicNodes API
NodeInfoAttribute..::..CompareTo Method
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Vergleicht diese Knoten-Info mit einer anderen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int CompareTo(
    NodeInfoAttribute other
)
Visual Basic
Public Function CompareTo ( _
    other As NodeInfoAttribute _
) As Integer
F#
abstract CompareTo :
        other:NodeInfoAttribute -> int
override CompareTo :
        other:NodeInfoAttribute -> int

Parameters

other
Type: DynamicNode.Core..::..NodeInfoAttribute
Die andere Knoten-Info.

Return Value

Einen 32-Bit vorzeichenbehafteten Integer, der angibt in welcher relativen Reihenfolge sich die verglichenen Objekte befinden. Der Rückgabewert hat die folgende Bedeutung: Ein Wert kleiner 0 bedeutet, dieses Objekt ist kleiner als other. Ein Wert gleich 0 bedeutet, dieses Objekt ist gleich other. Ein Wert größer als 0 bedeutet, dieses Objekt ist größer als other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

NodeInfoAttribute Class
DynamicNode.Core Namespace


FromNode Method

[image]

DynamicNodes API
NodeInfoAttribute..::..FromNode Method
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ermittelt zu einem Knotentyp die Knoten-Info.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static NodeInfoAttribute FromNode(
    Type type
)
Visual Basic
Public Shared Function FromNode ( _
    type As Type _
) As NodeInfoAttribute
F#
static member FromNode :
        type:Type -> NodeInfoAttribute

Parameters

type
Type: System..::..Type
Der Knoten-Type.

Return Value

Ein NodeInfoAttribute-Objekt oder null, wenn der Knoten keine Meta-Informationen definiert.

Remarks

Das funktioniert auch, wenn die Knoten-Info mit Hilfe von StaticNodeInfoAttribute angegeben werden.

See Also

NodeInfoAttribute Class
DynamicNode.Core Namespace


NodeInfoAttribute Properties

[image] [image]

DynamicNodes API
NodeInfoAttribute Properties
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeInfoAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | Description | Gibt eine Kurzbeschreibung für diesen Knoten-Typ zurück.
Public property | Group | Gibt die Knoten-Gruppe zurück.

See Also

NodeInfoAttribute Class
DynamicNode.Core Namespace


Caption Property

[image]

DynamicNodes API
NodeInfoAttribute..::..Caption Property
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung des Knoten-Typs zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Caption { get; }
Visual Basic
Public ReadOnly Property Caption As String
    Get
F#
member Caption : string

Field Value

Die Beschriftung des Knoten-Typs.

See Also

NodeInfoAttribute Class
DynamicNode.Core Namespace


Description Property

[image]

DynamicNodes API
NodeInfoAttribute..::..Description Property
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kurzbeschreibung für diesen Knoten-Typ zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
F#
member Description : string

Field Value

Die Kurzbeschreibung .

See Also

NodeInfoAttribute Class
DynamicNode.Core Namespace


Group Property

[image]

DynamicNodes API
NodeInfoAttribute..::..Group Property
NodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Knoten-Gruppe zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Group { get; }
Visual Basic
Public ReadOnly Property Group As String
    Get
F#
member Group : string

Field Value

Die Knoten-Gruppe.

See Also

NodeInfoAttribute Class
DynamicNode.Core Namespace


NodeInfoResourceClassAttribute Class

[image]

DynamicNodes API
NodeInfoResourceClassAttribute Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Mit diesem Assebmly-Attribut wird die Klasse benannt, welche den ResourceManager und die CultureInfo für das Laden von Knoten-Metadaten zur Verfügung stellt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class NodeInfoResourceClassAttribute : Attribute
Visual Basic
Public Class NodeInfoResourceClassAttribute _
    Inherits Attribute
F#
type NodeInfoResourceClassAttribute =
    class
        inherit Attribute
    end

Inheritance Hierarchy

System..::..Object
System..::..Attribute
DynamicNode.Core..::..NodeInfoResourceClassAttribute

See Also

NodeInfoResourceClassAttribute Members
DynamicNode.Core Namespace


NodeInfoResourceClassAttribute Members

[image] [image]

DynamicNodes API
NodeInfoResourceClassAttribute Members
NodeInfoResourceClassAttribute Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeInfoResourceClassAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | NodeInfoResourceClassAttribute | Initialisiert eine neue Instanz von NodeInfoResourceClassAttribute.

Methods

 | Name | Description
Public method | GetNodeInfo | Gibt für einen Knoten

Properties

 | Name | Description
Public property | Culture | Gibt die Ressource-Kultur zurück.
Public property | ResourceManager | Gibt den Ressourcen-Manager zurück.

See Also

NodeInfoResourceClassAttribute Class
DynamicNode.Core Namespace


NodeInfoResourceClassAttribute Constructor

[image]

DynamicNodes API
NodeInfoResourceClassAttribute Constructor
NodeInfoResourceClassAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von NodeInfoResourceClassAttribute.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeInfoResourceClassAttribute(
    Type resourceClass
)
Visual Basic
Public Sub New ( _
    resourceClass As Type _
)
F#
new :
        resourceClass:Type -> NodeInfoResourceClassAttribute

Parameters

resourceClass
Type: System..::..Type
Der Type der Ressourcen-Klasse.

See Also

NodeInfoResourceClassAttribute Class
DynamicNode.Core Namespace


NodeInfoResourceClassAttribute Methods

[image] [image]

DynamicNodes API
NodeInfoResourceClassAttribute Methods
NodeInfoResourceClassAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeInfoResourceClassAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetNodeInfo | Gibt für einen Knoten

See Also

NodeInfoResourceClassAttribute Class
DynamicNode.Core Namespace


GetNodeInfo Method

[image]

DynamicNodes API
NodeInfoResourceClassAttribute..::..GetNodeInfo Method
NodeInfoResourceClassAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für einen Knoten

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeInfoAttribute GetNodeInfo(
    Type nodeType,
    string groupName
)
Visual Basic
Public Function GetNodeInfo ( _
    nodeType As Type, _
    groupName As String _
) As NodeInfoAttribute
F#
member GetNodeInfo :
        nodeType:Type *
        groupName:string -> NodeInfoAttribute

Parameters

nodeType
Type: System..::..Type
Type of the node.
groupName
Type: System..::..String
Name of the group.

Return Value

[Missing <returns> documentation for "M:DynamicNode.Core.NodeInfoResourceClassAttribute.GetNodeInfo(System.Type,System.String)"]

See Also

NodeInfoResourceClassAttribute Class
DynamicNode.Core Namespace


NodeInfoResourceClassAttribute Properties

[image] [image]

DynamicNodes API
NodeInfoResourceClassAttribute Properties
NodeInfoResourceClassAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeInfoResourceClassAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gibt die Ressource-Kultur zurück.
Public property | ResourceManager | Gibt den Ressourcen-Manager zurück.

See Also

NodeInfoResourceClassAttribute Class
DynamicNode.Core Namespace


Culture Property

[image]

DynamicNodes API
NodeInfoResourceClassAttribute..::..Culture Property
NodeInfoResourceClassAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ressource-Kultur zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public CultureInfo Culture { get; }
Visual Basic
Public ReadOnly Property Culture As CultureInfo
    Get
F#
member Culture : CultureInfo

Field Value

Die Ressourcen-Kultur.

See Also

NodeInfoResourceClassAttribute Class
DynamicNode.Core Namespace


ResourceManager Property

[image]

DynamicNodes API
NodeInfoResourceClassAttribute..::..ResourceManager Property
NodeInfoResourceClassAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Ressourcen-Manager zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public ResourceManager ResourceManager { get; }
Visual Basic
Public ReadOnly Property ResourceManager As ResourceManager
    Get
F#
member ResourceManager : ResourceManager

Field Value

Der Ressourcen-Manager.

See Also

NodeInfoResourceClassAttribute Class
DynamicNode.Core Namespace


NodeLibDescriptorAttribute Class

[image]

DynamicNodes API
NodeLibDescriptorAttribute Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Reichert eine Knotenbibliothek um Metainformationen an.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class NodeLibDescriptorAttribute : Attribute
Visual Basic
Public Class NodeLibDescriptorAttribute _
    Inherits Attribute
F#
type NodeLibDescriptorAttribute =
    class
        inherit Attribute
    end

Inheritance Hierarchy

System..::..Object
System..::..Attribute
DynamicNode.Core..::..NodeLibDescriptorAttribute

See Also

NodeLibDescriptorAttribute Members
DynamicNode.Core Namespace


NodeLibDescriptorAttribute Members

[image] [image]

DynamicNodes API
NodeLibDescriptorAttribute Members
NodeLibDescriptorAttribute Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeLibDescriptorAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | NodeLibDescriptorAttribute | Initialisiert eine neue Instanz von NodeLibDescriptorAttribute.

Properties

Name Description
Public property DescriptorType
Gibt den Type einer Klasse zurück, welche die statische Initialisierungmethode enthält.
Public property InitializeMethod
Gibt den Namen einer statischen Initialiserungsmethode zurück. Die Methode besitzt den folgenden Aufbau:
CopyC#
1public static void Methodenname(DynamicNode.Core.NodeFactory factory)
2{
3    // Initialisierung der Knotenbibliothek
4}

See Also

NodeLibDescriptorAttribute Class
DynamicNode.Core Namespace


NodeLibDescriptorAttribute Constructor

[image]

DynamicNodes API
NodeLibDescriptorAttribute Constructor
NodeLibDescriptorAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von NodeLibDescriptorAttribute.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeLibDescriptorAttribute(
    Type descriptorType,
    string initializeMethod
)
Visual Basic
Public Sub New ( _
    descriptorType As Type, _
    initializeMethod As String _
)
F#
new :
        descriptorType:Type *
        initializeMethod:string -> NodeLibDescriptorAttribute

Parameters

descriptorType
Type: System..::..Type
Eine Klasse die eine statische Initialisierungsmethode für die Knotenbibliothek enthält.
initializeMethod
Type: System..::..String
Der Name der statischen Initialisierungsmethode. Die Methode muss den folgenden Aufbau besitzen:
CopyC#
1public static void Methodenname(DynamicNode.Core.NodeFactory factory)
2{
3    // Initialisierung der Knotenbibliothek
4}

See Also

NodeLibDescriptorAttribute Class
DynamicNode.Core Namespace


NodeLibDescriptorAttribute Properties

[image] [image]

DynamicNodes API
NodeLibDescriptorAttribute Properties
NodeLibDescriptorAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeLibDescriptorAttribute type exposes the following members.

Properties

Name Description
Public property DescriptorType
Gibt den Type einer Klasse zurück, welche die statische Initialisierungmethode enthält.
Public property InitializeMethod
Gibt den Namen einer statischen Initialiserungsmethode zurück. Die Methode besitzt den folgenden Aufbau:
CopyC#
1public static void Methodenname(DynamicNode.Core.NodeFactory factory)
2{
3    // Initialisierung der Knotenbibliothek
4}

See Also

NodeLibDescriptorAttribute Class
DynamicNode.Core Namespace


DescriptorType Property

[image]

DynamicNodes API
NodeLibDescriptorAttribute..::..DescriptorType Property
NodeLibDescriptorAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Type einer Klasse zurück, welche die statische Initialisierungmethode enthält.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Type DescriptorType { get; }
Visual Basic
Public ReadOnly Property DescriptorType As Type
    Get
F#
member DescriptorType : Type

Field Value

Der Type einer Klasse.

See Also

NodeLibDescriptorAttribute Class
DynamicNode.Core Namespace


InitializeMethod Property

[image]

DynamicNodes API
NodeLibDescriptorAttribute..::..InitializeMethod Property
NodeLibDescriptorAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen einer statischen Initialiserungsmethode zurück. Die Methode besitzt den folgenden Aufbau:
CopyC#
1public static void Methodenname(DynamicNode.Core.NodeFactory factory)
2{
3    // Initialisierung der Knotenbibliothek
4}

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string InitializeMethod { get; }
Visual Basic
Public ReadOnly Property InitializeMethod As String
    Get
F#
member InitializeMethod : string

Field Value

Der Name einer statischen Initialisierungsmethode.

See Also

NodeLibDescriptorAttribute Class
DynamicNode.Core Namespace


OutPort Class

[image]

DynamicNodes API
OutPort Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Ausgang für einen Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class OutPort : Port
Visual Basic
Public Class OutPort _
    Inherits Port
F#
type OutPort =
    class
        inherit Port
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' IPort >)>)>
DynamicNode.Model..::..ChildObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Core..::..Port
DynamicNode.Core..::..OutPort
DynamicNode.Core.Nodes..::..NSubGraph..::..WrappingOutPort
DynamicNode.Core..::..TriggerOutPort

See Also

OutPort Members
DynamicNode.Core Namespace


OutPort Members

[image] [image]

DynamicNodes API
OutPort Members
OutPort Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPort type exposes the following members.

Constructors

 | Name | Description
Public method | OutPort(INode, String) | Initialisiert eine untypisierte OutPort-Instanz. Ohne Weiteres ist dieser Ausgang nur mit generischen Eingängen kompatibel.
Public method | OutPort(INode, String, IOutPortDataTypeProvider) | Initialisiert eine generische OutPort-Instanz. Dieser Ausgang besitzt immer den Datentyp seines Datentyp-Providers. Ein Datentyp-Provider kann z.B. ein InPort oder eine InPortDataTypeGroup sein.
Public method | OutPort(INode, String, Type) | Initialisiert eine typisierte OutPort-Instanz.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Stellt eine Verbindung zu einen Eingangs-Port her.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Eingangs-Port.
Public method | DisconnectAll | Trennt alle Verbindungen dieses Ausgangs-Ports.
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Fire | Gibt das Token an die verbundenen Eingänge weiter.
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Overrides Port..::..IsConnectableTo(IPort, Type%).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem der unterstützte Datentyp geändert wurden. Falls Verbindungen bestehen wird erneut geprüft ob Verbindungen gültig sind. Falls die Verbindung ungüötig ist, wird sie getrennt.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from Port.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from Port.)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Overrides Object..::..ToString()()()().)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Overrides Port..::..TryConnect(IPort).)
Public method | UpdateToken(Object) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet, das Token gehört keinem Stream an.
Public method | UpdateToken(Token) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst.
Public method | UpdateToken(TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet, das Token gehört zu keinem Stream.
Public method | UpdateToken(Object, TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Das Token gehört zu keinem Stream.
Public method | UpdateToken(Object, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet.
Public method | UpdateToken(TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet.
Public method | UpdateToken(Object, TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst.
Public method | UpdateTokenNotSet()()()() | Belegt den Ausgang mit einem lehren Token welches zu keinem Stream gehört.
Public method | UpdateTokenNotSet(Stream, Int64) | Belegt den Ausgang mit einem lehren Token.

Properties

 | Name | Description
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Ausgangs-Ports zu anderen Eingangs-Ports angepasst werden kann.
Public property | ConnectedPorts | Gibt ein Array mit allen verbundenen Eingängen zurück.
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Overrides Port..::..ConnectionCount.)
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Ausgang.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | NeedToFire | Gibt einen Wert zurück, der angibt, ob der Ausgang mit einem Token belegt ist, welches noch nicht gefeuert wurde.
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedType | Gibt den unterstützten Datentyp des Ausgangs zurück.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | Fired | Tritt auf, wenn das aktuelle Token an die verbundenen Eingänge weitergegeben wurde.
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)
Public event | TypeSupportChanged | Wird ausgelöst, wenn der Datentyp des Ausgangs geändert wurde und alle ausgehenden Verbindungen neu verhandelt werden müssen.

See Also

OutPort Class
DynamicNode.Core Namespace


OutPort Constructor

[image] [image]

DynamicNodes API
OutPort Constructor
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | OutPort(INode, String) | Initialisiert eine untypisierte OutPort-Instanz. Ohne Weiteres ist dieser Ausgang nur mit generischen Eingängen kompatibel.
Public method | OutPort(INode, String, IOutPortDataTypeProvider) | Initialisiert eine generische OutPort-Instanz. Dieser Ausgang besitzt immer den Datentyp seines Datentyp-Providers. Ein Datentyp-Provider kann z.B. ein InPort oder eine InPortDataTypeGroup sein.
Public method | OutPort(INode, String, Type) | Initialisiert eine typisierte OutPort-Instanz.

See Also

OutPort Class
OutPort Members
DynamicNode.Core Namespace


OutPort Constructor (INode, String)

[image]

DynamicNodes API
OutPort Constructor (INode, String)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine untypisierte OutPort-Instanz. Ohne Weiteres ist dieser Ausgang nur mit generischen Eingängen kompatibel.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public OutPort(
    INode parent,
    string name
)
Visual Basic
Public Sub New ( _
    parent As INode, _
    name As String _
)
F#
new :
        parent:INode *
        name:string -> OutPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten, für den der Ausgangs-Port erstellt wird, oder null, falls der Port noch keinem Knoten hinzugefügt werden soll.
name
Type: System..::..String
Der Name des Ausgangs-Ports

See Also

OutPort Class
OutPort Overload
DynamicNode.Core Namespace


OutPort Constructor (INode, String, IOutPortDataTypeProvider)

[image]

DynamicNodes API
OutPort Constructor (INode, String, IOutPortDataTypeProvider)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine generische OutPort-Instanz. Dieser Ausgang besitzt immer den Datentyp seines Datentyp-Providers. Ein Datentyp-Provider kann z.B. ein InPort oder eine InPortDataTypeGroup sein.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public OutPort(
    INode parent,
    string name,
    IOutPortDataTypeProvider typeProvider
)
Visual Basic
Public Sub New ( _
    parent As INode, _
    name As String, _
    typeProvider As IOutPortDataTypeProvider _
)
F#
new :
        parent:INode *
        name:string *
        typeProvider:IOutPortDataTypeProvider -> OutPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten, für den der Ausgangs-Port erstellt wird, oder null, falls der Port noch keinem Knoten hinzugefügt werden soll.
name
Type: System..::..String
Der Name des Ausgangs-Ports
typeProvider
Type: DynamicNode.Core..::..IOutPortDataTypeProvider
Das Objekt dessen Datentyp übernommen werden soll. Z.B. ein InPort oder eine InPortDataTypeGroup.

See Also

OutPort Class
OutPort Overload
DynamicNode.Core Namespace


OutPort Constructor (INode, String, Type)

[image]

DynamicNodes API
OutPort Constructor (INode, String, Type)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine typisierte OutPort-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public OutPort(
    INode parent,
    string name,
    Type dataType
)
Visual Basic
Public Sub New ( _
    parent As INode, _
    name As String, _
    dataType As Type _
)
F#
new :
        parent:INode *
        name:string *
        dataType:Type -> OutPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten, für den der Ausgangs-Port erstellt wird, oder null, falls der Port noch keinem Knoten hinzugefügt werden soll.
name
Type: System..::..String
Der Name des Ausgangs-Ports
dataType
Type: System..::..Type
Der unterstützte Datentyp.

See Also

OutPort Class
OutPort Overload
DynamicNode.Core Namespace


OutPort Methods

[image] [image]

DynamicNodes API
OutPort Methods
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPort type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Stellt eine Verbindung zu einen Eingangs-Port her.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Eingangs-Port.
Public method | DisconnectAll | Trennt alle Verbindungen dieses Ausgangs-Ports.
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Fire | Gibt das Token an die verbundenen Eingänge weiter.
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Overrides Port..::..IsConnectableTo(IPort, Type%).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem der unterstützte Datentyp geändert wurden. Falls Verbindungen bestehen wird erneut geprüft ob Verbindungen gültig sind. Falls die Verbindung ungüötig ist, wird sie getrennt.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from Port.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from Port.)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Overrides Object..::..ToString()()()().)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Overrides Port..::..TryConnect(IPort).)
Public method | UpdateToken(Object) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet, das Token gehört keinem Stream an.
Public method | UpdateToken(Token) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst.
Public method | UpdateToken(TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet, das Token gehört zu keinem Stream.
Public method | UpdateToken(Object, TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Das Token gehört zu keinem Stream.
Public method | UpdateToken(Object, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet.
Public method | UpdateToken(TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet.
Public method | UpdateToken(Object, TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst.
Public method | UpdateTokenNotSet()()()() | Belegt den Ausgang mit einem lehren Token welches zu keinem Stream gehört.
Public method | UpdateTokenNotSet(Stream, Int64) | Belegt den Ausgang mit einem lehren Token.

See Also

OutPort Class
DynamicNode.Core Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
OutPort..::..BeforeUseExtension Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

OutPort Class
OutPort Members
DynamicNode.Core Namespace


Connect Method

[image]

DynamicNodes API
OutPort..::..Connect Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt eine Verbindung zu einen Eingangs-Port her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Connect(
    InPort iP,
    Type typeSelection
)
Visual Basic
Public Sub Connect ( _
    iP As InPort, _
    typeSelection As Type _
)
F#
member Connect :
        iP:InPort *
        typeSelection:Type -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Der Eingangs-Port.
typeSelection
Type: System..::..Type
Der ausgewählte Datentyp für die Verbindung.

See Also

OutPort Class
DynamicNode.Core Namespace


Disconnect Method

[image]

DynamicNodes API
OutPort..::..Disconnect Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Trennt die Verbindung zu einem Eingangs-Port.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Disconnect(
    InPort iP
)
Visual Basic
Public Sub Disconnect ( _
    iP As InPort _
)
F#
member Disconnect :
        iP:InPort -> unit

Parameters

iP
Type: DynamicNode.Core..::..InPort
Der Eingangs-Port.

See Also

OutPort Class
DynamicNode.Core Namespace


DisconnectAll Method

[image]

DynamicNodes API
OutPort..::..DisconnectAll Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Trennt alle Verbindungen dieses Ausgangs-Ports.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void DisconnectAll()
Visual Basic
Public Sub DisconnectAll
F#
member DisconnectAll : unit -> unit

See Also

OutPort Class
DynamicNode.Core Namespace


Fire Method

[image]

DynamicNodes API
OutPort..::..Fire Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Token an die verbundenen Eingänge weiter.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Fire()
Visual Basic
Public Sub Fire
F#
member Fire : unit -> unit

See Also

OutPort Class
DynamicNode.Core Namespace


IsConnectableTo Method

[image]

DynamicNodes API
OutPort..::..IsConnectableTo Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob dieser Port mit einem anderem Port verbunden werden kann.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool IsConnectableTo(
    IPort port,
    out Type possibleTypeSelection
)
Visual Basic
Public Overrides Function IsConnectableTo ( _
    port As IPort, _
    <OutAttribute> ByRef possibleTypeSelection As Type _
) As Boolean
F#
abstract IsConnectableTo :
        port:IPort *
        possibleTypeSelection:Type byref -> bool
override IsConnectableTo :
        port:IPort *
        possibleTypeSelection:Type byref -> bool

Parameters

port
Type: DynamicNode.Core..::..IPort
Der andere Port.
possibleTypeSelection
Type: System..::..Type %
Wird mit dem ausgewählten Datentyp belegt, oder null, wenn der Rückgabewert false ist.

Return Value

true, wenn eine Verbindung mit dem anderen Port möglich ist, sonst false.

Implements

IPort..::..IsConnectableTo(IPort, Type%)

See Also

OutPort Class
DynamicNode.Core Namespace


NotifyTypeSupportChanged Method

[image]

DynamicNodes API
OutPort..::..NotifyTypeSupportChanged Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Muss aufgerufen werden, nachdem der unterstützte Datentyp geändert wurden.
Falls Verbindungen bestehen wird erneut geprüft ob Verbindungen gültig sind. Falls die Verbindung ungüötig ist, wird sie getrennt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void NotifyTypeSupportChanged(
    bool resetReadCopy
)
Visual Basic
Public Sub NotifyTypeSupportChanged ( _
    resetReadCopy As Boolean _
)
F#
member NotifyTypeSupportChanged :
        resetReadCopy:bool -> unit

Parameters

resetReadCopy
Type: System..::..Boolean
Gibt an, ob die Lesekopie auf Kompatibilität überprüft und falls inkompatibel durch eine leere Marke ersetzt werden soll.

See Also

OutPort Class
DynamicNode.Core Namespace


ToString Method

[image]

DynamicNodes API
OutPort..::..ToString Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen String zurück, der den aktuellen Object darstellt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Ein String, der den aktuellen Object darstellt.

See Also

OutPort Class
DynamicNode.Core Namespace


TraceError Method

[image] [image]

DynamicNodes API
OutPort..::..TraceError Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

OutPort Class
OutPort Members
DynamicNode.Core Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
OutPort..::..TraceInfo Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

OutPort Class
OutPort Members
DynamicNode.Core Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
OutPort..::..TraceVerbose Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

OutPort Class
OutPort Members
DynamicNode.Core Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
OutPort..::..TraceVerboseData Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

OutPort Class
OutPort Members
DynamicNode.Core Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
OutPort..::..TraceWarning Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

OutPort Class
OutPort Members
DynamicNode.Core Namespace


TryConnect Method

[image]

DynamicNodes API
OutPort..::..TryConnect Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool TryConnect(
    IPort port
)
Visual Basic
Public Overrides Function TryConnect ( _
    port As IPort _
) As Boolean
F#
abstract TryConnect :
        port:IPort -> bool
override TryConnect :
        port:IPort -> bool

Parameters

port
Type: DynamicNode.Core..::..IPort
Ein Anschluss.

Return Value

true, wenn die Verbindung aufgebaut werden konnte, sonst false.

Implements

IPort..::..TryConnect(IPort)

See Also

OutPort Class
DynamicNode.Core Namespace


UpdateToken Method

[image] [image]

DynamicNodes API
OutPort..::..UpdateToken Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | UpdateToken(Object) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet, das Token gehört keinem Stream an.
Public method | UpdateToken(Token) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst.
Public method | UpdateToken(TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet, das Token gehört zu keinem Stream.
Public method | UpdateToken(Object, TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Das Token gehört zu keinem Stream.
Public method | UpdateToken(Object, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet.
Public method | UpdateToken(TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet.
Public method | UpdateToken(Object, TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst.

See Also

OutPort Class
OutPort Members
DynamicNode.Core Namespace


UpdateToken Method (Object)

[image]

DynamicNodes API
OutPort..::..UpdateToken Method (Object)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet, das Token gehört keinem Stream an.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UpdateToken(
    Object value
)
Visual Basic
Public Sub UpdateToken ( _
    value As Object _
)
F#
member UpdateToken :
        value:Object -> unit

Parameters

value
Type: System..::..Object
Das Wert des neuen Tokens.

See Also

OutPort Class
UpdateToken Overload
DynamicNode.Core Namespace


UpdateToken Method (Token)

[image]

DynamicNodes API
OutPort..::..UpdateToken Method (Token)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UpdateToken(
    Token token
)
Visual Basic
Public Sub UpdateToken ( _
    token As Token _
)
F#
member UpdateToken :
        token:Token -> unit

Parameters

token
Type: DynamicNode.Core..::..Token
Das neue Token.

See Also

OutPort Class
UpdateToken Overload
DynamicNode.Core Namespace


UpdateToken Method (TokenState)

[image]

DynamicNodes API
OutPort..::..UpdateToken Method (TokenState)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet, das Token gehört zu keinem Stream.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UpdateToken(
    TokenState state
)
Visual Basic
Public Sub UpdateToken ( _
    state As TokenState _
)
F#
member UpdateToken :
        state:TokenState -> unit

Parameters

state
Type: DynamicNode.Core..::..TokenState
Das Status des neuen Tokens.

See Also

OutPort Class
UpdateToken Overload
DynamicNode.Core Namespace


UpdateToken Method (Object, TokenState)

[image]

DynamicNodes API
OutPort..::..UpdateToken Method (Object, TokenState)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Das Token gehört zu keinem Stream.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UpdateToken(
    Object value,
    TokenState state
)
Visual Basic
Public Sub UpdateToken ( _
    value As Object, _
    state As TokenState _
)
F#
member UpdateToken :
        value:Object *
        state:TokenState -> unit

Parameters

value
Type: System..::..Object
Das Wert des neuen Tokens.
state
Type: DynamicNode.Core..::..TokenState
Das Status des neuen Tokens.

See Also

OutPort Class
UpdateToken Overload
DynamicNode.Core Namespace


UpdateToken Method (Object, Stream, Int64)

[image]

DynamicNodes API
OutPort..::..UpdateToken Method (Object, Stream, Int64)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UpdateToken(
    Object value,
    Stream stream,
    long index
)
Visual Basic
Public Sub UpdateToken ( _
    value As Object, _
    stream As Stream, _
    index As Long _
)
F#
member UpdateToken :
        value:Object *
        stream:Stream *
        index:int64 -> unit

Parameters

value
Type: System..::..Object
Das Wert des neuen Tokens.
stream
Type: DynamicNode.Core..::..Stream
Ein Stream zu dem das Token gehört.
index
Type: System..::..Int64
Die Sequenz-Nummer des Tokens im Stream.

See Also

OutPort Class
UpdateToken Overload
DynamicNode.Core Namespace


UpdateToken Method (TokenState, Stream, Int64)

[image]

DynamicNodes API
OutPort..::..UpdateToken Method (TokenState, Stream, Int64)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UpdateToken(
    TokenState state,
    Stream stream,
    long index
)
Visual Basic
Public Sub UpdateToken ( _
    state As TokenState, _
    stream As Stream, _
    index As Long _
)
F#
member UpdateToken :
        state:TokenState *
        stream:Stream *
        index:int64 -> unit

Parameters

state
Type: DynamicNode.Core..::..TokenState
Das Status des neuen Tokens.
stream
Type: DynamicNode.Core..::..Stream
Ein Stream zu dem das Token gehört.
index
Type: System..::..Int64
Die Sequenz-Nummer des Tokens im Stream.

See Also

OutPort Class
UpdateToken Overload
DynamicNode.Core Namespace


UpdateToken Method (Object, TokenState, Stream, Int64)

[image]

DynamicNodes API
OutPort..::..UpdateToken Method (Object, TokenState, Stream, Int64)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UpdateToken(
    Object value,
    TokenState state,
    Stream stream,
    long index
)
Visual Basic
Public Sub UpdateToken ( _
    value As Object, _
    state As TokenState, _
    stream As Stream, _
    index As Long _
)
F#
member UpdateToken :
        value:Object *
        state:TokenState *
        stream:Stream *
        index:int64 -> unit

Parameters

value
Type: System..::..Object
Das Wert des neuen Tokens.
state
Type: DynamicNode.Core..::..TokenState
Das Status des neuen Tokens.
stream
Type: DynamicNode.Core..::..Stream
Ein Stream zu dem das Token gehört.
index
Type: System..::..Int64
Die Sequenz-Nummer des Tokens im Stream.

See Also

OutPort Class
UpdateToken Overload
DynamicNode.Core Namespace


UpdateTokenNotSet Method

[image] [image]

DynamicNodes API
OutPort..::..UpdateTokenNotSet Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | UpdateTokenNotSet()()()() | Belegt den Ausgang mit einem lehren Token welches zu keinem Stream gehört.
Public method | UpdateTokenNotSet(Stream, Int64) | Belegt den Ausgang mit einem lehren Token.

See Also

OutPort Class
OutPort Members
DynamicNode.Core Namespace


UpdateTokenNotSet Method

[image]

DynamicNodes API
OutPort..::..UpdateTokenNotSet Method
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Belegt den Ausgang mit einem lehren Token welches zu keinem Stream gehört.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UpdateTokenNotSet()
Visual Basic
Public Sub UpdateTokenNotSet
F#
member UpdateTokenNotSet : unit -> unit

See Also

OutPort Class
UpdateTokenNotSet Overload
DynamicNode.Core Namespace


UpdateTokenNotSet Method (Stream, Int64)

[image]

DynamicNodes API
OutPort..::..UpdateTokenNotSet Method (Stream, Int64)
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Belegt den Ausgang mit einem lehren Token.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void UpdateTokenNotSet(
    Stream stream,
    long index
)
Visual Basic
Public Sub UpdateTokenNotSet ( _
    stream As Stream, _
    index As Long _
)
F#
member UpdateTokenNotSet :
        stream:Stream *
        index:int64 -> unit

Parameters

stream
Type: DynamicNode.Core..::..Stream
Ein Stream zu dem das Token gehört.
index
Type: System..::..Int64
Die Sequenz-Nummer des Tokens im Stream.

See Also

OutPort Class
UpdateTokenNotSet Overload
DynamicNode.Core Namespace


OutPort Properties

[image] [image]

DynamicNodes API
OutPort Properties
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPort type exposes the following members.

Properties

 | Name | Description
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Ausgangs-Ports zu anderen Eingangs-Ports angepasst werden kann.
Public property | ConnectedPorts | Gibt ein Array mit allen verbundenen Eingängen zurück.
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Overrides Port..::..ConnectionCount.)
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Ausgang.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | NeedToFire | Gibt einen Wert zurück, der angibt, ob der Ausgang mit einem Token belegt ist, welches noch nicht gefeuert wurde.
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedType | Gibt den unterstützten Datentyp des Ausgangs zurück.

See Also

OutPort Class
DynamicNode.Core Namespace


CompatibilityChecker Property

[image]

DynamicNodes API
OutPort..::..CompatibilityChecker Property
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Ausgangs-Ports zu anderen Eingangs-Ports angepasst werden kann.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual CompatibilityChecker<InPort> CompatibilityChecker { get; set; }
Visual Basic
Public Overridable Property CompatibilityChecker As CompatibilityChecker(Of InPort)
    Get
    Set
F#
abstract CompatibilityChecker : CompatibilityChecker<InPort> with get, set
override CompatibilityChecker : CompatibilityChecker<InPort> with get, set

Field Value

Der Kompatibilitäts-Checker.

See Also

OutPort Class
DynamicNode.Core Namespace
OutPort..::..CompatibilityChecker


ConnectedPorts Property

[image]

DynamicNodes API
OutPort..::..ConnectedPorts Property
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen verbundenen Eingängen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual InPort[] ConnectedPorts { get; }
Visual Basic
Public Overridable ReadOnly Property ConnectedPorts As InPort()
    Get
F#
abstract ConnectedPorts : InPort[]
override ConnectedPorts : InPort[]

Field Value

Alle verbundenen Eingangs-Ports.

See Also

OutPort Class
DynamicNode.Core Namespace


ConnectionCount Property

[image]

DynamicNodes API
OutPort..::..ConnectionCount Property
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller Verbindungen mit diesem Port zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override int ConnectionCount { get; }
Visual Basic
Public Overrides ReadOnly Property ConnectionCount As Integer
    Get
F#
abstract ConnectionCount : int
override ConnectionCount : int

Field Value

Die Anzahl der Verbindungen.

Implements

IPort..::..ConnectionCount

See Also

OutPort Class
DynamicNode.Core Namespace


DataTypeProvider Property

[image]

DynamicNodes API
OutPort..::..DataTypeProvider Property
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Daten-Typ-Provider für diesen Ausgang.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IOutPortDataTypeProvider DataTypeProvider { get; set; }
Visual Basic
Public Property DataTypeProvider As IOutPortDataTypeProvider
    Get
    Set
F#
member DataTypeProvider : IOutPortDataTypeProvider with get, set

Field Value

Der Daten-Typ-Provider.

See Also

OutPort Class
DynamicNode.Core Namespace


NeedToFire Property

[image]

DynamicNodes API
OutPort..::..NeedToFire Property
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob der Ausgang mit einem Token belegt ist, welches noch nicht gefeuert wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual bool NeedToFire { get; }
Visual Basic
Public Overridable ReadOnly Property NeedToFire As Boolean
    Get
F#
abstract NeedToFire : bool
override NeedToFire : bool

See Also

OutPort Class
DynamicNode.Core Namespace


SupportedType Property

[image]

DynamicNodes API
OutPort..::..SupportedType Property
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den unterstützten Datentyp des Ausgangs zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual Type SupportedType { get; }
Visual Basic
Public Overridable ReadOnly Property SupportedType As Type
    Get
F#
abstract SupportedType : Type
override SupportedType : Type

Field Value

Der vom Ausgang unterstützte Datentyp.

See Also

OutPort Class
DynamicNode.Core Namespace


OutPort Events

[image] [image]

DynamicNodes API
OutPort Events
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPort type exposes the following members.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | Fired | Tritt auf, wenn das aktuelle Token an die verbundenen Eingänge weitergegeben wurde.
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)
Public event | TypeSupportChanged | Wird ausgelöst, wenn der Datentyp des Ausgangs geändert wurde und alle ausgehenden Verbindungen neu verhandelt werden müssen.

See Also

OutPort Class
DynamicNode.Core Namespace


Fired Event

[image]

DynamicNodes API
OutPort..::..Fired Event
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn das aktuelle Token an die verbundenen Eingänge weitergegeben wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event FireHandler Fired
Visual Basic
Public Event Fired As FireHandler
F#
member Fired : IEvent<FireHandler,
    EventArgs>

See Also

OutPort Class
DynamicNode.Core Namespace


TypeSupportChanged Event

[image]

DynamicNodes API
OutPort..::..TypeSupportChanged Event
OutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Datentyp des Ausgangs geändert wurde und alle ausgehenden Verbindungen neu verhandelt werden müssen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler TypeSupportChanged
Visual Basic
Public Event TypeSupportChanged As EventHandler
F#
member TypeSupportChanged : IEvent<EventHandler,
    EventArgs>

See Also

OutPort Class
DynamicNode.Core Namespace


OutPortAttribute Class

[image]

DynamicNodes API
OutPortAttribute Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Dieses Attribut kann benutzt werden um ein Feld mit dem Datentyp OutPortHandler<(Of <(<'T>)>)> als Ausgangs-Port zu markieren. Falls eine Eigenschaft in einer von Node abgeleiteten Klasse mit OutPortAttribute markiert ist, wird im Standardkonstruktor von Node automatisch ein Ausgangs-Port erzeugt und mit der markierten Eigenschaft verknüpft.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class OutPortAttribute : Attribute
Visual Basic
Public Class OutPortAttribute _
    Inherits Attribute
F#
type OutPortAttribute =
    class
        inherit Attribute
    end

Inheritance Hierarchy

System..::..Object
System..::..Attribute
DynamicNode.Core..::..OutPortAttribute

See Also

OutPortAttribute Members
DynamicNode.Core Namespace


OutPortAttribute Members

[image] [image]

DynamicNodes API
OutPortAttribute Members
OutPortAttribute Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | OutPortAttribute | Initialisiert eine InPortAttribute-Instanz.

Properties

 | Name | Description
Public property | Name | Gibt den Namen des Ports zurück.

See Also

OutPortAttribute Class
DynamicNode.Core Namespace


OutPortAttribute Constructor

[image]

DynamicNodes API
OutPortAttribute Constructor
OutPortAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine InPortAttribute-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public OutPortAttribute(
    string portName
)
Visual Basic
Public Sub New ( _
    portName As String _
)
F#
new :
        portName:string -> OutPortAttribute

Parameters

portName
Type: System..::..String
Der Name des Eingangs-Ports.

See Also

OutPortAttribute Class
DynamicNode.Core Namespace


OutPortAttribute Properties

[image] [image]

DynamicNodes API
OutPortAttribute Properties
OutPortAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gibt den Namen des Ports zurück.

See Also

OutPortAttribute Class
DynamicNode.Core Namespace


Name Property

[image]

DynamicNodes API
OutPortAttribute..::..Name Property
OutPortAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Ports zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
member Name : string

Field Value

Der name des Ports.

See Also

OutPortAttribute Class
DynamicNode.Core Namespace


OutPortDataTypeProvider Class

[image]

DynamicNodes API
OutPortDataTypeProvider Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine einfache Implementierung für IOutPortDataTypeProvider.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class OutPortDataTypeProvider : IOutPortDataTypeProvider,
    IExtension<INode>, IStorable
Visual Basic
Public Class OutPortDataTypeProvider _
    Implements IOutPortDataTypeProvider, IExtension(Of INode),  _
    IStorable
F#
type OutPortDataTypeProvider =
    class
        interface IOutPortDataTypeProvider
        interface IExtension<INode>
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..OutPortDataTypeProvider

See Also

OutPortDataTypeProvider Members
DynamicNode.Core Namespace


OutPortDataTypeProvider Members

[image] [image]

DynamicNodes API
OutPortDataTypeProvider Members
OutPortDataTypeProvider Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortDataTypeProvider type exposes the following members.

Constructors

 | Name | Description
Public method | OutPortDataTypeProvider | Initializes a new instance of the OutPortDataTypeProvider class

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | SupportedDataType | Gibt den bereitgestellten Datentyp zurück.

Events

 | Name | Description
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


OutPortDataTypeProvider Constructor

[image]

DynamicNodes API
OutPortDataTypeProvider Constructor
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the OutPortDataTypeProvider class

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public OutPortDataTypeProvider()
Visual Basic
Public Sub New
F#
new : unit -> OutPortDataTypeProvider

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


OutPortDataTypeProvider Fields

[image] [image]

DynamicNodes API
OutPortDataTypeProvider Fields
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortDataTypeProvider type exposes the following members.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID.

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


EXT_ID Field

[image]

DynamicNodes API
OutPortDataTypeProvider..::..EXT_ID Field
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


OutPortDataTypeProvider Methods

[image] [image]

DynamicNodes API
OutPortDataTypeProvider Methods
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortDataTypeProvider type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


AfterAttaching Method

[image]

DynamicNodes API
OutPortDataTypeProvider..::..AfterAttaching Method
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterAttaching(
    INode g
)
Visual Basic
Public Sub AfterAttaching ( _
    g As INode _
)
F#
abstract AfterAttaching :
        g:INode -> unit
override AfterAttaching :
        g:INode -> unit

Parameters

g
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


AfterDetaching Method

[image]

DynamicNodes API
OutPortDataTypeProvider..::..AfterDetaching Method
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterDetaching(
    INode o
)
Visual Basic
Public Sub AfterDetaching ( _
    o As INode _
)
F#
abstract AfterDetaching :
        o:INode -> unit
override AfterDetaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


AfterRestoring Method

[image]

DynamicNodes API
OutPortDataTypeProvider..::..AfterRestoring Method
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
OutPortDataTypeProvider..::..OnRestore Method
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschafts-Leser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
OutPortDataTypeProvider..::..OnStore Method
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschafts-Writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


OutPortDataTypeProvider Properties

[image] [image]

DynamicNodes API
OutPortDataTypeProvider Properties
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortDataTypeProvider type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | SupportedDataType | Gibt den bereitgestellten Datentyp zurück.

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


Id Property

[image]

DynamicNodes API
OutPortDataTypeProvider..::..Id Property
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


IsUsingStorage Property

[image]

DynamicNodes API
OutPortDataTypeProvider..::..IsUsingStorage Property
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


SupportedDataType Property

[image]

DynamicNodes API
OutPortDataTypeProvider..::..SupportedDataType Property
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den bereitgestellten Datentyp zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Type SupportedDataType { get; set; }
Visual Basic
Public Property SupportedDataType As Type
    Get
    Set
F#
abstract SupportedDataType : Type with get, set
override SupportedDataType : Type with get, set

Field Value

Der aktuelle Datentyp, oder null, wenn keiner bereitgestellt wird.

Implements

IOutPortDataTypeProvider..::..SupportedDataType

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


OutPortDataTypeProvider Events

[image] [image]

DynamicNodes API
OutPortDataTypeProvider Events
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortDataTypeProvider type exposes the following members.

Events

 | Name | Description
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


SupportedDataTypeChanged Event

[image]

DynamicNodes API
OutPortDataTypeProvider..::..SupportedDataTypeChanged Event
OutPortDataTypeProvider Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn sich der bereitsgestellte Datentyp ändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler SupportedDataTypeChanged
Visual Basic
Public Event SupportedDataTypeChanged As EventHandler
F#
abstract SupportedDataTypeChanged : IEvent<EventHandler,
    EventArgs>
override SupportedDataTypeChanged : IEvent<EventHandler,
    EventArgs>

Implements

IOutPortDataTypeProvider..::..SupportedDataTypeChanged

See Also

OutPortDataTypeProvider Class
DynamicNode.Core Namespace


OutPortHandler(T) Delegate

[image]

DynamicNodes API
OutPortHandler<(Of <(<'T>)>)> Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Delegate für das deklarative Erzeugen eines Ausgangs. Dazu muss ein öffentliches Feld mit diesem Delegate als Datentyp mit dem Attribut OutPortAttribute markiert werden. Der Datentyp des Ausgangs wird durch den Typparameter T definiert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public delegate void OutPortHandler<T>(
    Token newToken
)
Visual Basic
Public Delegate Sub OutPortHandler(Of T) ( _
    newToken As Token _
)
F#
type OutPortHandler =
    delegate of
        newToken:Token -> unit

Parameters

newToken
Type: DynamicNode.Core..::..Token
Das neue Token.

Type Parameters

T
Der Datentyp des Ausgangs.

See Also

DynamicNode.Core Namespace


Parallelizing Enumeration

[image]

DynamicNodes API
Parallelizing Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Aufzählung aller möglichen Parallelisierungsformen von Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public enum Parallelizing
Visual Basic
Public Enumeration Parallelizing
F#
type Parallelizing

Members

Member name | Description
Synchron |
SingleThreaded |
MultiThreaded |

See Also

DynamicNode.Core Namespace


PoolThreadManager Class

[image]

DynamicNodes API
PoolThreadManager Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Implementierung von IThreadManager, welche die Funktionen der Klasse ThreadPool nutzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class PoolThreadManager : IThreadManager,
    IStorable, IDisposable
Visual Basic
Public Class PoolThreadManager _
    Implements IThreadManager, IStorable, IDisposable
F#
type PoolThreadManager =
    class
        interface IThreadManager
        interface IStorable
        interface IDisposable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..PoolThreadManager

See Also

PoolThreadManager Members
DynamicNode.Core Namespace


PoolThreadManager Members

[image] [image]

DynamicNodes API
PoolThreadManager Members
PoolThreadManager Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PoolThreadManager type exposes the following members.

Constructors

 | Name | Description
Public method | PoolThreadManager | Initialisiert eine neue Instanz der Klasse PoolThreadManager.

Methods

 | Name | Description
Public method | AbortAllTasks | Bricht die Ausführung aller Aufgaben ab.
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.
Public method | GetNewTaskId | Gibt eine neue eindeutige Task-ID zurück.
Public method | IsTaskRunning | Prüft, ob eine Aufgabe mit der übergebenen Task-ID ausgeführt wird oder auf ihre Ausführung wartet.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Protected method | OnTaskAbort | Wird aufgerufen wenn eine Aufgabe abgebrochen wurde.
Protected method | OnTaskEnd | Wird aufgerufen wenn die Ausführung einer Aufgabe endet.
Protected method | OnTaskStart | Wird aufgerufen wenn die Ausführung einer Aufgabe beginnt.
Public method | RegisterSingleThreadContext | Registriert einen Synchronisierungskontext für die Ausführung von Aufgaben in Single-Thread-Objekt-Modellen.
Public method | RunTask | Führt ein ThreadStart-Delegate nebenläufig aus.
Public method | RunTaskSingleThreaded | Führt ein ThreadStart-Delegate mit einem einzigen Thread aus.
Public method | SupportsSingleThreadContext | Gibt true zurück, wenn es Synchronisierungskontext mit der übergebenen ID registriert wurde.

Properties

 | Name | Description
Public property | ActiveThreadCount | Gibt die Anzahl der aktiven Threads zurück.
Public property | MaxThreadCount | Liest oder schreibt die maximale Anzahl an nebenläufigen Threads.
Public property | UseMultiThreading | Liest oder Schreibt einen Wert, der angibt ob Parallelverarbeitung aktiv ist.

Events

 | Name | Description
Public event | TaskAbort | Wird ausgelöst, wenn ein Thread abgebrochen wurde.
Public event | TaskEnd | Wird ausgelöst, wenn ein Thread beendet wurde.
Public event | TaskStart | Wird ausgelöst, wenn ein Thread gestartet wurde.

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


PoolThreadManager Constructor

[image]

DynamicNodes API
PoolThreadManager Constructor
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse PoolThreadManager.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public PoolThreadManager(
    IRuntime runtime
)
Visual Basic
Public Sub New ( _
    runtime As IRuntime _
)
F#
new :
        runtime:IRuntime -> PoolThreadManager

Parameters

runtime
Type: DynamicNode.Core..::..IRuntime
Die Laufzeitumgebung.

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


PoolThreadManager Methods

[image] [image]

DynamicNodes API
PoolThreadManager Methods
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PoolThreadManager type exposes the following members.

Methods

 | Name | Description
Public method | AbortAllTasks | Bricht die Ausführung aller Aufgaben ab.
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.
Public method | GetNewTaskId | Gibt eine neue eindeutige Task-ID zurück.
Public method | IsTaskRunning | Prüft, ob eine Aufgabe mit der übergebenen Task-ID ausgeführt wird oder auf ihre Ausführung wartet.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Protected method | OnTaskAbort | Wird aufgerufen wenn eine Aufgabe abgebrochen wurde.
Protected method | OnTaskEnd | Wird aufgerufen wenn die Ausführung einer Aufgabe endet.
Protected method | OnTaskStart | Wird aufgerufen wenn die Ausführung einer Aufgabe beginnt.
Public method | RegisterSingleThreadContext | Registriert einen Synchronisierungskontext für die Ausführung von Aufgaben in Single-Thread-Objekt-Modellen.
Public method | RunTask | Führt ein ThreadStart-Delegate nebenläufig aus.
Public method | RunTaskSingleThreaded | Führt ein ThreadStart-Delegate mit einem einzigen Thread aus.
Public method | SupportsSingleThreadContext | Gibt true zurück, wenn es Synchronisierungskontext mit der übergebenen ID registriert wurde.

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


AbortAllTasks Method

[image]

DynamicNodes API
PoolThreadManager..::..AbortAllTasks Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bricht die Ausführung aller Aufgaben ab.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AbortAllTasks()
Visual Basic
Public Sub AbortAllTasks
F#
abstract AbortAllTasks : unit -> unit
override AbortAllTasks : unit -> unit

Implements

IThreadManager..::..AbortAllTasks()()()()

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


Dispose Method

[image]

DynamicNodes API
PoolThreadManager..::..Dispose Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
F#
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposable..::..Dispose()()()()

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


GetNewTaskId Method

[image]

DynamicNodes API
PoolThreadManager..::..GetNewTaskId Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine neue eindeutige Task-ID zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string GetNewTaskId()
Visual Basic
Public Function GetNewTaskId As String
F#
abstract GetNewTaskId : unit -> string
override GetNewTaskId : unit -> string

Return Value

Eine Task-ID.

Implements

IThreadManager..::..GetNewTaskId()()()()

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


IsTaskRunning Method

[image]

DynamicNodes API
PoolThreadManager..::..IsTaskRunning Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob eine Aufgabe mit der übergebenen Task-ID ausgeführt wird oder auf ihre Ausführung wartet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsTaskRunning(
    string taskId
)
Visual Basic
Public Function IsTaskRunning ( _
    taskId As String _
) As Boolean
F#
abstract IsTaskRunning :
        taskId:string -> bool
override IsTaskRunning :
        taskId:string -> bool

Parameters

taskId
Type: System..::..String
Die Task-ID.

Return Value

true wenn die Aufgabe wartet oder ausgeführt wird; sonst, false.

Implements

IThreadManager..::..IsTaskRunning(String)

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
PoolThreadManager..::..OnRestore Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
PoolThreadManager..::..OnStore Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


OnTaskAbort Method

[image]

DynamicNodes API
PoolThreadManager..::..OnTaskAbort Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn eine Aufgabe abgebrochen wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnTaskAbort(
    string id,
    Thread thread
)
Visual Basic
Protected Sub OnTaskAbort ( _
    id As String, _
    thread As Thread _
)
F#
member OnTaskAbort :
        id:string *
        thread:Thread -> unit

Parameters

id
Type: System..::..String
Die Task-ID.
thread
Type: System.Threading..::..Thread
Der Thread.

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


OnTaskEnd Method

[image]

DynamicNodes API
PoolThreadManager..::..OnTaskEnd Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn die Ausführung einer Aufgabe endet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnTaskEnd(
    string id,
    Thread thread
)
Visual Basic
Protected Sub OnTaskEnd ( _
    id As String, _
    thread As Thread _
)
F#
member OnTaskEnd :
        id:string *
        thread:Thread -> unit

Parameters

id
Type: System..::..String
Die Task-ID.
thread
Type: System.Threading..::..Thread
Der Thread.

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


OnTaskStart Method

[image]

DynamicNodes API
PoolThreadManager..::..OnTaskStart Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn die Ausführung einer Aufgabe beginnt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnTaskStart(
    string id,
    Thread thread
)
Visual Basic
Protected Sub OnTaskStart ( _
    id As String, _
    thread As Thread _
)
F#
member OnTaskStart :
        id:string *
        thread:Thread -> unit

Parameters

id
Type: System..::..String
Die Task-ID.
thread
Type: System.Threading..::..Thread
Der Thread.

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


RegisterSingleThreadContext Method

[image]

DynamicNodes API
PoolThreadManager..::..RegisterSingleThreadContext Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert einen Synchronisierungskontext für die Ausführung von Aufgaben in Single-Thread-Objekt-Modellen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RegisterSingleThreadContext(
    ISingleThreadContext context
)
Visual Basic
Public Sub RegisterSingleThreadContext ( _
    context As ISingleThreadContext _
)
F#
abstract RegisterSingleThreadContext :
        context:ISingleThreadContext -> unit
override RegisterSingleThreadContext :
        context:ISingleThreadContext -> unit

Parameters

context
Type: DynamicNode.Core..::..ISingleThreadContext
Der Synchronisierungskontext.

Implements

IThreadManager..::..RegisterSingleThreadContext(ISingleThreadContext)

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


RunTask Method

[image]

DynamicNodes API
PoolThreadManager..::..RunTask Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Führt ein ThreadStart-Delegate nebenläufig aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RunTask(
    string taskId,
    ThreadStart task
)
Visual Basic
Public Sub RunTask ( _
    taskId As String, _
    task As ThreadStart _
)
F#
abstract RunTask :
        taskId:string *
        task:ThreadStart -> unit
override RunTask :
        taskId:string *
        task:ThreadStart -> unit

Parameters

taskId
Type: System..::..String
Die Task-ID zur Kennzeichnung der neuen Aufgabe.
task
Type: System.Threading..::..ThreadStart
Das Delegate, welches nebenläufig ausgeführt werden soll.

Implements

IThreadManager..::..RunTask(String, ThreadStart)

Remarks

Wenn ein Thread mit der übergebenen Task-ID gerade ausgeführt wird, oder auf seine Ausführung wartet, wird dieser abgebrochen, bzw. nicht gestartet.

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


RunTaskSingleThreaded Method

[image]

DynamicNodes API
PoolThreadManager..::..RunTaskSingleThreaded Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt ein ThreadStart-Delegate mit einem einzigen Thread aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RunTaskSingleThreaded(
    string taskId,
    string syncContext,
    ThreadStart task
)
Visual Basic
Public Sub RunTaskSingleThreaded ( _
    taskId As String, _
    syncContext As String, _
    task As ThreadStart _
)
F#
abstract RunTaskSingleThreaded :
        taskId:string *
        syncContext:string *
        task:ThreadStart -> unit
override RunTaskSingleThreaded :
        taskId:string *
        syncContext:string *
        task:ThreadStart -> unit

Parameters

taskId
Type: System..::..String
Die Task-ID zur Kennzeichnung der neuen Aufgabe.
syncContext
Type: System..::..String
Die ID des Synchronisierungskontextes.
task
Type: System.Threading..::..ThreadStart
Das Delegate, welches ausgeführt werden soll.

Implements

IThreadManager..::..RunTaskSingleThreaded(String, String, ThreadStart)

Remarks

Wenn eine Aufgabe mit der übergebenen Task-ID gerade ausgeführt wird, oder auf seine Ausführung wartet, wird dieser abgebrochen, bzw. nicht gestartet.

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


SupportsSingleThreadContext Method

[image]

DynamicNodes API
PoolThreadManager..::..SupportsSingleThreadContext Method
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt true zurück, wenn es Synchronisierungskontext mit der übergebenen ID registriert wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool SupportsSingleThreadContext(
    string id
)
Visual Basic
Public Function SupportsSingleThreadContext ( _
    id As String _
) As Boolean
F#
abstract SupportsSingleThreadContext :
        id:string -> bool
override SupportsSingleThreadContext :
        id:string -> bool

Parameters

id
Type: System..::..String
Die ID des Synchronisierungskontextes.

Return Value

true, wenn der übergebene Sysnchronisierungskontext unterstützt wird, sonst false.

Implements

IThreadManager..::..SupportsSingleThreadContext(String)

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


PoolThreadManager Properties

[image] [image]

DynamicNodes API
PoolThreadManager Properties
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PoolThreadManager type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThreadCount | Gibt die Anzahl der aktiven Threads zurück.
Public property | MaxThreadCount | Liest oder schreibt die maximale Anzahl an nebenläufigen Threads.
Public property | UseMultiThreading | Liest oder Schreibt einen Wert, der angibt ob Parallelverarbeitung aktiv ist.

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


ActiveThreadCount Property

[image]

DynamicNodes API
PoolThreadManager..::..ActiveThreadCount Property
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der aktiven Threads zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int ActiveThreadCount { get; }
Visual Basic
Public ReadOnly Property ActiveThreadCount As Integer
    Get
F#
abstract ActiveThreadCount : int
override ActiveThreadCount : int

Field Value

Anzahl der aktiven Threads

Implements

IThreadManager..::..ActiveThreadCount

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


MaxThreadCount Property

[image]

DynamicNodes API
PoolThreadManager..::..MaxThreadCount Property
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die maximale Anzahl an nebenläufigen Threads.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int MaxThreadCount { get; set; }
Visual Basic
Public Property MaxThreadCount As Integer
    Get
    Set
F#
abstract MaxThreadCount : int with get, set
override MaxThreadCount : int with get, set

Field Value

Die maximale Nebenläufigkeit.

Implements

IThreadManager..::..MaxThreadCount

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


UseMultiThreading Property

[image]

DynamicNodes API
PoolThreadManager..::..UseMultiThreading Property
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder Schreibt einen Wert, der angibt ob Parallelverarbeitung aktiv ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool UseMultiThreading { get; set; }
Visual Basic
Public Property UseMultiThreading As Boolean
    Get
    Set
F#
abstract UseMultiThreading : bool with get, set
override UseMultiThreading : bool with get, set

Field Value

true wenn Parallelverarbeitung aktiv ist; sonst, false.

Implements

IThreadManager..::..UseMultiThreading

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


PoolThreadManager Events

[image] [image]

DynamicNodes API
PoolThreadManager Events
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PoolThreadManager type exposes the following members.

Events

 | Name | Description
Public event | TaskAbort | Wird ausgelöst, wenn ein Thread abgebrochen wurde.
Public event | TaskEnd | Wird ausgelöst, wenn ein Thread beendet wurde.
Public event | TaskStart | Wird ausgelöst, wenn ein Thread gestartet wurde.

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


TaskAbort Event

[image]

DynamicNodes API
PoolThreadManager..::..TaskAbort Event
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Thread abgebrochen wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<TaskEventArgs> TaskAbort
Visual Basic
Public Event TaskAbort As EventHandler(Of TaskEventArgs)
F#
abstract TaskAbort : IEvent<EventHandler<TaskEventArgs>,
    TaskEventArgs>
override TaskAbort : IEvent<EventHandler<TaskEventArgs>,
    TaskEventArgs>

Implements

IThreadManager..::..TaskAbort

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


TaskEnd Event

[image]

DynamicNodes API
PoolThreadManager..::..TaskEnd Event
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Thread beendet wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<TaskEventArgs> TaskEnd
Visual Basic
Public Event TaskEnd As EventHandler(Of TaskEventArgs)
F#
abstract TaskEnd : IEvent<EventHandler<TaskEventArgs>,
    TaskEventArgs>
override TaskEnd : IEvent<EventHandler<TaskEventArgs>,
    TaskEventArgs>

Implements

IThreadManager..::..TaskEnd

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


TaskStart Event

[image]

DynamicNodes API
PoolThreadManager..::..TaskStart Event
PoolThreadManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Thread gestartet wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<TaskEventArgs> TaskStart
Visual Basic
Public Event TaskStart As EventHandler(Of TaskEventArgs)
F#
abstract TaskStart : IEvent<EventHandler<TaskEventArgs>,
    TaskEventArgs>
override TaskStart : IEvent<EventHandler<TaskEventArgs>,
    TaskEventArgs>

Implements

IThreadManager..::..TaskStart

See Also

PoolThreadManager Class
DynamicNode.Core Namespace


Port Class

[image]

DynamicNodes API
Port Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die abstrakte Basis-Klasse für Ein- und Ausgabe-Ports.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract class Port : ChildObject<INode, IPort>,
    IPort, IChild<INode, IPort>, IBaseObject,
    IIdentifiable, IStorable, IExtensible<IPort>, IDisposable
Visual Basic
Public MustInherit Class Port _
    Inherits ChildObject(Of INode, IPort) _
    Implements IPort, IChild(Of INode, IPort),  _
    IBaseObject, IIdentifiable, IStorable, IExtensible(Of IPort),  _
    IDisposable
F#
[<AbstractClassAttribute>]
type Port =
    class
        inherit ChildObject<INode, IPort>
        interface IPort
        interface IChild<INode, IPort>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
        interface IExtensible<IPort>
        interface IDisposable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' IPort >)>)>
DynamicNode.Model..::..ChildObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Core..::..Port
DynamicNode.Core..::..InPort
DynamicNode.Core..::..OutPort

See Also

Port Members
DynamicNode.Core Namespace


Port Members

[image] [image]

DynamicNodes API
Port Members
Port Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Port type exposes the following members.

Constructors

 | Name | Description
Protected method | Port | Initialisiert eine Port-Instanz.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Overrides BaseObject..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Overrides BaseObject..::..OnStore(IPropertyWriter).)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus.
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück.
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück.
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist.
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Overrides BaseObject..::..LocalTrace.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Overrides BaseObject..::..NameDefaultValue.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört.
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
 | PortTraceSource | Gibt die Ablaufverfolgungsquelle für Anschlüsse zurück.
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports.
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert.
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird.

See Also

Port Class
DynamicNode.Core Namespace


Port Constructor

[image]

DynamicNodes API
Port Constructor
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Port-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected Port(
    INode parent,
    string name
)
Visual Basic
Protected Sub New ( _
    parent As INode, _
    name As String _
)
F#
new :
        parent:INode *
        name:string -> Port

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten, für den der Port erstellt wird oder null, wenn der Port noch keinem Knoten hinzugefügt werden soll.
name
Type: System..::..String
Der Name des Ports

See Also

Port Class
DynamicNode.Core Namespace


Port Methods

[image] [image]

DynamicNodes API
Port Methods
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Port type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Overrides BaseObject..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Overrides BaseObject..::..OnStore(IPropertyWriter).)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus.
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam.

See Also

Port Class
DynamicNode.Core Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
Port..::..BeforeUseExtension Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

Port Class
Port Members
DynamicNode.Core Namespace


GetAddress Method

[image]

DynamicNodes API
Port..::..GetAddress Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Zeichenfolge zurück, welche den Port identifiziert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string GetAddress()
Visual Basic
Public Function GetAddress As String
F#
abstract GetAddress : unit -> string
override GetAddress : unit -> string

Return Value

Eine Port-Adresse.

Implements

IPort..::..GetAddress()()()()

See Also

Port Class
DynamicNode.Core Namespace


IsConnectableTo Method

[image]

DynamicNodes API
Port..::..IsConnectableTo Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob dieser Port mit einem anderem Port verbunden werden kann.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract bool IsConnectableTo(
    IPort port,
    out Type possibleTypeSelection
)
Visual Basic
Public MustOverride Function IsConnectableTo ( _
    port As IPort, _
    <OutAttribute> ByRef possibleTypeSelection As Type _
) As Boolean
F#
abstract IsConnectableTo :
        port:IPort *
        possibleTypeSelection:Type byref -> bool

Parameters

port
Type: DynamicNode.Core..::..IPort
Der andere Port.
possibleTypeSelection
Type: System..::..Type %
Wird mit dem ausgewählten Datentyp belegt, oder null, wenn der Rückgabewert false ist.

Return Value

true, wenn eine Verbindung mit dem anderen Port möglich ist, sonst false.

Implements

IPort..::..IsConnectableTo(IPort, Type%)

See Also

Port Class
DynamicNode.Core Namespace


OnConnectionChange Method

[image]

DynamicNodes API
Port..::..OnConnectionChange Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnConnectionChange(
    int count
)
Visual Basic
Protected Sub OnConnectionChange ( _
    count As Integer _
)
F#
member OnConnectionChange :
        count:int -> unit

Parameters

count
Type: System..::..Int32
Die neue Anzahl der Verbindungen.

See Also

Port Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
Port..::..OnRestore Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overrides Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)

See Also

Port Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
Port..::..OnStore Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overrides Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)

See Also

Port Class
DynamicNode.Core Namespace


OnUpdate Method

[image]

DynamicNodes API
Port..::..OnUpdate Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnUpdate(
    Token token
)
Visual Basic
Protected Sub OnUpdate ( _
    token As Token _
)
F#
member OnUpdate :
        token:Token -> unit

Parameters

token
Type: DynamicNode.Core..::..Token
Das neue Token.

See Also

Port Class
DynamicNode.Core Namespace


TraceError Method

[image] [image]

DynamicNodes API
Port..::..TraceError Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Port Class
Port Members
DynamicNode.Core Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
Port..::..TraceInfo Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Port Class
Port Members
DynamicNode.Core Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
Port..::..TraceVerbose Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Port Class
Port Members
DynamicNode.Core Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
Port..::..TraceVerboseData Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Port Class
Port Members
DynamicNode.Core Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
Port..::..TraceWarning Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Port Class
Port Members
DynamicNode.Core Namespace


TryConnect Method

[image]

DynamicNodes API
Port..::..TryConnect Method
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract bool TryConnect(
    IPort port
)
Visual Basic
Public MustOverride Function TryConnect ( _
    port As IPort _
) As Boolean
F#
abstract TryConnect :
        port:IPort -> bool

Parameters

port
Type: DynamicNode.Core..::..IPort
Ein Anschluss.

Return Value

true, wenn die Verbindung aufgebaut werden konnte, sonst false.

Implements

IPort..::..TryConnect(IPort)

See Also

Port Class
DynamicNode.Core Namespace


Port Properties

[image] [image]

DynamicNodes API
Port Properties
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Port type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück.
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück.
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist.
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Overrides BaseObject..::..LocalTrace.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Overrides BaseObject..::..NameDefaultValue.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört.
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
 | PortTraceSource | Gibt die Ablaufverfolgungsquelle für Anschlüsse zurück.
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports.
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port.

See Also

Port Class
DynamicNode.Core Namespace


ConnectionCount Property

[image]

DynamicNodes API
Port..::..ConnectionCount Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller Verbindungen mit diesem Port zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract int ConnectionCount { get; }
Visual Basic
Public MustOverride ReadOnly Property ConnectionCount As Integer
    Get
F#
abstract ConnectionCount : int

Field Value

Die Anzahl der Verbindungen.

Implements

IPort..::..ConnectionCount

See Also

Port Class
DynamicNode.Core Namespace


CurrentTokenState Property

[image]

DynamicNodes API
Port..::..CurrentTokenState Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Zustand des letzten Tokens zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenState CurrentTokenState { get; }
Visual Basic
Public ReadOnly Property CurrentTokenState As TokenState
    Get
F#
member CurrentTokenState : TokenState

Field Value

Der Zustand des letzten Tokens.

See Also

Port Class
DynamicNode.Core Namespace


CurrentTokenValue Property

[image]

DynamicNodes API
Port..::..CurrentTokenValue Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert des letzten Tokens zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Object CurrentTokenValue { get; }
Visual Basic
Public ReadOnly Property CurrentTokenValue As Object
    Get
F#
member CurrentTokenValue : Object

Field Value

Der Wert des letzten Tokens.

See Also

Port Class
DynamicNode.Core Namespace


IsSuperPort Property

[image]

DynamicNodes API
Port..::..IsSuperPort Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an oder legt fest ob dieser Port ein Super-Port ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsSuperPort { get; set; }
Visual Basic
Public Property IsSuperPort As Boolean
    Get
    Set
F#
abstract IsSuperPort : bool with get, set
override IsSuperPort : bool with get, set

Field Value

true wenn die Instanz ein Super-Port ist, sonst false.

Implements

IPort..::..IsSuperPort

See Also

Port Class
DynamicNode.Core Namespace


LocalTrace Property

[image]

DynamicNodes API
Port..::..LocalTrace Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override TraceSource LocalTrace { get; }
Visual Basic
Protected Overrides ReadOnly Property LocalTrace As TraceSource
    Get
F#
abstract LocalTrace : TraceSource
override LocalTrace : TraceSource

See Also

Port Class
DynamicNode.Core Namespace


NameDefaultValue Property

[image]

DynamicNodes API
Port..::..NameDefaultValue Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standardwert für die Eigenschaft Name zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override string NameDefaultValue { get; }
Visual Basic
Protected Overrides ReadOnly Property NameDefaultValue As String
    Get
F#
abstract NameDefaultValue : string
override NameDefaultValue : string

Field Value

Der Standardwert von Name.

See Also

Port Class
DynamicNode.Core Namespace


Node Property

[image]

DynamicNodes API
Port..::..Node Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Knoten zurück, zu dem dieser Port gehört.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public INode Node { get; }
Visual Basic
Public ReadOnly Property Node As INode
    Get
F#
abstract Node : INode
override Node : INode

Field Value

Der Knoten, zu dem dieser Port gehört.

Implements

IPort..::..Node

See Also

Port Class
DynamicNode.Core Namespace


PortTraceSource Property

[image]

DynamicNodes API
Port..::..PortTraceSource Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ablaufverfolgungsquelle für Anschlüsse zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TraceSource PortTraceSource { get; }
Visual Basic
Public Shared ReadOnly Property PortTraceSource As TraceSource
    Get
F#
static member PortTraceSource : TraceSource

See Also

Port Class
DynamicNode.Core Namespace


ReadCopy Property

[image]

DynamicNodes API
Port..::..ReadCopy Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Token ReadCopy { get; }
Visual Basic
Public ReadOnly Property ReadCopy As Token
    Get
F#
abstract ReadCopy : Token
override ReadCopy : Token

Field Value

Die Lese-Kopie des letzten Tokens.

Implements

IPort..::..ReadCopy

See Also

Port Class
DynamicNode.Core Namespace


SuperName Property

[image]

DynamicNodes API
Port..::..SuperName Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die Super-ID für Modul-Ports.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string SuperName { get; set; }
Visual Basic
Public Property SuperName As String
    Get
    Set
F#
abstract SuperName : string with get, set
override SuperName : string with get, set

Field Value

Die Super-ID.

Implements

IPort..::..SuperName

See Also

Port Class
DynamicNode.Core Namespace


SuperSortIndex Property

[image]

DynamicNodes API
Port..::..SuperSortIndex Property
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Sortier-Index für den Super-Port.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int SuperSortIndex { get; set; }
Visual Basic
Public Property SuperSortIndex As Integer
    Get
    Set
F#
abstract SuperSortIndex : int with get, set
override SuperSortIndex : int with get, set

Field Value

Eine Ganzzahl, welche die Reihenfolge der Anschlüsse an einem Modul steuert.

Implements

IPort..::..SuperSortIndex

See Also

Port Class
DynamicNode.Core Namespace


Port Events

[image] [image]

DynamicNodes API
Port Events
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Port type exposes the following members.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert.
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird.

See Also

Port Class
DynamicNode.Core Namespace


ConnectionChange Event

[image]

DynamicNodes API
Port..::..ConnectionChange Event
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event ConnectionChangedHandler ConnectionChange
Visual Basic
Public Event ConnectionChange As ConnectionChangedHandler
F#
abstract ConnectionChange : IEvent<ConnectionChangedHandler,
    EventArgs>
override ConnectionChange : IEvent<ConnectionChangedHandler,
    EventArgs>

Implements

IPort..::..ConnectionChange

See Also

Port Class
DynamicNode.Core Namespace


TokenUpdate Event

[image]

DynamicNodes API
Port..::..TokenUpdate Event
Port Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event TokenUpdateHandler TokenUpdate
Visual Basic
Public Event TokenUpdate As TokenUpdateHandler
F#
member TokenUpdate : IEvent<TokenUpdateHandler,
    EventArgs>

See Also

Port Class
DynamicNode.Core Namespace


ResourceNodeInfoAttribute Class

[image]

DynamicNodes API
ResourceNodeInfoAttribute Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Dieses Attribut wird verwendet um für eine von Node abgeleitete Klasse die Meta-Daten anzugeben. Im Unterscheid zu NodeInfoAttribute werden die Meta-Daten nicht als Konstanten angegeben, sondern aus einer Ressourcen-Bibliothek geladen. Dadurch wird es möglich, die Meta-Daten zu lokalisieren. Der Name des Knotens wird mit der ID <Klassenname>_Caption gesucht und die Beschreibung mit der ID <Klassenname>_Description. Die Gruppe wird mit der ID Group_<Gruppenname> gesucht. Diese Meta-Daten werden verwendet um eine Auswahl der verfügbaren Knoten-Typen in der Benutzeroberfläche zu ermöglichen, ohne einen Knoten zu instanzieren.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class ResourceNodeInfoAttribute : Attribute
Visual Basic
Public Class ResourceNodeInfoAttribute _
    Inherits Attribute
F#
type ResourceNodeInfoAttribute =
    class
        inherit Attribute
    end

Remarks

Falls keine Lokalisierung der Meta-Daten erforderlich ist, sollte zur Vereinfachung NodeInfoAttribute direkt verwendet werden.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
DynamicNode.Core..::..ResourceNodeInfoAttribute

See Also

ResourceNodeInfoAttribute Members
DynamicNode.Core Namespace


ResourceNodeInfoAttribute Members

[image] [image]

DynamicNodes API
ResourceNodeInfoAttribute Members
ResourceNodeInfoAttribute Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ResourceNodeInfoAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceNodeInfoAttribute | Initialisiert eine neue Instanz von StaticNodeInfoAttribute. Damit die Meta-Daten automatisch aus als Ressource geladen werden können, muss das Assembly der Knotenbibliothek mit dem NodeInfoResourceClassAttribute-Attribut annotiert sein.

Methods

 | Name | Description
Public method | GetNodeInfo | Lädt die lokalisierten Metadaten als Resource.

See Also

ResourceNodeInfoAttribute Class
DynamicNode.Core Namespace


ResourceNodeInfoAttribute Constructor

[image]

DynamicNodes API
ResourceNodeInfoAttribute Constructor
ResourceNodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Initialisiert eine neue Instanz von StaticNodeInfoAttribute.

Damit die Meta-Daten automatisch aus als Ressource geladen werden können, muss das Assembly der Knotenbibliothek mit dem NodeInfoResourceClassAttribute-Attribut annotiert sein.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public ResourceNodeInfoAttribute(
    string groupName
)
Visual Basic
Public Sub New ( _
    groupName As String _
)
F#
new :
        groupName:string -> ResourceNodeInfoAttribute

Parameters

groupName
Type: System..::..String
Der allgemeine Name der Knotengruppe, mit dem der lokalisierte Name als Ressource geladen werden kann.

See Also

ResourceNodeInfoAttribute Class
DynamicNode.Core Namespace


ResourceNodeInfoAttribute Methods

[image] [image]

DynamicNodes API
ResourceNodeInfoAttribute Methods
ResourceNodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ResourceNodeInfoAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetNodeInfo | Lädt die lokalisierten Metadaten als Resource.

See Also

ResourceNodeInfoAttribute Class
DynamicNode.Core Namespace


GetNodeInfo Method

[image]

DynamicNodes API
ResourceNodeInfoAttribute..::..GetNodeInfo Method
ResourceNodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Lädt die lokalisierten Metadaten als Resource.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeInfoAttribute GetNodeInfo(
    Type nodeType
)
Visual Basic
Public Function GetNodeInfo ( _
    nodeType As Type _
) As NodeInfoAttribute
F#
member GetNodeInfo :
        nodeType:Type -> NodeInfoAttribute

Parameters

nodeType
Type: System..::..Type
Der Knotentyp der mit diesem Attribut annotiert wurde.

Return Value

Die Knoten-Info.

See Also

ResourceNodeInfoAttribute Class
DynamicNode.Core Namespace


Runtime Class

[image]

DynamicNodes API
Runtime Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Kern einer DynamicNode-Anwendung.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class Runtime : ParentObject<IRuntime, IGraph>,
    IRuntime, IParent<IRuntime, IGraph>, IBaseObject,
    IIdentifiable, IStorable, IExtensible<IRuntime>, IDisposable
Visual Basic
Public Class Runtime _
    Inherits ParentObject(Of IRuntime, IGraph) _
    Implements IRuntime, IParent(Of IRuntime, IGraph),  _
    IBaseObject, IIdentifiable, IStorable, IExtensible(Of IRuntime),  _
    IDisposable
F#
type Runtime =
    class
        inherit ParentObject<IRuntime, IGraph>
        interface IRuntime
        interface IParent<IRuntime, IGraph>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
        interface IExtensible<IRuntime>
        interface IDisposable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' IRuntime >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' IRuntime, IGraph >)>)>
DynamicNode.Core..::..Runtime

See Also

Runtime Members
DynamicNode.Core Namespace


Runtime Members

[image] [image]

DynamicNodes API
Runtime Members
Runtime Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Runtime type exposes the following members.

Constructors

 | Name | Description
Public method | Runtime | Initialisiert eine Runtime-Instanz.

Methods

 | Name | Description
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche die Laufzeitumgebung innerhalb der Application-Domain eindeutig identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildAdded(TChild).)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildRemoved(TChild).)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnDisposing()()()().)
Public method | OnGraphAffected | Löst das Ereignis GraphAffected aus.
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnStore(IPropertyWriter).)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

Properties

 | Name | Description
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Configuration | Gibt die IConfiguration zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Overrides BaseObject..::..IdDefaultValue.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Overrides BaseObject..::..LocalTrace.)
Public property | MsgBus | Gibt den System-Nachrichten-Bus zurück.
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Overrides BaseObject..::..NameDefaultValue.)
Public property | NodeFactory | Gibt den NodeFactory zurück, oder legt ihn fest.
 | RuntimeTraceSource | Gibt die Ablaufverfolgungsquelle für Laufzeitumgebungen zurück.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | ThreadManager | Gibt den IThreadManager zurück.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | GraphAffected | Wird ausgelöst, wenn bei einer Änderung in der Laufzeitumgebung einGraph betroffen ist.
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)

See Also

Runtime Class
DynamicNode.Core Namespace


Runtime Constructor

[image]

DynamicNodes API
Runtime Constructor
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Runtime-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Runtime(
    IConfiguration configuration,
    MessageBus messageBus
)
Visual Basic
Public Sub New ( _
    configuration As IConfiguration, _
    messageBus As MessageBus _
)
F#
new :
        configuration:IConfiguration *
        messageBus:MessageBus -> Runtime

Parameters

configuration
Type: DynamicNode.Core..::..IConfiguration
Eine Konfiguration.
messageBus
Type: DynamicNode.Core..::..MessageBus
Ein Nachrichtenbus.

See Also

Runtime Class
DynamicNode.Core Namespace


Runtime Methods

[image] [image]

DynamicNodes API
Runtime Methods
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Runtime type exposes the following members.

Methods

 | Name | Description
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche die Laufzeitumgebung innerhalb der Application-Domain eindeutig identifiziert.
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildAdded(TChild).)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildRemoved(TChild).)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnDisposing()()()().)
Public method | OnGraphAffected | Löst das Ereignis GraphAffected aus.
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnStore(IPropertyWriter).)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Runtime Class
DynamicNode.Core Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
Runtime..::..BeforeUseExtension Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

Runtime Class
Runtime Members
DynamicNode.Core Namespace


GetAddress Method

[image]

DynamicNodes API
Runtime..::..GetAddress Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Zeichenfolge zurück, welche die Laufzeitumgebung innerhalb der Application-Domain eindeutig identifiziert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string GetAddress()
Visual Basic
Public Function GetAddress As String
F#
abstract GetAddress : unit -> string
override GetAddress : unit -> string

Return Value

Eine Adresse.

Implements

IRuntime..::..GetAddress()()()()

See Also

Runtime Class
DynamicNode.Core Namespace


OnChildAdded Method

[image]

DynamicNodes API
Runtime..::..OnChildAdded Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnChildAdded(
    IGraph childToAdd
)
Visual Basic
Protected Overrides Sub OnChildAdded ( _
    childToAdd As IGraph _
)
F#
abstract OnChildAdded :
        childToAdd:IGraph -> unit
override OnChildAdded :
        childToAdd:IGraph -> unit

Parameters

childToAdd
Type: DynamicNode.Core..::..IGraph
Das hinzugefügte Kindobjekt.

See Also

Runtime Class
DynamicNode.Core Namespace


OnChildRemoved Method

[image]

DynamicNodes API
Runtime..::..OnChildRemoved Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnChildRemoved(
    IGraph childToRemove
)
Visual Basic
Protected Overrides Sub OnChildRemoved ( _
    childToRemove As IGraph _
)
F#
abstract OnChildRemoved :
        childToRemove:IGraph -> unit
override OnChildRemoved :
        childToRemove:IGraph -> unit

Parameters

childToRemove
Type: DynamicNode.Core..::..IGraph
Die entfernten Kindobjekte.

See Also

Runtime Class
DynamicNode.Core Namespace


OnDisposing Method

[image]

DynamicNodes API
Runtime..::..OnDisposing Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnDisposing()
Visual Basic
Protected Overrides Sub OnDisposing
F#
abstract OnDisposing : unit -> unit
override OnDisposing : unit -> unit

See Also

Runtime Class
DynamicNode.Core Namespace


OnGraphAffected Method

[image]

DynamicNodes API
Runtime..::..OnGraphAffected Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis GraphAffected aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void OnGraphAffected(
    GraphEventArgs e
)
Visual Basic
Public Sub OnGraphAffected ( _
    e As GraphEventArgs _
)
F#
member OnGraphAffected :
        e:GraphEventArgs -> unit

Parameters

e
Type: DynamicNode.Core..::..GraphEventArgs
Eine GraphEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

Runtime Class
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
Runtime..::..OnRestore Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overrides Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)

See Also

Runtime Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
Runtime..::..OnStore Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overrides Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)

See Also

Runtime Class
DynamicNode.Core Namespace


TraceError Method

[image] [image]

DynamicNodes API
Runtime..::..TraceError Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Runtime Class
Runtime Members
DynamicNode.Core Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
Runtime..::..TraceInfo Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Runtime Class
Runtime Members
DynamicNode.Core Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
Runtime..::..TraceVerbose Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Runtime Class
Runtime Members
DynamicNode.Core Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
Runtime..::..TraceVerboseData Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Runtime Class
Runtime Members
DynamicNode.Core Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
Runtime..::..TraceWarning Method
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

Runtime Class
Runtime Members
DynamicNode.Core Namespace


Runtime Properties

[image] [image]

DynamicNodes API
Runtime Properties
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Runtime type exposes the following members.

Properties

 | Name | Description
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Configuration | Gibt die IConfiguration zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Overrides BaseObject..::..IdDefaultValue.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Overrides BaseObject..::..LocalTrace.)
Public property | MsgBus | Gibt den System-Nachrichten-Bus zurück.
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Overrides BaseObject..::..NameDefaultValue.)
Public property | NodeFactory | Gibt den NodeFactory zurück, oder legt ihn fest.
 | RuntimeTraceSource | Gibt die Ablaufverfolgungsquelle für Laufzeitumgebungen zurück.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | ThreadManager | Gibt den IThreadManager zurück.

See Also

Runtime Class
DynamicNode.Core Namespace


Configuration Property

[image]

DynamicNodes API
Runtime..::..Configuration Property
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die IConfiguration zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IConfiguration Configuration { get; }
Visual Basic
Public ReadOnly Property Configuration As IConfiguration
    Get
F#
abstract Configuration : IConfiguration
override Configuration : IConfiguration

Field Value

Die DynamicNodes-System-Konfiguration.

Implements

IRuntime..::..Configuration

See Also

Runtime Class
DynamicNode.Core Namespace


IdDefaultValue Property

[image]

DynamicNodes API
Runtime..::..IdDefaultValue Property
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standardwert für die Eigenschaft Id zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override int IdDefaultValue { get; }
Visual Basic
Protected Overrides ReadOnly Property IdDefaultValue As Integer
    Get
F#
abstract IdDefaultValue : int
override IdDefaultValue : int

Field Value

Der Standardwert von Id.

See Also

Runtime Class
DynamicNode.Core Namespace


Item Property

[image] [image]

DynamicNodes API
Runtime..::..Item Property
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

Runtime Class
Runtime Members
DynamicNode.Core Namespace


LocalTrace Property

[image]

DynamicNodes API
Runtime..::..LocalTrace Property
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override TraceSource LocalTrace { get; }
Visual Basic
Protected Overrides ReadOnly Property LocalTrace As TraceSource
    Get
F#
abstract LocalTrace : TraceSource
override LocalTrace : TraceSource

See Also

Runtime Class
DynamicNode.Core Namespace


MsgBus Property

[image]

DynamicNodes API
Runtime..::..MsgBus Property
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den System-Nachrichten-Bus zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public MessageBus MsgBus { get; }
Visual Basic
Public ReadOnly Property MsgBus As MessageBus
    Get
F#
abstract MsgBus : MessageBus
override MsgBus : MessageBus

Field Value

Der System-Nachrichten-Bus.

Implements

IRuntime..::..MsgBus

See Also

Runtime Class
DynamicNode.Core Namespace


NameDefaultValue Property

[image]

DynamicNodes API
Runtime..::..NameDefaultValue Property
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standardwert für die Eigenschaft Name zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override string NameDefaultValue { get; }
Visual Basic
Protected Overrides ReadOnly Property NameDefaultValue As String
    Get
F#
abstract NameDefaultValue : string
override NameDefaultValue : string

Field Value

Der Standardwert von Name.

See Also

Runtime Class
DynamicNode.Core Namespace


NodeFactory Property

[image]

DynamicNodes API
Runtime..::..NodeFactory Property
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den NodeFactory zurück, oder legt ihn fest.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeFactory NodeFactory { get; set; }
Visual Basic
Public Property NodeFactory As NodeFactory
    Get
    Set
F#
abstract NodeFactory : NodeFactory with get, set
override NodeFactory : NodeFactory with get, set

Field Value

Der Knoten-Erzeuger.

Implements

IRuntime..::..NodeFactory

See Also

Runtime Class
DynamicNode.Core Namespace


RuntimeTraceSource Property

[image]

DynamicNodes API
Runtime..::..RuntimeTraceSource Property
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ablaufverfolgungsquelle für Laufzeitumgebungen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TraceSource RuntimeTraceSource { get; }
Visual Basic
Public Shared ReadOnly Property RuntimeTraceSource As TraceSource
    Get
F#
static member RuntimeTraceSource : TraceSource

See Also

Runtime Class
DynamicNode.Core Namespace


ThreadManager Property

[image]

DynamicNodes API
Runtime..::..ThreadManager Property
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den IThreadManager zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IThreadManager ThreadManager { get; }
Visual Basic
Public ReadOnly Property ThreadManager As IThreadManager
    Get
F#
abstract ThreadManager : IThreadManager
override ThreadManager : IThreadManager

Field Value

Der Thread-Manager.

Implements

IRuntime..::..ThreadManager

See Also

Runtime Class
DynamicNode.Core Namespace


Runtime Events

[image] [image]

DynamicNodes API
Runtime Events
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Runtime type exposes the following members.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | GraphAffected | Wird ausgelöst, wenn bei einer Änderung in der Laufzeitumgebung einGraph betroffen ist.
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)

See Also

Runtime Class
DynamicNode.Core Namespace


GraphAffected Event

[image]

DynamicNodes API
Runtime..::..GraphAffected Event
Runtime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn bei einer Änderung in der Laufzeitumgebung einGraph betroffen ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<GraphEventArgs> GraphAffected
Visual Basic
Public Event GraphAffected As EventHandler(Of GraphEventArgs)
F#
abstract GraphAffected : IEvent<EventHandler<GraphEventArgs>,
    GraphEventArgs>
override GraphAffected : IEvent<EventHandler<GraphEventArgs>,
    GraphEventArgs>

Implements

IRuntime..::..GraphAffected

See Also

Runtime Class
DynamicNode.Core Namespace


SerializedGraph Class

[image]

DynamicNodes API
SerializedGraph Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Repräsentiert einen serialisierten Graphen einschließlich dem Zustand aller Erweiterungen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
[SerializableAttribute]
public class SerializedGraph : SerializedObject
Visual Basic
<SerializableAttribute> _
Public Class SerializedGraph _
    Inherits SerializedObject
F#
[<SerializableAttribute>]
type SerializedGraph =
    class
        inherit SerializedObject
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..SerializedObject
DynamicNode.Core..::..SerializedGraph

See Also

SerializedGraph Members
DynamicNode.Core Namespace


SerializedGraph Members

[image] [image]

DynamicNodes API
SerializedGraph Members
SerializedGraph Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedGraph type exposes the following members.

Constructors

 | Name | Description
Public method | SerializedGraph()()()() | Initialisiert eine neue Instanz der Klasse SerializedGraph.
Public method | SerializedGraph(array<Byte>[]()[][]) | Initialisiert einen neue Instanz der Klasse SerializedGraph mit Hilfe der Serialisierungsdaten.
Public method | SerializedGraph(IGraph) | Initialisiert einen neue Instanz der Klasse SerializedGraph mit Hilfe eines Graphen.

Methods

 | Name | Description
Protected method | CreateXmlSerializationContext | Erzeugt den Kontext zum Serialisieren mittels XmlWriter. Wird der Kontext per Dispose()()()() entsorgt, werden die Serialisierungsdaten in Data gespeichert. (Inherited from SerializedObject.)
 | DeserializeGraph | Deserialisiert einen Graphen und stellt seinen Zustand einschließlich der statischen Erweiterungen wieder her.
Public method | InstantiateGraph | Stellt den Graphen wieder her.
Protected method | LoadDataAsXml | Lädt die Serialiserungsdaten als XML-Dokument. (Inherited from SerializedObject.)
 | SerializeGraph | Serialisiert einen Graphen einschließlich Erweiterungen.

Properties

 | Name | Description
Public property | Data | Gibt die Serialiserungsdaten zurück oder legt sie fest. (Inherited from SerializedObject.)

See Also

SerializedGraph Class
DynamicNode.Core Namespace


SerializedGraph Constructor

[image] [image]

DynamicNodes API
SerializedGraph Constructor
SerializedGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | SerializedGraph()()()() | Initialisiert eine neue Instanz der Klasse SerializedGraph.
Public method | SerializedGraph(array<Byte>[]()[][]) | Initialisiert einen neue Instanz der Klasse SerializedGraph mit Hilfe der Serialisierungsdaten.
Public method | SerializedGraph(IGraph) | Initialisiert einen neue Instanz der Klasse SerializedGraph mit Hilfe eines Graphen.

See Also

SerializedGraph Class
SerializedGraph Members
DynamicNode.Core Namespace


SerializedGraph Constructor

[image]

DynamicNodes API
SerializedGraph Constructor
SerializedGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse SerializedGraph.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SerializedGraph()
Visual Basic
Public Sub New
F#
new : unit -> SerializedGraph

See Also

SerializedGraph Class
SerializedGraph Overload
DynamicNode.Core Namespace


SerializedGraph Constructor (Byte[])

[image]

DynamicNodes API
SerializedGraph Constructor (array<Byte>[]()[][])
SerializedGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neue Instanz der Klasse SerializedGraph mit Hilfe der Serialisierungsdaten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SerializedGraph(
    byte[] data
)
Visual Basic
Public Sub New ( _
    data As Byte() _
)
F#
new :
        data:byte[] -> SerializedGraph

Parameters

data
Type: array< System..::..Byte >[]()[][]
Die Serialisierungsdaten.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für datanull übergeben wird.

See Also

SerializedGraph Class
SerializedGraph Overload
DynamicNode.Core Namespace


SerializedGraph Constructor (IGraph)

[image]

DynamicNodes API
SerializedGraph Constructor (IGraph)
SerializedGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neue Instanz der Klasse SerializedGraph mit Hilfe eines Graphen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SerializedGraph(
    IGraph graph
)
Visual Basic
Public Sub New ( _
    graph As IGraph _
)
F#
new :
        graph:IGraph -> SerializedGraph

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für graphnull übergeben wird.

See Also

SerializedGraph Class
SerializedGraph Overload
DynamicNode.Core Namespace


SerializedGraph Methods

[image] [image]

DynamicNodes API
SerializedGraph Methods
SerializedGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedGraph type exposes the following members.

Methods

 | Name | Description
Protected method | CreateXmlSerializationContext | Erzeugt den Kontext zum Serialisieren mittels XmlWriter. Wird der Kontext per Dispose()()()() entsorgt, werden die Serialisierungsdaten in Data gespeichert. (Inherited from SerializedObject.)
 | DeserializeGraph | Deserialisiert einen Graphen und stellt seinen Zustand einschließlich der statischen Erweiterungen wieder her.
Public method | InstantiateGraph | Stellt den Graphen wieder her.
Protected method | LoadDataAsXml | Lädt die Serialiserungsdaten als XML-Dokument. (Inherited from SerializedObject.)
 | SerializeGraph | Serialisiert einen Graphen einschließlich Erweiterungen.

See Also

SerializedGraph Class
DynamicNode.Core Namespace


DeserializeGraph Method

[image]

DynamicNodes API
SerializedGraph..::..DeserializeGraph Method
SerializedGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Deserialisiert einen Graphen und stellt seinen Zustand einschließlich der statischen Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static IGraph DeserializeGraph(
    XmlElement e,
    IRuntime runtime,
    IGraphStorage storage,
    params IExtension<IGraph>[] extensions
)
Visual Basic
Public Shared Function DeserializeGraph ( _
    e As XmlElement, _
    runtime As IRuntime, _
    storage As IGraphStorage, _
    ParamArray extensions As IExtension(Of IGraph)() _
) As IGraph
F#
static member DeserializeGraph :
        e:XmlElement *
        runtime:IRuntime *
        storage:IGraphStorage *
        extensions:IExtension<IGraph>[] -> IGraph

Parameters

e
Type: System.Xml..::..XmlElement
Das XmlElement, das die Beschreibung des Graphen enthält.
runtime
Type: DynamicNode.Core..::..IRuntime
Die Laufzeitumgebung
storage
Type: DynamicNode.Core..::..IGraphStorage
Ein IGraphStorage oder null.
extensions
Type: array< DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>>[]()[][]
Die Erweiterungen, die direkt beim Instanzieren des Graphen geladen werden sollen.

Return Value

[Missing <returns> documentation for "M:DynamicNode.Core.SerializedGraph.DeserializeGraph(System.Xml.XmlElement,DynamicNode.Core.IRuntime,DynamicNode.Core.IGraphStorage,DynamicNode.Model.IExtension{DynamicNode.Core.IGraph}[])"]

See Also

SerializedGraph Class
DynamicNode.Core Namespace


InstantiateGraph Method

[image]

DynamicNodes API
SerializedGraph..::..InstantiateGraph Method
SerializedGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt den Graphen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IGraph InstantiateGraph(
    IRuntime runtime,
    params IExtension<IGraph>[] extensions
)
Visual Basic
Public Function InstantiateGraph ( _
    runtime As IRuntime, _
    ParamArray extensions As IExtension(Of IGraph)() _
) As IGraph
F#
member InstantiateGraph :
        runtime:IRuntime *
        extensions:IExtension<IGraph>[] -> IGraph

Parameters

runtime
Type: DynamicNode.Core..::..IRuntime
Die Laufzeitumgebung.
extensions
Type: array< DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>>[]()[][]
Alle Graph-Erweiterungen die direkt beim Instanzieren angefügt werden sollen.

Return Value

[Missing <returns> documentation for "M:DynamicNode.Core.SerializedGraph.InstantiateGraph(DynamicNode.Core.IRuntime,DynamicNode.Model.IExtension{DynamicNode.Core.IGraph}[])"]

See Also

SerializedGraph Class
DynamicNode.Core Namespace


SerializeGraph Method

[image]

DynamicNodes API
SerializedGraph..::..SerializeGraph Method
SerializedGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Serialisiert einen Graphen einschließlich Erweiterungen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void SerializeGraph(
    XmlWriter target,
    IGraph graph
)
Visual Basic
Public Shared Sub SerializeGraph ( _
    target As XmlWriter, _
    graph As IGraph _
)
F#
static member SerializeGraph :
        target:XmlWriter *
        graph:IGraph -> unit

Parameters

target
Type: System.Xml..::..XmlWriter
Ein XmlWriter in dem der Zustand des Graphen gespeichert werden soll.
graph
Type: DynamicNode.Core..::..IGraph

[Missing <param name="graph"/> documentation for "M:DynamicNode.Core.SerializedGraph.SerializeGraph(System.Xml.XmlWriter,DynamicNode.Core.IGraph)"]

See Also

SerializedGraph Class
DynamicNode.Core Namespace


SerializedGraph Properties

[image] [image]

DynamicNodes API
SerializedGraph Properties
SerializedGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedGraph type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gibt die Serialiserungsdaten zurück oder legt sie fest. (Inherited from SerializedObject.)

See Also

SerializedGraph Class
DynamicNode.Core Namespace


SerializedNode Class

[image]

DynamicNodes API
SerializedNode Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Repräsentiert einen serialisierten Knoten einschließlich dem Zustand aller statischen Erweiterungen von Knoten und Anschlüssen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
[SerializableAttribute]
public class SerializedNode : SerializedObject
Visual Basic
<SerializableAttribute> _
Public Class SerializedNode _
    Inherits SerializedObject
F#
[<SerializableAttribute>]
type SerializedNode =
    class
        inherit SerializedObject
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..SerializedObject
DynamicNode.Core..::..SerializedNode

See Also

SerializedNode Members
DynamicNode.Core Namespace


SerializedNode Members

[image] [image]

DynamicNodes API
SerializedNode Members
SerializedNode Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedNode type exposes the following members.

Constructors

 | Name | Description
Public method | SerializedNode()()()() | Initialisiert einen neue Instanz der Klasse SerializedNode.
Public method | SerializedNode(array<Byte>[]()[][]) | Initialisiert einen neue Instanz der Klasse SerializedNode mit Hilfe der Serialisierungsdaten.
Public method | SerializedNode(INode) | Initialisiert einen neue Instanz der Klasse SerializedNode mit Hilfe eines Knoten.

Methods

 | Name | Description
Protected method | CreateXmlSerializationContext | Erzeugt den Kontext zum Serialisieren mittels XmlWriter. Wird der Kontext per Dispose()()()() entsorgt, werden die Serialisierungsdaten in Data gespeichert. (Inherited from SerializedObject.)
 | DeserializeNode | Deserialisiert einen Knoten aus einem XmlElement und instanziert ihn in dem übergebenen Graphen.
Public method | Instantiate | Instanziert den serialisierten Knoten in einem Graph und stellt alle persistierten Eigenschaften einschließlich der statischen Knoten- und Anschlusserweiterungen wieder her.
Protected method | LoadDataAsXml | Lädt die Serialiserungsdaten als XML-Dokument. (Inherited from SerializedObject.)
 | SerializeNode | Serialisiert einen Knoten und speichert seinen Zustand einschließlich der statischen Knoten- und Anschlusserweiterungen in w.

Properties

 | Name | Description
Public property | Data | Gibt die Serialiserungsdaten zurück oder legt sie fest. (Inherited from SerializedObject.)

See Also

SerializedNode Class
DynamicNode.Core Namespace


SerializedNode Constructor

[image] [image]

DynamicNodes API
SerializedNode Constructor
SerializedNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | SerializedNode()()()() | Initialisiert einen neue Instanz der Klasse SerializedNode.
Public method | SerializedNode(array<Byte>[]()[][]) | Initialisiert einen neue Instanz der Klasse SerializedNode mit Hilfe der Serialisierungsdaten.
Public method | SerializedNode(INode) | Initialisiert einen neue Instanz der Klasse SerializedNode mit Hilfe eines Knoten.

See Also

SerializedNode Class
SerializedNode Members
DynamicNode.Core Namespace


SerializedNode Constructor

[image]

DynamicNodes API
SerializedNode Constructor
SerializedNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neue Instanz der Klasse SerializedNode.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SerializedNode()
Visual Basic
Public Sub New
F#
new : unit -> SerializedNode

See Also

SerializedNode Class
SerializedNode Overload
DynamicNode.Core Namespace


SerializedNode Constructor (Byte[])

[image]

DynamicNodes API
SerializedNode Constructor (array<Byte>[]()[][])
SerializedNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neue Instanz der Klasse SerializedNode mit Hilfe der Serialisierungsdaten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SerializedNode(
    byte[] data
)
Visual Basic
Public Sub New ( _
    data As Byte() _
)
F#
new :
        data:byte[] -> SerializedNode

Parameters

data
Type: array< System..::..Byte >[]()[][]
Die Serialisierungsdaten.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für datanull übergeben wird.

See Also

SerializedNode Class
SerializedNode Overload
DynamicNode.Core Namespace


SerializedNode Constructor (INode)

[image]

DynamicNodes API
SerializedNode Constructor (INode)
SerializedNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neue Instanz der Klasse SerializedNode mit Hilfe eines Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SerializedNode(
    INode node
)
Visual Basic
Public Sub New ( _
    node As INode _
)
F#
new :
        node:INode -> SerializedNode

Parameters

node
Type: DynamicNode.Core..::..INode
Der Knoten.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für nodenull übergeben wurde.

See Also

SerializedNode Class
SerializedNode Overload
DynamicNode.Core Namespace


SerializedNode Methods

[image] [image]

DynamicNodes API
SerializedNode Methods
SerializedNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedNode type exposes the following members.

Methods

 | Name | Description
Protected method | CreateXmlSerializationContext | Erzeugt den Kontext zum Serialisieren mittels XmlWriter. Wird der Kontext per Dispose()()()() entsorgt, werden die Serialisierungsdaten in Data gespeichert. (Inherited from SerializedObject.)
 | DeserializeNode | Deserialisiert einen Knoten aus einem XmlElement und instanziert ihn in dem übergebenen Graphen.
Public method | Instantiate | Instanziert den serialisierten Knoten in einem Graph und stellt alle persistierten Eigenschaften einschließlich der statischen Knoten- und Anschlusserweiterungen wieder her.
Protected method | LoadDataAsXml | Lädt die Serialiserungsdaten als XML-Dokument. (Inherited from SerializedObject.)
 | SerializeNode | Serialisiert einen Knoten und speichert seinen Zustand einschließlich der statischen Knoten- und Anschlusserweiterungen in w.

See Also

SerializedNode Class
DynamicNode.Core Namespace


DeserializeNode Method

[image]

DynamicNodes API
SerializedNode..::..DeserializeNode Method
SerializedNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Deserialisiert einen Knoten aus einem XmlElement und instanziert ihn in dem übergebenen Graphen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static INode DeserializeNode(
    XmlElement e,
    IGraph graph,
    out int originalId,
    bool withOriginalId
)
Visual Basic
Public Shared Function DeserializeNode ( _
    e As XmlElement, _
    graph As IGraph, _
    <OutAttribute> ByRef originalId As Integer, _
    withOriginalId As Boolean _
) As INode
F#
static member DeserializeNode :
        e:XmlElement *
        graph:IGraph *
        originalId:int byref *
        withOriginalId:bool -> INode

Parameters

e
Type: System.Xml..::..XmlElement
Das XmlElement, das die Beschreibung des Knotens enthält.
graph
Type: DynamicNode.Core..::..IGraph
Der Graph, in dem der Knoten wiederhergestellt werden soll.
originalId
Type: System..::..Int32 %
Die originale ID.
withOriginalId
Type: System..::..Boolean
Wenn true, wird der Knoten mit seiner alten ID in den Graphen eingesetzt, sonst bekommt er eine neue ID vom Graphen.

Return Value

Der deserialisierte Knoten oder null wenn die Deserialisierung fehlgeschlagen ist.

See Also

SerializedNode Class
DynamicNode.Core Namespace


Instantiate Method

[image]

DynamicNodes API
SerializedNode..::..Instantiate Method
SerializedNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Instanziert den serialisierten Knoten in einem Graph und stellt alle persistierten Eigenschaften einschließlich der statischen Knoten- und Anschlusserweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public INode Instantiate(
    IGraph graph,
    bool withOriginalId
)
Visual Basic
Public Function Instantiate ( _
    graph As IGraph, _
    withOriginalId As Boolean _
) As INode
F#
member Instantiate :
        graph:IGraph *
        withOriginalId:bool -> INode

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph in dem der Knoten instanziert werden sollen.
withOriginalId
Type: System..::..Boolean
Wenn true, wird der Knoten mit seiner alten ID in den Graphen eingesetzt, sonst bekommt er eine neue ID vom Graphen.

Return Value

Der instanzierte Knoten.

See Also

SerializedNode Class
DynamicNode.Core Namespace


SerializeNode Method

[image]

DynamicNodes API
SerializedNode..::..SerializeNode Method
SerializedNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Serialisiert einen Knoten und speichert seinen Zustand einschließlich der statischen Knoten- und Anschlusserweiterungen in w.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void SerializeNode(
    XmlWriter w,
    INode n,
    Predicate<InPort> connectionFilter
)
Visual Basic
Public Shared Sub SerializeNode ( _
    w As XmlWriter, _
    n As INode, _
    connectionFilter As Predicate(Of InPort) _
)
F#
static member SerializeNode :
        w:XmlWriter *
        n:INode *
        connectionFilter:Predicate<InPort> -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Ein XmlWriter in dem der Knoten seinen Zustand speichert.
n
Type: DynamicNode.Core..::..INode
Der Knoten
connectionFilter
Type: System..::..Predicate <(Of <(<' InPort >)>)>
Ein Prädikat das bestimmt, welche eingehenden Verbindungen gespeichert werden sollen.

See Also

SerializedNode Class
DynamicNode.Core Namespace


SerializedNode Properties

[image] [image]

DynamicNodes API
SerializedNode Properties
SerializedNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedNode type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gibt die Serialiserungsdaten zurück oder legt sie fest. (Inherited from SerializedObject.)

See Also

SerializedNode Class
DynamicNode.Core Namespace


SerializedNodeSet Class

[image]

DynamicNodes API
SerializedNodeSet Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Repräsentiert eine Gruppe von serialisierten Knoten (SerializedNode) einschließlich der Verbindungen die sich innerhalb der Gruppe befinden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
[SerializableAttribute]
public class SerializedNodeSet : SerializedObject
Visual Basic
<SerializableAttribute> _
Public Class SerializedNodeSet _
    Inherits SerializedObject
F#
[<SerializableAttribute>]
type SerializedNodeSet =
    class
        inherit SerializedObject
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..SerializedObject
DynamicNode.Core..::..SerializedNodeSet

See Also

SerializedNodeSet Members
DynamicNode.Core Namespace


SerializedNodeSet Members

[image] [image]

DynamicNodes API
SerializedNodeSet Members
SerializedNodeSet Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedNodeSet type exposes the following members.

Constructors

 | Name | Description
Public method | SerializedNodeSet()()()() | Initialisiert einen neue Instanz der Klasse SerializedNodeSet.
Public method | SerializedNodeSet(array<Byte>[]()[][]) | Initialisiert einen neue Instanz der Klasse SerializedNodeSet mit Hilfe der Serialisierungsdaten.
Public method | SerializedNodeSet(IEnumerable<(Of <<'(INode>)>>), Predicate<(Of <<'(InPort>)>>)) | Initialisiert einen neue Instanz der Klasse SerializedNodeSet mit Hilfe einer Aufzählung von Knoten.

Methods

 | Name | Description
Protected method | CreateXmlSerializationContext | Erzeugt den Kontext zum Serialisieren mittels XmlWriter. Wird der Kontext per Dispose()()()() entsorgt, werden die Serialisierungsdaten in Data gespeichert. (Inherited from SerializedObject.)
 | DeserializeNodes | Deserialisiert eine Knotengruppe aus einem XmlElement und instanziert ihn in dem übergebenen Graphen. Alle Verbindungen werden wieder hergestellt.
Public method | Instantiate | Instanziert die serialisierten Knoten in einem Graph und stellt alle persistierten Eigenschaften einschließlich der statischen Knoten- und Anschlusserweiterungen wieder her.
Protected method | LoadDataAsXml | Lädt die Serialiserungsdaten als XML-Dokument. (Inherited from SerializedObject.)
 | SerializeNodes | Serialisiert eine Knotengruppe und speichert ihren Zustand einschließlich der statischen Knoten- und Anschlusserweiterungen in target.

Properties

 | Name | Description
Public property | Data | Gibt die Serialiserungsdaten zurück oder legt sie fest. (Inherited from SerializedObject.)

See Also

SerializedNodeSet Class
DynamicNode.Core Namespace


SerializedNodeSet Constructor

[image] [image]

DynamicNodes API
SerializedNodeSet Constructor
SerializedNodeSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | SerializedNodeSet()()()() | Initialisiert einen neue Instanz der Klasse SerializedNodeSet.
Public method | SerializedNodeSet(array<Byte>[]()[][]) | Initialisiert einen neue Instanz der Klasse SerializedNodeSet mit Hilfe der Serialisierungsdaten.
Public method | SerializedNodeSet(IEnumerable<(Of <<'(INode>)>>), Predicate<(Of <<'(InPort>)>>)) | Initialisiert einen neue Instanz der Klasse SerializedNodeSet mit Hilfe einer Aufzählung von Knoten.

See Also

SerializedNodeSet Class
SerializedNodeSet Members
DynamicNode.Core Namespace


SerializedNodeSet Constructor

[image]

DynamicNodes API
SerializedNodeSet Constructor
SerializedNodeSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neue Instanz der Klasse SerializedNodeSet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SerializedNodeSet()
Visual Basic
Public Sub New
F#
new : unit -> SerializedNodeSet

See Also

SerializedNodeSet Class
SerializedNodeSet Overload
DynamicNode.Core Namespace


SerializedNodeSet Constructor (Byte[])

[image]

DynamicNodes API
SerializedNodeSet Constructor (array<Byte>[]()[][])
SerializedNodeSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neue Instanz der Klasse SerializedNodeSet mit Hilfe der Serialisierungsdaten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SerializedNodeSet(
    byte[] data
)
Visual Basic
Public Sub New ( _
    data As Byte() _
)
F#
new :
        data:byte[] -> SerializedNodeSet

Parameters

data
Type: array< System..::..Byte >[]()[][]
Die Serialisierungsdaten.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für datanull übergeben wird.

See Also

SerializedNodeSet Class
SerializedNodeSet Overload
DynamicNode.Core Namespace


SerializedNodeSet Constructor (IEnumerable(INode), Predicate(InPort))

[image]

DynamicNodes API
SerializedNodeSet Constructor (IEnumerable<(Of <(<'INode>)>)>, Predicate<(Of <(<'InPort>)>)>)
SerializedNodeSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neue Instanz der Klasse SerializedNodeSet mit Hilfe einer Aufzählung von Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SerializedNodeSet(
    IEnumerable<INode> nodes,
    Predicate<InPort> connectionFilter
)
Visual Basic
Public Sub New ( _
    nodes As IEnumerable(Of INode), _
    connectionFilter As Predicate(Of InPort) _
)
F#
new :
        nodes:IEnumerable<INode> *
        connectionFilter:Predicate<InPort> -> SerializedNodeSet

Parameters

nodes
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' INode >)>)>
The node.
connectionFilter
Type: System..::..Predicate <(Of <(<' InPort >)>)>
Ein Prädikat das bestimmt, welche eingehenden Verbindungen gespeichert werden sollen.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für nodesnull übergeben wurde.

See Also

SerializedNodeSet Class
SerializedNodeSet Overload
DynamicNode.Core Namespace


SerializedNodeSet Methods

[image] [image]

DynamicNodes API
SerializedNodeSet Methods
SerializedNodeSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedNodeSet type exposes the following members.

Methods

 | Name | Description
Protected method | CreateXmlSerializationContext | Erzeugt den Kontext zum Serialisieren mittels XmlWriter. Wird der Kontext per Dispose()()()() entsorgt, werden die Serialisierungsdaten in Data gespeichert. (Inherited from SerializedObject.)
 | DeserializeNodes | Deserialisiert eine Knotengruppe aus einem XmlElement und instanziert ihn in dem übergebenen Graphen. Alle Verbindungen werden wieder hergestellt.
Public method | Instantiate | Instanziert die serialisierten Knoten in einem Graph und stellt alle persistierten Eigenschaften einschließlich der statischen Knoten- und Anschlusserweiterungen wieder her.
Protected method | LoadDataAsXml | Lädt die Serialiserungsdaten als XML-Dokument. (Inherited from SerializedObject.)
 | SerializeNodes | Serialisiert eine Knotengruppe und speichert ihren Zustand einschließlich der statischen Knoten- und Anschlusserweiterungen in target.

See Also

SerializedNodeSet Class
DynamicNode.Core Namespace


DeserializeNodes Method

[image]

DynamicNodes API
SerializedNodeSet..::..DeserializeNodes Method
SerializedNodeSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Deserialisiert eine Knotengruppe aus einem XmlElement und instanziert ihn in dem übergebenen Graphen. Alle Verbindungen werden wieder hergestellt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static INode[] DeserializeNodes(
    XmlElement source,
    IGraph graph,
    bool withOriginalIds
)
Visual Basic
Public Shared Function DeserializeNodes ( _
    source As XmlElement, _
    graph As IGraph, _
    withOriginalIds As Boolean _
) As INode()
F#
static member DeserializeNodes :
        source:XmlElement *
        graph:IGraph *
        withOriginalIds:bool -> INode[]

Parameters

source
Type: System.Xml..::..XmlElement
Das XmlElement, das die Beschreibung des Knotens enthält.
graph
Type: DynamicNode.Core..::..IGraph
Der Graph, in dem der Knoten wiederhergestellt werden soll.
withOriginalIds
Type: System..::..Boolean
Wenn true übergeben wird, werden die Knoten mit ihren originalen IDs eingesetzt.

Return Value

Ein Array der deserialisierten Knoten.

See Also

SerializedNodeSet Class
DynamicNode.Core Namespace


Instantiate Method

[image]

DynamicNodes API
SerializedNodeSet..::..Instantiate Method
SerializedNodeSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Instanziert die serialisierten Knoten in einem Graph und stellt alle persistierten Eigenschaften einschließlich der statischen Knoten- und Anschlusserweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public INode[] Instantiate(
    IGraph graph,
    bool withOriginalIds
)
Visual Basic
Public Function Instantiate ( _
    graph As IGraph, _
    withOriginalIds As Boolean _
) As INode()
F#
member Instantiate :
        graph:IGraph *
        withOriginalIds:bool -> INode[]

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph in dem die Knoten instanziert werden sollen.
withOriginalIds
Type: System..::..Boolean
Wenn true übergeben wird, werden die Knoten mit ihren originalen IDs eingesetzt.

Return Value

Ein Array mit den instanzierten Knoten.

See Also

SerializedNodeSet Class
DynamicNode.Core Namespace


SerializeNodes Method

[image]

DynamicNodes API
SerializedNodeSet..::..SerializeNodes Method
SerializedNodeSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Serialisiert eine Knotengruppe und speichert ihren Zustand einschließlich der statischen Knoten- und Anschlusserweiterungen in target.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void SerializeNodes(
    XmlWriter target,
    IEnumerable<INode> nodes,
    Predicate<InPort> connectionFilter
)
Visual Basic
Public Shared Sub SerializeNodes ( _
    target As XmlWriter, _
    nodes As IEnumerable(Of INode), _
    connectionFilter As Predicate(Of InPort) _
)
F#
static member SerializeNodes :
        target:XmlWriter *
        nodes:IEnumerable<INode> *
        connectionFilter:Predicate<InPort> -> unit

Parameters

target
Type: System.Xml..::..XmlWriter
Ein XmlWriter in dem der Zustand der Knoten gespeichert werden soll.
nodes
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' INode >)>)>
Die Knoten
connectionFilter
Type: System..::..Predicate <(Of <(<' InPort >)>)>
Ein Prädikat das bestimmt, welche eingehenden Verbindungen gespeichert werden sollen.

See Also

SerializedNodeSet Class
DynamicNode.Core Namespace


SerializedNodeSet Properties

[image] [image]

DynamicNodes API
SerializedNodeSet Properties
SerializedNodeSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedNodeSet type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gibt die Serialiserungsdaten zurück oder legt sie fest. (Inherited from SerializedObject.)

See Also

SerializedNodeSet Class
DynamicNode.Core Namespace


SerializedObject Class

[image]

DynamicNodes API
SerializedObject Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Repräsentiert ein serialisiertes Objekt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
[SerializableAttribute]
public abstract class SerializedObject
Visual Basic
<SerializableAttribute> _
Public MustInherit Class SerializedObject
F#
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type SerializedObject =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..SerializedObject
DynamicNode.Core..::..SerializedGraph
DynamicNode.Core..::..SerializedNode
DynamicNode.Core..::..SerializedNodeSet

See Also

SerializedObject Members
DynamicNode.Core Namespace


SerializedObject Members

[image] [image]

DynamicNodes API
SerializedObject Members
SerializedObject Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedObject type exposes the following members.

Constructors

 | Name | Description
Protected method | SerializedObject()()()() | Initialisiert eine neue Instanz der Klasse SerializedObject.
Protected method | SerializedObject(array<Byte>[]()[][]) | Initialisiert eine neue Instanz der Klasse SerializedObject mit Hilfe der Serialisierungsdaten.

Methods

 | Name | Description
Protected method | CreateXmlSerializationContext | Erzeugt den Kontext zum Serialisieren mittels XmlWriter. Wird der Kontext per Dispose()()()() entsorgt, werden die Serialisierungsdaten in Data gespeichert.
Protected method | LoadDataAsXml | Lädt die Serialiserungsdaten als XML-Dokument.

Properties

 | Name | Description
Public property | Data | Gibt die Serialiserungsdaten zurück oder legt sie fest.

See Also

SerializedObject Class
DynamicNode.Core Namespace


SerializedObject Constructor

[image] [image]

DynamicNodes API
SerializedObject Constructor
SerializedObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | SerializedObject()()()() | Initialisiert eine neue Instanz der Klasse SerializedObject.
Protected method | SerializedObject(array<Byte>[]()[][]) | Initialisiert eine neue Instanz der Klasse SerializedObject mit Hilfe der Serialisierungsdaten.

See Also

SerializedObject Class
SerializedObject Members
DynamicNode.Core Namespace


SerializedObject Constructor

[image]

DynamicNodes API
SerializedObject Constructor
SerializedObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse SerializedObject.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected SerializedObject()
Visual Basic
Protected Sub New
F#
new : unit -> SerializedObject

See Also

SerializedObject Class
SerializedObject Overload
DynamicNode.Core Namespace


SerializedObject Constructor (Byte[])

[image]

DynamicNodes API
SerializedObject Constructor (array<Byte>[]()[][])
SerializedObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse SerializedObject mit Hilfe der Serialisierungsdaten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected SerializedObject(
    byte[] data
)
Visual Basic
Protected Sub New ( _
    data As Byte() _
)
F#
new :
        data:byte[] -> SerializedObject

Parameters

data
Type: array< System..::..Byte >[]()[][]
Die Serialisierungsdaten.

See Also

SerializedObject Class
SerializedObject Overload
DynamicNode.Core Namespace


SerializedObject Methods

[image] [image]

DynamicNodes API
SerializedObject Methods
SerializedObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedObject type exposes the following members.

Methods

 | Name | Description
Protected method | CreateXmlSerializationContext | Erzeugt den Kontext zum Serialisieren mittels XmlWriter. Wird der Kontext per Dispose()()()() entsorgt, werden die Serialisierungsdaten in Data gespeichert.
Protected method | LoadDataAsXml | Lädt die Serialiserungsdaten als XML-Dokument.

See Also

SerializedObject Class
DynamicNode.Core Namespace


CreateXmlSerializationContext Method

[image]

DynamicNodes API
SerializedObject..::..CreateXmlSerializationContext Method
SerializedObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt den Kontext zum Serialisieren mittels XmlWriter. Wird der Kontext per Dispose()()()() entsorgt, werden die Serialisierungsdaten in Data gespeichert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected SerializedObject..::..SerializationContext CreateXmlSerializationContext()
Visual Basic
Protected Function CreateXmlSerializationContext As SerializedObject..::..SerializationContext
F#
member CreateXmlSerializationContext : unit -> SerializedObject..::..SerializationContext

Return Value

Den XML-Serialisierungskontext.

See Also

SerializedObject Class
DynamicNode.Core Namespace


LoadDataAsXml Method

[image]

DynamicNodes API
SerializedObject..::..LoadDataAsXml Method
SerializedObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Lädt die Serialiserungsdaten als XML-Dokument.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected XmlElement LoadDataAsXml()
Visual Basic
Protected Function LoadDataAsXml As XmlElement
F#
member LoadDataAsXml : unit -> XmlElement

Return Value

Das XML-Dokument.

See Also

SerializedObject Class
DynamicNode.Core Namespace


SerializedObject Properties

[image] [image]

DynamicNodes API
SerializedObject Properties
SerializedObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedObject type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gibt die Serialiserungsdaten zurück oder legt sie fest.

See Also

SerializedObject Class
DynamicNode.Core Namespace


Data Property

[image]

DynamicNodes API
SerializedObject..::..Data Property
SerializedObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Serialiserungsdaten zurück oder legt sie fest.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public byte[] Data { get; set; }
Visual Basic
Public Property Data As Byte()
    Get
    Set
F#
member Data : byte[] with get, set

Field Value

Die Serialisierungsdaten.

See Also

SerializedObject Class
DynamicNode.Core Namespace


SerializedObject.SerializationContext Class

[image]

DynamicNodes API
SerializedObject..::..SerializationContext Class
SerializedObject Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der XML-Serialisierungskontext.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected class SerializationContext : IDisposable
Visual Basic
Protected Class SerializationContext _
    Implements IDisposable
F#
type SerializationContext =
    class
        interface IDisposable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..SerializedObject..::..SerializationContext

See Also

SerializedObject..::..SerializationContext Members
DynamicNode.Core Namespace


SerializedObject.SerializationContext Members

[image] [image]

DynamicNodes API
SerializedObject..::..SerializationContext Members
SerializedObject..::..SerializationContext Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Repräsentiert ein serialisiertes Objekt.

The SerializedObject..::..SerializationContext type exposes the following members.

Constructors

 | Name | Description
Public method | SerializedObject..::..SerializationContext | Initialisiert eine neue Instanz der Klasse SerializedObject..::..SerializationContext.

Methods

 | Name | Description
Public method | Dispose | Beendet die Serialiserung und speichert die Serialisierungsdaten in Data.

Properties

 | Name | Description
Public property | XmlWriter | Der XmlWriter mit dem die Serialisierung durchgeführt wird.

See Also

SerializedObject..::..SerializationContext Class
DynamicNode.Core Namespace


SerializedObject.SerializationContext Constructor

[image]

DynamicNodes API
SerializedObject..::..SerializationContext Constructor
SerializedObject..::..SerializationContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse SerializedObject..::..SerializationContext.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SerializationContext(
    SerializedObject serializedObject
)
Visual Basic
Public Sub New ( _
    serializedObject As SerializedObject _
)
F#
new :
        serializedObject:SerializedObject -> SerializationContext

Parameters

serializedObject
Type: DynamicNode.Core..::..SerializedObject
Eine Instanz von SerializedObject in der nach Entsorgung des Serialisierungskontextes die Serialiserungsdaten gespeichert werden sollen.

See Also

SerializedObject..::..SerializationContext Class
DynamicNode.Core Namespace


SerializedObject.SerializationContext Methods

[image] [image]

DynamicNodes API
SerializedObject..::..SerializationContext Methods
SerializedObject..::..SerializationContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedObject..::..SerializationContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Beendet die Serialiserung und speichert die Serialisierungsdaten in Data.

See Also

SerializedObject..::..SerializationContext Class
DynamicNode.Core Namespace


Dispose Method

[image]

DynamicNodes API
SerializedObject..::..SerializationContext..::..Dispose Method
SerializedObject..::..SerializationContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beendet die Serialiserung und speichert die Serialisierungsdaten in Data.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
F#
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposable..::..Dispose()()()()

See Also

SerializedObject..::..SerializationContext Class
DynamicNode.Core Namespace


SerializedObject.SerializationContext Properties

[image] [image]

DynamicNodes API
SerializedObject..::..SerializationContext Properties
SerializedObject..::..SerializationContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SerializedObject..::..SerializationContext type exposes the following members.

Properties

 | Name | Description
Public property | XmlWriter | Der XmlWriter mit dem die Serialisierung durchgeführt wird.

See Also

SerializedObject..::..SerializationContext Class
DynamicNode.Core Namespace


XmlWriter Property

[image]

DynamicNodes API
SerializedObject..::..SerializationContext..::..XmlWriter Property
SerializedObject..::..SerializationContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der XmlWriter mit dem die Serialisierung durchgeführt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public XmlWriter XmlWriter { get; private set; }
Visual Basic
Public Property XmlWriter As XmlWriter
    Get
    Private Set
F#
member XmlWriter : XmlWriter with get, private set

See Also

SerializedObject..::..SerializationContext Class
DynamicNode.Core Namespace


SimpleMethod Delegate

[image]

DynamicNodes API
SimpleMethod Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein einfaches parameterloses Delegate mit void als Rückgabewert.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public delegate void SimpleMethod()
Visual Basic
Public Delegate Sub SimpleMethod
F#
type SimpleMethod =
    delegate of unit -> unit

See Also

DynamicNode.Core Namespace


StaticNodeInfoAttribute Class

[image]

DynamicNodes API
StaticNodeInfoAttribute Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Dieses Attribut wird verwendet um für eine von Node abgeleitete Klasse die Meta-Daten anzugeben. Im Unterscheid zu NodeInfoAttribute werden die Meta-Daten nicht als Konstanten angegeben, sondern eine öffentlich statisch Methode beschrieben, welche die Meta-Daten liefert. Dadurch wird es möglich, die Meta-Daten zu lokalisieren. Diese Meta-Daten werden verwendet um eine Auswahl der verfügbaren Knoten-Typen in der Benutzeroberfläche zu ermöglichen, ohne einen Knoten zu instanzieren.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class StaticNodeInfoAttribute : Attribute
Visual Basic
Public Class StaticNodeInfoAttribute _
    Inherits Attribute
F#
type StaticNodeInfoAttribute =
    class
        inherit Attribute
    end

Remarks

Falls keine Lokalisierung der Meta-Daten erforderlich ist, sollte zur Vereinfachung NodeInfoAttribute direkt verwendet werden.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
DynamicNode.Core..::..StaticNodeInfoAttribute

See Also

StaticNodeInfoAttribute Members
DynamicNode.Core Namespace


StaticNodeInfoAttribute Members

[image] [image]

DynamicNodes API
StaticNodeInfoAttribute Members
StaticNodeInfoAttribute Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The StaticNodeInfoAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | StaticNodeInfoAttribute | Initialisiert eine neue Instanz von StaticNodeInfoAttribute. Es wird die Beschreibung einer öffentlichen statischen Methode benötigt, um dieses Attribut zu initialisieren. Diese Methode darf keine Parameter erwarten und muss den Rückgabetyp NodeInfoAttribute besitzen.

Methods

 | Name | Description
Public method | GetNodeInfo | Ruft die statische Methode auf, mit welcher diese Instanz initialsiert wurde und gibt die erhaltene NodeInfoAttribute-Instanz zurück.

See Also

StaticNodeInfoAttribute Class
DynamicNode.Core Namespace


StaticNodeInfoAttribute Constructor

[image]

DynamicNodes API
StaticNodeInfoAttribute Constructor
StaticNodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Initialisiert eine neue Instanz von StaticNodeInfoAttribute.

Es wird die Beschreibung einer öffentlichen statischen Methode benötigt, um dieses Attribut zu initialisieren. Diese Methode darf keine Parameter erwarten und muss den Rückgabetyp NodeInfoAttribute besitzen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public StaticNodeInfoAttribute(
    Type type,
    string method
)
Visual Basic
Public Sub New ( _
    type As Type, _
    method As String _
)
F#
new :
        type:Type *
        method:string -> StaticNodeInfoAttribute

Parameters

type
Type: System..::..Type
Die Klasse, welche die statische Methode zur Verfügung stellt.
method
Type: System..::..String
Der Name der Methode.

See Also

StaticNodeInfoAttribute Class
DynamicNode.Core Namespace


StaticNodeInfoAttribute Methods

[image] [image]

DynamicNodes API
StaticNodeInfoAttribute Methods
StaticNodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The StaticNodeInfoAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetNodeInfo | Ruft die statische Methode auf, mit welcher diese Instanz initialsiert wurde und gibt die erhaltene NodeInfoAttribute-Instanz zurück.

See Also

StaticNodeInfoAttribute Class
DynamicNode.Core Namespace


GetNodeInfo Method

[image]

DynamicNodes API
StaticNodeInfoAttribute..::..GetNodeInfo Method
StaticNodeInfoAttribute Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die statische Methode auf, mit welcher diese Instanz initialsiert wurde und gibt die erhaltene NodeInfoAttribute-Instanz zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NodeInfoAttribute GetNodeInfo()
Visual Basic
Public Function GetNodeInfo As NodeInfoAttribute
F#
member GetNodeInfo : unit -> NodeInfoAttribute

Return Value

Die Knoten-Info.

See Also

StaticNodeInfoAttribute Class
DynamicNode.Core Namespace


Stream Class

[image]

DynamicNodes API
Stream Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Beschreibung einer Token-Sequenz. Kann als Basis-Klasse für spezialisierte Streams dienen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class Stream
Visual Basic
Public Class Stream
F#
type Stream =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..Stream

See Also

Stream Members
DynamicNode.Core Namespace


Stream Members

[image] [image]

DynamicNodes API
Stream Members
Stream Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Stream type exposes the following members.

Constructors

 | Name | Description
Public method | Stream(INode) | Initialisiert eine Instanz der Klasse Stream. Der Name des Streams wird aus der Adresse des Quell-Knotens und einer zufälligen Zahl gebildet.
Public method | Stream(INode, String) | Initialisiert eine Instanz der Klasse Stream.

Methods

 | Name | Description
 | BuildNewStreamId | Erzeugt einen eindeutigen Stream-Namen aus Adresse des Quellknotens und einer 4-stelligen Zufallszahl.
Public method | NotifyEndOfStream | Muss vom Quellknoten, nach der Produktion des letzten Samples für diesen Stream, aufgerufen werden.
Public method | NotifyNextSample | Muss vom Quellknoten, bei der Produktion eines Samples für diesen Stream, aufgerufen werden.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | IsEnded | Gibt an ob der Quellknoten die Produktion von Samples eingestellt hat. In diesem Fall gibt LastPublishedIndex den Index vom Abschluss-Sample des Streams zurück.
Public property | LastPublishedIndex | Der Index des letzten Samples welches vom Quell-Knoten erzeugt wurde.
Public property | Name | Gibt den Namen des Streams zurück.
Public property | Source | Gibt den Quell-Knoten des Streams zurück.

See Also

Stream Class
DynamicNode.Core Namespace


Stream Constructor

[image] [image]

DynamicNodes API
Stream Constructor
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Stream(INode) | Initialisiert eine Instanz der Klasse Stream. Der Name des Streams wird aus der Adresse des Quell-Knotens und einer zufälligen Zahl gebildet.
Public method | Stream(INode, String) | Initialisiert eine Instanz der Klasse Stream.

See Also

Stream Class
Stream Members
DynamicNode.Core Namespace


Stream Constructor (INode)

[image]

DynamicNodes API
Stream Constructor (INode)
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Instanz der Klasse Stream. Der Name des Streams wird aus der Adresse des Quell-Knotens und einer zufälligen Zahl gebildet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Stream(
    INode source
)
Visual Basic
Public Sub New ( _
    source As INode _
)
F#
new :
        source:INode -> Stream

Parameters

source
Type: DynamicNode.Core..::..INode
Der Quell-Knoten des Streams.

See Also

Stream Class
Stream Overload
DynamicNode.Core Namespace


Stream Constructor (INode, String)

[image]

DynamicNodes API
Stream Constructor (INode, String)
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Instanz der Klasse Stream.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Stream(
    INode source,
    string name
)
Visual Basic
Public Sub New ( _
    source As INode, _
    name As String _
)
F#
new :
        source:INode *
        name:string -> Stream

Parameters

source
Type: DynamicNode.Core..::..INode
Der Quell-Knoten des Streams.
name
Type: System..::..String
Der Name des Streams.

See Also

Stream Class
Stream Overload
DynamicNode.Core Namespace


Stream Methods

[image] [image]

DynamicNodes API
Stream Methods
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Stream type exposes the following members.

Methods

 | Name | Description
 | BuildNewStreamId | Erzeugt einen eindeutigen Stream-Namen aus Adresse des Quellknotens und einer 4-stelligen Zufallszahl.
Public method | NotifyEndOfStream | Muss vom Quellknoten, nach der Produktion des letzten Samples für diesen Stream, aufgerufen werden.
Public method | NotifyNextSample | Muss vom Quellknoten, bei der Produktion eines Samples für diesen Stream, aufgerufen werden.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

Stream Class
DynamicNode.Core Namespace


BuildNewStreamId Method

[image]

DynamicNodes API
Stream..::..BuildNewStreamId Method
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt einen eindeutigen Stream-Namen aus Adresse des Quellknotens und einer 4-stelligen Zufallszahl.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string BuildNewStreamId(
    INode source
)
Visual Basic
Public Shared Function BuildNewStreamId ( _
    source As INode _
) As String
F#
static member BuildNewStreamId :
        source:INode -> string

Parameters

source
Type: DynamicNode.Core..::..INode
Der Quellknoten.

Return Value

Ein Stream-Name

See Also

Stream Class
DynamicNode.Core Namespace


NotifyEndOfStream Method

[image]

DynamicNodes API
Stream..::..NotifyEndOfStream Method
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Muss vom Quellknoten, nach der Produktion des letzten Samples für diesen Stream, aufgerufen werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void NotifyEndOfStream()
Visual Basic
Public Sub NotifyEndOfStream
F#
member NotifyEndOfStream : unit -> unit

See Also

Stream Class
DynamicNode.Core Namespace


NotifyNextSample Method

[image]

DynamicNodes API
Stream..::..NotifyNextSample Method
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Muss vom Quellknoten, bei der Produktion eines Samples für diesen Stream, aufgerufen werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void NotifyNextSample()
Visual Basic
Public Sub NotifyNextSample
F#
member NotifyNextSample : unit -> unit

See Also

Stream Class
DynamicNode.Core Namespace


ToString Method

[image]

DynamicNodes API
Stream..::..ToString Method
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents the current Object.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents the current Object.

See Also

Stream Class
DynamicNode.Core Namespace


Stream Properties

[image] [image]

DynamicNodes API
Stream Properties
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Stream type exposes the following members.

Properties

 | Name | Description
Public property | IsEnded | Gibt an ob der Quellknoten die Produktion von Samples eingestellt hat. In diesem Fall gibt LastPublishedIndex den Index vom Abschluss-Sample des Streams zurück.
Public property | LastPublishedIndex | Der Index des letzten Samples welches vom Quell-Knoten erzeugt wurde.
Public property | Name | Gibt den Namen des Streams zurück.
Public property | Source | Gibt den Quell-Knoten des Streams zurück.

See Also

Stream Class
DynamicNode.Core Namespace


IsEnded Property

[image]

DynamicNodes API
Stream..::..IsEnded Property
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an ob der Quellknoten die Produktion von Samples eingestellt hat. In diesem Fall gibt LastPublishedIndex den Index vom Abschluss-Sample des Streams zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsEnded { get; }
Visual Basic
Public ReadOnly Property IsEnded As Boolean
    Get
F#
member IsEnded : bool

Field Value

true wenn der Quellknoten keine weiteren Samples für diesen Stream produziert, sonst false.

See Also

Stream Class
DynamicNode.Core Namespace


LastPublishedIndex Property

[image]

DynamicNodes API
Stream..::..LastPublishedIndex Property
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Index des letzten Samples welches vom Quell-Knoten erzeugt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public long LastPublishedIndex { get; }
Visual Basic
Public ReadOnly Property LastPublishedIndex As Long
    Get
F#
member LastPublishedIndex : int64

Field Value

Der Index des als letztes vom Quellknoten erzeugten Samples.

See Also

Stream Class
DynamicNode.Core Namespace


Name Property

[image]

DynamicNodes API
Stream..::..Name Property
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Streams zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
member Name : string

Field Value

Der Namen des Streams.

See Also

Stream Class
DynamicNode.Core Namespace


Source Property

[image]

DynamicNodes API
Stream..::..Source Property
Stream Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Quell-Knoten des Streams zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public INode Source { get; }
Visual Basic
Public ReadOnly Property Source As INode
    Get
F#
member Source : INode

Field Value

Der Quell-Knoten des Streams.

See Also

Stream Class
DynamicNode.Core Namespace


StreamNode Class

[image]

DynamicNodes API
StreamNode Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine abstrakte Knoten-Basisklasse die optinale Synchronisationsmechanismen für Streams bietet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract class StreamNode : Node
Visual Basic
Public MustInherit Class StreamNode _
    Inherits Node
F#
[<AbstractClassAttribute>]
type StreamNode =
    class
        inherit Node
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core..::..StreamNode
DynamicNode.Ext.Visual..::..ProgressNode
DynamicNode.Ext.Visual..::..VisualNode

See Also

StreamNode Members
DynamicNode.Core Namespace


StreamNode Members

[image] [image]

DynamicNodes API
StreamNode Members
StreamNode Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The StreamNode type exposes the following members.

Constructors

 | Name | Description
Protected method | StreamNode | Initializes a new instance of the StreamNode class

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Overrides Node..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Overrides Node..::..OnStore(IPropertyWriter).)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird.
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird.
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet.
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet.
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides Node..::..Work()()()().)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes.
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes.
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist.
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück.
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde.
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde.

See Also

StreamNode Class
DynamicNode.Core Namespace


StreamNode Constructor

[image]

DynamicNodes API
StreamNode Constructor
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the StreamNode class

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected StreamNode()
Visual Basic
Protected Sub New
F#
new : unit -> StreamNode

See Also

StreamNode Class
DynamicNode.Core Namespace


StreamNode Methods

[image] [image]

DynamicNodes API
StreamNode Methods
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The StreamNode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Overrides Node..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Overrides Node..::..OnStore(IPropertyWriter).)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird.
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird.
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet.
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet.
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides Node..::..Work()()()().)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

See Also

StreamNode Class
DynamicNode.Core Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
StreamNode..::..BeforeUseExtension Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

StreamNode Class
StreamNode Members
DynamicNode.Core Namespace


Duplicate Method

[image] [image]

DynamicNodes API
StreamNode..::..Duplicate Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

StreamNode Class
StreamNode Members
DynamicNode.Core Namespace


OnRestore Method

[image]

DynamicNodes API
StreamNode..::..OnRestore Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overrides Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der IPropertyReader mit dem benutzerdefinierte Eigenschaften des Knotens gelesen werden können.

Implements

IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)

Remarks

Diese Methode wird beim Laden eines Graphen aufgerufen bevor die Verbindungen zwischen den Knoten wiederhergstellt werden.

See Also

StreamNode Class
DynamicNode.Core Namespace


OnStore Method

[image]

DynamicNodes API
StreamNode..::..OnStore Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overrides Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der IPropertyWriter mit dem benutzerdefinierte Eigenschaften des Knotens gespeichert werden können.

Implements

IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)

See Also

StreamNode Class
DynamicNode.Core Namespace


OnTokenRejected Method

[image]

DynamicNodes API
StreamNode..::..OnTokenRejected Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnTokenRejected(
    Token token
)
Visual Basic
Protected Sub OnTokenRejected ( _
    token As Token _
)
F#
member OnTokenRejected :
        token:Token -> unit

Parameters

token
Type: DynamicNode.Core..::..Token
Das verworfene Token.

See Also

StreamNode Class
DynamicNode.Core Namespace


OnTokenSetRejected Method

[image]

DynamicNodes API
StreamNode..::..OnTokenSetRejected Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnTokenSetRejected(
    TokenSet tokenSet
)
Visual Basic
Protected Sub OnTokenSetRejected ( _
    tokenSet As TokenSet _
)
F#
member OnTokenSetRejected :
        tokenSet:TokenSet -> unit

Parameters

tokenSet
Type: DynamicNode.Core..::..TokenSet
Das verworfene TokenSet.

See Also

StreamNode Class
DynamicNode.Core Namespace


RegisterStreamInPorts Method

[image] [image]

DynamicNodes API
StreamNode..::..RegisterStreamInPorts Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet.
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet.

See Also

StreamNode Class
StreamNode Members
DynamicNode.Core Namespace


RegisterStreamInPorts Method (String[])

[image]

DynamicNodes API
StreamNode..::..RegisterStreamInPorts Method (array<String>[]()[][])
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RegisterStreamInPorts(
    params string[] inPortNames
)
Visual Basic
Public Sub RegisterStreamInPorts ( _
    ParamArray inPortNames As String() _
)
F#
member RegisterStreamInPorts :
        inPortNames:string[] -> unit

Parameters

inPortNames
Type: array< System..::..String >[]()[][]
Die Namen der Eingänge.

See Also

StreamNode Class
RegisterStreamInPorts Overload
DynamicNode.Core Namespace


RegisterStreamInPorts Method (InPort[])

[image]

DynamicNodes API
StreamNode..::..RegisterStreamInPorts Method (array<InPort>[]()[][])
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RegisterStreamInPorts(
    params InPort[] inPorts
)
Visual Basic
Public Sub RegisterStreamInPorts ( _
    ParamArray inPorts As InPort() _
)
F#
member RegisterStreamInPorts :
        inPorts:InPort[] -> unit

Parameters

inPorts
Type: array< DynamicNode.Core..::..InPort >[]()[][]
The in ports.

See Also

StreamNode Class
RegisterStreamInPorts Overload
DynamicNode.Core Namespace


TraceError Method

[image] [image]

DynamicNodes API
StreamNode..::..TraceError Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

StreamNode Class
StreamNode Members
DynamicNode.Core Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
StreamNode..::..TraceInfo Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

StreamNode Class
StreamNode Members
DynamicNode.Core Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
StreamNode..::..TraceVerbose Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

StreamNode Class
StreamNode Members
DynamicNode.Core Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
StreamNode..::..TraceVerboseData Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

StreamNode Class
StreamNode Members
DynamicNode.Core Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
StreamNode..::..TraceWarning Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

StreamNode Class
StreamNode Members
DynamicNode.Core Namespace


Work Method

[image] [image]

DynamicNodes API
StreamNode..::..Work Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides Node..::..Work()()()().)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

See Also

StreamNode Class
StreamNode Members
DynamicNode.Core Namespace


Work Method

[image]

DynamicNodes API
StreamNode..::..Work Method
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void Work()
Visual Basic
Public Overrides Sub Work
F#
abstract Work : unit -> unit
override Work : unit -> unit

See Also

StreamNode Class
Work Overload
DynamicNode.Core Namespace


Work Method (TokenSet)

[image]

DynamicNodes API
StreamNode..::..Work Method (TokenSet)
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract void Work(
    TokenSet ts
)
Visual Basic
Public MustOverride Sub Work ( _
    ts As TokenSet _
)
F#
abstract Work :
        ts:TokenSet -> unit

Parameters

ts
Type: DynamicNode.Core..::..TokenSet
Das TokenSet mit den aktuellen Tokens aller Eingänge.

See Also

StreamNode Class
Work Overload
DynamicNode.Core Namespace


StreamNode Properties

[image] [image]

DynamicNodes API
StreamNode Properties
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The StreamNode type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes.
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes.
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist.
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück.
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

StreamNode Class
DynamicNode.Core Namespace


IndexSortWindow Property

[image]

DynamicNodes API
StreamNode..::..IndexSortWindow Property
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt das Sortierfenster für Token-Indizes.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int IndexSortWindow { get; set; }
Visual Basic
Public Property IndexSortWindow As Integer
    Get
    Set
F#
member IndexSortWindow : int with get, set

Field Value

Das Token-Index-Sortierfenster.

See Also

StreamNode Class
DynamicNode.Core Namespace


IndexSyncWindow Property

[image]

DynamicNodes API
StreamNode..::..IndexSyncWindow Property
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt das Synchronisationsfenster für Token-Indizes.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int IndexSyncWindow { get; set; }
Visual Basic
Public Property IndexSyncWindow As Integer
    Get
    Set
F#
member IndexSyncWindow : int with get, set

Field Value

Das Token-Index-Synchronisationsfenster.

See Also

StreamNode Class
DynamicNode.Core Namespace


IsSynchronizationModeChangeable Property

[image]

DynamicNodes API
StreamNode..::..IsSynchronizationModeChangeable Property
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsSynchronizationModeChangeable { get; protected set; }
Visual Basic
Public Property IsSynchronizationModeChangeable As Boolean
    Get
    Protected Set
F#
member IsSynchronizationModeChangeable : bool with get, set

Field Value

true wenn der Synchronisationsmodus geändert werden darf, sonst false.

See Also

StreamNode Class
DynamicNode.Core Namespace


Item Property

[image] [image]

DynamicNodes API
StreamNode..::..Item Property
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

StreamNode Class
StreamNode Members
DynamicNode.Core Namespace


SynchronizationMode Property

[image]

DynamicNodes API
StreamNode..::..SynchronizationMode Property
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Synchronisation-Modus fest oder gibt ihn zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SynchronizationMode SynchronizationMode { get; set; }
Visual Basic
Public Property SynchronizationMode As SynchronizationMode
    Get
    Set
F#
member SynchronizationMode : SynchronizationMode with get, set

Field Value

Der Synchronisationsmodus.

See Also

StreamNode Class
DynamicNode.Core Namespace


StreamNode Events

[image] [image]

DynamicNodes API
StreamNode Events
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The StreamNode type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde.
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde.

See Also

StreamNode Class
DynamicNode.Core Namespace


TokenRejected Event

[image]

DynamicNodes API
StreamNode..::..TokenRejected Event
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<TokenRejectionEventArgs> TokenRejected
Visual Basic
Public Event TokenRejected As EventHandler(Of TokenRejectionEventArgs)
F#
member TokenRejected : IEvent<EventHandler<TokenRejectionEventArgs>,
    TokenRejectionEventArgs>

See Also

StreamNode Class
DynamicNode.Core Namespace


TokenSetRejected Event

[image]

DynamicNodes API
StreamNode..::..TokenSetRejected Event
StreamNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<TokenSetRejectionEventArgs> TokenSetRejected
Visual Basic
Public Event TokenSetRejected As EventHandler(Of TokenSetRejectionEventArgs)
F#
member TokenSetRejected : IEvent<EventHandler<TokenSetRejectionEventArgs>,
    TokenSetRejectionEventArgs>

See Also

StreamNode Class
DynamicNode.Core Namespace


SubGraphEventArgs Class

[image]

DynamicNodes API
SubGraphEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignisargumente, einen Sub-Graphen referenzieren.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class SubGraphEventArgs : EventArgs
Visual Basic
Public Class SubGraphEventArgs _
    Inherits EventArgs
F#
type SubGraphEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Core..::..SubGraphEventArgs

See Also

SubGraphEventArgs Members
DynamicNode.Core Namespace


SubGraphEventArgs Members

[image] [image]

DynamicNodes API
SubGraphEventArgs Members
SubGraphEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SubGraphEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SubGraphEventArgs | Initialisiert eine NodeEventArgs-Instanz.

Properties

 | Name | Description
Public property | SubGraph | Gibt den betroffenen Sub-Graphen-Knoten zurück.

See Also

SubGraphEventArgs Class
DynamicNode.Core Namespace


SubGraphEventArgs Constructor

[image]

DynamicNodes API
SubGraphEventArgs Constructor
SubGraphEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine NodeEventArgs-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SubGraphEventArgs(
    NSubGraph subGraphNode
)
Visual Basic
Public Sub New ( _
    subGraphNode As NSubGraph _
)
F#
new :
        subGraphNode:NSubGraph -> SubGraphEventArgs

Parameters

subGraphNode
Type: DynamicNode.Core.Nodes..::..NSubGraph
Der Sub-Graph-Knoten.

See Also

SubGraphEventArgs Class
DynamicNode.Core Namespace


SubGraphEventArgs Properties

[image] [image]

DynamicNodes API
SubGraphEventArgs Properties
SubGraphEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SubGraphEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | SubGraph | Gibt den betroffenen Sub-Graphen-Knoten zurück.

See Also

SubGraphEventArgs Class
DynamicNode.Core Namespace


SubGraph Property

[image]

DynamicNodes API
SubGraphEventArgs..::..SubGraph Property
SubGraphEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den betroffenen Sub-Graphen-Knoten zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NSubGraph SubGraph { get; }
Visual Basic
Public ReadOnly Property SubGraph As NSubGraph
    Get
F#
member SubGraph : NSubGraph

Field Value

Der betroffene Sub-Graph.

See Also

SubGraphEventArgs Class
DynamicNode.Core Namespace


SynchronizationMode Enumeration

[image]

DynamicNodes API
SynchronizationMode Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Synchronisationsmodus für einen Knoten vor.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public enum SynchronizationMode
Visual Basic
Public Enumeration SynchronizationMode
F#
type SynchronizationMode

Members

Member name | Description
No |
IndexGroup |
IndexGroupAndSort |

See Also

DynamicNode.Core Namespace


TaskEventArgs Class

[image]

DynamicNodes API
TaskEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ereignisparameter für Task-Ereignisse.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class TaskEventArgs : EventArgs
Visual Basic
Public Class TaskEventArgs _
    Inherits EventArgs
F#
type TaskEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Core..::..TaskEventArgs

See Also

TaskEventArgs Members
DynamicNode.Core Namespace


TaskEventArgs Members

[image] [image]

DynamicNodes API
TaskEventArgs Members
TaskEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TaskEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TaskEventArgs | Initialisiert eine neue Instanz von TaskEventArgs.

Properties

 | Name | Description
Public property | Id | Gibt die Task-ID zurück.
Public property | Thread | Gibt den Thread zurück, in dem die Aufgabe ausgeführt wird.

See Also

TaskEventArgs Class
DynamicNode.Core Namespace


TaskEventArgs Constructor

[image]

DynamicNodes API
TaskEventArgs Constructor
TaskEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von TaskEventArgs.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TaskEventArgs(
    string id,
    Thread thread
)
Visual Basic
Public Sub New ( _
    id As String, _
    thread As Thread _
)
F#
new :
        id:string *
        thread:Thread -> TaskEventArgs

Parameters

id
Type: System..::..String
Die Task-ID
thread
Type: System.Threading..::..Thread
Der Thread

See Also

TaskEventArgs Class
DynamicNode.Core Namespace


TaskEventArgs Properties

[image] [image]

DynamicNodes API
TaskEventArgs Properties
TaskEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TaskEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt die Task-ID zurück.
Public property | Thread | Gibt den Thread zurück, in dem die Aufgabe ausgeführt wird.

See Also

TaskEventArgs Class
DynamicNode.Core Namespace


Id Property

[image]

DynamicNodes API
TaskEventArgs..::..Id Property
TaskEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Task-ID zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
member Id : string

See Also

TaskEventArgs Class
DynamicNode.Core Namespace


Thread Property

[image]

DynamicNodes API
TaskEventArgs..::..Thread Property
TaskEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Thread zurück, in dem die Aufgabe ausgeführt wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Thread Thread { get; }
Visual Basic
Public ReadOnly Property Thread As Thread
    Get
F#
member Thread : Thread

See Also

TaskEventArgs Class
DynamicNode.Core Namespace


Token Structure

[image]

DynamicNodes API
Token Structure
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Datenstruktur für ein Token.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
[SerializableAttribute]
public struct Token
Visual Basic
<SerializableAttribute> _
Public Structure Token
F#
[<SealedAttribute>]
[<SerializableAttribute>]
type Token =  struct end

See Also

Token Members
DynamicNode.Core Namespace


Token Members

[image] [image]

DynamicNodes API
Token Members
Token Structure Constructors Methods Operators Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Token type exposes the following members.

Constructors

 | Name | Description
Public method | Token(Object) | Initialisiert eine neue Instanz der Struktur Token. Der Status wird auf valid gesetzt, das Token gehört keinem Stream an.
Public method | Token(TokenState) | Initialisiert eine neue Instanz der Struktur Token. Der Wert wird auf null gesetzt.
Public method | Token(Object, TokenState) | Initialisiert eine neue Instanz der Struktur Token.
Public method | Token(Object, Stream, Int64) | Initialisiert eine neue Instanz der Struktur Token. Der Status wird auf valid gesetzt.
Public method | Token(TokenState, Stream, Int64) | Initialisiert eine neue Instanz der Struktur Token. Der Wert wird auf null gesetzt.
Public method | Token(Object, TokenState, Stream, Int64) | Initialisiert eine neue Instanz der Struktur Token.

Methods

 | Name | Description
Public method | Equals | Gibt an, ob diese Instanz und ein angegebenes Objekt gleich sind. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | Gibt den Hashcode für diese Instanz zurück. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetValue<(Of <<'(T>)>>)(T) | Gibt den Wert zurück. Wenn der Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Wert null ist, wird def zurückgegeben.
Public method | GetValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den Wert zurück. Wenn mustBeValid gleich true und der Status nicht Valid oder wenn mustBeValid == false und der Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Wert null ist, wird def zurückgegeben.
 | Max | Gibt den besseren der beiden Markenzustände zurück.
 | MaxOfAll | Gibt den besten Markenzustand zurück.
 | Min | Gibt den schlechteren der beiden Markenzustände zurück.
 | MinOfAll | Gibt den schlechtesten Markenzustand zurück.
Public method | ToString | Gibt den voll qualifizierten Typnamen dieser Instanz zurück. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality | Implementiert den Operator ==.
Inequality | Implementiert den Operator !=.

Properties

 | Name | Description
Public property | Index | Gibt den Index der Marke zurück.
Public property | State | Gibt den Status des Wertes zurück.
Public property | Stream | Gibt den Stream zurück oder null, wenn der Token zu keinem Stream gehört.
Public property | Value | Gibt den Wert zurück.

See Also

Token Structure
DynamicNode.Core Namespace


Token Constructor

[image] [image]

DynamicNodes API
Token Constructor
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Token(Object) | Initialisiert eine neue Instanz der Struktur Token. Der Status wird auf valid gesetzt, das Token gehört keinem Stream an.
Public method | Token(TokenState) | Initialisiert eine neue Instanz der Struktur Token. Der Wert wird auf null gesetzt.
Public method | Token(Object, TokenState) | Initialisiert eine neue Instanz der Struktur Token.
Public method | Token(Object, Stream, Int64) | Initialisiert eine neue Instanz der Struktur Token. Der Status wird auf valid gesetzt.
Public method | Token(TokenState, Stream, Int64) | Initialisiert eine neue Instanz der Struktur Token. Der Wert wird auf null gesetzt.
Public method | Token(Object, TokenState, Stream, Int64) | Initialisiert eine neue Instanz der Struktur Token.

See Also

Token Structure
Token Members
DynamicNode.Core Namespace


Token Constructor (Object)

[image]

DynamicNodes API
Token Constructor (Object)
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur Token. Der Status wird auf valid gesetzt, das Token gehört keinem Stream an.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Token(
    Object value
)
Visual Basic
Public Sub New ( _
    value As Object _
)
F#
new :
        value:Object -> Token

Parameters

value
Type: System..::..Object
Der Wert.

See Also

Token Structure
Token Overload
DynamicNode.Core Namespace


Token Constructor (TokenState)

[image]

DynamicNodes API
Token Constructor (TokenState)
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur Token. Der Wert wird auf null gesetzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Token(
    TokenState state
)
Visual Basic
Public Sub New ( _
    state As TokenState _
)
F#
new :
        state:TokenState -> Token

Parameters

state
Type: DynamicNode.Core..::..TokenState
Der Status.

See Also

Token Structure
Token Overload
DynamicNode.Core Namespace


Token Constructor (Object, TokenState)

[image]

DynamicNodes API
Token Constructor (Object, TokenState)
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur Token.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Token(
    Object value,
    TokenState state
)
Visual Basic
Public Sub New ( _
    value As Object, _
    state As TokenState _
)
F#
new :
        value:Object *
        state:TokenState -> Token

Parameters

value
Type: System..::..Object
Der Wert.
state
Type: DynamicNode.Core..::..TokenState
Der Status.

See Also

Token Structure
Token Overload
DynamicNode.Core Namespace


Token Constructor (Object, Stream, Int64)

[image]

DynamicNodes API
Token Constructor (Object, Stream, Int64)
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur Token. Der Status wird auf valid gesetzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Token(
    Object value,
    Stream stream,
    long index
)
Visual Basic
Public Sub New ( _
    value As Object, _
    stream As Stream, _
    index As Long _
)
F#
new :
        value:Object *
        stream:Stream *
        index:int64 -> Token

Parameters

value
Type: System..::..Object
Der Wert.
stream
Type: DynamicNode.Core..::..Stream
Der Stream.
index
Type: System..::..Int64
Der Index.

See Also

Token Structure
Token Overload
DynamicNode.Core Namespace


Token Constructor (TokenState, Stream, Int64)

[image]

DynamicNodes API
Token Constructor (TokenState, Stream, Int64)
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur Token. Der Wert wird auf null gesetzt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Token(
    TokenState state,
    Stream stream,
    long index
)
Visual Basic
Public Sub New ( _
    state As TokenState, _
    stream As Stream, _
    index As Long _
)
F#
new :
        state:TokenState *
        stream:Stream *
        index:int64 -> Token

Parameters

state
Type: DynamicNode.Core..::..TokenState
Der Status.
stream
Type: DynamicNode.Core..::..Stream
Der Stream.
index
Type: System..::..Int64
Der Index.

See Also

Token Structure
Token Overload
DynamicNode.Core Namespace


Token Constructor (Object, TokenState, Stream, Int64)

[image]

DynamicNodes API
Token Constructor (Object, TokenState, Stream, Int64)
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur Token.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Token(
    Object value,
    TokenState state,
    Stream stream,
    long index
)
Visual Basic
Public Sub New ( _
    value As Object, _
    state As TokenState, _
    stream As Stream, _
    index As Long _
)
F#
new :
        value:Object *
        state:TokenState *
        stream:Stream *
        index:int64 -> Token

Parameters

value
Type: System..::..Object
Der Wert.
state
Type: DynamicNode.Core..::..TokenState
Der Status.
stream
Type: DynamicNode.Core..::..Stream
Der Stream.
index
Type: System..::..Int64
Der Index.

See Also

Token Structure
Token Overload
DynamicNode.Core Namespace


Token Methods

[image] [image]

DynamicNodes API
Token Methods
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Token type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Gibt an, ob diese Instanz und ein angegebenes Objekt gleich sind. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | Gibt den Hashcode für diese Instanz zurück. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetValue<(Of <<'(T>)>>)(T) | Gibt den Wert zurück. Wenn der Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Wert null ist, wird def zurückgegeben.
Public method | GetValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den Wert zurück. Wenn mustBeValid gleich true und der Status nicht Valid oder wenn mustBeValid == false und der Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Wert null ist, wird def zurückgegeben.
 | Max | Gibt den besseren der beiden Markenzustände zurück.
 | MaxOfAll | Gibt den besten Markenzustand zurück.
 | Min | Gibt den schlechteren der beiden Markenzustände zurück.
 | MinOfAll | Gibt den schlechtesten Markenzustand zurück.
Public method | ToString | Gibt den voll qualifizierten Typnamen dieser Instanz zurück. (Overrides ValueType..::..ToString()()()().)

See Also

Token Structure
DynamicNode.Core Namespace


Equals Method

[image]

DynamicNodes API
Token..::..Equals Method
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob diese Instanz und ein angegebenes Objekt gleich sind.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
F#
abstract Equals :
        obj:Object -> bool
override Equals :
        obj:Object -> bool

Parameters

obj
Type: System..::..Object
Ein weiteres Objekt für den Vergleich.

Return Value

true, wenn obj und diese Instanz denselben Typ aufweisen und denselben Wert darstellen, andernfalls false.

See Also

Token Structure
DynamicNode.Core Namespace


GetHashCode Method

[image]

DynamicNodes API
Token..::..GetHashCode Method
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Hashcode für diese Instanz zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Eine 32-Bit-Ganzzahl mit Vorzeichen. Diese ist der Hashcode für die Instanz.

See Also

Token Structure
DynamicNode.Core Namespace


GetValue Method

[image] [image]

DynamicNodes API
Token..::..GetValue Method
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(T) | Gibt den Wert zurück. Wenn der Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Wert null ist, wird def zurückgegeben.
Public method | GetValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den Wert zurück. Wenn mustBeValid gleich true und der Status nicht Valid oder wenn mustBeValid == false und der Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Wert null ist, wird def zurückgegeben.

See Also

Token Structure
Token Members
DynamicNode.Core Namespace


GetValue(T) Method (T)

[image]

DynamicNodes API
Token..::..GetValue<(Of <(<'T>)>)> Method (T)
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert zurück. Wenn der Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Wert null ist, wird def zurückgegeben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public T GetValue<T>(
    T def
)
Visual Basic
Public Function GetValue(Of T) ( _
    def As T _
) As T
F#
member GetValue :
        def:'T -> 'T

Parameters

def
Type: T
Der Standardwert.

Type Parameters

T
Der Typ als welcher der Wert zurückgegeben werden soll.

Return Value

Ein sicherer Wert.

Exceptions

Exception | Condition
System..::..InvalidCastException | Wenn der Wert sich nicht in T umwandeln lässt.

See Also

Token Structure
GetValue Overload
DynamicNode.Core Namespace


GetValue(T) Method (T, Boolean)

[image]

DynamicNodes API
Token..::..GetValue<(Of <(<'T>)>)> Method (T, Boolean)
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert zurück. Wenn mustBeValid gleich true und der Status nicht Valid oder wenn mustBeValid == false und der Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Wert null ist, wird def zurückgegeben.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public T GetValue<T>(
    T def,
    bool mustBeValid
)
Visual Basic
Public Function GetValue(Of T) ( _
    def As T, _
    mustBeValid As Boolean _
) As T
F#
member GetValue :
        def:'T *
        mustBeValid:bool -> 'T

Parameters

def
Type: T
Der Standardwert.
mustBeValid
Type: System..::..Boolean
Wenn true übergeben wird, muss der Status Valid sein, damit der Wert zurückgegeben werden darf.

Type Parameters

T
Der Typ als welcher der Wert zurückgegeben werden soll.

Return Value

Ein sicherer Wert.

Exceptions

Exception | Condition
System..::..InvalidCastException | Wenn der Wert sich nicht in T umwandeln lässt.

See Also

Token Structure
GetValue Overload
DynamicNode.Core Namespace


Max Method

[image]

DynamicNodes API
Token..::..Max Method
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den besseren der beiden Markenzustände zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TokenState Max(
    TokenState ts1,
    TokenState ts2
)
Visual Basic
Public Shared Function Max ( _
    ts1 As TokenState, _
    ts2 As TokenState _
) As TokenState
F#
static member Max :
        ts1:TokenState *
        ts2:TokenState -> TokenState

Parameters

ts1
Type: DynamicNode.Core..::..TokenState
Ein Markenzustand.
ts2
Type: DynamicNode.Core..::..TokenState
Ein Markenzustand.

Return Value

Der bessere Markenzustand.

See Also

Token Structure
DynamicNode.Core Namespace


MaxOfAll Method

[image]

DynamicNodes API
Token..::..MaxOfAll Method
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den besten Markenzustand zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TokenState MaxOfAll(
    params TokenState[] states
)
Visual Basic
Public Shared Function MaxOfAll ( _
    ParamArray states As TokenState() _
) As TokenState
F#
static member MaxOfAll :
        states:TokenState[] -> TokenState

Parameters

states
Type: array< DynamicNode.Core..::..TokenState >[]()[][]
Markenzustände.

Return Value

Der schlechteste Zustand.

See Also

Token Structure
DynamicNode.Core Namespace


Min Method

[image]

DynamicNodes API
Token..::..Min Method
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den schlechteren der beiden Markenzustände zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TokenState Min(
    TokenState ts1,
    TokenState ts2
)
Visual Basic
Public Shared Function Min ( _
    ts1 As TokenState, _
    ts2 As TokenState _
) As TokenState
F#
static member Min :
        ts1:TokenState *
        ts2:TokenState -> TokenState

Parameters

ts1
Type: DynamicNode.Core..::..TokenState
Ein Markenzustand.
ts2
Type: DynamicNode.Core..::..TokenState
Ein Markenzustand.

Return Value

Der schlechtere Markenzustand.

See Also

Token Structure
DynamicNode.Core Namespace


MinOfAll Method

[image]

DynamicNodes API
Token..::..MinOfAll Method
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den schlechtesten Markenzustand zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TokenState MinOfAll(
    params TokenState[] states
)
Visual Basic
Public Shared Function MinOfAll ( _
    ParamArray states As TokenState() _
) As TokenState
F#
static member MinOfAll :
        states:TokenState[] -> TokenState

Parameters

states
Type: array< DynamicNode.Core..::..TokenState >[]()[][]
Markenzustände.

Return Value

Der schlechteste Zustand.

See Also

Token Structure
DynamicNode.Core Namespace


ToString Method

[image]

DynamicNodes API
Token..::..ToString Method
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den voll qualifizierten Typnamen dieser Instanz zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Eine String-Klasse, die den voll qualifizierten Typnamen enthält.

See Also

Token Structure
DynamicNode.Core Namespace


Token Operators

[image] [image]

DynamicNodes API
Token Operators
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Token type exposes the following members.

Operators

Name | Description
Equality | Implementiert den Operator ==.
Inequality | Implementiert den Operator !=.

See Also

Token Structure
DynamicNode.Core Namespace


Equality Operator

[image]

DynamicNodes API
Token..::..Equality Operator
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Implementiert den Operator ==.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static bool operator ==(
    Token t1,
    Token t2
)
Visual Basic
Public Shared Operator = ( _
    t1 As Token, _
    t2 As Token _
) As Boolean
F#
static let inline (=)
        t1:Token *
        t2:Token  : bool

Parameters

t1
Type: DynamicNode.Core..::..Token
Ein Token.
t2
Type: DynamicNode.Core..::..Token
Ein weiteres Token.

Return Value

true, wenn die Token gleich sind, sonst false.

See Also

Token Structure
DynamicNode.Core Namespace


Inequality Operator

[image]

DynamicNodes API
Token..::..Inequality Operator
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Implementiert den Operator !=.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static bool operator !=(
    Token t1,
    Token t2
)
Visual Basic
Public Shared Operator <> ( _
    t1 As Token, _
    t2 As Token _
) As Boolean
F#
static let inline (<>)
        t1:Token *
        t2:Token  : bool

Parameters

t1
Type: DynamicNode.Core..::..Token
Ein Token.
t2
Type: DynamicNode.Core..::..Token
Ein weiteres Token.

Return Value

true, wenn die Token ungleich sind, sonst false.

See Also

Token Structure
DynamicNode.Core Namespace


Token Properties

[image] [image]

DynamicNodes API
Token Properties
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Token type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gibt den Index der Marke zurück.
Public property | State | Gibt den Status des Wertes zurück.
Public property | Stream | Gibt den Stream zurück oder null, wenn der Token zu keinem Stream gehört.
Public property | Value | Gibt den Wert zurück.

See Also

Token Structure
DynamicNode.Core Namespace


Index Property

[image]

DynamicNodes API
Token..::..Index Property
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Index der Marke zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public long Index { get; }
Visual Basic
Public ReadOnly Property Index As Long
    Get
F#
member Index : int64

Field Value

Der Index.

See Also

Token Structure
DynamicNode.Core Namespace


State Property

[image]

DynamicNodes API
Token..::..State Property
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Status des Wertes zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenState State { get; }
Visual Basic
Public ReadOnly Property State As TokenState
    Get
F#
member State : TokenState

Field Value

Der Status.

See Also

Token Structure
DynamicNode.Core Namespace


Stream Property

[image]

DynamicNodes API
Token..::..Stream Property
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Stream zurück oder null, wenn der Token zu keinem Stream gehört.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Stream Stream { get; }
Visual Basic
Public ReadOnly Property Stream As Stream
    Get
F#
member Stream : Stream

Field Value

Der Stream.

See Also

Token Structure
DynamicNode.Core Namespace


Value Property

[image]

DynamicNodes API
Token..::..Value Property
Token Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Object Value { get; }
Visual Basic
Public ReadOnly Property Value As Object
    Get
F#
member Value : Object

Field Value

Der Wert.

See Also

Token Structure
DynamicNode.Core Namespace


TokenRejectionEventArgs Class

[image]

DynamicNodes API
TokenRejectionEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignis-Argumente für Rejection. Diese Klasse ist nicht threadsicher!

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class TokenRejectionEventArgs : EventArgs
Visual Basic
Public Class TokenRejectionEventArgs _
    Inherits EventArgs
F#
type TokenRejectionEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Core..::..TokenRejectionEventArgs

See Also

TokenRejectionEventArgs Members
DynamicNode.Core Namespace


TokenRejectionEventArgs Members

[image] [image]

DynamicNodes API
TokenRejectionEventArgs Members
TokenRejectionEventArgs Class Constructors Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenRejectionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TokenRejectionEventArgs | Initialisiert eine neue Instanz von TokenRejectionEventArgs.

Fields

 | Name | Description
Public field | token | Das verworfene Token.

See Also

TokenRejectionEventArgs Class
DynamicNode.Core Namespace


TokenRejectionEventArgs Constructor

[image]

DynamicNodes API
TokenRejectionEventArgs Constructor
TokenRejectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von TokenRejectionEventArgs.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenRejectionEventArgs(
    Token token
)
Visual Basic
Public Sub New ( _
    token As Token _
)
F#
new :
        token:Token -> TokenRejectionEventArgs

Parameters

token
Type: DynamicNode.Core..::..Token
Das verworfene Token.

See Also

TokenRejectionEventArgs Class
DynamicNode.Core Namespace


TokenRejectionEventArgs Fields

[image] [image]

DynamicNodes API
TokenRejectionEventArgs Fields
TokenRejectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenRejectionEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | token | Das verworfene Token.

See Also

TokenRejectionEventArgs Class
DynamicNode.Core Namespace


token Field

[image]

DynamicNodes API
TokenRejectionEventArgs..::..token Field
TokenRejectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das verworfene Token.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public readonly Token token
Visual Basic
Public ReadOnly token As Token
F#
val token: Token

See Also

TokenRejectionEventArgs Class
DynamicNode.Core Namespace


TokenSet Class

[image]

DynamicNodes API
TokenSet Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Set von Tokens, welche durch eine PortId identifiziert werden.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class TokenSet : IDictionary<string, Token>,
    ICollection<KeyValuePair<string, Token>>, IEnumerable<KeyValuePair<string, Token>>,
    IEnumerable
Visual Basic
Public Class TokenSet _
    Implements IDictionary(Of String, Token),  _
    ICollection(Of KeyValuePair(Of String, Token)), IEnumerable(Of KeyValuePair(Of String, Token)),  _
    IEnumerable
F#
type TokenSet =
    class
        interface IDictionary<string, Token>
        interface ICollection<KeyValuePair<string, Token>>
        interface IEnumerable<KeyValuePair<string, Token>>
        interface IEnumerable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..TokenSet

See Also

TokenSet Members
DynamicNode.Core Namespace


TokenSet Members

[image] [image]

DynamicNodes API
TokenSet Members
TokenSet Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSet type exposes the following members.

Constructors

 | Name | Description
Public method | TokenSet()()()() | Initialisiert ein leeres TokenSet.
Public method | TokenSet(Int32) | Initialisiert ein leeres TokenSet mit einer vorgegebenen Größe.
Public method | TokenSet(INode) | Initialisiert ein TokenSet mit den aktuellen Tokens von den Eingängen eines Knotens.
Public method | TokenSet(INode, array<String>[]()[][]) | Initialisiert ein TokenSet mit den aktuellen Tokens von den Eingängen eines Knotens. Die Eingänge, identifiziert durch ihre IDs in excludeInPorts, werden nicht berücksichtigt.

Methods

 | Name | Description
Public method | Add(KeyValuePair<(Of <<'(String, Token>)>>)) | Fügt der TokenSet ein Element hinzu.
Public method | Add(String, Token) | Fügt dem TokenSet ein Token mit der angegebenen PortId hinzu.
Public method | Add(String, Token, Boolean) | Fügt dem TokenSet ein Token mit der angegebenen PortId hinzu.
Public method | Clear | Entfernt alle Elemente aus TokenSet.
Public method | Contains | Bestimmt, ob TokenSet einen bestimmtes PortId-Token-Paar enthält.
Public method | ContainsKey | Ermittelt, ob TokenSet ein Token mit der angegebenen PortId enthält.
Public method | CopyTo | Kopiert die Elemente von TokenSet in ein Array, beginnend bei einem bestimmten Array-Index.
Public method | ExcludeFromMinMaxCalculation | Schließt die Ports, idfentifiziert durch die übergebenen PortIds von der Berechnung des schlechtesten und besten Token-Status aus.
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft.
 | MinInPortTokenState | Gibt den schlechtesten Token-Status von allen Eingängen eines Knotens zurück. Der beste ist Valid, schlechter ist Invalid und der schlechteste ist NotSet.
Public method | Remove(KeyValuePair<(Of <<'(String, Token>)>>)) | Entfernt das erste Vorkommen eines bestimmten Tokens aus TokenSet.
Public method | Remove(String) | Entfernt ein Token mit der angegebenen PortId aus dem TokenSet.
Public method | TryGetValue | Ruft das der angegebenen PortId zugeordnete Token ab.

Properties

 | Name | Description
Public property | Count | Ruft die Anzahl der Elemente ab, die in TokenSet enthalten sind.
Public property | HasNewToken | Gibt true zurück, wenn bei der automatischen Initialisierung mit einem Knoten neue Tokens gefunden wurden, oder wenn keine automatische Initialsierung stattgefunden hat, sonst false.
Public property | IndexOfSet | Gibt den Index des Tokens zurück, welches als letztes dem Set hinzugefügt wurde.
Public property | IsReadOnly | Ruft einen Wert ab, der angibt, ob TokenSet schreibgeschützt ist.
Public property | Item[([( String])]) | Gibt das Token für eine PortId zurück.
Public property | Item[([( Port])]) | Gibt das Token für den angegebenen Port zurück.
Public property | Keys | Ruft eine ICollection<(Of <(<'T>)>)>-Schnittstelle ab, die die PortIds von TokenSet enthält.
Public property | MaxTokenState | Gibt den besten Token-Status der Tokens im TokenSet zurück.
Public property | MinTokenState | Gibt den schlechtesten Token-Status der Tokens im TokenSet zurück.
Public property | StreamOfSet | Gibt den Stream des Tokens zurück, welches als letztes dem Set hinzugefügt wurde.
Public property | Values | Ruft eine ICollection<(Of <(<'T>)>)> ab, die die Token aus TokenSet enthält.

See Also

TokenSet Class
DynamicNode.Core Namespace


TokenSet Constructor

[image] [image]

DynamicNodes API
TokenSet Constructor
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TokenSet()()()() | Initialisiert ein leeres TokenSet.
Public method | TokenSet(Int32) | Initialisiert ein leeres TokenSet mit einer vorgegebenen Größe.
Public method | TokenSet(INode) | Initialisiert ein TokenSet mit den aktuellen Tokens von den Eingängen eines Knotens.
Public method | TokenSet(INode, array<String>[]()[][]) | Initialisiert ein TokenSet mit den aktuellen Tokens von den Eingängen eines Knotens. Die Eingänge, identifiziert durch ihre IDs in excludeInPorts, werden nicht berücksichtigt.

See Also

TokenSet Class
TokenSet Members
DynamicNode.Core Namespace


TokenSet Constructor

[image]

DynamicNodes API
TokenSet Constructor
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert ein leeres TokenSet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenSet()
Visual Basic
Public Sub New
F#
new : unit -> TokenSet

See Also

TokenSet Class
TokenSet Overload
DynamicNode.Core Namespace


TokenSet Constructor (Int32)

[image]

DynamicNodes API
TokenSet Constructor (Int32)
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert ein leeres TokenSet mit einer vorgegebenen Größe.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenSet(
    int capacity
)
Visual Basic
Public Sub New ( _
    capacity As Integer _
)
F#
new :
        capacity:int -> TokenSet

Parameters

capacity
Type: System..::..Int32
The capacity.

See Also

TokenSet Class
TokenSet Overload
DynamicNode.Core Namespace


TokenSet Constructor (INode)

[image]

DynamicNodes API
TokenSet Constructor (INode)
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert ein TokenSet mit den aktuellen Tokens von den Eingängen eines Knotens.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenSet(
    INode node
)
Visual Basic
Public Sub New ( _
    node As INode _
)
F#
new :
        node:INode -> TokenSet

Parameters

node
Type: DynamicNode.Core..::..INode
Ein Knoten.

See Also

TokenSet Class
TokenSet Overload
DynamicNode.Core Namespace


TokenSet Constructor (INode, String[])

[image]

DynamicNodes API
TokenSet Constructor (INode, array<String>[]()[][])
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert ein TokenSet mit den aktuellen Tokens von den Eingängen eines Knotens. Die Eingänge, identifiziert durch ihre IDs in excludeInPorts, werden nicht berücksichtigt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenSet(
    INode node,
    params string[] excludeInPorts
)
Visual Basic
Public Sub New ( _
    node As INode, _
    ParamArray excludeInPorts As String() _
)
F#
new :
        node:INode *
        excludeInPorts:string[] -> TokenSet

Parameters

node
Type: DynamicNode.Core..::..INode
Ein Knoten.
excludeInPorts
Type: array< System..::..String >[]()[][]
Die IDs der Eingänge welche ignoriert werden sollen.

See Also

TokenSet Class
TokenSet Overload
DynamicNode.Core Namespace


TokenSet Methods

[image] [image]

DynamicNodes API
TokenSet Methods
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSet type exposes the following members.

Methods

 | Name | Description
Public method | Add(KeyValuePair<(Of <<'(String, Token>)>>)) | Fügt der TokenSet ein Element hinzu.
Public method | Add(String, Token) | Fügt dem TokenSet ein Token mit der angegebenen PortId hinzu.
Public method | Add(String, Token, Boolean) | Fügt dem TokenSet ein Token mit der angegebenen PortId hinzu.
Public method | Clear | Entfernt alle Elemente aus TokenSet.
Public method | Contains | Bestimmt, ob TokenSet einen bestimmtes PortId-Token-Paar enthält.
Public method | ContainsKey | Ermittelt, ob TokenSet ein Token mit der angegebenen PortId enthält.
Public method | CopyTo | Kopiert die Elemente von TokenSet in ein Array, beginnend bei einem bestimmten Array-Index.
Public method | ExcludeFromMinMaxCalculation | Schließt die Ports, idfentifiziert durch die übergebenen PortIds von der Berechnung des schlechtesten und besten Token-Status aus.
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft.
 | MinInPortTokenState | Gibt den schlechtesten Token-Status von allen Eingängen eines Knotens zurück. Der beste ist Valid, schlechter ist Invalid und der schlechteste ist NotSet.
Public method | Remove(KeyValuePair<(Of <<'(String, Token>)>>)) | Entfernt das erste Vorkommen eines bestimmten Tokens aus TokenSet.
Public method | Remove(String) | Entfernt ein Token mit der angegebenen PortId aus dem TokenSet.
Public method | TryGetValue | Ruft das der angegebenen PortId zugeordnete Token ab.

See Also

TokenSet Class
DynamicNode.Core Namespace


Add Method

[image] [image]

DynamicNodes API
TokenSet..::..Add Method
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Add(KeyValuePair<(Of <<'(String, Token>)>>)) | Fügt der TokenSet ein Element hinzu.
Public method | Add(String, Token) | Fügt dem TokenSet ein Token mit der angegebenen PortId hinzu.
Public method | Add(String, Token, Boolean) | Fügt dem TokenSet ein Token mit der angegebenen PortId hinzu.

See Also

TokenSet Class
TokenSet Members
DynamicNode.Core Namespace


Add Method (KeyValuePair(String, Token))

[image]

DynamicNodes API
TokenSet..::..Add Method (KeyValuePair<(Of <(<'String, Token>)>)>)
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt der TokenSet ein Element hinzu.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Add(
    KeyValuePair<string, Token> item
)
Visual Basic
Public Sub Add ( _
    item As KeyValuePair(Of String, Token) _
)
F#
abstract Add :
        item:KeyValuePair<string, Token> -> unit
override Add :
        item:KeyValuePair<string, Token> -> unit

Parameters

item
Type: System.Collections.Generic..::..KeyValuePair <(Of <(<' String, Token >)>)>
Das Objekt, das TokenSet hinzugefügt werden soll.

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

TokenSet Class
Add Overload
DynamicNode.Core Namespace


Add Method (String, Token)

[image]

DynamicNodes API
TokenSet..::..Add Method (String, Token)
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt dem TokenSet ein Token mit der angegebenen PortId hinzu.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Add(
    string portId,
    Token token
)
Visual Basic
Public Sub Add ( _
    portId As String, _
    token As Token _
)
F#
abstract Add :
        portId:string *
        token:Token -> unit
override Add :
        portId:string *
        token:Token -> unit

Parameters

portId
Type: System..::..String
Die PortId des Anschlusses zu dem das Token gehört.
token
Type: DynamicNode.Core..::..Token
Das Token, das zum TokenSet hinzugefügt werden soll.

Implements

IDictionary<(Of <(<'TKey, TValue>)>)>..::..Add(TKey, TValue)

Exceptions

Exception | Condition
System..::..ArgumentNullException | portId ist null.
System..::..ArgumentException | Ein Token mit derselben PortId ist bereits im TokenSet vorhanden.

See Also

TokenSet Class
Add Overload
DynamicNode.Core Namespace


Add Method (String, Token, Boolean)

[image]

DynamicNodes API
TokenSet..::..Add Method (String, Token, Boolean)
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt dem TokenSet ein Token mit der angegebenen PortId hinzu.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Add(
    string portId,
    Token token,
    bool noteStream
)
Visual Basic
Public Sub Add ( _
    portId As String, _
    token As Token, _
    noteStream As Boolean _
)
F#
member Add :
        portId:string *
        token:Token *
        noteStream:bool -> unit

Parameters

portId
Type: System..::..String
Die PortId des Anschlusses zu dem das Token gehört.
token
Type: DynamicNode.Core..::..Token
Das Token, das zum TokenSet hinzugefügt werden soll.
noteStream
Type: System..::..Boolean
Wenn true, wird der Stream und der Index als StreamOfSet und IndexOfSet gespeichert.

Exceptions

Exception | Condition
System..::..ArgumentNullException | portId ist null.
System..::..ArgumentException | Ein Token mit derselben PortId ist bereits im TokenSet vorhanden.

See Also

TokenSet Class
Add Overload
DynamicNode.Core Namespace


Clear Method

[image]

DynamicNodes API
TokenSet..::..Clear Method
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt alle Elemente aus TokenSet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
F#
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

TokenSet Class
DynamicNode.Core Namespace


Contains Method

[image]

DynamicNodes API
TokenSet..::..Contains Method
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bestimmt, ob TokenSet einen bestimmtes PortId-Token-Paar enthält.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool Contains(
    KeyValuePair<string, Token> item
)
Visual Basic
Public Function Contains ( _
    item As KeyValuePair(Of String, Token) _
) As Boolean
F#
abstract Contains :
        item:KeyValuePair<string, Token> -> bool
override Contains :
        item:KeyValuePair<string, Token> -> bool

Parameters

item
Type: System.Collections.Generic..::..KeyValuePair <(Of <(<' String, Token >)>)>
Das im TokenSet zu suchende PortId-Token-Paar.

Return Value

true, wenn sich item in TokenSet befindet, andernfalls false.

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

TokenSet Class
DynamicNode.Core Namespace


ContainsKey Method

[image]

DynamicNodes API
TokenSet..::..ContainsKey Method
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ermittelt, ob TokenSet ein Token mit der angegebenen PortId enthält.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool ContainsKey(
    string portId
)
Visual Basic
Public Function ContainsKey ( _
    portId As String _
) As Boolean
F#
abstract ContainsKey :
        portId:string -> bool
override ContainsKey :
        portId:string -> bool

Parameters

portId
Type: System..::..String
Die im TokenSet zu suchende PortId.

Return Value

true, wenn das TokenSet ein Token mit der PortId enthält, andernfalls false.

Implements

IDictionary<(Of <(<'TKey, TValue>)>)>..::..ContainsKey(TKey)

Exceptions

Exception | Condition
System..::..ArgumentNullException | portId ist null.

See Also

TokenSet Class
DynamicNode.Core Namespace


CopyTo Method

[image]

DynamicNodes API
TokenSet..::..CopyTo Method
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Kopiert die Elemente von TokenSet in ein Array, beginnend bei einem bestimmten Array-Index.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void CopyTo(
    KeyValuePair<string, Token>[] array,
    int arrayIndex
)
Visual Basic
Public Sub CopyTo ( _
    array As KeyValuePair(Of String, Token)(), _
    arrayIndex As Integer _
)
F#
abstract CopyTo :
        array:KeyValuePair<string, Token>[] *
        arrayIndex:int -> unit
override CopyTo :
        array:KeyValuePair<string, Token>[] *
        arrayIndex:int -> unit

Parameters

array
Type: array< System.Collections.Generic..::..KeyValuePair <(Of <(<' String, Token >)>)>>[]()[][]
Das eindimensionale Array, das das Ziel der aus TokenSet kopierten Elemente ist. Für Array muss eine nullbasierte Indizierung verwendet werden.
arrayIndex
Type: System..::..Int32
Der nullbasierte Index in array, ab dem kopiert wird.

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

Exceptions

Exception | Condition
System..::..ArgumentNullException | array ist null.
System..::..ArgumentOutOfRangeException | arrayIndex ist kleiner als 0 (null).
System..::..ArgumentException | array ist mehrdimensional. – oder – arrayIndex ist größer oder gleich der Länge von array. – oder – Die Anzahl der aus der Quell-TokenSet zu kopierenden Elemente ist größer als der verfügbare Platz von arrayIndex bis zum Ende des Ziel-array.

See Also

TokenSet Class
DynamicNode.Core Namespace


ExcludeFromMinMaxCalculation Method

[image]

DynamicNodes API
TokenSet..::..ExcludeFromMinMaxCalculation Method
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schließt die Ports, idfentifiziert durch die übergebenen PortIds von der Berechnung des schlechtesten und besten Token-Status aus.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ExcludeFromMinMaxCalculation(
    params string[] portNames
)
Visual Basic
Public Sub ExcludeFromMinMaxCalculation ( _
    ParamArray portNames As String() _
)
F#
member ExcludeFromMinMaxCalculation :
        portNames:string[] -> unit

Parameters

portNames
Type: array< System..::..String >[]()[][]
Die Namen der auszuschließenden Ports.

See Also

TokenSet Class
DynamicNode.Core Namespace


GetEnumerator Method

[image]

DynamicNodes API
TokenSet..::..GetEnumerator Method
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Enumerator zurück, der die Auflistung durchläuft.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IEnumerator<KeyValuePair<string, Token>> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, Token))
F#
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, Token>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, Token>>

Return Value

Ein IEnumerator<(Of <(<'T>)>)>, der zum Durchlaufen der Auflistung verwendet werden kann.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

TokenSet Class
DynamicNode.Core Namespace


MinInPortTokenState Method

[image]

DynamicNodes API
TokenSet..::..MinInPortTokenState Method
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den schlechtesten Token-Status von allen Eingängen eines Knotens zurück. Der beste ist Valid, schlechter ist Invalid und der schlechteste ist NotSet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TokenState MinInPortTokenState(
    INode node,
    params InPort[] excludes
)
Visual Basic
Public Shared Function MinInPortTokenState ( _
    node As INode, _
    ParamArray excludes As InPort() _
) As TokenState
F#
static member MinInPortTokenState :
        node:INode *
        excludes:InPort[] -> TokenState

Parameters

node
Type: DynamicNode.Core..::..INode
Der Knoten, dessen Eingänge überprüft werden sollen.
excludes
Type: array< DynamicNode.Core..::..InPort >[]()[][]
Alle Eingänge, welche ignoriert werden sollen.

Return Value

Einen Token-Status.

See Also

TokenSet Class
DynamicNode.Core Namespace


Remove Method

[image] [image]

DynamicNodes API
TokenSet..::..Remove Method
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Remove(KeyValuePair<(Of <<'(String, Token>)>>)) | Entfernt das erste Vorkommen eines bestimmten Tokens aus TokenSet.
Public method | Remove(String) | Entfernt ein Token mit der angegebenen PortId aus dem TokenSet.

See Also

TokenSet Class
TokenSet Members
DynamicNode.Core Namespace


Remove Method (KeyValuePair(String, Token))

[image]

DynamicNodes API
TokenSet..::..Remove Method (KeyValuePair<(Of <(<'String, Token>)>)>)
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt das erste Vorkommen eines bestimmten Tokens aus TokenSet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool Remove(
    KeyValuePair<string, Token> item
)
Visual Basic
Public Function Remove ( _
    item As KeyValuePair(Of String, Token) _
) As Boolean
F#
abstract Remove :
        item:KeyValuePair<string, Token> -> bool
override Remove :
        item:KeyValuePair<string, Token> -> bool

Parameters

item
Type: System.Collections.Generic..::..KeyValuePair <(Of <(<' String, Token >)>)>
Das aus dem TokenSet zu entfernende PortId-Token-Paar.

Return Value

true, wenn item erfolgreich aus TokenSet gelöscht wurde, andernfalls false. Diese Methode gibt auch dann false zurück, wenn item nicht im TokenSet gefunden wurde.

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

TokenSet Class
Remove Overload
DynamicNode.Core Namespace


Remove Method (String)

[image]

DynamicNodes API
TokenSet..::..Remove Method (String)
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt ein Token mit der angegebenen PortId aus dem TokenSet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool Remove(
    string portId
)
Visual Basic
Public Function Remove ( _
    portId As String _
) As Boolean
F#
abstract Remove :
        portId:string -> bool
override Remove :
        portId:string -> bool

Parameters

portId
Type: System..::..String
Die PortId.

Return Value

true, wenn ein Element mit der angegebenen PortId gefunden und entfernt wurde.

Implements

IDictionary<(Of <(<'TKey, TValue>)>)>..::..Remove(TKey)

See Also

TokenSet Class
Remove Overload
DynamicNode.Core Namespace


TryGetValue Method

[image]

DynamicNodes API
TokenSet..::..TryGetValue Method
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft das der angegebenen PortId zugeordnete Token ab.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool TryGetValue(
    string portId,
    out Token value
)
Visual Basic
Public Function TryGetValue ( _
    portId As String, _
    <OutAttribute> ByRef value As Token _
) As Boolean
F#
abstract TryGetValue :
        portId:string *
        value:Token byref -> bool
override TryGetValue :
        portId:string *
        value:Token byref -> bool

Parameters

portId
Type: System..::..String
Die PortId, dessen Token abgerufen werden soll.
value
Type: DynamicNode.Core..::..Token %
Wenn diese Methode zurückgegeben wird, enthält sie das der angegebenen PortId zugeordnete Token, wenn die PortId gefunden wird, andernfalls enthält sie ein nicht initialisiertes Token. Dieser Parameter wird nicht initialisiert übergeben.

Return Value

true, wenn das TokenSet ein Token mit der angegebenen PortId enthält, andernfalls false.

Implements

IDictionary<(Of <(<'TKey, TValue>)>)>..::..TryGetValue(TKey, TValue%)

Exceptions

Exception | Condition
System..::..ArgumentNullException | portId ist null.

See Also

TokenSet Class
DynamicNode.Core Namespace


TokenSet Properties

[image] [image]

DynamicNodes API
TokenSet Properties
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSet type exposes the following members.

Properties

 | Name | Description
Public property | Count | Ruft die Anzahl der Elemente ab, die in TokenSet enthalten sind.
Public property | HasNewToken | Gibt true zurück, wenn bei der automatischen Initialisierung mit einem Knoten neue Tokens gefunden wurden, oder wenn keine automatische Initialsierung stattgefunden hat, sonst false.
Public property | IndexOfSet | Gibt den Index des Tokens zurück, welches als letztes dem Set hinzugefügt wurde.
Public property | IsReadOnly | Ruft einen Wert ab, der angibt, ob TokenSet schreibgeschützt ist.
Public property | Item[([( String])]) | Gibt das Token für eine PortId zurück.
Public property | Item[([( Port])]) | Gibt das Token für den angegebenen Port zurück.
Public property | Keys | Ruft eine ICollection<(Of <(<'T>)>)>-Schnittstelle ab, die die PortIds von TokenSet enthält.
Public property | MaxTokenState | Gibt den besten Token-Status der Tokens im TokenSet zurück.
Public property | MinTokenState | Gibt den schlechtesten Token-Status der Tokens im TokenSet zurück.
Public property | StreamOfSet | Gibt den Stream des Tokens zurück, welches als letztes dem Set hinzugefügt wurde.
Public property | Values | Ruft eine ICollection<(Of <(<'T>)>)> ab, die die Token aus TokenSet enthält.

See Also

TokenSet Class
DynamicNode.Core Namespace


Count Property

[image]

DynamicNodes API
TokenSet..::..Count Property
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Anzahl der Elemente ab, die in TokenSet enthalten sind.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
F#
abstract Count : int
override Count : int

Field Value

Return Value

Die Anzahl der Elemente, die in TokenSet enthalten sind.

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

TokenSet Class
DynamicNode.Core Namespace


HasNewToken Property

[image]

DynamicNodes API
TokenSet..::..HasNewToken Property
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt true zurück, wenn bei der automatischen Initialisierung mit einem Knoten neue Tokens gefunden wurden, oder wenn keine automatische Initialsierung stattgefunden hat, sonst false.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool HasNewToken { get; }
Visual Basic
Public ReadOnly Property HasNewToken As Boolean
    Get
F#
member HasNewToken : bool

See Also

TokenSet Class
DynamicNode.Core Namespace


IndexOfSet Property

[image]

DynamicNodes API
TokenSet..::..IndexOfSet Property
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Index des Tokens zurück, welches als letztes dem Set hinzugefügt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public long IndexOfSet { get; }
Visual Basic
Public ReadOnly Property IndexOfSet As Long
    Get
F#
member IndexOfSet : int64

Return Value

Der Index des letzten Tokens.

See Also

TokenSet Class
DynamicNode.Core Namespace


IsReadOnly Property

[image]

DynamicNodes API
TokenSet..::..IsReadOnly Property
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob TokenSet schreibgeschützt ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
F#
abstract IsReadOnly : bool
override IsReadOnly : bool

Field Value

Return Value

true, wenn TokenSet schreibgeschützt ist, andernfalls false.

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly

See Also

TokenSet Class
DynamicNode.Core Namespace


Item Property

[image] [image]

DynamicNodes API
TokenSet..::..Item Property
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gibt das Token für eine PortId zurück.
Public property | Item[([( Port])]) | Gibt das Token für den angegebenen Port zurück.

See Also

TokenSet Class
TokenSet Members
DynamicNode.Core Namespace


Item Property (String)

[image]

DynamicNodes API
TokenSet..::..Item Property (String)
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Token für eine PortId zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Token this[
    string portId
] { get; set; }
Visual Basic
Public Default Property Item ( _
    portId As String _
) As Token
    Get
    Set
F#
abstract Item : Token with get, set
override Item : Token with get, set

Parameters

portId
Type: System..::..String

Field Value

Implements

IDictionary<(Of <(<'TKey, TValue>)>)>..::..Item[([( TKey])])

See Also

TokenSet Class
Item Overload
DynamicNode.Core Namespace


Item Property (Port)

[image]

DynamicNodes API
TokenSet..::..Item Property (Port)
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Token für den angegebenen Port zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Token this[
    Port port
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    port As Port _
) As Token
    Get
F#
member Item : Token

Parameters

port
Type: DynamicNode.Core..::..Port

Field Value

Das Token für einen Port.

See Also

TokenSet Class
Item Overload
DynamicNode.Core Namespace


Keys Property

[image]

DynamicNodes API
TokenSet..::..Keys Property
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft eine ICollection<(Of <(<'T>)>)>-Schnittstelle ab, die die PortIds von TokenSet enthält.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public ICollection<string> Keys { get; }
Visual Basic
Public ReadOnly Property Keys As ICollection(Of String)
    Get
F#
abstract Keys : ICollection<string>
override Keys : ICollection<string>

Field Value

Return Value

Eine ICollection<(Of <(<'T>)>)>, die die PortIds des TokenSet enthält.

Implements

IDictionary<(Of <(<'TKey, TValue>)>)>..::..Keys

See Also

TokenSet Class
DynamicNode.Core Namespace


MaxTokenState Property

[image]

DynamicNodes API
TokenSet..::..MaxTokenState Property
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den besten Token-Status der Tokens im TokenSet zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenState MaxTokenState { get; }
Visual Basic
Public ReadOnly Property MaxTokenState As TokenState
    Get
F#
member MaxTokenState : TokenState

Field Value

Der beste Token-Status.

See Also

TokenSet Class
DynamicNode.Core Namespace


MinTokenState Property

[image]

DynamicNodes API
TokenSet..::..MinTokenState Property
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den schlechtesten Token-Status der Tokens im TokenSet zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenState MinTokenState { get; }
Visual Basic
Public ReadOnly Property MinTokenState As TokenState
    Get
F#
member MinTokenState : TokenState

Field Value

Der schlechteste Token-Status.

See Also

TokenSet Class
DynamicNode.Core Namespace


StreamOfSet Property

[image]

DynamicNodes API
TokenSet..::..StreamOfSet Property
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Stream des Tokens zurück, welches als letztes dem Set hinzugefügt wurde.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Stream StreamOfSet { get; }
Visual Basic
Public ReadOnly Property StreamOfSet As Stream
    Get
F#
member StreamOfSet : Stream

Return Value

Der Stream des letzten Tokens.

See Also

TokenSet Class
DynamicNode.Core Namespace


Values Property

[image]

DynamicNodes API
TokenSet..::..Values Property
TokenSet Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft eine ICollection<(Of <(<'T>)>)> ab, die die Token aus TokenSet enthält.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public ICollection<Token> Values { get; }
Visual Basic
Public ReadOnly Property Values As ICollection(Of Token)
    Get
F#
abstract Values : ICollection<Token>
override Values : ICollection<Token>

Field Value

Return Value

Eine ICollection<(Of <(<'T>)>)>, die die Token aus TokenSet enthält.

Implements

IDictionary<(Of <(<'TKey, TValue>)>)>..::..Values

See Also

TokenSet Class
DynamicNode.Core Namespace


TokenSetRejectionEventArgs Class

[image]

DynamicNodes API
TokenSetRejectionEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignis-Argumente für Rejection. Diese Klasse ist nicht threadsicher!

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class TokenSetRejectionEventArgs : EventArgs
Visual Basic
Public Class TokenSetRejectionEventArgs _
    Inherits EventArgs
F#
type TokenSetRejectionEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Core..::..TokenSetRejectionEventArgs

See Also

TokenSetRejectionEventArgs Members
DynamicNode.Core Namespace


TokenSetRejectionEventArgs Members

[image] [image]

DynamicNodes API
TokenSetRejectionEventArgs Members
TokenSetRejectionEventArgs Class Constructors Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSetRejectionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TokenSetRejectionEventArgs | Initialisiert eine neue Instanz von TokenSetRejectionEventArgs.

Fields

 | Name | Description
Public field | tokenSet | Das verworfene TokenSet.

See Also

TokenSetRejectionEventArgs Class
DynamicNode.Core Namespace


TokenSetRejectionEventArgs Constructor

[image]

DynamicNodes API
TokenSetRejectionEventArgs Constructor
TokenSetRejectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von TokenSetRejectionEventArgs.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenSetRejectionEventArgs(
    TokenSet tokenSet
)
Visual Basic
Public Sub New ( _
    tokenSet As TokenSet _
)
F#
new :
        tokenSet:TokenSet -> TokenSetRejectionEventArgs

Parameters

tokenSet
Type: DynamicNode.Core..::..TokenSet
Das verworfene TokenSet.

See Also

TokenSetRejectionEventArgs Class
DynamicNode.Core Namespace


TokenSetRejectionEventArgs Fields

[image] [image]

DynamicNodes API
TokenSetRejectionEventArgs Fields
TokenSetRejectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSetRejectionEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | tokenSet | Das verworfene TokenSet.

See Also

TokenSetRejectionEventArgs Class
DynamicNode.Core Namespace


tokenSet Field

[image]

DynamicNodes API
TokenSetRejectionEventArgs..::..tokenSet Field
TokenSetRejectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das verworfene TokenSet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public readonly TokenSet tokenSet
Visual Basic
Public ReadOnly tokenSet As TokenSet
F#
val tokenSet: TokenSet

See Also

TokenSetRejectionEventArgs Class
DynamicNode.Core Namespace


TokenSetSorter Class

[image]

DynamicNodes API
TokenSetSorter Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein sortierender Puffer für TokenSets.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class TokenSetSorter
Visual Basic
Public Class TokenSetSorter
F#
type TokenSetSorter =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..TokenSetSorter

See Also

TokenSetSorter Members
DynamicNode.Core Namespace


TokenSetSorter Members

[image] [image]

DynamicNodes API
TokenSetSorter Members
TokenSetSorter Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSetSorter type exposes the following members.

Constructors

 | Name | Description
Public method | TokenSetSorter | Initialisiert eine neue Instanz der Klasse TokenSetSorter.

Methods

 | Name | Description
Public method | HasNext | Prüft ob ein TokenSet mit dem nächsten Index verfügbar ist.
Public method | Insert | Fügt ein neues TokenSet zum Sortier-Puffer hinzu.
Protected method | OnRejection | Wird aufgerufen wenn ein TokenSet verworfen wird.
Public method | RemoveNext | Gibt das nächste TokenSet zurück und entfernt es aus dem Sortier-Puffer.

Properties

 | Name | Description
Public property | MaxLength | Gibt die maximale Größe des Sortier-Puffers zurück oder legt sie fest.
Public property | NextTargetIndex | Gibt den nächsten Index zurück auf den gewartet wird.

Events

 | Name | Description
Public event | Rejection | Tritt auf wenn ein TokenSet verworfen wird. Das passiert wenn ein TokenSet mit bereits übersprungenem Index an den Sortierer übergeben wird.

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


TokenSetSorter Constructor

[image]

DynamicNodes API
TokenSetSorter Constructor
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse TokenSetSorter.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenSetSorter(
    int maxLength
)
Visual Basic
Public Sub New ( _
    maxLength As Integer _
)
F#
new :
        maxLength:int -> TokenSetSorter

Parameters

maxLength
Type: System..::..Int32
Die maximale Größe des Sortier-Puffers.

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


TokenSetSorter Methods

[image] [image]

DynamicNodes API
TokenSetSorter Methods
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSetSorter type exposes the following members.

Methods

 | Name | Description
Public method | HasNext | Prüft ob ein TokenSet mit dem nächsten Index verfügbar ist.
Public method | Insert | Fügt ein neues TokenSet zum Sortier-Puffer hinzu.
Protected method | OnRejection | Wird aufgerufen wenn ein TokenSet verworfen wird.
Public method | RemoveNext | Gibt das nächste TokenSet zurück und entfernt es aus dem Sortier-Puffer.

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


HasNext Method

[image]

DynamicNodes API
TokenSetSorter..::..HasNext Method
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob ein TokenSet mit dem nächsten Index verfügbar ist.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool HasNext()
Visual Basic
Public Function HasNext As Boolean
F#
member HasNext : unit -> bool

Return Value

true wenn RemoveNext()()()() das nächste TokenSet zurückgibt, sonst false.

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


Insert Method

[image]

DynamicNodes API
TokenSetSorter..::..Insert Method
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt ein neues TokenSet zum Sortier-Puffer hinzu.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Insert(
    TokenSet tokenSet
)
Visual Basic
Public Sub Insert ( _
    tokenSet As TokenSet _
)
F#
member Insert :
        tokenSet:TokenSet -> unit

Parameters

tokenSet
Type: DynamicNode.Core..::..TokenSet
Ein neues TokenSet.

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


OnRejection Method

[image]

DynamicNodes API
TokenSetSorter..::..OnRejection Method
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn ein TokenSet verworfen wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnRejection(
    TokenSet tokenSet
)
Visual Basic
Protected Sub OnRejection ( _
    tokenSet As TokenSet _
)
F#
member OnRejection :
        tokenSet:TokenSet -> unit

Parameters

tokenSet
Type: DynamicNode.Core..::..TokenSet
The token set.

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


RemoveNext Method

[image]

DynamicNodes API
TokenSetSorter..::..RemoveNext Method
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das nächste TokenSet zurück und entfernt es aus dem Sortier-Puffer.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenSet RemoveNext()
Visual Basic
Public Function RemoveNext As TokenSet
F#
member RemoveNext : unit -> TokenSet

Return Value

Das nächste gültige TokenSet.

Exceptions

Exception | Condition
System..::..InvalidOperationException | HasNext()()()() == false

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


TokenSetSorter Properties

[image] [image]

DynamicNodes API
TokenSetSorter Properties
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSetSorter type exposes the following members.

Properties

 | Name | Description
Public property | MaxLength | Gibt die maximale Größe des Sortier-Puffers zurück oder legt sie fest.
Public property | NextTargetIndex | Gibt den nächsten Index zurück auf den gewartet wird.

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


MaxLength Property

[image]

DynamicNodes API
TokenSetSorter..::..MaxLength Property
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die maximale Größe des Sortier-Puffers zurück oder legt sie fest.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Integer
    Get
    Set
F#
member MaxLength : int with get, set

Field Value

Die maximale Größe des Sortier-Puffers.

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


NextTargetIndex Property

[image]

DynamicNodes API
TokenSetSorter..::..NextTargetIndex Property
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den nächsten Index zurück auf den gewartet wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public long NextTargetIndex { get; }
Visual Basic
Public ReadOnly Property NextTargetIndex As Long
    Get
F#
member NextTargetIndex : int64

Field Value

Der nächste Index.

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


TokenSetSorter Events

[image] [image]

DynamicNodes API
TokenSetSorter Events
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSetSorter type exposes the following members.

Events

 | Name | Description
Public event | Rejection | Tritt auf wenn ein TokenSet verworfen wird. Das passiert wenn ein TokenSet mit bereits übersprungenem Index an den Sortierer übergeben wird.

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


Rejection Event

[image]

DynamicNodes API
TokenSetSorter..::..Rejection Event
TokenSetSorter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn ein TokenSet verworfen wird. Das passiert wenn ein TokenSet mit bereits übersprungenem Index an den Sortierer übergeben wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<TokenSetRejectionEventArgs> Rejection
Visual Basic
Public Event Rejection As EventHandler(Of TokenSetRejectionEventArgs)
F#
member Rejection : IEvent<EventHandler<TokenSetRejectionEventArgs>,
    TokenSetRejectionEventArgs>

See Also

TokenSetSorter Class
DynamicNode.Core Namespace


TokenState Enumeration

[image]

DynamicNodes API
TokenState Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beschreibt den Zustand eines Werts als Teil eines Tokens.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
[SerializableAttribute]
public enum TokenState
Visual Basic
<SerializableAttribute> _
Public Enumeration TokenState
F#
[<SerializableAttribute>]
type TokenState

Members

Member name | Description
Valid |
Invalid |
NotSet |

See Also

DynamicNode.Core Namespace


TokenSynchronizer Class

[image]

DynamicNodes API
TokenSynchronizer Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Synchronisiert eintreffende Tokens eines Knotens nach Index.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class TokenSynchronizer
Visual Basic
Public Class TokenSynchronizer
F#
type TokenSynchronizer =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..TokenSynchronizer

See Also

TokenSynchronizer Members
DynamicNode.Core Namespace


TokenSynchronizer Members

[image] [image]

DynamicNodes API
TokenSynchronizer Members
TokenSynchronizer Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSynchronizer type exposes the following members.

Constructors

 | Name | Description
Public method | TokenSynchronizer | Initialisiert eine neue TokenSynchronizer-Instanz.

Methods

 | Name | Description
Public method | IsStreamOnInPortsPresent | Prüft ob mindestens ein Stream an den Eingängen anliegt.
Protected method | OnRejection | Wird aufgerufen, wenn ein Token verworfen wird.
Public method | ProcessActivation | Ein Aktivierung des Knotens verarbeiten von dem die registrierten Eingänge stammen.

Properties

 | Name | Description
Public property | IndexSyncWindow | Liest und schreibt die Größe des Index-Bereichs in dem nach passenden Token-Sets gesucht werden soll. Wird dieser Wert klein gewählt werden evtl. viele zu alte Tokens verworfen. Wird der Wert groß gewählt belegt der TokenSynchronizer mehr Speicherplatz.
Public property | Queue | Gibt die Queue mit den vollständigen Token-Sets zurück.
Public property | SyncedInPorts | GIbt eine Aufzählung mit allen synchronisierten Eingängen zurück.

Events

 | Name | Description
Public event | Rejection | Tritt auf wenn ein Token verworfen wird.

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


TokenSynchronizer Constructor

[image]

DynamicNodes API
TokenSynchronizer Constructor
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue TokenSynchronizer-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenSynchronizer(
    IEnumerable<InPort> inPorts,
    int indexSyncWindow
)
Visual Basic
Public Sub New ( _
    inPorts As IEnumerable(Of InPort), _
    indexSyncWindow As Integer _
)
F#
new :
        inPorts:IEnumerable<InPort> *
        indexSyncWindow:int -> TokenSynchronizer

Parameters

inPorts
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' InPort >)>)>
Eine Aufzähllung aller zu registrierenden Eingänge.
indexSyncWindow
Type: System..::..Int32
Die maximale Kapazität der Token-Listen für die Synchronisation.

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


TokenSynchronizer Methods

[image] [image]

DynamicNodes API
TokenSynchronizer Methods
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSynchronizer type exposes the following members.

Methods

 | Name | Description
Public method | IsStreamOnInPortsPresent | Prüft ob mindestens ein Stream an den Eingängen anliegt.
Protected method | OnRejection | Wird aufgerufen, wenn ein Token verworfen wird.
Public method | ProcessActivation | Ein Aktivierung des Knotens verarbeiten von dem die registrierten Eingänge stammen.

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


IsStreamOnInPortsPresent Method

[image]

DynamicNodes API
TokenSynchronizer..::..IsStreamOnInPortsPresent Method
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob mindestens ein Stream an den Eingängen anliegt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsStreamOnInPortsPresent()
Visual Basic
Public Function IsStreamOnInPortsPresent As Boolean
F#
member IsStreamOnInPortsPresent : unit -> bool

Return Value

true, wenn an mindestens einem Eingang ein Stream anliegt.

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


OnRejection Method

[image]

DynamicNodes API
TokenSynchronizer..::..OnRejection Method
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Token verworfen wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void OnRejection(
    Token token
)
Visual Basic
Protected Sub OnRejection ( _
    token As Token _
)
F#
member OnRejection :
        token:Token -> unit

Parameters

token
Type: DynamicNode.Core..::..Token
The token.

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


ProcessActivation Method

[image]

DynamicNodes API
TokenSynchronizer..::..ProcessActivation Method
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Aktivierung des Knotens verarbeiten von dem die registrierten Eingänge stammen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ProcessActivation()
Visual Basic
Public Sub ProcessActivation
F#
member ProcessActivation : unit -> unit

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


TokenSynchronizer Properties

[image] [image]

DynamicNodes API
TokenSynchronizer Properties
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSynchronizer type exposes the following members.

Properties

 | Name | Description
Public property | IndexSyncWindow | Liest und schreibt die Größe des Index-Bereichs in dem nach passenden Token-Sets gesucht werden soll. Wird dieser Wert klein gewählt werden evtl. viele zu alte Tokens verworfen. Wird der Wert groß gewählt belegt der TokenSynchronizer mehr Speicherplatz.
Public property | Queue | Gibt die Queue mit den vollständigen Token-Sets zurück.
Public property | SyncedInPorts | GIbt eine Aufzählung mit allen synchronisierten Eingängen zurück.

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


IndexSyncWindow Property

[image]

DynamicNodes API
TokenSynchronizer..::..IndexSyncWindow Property
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest und schreibt die Größe des Index-Bereichs in dem nach passenden Token-Sets gesucht werden soll. Wird dieser Wert klein gewählt werden evtl. viele zu alte Tokens verworfen. Wird der Wert groß gewählt belegt der TokenSynchronizer mehr Speicherplatz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int IndexSyncWindow { get; set; }
Visual Basic
Public Property IndexSyncWindow As Integer
    Get
    Set
F#
member IndexSyncWindow : int with get, set

Field Value

Das Index-Synchronisations-Fenster.

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


Queue Property

[image]

DynamicNodes API
TokenSynchronizer..::..Queue Property
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Queue mit den vollständigen Token-Sets zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Queue<TokenSet> Queue { get; }
Visual Basic
Public ReadOnly Property Queue As Queue(Of TokenSet)
    Get
F#
member Queue : Queue<TokenSet>

Field Value

Die Queue der vollständigen Token-Sets.

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


SyncedInPorts Property

[image]

DynamicNodes API
TokenSynchronizer..::..SyncedInPorts Property
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
GIbt eine Aufzählung mit allen synchronisierten Eingängen zurück.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IEnumerable<InPort> SyncedInPorts { get; }
Visual Basic
Public ReadOnly Property SyncedInPorts As IEnumerable(Of InPort)
    Get
F#
member SyncedInPorts : IEnumerable<InPort>

Field Value

Die synchronisierten Eingänge.

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


TokenSynchronizer Events

[image] [image]

DynamicNodes API
TokenSynchronizer Events
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TokenSynchronizer type exposes the following members.

Events

 | Name | Description
Public event | Rejection | Tritt auf wenn ein Token verworfen wird.

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


Rejection Event

[image]

DynamicNodes API
TokenSynchronizer..::..Rejection Event
TokenSynchronizer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn ein Token verworfen wird.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<TokenRejectionEventArgs> Rejection
Visual Basic
Public Event Rejection As EventHandler(Of TokenRejectionEventArgs)
F#
member Rejection : IEvent<EventHandler<TokenRejectionEventArgs>,
    TokenRejectionEventArgs>

See Also

TokenSynchronizer Class
DynamicNode.Core Namespace


TokenUpdateHandler Delegate

[image]

DynamicNodes API
TokenUpdateHandler Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Handler zum benachrichtigen von Veränderungen des Wertes eines Ports.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public delegate void TokenUpdateHandler(
    Port port,
    Token token
)
Visual Basic
Public Delegate Sub TokenUpdateHandler ( _
    port As Port, _
    token As Token _
)
F#
type TokenUpdateHandler =
    delegate of
        port:Port *
        token:Token -> unit

Parameters

port
Type: DynamicNode.Core..::..Port
token
Type: DynamicNode.Core..::..Token

See Also

DynamicNode.Core Namespace


TriggerInPort Class

[image]

DynamicNodes API
TriggerInPort Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Eingang dient Knoten als Steuereingang für die Aktivierung.

Am Beginn der Implementierung für die Work()()()()-Methode wird IsWorkingAllowed überprüft und sollte false zurückgegeben werden, wird die Arbeitsmethode unverzüglich verlassen.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class TriggerInPort : InPort
Visual Basic
Public Class TriggerInPort _
    Inherits InPort
F#
type TriggerInPort =
    class
        inherit InPort
    end

Remarks

Alle Knoten die einen Seiteneffekt hervorrufen, z.B. Ausgabe auf Bildschirm, Dateisystem, Netzwerk, etc. oder die einen erheblichen Arbeitsaufwand erzeugen und deren Arbeit potentiell viel Zeit in Anspruch nimmt, sollten einen TriggerInPort verwenden. Dadurch kann der Seiteneffekt des Knotens bzw. der Zeitpunkt seiner Arbeit kontrolliert werden.

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' IPort >)>)>
DynamicNode.Model..::..ChildObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Core..::..Port
DynamicNode.Core..::..InPort
DynamicNode.Core..::..TriggerInPort

See Also

TriggerInPort Members
DynamicNode.Core Namespace


TriggerInPort Members

[image] [image]

DynamicNodes API
TriggerInPort Members
TriggerInPort Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TriggerInPort type exposes the following members.

Constructors

 | Name | Description
Public method | TriggerInPort(INode) | Initialisert eine neue Instanz der Klasse TriggerInPort mit dem Namen "triggerIn" und ohne Datentyp (universell kompatibel).
Public method | TriggerInPort(INode, String) | Initialisert eine neue Instanz der Klasse TriggerInPort mit dem Namen "triggerIn" und ohne Datentyp (universell kompatibel).

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Verbindet einen Ausgangs-Port mit diesem Eingangs-Port. (Inherited from InPort.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Ausgang, falls eine solche Verbindung besteht. (Inherited from InPort.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Inherited from InPort.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem die unterstützten Datentypen geändert wurden. Falls eine Verbindung besteht wird erneut geprüft welcher Datentyp optimal ist. Falls ein anderer Datentyp als der zur Zeit ausgewählte optimal ist, wird der optimale Datentyp ausgewählt. Falls die Verbindung ungültig ist, wird sie getrennt. (Inherited from InPort.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnCurrentTokenChanged | Wird aufgerufen, wenn das Ereignis CurrentTokenChanged ausgelöst werden soll. (Inherited from InPort.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from InPort.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from InPort.)
Protected method | OnSupportedDataTypeChanged | Wird aufgerufen wenn der für die aktuelle Verbindung ausgewählte Datentyp geändert wurde. Löst das Ereignis SupportedDataTypeChanged aus. (Inherited from InPort.)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | PrepareNextToken | Bereitet den Eingang auf die nächste Arbeitsphase des Knotens vor. Falls ein Queue vorhanden ist, wird dazu das nächste Token aus dem Queue geholt. (Inherited from InPort.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from InPort.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Inherited from InPort.)
Public method | UpdateToken | Aktualisiert den Wert des Ports und setzt den Wert-Zustand auf Valid. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from InPort.)

Properties

 | Name | Description
Public property | CanHaveQueue | Liest oder schreibt einen Wert, der angibt ob dieser Eingang eine Queue haben darf. (Inherited from InPort.)
Public property | Capacity | Liest oder schreibt die Kapazität der evtl. vorhandenen Queue. (Inherited from InPort.)
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Eingangs-Ports zu anderen Ausgangs-Ports angepasst werden kann. (Inherited from InPort.)
Public property | ConnectedOutPort | Gibt den verbundenen Ausgangs-Port zurück der mit diesem Eingangs-Port verbunden ist, oder null, wenn keine Verbindung besteht. (Inherited from InPort.)
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from InPort.)
Public property | CurrentToken | Gibt das Token zurück, welches für den aktuellen Arbeitsschritt verwendet werden soll. (Inherited from InPort.)
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Eingang. (Inherited from InPort.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | HasQueue | Liest oder schreibt einen Wert der angibt ob diese Instanz eine Queue besitzt. (Inherited from InPort.)
Public property | HasWaitingToken | Gibt einen Wert zurück, der angibt ob der nächste Aufruf von PrepareNextToken()()()() ein neues Token zur Verarbeitung bereitstellt oder nicht. (Inherited from InPort.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsConnected | Prüft, ob diese Instanz mit einem Ausgangs-Port verbunden ist. (Inherited from InPort.)
Public property | IsCurrentTokenNew | Gibt einen Wert zurück der angibt, ob das aktuelle Token neu ist. (Inherited from InPort.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsMandatory | Gibt einen Wert zurück oder legt ihn fest, der angibt ob der Eingang mit einem Token belegt werden muss, damit der Knoten arbeiten kann. (Inherited from InPort.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Public property | IsWorkingAllowed | Gibt einen Wert zurück, der angibt ob die Arbeitsmethode des Elternknotens ausgeführt werden darf oder nicht. Wird false zurückgegeben, darf die Arbeitsmethode nichts tun, andernfalls darf die Arbeitsmethode ihre Arbeit verrichten.
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedDataType | Gibt den für die aktuelle Verbindung ausgewählten Datentyp zurück, oder legt ihn fest. (Inherited from InPort.)
Public property | SupportedTypes | Gibt eine Liste mit allen unterstützten Datentypen zurück. Falls ein Daten-Typ-Provider eingerichtet ist, wird dessen Liste zurückgegeben. (Inherited from InPort.)
Public property | UpdateWithNotSetAtDisconnect | Liest oder schreibt einen Wert, der angibt ob der Eingang mit einem Token 'NotSet' belegt werden soll, sobald die Verbindung getrennt wird. (Inherited from InPort.)

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | CurrentTokenChanged | Wird ausgelöst, wenn das aktuelle Token zur Verarbeitung geändert wird. (Inherited from InPort.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn der ausgewählte Datentyp für die Verbindung geändert wird. (Inherited from InPort.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)

See Also

TriggerInPort Class
DynamicNode.Core Namespace


TriggerInPort Constructor

[image] [image]

DynamicNodes API
TriggerInPort Constructor
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TriggerInPort(INode) | Initialisert eine neue Instanz der Klasse TriggerInPort mit dem Namen "triggerIn" und ohne Datentyp (universell kompatibel).
Public method | TriggerInPort(INode, String) | Initialisert eine neue Instanz der Klasse TriggerInPort mit dem Namen "triggerIn" und ohne Datentyp (universell kompatibel).

See Also

TriggerInPort Class
TriggerInPort Members
DynamicNode.Core Namespace


TriggerInPort Constructor (INode)

[image]

DynamicNodes API
TriggerInPort Constructor (INode)
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisert eine neue Instanz der Klasse TriggerInPort mit dem Namen "triggerIn" und ohne Datentyp (universell kompatibel).

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TriggerInPort(
    INode parent
)
Visual Basic
Public Sub New ( _
    parent As INode _
)
F#
new :
        parent:INode -> TriggerInPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten, dem der Steuereingang hinzugefügt werden soll.

See Also

TriggerInPort Class
TriggerInPort Overload
DynamicNode.Core Namespace


TriggerInPort Constructor (INode, String)

[image]

DynamicNodes API
TriggerInPort Constructor (INode, String)
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisert eine neue Instanz der Klasse TriggerInPort mit dem Namen "triggerIn" und ohne Datentyp (universell kompatibel).

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TriggerInPort(
    INode parent,
    string name
)
Visual Basic
Public Sub New ( _
    parent As INode, _
    name As String _
)
F#
new :
        parent:INode *
        name:string -> TriggerInPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten, dem der Steuereingang hinzugefügt werden soll.
name
Type: System..::..String
Der Name des Ports.

See Also

TriggerInPort Class
TriggerInPort Overload
DynamicNode.Core Namespace


TriggerInPort Methods

[image] [image]

DynamicNodes API
TriggerInPort Methods
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TriggerInPort type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Verbindet einen Ausgangs-Port mit diesem Eingangs-Port. (Inherited from InPort.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Ausgang, falls eine solche Verbindung besteht. (Inherited from InPort.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Inherited from InPort.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem die unterstützten Datentypen geändert wurden. Falls eine Verbindung besteht wird erneut geprüft welcher Datentyp optimal ist. Falls ein anderer Datentyp als der zur Zeit ausgewählte optimal ist, wird der optimale Datentyp ausgewählt. Falls die Verbindung ungültig ist, wird sie getrennt. (Inherited from InPort.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnCurrentTokenChanged | Wird aufgerufen, wenn das Ereignis CurrentTokenChanged ausgelöst werden soll. (Inherited from InPort.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from InPort.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from InPort.)
Protected method | OnSupportedDataTypeChanged | Wird aufgerufen wenn der für die aktuelle Verbindung ausgewählte Datentyp geändert wurde. Löst das Ereignis SupportedDataTypeChanged aus. (Inherited from InPort.)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | PrepareNextToken | Bereitet den Eingang auf die nächste Arbeitsphase des Knotens vor. Falls ein Queue vorhanden ist, wird dazu das nächste Token aus dem Queue geholt. (Inherited from InPort.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from InPort.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Inherited from InPort.)
Public method | UpdateToken | Aktualisiert den Wert des Ports und setzt den Wert-Zustand auf Valid. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from InPort.)

See Also

TriggerInPort Class
DynamicNode.Core Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
TriggerInPort..::..BeforeUseExtension Method
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

TriggerInPort Class
TriggerInPort Members
DynamicNode.Core Namespace


GetCurrentValue Method

[image] [image]

DynamicNodes API
TriggerInPort..::..GetCurrentValue Method
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)

See Also

TriggerInPort Class
TriggerInPort Members
DynamicNode.Core Namespace


TraceError Method

[image] [image]

DynamicNodes API
TriggerInPort..::..TraceError Method
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

TriggerInPort Class
TriggerInPort Members
DynamicNode.Core Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
TriggerInPort..::..TraceInfo Method
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

TriggerInPort Class
TriggerInPort Members
DynamicNode.Core Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
TriggerInPort..::..TraceVerbose Method
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

TriggerInPort Class
TriggerInPort Members
DynamicNode.Core Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
TriggerInPort..::..TraceVerboseData Method
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

TriggerInPort Class
TriggerInPort Members
DynamicNode.Core Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
TriggerInPort..::..TraceWarning Method
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

TriggerInPort Class
TriggerInPort Members
DynamicNode.Core Namespace


TriggerInPort Properties

[image] [image]

DynamicNodes API
TriggerInPort Properties
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TriggerInPort type exposes the following members.

Properties

 | Name | Description
Public property | CanHaveQueue | Liest oder schreibt einen Wert, der angibt ob dieser Eingang eine Queue haben darf. (Inherited from InPort.)
Public property | Capacity | Liest oder schreibt die Kapazität der evtl. vorhandenen Queue. (Inherited from InPort.)
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Eingangs-Ports zu anderen Ausgangs-Ports angepasst werden kann. (Inherited from InPort.)
Public property | ConnectedOutPort | Gibt den verbundenen Ausgangs-Port zurück der mit diesem Eingangs-Port verbunden ist, oder null, wenn keine Verbindung besteht. (Inherited from InPort.)
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from InPort.)
Public property | CurrentToken | Gibt das Token zurück, welches für den aktuellen Arbeitsschritt verwendet werden soll. (Inherited from InPort.)
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Eingang. (Inherited from InPort.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | HasQueue | Liest oder schreibt einen Wert der angibt ob diese Instanz eine Queue besitzt. (Inherited from InPort.)
Public property | HasWaitingToken | Gibt einen Wert zurück, der angibt ob der nächste Aufruf von PrepareNextToken()()()() ein neues Token zur Verarbeitung bereitstellt oder nicht. (Inherited from InPort.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsConnected | Prüft, ob diese Instanz mit einem Ausgangs-Port verbunden ist. (Inherited from InPort.)
Public property | IsCurrentTokenNew | Gibt einen Wert zurück der angibt, ob das aktuelle Token neu ist. (Inherited from InPort.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsMandatory | Gibt einen Wert zurück oder legt ihn fest, der angibt ob der Eingang mit einem Token belegt werden muss, damit der Knoten arbeiten kann. (Inherited from InPort.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Public property | IsWorkingAllowed | Gibt einen Wert zurück, der angibt ob die Arbeitsmethode des Elternknotens ausgeführt werden darf oder nicht. Wird false zurückgegeben, darf die Arbeitsmethode nichts tun, andernfalls darf die Arbeitsmethode ihre Arbeit verrichten.
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedDataType | Gibt den für die aktuelle Verbindung ausgewählten Datentyp zurück, oder legt ihn fest. (Inherited from InPort.)
Public property | SupportedTypes | Gibt eine Liste mit allen unterstützten Datentypen zurück. Falls ein Daten-Typ-Provider eingerichtet ist, wird dessen Liste zurückgegeben. (Inherited from InPort.)
Public property | UpdateWithNotSetAtDisconnect | Liest oder schreibt einen Wert, der angibt ob der Eingang mit einem Token 'NotSet' belegt werden soll, sobald die Verbindung getrennt wird. (Inherited from InPort.)

See Also

TriggerInPort Class
DynamicNode.Core Namespace


IsWorkingAllowed Property

[image]

DynamicNodes API
TriggerInPort..::..IsWorkingAllowed Property
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob die Arbeitsmethode des Elternknotens ausgeführt werden darf oder nicht. Wird false zurückgegeben, darf die Arbeitsmethode nichts tun, andernfalls darf die Arbeitsmethode ihre Arbeit verrichten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsWorkingAllowed { get; }
Visual Basic
Public ReadOnly Property IsWorkingAllowed As Boolean
    Get
F#
member IsWorkingAllowed : bool

See Also

TriggerInPort Class
DynamicNode.Core Namespace


TriggerInPort Events

[image] [image]

DynamicNodes API
TriggerInPort Events
TriggerInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TriggerInPort type exposes the following members.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | CurrentTokenChanged | Wird ausgelöst, wenn das aktuelle Token zur Verarbeitung geändert wird. (Inherited from InPort.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn der ausgewählte Datentyp für die Verbindung geändert wird. (Inherited from InPort.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)

See Also

TriggerInPort Class
DynamicNode.Core Namespace


TriggerOutPort Class

[image]

DynamicNodes API
TriggerOutPort Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Dieser Ausgang dient Knoten für Benachrichtigungen über den Abschluss ihrer Arbeit.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class TriggerOutPort : OutPort
Visual Basic
Public Class TriggerOutPort _
    Inherits OutPort
F#
type TriggerOutPort =
    class
        inherit OutPort
    end

Remarks

Alle Knoten die einen Seiteneffekt hervorrufen, z.B. Ausgabe auf Bildschirm, Dateisystem, Netzwerk, etc., sollten einen TriggerOutPort verwenden. Dadurch kann der Abschluss des Seiteneffekts als Steuersignal für weitere Aktionen verwendet werden.

Remarks

Einem Knoten kann immer nur ein TriggerOutPort hinzugefügt werden.

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' IPort >)>)>
DynamicNode.Model..::..ChildObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Core..::..Port
DynamicNode.Core..::..OutPort
DynamicNode.Core..::..TriggerOutPort

See Also

TriggerOutPort Members
DynamicNode.Core Namespace


TriggerOutPort Members

[image] [image]

DynamicNodes API
TriggerOutPort Members
TriggerOutPort Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TriggerOutPort type exposes the following members.

Constructors

 | Name | Description
Public method | TriggerOutPort(INode) | Initialisert eine Instanz der Klasse TriggerOutPort mit dem Namen "triggerOut" und dem Datentyp ControlTrigger.
Public method | TriggerOutPort(INode, String) | Initialisert eine Instanz der Klasse TriggerOutPort mit dem Namen "triggerOut" und dem Datentyp ControlTrigger.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Stellt eine Verbindung zu einen Eingangs-Port her. (Inherited from OutPort.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Eingangs-Port. (Inherited from OutPort.)
Public method | DisconnectAll | Trennt alle Verbindungen dieses Ausgangs-Ports. (Inherited from OutPort.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Fire | Gibt das Token an die verbundenen Eingänge weiter. (Inherited from OutPort.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Inherited from OutPort.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem der unterstützte Datentyp geändert wurden. Falls Verbindungen bestehen wird erneut geprüft ob Verbindungen gültig sind. Falls die Verbindung ungüötig ist, wird sie getrennt. (Inherited from OutPort.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from Port.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from Port.)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from OutPort.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Trigger | Gibt den Abschluss der Knotenarbeit bekannt und verwendet für die Erzeugung der Marke MinTokenState, StreamOfSet und IndexOfSet.
Public method | TriggerInvalid()()()() | Legt eine ungültige Marke auf den Ausgang und gibt damit den Abschluss der Knotenarbeit bekannt.
Public method | TriggerInvalid(Stream, Int64) | Legt eine ungültige Marke mit einer Stream-Bindung auf den Ausgang und gibt damit den fehlerhaften Abschluss der Knotenarbeit bekannt.
Public method | TriggerValid()()()() | Legt eine gültige Marke auf den Ausgang und gibt damit den Abschluss der Knotenarbeit bekannt.
Public method | TriggerValid(Stream, Int64) | Legt eine gültige Marke mit einer Stream-Bindung auf den Ausgang und gibt damit den fehlerhaften Abschluss der Knotenarbeit bekannt.
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Inherited from OutPort.)
Public method | UpdateToken(Object) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet, das Token gehört keinem Stream an. (Inherited from OutPort.)
Public method | UpdateToken(Token) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)
Public method | UpdateToken(TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet, das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet. (Inherited from OutPort.)
Public method | UpdateToken(TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)
Public method | UpdateTokenNotSet()()()() | Belegt den Ausgang mit einem lehren Token welches zu keinem Stream gehört. (Inherited from OutPort.)
Public method | UpdateTokenNotSet(Stream, Int64) | Belegt den Ausgang mit einem lehren Token. (Inherited from OutPort.)

Properties

 | Name | Description
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Ausgangs-Ports zu anderen Eingangs-Ports angepasst werden kann. (Inherited from OutPort.)
Public property | ConnectedPorts | Gibt ein Array mit allen verbundenen Eingängen zurück. (Inherited from OutPort.)
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from OutPort.)
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Ausgang. (Inherited from OutPort.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | NeedToFire | Gibt einen Wert zurück, der angibt, ob der Ausgang mit einem Token belegt ist, welches noch nicht gefeuert wurde. (Inherited from OutPort.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedType | Gibt den unterstützten Datentyp des Ausgangs zurück. (Inherited from OutPort.)

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | Fired | Tritt auf, wenn das aktuelle Token an die verbundenen Eingänge weitergegeben wurde. (Inherited from OutPort.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)
Public event | TypeSupportChanged | Wird ausgelöst, wenn der Datentyp des Ausgangs geändert wurde und alle ausgehenden Verbindungen neu verhandelt werden müssen. (Inherited from OutPort.)

See Also

TriggerOutPort Class
DynamicNode.Core Namespace


TriggerOutPort Constructor

[image] [image]

DynamicNodes API
TriggerOutPort Constructor
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TriggerOutPort(INode) | Initialisert eine Instanz der Klasse TriggerOutPort mit dem Namen "triggerOut" und dem Datentyp ControlTrigger.
Public method | TriggerOutPort(INode, String) | Initialisert eine Instanz der Klasse TriggerOutPort mit dem Namen "triggerOut" und dem Datentyp ControlTrigger.

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


TriggerOutPort Constructor (INode)

[image]

DynamicNodes API
TriggerOutPort Constructor (INode)
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisert eine Instanz der Klasse TriggerOutPort mit dem Namen "triggerOut" und dem Datentyp ControlTrigger.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TriggerOutPort(
    INode parent
)
Visual Basic
Public Sub New ( _
    parent As INode _
)
F#
new :
        parent:INode -> TriggerOutPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten dem der Steuerausgang hinzugefügt werden soll.

See Also

TriggerOutPort Class
TriggerOutPort Overload
DynamicNode.Core Namespace


TriggerOutPort Constructor (INode, String)

[image]

DynamicNodes API
TriggerOutPort Constructor (INode, String)
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisert eine Instanz der Klasse TriggerOutPort mit dem Namen "triggerOut" und dem Datentyp ControlTrigger.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TriggerOutPort(
    INode parent,
    string name
)
Visual Basic
Public Sub New ( _
    parent As INode, _
    name As String _
)
F#
new :
        parent:INode *
        name:string -> TriggerOutPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Knoten dem der Steuerausgang hinzugefügt werden soll.
name
Type: System..::..String
Der Name des Ports.

See Also

TriggerOutPort Class
TriggerOutPort Overload
DynamicNode.Core Namespace


TriggerOutPort Methods

[image] [image]

DynamicNodes API
TriggerOutPort Methods
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TriggerOutPort type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Stellt eine Verbindung zu einen Eingangs-Port her. (Inherited from OutPort.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Eingangs-Port. (Inherited from OutPort.)
Public method | DisconnectAll | Trennt alle Verbindungen dieses Ausgangs-Ports. (Inherited from OutPort.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Fire | Gibt das Token an die verbundenen Eingänge weiter. (Inherited from OutPort.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Inherited from OutPort.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem der unterstützte Datentyp geändert wurden. Falls Verbindungen bestehen wird erneut geprüft ob Verbindungen gültig sind. Falls die Verbindung ungüötig ist, wird sie getrennt. (Inherited from OutPort.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from Port.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from Port.)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from OutPort.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Trigger | Gibt den Abschluss der Knotenarbeit bekannt und verwendet für die Erzeugung der Marke MinTokenState, StreamOfSet und IndexOfSet.
Public method | TriggerInvalid()()()() | Legt eine ungültige Marke auf den Ausgang und gibt damit den Abschluss der Knotenarbeit bekannt.
Public method | TriggerInvalid(Stream, Int64) | Legt eine ungültige Marke mit einer Stream-Bindung auf den Ausgang und gibt damit den fehlerhaften Abschluss der Knotenarbeit bekannt.
Public method | TriggerValid()()()() | Legt eine gültige Marke auf den Ausgang und gibt damit den Abschluss der Knotenarbeit bekannt.
Public method | TriggerValid(Stream, Int64) | Legt eine gültige Marke mit einer Stream-Bindung auf den Ausgang und gibt damit den fehlerhaften Abschluss der Knotenarbeit bekannt.
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Inherited from OutPort.)
Public method | UpdateToken(Object) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet, das Token gehört keinem Stream an. (Inherited from OutPort.)
Public method | UpdateToken(Token) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)
Public method | UpdateToken(TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet, das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet. (Inherited from OutPort.)
Public method | UpdateToken(TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)
Public method | UpdateTokenNotSet()()()() | Belegt den Ausgang mit einem lehren Token welches zu keinem Stream gehört. (Inherited from OutPort.)
Public method | UpdateTokenNotSet(Stream, Int64) | Belegt den Ausgang mit einem lehren Token. (Inherited from OutPort.)

See Also

TriggerOutPort Class
DynamicNode.Core Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
TriggerOutPort..::..BeforeUseExtension Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


TraceError Method

[image] [image]

DynamicNodes API
TriggerOutPort..::..TraceError Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
TriggerOutPort..::..TraceInfo Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
TriggerOutPort..::..TraceVerbose Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
TriggerOutPort..::..TraceVerboseData Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
TriggerOutPort..::..TraceWarning Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


Trigger Method

[image]

DynamicNodes API
TriggerOutPort..::..Trigger Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Abschluss der Knotenarbeit bekannt und verwendet für die Erzeugung der Marke MinTokenState, StreamOfSet und IndexOfSet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Trigger(
    TokenSet ts
)
Visual Basic
Public Sub Trigger ( _
    ts As TokenSet _
)
F#
member Trigger :
        ts:TokenSet -> unit

Parameters

ts
Type: DynamicNode.Core..::..TokenSet
Das TokenSet das der Arbeitsmethode übergeben wurde.

See Also

TriggerOutPort Class
DynamicNode.Core Namespace


TriggerInvalid Method

[image] [image]

DynamicNodes API
TriggerOutPort..::..TriggerInvalid Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TriggerInvalid()()()() | Legt eine ungültige Marke auf den Ausgang und gibt damit den Abschluss der Knotenarbeit bekannt.
Public method | TriggerInvalid(Stream, Int64) | Legt eine ungültige Marke mit einer Stream-Bindung auf den Ausgang und gibt damit den fehlerhaften Abschluss der Knotenarbeit bekannt.

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


TriggerInvalid Method

[image]

DynamicNodes API
TriggerOutPort..::..TriggerInvalid Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Legt eine ungültige Marke auf den Ausgang und gibt damit den Abschluss der Knotenarbeit bekannt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TriggerInvalid()
Visual Basic
Public Sub TriggerInvalid
F#
member TriggerInvalid : unit -> unit

See Also

TriggerOutPort Class
TriggerInvalid Overload
DynamicNode.Core Namespace


TriggerInvalid Method (Stream, Int64)

[image]

DynamicNodes API
TriggerOutPort..::..TriggerInvalid Method (Stream, Int64)
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Legt eine ungültige Marke mit einer Stream-Bindung auf den Ausgang und gibt damit den fehlerhaften Abschluss der Knotenarbeit bekannt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TriggerInvalid(
    Stream stream,
    long index
)
Visual Basic
Public Sub TriggerInvalid ( _
    stream As Stream, _
    index As Long _
)
F#
member TriggerInvalid :
        stream:Stream *
        index:int64 -> unit

Parameters

stream
Type: DynamicNode.Core..::..Stream
Der Datenstrom in dem der Knoten arbeitet.
index
Type: System..::..Int64
Die laufenden Nummer im Datenstrom in dem der Knoten arbeitet.

See Also

TriggerOutPort Class
TriggerInvalid Overload
DynamicNode.Core Namespace


TriggerValid Method

[image] [image]

DynamicNodes API
TriggerOutPort..::..TriggerValid Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TriggerValid()()()() | Legt eine gültige Marke auf den Ausgang und gibt damit den Abschluss der Knotenarbeit bekannt.
Public method | TriggerValid(Stream, Int64) | Legt eine gültige Marke mit einer Stream-Bindung auf den Ausgang und gibt damit den fehlerhaften Abschluss der Knotenarbeit bekannt.

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


TriggerValid Method

[image]

DynamicNodes API
TriggerOutPort..::..TriggerValid Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Legt eine gültige Marke auf den Ausgang und gibt damit den Abschluss der Knotenarbeit bekannt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TriggerValid()
Visual Basic
Public Sub TriggerValid
F#
member TriggerValid : unit -> unit

See Also

TriggerOutPort Class
TriggerValid Overload
DynamicNode.Core Namespace


TriggerValid Method (Stream, Int64)

[image]

DynamicNodes API
TriggerOutPort..::..TriggerValid Method (Stream, Int64)
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Legt eine gültige Marke mit einer Stream-Bindung auf den Ausgang und gibt damit den fehlerhaften Abschluss der Knotenarbeit bekannt.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TriggerValid(
    Stream stream,
    long index
)
Visual Basic
Public Sub TriggerValid ( _
    stream As Stream, _
    index As Long _
)
F#
member TriggerValid :
        stream:Stream *
        index:int64 -> unit

Parameters

stream
Type: DynamicNode.Core..::..Stream
Der Datenstrom in dem der Knoten arbeitet.
index
Type: System..::..Int64
Die laufenden Nummer im Datenstrom in dem der Knoten arbeitet.

See Also

TriggerOutPort Class
TriggerValid Overload
DynamicNode.Core Namespace


UpdateToken Method

[image] [image]

DynamicNodes API
TriggerOutPort..::..UpdateToken Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | UpdateToken(Object) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet, das Token gehört keinem Stream an. (Inherited from OutPort.)
Public method | UpdateToken(Token) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)
Public method | UpdateToken(TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet, das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet. (Inherited from OutPort.)
Public method | UpdateToken(TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


UpdateTokenNotSet Method

[image] [image]

DynamicNodes API
TriggerOutPort..::..UpdateTokenNotSet Method
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | UpdateTokenNotSet()()()() | Belegt den Ausgang mit einem lehren Token welches zu keinem Stream gehört. (Inherited from OutPort.)
Public method | UpdateTokenNotSet(Stream, Int64) | Belegt den Ausgang mit einem lehren Token. (Inherited from OutPort.)

See Also

TriggerOutPort Class
TriggerOutPort Members
DynamicNode.Core Namespace


TriggerOutPort Properties

[image] [image]

DynamicNodes API
TriggerOutPort Properties
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TriggerOutPort type exposes the following members.

Properties

 | Name | Description
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Ausgangs-Ports zu anderen Eingangs-Ports angepasst werden kann. (Inherited from OutPort.)
Public property | ConnectedPorts | Gibt ein Array mit allen verbundenen Eingängen zurück. (Inherited from OutPort.)
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from OutPort.)
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Ausgang. (Inherited from OutPort.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | NeedToFire | Gibt einen Wert zurück, der angibt, ob der Ausgang mit einem Token belegt ist, welches noch nicht gefeuert wurde. (Inherited from OutPort.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedType | Gibt den unterstützten Datentyp des Ausgangs zurück. (Inherited from OutPort.)

See Also

TriggerOutPort Class
DynamicNode.Core Namespace


TriggerOutPort Events

[image] [image]

DynamicNodes API
TriggerOutPort Events
TriggerOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TriggerOutPort type exposes the following members.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | Fired | Tritt auf, wenn das aktuelle Token an die verbundenen Eingänge weitergegeben wurde. (Inherited from OutPort.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)
Public event | TypeSupportChanged | Wird ausgelöst, wenn der Datentyp des Ausgangs geändert wurde und alle ausgehenden Verbindungen neu verhandelt werden müssen. (Inherited from OutPort.)

See Also

TriggerOutPort Class
DynamicNode.Core Namespace


XmlGraphStorage Class

[image]

DynamicNodes API
XmlGraphStorage Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Implementierung von IGraphStorage, welche mit XML-Daten arbeitet.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class XmlGraphStorage : IGraphStorage
Visual Basic
Public Class XmlGraphStorage _
    Implements IGraphStorage
F#
type XmlGraphStorage =
    class
        interface IGraphStorage
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Core..::..XmlGraphStorage

See Also

XmlGraphStorage Members
DynamicNode.Core Namespace


XmlGraphStorage Members

[image] [image]

DynamicNodes API
XmlGraphStorage Members
XmlGraphStorage Class Constructors Methods Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlGraphStorage type exposes the following members.

Constructors

 | Name | Description
Public method | XmlGraphStorage | Initialisiert eine XmlGraphStorage-Instanz.

Methods

 | Name | Description
Public method | GetRootElement | Erzeugt zu der XML-Datei einen XPathNavigator für den Wurzel-Knoten.
Public method | Restore(array<IExtension<(Of <<'(IGraph>)>>)>[]()[][]) | Erzeugt ein Knoten-Graph aus einer Datei.
 | Restore(IRuntime, String, array<IExtension<(Of <<'(IGraph>)>>)>[]()[][]) | Erzeugt ein Knoten-Graph aus einer Datei.
 | RestoreDynamicExtensions<(Of <<'(T>)>>)(XmlElement, IExtensible<(Of <<'(T>)>>), IEnumerable<(Of <<'(String>)>>)) | Stellt dynamische Erweiterungen eines Objektes wieder her.
 | RestoreDynamicExtensions<(Of <<'(T>)>>)(XmlElement, IExtensible<(Of <<'(T>)>>), IEnumerable<(Of <<'(Type>)>>)) | Stellt dynamische Erweiterungen eines Objektes wieder her.
Public method | RestoreGraphExtension(IGraph, IExtension<(Of <<'(IGraph>)>>)) | Stellt eine Graphen-Erweiterung wieder her.
 | RestoreGraphExtension(XmlElement, IGraph, IExtension<(Of <<'(IGraph>)>>)) | Stellt eine Graph-Erweiterung wieder her.
Public method | RestoreNodeExtensions(IGraph, array<String>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
Public method | RestoreNodeExtensions(IGraph, array<Type>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
 | RestoreNodeExtensions(XmlElement, IGraph, array<String>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
 | RestoreNodeExtensions(XmlElement, IGraph, array<Type>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
Public method | RestorePortExtensions(IGraph, array<String>[]()[][]) | Stellt Port-Erweiterungen wieder her.
Public method | RestorePortExtensions(IGraph, array<Type>[]()[][]) | Stellt Port-Erweiterungen wieder her.
 | RestorePortExtensions(XmlElement, IGraph, array<String>[]()[][]) | Stellt Port-Erweiterungen wieder her.
 | RestorePortExtensions(XmlElement, IGraph, array<Type>[]()[][]) | Stellt Port-Erweiterungen wieder her.
 | RestoreStaticExtensions<(Of <<'(T>)>>) | Stellt den Zustand aller statischen Erweiterungen eines Objektes wieder her.
Public method | Store | Speichert das übergebene IGraph in einer Datei.
 | StoreExtensions<(Of <<'(T>)>>) | Speichert den Zustand aller Erweiterungen in dem übergebenen XmlWriter.

Fields

Name | Description
FORMAT_VERSION | Die aktuelle Datei-Format-Version

See Also

XmlGraphStorage Class
DynamicNode.Core Namespace


XmlGraphStorage Constructor

[image]

DynamicNodes API
XmlGraphStorage Constructor
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine XmlGraphStorage-Instanz.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public XmlGraphStorage(
    IRuntime runtime,
    string file
)
Visual Basic
Public Sub New ( _
    runtime As IRuntime, _
    file As String _
)
F#
new :
        runtime:IRuntime *
        file:string -> XmlGraphStorage

Parameters

runtime
Type: DynamicNode.Core..::..IRuntime
Die Laufzeitumgebung.
file
Type: System..::..String
Die XML-Datei.

See Also

XmlGraphStorage Class
DynamicNode.Core Namespace


XmlGraphStorage Fields

[image] [image]

DynamicNodes API
XmlGraphStorage Fields
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlGraphStorage type exposes the following members.

Fields

Name | Description
FORMAT_VERSION | Die aktuelle Datei-Format-Version

See Also

XmlGraphStorage Class
DynamicNode.Core Namespace


FORMAT_VERSION Field

[image]

DynamicNodes API
XmlGraphStorage..::..FORMAT_VERSION Field
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die aktuelle Datei-Format-Version

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public const float FORMAT_VERSION
Visual Basic
Public Const FORMAT_VERSION As Single
F#
static val mutable FORMAT_VERSION: float32

See Also

XmlGraphStorage Class
DynamicNode.Core Namespace


XmlGraphStorage Methods

[image] [image]

DynamicNodes API
XmlGraphStorage Methods
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlGraphStorage type exposes the following members.

Methods

 | Name | Description
Public method | GetRootElement | Erzeugt zu der XML-Datei einen XPathNavigator für den Wurzel-Knoten.
Public method | Restore(array<IExtension<(Of <<'(IGraph>)>>)>[]()[][]) | Erzeugt ein Knoten-Graph aus einer Datei.
 | Restore(IRuntime, String, array<IExtension<(Of <<'(IGraph>)>>)>[]()[][]) | Erzeugt ein Knoten-Graph aus einer Datei.
 | RestoreDynamicExtensions<(Of <<'(T>)>>)(XmlElement, IExtensible<(Of <<'(T>)>>), IEnumerable<(Of <<'(String>)>>)) | Stellt dynamische Erweiterungen eines Objektes wieder her.
 | RestoreDynamicExtensions<(Of <<'(T>)>>)(XmlElement, IExtensible<(Of <<'(T>)>>), IEnumerable<(Of <<'(Type>)>>)) | Stellt dynamische Erweiterungen eines Objektes wieder her.
Public method | RestoreGraphExtension(IGraph, IExtension<(Of <<'(IGraph>)>>)) | Stellt eine Graphen-Erweiterung wieder her.
 | RestoreGraphExtension(XmlElement, IGraph, IExtension<(Of <<'(IGraph>)>>)) | Stellt eine Graph-Erweiterung wieder her.
Public method | RestoreNodeExtensions(IGraph, array<String>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
Public method | RestoreNodeExtensions(IGraph, array<Type>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
 | RestoreNodeExtensions(XmlElement, IGraph, array<String>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
 | RestoreNodeExtensions(XmlElement, IGraph, array<Type>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
Public method | RestorePortExtensions(IGraph, array<String>[]()[][]) | Stellt Port-Erweiterungen wieder her.
Public method | RestorePortExtensions(IGraph, array<Type>[]()[][]) | Stellt Port-Erweiterungen wieder her.
 | RestorePortExtensions(XmlElement, IGraph, array<String>[]()[][]) | Stellt Port-Erweiterungen wieder her.
 | RestorePortExtensions(XmlElement, IGraph, array<Type>[]()[][]) | Stellt Port-Erweiterungen wieder her.
 | RestoreStaticExtensions<(Of <<'(T>)>>) | Stellt den Zustand aller statischen Erweiterungen eines Objektes wieder her.
Public method | Store | Speichert das übergebene IGraph in einer Datei.
 | StoreExtensions<(Of <<'(T>)>>) | Speichert den Zustand aller Erweiterungen in dem übergebenen XmlWriter.

See Also

XmlGraphStorage Class
DynamicNode.Core Namespace


GetRootElement Method

[image]

DynamicNodes API
XmlGraphStorage..::..GetRootElement Method
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt zu der XML-Datei einen XPathNavigator für den Wurzel-Knoten.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public XmlElement GetRootElement()
Visual Basic
Public Function GetRootElement As XmlElement
F#
member GetRootElement : unit -> XmlElement

Return Value

Einen Path-Navigator oder null, wenn ein Fehler aufgetreten ist.

See Also

XmlGraphStorage Class
DynamicNode.Core Namespace


Restore Method

[image] [image]

DynamicNodes API
XmlGraphStorage..::..Restore Method
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Restore(array<IExtension<(Of <<'(IGraph>)>>)>[]()[][]) | Erzeugt ein Knoten-Graph aus einer Datei.
 | Restore(IRuntime, String, array<IExtension<(Of <<'(IGraph>)>>)>[]()[][]) | Erzeugt ein Knoten-Graph aus einer Datei.

See Also

XmlGraphStorage Class
XmlGraphStorage Members
DynamicNode.Core Namespace


Restore Method (IExtension(IGraph)[])

[image]

DynamicNodes API
XmlGraphStorage..::..Restore Method (array<IExtension<(Of <(<'IGraph>)>)>>[]()[][])
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Knoten-Graph aus einer Datei.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IGraph Restore(
    params IExtension<IGraph>[] extensions
)
Visual Basic
Public Function Restore ( _
    ParamArray extensions As IExtension(Of IGraph)() _
) As IGraph
F#
abstract Restore :
        extensions:IExtension<IGraph>[] -> IGraph
override Restore :
        extensions:IExtension<IGraph>[] -> IGraph

Parameters

extensions
Type: array< DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>>[]()[][]
Alle Erweiterungen, die sofort an der Graph angefügt werden sollen.

Return Value

Der Graph.

Implements

IGraphStorage..::..Restore(array<IExtension<(Of <<'(IGraph>)>>)>[]()[][])

See Also

XmlGraphStorage Class
Restore Overload
DynamicNode.Core Namespace


Restore Method (IRuntime, String, IExtension(IGraph)[])

[image]

DynamicNodes API
XmlGraphStorage..::..Restore Method (IRuntime, String, array<IExtension<(Of <(<'IGraph>)>)>>[]()[][])
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Knoten-Graph aus einer Datei.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static IGraph Restore(
    IRuntime runtime,
    string file,
    params IExtension<IGraph>[] extensions
)
Visual Basic
Public Shared Function Restore ( _
    runtime As IRuntime, _
    file As String, _
    ParamArray extensions As IExtension(Of IGraph)() _
) As IGraph
F#
static member Restore :
        runtime:IRuntime *
        file:string *
        extensions:IExtension<IGraph>[] -> IGraph

Parameters

runtime
Type: DynamicNode.Core..::..IRuntime
Die Laufzeitumgebung.
file
Type: System..::..String
Die Quelldatei.
extensions
Type: array< DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>>[]()[][]
Alle Erweiterungen, die sofort an der Graph angefügt werden sollen.

Return Value

Der Graph.

See Also

XmlGraphStorage Class
Restore Overload
DynamicNode.Core Namespace


RestoreDynamicExtensions Method

[image] [image]

DynamicNodes API
XmlGraphStorage..::..RestoreDynamicExtensions Method
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
RestoreDynamicExtensions<(Of <<'(T>)>>)(XmlElement, IExtensible<(Of <<'(T>)>>), IEnumerable<(Of <<'(String>)>>)) | Stellt dynamische Erweiterungen eines Objektes wieder her.
RestoreDynamicExtensions<(Of <<'(T>)>>)(XmlElement, IExtensible<(Of <<'(T>)>>), IEnumerable<(Of <<'(Type>)>>)) | Stellt dynamische Erweiterungen eines Objektes wieder her.

See Also

XmlGraphStorage Class
XmlGraphStorage Members
DynamicNode.Core Namespace


RestoreDynamicExtensions(T) Method (XmlElement, IExtensible(T), IEnumerable(String))

[image]

DynamicNodes API
XmlGraphStorage..::..RestoreDynamicExtensions<(Of <(<'T>)>)> Method (XmlElement, IExtensible<(Of <(<'T>)>)>, IEnumerable<(Of <(<'String>)>)>)
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt dynamische Erweiterungen eines Objektes wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void RestoreDynamicExtensions<T>(
    XmlElement e,
    IExtensible<T> o,
    IEnumerable<string> extensionIds
)
Visual Basic
Public Shared Sub RestoreDynamicExtensions(Of T) ( _
    e As XmlElement, _
    o As IExtensible(Of T), _
    extensionIds As IEnumerable(Of String) _
)
F#
static member RestoreDynamicExtensions :
        e:XmlElement *
        o:IExtensible<'T> *
        extensionIds:IEnumerable<string> -> unit

Parameters

e
Type: System.Xml..::..XmlElement
Die Quelle.
o
Type: DynamicNode.Model..::..IExtensible <(Of <(<'T>)>)>
Das erweiterte Objekt.
extensionIds
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
Eine Liste mit Erweiterungs-IDs.

Type Parameters

T
Der Typ des erweiterten Objektes.

See Also

XmlGraphStorage Class
RestoreDynamicExtensions Overload
DynamicNode.Core Namespace


RestoreDynamicExtensions(T) Method (XmlElement, IExtensible(T), IEnumerable(Type))

[image]

DynamicNodes API
XmlGraphStorage..::..RestoreDynamicExtensions<(Of <(<'T>)>)> Method (XmlElement, IExtensible<(Of <(<'T>)>)>, IEnumerable<(Of <(<'Type>)>)>)
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt dynamische Erweiterungen eines Objektes wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void RestoreDynamicExtensions<T>(
    XmlElement e,
    IExtensible<T> o,
    IEnumerable<Type> extensionTypes
)
Visual Basic
Public Shared Sub RestoreDynamicExtensions(Of T) ( _
    e As XmlElement, _
    o As IExtensible(Of T), _
    extensionTypes As IEnumerable(Of Type) _
)
F#
static member RestoreDynamicExtensions :
        e:XmlElement *
        o:IExtensible<'T> *
        extensionTypes:IEnumerable<Type> -> unit

Parameters

e
Type: System.Xml..::..XmlElement
Die Quelle.
o
Type: DynamicNode.Model..::..IExtensible <(Of <(<'T>)>)>
Das erweiterte Objekt.
extensionTypes
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Type >)>)>
Eine Liste mit Erweiterungstypen.

Type Parameters

T
Der Typ des erweiterten Objektes.

See Also

XmlGraphStorage Class
RestoreDynamicExtensions Overload
DynamicNode.Core Namespace


RestoreGraphExtension Method

[image] [image]

DynamicNodes API
XmlGraphStorage..::..RestoreGraphExtension Method
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RestoreGraphExtension(IGraph, IExtension<(Of <<'(IGraph>)>>)) | Stellt eine Graphen-Erweiterung wieder her.
 | RestoreGraphExtension(XmlElement, IGraph, IExtension<(Of <<'(IGraph>)>>)) | Stellt eine Graph-Erweiterung wieder her.

See Also

XmlGraphStorage Class
XmlGraphStorage Members
DynamicNode.Core Namespace


RestoreGraphExtension Method (IGraph, IExtension(IGraph))

[image]

DynamicNodes API
XmlGraphStorage..::..RestoreGraphExtension Method (IGraph, IExtension<(Of <(<'IGraph>)>)>)
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt eine Graphen-Erweiterung wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RestoreGraphExtension(
    IGraph graph,
    IExtension<IGraph> extension
)
Visual Basic
Public Sub RestoreGraphExtension ( _
    graph As IGraph, _
    extension As IExtension(Of IGraph) _
)
F#
abstract RestoreGraphExtension :
        graph:IGraph *
        extension:IExtension<IGraph> -> unit
override RestoreGraphExtension :
        graph:IGraph *
        extension:IExtension<IGraph> -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph an dem die Erweiterung arbeitet.
extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>
Die Erweiterung, deren Eigenschaften wieder hergestellt werden sollen.

Implements

IGraphStorage..::..RestoreGraphExtension(IGraph, IExtension<(Of <<'(IGraph>)>>))

See Also

XmlGraphStorage Class
RestoreGraphExtension Overload
DynamicNode.Core Namespace


RestoreGraphExtension Method (XmlElement, IGraph, IExtension(IGraph))

[image]

DynamicNodes API
XmlGraphStorage..::..RestoreGraphExtension Method (XmlElement, IGraph, IExtension<(Of <(<'IGraph>)>)>)
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt eine Graph-Erweiterung wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void RestoreGraphExtension(
    XmlElement source,
    IGraph graph,
    IExtension<IGraph> extension
)
Visual Basic
Public Shared Sub RestoreGraphExtension ( _
    source As XmlElement, _
    graph As IGraph, _
    extension As IExtension(Of IGraph) _
)
F#
static member RestoreGraphExtension :
        source:XmlElement *
        graph:IGraph *
        extension:IExtension<IGraph> -> unit

Parameters

source
Type: System.Xml..::..XmlElement
Das Quellelement.
graph
Type: DynamicNode.Core..::..IGraph
Der Graph an dem die Erweiterung arbeitet.
extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' IGraph >)>)>
Die Erweiterung, deren Eigenschaften wieder hergestellt werden sollen.

See Also

XmlGraphStorage Class
RestoreGraphExtension Overload
DynamicNode.Core Namespace


RestoreNodeExtensions Method

[image] [image]

DynamicNodes API
XmlGraphStorage..::..RestoreNodeExtensions Method
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RestoreNodeExtensions(IGraph, array<String>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
Public method | RestoreNodeExtensions(IGraph, array<Type>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
 | RestoreNodeExtensions(XmlElement, IGraph, array<String>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.
 | RestoreNodeExtensions(XmlElement, IGraph, array<Type>[]()[][]) | Stellt Knoten-Erweiterungen wieder her.

See Also

XmlGraphStorage Class
XmlGraphStorage Members
DynamicNode.Core Namespace


RestoreNodeExtensions Method (IGraph, String[])

[image]

DynamicNodes API
XmlGraphStorage..::..RestoreNodeExtensions Method (IGraph, array<String>[]()[][])
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Knoten-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RestoreNodeExtensions(
    IGraph graph,
    params string[] nodeExtensionIds
)
Visual Basic
Public Sub RestoreNodeExtensions ( _
    graph As IGraph, _
    ParamArray nodeExtensionIds As String() _
)
F#
abstract RestoreNodeExtensions :
        graph:IGraph *
        nodeExtensionIds:string[] -> unit
override RestoreNodeExtensions :
        graph:IGraph *
        nodeExtensionIds:string[] -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Knoten rekonstruiert werden sollen.
nodeExtensionIds
Type: array< System..::..String >[]()[][]
Die IDs der Erweiterungen, welche wieder hergestellt werden sollen.

Implements

IGraphStorage..::..RestoreNodeExtensions(IGraph, array<String>[]()[][])

See Also

XmlGraphStorage Class
RestoreNodeExtensions Overload
DynamicNode.Core Namespace


RestoreNodeExtensions Method (IGraph, Type[])

[image]

DynamicNodes API
XmlGraphStorage..::..RestoreNodeExtensions Method (IGraph, array<Type>[]()[][])
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Knoten-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RestoreNodeExtensions(
    IGraph graph,
    params Type[] nodeExtensionTypes
)
Visual Basic
Public Sub RestoreNodeExtensions ( _
    graph As IGraph, _
    ParamArray nodeExtensionTypes As Type() _
)
F#
abstract RestoreNodeExtensions :
        graph:IGraph *
        nodeExtensionTypes:Type[] -> unit
override RestoreNodeExtensions :
        graph:IGraph *
        nodeExtensionTypes:Type[] -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Knoten rekonstruiert werden sollen.
nodeExtensionTypes
Type: array< System..::..Type >[]()[][]
Die Typen der Erweiterungen, welche wieder hergestellt werden sollen.

Implements

IGraphStorage..::..RestoreNodeExtensions(IGraph, array<Type>[]()[][])

See Also

XmlGraphStorage Class
RestoreNodeExtensions Overload
DynamicNode.Core Namespace


RestoreNodeExtensions Method (XmlElement, IGraph, String[])

[image]

DynamicNodes API
XmlGraphStorage..::..RestoreNodeExtensions Method (XmlElement, IGraph, array<String>[]()[][])
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Knoten-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void RestoreNodeExtensions(
    XmlElement source,
    IGraph graph,
    params string[] nodeExtensionIds
)
Visual Basic
Public Shared Sub RestoreNodeExtensions ( _
    source As XmlElement, _
    graph As IGraph, _
    ParamArray nodeExtensionIds As String() _
)
F#
static member RestoreNodeExtensions :
        source:XmlElement *
        graph:IGraph *
        nodeExtensionIds:string[] -> unit

Parameters

source
Type: System.Xml..::..XmlElement
Das Quellelement.
graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Knoten rekonstruiert werden sollen.
nodeExtensionIds
Type: array< System..::..String >[]()[][]
Die IDs der Erweiterungen, welche wieder hergestellt werden sollen.

See Also

XmlGraphStorage Class
RestoreNodeExtensions Overload
DynamicNode.Core Namespace


RestoreNodeExtensions Method (XmlElement, IGraph, Type[])

[image]

DynamicNodes API
XmlGraphStorage..::..RestoreNodeExtensions Method (XmlElement, IGraph, array<Type>[]()[][])
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Knoten-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void RestoreNodeExtensions(
    XmlElement source,
    IGraph graph,
    params Type[] nodeExtensionTypes
)
Visual Basic
Public Shared Sub RestoreNodeExtensions ( _
    source As XmlElement, _
    graph As IGraph, _
    ParamArray nodeExtensionTypes As Type() _
)
F#
static member RestoreNodeExtensions :
        source:XmlElement *
        graph:IGraph *
        nodeExtensionTypes:Type[] -> unit

Parameters

source
Type: System.Xml..::..XmlElement
Das Quellelement.
graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Knoten rekonstruiert werden sollen.
nodeExtensionTypes
Type: array< System..::..Type >[]()[][]
Die Typen der Erweiterungen, welche wieder hergestellt werden sollen.

See Also

XmlGraphStorage Class
RestoreNodeExtensions Overload
DynamicNode.Core Namespace


RestorePortExtensions Method

[image] [image]

DynamicNodes API
XmlGraphStorage..::..RestorePortExtensions Method
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RestorePortExtensions(IGraph, array<String>[]()[][]) | Stellt Port-Erweiterungen wieder her.
Public method | RestorePortExtensions(IGraph, array<Type>[]()[][]) | Stellt Port-Erweiterungen wieder her.
 | RestorePortExtensions(XmlElement, IGraph, array<String>[]()[][]) | Stellt Port-Erweiterungen wieder her.
 | RestorePortExtensions(XmlElement, IGraph, array<Type>[]()[][]) | Stellt Port-Erweiterungen wieder her.

See Also

XmlGraphStorage Class
XmlGraphStorage Members
DynamicNode.Core Namespace


RestorePortExtensions Method (IGraph, String[])

[image]

DynamicNodes API
XmlGraphStorage..::..RestorePortExtensions Method (IGraph, array<String>[]()[][])
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Port-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RestorePortExtensions(
    IGraph graph,
    params string[] portExtensionIds
)
Visual Basic
Public Sub RestorePortExtensions ( _
    graph As IGraph, _
    ParamArray portExtensionIds As String() _
)
F#
abstract RestorePortExtensions :
        graph:IGraph *
        portExtensionIds:string[] -> unit
override RestorePortExtensions :
        graph:IGraph *
        portExtensionIds:string[] -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Ports rekonstruiert werden sollen.
portExtensionIds
Type: array< System..::..String >[]()[][]
Die IDs der Erweiterungen, welche wieder hergestellt werden sollen.

Implements

IGraphStorage..::..RestorePortExtensions(IGraph, array<String>[]()[][])

See Also

XmlGraphStorage Class
RestorePortExtensions Overload
DynamicNode.Core Namespace


RestorePortExtensions Method (IGraph, Type[])

[image]

DynamicNodes API
XmlGraphStorage..::..RestorePortExtensions Method (IGraph, array<Type>[]()[][])
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Port-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RestorePortExtensions(
    IGraph graph,
    params Type[] portExtensionTypes
)
Visual Basic
Public Sub RestorePortExtensions ( _
    graph As IGraph, _
    ParamArray portExtensionTypes As Type() _
)
F#
abstract RestorePortExtensions :
        graph:IGraph *
        portExtensionTypes:Type[] -> unit
override RestorePortExtensions :
        graph:IGraph *
        portExtensionTypes:Type[] -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Ports rekonstruiert werden sollen.
portExtensionTypes
Type: array< System..::..Type >[]()[][]
Die Typen der Erweiterungen, welche wieder hergestellt werden sollen.

Implements

IGraphStorage..::..RestorePortExtensions(IGraph, array<Type>[]()[][])

See Also

XmlGraphStorage Class
RestorePortExtensions Overload
DynamicNode.Core Namespace


RestorePortExtensions Method (XmlElement, IGraph, String[])

[image]

DynamicNodes API
XmlGraphStorage..::..RestorePortExtensions Method (XmlElement, IGraph, array<String>[]()[][])
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Port-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void RestorePortExtensions(
    XmlElement source,
    IGraph graph,
    params string[] portExtensionIds
)
Visual Basic
Public Shared Sub RestorePortExtensions ( _
    source As XmlElement, _
    graph As IGraph, _
    ParamArray portExtensionIds As String() _
)
F#
static member RestorePortExtensions :
        source:XmlElement *
        graph:IGraph *
        portExtensionIds:string[] -> unit

Parameters

source
Type: System.Xml..::..XmlElement
Das Quellelement.
graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Ports rekonstruiert werden sollen.
portExtensionIds
Type: array< System..::..String >[]()[][]
Die IDs der Erweiterungen, welche wieder hergestellt werden sollen.

See Also

XmlGraphStorage Class
RestorePortExtensions Overload
DynamicNode.Core Namespace


RestorePortExtensions Method (XmlElement, IGraph, Type[])

[image]

DynamicNodes API
XmlGraphStorage..::..RestorePortExtensions Method (XmlElement, IGraph, array<Type>[]()[][])
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Port-Erweiterungen wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void RestorePortExtensions(
    XmlElement source,
    IGraph graph,
    params Type[] portExtensionTypes
)
Visual Basic
Public Shared Sub RestorePortExtensions ( _
    source As XmlElement, _
    graph As IGraph, _
    ParamArray portExtensionTypes As Type() _
)
F#
static member RestorePortExtensions :
        source:XmlElement *
        graph:IGraph *
        portExtensionTypes:Type[] -> unit

Parameters

source
Type: System.Xml..::..XmlElement
Ein XML-Element das die Beschreibungen der Knoten enthält.
graph
Type: DynamicNode.Core..::..IGraph
Der Graph, dessen Ports rekonstruiert werden sollen.
portExtensionTypes
Type: array< System..::..Type >[]()[][]
Die Typen der Erweiterungen, welche wieder hergestellt werden sollen.

See Also

XmlGraphStorage Class
RestorePortExtensions Overload
DynamicNode.Core Namespace


RestoreStaticExtensions(T) Method

[image]

DynamicNodes API
XmlGraphStorage..::..RestoreStaticExtensions<(Of <(<'T>)>)> Method
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt den Zustand aller statischen Erweiterungen eines Objektes wieder her.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void RestoreStaticExtensions<T>(
    XmlElement e,
    IExtensible<T> o
)
Visual Basic
Public Shared Sub RestoreStaticExtensions(Of T) ( _
    e As XmlElement, _
    o As IExtensible(Of T) _
)
F#
static member RestoreStaticExtensions :
        e:XmlElement *
        o:IExtensible<'T> -> unit

Parameters

e
Type: System.Xml..::..XmlElement
Die Quelle.
o
Type: DynamicNode.Model..::..IExtensible <(Of <(<'T>)>)>
Das erweiterte Objekt.

Type Parameters

T
Der Typ des erweiterten Objektes.

See Also

XmlGraphStorage Class
DynamicNode.Core Namespace


Store Method

[image]

DynamicNodes API
XmlGraphStorage..::..Store Method
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Speichert das übergebene IGraph in einer Datei.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Store(
    IGraph graph
)
Visual Basic
Public Sub Store ( _
    graph As IGraph _
)
F#
abstract Store :
        graph:IGraph -> unit
override Store :
        graph:IGraph -> unit

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph.

Implements

IGraphStorage..::..Store(IGraph)

See Also

XmlGraphStorage Class
DynamicNode.Core Namespace


StoreExtensions(T) Method

[image]

DynamicNodes API
XmlGraphStorage..::..StoreExtensions<(Of <(<'T>)>)> Method
XmlGraphStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Speichert den Zustand aller Erweiterungen in dem übergebenen XmlWriter.

Namespace: DynamicNode.Core
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void StoreExtensions<T>(
    XmlWriter w,
    IExtensible<T> o
)
Visual Basic
Public Shared Sub StoreExtensions(Of T) ( _
    w As XmlWriter, _
    o As IExtensible(Of T) _
)
F#
static member StoreExtensions :
        w:XmlWriter *
        o:IExtensible<'T> -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Das Ziel für die Speicherung.
o
Type: DynamicNode.Model..::..IExtensible <(Of <(<'T>)>)>
Das erweiterte Objekt.

Type Parameters

T
Der Typ des erweiterten Objektes.

See Also

XmlGraphStorage Class
DynamicNode.Core Namespace


DynamicNode.Core.Nodes Namespace

[image]

DynamicNodes API
DynamicNode.Core.Nodes Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält alle konkreten Knoten-Implementierungen, die zum Systemkern gehören.

Classes

 | Class | Description
Public class | NFlag | Ein Knoten welcher ein Graphen-Flag repräsentiert.
Public class | NSubGraph | Kapselt ein DynamicNode-Sub-Graph als Knoten.
Public class | NSubGraph..::..WrappingInPort | Kapselt den Super-Eingang eines Sub-Graphen.
Public class | NSubGraph..::..WrappingOutPort | Kapselt den Super-Ausgang eines Sub-Graphen.


NFlag Class

[image]

DynamicNodes API
NFlag Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Knoten welcher ein Graphen-Flag repräsentiert.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class NFlag : Node, IFlag
Visual Basic
Public Class NFlag _
    Inherits Node _
    Implements IFlag
F#
type NFlag =
    class
        inherit Node
        interface IFlag
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core.Nodes..::..NFlag

See Also

NFlag Members
DynamicNode.Core.Nodes Namespace


NFlag Members

[image] [image]

DynamicNodes API
NFlag Members
NFlag Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NFlag type exposes the following members.

Constructors

 | Name | Description
Public method | NFlag | Initialisiert eine neue NFlag Instanz.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
 | GetNodeInfo | Gibt die Knoten-Info zurück.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Overrides Node..::..OnInitPortDefaults()()()().)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Overrides Node..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Overrides Node..::..OnStore(IPropertyWriter).)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides Node..::..Work()()()().)

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | FlagName | Gibt den Namen des Graphen-Flags zurück.
Public property | FlagState | Gibt den Zustand des Graphen-Flags zurück.
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


NFlag Constructor

[image]

DynamicNodes API
NFlag Constructor
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue NFlag Instanz.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NFlag()
Visual Basic
Public Sub New
F#
new : unit -> NFlag

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


NFlag Methods

[image] [image]

DynamicNodes API
NFlag Methods
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NFlag type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
 | GetNodeInfo | Gibt die Knoten-Info zurück.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Overrides Node..::..OnInitPortDefaults()()()().)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Overrides Node..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Overrides Node..::..OnStore(IPropertyWriter).)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides Node..::..Work()()()().)

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
NFlag..::..BeforeUseExtension Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

NFlag Class
NFlag Members
DynamicNode.Core.Nodes Namespace


Duplicate Method

[image] [image]

DynamicNodes API
NFlag..::..Duplicate Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

NFlag Class
NFlag Members
DynamicNode.Core.Nodes Namespace


GetNodeInfo Method

[image]

DynamicNodes API
NFlag..::..GetNodeInfo Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Knoten-Info zurück.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static NodeInfoAttribute GetNodeInfo()
Visual Basic
Public Shared Function GetNodeInfo As NodeInfoAttribute
F#
static member GetNodeInfo : unit -> NodeInfoAttribute

Return Value

Eine NodeInfoAttribute-Instanz.

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


OnInitPortDefaults Method

[image]

DynamicNodes API
NFlag..::..OnInitPortDefaults Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnInitPortDefaults()
Visual Basic
Public Overrides Sub OnInitPortDefaults
F#
abstract OnInitPortDefaults : unit -> unit
override OnInitPortDefaults : unit -> unit

Implements

INode..::..OnInitPortDefaults()()()()

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


OnRestore Method

[image]

DynamicNodes API
NFlag..::..OnRestore Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overrides Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der IPropertyReader mit dem benutzerdefinierte Eigenschaften des Knotens gelesen werden können.

Implements

IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)

Remarks

Diese Methode wird beim Laden eines Graphen aufgerufen bevor die Verbindungen zwischen den Knoten wiederhergstellt werden.

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


OnStore Method

[image]

DynamicNodes API
NFlag..::..OnStore Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overrides Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der IPropertyWriter mit dem benutzerdefinierte Eigenschaften des Knotens gespeichert werden können.

Implements

IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


TraceError Method

[image] [image]

DynamicNodes API
NFlag..::..TraceError Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NFlag Class
NFlag Members
DynamicNode.Core.Nodes Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
NFlag..::..TraceInfo Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NFlag Class
NFlag Members
DynamicNode.Core.Nodes Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
NFlag..::..TraceVerbose Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NFlag Class
NFlag Members
DynamicNode.Core.Nodes Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
NFlag..::..TraceVerboseData Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NFlag Class
NFlag Members
DynamicNode.Core.Nodes Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
NFlag..::..TraceWarning Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NFlag Class
NFlag Members
DynamicNode.Core.Nodes Namespace


Work Method

[image]

DynamicNodes API
NFlag..::..Work Method
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void Work()
Visual Basic
Public Overrides Sub Work
F#
abstract Work : unit -> unit
override Work : unit -> unit

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


NFlag Properties

[image] [image]

DynamicNodes API
NFlag Properties
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NFlag type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | FlagName | Gibt den Namen des Graphen-Flags zurück.
Public property | FlagState | Gibt den Zustand des Graphen-Flags zurück.
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


FlagName Property

[image]

DynamicNodes API
NFlag..::..FlagName Property
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Graphen-Flags zurück.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string FlagName { get; }
Visual Basic
Public ReadOnly Property FlagName As String
    Get
F#
abstract FlagName : string
override FlagName : string

Field Value

Der Namen des Graphen-Flags.

Implements

IFlag..::..FlagName

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


FlagState Property

[image]

DynamicNodes API
NFlag..::..FlagState Property
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Zustand des Graphen-Flags zurück.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TokenState FlagState { get; }
Visual Basic
Public ReadOnly Property FlagState As TokenState
    Get
F#
abstract FlagState : TokenState
override FlagState : TokenState

Field Value

Der Zustand des Graphen-Flags.

Implements

IFlag..::..FlagState

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


Item Property

[image] [image]

DynamicNodes API
NFlag..::..Item Property
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

NFlag Class
NFlag Members
DynamicNode.Core.Nodes Namespace


NFlag Events

[image] [image]

DynamicNodes API
NFlag Events
NFlag Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NFlag type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)

See Also

NFlag Class
DynamicNode.Core.Nodes Namespace


NSubGraph Class

[image]

DynamicNodes API
NSubGraph Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Kapselt ein DynamicNode-Sub-Graph als Knoten.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class NSubGraph : Node
Visual Basic
Public Class NSubGraph _
    Inherits Node
F#
type NSubGraph =
    class
        inherit Node
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core.Nodes..::..NSubGraph

See Also

NSubGraph Members
DynamicNode.Core.Nodes Namespace


NSubGraph Members

[image] [image]

DynamicNodes API
NSubGraph Members
NSubGraph Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph type exposes the following members.

Constructors

 | Name | Description
Public method | NSubGraph | Initialisiert eine NSubGraph-Instanz.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
 | GetNodeInfo | Gibt die Knoten-Info zurück.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | MakePathAbsolute | Macht den übergebenen Modulpfad absolut.
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Overrides Node..::..OnCommand(String).)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Overrides Node..::..OnDefaultCommand()()()().)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Overrides HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..OnDisposing()()()().)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Public method | OnOpen | Löst das Ereignis Open aus.
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. (Overrides Node..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. (Overrides Node..::..OnStore(IPropertyWriter).)
Protected method | OnSubGraphLoaded | Löst das Ereignis SubGraphLoaded aus.
Protected method | OnSubGraphLoading | Löst das Ereignis SubGraphLoading aus.
Protected method | OnSubGraphUnloaded | Löst das Ereignis SubGraphUnloaded aus.
Protected method | OnSubGraphUnloading | Löst das Ereignis SubGraphUnloading aus.
Public method | PrepareForLoadingModuleOnActivation | Bereitet den Sub-Graph-Knoten darauf vor, bei der nächsten Aktivierung die übergebene Datei als Modul zu laden.
Public method | ReloadModule |
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
 | TryMakePathRelative | Versucht den übergebenen Pfad relativ zur Benutzermodulbibliothek oder zur Systemmodulbibliothek zu machen.
Public method | Work | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides Node..::..Work()()()().)

Fields

Name | Description
SYSTEM_MODULE_PREFIX | Das Pfadpräfix für Pfade von Systemmodulen.
WORKSPACE_MODULE_PREFIX | Das Pfadpräfix für Pfade von Benutzermodulen.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | ModuleFile | Liest oder schreibt den Dateinamen der Modul-Datei.
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SubGraph | Gibt das geladenen Sub-Graph zurück, oder null.
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | Open | Tritt auf, wenn die Entwicklungsumgebung das Sub-Graph öffnen soll.
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | SubGraphLoaded | Tritt auf, wenn der Sub-Graph vollständig geladen und initialisiert ist.
Public event | SubGraphLoading | Tritt auf, wenn bevor ein Sub-Graph geladen wird.
Public event | SubGraphUnloaded | Tritt auf, wenn der Sub-Graph entladen wurde.
Public event | SubGraphUnloading | Tritt auf, bevor der Sub-Graph entladen wird.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


NSubGraph Constructor

[image]

DynamicNodes API
NSubGraph Constructor
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine NSubGraph-Instanz.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public NSubGraph()
Visual Basic
Public Sub New
F#
new : unit -> NSubGraph

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


NSubGraph Fields

[image] [image]

DynamicNodes API
NSubGraph Fields
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph type exposes the following members.

Fields

Name | Description
SYSTEM_MODULE_PREFIX | Das Pfadpräfix für Pfade von Systemmodulen.
WORKSPACE_MODULE_PREFIX | Das Pfadpräfix für Pfade von Benutzermodulen.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


SYSTEM_MODULE_PREFIX Field

[image]

DynamicNodes API
NSubGraph..::..SYSTEM_MODULE_PREFIX Field
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Pfadpräfix für Pfade von Systemmodulen.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static readonly string SYSTEM_MODULE_PREFIX
Visual Basic
Public Shared ReadOnly SYSTEM_MODULE_PREFIX As String
F#
static val SYSTEM_MODULE_PREFIX: string

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


WORKSPACE_MODULE_PREFIX Field

[image]

DynamicNodes API
NSubGraph..::..WORKSPACE_MODULE_PREFIX Field
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Pfadpräfix für Pfade von Benutzermodulen.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static readonly string WORKSPACE_MODULE_PREFIX
Visual Basic
Public Shared ReadOnly WORKSPACE_MODULE_PREFIX As String
F#
static val WORKSPACE_MODULE_PREFIX: string

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


NSubGraph Methods

[image] [image]

DynamicNodes API
NSubGraph Methods
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
 | GetNodeInfo | Gibt die Knoten-Info zurück.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | MakePathAbsolute | Macht den übergebenen Modulpfad absolut.
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Overrides Node..::..OnCommand(String).)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Overrides Node..::..OnDefaultCommand()()()().)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Overrides HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..OnDisposing()()()().)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Public method | OnOpen | Löst das Ereignis Open aus.
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. (Overrides Node..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. (Overrides Node..::..OnStore(IPropertyWriter).)
Protected method | OnSubGraphLoaded | Löst das Ereignis SubGraphLoaded aus.
Protected method | OnSubGraphLoading | Löst das Ereignis SubGraphLoading aus.
Protected method | OnSubGraphUnloaded | Löst das Ereignis SubGraphUnloaded aus.
Protected method | OnSubGraphUnloading | Löst das Ereignis SubGraphUnloading aus.
Public method | PrepareForLoadingModuleOnActivation | Bereitet den Sub-Graph-Knoten darauf vor, bei der nächsten Aktivierung die übergebene Datei als Modul zu laden.
Public method | ReloadModule |
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
 | TryMakePathRelative | Versucht den übergebenen Pfad relativ zur Benutzermodulbibliothek oder zur Systemmodulbibliothek zu machen.
Public method | Work | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides Node..::..Work()()()().)

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
NSubGraph..::..BeforeUseExtension Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

NSubGraph Class
NSubGraph Members
DynamicNode.Core.Nodes Namespace


Duplicate Method

[image] [image]

DynamicNodes API
NSubGraph..::..Duplicate Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

NSubGraph Class
NSubGraph Members
DynamicNode.Core.Nodes Namespace


GetNodeInfo Method

[image]

DynamicNodes API
NSubGraph..::..GetNodeInfo Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Knoten-Info zurück.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static NodeInfoAttribute GetNodeInfo()
Visual Basic
Public Shared Function GetNodeInfo As NodeInfoAttribute
F#
static member GetNodeInfo : unit -> NodeInfoAttribute

Return Value

Eine NodeInfoAttribute-Instanz.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


MakePathAbsolute Method

[image]

DynamicNodes API
NSubGraph..::..MakePathAbsolute Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Macht den übergebenen Modulpfad absolut.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string MakePathAbsolute(
    string modulePath,
    IConfiguration config
)
Visual Basic
Public Function MakePathAbsolute ( _
    modulePath As String, _
    config As IConfiguration _
) As String
F#
member MakePathAbsolute :
        modulePath:string *
        config:IConfiguration -> string

Parameters

modulePath
Type: System..::..String
Der potentiell relative Modulpfad.
config
Type: DynamicNode.Core..::..IConfiguration
Die Laufzeitumgebungskonfiguration.

Return Value

Einen absoluten Dateipfad für das Modul.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für confignull übergeben wird.
System..::..NotSupportedException | Wird geworfen, wenn sich der relative Pfad auf die Benutzermodulbibliothek bezieht, die Laufzeitumgebung aber ohne Arbeitsbereich gestartet wurde.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


OnCommand Method

[image]

DynamicNodes API
NSubGraph..::..OnCommand Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnCommand(
    string command
)
Visual Basic
Public Overrides Sub OnCommand ( _
    command As String _
)
F#
abstract OnCommand :
        command:string -> unit
override OnCommand :
        command:string -> unit

Parameters

command
Type: System..::..String
Der Befehls-Code des Benutzerbefehls.

Implements

INode..::..OnCommand(String)

Remarks

Diese Methode sollte von einer Klasse überschrieben werden, die einen oder mehrere Benutzerbefehle mit AddCommand(String, String) registriert hat.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


OnDefaultCommand Method

[image]

DynamicNodes API
NSubGraph..::..OnDefaultCommand Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnDefaultCommand()
Visual Basic
Public Overrides Sub OnDefaultCommand
F#
abstract OnDefaultCommand : unit -> unit
override OnDefaultCommand : unit -> unit

Implements

INode..::..OnDefaultCommand()()()()

Remarks

Diese Methode muss nicht überschrieben werden.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


OnDisposing Method

[image]

DynamicNodes API
NSubGraph..::..OnDisposing Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnDisposing()
Visual Basic
Protected Overrides Sub OnDisposing
F#
abstract OnDisposing : unit -> unit
override OnDisposing : unit -> unit

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


OnOpen Method

[image]

DynamicNodes API
NSubGraph..::..OnOpen Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Open aus.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void OnOpen()
Visual Basic
Public Overridable Sub OnOpen
F#
abstract OnOpen : unit -> unit
override OnOpen : unit -> unit

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


OnRestore Method

[image]

DynamicNodes API
NSubGraph..::..OnRestore Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Graph rekonstruiert wird.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overrides Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der IPropertyWriter mit dem benutzerdefinierte Eigenschaften des Knotens gespeichert werden können.

Implements

IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


OnStore Method

[image]

DynamicNodes API
NSubGraph..::..OnStore Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Graph gespeichert wird.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overrides Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der IPropertyWriter mit dem benutzerdefinierte Eigenschaften des Knotens gespeichert werden können.

Implements

IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


OnSubGraphLoaded Method

[image]

DynamicNodes API
NSubGraph..::..OnSubGraphLoaded Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis SubGraphLoaded aus.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnSubGraphLoaded()
Visual Basic
Protected Overridable Sub OnSubGraphLoaded
F#
abstract OnSubGraphLoaded : unit -> unit
override OnSubGraphLoaded : unit -> unit

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


OnSubGraphLoading Method

[image]

DynamicNodes API
NSubGraph..::..OnSubGraphLoading Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis SubGraphLoading aus.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnSubGraphLoading()
Visual Basic
Protected Overridable Sub OnSubGraphLoading
F#
abstract OnSubGraphLoading : unit -> unit
override OnSubGraphLoading : unit -> unit

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


OnSubGraphUnloaded Method

[image]

DynamicNodes API
NSubGraph..::..OnSubGraphUnloaded Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis SubGraphUnloaded aus.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnSubGraphUnloaded()
Visual Basic
Protected Overridable Sub OnSubGraphUnloaded
F#
abstract OnSubGraphUnloaded : unit -> unit
override OnSubGraphUnloaded : unit -> unit

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


OnSubGraphUnloading Method

[image]

DynamicNodes API
NSubGraph..::..OnSubGraphUnloading Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis SubGraphUnloading aus.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnSubGraphUnloading()
Visual Basic
Protected Overridable Sub OnSubGraphUnloading
F#
abstract OnSubGraphUnloading : unit -> unit
override OnSubGraphUnloading : unit -> unit

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


PrepareForLoadingModuleOnActivation Method

[image]

DynamicNodes API
NSubGraph..::..PrepareForLoadingModuleOnActivation Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bereitet den Sub-Graph-Knoten darauf vor, bei der nächsten Aktivierung die übergebene Datei als Modul zu laden.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void PrepareForLoadingModuleOnActivation(
    string file
)
Visual Basic
Public Sub PrepareForLoadingModuleOnActivation ( _
    file As String _
)
F#
member PrepareForLoadingModuleOnActivation :
        file:string -> unit

Parameters

file
Type: System..::..String
Der Pfad zu einer Modul-Datei.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


ReloadModule Method

[image]

DynamicNodes API
NSubGraph..::..ReloadModule Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "M:DynamicNode.Core.Nodes.NSubGraph.ReloadModule"]

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ReloadModule()
Visual Basic
Public Sub ReloadModule
F#
member ReloadModule : unit -> unit

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


TraceError Method

[image] [image]

DynamicNodes API
NSubGraph..::..TraceError Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph Class
NSubGraph Members
DynamicNode.Core.Nodes Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
NSubGraph..::..TraceInfo Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph Class
NSubGraph Members
DynamicNode.Core.Nodes Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
NSubGraph..::..TraceVerbose Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph Class
NSubGraph Members
DynamicNode.Core.Nodes Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
NSubGraph..::..TraceVerboseData Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph Class
NSubGraph Members
DynamicNode.Core.Nodes Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
NSubGraph..::..TraceWarning Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph Class
NSubGraph Members
DynamicNode.Core.Nodes Namespace


TryMakePathRelative Method

[image]

DynamicNodes API
NSubGraph..::..TryMakePathRelative Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht den übergebenen Pfad relativ zur Benutzermodulbibliothek oder zur Systemmodulbibliothek zu machen.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string TryMakePathRelative(
    string filePath,
    IConfiguration config
)
Visual Basic
Public Shared Function TryMakePathRelative ( _
    filePath As String, _
    config As IConfiguration _
) As String
F#
static member TryMakePathRelative :
        filePath:string *
        config:IConfiguration -> string

Parameters

filePath
Type: System..::..String
Der Pfad zu einer Projektdatei.
config
Type: DynamicNode.Core..::..IConfiguration
Die Laufzeitumgebungskonfiguration.

Return Value

Der evtl. relativierte Pfad.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für confignull übergeben wird.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


Work Method

[image]

DynamicNodes API
NSubGraph..::..Work Method
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void Work()
Visual Basic
Public Overrides Sub Work
F#
abstract Work : unit -> unit
override Work : unit -> unit

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


NSubGraph Properties

[image] [image]

DynamicNodes API
NSubGraph Properties
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | ModuleFile | Liest oder schreibt den Dateinamen der Modul-Datei.
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SubGraph | Gibt das geladenen Sub-Graph zurück, oder null.
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


Item Property

[image] [image]

DynamicNodes API
NSubGraph..::..Item Property
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

NSubGraph Class
NSubGraph Members
DynamicNode.Core.Nodes Namespace


ModuleFile Property

[image]

DynamicNodes API
NSubGraph..::..ModuleFile Property
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Dateinamen der Modul-Datei.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string ModuleFile { get; set; }
Visual Basic
Public Property ModuleFile As String
    Get
    Set
F#
member ModuleFile : string with get, set

Field Value

Die Modul-Datei.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


SubGraph Property

[image]

DynamicNodes API
NSubGraph..::..SubGraph Property
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das geladenen Sub-Graph zurück, oder null.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IGraph SubGraph { get; private set; }
Visual Basic
Public Property SubGraph As IGraph
    Get
    Private Set
F#
member SubGraph : IGraph with get, private set

Field Value

Das Sub-Graph.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


NSubGraph Events

[image] [image]

DynamicNodes API
NSubGraph Events
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | Open | Tritt auf, wenn die Entwicklungsumgebung das Sub-Graph öffnen soll.
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | SubGraphLoaded | Tritt auf, wenn der Sub-Graph vollständig geladen und initialisiert ist.
Public event | SubGraphLoading | Tritt auf, wenn bevor ein Sub-Graph geladen wird.
Public event | SubGraphUnloaded | Tritt auf, wenn der Sub-Graph entladen wurde.
Public event | SubGraphUnloading | Tritt auf, bevor der Sub-Graph entladen wird.

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


Open Event

[image]

DynamicNodes API
NSubGraph..::..Open Event
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn die Entwicklungsumgebung das Sub-Graph öffnen soll.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler Open
Visual Basic
Public Event Open As EventHandler
F#
member Open : IEvent<EventHandler,
    EventArgs>

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


SubGraphLoaded Event

[image]

DynamicNodes API
NSubGraph..::..SubGraphLoaded Event
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn der Sub-Graph vollständig geladen und initialisiert ist.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler SubGraphLoaded
Visual Basic
Public Event SubGraphLoaded As EventHandler
F#
member SubGraphLoaded : IEvent<EventHandler,
    EventArgs>

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


SubGraphLoading Event

[image]

DynamicNodes API
NSubGraph..::..SubGraphLoading Event
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn bevor ein Sub-Graph geladen wird.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler SubGraphLoading
Visual Basic
Public Event SubGraphLoading As EventHandler
F#
member SubGraphLoading : IEvent<EventHandler,
    EventArgs>

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


SubGraphUnloaded Event

[image]

DynamicNodes API
NSubGraph..::..SubGraphUnloaded Event
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn der Sub-Graph entladen wurde.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler SubGraphUnloaded
Visual Basic
Public Event SubGraphUnloaded As EventHandler
F#
member SubGraphUnloaded : IEvent<EventHandler,
    EventArgs>

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


SubGraphUnloading Event

[image]

DynamicNodes API
NSubGraph..::..SubGraphUnloading Event
NSubGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, bevor der Sub-Graph entladen wird.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler SubGraphUnloading
Visual Basic
Public Event SubGraphUnloading As EventHandler
F#
member SubGraphUnloading : IEvent<EventHandler,
    EventArgs>

See Also

NSubGraph Class
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingInPort Class

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort Class
NSubGraph Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Kapselt den Super-Eingang eines Sub-Graphen.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class WrappingInPort : InPort
Visual Basic
Public Class WrappingInPort _
    Inherits InPort
F#
type WrappingInPort =
    class
        inherit InPort
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' IPort >)>)>
DynamicNode.Model..::..ChildObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Core..::..Port
DynamicNode.Core..::..InPort
DynamicNode.Core.Nodes..::..NSubGraph..::..WrappingInPort

See Also

NSubGraph..::..WrappingInPort Members
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingInPort Members

[image] [image]

DynamicNodes API
NSubGraph..::..WrappingInPort Members
NSubGraph..::..WrappingInPort Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Kapselt ein DynamicNode-Sub-Graph als Knoten.

The NSubGraph..::..WrappingInPort type exposes the following members.

Constructors

 | Name | Description
Public method | NSubGraph..::..WrappingInPort | Initialisiert eine neue Instanz von NSubGraph..::..WrappingInPort.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Verbindet einen Ausgangs-Port mit diesem Eingangs-Port. (Overrides InPort..::..Connect(OutPort, Type).)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Ausgang, falls eine solche Verbindung besteht. (Overrides InPort..::..Disconnect()()()().)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Overrides InPort..::..GetCurrentValue<(Of <<'(T>)>>)(T).)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Overrides InPort..::..GetCurrentValue<(Of <<'(T>)>>)(T, Boolean).)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Overrides InPort..::..IsConnectableTo(IPort, Type%).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem die unterstützten Datentypen geändert wurden. Falls eine Verbindung besteht wird erneut geprüft welcher Datentyp optimal ist. Falls ein anderer Datentyp als der zur Zeit ausgewählte optimal ist, wird der optimale Datentyp ausgewählt. Falls die Verbindung ungültig ist, wird sie getrennt. (Overrides InPort..::..NotifyTypeSupportChanged()()()().)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnCurrentTokenChanged | Wird aufgerufen, wenn das Ereignis CurrentTokenChanged ausgelöst werden soll. (Inherited from InPort.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from InPort.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from InPort.)
Protected method | OnSupportedDataTypeChanged | Wird aufgerufen wenn der für die aktuelle Verbindung ausgewählte Datentyp geändert wurde. Löst das Ereignis SupportedDataTypeChanged aus. (Inherited from InPort.)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | PrepareNextToken | Bereitet den Eingang auf die nächste Arbeitsphase des Knotens vor. Falls ein Queue vorhanden ist, wird dazu das nächste Token aus dem Queue geholt. (Inherited from InPort.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from InPort.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Inherited from InPort.)
Public method | UpdateToken | Aktualisiert den Wert des Ports und setzt den Wert-Zustand auf Valid. Dabei wird das Ereignis TokenUpdate ausgelöst. (Overrides InPort..::..UpdateToken(Token).)

Properties

 | Name | Description
Public property | CanHaveQueue | Liest oder schreibt einen Wert, der angibt ob dieser Eingang eine Queue haben darf. (Overrides InPort..::..CanHaveQueue.)
Public property | Capacity | Liest oder schreibt die Kapazität der evtl. vorhandenen Queue. (Inherited from InPort.)
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Eingangs-Ports zu anderen Ausgangs-Ports angepasst werden kann. (Overrides InPort..::..CompatibilityChecker.)
Public property | ConnectedOutPort | Gibt den verbundenen Ausgangs-Port zurück der mit diesem Eingangs-Port verbunden ist, oder null, wenn keine Verbindung besteht. (Overrides InPort..::..ConnectedOutPort.)
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from InPort.)
Public property | CurrentToken | Gibt das Token zurück, welches für den aktuellen Arbeitsschritt verwendet werden soll. (Overrides InPort..::..CurrentToken.)
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Eingang. (Inherited from InPort.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | HasQueue | Liest oder schreibt einen Wert der angibt ob diese Instanz eine Queue besitzt. (Overrides InPort..::..HasQueue.)
Public property | HasWaitingToken | Gibt einen Wert zurück, der angibt ob der nächste Aufruf von PrepareNextToken()()()() ein neues Token zur Verarbeitung bereitstellt oder nicht. (Overrides InPort..::..HasWaitingToken.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsConnected | Prüft, ob diese Instanz mit einem Ausgangs-Port verbunden ist. (Overrides InPort..::..IsConnected.)
Public property | IsCurrentTokenNew | Gibt einen Wert zurück der angibt, ob das aktuelle Token neu ist. (Overrides InPort..::..IsCurrentTokenNew.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsMandatory | Gibt einen Wert zurück oder legt ihn fest, der angibt ob der Eingang mit einem Token belegt werden muss, damit der Knoten arbeiten kann. (Inherited from InPort.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedDataType | Gibt den für die aktuelle Verbindung ausgewählten Datentyp zurück, oder legt ihn fest. (Overrides InPort..::..SupportedDataType.)
Public property | SupportedTypes | Gibt eine Liste mit allen unterstützten Datentypen zurück. Falls ein Daten-Typ-Provider eingerichtet ist, wird dessen Liste zurückgegeben. (Overrides InPort..::..SupportedTypes.)
Public property | UpdateWithNotSetAtDisconnect | Liest oder schreibt einen Wert, der angibt ob der Eingang mit einem Token 'NotSet' belegt werden soll, sobald die Verbindung getrennt wird. (Overrides InPort..::..UpdateWithNotSetAtDisconnect.)
Public property | WrappedInPort | Gibt den gekapselten Eingang zurück.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | CurrentTokenChanged | Wird ausgelöst, wenn das aktuelle Token zur Verarbeitung geändert wird. (Inherited from InPort.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn der ausgewählte Datentyp für die Verbindung geändert wird. (Inherited from InPort.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingInPort Constructor

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort Constructor
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von NSubGraph..::..WrappingInPort.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public WrappingInPort(
    NSubGraph parent,
    InPort sIP
)
Visual Basic
Public Sub New ( _
    parent As NSubGraph, _
    sIP As InPort _
)
F#
new :
        parent:NSubGraph *
        sIP:InPort -> WrappingInPort

Parameters

parent
Type: DynamicNode.Core.Nodes..::..NSubGraph
Der Elternknoten.
sIP
Type: DynamicNode.Core..::..InPort
Der zu kapselende Super-Eingang.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingInPort Methods

[image] [image]

DynamicNodes API
NSubGraph..::..WrappingInPort Methods
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph..::..WrappingInPort type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Verbindet einen Ausgangs-Port mit diesem Eingangs-Port. (Overrides InPort..::..Connect(OutPort, Type).)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Ausgang, falls eine solche Verbindung besteht. (Overrides InPort..::..Disconnect()()()().)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Overrides InPort..::..GetCurrentValue<(Of <<'(T>)>>)(T).)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Overrides InPort..::..GetCurrentValue<(Of <<'(T>)>>)(T, Boolean).)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Overrides InPort..::..IsConnectableTo(IPort, Type%).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem die unterstützten Datentypen geändert wurden. Falls eine Verbindung besteht wird erneut geprüft welcher Datentyp optimal ist. Falls ein anderer Datentyp als der zur Zeit ausgewählte optimal ist, wird der optimale Datentyp ausgewählt. Falls die Verbindung ungültig ist, wird sie getrennt. (Overrides InPort..::..NotifyTypeSupportChanged()()()().)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnCurrentTokenChanged | Wird aufgerufen, wenn das Ereignis CurrentTokenChanged ausgelöst werden soll. (Inherited from InPort.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from InPort.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from InPort.)
Protected method | OnSupportedDataTypeChanged | Wird aufgerufen wenn der für die aktuelle Verbindung ausgewählte Datentyp geändert wurde. Löst das Ereignis SupportedDataTypeChanged aus. (Inherited from InPort.)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | PrepareNextToken | Bereitet den Eingang auf die nächste Arbeitsphase des Knotens vor. Falls ein Queue vorhanden ist, wird dazu das nächste Token aus dem Queue geholt. (Inherited from InPort.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from InPort.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Inherited from InPort.)
Public method | UpdateToken | Aktualisiert den Wert des Ports und setzt den Wert-Zustand auf Valid. Dabei wird das Ereignis TokenUpdate ausgelöst. (Overrides InPort..::..UpdateToken(Token).)

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
WrappingInPort..::..BeforeUseExtension Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

NSubGraph..::..WrappingInPort Class
NSubGraph..::..WrappingInPort Members
DynamicNode.Core.Nodes Namespace


Connect Method

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..Connect Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verbindet einen Ausgangs-Port mit diesem Eingangs-Port.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void Connect(
    OutPort outPort,
    Type typeSelection
)
Visual Basic
Public Overrides Sub Connect ( _
    outPort As OutPort, _
    typeSelection As Type _
)
F#
abstract Connect :
        outPort:OutPort *
        typeSelection:Type -> unit
override Connect :
        outPort:OutPort *
        typeSelection:Type -> unit

Parameters

outPort
Type: DynamicNode.Core..::..OutPort
Ein Ausgangs-Port.
typeSelection
Type: System..::..Type
Der Datentyp, auf dem die Verbindung beruht.

Remarks

Ruft Connect(InPort, Type) auf.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


Disconnect Method

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..Disconnect Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Trennt die Verbindung zu einem Ausgang, falls eine solche Verbindung besteht.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void Disconnect()
Visual Basic
Public Overrides Sub Disconnect
F#
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit

Remarks

Ruft Disconnect(InPort) auf.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


GetCurrentValue Method

[image] [image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..GetCurrentValue Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T) | Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Overrides InPort..::..GetCurrentValue<(Of <<'(T>)>>)(T).)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Inherited from InPort.)
Public method | GetCurrentValue<(Of <<'(T>)>>)(T, Boolean) | Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben. (Overrides InPort..::..GetCurrentValue<(Of <<'(T>)>>)(T, Boolean).)

See Also

NSubGraph..::..WrappingInPort Class
NSubGraph..::..WrappingInPort Members
DynamicNode.Core.Nodes Namespace


GetCurrentValue(T) Method (T)

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..GetCurrentValue<(Of <(<'T>)>)> Method (T)
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuellen Wert in einem bestimmten Typ zurück. Wenn der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override T GetCurrentValue<T>(
    T def
)
Visual Basic
Public Overrides Function GetCurrentValue(Of T) ( _
    def As T _
) As T
F#
abstract GetCurrentValue :
        def:'T -> 'T
override GetCurrentValue :
        def:'T -> 'T

Parameters

def
Type: T
Der Standardwert.

Type Parameters

T
Der Typ des erwarteten Wertes.

Return Value

Ein sicherer Wert.

Exceptions

Exception | Condition
System..::..InvalidCastException | Wird geworfen, wenn der Token-Wert nicht in den Typ T umgewandelt werden kann.

See Also

NSubGraph..::..WrappingInPort Class
GetCurrentValue Overload
DynamicNode.Core.Nodes Namespace


GetCurrentValue(T) Method (T, Boolean)

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..GetCurrentValue<(Of <(<'T>)>)> Method (T, Boolean)
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuellen Wert zurück. Wenn mustBeValid gleich true und der aktuelle Token-Status nicht Valid oder wenn mustBeValid == false und der aktuelle Token-Status NotSet ist, wird def zurückgegeben. Wenn der Typ T kein Referenz-Typ ist und der Token-Wert null ist, wird def zurückgegeben.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override T GetCurrentValue<T>(
    T def,
    bool mustBeValid
)
Visual Basic
Public Overrides Function GetCurrentValue(Of T) ( _
    def As T, _
    mustBeValid As Boolean _
) As T
F#
abstract GetCurrentValue :
        def:'T *
        mustBeValid:bool -> 'T
override GetCurrentValue :
        def:'T *
        mustBeValid:bool -> 'T

Parameters

def
Type: T
Der Standardwert.
mustBeValid
Type: System..::..Boolean
Wenn true übergeben wird, muss der aktuelle Token-Status Valid sein, damit der Token-Wert zurückgegeben werden darf.

Type Parameters

T
Der Typ des erwarteten Wertes.

Return Value

Ein sicherer Wert.

Exceptions

Exception | Condition
System..::..InvalidCastException | Wird geworfen, wenn der Token-Wert nicht in den Typ T umgewandelt werden kann.

See Also

NSubGraph..::..WrappingInPort Class
GetCurrentValue Overload
DynamicNode.Core.Nodes Namespace


IsConnectableTo Method

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..IsConnectableTo Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob dieser Port mit einem anderem Port verbunden werden kann.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool IsConnectableTo(
    IPort port,
    out Type possibleTypeSelection
)
Visual Basic
Public Overrides Function IsConnectableTo ( _
    port As IPort, _
    <OutAttribute> ByRef possibleTypeSelection As Type _
) As Boolean
F#
abstract IsConnectableTo :
        port:IPort *
        possibleTypeSelection:Type byref -> bool
override IsConnectableTo :
        port:IPort *
        possibleTypeSelection:Type byref -> bool

Parameters

port
Type: DynamicNode.Core..::..IPort
Der andere Port.
possibleTypeSelection
Type: System..::..Type %
Wird mit dem ausgewählten Datentyp belegt, oder null, wenn der Rückgabewert false ist.

Return Value

true, wenn eine Verbindung mit dem anderen Port möglich ist, sonst false.

Implements

IPort..::..IsConnectableTo(IPort, Type%)

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


NotifyTypeSupportChanged Method

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..NotifyTypeSupportChanged Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Muss aufgerufen werden, nachdem die unterstützten Datentypen geändert wurden.
Falls eine Verbindung besteht wird erneut geprüft welcher Datentyp optimal ist. Falls ein anderer Datentyp als der zur Zeit ausgewählte optimal ist, wird der optimale Datentyp ausgewählt. Falls die Verbindung ungültig ist, wird sie getrennt.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void NotifyTypeSupportChanged()
Visual Basic
Public Overrides Sub NotifyTypeSupportChanged
F#
abstract NotifyTypeSupportChanged : unit -> unit
override NotifyTypeSupportChanged : unit -> unit

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


TraceError Method

[image] [image]

DynamicNodes API
WrappingInPort..::..TraceError Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph..::..WrappingInPort Class
NSubGraph..::..WrappingInPort Members
DynamicNode.Core.Nodes Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
WrappingInPort..::..TraceInfo Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph..::..WrappingInPort Class
NSubGraph..::..WrappingInPort Members
DynamicNode.Core.Nodes Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
WrappingInPort..::..TraceVerbose Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph..::..WrappingInPort Class
NSubGraph..::..WrappingInPort Members
DynamicNode.Core.Nodes Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
WrappingInPort..::..TraceVerboseData Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph..::..WrappingInPort Class
NSubGraph..::..WrappingInPort Members
DynamicNode.Core.Nodes Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
WrappingInPort..::..TraceWarning Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph..::..WrappingInPort Class
NSubGraph..::..WrappingInPort Members
DynamicNode.Core.Nodes Namespace


UpdateToken Method

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..UpdateToken Method
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert den Wert des Ports und setzt den Wert-Zustand auf Valid. Dabei wird das Ereignis TokenUpdate ausgelöst.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void UpdateToken(
    Token token
)
Visual Basic
Public Overrides Sub UpdateToken ( _
    token As Token _
)
F#
abstract UpdateToken :
        token:Token -> unit
override UpdateToken :
        token:Token -> unit

Parameters

token
Type: DynamicNode.Core..::..Token
Das neue Token

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingInPort Properties

[image] [image]

DynamicNodes API
NSubGraph..::..WrappingInPort Properties
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph..::..WrappingInPort type exposes the following members.

Properties

 | Name | Description
Public property | CanHaveQueue | Liest oder schreibt einen Wert, der angibt ob dieser Eingang eine Queue haben darf. (Overrides InPort..::..CanHaveQueue.)
Public property | Capacity | Liest oder schreibt die Kapazität der evtl. vorhandenen Queue. (Inherited from InPort.)
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Eingangs-Ports zu anderen Ausgangs-Ports angepasst werden kann. (Overrides InPort..::..CompatibilityChecker.)
Public property | ConnectedOutPort | Gibt den verbundenen Ausgangs-Port zurück der mit diesem Eingangs-Port verbunden ist, oder null, wenn keine Verbindung besteht. (Overrides InPort..::..ConnectedOutPort.)
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from InPort.)
Public property | CurrentToken | Gibt das Token zurück, welches für den aktuellen Arbeitsschritt verwendet werden soll. (Overrides InPort..::..CurrentToken.)
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Eingang. (Inherited from InPort.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | HasQueue | Liest oder schreibt einen Wert der angibt ob diese Instanz eine Queue besitzt. (Overrides InPort..::..HasQueue.)
Public property | HasWaitingToken | Gibt einen Wert zurück, der angibt ob der nächste Aufruf von PrepareNextToken()()()() ein neues Token zur Verarbeitung bereitstellt oder nicht. (Overrides InPort..::..HasWaitingToken.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsConnected | Prüft, ob diese Instanz mit einem Ausgangs-Port verbunden ist. (Overrides InPort..::..IsConnected.)
Public property | IsCurrentTokenNew | Gibt einen Wert zurück der angibt, ob das aktuelle Token neu ist. (Overrides InPort..::..IsCurrentTokenNew.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsMandatory | Gibt einen Wert zurück oder legt ihn fest, der angibt ob der Eingang mit einem Token belegt werden muss, damit der Knoten arbeiten kann. (Inherited from InPort.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedDataType | Gibt den für die aktuelle Verbindung ausgewählten Datentyp zurück, oder legt ihn fest. (Overrides InPort..::..SupportedDataType.)
Public property | SupportedTypes | Gibt eine Liste mit allen unterstützten Datentypen zurück. Falls ein Daten-Typ-Provider eingerichtet ist, wird dessen Liste zurückgegeben. (Overrides InPort..::..SupportedTypes.)
Public property | UpdateWithNotSetAtDisconnect | Liest oder schreibt einen Wert, der angibt ob der Eingang mit einem Token 'NotSet' belegt werden soll, sobald die Verbindung getrennt wird. (Overrides InPort..::..UpdateWithNotSetAtDisconnect.)
Public property | WrappedInPort | Gibt den gekapselten Eingang zurück.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


CanHaveQueue Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..CanHaveQueue Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob dieser Eingang eine Queue haben darf.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool CanHaveQueue { get; }
Visual Basic
Public Overrides ReadOnly Property CanHaveQueue As Boolean
    Get
F#
abstract CanHaveQueue : bool
override CanHaveQueue : bool

Field Value

true wenn dieser Eingang eine Queue besitzen darf, sonst false.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


CompatibilityChecker Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..CompatibilityChecker Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Eingangs-Ports zu anderen Ausgangs-Ports angepasst werden kann.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override CompatibilityChecker<OutPort> CompatibilityChecker { get; set; }
Visual Basic
Public Overrides Property CompatibilityChecker As CompatibilityChecker(Of OutPort)
    Get
    Set
F#
abstract CompatibilityChecker : CompatibilityChecker<OutPort> with get, set
override CompatibilityChecker : CompatibilityChecker<OutPort> with get, set

Field Value

Der Kompatibilitäts-Checker.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace
NSubGraph..::..WrappingInPort..::..CompatibilityChecker


ConnectedOutPort Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..ConnectedOutPort Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den verbundenen Ausgangs-Port zurück der mit diesem Eingangs-Port verbunden ist, oder null, wenn keine Verbindung besteht.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override OutPort ConnectedOutPort { get; }
Visual Basic
Public Overrides ReadOnly Property ConnectedOutPort As OutPort
    Get
F#
abstract ConnectedOutPort : OutPort
override ConnectedOutPort : OutPort

Field Value

Der verbundene Ausgangs-Port.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


CurrentToken Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..CurrentToken Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Token zurück, welches für den aktuellen Arbeitsschritt verwendet werden soll.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override Token CurrentToken { get; }
Visual Basic
Public Overrides ReadOnly Property CurrentToken As Token
    Get
F#
abstract CurrentToken : Token
override CurrentToken : Token

Field Value

Das aktuelle Token.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


HasQueue Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..HasQueue Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert der angibt ob diese Instanz eine Queue besitzt.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool HasQueue { get; set; }
Visual Basic
Public Overrides Property HasQueue As Boolean
    Get
    Set
F#
abstract HasQueue : bool with get, set
override HasQueue : bool with get, set

Field Value

true wenn diese Instanz eine Queue besitzt, sonst false.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


HasWaitingToken Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..HasWaitingToken Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob der nächste Aufruf von PrepareNextToken()()()() ein neues Token zur Verarbeitung bereitstellt oder nicht.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool HasWaitingToken { get; }
Visual Basic
Public Overrides ReadOnly Property HasWaitingToken As Boolean
    Get
F#
abstract HasWaitingToken : bool
override HasWaitingToken : bool

Field Value

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


IsConnected Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..IsConnected Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob diese Instanz mit einem Ausgangs-Port verbunden ist.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool IsConnected { get; }
Visual Basic
Public Overrides ReadOnly Property IsConnected As Boolean
    Get
F#
abstract IsConnected : bool
override IsConnected : bool

Field Value

true, wenn diese Instanz mit einem Ausgangs-Port verbunden ist, sonst false.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


IsCurrentTokenNew Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..IsCurrentTokenNew Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück der angibt, ob das aktuelle Token neu ist.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool IsCurrentTokenNew { get; }
Visual Basic
Public Overrides ReadOnly Property IsCurrentTokenNew As Boolean
    Get
F#
abstract IsCurrentTokenNew : bool
override IsCurrentTokenNew : bool

Field Value

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


SupportedDataType Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..SupportedDataType Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den für die aktuelle Verbindung ausgewählten Datentyp zurück, oder legt ihn fest.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override Type SupportedDataType { get; internal set; }
Visual Basic
Public Overrides Property SupportedDataType As Type
    Get
    Friend Set
F#
abstract SupportedDataType : Type with get, internal set
override SupportedDataType : Type with get, internal set

Field Value

Der aktuelle Datentyp, oder null, wenn keine Verbindung besteht.

Implements

IOutPortDataTypeProvider..::..SupportedDataType

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


SupportedTypes Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..SupportedTypes Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Liste mit allen unterstützten Datentypen zurück. Falls ein Daten-Typ-Provider eingerichtet ist, wird dessen Liste zurückgegeben.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override Type[] SupportedTypes { get; }
Visual Basic
Public Overrides ReadOnly Property SupportedTypes As Type()
    Get
F#
abstract SupportedTypes : Type[]
override SupportedTypes : Type[]

Field Value

Alle unterstützten Datentypen.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


UpdateWithNotSetAtDisconnect Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..UpdateWithNotSetAtDisconnect Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob der Eingang mit einem Token 'NotSet' belegt werden soll, sobald die Verbindung getrennt wird.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool UpdateWithNotSetAtDisconnect { get; set; }
Visual Basic
Public Overrides Property UpdateWithNotSetAtDisconnect As Boolean
    Get
    Set
F#
abstract UpdateWithNotSetAtDisconnect : bool with get, set
override UpdateWithNotSetAtDisconnect : bool with get, set

Field Value

true wenn der Eingang mit einem Token 'NotSet' belegt werden soll, sobald die Verbindung getrennt wird, sonst false.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


WrappedInPort Property

[image]

DynamicNodes API
NSubGraph..::..WrappingInPort..::..WrappedInPort Property
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den gekapselten Eingang zurück.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public InPort WrappedInPort { get; }
Visual Basic
Public ReadOnly Property WrappedInPort As InPort
    Get
F#
member WrappedInPort : InPort

Field Value

Der gekapselte Super-Eingang.

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingInPort Events

[image] [image]

DynamicNodes API
NSubGraph..::..WrappingInPort Events
NSubGraph..::..WrappingInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph..::..WrappingInPort type exposes the following members.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | CurrentTokenChanged | Wird ausgelöst, wenn das aktuelle Token zur Verarbeitung geändert wird. (Inherited from InPort.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | SupportedDataTypeChanged | Wird ausgelöst, wenn der ausgewählte Datentyp für die Verbindung geändert wird. (Inherited from InPort.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)

See Also

NSubGraph..::..WrappingInPort Class
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingOutPort Class

[image]

DynamicNodes API
NSubGraph..::..WrappingOutPort Class
NSubGraph Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Kapselt den Super-Ausgang eines Sub-Graphen.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class WrappingOutPort : OutPort
Visual Basic
Public Class WrappingOutPort _
    Inherits OutPort
F#
type WrappingOutPort =
    class
        inherit OutPort
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' IPort >)>)>
DynamicNode.Model..::..ChildObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Core..::..Port
DynamicNode.Core..::..OutPort
DynamicNode.Core.Nodes..::..NSubGraph..::..WrappingOutPort

See Also

NSubGraph..::..WrappingOutPort Members
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingOutPort Members

[image] [image]

DynamicNodes API
NSubGraph..::..WrappingOutPort Members
NSubGraph..::..WrappingOutPort Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Kapselt ein DynamicNode-Sub-Graph als Knoten.

The NSubGraph..::..WrappingOutPort type exposes the following members.

Constructors

 | Name | Description
Public method | NSubGraph..::..WrappingOutPort | Initialisiert eine neue Instanz von NSubGraph..::..WrappingOutPort.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Stellt eine Verbindung zu einen Eingangs-Port her. (Inherited from OutPort.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Eingangs-Port. (Inherited from OutPort.)
Public method | DisconnectAll | Trennt alle Verbindungen dieses Ausgangs-Ports. (Inherited from OutPort.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Fire | Gibt das Token an die verbundenen Eingänge weiter. (Inherited from OutPort.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Overrides OutPort..::..IsConnectableTo(IPort, Type%).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem der unterstützte Datentyp geändert wurden. Falls Verbindungen bestehen wird erneut geprüft ob Verbindungen gültig sind. Falls die Verbindung ungüötig ist, wird sie getrennt. (Inherited from OutPort.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from Port.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from Port.)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from OutPort.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Inherited from OutPort.)
Public method | UpdateToken(Object) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet, das Token gehört keinem Stream an. (Inherited from OutPort.)
Public method | UpdateToken(Token) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)
Public method | UpdateToken(TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet, das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet. (Inherited from OutPort.)
Public method | UpdateToken(TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)
Public method | UpdateTokenNotSet()()()() | Belegt den Ausgang mit einem lehren Token welches zu keinem Stream gehört. (Inherited from OutPort.)
Public method | UpdateTokenNotSet(Stream, Int64) | Belegt den Ausgang mit einem lehren Token. (Inherited from OutPort.)

Properties

 | Name | Description
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Ausgangs-Ports zu anderen Eingangs-Ports angepasst werden kann. (Overrides OutPort..::..CompatibilityChecker.)
Public property | ConnectedPorts | Gibt ein Array mit allen verbundenen Eingängen zurück. (Inherited from OutPort.)
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from OutPort.)
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Ausgang. (Inherited from OutPort.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | NeedToFire | Gibt einen Wert zurück, der angibt, ob der Ausgang mit einem Token belegt ist, welches noch nicht gefeuert wurde. (Inherited from OutPort.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedType | Gibt den unterstützten Datentyp des Ausgangs zurück. (Overrides OutPort..::..SupportedType.)
Public property | WrappedOutPort | Gibt den gekapselten Super-Ausgang zurück.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | Fired | Tritt auf, wenn das aktuelle Token an die verbundenen Eingänge weitergegeben wurde. (Inherited from OutPort.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)
Public event | TypeSupportChanged | Wird ausgelöst, wenn der Datentyp des Ausgangs geändert wurde und alle ausgehenden Verbindungen neu verhandelt werden müssen. (Inherited from OutPort.)

See Also

NSubGraph..::..WrappingOutPort Class
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingOutPort Constructor

[image]

DynamicNodes API
NSubGraph..::..WrappingOutPort Constructor
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von NSubGraph..::..WrappingOutPort.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public WrappingOutPort(
    INode parent,
    OutPort sOP
)
Visual Basic
Public Sub New ( _
    parent As INode, _
    sOP As OutPort _
)
F#
new :
        parent:INode *
        sOP:OutPort -> WrappingOutPort

Parameters

parent
Type: DynamicNode.Core..::..INode
Der Elternknoten.
sOP
Type: DynamicNode.Core..::..OutPort
Der zu kapselnde Super-Ausgang.

See Also

NSubGraph..::..WrappingOutPort Class
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingOutPort Methods

[image] [image]

DynamicNodes API
NSubGraph..::..WrappingOutPort Methods
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph..::..WrappingOutPort type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Connect | Stellt eine Verbindung zu einen Eingangs-Port her. (Inherited from OutPort.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Disconnect | Trennt die Verbindung zu einem Eingangs-Port. (Inherited from OutPort.)
Public method | DisconnectAll | Trennt alle Verbindungen dieses Ausgangs-Ports. (Inherited from OutPort.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Fire | Gibt das Token an die verbundenen Eingänge weiter. (Inherited from OutPort.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Port identifiziert. (Inherited from Port.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsConnectableTo | Prüft, ob dieser Port mit einem anderem Port verbunden werden kann. (Overrides OutPort..::..IsConnectableTo(IPort, Type%).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | NotifyTypeSupportChanged | Muss aufgerufen werden, nachdem der unterstützte Datentyp geändert wurden. Falls Verbindungen bestehen wird erneut geprüft ob Verbindungen gültig sind. Falls die Verbindung ungüötig ist, wird sie getrennt. (Inherited from OutPort.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnConnectionChange | Wird aufgerufen wenn sich die Anzahl der Verbindungen geändert hat. (Inherited from Port.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from Port.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from Port.)
Protected method | OnUpdate | Wird aufgerufen, wenn der Port ein neues Token bekommt. Diese Methode aktualisiert die Lese-Kopie und löst das Ereignis TokenUpdate aus. (Inherited from Port.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from OutPort.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TryConnect | Versucht eine Verbindung zum übergebene Anschluss aufzubauen. Liefert einen Wahrheitswert zurück, der angibt ob die Verbindung zustande kam. (Inherited from OutPort.)
Public method | UpdateToken(Object) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet, das Token gehört keinem Stream an. (Inherited from OutPort.)
Public method | UpdateToken(Token) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)
Public method | UpdateToken(TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet, das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet. (Inherited from OutPort.)
Public method | UpdateToken(TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)
Public method | UpdateTokenNotSet()()()() | Belegt den Ausgang mit einem lehren Token welches zu keinem Stream gehört. (Inherited from OutPort.)
Public method | UpdateTokenNotSet(Stream, Int64) | Belegt den Ausgang mit einem lehren Token. (Inherited from OutPort.)

See Also

NSubGraph..::..WrappingOutPort Class
DynamicNode.Core.Nodes Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
WrappingOutPort..::..BeforeUseExtension Method
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

NSubGraph..::..WrappingOutPort Class
NSubGraph..::..WrappingOutPort Members
DynamicNode.Core.Nodes Namespace


IsConnectableTo Method

[image]

DynamicNodes API
NSubGraph..::..WrappingOutPort..::..IsConnectableTo Method
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob dieser Port mit einem anderem Port verbunden werden kann.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override bool IsConnectableTo(
    IPort port,
    out Type possibleTypeSelection
)
Visual Basic
Public Overrides Function IsConnectableTo ( _
    port As IPort, _
    <OutAttribute> ByRef possibleTypeSelection As Type _
) As Boolean
F#
abstract IsConnectableTo :
        port:IPort *
        possibleTypeSelection:Type byref -> bool
override IsConnectableTo :
        port:IPort *
        possibleTypeSelection:Type byref -> bool

Parameters

port
Type: DynamicNode.Core..::..IPort
Der andere Port.
possibleTypeSelection
Type: System..::..Type %
Wird mit dem ausgewählten Datentyp belegt, oder null, wenn der Rückgabewert false ist.

Return Value

true, wenn eine Verbindung mit dem anderen Port möglich ist, sonst false.

Implements

IPort..::..IsConnectableTo(IPort, Type%)

See Also

NSubGraph..::..WrappingOutPort Class
DynamicNode.Core.Nodes Namespace


TraceError Method

[image] [image]

DynamicNodes API
WrappingOutPort..::..TraceError Method
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph..::..WrappingOutPort Class
NSubGraph..::..WrappingOutPort Members
DynamicNode.Core.Nodes Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
WrappingOutPort..::..TraceInfo Method
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph..::..WrappingOutPort Class
NSubGraph..::..WrappingOutPort Members
DynamicNode.Core.Nodes Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
WrappingOutPort..::..TraceVerbose Method
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph..::..WrappingOutPort Class
NSubGraph..::..WrappingOutPort Members
DynamicNode.Core.Nodes Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
WrappingOutPort..::..TraceVerboseData Method
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph..::..WrappingOutPort Class
NSubGraph..::..WrappingOutPort Members
DynamicNode.Core.Nodes Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
WrappingOutPort..::..TraceWarning Method
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NSubGraph..::..WrappingOutPort Class
NSubGraph..::..WrappingOutPort Members
DynamicNode.Core.Nodes Namespace


UpdateToken Method

[image] [image]

DynamicNodes API
WrappingOutPort..::..UpdateToken Method
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | UpdateToken(Object) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet, das Token gehört keinem Stream an. (Inherited from OutPort.)
Public method | UpdateToken(Token) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)
Public method | UpdateToken(TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet, das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Das Token gehört zu keinem Stream. (Inherited from OutPort.)
Public method | UpdateToken(Object, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Token-Status wird Valid verwendet. (Inherited from OutPort.)
Public method | UpdateToken(TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. Als Wert wird null verwendet. (Inherited from OutPort.)
Public method | UpdateToken(Object, TokenState, Stream, Int64) | Aktualisiert das Token des Ports. Dabei wird das Ereignis TokenUpdate ausgelöst. (Inherited from OutPort.)

See Also

NSubGraph..::..WrappingOutPort Class
NSubGraph..::..WrappingOutPort Members
DynamicNode.Core.Nodes Namespace


UpdateTokenNotSet Method

[image] [image]

DynamicNodes API
WrappingOutPort..::..UpdateTokenNotSet Method
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | UpdateTokenNotSet()()()() | Belegt den Ausgang mit einem lehren Token welches zu keinem Stream gehört. (Inherited from OutPort.)
Public method | UpdateTokenNotSet(Stream, Int64) | Belegt den Ausgang mit einem lehren Token. (Inherited from OutPort.)

See Also

NSubGraph..::..WrappingOutPort Class
NSubGraph..::..WrappingOutPort Members
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingOutPort Properties

[image] [image]

DynamicNodes API
NSubGraph..::..WrappingOutPort Properties
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph..::..WrappingOutPort type exposes the following members.

Properties

 | Name | Description
Public property | CompatibilityChecker | Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Ausgangs-Ports zu anderen Eingangs-Ports angepasst werden kann. (Overrides OutPort..::..CompatibilityChecker.)
Public property | ConnectedPorts | Gibt ein Array mit allen verbundenen Eingängen zurück. (Inherited from OutPort.)
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from OutPort.)
Public property | CurrentTokenState | Gibt den Zustand des letzten Tokens zurück. (Inherited from Port.)
Public property | CurrentTokenValue | Gibt den Wert des letzten Tokens zurück. (Inherited from Port.)
Public property | DataTypeProvider | Liest oder schreibt einen Daten-Typ-Provider für diesen Ausgang. (Inherited from OutPort.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from Port.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Port.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Port.)
Public property | NeedToFire | Gibt einen Wert zurück, der angibt, ob der Ausgang mit einem Token belegt ist, welches noch nicht gefeuert wurde. (Inherited from OutPort.)
Public property | Node | Gibt den Knoten zurück, zu dem dieser Port gehört. (Inherited from Port.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public property | ReadCopy | Gibt die Lese-Kopie des letzten Tokens zurück, mit dem der Port aktualisiert wurde. (Inherited from Port.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SuperName | Liest oder schreibt die Super-ID für Modul-Ports. (Inherited from Port.)
Public property | SuperSortIndex | Liest oder schreibt den Sortier-Index für den Super-Port. (Inherited from Port.)
Public property | SupportedType | Gibt den unterstützten Datentyp des Ausgangs zurück. (Overrides OutPort..::..SupportedType.)
Public property | WrappedOutPort | Gibt den gekapselten Super-Ausgang zurück.

See Also

NSubGraph..::..WrappingOutPort Class
DynamicNode.Core.Nodes Namespace


CompatibilityChecker Property

[image]

DynamicNodes API
NSubGraph..::..WrappingOutPort..::..CompatibilityChecker Property
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Kompatibilitäts-Checker, mit dem die Kompatibilität dieses Ausgangs-Ports zu anderen Eingangs-Ports angepasst werden kann.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override CompatibilityChecker<InPort> CompatibilityChecker { get; set; }
Visual Basic
Public Overrides Property CompatibilityChecker As CompatibilityChecker(Of InPort)
    Get
    Set
F#
abstract CompatibilityChecker : CompatibilityChecker<InPort> with get, set
override CompatibilityChecker : CompatibilityChecker<InPort> with get, set

Field Value

Der Kompatibilitäts-Checker.

See Also

NSubGraph..::..WrappingOutPort Class
DynamicNode.Core.Nodes Namespace
NSubGraph..::..WrappingOutPort..::..CompatibilityChecker


SupportedType Property

[image]

DynamicNodes API
NSubGraph..::..WrappingOutPort..::..SupportedType Property
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den unterstützten Datentyp des Ausgangs zurück.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override Type SupportedType { get; }
Visual Basic
Public Overrides ReadOnly Property SupportedType As Type
    Get
F#
abstract SupportedType : Type
override SupportedType : Type

Field Value

Der vom Ausgang unterstützte Datentyp.

See Also

NSubGraph..::..WrappingOutPort Class
DynamicNode.Core.Nodes Namespace


WrappedOutPort Property

[image]

DynamicNodes API
NSubGraph..::..WrappingOutPort..::..WrappedOutPort Property
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den gekapselten Super-Ausgang zurück.

Namespace: DynamicNode.Core.Nodes
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public OutPort WrappedOutPort { get; }
Visual Basic
Public ReadOnly Property WrappedOutPort As OutPort
    Get
F#
member WrappedOutPort : OutPort

Field Value

Der gekapselte Super-Ausgang.

See Also

NSubGraph..::..WrappingOutPort Class
DynamicNode.Core.Nodes Namespace


NSubGraph.WrappingOutPort Events

[image] [image]

DynamicNodes API
NSubGraph..::..WrappingOutPort Events
NSubGraph..::..WrappingOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NSubGraph..::..WrappingOutPort type exposes the following members.

Events

 | Name | Description
Public event | ConnectionChange | Wird ausgelöst, wenn sich die Anzahl der Verbindungen ändert. (Inherited from Port.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | Fired | Tritt auf, wenn das aktuelle Token an die verbundenen Eingänge weitergegeben wurde. (Inherited from OutPort.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from ChildObject<(Of <(<'TParent, TSelf>)>)>.)
Public event | TokenUpdate | Ein Ereignis, welches ausgelöst wird, wenn der Token des Ports aktualisiert wird. (Inherited from Port.)
Public event | TypeSupportChanged | Wird ausgelöst, wenn der Datentyp des Ausgangs geändert wurde und alle ausgehenden Verbindungen neu verhandelt werden müssen. (Inherited from OutPort.)

See Also

NSubGraph..::..WrappingOutPort Class
DynamicNode.Core.Nodes Namespace


DynamicNode.Ext.Cockpit Namespace

[image]

DynamicNodes API
DynamicNode.Ext.Cockpit Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält eine Erweiterung, welche die Programmierung einer Cockpit-Benutzerschnittstelle mit Hilfe von Knoten ermöglicht. Die Knotenbibliothek, welche Knoten für Cockpit-Steuerelemente bereitstellt ist DNLibCockpit.

Classes

 | Class | Description
Public class | BaseCockpitControl | Die Basisklasse für Cockpit-Steuerelemente.
Public class | BaseCockpitInputControl | Die Basisklasse für Cockpit-Steuerelemente.
Public class | BaseCockpitOutputControl | Die Basisklasse für Cockpit-Steuerelemente die einen Wert ausgeben.
Public class | CockpitExtension | Die Basisklasse für Erweiterungen zur Verwaltung eines Cockpit-Steuerelements. In dieser Klasse werden allgemeine Eigenschaften von Cockpit-Steuerelementen zusammengefasst.
Public class | CockpitInputExtension | Die Basisklasse für eine Eingabe-Cockpit-Erweiterung.
Public class | CockpitInputNode<(Of <(<'T>)>)> | Eine Basisklasse für Cockpit-Knoten die einen Wert durch ein Cockpit-Steuerelement erzeugen.
Public class | CockpitNode | Die Basisklasse für Cockpit-Knoten.
Public class | CockpitOutputExtension | Die Basisklasse für eine Eingabe-Cockpit-Erweiterung.
Public class | CockpitOutputNode<(Of <(<'T>)>)> | Eine Basisklasse für Cockpit-Knoten die einen Wert durch ein Cockpit-Steuerelement erzeugen.
Public class | CockpitPanel | Das Container-Steuerelement zur Aufnahme von mehreren Cockpit-Steuerelementen.
Public class | CockpitPersistence | Stellt Hilfsmethoden zum Sichern und Wiederherstellen von Cockpit-Eigenschaften mit einem IPropertyWriter und einem IPropertyReader zur Verfügung.
Public class | CockpitProperty<(Of <(<'T>)>)> | Der statische Kontext einer Eigenschaft.
Public class | CockpitPropertyInstance<(Of <(<'T>)>)> | Stellt eine Wert-Instanz für eine Eigenschaft (CockpitProperty<(Of <(<'T>)>)>) dar.
Public class | ControlSyncContext | Ein Synchronisationskontext für Windows-Forms-Steuerelemente.
Public class | TypedCockpitInputExtension<(Of <(<'TValue>)>)> | Die Basisklasse für Cockpit-Erweiterungen die mit einem bestimmten Datentyp arbeiten.
Public class | ValuePublishingEventArgs | Stellt Daten für das ValuePublishing-Ereignis bereit.

Interfaces

 | Interface | Description
Public interface | ICockpitPropertyContext | Die allgemeine Schnittstelle für einen Cockpit-Eigenschaftskontext.
Public interface | ICockpitPropertyInstance | Die allgemeine Schnittstelle für Cockpit-Eigenschaften.
Public interface | IPropertySyncContext | Die Schnittstelle eines Synchronisationskontexts.

Delegates

 | Delegate | Description
Public delegate | CockpitPropertyReader<(Of <(<'T>)>)> | Ein Delegat zum Wiederherstellen von Eigenschaftswerten aus einem IPropertyReader.
Public delegate | CockpitPropertyWriter<(Of <(<'T>)>)> | Ein Delegat zum Sichern von Eigenschaftswerten in einen IPropertyWriter.


BaseCockpitControl Class

[image]

DynamicNodes API
BaseCockpitControl Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für Cockpit-Steuerelemente.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public class BaseCockpitControl : UserControl
Visual Basic
Public Class BaseCockpitControl _
    Inherits UserControl
F#
type BaseCockpitControl =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Cockpit..::..BaseCockpitControl
DynamicNode.Ext.Cockpit..::..BaseCockpitInputControl
DynamicNode.Ext.Cockpit..::..BaseCockpitOutputControl

See Also

BaseCockpitControl Members
DynamicNode.Ext.Cockpit Namespace


BaseCockpitControl Members

[image] [image]

DynamicNodes API
BaseCockpitControl Members
BaseCockpitControl Class Constructors Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitControl type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseCockpitControl | Initialisiert eine neue Instanz von BaseCockpitControl.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnCockpitExtensionAttaching | Wird aufgerufen wenn eine Steuerelementbeschreibung zugewiesen wird.
Protected method | OnCockpitExtensionRemoving | Wird aufgerufen wenn die aktuelle Steuerelementbeschreibung entzogen wird.
Protected method | OnSizeChanged | Löst das SizeChanged-Ereignis aus. (Overrides Control..::..OnSizeChanged(EventArgs).)

Fields

 | Name | Description
Protected field | panelContent | Das Panel für den Inhalt des Cockpit-Steuerelements.
Protected field | panelTitle | Das Panel für den Titlebereich des Cockpit-Steuerelements.

Properties

 | Name | Description
Protected property | CockpitCaption | Gibt einen Wert zurück oder legt ihn fest, der die Beschriftung des Steuerelements enthält.
Public property | Extension | Gibt die Cockpit-Steuerelement-Erweiterumg zurück oder legt sie fest.
Protected property | TitleRegionHeight | Gibt die Höhe des Kopfbereichs zurück.

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitControl Constructor

[image]

DynamicNodes API
BaseCockpitControl Constructor
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von BaseCockpitControl.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected BaseCockpitControl()
Visual Basic
Protected Sub New
F#
new : unit -> BaseCockpitControl

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitControl Fields

[image] [image]

DynamicNodes API
BaseCockpitControl Fields
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitControl type exposes the following members.

Fields

 | Name | Description
Protected field | panelContent | Das Panel für den Inhalt des Cockpit-Steuerelements.
Protected field | panelTitle | Das Panel für den Titlebereich des Cockpit-Steuerelements.

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


panelContent Field

[image]

DynamicNodes API
BaseCockpitControl..::..panelContent Field
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Panel für den Inhalt des Cockpit-Steuerelements.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected Panel panelContent
Visual Basic
Protected panelContent As Panel
F#
val mutable panelContent: Panel

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


panelTitle Field

[image]

DynamicNodes API
BaseCockpitControl..::..panelTitle Field
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Panel für den Titlebereich des Cockpit-Steuerelements.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected Panel panelTitle
Visual Basic
Protected panelTitle As Panel
F#
val mutable panelTitle: Panel

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitControl Methods

[image] [image]

DynamicNodes API
BaseCockpitControl Methods
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitControl type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnCockpitExtensionAttaching | Wird aufgerufen wenn eine Steuerelementbeschreibung zugewiesen wird.
Protected method | OnCockpitExtensionRemoving | Wird aufgerufen wenn die aktuelle Steuerelementbeschreibung entzogen wird.
Protected method | OnSizeChanged | Löst das SizeChanged-Ereignis aus. (Overrides Control..::..OnSizeChanged(EventArgs).)

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


Dispose Method

[image]

DynamicNodes API
BaseCockpitControl..::..Dispose Method
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


OnCockpitExtensionAttaching Method

[image]

DynamicNodes API
BaseCockpitControl..::..OnCockpitExtensionAttaching Method
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn eine Steuerelementbeschreibung zugewiesen wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected virtual void OnCockpitExtensionAttaching()
Visual Basic
Protected Overridable Sub OnCockpitExtensionAttaching
F#
abstract OnCockpitExtensionAttaching : unit -> unit
override OnCockpitExtensionAttaching : unit -> unit

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


OnCockpitExtensionRemoving Method

[image]

DynamicNodes API
BaseCockpitControl..::..OnCockpitExtensionRemoving Method
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn die aktuelle Steuerelementbeschreibung entzogen wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected virtual void OnCockpitExtensionRemoving()
Visual Basic
Protected Overridable Sub OnCockpitExtensionRemoving
F#
abstract OnCockpitExtensionRemoving : unit -> unit
override OnCockpitExtensionRemoving : unit -> unit

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


OnSizeChanged Method

[image]

DynamicNodes API
BaseCockpitControl..::..OnSizeChanged Method
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das SizeChanged-Ereignis aus.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
F#
abstract OnSizeChanged :
        e:EventArgs -> unit
override OnSizeChanged :
        e:EventArgs -> unit

Parameters

e
Type: System..::..EventArgs
Ein EventArgs, der die Ereignisdaten enthält.

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitControl Properties

[image] [image]

DynamicNodes API
BaseCockpitControl Properties
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitControl type exposes the following members.

Properties

 | Name | Description
Protected property | CockpitCaption | Gibt einen Wert zurück oder legt ihn fest, der die Beschriftung des Steuerelements enthält.
Public property | Extension | Gibt die Cockpit-Steuerelement-Erweiterumg zurück oder legt sie fest.
Protected property | TitleRegionHeight | Gibt die Höhe des Kopfbereichs zurück.

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


CockpitCaption Property

[image]

DynamicNodes API
BaseCockpitControl..::..CockpitCaption Property
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der die Beschriftung des Steuerelements enthält.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected string CockpitCaption { get; set; }
Visual Basic
Protected Property CockpitCaption As String
    Get
    Set
F#
member CockpitCaption : string with get, set

Field Value

Die Beschriftung des Steuerelements.

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


Extension Property

[image]

DynamicNodes API
BaseCockpitControl..::..Extension Property
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Cockpit-Steuerelement-Erweiterumg zurück oder legt sie fest.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public CockpitExtension Extension { get; set; }
Visual Basic
Public Property Extension As CockpitExtension
    Get
    Set
F#
member Extension : CockpitExtension with get, set

Field Value

Die Cockpit-Steuerelement-Erweiterung.

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


TitleRegionHeight Property

[image]

DynamicNodes API
BaseCockpitControl..::..TitleRegionHeight Property
BaseCockpitControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Höhe des Kopfbereichs zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected int TitleRegionHeight { get; }
Visual Basic
Protected ReadOnly Property TitleRegionHeight As Integer
    Get
F#
member TitleRegionHeight : int

Field Value

Die Höhe des Kopfbereichs.

See Also

BaseCockpitControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitInputControl Class

[image]

DynamicNodes API
BaseCockpitInputControl Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für Cockpit-Steuerelemente.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public class BaseCockpitInputControl : BaseCockpitControl
Visual Basic
Public Class BaseCockpitInputControl _
    Inherits BaseCockpitControl
F#
type BaseCockpitInputControl =
    class
        inherit BaseCockpitControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Cockpit..::..BaseCockpitControl
DynamicNode.Ext.Cockpit..::..BaseCockpitInputControl

See Also

BaseCockpitInputControl Members
DynamicNode.Ext.Cockpit Namespace


BaseCockpitInputControl Members

[image] [image]

DynamicNodes API
BaseCockpitInputControl Members
BaseCockpitInputControl Class Constructors Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitInputControl type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseCockpitInputControl | Initialisiert eine neue Instanz von BaseCockpitInputControl.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides BaseCockpitControl..::..Dispose(Boolean).)
Protected method | OnCockpitExtensionAttaching | Wird aufgerufen wenn eine Steuerelementbeschreibung zugewiesen wird. (Overrides BaseCockpitControl..::..OnCockpitExtensionAttaching()()()().)
Protected method | OnCockpitExtensionRemoving | Wird aufgerufen wenn die aktuelle Steuerelementbeschreibung entzogen wird. (Overrides BaseCockpitControl..::..OnCockpitExtensionRemoving()()()().)
Protected method | OnSizeChanged | Löst das SizeChanged-Ereignis aus. (Inherited from BaseCockpitControl.)

Fields

 | Name | Description
Protected field | panelContent | Das Panel für den Inhalt des Cockpit-Steuerelements. (Inherited from BaseCockpitControl.)
Protected field | panelTitle | Das Panel für den Titlebereich des Cockpit-Steuerelements. (Inherited from BaseCockpitControl.)

Properties

 | Name | Description
Protected property | CockpitCaption | Gibt einen Wert zurück oder legt ihn fest, der die Beschriftung des Steuerelements enthält. (Inherited from BaseCockpitControl.)
Public property | Extension | Gibt die Cockpit-Steuerelement-Erweiterumg zurück oder legt sie fest. (Inherited from BaseCockpitControl.)
Protected property | InputExtension | Gibt die Eingabe-Cockpit-Erweiterung für dieses Cockpit-Steuerelement zurück.
Protected property | TitleRegionHeight | Gibt die Höhe des Kopfbereichs zurück. (Inherited from BaseCockpitControl.)

See Also

BaseCockpitInputControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitInputControl Constructor

[image]

DynamicNodes API
BaseCockpitInputControl Constructor
BaseCockpitInputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von BaseCockpitInputControl.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected BaseCockpitInputControl()
Visual Basic
Protected Sub New
F#
new : unit -> BaseCockpitInputControl

See Also

BaseCockpitInputControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitInputControl Fields

[image] [image]

DynamicNodes API
BaseCockpitInputControl Fields
BaseCockpitInputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitInputControl type exposes the following members.

Fields

 | Name | Description
Protected field | panelContent | Das Panel für den Inhalt des Cockpit-Steuerelements. (Inherited from BaseCockpitControl.)
Protected field | panelTitle | Das Panel für den Titlebereich des Cockpit-Steuerelements. (Inherited from BaseCockpitControl.)

See Also

BaseCockpitInputControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitInputControl Methods

[image] [image]

DynamicNodes API
BaseCockpitInputControl Methods
BaseCockpitInputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitInputControl type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides BaseCockpitControl..::..Dispose(Boolean).)
Protected method | OnCockpitExtensionAttaching | Wird aufgerufen wenn eine Steuerelementbeschreibung zugewiesen wird. (Overrides BaseCockpitControl..::..OnCockpitExtensionAttaching()()()().)
Protected method | OnCockpitExtensionRemoving | Wird aufgerufen wenn die aktuelle Steuerelementbeschreibung entzogen wird. (Overrides BaseCockpitControl..::..OnCockpitExtensionRemoving()()()().)
Protected method | OnSizeChanged | Löst das SizeChanged-Ereignis aus. (Inherited from BaseCockpitControl.)

See Also

BaseCockpitInputControl Class
DynamicNode.Ext.Cockpit Namespace


Dispose Method

[image]

DynamicNodes API
BaseCockpitInputControl..::..Dispose Method
BaseCockpitInputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

BaseCockpitInputControl Class
DynamicNode.Ext.Cockpit Namespace


OnCockpitExtensionAttaching Method

[image]

DynamicNodes API
BaseCockpitInputControl..::..OnCockpitExtensionAttaching Method
BaseCockpitInputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn eine Steuerelementbeschreibung zugewiesen wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void OnCockpitExtensionAttaching()
Visual Basic
Protected Overrides Sub OnCockpitExtensionAttaching
F#
abstract OnCockpitExtensionAttaching : unit -> unit
override OnCockpitExtensionAttaching : unit -> unit

See Also

BaseCockpitInputControl Class
DynamicNode.Ext.Cockpit Namespace


OnCockpitExtensionRemoving Method

[image]

DynamicNodes API
BaseCockpitInputControl..::..OnCockpitExtensionRemoving Method
BaseCockpitInputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn die aktuelle Steuerelementbeschreibung entzogen wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void OnCockpitExtensionRemoving()
Visual Basic
Protected Overrides Sub OnCockpitExtensionRemoving
F#
abstract OnCockpitExtensionRemoving : unit -> unit
override OnCockpitExtensionRemoving : unit -> unit

See Also

BaseCockpitInputControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitInputControl Properties

[image] [image]

DynamicNodes API
BaseCockpitInputControl Properties
BaseCockpitInputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitInputControl type exposes the following members.

Properties

 | Name | Description
Protected property | CockpitCaption | Gibt einen Wert zurück oder legt ihn fest, der die Beschriftung des Steuerelements enthält. (Inherited from BaseCockpitControl.)
Public property | Extension | Gibt die Cockpit-Steuerelement-Erweiterumg zurück oder legt sie fest. (Inherited from BaseCockpitControl.)
Protected property | InputExtension | Gibt die Eingabe-Cockpit-Erweiterung für dieses Cockpit-Steuerelement zurück.
Protected property | TitleRegionHeight | Gibt die Höhe des Kopfbereichs zurück. (Inherited from BaseCockpitControl.)

See Also

BaseCockpitInputControl Class
DynamicNode.Ext.Cockpit Namespace


InputExtension Property

[image]

DynamicNodes API
BaseCockpitInputControl..::..InputExtension Property
BaseCockpitInputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Eingabe-Cockpit-Erweiterung für dieses Cockpit-Steuerelement zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected CockpitInputExtension InputExtension { get; }
Visual Basic
Protected ReadOnly Property InputExtension As CockpitInputExtension
    Get
F#
member InputExtension : CockpitInputExtension

See Also

BaseCockpitInputControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitOutputControl Class

[image]

DynamicNodes API
BaseCockpitOutputControl Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für Cockpit-Steuerelemente die einen Wert ausgeben.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public class BaseCockpitOutputControl : BaseCockpitControl
Visual Basic
Public Class BaseCockpitOutputControl _
    Inherits BaseCockpitControl
F#
type BaseCockpitOutputControl =
    class
        inherit BaseCockpitControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Cockpit..::..BaseCockpitControl
DynamicNode.Ext.Cockpit..::..BaseCockpitOutputControl

See Also

BaseCockpitOutputControl Members
DynamicNode.Ext.Cockpit Namespace


BaseCockpitOutputControl Members

[image] [image]

DynamicNodes API
BaseCockpitOutputControl Members
BaseCockpitOutputControl Class Constructors Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitOutputControl type exposes the following members.

Constructors

 | Name | Description
Public method | BaseCockpitOutputControl | Initialisiert eine neue Instanz der Klasse BaseCockpitControl.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides BaseCockpitControl..::..Dispose(Boolean).)
Protected method | OnCockpitExtensionAttaching | Wird aufgerufen wenn eine Steuerelementbeschreibung zugewiesen wird. (Inherited from BaseCockpitControl.)
Protected method | OnCockpitExtensionRemoving | Wird aufgerufen wenn die aktuelle Steuerelementbeschreibung entzogen wird. (Inherited from BaseCockpitControl.)
Protected method | OnSizeChanged | Löst das SizeChanged-Ereignis aus. (Inherited from BaseCockpitControl.)
Public method | ShowValue | Zeigt einen neuen Wert im Steuerelement an.

Fields

 | Name | Description
Protected field | panelContent | Das Panel für den Inhalt des Cockpit-Steuerelements. (Inherited from BaseCockpitControl.)
Protected field | panelTitle | Das Panel für den Titlebereich des Cockpit-Steuerelements. (Inherited from BaseCockpitControl.)

Properties

 | Name | Description
Protected property | CockpitCaption | Gibt einen Wert zurück oder legt ihn fest, der die Beschriftung des Steuerelements enthält. (Inherited from BaseCockpitControl.)
Public property | Extension | Gibt die Cockpit-Steuerelement-Erweiterumg zurück oder legt sie fest. (Inherited from BaseCockpitControl.)
Protected property | TitleRegionHeight | Gibt die Höhe des Kopfbereichs zurück. (Inherited from BaseCockpitControl.)

See Also

BaseCockpitOutputControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitOutputControl Constructor

[image]

DynamicNodes API
BaseCockpitOutputControl Constructor
BaseCockpitOutputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse BaseCockpitControl.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public BaseCockpitOutputControl()
Visual Basic
Public Sub New
F#
new : unit -> BaseCockpitOutputControl

See Also

BaseCockpitOutputControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitOutputControl Fields

[image] [image]

DynamicNodes API
BaseCockpitOutputControl Fields
BaseCockpitOutputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitOutputControl type exposes the following members.

Fields

 | Name | Description
Protected field | panelContent | Das Panel für den Inhalt des Cockpit-Steuerelements. (Inherited from BaseCockpitControl.)
Protected field | panelTitle | Das Panel für den Titlebereich des Cockpit-Steuerelements. (Inherited from BaseCockpitControl.)

See Also

BaseCockpitOutputControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitOutputControl Methods

[image] [image]

DynamicNodes API
BaseCockpitOutputControl Methods
BaseCockpitOutputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitOutputControl type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides BaseCockpitControl..::..Dispose(Boolean).)
Protected method | OnCockpitExtensionAttaching | Wird aufgerufen wenn eine Steuerelementbeschreibung zugewiesen wird. (Inherited from BaseCockpitControl.)
Protected method | OnCockpitExtensionRemoving | Wird aufgerufen wenn die aktuelle Steuerelementbeschreibung entzogen wird. (Inherited from BaseCockpitControl.)
Protected method | OnSizeChanged | Löst das SizeChanged-Ereignis aus. (Inherited from BaseCockpitControl.)
Public method | ShowValue | Zeigt einen neuen Wert im Steuerelement an.

See Also

BaseCockpitOutputControl Class
DynamicNode.Ext.Cockpit Namespace


Dispose Method

[image]

DynamicNodes API
BaseCockpitOutputControl..::..Dispose Method
BaseCockpitOutputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

BaseCockpitOutputControl Class
DynamicNode.Ext.Cockpit Namespace


ShowValue Method

[image]

DynamicNodes API
BaseCockpitOutputControl..::..ShowValue Method
BaseCockpitOutputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeigt einen neuen Wert im Steuerelement an.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public virtual void ShowValue(
    Object value
)
Visual Basic
Public Overridable Sub ShowValue ( _
    value As Object _
)
F#
abstract ShowValue :
        value:Object -> unit
override ShowValue :
        value:Object -> unit

Parameters

value
Type: System..::..Object
Der neue Wert.

See Also

BaseCockpitOutputControl Class
DynamicNode.Ext.Cockpit Namespace


BaseCockpitOutputControl Properties

[image] [image]

DynamicNodes API
BaseCockpitOutputControl Properties
BaseCockpitOutputControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseCockpitOutputControl type exposes the following members.

Properties

 | Name | Description
Protected property | CockpitCaption | Gibt einen Wert zurück oder legt ihn fest, der die Beschriftung des Steuerelements enthält. (Inherited from BaseCockpitControl.)
Public property | Extension | Gibt die Cockpit-Steuerelement-Erweiterumg zurück oder legt sie fest. (Inherited from BaseCockpitControl.)
Protected property | TitleRegionHeight | Gibt die Höhe des Kopfbereichs zurück. (Inherited from BaseCockpitControl.)

See Also

BaseCockpitOutputControl Class
DynamicNode.Ext.Cockpit Namespace


CockpitExtension Class

[image]

DynamicNodes API
CockpitExtension Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für Erweiterungen zur Verwaltung eines Cockpit-Steuerelements. In dieser Klasse werden allgemeine Eigenschaften von Cockpit-Steuerelementen zusammengefasst.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public abstract class CockpitExtension : IExtension<INode>,
    IStorable, INotifyPropertyChanged
Visual Basic
Public MustInherit Class CockpitExtension _
    Implements IExtension(Of INode), IStorable,  _
    INotifyPropertyChanged
F#
[<AbstractClassAttribute>]
type CockpitExtension =
    class
        interface IExtension<INode>
        interface IStorable
        interface INotifyPropertyChanged
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Cockpit..::..CockpitExtension
DynamicNode.Ext.Cockpit..::..CockpitInputExtension
DynamicNode.Ext.Cockpit..::..CockpitOutputExtension

See Also

CockpitExtension Members
DynamicNode.Ext.Cockpit Namespace


CockpitExtension Members

[image] [image]

DynamicNodes API
CockpitExtension Members
CockpitExtension Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitExtension type exposes the following members.

Constructors

 | Name | Description
Protected method | CockpitExtension | Initialisiert eine neue Instanz der Klasse CockpitExtension.

Methods

 | Name | Description
Public method | AfterAttaching | Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | GetProperties | Gibt eine Aufzählung mit allen Cockpit-Eigenschaften dieser Cockpit-Erweiterung zurück.
Protected method | OnPropertyChanged | Löst das Ereignis PropertyChanged aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Protected method | UpdateSyncContext | Muss aufgerufen werden, wenn das Cockpit-Steuerelement erzeugt wird.

Fields

 | Name | Description
 | EXT_ID | Die Erweiterungs-ID des Cockpit-Steuerelements. Da diese Erweiterung nur ein mal je Knoten angefügt werden kann, ist diese ID immer die gleiche.
Public field | Name | Der Name des Cockpit-Parameters.
Public field | SortIndex | Ein Wert der die Sortierung der Cockpit-Steuerelementen beeinflusst.

Properties

 | Name | Description
Public property | CockpitControl | Gibt das Cockpitsteuerelement zurück.
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | Node | Gibt den Knoten zurück, an den die Erweiterung gebunden wurde.
Public property | SyncContext | Der Synchronisierungskontext für die Kommunikation des Knotens mit dem Cockpitsteuerelement.

Events

 | Name | Description
Public event | PropertyChanged | Tritt auf, wenn eine Eigenschaft dieses Objektes geändert wurde.

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitExtension Constructor

[image]

DynamicNodes API
CockpitExtension Constructor
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse CockpitExtension.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected CockpitExtension()
Visual Basic
Protected Sub New
F#
new : unit -> CockpitExtension

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitExtension Fields

[image] [image]

DynamicNodes API
CockpitExtension Fields
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitExtension type exposes the following members.

Fields

 | Name | Description
 | EXT_ID | Die Erweiterungs-ID des Cockpit-Steuerelements. Da diese Erweiterung nur ein mal je Knoten angefügt werden kann, ist diese ID immer die gleiche.
Public field | Name | Der Name des Cockpit-Parameters.
Public field | SortIndex | Ein Wert der die Sortierung der Cockpit-Steuerelementen beeinflusst.

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


EXT_ID Field

[image]

DynamicNodes API
CockpitExtension..::..EXT_ID Field
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID des Cockpit-Steuerelements.
Da diese Erweiterung nur ein mal je Knoten angefügt werden kann, ist diese ID immer die gleiche.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


Name Field

[image]

DynamicNodes API
CockpitExtension..::..Name Field
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Name des Cockpit-Parameters.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public readonly CockpitPropertyInstance<string> Name
Visual Basic
Public ReadOnly Name As CockpitPropertyInstance(Of String)
F#
val Name: CockpitPropertyInstance<string>

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


SortIndex Field

[image]

DynamicNodes API
CockpitExtension..::..SortIndex Field
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Wert der die Sortierung der Cockpit-Steuerelementen beeinflusst.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public readonly CockpitPropertyInstance<int> SortIndex
Visual Basic
Public ReadOnly SortIndex As CockpitPropertyInstance(Of Integer)
F#
val SortIndex: CockpitPropertyInstance<int>

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitExtension Methods

[image] [image]

DynamicNodes API
CockpitExtension Methods
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitExtension type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | GetProperties | Gibt eine Aufzählung mit allen Cockpit-Eigenschaften dieser Cockpit-Erweiterung zurück.
Protected method | OnPropertyChanged | Löst das Ereignis PropertyChanged aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Protected method | UpdateSyncContext | Muss aufgerufen werden, wenn das Cockpit-Steuerelement erzeugt wird.

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


AfterAttaching Method

[image]

DynamicNodes API
CockpitExtension..::..AfterAttaching Method
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public virtual void AfterAttaching(
    INode o
)
Visual Basic
Public Overridable Sub AfterAttaching ( _
    o As INode _
)
F#
abstract AfterAttaching :
        o:INode -> unit
override AfterAttaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


AfterDetaching Method

[image]

DynamicNodes API
CockpitExtension..::..AfterDetaching Method
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public virtual void AfterDetaching(
    INode o
)
Visual Basic
Public Overridable Sub AfterDetaching ( _
    o As INode _
)
F#
abstract AfterDetaching :
        o:INode -> unit
override AfterDetaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


AfterRestoring Method

[image]

DynamicNodes API
CockpitExtension..::..AfterRestoring Method
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public virtual void AfterRestoring()
Visual Basic
Public Overridable Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


GetProperties Method

[image]

DynamicNodes API
CockpitExtension..::..GetProperties Method
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen Cockpit-Eigenschaften dieser Cockpit-Erweiterung zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public virtual IEnumerable<ICockpitPropertyInstance> GetProperties()
Visual Basic
Public Overridable Function GetProperties As IEnumerable(Of ICockpitPropertyInstance)
F#
abstract GetProperties : unit -> IEnumerable<ICockpitPropertyInstance>
override GetProperties : unit -> IEnumerable<ICockpitPropertyInstance>

Return Value

Alle Cockpit-Eigenschaften.

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


OnPropertyChanged Method

[image]

DynamicNodes API
CockpitExtension..::..OnPropertyChanged Method
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis PropertyChanged aus.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propName As String _
)
F#
abstract OnPropertyChanged :
        propName:string -> unit
override OnPropertyChanged :
        propName:string -> unit

Parameters

propName
Type: System..::..String
Der Name der geänderten Eigenschaft.

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


OnRestore Method

[image]

DynamicNodes API
CockpitExtension..::..OnRestore Method
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public virtual void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overridable Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


OnStore Method

[image]

DynamicNodes API
CockpitExtension..::..OnStore Method
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public virtual void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overridable Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


UpdateSyncContext Method

[image]

DynamicNodes API
CockpitExtension..::..UpdateSyncContext Method
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Muss aufgerufen werden, wenn das Cockpit-Steuerelement erzeugt wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected void UpdateSyncContext(
    IPropertySyncContext syncContext
)
Visual Basic
Protected Sub UpdateSyncContext ( _
    syncContext As IPropertySyncContext _
)
F#
member UpdateSyncContext :
        syncContext:IPropertySyncContext -> unit

Parameters

syncContext
Type: DynamicNode.Ext.Cockpit..::..IPropertySyncContext

[Missing <param name="syncContext"/> documentation for "M:DynamicNode.Ext.Cockpit.CockpitExtension.UpdateSyncContext(DynamicNode.Ext.Cockpit.IPropertySyncContext)"]

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitExtension Properties

[image] [image]

DynamicNodes API
CockpitExtension Properties
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitExtension type exposes the following members.

Properties

 | Name | Description
Public property | CockpitControl | Gibt das Cockpitsteuerelement zurück.
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | Node | Gibt den Knoten zurück, an den die Erweiterung gebunden wurde.
Public property | SyncContext | Der Synchronisierungskontext für die Kommunikation des Knotens mit dem Cockpitsteuerelement.

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitControl Property

[image]

DynamicNodes API
CockpitExtension..::..CockpitControl Property
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Cockpitsteuerelement zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public abstract BaseCockpitControl CockpitControl { get; }
Visual Basic
Public MustOverride ReadOnly Property CockpitControl As BaseCockpitControl
    Get
F#
abstract CockpitControl : BaseCockpitControl

Field Value

Das Cockpit-Steuerelement.

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


Id Property

[image]

DynamicNodes API
CockpitExtension..::..Id Property
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


IsUsingStorage Property

[image]

DynamicNodes API
CockpitExtension..::..IsUsingStorage Property
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


Node Property

[image]

DynamicNodes API
CockpitExtension..::..Node Property
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Knoten zurück, an den die Erweiterung gebunden wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public CockpitNode Node { get; private set; }
Visual Basic
Public Property Node As CockpitNode
    Get
    Private Set
F#
member Node : CockpitNode with get, private set

Field Value

Der Knoten.

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


SyncContext Property

[image]

DynamicNodes API
CockpitExtension..::..SyncContext Property
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Synchronisierungskontext für die Kommunikation des Knotens mit dem Cockpitsteuerelement.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public IPropertySyncContext SyncContext { get; private set; }
Visual Basic
Public Property SyncContext As IPropertySyncContext
    Get
    Private Set
F#
member SyncContext : IPropertySyncContext with get, private set

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitExtension Events

[image] [image]

DynamicNodes API
CockpitExtension Events
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitExtension type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Tritt auf, wenn eine Eigenschaft dieses Objektes geändert wurde.

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


PropertyChanged Event

[image]

DynamicNodes API
CockpitExtension..::..PropertyChanged Event
CockpitExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn eine Eigenschaft dieses Objektes geändert wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
F#
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

CockpitExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitInputExtension Class

[image]

DynamicNodes API
CockpitInputExtension Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für eine Eingabe-Cockpit-Erweiterung.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public abstract class CockpitInputExtension : CockpitExtension
Visual Basic
Public MustInherit Class CockpitInputExtension _
    Inherits CockpitExtension
F#
[<AbstractClassAttribute>]
type CockpitInputExtension =
    class
        inherit CockpitExtension
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Cockpit..::..CockpitExtension
DynamicNode.Ext.Cockpit..::..CockpitInputExtension
DynamicNode.Ext.Cockpit..::..TypedCockpitInputExtension<(Of <(<'TValue>)>)>

See Also

CockpitInputExtension Members
DynamicNode.Ext.Cockpit Namespace


CockpitInputExtension Members

[image] [image]

DynamicNodes API
CockpitInputExtension Members
CockpitInputExtension Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitInputExtension type exposes the following members.

Constructors

 | Name | Description
Protected method | CockpitInputExtension | Initializes a new instance of the CockpitInputExtension class

Methods

 | Name | Description
Public method | AfterAttaching | Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde. (Inherited from CockpitExtension.)
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde. (Inherited from CockpitExtension.)
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde. (Inherited from CockpitExtension.)
Public method | GetProperties | Gibt eine Aufzählung mit allen Cockpit-Eigenschaften dieser Cockpit-Erweiterung zurück. (Overrides CockpitExtension..::..GetProperties()()()().)
Protected method | OnPropertyChanged | Löst das Ereignis PropertyChanged aus. (Inherited from CockpitExtension.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from CockpitExtension.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from CockpitExtension.)
Protected method | OnValueChanged | Muss aufgerufen werden, wenn im Cockpit-Steuerelement der Wert verändert wurde. Ruft OnValuePublishing()()()() auf, wenn AutoPublish gleich true ist.
Protected method | OnValuePublishing | Löst das Ereignis ValuePublishing aus.
Protected method | UpdateSyncContext | Muss aufgerufen werden, wenn das Cockpit-Steuerelement erzeugt wird. (Inherited from CockpitExtension.)

Fields

 | Name | Description
Public field | AutoPublish | Ein Wert der angibt, ob Änderungen in der Benutzeroberfläche automatisch als neue Parameter-Werte weitergegeben werden.
Public field | Name | Der Name des Cockpit-Parameters. (Inherited from CockpitExtension.)
Public field | SortIndex | Ein Wert der die Sortierung der Cockpit-Steuerelementen beeinflusst. (Inherited from CockpitExtension.)

Properties

 | Name | Description
Public property | CockpitControl | Gibt das Cockpitsteuerelement zurück. (Inherited from CockpitExtension.)
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist. (Inherited from CockpitExtension.)
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt. (Inherited from CockpitExtension.)
Public property | Node | Gibt den Knoten zurück, an den die Erweiterung gebunden wurde. (Inherited from CockpitExtension.)
Public property | SyncContext | Der Synchronisierungskontext für die Kommunikation des Knotens mit dem Cockpitsteuerelement. (Inherited from CockpitExtension.)
Protected property | ValueAsObject | Gibt den aktuellen Wert des Cockpit-Steuerelements zurück.

Events

 | Name | Description
Public event | PropertyChanged | Tritt auf, wenn eine Eigenschaft dieses Objektes geändert wurde. (Inherited from CockpitExtension.)
Public event | ValueChanged | Tritt auf, wenn der Wert durch das Steuerelement geändert wurde.
Public event | ValuePublishing | Tritt auf, wenn der Wert durch das Cockpit-Steuerelement geändert wurde.

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitInputExtension Constructor

[image]

DynamicNodes API
CockpitInputExtension Constructor
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the CockpitInputExtension class

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected CockpitInputExtension()
Visual Basic
Protected Sub New
F#
new : unit -> CockpitInputExtension

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitInputExtension Fields

[image] [image]

DynamicNodes API
CockpitInputExtension Fields
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitInputExtension type exposes the following members.

Fields

 | Name | Description
Public field | AutoPublish | Ein Wert der angibt, ob Änderungen in der Benutzeroberfläche automatisch als neue Parameter-Werte weitergegeben werden.
Public field | Name | Der Name des Cockpit-Parameters. (Inherited from CockpitExtension.)
Public field | SortIndex | Ein Wert der die Sortierung der Cockpit-Steuerelementen beeinflusst. (Inherited from CockpitExtension.)

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


AutoPublish Field

[image]

DynamicNodes API
CockpitInputExtension..::..AutoPublish Field
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Wert der angibt, ob Änderungen in der Benutzeroberfläche automatisch als neue Parameter-Werte weitergegeben werden.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public readonly CockpitPropertyInstance<bool> AutoPublish
Visual Basic
Public ReadOnly AutoPublish As CockpitPropertyInstance(Of Boolean)
F#
val AutoPublish: CockpitPropertyInstance<bool>

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitInputExtension Methods

[image] [image]

DynamicNodes API
CockpitInputExtension Methods
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitInputExtension type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde. (Inherited from CockpitExtension.)
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde. (Inherited from CockpitExtension.)
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde. (Inherited from CockpitExtension.)
Public method | GetProperties | Gibt eine Aufzählung mit allen Cockpit-Eigenschaften dieser Cockpit-Erweiterung zurück. (Overrides CockpitExtension..::..GetProperties()()()().)
Protected method | OnPropertyChanged | Löst das Ereignis PropertyChanged aus. (Inherited from CockpitExtension.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from CockpitExtension.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from CockpitExtension.)
Protected method | OnValueChanged | Muss aufgerufen werden, wenn im Cockpit-Steuerelement der Wert verändert wurde. Ruft OnValuePublishing()()()() auf, wenn AutoPublish gleich true ist.
Protected method | OnValuePublishing | Löst das Ereignis ValuePublishing aus.
Protected method | UpdateSyncContext | Muss aufgerufen werden, wenn das Cockpit-Steuerelement erzeugt wird. (Inherited from CockpitExtension.)

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


GetProperties Method

[image]

DynamicNodes API
CockpitInputExtension..::..GetProperties Method
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen Cockpit-Eigenschaften dieser Cockpit-Erweiterung zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public override IEnumerable<ICockpitPropertyInstance> GetProperties()
Visual Basic
Public Overrides Function GetProperties As IEnumerable(Of ICockpitPropertyInstance)
F#
abstract GetProperties : unit -> IEnumerable<ICockpitPropertyInstance>
override GetProperties : unit -> IEnumerable<ICockpitPropertyInstance>

Return Value

Alle Cockpit-Eigenschaften.

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


OnValueChanged Method

[image]

DynamicNodes API
CockpitInputExtension..::..OnValueChanged Method
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Muss aufgerufen werden, wenn im Cockpit-Steuerelement der Wert verändert wurde. Ruft OnValuePublishing()()()() auf, wenn AutoPublish gleich true ist.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected void OnValueChanged()
Visual Basic
Protected Sub OnValueChanged
F#
member OnValueChanged : unit -> unit

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


OnValuePublishing Method

[image]

DynamicNodes API
CockpitInputExtension..::..OnValuePublishing Method
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis ValuePublishing aus.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected void OnValuePublishing()
Visual Basic
Protected Sub OnValuePublishing
F#
member OnValuePublishing : unit -> unit

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitInputExtension Properties

[image] [image]

DynamicNodes API
CockpitInputExtension Properties
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitInputExtension type exposes the following members.

Properties

 | Name | Description
Public property | CockpitControl | Gibt das Cockpitsteuerelement zurück. (Inherited from CockpitExtension.)
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist. (Inherited from CockpitExtension.)
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt. (Inherited from CockpitExtension.)
Public property | Node | Gibt den Knoten zurück, an den die Erweiterung gebunden wurde. (Inherited from CockpitExtension.)
Public property | SyncContext | Der Synchronisierungskontext für die Kommunikation des Knotens mit dem Cockpitsteuerelement. (Inherited from CockpitExtension.)
Protected property | ValueAsObject | Gibt den aktuellen Wert des Cockpit-Steuerelements zurück.

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


ValueAsObject Property

[image]

DynamicNodes API
CockpitInputExtension..::..ValueAsObject Property
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuellen Wert des Cockpit-Steuerelements zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected abstract Object ValueAsObject { get; }
Visual Basic
Protected MustOverride ReadOnly Property ValueAsObject As Object
    Get
F#
abstract ValueAsObject : Object

Field Value

Der Wert des Cockpit-Steuerelements.

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitInputExtension Events

[image] [image]

DynamicNodes API
CockpitInputExtension Events
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitInputExtension type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Tritt auf, wenn eine Eigenschaft dieses Objektes geändert wurde. (Inherited from CockpitExtension.)
Public event | ValueChanged | Tritt auf, wenn der Wert durch das Steuerelement geändert wurde.
Public event | ValuePublishing | Tritt auf, wenn der Wert durch das Cockpit-Steuerelement geändert wurde.

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


ValueChanged Event

[image]

DynamicNodes API
CockpitInputExtension..::..ValueChanged Event
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn der Wert durch das Steuerelement geändert wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
F#
member ValueChanged : IEvent<EventHandler,
    EventArgs>

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


ValuePublishing Event

[image]

DynamicNodes API
CockpitInputExtension..::..ValuePublishing Event
CockpitInputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn der Wert durch das Cockpit-Steuerelement geändert wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public event EventHandler<ValuePublishingEventArgs> ValuePublishing
Visual Basic
Public Event ValuePublishing As EventHandler(Of ValuePublishingEventArgs)
F#
member ValuePublishing : IEvent<EventHandler<ValuePublishingEventArgs>,
    ValuePublishingEventArgs>

See Also

CockpitInputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitInputNode(T) Class

[image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Basisklasse für Cockpit-Knoten die einen Wert durch ein Cockpit-Steuerelement erzeugen.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public abstract class CockpitInputNode<T> : CockpitNode
Visual Basic
Public MustInherit Class CockpitInputNode(Of T) _
    Inherits CockpitNode
F#
[<AbstractClassAttribute>]
type CockpitInputNode<'T> =
    class
        inherit CockpitNode
    end

Type Parameters

T
Der Datentyp der Werte, die durch das Cockpit-Steuerelement erzeugt werden.

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core..::..StreamNode
DynamicNode.Ext.Visual..::..VisualNode
DynamicNode.Ext.Cockpit..::..CockpitNode
DynamicNode.Ext.Cockpit..::..CockpitInputNode<(Of <(<'T>)>)>

See Also

CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


CockpitInputNode(T) Members

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)> Members
CockpitInputNode<(Of <(<'T>)>)> Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitInputNode<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | CockpitInputNode<(Of <(<'T>)>)> | Initialisiert eine neue CockpitInputNode<(Of <(<'T>)>)>-Instanz.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Inherited from VisualNode.)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Inherited from CockpitNode.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from CockpitNode.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from CockpitNode.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from CockpitNode.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from CockpitNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Public method | SendNewCockpitValue | Schickt einen neuen Wert
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides CockpitNode..::..Work(TokenSet).)

Fields

 | Name | Description
Protected field | AllowNullTransfer | true, wenn auch neue null-Werte weitergegeben werden sollen, sonst false.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | CockpitExtension | Gibt die CockpitExtension zurück, welche die Eigenschaften des Cockpitsteuerelements kapselt. (Overrides CockpitNode..::..CockpitExtension.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Icon | Gibt das Symbol des Cockpit-Steuerelements zurück oder legt es fest. (Inherited from CockpitNode.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitInputNode(T) Constructor

[image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)> Constructor
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue CockpitInputNode<(Of <(<'T>)>)>-Instanz.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected CockpitInputNode(
    CockpitInputExtension cockpitExtension,
    bool allowNullTransfer
)
Visual Basic
Protected Sub New ( _
    cockpitExtension As CockpitInputExtension, _
    allowNullTransfer As Boolean _
)
F#
new :
        cockpitExtension:CockpitInputExtension *
        allowNullTransfer:bool -> CockpitInputNode

Parameters

cockpitExtension
Type: DynamicNode.Ext.Cockpit..::..CockpitInputExtension
Die Cockpit-Knoten-Erweiterung.
allowNullTransfer
Type: System..::..Boolean
Gibt auch null-Werte weiter, falls true übergeben wird.

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitInputNode(T) Fields

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)> Fields
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitInputNode<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | AllowNullTransfer | true, wenn auch neue null-Werte weitergegeben werden sollen, sonst false.

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


AllowNullTransfer Field

[image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..AllowNullTransfer Field
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
true, wenn auch neue null-Werte weitergegeben werden sollen, sonst false.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected bool AllowNullTransfer
Visual Basic
Protected AllowNullTransfer As Boolean
F#
val mutable AllowNullTransfer: bool

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitInputNode(T) Methods

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)> Methods
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitInputNode<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Inherited from VisualNode.)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Inherited from CockpitNode.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from CockpitNode.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from CockpitNode.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from CockpitNode.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from CockpitNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Public method | SendNewCockpitValue | Schickt einen neuen Wert
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides CockpitNode..::..Work(TokenSet).)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..BeforeUseExtension Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


Duplicate Method

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..Duplicate Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


PaintCustomArea Method

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..PaintCustomArea Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from CockpitNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


RegisterStreamInPorts Method

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..RegisterStreamInPorts Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


SendNewCockpitValue Method

[image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..SendNewCockpitValue Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schickt einen neuen Wert

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public void SendNewCockpitValue(
    T newValue
)
Visual Basic
Public Sub SendNewCockpitValue ( _
    newValue As T _
)
F#
member SendNewCockpitValue :
        newValue:'T -> unit

Parameters

newValue
Type: T

[Missing <param name="newValue"/> documentation for "M:DynamicNode.Ext.Cockpit.CockpitInputNode`1.SendNewCockpitValue(`0)"]

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


TraceError Method

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..TraceError Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..TraceInfo Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..TraceVerbose Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..TraceVerboseData Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..TraceWarning Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


Work Method

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..Work Method
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides CockpitNode..::..Work(TokenSet).)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


Work Method (TokenSet)

[image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..Work Method (TokenSet)
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public override void Work(
    TokenSet ts
)
Visual Basic
Public Overrides Sub Work ( _
    ts As TokenSet _
)
F#
abstract Work :
        ts:TokenSet -> unit
override Work :
        ts:TokenSet -> unit

Parameters

ts
Type: DynamicNode.Core..::..TokenSet
Das TokenSet mit den aktuellen Tokens aller Eingänge.

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
Work Overload
DynamicNode.Ext.Cockpit Namespace


CockpitInputNode(T) Properties

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)> Properties
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitInputNode<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | CockpitExtension | Gibt die CockpitExtension zurück, welche die Eigenschaften des Cockpitsteuerelements kapselt. (Overrides CockpitNode..::..CockpitExtension.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Icon | Gibt das Symbol des Cockpit-Steuerelements zurück oder legt es fest. (Inherited from CockpitNode.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitExtension Property

[image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..CockpitExtension Property
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die CockpitExtension zurück, welche die Eigenschaften des Cockpitsteuerelements kapselt.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override CockpitExtension CockpitExtension { get; }
Visual Basic
Protected Overrides ReadOnly Property CockpitExtension As CockpitExtension
    Get
F#
abstract CockpitExtension : CockpitExtension
override CockpitExtension : CockpitExtension

Field Value

Die Cockpit-Steuerelement-Erweiterung.

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


Item Property

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)>..::..Item Property
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
CockpitInputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


CockpitInputNode(T) Events

[image] [image]

DynamicNodes API
CockpitInputNode<(Of <(<'T>)>)> Events
CockpitInputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitInputNode<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

CockpitInputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitNode Class

[image]

DynamicNodes API
CockpitNode Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für Cockpit-Knoten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public abstract class CockpitNode : VisualNode
Visual Basic
Public MustInherit Class CockpitNode _
    Inherits VisualNode
F#
[<AbstractClassAttribute>]
type CockpitNode =
    class
        inherit VisualNode
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core..::..StreamNode
DynamicNode.Ext.Visual..::..VisualNode
DynamicNode.Ext.Cockpit..::..CockpitNode
DynamicNode.Ext.Cockpit..::..CockpitInputNode<(Of <(<'T>)>)>
DynamicNode.Ext.Cockpit..::..CockpitOutputNode<(Of <(<'T>)>)>

See Also

CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


CockpitNode Members

[image] [image]

DynamicNodes API
CockpitNode Members
CockpitNode Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitNode type exposes the following members.

Constructors

 | Name | Description
Protected method | CockpitNode | Initialisiert eine neue CockpitNode-Instanz.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Inherited from VisualNode.)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Overrides VisualNode..::..InitVisualization(NodeVisualization).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnAttachExtension(IExtension<(Of <<'(TSelf>)>>), Boolean).)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnDetachExtension(IExtension<(Of <<'(TSelf>)>>)).)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Overrides Node..::..OnInitPortDefaults()()()().)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides StreamNode..::..Work(TokenSet).)

Fields

Name | Description
cockpitCnt | Ein Zähler für die automatische Erzeugung von initialen Parameternamen.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | CockpitExtension | Gibt die CockpitExtension zurück, welche die Eigenschaften des Cockpitsteuerelements kapselt.
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Icon | Gibt das Symbol des Cockpit-Steuerelements zurück oder legt es fest.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


CockpitNode Constructor

[image]

DynamicNodes API
CockpitNode Constructor
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue CockpitNode-Instanz.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected CockpitNode()
Visual Basic
Protected Sub New
F#
new : unit -> CockpitNode

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


CockpitNode Fields

[image] [image]

DynamicNodes API
CockpitNode Fields
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitNode type exposes the following members.

Fields

Name | Description
cockpitCnt | Ein Zähler für die automatische Erzeugung von initialen Parameternamen.

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


cockpitCnt Field

[image]

DynamicNodes API
CockpitNode..::..cockpitCnt Field
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Zähler für die automatische Erzeugung von initialen Parameternamen.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected static long cockpitCnt
Visual Basic
Protected Shared cockpitCnt As Long
F#
static val mutable cockpitCnt: int64

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


CockpitNode Methods

[image] [image]

DynamicNodes API
CockpitNode Methods
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitNode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Inherited from VisualNode.)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Overrides VisualNode..::..InitVisualization(NodeVisualization).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnAttachExtension(IExtension<(Of <<'(TSelf>)>>), Boolean).)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnDetachExtension(IExtension<(Of <<'(TSelf>)>>)).)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Overrides Node..::..OnInitPortDefaults()()()().)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides StreamNode..::..Work(TokenSet).)

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
CockpitNode..::..BeforeUseExtension Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


Duplicate Method

[image] [image]

DynamicNodes API
CockpitNode..::..Duplicate Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


InitVisualization Method

[image]

DynamicNodes API
CockpitNode..::..InitVisualization Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die Knoten-Visualisierung.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void InitVisualization(
    NodeVisualization nVis
)
Visual Basic
Protected Overrides Sub InitVisualization ( _
    nVis As NodeVisualization _
)
F#
abstract InitVisualization :
        nVis:NodeVisualization -> unit
override InitVisualization :
        nVis:NodeVisualization -> unit

Parameters

nVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


OnAttachExtension Method

[image]

DynamicNodes API
CockpitNode..::..OnAttachExtension Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void OnAttachExtension(
    IExtension<INode> extension,
    bool successful
)
Visual Basic
Protected Overrides Sub OnAttachExtension ( _
    extension As IExtension(Of INode), _
    successful As Boolean _
)
F#
abstract OnAttachExtension :
        extension:IExtension<INode> *
        successful:bool -> unit
override OnAttachExtension :
        extension:IExtension<INode> *
        successful:bool -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' INode >)>)>
Die Erweiterung.
successful
Type: System..::..Boolean
true wenn die Erweiterung erfolgreich registriert werden konnte, andernfalls false.

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


OnDetachExtension Method

[image]

DynamicNodes API
CockpitNode..::..OnDetachExtension Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn eine Erweiterung entfernt wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void OnDetachExtension(
    IExtension<INode> extension
)
Visual Basic
Protected Overrides Sub OnDetachExtension ( _
    extension As IExtension(Of INode) _
)
F#
abstract OnDetachExtension :
        extension:IExtension<INode> -> unit
override OnDetachExtension :
        extension:IExtension<INode> -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' INode >)>)>
Die Erweiterung.

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


OnInitPortDefaults Method

[image]

DynamicNodes API
CockpitNode..::..OnInitPortDefaults Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public override void OnInitPortDefaults()
Visual Basic
Public Overrides Sub OnInitPortDefaults
F#
abstract OnInitPortDefaults : unit -> unit
override OnInitPortDefaults : unit -> unit

Implements

INode..::..OnInitPortDefaults()()()()

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


PaintCustomArea Method

[image] [image]

DynamicNodes API
CockpitNode..::..PaintCustomArea Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


PaintCustomArea Method (Graphics, RectangleF, IPaintProperties)

[image]

DynamicNodes API
CockpitNode..::..PaintCustomArea Method (Graphics, RectangleF, IPaintProperties)
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected virtual void PaintCustomArea(
    Graphics g,
    RectangleF area,
    IPaintProperties pp
)
Visual Basic
Protected Overridable Sub PaintCustomArea ( _
    g As Graphics, _
    area As RectangleF, _
    pp As IPaintProperties _
)
F#
abstract PaintCustomArea :
        g:Graphics *
        area:RectangleF *
        pp:IPaintProperties -> unit
override PaintCustomArea :
        g:Graphics *
        area:RectangleF *
        pp:IPaintProperties -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Der grafische Kontext.
area
Type: System.Drawing..::..RectangleF
Der benutzerdefinierte Bereich.
pp
Type: DynamicNode.Ext.Visual..::..IPaintProperties
Eine Sammlung von Zeichenressourcen.

See Also

CockpitNode Class
PaintCustomArea Overload
DynamicNode.Ext.Cockpit Namespace


RegisterStreamInPorts Method

[image] [image]

DynamicNodes API
CockpitNode..::..RegisterStreamInPorts Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


TraceError Method

[image] [image]

DynamicNodes API
CockpitNode..::..TraceError Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
CockpitNode..::..TraceInfo Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
CockpitNode..::..TraceVerbose Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
CockpitNode..::..TraceVerboseData Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
CockpitNode..::..TraceWarning Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


Work Method

[image] [image]

DynamicNodes API
CockpitNode..::..Work Method
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides StreamNode..::..Work(TokenSet).)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


Work Method (TokenSet)

[image]

DynamicNodes API
CockpitNode..::..Work Method (TokenSet)
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public override void Work(
    TokenSet ts
)
Visual Basic
Public Overrides Sub Work ( _
    ts As TokenSet _
)
F#
abstract Work :
        ts:TokenSet -> unit
override Work :
        ts:TokenSet -> unit

Parameters

ts
Type: DynamicNode.Core..::..TokenSet
Das TokenSet mit den aktuellen Tokens aller Eingänge.

See Also

CockpitNode Class
Work Overload
DynamicNode.Ext.Cockpit Namespace


CockpitNode Properties

[image] [image]

DynamicNodes API
CockpitNode Properties
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitNode type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | CockpitExtension | Gibt die CockpitExtension zurück, welche die Eigenschaften des Cockpitsteuerelements kapselt.
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Icon | Gibt das Symbol des Cockpit-Steuerelements zurück oder legt es fest.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


CockpitExtension Property

[image]

DynamicNodes API
CockpitNode..::..CockpitExtension Property
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die CockpitExtension zurück, welche die Eigenschaften des Cockpitsteuerelements kapselt.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected abstract CockpitExtension CockpitExtension { get; }
Visual Basic
Protected MustOverride ReadOnly Property CockpitExtension As CockpitExtension
    Get
F#
abstract CockpitExtension : CockpitExtension

Field Value

Die Cockpit-Steuerelement-Erweiterung.

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


Icon Property

[image]

DynamicNodes API
CockpitNode..::..Icon Property
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Symbol des Cockpit-Steuerelements zurück oder legt es fest.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public Bitmap Icon { get; set; }
Visual Basic
Public Property Icon As Bitmap
    Get
    Set
F#
member Icon : Bitmap with get, set

Field Value

Das Symbol des Steuerelements.

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


Item Property

[image] [image]

DynamicNodes API
CockpitNode..::..Item Property
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

CockpitNode Class
CockpitNode Members
DynamicNode.Ext.Cockpit Namespace


CockpitNode Events

[image] [image]

DynamicNodes API
CockpitNode Events
CockpitNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitNode type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

CockpitNode Class
DynamicNode.Ext.Cockpit Namespace


CockpitOutputExtension Class

[image]

DynamicNodes API
CockpitOutputExtension Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für eine Eingabe-Cockpit-Erweiterung.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public abstract class CockpitOutputExtension : CockpitExtension
Visual Basic
Public MustInherit Class CockpitOutputExtension _
    Inherits CockpitExtension
F#
[<AbstractClassAttribute>]
type CockpitOutputExtension =
    class
        inherit CockpitExtension
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Cockpit..::..CockpitExtension
DynamicNode.Ext.Cockpit..::..CockpitOutputExtension

See Also

CockpitOutputExtension Members
DynamicNode.Ext.Cockpit Namespace


CockpitOutputExtension Members

[image] [image]

DynamicNodes API
CockpitOutputExtension Members
CockpitOutputExtension Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitOutputExtension type exposes the following members.

Constructors

 | Name | Description
Protected method | CockpitOutputExtension | Initializes a new instance of the CockpitOutputExtension class

Methods

 | Name | Description
Public method | AfterAttaching | Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde. (Inherited from CockpitExtension.)
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde. (Inherited from CockpitExtension.)
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde. (Inherited from CockpitExtension.)
Public method | GetProperties | Gibt eine Aufzählung mit allen Cockpit-Eigenschaften dieser Cockpit-Erweiterung zurück. (Inherited from CockpitExtension.)
Protected method | OnPropertyChanged | Löst das Ereignis PropertyChanged aus. (Inherited from CockpitExtension.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from CockpitExtension.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from CockpitExtension.)
Public method | PublishNewValue | Gibt einen neuen Wert für die Ausgabe im Cockpit-Steuerelement an.
Protected method | UpdateSyncContext | Muss aufgerufen werden, wenn das Cockpit-Steuerelement erzeugt wird. (Inherited from CockpitExtension.)

Fields

 | Name | Description
Public field | Name | Der Name des Cockpit-Parameters. (Inherited from CockpitExtension.)
Public field | SortIndex | Ein Wert der die Sortierung der Cockpit-Steuerelementen beeinflusst. (Inherited from CockpitExtension.)

Properties

 | Name | Description
Public property | CockpitControl | Gibt das Cockpitsteuerelement zurück. (Inherited from CockpitExtension.)
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist. (Inherited from CockpitExtension.)
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt. (Inherited from CockpitExtension.)
Public property | Node | Gibt den Knoten zurück, an den die Erweiterung gebunden wurde. (Inherited from CockpitExtension.)
Public property | SyncContext | Der Synchronisierungskontext für die Kommunikation des Knotens mit dem Cockpitsteuerelement. (Inherited from CockpitExtension.)

Events

 | Name | Description
Public event | NewValue | Tritt auf, wenn der Wert durch das Cockpit-Steuerelement geändert wurde.
Public event | PropertyChanged | Tritt auf, wenn eine Eigenschaft dieses Objektes geändert wurde. (Inherited from CockpitExtension.)

See Also

CockpitOutputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitOutputExtension Constructor

[image]

DynamicNodes API
CockpitOutputExtension Constructor
CockpitOutputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the CockpitOutputExtension class

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected CockpitOutputExtension()
Visual Basic
Protected Sub New
F#
new : unit -> CockpitOutputExtension

See Also

CockpitOutputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitOutputExtension Fields

[image] [image]

DynamicNodes API
CockpitOutputExtension Fields
CockpitOutputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitOutputExtension type exposes the following members.

Fields

 | Name | Description
Public field | Name | Der Name des Cockpit-Parameters. (Inherited from CockpitExtension.)
Public field | SortIndex | Ein Wert der die Sortierung der Cockpit-Steuerelementen beeinflusst. (Inherited from CockpitExtension.)

See Also

CockpitOutputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitOutputExtension Methods

[image] [image]

DynamicNodes API
CockpitOutputExtension Methods
CockpitOutputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitOutputExtension type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde. (Inherited from CockpitExtension.)
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde. (Inherited from CockpitExtension.)
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde. (Inherited from CockpitExtension.)
Public method | GetProperties | Gibt eine Aufzählung mit allen Cockpit-Eigenschaften dieser Cockpit-Erweiterung zurück. (Inherited from CockpitExtension.)
Protected method | OnPropertyChanged | Löst das Ereignis PropertyChanged aus. (Inherited from CockpitExtension.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from CockpitExtension.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from CockpitExtension.)
Public method | PublishNewValue | Gibt einen neuen Wert für die Ausgabe im Cockpit-Steuerelement an.
Protected method | UpdateSyncContext | Muss aufgerufen werden, wenn das Cockpit-Steuerelement erzeugt wird. (Inherited from CockpitExtension.)

See Also

CockpitOutputExtension Class
DynamicNode.Ext.Cockpit Namespace


PublishNewValue Method

[image]

DynamicNodes API
CockpitOutputExtension..::..PublishNewValue Method
CockpitOutputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen neuen Wert für die Ausgabe im Cockpit-Steuerelement an.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public virtual void PublishNewValue(
    Object value
)
Visual Basic
Public Overridable Sub PublishNewValue ( _
    value As Object _
)
F#
abstract PublishNewValue :
        value:Object -> unit
override PublishNewValue :
        value:Object -> unit

Parameters

value
Type: System..::..Object
Der neue Wert.

See Also

CockpitOutputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitOutputExtension Properties

[image] [image]

DynamicNodes API
CockpitOutputExtension Properties
CockpitOutputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitOutputExtension type exposes the following members.

Properties

 | Name | Description
Public property | CockpitControl | Gibt das Cockpitsteuerelement zurück. (Inherited from CockpitExtension.)
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist. (Inherited from CockpitExtension.)
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt. (Inherited from CockpitExtension.)
Public property | Node | Gibt den Knoten zurück, an den die Erweiterung gebunden wurde. (Inherited from CockpitExtension.)
Public property | SyncContext | Der Synchronisierungskontext für die Kommunikation des Knotens mit dem Cockpitsteuerelement. (Inherited from CockpitExtension.)

See Also

CockpitOutputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitOutputExtension Events

[image] [image]

DynamicNodes API
CockpitOutputExtension Events
CockpitOutputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitOutputExtension type exposes the following members.

Events

 | Name | Description
Public event | NewValue | Tritt auf, wenn der Wert durch das Cockpit-Steuerelement geändert wurde.
Public event | PropertyChanged | Tritt auf, wenn eine Eigenschaft dieses Objektes geändert wurde. (Inherited from CockpitExtension.)

See Also

CockpitOutputExtension Class
DynamicNode.Ext.Cockpit Namespace


NewValue Event

[image]

DynamicNodes API
CockpitOutputExtension..::..NewValue Event
CockpitOutputExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn der Wert durch das Cockpit-Steuerelement geändert wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public event EventHandler<ValuePublishingEventArgs> NewValue
Visual Basic
Public Event NewValue As EventHandler(Of ValuePublishingEventArgs)
F#
member NewValue : IEvent<EventHandler<ValuePublishingEventArgs>,
    ValuePublishingEventArgs>

See Also

CockpitOutputExtension Class
DynamicNode.Ext.Cockpit Namespace


CockpitOutputNode(T) Class

[image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Basisklasse für Cockpit-Knoten die einen Wert durch ein Cockpit-Steuerelement erzeugen.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public abstract class CockpitOutputNode<T> : CockpitNode
Visual Basic
Public MustInherit Class CockpitOutputNode(Of T) _
    Inherits CockpitNode
F#
[<AbstractClassAttribute>]
type CockpitOutputNode<'T> =
    class
        inherit CockpitNode
    end

Type Parameters

T
Der Datentyp der Werte, die durch das Cockpit-Steuerelement erzeugt werden.

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core..::..StreamNode
DynamicNode.Ext.Visual..::..VisualNode
DynamicNode.Ext.Cockpit..::..CockpitNode
DynamicNode.Ext.Cockpit..::..CockpitOutputNode<(Of <(<'T>)>)>

See Also

CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


CockpitOutputNode(T) Members

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)> Members
CockpitOutputNode<(Of <(<'T>)>)> Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitOutputNode<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | CockpitOutputNode<(Of <(<'T>)>)> | Initialisiert eine neue CockpitInputNode<(Of <(<'T>)>)>-Instanz.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Inherited from VisualNode.)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Overrides CockpitNode..::..InitVisualization(NodeVisualization).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from CockpitNode.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from CockpitNode.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from CockpitNode.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from CockpitNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Protected method | ProcessValue | Führt eine Vorverarbeitung des eingetroffenen Wertes durch. Diese Methode kann z.B. für Konvertierungen überschrieben werden.
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides CockpitNode..::..Work(TokenSet).)

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | CockpitExtension | Gibt die CockpitExtension zurück, welche die Eigenschaften des Cockpitsteuerelements kapselt. (Overrides CockpitNode..::..CockpitExtension.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Icon | Gibt das Symbol des Cockpit-Steuerelements zurück oder legt es fest. (Inherited from CockpitNode.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | ValueInPort | Gibt den Eingang für den anzuzeigenden Wert zurück.
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitOutputNode(T) Constructor

[image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)> Constructor
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue CockpitInputNode<(Of <(<'T>)>)>-Instanz.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected CockpitOutputNode(
    CockpitOutputExtension cockpitExtension
)
Visual Basic
Protected Sub New ( _
    cockpitExtension As CockpitOutputExtension _
)
F#
new :
        cockpitExtension:CockpitOutputExtension -> CockpitOutputNode

Parameters

cockpitExtension
Type: DynamicNode.Ext.Cockpit..::..CockpitOutputExtension
Die Cockpit-Knoten-Erweiterung.

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitOutputNode(T) Methods

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)> Methods
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitOutputNode<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Inherited from VisualNode.)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Overrides CockpitNode..::..InitVisualization(NodeVisualization).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from CockpitNode.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from CockpitNode.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from CockpitNode.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from CockpitNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Protected method | ProcessValue | Führt eine Vorverarbeitung des eingetroffenen Wertes durch. Diese Methode kann z.B. für Konvertierungen überschrieben werden.
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides CockpitNode..::..Work(TokenSet).)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..BeforeUseExtension Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


Duplicate Method

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..Duplicate Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


InitVisualization Method

[image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..InitVisualization Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die Knoten-Visualisierung.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void InitVisualization(
    NodeVisualization nVis
)
Visual Basic
Protected Overrides Sub InitVisualization ( _
    nVis As NodeVisualization _
)
F#
abstract InitVisualization :
        nVis:NodeVisualization -> unit
override InitVisualization :
        nVis:NodeVisualization -> unit

Parameters

nVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


PaintCustomArea Method

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..PaintCustomArea Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from CockpitNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


ProcessValue Method

[image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..ProcessValue Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Vorverarbeitung des eingetroffenen Wertes durch. Diese Methode kann z.B. für Konvertierungen überschrieben werden.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected virtual Object ProcessValue(
    Object value,
    Type selectedType
)
Visual Basic
Protected Overridable Function ProcessValue ( _
    value As Object, _
    selectedType As Type _
) As Object
F#
abstract ProcessValue :
        value:Object *
        selectedType:Type -> Object
override ProcessValue :
        value:Object *
        selectedType:Type -> Object

Parameters

value
Type: System..::..Object
Der eingetroffene Wert.
selectedType
Type: System..::..Type
Der Type der zur Zeit für die Kompatibilität des Eingangs ausgewählt ist.

Return Value

Der vorverarbeitete Wert.

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


RegisterStreamInPorts Method

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..RegisterStreamInPorts Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


TraceError Method

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..TraceError Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..TraceInfo Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..TraceVerbose Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..TraceVerboseData Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..TraceWarning Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


Work Method

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..Work Method
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides CockpitNode..::..Work(TokenSet).)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


Work Method (TokenSet)

[image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..Work Method (TokenSet)
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public override void Work(
    TokenSet ts
)
Visual Basic
Public Overrides Sub Work ( _
    ts As TokenSet _
)
F#
abstract Work :
        ts:TokenSet -> unit
override Work :
        ts:TokenSet -> unit

Parameters

ts
Type: DynamicNode.Core..::..TokenSet
Das TokenSet mit den aktuellen Tokens aller Eingänge.

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
Work Overload
DynamicNode.Ext.Cockpit Namespace


CockpitOutputNode(T) Properties

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)> Properties
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitOutputNode<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | CockpitExtension | Gibt die CockpitExtension zurück, welche die Eigenschaften des Cockpitsteuerelements kapselt. (Overrides CockpitNode..::..CockpitExtension.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Icon | Gibt das Symbol des Cockpit-Steuerelements zurück oder legt es fest. (Inherited from CockpitNode.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | ValueInPort | Gibt den Eingang für den anzuzeigenden Wert zurück.
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitExtension Property

[image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..CockpitExtension Property
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die CockpitExtension zurück, welche die Eigenschaften des Cockpitsteuerelements kapselt.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override CockpitExtension CockpitExtension { get; }
Visual Basic
Protected Overrides ReadOnly Property CockpitExtension As CockpitExtension
    Get
F#
abstract CockpitExtension : CockpitExtension
override CockpitExtension : CockpitExtension

Field Value

Die Cockpit-Steuerelement-Erweiterung.

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


Item Property

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..Item Property
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
CockpitOutputNode<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


ValueInPort Property

[image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)>..::..ValueInPort Property
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Eingang für den anzuzeigenden Wert zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected InPort ValueInPort { get; }
Visual Basic
Protected ReadOnly Property ValueInPort As InPort
    Get
F#
member ValueInPort : InPort

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitOutputNode(T) Events

[image] [image]

DynamicNodes API
CockpitOutputNode<(Of <(<'T>)>)> Events
CockpitOutputNode<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitOutputNode<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

CockpitOutputNode<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitPanel Class

[image]

DynamicNodes API
CockpitPanel Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Container-Steuerelement zur Aufnahme von mehreren Cockpit-Steuerelementen.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public class CockpitPanel : UserControl
Visual Basic
Public Class CockpitPanel _
    Inherits UserControl
F#
type CockpitPanel =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Cockpit..::..CockpitPanel

See Also

CockpitPanel Members
DynamicNode.Ext.Cockpit Namespace


CockpitPanel Members

[image] [image]

DynamicNodes API
CockpitPanel Members
CockpitPanel Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitPanel type exposes the following members.

Constructors

 | Name | Description
Public method | CockpitPanel | Initialisiert eine neue Instanz von CockpitPanel.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)

Properties

 | Name | Description
Public property | AutoHeight | Gibt einen Wert zurück oder legt ihn fest der angibt, ob das Panel seine Höhe automatisch an die Höhe der enthaltenen Cockpit-Steuerelemente anpassen soll.
Public property | Graph | Gibt den Graphen zurück, dessen Cokcpit-Steuerelemente dargestellt werden sollen oder legt ihn fest.
Public property | UsedHeight | Gibt die Höhe zurück, die von den Cockpit-Steuerelementen benötigt wird.

See Also

CockpitPanel Class
DynamicNode.Ext.Cockpit Namespace


CockpitPanel Constructor

[image]

DynamicNodes API
CockpitPanel Constructor
CockpitPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von CockpitPanel.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public CockpitPanel()
Visual Basic
Public Sub New
F#
new : unit -> CockpitPanel

See Also

CockpitPanel Class
DynamicNode.Ext.Cockpit Namespace


CockpitPanel Methods

[image] [image]

DynamicNodes API
CockpitPanel Methods
CockpitPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitPanel type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

CockpitPanel Class
DynamicNode.Ext.Cockpit Namespace


Dispose Method

[image]

DynamicNodes API
CockpitPanel..::..Dispose Method
CockpitPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

CockpitPanel Class
DynamicNode.Ext.Cockpit Namespace


CockpitPanel Properties

[image] [image]

DynamicNodes API
CockpitPanel Properties
CockpitPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitPanel type exposes the following members.

Properties

 | Name | Description
Public property | AutoHeight | Gibt einen Wert zurück oder legt ihn fest der angibt, ob das Panel seine Höhe automatisch an die Höhe der enthaltenen Cockpit-Steuerelemente anpassen soll.
Public property | Graph | Gibt den Graphen zurück, dessen Cokcpit-Steuerelemente dargestellt werden sollen oder legt ihn fest.
Public property | UsedHeight | Gibt die Höhe zurück, die von den Cockpit-Steuerelementen benötigt wird.

See Also

CockpitPanel Class
DynamicNode.Ext.Cockpit Namespace


AutoHeight Property

[image]

DynamicNodes API
CockpitPanel..::..AutoHeight Property
CockpitPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest der angibt, ob das Panel seine Höhe automatisch an die Höhe der enthaltenen Cockpit-Steuerelemente anpassen soll.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public bool AutoHeight { get; set; }
Visual Basic
Public Property AutoHeight As Boolean
    Get
    Set
F#
member AutoHeight : bool with get, set

See Also

CockpitPanel Class
DynamicNode.Ext.Cockpit Namespace


Graph Property

[image]

DynamicNodes API
CockpitPanel..::..Graph Property
CockpitPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Graphen zurück, dessen Cokcpit-Steuerelemente dargestellt werden sollen oder legt ihn fest.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public IGraph Graph { get; set; }
Visual Basic
Public Property Graph As IGraph
    Get
    Set
F#
member Graph : IGraph with get, set

Field Value

Der Graph, dessen Steuerelemente dargestellt werden sollen.

See Also

CockpitPanel Class
DynamicNode.Ext.Cockpit Namespace


UsedHeight Property

[image]

DynamicNodes API
CockpitPanel..::..UsedHeight Property
CockpitPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Höhe zurück, die von den Cockpit-Steuerelementen benötigt wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public int UsedHeight { get; private set; }
Visual Basic
Public Property UsedHeight As Integer
    Get
    Private Set
F#
member UsedHeight : int with get, private set

See Also

CockpitPanel Class
DynamicNode.Ext.Cockpit Namespace


CockpitPersistence Class

[image]

DynamicNodes API
CockpitPersistence Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Hilfsmethoden zum Sichern und Wiederherstellen von Cockpit-Eigenschaften mit einem IPropertyWriter und einem IPropertyReader zur Verfügung.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static class CockpitPersistence
Visual Basic
Public NotInheritable Class CockpitPersistence
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CockpitPersistence =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Cockpit..::..CockpitPersistence

See Also

CockpitPersistence Members
DynamicNode.Ext.Cockpit Namespace


CockpitPersistence Members

[image] [image]

DynamicNodes API
CockpitPersistence Members
CockpitPersistence Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitPersistence type exposes the following members.

Methods

Name | Description
ReadBoolean | Die Hilfsmethode zum Lesen von Boolean-Werten.
ReadByte | Die Hilfsmethode zum Lesen von Byte-Werten.
ReadDecimal | Die Hilfsmethode zum Lesen von Decimal-Werten.
ReadDouble | Die Hilfsmethode zum Lesen von Double-Werten.
ReadEnum<(Of <<'(T>)>>) | Die Hilfsmethode zum Lesen von Enum-Werten.
ReadInt16 | Die Hilfsmethode zum Lesen von Int16-Werten.
ReadInt32 | Die Hilfsmethode zum Lesen von Int32-Werten.
ReadInt64 | Die Hilfsmethode zum Lesen von Int64-Werten.
ReadObject<(Of <<'(T>)>>) | Die Hilfsmethode zum Lesen von IXmlSerializable-Werten.
ReadSingle | Die Hilfsmethode zum Lesen von Single-Werten.
ReadString | Die Hilfsmethode zum Lesen von String-Werten.
WriteBoolean | Die Hilfsmethode zum Schreiben von Boolean-Werten.
WriteByte | Die Hilfsmethode zum Schreiben von Byte-Werten.
WriteDecimal | Die Hilfsmethode zum Schreiben von Decimal-Werten.
WriteDouble | Die Hilfsmethode zum Schreiben von Double-Werten.
WriteEnum<(Of <<'(T>)>>) | Die Hilfsmethode zum Schreiben von Enum-Werten.
WriteInt16 | Die Hilfsmethode zum Schreiben von Int16-Werten.
WriteInt32 | Die Hilfsmethode zum Schreiben von Int32-Werten.
WriteInt64 | Die Hilfsmethode zum Schreiben von Int64-Werten.
WriteObject<(Of <<'(T>)>>) | Die Hilfsmethode zum Schreiben von IXmlSerializable-Werten.
WriteSingle | Die Hilfsmethode zum Schreiben von Single-Werten.
WriteString | Die Hilfsmethode zum Schreiben von String-Werten.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


CockpitPersistence Methods

[image] [image]

DynamicNodes API
CockpitPersistence Methods
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitPersistence type exposes the following members.

Methods

Name | Description
ReadBoolean | Die Hilfsmethode zum Lesen von Boolean-Werten.
ReadByte | Die Hilfsmethode zum Lesen von Byte-Werten.
ReadDecimal | Die Hilfsmethode zum Lesen von Decimal-Werten.
ReadDouble | Die Hilfsmethode zum Lesen von Double-Werten.
ReadEnum<(Of <<'(T>)>>) | Die Hilfsmethode zum Lesen von Enum-Werten.
ReadInt16 | Die Hilfsmethode zum Lesen von Int16-Werten.
ReadInt32 | Die Hilfsmethode zum Lesen von Int32-Werten.
ReadInt64 | Die Hilfsmethode zum Lesen von Int64-Werten.
ReadObject<(Of <<'(T>)>>) | Die Hilfsmethode zum Lesen von IXmlSerializable-Werten.
ReadSingle | Die Hilfsmethode zum Lesen von Single-Werten.
ReadString | Die Hilfsmethode zum Lesen von String-Werten.
WriteBoolean | Die Hilfsmethode zum Schreiben von Boolean-Werten.
WriteByte | Die Hilfsmethode zum Schreiben von Byte-Werten.
WriteDecimal | Die Hilfsmethode zum Schreiben von Decimal-Werten.
WriteDouble | Die Hilfsmethode zum Schreiben von Double-Werten.
WriteEnum<(Of <<'(T>)>>) | Die Hilfsmethode zum Schreiben von Enum-Werten.
WriteInt16 | Die Hilfsmethode zum Schreiben von Int16-Werten.
WriteInt32 | Die Hilfsmethode zum Schreiben von Int32-Werten.
WriteInt64 | Die Hilfsmethode zum Schreiben von Int64-Werten.
WriteObject<(Of <<'(T>)>>) | Die Hilfsmethode zum Schreiben von IXmlSerializable-Werten.
WriteSingle | Die Hilfsmethode zum Schreiben von Single-Werten.
WriteString | Die Hilfsmethode zum Schreiben von String-Werten.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadBoolean Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadBoolean Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von Boolean-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadBoolean(
    CockpitPropertyInstance<bool> instance,
    IPropertyReader pr
)
Visual Basic
Public Shared Sub ReadBoolean ( _
    instance As CockpitPropertyInstance(Of Boolean), _
    pr As IPropertyReader _
)
F#
static member ReadBoolean :
        instance:CockpitPropertyInstance<bool> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Boolean >)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadByte Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadByte Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von Byte-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadByte(
    CockpitPropertyInstance<byte> instance,
    IPropertyReader pr
)
Visual Basic
Public Shared Sub ReadByte ( _
    instance As CockpitPropertyInstance(Of Byte), _
    pr As IPropertyReader _
)
F#
static member ReadByte :
        instance:CockpitPropertyInstance<byte> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Byte >)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadDecimal Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadDecimal Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von Decimal-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadDecimal(
    CockpitPropertyInstance<decimal> instance,
    IPropertyReader pr
)
Visual Basic
Public Shared Sub ReadDecimal ( _
    instance As CockpitPropertyInstance(Of Decimal), _
    pr As IPropertyReader _
)
F#
static member ReadDecimal :
        instance:CockpitPropertyInstance<decimal> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Decimal >)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadDouble Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadDouble Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von Double-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadDouble(
    CockpitPropertyInstance<double> instance,
    IPropertyReader pr
)
Visual Basic
Public Shared Sub ReadDouble ( _
    instance As CockpitPropertyInstance(Of Double), _
    pr As IPropertyReader _
)
F#
static member ReadDouble :
        instance:CockpitPropertyInstance<float> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Double >)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadEnum(T) Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadEnum<(Of <(<'T>)>)> Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von Enum-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadEnum<T>(
    CockpitPropertyInstance<T> instance,
    IPropertyReader pr
)
Visual Basic
Public Shared Sub ReadEnum(Of T) ( _
    instance As CockpitPropertyInstance(Of T), _
    pr As IPropertyReader _
)
F#
static member ReadEnum :
        instance:CockpitPropertyInstance<'T> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<'T>)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

Type Parameters

T
Der Typ der Aufzählung.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadInt16 Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadInt16 Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von Int16-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadInt16(
    CockpitPropertyInstance<short> instance,
    IPropertyReader pr
)
Visual Basic
Public Shared Sub ReadInt16 ( _
    instance As CockpitPropertyInstance(Of Short), _
    pr As IPropertyReader _
)
F#
static member ReadInt16 :
        instance:CockpitPropertyInstance<int16> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Int16 >)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadInt32 Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadInt32 Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von Int32-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadInt32(
    CockpitPropertyInstance<int> instance,
    IPropertyReader pr
)
Visual Basic
Public Shared Sub ReadInt32 ( _
    instance As CockpitPropertyInstance(Of Integer), _
    pr As IPropertyReader _
)
F#
static member ReadInt32 :
        instance:CockpitPropertyInstance<int> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Int32 >)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadInt64 Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadInt64 Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von Int64-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadInt64(
    CockpitPropertyInstance<long> instance,
    IPropertyReader pr
)
Visual Basic
Public Shared Sub ReadInt64 ( _
    instance As CockpitPropertyInstance(Of Long), _
    pr As IPropertyReader _
)
F#
static member ReadInt64 :
        instance:CockpitPropertyInstance<int64> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Int64 >)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadObject(T) Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadObject<(Of <(<'T>)>)> Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von IXmlSerializable-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadObject<T>(
    CockpitPropertyInstance<T> instance,
    IPropertyReader pr
)
where T : IXmlSerializable
Visual Basic
Public Shared Sub ReadObject(Of T As IXmlSerializable) ( _
    instance As CockpitPropertyInstance(Of T), _
    pr As IPropertyReader _
)
F#
static member ReadObject :
        instance:CockpitPropertyInstance<'T> *
        pr:IPropertyReader -> unit  when 'T : IXmlSerializable

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<'T>)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:DynamicNode.Ext.Cockpit.CockpitPersistence.ReadObject``1(DynamicNode.Ext.Cockpit.CockpitPropertyInstance{``0},DynamicNode.Persistence.IPropertyReader)"]

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadSingle Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadSingle Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von Single-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadSingle(
    CockpitPropertyInstance<float> instance,
    IPropertyReader pr
)
Visual Basic
Public Shared Sub ReadSingle ( _
    instance As CockpitPropertyInstance(Of Single), _
    pr As IPropertyReader _
)
F#
static member ReadSingle :
        instance:CockpitPropertyInstance<float32> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Single >)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


ReadString Method

[image]

DynamicNodes API
CockpitPersistence..::..ReadString Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Lesen von String-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void ReadString(
    CockpitPropertyInstance<string> instance,
    IPropertyReader pr
)
Visual Basic
Public Shared Sub ReadString ( _
    instance As CockpitPropertyInstance(Of String), _
    pr As IPropertyReader _
)
F#
static member ReadString :
        instance:CockpitPropertyInstance<string> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' String >)>)>
Die Eigenschaft deren Wert wiederhergestellt werden soll.
pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der Eigenschaftsleser.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteBoolean Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteBoolean Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von Boolean-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteBoolean(
    CockpitPropertyInstance<bool> instance,
    IPropertyWriter pw
)
Visual Basic
Public Shared Sub WriteBoolean ( _
    instance As CockpitPropertyInstance(Of Boolean), _
    pw As IPropertyWriter _
)
F#
static member WriteBoolean :
        instance:CockpitPropertyInstance<bool> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Boolean >)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteByte Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteByte Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von Byte-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteByte(
    CockpitPropertyInstance<byte> instance,
    IPropertyWriter pw
)
Visual Basic
Public Shared Sub WriteByte ( _
    instance As CockpitPropertyInstance(Of Byte), _
    pw As IPropertyWriter _
)
F#
static member WriteByte :
        instance:CockpitPropertyInstance<byte> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Byte >)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteDecimal Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteDecimal Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von Decimal-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteDecimal(
    CockpitPropertyInstance<decimal> instance,
    IPropertyWriter pw
)
Visual Basic
Public Shared Sub WriteDecimal ( _
    instance As CockpitPropertyInstance(Of Decimal), _
    pw As IPropertyWriter _
)
F#
static member WriteDecimal :
        instance:CockpitPropertyInstance<decimal> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Decimal >)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteDouble Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteDouble Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von Double-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteDouble(
    CockpitPropertyInstance<double> instance,
    IPropertyWriter pw
)
Visual Basic
Public Shared Sub WriteDouble ( _
    instance As CockpitPropertyInstance(Of Double), _
    pw As IPropertyWriter _
)
F#
static member WriteDouble :
        instance:CockpitPropertyInstance<float> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Double >)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteEnum(T) Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteEnum<(Of <(<'T>)>)> Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von Enum-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteEnum<T>(
    CockpitPropertyInstance<T> instance,
    IPropertyWriter pw
)
Visual Basic
Public Shared Sub WriteEnum(Of T) ( _
    instance As CockpitPropertyInstance(Of T), _
    pw As IPropertyWriter _
)
F#
static member WriteEnum :
        instance:CockpitPropertyInstance<'T> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<'T>)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:DynamicNode.Ext.Cockpit.CockpitPersistence.WriteEnum``1(DynamicNode.Ext.Cockpit.CockpitPropertyInstance{``0},DynamicNode.Persistence.IPropertyWriter)"]

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteInt16 Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteInt16 Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von Int16-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteInt16(
    CockpitPropertyInstance<short> instance,
    IPropertyWriter pw
)
Visual Basic
Public Shared Sub WriteInt16 ( _
    instance As CockpitPropertyInstance(Of Short), _
    pw As IPropertyWriter _
)
F#
static member WriteInt16 :
        instance:CockpitPropertyInstance<int16> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Int16 >)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteInt32 Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteInt32 Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von Int32-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteInt32(
    CockpitPropertyInstance<int> instance,
    IPropertyWriter pw
)
Visual Basic
Public Shared Sub WriteInt32 ( _
    instance As CockpitPropertyInstance(Of Integer), _
    pw As IPropertyWriter _
)
F#
static member WriteInt32 :
        instance:CockpitPropertyInstance<int> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Int32 >)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteInt64 Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteInt64 Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von Int64-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteInt64(
    CockpitPropertyInstance<long> instance,
    IPropertyWriter pw
)
Visual Basic
Public Shared Sub WriteInt64 ( _
    instance As CockpitPropertyInstance(Of Long), _
    pw As IPropertyWriter _
)
F#
static member WriteInt64 :
        instance:CockpitPropertyInstance<int64> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Int64 >)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteObject(T) Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteObject<(Of <(<'T>)>)> Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von IXmlSerializable-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteObject<T>(
    CockpitPropertyInstance<T> instance,
    IPropertyWriter pw
)
where T : IXmlSerializable
Visual Basic
Public Shared Sub WriteObject(Of T As IXmlSerializable) ( _
    instance As CockpitPropertyInstance(Of T), _
    pw As IPropertyWriter _
)
F#
static member WriteObject :
        instance:CockpitPropertyInstance<'T> *
        pw:IPropertyWriter -> unit  when 'T : IXmlSerializable

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<'T>)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:DynamicNode.Ext.Cockpit.CockpitPersistence.WriteObject``1(DynamicNode.Ext.Cockpit.CockpitPropertyInstance{``0},DynamicNode.Persistence.IPropertyWriter)"]

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteSingle Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteSingle Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von Single-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteSingle(
    CockpitPropertyInstance<float> instance,
    IPropertyWriter pw
)
Visual Basic
Public Shared Sub WriteSingle ( _
    instance As CockpitPropertyInstance(Of Single), _
    pw As IPropertyWriter _
)
F#
static member WriteSingle :
        instance:CockpitPropertyInstance<float32> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' Single >)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


WriteString Method

[image]

DynamicNodes API
CockpitPersistence..::..WriteString Method
CockpitPersistence Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Hilfsmethode zum Schreiben von String-Werten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public static void WriteString(
    CockpitPropertyInstance<string> instance,
    IPropertyWriter pw
)
Visual Basic
Public Shared Sub WriteString ( _
    instance As CockpitPropertyInstance(Of String), _
    pw As IPropertyWriter _
)
F#
static member WriteString :
        instance:CockpitPropertyInstance<string> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<' String >)>)>
Die Eigenschaft deren Wert gesichert werden soll.
pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der Eigenschaftsschreiber.

See Also

CockpitPersistence Class
DynamicNode.Ext.Cockpit Namespace


CockpitProperty(T) Class

[image]

DynamicNodes API
CockpitProperty<(Of <(<'T>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der statische Kontext einer Eigenschaft.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public class CockpitProperty<T> : ICockpitPropertyContext
Visual Basic
Public Class CockpitProperty(Of T) _
    Implements ICockpitPropertyContext
F#
type CockpitProperty<'T> =
    class
        interface ICockpitPropertyContext
    end

Type Parameters

T
Der Datentype des Eigenschaftswertes.

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Cockpit..::..CockpitProperty<(Of <(<'T>)>)>

See Also

CockpitProperty<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


CockpitProperty(T) Members

[image] [image]

DynamicNodes API
CockpitProperty<(Of <(<'T>)>)> Members
CockpitProperty<(Of <(<'T>)>)> Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitProperty<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | CockpitProperty<(Of <(<'T>)>)> | Initialisiert eine neue CockpitProperty<(Of <(<'T>)>)>-Instanz.

Properties

 | Name | Description
Public property | DefaultValue | Gibt den Standardwert der Eigenschaft zurück.
Public property | DefaultValueAsObject | Gibt den allgemeinen Standardwert der Eigenschaft zurück.
Public property | Name | Gibt den Namen der Eigenschaft zurück.
Public property | ReadMethod | Gibt die Hilfmethode zum Lesen eines Eigenschaftswertes aus einem IPropertyReader zurück.
Public property | SortIndex | Gibt einen Sortierindex zurück, der für die Anzeige von mehreren Eigenschaften benutzt werden kann.
Public property | WriteMethod | Gibt die Hilfmethode zum Schreiben eines Eigenschaftswertes in einen IPropertyWriter zurück.

See Also

CockpitProperty<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitProperty(T) Constructor

[image]

DynamicNodes API
CockpitProperty<(Of <(<'T>)>)> Constructor
CockpitProperty<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue CockpitProperty<(Of <(<'T>)>)>-Instanz.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public CockpitProperty(
    string name,
    T defaultValue,
    CockpitPropertyReader<T> readMethod,
    CockpitPropertyWriter<T> writeMethod,
    int sortIndex
)
Visual Basic
Public Sub New ( _
    name As String, _
    defaultValue As T, _
    readMethod As CockpitPropertyReader(Of T), _
    writeMethod As CockpitPropertyWriter(Of T), _
    sortIndex As Integer _
)
F#
new :
        name:string *
        defaultValue:'T *
        readMethod:CockpitPropertyReader<'T> *
        writeMethod:CockpitPropertyWriter<'T> *
        sortIndex:int -> CockpitProperty

Parameters

name
Type: System..::..String
Der Name.
defaultValue
Type: T
Der Standardwert.
readMethod
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyReader <(Of <(<' T >)>)>
Die Methode zum Wiederherstellen des Eigenschaftswertes.
writeMethod
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyWriter <(Of <(<' T >)>)>
Die Methode zum Sichern des Eigenschaftswertes.
sortIndex
Type: System..::..Int32
Der Sortierindex.

See Also

CockpitProperty<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitProperty(T) Properties

[image] [image]

DynamicNodes API
CockpitProperty<(Of <(<'T>)>)> Properties
CockpitProperty<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitProperty<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | DefaultValue | Gibt den Standardwert der Eigenschaft zurück.
Public property | DefaultValueAsObject | Gibt den allgemeinen Standardwert der Eigenschaft zurück.
Public property | Name | Gibt den Namen der Eigenschaft zurück.
Public property | ReadMethod | Gibt die Hilfmethode zum Lesen eines Eigenschaftswertes aus einem IPropertyReader zurück.
Public property | SortIndex | Gibt einen Sortierindex zurück, der für die Anzeige von mehreren Eigenschaften benutzt werden kann.
Public property | WriteMethod | Gibt die Hilfmethode zum Schreiben eines Eigenschaftswertes in einen IPropertyWriter zurück.

See Also

CockpitProperty<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


DefaultValue Property

[image]

DynamicNodes API
CockpitProperty<(Of <(<'T>)>)>..::..DefaultValue Property
CockpitProperty<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standardwert der Eigenschaft zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public T DefaultValue { get; private set; }
Visual Basic
Public Property DefaultValue As T
    Get
    Private Set
F#
member DefaultValue : 'T with get, private set

Field Value

Der Standardwert der Eigenschaft.

See Also

CockpitProperty<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


DefaultValueAsObject Property

[image]

DynamicNodes API
CockpitProperty<(Of <(<'T>)>)>..::..DefaultValueAsObject Property
CockpitProperty<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den allgemeinen Standardwert der Eigenschaft zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public Object DefaultValueAsObject { get; }
Visual Basic
Public ReadOnly Property DefaultValueAsObject As Object
    Get
F#
abstract DefaultValueAsObject : Object
override DefaultValueAsObject : Object

Field Value

Der allgemeine Standardwert der Eigenschaft.

Implements

ICockpitPropertyContext..::..DefaultValueAsObject

See Also

CockpitProperty<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


Name Property

[image]

DynamicNodes API
CockpitProperty<(Of <(<'T>)>)>..::..Name Property
CockpitProperty<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen der Eigenschaft zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
F#
abstract Name : string with get, private set
override Name : string with get, private set

Field Value

Der Name der Eigenschaft.

Implements

ICockpitPropertyContext..::..Name

Remarks

Wird als Schlüssel beim Sichern der Eigenschaft verwendet.

See Also

CockpitProperty<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


ReadMethod Property

[image]

DynamicNodes API
CockpitProperty<(Of <(<'T>)>)>..::..ReadMethod Property
CockpitProperty<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Hilfmethode zum Lesen eines Eigenschaftswertes aus einem IPropertyReader zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public CockpitPropertyReader<T> ReadMethod { get; private set; }
Visual Basic
Public Property ReadMethod As CockpitPropertyReader(Of T)
    Get
    Private Set
F#
member ReadMethod : CockpitPropertyReader<'T> with get, private set

Field Value

Die Methode zum Wiederherstellen des Eigenschaftswertes.

See Also

CockpitProperty<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


SortIndex Property

[image]

DynamicNodes API
CockpitProperty<(Of <(<'T>)>)>..::..SortIndex Property
CockpitProperty<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Sortierindex zurück, der für die Anzeige von mehreren Eigenschaften benutzt werden kann.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public int SortIndex { get; private set; }
Visual Basic
Public Property SortIndex As Integer
    Get
    Private Set
F#
abstract SortIndex : int with get, private set
override SortIndex : int with get, private set

Field Value

Der Sortierindex.

Implements

ICockpitPropertyContext..::..SortIndex

See Also

CockpitProperty<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


WriteMethod Property

[image]

DynamicNodes API
CockpitProperty<(Of <(<'T>)>)>..::..WriteMethod Property
CockpitProperty<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Hilfmethode zum Schreiben eines Eigenschaftswertes in einen IPropertyWriter zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public CockpitPropertyWriter<T> WriteMethod { get; private set; }
Visual Basic
Public Property WriteMethod As CockpitPropertyWriter(Of T)
    Get
    Private Set
F#
member WriteMethod : CockpitPropertyWriter<'T> with get, private set

Field Value

Die Methode zum Sichern des Eigenschaftswertes.

See Also

CockpitProperty<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitPropertyInstance(T) Class

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt eine Wert-Instanz für eine Eigenschaft (CockpitProperty<(Of <(<'T>)>)>) dar.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public class CockpitPropertyInstance<T> : ICockpitPropertyInstance,
    IStorable
Visual Basic
Public Class CockpitPropertyInstance(Of T) _
    Implements ICockpitPropertyInstance, IStorable
F#
type CockpitPropertyInstance<'T> =
    class
        interface ICockpitPropertyInstance
        interface IStorable
    end

Type Parameters

T
Der Typ des Eigenschaftswertes.

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance<(Of <(<'T>)>)>

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Members
DynamicNode.Ext.Cockpit Namespace


CockpitPropertyInstance(T) Members

[image] [image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)> Members
CockpitPropertyInstance<(Of <(<'T>)>)> Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitPropertyInstance<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | CockpitPropertyInstance<(Of <(<'T>)>)> | Initialisiert eine neue CockpitPropertyInstance<(Of <(<'T>)>)>-Instanz.

Methods

 | Name | Description
Public method | CreateInPort | Erzeugt in dem übergebenen Cockpit-Knoten einen Eingang als Schnittstelle für diese Eigenschaft.
Public method | DisposeInPort | Entsorgt den verbundenen Eingang.
Protected method | OnIsInPortConnectedChanged | Löst das Ereignis IsInPortConnectedChanged mit Hilfe des Synchronistationskontextes SyncContext aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Protected method | OnValueChanged | Löst das Ereignis ValueChanged auf dem Thread des Synchronisations-Kontextes (SyncContext) aus.
Public method | UpdateFromInPort | Versucht von PropertyInPort einen aktuellen Wert zu erhalten und den Wert der Eigenschaft damit zu aktualisieren.

Properties

 | Name | Description
Public property | IsInPortConnected | Gibt einen Wert zurück, der angibt ob der Eingang PropertyInPort verbunden ist oder nicht.
Public property | Property | Gibt die Eigenschaft dieser Instanz zurück.
Public property | PropertyContext | Gibt den allgemeinen statischen Eigenschaftskontext zurück.
Public property | PropertyInPort | Gibt den Eingang zurück, der als Schnittstelle für diese Eigenschaft dient.
Public property | SyncContext | Liest oder schreibt den Synchronisationskontext, mit dessen Hilfe das ValueChanged-Ereignis ausgelöst werden soll.
Public property | Value | Liest oder schreibt des Wert der Eigenschaft.
Public property | ValueAsObject | Gibt den Wert der Eigenschaft als Object zurück.

Events

 | Name | Description
Public event | IsInPortConnectedChanged | Tritt auf wenn IsInPortConnected geändert wurde.
Public event | ValueChanged | Tritt auf wenn der Wert der Eigenschaft geändert wurde.

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitPropertyInstance(T) Constructor

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)> Constructor
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue CockpitPropertyInstance<(Of <(<'T>)>)>-Instanz.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public CockpitPropertyInstance(
    CockpitProperty<T> property
)
Visual Basic
Public Sub New ( _
    property As CockpitProperty(Of T) _
)
F#
new :
        property:CockpitProperty<'T> -> CockpitPropertyInstance

Parameters

property
Type: DynamicNode.Ext.Cockpit..::..CockpitProperty <(Of <(<' T >)>)>
Die Eigenschaft.

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitPropertyInstance(T) Methods

[image] [image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)> Methods
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitPropertyInstance<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CreateInPort | Erzeugt in dem übergebenen Cockpit-Knoten einen Eingang als Schnittstelle für diese Eigenschaft.
Public method | DisposeInPort | Entsorgt den verbundenen Eingang.
Protected method | OnIsInPortConnectedChanged | Löst das Ereignis IsInPortConnectedChanged mit Hilfe des Synchronistationskontextes SyncContext aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Protected method | OnValueChanged | Löst das Ereignis ValueChanged auf dem Thread des Synchronisations-Kontextes (SyncContext) aus.
Public method | UpdateFromInPort | Versucht von PropertyInPort einen aktuellen Wert zu erhalten und den Wert der Eigenschaft damit zu aktualisieren.

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CreateInPort Method

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..CreateInPort Method
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt in dem übergebenen Cockpit-Knoten einen Eingang als Schnittstelle für diese Eigenschaft.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public void CreateInPort(
    CockpitNode node
)
Visual Basic
Public Sub CreateInPort ( _
    node As CockpitNode _
)
F#
abstract CreateInPort :
        node:CockpitNode -> unit
override CreateInPort :
        node:CockpitNode -> unit

Parameters

node
Type: DynamicNode.Ext.Cockpit..::..CockpitNode
Der Cockpit-Knoten.

Implements

ICockpitPropertyInstance..::..CreateInPort(CockpitNode)

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


DisposeInPort Method

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..DisposeInPort Method
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entsorgt den verbundenen Eingang.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public void DisposeInPort()
Visual Basic
Public Sub DisposeInPort
F#
abstract DisposeInPort : unit -> unit
override DisposeInPort : unit -> unit

Implements

ICockpitPropertyInstance..::..DisposeInPort()()()()

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


OnIsInPortConnectedChanged Method

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..OnIsInPortConnectedChanged Method
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis IsInPortConnectedChanged mit Hilfe des Synchronistationskontextes SyncContext aus.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected virtual void OnIsInPortConnectedChanged()
Visual Basic
Protected Overridable Sub OnIsInPortConnectedChanged
F#
abstract OnIsInPortConnectedChanged : unit -> unit
override OnIsInPortConnectedChanged : unit -> unit

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


OnRestore Method

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..OnRestore Method
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


OnStore Method

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..OnStore Method
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


OnValueChanged Method

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..OnValueChanged Method
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis ValueChanged auf dem Thread des Synchronisations-Kontextes (SyncContext) aus.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected virtual void OnValueChanged()
Visual Basic
Protected Overridable Sub OnValueChanged
F#
abstract OnValueChanged : unit -> unit
override OnValueChanged : unit -> unit

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


UpdateFromInPort Method

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..UpdateFromInPort Method
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht von PropertyInPort einen aktuellen Wert zu erhalten und den Wert der Eigenschaft damit zu aktualisieren.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public void UpdateFromInPort()
Visual Basic
Public Sub UpdateFromInPort
F#
abstract UpdateFromInPort : unit -> unit
override UpdateFromInPort : unit -> unit

Implements

ICockpitPropertyInstance..::..UpdateFromInPort()()()()

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitPropertyInstance(T) Properties

[image] [image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)> Properties
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitPropertyInstance<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | IsInPortConnected | Gibt einen Wert zurück, der angibt ob der Eingang PropertyInPort verbunden ist oder nicht.
Public property | Property | Gibt die Eigenschaft dieser Instanz zurück.
Public property | PropertyContext | Gibt den allgemeinen statischen Eigenschaftskontext zurück.
Public property | PropertyInPort | Gibt den Eingang zurück, der als Schnittstelle für diese Eigenschaft dient.
Public property | SyncContext | Liest oder schreibt den Synchronisationskontext, mit dessen Hilfe das ValueChanged-Ereignis ausgelöst werden soll.
Public property | Value | Liest oder schreibt des Wert der Eigenschaft.
Public property | ValueAsObject | Gibt den Wert der Eigenschaft als Object zurück.

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


IsInPortConnected Property

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..IsInPortConnected Property
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob der Eingang PropertyInPort verbunden ist oder nicht.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public bool IsInPortConnected { get; }
Visual Basic
Public ReadOnly Property IsInPortConnected As Boolean
    Get
F#
abstract IsInPortConnected : bool
override IsInPortConnected : bool

Field Value

true wenn der Eingang PropertyInPort verbunden ist, sonst false.

Implements

ICockpitPropertyInstance..::..IsInPortConnected

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


Property Property

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..Property Property
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Eigenschaft dieser Instanz zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public CockpitProperty<T> Property { get; }
Visual Basic
Public ReadOnly Property Property As CockpitProperty(Of T)
    Get
F#
member Property : CockpitProperty<'T>

Field Value

Die Eigenschaft.

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


PropertyContext Property

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..PropertyContext Property
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den allgemeinen statischen Eigenschaftskontext zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public ICockpitPropertyContext PropertyContext { get; }
Visual Basic
Public ReadOnly Property PropertyContext As ICockpitPropertyContext
    Get
F#
abstract PropertyContext : ICockpitPropertyContext
override PropertyContext : ICockpitPropertyContext

Field Value

Der allgemeine statische Eigenschaftskontext.

Implements

ICockpitPropertyInstance..::..PropertyContext

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


PropertyInPort Property

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..PropertyInPort Property
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Eingang zurück, der als Schnittstelle für diese Eigenschaft dient.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public InPort PropertyInPort { get; }
Visual Basic
Public ReadOnly Property PropertyInPort As InPort
    Get
F#
abstract PropertyInPort : InPort
override PropertyInPort : InPort

Field Value

Der Eingang dieser Eigenschaft.

Implements

ICockpitPropertyInstance..::..PropertyInPort

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


SyncContext Property

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..SyncContext Property
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Synchronisationskontext, mit dessen Hilfe das ValueChanged-Ereignis ausgelöst werden soll.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public IPropertySyncContext SyncContext { get; set; }
Visual Basic
Public Property SyncContext As IPropertySyncContext
    Get
    Set
F#
abstract SyncContext : IPropertySyncContext with get, set
override SyncContext : IPropertySyncContext with get, set

Field Value

Der Synchronisationskontext für ValueChanged.

Implements

ICockpitPropertyInstance..::..SyncContext

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


Value Property

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..Value Property
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt des Wert der Eigenschaft.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public T Value { get; set; }
Visual Basic
Public Property Value As T
    Get
    Set
F#
member Value : 'T with get, set

Field Value

Der Wert.

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


ValueAsObject Property

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..ValueAsObject Property
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert der Eigenschaft als Object zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public Object ValueAsObject { get; }
Visual Basic
Public ReadOnly Property ValueAsObject As Object
    Get
F#
abstract ValueAsObject : Object
override ValueAsObject : Object

Field Value

Der Wert der Eigenschaft.

Implements

ICockpitPropertyInstance..::..ValueAsObject

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitPropertyInstance(T) Events

[image] [image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)> Events
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CockpitPropertyInstance<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | IsInPortConnectedChanged | Tritt auf wenn IsInPortConnected geändert wurde.
Public event | ValueChanged | Tritt auf wenn der Wert der Eigenschaft geändert wurde.

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


IsInPortConnectedChanged Event

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..IsInPortConnectedChanged Event
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn IsInPortConnected geändert wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public event EventHandler IsInPortConnectedChanged
Visual Basic
Public Event IsInPortConnectedChanged As EventHandler
F#
abstract IsInPortConnectedChanged : IEvent<EventHandler,
    EventArgs>
override IsInPortConnectedChanged : IEvent<EventHandler,
    EventArgs>

Implements

ICockpitPropertyInstance..::..IsInPortConnectedChanged

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


ValueChanged Event

[image]

DynamicNodes API
CockpitPropertyInstance<(Of <(<'T>)>)>..::..ValueChanged Event
CockpitPropertyInstance<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn der Wert der Eigenschaft geändert wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
F#
abstract ValueChanged : IEvent<EventHandler,
    EventArgs>
override ValueChanged : IEvent<EventHandler,
    EventArgs>

Implements

ICockpitPropertyInstance..::..ValueChanged

See Also

CockpitPropertyInstance<(Of <(<'T>)>)> Class
DynamicNode.Ext.Cockpit Namespace


CockpitPropertyReader(T) Delegate

[image]

DynamicNodes API
CockpitPropertyReader<(Of <(<'T>)>)> Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Delegat zum Wiederherstellen von Eigenschaftswerten aus einem IPropertyReader.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public delegate void CockpitPropertyReader<T>(
    CockpitPropertyInstance<T> instance,
    IPropertyReader pr
)
Visual Basic
Public Delegate Sub CockpitPropertyReader(Of T) ( _
    instance As CockpitPropertyInstance(Of T), _
    pr As IPropertyReader _
)
F#
type CockpitPropertyReader =
    delegate of
        instance:CockpitPropertyInstance<'T> *
        pr:IPropertyReader -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<'T>)>)>
pr
Type: DynamicNode.Persistence..::..IPropertyReader

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:DynamicNode.Ext.Cockpit.CockpitPropertyReader`1"]

See Also

DynamicNode.Ext.Cockpit Namespace


CockpitPropertyWriter(T) Delegate

[image]

DynamicNodes API
CockpitPropertyWriter<(Of <(<'T>)>)> Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Delegat zum Sichern von Eigenschaftswerten in einen IPropertyWriter.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public delegate void CockpitPropertyWriter<T>(
    CockpitPropertyInstance<T> instance,
    IPropertyWriter pw
)
Visual Basic
Public Delegate Sub CockpitPropertyWriter(Of T) ( _
    instance As CockpitPropertyInstance(Of T), _
    pw As IPropertyWriter _
)
F#
type CockpitPropertyWriter =
    delegate of
        instance:CockpitPropertyInstance<'T> *
        pw:IPropertyWriter -> unit

Parameters

instance
Type: DynamicNode.Ext.Cockpit..::..CockpitPropertyInstance <(Of <(<'T>)>)>
pw
Type: DynamicNode.Persistence..::..IPropertyWriter

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:DynamicNode.Ext.Cockpit.CockpitPropertyWriter`1"]

See Also

DynamicNode.Ext.Cockpit Namespace


ControlSyncContext Class

[image]

DynamicNodes API
ControlSyncContext Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Synchronisationskontext für Windows-Forms-Steuerelemente.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public class ControlSyncContext : IPropertySyncContext
Visual Basic
Public Class ControlSyncContext _
    Implements IPropertySyncContext
F#
type ControlSyncContext =
    class
        interface IPropertySyncContext
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Cockpit..::..ControlSyncContext

See Also

ControlSyncContext Members
DynamicNode.Ext.Cockpit Namespace


ControlSyncContext Members

[image] [image]

DynamicNodes API
ControlSyncContext Members
ControlSyncContext Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ControlSyncContext type exposes the following members.

Constructors

 | Name | Description
Public method | ControlSyncContext | Initialisiert eine neue ControlSyncContext-Instanz.

Methods

 | Name | Description
Public method | Invoke | Ruft die übergebene Methode im Thread des Synchronisationskontextes auf.

Properties

 | Name | Description
Public property | InvokeRequired | Gibt einen Wert zurück, der angibt ob eine Synchronisation mit Invoke(SimpleMethod) notwendig ist oder nicht.

See Also

ControlSyncContext Class
DynamicNode.Ext.Cockpit Namespace


ControlSyncContext Constructor

[image]

DynamicNodes API
ControlSyncContext Constructor
ControlSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue ControlSyncContext-Instanz.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public ControlSyncContext(
    Control control
)
Visual Basic
Public Sub New ( _
    control As Control _
)
F#
new :
        control:Control -> ControlSyncContext

Parameters

control
Type: System.Windows.Forms..::..Control
Ein Windows-Forms-Steuerelement.

See Also

ControlSyncContext Class
DynamicNode.Ext.Cockpit Namespace


ControlSyncContext Methods

[image] [image]

DynamicNodes API
ControlSyncContext Methods
ControlSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ControlSyncContext type exposes the following members.

Methods

 | Name | Description
Public method | Invoke | Ruft die übergebene Methode im Thread des Synchronisationskontextes auf.

See Also

ControlSyncContext Class
DynamicNode.Ext.Cockpit Namespace


Invoke Method

[image]

DynamicNodes API
ControlSyncContext..::..Invoke Method
ControlSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die übergebene Methode im Thread des Synchronisationskontextes auf.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public void Invoke(
    SimpleMethod action
)
Visual Basic
Public Sub Invoke ( _
    action As SimpleMethod _
)
F#
abstract Invoke :
        action:SimpleMethod -> unit
override Invoke :
        action:SimpleMethod -> unit

Parameters

action
Type: DynamicNode.Core..::..SimpleMethod
Die aufzurufende Methode.

Implements

IPropertySyncContext..::..Invoke(SimpleMethod)

See Also

ControlSyncContext Class
DynamicNode.Ext.Cockpit Namespace


ControlSyncContext Properties

[image] [image]

DynamicNodes API
ControlSyncContext Properties
ControlSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ControlSyncContext type exposes the following members.

Properties

 | Name | Description
Public property | InvokeRequired | Gibt einen Wert zurück, der angibt ob eine Synchronisation mit Invoke(SimpleMethod) notwendig ist oder nicht.

See Also

ControlSyncContext Class
DynamicNode.Ext.Cockpit Namespace


InvokeRequired Property

[image]

DynamicNodes API
ControlSyncContext..::..InvokeRequired Property
ControlSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob eine Synchronisation mit Invoke(SimpleMethod) notwendig ist oder nicht.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public bool InvokeRequired { get; }
Visual Basic
Public ReadOnly Property InvokeRequired As Boolean
    Get
F#
abstract InvokeRequired : bool
override InvokeRequired : bool

Field Value

true wenn Invoke(SimpleMethod) aufgerufen werden muss, sonst false.

Implements

IPropertySyncContext..::..InvokeRequired

See Also

ControlSyncContext Class
DynamicNode.Ext.Cockpit Namespace


ICockpitPropertyContext Interface

[image]

DynamicNodes API
ICockpitPropertyContext Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die allgemeine Schnittstelle für einen Cockpit-Eigenschaftskontext.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public interface ICockpitPropertyContext
Visual Basic
Public Interface ICockpitPropertyContext
F#
type ICockpitPropertyContext =  interface end

Remarks

Diese Schnittstelle stellt keinen Zugriff auf den Standardwert der Cockpit-Eigenschaft zur Verfügung. Der Zugriff auf den Standardwert der Cockpit-Eigenschaft ist nur über die generische Klasse CockpitProperty<(Of <(<'T>)>)> möglich.

See Also

ICockpitPropertyContext Members
DynamicNode.Ext.Cockpit Namespace


ICockpitPropertyContext Members

[image] [image]

DynamicNodes API
ICockpitPropertyContext Members
ICockpitPropertyContext Interface Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ICockpitPropertyContext type exposes the following members.

Properties

 | Name | Description
Public property | DefaultValueAsObject | Gibt den allgemeinen Standardwert der Eigenschaft zurück.
Public property | Name | Gibt den Namen der Eigenschaft zurück.
Public property | SortIndex | Gibt einen Sortierindex zurück, der für die Anzeige von mehreren Eigenschaften benutzt werden kann.

See Also

ICockpitPropertyContext Interface
DynamicNode.Ext.Cockpit Namespace


ICockpitPropertyContext Properties

[image] [image]

DynamicNodes API
ICockpitPropertyContext Properties
ICockpitPropertyContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ICockpitPropertyContext type exposes the following members.

Properties

 | Name | Description
Public property | DefaultValueAsObject | Gibt den allgemeinen Standardwert der Eigenschaft zurück.
Public property | Name | Gibt den Namen der Eigenschaft zurück.
Public property | SortIndex | Gibt einen Sortierindex zurück, der für die Anzeige von mehreren Eigenschaften benutzt werden kann.

See Also

ICockpitPropertyContext Interface
DynamicNode.Ext.Cockpit Namespace


DefaultValueAsObject Property

[image]

DynamicNodes API
ICockpitPropertyContext..::..DefaultValueAsObject Property
ICockpitPropertyContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den allgemeinen Standardwert der Eigenschaft zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
Object DefaultValueAsObject { get; }
Visual Basic
ReadOnly Property DefaultValueAsObject As Object
    Get
F#
abstract DefaultValueAsObject : Object

Field Value

Der allgemeine Standardwert der Eigenschaft.

See Also

ICockpitPropertyContext Interface
DynamicNode.Ext.Cockpit Namespace


Name Property

[image]

DynamicNodes API
ICockpitPropertyContext..::..Name Property
ICockpitPropertyContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen der Eigenschaft zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
F#
abstract Name : string

Field Value

Der Name der Eigenschaft.

Remarks

Wird als Schlüssel beim Sichern der Eigenschaft verwendet.

See Also

ICockpitPropertyContext Interface
DynamicNode.Ext.Cockpit Namespace


SortIndex Property

[image]

DynamicNodes API
ICockpitPropertyContext..::..SortIndex Property
ICockpitPropertyContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Sortierindex zurück, der für die Anzeige von mehreren Eigenschaften benutzt werden kann.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
int SortIndex { get; }
Visual Basic
ReadOnly Property SortIndex As Integer
    Get
F#
abstract SortIndex : int

Field Value

Der Sortierindex.

See Also

ICockpitPropertyContext Interface
DynamicNode.Ext.Cockpit Namespace


ICockpitPropertyInstance Interface

[image]

DynamicNodes API
ICockpitPropertyInstance Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die allgemeine Schnittstelle für Cockpit-Eigenschaften.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public interface ICockpitPropertyInstance : IStorable
Visual Basic
Public Interface ICockpitPropertyInstance _
    Inherits IStorable
F#
type ICockpitPropertyInstance =
    interface
        interface IStorable
    end

Remarks

Diese Schnittstelle stellt keinen typsicheren Zugriff auf den Eigenschaftswert zur Verfügung. Der saubere Zugriff auf den Eigenschaftswert ist nur auf der generischen Klasse CockpitPropertyInstance<(Of <(<'T>)>)> möglich.

See Also

ICockpitPropertyInstance Members
DynamicNode.Ext.Cockpit Namespace


ICockpitPropertyInstance Members

[image] [image]

DynamicNodes API
ICockpitPropertyInstance Members
ICockpitPropertyInstance Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ICockpitPropertyInstance type exposes the following members.

Methods

 | Name | Description
Public method | CreateInPort | Erzeugt in dem übergebenen Cockpit-Knoten einen Eingang als Schnittstelle für diese Eigenschaft.
Public method | DisposeInPort | Entsorgt den verbundenen Eingang.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | UpdateFromInPort | Versucht von PropertyInPort einen aktuellen Wert zu erhalten und den Wert der Eigenschaft damit zu aktualisieren.

Properties

 | Name | Description
Public property | IsInPortConnected | Gibt einen Wert zurück, der angibt ob der Eingang PropertyInPort verbunden ist oder nicht.
Public property | PropertyContext | Gibt den allgemeinen statischen Eigenschaftskontext zurück.
Public property | PropertyInPort | Gibt den Eingang zurück, der als Schnittstelle für diese Eigenschaft dient.
Public property | SyncContext | Liest oder schreibt den Synchronisationskontext, mit dessen Hilfe das ValueChanged-Ereignis ausgelöst werden soll.
Public property | ValueAsObject | Gibt den Wert der Eigenschaft als Object zurück.

Events

 | Name | Description
Public event | IsInPortConnectedChanged | Tritt auf wenn IsInPortConnected geändert wurde.
Public event | ValueChanged | Tritt auf wenn der Wert der Eigenschaft geändert wurde.

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


ICockpitPropertyInstance Methods

[image] [image]

DynamicNodes API
ICockpitPropertyInstance Methods
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ICockpitPropertyInstance type exposes the following members.

Methods

 | Name | Description
Public method | CreateInPort | Erzeugt in dem übergebenen Cockpit-Knoten einen Eingang als Schnittstelle für diese Eigenschaft.
Public method | DisposeInPort | Entsorgt den verbundenen Eingang.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | UpdateFromInPort | Versucht von PropertyInPort einen aktuellen Wert zu erhalten und den Wert der Eigenschaft damit zu aktualisieren.

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


CreateInPort Method

[image]

DynamicNodes API
ICockpitPropertyInstance..::..CreateInPort Method
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt in dem übergebenen Cockpit-Knoten einen Eingang als Schnittstelle für diese Eigenschaft.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
void CreateInPort(
    CockpitNode node
)
Visual Basic
Sub CreateInPort ( _
    node As CockpitNode _
)
F#
abstract CreateInPort :
        node:CockpitNode -> unit

Parameters

node
Type: DynamicNode.Ext.Cockpit..::..CockpitNode
Der Cockpit-Knoten.

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


DisposeInPort Method

[image]

DynamicNodes API
ICockpitPropertyInstance..::..DisposeInPort Method
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entsorgt den verbundenen Eingang.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
void DisposeInPort()
Visual Basic
Sub DisposeInPort
F#
abstract DisposeInPort : unit -> unit

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


UpdateFromInPort Method

[image]

DynamicNodes API
ICockpitPropertyInstance..::..UpdateFromInPort Method
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht von PropertyInPort einen aktuellen Wert zu erhalten und den Wert der Eigenschaft damit zu aktualisieren.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
void UpdateFromInPort()
Visual Basic
Sub UpdateFromInPort
F#
abstract UpdateFromInPort : unit -> unit

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


ICockpitPropertyInstance Properties

[image] [image]

DynamicNodes API
ICockpitPropertyInstance Properties
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ICockpitPropertyInstance type exposes the following members.

Properties

 | Name | Description
Public property | IsInPortConnected | Gibt einen Wert zurück, der angibt ob der Eingang PropertyInPort verbunden ist oder nicht.
Public property | PropertyContext | Gibt den allgemeinen statischen Eigenschaftskontext zurück.
Public property | PropertyInPort | Gibt den Eingang zurück, der als Schnittstelle für diese Eigenschaft dient.
Public property | SyncContext | Liest oder schreibt den Synchronisationskontext, mit dessen Hilfe das ValueChanged-Ereignis ausgelöst werden soll.
Public property | ValueAsObject | Gibt den Wert der Eigenschaft als Object zurück.

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


IsInPortConnected Property

[image]

DynamicNodes API
ICockpitPropertyInstance..::..IsInPortConnected Property
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob der Eingang PropertyInPort verbunden ist oder nicht.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
bool IsInPortConnected { get; }
Visual Basic
ReadOnly Property IsInPortConnected As Boolean
    Get
F#
abstract IsInPortConnected : bool

Field Value

true wenn der Eingang PropertyInPort verbunden ist, sonst false.

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


PropertyContext Property

[image]

DynamicNodes API
ICockpitPropertyInstance..::..PropertyContext Property
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den allgemeinen statischen Eigenschaftskontext zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
ICockpitPropertyContext PropertyContext { get; }
Visual Basic
ReadOnly Property PropertyContext As ICockpitPropertyContext
    Get
F#
abstract PropertyContext : ICockpitPropertyContext

Field Value

Der allgemeine statische Eigenschaftskontext.

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


PropertyInPort Property

[image]

DynamicNodes API
ICockpitPropertyInstance..::..PropertyInPort Property
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Eingang zurück, der als Schnittstelle für diese Eigenschaft dient.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
InPort PropertyInPort { get; }
Visual Basic
ReadOnly Property PropertyInPort As InPort
    Get
F#
abstract PropertyInPort : InPort

Field Value

Der Eingang dieser Eigenschaft.

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


SyncContext Property

[image]

DynamicNodes API
ICockpitPropertyInstance..::..SyncContext Property
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Synchronisationskontext, mit dessen Hilfe das ValueChanged-Ereignis ausgelöst werden soll.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
IPropertySyncContext SyncContext { get; set; }
Visual Basic
Property SyncContext As IPropertySyncContext
    Get
    Set
F#
abstract SyncContext : IPropertySyncContext with get, set

Field Value

Der Synchronisationskontext für ValueChanged.

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


ValueAsObject Property

[image]

DynamicNodes API
ICockpitPropertyInstance..::..ValueAsObject Property
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert der Eigenschaft als Object zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
Object ValueAsObject { get; }
Visual Basic
ReadOnly Property ValueAsObject As Object
    Get
F#
abstract ValueAsObject : Object

Field Value

Der Wert der Eigenschaft.

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


ICockpitPropertyInstance Events

[image] [image]

DynamicNodes API
ICockpitPropertyInstance Events
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ICockpitPropertyInstance type exposes the following members.

Events

 | Name | Description
Public event | IsInPortConnectedChanged | Tritt auf wenn IsInPortConnected geändert wurde.
Public event | ValueChanged | Tritt auf wenn der Wert der Eigenschaft geändert wurde.

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


IsInPortConnectedChanged Event

[image]

DynamicNodes API
ICockpitPropertyInstance..::..IsInPortConnectedChanged Event
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn IsInPortConnected geändert wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
event EventHandler IsInPortConnectedChanged
Visual Basic
Event IsInPortConnectedChanged As EventHandler
F#
abstract IsInPortConnectedChanged : IEvent<EventHandler,
    EventArgs>

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


ValueChanged Event

[image]

DynamicNodes API
ICockpitPropertyInstance..::..ValueChanged Event
ICockpitPropertyInstance Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn der Wert der Eigenschaft geändert wurde.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
event EventHandler ValueChanged
Visual Basic
Event ValueChanged As EventHandler
F#
abstract ValueChanged : IEvent<EventHandler,
    EventArgs>

See Also

ICockpitPropertyInstance Interface
DynamicNode.Ext.Cockpit Namespace


IPropertySyncContext Interface

[image]

DynamicNodes API
IPropertySyncContext Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle eines Synchronisationskontexts.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public interface IPropertySyncContext
Visual Basic
Public Interface IPropertySyncContext
F#
type IPropertySyncContext =  interface end

See Also

IPropertySyncContext Members
DynamicNode.Ext.Cockpit Namespace


IPropertySyncContext Members

[image] [image]

DynamicNodes API
IPropertySyncContext Members
IPropertySyncContext Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPropertySyncContext type exposes the following members.

Methods

 | Name | Description
Public method | Invoke | Ruft die übergebene Methode im Thread des Synchronisationskontextes auf.

Properties

 | Name | Description
Public property | InvokeRequired | Gibt einen Wert zurück, der angibt ob eine Synchronisation mit Invoke(SimpleMethod) notwendig ist oder nicht.

See Also

IPropertySyncContext Interface
DynamicNode.Ext.Cockpit Namespace


IPropertySyncContext Methods

[image] [image]

DynamicNodes API
IPropertySyncContext Methods
IPropertySyncContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPropertySyncContext type exposes the following members.

Methods

 | Name | Description
Public method | Invoke | Ruft die übergebene Methode im Thread des Synchronisationskontextes auf.

See Also

IPropertySyncContext Interface
DynamicNode.Ext.Cockpit Namespace


Invoke Method

[image]

DynamicNodes API
IPropertySyncContext..::..Invoke Method
IPropertySyncContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die übergebene Methode im Thread des Synchronisationskontextes auf.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
void Invoke(
    SimpleMethod action
)
Visual Basic
Sub Invoke ( _
    action As SimpleMethod _
)
F#
abstract Invoke :
        action:SimpleMethod -> unit

Parameters

action
Type: DynamicNode.Core..::..SimpleMethod
Die aufzurufende Methode.

See Also

IPropertySyncContext Interface
DynamicNode.Ext.Cockpit Namespace


IPropertySyncContext Properties

[image] [image]

DynamicNodes API
IPropertySyncContext Properties
IPropertySyncContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPropertySyncContext type exposes the following members.

Properties

 | Name | Description
Public property | InvokeRequired | Gibt einen Wert zurück, der angibt ob eine Synchronisation mit Invoke(SimpleMethod) notwendig ist oder nicht.

See Also

IPropertySyncContext Interface
DynamicNode.Ext.Cockpit Namespace


InvokeRequired Property

[image]

DynamicNodes API
IPropertySyncContext..::..InvokeRequired Property
IPropertySyncContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob eine Synchronisation mit Invoke(SimpleMethod) notwendig ist oder nicht.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
bool InvokeRequired { get; }
Visual Basic
ReadOnly Property InvokeRequired As Boolean
    Get
F#
abstract InvokeRequired : bool

Field Value

true wenn Invoke(SimpleMethod) aufgerufen werden muss, sonst false.

See Also

IPropertySyncContext Interface
DynamicNode.Ext.Cockpit Namespace


TypedCockpitInputExtension(TValue) Class

[image]

DynamicNodes API
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für Cockpit-Erweiterungen die mit einem bestimmten Datentyp arbeiten.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public abstract class TypedCockpitInputExtension<TValue> : CockpitInputExtension
Visual Basic
Public MustInherit Class TypedCockpitInputExtension(Of TValue) _
    Inherits CockpitInputExtension
F#
[<AbstractClassAttribute>]
type TypedCockpitInputExtension<'TValue> =
    class
        inherit CockpitInputExtension
    end

Type Parameters

TValue
Der Datentyp des zu steuerenden Parameters.

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Cockpit..::..CockpitExtension
DynamicNode.Ext.Cockpit..::..CockpitInputExtension
DynamicNode.Ext.Cockpit..::..TypedCockpitInputExtension<(Of <(<'TValue>)>)>

See Also

TypedCockpitInputExtension<(Of <(<'TValue>)>)> Members
DynamicNode.Ext.Cockpit Namespace


TypedCockpitInputExtension(TValue) Members

[image] [image]

DynamicNodes API
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Members
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypedCockpitInputExtension<(Of <(<'TValue>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | TypedCockpitInputExtension<(Of <(<'TValue>)>)> | Initializes a new instance of the TypedCockpitInputExtension<(Of <(<'TValue>)>)> class

Methods

 | Name | Description
Public method | AfterAttaching | Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde. (Inherited from CockpitExtension.)
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde. (Inherited from CockpitExtension.)
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde. (Inherited from CockpitExtension.)
Public method | GetProperties | Gibt eine Aufzählung mit allen Cockpit-Eigenschaften dieser Cockpit-Erweiterung zurück. (Inherited from CockpitInputExtension.)
Protected method | OnPropertyChanged | Löst das Ereignis PropertyChanged aus. (Inherited from CockpitExtension.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from CockpitExtension.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from CockpitExtension.)
Protected method | OnValueChanged | Muss aufgerufen werden, wenn im Cockpit-Steuerelement der Wert verändert wurde. Ruft OnValuePublishing()()()() auf, wenn AutoPublish gleich true ist. (Inherited from CockpitInputExtension.)
Protected method | OnValuePublishing | Löst das Ereignis ValuePublishing aus. (Inherited from CockpitInputExtension.)
Protected method | UpdateSyncContext | Muss aufgerufen werden, wenn das Cockpit-Steuerelement erzeugt wird. (Inherited from CockpitExtension.)
Public method | UpdateValue | Aktualisiert den Wert. Wird vom Steuerelement aufgerufen.

Fields

 | Name | Description
Public field | AutoPublish | Ein Wert der angibt, ob Änderungen in der Benutzeroberfläche automatisch als neue Parameter-Werte weitergegeben werden. (Inherited from CockpitInputExtension.)
Public field | Name | Der Name des Cockpit-Parameters. (Inherited from CockpitExtension.)
Public field | SortIndex | Ein Wert der die Sortierung der Cockpit-Steuerelementen beeinflusst. (Inherited from CockpitExtension.)

Properties

 | Name | Description
Public property | CockpitControl | Gibt das Cockpitsteuerelement zurück. (Inherited from CockpitExtension.)
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist. (Inherited from CockpitExtension.)
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt. (Inherited from CockpitExtension.)
Public property | Node | Gibt den Knoten zurück, an den die Erweiterung gebunden wurde. (Inherited from CockpitExtension.)
Public property | SyncContext | Der Synchronisierungskontext für die Kommunikation des Knotens mit dem Cockpitsteuerelement. (Inherited from CockpitExtension.)
Public property | Value | Gibt den Wert des Cockpit-Steuerelements zurück.
Protected property | ValueAsObject | Gibt den aktuellen Wert des Cockpit-Steuerelements zurück. (Overrides CockpitInputExtension..::..ValueAsObject.)

Events

 | Name | Description
Public event | PropertyChanged | Tritt auf, wenn eine Eigenschaft dieses Objektes geändert wurde. (Inherited from CockpitExtension.)
Public event | ValueChanged | Tritt auf, wenn der Wert durch das Steuerelement geändert wurde. (Inherited from CockpitInputExtension.)
Public event | ValuePublishing | Tritt auf, wenn der Wert durch das Cockpit-Steuerelement geändert wurde. (Inherited from CockpitInputExtension.)

See Also

TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class
DynamicNode.Ext.Cockpit Namespace


TypedCockpitInputExtension(TValue) Constructor

[image]

DynamicNodes API
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Constructor
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the TypedCockpitInputExtension<(Of <(<'TValue>)>)> class

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected TypedCockpitInputExtension()
Visual Basic
Protected Sub New
F#
new : unit -> TypedCockpitInputExtension

See Also

TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class
DynamicNode.Ext.Cockpit Namespace


TypedCockpitInputExtension(TValue) Fields

[image] [image]

DynamicNodes API
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Fields
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypedCockpitInputExtension<(Of <(<'TValue>)>)> type exposes the following members.

Fields

 | Name | Description
Public field | AutoPublish | Ein Wert der angibt, ob Änderungen in der Benutzeroberfläche automatisch als neue Parameter-Werte weitergegeben werden. (Inherited from CockpitInputExtension.)
Public field | Name | Der Name des Cockpit-Parameters. (Inherited from CockpitExtension.)
Public field | SortIndex | Ein Wert der die Sortierung der Cockpit-Steuerelementen beeinflusst. (Inherited from CockpitExtension.)

See Also

TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class
DynamicNode.Ext.Cockpit Namespace


TypedCockpitInputExtension(TValue) Methods

[image] [image]

DynamicNodes API
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Methods
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypedCockpitInputExtension<(Of <(<'TValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde. (Inherited from CockpitExtension.)
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde. (Inherited from CockpitExtension.)
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde. (Inherited from CockpitExtension.)
Public method | GetProperties | Gibt eine Aufzählung mit allen Cockpit-Eigenschaften dieser Cockpit-Erweiterung zurück. (Inherited from CockpitInputExtension.)
Protected method | OnPropertyChanged | Löst das Ereignis PropertyChanged aus. (Inherited from CockpitExtension.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from CockpitExtension.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from CockpitExtension.)
Protected method | OnValueChanged | Muss aufgerufen werden, wenn im Cockpit-Steuerelement der Wert verändert wurde. Ruft OnValuePublishing()()()() auf, wenn AutoPublish gleich true ist. (Inherited from CockpitInputExtension.)
Protected method | OnValuePublishing | Löst das Ereignis ValuePublishing aus. (Inherited from CockpitInputExtension.)
Protected method | UpdateSyncContext | Muss aufgerufen werden, wenn das Cockpit-Steuerelement erzeugt wird. (Inherited from CockpitExtension.)
Public method | UpdateValue | Aktualisiert den Wert. Wird vom Steuerelement aufgerufen.

See Also

TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class
DynamicNode.Ext.Cockpit Namespace


UpdateValue Method

[image]

DynamicNodes API
TypedCockpitInputExtension<(Of <(<'TValue>)>)>..::..UpdateValue Method
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert den Wert. Wird vom Steuerelement aufgerufen.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public void UpdateValue(
    TValue newValue
)
Visual Basic
Public Sub UpdateValue ( _
    newValue As TValue _
)
F#
member UpdateValue :
        newValue:'TValue -> unit

Parameters

newValue
Type: TValue
Der neue Wert.

See Also

TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class
DynamicNode.Ext.Cockpit Namespace


TypedCockpitInputExtension(TValue) Properties

[image] [image]

DynamicNodes API
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Properties
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypedCockpitInputExtension<(Of <(<'TValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | CockpitControl | Gibt das Cockpitsteuerelement zurück. (Inherited from CockpitExtension.)
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist. (Inherited from CockpitExtension.)
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt. (Inherited from CockpitExtension.)
Public property | Node | Gibt den Knoten zurück, an den die Erweiterung gebunden wurde. (Inherited from CockpitExtension.)
Public property | SyncContext | Der Synchronisierungskontext für die Kommunikation des Knotens mit dem Cockpitsteuerelement. (Inherited from CockpitExtension.)
Public property | Value | Gibt den Wert des Cockpit-Steuerelements zurück.
Protected property | ValueAsObject | Gibt den aktuellen Wert des Cockpit-Steuerelements zurück. (Overrides CockpitInputExtension..::..ValueAsObject.)

See Also

TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class
DynamicNode.Ext.Cockpit Namespace


Value Property

[image]

DynamicNodes API
TypedCockpitInputExtension<(Of <(<'TValue>)>)>..::..Value Property
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert des Cockpit-Steuerelements zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public TValue Value { get; }
Visual Basic
Public ReadOnly Property Value As TValue
    Get
F#
member Value : 'TValue

Field Value

Der Wert.

See Also

TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class
DynamicNode.Ext.Cockpit Namespace


ValueAsObject Property

[image]

DynamicNodes API
TypedCockpitInputExtension<(Of <(<'TValue>)>)>..::..ValueAsObject Property
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuellen Wert des Cockpit-Steuerelements zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
protected override Object ValueAsObject { get; }
Visual Basic
Protected Overrides ReadOnly Property ValueAsObject As Object
    Get
F#
abstract ValueAsObject : Object
override ValueAsObject : Object

Field Value

Der Wert des Cockpit-Steuerelements.

See Also

TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class
DynamicNode.Ext.Cockpit Namespace


TypedCockpitInputExtension(TValue) Events

[image] [image]

DynamicNodes API
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Events
TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypedCockpitInputExtension<(Of <(<'TValue>)>)> type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Tritt auf, wenn eine Eigenschaft dieses Objektes geändert wurde. (Inherited from CockpitExtension.)
Public event | ValueChanged | Tritt auf, wenn der Wert durch das Steuerelement geändert wurde. (Inherited from CockpitInputExtension.)
Public event | ValuePublishing | Tritt auf, wenn der Wert durch das Cockpit-Steuerelement geändert wurde. (Inherited from CockpitInputExtension.)

See Also

TypedCockpitInputExtension<(Of <(<'TValue>)>)> Class
DynamicNode.Ext.Cockpit Namespace


ValuePublishingEventArgs Class

[image]

DynamicNodes API
ValuePublishingEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Daten für das ValuePublishing-Ereignis bereit.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public class ValuePublishingEventArgs : EventArgs
Visual Basic
Public Class ValuePublishingEventArgs _
    Inherits EventArgs
F#
type ValuePublishingEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Ext.Cockpit..::..ValuePublishingEventArgs

See Also

ValuePublishingEventArgs Members
DynamicNode.Ext.Cockpit Namespace


ValuePublishingEventArgs Members

[image] [image]

DynamicNodes API
ValuePublishingEventArgs Members
ValuePublishingEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ValuePublishingEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ValuePublishingEventArgs | Initialisiert eine neue ValuePublishingEventArgs-Instanz.

Properties

 | Name | Description
Public property | NewValue | Gibt den neuen Wert des Cockpit-Steuerelements zurück.

See Also

ValuePublishingEventArgs Class
DynamicNode.Ext.Cockpit Namespace


ValuePublishingEventArgs Constructor

[image]

DynamicNodes API
ValuePublishingEventArgs Constructor
ValuePublishingEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue ValuePublishingEventArgs-Instanz.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public ValuePublishingEventArgs(
    Object newValue
)
Visual Basic
Public Sub New ( _
    newValue As Object _
)
F#
new :
        newValue:Object -> ValuePublishingEventArgs

Parameters

newValue
Type: System..::..Object
Der neue Wert.

See Also

ValuePublishingEventArgs Class
DynamicNode.Ext.Cockpit Namespace


ValuePublishingEventArgs Properties

[image] [image]

DynamicNodes API
ValuePublishingEventArgs Properties
ValuePublishingEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ValuePublishingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewValue | Gibt den neuen Wert des Cockpit-Steuerelements zurück.

See Also

ValuePublishingEventArgs Class
DynamicNode.Ext.Cockpit Namespace


NewValue Property

[image]

DynamicNodes API
ValuePublishingEventArgs..::..NewValue Property
ValuePublishingEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den neuen Wert des Cockpit-Steuerelements zurück.

Namespace: DynamicNode.Ext.Cockpit
Assembly: DNExtCockpit (in DNExtCockpit.dll) Version: 1.0.4679.19815 (1.0.0.0)

Syntax

C#
public Object NewValue { get; }
Visual Basic
Public ReadOnly Property NewValue As Object
    Get
F#
member NewValue : Object

Field Value

Der neue Wert.

See Also

ValuePublishingEventArgs Class
DynamicNode.Ext.Cockpit Namespace


DynamicNode.Ext.Gui Namespace

[image]

DynamicNodes API
DynamicNode.Ext.Gui Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält Klassen für die Erweiterung der Benutzeroberfläche mit Hilfe von Scripten oder externen Assemblies. Die Erweiterungen der Benutzeroberfläche werden mit Hilfe von XML-Dateien (*.gui.xml) beschrieben. Es können statische .NET-Methoden oder PowerShell-Scripts als Befehle in der Benutzeroberfläche verfügbar gemacht werden. Mit Hilfe der Klassen in diesem Namensraum, kann die Benutzeroberfläche von DynamicNodes um Funktionen erweitert werden, ohne DynamicNodes neu zu kompilieren.

Die wichtigste Klasse in diesem Namensraum ist CommandLoader<(Of <<'(TAppCore>)>>).

Classes

 | Class | Description
Public class | CommandBase | Die Basisklasse für Befehle.
Public class | CommandLoader<(Of <(<'TAppCore>)>)> | Der CommandLoader<(Of <(<'TAppCore>)>)> durchsucht das das Unterverzeichnis gui des DynamicNodes-System-Verzeichnis nach Erweiterungen für die Benutzeroberfläche. Diese Erweiterungen werden durch eine XML-Datei mit Endung ".gui.xml" beschrieben und verwenden den XML-Namensraum http://dynamicnodes.mastersign.de/GuiExtension
Public class | ConditionResult | Das Ergebnis einer Aktivitätsüberprüfung.
Public class | ContextCommand<(Of <(<'TAppCore, TContext>)>)> | Ein kontextgebundener Befehl.

Interfaces

 | Interface | Description
Public interface | IShellProcessor<(Of <(<'TAppCore>)>)> | Die Schnittstelle für Objekte, welche die Ausführung von Scripten ermöglichen.

Delegates

 | Delegate | Description
Public delegate | ActionHandler<(Of <(<'TAppCore, TContext>)>)> | Ein generischer Delegat für kontextgebundene Befehle.
Public delegate | ConditionHandler<(Of <(<'TAppCore, TContext>)>)> | Ein Delegat um zu überprüfen, ob ein Befehl für den angegebenen Kontext aktiv ist.


ActionHandler(TAppCore, TContext) Delegate

[image]

DynamicNodes API
ActionHandler<(Of <(<'TAppCore, TContext>)>)> Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein generischer Delegat für kontextgebundene Befehle.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public delegate void ActionHandler<TAppCore, TContext>(
    TAppCore appCore,
    TContext context
)
Visual Basic
Public Delegate Sub ActionHandler(Of TAppCore, TContext) ( _
    appCore As TAppCore, _
    context As TContext _
)
F#
type ActionHandler =
    delegate of
        appCore:'TAppCore *
        context:'TContext -> unit

Parameters

appCore
Type: TAppCore
Der Kern der Anwendung.
context
Type: TContext
Der Kontext des Befehls.

Type Parameters

TAppCore
Der Type des Anwendungskerns.
TContext
Der Type des Kontextes.

See Also

DynamicNode.Ext.Gui Namespace


CommandBase Class

[image]

DynamicNodes API
CommandBase Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für Befehle.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public abstract class CommandBase
Visual Basic
Public MustInherit Class CommandBase
F#
[<AbstractClassAttribute>]
type CommandBase =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Gui..::..CommandBase
DynamicNode.Ext.Gui..::..ContextCommand<(Of <(<'TAppCore, TContext>)>)>

See Also

CommandBase Members
DynamicNode.Ext.Gui Namespace


CommandBase Members

[image] [image]

DynamicNodes API
CommandBase Members
CommandBase Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CommandBase type exposes the following members.

Constructors

 | Name | Description
Protected method | CommandBase | Initializes a new instance of the CommandBase class

Methods

 | Name | Description
Public method | Execute | Führt diesen Befehl aus.
Public method | GetIconImage | Gibt ein Bild des Icons in der angegebenen Größe zurück.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung des Befehls zurück, oder legt sie fest.
Public property | Description | Gibt die Beschreibung des Befehls zurück, oder legt sie fest. Diese kann z.B. in einem Tooltip angezeigt werden.
Public property | Enabled | Gets einen Wert der angibt ob dieser Befehl aktiv ist.
Public property | Group | Gibt die Befehlsgruppe zurück oder legt sie fest. Eine Befehlsgruppe dient zum Zusammenfassen einer kleineren Anzahl von Befehlen. In der Benutzeroberfläche können Befehlsgruppen z.B. durch ein Untermenü in einem Kontextmenü dargestellt werden.
Public property | Icon | Gibt das Icon des Befehls zurück oder legt es fest.

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


CommandBase Constructor

[image]

DynamicNodes API
CommandBase Constructor
CommandBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the CommandBase class

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
protected CommandBase()
Visual Basic
Protected Sub New
F#
new : unit -> CommandBase

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


CommandBase Methods

[image] [image]

DynamicNodes API
CommandBase Methods
CommandBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CommandBase type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Führt diesen Befehl aus.
Public method | GetIconImage | Gibt ein Bild des Icons in der angegebenen Größe zurück.

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


Execute Method

[image]

DynamicNodes API
CommandBase..::..Execute Method
CommandBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt diesen Befehl aus.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public abstract void Execute()
Visual Basic
Public MustOverride Sub Execute
F#
abstract Execute : unit -> unit

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


GetIconImage Method

[image]

DynamicNodes API
CommandBase..::..GetIconImage Method
CommandBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Bild des Icons in der angegebenen Größe zurück.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public Image GetIconImage(
    int size
)
Visual Basic
Public Function GetIconImage ( _
    size As Integer _
) As Image
F#
member GetIconImage :
        size:int -> Image

Parameters

size
Type: System..::..Int32
Die Größe des geforderten Icons.

Return Value

Ein Bild des Icons oder null, wenn Icon null ist.

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


CommandBase Properties

[image] [image]

DynamicNodes API
CommandBase Properties
CommandBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CommandBase type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung des Befehls zurück, oder legt sie fest.
Public property | Description | Gibt die Beschreibung des Befehls zurück, oder legt sie fest. Diese kann z.B. in einem Tooltip angezeigt werden.
Public property | Enabled | Gets einen Wert der angibt ob dieser Befehl aktiv ist.
Public property | Group | Gibt die Befehlsgruppe zurück oder legt sie fest. Eine Befehlsgruppe dient zum Zusammenfassen einer kleineren Anzahl von Befehlen. In der Benutzeroberfläche können Befehlsgruppen z.B. durch ein Untermenü in einem Kontextmenü dargestellt werden.
Public property | Icon | Gibt das Icon des Befehls zurück oder legt es fest.

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


Caption Property

[image]

DynamicNodes API
CommandBase..::..Caption Property
CommandBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung des Befehls zurück, oder legt sie fest.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public string Caption { get; set; }
Visual Basic
Public Property Caption As String
    Get
    Set
F#
member Caption : string with get, set

Field Value

Die Beschriftung des Befehls.

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


Description Property

[image]

DynamicNodes API
CommandBase..::..Description Property
CommandBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Befehls zurück, oder legt sie fest. Diese kann z.B. in einem Tooltip angezeigt werden.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
F#
member Description : string with get, set

Field Value

Die Beschreibung des Befehls oder null, wenn keine Beschreibung angegeben ist.

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


Enabled Property

[image]

DynamicNodes API
CommandBase..::..Enabled Property
CommandBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gets einen Wert der angibt ob dieser Befehl aktiv ist.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public abstract bool Enabled { get; }
Visual Basic
Public MustOverride ReadOnly Property Enabled As Boolean
    Get
F#
abstract Enabled : bool

Field Value

true wenn der Befehl aktiv ist, sonst false.

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


Group Property

[image]

DynamicNodes API
CommandBase..::..Group Property
CommandBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Befehlsgruppe zurück oder legt sie fest. Eine Befehlsgruppe dient zum Zusammenfassen einer kleineren Anzahl von Befehlen. In der Benutzeroberfläche können Befehlsgruppen z.B. durch ein Untermenü in einem Kontextmenü dargestellt werden.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public string Group { get; set; }
Visual Basic
Public Property Group As String
    Get
    Set
F#
member Group : string with get, set

Field Value

Die Befehlsgruppe oder null, wenn der Befehl keiner Gruppe angehört.

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


Icon Property

[image]

DynamicNodes API
CommandBase..::..Icon Property
CommandBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Icon des Befehls zurück oder legt es fest.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public Icon Icon { get; set; }
Visual Basic
Public Property Icon As Icon
    Get
    Set
F#
member Icon : Icon with get, set

Field Value

Das Icon des Befehls oder null, wenn der Befehl kein Icon besitzt.

See Also

CommandBase Class
DynamicNode.Ext.Gui Namespace


CommandLoader(TAppCore) Class

[image]

DynamicNodes API
CommandLoader<(Of <(<'TAppCore>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der CommandLoader<(Of <(<'TAppCore>)>)> durchsucht das das Unterverzeichnis gui des DynamicNodes-System-Verzeichnis nach Erweiterungen für die Benutzeroberfläche. Diese Erweiterungen werden durch eine XML-Datei mit Endung ".gui.xml" beschrieben und verwenden den XML-Namensraum http://dynamicnodes.mastersign.de/GuiExtension

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public class CommandLoader<TAppCore>
Visual Basic
Public Class CommandLoader(Of TAppCore)
F#
type CommandLoader<'TAppCore> =  class end

Type Parameters

TAppCore
Der Type des Anwendungskerns. Der Anwendungskern ist ein Objekt der DynamicNodes-Anwendung, welche jedem Befehl als Schnittstelle zur Anwendung mitgegeben wird.

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Gui..::..CommandLoader<(Of <(<'TAppCore>)>)>

See Also

CommandLoader<(Of <(<'TAppCore>)>)> Members
DynamicNode.Ext.Gui Namespace


CommandLoader(TAppCore) Members

[image] [image]

DynamicNodes API
CommandLoader<(Of <(<'TAppCore>)>)> Members
CommandLoader<(Of <(<'TAppCore>)>)> Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CommandLoader<(Of <(<'TAppCore>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | CommandLoader<(Of <(<'TAppCore>)>)> | Initializes a new instance of the CommandLoader<(Of <(<'TAppCore>)>)> class

Methods

 | Name | Description
Public method | GetContextCommandGroups<(Of <<'(TContext>)>>) | Gibt alle Befehlsgruppen für einen bestimmten Kontext zurück.
Public method | GetContextCommands<(Of <<'(TContext>)>>) | Gibt alle Befehle für den übergebenen Kontext-Type zurück.
Public method | Initialize | Initialisiert diesen CommandLoader<(Of <(<'TAppCore>)>)> mit Hilfe der DynamicNodes-Konfiguration config und einem Objekt für die Script-Ausführung processor.

See Also

CommandLoader<(Of <(<'TAppCore>)>)> Class
DynamicNode.Ext.Gui Namespace


CommandLoader(TAppCore) Constructor

[image]

DynamicNodes API
CommandLoader<(Of <(<'TAppCore>)>)> Constructor
CommandLoader<(Of <(<'TAppCore>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the CommandLoader<(Of <(<'TAppCore>)>)> class

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public CommandLoader()
Visual Basic
Public Sub New
F#
new : unit -> CommandLoader

See Also

CommandLoader<(Of <(<'TAppCore>)>)> Class
DynamicNode.Ext.Gui Namespace


CommandLoader(TAppCore) Methods

[image] [image]

DynamicNodes API
CommandLoader<(Of <(<'TAppCore>)>)> Methods
CommandLoader<(Of <(<'TAppCore>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CommandLoader<(Of <(<'TAppCore>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetContextCommandGroups<(Of <<'(TContext>)>>) | Gibt alle Befehlsgruppen für einen bestimmten Kontext zurück.
Public method | GetContextCommands<(Of <<'(TContext>)>>) | Gibt alle Befehle für den übergebenen Kontext-Type zurück.
Public method | Initialize | Initialisiert diesen CommandLoader<(Of <(<'TAppCore>)>)> mit Hilfe der DynamicNodes-Konfiguration config und einem Objekt für die Script-Ausführung processor.

See Also

CommandLoader<(Of <(<'TAppCore>)>)> Class
DynamicNode.Ext.Gui Namespace


GetContextCommandGroups(TContext) Method

[image]

DynamicNodes API
CommandLoader<(Of <(<'TAppCore>)>)>..::..GetContextCommandGroups<(Of <(<'TContext>)>)> Method
CommandLoader<(Of <(<'TAppCore>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle Befehlsgruppen für einen bestimmten Kontext zurück.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public IEnumerable<string> GetContextCommandGroups<TContext>()
Visual Basic
Public Function GetContextCommandGroups(Of TContext) As IEnumerable(Of String)
F#
member GetContextCommandGroups : unit -> IEnumerable<string>

Type Parameters

TContext
Der Type des Kontextes.

Return Value

Eine Aufzählung mit den Befehlsgruppen.

See Also

CommandLoader<(Of <(<'TAppCore>)>)> Class
DynamicNode.Ext.Gui Namespace


GetContextCommands(TContext) Method

[image]

DynamicNodes API
CommandLoader<(Of <(<'TAppCore>)>)>..::..GetContextCommands<(Of <(<'TContext>)>)> Method
CommandLoader<(Of <(<'TAppCore>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle Befehle für den übergebenen Kontext-Type zurück.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public IEnumerable<ContextCommand<TAppCore, TContext>> GetContextCommands<TContext>(
    string group
)
Visual Basic
Public Function GetContextCommands(Of TContext) ( _
    group As String _
) As IEnumerable(Of ContextCommand(Of TAppCore, TContext))
F#
member GetContextCommands :
        group:string -> IEnumerable<ContextCommand<'TAppCore, 'TContext>>

Parameters

group
Type: System..::..String
Die Gruppe, deren Befehle ausgesucht werden sollen oder null, wenn die Befehle ohne Gruppe gesucht werden sollen.

Type Parameters

TContext
Der Type des Kontexts, für den Befehle gesucht werden.

Return Value

Eine Aufzählung mit Befehlen.

See Also

CommandLoader<(Of <(<'TAppCore>)>)> Class
DynamicNode.Ext.Gui Namespace


Initialize Method

[image]

DynamicNodes API
CommandLoader<(Of <(<'TAppCore>)>)>..::..Initialize Method
CommandLoader<(Of <(<'TAppCore>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert diesen CommandLoader<(Of <(<'TAppCore>)>)> mit Hilfe der DynamicNodes-Konfiguration config und einem Objekt für die Script-Ausführung processor.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public void Initialize(
    IConfiguration config,
    IShellProcessor<TAppCore> processor
)
Visual Basic
Public Sub Initialize ( _
    config As IConfiguration, _
    processor As IShellProcessor(Of TAppCore) _
)
F#
member Initialize :
        config:IConfiguration *
        processor:IShellProcessor<'TAppCore> -> unit

Parameters

config
Type: DynamicNode.Core..::..IConfiguration
Die DynamicNodes-Konfiguration.
processor
Type: DynamicNode.Ext.Gui..::..IShellProcessor <(Of <(<' TAppCore >)>)>
Ein Objekt, welches Script-Befehle ausführen kann oder null, wenn es keine Unterstützung für das Ausführen von Scripten gibt.

See Also

CommandLoader<(Of <(<'TAppCore>)>)> Class
DynamicNode.Ext.Gui Namespace


ConditionHandler(TAppCore, TContext) Delegate

[image]

DynamicNodes API
ConditionHandler<(Of <(<'TAppCore, TContext>)>)> Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Delegat um zu überprüfen, ob ein Befehl für den angegebenen Kontext aktiv ist.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public delegate void ConditionHandler<TAppCore, TContext>(
    TAppCore appCore,
    TContext context,
    ConditionResult result
)
Visual Basic
Public Delegate Sub ConditionHandler(Of TAppCore, TContext) ( _
    appCore As TAppCore, _
    context As TContext, _
    result As ConditionResult _
)
F#
type ConditionHandler =
    delegate of
        appCore:'TAppCore *
        context:'TContext *
        result:ConditionResult -> unit

Parameters

appCore
Type: TAppCore
Der Kern der Anwendung.
context
Type: TContext
Der Kontext des Befehls.
result
Type: DynamicNode.Ext.Gui..::..ConditionResult
Ein Container für das Ergebis der Prüfung.

Type Parameters

TAppCore
Der Type des Anwendungskerns.
TContext
Der Type des Kontextes.

Return Value

true, wenn der zugehörige Befehl aktiv ist, sonst false.

See Also

DynamicNode.Ext.Gui Namespace


ConditionResult Class

[image]

DynamicNodes API
ConditionResult Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Ergebnis einer Aktivitätsüberprüfung.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public class ConditionResult
Visual Basic
Public Class ConditionResult
F#
type ConditionResult =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Gui..::..ConditionResult

See Also

ConditionResult Members
DynamicNode.Ext.Gui Namespace


ConditionResult Members

[image] [image]

DynamicNodes API
ConditionResult Members
ConditionResult Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ConditionResult type exposes the following members.

Constructors

 | Name | Description
Public method | ConditionResult | Initializes a new instance of the ConditionResult class

Properties

 | Name | Description
Public property | Value | Gibt einen Wert zurück oder legt ihn fest, der angibt ob der überprüfte Befehl aktiv ist oder nicht.

See Also

ConditionResult Class
DynamicNode.Ext.Gui Namespace


ConditionResult Constructor

[image]

DynamicNodes API
ConditionResult Constructor
ConditionResult Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the ConditionResult class

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public ConditionResult()
Visual Basic
Public Sub New
F#
new : unit -> ConditionResult

See Also

ConditionResult Class
DynamicNode.Ext.Gui Namespace


ConditionResult Properties

[image] [image]

DynamicNodes API
ConditionResult Properties
ConditionResult Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ConditionResult type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gibt einen Wert zurück oder legt ihn fest, der angibt ob der überprüfte Befehl aktiv ist oder nicht.

See Also

ConditionResult Class
DynamicNode.Ext.Gui Namespace


Value Property

[image]

DynamicNodes API
ConditionResult..::..Value Property
ConditionResult Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt ob der überprüfte Befehl aktiv ist oder nicht.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public bool Value { get; set; }
Visual Basic
Public Property Value As Boolean
    Get
    Set
F#
member Value : bool with get, set

Field Value

true wenn der überprüfte Befehl aktiv ist, sonst false.

See Also

ConditionResult Class
DynamicNode.Ext.Gui Namespace


ContextCommand(TAppCore, TContext) Class

[image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein kontextgebundener Befehl.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public class ContextCommand<TAppCore, TContext> : CommandBase
Visual Basic
Public Class ContextCommand(Of TAppCore, TContext) _
    Inherits CommandBase
F#
type ContextCommand<'TAppCore, 'TContext> =
    class
        inherit CommandBase
    end

Type Parameters

TAppCore
Der Type des Anwendungskerns.
TContext
Der Type des Befehls-Kontexts.

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Gui..::..CommandBase
DynamicNode.Ext.Gui..::..ContextCommand<(Of <(<'TAppCore, TContext>)>)>

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Members
DynamicNode.Ext.Gui Namespace


ContextCommand(TAppCore, TContext) Members

[image] [image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Members
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ContextCommand<(Of <(<'TAppCore, TContext>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ContextCommand<(Of <(<'TAppCore, TContext>)>)> | Initialisiert eine neue Instanz von ContextCommand<(Of <(<'TAppCore, TContext>)>)>.

Methods

 | Name | Description
Public method | Execute | Führt diesen Befehl aus. (Overrides CommandBase..::..Execute()()()().)
Public method | GetIconImage | Gibt ein Bild des Icons in der angegebenen Größe zurück. (Inherited from CommandBase.)
Public method | SetAction | Registriert einen ActionHandler<(Of <(<'TAppCore, TContext>)>)> für die Ausführung des Befehls.
Public method | SetCondition | Registriert einen ConditionHandler<(Of <(<'TAppCore, TContext>)>)> für die Aktivitätsprüfung in einem Kontext.

Properties

 | Name | Description
Public property | AppCore | Gibt den Anwendungskern zurück oder legt ihn fest.
Public property | Caption | Gibt die Beschriftung des Befehls zurück, oder legt sie fest. (Inherited from CommandBase.)
Public property | ConditionDefault | Gibt den Standardwert für die Aktivitätsbedingung zurück. Ist ConditionHandler()()()() gleich null oder führt die Ausführung des Delegaten fehl, wird dieser Standardwert verwendet.
Public property | Context | Gets or sets the context.
Public property | Description | Gibt die Beschreibung des Befehls zurück, oder legt sie fest. Diese kann z.B. in einem Tooltip angezeigt werden. (Inherited from CommandBase.)
Public property | Enabled | Gets einen Wert der angibt ob dieser Befehl aktiv ist. (Overrides CommandBase..::..Enabled.)
Public property | Group | Gibt die Befehlsgruppe zurück oder legt sie fest. Eine Befehlsgruppe dient zum Zusammenfassen einer kleineren Anzahl von Befehlen. In der Benutzeroberfläche können Befehlsgruppen z.B. durch ein Untermenü in einem Kontextmenü dargestellt werden. (Inherited from CommandBase.)
Public property | Icon | Gibt das Icon des Befehls zurück oder legt es fest. (Inherited from CommandBase.)

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


ContextCommand(TAppCore, TContext) Constructor

[image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Constructor
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ContextCommand<(Of <(<'TAppCore, TContext>)>)>.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public ContextCommand()
Visual Basic
Public Sub New
F#
new : unit -> ContextCommand

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


ContextCommand(TAppCore, TContext) Methods

[image] [image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Methods
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ContextCommand<(Of <(<'TAppCore, TContext>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Führt diesen Befehl aus. (Overrides CommandBase..::..Execute()()()().)
Public method | GetIconImage | Gibt ein Bild des Icons in der angegebenen Größe zurück. (Inherited from CommandBase.)
Public method | SetAction | Registriert einen ActionHandler<(Of <(<'TAppCore, TContext>)>)> für die Ausführung des Befehls.
Public method | SetCondition | Registriert einen ConditionHandler<(Of <(<'TAppCore, TContext>)>)> für die Aktivitätsprüfung in einem Kontext.

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


Execute Method

[image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)>..::..Execute Method
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt diesen Befehl aus.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public override void Execute()
Visual Basic
Public Overrides Sub Execute
F#
abstract Execute : unit -> unit
override Execute : unit -> unit

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


SetAction Method

[image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)>..::..SetAction Method
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert einen ActionHandler<(Of <(<'TAppCore, TContext>)>)> für die Ausführung des Befehls.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public void SetAction(
    ActionHandler<TAppCore, TContext> handler
)
Visual Basic
Public Sub SetAction ( _
    handler As ActionHandler(Of TAppCore, TContext) _
)
F#
member SetAction :
        handler:ActionHandler<'TAppCore, 'TContext> -> unit

Parameters

handler
Type: DynamicNode.Ext.Gui..::..ActionHandler <(Of <(<' TAppCore, TContext >)>)>
Der Handler für die Befehlsausführung.

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


SetCondition Method

[image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)>..::..SetCondition Method
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert einen ConditionHandler<(Of <(<'TAppCore, TContext>)>)> für die Aktivitätsprüfung in einem Kontext.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public void SetCondition(
    ConditionHandler<TAppCore, TContext> handler
)
Visual Basic
Public Sub SetCondition ( _
    handler As ConditionHandler(Of TAppCore, TContext) _
)
F#
member SetCondition :
        handler:ConditionHandler<'TAppCore, 'TContext> -> unit

Parameters

handler
Type: DynamicNode.Ext.Gui..::..ConditionHandler <(Of <(<' TAppCore, TContext >)>)>
Der Handler für die Aktivitätsprüfung.

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


ContextCommand(TAppCore, TContext) Properties

[image] [image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Properties
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ContextCommand<(Of <(<'TAppCore, TContext>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | AppCore | Gibt den Anwendungskern zurück oder legt ihn fest.
Public property | Caption | Gibt die Beschriftung des Befehls zurück, oder legt sie fest. (Inherited from CommandBase.)
Public property | ConditionDefault | Gibt den Standardwert für die Aktivitätsbedingung zurück. Ist ConditionHandler()()()() gleich null oder führt die Ausführung des Delegaten fehl, wird dieser Standardwert verwendet.
Public property | Context | Gets or sets the context.
Public property | Description | Gibt die Beschreibung des Befehls zurück, oder legt sie fest. Diese kann z.B. in einem Tooltip angezeigt werden. (Inherited from CommandBase.)
Public property | Enabled | Gets einen Wert der angibt ob dieser Befehl aktiv ist. (Overrides CommandBase..::..Enabled.)
Public property | Group | Gibt die Befehlsgruppe zurück oder legt sie fest. Eine Befehlsgruppe dient zum Zusammenfassen einer kleineren Anzahl von Befehlen. In der Benutzeroberfläche können Befehlsgruppen z.B. durch ein Untermenü in einem Kontextmenü dargestellt werden. (Inherited from CommandBase.)
Public property | Icon | Gibt das Icon des Befehls zurück oder legt es fest. (Inherited from CommandBase.)

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


AppCore Property

[image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)>..::..AppCore Property
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Anwendungskern zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public TAppCore AppCore { get; set; }
Visual Basic
Public Property AppCore As TAppCore
    Get
    Set
F#
member AppCore : 'TAppCore with get, set

Field Value

Der Anwendungskern.

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


ConditionDefault Property

[image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)>..::..ConditionDefault Property
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standardwert für die Aktivitätsbedingung zurück. Ist ConditionHandler()()()() gleich null oder führt die Ausführung des Delegaten fehl, wird dieser Standardwert verwendet.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public bool ConditionDefault { get; set; }
Visual Basic
Public Property ConditionDefault As Boolean
    Get
    Set
F#
member ConditionDefault : bool with get, set

Field Value

true wenn der Befehl aktiv sein soll, falls die Aktivitätsprüfung nicht funktioniert, sonst false.

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


Context Property

[image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)>..::..Context Property
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gets or sets the context.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public TContext Context { get; set; }
Visual Basic
Public Property Context As TContext
    Get
    Set
F#
member Context : 'TContext with get, set

Field Value

The context.

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


Enabled Property

[image]

DynamicNodes API
ContextCommand<(Of <(<'TAppCore, TContext>)>)>..::..Enabled Property
ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gets einen Wert der angibt ob dieser Befehl aktiv ist.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public override bool Enabled { get; }
Visual Basic
Public Overrides ReadOnly Property Enabled As Boolean
    Get
F#
abstract Enabled : bool
override Enabled : bool

Field Value

true wenn der Befehl aktiv ist, sonst false.

See Also

ContextCommand<(Of <(<'TAppCore, TContext>)>)> Class
DynamicNode.Ext.Gui Namespace


IShellProcessor(TAppCore) Interface

[image]

DynamicNodes API
IShellProcessor<(Of <(<'TAppCore>)>)> Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für Objekte, welche die Ausführung von Scripten ermöglichen.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
public interface IShellProcessor<TAppCore>
Visual Basic
Public Interface IShellProcessor(Of TAppCore)
F#
type IShellProcessor<'TAppCore> =  interface end

Type Parameters

TAppCore
Der Type des Anwendungskerns.

See Also

IShellProcessor<(Of <(<'TAppCore>)>)> Members
DynamicNode.Ext.Gui Namespace


IShellProcessor(TAppCore) Members

[image] [image]

DynamicNodes API
IShellProcessor<(Of <(<'TAppCore>)>)> Members
IShellProcessor<(Of <(<'TAppCore>)>)> Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IShellProcessor<(Of <(<'TAppCore>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CheckCondition<(Of <<'(TContext>)>>) | Führt den übergebenen Befehl aus und wertet die Ausgabe als Wahrheitswert aus.
Public method | Execute<(Of <<'(TContext>)>>) | Führt den übergebenen Befehl aus.
Public method | LoadLibrary | Lädt eine Script-Bibliothek.

See Also

IShellProcessor<(Of <(<'TAppCore>)>)> Interface
DynamicNode.Ext.Gui Namespace


IShellProcessor(TAppCore) Methods

[image] [image]

DynamicNodes API
IShellProcessor<(Of <(<'TAppCore>)>)> Methods
IShellProcessor<(Of <(<'TAppCore>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IShellProcessor<(Of <(<'TAppCore>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CheckCondition<(Of <<'(TContext>)>>) | Führt den übergebenen Befehl aus und wertet die Ausgabe als Wahrheitswert aus.
Public method | Execute<(Of <<'(TContext>)>>) | Führt den übergebenen Befehl aus.
Public method | LoadLibrary | Lädt eine Script-Bibliothek.

See Also

IShellProcessor<(Of <(<'TAppCore>)>)> Interface
DynamicNode.Ext.Gui Namespace


CheckCondition(TContext) Method

[image]

DynamicNodes API
IShellProcessor<(Of <(<'TAppCore>)>)>..::..CheckCondition<(Of <(<'TContext>)>)> Method
IShellProcessor<(Of <(<'TAppCore>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt den übergebenen Befehl aus und wertet die Ausgabe als Wahrheitswert aus.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
void CheckCondition<TContext>(
    string command,
    TAppCore appCore,
    TContext context,
    ConditionResult result
)
Visual Basic
Sub CheckCondition(Of TContext) ( _
    command As String, _
    appCore As TAppCore, _
    context As TContext, _
    result As ConditionResult _
)
F#
abstract CheckCondition :
        command:string *
        appCore:'TAppCore *
        context:'TContext *
        result:ConditionResult -> unit

Parameters

command
Type: System..::..String
Der Befehl oder der absolute Pfad einer Scriptdatei.
appCore
Type: TAppCore
Der Anwendungskern.
context
Type: TContext
Der Kontext.
result
Type: DynamicNode.Ext.Gui..::..ConditionResult
Ein Container für das Ergebnis.

Type Parameters

TContext
Der Type des Befehls-Kontexts.

See Also

IShellProcessor<(Of <(<'TAppCore>)>)> Interface
DynamicNode.Ext.Gui Namespace


Execute(TContext) Method

[image]

DynamicNodes API
IShellProcessor<(Of <(<'TAppCore>)>)>..::..Execute<(Of <(<'TContext>)>)> Method
IShellProcessor<(Of <(<'TAppCore>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt den übergebenen Befehl aus.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
void Execute<TContext>(
    string command,
    TAppCore appCore,
    TContext context
)
Visual Basic
Sub Execute(Of TContext) ( _
    command As String, _
    appCore As TAppCore, _
    context As TContext _
)
F#
abstract Execute :
        command:string *
        appCore:'TAppCore *
        context:'TContext -> unit

Parameters

command
Type: System..::..String
Der Befehl oder der absolute Pfad einer Scriptdatei.
appCore
Type: TAppCore
Der Anwendungskern.
context
Type: TContext
Der Kontext.

Type Parameters

TContext
Der Type des Befehls-Kontexts.

See Also

IShellProcessor<(Of <(<'TAppCore>)>)> Interface
DynamicNode.Ext.Gui Namespace


LoadLibrary Method

[image]

DynamicNodes API
IShellProcessor<(Of <(<'TAppCore>)>)>..::..LoadLibrary Method
IShellProcessor<(Of <(<'TAppCore>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Lädt eine Script-Bibliothek.

Namespace: DynamicNode.Ext.Gui
Assembly: DNExtGui (in DNExtGui.dll) Version: 1.0.4679.19833 (1.0.0.0)

Syntax

C#
void LoadLibrary(
    string libPath
)
Visual Basic
Sub LoadLibrary ( _
    libPath As String _
)
F#
abstract LoadLibrary :
        libPath:string -> unit

Parameters

libPath
Type: System..::..String
Der Pfad zur Script-Datei.

See Also

IShellProcessor<(Of <(<'TAppCore>)>)> Interface
DynamicNode.Ext.Gui Namespace


DynamicNode.Ext.Objects Namespace

[image]

DynamicNodes API
DynamicNode.Ext.Objects Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält Erweiterungen für das Kapseln von CLR-Elementen wie Methoden, Properties oder Events in einigen wenigen generischen Knoten. Die Knotenbibliothek, welche diese Funktionalität verfügbar macht ist DNLibObjects.

Classes

 | Class | Description
Public class | AbstractMethodBase | Abstrakte Basisklasse für Knoten, deren Aufgabe darin besteht eine Methode auf zu rufen. Die Methode wird mit einer MethodInfo an den Knoten gebunden. Die Anschlüsse des Knotens werden automatisch der Methode entsprechende eingerichtet.
Public class | AbstractWrapper | Die Basisklasse für alle CLR-Wrapper-Knoten.
Public class | ClrLibraryBrowser | Stellt einen Browser für geladene Assemblies dar. Er stellt Namensräume und Typen eines Assemblies in einem Baum dar und zeigt alle geeigneten Member eines ausgewählten Typen in einer Liste an.
Public class | ClrTools | Stellt Unterstützung für das Reflektieren von CLR-Typen und CLR-Membern zur Verfügung.
Public class | CodeCompilerResult | Das Ergebnis der Kompilierung einer Knotenoperation zur Laufzeit.
Public class | ConstructorSelector | Ein Steuerelement zur Auswahl eines CLR-Konstruktors.
Public class | EventSelector | Ein Steuerelement zur Auswahl eines CLR-Ereignisses.
Public class | FieldSelector | Ein Steuerelement zur Auswahl eines CLR-Feldes.
Public class | MemberDragEventArgs | Stellt die Daten für das Ereignis MemberDrag bereit.
Public class | MethodSelector | Ein Steuerelement zur Auswahl einer CLR-Methode.
Public class | NCode | Eine Basisklasse für Knoten, deren Arbeitsmethode zur Laufzeit kompiliert wird.
Public class | ObjectMemberNodeFactory | Die Knotenfactory für CLR-Wrapper Knoten.
Public class | ObjectMemberNodeFactory..::..FactoryEventArgs | ENthält die Daten für das Ereignis NodeCreated.
Public class | ObjectNodeRegistry | Die Registry für CLR-Wrapper-Knoten.
Public class | PropertySelector | Ein Steuerelement zur Auswahl einer CLR-Eigenschaft.
Public class | TypeDragEventArgs | Stellt die Daten für das Ereignis TypeDrag bereit.
Public class | TypeSelector | Ein Steuerelement zur Auswahl eines CLR-Types. Die Auswahl erfolgt in drei Stufen: Zunächst wird ein Assembly ausgewählt, anschließend wird auf einen Namensraum eingegrenzt und im letzten Schritt wird ein Type gewählt.
Public class | WindowsFormsSyncContext | Ein Single-Thread-Kontext für Windows-Forms-Anwendungen.
Public class | WpfSyncContext | Stellt einen Single-Thread-Kontext für WPF-Anwendungen zur Verfügung.

Delegates

 | Delegate | Description
Public delegate | MemberInfoNodeCreator | Ein Knotenerzeuger für CLR-Wrapperknoten die ein Typenmitglied kapseln.
Public delegate | TypeNodeCreator | Ein Knotenerzeuger für CLR-Wrapperknoten die einen Typ kapseln.

Enumerations

 | Enumeration | Description
Public enumeration | CodeLanguage | Eine Aufzählung mit Programmiersprachen, die durch den Code-Editor mit Syntax-Highlighting unterstützt werden.
Public enumeration | Interactions | Eine Auflistung von Interaktionen mit dem CLR-Objekt-Modell.
Public enumeration | TypeOperations | Eine Auflistung von Operationen für CLR-Objekte.


AbstractMethodBase Class

[image]

DynamicNodes API
AbstractMethodBase Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Abstrakte Basisklasse für Knoten, deren Aufgabe darin besteht eine Methode auf zu rufen. Die Methode wird mit einer MethodInfo an den Knoten gebunden. Die Anschlüsse des Knotens werden automatisch der Methode entsprechende eingerichtet.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public abstract class AbstractMethodBase : AbstractWrapper
Visual Basic
Public MustInherit Class AbstractMethodBase _
    Inherits AbstractWrapper
F#
[<AbstractClassAttribute>]
type AbstractMethodBase =
    class
        inherit AbstractWrapper
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core..::..StreamNode
DynamicNode.Ext.Visual..::..VisualNode
DynamicNode.Ext.Objects..::..AbstractWrapper
DynamicNode.Ext.Objects..::..AbstractMethodBase
DynamicNode.Ext.Objects..::..NCode

See Also

AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


AbstractMethodBase Members

[image] [image]

DynamicNodes API
AbstractMethodBase Members
AbstractMethodBase Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractMethodBase type exposes the following members.

Constructors

 | Name | Description
Protected method | AbstractMethodBase()()()() | Initialisiert eine neue Instanz von AbstractMethodBase.
Protected method | AbstractMethodBase(MethodBase) | Initialisiert eine neue Instanz von AbstractMethodBase.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | CheckMethodBase | Überprüft ob die übergebene Methode geeignet ist. Falls die Methode ungeeignet ist wird eine ArgumentException geworfen.
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetInteractionSymbol1 | Gibt ein Bild für das erste der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren. (Overrides AbstractWrapper..::..GetInteractionSymbol1()()()().)
Protected method | GetInteractionSymbol2 | Gibt ein Bild für das zweite der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren. (Overrides AbstractWrapper..::..GetInteractionSymbol2()()()().)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetMaxClientWidth | Gibt die maximale Breite des benutzerdefinierten Bereichs der Knotendarstellung zurück. Die Breite wird anhand der Darstellung von den zwei Symbolen und den drei Textzeilen ermittelt. (Inherited from AbstractWrapper.)
Protected method | GetTextLine1 | Gibt die erste von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben. (Overrides AbstractWrapper..::..GetTextLine1()()()().)
Protected method | GetTextLine2 | Gibt die zweite von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben. (Inherited from AbstractWrapper.)
Protected method | Init | Initialisiert die aktuelle Instanz. Wird von den Konstruktoren aufgerufen. (Overrides AbstractWrapper..::..Init()()()().)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Inherited from VisualNode.)
Protected method | InitPorts | Initialisiert oder aktualisiert die Anschlüsse nach Auswahl einer Methode. (Overrides AbstractWrapper..::..InitPorts()()()().)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Inherited from AbstractWrapper.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Overrides AbstractWrapper..::..OnCommand(String).)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Overrides AbstractWrapper..::..OnDefaultCommand()()()().)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from AbstractWrapper.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Protected method | UpdateVisualization | Aktualisiert die visuelle Darstellung des Knotens. (Inherited from AbstractWrapper.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides StreamNode..::..Work(TokenSet).)

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected property | IsMethodStatic | Gibt einen Wert zurück, der angibt, ob die Methode statisch ist.
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | MethodBase | Liest oder schreibt die gekapselte Methode.
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Protected property | ReturnOutPortId | Gibt die Port-ID für den Ausgang zurück, der Rückgabewerte des Methodenaufrufs weiterleiten soll.
Protected property | ReturnType | Gibt den Datentyp für den Ausgang zurück, der den Rückgabewert des Methodenaufrufs weiterleiten soll.
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


AbstractMethodBase Constructor

[image] [image]

DynamicNodes API
AbstractMethodBase Constructor
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | AbstractMethodBase()()()() | Initialisiert eine neue Instanz von AbstractMethodBase.
Protected method | AbstractMethodBase(MethodBase) | Initialisiert eine neue Instanz von AbstractMethodBase.

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


AbstractMethodBase Constructor

[image]

DynamicNodes API
AbstractMethodBase Constructor
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von AbstractMethodBase.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected AbstractMethodBase()
Visual Basic
Protected Sub New
F#
new : unit -> AbstractMethodBase

See Also

AbstractMethodBase Class
AbstractMethodBase Overload
DynamicNode.Ext.Objects Namespace


AbstractMethodBase Constructor (MethodBase)

[image]

DynamicNodes API
AbstractMethodBase Constructor (MethodBase)
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von AbstractMethodBase.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected AbstractMethodBase(
    MethodBase methodBase
)
Visual Basic
Protected Sub New ( _
    methodBase As MethodBase _
)
F#
new :
        methodBase:MethodBase -> AbstractMethodBase

Parameters

methodBase
Type: System.Reflection..::..MethodBase
Eine initiale CLR-Methode.

See Also

AbstractMethodBase Class
AbstractMethodBase Overload
DynamicNode.Ext.Objects Namespace


AbstractMethodBase Methods

[image] [image]

DynamicNodes API
AbstractMethodBase Methods
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractMethodBase type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | CheckMethodBase | Überprüft ob die übergebene Methode geeignet ist. Falls die Methode ungeeignet ist wird eine ArgumentException geworfen.
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetInteractionSymbol1 | Gibt ein Bild für das erste der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren. (Overrides AbstractWrapper..::..GetInteractionSymbol1()()()().)
Protected method | GetInteractionSymbol2 | Gibt ein Bild für das zweite der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren. (Overrides AbstractWrapper..::..GetInteractionSymbol2()()()().)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetMaxClientWidth | Gibt die maximale Breite des benutzerdefinierten Bereichs der Knotendarstellung zurück. Die Breite wird anhand der Darstellung von den zwei Symbolen und den drei Textzeilen ermittelt. (Inherited from AbstractWrapper.)
Protected method | GetTextLine1 | Gibt die erste von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben. (Overrides AbstractWrapper..::..GetTextLine1()()()().)
Protected method | GetTextLine2 | Gibt die zweite von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben. (Inherited from AbstractWrapper.)
Protected method | Init | Initialisiert die aktuelle Instanz. Wird von den Konstruktoren aufgerufen. (Overrides AbstractWrapper..::..Init()()()().)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Inherited from VisualNode.)
Protected method | InitPorts | Initialisiert oder aktualisiert die Anschlüsse nach Auswahl einer Methode. (Overrides AbstractWrapper..::..InitPorts()()()().)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Inherited from AbstractWrapper.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Overrides AbstractWrapper..::..OnCommand(String).)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Overrides AbstractWrapper..::..OnDefaultCommand()()()().)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from AbstractWrapper.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Protected method | UpdateVisualization | Aktualisiert die visuelle Darstellung des Knotens. (Inherited from AbstractWrapper.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides StreamNode..::..Work(TokenSet).)

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
AbstractMethodBase..::..BeforeUseExtension Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


CheckMethodBase Method

[image]

DynamicNodes API
AbstractMethodBase..::..CheckMethodBase Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft ob die übergebene Methode geeignet ist. Falls die Methode ungeeignet ist wird eine ArgumentException geworfen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected abstract void CheckMethodBase(
    MethodBase mI
)
Visual Basic
Protected MustOverride Sub CheckMethodBase ( _
    mI As MethodBase _
)
F#
abstract CheckMethodBase :
        mI:MethodBase -> unit

Parameters

mI
Type: System.Reflection..::..MethodBase
Die zu prüfende Methode.

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


Duplicate Method

[image] [image]

DynamicNodes API
AbstractMethodBase..::..Duplicate Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


GetInteractionSymbol1 Method

[image]

DynamicNodes API
AbstractMethodBase..::..GetInteractionSymbol1 Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Bild für das erste der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override Image GetInteractionSymbol1()
Visual Basic
Protected Overrides Function GetInteractionSymbol1 As Image
F#
abstract GetInteractionSymbol1 : unit -> Image
override GetInteractionSymbol1 : unit -> Image

Return Value

Das erste von zwei Symbolen.

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


GetInteractionSymbol2 Method

[image]

DynamicNodes API
AbstractMethodBase..::..GetInteractionSymbol2 Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Bild für das zweite der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override Image GetInteractionSymbol2()
Visual Basic
Protected Overrides Function GetInteractionSymbol2 As Image
F#
abstract GetInteractionSymbol2 : unit -> Image
override GetInteractionSymbol2 : unit -> Image

Return Value

Das zweite von zwei Symbolen oder null.

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


GetTextLine1 Method

[image]

DynamicNodes API
AbstractMethodBase..::..GetTextLine1 Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die erste von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override string GetTextLine1()
Visual Basic
Protected Overrides Function GetTextLine1 As String
F#
abstract GetTextLine1 : unit -> string
override GetTextLine1 : unit -> string

Return Value

Die erste von drei Textzeilen.

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


Init Method

[image]

DynamicNodes API
AbstractMethodBase..::..Init Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die aktuelle Instanz. Wird von den Konstruktoren aufgerufen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void Init()
Visual Basic
Protected Overrides Sub Init
F#
abstract Init : unit -> unit
override Init : unit -> unit

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


InitPorts Method

[image]

DynamicNodes API
AbstractMethodBase..::..InitPorts Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert oder aktualisiert die Anschlüsse nach Auswahl einer Methode.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void InitPorts()
Visual Basic
Protected Overrides Sub InitPorts
F#
abstract InitPorts : unit -> unit
override InitPorts : unit -> unit

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


OnCommand Method

[image]

DynamicNodes API
AbstractMethodBase..::..OnCommand Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public override void OnCommand(
    string command
)
Visual Basic
Public Overrides Sub OnCommand ( _
    command As String _
)
F#
abstract OnCommand :
        command:string -> unit
override OnCommand :
        command:string -> unit

Parameters

command
Type: System..::..String
Der Befehls-Code des Benutzerbefehls.

Implements

INode..::..OnCommand(String)

Remarks

Diese Methode sollte von einer Klasse überschrieben werden, die einen oder mehrere Benutzerbefehle mit AddCommand(String, String) registriert hat.

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


OnDefaultCommand Method

[image]

DynamicNodes API
AbstractMethodBase..::..OnDefaultCommand Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public override void OnDefaultCommand()
Visual Basic
Public Overrides Sub OnDefaultCommand
F#
abstract OnDefaultCommand : unit -> unit
override OnDefaultCommand : unit -> unit

Implements

INode..::..OnDefaultCommand()()()()

Remarks

Diese Methode muss nicht überschrieben werden.

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


PaintCustomArea Method

[image] [image]

DynamicNodes API
AbstractMethodBase..::..PaintCustomArea Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from AbstractWrapper.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


RegisterStreamInPorts Method

[image] [image]

DynamicNodes API
AbstractMethodBase..::..RegisterStreamInPorts Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


TraceError Method

[image] [image]

DynamicNodes API
AbstractMethodBase..::..TraceError Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
AbstractMethodBase..::..TraceInfo Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
AbstractMethodBase..::..TraceVerbose Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
AbstractMethodBase..::..TraceVerboseData Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
AbstractMethodBase..::..TraceWarning Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


Work Method

[image] [image]

DynamicNodes API
AbstractMethodBase..::..Work Method
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Overrides StreamNode..::..Work(TokenSet).)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


Work Method (TokenSet)

[image]

DynamicNodes API
AbstractMethodBase..::..Work Method (TokenSet)
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public override void Work(
    TokenSet ts
)
Visual Basic
Public Overrides Sub Work ( _
    ts As TokenSet _
)
F#
abstract Work :
        ts:TokenSet -> unit
override Work :
        ts:TokenSet -> unit

Parameters

ts
Type: DynamicNode.Core..::..TokenSet
Das TokenSet mit den aktuellen Tokens aller Eingänge.

See Also

AbstractMethodBase Class
Work Overload
DynamicNode.Ext.Objects Namespace


AbstractMethodBase Properties

[image] [image]

DynamicNodes API
AbstractMethodBase Properties
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractMethodBase type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected property | IsMethodStatic | Gibt einen Wert zurück, der angibt, ob die Methode statisch ist.
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | MethodBase | Liest oder schreibt die gekapselte Methode.
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Protected property | ReturnOutPortId | Gibt die Port-ID für den Ausgang zurück, der Rückgabewerte des Methodenaufrufs weiterleiten soll.
Protected property | ReturnType | Gibt den Datentyp für den Ausgang zurück, der den Rückgabewert des Methodenaufrufs weiterleiten soll.
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


IsMethodStatic Property

[image]

DynamicNodes API
AbstractMethodBase..::..IsMethodStatic Property
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Methode statisch ist.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected abstract bool IsMethodStatic { get; }
Visual Basic
Protected MustOverride ReadOnly Property IsMethodStatic As Boolean
    Get
F#
abstract IsMethodStatic : bool

Field Value

true, wenn die Methode statisch ist, sonst false.

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


Item Property

[image] [image]

DynamicNodes API
AbstractMethodBase..::..Item Property
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

AbstractMethodBase Class
AbstractMethodBase Members
DynamicNode.Ext.Objects Namespace


MethodBase Property

[image]

DynamicNodes API
AbstractMethodBase..::..MethodBase Property
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die gekapselte Methode.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public MethodBase MethodBase { get; set; }
Visual Basic
Public Property MethodBase As MethodBase
    Get
    Set
F#
member MethodBase : MethodBase with get, set

Field Value

Die gekapselte CLR-Methode.

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


ReturnOutPortId Property

[image]

DynamicNodes API
AbstractMethodBase..::..ReturnOutPortId Property
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Port-ID für den Ausgang zurück, der Rückgabewerte des Methodenaufrufs weiterleiten soll.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected abstract string ReturnOutPortId { get; }
Visual Basic
Protected MustOverride ReadOnly Property ReturnOutPortId As String
    Get
F#
abstract ReturnOutPortId : string

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


ReturnType Property

[image]

DynamicNodes API
AbstractMethodBase..::..ReturnType Property
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Datentyp für den Ausgang zurück, der den Rückgabewert des Methodenaufrufs weiterleiten soll.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected abstract Type ReturnType { get; }
Visual Basic
Protected MustOverride ReadOnly Property ReturnType As Type
    Get
F#
abstract ReturnType : Type

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


AbstractMethodBase Events

[image] [image]

DynamicNodes API
AbstractMethodBase Events
AbstractMethodBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractMethodBase type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

AbstractMethodBase Class
DynamicNode.Ext.Objects Namespace


AbstractWrapper Class

[image]

DynamicNodes API
AbstractWrapper Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für alle CLR-Wrapper-Knoten.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public abstract class AbstractWrapper : VisualNode
Visual Basic
Public MustInherit Class AbstractWrapper _
    Inherits VisualNode
F#
[<AbstractClassAttribute>]
type AbstractWrapper =
    class
        inherit VisualNode
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core..::..StreamNode
DynamicNode.Ext.Visual..::..VisualNode
DynamicNode.Ext.Objects..::..AbstractWrapper
DynamicNode.Ext.Objects..::..AbstractMethodBase

See Also

AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


AbstractWrapper Members

[image] [image]

DynamicNodes API
AbstractWrapper Members
AbstractWrapper Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractWrapper type exposes the following members.

Constructors

 | Name | Description
Protected method | AbstractWrapper | Initialisiert eine neue Instanz von AbstractWrapper.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetInteractionSymbol1 | Gibt ein Bild für das erste der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren.
Protected method | GetInteractionSymbol2 | Gibt ein Bild für das zweite der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren.
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetMaxClientWidth | Gibt die maximale Breite des benutzerdefinierten Bereichs der Knotendarstellung zurück. Die Breite wird anhand der Darstellung von den zwei Symbolen und den drei Textzeilen ermittelt.
Protected method | GetTextLine1 | Gibt die erste von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben.
Protected method | GetTextLine2 | Gibt die zweite von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben.
Protected method | Init | Initialisiert die aktuelle Instanz. Wird von den Konstruktoren aufgerufen.
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Inherited from VisualNode.)
Protected method | InitPorts | Initialisiert oder aktualisiert die Anschlüsse nach Auswahl eines Properties.
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Overrides VisualNode..::..InitVisualization(NodeVisualization).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Overrides Node..::..OnCommand(String).)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Overrides Node..::..OnDefaultCommand()()()().)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Protected method | UpdateVisualization | Aktualisiert die visuelle Darstellung des Knotens.
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)

Fields

Name | Description
FontLine1 | Die Standardschriftart für die erste Textzeile in der Knotendarstellung.
FontLine2 | Die Standardschriftart für die zweite Textzeile in der Knotendarstellung.
FontMeasureBmp | Ein Bild von dem Graphics-Objekte erstellt werden können um Schriftgrößenmessungen durch zu führen.
InteractionSymbols | Ein ImageList-Objekt, welches typische .NET-Element-Symbole enthält.
LineHeight1 | Die Standardschriftgröße für die erste Textzeile in der Knotendarstellung.
LineHeight2 | Die Standardschriftgröße für die zweite Textzeile in der Knotendarstellung.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


AbstractWrapper Constructor

[image]

DynamicNodes API
AbstractWrapper Constructor
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von AbstractWrapper.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected AbstractWrapper()
Visual Basic
Protected Sub New
F#
new : unit -> AbstractWrapper

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


AbstractWrapper Fields

[image] [image]

DynamicNodes API
AbstractWrapper Fields
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractWrapper type exposes the following members.

Fields

Name | Description
FontLine1 | Die Standardschriftart für die erste Textzeile in der Knotendarstellung.
FontLine2 | Die Standardschriftart für die zweite Textzeile in der Knotendarstellung.
FontMeasureBmp | Ein Bild von dem Graphics-Objekte erstellt werden können um Schriftgrößenmessungen durch zu führen.
InteractionSymbols | Ein ImageList-Objekt, welches typische .NET-Element-Symbole enthält.
LineHeight1 | Die Standardschriftgröße für die erste Textzeile in der Knotendarstellung.
LineHeight2 | Die Standardschriftgröße für die zweite Textzeile in der Knotendarstellung.

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


FontLine1 Field

[image]

DynamicNodes API
AbstractWrapper..::..FontLine1 Field
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardschriftart für die erste Textzeile in der Knotendarstellung.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected static readonly Font FontLine1
Visual Basic
Protected Shared ReadOnly FontLine1 As Font
F#
static val FontLine1: Font

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


FontLine2 Field

[image]

DynamicNodes API
AbstractWrapper..::..FontLine2 Field
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardschriftart für die zweite Textzeile in der Knotendarstellung.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected static readonly Font FontLine2
Visual Basic
Protected Shared ReadOnly FontLine2 As Font
F#
static val FontLine2: Font

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


FontMeasureBmp Field

[image]

DynamicNodes API
AbstractWrapper..::..FontMeasureBmp Field
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Bild von dem Graphics-Objekte erstellt werden können um Schriftgrößenmessungen durch zu führen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected static readonly Bitmap FontMeasureBmp
Visual Basic
Protected Shared ReadOnly FontMeasureBmp As Bitmap
F#
static val FontMeasureBmp: Bitmap

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


InteractionSymbols Field

[image]

DynamicNodes API
AbstractWrapper..::..InteractionSymbols Field
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein ImageList-Objekt, welches typische .NET-Element-Symbole enthält.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected static readonly ImageList InteractionSymbols
Visual Basic
Protected Shared ReadOnly InteractionSymbols As ImageList
F#
static val InteractionSymbols: ImageList

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


LineHeight1 Field

[image]

DynamicNodes API
AbstractWrapper..::..LineHeight1 Field
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardschriftgröße für die erste Textzeile in der Knotendarstellung.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected static readonly float LineHeight1
Visual Basic
Protected Shared ReadOnly LineHeight1 As Single
F#
static val LineHeight1: float32

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


LineHeight2 Field

[image]

DynamicNodes API
AbstractWrapper..::..LineHeight2 Field
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardschriftgröße für die zweite Textzeile in der Knotendarstellung.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected static readonly float LineHeight2
Visual Basic
Protected Shared ReadOnly LineHeight2 As Single
F#
static val LineHeight2: float32

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


AbstractWrapper Methods

[image] [image]

DynamicNodes API
AbstractWrapper Methods
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractWrapper type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetInteractionSymbol1 | Gibt ein Bild für das erste der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren.
Protected method | GetInteractionSymbol2 | Gibt ein Bild für das zweite der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren.
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetMaxClientWidth | Gibt die maximale Breite des benutzerdefinierten Bereichs der Knotendarstellung zurück. Die Breite wird anhand der Darstellung von den zwei Symbolen und den drei Textzeilen ermittelt.
Protected method | GetTextLine1 | Gibt die erste von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben.
Protected method | GetTextLine2 | Gibt die zweite von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben.
Protected method | Init | Initialisiert die aktuelle Instanz. Wird von den Konstruktoren aufgerufen.
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Inherited from VisualNode.)
Protected method | InitPorts | Initialisiert oder aktualisiert die Anschlüsse nach Auswahl eines Properties.
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Overrides VisualNode..::..InitVisualization(NodeVisualization).)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Overrides Node..::..OnCommand(String).)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Overrides Node..::..OnDefaultCommand()()()().)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Protected method | UpdateVisualization | Aktualisiert die visuelle Darstellung des Knotens.
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
AbstractWrapper..::..BeforeUseExtension Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


Duplicate Method

[image] [image]

DynamicNodes API
AbstractWrapper..::..Duplicate Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


GetInteractionSymbol1 Method

[image]

DynamicNodes API
AbstractWrapper..::..GetInteractionSymbol1 Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Bild für das erste der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected virtual Image GetInteractionSymbol1()
Visual Basic
Protected Overridable Function GetInteractionSymbol1 As Image
F#
abstract GetInteractionSymbol1 : unit -> Image
override GetInteractionSymbol1 : unit -> Image

Return Value

Das erste von zwei Symbolen.

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


GetInteractionSymbol2 Method

[image]

DynamicNodes API
AbstractWrapper..::..GetInteractionSymbol2 Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Bild für das zweite der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected virtual Image GetInteractionSymbol2()
Visual Basic
Protected Overridable Function GetInteractionSymbol2 As Image
F#
abstract GetInteractionSymbol2 : unit -> Image
override GetInteractionSymbol2 : unit -> Image

Return Value

Das zweite von zwei Symbolen oder null.

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


GetMaxClientWidth Method

[image]

DynamicNodes API
AbstractWrapper..::..GetMaxClientWidth Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die maximale Breite des benutzerdefinierten Bereichs der Knotendarstellung zurück. Die Breite wird anhand der Darstellung von den zwei Symbolen und den drei Textzeilen ermittelt.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected float GetMaxClientWidth()
Visual Basic
Protected Function GetMaxClientWidth As Single
F#
member GetMaxClientWidth : unit -> float32

Return Value

Die maximale Breite der benutzerdefinierten Knotendarstellung.

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


GetTextLine1 Method

[image]

DynamicNodes API
AbstractWrapper..::..GetTextLine1 Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die erste von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected abstract string GetTextLine1()
Visual Basic
Protected MustOverride Function GetTextLine1 As String
F#
abstract GetTextLine1 : unit -> string

Return Value

Die erste von drei Textzeilen.

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


GetTextLine2 Method

[image]

DynamicNodes API
AbstractWrapper..::..GetTextLine2 Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die zweite von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected abstract string GetTextLine2()
Visual Basic
Protected MustOverride Function GetTextLine2 As String
F#
abstract GetTextLine2 : unit -> string

Return Value

Die zweite von drei Textzeilen.

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


Init Method

[image]

DynamicNodes API
AbstractWrapper..::..Init Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die aktuelle Instanz. Wird von den Konstruktoren aufgerufen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected virtual void Init()
Visual Basic
Protected Overridable Sub Init
F#
abstract Init : unit -> unit
override Init : unit -> unit

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


InitPorts Method

[image]

DynamicNodes API
AbstractWrapper..::..InitPorts Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert oder aktualisiert die Anschlüsse nach Auswahl eines Properties.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected abstract void InitPorts()
Visual Basic
Protected MustOverride Sub InitPorts
F#
abstract InitPorts : unit -> unit

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


InitVisualization Method

[image]

DynamicNodes API
AbstractWrapper..::..InitVisualization Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die Knoten-Visualisierung.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void InitVisualization(
    NodeVisualization nVis
)
Visual Basic
Protected Overrides Sub InitVisualization ( _
    nVis As NodeVisualization _
)
F#
abstract InitVisualization :
        nVis:NodeVisualization -> unit
override InitVisualization :
        nVis:NodeVisualization -> unit

Parameters

nVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


OnCommand Method

[image]

DynamicNodes API
AbstractWrapper..::..OnCommand Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public override void OnCommand(
    string command
)
Visual Basic
Public Overrides Sub OnCommand ( _
    command As String _
)
F#
abstract OnCommand :
        command:string -> unit
override OnCommand :
        command:string -> unit

Parameters

command
Type: System..::..String
Der Befehls-Code des Benutzerbefehls.

Implements

INode..::..OnCommand(String)

Remarks

Diese Methode sollte von einer Klasse überschrieben werden, die einen oder mehrere Benutzerbefehle mit AddCommand(String, String) registriert hat.

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


OnDefaultCommand Method

[image]

DynamicNodes API
AbstractWrapper..::..OnDefaultCommand Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public override void OnDefaultCommand()
Visual Basic
Public Overrides Sub OnDefaultCommand
F#
abstract OnDefaultCommand : unit -> unit
override OnDefaultCommand : unit -> unit

Implements

INode..::..OnDefaultCommand()()()()

Remarks

Diese Methode muss nicht überschrieben werden.

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


PaintCustomArea Method

[image] [image]

DynamicNodes API
AbstractWrapper..::..PaintCustomArea Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


PaintCustomArea Method (Graphics, RectangleF, IPaintProperties)

[image]

DynamicNodes API
AbstractWrapper..::..PaintCustomArea Method (Graphics, RectangleF, IPaintProperties)
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected virtual void PaintCustomArea(
    Graphics g,
    RectangleF area,
    IPaintProperties pp
)
Visual Basic
Protected Overridable Sub PaintCustomArea ( _
    g As Graphics, _
    area As RectangleF, _
    pp As IPaintProperties _
)
F#
abstract PaintCustomArea :
        g:Graphics *
        area:RectangleF *
        pp:IPaintProperties -> unit
override PaintCustomArea :
        g:Graphics *
        area:RectangleF *
        pp:IPaintProperties -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Der grafische Kontext.
area
Type: System.Drawing..::..RectangleF
Der benutzerdefinierte Bereich.
pp
Type: DynamicNode.Ext.Visual..::..IPaintProperties
Eine Sammlung von Zeichenressourcen.

See Also

AbstractWrapper Class
PaintCustomArea Overload
DynamicNode.Ext.Objects Namespace


RegisterStreamInPorts Method

[image] [image]

DynamicNodes API
AbstractWrapper..::..RegisterStreamInPorts Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


TraceError Method

[image] [image]

DynamicNodes API
AbstractWrapper..::..TraceError Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
AbstractWrapper..::..TraceInfo Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
AbstractWrapper..::..TraceVerbose Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
AbstractWrapper..::..TraceVerboseData Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
AbstractWrapper..::..TraceWarning Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


UpdateVisualization Method

[image]

DynamicNodes API
AbstractWrapper..::..UpdateVisualization Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktualisiert die visuelle Darstellung des Knotens.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected void UpdateVisualization()
Visual Basic
Protected Sub UpdateVisualization
F#
member UpdateVisualization : unit -> unit

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


Work Method

[image] [image]

DynamicNodes API
AbstractWrapper..::..Work Method
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


AbstractWrapper Properties

[image] [image]

DynamicNodes API
AbstractWrapper Properties
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractWrapper type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


Item Property

[image] [image]

DynamicNodes API
AbstractWrapper..::..Item Property
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

AbstractWrapper Class
AbstractWrapper Members
DynamicNode.Ext.Objects Namespace


AbstractWrapper Events

[image] [image]

DynamicNodes API
AbstractWrapper Events
AbstractWrapper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractWrapper type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

AbstractWrapper Class
DynamicNode.Ext.Objects Namespace


ClrLibraryBrowser Class

[image]

DynamicNodes API
ClrLibraryBrowser Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt einen Browser für geladene Assemblies dar. Er stellt Namensräume und Typen eines Assemblies in einem Baum dar und zeigt alle geeigneten Member eines ausgewählten Typen in einer Liste an.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class ClrLibraryBrowser : UserControl
Visual Basic
Public Class ClrLibraryBrowser _
    Inherits UserControl
F#
type ClrLibraryBrowser =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Objects..::..ClrLibraryBrowser

See Also

ClrLibraryBrowser Members
DynamicNode.Ext.Objects Namespace


ClrLibraryBrowser Members

[image] [image]

DynamicNodes API
ClrLibraryBrowser Members
ClrLibraryBrowser Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ClrLibraryBrowser type exposes the following members.

Constructors

 | Name | Description
Public method | ClrLibraryBrowser | Initialisiert eine neue Instanz von ClrLibraryBrowser.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnMemberDrag | Wird aufgerufen wenn ein Member-Element aus der Liste gezogen wird. Löst das Ereignis MemberDrag aus.
Protected method | OnTypeDrag | Wird aufgerufen wenn ein Type-Element aus dem Baum gezogen wird. Löst das Ereignis TypeDrag aus.

Properties

 | Name | Description
Public property | Assembly | Gibt das zur Zeit ausgewählte Assembly zurück, oder legt es fest.
Public property | Type | Gibt den zur Zeit ausgewählten Typen zurück, oder legt ihn fest.

Events

 | Name | Description
Public event | MemberDrag | Tritt auf, wenn ein Member-Element aus der Liste gezogen wird.
Public event | TypeDrag | Tritt auf, wenn ein Type-Element aus dem Baum gezogen wird.

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


ClrLibraryBrowser Constructor

[image]

DynamicNodes API
ClrLibraryBrowser Constructor
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ClrLibraryBrowser.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public ClrLibraryBrowser()
Visual Basic
Public Sub New
F#
new : unit -> ClrLibraryBrowser

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


ClrLibraryBrowser Methods

[image] [image]

DynamicNodes API
ClrLibraryBrowser Methods
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ClrLibraryBrowser type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnMemberDrag | Wird aufgerufen wenn ein Member-Element aus der Liste gezogen wird. Löst das Ereignis MemberDrag aus.
Protected method | OnTypeDrag | Wird aufgerufen wenn ein Type-Element aus dem Baum gezogen wird. Löst das Ereignis TypeDrag aus.

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


Dispose Method

[image]

DynamicNodes API
ClrLibraryBrowser..::..Dispose Method
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


OnMemberDrag Method

[image]

DynamicNodes API
ClrLibraryBrowser..::..OnMemberDrag Method
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn ein Member-Element aus der Liste gezogen wird. Löst das Ereignis MemberDrag aus.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected void OnMemberDrag(
    MemberInfo m
)
Visual Basic
Protected Sub OnMemberDrag ( _
    m As MemberInfo _
)
F#
member OnMemberDrag :
        m:MemberInfo -> unit

Parameters

m
Type: System.Reflection..::..MemberInfo
Der Member, der gezogen wird.

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


OnTypeDrag Method

[image]

DynamicNodes API
ClrLibraryBrowser..::..OnTypeDrag Method
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn ein Type-Element aus dem Baum gezogen wird. Löst das Ereignis TypeDrag aus.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected void OnTypeDrag(
    Type t
)
Visual Basic
Protected Sub OnTypeDrag ( _
    t As Type _
)
F#
member OnTypeDrag :
        t:Type -> unit

Parameters

t
Type: System..::..Type
Der Type, der gezogen wird.

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


ClrLibraryBrowser Properties

[image] [image]

DynamicNodes API
ClrLibraryBrowser Properties
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ClrLibraryBrowser type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Gibt das zur Zeit ausgewählte Assembly zurück, oder legt es fest.
Public property | Type | Gibt den zur Zeit ausgewählten Typen zurück, oder legt ihn fest.

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


Assembly Property

[image]

DynamicNodes API
ClrLibraryBrowser..::..Assembly Property
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das zur Zeit ausgewählte Assembly zurück, oder legt es fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Assembly Assembly { get; private set; }
Visual Basic
Public Property Assembly As Assembly
    Get
    Private Set
F#
member Assembly : Assembly with get, private set

Field Value

Ein Assembly.

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


Type Property

[image]

DynamicNodes API
ClrLibraryBrowser..::..Type Property
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den zur Zeit ausgewählten Typen zurück, oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Type Type { get; set; }
Visual Basic
Public Property Type As Type
    Get
    Set
F#
member Type : Type with get, set

Field Value

Ein Type.

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


ClrLibraryBrowser Events

[image] [image]

DynamicNodes API
ClrLibraryBrowser Events
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ClrLibraryBrowser type exposes the following members.

Events

 | Name | Description
Public event | MemberDrag | Tritt auf, wenn ein Member-Element aus der Liste gezogen wird.
Public event | TypeDrag | Tritt auf, wenn ein Type-Element aus dem Baum gezogen wird.

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


MemberDrag Event

[image]

DynamicNodes API
ClrLibraryBrowser..::..MemberDrag Event
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn ein Member-Element aus der Liste gezogen wird.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public event EventHandler<MemberDragEventArgs> MemberDrag
Visual Basic
Public Event MemberDrag As EventHandler(Of MemberDragEventArgs)
F#
member MemberDrag : IEvent<EventHandler<MemberDragEventArgs>,
    MemberDragEventArgs>

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


TypeDrag Event

[image]

DynamicNodes API
ClrLibraryBrowser..::..TypeDrag Event
ClrLibraryBrowser Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn ein Type-Element aus dem Baum gezogen wird.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public event EventHandler<TypeDragEventArgs> TypeDrag
Visual Basic
Public Event TypeDrag As EventHandler(Of TypeDragEventArgs)
F#
member TypeDrag : IEvent<EventHandler<TypeDragEventArgs>,
    TypeDragEventArgs>

See Also

ClrLibraryBrowser Class
DynamicNode.Ext.Objects Namespace


ClrTools Class

[image]

DynamicNodes API
ClrTools Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Unterstützung für das Reflektieren von CLR-Typen und CLR-Membern zur Verfügung.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static class ClrTools
Visual Basic
Public NotInheritable Class ClrTools
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ClrTools =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Objects..::..ClrTools

See Also

ClrTools Members
DynamicNode.Ext.Objects Namespace


ClrTools Members

[image] [image]

DynamicNodes API
ClrTools Members
ClrTools Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ClrTools type exposes the following members.

Methods

Name | Description
CheckConstructor | Überprüft, ob ein Konstruktor geeignet ist von DNObjects verarbeitet zu werden.
CheckEvent(EventInfo, String%) | Überprüft, ob ein Ereignis geeignet ist von DNObjects verarbeitet zu werden.
CheckEvent(EventInfo, Boolean, String%) | Überprüft, ob ein Ereignis geeignet ist von DNObjects verarbeitet zu werden.
CheckField(FieldInfo, String%) | Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.
CheckField(FieldInfo, Boolean, String%) | Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.
CheckField(FieldInfo, Boolean, Boolean, String%) | Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.
CheckMethod(MethodInfo, String%) | Überprüft, ob eine Methode geeignet ist von DNObjects verarbeitet zu werden.
CheckMethod(MethodInfo, Boolean, String%) | Überprüft, ob eine Methode geeignet ist von DNObjects verarbeitet zu werden.
CheckPropertyGet(PropertyInfo, String%) | Überprüft, ob der Getter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.
CheckPropertyGet(PropertyInfo, Boolean, String%) | Überprüft, ob der Getter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.
CheckPropertySet(PropertyInfo, String%) | Überprüft, ob der Setter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.
CheckPropertySet(PropertyInfo, Boolean, String%) | Überprüft, ob der Setter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.
CheckType | Überprüft, ob ein Type geeignet ist von DNObjects verarbeitet zu werden.
ConfigNodesParallelisation | Konfiguriert die Parallelität eines Knoten für den Zugriff auf den übergebenen übergebenen Typ. Wird ein Typ übergeben, der von Component erbt, wird Parallelizing auf SingleThreaded und SingleThreadContextId auf "winforms" gesetzt. Wird ein Typ übergeben, der von DispatcherObject erbt, wird Parallelizing auf SingleThreaded und SingleThreadContextId auf "wpf" gesetzt.
CreateInteractionSymbolList | Erzeugt eine ImageList die VS-typische Symbole für Typen und Member enthält.
FindConstructor | Findet einen Konstruktor anhand seiner Beschreibung mittels GetDescriptor(ConstructorInfo).
FindEvent | Findet ein Ereignis anhand seiner Beschreibung mittels GetDescriptor(EventInfo).
FindField | Findet ein Feld anhand seiner Beschreibung mittels GetDescriptor(FieldInfo).
FindMethod | Findet eine Methode anhand ihrer Beschreibung mittels GetDescriptor(MethodInfo).
FindProperty | Findet eine Eigenschaft anhand seiner Beschreibung mittels GetDescriptor(PropertyInfo).
FindType | Findet einen Type anhand seiner Beschreibung mittels GetDescriptor(Type).
GetAssemblyCaption | Gibt eine formatierte Beschriftung für ein Assembly zurück.
GetConstructorCaption | Gibt eine formatierte Beschriftung für einen Konstruktor zurück.
GetConstructors | Gibt eine Aufzählung mit allen geeigneten Konstruktoren eines Typen zurück.
GetDescriptor(ConstructorInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Konstruktors. Der Konstruktor kann mittels FindConstructor(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(EventInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Ereignisses. Das Ereignis kann mittels FindEvent(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(FieldInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Feldes. Das Feld kann mittels FindField(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(MethodInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eine Methode. Die Methode kann mittels FindMethod(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(PropertyInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung einer Eigenschaft. Die Eigenschaft kann mittels FindProperty(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(Type) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Typen. Der Type kann mittels FindType(String) und der Zeichenkette wiedergefunden werden.
GetEventCaption | Gibt eine formatierte Beschriftung für ein Ereignis zurück.
GetEvents(Type) | Gibt eine Aufzählung mit allen geeigneten Ereignissen eines Typen zurück.
GetEvents(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Ereignissen eines Typen zurück.
GetFieldCaption | Gibt eine formatierte Beschriftung für ein Feld zurück.
GetFields(Type) | Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.
GetFields(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.
GetFields(Type, Boolean, Boolean) | Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.
GetMember | Gibt alle geeigneten dynamischen Member eines Typs zurück.
GetMemberCaption | Gibt eine Beschriftung für einen Member zurück.
GetMethodCaption | Gibt eine formatierte Beschriftung für eine Methode zurück.
GetMethods(Type) | Gibt eine Aufzählung mit allen geeigneten Methoden eines Typen zurück.
GetMethods(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Methoden eines Typen zurück.
GetNamespaceCaption | Gibt eine formatierte Beschriftung für einen Namensraum zurück.
GetProperties(Type) | Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.
GetProperties(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.
GetProperties(Type, Boolean, Boolean) | Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.
GetPropertyCaption | Gibt eine formatierte Beschriftung für eine Eigenschaft zurück.
GetTypeCaption(Type) | Gibt eine formatierte Beschriftung für einen Type zurück.
GetTypeCaption(Type, Boolean) | Gibt eine formatierte Beschriftung für einen Type zurück.
GetTypes(Type) | Gibt eine Aufzählung mit allen geeigneten verschachtelten Typen eines Typen zurück.
GetTypes(Assembly, Boolean) | Gibt eine Aufzählung mit allen geeigneten Typen eines Assemblies zurück.
ImageIndex(MemberInfo) | Gibt für einen MemberInfo den Bild-Index zurück, unter dem ein passendes Symbol in einer ImageList von CreateInteractionSymbolList()()()() zu finden ist.
ImageIndex(Type) | Gibt für einen Type den Bild-Index zurück, unter dem ein passendes Symbol in einer ImageList von CreateInteractionSymbolList()()()() zu finden ist.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


ClrTools Methods

[image] [image]

DynamicNodes API
ClrTools Methods
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ClrTools type exposes the following members.

Methods

Name | Description
CheckConstructor | Überprüft, ob ein Konstruktor geeignet ist von DNObjects verarbeitet zu werden.
CheckEvent(EventInfo, String%) | Überprüft, ob ein Ereignis geeignet ist von DNObjects verarbeitet zu werden.
CheckEvent(EventInfo, Boolean, String%) | Überprüft, ob ein Ereignis geeignet ist von DNObjects verarbeitet zu werden.
CheckField(FieldInfo, String%) | Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.
CheckField(FieldInfo, Boolean, String%) | Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.
CheckField(FieldInfo, Boolean, Boolean, String%) | Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.
CheckMethod(MethodInfo, String%) | Überprüft, ob eine Methode geeignet ist von DNObjects verarbeitet zu werden.
CheckMethod(MethodInfo, Boolean, String%) | Überprüft, ob eine Methode geeignet ist von DNObjects verarbeitet zu werden.
CheckPropertyGet(PropertyInfo, String%) | Überprüft, ob der Getter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.
CheckPropertyGet(PropertyInfo, Boolean, String%) | Überprüft, ob der Getter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.
CheckPropertySet(PropertyInfo, String%) | Überprüft, ob der Setter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.
CheckPropertySet(PropertyInfo, Boolean, String%) | Überprüft, ob der Setter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.
CheckType | Überprüft, ob ein Type geeignet ist von DNObjects verarbeitet zu werden.
ConfigNodesParallelisation | Konfiguriert die Parallelität eines Knoten für den Zugriff auf den übergebenen übergebenen Typ. Wird ein Typ übergeben, der von Component erbt, wird Parallelizing auf SingleThreaded und SingleThreadContextId auf "winforms" gesetzt. Wird ein Typ übergeben, der von DispatcherObject erbt, wird Parallelizing auf SingleThreaded und SingleThreadContextId auf "wpf" gesetzt.
CreateInteractionSymbolList | Erzeugt eine ImageList die VS-typische Symbole für Typen und Member enthält.
FindConstructor | Findet einen Konstruktor anhand seiner Beschreibung mittels GetDescriptor(ConstructorInfo).
FindEvent | Findet ein Ereignis anhand seiner Beschreibung mittels GetDescriptor(EventInfo).
FindField | Findet ein Feld anhand seiner Beschreibung mittels GetDescriptor(FieldInfo).
FindMethod | Findet eine Methode anhand ihrer Beschreibung mittels GetDescriptor(MethodInfo).
FindProperty | Findet eine Eigenschaft anhand seiner Beschreibung mittels GetDescriptor(PropertyInfo).
FindType | Findet einen Type anhand seiner Beschreibung mittels GetDescriptor(Type).
GetAssemblyCaption | Gibt eine formatierte Beschriftung für ein Assembly zurück.
GetConstructorCaption | Gibt eine formatierte Beschriftung für einen Konstruktor zurück.
GetConstructors | Gibt eine Aufzählung mit allen geeigneten Konstruktoren eines Typen zurück.
GetDescriptor(ConstructorInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Konstruktors. Der Konstruktor kann mittels FindConstructor(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(EventInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Ereignisses. Das Ereignis kann mittels FindEvent(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(FieldInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Feldes. Das Feld kann mittels FindField(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(MethodInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eine Methode. Die Methode kann mittels FindMethod(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(PropertyInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung einer Eigenschaft. Die Eigenschaft kann mittels FindProperty(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(Type) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Typen. Der Type kann mittels FindType(String) und der Zeichenkette wiedergefunden werden.
GetEventCaption | Gibt eine formatierte Beschriftung für ein Ereignis zurück.
GetEvents(Type) | Gibt eine Aufzählung mit allen geeigneten Ereignissen eines Typen zurück.
GetEvents(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Ereignissen eines Typen zurück.
GetFieldCaption | Gibt eine formatierte Beschriftung für ein Feld zurück.
GetFields(Type) | Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.
GetFields(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.
GetFields(Type, Boolean, Boolean) | Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.
GetMember | Gibt alle geeigneten dynamischen Member eines Typs zurück.
GetMemberCaption | Gibt eine Beschriftung für einen Member zurück.
GetMethodCaption | Gibt eine formatierte Beschriftung für eine Methode zurück.
GetMethods(Type) | Gibt eine Aufzählung mit allen geeigneten Methoden eines Typen zurück.
GetMethods(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Methoden eines Typen zurück.
GetNamespaceCaption | Gibt eine formatierte Beschriftung für einen Namensraum zurück.
GetProperties(Type) | Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.
GetProperties(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.
GetProperties(Type, Boolean, Boolean) | Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.
GetPropertyCaption | Gibt eine formatierte Beschriftung für eine Eigenschaft zurück.
GetTypeCaption(Type) | Gibt eine formatierte Beschriftung für einen Type zurück.
GetTypeCaption(Type, Boolean) | Gibt eine formatierte Beschriftung für einen Type zurück.
GetTypes(Type) | Gibt eine Aufzählung mit allen geeigneten verschachtelten Typen eines Typen zurück.
GetTypes(Assembly, Boolean) | Gibt eine Aufzählung mit allen geeigneten Typen eines Assemblies zurück.
ImageIndex(MemberInfo) | Gibt für einen MemberInfo den Bild-Index zurück, unter dem ein passendes Symbol in einer ImageList von CreateInteractionSymbolList()()()() zu finden ist.
ImageIndex(Type) | Gibt für einen Type den Bild-Index zurück, unter dem ein passendes Symbol in einer ImageList von CreateInteractionSymbolList()()()() zu finden ist.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


CheckConstructor Method

[image]

DynamicNodes API
ClrTools..::..CheckConstructor Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob ein Konstruktor geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckConstructor(
    ConstructorInfo ci,
    out string msg
)
Visual Basic
Public Shared Function CheckConstructor ( _
    ci As ConstructorInfo, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckConstructor :
        ci:ConstructorInfo *
        msg:string byref -> bool

Parameters

ci
Type: System.Reflection..::..ConstructorInfo
Ein Konstruktor.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn der übergebene Konstruktor geeignet ist, sonst false.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


CheckEvent Method

[image] [image]

DynamicNodes API
ClrTools..::..CheckEvent Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
CheckEvent(EventInfo, String%) | Überprüft, ob ein Ereignis geeignet ist von DNObjects verarbeitet zu werden.
CheckEvent(EventInfo, Boolean, String%) | Überprüft, ob ein Ereignis geeignet ist von DNObjects verarbeitet zu werden.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


CheckEvent Method (EventInfo, String)

[image]

DynamicNodes API
ClrTools..::..CheckEvent Method (EventInfo, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob ein Ereignis geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckEvent(
    EventInfo ei,
    out string msg
)
Visual Basic
Public Shared Function CheckEvent ( _
    ei As EventInfo, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckEvent :
        ei:EventInfo *
        msg:string byref -> bool

Parameters

ei
Type: System.Reflection..::..EventInfo
Ein Ereignis.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn das übergebene Ereignis geeignet ist, sonst false.

See Also

ClrTools Class
CheckEvent Overload
DynamicNode.Ext.Objects Namespace


CheckEvent Method (EventInfo, Boolean, String)

[image]

DynamicNodes API
ClrTools..::..CheckEvent Method (EventInfo, Boolean, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob ein Ereignis geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckEvent(
    EventInfo ei,
    bool mustBeStatic,
    out string msg
)
Visual Basic
Public Shared Function CheckEvent ( _
    ei As EventInfo, _
    mustBeStatic As Boolean, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckEvent :
        ei:EventInfo *
        mustBeStatic:bool *
        msg:string byref -> bool

Parameters

ei
Type: System.Reflection..::..EventInfo
Ein Ereignis.
mustBeStatic
Type: System..::..Boolean
Falls true übergeben wird, muss das Ereignis statisch sein, sonst muss es dynamisch sein
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn das übergebene Ereignis geeignet ist, sonst false.

See Also

ClrTools Class
CheckEvent Overload
DynamicNode.Ext.Objects Namespace


CheckField Method

[image] [image]

DynamicNodes API
ClrTools..::..CheckField Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
CheckField(FieldInfo, String%) | Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.
CheckField(FieldInfo, Boolean, String%) | Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.
CheckField(FieldInfo, Boolean, Boolean, String%) | Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


CheckField Method (FieldInfo, String)

[image]

DynamicNodes API
ClrTools..::..CheckField Method (FieldInfo, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckField(
    FieldInfo fi,
    out string msg
)
Visual Basic
Public Shared Function CheckField ( _
    fi As FieldInfo, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckField :
        fi:FieldInfo *
        msg:string byref -> bool

Parameters

fi
Type: System.Reflection..::..FieldInfo
Ein Feld.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn das übergebene Feld geeignet ist, sonst false.

See Also

ClrTools Class
CheckField Overload
DynamicNode.Ext.Objects Namespace


CheckField Method (FieldInfo, Boolean, String)

[image]

DynamicNodes API
ClrTools..::..CheckField Method (FieldInfo, Boolean, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckField(
    FieldInfo fi,
    bool mustBeStatic,
    out string msg
)
Visual Basic
Public Shared Function CheckField ( _
    fi As FieldInfo, _
    mustBeStatic As Boolean, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckField :
        fi:FieldInfo *
        mustBeStatic:bool *
        msg:string byref -> bool

Parameters

fi
Type: System.Reflection..::..FieldInfo
Ein Feld.
mustBeStatic
Type: System..::..Boolean
Falls true übergeben wird, muss das Feld statisch sein, sonst muss es dynamisch sein.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn das übergebene Feld geeignet ist, sonst false.

See Also

ClrTools Class
CheckField Overload
DynamicNode.Ext.Objects Namespace


CheckField Method (FieldInfo, Boolean, Boolean, String)

[image]

DynamicNodes API
ClrTools..::..CheckField Method (FieldInfo, Boolean, Boolean, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob ein Feld geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckField(
    FieldInfo fi,
    bool mustBeStatic,
    bool writeable,
    out string msg
)
Visual Basic
Public Shared Function CheckField ( _
    fi As FieldInfo, _
    mustBeStatic As Boolean, _
    writeable As Boolean, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckField :
        fi:FieldInfo *
        mustBeStatic:bool *
        writeable:bool *
        msg:string byref -> bool

Parameters

fi
Type: System.Reflection..::..FieldInfo
Ein Feld.
mustBeStatic
Type: System..::..Boolean
Falls true übergeben wird, muss das Feld statisch sein, sonst muss es dynamisch sein.
writeable
Type: System..::..Boolean
true, wenn das Feld beschreibbar sein muss, false wenn es nur lesbar sein muss.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn das übergebene Feld geeignet ist, sonst false.

See Also

ClrTools Class
CheckField Overload
DynamicNode.Ext.Objects Namespace


CheckMethod Method

[image] [image]

DynamicNodes API
ClrTools..::..CheckMethod Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
CheckMethod(MethodInfo, String%) | Überprüft, ob eine Methode geeignet ist von DNObjects verarbeitet zu werden.
CheckMethod(MethodInfo, Boolean, String%) | Überprüft, ob eine Methode geeignet ist von DNObjects verarbeitet zu werden.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


CheckMethod Method (MethodInfo, String)

[image]

DynamicNodes API
ClrTools..::..CheckMethod Method (MethodInfo, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob eine Methode geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckMethod(
    MethodInfo mi,
    out string msg
)
Visual Basic
Public Shared Function CheckMethod ( _
    mi As MethodInfo, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckMethod :
        mi:MethodInfo *
        msg:string byref -> bool

Parameters

mi
Type: System.Reflection..::..MethodInfo
Ein Methode.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn die übergebene Methode geeignet ist, sonst false.

See Also

ClrTools Class
CheckMethod Overload
DynamicNode.Ext.Objects Namespace


CheckMethod Method (MethodInfo, Boolean, String)

[image]

DynamicNodes API
ClrTools..::..CheckMethod Method (MethodInfo, Boolean, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob eine Methode geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckMethod(
    MethodInfo mi,
    bool mustBeStatic,
    out string msg
)
Visual Basic
Public Shared Function CheckMethod ( _
    mi As MethodInfo, _
    mustBeStatic As Boolean, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckMethod :
        mi:MethodInfo *
        mustBeStatic:bool *
        msg:string byref -> bool

Parameters

mi
Type: System.Reflection..::..MethodInfo
Ein Methode.
mustBeStatic
Type: System..::..Boolean
Falls true übergeben wird, muss die Methode statisch sein, sonst muss sie dynamisch sein.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn die übergebene Methode geeignet ist, sonst false.

See Also

ClrTools Class
CheckMethod Overload
DynamicNode.Ext.Objects Namespace


CheckPropertyGet Method

[image] [image]

DynamicNodes API
ClrTools..::..CheckPropertyGet Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
CheckPropertyGet(PropertyInfo, String%) | Überprüft, ob der Getter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.
CheckPropertyGet(PropertyInfo, Boolean, String%) | Überprüft, ob der Getter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


CheckPropertyGet Method (PropertyInfo, String)

[image]

DynamicNodes API
ClrTools..::..CheckPropertyGet Method (PropertyInfo, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob der Getter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckPropertyGet(
    PropertyInfo pi,
    out string msg
)
Visual Basic
Public Shared Function CheckPropertyGet ( _
    pi As PropertyInfo, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckPropertyGet :
        pi:PropertyInfo *
        msg:string byref -> bool

Parameters

pi
Type: System.Reflection..::..PropertyInfo
Eine Eigenschaft.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn der Getter der übergebenen Eigenschaft geeignet ist, sonst false.

See Also

ClrTools Class
CheckPropertyGet Overload
DynamicNode.Ext.Objects Namespace


CheckPropertyGet Method (PropertyInfo, Boolean, String)

[image]

DynamicNodes API
ClrTools..::..CheckPropertyGet Method (PropertyInfo, Boolean, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob der Getter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckPropertyGet(
    PropertyInfo pi,
    bool mustBeStatic,
    out string msg
)
Visual Basic
Public Shared Function CheckPropertyGet ( _
    pi As PropertyInfo, _
    mustBeStatic As Boolean, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckPropertyGet :
        pi:PropertyInfo *
        mustBeStatic:bool *
        msg:string byref -> bool

Parameters

pi
Type: System.Reflection..::..PropertyInfo
Eine Eigenschaft.
mustBeStatic
Type: System..::..Boolean
Falls true übergeben wird, muss die Eigenschaft statisch sein, sonst muss sie dynamisch sein.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn der Getter der übergebenen Eigenschaft geeignet ist, sonst false.

See Also

ClrTools Class
CheckPropertyGet Overload
DynamicNode.Ext.Objects Namespace


CheckPropertySet Method

[image] [image]

DynamicNodes API
ClrTools..::..CheckPropertySet Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
CheckPropertySet(PropertyInfo, String%) | Überprüft, ob der Setter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.
CheckPropertySet(PropertyInfo, Boolean, String%) | Überprüft, ob der Setter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


CheckPropertySet Method (PropertyInfo, String)

[image]

DynamicNodes API
ClrTools..::..CheckPropertySet Method (PropertyInfo, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob der Setter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckPropertySet(
    PropertyInfo pi,
    out string msg
)
Visual Basic
Public Shared Function CheckPropertySet ( _
    pi As PropertyInfo, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckPropertySet :
        pi:PropertyInfo *
        msg:string byref -> bool

Parameters

pi
Type: System.Reflection..::..PropertyInfo
Eine Eigenschaft.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn der Setter der übergebenen Eigenschaft geeignet ist, sonst false.

See Also

ClrTools Class
CheckPropertySet Overload
DynamicNode.Ext.Objects Namespace


CheckPropertySet Method (PropertyInfo, Boolean, String)

[image]

DynamicNodes API
ClrTools..::..CheckPropertySet Method (PropertyInfo, Boolean, String%)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob der Setter einer Eigenschaft geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckPropertySet(
    PropertyInfo pi,
    bool mustBeStatic,
    out string msg
)
Visual Basic
Public Shared Function CheckPropertySet ( _
    pi As PropertyInfo, _
    mustBeStatic As Boolean, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckPropertySet :
        pi:PropertyInfo *
        mustBeStatic:bool *
        msg:string byref -> bool

Parameters

pi
Type: System.Reflection..::..PropertyInfo
Eine Eigenschaft.
mustBeStatic
Type: System..::..Boolean
Falls true übergeben wird, muss die Eigenschaft statisch sein, sonst muss sie dynamisch sein.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn der Setter der übergebenen Eigenschaft geeignet ist, sonst false.

See Also

ClrTools Class
CheckPropertySet Overload
DynamicNode.Ext.Objects Namespace


CheckType Method

[image]

DynamicNodes API
ClrTools..::..CheckType Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob ein Type geeignet ist von DNObjects verarbeitet zu werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static bool CheckType(
    Type t,
    bool noNested,
    out string msg
)
Visual Basic
Public Shared Function CheckType ( _
    t As Type, _
    noNested As Boolean, _
    <OutAttribute> ByRef msg As String _
) As Boolean
F#
static member CheckType :
        t:Type *
        noNested:bool *
        msg:string byref -> bool

Parameters

t
Type: System..::..Type
Ein Type.
noNested
Type: System..::..Boolean
Falls true übergeben wird, darf der Type nicht verschachtelt sein.
msg
Type: System..::..String %
Gibt im Fehlerfall eine Begründung zurück.

Return Value

true, wenn der übergebene Type geeignet ist, sonst false.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


ConfigNodesParallelisation Method

[image]

DynamicNodes API
ClrTools..::..ConfigNodesParallelisation Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Konfiguriert die Parallelität eines Knoten für den Zugriff auf den übergebenen übergebenen Typ. Wird ein Typ übergeben, der von Component erbt, wird Parallelizing auf SingleThreaded und SingleThreadContextId auf "winforms" gesetzt. Wird ein Typ übergeben, der von DispatcherObject erbt, wird Parallelizing auf SingleThreaded und SingleThreadContextId auf "wpf" gesetzt.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static void ConfigNodesParallelisation(
    INode node,
    Type boundType
)
Visual Basic
Public Shared Sub ConfigNodesParallelisation ( _
    node As INode, _
    boundType As Type _
)
F#
static member ConfigNodesParallelisation :
        node:INode *
        boundType:Type -> unit

Parameters

node
Type: DynamicNode.Core..::..INode
Der Knoten, dessen Parallelität konfiguriert werden soll.
boundType
Type: System..::..Type
Der Typ auf den der Knoten zugreifen soll.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


CreateInteractionSymbolList Method

[image]

DynamicNodes API
ClrTools..::..CreateInteractionSymbolList Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine ImageList die VS-typische Symbole für Typen und Member enthält.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static ImageList CreateInteractionSymbolList()
Visual Basic
Public Shared Function CreateInteractionSymbolList As ImageList
F#
static member CreateInteractionSymbolList : unit -> ImageList

Return Value

Eine ImageList mit Symbolen.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


FindConstructor Method

[image]

DynamicNodes API
ClrTools..::..FindConstructor Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Findet einen Konstruktor anhand seiner Beschreibung mittels GetDescriptor(ConstructorInfo).

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static ConstructorInfo FindConstructor(
    string descriptor
)
Visual Basic
Public Shared Function FindConstructor ( _
    descriptor As String _
) As ConstructorInfo
F#
static member FindConstructor :
        descriptor:string -> ConstructorInfo

Parameters

descriptor
Type: System..::..String
Eine beschreibende Zeichenkette.

Return Value

Ein ConstructorInfo-Objekt.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


FindEvent Method

[image]

DynamicNodes API
ClrTools..::..FindEvent Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Findet ein Ereignis anhand seiner Beschreibung mittels GetDescriptor(EventInfo).

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static EventInfo FindEvent(
    string descriptor
)
Visual Basic
Public Shared Function FindEvent ( _
    descriptor As String _
) As EventInfo
F#
static member FindEvent :
        descriptor:string -> EventInfo

Parameters

descriptor
Type: System..::..String
Eine beschreibende Zeichenkette.

Return Value

Ein EventInfo-Objekt.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


FindField Method

[image]

DynamicNodes API
ClrTools..::..FindField Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Findet ein Feld anhand seiner Beschreibung mittels GetDescriptor(FieldInfo).

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static FieldInfo FindField(
    string descriptor
)
Visual Basic
Public Shared Function FindField ( _
    descriptor As String _
) As FieldInfo
F#
static member FindField :
        descriptor:string -> FieldInfo

Parameters

descriptor
Type: System..::..String
Eine beschreibende Zeichenkette.

Return Value

Ein FieldInfo-Objekt.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


FindMethod Method

[image]

DynamicNodes API
ClrTools..::..FindMethod Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Findet eine Methode anhand ihrer Beschreibung mittels GetDescriptor(MethodInfo).

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static MethodInfo FindMethod(
    string descriptor
)
Visual Basic
Public Shared Function FindMethod ( _
    descriptor As String _
) As MethodInfo
F#
static member FindMethod :
        descriptor:string -> MethodInfo

Parameters

descriptor
Type: System..::..String
Eine beschreibende Zeichenkette.

Return Value

Ein MethodInfo-Objekt.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


FindProperty Method

[image]

DynamicNodes API
ClrTools..::..FindProperty Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Findet eine Eigenschaft anhand seiner Beschreibung mittels GetDescriptor(PropertyInfo).

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static PropertyInfo FindProperty(
    string descriptor
)
Visual Basic
Public Shared Function FindProperty ( _
    descriptor As String _
) As PropertyInfo
F#
static member FindProperty :
        descriptor:string -> PropertyInfo

Parameters

descriptor
Type: System..::..String
Eine beschreibende Zeichenkette.

Return Value

Ein PropertyInfo-Objekt.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


FindType Method

[image]

DynamicNodes API
ClrTools..::..FindType Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Findet einen Type anhand seiner Beschreibung mittels GetDescriptor(Type).

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static Type FindType(
    string descriptor
)
Visual Basic
Public Shared Function FindType ( _
    descriptor As String _
) As Type
F#
static member FindType :
        descriptor:string -> Type

Parameters

descriptor
Type: System..::..String
Eine beschreibende Zeichenkette.

Return Value

Ein Type-Objekt.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetAssemblyCaption Method

[image]

DynamicNodes API
ClrTools..::..GetAssemblyCaption Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine formatierte Beschriftung für ein Assembly zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetAssemblyCaption(
    Assembly a
)
Visual Basic
Public Shared Function GetAssemblyCaption ( _
    a As Assembly _
) As String
F#
static member GetAssemblyCaption :
        a:Assembly -> string

Parameters

a
Type: System.Reflection..::..Assembly
Ein Assembly.

Return Value

Eine Beschriftung.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetConstructorCaption Method

[image]

DynamicNodes API
ClrTools..::..GetConstructorCaption Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine formatierte Beschriftung für einen Konstruktor zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetConstructorCaption(
    ConstructorInfo constructor,
    bool nameOnly
)
Visual Basic
Public Shared Function GetConstructorCaption ( _
    constructor As ConstructorInfo, _
    nameOnly As Boolean _
) As String
F#
static member GetConstructorCaption :
        constructor:ConstructorInfo *
        nameOnly:bool -> string

Parameters

constructor
Type: System.Reflection..::..ConstructorInfo
Ein Konstruktor.
nameOnly
Type: System..::..Boolean
Gibt den Namen ohne Zusätze zurück, falls true übergeben wird.

Return Value

Eine Beschriftung.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetConstructors Method

[image]

DynamicNodes API
ClrTools..::..GetConstructors Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Konstruktoren eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<ConstructorInfo> GetConstructors(
    Type t
)
Visual Basic
Public Shared Function GetConstructors ( _
    t As Type _
) As IEnumerable(Of ConstructorInfo)
F#
static member GetConstructors :
        t:Type -> IEnumerable<ConstructorInfo>

Parameters

t
Type: System..::..Type
Ein Type.

Return Value

Eine Aufzählung mit geeigneten Konstruktoren.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetDescriptor Method

[image] [image]

DynamicNodes API
ClrTools..::..GetDescriptor Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
GetDescriptor(ConstructorInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Konstruktors. Der Konstruktor kann mittels FindConstructor(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(EventInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Ereignisses. Das Ereignis kann mittels FindEvent(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(FieldInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Feldes. Das Feld kann mittels FindField(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(MethodInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eine Methode. Die Methode kann mittels FindMethod(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(PropertyInfo) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung einer Eigenschaft. Die Eigenschaft kann mittels FindProperty(String) und der Zeichenkette wiedergefunden werden.
GetDescriptor(Type) | Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Typen. Der Type kann mittels FindType(String) und der Zeichenkette wiedergefunden werden.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


GetDescriptor Method (ConstructorInfo)

[image]

DynamicNodes API
ClrTools..::..GetDescriptor Method (ConstructorInfo)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Konstruktors. Der Konstruktor kann mittels FindConstructor(String) und der Zeichenkette wiedergefunden werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetDescriptor(
    ConstructorInfo constructor
)
Visual Basic
Public Shared Function GetDescriptor ( _
    constructor As ConstructorInfo _
) As String
F#
static member GetDescriptor :
        constructor:ConstructorInfo -> string

Parameters

constructor
Type: System.Reflection..::..ConstructorInfo
Ein Konstruktor.

Return Value

Eine eindeutiger Beschreibung für einen Konstruktor.

See Also

ClrTools Class
GetDescriptor Overload
DynamicNode.Ext.Objects Namespace


GetDescriptor Method (EventInfo)

[image]

DynamicNodes API
ClrTools..::..GetDescriptor Method (EventInfo)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Ereignisses. Das Ereignis kann mittels FindEvent(String) und der Zeichenkette wiedergefunden werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetDescriptor(
    EventInfo eventInfo
)
Visual Basic
Public Shared Function GetDescriptor ( _
    eventInfo As EventInfo _
) As String
F#
static member GetDescriptor :
        eventInfo:EventInfo -> string

Parameters

eventInfo
Type: System.Reflection..::..EventInfo
Ein Ereignis.

Return Value

Eine eindeutiger Beschreibung für ein Ereignis.

See Also

ClrTools Class
GetDescriptor Overload
DynamicNode.Ext.Objects Namespace


GetDescriptor Method (FieldInfo)

[image]

DynamicNodes API
ClrTools..::..GetDescriptor Method (FieldInfo)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Feldes. Das Feld kann mittels FindField(String) und der Zeichenkette wiedergefunden werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetDescriptor(
    FieldInfo fieldInfo
)
Visual Basic
Public Shared Function GetDescriptor ( _
    fieldInfo As FieldInfo _
) As String
F#
static member GetDescriptor :
        fieldInfo:FieldInfo -> string

Parameters

fieldInfo
Type: System.Reflection..::..FieldInfo
Ein Feld.

Return Value

Eine eindeutiger Beschreibung für ein Feld.

See Also

ClrTools Class
GetDescriptor Overload
DynamicNode.Ext.Objects Namespace


GetDescriptor Method (MethodInfo)

[image]

DynamicNodes API
ClrTools..::..GetDescriptor Method (MethodInfo)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eine Methode. Die Methode kann mittels FindMethod(String) und der Zeichenkette wiedergefunden werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetDescriptor(
    MethodInfo methodInfo
)
Visual Basic
Public Shared Function GetDescriptor ( _
    methodInfo As MethodInfo _
) As String
F#
static member GetDescriptor :
        methodInfo:MethodInfo -> string

Parameters

methodInfo
Type: System.Reflection..::..MethodInfo
Eine Methode.

Return Value

Eine eindeutiger Beschreibung für eine Methode.

See Also

ClrTools Class
GetDescriptor Overload
DynamicNode.Ext.Objects Namespace


GetDescriptor Method (PropertyInfo)

[image]

DynamicNodes API
ClrTools..::..GetDescriptor Method (PropertyInfo)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung einer Eigenschaft. Die Eigenschaft kann mittels FindProperty(String) und der Zeichenkette wiedergefunden werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetDescriptor(
    PropertyInfo propertyInfo
)
Visual Basic
Public Shared Function GetDescriptor ( _
    propertyInfo As PropertyInfo _
) As String
F#
static member GetDescriptor :
        propertyInfo:PropertyInfo -> string

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo
Eine Eigenschaft.

Return Value

Eine eindeutiger Beschreibung für eine Eigenschaft.

See Also

ClrTools Class
GetDescriptor Overload
DynamicNode.Ext.Objects Namespace


GetDescriptor Method (Type)

[image]

DynamicNodes API
ClrTools..::..GetDescriptor Method (Type)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine Mehrzeilige Zeichenkette zur eindeutigen Identifizierung eines Typen. Der Type kann mittels FindType(String) und der Zeichenkette wiedergefunden werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetDescriptor(
    Type type
)
Visual Basic
Public Shared Function GetDescriptor ( _
    type As Type _
) As String
F#
static member GetDescriptor :
        type:Type -> string

Parameters

type
Type: System..::..Type
Ein Type.

Return Value

Eine eindeutiger Beschreibung für einen Type.

See Also

ClrTools Class
GetDescriptor Overload
DynamicNode.Ext.Objects Namespace


GetEventCaption Method

[image]

DynamicNodes API
ClrTools..::..GetEventCaption Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine formatierte Beschriftung für ein Ereignis zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetEventCaption(
    EventInfo eventInfo,
    bool nameOnly
)
Visual Basic
Public Shared Function GetEventCaption ( _
    eventInfo As EventInfo, _
    nameOnly As Boolean _
) As String
F#
static member GetEventCaption :
        eventInfo:EventInfo *
        nameOnly:bool -> string

Parameters

eventInfo
Type: System.Reflection..::..EventInfo
Ein Ereignis.
nameOnly
Type: System..::..Boolean
Gibt nur den Namen des Ereignisses aus, falls true übergeben wird.

Return Value

Eine Beschriftung.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetEvents Method

[image] [image]

DynamicNodes API
ClrTools..::..GetEvents Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
GetEvents(Type) | Gibt eine Aufzählung mit allen geeigneten Ereignissen eines Typen zurück.
GetEvents(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Ereignissen eines Typen zurück.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


GetEvents Method (Type)

[image]

DynamicNodes API
ClrTools..::..GetEvents Method (Type)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Ereignissen eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<EventInfo> GetEvents(
    Type t
)
Visual Basic
Public Shared Function GetEvents ( _
    t As Type _
) As IEnumerable(Of EventInfo)
F#
static member GetEvents :
        t:Type -> IEnumerable<EventInfo>

Parameters

t
Type: System..::..Type
Ein Type.

Return Value

Eine Aufzählung mit geeigneten Ereignissen.

See Also

ClrTools Class
GetEvents Overload
DynamicNode.Ext.Objects Namespace


GetEvents Method (Type, Boolean)

[image]

DynamicNodes API
ClrTools..::..GetEvents Method (Type, Boolean)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Ereignissen eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<EventInfo> GetEvents(
    Type t,
    bool mustBeStatic
)
Visual Basic
Public Shared Function GetEvents ( _
    t As Type, _
    mustBeStatic As Boolean _
) As IEnumerable(Of EventInfo)
F#
static member GetEvents :
        t:Type *
        mustBeStatic:bool -> IEnumerable<EventInfo>

Parameters

t
Type: System..::..Type
Ein Type.
mustBeStatic
Type: System..::..Boolean
Falls true übergeben wird, muss das Ereignis statisch sein, sonst muss es dynamisch sein.

Return Value

Eine Aufzählung mit geeigneten Ereignissen.

See Also

ClrTools Class
GetEvents Overload
DynamicNode.Ext.Objects Namespace


GetFieldCaption Method

[image]

DynamicNodes API
ClrTools..::..GetFieldCaption Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine formatierte Beschriftung für ein Feld zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetFieldCaption(
    FieldInfo field
)
Visual Basic
Public Shared Function GetFieldCaption ( _
    field As FieldInfo _
) As String
F#
static member GetFieldCaption :
        field:FieldInfo -> string

Parameters

field
Type: System.Reflection..::..FieldInfo
Ein Feld.

Return Value

Eine Beschriftung.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetFields Method

[image] [image]

DynamicNodes API
ClrTools..::..GetFields Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
GetFields(Type) | Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.
GetFields(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.
GetFields(Type, Boolean, Boolean) | Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


GetFields Method (Type)

[image]

DynamicNodes API
ClrTools..::..GetFields Method (Type)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<FieldInfo> GetFields(
    Type t
)
Visual Basic
Public Shared Function GetFields ( _
    t As Type _
) As IEnumerable(Of FieldInfo)
F#
static member GetFields :
        t:Type -> IEnumerable<FieldInfo>

Parameters

t
Type: System..::..Type
Ein Type.

Return Value

Eine Aufzählung mit geeigneten Feldern.

See Also

ClrTools Class
GetFields Overload
DynamicNode.Ext.Objects Namespace


GetFields Method (Type, Boolean)

[image]

DynamicNodes API
ClrTools..::..GetFields Method (Type, Boolean)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<FieldInfo> GetFields(
    Type t,
    bool mustBeStatic
)
Visual Basic
Public Shared Function GetFields ( _
    t As Type, _
    mustBeStatic As Boolean _
) As IEnumerable(Of FieldInfo)
F#
static member GetFields :
        t:Type *
        mustBeStatic:bool -> IEnumerable<FieldInfo>

Parameters

t
Type: System..::..Type
Ein Type.
mustBeStatic
Type: System..::..Boolean
Die Felder müssen statisch sein, falls true übergeben wird, sonst müssen sie dynamisch sein.

Return Value

Eine Aufzählung mit geeigneten Feldern.

See Also

ClrTools Class
GetFields Overload
DynamicNode.Ext.Objects Namespace


GetFields Method (Type, Boolean, Boolean)

[image]

DynamicNodes API
ClrTools..::..GetFields Method (Type, Boolean, Boolean)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Feldern eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<FieldInfo> GetFields(
    Type t,
    bool mustBeStatic,
    bool writeable
)
Visual Basic
Public Shared Function GetFields ( _
    t As Type, _
    mustBeStatic As Boolean, _
    writeable As Boolean _
) As IEnumerable(Of FieldInfo)
F#
static member GetFields :
        t:Type *
        mustBeStatic:bool *
        writeable:bool -> IEnumerable<FieldInfo>

Parameters

t
Type: System..::..Type
Ein Type.
mustBeStatic
Type: System..::..Boolean
Die Felder müssen statisch sein, falls true übergeben wird, sonst müssen sie dynamisch sein.
writeable
Type: System..::..Boolean
Die Felder müssen beschreibbar sein, falls true übergeben wird, sonst müssen sie nur lesbar sein.

Return Value

Eine Aufzählung mit geeigneten Feldern.

See Also

ClrTools Class
GetFields Overload
DynamicNode.Ext.Objects Namespace


GetMember Method

[image]

DynamicNodes API
ClrTools..::..GetMember Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle geeigneten dynamischen Member eines Typs zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<MemberInfo> GetMember(
    Type t
)
Visual Basic
Public Shared Function GetMember ( _
    t As Type _
) As IEnumerable(Of MemberInfo)
F#
static member GetMember :
        t:Type -> IEnumerable<MemberInfo>

Parameters

t
Type: System..::..Type
Der Type, dessen Member zurückgegeben werden sollen.

Return Value

Eine Aufzählung mit allen geeignet dynamischen Membern des übergebenen Types.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetMemberCaption Method

[image]

DynamicNodes API
ClrTools..::..GetMemberCaption Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Beschriftung für einen Member zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetMemberCaption(
    MemberInfo mi,
    bool nameOnly
)
Visual Basic
Public Shared Function GetMemberCaption ( _
    mi As MemberInfo, _
    nameOnly As Boolean _
) As String
F#
static member GetMemberCaption :
        mi:MemberInfo *
        nameOnly:bool -> string

Parameters

mi
Type: System.Reflection..::..MemberInfo
Der Member der beschriftet werden soll.
nameOnly
Type: System..::..Boolean
Gibt den Namen ohne Zusätze zurück, falls true übergeben wird.

Return Value

Eine Beschriftung.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetMethodCaption Method

[image]

DynamicNodes API
ClrTools..::..GetMethodCaption Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine formatierte Beschriftung für eine Methode zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetMethodCaption(
    MethodInfo method,
    bool nameOnly
)
Visual Basic
Public Shared Function GetMethodCaption ( _
    method As MethodInfo, _
    nameOnly As Boolean _
) As String
F#
static member GetMethodCaption :
        method:MethodInfo *
        nameOnly:bool -> string

Parameters

method
Type: System.Reflection..::..MethodInfo
Eine Methode.
nameOnly
Type: System..::..Boolean
Gibt den Namen ohne Zusätze zurück, falls true übergeben wird.

Return Value

Eine Beschriftung.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetMethods Method

[image] [image]

DynamicNodes API
ClrTools..::..GetMethods Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
GetMethods(Type) | Gibt eine Aufzählung mit allen geeigneten Methoden eines Typen zurück.
GetMethods(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Methoden eines Typen zurück.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


GetMethods Method (Type)

[image]

DynamicNodes API
ClrTools..::..GetMethods Method (Type)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Methoden eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<MethodInfo> GetMethods(
    Type t
)
Visual Basic
Public Shared Function GetMethods ( _
    t As Type _
) As IEnumerable(Of MethodInfo)
F#
static member GetMethods :
        t:Type -> IEnumerable<MethodInfo>

Parameters

t
Type: System..::..Type
Ein Type.

Return Value

Eine Aufzählung mit geeigneten Methoden.

See Also

ClrTools Class
GetMethods Overload
DynamicNode.Ext.Objects Namespace


GetMethods Method (Type, Boolean)

[image]

DynamicNodes API
ClrTools..::..GetMethods Method (Type, Boolean)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Methoden eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<MethodInfo> GetMethods(
    Type t,
    bool mustBeStatic
)
Visual Basic
Public Shared Function GetMethods ( _
    t As Type, _
    mustBeStatic As Boolean _
) As IEnumerable(Of MethodInfo)
F#
static member GetMethods :
        t:Type *
        mustBeStatic:bool -> IEnumerable<MethodInfo>

Parameters

t
Type: System..::..Type
Ein Type.
mustBeStatic
Type: System..::..Boolean
Die Methoden müssen statisch sein, falls true übergeben wird, sonst müssen sie dynamisch sein.

Return Value

Eine Aufzählung mit geeigneten Methoden.

See Also

ClrTools Class
GetMethods Overload
DynamicNode.Ext.Objects Namespace


GetNamespaceCaption Method

[image]

DynamicNodes API
ClrTools..::..GetNamespaceCaption Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine formatierte Beschriftung für einen Namensraum zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetNamespaceCaption(
    string ns
)
Visual Basic
Public Shared Function GetNamespaceCaption ( _
    ns As String _
) As String
F#
static member GetNamespaceCaption :
        ns:string -> string

Parameters

ns
Type: System..::..String
Ein Namensraum als Zeichenkette.

Return Value

Eine Beschriftung.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetProperties Method

[image] [image]

DynamicNodes API
ClrTools..::..GetProperties Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
GetProperties(Type) | Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.
GetProperties(Type, Boolean) | Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.
GetProperties(Type, Boolean, Boolean) | Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


GetProperties Method (Type)

[image]

DynamicNodes API
ClrTools..::..GetProperties Method (Type)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<PropertyInfo> GetProperties(
    Type t
)
Visual Basic
Public Shared Function GetProperties ( _
    t As Type _
) As IEnumerable(Of PropertyInfo)
F#
static member GetProperties :
        t:Type -> IEnumerable<PropertyInfo>

Parameters

t
Type: System..::..Type
Ein Type.

Return Value

Eine Aufzählung mit geeigneten Eigenschaften.

See Also

ClrTools Class
GetProperties Overload
DynamicNode.Ext.Objects Namespace


GetProperties Method (Type, Boolean)

[image]

DynamicNodes API
ClrTools..::..GetProperties Method (Type, Boolean)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<PropertyInfo> GetProperties(
    Type t,
    bool mustBeStatic
)
Visual Basic
Public Shared Function GetProperties ( _
    t As Type, _
    mustBeStatic As Boolean _
) As IEnumerable(Of PropertyInfo)
F#
static member GetProperties :
        t:Type *
        mustBeStatic:bool -> IEnumerable<PropertyInfo>

Parameters

t
Type: System..::..Type
Ein Type.
mustBeStatic
Type: System..::..Boolean
Die Eigenschaften müssen statisch sein, falls true übergeben wird, sonst müssen sie dynamisch sein.

Return Value

Eine Aufzählung mit geeigneten Eigenschaften.

See Also

ClrTools Class
GetProperties Overload
DynamicNode.Ext.Objects Namespace


GetProperties Method (Type, Boolean, Boolean)

[image]

DynamicNodes API
ClrTools..::..GetProperties Method (Type, Boolean, Boolean)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Eigenschaften eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<PropertyInfo> GetProperties(
    Type t,
    bool mustBeStatic,
    bool writeable
)
Visual Basic
Public Shared Function GetProperties ( _
    t As Type, _
    mustBeStatic As Boolean, _
    writeable As Boolean _
) As IEnumerable(Of PropertyInfo)
F#
static member GetProperties :
        t:Type *
        mustBeStatic:bool *
        writeable:bool -> IEnumerable<PropertyInfo>

Parameters

t
Type: System..::..Type
Ein Type.
mustBeStatic
Type: System..::..Boolean
Die Eigenschaften müssen statisch sein, falls true übergeben wird, sonst müssen sie dynamisch sein.
writeable
Type: System..::..Boolean
Die Eigenschaften müssen einen geeigneten Setter besitzen, falls true übergeben wird, sonst müssen sie einen geeigneten Getter besitzen.

Return Value

Eine Aufzählung mit geeigneten Eigenschaften.

See Also

ClrTools Class
GetProperties Overload
DynamicNode.Ext.Objects Namespace


GetPropertyCaption Method

[image]

DynamicNodes API
ClrTools..::..GetPropertyCaption Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine formatierte Beschriftung für eine Eigenschaft zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetPropertyCaption(
    PropertyInfo property,
    bool nameOnly
)
Visual Basic
Public Shared Function GetPropertyCaption ( _
    property As PropertyInfo, _
    nameOnly As Boolean _
) As String
F#
static member GetPropertyCaption :
        property:PropertyInfo *
        nameOnly:bool -> string

Parameters

property
Type: System.Reflection..::..PropertyInfo
Eine Eigenschaft.
nameOnly
Type: System..::..Boolean
Gibt den Namen ohne Zusätze zurück, falls true übergeben wird.

Return Value

Eine Beschriftung.

See Also

ClrTools Class
DynamicNode.Ext.Objects Namespace


GetTypeCaption Method

[image] [image]

DynamicNodes API
ClrTools..::..GetTypeCaption Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
GetTypeCaption(Type) | Gibt eine formatierte Beschriftung für einen Type zurück.
GetTypeCaption(Type, Boolean) | Gibt eine formatierte Beschriftung für einen Type zurück.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


GetTypeCaption Method (Type)

[image]

DynamicNodes API
ClrTools..::..GetTypeCaption Method (Type)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine formatierte Beschriftung für einen Type zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetTypeCaption(
    Type t
)
Visual Basic
Public Shared Function GetTypeCaption ( _
    t As Type _
) As String
F#
static member GetTypeCaption :
        t:Type -> string

Parameters

t
Type: System..::..Type
Ein Type.

Return Value

Eine Beschriftung.

See Also

ClrTools Class
GetTypeCaption Overload
DynamicNode.Ext.Objects Namespace


GetTypeCaption Method (Type, Boolean)

[image]

DynamicNodes API
ClrTools..::..GetTypeCaption Method (Type, Boolean)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine formatierte Beschriftung für einen Type zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static string GetTypeCaption(
    Type t,
    bool withNestedPath
)
Visual Basic
Public Shared Function GetTypeCaption ( _
    t As Type, _
    withNestedPath As Boolean _
) As String
F#
static member GetTypeCaption :
        t:Type *
        withNestedPath:bool -> string

Parameters

t
Type: System..::..Type
Ein Type.
withNestedPath
Type: System..::..Boolean
Falls der übergebene Type ein verschachtelter Typ ist, gibt withNestedPath an, ob der Pfad der Verschachtelung mit zurückgegeben werden soll.

Return Value

Eine Beschriftung.

See Also

ClrTools Class
GetTypeCaption Overload
DynamicNode.Ext.Objects Namespace


GetTypes Method

[image] [image]

DynamicNodes API
ClrTools..::..GetTypes Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
GetTypes(Type) | Gibt eine Aufzählung mit allen geeigneten verschachtelten Typen eines Typen zurück.
GetTypes(Assembly, Boolean) | Gibt eine Aufzählung mit allen geeigneten Typen eines Assemblies zurück.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


GetTypes Method (Type)

[image]

DynamicNodes API
ClrTools..::..GetTypes Method (Type)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten verschachtelten Typen eines Typen zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<Type> GetTypes(
    Type t
)
Visual Basic
Public Shared Function GetTypes ( _
    t As Type _
) As IEnumerable(Of Type)
F#
static member GetTypes :
        t:Type -> IEnumerable<Type>

Parameters

t
Type: System..::..Type
Ein Type.

Return Value

Eine Aufzählung mit geeigneten Typen.

See Also

ClrTools Class
GetTypes Overload
DynamicNode.Ext.Objects Namespace


GetTypes Method (Assembly, Boolean)

[image]

DynamicNodes API
ClrTools..::..GetTypes Method (Assembly, Boolean)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen geeigneten Typen eines Assemblies zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static IEnumerable<Type> GetTypes(
    Assembly a,
    bool noNested
)
Visual Basic
Public Shared Function GetTypes ( _
    a As Assembly, _
    noNested As Boolean _
) As IEnumerable(Of Type)
F#
static member GetTypes :
        a:Assembly *
        noNested:bool -> IEnumerable<Type>

Parameters

a
Type: System.Reflection..::..Assembly
Ein Assembly.
noNested
Type: System..::..Boolean
Es werden keine verschachtelten Typen zurückgegeben, falls true übergeben wird.

Return Value

Eine Aufzählung mit geeigneten Typen.

See Also

ClrTools Class
GetTypes Overload
DynamicNode.Ext.Objects Namespace


ImageIndex Method

[image] [image]

DynamicNodes API
ClrTools..::..ImageIndex Method
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
ImageIndex(MemberInfo) | Gibt für einen MemberInfo den Bild-Index zurück, unter dem ein passendes Symbol in einer ImageList von CreateInteractionSymbolList()()()() zu finden ist.
ImageIndex(Type) | Gibt für einen Type den Bild-Index zurück, unter dem ein passendes Symbol in einer ImageList von CreateInteractionSymbolList()()()() zu finden ist.

See Also

ClrTools Class
ClrTools Members
DynamicNode.Ext.Objects Namespace


ImageIndex Method (MemberInfo)

[image]

DynamicNodes API
ClrTools..::..ImageIndex Method (MemberInfo)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für einen MemberInfo den Bild-Index zurück, unter dem ein passendes Symbol in einer ImageList von CreateInteractionSymbolList()()()() zu finden ist.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static int ImageIndex(
    MemberInfo member
)
Visual Basic
Public Shared Function ImageIndex ( _
    member As MemberInfo _
) As Integer
F#
static member ImageIndex :
        member:MemberInfo -> int

Parameters

member
Type: System.Reflection..::..MemberInfo
Ein Member.

Return Value

Der Index des ausgewählten Symbols.

See Also

ClrTools Class
ImageIndex Overload
DynamicNode.Ext.Objects Namespace


ImageIndex Method (Type)

[image]

DynamicNodes API
ClrTools..::..ImageIndex Method (Type)
ClrTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für einen Type den Bild-Index zurück, unter dem ein passendes Symbol in einer ImageList von CreateInteractionSymbolList()()()() zu finden ist.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static int ImageIndex(
    Type type
)
Visual Basic
Public Shared Function ImageIndex ( _
    type As Type _
) As Integer
F#
static member ImageIndex :
        type:Type -> int

Parameters

type
Type: System..::..Type
Ein Type für den ein Symbol gesucht wird.

Return Value

Der Index des ausgewählten Symbols.

See Also

ClrTools Class
ImageIndex Overload
DynamicNode.Ext.Objects Namespace


CodeCompilerResult Class

[image]

DynamicNodes API
CodeCompilerResult Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Ergebnis der Kompilierung einer Knotenoperation zur Laufzeit.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class CodeCompilerResult
Visual Basic
Public Class CodeCompilerResult
F#
type CodeCompilerResult =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Objects..::..CodeCompilerResult

See Also

CodeCompilerResult Members
DynamicNode.Ext.Objects Namespace


CodeCompilerResult Members

[image] [image]

DynamicNodes API
CodeCompilerResult Members
CodeCompilerResult Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CodeCompilerResult type exposes the following members.

Constructors

 | Name | Description
Public method | CodeCompilerResult(MethodInfo) | Initialisiert eine neue Instanz von CodeCompilerResult mit dem Kompilierergebnis in Form einer statischen Methode.
Public method | CodeCompilerResult(String) | Initialisiert eine neue Instanz von CodeCompilerResult mit einer Fehlermeldung.

Properties

 | Name | Description
Public property | ErrorMessage | Eine Fehlermeldung oder null, wenn die Kompilierung erfolgreich war.
Public property | IsSuccess | Gibt true zurück, wenn der Kompiliervorgang erfolgreich war, sonst false.
Public property | Method | Das Ergebnis der Kompilierung in Form einer statischen Methode oder null, wenn Fehler bei der Kompilierung aufgetreten sind.

See Also

CodeCompilerResult Class
DynamicNode.Ext.Objects Namespace


CodeCompilerResult Constructor

[image] [image]

DynamicNodes API
CodeCompilerResult Constructor
CodeCompilerResult Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | CodeCompilerResult(MethodInfo) | Initialisiert eine neue Instanz von CodeCompilerResult mit dem Kompilierergebnis in Form einer statischen Methode.
Public method | CodeCompilerResult(String) | Initialisiert eine neue Instanz von CodeCompilerResult mit einer Fehlermeldung.

See Also

CodeCompilerResult Class
CodeCompilerResult Members
DynamicNode.Ext.Objects Namespace


CodeCompilerResult Constructor (MethodInfo)

[image]

DynamicNodes API
CodeCompilerResult Constructor (MethodInfo)
CodeCompilerResult Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von CodeCompilerResult mit dem Kompilierergebnis in Form einer statischen Methode.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public CodeCompilerResult(
    MethodInfo method
)
Visual Basic
Public Sub New ( _
    method As MethodInfo _
)
F#
new :
        method:MethodInfo -> CodeCompilerResult

Parameters

method
Type: System.Reflection..::..MethodInfo
Eine statische Methode.

See Also

CodeCompilerResult Class
CodeCompilerResult Overload
DynamicNode.Ext.Objects Namespace


CodeCompilerResult Constructor (String)

[image]

DynamicNodes API
CodeCompilerResult Constructor (String)
CodeCompilerResult Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von CodeCompilerResult mit einer Fehlermeldung.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public CodeCompilerResult(
    string errorMessage
)
Visual Basic
Public Sub New ( _
    errorMessage As String _
)
F#
new :
        errorMessage:string -> CodeCompilerResult

Parameters

errorMessage
Type: System..::..String
Die Fehlermeldung.

See Also

CodeCompilerResult Class
CodeCompilerResult Overload
DynamicNode.Ext.Objects Namespace


CodeCompilerResult Properties

[image] [image]

DynamicNodes API
CodeCompilerResult Properties
CodeCompilerResult Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The CodeCompilerResult type exposes the following members.

Properties

 | Name | Description
Public property | ErrorMessage | Eine Fehlermeldung oder null, wenn die Kompilierung erfolgreich war.
Public property | IsSuccess | Gibt true zurück, wenn der Kompiliervorgang erfolgreich war, sonst false.
Public property | Method | Das Ergebnis der Kompilierung in Form einer statischen Methode oder null, wenn Fehler bei der Kompilierung aufgetreten sind.

See Also

CodeCompilerResult Class
DynamicNode.Ext.Objects Namespace


ErrorMessage Property

[image]

DynamicNodes API
CodeCompilerResult..::..ErrorMessage Property
CodeCompilerResult Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Fehlermeldung oder null, wenn die Kompilierung erfolgreich war.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public string ErrorMessage { get; private set; }
Visual Basic
Public Property ErrorMessage As String
    Get
    Private Set
F#
member ErrorMessage : string with get, private set

See Also

CodeCompilerResult Class
DynamicNode.Ext.Objects Namespace


IsSuccess Property

[image]

DynamicNodes API
CodeCompilerResult..::..IsSuccess Property
CodeCompilerResult Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt true zurück, wenn der Kompiliervorgang erfolgreich war, sonst false.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public bool IsSuccess { get; }
Visual Basic
Public ReadOnly Property IsSuccess As Boolean
    Get
F#
member IsSuccess : bool

See Also

CodeCompilerResult Class
DynamicNode.Ext.Objects Namespace


Method Property

[image]

DynamicNodes API
CodeCompilerResult..::..Method Property
CodeCompilerResult Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Ergebnis der Kompilierung in Form einer statischen Methode oder null, wenn Fehler bei der Kompilierung aufgetreten sind.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public MethodInfo Method { get; private set; }
Visual Basic
Public Property Method As MethodInfo
    Get
    Private Set
F#
member Method : MethodInfo with get, private set

See Also

CodeCompilerResult Class
DynamicNode.Ext.Objects Namespace


CodeLanguage Enumeration

[image]

DynamicNodes API
CodeLanguage Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Aufzählung mit Programmiersprachen, die durch den Code-Editor mit Syntax-Highlighting unterstützt werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public enum CodeLanguage
Visual Basic
Public Enumeration CodeLanguage
F#
type CodeLanguage

Members

Member name | Description
CSharp |
VBNet |
JScript |
FSharp |
Unknown |

See Also

DynamicNode.Ext.Objects Namespace


ConstructorSelector Class

[image]

DynamicNodes API
ConstructorSelector Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Steuerelement zur Auswahl eines CLR-Konstruktors.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class ConstructorSelector : UserControl
Visual Basic
Public Class ConstructorSelector _
    Inherits UserControl
F#
type ConstructorSelector =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Objects..::..ConstructorSelector

See Also

ConstructorSelector Members
DynamicNode.Ext.Objects Namespace


ConstructorSelector Members

[image] [image]

DynamicNodes API
ConstructorSelector Members
ConstructorSelector Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ConstructorSelector type exposes the following members.

Constructors

 | Name | Description
Public method | ConstructorSelector | Initialisiert eine neue Instanz von ConstructorSelector.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnConstructorSelected | Wird aufgerufen, wenn ein neuer Konstruktor ausgewählt wurde. Löst das Ereignis ConstructorSelected aus.

Properties

 | Name | Description
Public property | Constructor | Gibt den aktuell ausgewählten Konstruktor zurück, oder legt ihn fest.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

Events

 | Name | Description
Public event | ConstructorSelected | Wird ausgelöst, wenn ein neuer Konstruktor ausgewählt wurde.

See Also

ConstructorSelector Class
DynamicNode.Ext.Objects Namespace


ConstructorSelector Constructor

[image]

DynamicNodes API
ConstructorSelector Constructor
ConstructorSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ConstructorSelector.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public ConstructorSelector()
Visual Basic
Public Sub New
F#
new : unit -> ConstructorSelector

See Also

ConstructorSelector Class
DynamicNode.Ext.Objects Namespace


ConstructorSelector Methods

[image] [image]

DynamicNodes API
ConstructorSelector Methods
ConstructorSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ConstructorSelector type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnConstructorSelected | Wird aufgerufen, wenn ein neuer Konstruktor ausgewählt wurde. Löst das Ereignis ConstructorSelected aus.

See Also

ConstructorSelector Class
DynamicNode.Ext.Objects Namespace


Dispose Method

[image]

DynamicNodes API
ConstructorSelector..::..Dispose Method
ConstructorSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

ConstructorSelector Class
DynamicNode.Ext.Objects Namespace


OnConstructorSelected Method

[image]

DynamicNodes API
ConstructorSelector..::..OnConstructorSelected Method
ConstructorSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein neuer Konstruktor ausgewählt wurde. Löst das Ereignis ConstructorSelected aus.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected void OnConstructorSelected()
Visual Basic
Protected Sub OnConstructorSelected
F#
member OnConstructorSelected : unit -> unit

See Also

ConstructorSelector Class
DynamicNode.Ext.Objects Namespace


ConstructorSelector Properties

[image] [image]

DynamicNodes API
ConstructorSelector Properties
ConstructorSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ConstructorSelector type exposes the following members.

Properties

 | Name | Description
Public property | Constructor | Gibt den aktuell ausgewählten Konstruktor zurück, oder legt ihn fest.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

See Also

ConstructorSelector Class
DynamicNode.Ext.Objects Namespace


Constructor Property

[image]

DynamicNodes API
ConstructorSelector..::..Constructor Property
ConstructorSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuell ausgewählten Konstruktor zurück, oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public ConstructorInfo Constructor { get; set; }
Visual Basic
Public Property Constructor As ConstructorInfo
    Get
    Set
F#
member Constructor : ConstructorInfo with get, set

Field Value

Der ausgewählte Konstruktor.

See Also

ConstructorSelector Class
DynamicNode.Ext.Objects Namespace


Type Property

[image]

DynamicNodes API
ConstructorSelector..::..Type Property
ConstructorSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Type Type { get; set; }
Visual Basic
Public Property Type As Type
    Get
    Set
F#
member Type : Type with get, set

Field Value

Der ausgewählte Type.

See Also

ConstructorSelector Class
DynamicNode.Ext.Objects Namespace


ConstructorSelector Events

[image] [image]

DynamicNodes API
ConstructorSelector Events
ConstructorSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ConstructorSelector type exposes the following members.

Events

 | Name | Description
Public event | ConstructorSelected | Wird ausgelöst, wenn ein neuer Konstruktor ausgewählt wurde.

See Also

ConstructorSelector Class
DynamicNode.Ext.Objects Namespace


ConstructorSelected Event

[image]

DynamicNodes API
ConstructorSelector..::..ConstructorSelected Event
ConstructorSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein neuer Konstruktor ausgewählt wurde.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public event EventHandler ConstructorSelected
Visual Basic
Public Event ConstructorSelected As EventHandler
F#
member ConstructorSelected : IEvent<EventHandler,
    EventArgs>

See Also

ConstructorSelector Class
DynamicNode.Ext.Objects Namespace


EventSelector Class

[image]

DynamicNodes API
EventSelector Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Steuerelement zur Auswahl eines CLR-Ereignisses.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class EventSelector : UserControl
Visual Basic
Public Class EventSelector _
    Inherits UserControl
F#
type EventSelector =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Objects..::..EventSelector

See Also

EventSelector Members
DynamicNode.Ext.Objects Namespace


EventSelector Members

[image] [image]

DynamicNodes API
EventSelector Members
EventSelector Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EventSelector type exposes the following members.

Constructors

 | Name | Description
Public method | EventSelector | Initialisiert eine neue Instanz von EventSelector.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnEventSelected | Wird aufgerufen, wenn ein neues Ereignis ausgewählt wurde. Löst das Ereignis EventSelected aus.

Properties

 | Name | Description
Public property | Event | Gibt das aktuell ausgewählte Ereignis zurück, oder legt es fest.
Public property | ShowStaticEvents | Gibt einen Wert zurück oder legt ihn fest der angibt, ob statische oder dynamische Ereignisse zur Auswahl stehen sollen.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

Events

 | Name | Description
Public event | EventSelected | Wird ausgelöst, wenn ein neues Ereignis ausgewählt wurde.

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


EventSelector Constructor

[image]

DynamicNodes API
EventSelector Constructor
EventSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von EventSelector.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public EventSelector()
Visual Basic
Public Sub New
F#
new : unit -> EventSelector

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


EventSelector Methods

[image] [image]

DynamicNodes API
EventSelector Methods
EventSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EventSelector type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnEventSelected | Wird aufgerufen, wenn ein neues Ereignis ausgewählt wurde. Löst das Ereignis EventSelected aus.

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


Dispose Method

[image]

DynamicNodes API
EventSelector..::..Dispose Method
EventSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


OnEventSelected Method

[image]

DynamicNodes API
EventSelector..::..OnEventSelected Method
EventSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein neues Ereignis ausgewählt wurde. Löst das Ereignis EventSelected aus.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected void OnEventSelected()
Visual Basic
Protected Sub OnEventSelected
F#
member OnEventSelected : unit -> unit

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


EventSelector Properties

[image] [image]

DynamicNodes API
EventSelector Properties
EventSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EventSelector type exposes the following members.

Properties

 | Name | Description
Public property | Event | Gibt das aktuell ausgewählte Ereignis zurück, oder legt es fest.
Public property | ShowStaticEvents | Gibt einen Wert zurück oder legt ihn fest der angibt, ob statische oder dynamische Ereignisse zur Auswahl stehen sollen.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


Event Property

[image]

DynamicNodes API
EventSelector..::..Event Property
EventSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das aktuell ausgewählte Ereignis zurück, oder legt es fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public EventInfo Event { get; set; }
Visual Basic
Public Property Event As EventInfo
    Get
    Set
F#
member Event : EventInfo with get, set

Field Value

Das ausgewählte Ereignis.

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


ShowStaticEvents Property

[image]

DynamicNodes API
EventSelector..::..ShowStaticEvents Property
EventSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest der angibt, ob statische oder dynamische Ereignisse zur Auswahl stehen sollen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public bool ShowStaticEvents { get; set; }
Visual Basic
Public Property ShowStaticEvents As Boolean
    Get
    Set
F#
member ShowStaticEvents : bool with get, set

Field Value

true wenn statische Ereignisse zur Auswahl stehen sollen, sonst false.

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


Type Property

[image]

DynamicNodes API
EventSelector..::..Type Property
EventSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Type Type { get; set; }
Visual Basic
Public Property Type As Type
    Get
    Set
F#
member Type : Type with get, set

Field Value

Der ausgewählte Type.

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


EventSelector Events

[image] [image]

DynamicNodes API
EventSelector Events
EventSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EventSelector type exposes the following members.

Events

 | Name | Description
Public event | EventSelected | Wird ausgelöst, wenn ein neues Ereignis ausgewählt wurde.

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


EventSelected Event

[image]

DynamicNodes API
EventSelector..::..EventSelected Event
EventSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein neues Ereignis ausgewählt wurde.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public event EventHandler EventSelected
Visual Basic
Public Event EventSelected As EventHandler
F#
member EventSelected : IEvent<EventHandler,
    EventArgs>

See Also

EventSelector Class
DynamicNode.Ext.Objects Namespace


FieldSelector Class

[image]

DynamicNodes API
FieldSelector Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Steuerelement zur Auswahl eines CLR-Feldes.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class FieldSelector : UserControl
Visual Basic
Public Class FieldSelector _
    Inherits UserControl
F#
type FieldSelector =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Objects..::..FieldSelector

See Also

FieldSelector Members
DynamicNode.Ext.Objects Namespace


FieldSelector Members

[image] [image]

DynamicNodes API
FieldSelector Members
FieldSelector Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The FieldSelector type exposes the following members.

Constructors

 | Name | Description
Public method | FieldSelector | Initialisiert eine neue Instanz von FieldSelector.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnFieldSelected | Wird aufgerufen, wenn ein neues Feld ausgewählt wurde. Löst das Ereignis FieldSelected aus.

Properties

 | Name | Description
Public property | Field | Gibt das aktuell ausgewählte Feld zurück, oder legt es fest.
Public property | MustBeStatic | Gibt einen Wert zurück oder legt ihn fest, der angibt, ob statische oder dynamische Felder zur Auswahl stehen sollen.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.
Public property | Writeable | Gibt einen Wert zurück oder legt ihn fest, der angibt, ob lesbare oder schreibbare Felder zur Auswahl stehen sollen.

Events

 | Name | Description
Public event | FieldSelected | Wird ausgelöst, wenn ein neues Feld ausgewählt wurde.

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


FieldSelector Constructor

[image]

DynamicNodes API
FieldSelector Constructor
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von FieldSelector.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public FieldSelector()
Visual Basic
Public Sub New
F#
new : unit -> FieldSelector

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


FieldSelector Methods

[image] [image]

DynamicNodes API
FieldSelector Methods
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The FieldSelector type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnFieldSelected | Wird aufgerufen, wenn ein neues Feld ausgewählt wurde. Löst das Ereignis FieldSelected aus.

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


Dispose Method

[image]

DynamicNodes API
FieldSelector..::..Dispose Method
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


OnFieldSelected Method

[image]

DynamicNodes API
FieldSelector..::..OnFieldSelected Method
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein neues Feld ausgewählt wurde. Löst das Ereignis FieldSelected aus.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected void OnFieldSelected()
Visual Basic
Protected Sub OnFieldSelected
F#
member OnFieldSelected : unit -> unit

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


FieldSelector Properties

[image] [image]

DynamicNodes API
FieldSelector Properties
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The FieldSelector type exposes the following members.

Properties

 | Name | Description
Public property | Field | Gibt das aktuell ausgewählte Feld zurück, oder legt es fest.
Public property | MustBeStatic | Gibt einen Wert zurück oder legt ihn fest, der angibt, ob statische oder dynamische Felder zur Auswahl stehen sollen.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.
Public property | Writeable | Gibt einen Wert zurück oder legt ihn fest, der angibt, ob lesbare oder schreibbare Felder zur Auswahl stehen sollen.

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


Field Property

[image]

DynamicNodes API
FieldSelector..::..Field Property
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das aktuell ausgewählte Feld zurück, oder legt es fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public FieldInfo Field { get; set; }
Visual Basic
Public Property Field As FieldInfo
    Get
    Set
F#
member Field : FieldInfo with get, set

Field Value

Das ausgewählte Feld.

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


MustBeStatic Property

[image]

DynamicNodes API
FieldSelector..::..MustBeStatic Property
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt, ob statische oder dynamische Felder zur Auswahl stehen sollen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public bool MustBeStatic { get; set; }
Visual Basic
Public Property MustBeStatic As Boolean
    Get
    Set
F#
member MustBeStatic : bool with get, set

Field Value

true wenn statische Felder zur Auswahl stehen sollen, sonst false.

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


Type Property

[image]

DynamicNodes API
FieldSelector..::..Type Property
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Type Type { get; set; }
Visual Basic
Public Property Type As Type
    Get
    Set
F#
member Type : Type with get, set

Field Value

Der ausgewählte Type.

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


Writeable Property

[image]

DynamicNodes API
FieldSelector..::..Writeable Property
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt, ob lesbare oder schreibbare Felder zur Auswahl stehen sollen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public bool Writeable { get; set; }
Visual Basic
Public Property Writeable As Boolean
    Get
    Set
F#
member Writeable : bool with get, set

Field Value

true wenn schreibbare Felder zur Auswahl stehen sollen, sonst false.

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


FieldSelector Events

[image] [image]

DynamicNodes API
FieldSelector Events
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The FieldSelector type exposes the following members.

Events

 | Name | Description
Public event | FieldSelected | Wird ausgelöst, wenn ein neues Feld ausgewählt wurde.

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


FieldSelected Event

[image]

DynamicNodes API
FieldSelector..::..FieldSelected Event
FieldSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein neues Feld ausgewählt wurde.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public event EventHandler FieldSelected
Visual Basic
Public Event FieldSelected As EventHandler
F#
member FieldSelected : IEvent<EventHandler,
    EventArgs>

See Also

FieldSelector Class
DynamicNode.Ext.Objects Namespace


Interactions Enumeration

[image]

DynamicNodes API
Interactions Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Auflistung von Interaktionen mit dem CLR-Objekt-Modell.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public enum Interactions
Visual Basic
Public Enumeration Interactions
F#
type Interactions

Members

Member name | Description
Constructor |
FieldRead |
FieldWrite |
PropertyGet |
PropertySet |
MethodCall |
Event |
StaticFieldRead |
StaticFieldWrite |
StaticPropertyGet |
StaticPropertySet |
StaticMethodCall |
StaticEvent |

See Also

DynamicNode.Ext.Objects Namespace


MemberDragEventArgs Class

[image]

DynamicNodes API
MemberDragEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt die Daten für das Ereignis MemberDrag bereit.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class MemberDragEventArgs : EventArgs
Visual Basic
Public Class MemberDragEventArgs _
    Inherits EventArgs
F#
type MemberDragEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Ext.Objects..::..MemberDragEventArgs

See Also

MemberDragEventArgs Members
DynamicNode.Ext.Objects Namespace


MemberDragEventArgs Members

[image] [image]

DynamicNodes API
MemberDragEventArgs Members
MemberDragEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MemberDragEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MemberDragEventArgs | Initialisiert eine neue Instanz von MemberDragEventArgs.

Properties

 | Name | Description
Public property | Control | Gibt das Steuerelement zurück, bei dem die Drag&Drop-Operation beginnt.
Public property | MemberInfo | Gibt den Member zurück, der aus dem Browser gezogen wurde.

See Also

MemberDragEventArgs Class
DynamicNode.Ext.Objects Namespace


MemberDragEventArgs Constructor

[image]

DynamicNodes API
MemberDragEventArgs Constructor
MemberDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von MemberDragEventArgs.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public MemberDragEventArgs(
    MemberInfo memberInfo,
    Control control
)
Visual Basic
Public Sub New ( _
    memberInfo As MemberInfo, _
    control As Control _
)
F#
new :
        memberInfo:MemberInfo *
        control:Control -> MemberDragEventArgs

Parameters

memberInfo
Type: System.Reflection..::..MemberInfo
Der Member der aus dem Browser gezogen wurde.
control
Type: System.Windows.Forms..::..Control
Das Steuerelement bei dem die Drag&Drop-Operation beginnt.

See Also

MemberDragEventArgs Class
DynamicNode.Ext.Objects Namespace


MemberDragEventArgs Properties

[image] [image]

DynamicNodes API
MemberDragEventArgs Properties
MemberDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MemberDragEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Control | Gibt das Steuerelement zurück, bei dem die Drag&Drop-Operation beginnt.
Public property | MemberInfo | Gibt den Member zurück, der aus dem Browser gezogen wurde.

See Also

MemberDragEventArgs Class
DynamicNode.Ext.Objects Namespace


Control Property

[image]

DynamicNodes API
MemberDragEventArgs..::..Control Property
MemberDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Steuerelement zurück, bei dem die Drag&Drop-Operation beginnt.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Control Control { get; private set; }
Visual Basic
Public Property Control As Control
    Get
    Private Set
F#
member Control : Control with get, private set

Field Value

Das Steuerelement bei dem die Drag&Drop-Operation beginnt.

See Also

MemberDragEventArgs Class
DynamicNode.Ext.Objects Namespace


MemberInfo Property

[image]

DynamicNodes API
MemberDragEventArgs..::..MemberInfo Property
MemberDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Member zurück, der aus dem Browser gezogen wurde.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public MemberInfo MemberInfo { get; private set; }
Visual Basic
Public Property MemberInfo As MemberInfo
    Get
    Private Set
F#
member MemberInfo : MemberInfo with get, private set

Field Value

Der Member der aus dem Browser gezogen wurde.

See Also

MemberDragEventArgs Class
DynamicNode.Ext.Objects Namespace


MemberInfoNodeCreator Delegate

[image]

DynamicNodes API
MemberInfoNodeCreator Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Knotenerzeuger für CLR-Wrapperknoten die ein Typenmitglied kapseln.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public delegate INode MemberInfoNodeCreator(
    MemberInfo member
)
Visual Basic
Public Delegate Function MemberInfoNodeCreator ( _
    member As MemberInfo _
) As INode
F#
type MemberInfoNodeCreator =
    delegate of
        member:MemberInfo -> INode

Parameters

member
Type: System.Reflection..::..MemberInfo

See Also

DynamicNode.Ext.Objects Namespace


MethodSelector Class

[image]

DynamicNodes API
MethodSelector Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Steuerelement zur Auswahl einer CLR-Methode.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class MethodSelector : UserControl
Visual Basic
Public Class MethodSelector _
    Inherits UserControl
F#
type MethodSelector =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Objects..::..MethodSelector

See Also

MethodSelector Members
DynamicNode.Ext.Objects Namespace


MethodSelector Members

[image] [image]

DynamicNodes API
MethodSelector Members
MethodSelector Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MethodSelector type exposes the following members.

Constructors

 | Name | Description
Public method | MethodSelector | Initialisiert eine neue Instanz von MethodSelector.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnMethodSelected | Wird aufgerufen, wenn eine neue Methode ausgewählt wurde. Löst das Ereignis MethodSelected aus.

Properties

 | Name | Description
Public property | Method | Gibt die aktuell ausgewählte Methode zurück, oder legt sie fest.
Public property | MustBeStatic | Gibt einen Wert zurück oder legt ihn fest, der angibt, ob statische oder dynamische Methoden zur Auswahl stehen sollen.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

Events

 | Name | Description
Public event | MethodSelected | Wird ausgelöst, wenn eine neue Methode ausgewählt wurde.

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


MethodSelector Constructor

[image]

DynamicNodes API
MethodSelector Constructor
MethodSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von MethodSelector.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public MethodSelector()
Visual Basic
Public Sub New
F#
new : unit -> MethodSelector

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


MethodSelector Methods

[image] [image]

DynamicNodes API
MethodSelector Methods
MethodSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MethodSelector type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnMethodSelected | Wird aufgerufen, wenn eine neue Methode ausgewählt wurde. Löst das Ereignis MethodSelected aus.

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


Dispose Method

[image]

DynamicNodes API
MethodSelector..::..Dispose Method
MethodSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


OnMethodSelected Method

[image]

DynamicNodes API
MethodSelector..::..OnMethodSelected Method
MethodSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn eine neue Methode ausgewählt wurde. Löst das Ereignis MethodSelected aus.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected void OnMethodSelected()
Visual Basic
Protected Sub OnMethodSelected
F#
member OnMethodSelected : unit -> unit

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


MethodSelector Properties

[image] [image]

DynamicNodes API
MethodSelector Properties
MethodSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MethodSelector type exposes the following members.

Properties

 | Name | Description
Public property | Method | Gibt die aktuell ausgewählte Methode zurück, oder legt sie fest.
Public property | MustBeStatic | Gibt einen Wert zurück oder legt ihn fest, der angibt, ob statische oder dynamische Methoden zur Auswahl stehen sollen.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


Method Property

[image]

DynamicNodes API
MethodSelector..::..Method Property
MethodSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die aktuell ausgewählte Methode zurück, oder legt sie fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public MethodInfo Method { get; set; }
Visual Basic
Public Property Method As MethodInfo
    Get
    Set
F#
member Method : MethodInfo with get, set

Field Value

Die ausgewählte Methode.

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


MustBeStatic Property

[image]

DynamicNodes API
MethodSelector..::..MustBeStatic Property
MethodSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt, ob statische oder dynamische Methoden zur Auswahl stehen sollen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public bool MustBeStatic { get; set; }
Visual Basic
Public Property MustBeStatic As Boolean
    Get
    Set
F#
member MustBeStatic : bool with get, set

Field Value

true wenn statische Methoden zur Auswahl stehen sollen, sonst false.

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


Type Property

[image]

DynamicNodes API
MethodSelector..::..Type Property
MethodSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Type Type { get; set; }
Visual Basic
Public Property Type As Type
    Get
    Set
F#
member Type : Type with get, set

Field Value

Der ausgewählte Type.

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


MethodSelector Events

[image] [image]

DynamicNodes API
MethodSelector Events
MethodSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MethodSelector type exposes the following members.

Events

 | Name | Description
Public event | MethodSelected | Wird ausgelöst, wenn eine neue Methode ausgewählt wurde.

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


MethodSelected Event

[image]

DynamicNodes API
MethodSelector..::..MethodSelected Event
MethodSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine neue Methode ausgewählt wurde.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public event EventHandler MethodSelected
Visual Basic
Public Event MethodSelected As EventHandler
F#
member MethodSelected : IEvent<EventHandler,
    EventArgs>

See Also

MethodSelector Class
DynamicNode.Ext.Objects Namespace


NCode Class

[image]

DynamicNodes API
NCode Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Basisklasse für Knoten, deren Arbeitsmethode zur Laufzeit kompiliert wird.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public abstract class NCode : AbstractMethodBase
Visual Basic
Public MustInherit Class NCode _
    Inherits AbstractMethodBase
F#
[<AbstractClassAttribute>]
type NCode =
    class
        inherit AbstractMethodBase
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core..::..StreamNode
DynamicNode.Ext.Visual..::..VisualNode
DynamicNode.Ext.Objects..::..AbstractWrapper
DynamicNode.Ext.Objects..::..AbstractMethodBase
DynamicNode.Ext.Objects..::..NCode

See Also

NCode Members
DynamicNode.Ext.Objects Namespace


NCode Members

[image] [image]

DynamicNodes API
NCode Members
NCode Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NCode type exposes the following members.

Constructors

 | Name | Description
Protected method | NCode | Initializes a new instance of the NCode class

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | CheckMethodBase | Überprüft ob die übergebene Methode geeignet ist. Falls ddie Methode ungeeignet ist wird eine ArgumentException geworfen. (Overrides AbstractMethodBase..::..CheckMethodBase(MethodBase).)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Protected method | Compile | Wird aufgerufen, wenn
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | CreateDefaultCompilerParameters | Erzeugt die Standardparameter für einen Compileraufruf.
Protected method | CreateInMemoryAssemblyName | Erzeugt einen neuen Assembly-Namen mit einem zufälligem Anteil.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetInteractionSymbol1 | Gibt ein Bild für das erste der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren. (Inherited from AbstractMethodBase.)
Protected method | GetInteractionSymbol2 | Gibt ein Bild für das zweite der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren. (Inherited from AbstractMethodBase.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetMaxClientWidth | Gibt die maximale Breite des benutzerdefinierten Bereichs der Knotendarstellung zurück. Die Breite wird anhand der Darstellung von den zwei Symbolen und den drei Textzeilen ermittelt. (Inherited from AbstractWrapper.)
Protected method | GetTextLine1 | Gibt die erste von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben. (Overrides AbstractMethodBase..::..GetTextLine1()()()().)
Protected method | GetTextLine2 | Gibt die zweite von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben. (Overrides AbstractWrapper..::..GetTextLine2()()()().)
Protected method | Init | Initialisiert die aktuelle Instanz. Wird von den Konstruktoren aufgerufen. (Inherited from AbstractMethodBase.)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Overrides VisualNode..::..InitControlPanel(NodeControlPanelExtension).)
Protected method | InitPorts | Initialisiert oder aktualisiert die Anschlüsse nach Auswahl einer Methode. (Inherited from AbstractMethodBase.)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Inherited from AbstractWrapper.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from AbstractMethodBase.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from AbstractMethodBase.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Overrides StreamNode..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Overrides StreamNode..::..OnStore(IPropertyWriter).)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from AbstractWrapper.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Protected method | SetCodeSourceWithoutCompilation | Setzt den Quelltext ohne eine automatische Kompilierung.
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Protected method | UpdateVisualization | Aktualisiert die visuelle Darstellung des Knotens. (Inherited from AbstractWrapper.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from AbstractMethodBase.)

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | CodeLanguage | Gibt die Programmiersprache zurück, in der die Arbeitsmethode implementiert ist.
Public property | CodeLanguageCaption | Gibt den Namen der Programmiersprache zurück, in der die Arbeitsmethode implementiert ist.
Public property | CodeName | Gibt den Namen der Arbeitsmethode zurück oder legt ihn fest.
Public property | CodeSource | Gibt den Quelltext zurück oder legt ihn fest.
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected property | IsMethodStatic | Gibt einen Wert zurück, der angibt, ob die Methode statisch ist. (Overrides AbstractMethodBase..::..IsMethodStatic.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | MethodBase | Liest oder schreibt die gekapselte Methode. (Inherited from AbstractMethodBase.)
Protected property | MethodInfo | Gibt die Methodenbeschreibung der gekapselten Methode zurück, oder legt sie fest. Beim Festlegen der Methode werden die Anschlüsse des Knotens automatisch an die Methodensignatur angepasst.
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Protected property | ReturnOutPortId | Gibt die Port-ID für den Ausgang zurück, der Rückgabewerte des Methodenaufrufs weiterleiten soll. (Overrides AbstractMethodBase..::..ReturnOutPortId.)
Protected property | ReturnType | Gibt den Datentyp für den Ausgang zurück, der den Rückgabewert des Methodenaufrufs weiterleiten soll. (Overrides AbstractMethodBase..::..ReturnType.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


NCode Constructor

[image]

DynamicNodes API
NCode Constructor
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the NCode class

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected NCode()
Visual Basic
Protected Sub New
F#
new : unit -> NCode

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


NCode Methods

[image] [image]

DynamicNodes API
NCode Methods
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NCode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | CheckMethodBase | Überprüft ob die übergebene Methode geeignet ist. Falls ddie Methode ungeeignet ist wird eine ArgumentException geworfen. (Overrides AbstractMethodBase..::..CheckMethodBase(MethodBase).)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Protected method | Compile | Wird aufgerufen, wenn
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | CreateDefaultCompilerParameters | Erzeugt die Standardparameter für einen Compileraufruf.
Protected method | CreateInMemoryAssemblyName | Erzeugt einen neuen Assembly-Namen mit einem zufälligem Anteil.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetInteractionSymbol1 | Gibt ein Bild für das erste der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren. (Inherited from AbstractMethodBase.)
Protected method | GetInteractionSymbol2 | Gibt ein Bild für das zweite der zwei möglichen Symbole zurück, welches das gekapselte .NET-Element repräsentieren. (Inherited from AbstractMethodBase.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | GetMaxClientWidth | Gibt die maximale Breite des benutzerdefinierten Bereichs der Knotendarstellung zurück. Die Breite wird anhand der Darstellung von den zwei Symbolen und den drei Textzeilen ermittelt. (Inherited from AbstractWrapper.)
Protected method | GetTextLine1 | Gibt die erste von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben. (Overrides AbstractMethodBase..::..GetTextLine1()()()().)
Protected method | GetTextLine2 | Gibt die zweite von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben. (Overrides AbstractWrapper..::..GetTextLine2()()()().)
Protected method | Init | Initialisiert die aktuelle Instanz. Wird von den Konstruktoren aufgerufen. (Inherited from AbstractMethodBase.)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung. (Overrides VisualNode..::..InitControlPanel(NodeControlPanelExtension).)
Protected method | InitPorts | Initialisiert oder aktualisiert die Anschlüsse nach Auswahl einer Methode. (Inherited from AbstractMethodBase.)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung. (Inherited from AbstractWrapper.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from AbstractMethodBase.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from AbstractMethodBase.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Overrides StreamNode..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Overrides StreamNode..::..OnStore(IPropertyWriter).)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from AbstractWrapper.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde. (Inherited from VisualNode.)
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet. (Inherited from VisualNode.)
Protected method | SetCodeSourceWithoutCompilation | Setzt den Quelltext ohne eine automatische Kompilierung.
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Protected method | UpdateVisualization | Aktualisiert die visuelle Darstellung des Knotens. (Inherited from AbstractWrapper.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from AbstractMethodBase.)

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
NCode..::..BeforeUseExtension Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Inherited from VisualNode.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


CheckMethodBase Method

[image]

DynamicNodes API
NCode..::..CheckMethodBase Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft ob die übergebene Methode geeignet ist. Falls ddie Methode ungeeignet ist wird eine ArgumentException geworfen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void CheckMethodBase(
    MethodBase mI
)
Visual Basic
Protected Overrides Sub CheckMethodBase ( _
    mI As MethodBase _
)
F#
abstract CheckMethodBase :
        mI:MethodBase -> unit
override CheckMethodBase :
        mI:MethodBase -> unit

Parameters

mI
Type: System.Reflection..::..MethodBase
Die zu prüfende Methode.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


Compile Method

[image]

DynamicNodes API
NCode..::..Compile Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected abstract CodeCompilerResult Compile()
Visual Basic
Protected MustOverride Function Compile As CodeCompilerResult
F#
abstract Compile : unit -> CodeCompilerResult

Return Value

[Missing <returns> documentation for "M:DynamicNode.Ext.Objects.NCode.Compile"]

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


CreateDefaultCompilerParameters Method

[image]

DynamicNodes API
NCode..::..CreateDefaultCompilerParameters Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt die Standardparameter für einen Compileraufruf.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected CompilerParameters CreateDefaultCompilerParameters()
Visual Basic
Protected Function CreateDefaultCompilerParameters As CompilerParameters
F#
member CreateDefaultCompilerParameters : unit -> CompilerParameters

Return Value

Standardparameter für einen Compileraufruf.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


CreateInMemoryAssemblyName Method

[image]

DynamicNodes API
NCode..::..CreateInMemoryAssemblyName Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt einen neuen Assembly-Namen mit einem zufälligem Anteil.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected string CreateInMemoryAssemblyName()
Visual Basic
Protected Function CreateInMemoryAssemblyName As String
F#
member CreateInMemoryAssemblyName : unit -> string

Return Value

Einen Assembly-Namen.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


Duplicate Method

[image] [image]

DynamicNodes API
NCode..::..Duplicate Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


GetTextLine1 Method

[image]

DynamicNodes API
NCode..::..GetTextLine1 Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die erste von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override string GetTextLine1()
Visual Basic
Protected Overrides Function GetTextLine1 As String
F#
abstract GetTextLine1 : unit -> string
override GetTextLine1 : unit -> string

Return Value

Die erste von drei Textzeilen.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


GetTextLine2 Method

[image]

DynamicNodes API
NCode..::..GetTextLine2 Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die zweite von drei möglichen Textzeilen zurück, welche das gekapselte .NET-Element beschreiben.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override string GetTextLine2()
Visual Basic
Protected Overrides Function GetTextLine2 As String
F#
abstract GetTextLine2 : unit -> string
override GetTextLine2 : unit -> string

Return Value

Die zweite von drei Textzeilen.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


InitControlPanel Method

[image]

DynamicNodes API
NCode..::..InitControlPanel Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die Knoten-Steuerung.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void InitControlPanel(
    NodeControlPanelExtension ctrlPanelExt
)
Visual Basic
Protected Overrides Sub InitControlPanel ( _
    ctrlPanelExt As NodeControlPanelExtension _
)
F#
abstract InitControlPanel :
        ctrlPanelExt:NodeControlPanelExtension -> unit
override InitControlPanel :
        ctrlPanelExt:NodeControlPanelExtension -> unit

Parameters

ctrlPanelExt
Type: DynamicNode.Ext.Visual..::..NodeControlPanelExtension
Die Knoten-Steuerung.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


OnRestore Method

[image]

DynamicNodes API
NCode..::..OnRestore Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public override void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overrides Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Der IPropertyReader mit dem benutzerdefinierte Eigenschaften des Knotens gelesen werden können.

Implements

IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)

Remarks

Diese Methode wird beim Laden eines Graphen aufgerufen bevor die Verbindungen zwischen den Knoten wiederhergstellt werden.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


OnStore Method

[image]

DynamicNodes API
NCode..::..OnStore Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public override void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overrides Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Der IPropertyWriter mit dem benutzerdefinierte Eigenschaften des Knotens gespeichert werden können.

Implements

IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


PaintCustomArea Method

[image] [image]

DynamicNodes API
NCode..::..PaintCustomArea Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from AbstractWrapper.)
Protected method | PaintCustomArea(Graphics, RectangleF, IPaintProperties) | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen. (Inherited from VisualNode.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


RegisterStreamInPorts Method

[image] [image]

DynamicNodes API
NCode..::..RegisterStreamInPorts Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


SetCodeSourceWithoutCompilation Method

[image]

DynamicNodes API
NCode..::..SetCodeSourceWithoutCompilation Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Setzt den Quelltext ohne eine automatische Kompilierung.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected void SetCodeSourceWithoutCompilation(
    string codeSource
)
Visual Basic
Protected Sub SetCodeSourceWithoutCompilation ( _
    codeSource As String _
)
F#
member SetCodeSourceWithoutCompilation :
        codeSource:string -> unit

Parameters

codeSource
Type: System..::..String
Der neue Quelltext.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


TraceError Method

[image] [image]

DynamicNodes API
NCode..::..TraceError Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
NCode..::..TraceInfo Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
NCode..::..TraceVerbose Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
NCode..::..TraceVerboseData Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
NCode..::..TraceWarning Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


Work Method

[image] [image]

DynamicNodes API
NCode..::..Work Method
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from AbstractMethodBase.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


NCode Properties

[image] [image]

DynamicNodes API
NCode Properties
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NCode type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | CodeLanguage | Gibt die Programmiersprache zurück, in der die Arbeitsmethode implementiert ist.
Public property | CodeLanguageCaption | Gibt den Namen der Programmiersprache zurück, in der die Arbeitsmethode implementiert ist.
Public property | CodeName | Gibt den Namen der Arbeitsmethode zurück oder legt ihn fest.
Public property | CodeSource | Gibt den Quelltext zurück oder legt ihn fest.
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet. (Inherited from VisualNode.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück. (Inherited from VisualNode.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected property | IsMethodStatic | Gibt einen Wert zurück, der angibt, ob die Methode statisch ist. (Overrides AbstractMethodBase..::..IsMethodStatic.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | MethodBase | Liest oder schreibt die gekapselte Methode. (Inherited from AbstractMethodBase.)
Protected property | MethodInfo | Gibt die Methodenbeschreibung der gekapselten Methode zurück, oder legt sie fest. Beim Festlegen der Methode werden die Anschlüsse des Knotens automatisch an die Methodensignatur angepasst.
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück. (Inherited from VisualNode.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück. (Inherited from VisualNode.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Protected property | ReturnOutPortId | Gibt die Port-ID für den Ausgang zurück, der Rückgabewerte des Methodenaufrufs weiterleiten soll. (Overrides AbstractMethodBase..::..ReturnOutPortId.)
Protected property | ReturnType | Gibt den Datentyp für den Ausgang zurück, der den Rückgabewert des Methodenaufrufs weiterleiten soll. (Overrides AbstractMethodBase..::..ReturnType.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


CodeLanguage Property

[image]

DynamicNodes API
NCode..::..CodeLanguage Property
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Programmiersprache zurück, in der die Arbeitsmethode implementiert ist.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public virtual CodeLanguage CodeLanguage { get; }
Visual Basic
Public Overridable ReadOnly Property CodeLanguage As CodeLanguage
    Get
F#
abstract CodeLanguage : CodeLanguage
override CodeLanguage : CodeLanguage

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


CodeLanguageCaption Property

[image]

DynamicNodes API
NCode..::..CodeLanguageCaption Property
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen der Programmiersprache zurück, in der die Arbeitsmethode implementiert ist.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public abstract string CodeLanguageCaption { get; }
Visual Basic
Public MustOverride ReadOnly Property CodeLanguageCaption As String
    Get
F#
abstract CodeLanguageCaption : string

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


CodeName Property

[image]

DynamicNodes API
NCode..::..CodeName Property
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen der Arbeitsmethode zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public string CodeName { get; set; }
Visual Basic
Public Property CodeName As String
    Get
    Set
F#
member CodeName : string with get, set

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


CodeSource Property

[image]

DynamicNodes API
NCode..::..CodeSource Property
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Quelltext zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public string CodeSource { get; set; }
Visual Basic
Public Property CodeSource As String
    Get
    Set
F#
member CodeSource : string with get, set

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


IsMethodStatic Property

[image]

DynamicNodes API
NCode..::..IsMethodStatic Property
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Methode statisch ist.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override bool IsMethodStatic { get; }
Visual Basic
Protected Overrides ReadOnly Property IsMethodStatic As Boolean
    Get
F#
abstract IsMethodStatic : bool
override IsMethodStatic : bool

Field Value

true, wenn die Methode statisch ist, sonst false.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


Item Property

[image] [image]

DynamicNodes API
NCode..::..Item Property
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

NCode Class
NCode Members
DynamicNode.Ext.Objects Namespace


MethodInfo Property

[image]

DynamicNodes API
NCode..::..MethodInfo Property
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Methodenbeschreibung der gekapselten Methode zurück, oder legt sie fest. Beim Festlegen der Methode werden die Anschlüsse des Knotens automatisch an die Methodensignatur angepasst.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected MethodInfo MethodInfo { get; private set; }
Visual Basic
Protected Property MethodInfo As MethodInfo
    Get
    Private Set
F#
member MethodInfo : MethodInfo with get, private set

Field Value

Die gekapselte statische Methode.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


ReturnOutPortId Property

[image]

DynamicNodes API
NCode..::..ReturnOutPortId Property
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Port-ID für den Ausgang zurück, der Rückgabewerte des Methodenaufrufs weiterleiten soll.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override string ReturnOutPortId { get; }
Visual Basic
Protected Overrides ReadOnly Property ReturnOutPortId As String
    Get
F#
abstract ReturnOutPortId : string
override ReturnOutPortId : string

Field Value

Port-ID des Ausgangs für Rückgabewerte.

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


ReturnType Property

[image]

DynamicNodes API
NCode..::..ReturnType Property
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Datentyp für den Ausgang zurück, der den Rückgabewert des Methodenaufrufs weiterleiten soll.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override Type ReturnType { get; }
Visual Basic
Protected Overrides ReadOnly Property ReturnType As Type
    Get
F#
abstract ReturnType : Type
override ReturnType : Type

Field Value

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


NCode Events

[image] [image]

DynamicNodes API
NCode Events
NCode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NCode type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

NCode Class
DynamicNode.Ext.Objects Namespace


ObjectMemberNodeFactory Class

[image]

DynamicNodes API
ObjectMemberNodeFactory Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Knotenfactory für CLR-Wrapper Knoten.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class ObjectMemberNodeFactory : ICustomNodeFactory
Visual Basic
Public Class ObjectMemberNodeFactory _
    Implements ICustomNodeFactory
F#
type ObjectMemberNodeFactory =
    class
        interface ICustomNodeFactory
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Objects..::..ObjectMemberNodeFactory

See Also

ObjectMemberNodeFactory Members
DynamicNode.Ext.Objects Namespace


ObjectMemberNodeFactory Members

[image] [image]

DynamicNodes API
ObjectMemberNodeFactory Members
ObjectMemberNodeFactory Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ObjectMemberNodeFactory type exposes the following members.

Constructors

 | Name | Description
Public method | ObjectMemberNodeFactory | Initialisiert eine neue Instanz von ObjectMemberNodeFactory mit einem zu kapselnden Member.

Methods

 | Name | Description
Public method | CreateNode | Erzeugt einen neuen Knoten mit Hilfe einer Factory-Variation.
Public method | GetVariations | Gibt alle möglichen Variationen für diese Factory zurück. Die Factory muss mindestens eine Variation zur Verfügung stellen.
Protected method | OnCreated | Wird aufgerufen, wenn ein Knoten erstellt wurde. Löst das Ereignis NodeCreated aus.

Properties

 | Name | Description
Public property | Member | Gibt den zu kapselnden Member zurück.

Events

 | Name | Description
Public event | NodeCreated | Wird ausgelöst, wenn ein Knoten erstellt wurde.

See Also

ObjectMemberNodeFactory Class
DynamicNode.Ext.Objects Namespace


ObjectMemberNodeFactory Constructor

[image]

DynamicNodes API
ObjectMemberNodeFactory Constructor
ObjectMemberNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ObjectMemberNodeFactory mit einem zu kapselnden Member.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public ObjectMemberNodeFactory(
    MemberInfo member
)
Visual Basic
Public Sub New ( _
    member As MemberInfo _
)
F#
new :
        member:MemberInfo -> ObjectMemberNodeFactory

Parameters

member
Type: System.Reflection..::..MemberInfo
Der zu kapselnde Member.

See Also

ObjectMemberNodeFactory Class
DynamicNode.Ext.Objects Namespace


ObjectMemberNodeFactory Methods

[image] [image]

DynamicNodes API
ObjectMemberNodeFactory Methods
ObjectMemberNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ObjectMemberNodeFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateNode | Erzeugt einen neuen Knoten mit Hilfe einer Factory-Variation.
Public method | GetVariations | Gibt alle möglichen Variationen für diese Factory zurück. Die Factory muss mindestens eine Variation zur Verfügung stellen.
Protected method | OnCreated | Wird aufgerufen, wenn ein Knoten erstellt wurde. Löst das Ereignis NodeCreated aus.

See Also

ObjectMemberNodeFactory Class
DynamicNode.Ext.Objects Namespace


CreateNode Method

[image]

DynamicNodes API
ObjectMemberNodeFactory..::..CreateNode Method
ObjectMemberNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt einen neuen Knoten mit Hilfe einer Factory-Variation.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public INode CreateNode(
    CustomNodeFactoryVariation variation
)
Visual Basic
Public Function CreateNode ( _
    variation As CustomNodeFactoryVariation _
) As INode
F#
abstract CreateNode :
        variation:CustomNodeFactoryVariation -> INode
override CreateNode :
        variation:CustomNodeFactoryVariation -> INode

Parameters

variation
Type: DynamicNode.Core..::..CustomNodeFactoryVariation
Eine Factory-Variation.

Return Value

Der erzeugte Knoten.

Implements

ICustomNodeFactory..::..CreateNode(CustomNodeFactoryVariation)

See Also

ObjectMemberNodeFactory Class
DynamicNode.Ext.Objects Namespace


GetVariations Method

[image]

DynamicNodes API
ObjectMemberNodeFactory..::..GetVariations Method
ObjectMemberNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle möglichen Variationen für diese Factory zurück. Die Factory muss mindestens eine Variation zur Verfügung stellen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public IEnumerable<CustomNodeFactoryVariation> GetVariations()
Visual Basic
Public Function GetVariations As IEnumerable(Of CustomNodeFactoryVariation)
F#
abstract GetVariations : unit -> IEnumerable<CustomNodeFactoryVariation>
override GetVariations : unit -> IEnumerable<CustomNodeFactoryVariation>

Return Value

Eine Aufzählung mit allen Variationen der Factory.

Implements

ICustomNodeFactory..::..GetVariations()()()()

See Also

ObjectMemberNodeFactory Class
DynamicNode.Ext.Objects Namespace


OnCreated Method

[image]

DynamicNodes API
ObjectMemberNodeFactory..::..OnCreated Method
ObjectMemberNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Knoten erstellt wurde. Löst das Ereignis NodeCreated aus.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected virtual void OnCreated(
    INode node
)
Visual Basic
Protected Overridable Sub OnCreated ( _
    node As INode _
)
F#
abstract OnCreated :
        node:INode -> unit
override OnCreated :
        node:INode -> unit

Parameters

node
Type: DynamicNode.Core..::..INode
Der erstellte Knoten.

See Also

ObjectMemberNodeFactory Class
DynamicNode.Ext.Objects Namespace


ObjectMemberNodeFactory Properties

[image] [image]

DynamicNodes API
ObjectMemberNodeFactory Properties
ObjectMemberNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ObjectMemberNodeFactory type exposes the following members.

Properties

 | Name | Description
Public property | Member | Gibt den zu kapselnden Member zurück.

See Also

ObjectMemberNodeFactory Class
DynamicNode.Ext.Objects Namespace


Member Property

[image]

DynamicNodes API
ObjectMemberNodeFactory..::..Member Property
ObjectMemberNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den zu kapselnden Member zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public MemberInfo Member { get; private set; }
Visual Basic
Public Property Member As MemberInfo
    Get
    Private Set
F#
member Member : MemberInfo with get, private set

Field Value

Der zu kapselnde Member.

See Also

ObjectMemberNodeFactory Class
DynamicNode.Ext.Objects Namespace


ObjectMemberNodeFactory Events

[image] [image]

DynamicNodes API
ObjectMemberNodeFactory Events
ObjectMemberNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ObjectMemberNodeFactory type exposes the following members.

Events

 | Name | Description
Public event | NodeCreated | Wird ausgelöst, wenn ein Knoten erstellt wurde.

See Also

ObjectMemberNodeFactory Class
DynamicNode.Ext.Objects Namespace


NodeCreated Event

[image]

DynamicNodes API
ObjectMemberNodeFactory..::..NodeCreated Event
ObjectMemberNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Knoten erstellt wurde.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public event EventHandler<ObjectMemberNodeFactory..::..FactoryEventArgs> NodeCreated
Visual Basic
Public Event NodeCreated As EventHandler(Of ObjectMemberNodeFactory..::..FactoryEventArgs)
F#
member NodeCreated : IEvent<EventHandler<ObjectMemberNodeFactory..::..FactoryEventArgs>,
    ObjectMemberNodeFactory..::..FactoryEventArgs>

See Also

ObjectMemberNodeFactory Class
DynamicNode.Ext.Objects Namespace


ObjectMemberNodeFactory.FactoryEventArgs Class

[image]

DynamicNodes API
ObjectMemberNodeFactory..::..FactoryEventArgs Class
ObjectMemberNodeFactory Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
ENthält die Daten für das Ereignis NodeCreated.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class FactoryEventArgs : EventArgs
Visual Basic
Public Class FactoryEventArgs _
    Inherits EventArgs
F#
type FactoryEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Ext.Objects..::..ObjectMemberNodeFactory..::..FactoryEventArgs

See Also

ObjectMemberNodeFactory..::..FactoryEventArgs Members
DynamicNode.Ext.Objects Namespace


ObjectMemberNodeFactory.FactoryEventArgs Members

[image] [image]

DynamicNodes API
ObjectMemberNodeFactory..::..FactoryEventArgs Members
ObjectMemberNodeFactory..::..FactoryEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Die Knotenfactory für CLR-Wrapper Knoten.

The ObjectMemberNodeFactory..::..FactoryEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ObjectMemberNodeFactory..::..FactoryEventArgs | Initialisiert eine neue ObjectMemberNodeFactory..::..FactoryEventArgs-Instanz mit einem Knoten.

Properties

 | Name | Description
Public property | Node | Gibt den Knoten zurück.

See Also

ObjectMemberNodeFactory..::..FactoryEventArgs Class
DynamicNode.Ext.Objects Namespace


ObjectMemberNodeFactory.FactoryEventArgs Constructor

[image]

DynamicNodes API
ObjectMemberNodeFactory..::..FactoryEventArgs Constructor
ObjectMemberNodeFactory..::..FactoryEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue ObjectMemberNodeFactory..::..FactoryEventArgs-Instanz mit einem Knoten.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public FactoryEventArgs(
    INode node
)
Visual Basic
Public Sub New ( _
    node As INode _
)
F#
new :
        node:INode -> FactoryEventArgs

Parameters

node
Type: DynamicNode.Core..::..INode
Der Knoten.

See Also

ObjectMemberNodeFactory..::..FactoryEventArgs Class
DynamicNode.Ext.Objects Namespace


ObjectMemberNodeFactory.FactoryEventArgs Properties

[image] [image]

DynamicNodes API
ObjectMemberNodeFactory..::..FactoryEventArgs Properties
ObjectMemberNodeFactory..::..FactoryEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ObjectMemberNodeFactory..::..FactoryEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Node | Gibt den Knoten zurück.

See Also

ObjectMemberNodeFactory..::..FactoryEventArgs Class
DynamicNode.Ext.Objects Namespace


Node Property

[image]

DynamicNodes API
ObjectMemberNodeFactory..::..FactoryEventArgs..::..Node Property
ObjectMemberNodeFactory..::..FactoryEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Knoten zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public INode Node { get; private set; }
Visual Basic
Public Property Node As INode
    Get
    Private Set
F#
member Node : INode with get, private set

See Also

ObjectMemberNodeFactory..::..FactoryEventArgs Class
DynamicNode.Ext.Objects Namespace


ObjectNodeRegistry Class

[image]

DynamicNodes API
ObjectNodeRegistry Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Registry für CLR-Wrapper-Knoten.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static class ObjectNodeRegistry
Visual Basic
Public NotInheritable Class ObjectNodeRegistry
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ObjectNodeRegistry =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Objects..::..ObjectNodeRegistry

See Also

ObjectNodeRegistry Members
DynamicNode.Ext.Objects Namespace


ObjectNodeRegistry Members

[image] [image]

DynamicNodes API
ObjectNodeRegistry Members
ObjectNodeRegistry Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Methods

Name | Description
GetCreator(Interactions) | Gibt für eine Interaktion einen Knotenerzeuger zurück.
GetCreator(TypeOperations) | Gibt für eine Operation einen Knotenerzeuger zurück.
RegisterCreator(Interactions, MemberInfoNodeCreator) | Registriert den übergebenen Knotenerzeuger creator für die ebenfalls übergebene Interaktion.
RegisterCreator(TypeOperations, TypeNodeCreator) | Registriert den übergebenen Knotenerzeuger creator für die ebenfalls übergebene Operation.

See Also

ObjectNodeRegistry Class
DynamicNode.Ext.Objects Namespace


ObjectNodeRegistry Methods

[image] [image]

DynamicNodes API
ObjectNodeRegistry Methods
ObjectNodeRegistry Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Methods

Name | Description
GetCreator(Interactions) | Gibt für eine Interaktion einen Knotenerzeuger zurück.
GetCreator(TypeOperations) | Gibt für eine Operation einen Knotenerzeuger zurück.
RegisterCreator(Interactions, MemberInfoNodeCreator) | Registriert den übergebenen Knotenerzeuger creator für die ebenfalls übergebene Interaktion.
RegisterCreator(TypeOperations, TypeNodeCreator) | Registriert den übergebenen Knotenerzeuger creator für die ebenfalls übergebene Operation.

See Also

ObjectNodeRegistry Class
DynamicNode.Ext.Objects Namespace


GetCreator Method

[image] [image]

DynamicNodes API
ObjectNodeRegistry..::..GetCreator Method
ObjectNodeRegistry Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
GetCreator(Interactions) | Gibt für eine Interaktion einen Knotenerzeuger zurück.
GetCreator(TypeOperations) | Gibt für eine Operation einen Knotenerzeuger zurück.

See Also

ObjectNodeRegistry Class
ObjectNodeRegistry Members
DynamicNode.Ext.Objects Namespace


GetCreator Method (Interactions)

[image]

DynamicNodes API
ObjectNodeRegistry..::..GetCreator Method (Interactions)
ObjectNodeRegistry Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für eine Interaktion einen Knotenerzeuger zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static MemberInfoNodeCreator GetCreator(
    Interactions interaction
)
Visual Basic
Public Shared Function GetCreator ( _
    interaction As Interactions _
) As MemberInfoNodeCreator
F#
static member GetCreator :
        interaction:Interactions -> MemberInfoNodeCreator

Parameters

interaction
Type: DynamicNode.Ext.Objects..::..Interactions
Die Interaktion.

Return Value

Einen Knotenerzeuger oder null, wenn für die übergebene Interaktion kein Knotenerzeuger registriert ist.

See Also

ObjectNodeRegistry Class
GetCreator Overload
DynamicNode.Ext.Objects Namespace


GetCreator Method (TypeOperations)

[image]

DynamicNodes API
ObjectNodeRegistry..::..GetCreator Method (TypeOperations)
ObjectNodeRegistry Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für eine Operation einen Knotenerzeuger zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static TypeNodeCreator GetCreator(
    TypeOperations operation
)
Visual Basic
Public Shared Function GetCreator ( _
    operation As TypeOperations _
) As TypeNodeCreator
F#
static member GetCreator :
        operation:TypeOperations -> TypeNodeCreator

Parameters

operation
Type: DynamicNode.Ext.Objects..::..TypeOperations
Die Operaktion.

Return Value

Einen Knotenerzeuger oder null, wenn für die übergebene Operaktion kein Knotenerzeuger registriert ist.

See Also

ObjectNodeRegistry Class
GetCreator Overload
DynamicNode.Ext.Objects Namespace


RegisterCreator Method

[image] [image]

DynamicNodes API
ObjectNodeRegistry..::..RegisterCreator Method
ObjectNodeRegistry Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
RegisterCreator(Interactions, MemberInfoNodeCreator) | Registriert den übergebenen Knotenerzeuger creator für die ebenfalls übergebene Interaktion.
RegisterCreator(TypeOperations, TypeNodeCreator) | Registriert den übergebenen Knotenerzeuger creator für die ebenfalls übergebene Operation.

See Also

ObjectNodeRegistry Class
ObjectNodeRegistry Members
DynamicNode.Ext.Objects Namespace


RegisterCreator Method (Interactions, MemberInfoNodeCreator)

[image]

DynamicNodes API
ObjectNodeRegistry..::..RegisterCreator Method (Interactions, MemberInfoNodeCreator)
ObjectNodeRegistry Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert den übergebenen Knotenerzeuger creator für die ebenfalls übergebene Interaktion.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static void RegisterCreator(
    Interactions interaction,
    MemberInfoNodeCreator creator
)
Visual Basic
Public Shared Sub RegisterCreator ( _
    interaction As Interactions, _
    creator As MemberInfoNodeCreator _
)
F#
static member RegisterCreator :
        interaction:Interactions *
        creator:MemberInfoNodeCreator -> unit

Parameters

interaction
Type: DynamicNode.Ext.Objects..::..Interactions
Die Interaktion für die ein Knotenerzeuger registriert werden soll.
creator
Type: DynamicNode.Ext.Objects..::..MemberInfoNodeCreator
Ein Knotenerzeuger.

See Also

ObjectNodeRegistry Class
RegisterCreator Overload
DynamicNode.Ext.Objects Namespace


RegisterCreator Method (TypeOperations, TypeNodeCreator)

[image]

DynamicNodes API
ObjectNodeRegistry..::..RegisterCreator Method (TypeOperations, TypeNodeCreator)
ObjectNodeRegistry Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert den übergebenen Knotenerzeuger creator für die ebenfalls übergebene Operation.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static void RegisterCreator(
    TypeOperations operation,
    TypeNodeCreator creator
)
Visual Basic
Public Shared Sub RegisterCreator ( _
    operation As TypeOperations, _
    creator As TypeNodeCreator _
)
F#
static member RegisterCreator :
        operation:TypeOperations *
        creator:TypeNodeCreator -> unit

Parameters

operation
Type: DynamicNode.Ext.Objects..::..TypeOperations
Die Operation für die ein Knotenerzeuger registriert werden soll.
creator
Type: DynamicNode.Ext.Objects..::..TypeNodeCreator
Ein Knotenerzeuger.

See Also

ObjectNodeRegistry Class
RegisterCreator Overload
DynamicNode.Ext.Objects Namespace


PropertySelector Class

[image]

DynamicNodes API
PropertySelector Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Steuerelement zur Auswahl einer CLR-Eigenschaft.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class PropertySelector : UserControl
Visual Basic
Public Class PropertySelector _
    Inherits UserControl
F#
type PropertySelector =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Objects..::..PropertySelector

See Also

PropertySelector Members
DynamicNode.Ext.Objects Namespace


PropertySelector Members

[image] [image]

DynamicNodes API
PropertySelector Members
PropertySelector Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PropertySelector type exposes the following members.

Constructors

 | Name | Description
Public method | PropertySelector | Initialisiert eine neue Instanz von PropertySelector.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnPropertySelected | Wird aufgerufen, wenn eine neue Eigenschaft ausgewählt wurde. Löst das Ereignis PropertySelected aus.

Properties

 | Name | Description
Public property | MustBeStatic | Gibt einen Wert zurück oder legt ihn fest, der angibt, ob statische oder dynamische Eigenschaften zur Auswahl stehen sollen.
Public property | Property | Gibt die aktuell ausgewählte Eigenschaft zurück, oder legt sie fest.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.
Public property | Writeable | Gibt einen Wert zurück oder legt ihn fest, der angibt, ob lesbare oder schreibbare Eigenschaften zur Auswahl stehen sollen.

Events

 | Name | Description
Public event | PropertySelected | Wird ausgelöst, wenn eine neue Eigenschaft ausgewählt wurde.

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


PropertySelector Constructor

[image]

DynamicNodes API
PropertySelector Constructor
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von PropertySelector.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public PropertySelector()
Visual Basic
Public Sub New
F#
new : unit -> PropertySelector

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


PropertySelector Methods

[image] [image]

DynamicNodes API
PropertySelector Methods
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PropertySelector type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnPropertySelected | Wird aufgerufen, wenn eine neue Eigenschaft ausgewählt wurde. Löst das Ereignis PropertySelected aus.

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


Dispose Method

[image]

DynamicNodes API
PropertySelector..::..Dispose Method
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


OnPropertySelected Method

[image]

DynamicNodes API
PropertySelector..::..OnPropertySelected Method
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn eine neue Eigenschaft ausgewählt wurde. Löst das Ereignis PropertySelected aus.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected void OnPropertySelected()
Visual Basic
Protected Sub OnPropertySelected
F#
member OnPropertySelected : unit -> unit

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


PropertySelector Properties

[image] [image]

DynamicNodes API
PropertySelector Properties
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PropertySelector type exposes the following members.

Properties

 | Name | Description
Public property | MustBeStatic | Gibt einen Wert zurück oder legt ihn fest, der angibt, ob statische oder dynamische Eigenschaften zur Auswahl stehen sollen.
Public property | Property | Gibt die aktuell ausgewählte Eigenschaft zurück, oder legt sie fest.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.
Public property | Writeable | Gibt einen Wert zurück oder legt ihn fest, der angibt, ob lesbare oder schreibbare Eigenschaften zur Auswahl stehen sollen.

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


MustBeStatic Property

[image]

DynamicNodes API
PropertySelector..::..MustBeStatic Property
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt, ob statische oder dynamische Eigenschaften zur Auswahl stehen sollen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public bool MustBeStatic { get; set; }
Visual Basic
Public Property MustBeStatic As Boolean
    Get
    Set
F#
member MustBeStatic : bool with get, set

Field Value

true wenn statische Eigenschaften zur Auswahl stehen sollen, sonst false.

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


Property Property

[image]

DynamicNodes API
PropertySelector..::..Property Property
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die aktuell ausgewählte Eigenschaft zurück, oder legt sie fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public PropertyInfo Property { get; set; }
Visual Basic
Public Property Property As PropertyInfo
    Get
    Set
F#
member Property : PropertyInfo with get, set

Field Value

Die ausgewählte Eigenschaft.

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


Type Property

[image]

DynamicNodes API
PropertySelector..::..Type Property
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Type Type { get; set; }
Visual Basic
Public Property Type As Type
    Get
    Set
F#
member Type : Type with get, set

Field Value

Der ausgewählte Type.

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


Writeable Property

[image]

DynamicNodes API
PropertySelector..::..Writeable Property
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt, ob lesbare oder schreibbare Eigenschaften zur Auswahl stehen sollen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public bool Writeable { get; set; }
Visual Basic
Public Property Writeable As Boolean
    Get
    Set
F#
member Writeable : bool with get, set

Field Value

true wenn schreibbare Eigenschaften zur Auswahl stehen sollen, sonst false.

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


PropertySelector Events

[image] [image]

DynamicNodes API
PropertySelector Events
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PropertySelector type exposes the following members.

Events

 | Name | Description
Public event | PropertySelected | Wird ausgelöst, wenn eine neue Eigenschaft ausgewählt wurde.

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


PropertySelected Event

[image]

DynamicNodes API
PropertySelector..::..PropertySelected Event
PropertySelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine neue Eigenschaft ausgewählt wurde.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public event EventHandler PropertySelected
Visual Basic
Public Event PropertySelected As EventHandler
F#
member PropertySelected : IEvent<EventHandler,
    EventArgs>

See Also

PropertySelector Class
DynamicNode.Ext.Objects Namespace


TypeDragEventArgs Class

[image]

DynamicNodes API
TypeDragEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt die Daten für das Ereignis TypeDrag bereit.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class TypeDragEventArgs : EventArgs
Visual Basic
Public Class TypeDragEventArgs _
    Inherits EventArgs
F#
type TypeDragEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Ext.Objects..::..TypeDragEventArgs

See Also

TypeDragEventArgs Members
DynamicNode.Ext.Objects Namespace


TypeDragEventArgs Members

[image] [image]

DynamicNodes API
TypeDragEventArgs Members
TypeDragEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypeDragEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TypeDragEventArgs | Initialisiert eine neue Instanz von TypeDragEventArgs.

Properties

 | Name | Description
Public property | Control | Gibt das Steuerelement zurück, bei dem die Drag&Drop-Operation beginnt.
Public property | Type | Gibt den Type zurück, der aus dem Browser gezogen wurde.

See Also

TypeDragEventArgs Class
DynamicNode.Ext.Objects Namespace


TypeDragEventArgs Constructor

[image]

DynamicNodes API
TypeDragEventArgs Constructor
TypeDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von TypeDragEventArgs.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public TypeDragEventArgs(
    Type type,
    Control control
)
Visual Basic
Public Sub New ( _
    type As Type, _
    control As Control _
)
F#
new :
        type:Type *
        control:Control -> TypeDragEventArgs

Parameters

type
Type: System..::..Type
Der Type der aus dem Browser gezogen wurde.
control
Type: System.Windows.Forms..::..Control
Das Steuerelement bei dem die Drag&Drop-Operation beginnt.

See Also

TypeDragEventArgs Class
DynamicNode.Ext.Objects Namespace


TypeDragEventArgs Properties

[image] [image]

DynamicNodes API
TypeDragEventArgs Properties
TypeDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypeDragEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Control | Gibt das Steuerelement zurück, bei dem die Drag&Drop-Operation beginnt.
Public property | Type | Gibt den Type zurück, der aus dem Browser gezogen wurde.

See Also

TypeDragEventArgs Class
DynamicNode.Ext.Objects Namespace


Control Property

[image]

DynamicNodes API
TypeDragEventArgs..::..Control Property
TypeDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Steuerelement zurück, bei dem die Drag&Drop-Operation beginnt.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Control Control { get; private set; }
Visual Basic
Public Property Control As Control
    Get
    Private Set
F#
member Control : Control with get, private set

Field Value

Das Steuerelement bei dem die Drag&Drop-Operation beginnt.

See Also

TypeDragEventArgs Class
DynamicNode.Ext.Objects Namespace


Type Property

[image]

DynamicNodes API
TypeDragEventArgs..::..Type Property
TypeDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Type zurück, der aus dem Browser gezogen wurde.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Type Type { get; private set; }
Visual Basic
Public Property Type As Type
    Get
    Private Set
F#
member Type : Type with get, private set

Field Value

Der Type der aus dem Browser gezogen wurde.

See Also

TypeDragEventArgs Class
DynamicNode.Ext.Objects Namespace


TypeNodeCreator Delegate

[image]

DynamicNodes API
TypeNodeCreator Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Knotenerzeuger für CLR-Wrapperknoten die einen Typ kapseln.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public delegate INode TypeNodeCreator(
    Type type
)
Visual Basic
Public Delegate Function TypeNodeCreator ( _
    type As Type _
) As INode
F#
type TypeNodeCreator =
    delegate of
        type:Type -> INode

Parameters

type
Type: System..::..Type

See Also

DynamicNode.Ext.Objects Namespace


TypeOperations Enumeration

[image]

DynamicNodes API
TypeOperations Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Auflistung von Operationen für CLR-Objekte.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public enum TypeOperations
Visual Basic
Public Enumeration TypeOperations
F#
type TypeOperations

Members

Member name | Description
Instance |
Cast |

See Also

DynamicNode.Ext.Objects Namespace


TypeSelector Class

[image]

DynamicNodes API
TypeSelector Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Steuerelement zur Auswahl eines CLR-Types. Die Auswahl erfolgt in drei Stufen: Zunächst wird ein Assembly ausgewählt, anschließend wird auf einen Namensraum eingegrenzt und im letzten Schritt wird ein Type gewählt.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class TypeSelector : UserControl
Visual Basic
Public Class TypeSelector _
    Inherits UserControl
F#
type TypeSelector =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Objects..::..TypeSelector

See Also

TypeSelector Members
DynamicNode.Ext.Objects Namespace


TypeSelector Members

[image] [image]

DynamicNodes API
TypeSelector Members
TypeSelector Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypeSelector type exposes the following members.

Constructors

 | Name | Description
Public method | TypeSelector | Initialisiert eine neue Instanz von TypeSelector.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnTypeSelected | Wird aufgerufen, wenn ein neuer Type ausgewählt wurde. Löst das Ereignis TypeSelected aus.

Properties

 | Name | Description
Public property | Assembly | Gibt das aktuell ausgewählte Assembly zurück, oder legt es fest.
Public property | NameSpace | Gibt den aktuell ausgewählten Namensraum zurück, oder legt ihn fest.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

Events

 | Name | Description
Public event | TypeSelected | Wird ausgelöst, wenn ein neuer Type ausgewählt wurde.

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


TypeSelector Constructor

[image]

DynamicNodes API
TypeSelector Constructor
TypeSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von TypeSelector.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public TypeSelector()
Visual Basic
Public Sub New
F#
new : unit -> TypeSelector

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


TypeSelector Methods

[image] [image]

DynamicNodes API
TypeSelector Methods
TypeSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypeSelector type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnTypeSelected | Wird aufgerufen, wenn ein neuer Type ausgewählt wurde. Löst das Ereignis TypeSelected aus.

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


Dispose Method

[image]

DynamicNodes API
TypeSelector..::..Dispose Method
TypeSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


OnTypeSelected Method

[image]

DynamicNodes API
TypeSelector..::..OnTypeSelected Method
TypeSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein neuer Type ausgewählt wurde. Löst das Ereignis TypeSelected aus.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
protected void OnTypeSelected()
Visual Basic
Protected Sub OnTypeSelected
F#
member OnTypeSelected : unit -> unit

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


TypeSelector Properties

[image] [image]

DynamicNodes API
TypeSelector Properties
TypeSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypeSelector type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Gibt das aktuell ausgewählte Assembly zurück, oder legt es fest.
Public property | NameSpace | Gibt den aktuell ausgewählten Namensraum zurück, oder legt ihn fest.
Public property | Type | Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


Assembly Property

[image]

DynamicNodes API
TypeSelector..::..Assembly Property
TypeSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das aktuell ausgewählte Assembly zurück, oder legt es fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Assembly Assembly { get; private set; }
Visual Basic
Public Property Assembly As Assembly
    Get
    Private Set
F#
member Assembly : Assembly with get, private set

Field Value

Das gewählte Assembly.

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


NameSpace Property

[image]

DynamicNodes API
TypeSelector..::..NameSpace Property
TypeSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuell ausgewählten Namensraum zurück, oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public string NameSpace { get; private set; }
Visual Basic
Public Property NameSpace As String
    Get
    Private Set
F#
member NameSpace : string with get, private set

Field Value

Der gewählte Namensraum.

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


Type Property

[image]

DynamicNodes API
TypeSelector..::..Type Property
TypeSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuell ausgewählten Type zurück, oder legt ihn fest.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public Type Type { get; set; }
Visual Basic
Public Property Type As Type
    Get
    Set
F#
member Type : Type with get, set

Field Value

Der ausgewählte Type.

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


TypeSelector Events

[image] [image]

DynamicNodes API
TypeSelector Events
TypeSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TypeSelector type exposes the following members.

Events

 | Name | Description
Public event | TypeSelected | Wird ausgelöst, wenn ein neuer Type ausgewählt wurde.

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


TypeSelected Event

[image]

DynamicNodes API
TypeSelector..::..TypeSelected Event
TypeSelector Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein neuer Type ausgewählt wurde.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public event EventHandler TypeSelected
Visual Basic
Public Event TypeSelected As EventHandler
F#
member TypeSelected : IEvent<EventHandler,
    EventArgs>

See Also

TypeSelector Class
DynamicNode.Ext.Objects Namespace


WindowsFormsSyncContext Class

[image]

DynamicNodes API
WindowsFormsSyncContext Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Single-Thread-Kontext für Windows-Forms-Anwendungen.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class WindowsFormsSyncContext : ISingleThreadContext
Visual Basic
Public Class WindowsFormsSyncContext _
    Implements ISingleThreadContext
F#
type WindowsFormsSyncContext =
    class
        interface ISingleThreadContext
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Objects..::..WindowsFormsSyncContext

See Also

WindowsFormsSyncContext Members
DynamicNode.Ext.Objects Namespace


WindowsFormsSyncContext Members

[image] [image]

DynamicNodes API
WindowsFormsSyncContext Members
WindowsFormsSyncContext Class Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The WindowsFormsSyncContext type exposes the following members.

Methods

 | Name | Description
Public method | Close | Beendet den Synchronisierungskontext.
Public method | InvokeAsync | Führt eine Aufgabe in dem Synchronisierungskontext durch.
 | Register | Registriert diesen Single-Thread-Kontext bei einem IThreadManager.

Properties

 | Name | Description
Public property | Id | Gibt die ID des Synchronisierungskontexts zurück.

See Also

WindowsFormsSyncContext Class
DynamicNode.Ext.Objects Namespace


WindowsFormsSyncContext Methods

[image] [image]

DynamicNodes API
WindowsFormsSyncContext Methods
WindowsFormsSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The WindowsFormsSyncContext type exposes the following members.

Methods

 | Name | Description
Public method | Close | Beendet den Synchronisierungskontext.
Public method | InvokeAsync | Führt eine Aufgabe in dem Synchronisierungskontext durch.
 | Register | Registriert diesen Single-Thread-Kontext bei einem IThreadManager.

See Also

WindowsFormsSyncContext Class
DynamicNode.Ext.Objects Namespace


Close Method

[image]

DynamicNodes API
WindowsFormsSyncContext..::..Close Method
WindowsFormsSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beendet den Synchronisierungskontext.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
F#
abstract Close : unit -> unit
override Close : unit -> unit

Implements

ISingleThreadContext..::..Close()()()()

See Also

WindowsFormsSyncContext Class
DynamicNode.Ext.Objects Namespace


InvokeAsync Method

[image]

DynamicNodes API
WindowsFormsSyncContext..::..InvokeAsync Method
WindowsFormsSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Aufgabe in dem Synchronisierungskontext durch.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public void InvokeAsync(
    ThreadStart task
)
Visual Basic
Public Sub InvokeAsync ( _
    task As ThreadStart _
)
F#
abstract InvokeAsync :
        task:ThreadStart -> unit
override InvokeAsync :
        task:ThreadStart -> unit

Parameters

task
Type: System.Threading..::..ThreadStart
Die Aufgabe.

Implements

ISingleThreadContext..::..InvokeAsync(ThreadStart)

See Also

WindowsFormsSyncContext Class
DynamicNode.Ext.Objects Namespace


Register Method

[image]

DynamicNodes API
WindowsFormsSyncContext..::..Register Method
WindowsFormsSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert diesen Single-Thread-Kontext bei einem IThreadManager.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static void Register(
    IThreadManager threadManager
)
Visual Basic
Public Shared Sub Register ( _
    threadManager As IThreadManager _
)
F#
static member Register :
        threadManager:IThreadManager -> unit

Parameters

threadManager
Type: DynamicNode.Core..::..IThreadManager
Ein Thread-Manager.

See Also

WindowsFormsSyncContext Class
DynamicNode.Ext.Objects Namespace


WindowsFormsSyncContext Properties

[image] [image]

DynamicNodes API
WindowsFormsSyncContext Properties
WindowsFormsSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The WindowsFormsSyncContext type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt die ID des Synchronisierungskontexts zurück.

See Also

WindowsFormsSyncContext Class
DynamicNode.Ext.Objects Namespace


Id Property

[image]

DynamicNodes API
WindowsFormsSyncContext..::..Id Property
WindowsFormsSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Synchronisierungskontexts zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID des Synchronisierungskontexts.

Implements

ISingleThreadContext..::..Id

See Also

WindowsFormsSyncContext Class
DynamicNode.Ext.Objects Namespace


WpfSyncContext Class

[image]

DynamicNodes API
WpfSyncContext Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt einen Single-Thread-Kontext für WPF-Anwendungen zur Verfügung.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public class WpfSyncContext : ISingleThreadContext
Visual Basic
Public Class WpfSyncContext _
    Implements ISingleThreadContext
F#
type WpfSyncContext =
    class
        interface ISingleThreadContext
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Objects..::..WpfSyncContext

See Also

WpfSyncContext Members
DynamicNode.Ext.Objects Namespace


WpfSyncContext Members

[image] [image]

DynamicNodes API
WpfSyncContext Members
WpfSyncContext Class Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The WpfSyncContext type exposes the following members.

Methods

 | Name | Description
Public method | Close | Beendet den Synchronisierungskontext.
Public method | InvokeAsync | Führt eine Aufgabe in dem Synchronisierungskontext durch.
 | Register | Registriert diesen Single-Thread-Kontext bei einem IThreadManager.

Properties

 | Name | Description
Public property | Id | Gibt die ID des Synchronisierungskontexts zurück.

See Also

WpfSyncContext Class
DynamicNode.Ext.Objects Namespace


WpfSyncContext Methods

[image] [image]

DynamicNodes API
WpfSyncContext Methods
WpfSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The WpfSyncContext type exposes the following members.

Methods

 | Name | Description
Public method | Close | Beendet den Synchronisierungskontext.
Public method | InvokeAsync | Führt eine Aufgabe in dem Synchronisierungskontext durch.
 | Register | Registriert diesen Single-Thread-Kontext bei einem IThreadManager.

See Also

WpfSyncContext Class
DynamicNode.Ext.Objects Namespace


Close Method

[image]

DynamicNodes API
WpfSyncContext..::..Close Method
WpfSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beendet den Synchronisierungskontext.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
F#
abstract Close : unit -> unit
override Close : unit -> unit

Implements

ISingleThreadContext..::..Close()()()()

See Also

WpfSyncContext Class
DynamicNode.Ext.Objects Namespace


InvokeAsync Method

[image]

DynamicNodes API
WpfSyncContext..::..InvokeAsync Method
WpfSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Aufgabe in dem Synchronisierungskontext durch.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public void InvokeAsync(
    ThreadStart task
)
Visual Basic
Public Sub InvokeAsync ( _
    task As ThreadStart _
)
F#
abstract InvokeAsync :
        task:ThreadStart -> unit
override InvokeAsync :
        task:ThreadStart -> unit

Parameters

task
Type: System.Threading..::..ThreadStart
Die Aufgabe.

Implements

ISingleThreadContext..::..InvokeAsync(ThreadStart)

See Also

WpfSyncContext Class
DynamicNode.Ext.Objects Namespace


Register Method

[image]

DynamicNodes API
WpfSyncContext..::..Register Method
WpfSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert diesen Single-Thread-Kontext bei einem IThreadManager.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public static void Register(
    IThreadManager threadManager
)
Visual Basic
Public Shared Sub Register ( _
    threadManager As IThreadManager _
)
F#
static member Register :
        threadManager:IThreadManager -> unit

Parameters

threadManager
Type: DynamicNode.Core..::..IThreadManager
Ein Thread-Manager.

See Also

WpfSyncContext Class
DynamicNode.Ext.Objects Namespace


WpfSyncContext Properties

[image] [image]

DynamicNodes API
WpfSyncContext Properties
WpfSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The WpfSyncContext type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt die ID des Synchronisierungskontexts zurück.

See Also

WpfSyncContext Class
DynamicNode.Ext.Objects Namespace


Id Property

[image]

DynamicNodes API
WpfSyncContext..::..Id Property
WpfSyncContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Synchronisierungskontexts zurück.

Namespace: DynamicNode.Ext.Objects
Assembly: DNExtObjects (in DNExtObjects.dll) Version: 1.1.4679.19819 (1.1.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID des Synchronisierungskontexts.

Implements

ISingleThreadContext..::..Id

See Also

WpfSyncContext Class
DynamicNode.Ext.Objects Namespace


DynamicNode.Ext.Remoting Namespace

[image]

DynamicNodes API
DynamicNode.Ext.Remoting Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält eine Standardimplementierung der Schnittstellen aus dem Namensraum DynamicNode.Remoting. Die Implementierung wird durch eine Anzahl an Proxy-Klassen realisiert, welche den Fernzugriff auf das Datenmodell einer Laufzeitumgebung gestatten.

Classes

 | Class | Description
Public class | DynamicNodesApp | Die WCF-Dienstklasse für die Anwendungsfernsteuerung.
Public class | RemoteApplicationContext | Der Fernsteuerungs-Proxy für die DynamicNodes-Anwendung.
Public class | RemoteGraph | Ein Fernsteuerungs-Proxy für einen Graphen.
Public class | RemoteInPort | Ein Fernsteuerungs-Proxy für einen Eingang.
Public class | RemoteNode | Ein Fernsteuerungs-Proxy für einen Knoten.
Public class | RemoteOutPort | Ein Fernsteuerungs-Proxy für einen Ausgang.
Public class | RemotePortBase | Die Basisklasse für Fernsteuerungs-Proxy-Klassen von Anschlüssen.
Public class | RemoteRuntime | Ein Fernsteuerungs-Proxy für eine Laufzeitumgebung.
Public class | ServerContext | Ein Kontext für die Bereitstellung einer Fernsteuerungsschnittstelle.

Interfaces

 | Interface | Description
Public interface | IDynamicNodesApp | Der Service-Contract für eine WCF-Schnittstelle zu DynamicNodes.

Enumerations

 | Enumeration | Description
Public enumeration | RemoteMethod | Die Protokolle für die Fernsteuerungsschnittstelle.


DynamicNodesApp Class

[image]

DynamicNodes API
DynamicNodesApp Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die WCF-Dienstklasse für die Anwendungsfernsteuerung.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class DynamicNodesApp : IDynamicNodesApp
Visual Basic
Public Class DynamicNodesApp _
    Implements IDynamicNodesApp
F#
type DynamicNodesApp =
    class
        interface IDynamicNodesApp
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Remoting..::..DynamicNodesApp

See Also

DynamicNodesApp Members
DynamicNode.Ext.Remoting Namespace


DynamicNodesApp Members

[image] [image]

DynamicNodes API
DynamicNodesApp Members
DynamicNodesApp Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DynamicNodesApp type exposes the following members.

Constructors

 | Name | Description
Public method | DynamicNodesApp | Initializes a new instance of the DynamicNodesApp class

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein PowerShell-Script in der DynamicNodes-Anwendung aus.

See Also

DynamicNodesApp Class
DynamicNode.Ext.Remoting Namespace


DynamicNodesApp Constructor

[image]

DynamicNodes API
DynamicNodesApp Constructor
DynamicNodesApp Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the DynamicNodesApp class

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public DynamicNodesApp()
Visual Basic
Public Sub New
F#
new : unit -> DynamicNodesApp

See Also

DynamicNodesApp Class
DynamicNode.Ext.Remoting Namespace


DynamicNodesApp Methods

[image] [image]

DynamicNodes API
DynamicNodesApp Methods
DynamicNodesApp Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DynamicNodesApp type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein PowerShell-Script in der DynamicNodes-Anwendung aus.

See Also

DynamicNodesApp Class
DynamicNode.Ext.Remoting Namespace


ExecuteScript Method

[image]

DynamicNodes API
DynamicNodesApp..::..ExecuteScript Method
DynamicNodesApp Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt ein PowerShell-Script in der DynamicNodes-Anwendung aus.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string ExecuteScript(
    string script
)
Visual Basic
Public Function ExecuteScript ( _
    script As String _
) As String
F#
abstract ExecuteScript :
        script:string -> string
override ExecuteScript :
        script:string -> string

Parameters

script
Type: System..::..String
Der Quelltext des Scripts..

Return Value

Die Ausgabe des Scripts.

Implements

IDynamicNodesApp..::..ExecuteScript(String)

See Also

DynamicNodesApp Class
DynamicNode.Ext.Remoting Namespace


IDynamicNodesApp Interface

[image]

DynamicNodes API
IDynamicNodesApp Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Service-Contract für eine WCF-Schnittstelle zu DynamicNodes.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public interface IDynamicNodesApp
Visual Basic
Public Interface IDynamicNodesApp
F#
type IDynamicNodesApp =  interface end

See Also

IDynamicNodesApp Members
DynamicNode.Ext.Remoting Namespace


IDynamicNodesApp Members

[image] [image]

DynamicNodes API
IDynamicNodesApp Members
IDynamicNodesApp Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IDynamicNodesApp type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein PowerShell-Script in der DynamicNodes-Anwendung aus.

See Also

IDynamicNodesApp Interface
DynamicNode.Ext.Remoting Namespace


IDynamicNodesApp Methods

[image] [image]

DynamicNodes API
IDynamicNodesApp Methods
IDynamicNodesApp Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IDynamicNodesApp type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein PowerShell-Script in der DynamicNodes-Anwendung aus.

See Also

IDynamicNodesApp Interface
DynamicNode.Ext.Remoting Namespace


ExecuteScript Method

[image]

DynamicNodes API
IDynamicNodesApp..::..ExecuteScript Method
IDynamicNodesApp Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt ein PowerShell-Script in der DynamicNodes-Anwendung aus.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string ExecuteScript(
    string script
)
Visual Basic
Function ExecuteScript ( _
    script As String _
) As String
F#
abstract ExecuteScript :
        script:string -> string

Parameters

script
Type: System..::..String
Der Quelltext des Scripts..

Return Value

Die Ausgabe des Scripts.

See Also

IDynamicNodesApp Interface
DynamicNode.Ext.Remoting Namespace


RemoteApplicationContext Class

[image]

DynamicNodes API
RemoteApplicationContext Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Fernsteuerungs-Proxy für die DynamicNodes-Anwendung.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class RemoteApplicationContext : IRemoteApplicationContext
Visual Basic
Public Class RemoteApplicationContext _
    Implements IRemoteApplicationContext
F#
type RemoteApplicationContext =
    class
        interface IRemoteApplicationContext
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Remoting..::..RemoteApplicationContext

See Also

RemoteApplicationContext Members
DynamicNode.Ext.Remoting Namespace


RemoteApplicationContext Members

[image] [image]

DynamicNodes API
RemoteApplicationContext Members
RemoteApplicationContext Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteApplicationContext type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein Script in der DynamicNodes-Anwendung aus.

See Also

RemoteApplicationContext Class
DynamicNode.Ext.Remoting Namespace


RemoteApplicationContext Methods

[image] [image]

DynamicNodes API
RemoteApplicationContext Methods
RemoteApplicationContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteApplicationContext type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein Script in der DynamicNodes-Anwendung aus.

See Also

RemoteApplicationContext Class
DynamicNode.Ext.Remoting Namespace


ExecuteScript Method

[image]

DynamicNodes API
RemoteApplicationContext..::..ExecuteScript Method
RemoteApplicationContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt ein Script in der DynamicNodes-Anwendung aus.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string ExecuteScript(
    string script
)
Visual Basic
Public Function ExecuteScript ( _
    script As String _
) As String
F#
abstract ExecuteScript :
        script:string -> string
override ExecuteScript :
        script:string -> string

Parameters

script
Type: System..::..String
Der Quelltext des Scripts.

Return Value

Die Ausgabe.

Implements

IRemoteApplicationContext..::..ExecuteScript(String)

See Also

RemoteApplicationContext Class
DynamicNode.Ext.Remoting Namespace


RemoteGraph Class

[image]

DynamicNodes API
RemoteGraph Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Fernsteuerungs-Proxy für einen Graphen.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class RemoteGraph : IRemoteGraph
Visual Basic
Public Class RemoteGraph _
    Implements IRemoteGraph
F#
type RemoteGraph =
    class
        interface IRemoteGraph
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Remoting..::..RemoteGraph

See Also

RemoteGraph Members
DynamicNode.Ext.Remoting Namespace


RemoteGraph Members

[image] [image]

DynamicNodes API
RemoteGraph Members
RemoteGraph Class Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteGraph type exposes the following members.

Methods

 | Name | Description
Public method | ActivateNodes | Aktiviert alle Knoten im Graphen.

Properties

 | Name | Description
Public property | Description | Gibt eine Beschreibung des Graphen zurück.
Public property | GraphStateFlags | Gibt ein Wörterbuch mit den Flags des Graphen zurück. Graphen-Flags werden durch Knoten der Klasse DynamicNode.Core.Nodes.NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens. Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.
Public property | Id | Gibt die ID des Graphen zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen des Graphen zurück.
Public property | Nodes | Gibt die Knoten des Graphen als Array zurück.

See Also

RemoteGraph Class
DynamicNode.Ext.Remoting Namespace


RemoteGraph Methods

[image] [image]

DynamicNodes API
RemoteGraph Methods
RemoteGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteGraph type exposes the following members.

Methods

 | Name | Description
Public method | ActivateNodes | Aktiviert alle Knoten im Graphen.

See Also

RemoteGraph Class
DynamicNode.Ext.Remoting Namespace


ActivateNodes Method

[image]

DynamicNodes API
RemoteGraph..::..ActivateNodes Method
RemoteGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert alle Knoten im Graphen.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void ActivateNodes()
Visual Basic
Public Sub ActivateNodes
F#
abstract ActivateNodes : unit -> unit
override ActivateNodes : unit -> unit

Implements

IRemoteGraph..::..ActivateNodes()()()()

See Also

RemoteGraph Class
DynamicNode.Ext.Remoting Namespace


RemoteGraph Properties

[image] [image]

DynamicNodes API
RemoteGraph Properties
RemoteGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteGraph type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gibt eine Beschreibung des Graphen zurück.
Public property | GraphStateFlags | Gibt ein Wörterbuch mit den Flags des Graphen zurück. Graphen-Flags werden durch Knoten der Klasse DynamicNode.Core.Nodes.NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens. Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.
Public property | Id | Gibt die ID des Graphen zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen des Graphen zurück.
Public property | Nodes | Gibt die Knoten des Graphen als Array zurück.

See Also

RemoteGraph Class
DynamicNode.Ext.Remoting Namespace


Description Property

[image]

DynamicNodes API
RemoteGraph..::..Description Property
RemoteGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Beschreibung des Graphen zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
F#
abstract Description : string
override Description : string

Field Value

Die Beschreibung.

Implements

IRemoteGraph..::..Description

See Also

RemoteGraph Class
DynamicNode.Ext.Remoting Namespace


GraphStateFlags Property

[image]

DynamicNodes API
RemoteGraph..::..GraphStateFlags Property
RemoteGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Gibt ein Wörterbuch mit den Flags des Graphen zurück.

Graphen-Flags werden durch Knoten der Klasse DynamicNode.Core.Nodes.NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens.

Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public IDictionary<string, RemoteTokenState> GraphStateFlags { get; }
Visual Basic
Public ReadOnly Property GraphStateFlags As IDictionary(Of String, RemoteTokenState)
    Get
F#
abstract GraphStateFlags : IDictionary<string, RemoteTokenState>
override GraphStateFlags : IDictionary<string, RemoteTokenState>

Field Value

Die Flags des Graphen.

Implements

IRemoteGraph..::..GraphStateFlags

See Also

RemoteGraph Class
DynamicNode.Ext.Remoting Namespace


Id Property

[image]

DynamicNodes API
RemoteGraph..::..Id Property
RemoteGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Graphen zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
F#
abstract Id : int
override Id : int

Field Value

Die ID.

Implements

IRemoteGraph..::..Id

See Also

RemoteGraph Class
DynamicNode.Ext.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
RemoteGraph..::..IsDisposed Property
RemoteGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsDisposed { get; }
Visual Basic
Public ReadOnly Property IsDisposed As Boolean
    Get
F#
abstract IsDisposed : bool
override IsDisposed : bool

Field Value

true, wenn das Objekt freigegeben wurde, andernfalls false.

Implements

IRemoteGraph..::..IsDisposed

See Also

RemoteGraph Class
DynamicNode.Ext.Remoting Namespace


Name Property

[image]

DynamicNodes API
RemoteGraph..::..Name Property
RemoteGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Graphen zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
abstract Name : string
override Name : string

Field Value

Der Name.

Implements

IRemoteGraph..::..Name

See Also

RemoteGraph Class
DynamicNode.Ext.Remoting Namespace


Nodes Property

[image]

DynamicNodes API
RemoteGraph..::..Nodes Property
RemoteGraph Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Knoten des Graphen als Array zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public IRemoteNode[] Nodes { get; }
Visual Basic
Public ReadOnly Property Nodes As IRemoteNode()
    Get
F#
abstract Nodes : IRemoteNode[]
override Nodes : IRemoteNode[]

Field Value

Die Knoten des Graphen.

Implements

IRemoteGraph..::..Nodes

See Also

RemoteGraph Class
DynamicNode.Ext.Remoting Namespace


RemoteInPort Class

[image]

DynamicNodes API
RemoteInPort Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Fernsteuerungs-Proxy für einen Eingang.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class RemoteInPort : RemotePortBase,
    IRemoteInPort, IRemotePort
Visual Basic
Public Class RemoteInPort _
    Inherits RemotePortBase _
    Implements IRemoteInPort, IRemotePort
F#
type RemoteInPort =
    class
        inherit RemotePortBase
        interface IRemoteInPort
        interface IRemotePort
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Remoting..::..RemotePortBase
DynamicNode.Ext.Remoting..::..RemoteInPort

See Also

RemoteInPort Members
DynamicNode.Ext.Remoting Namespace


RemoteInPort Members

[image] [image]

DynamicNodes API
RemoteInPort Members
RemoteInPort Class Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteInPort type exposes the following members.

Fields

 | Name | Description
Protected field | Port | Der ferngesteuerte Anschluss. (Inherited from RemotePortBase.)

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from RemotePortBase.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | HasQueue | Gibt einen Wert zurück, der angibt ob diese Instanz eine Queue besitzt.
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from RemotePortBase.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from RemotePortBase.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from RemotePortBase.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from RemotePortBase.)

See Also

RemoteInPort Class
DynamicNode.Ext.Remoting Namespace


RemoteInPort Fields

[image] [image]

DynamicNodes API
RemoteInPort Fields
RemoteInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteInPort type exposes the following members.

Fields

 | Name | Description
Protected field | Port | Der ferngesteuerte Anschluss. (Inherited from RemotePortBase.)

See Also

RemoteInPort Class
DynamicNode.Ext.Remoting Namespace


RemoteInPort Properties

[image] [image]

DynamicNodes API
RemoteInPort Properties
RemoteInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteInPort type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from RemotePortBase.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | HasQueue | Gibt einen Wert zurück, der angibt ob diese Instanz eine Queue besitzt.
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from RemotePortBase.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from RemotePortBase.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from RemotePortBase.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from RemotePortBase.)

See Also

RemoteInPort Class
DynamicNode.Ext.Remoting Namespace


HasQueue Property

[image]

DynamicNodes API
RemoteInPort..::..HasQueue Property
RemoteInPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob diese Instanz eine Queue besitzt.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool HasQueue { get; }
Visual Basic
Public ReadOnly Property HasQueue As Boolean
    Get
F#
abstract HasQueue : bool
override HasQueue : bool

Field Value

true wenn diese Instanz eine Queue besitzt, sonst false.

Implements

IRemoteInPort..::..HasQueue

See Also

RemoteInPort Class
DynamicNode.Ext.Remoting Namespace


RemoteMethod Enumeration

[image]

DynamicNodes API
RemoteMethod Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Protokolle für die Fernsteuerungsschnittstelle.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public enum RemoteMethod
Visual Basic
Public Enumeration RemoteMethod
F#
type RemoteMethod

Members

Member name | Description
HTTP |
TCP |

See Also

DynamicNode.Ext.Remoting Namespace


RemoteNode Class

[image]

DynamicNodes API
RemoteNode Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Fernsteuerungs-Proxy für einen Knoten.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class RemoteNode : IRemoteNode
Visual Basic
Public Class RemoteNode _
    Implements IRemoteNode
F#
type RemoteNode =
    class
        interface IRemoteNode
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Remoting..::..RemoteNode

See Also

RemoteNode Members
DynamicNode.Ext.Remoting Namespace


RemoteNode Members

[image] [image]

DynamicNodes API
RemoteNode Members
RemoteNode Class Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteNode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen.
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Properties

 | Name | Description
Public property | Commands | Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.
Public property | Description | Gibt eine Beschreibung des Knoten zurück.
Public property | Id | Gibt die ID des Knoten zurück.
Public property | InPorts | Gibt ein Array mit allen Eingängen des Knotens zurück.
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen des Knoten zurück.
Public property | OutPorts | Gibt ein Array mit allen Ausgängen des Knotens zurück.
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück.
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück.

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


RemoteNode Methods

[image] [image]

DynamicNodes API
RemoteNode Methods
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteNode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen.
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


Activate Method

[image]

DynamicNodes API
RemoteNode..::..Activate Method
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert den Knoten von außen.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void Activate()
Visual Basic
Public Sub Activate
F#
abstract Activate : unit -> unit
override Activate : unit -> unit

Implements

IRemoteNode..::..Activate()()()()

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


OnCommand Method

[image]

DynamicNodes API
RemoteNode..::..OnCommand Method
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void OnCommand(
    string command
)
Visual Basic
Public Sub OnCommand ( _
    command As String _
)
F#
abstract OnCommand :
        command:string -> unit
override OnCommand :
        command:string -> unit

Parameters

command
Type: System..::..String
Der Befehls-Code des Benutzerbefehls.

Implements

IRemoteNode..::..OnCommand(String)

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


OnDefaultCommand Method

[image]

DynamicNodes API
RemoteNode..::..OnDefaultCommand Method
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void OnDefaultCommand()
Visual Basic
Public Sub OnDefaultCommand
F#
abstract OnDefaultCommand : unit -> unit
override OnDefaultCommand : unit -> unit

Implements

IRemoteNode..::..OnDefaultCommand()()()()

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


RemoteNode Properties

[image] [image]

DynamicNodes API
RemoteNode Properties
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteNode type exposes the following members.

Properties

 | Name | Description
Public property | Commands | Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.
Public property | Description | Gibt eine Beschreibung des Knoten zurück.
Public property | Id | Gibt die ID des Knoten zurück.
Public property | InPorts | Gibt ein Array mit allen Eingängen des Knotens zurück.
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen des Knoten zurück.
Public property | OutPorts | Gibt ein Array mit allen Ausgängen des Knotens zurück.
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück.
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück.

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


Commands Property

[image]

DynamicNodes API
RemoteNode..::..Commands Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public IDictionary<string, string> Commands { get; }
Visual Basic
Public ReadOnly Property Commands As IDictionary(Of String, String)
    Get
F#
abstract Commands : IDictionary<string, string>
override Commands : IDictionary<string, string>

Field Value

Die Benutzerbefehle.

Implements

IRemoteNode..::..Commands

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


Description Property

[image]

DynamicNodes API
RemoteNode..::..Description Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Beschreibung des Knoten zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
F#
abstract Description : string
override Description : string

Field Value

Die Beschreibung.

Implements

IRemoteNode..::..Description

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


Id Property

[image]

DynamicNodes API
RemoteNode..::..Id Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Knoten zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
F#
abstract Id : int
override Id : int

Field Value

Die ID.

Implements

IRemoteNode..::..Id

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


InPorts Property

[image]

DynamicNodes API
RemoteNode..::..InPorts Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Eingängen des Knotens zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public IRemoteInPort[] InPorts { get; }
Visual Basic
Public ReadOnly Property InPorts As IRemoteInPort()
    Get
F#
abstract InPorts : IRemoteInPort[]
override InPorts : IRemoteInPort[]

Field Value

Die Eingänge.

Implements

IRemoteNode..::..InPorts

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


IsActive Property

[image]

DynamicNodes API
RemoteNode..::..IsActive Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As Boolean
    Get
F#
abstract IsActive : bool
override IsActive : bool

Field Value

true, wenn dieser Knoten aktiv ist, sonst false.

Implements

IRemoteNode..::..IsActive

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
RemoteNode..::..IsDisposed Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsDisposed { get; }
Visual Basic
Public ReadOnly Property IsDisposed As Boolean
    Get
F#
abstract IsDisposed : bool
override IsDisposed : bool

Field Value

true, wenn das Objekt freigegeben wurde, andernfalls false.

Implements

IRemoteNode..::..IsDisposed

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


Name Property

[image]

DynamicNodes API
RemoteNode..::..Name Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Knoten zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
abstract Name : string
override Name : string

Field Value

Der Name.

Implements

IRemoteNode..::..Name

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


OutPorts Property

[image]

DynamicNodes API
RemoteNode..::..OutPorts Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Ausgängen des Knotens zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public IRemoteOutPort[] OutPorts { get; }
Visual Basic
Public ReadOnly Property OutPorts As IRemoteOutPort()
    Get
F#
abstract OutPorts : IRemoteOutPort[]
override OutPorts : IRemoteOutPort[]

Field Value

Die Ausgänge.

Implements

IRemoteNode..::..OutPorts

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


TypeCaption Property

[image]

DynamicNodes API
RemoteNode..::..TypeCaption Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung des Knoten-Typs zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string TypeCaption { get; }
Visual Basic
Public ReadOnly Property TypeCaption As String
    Get
F#
abstract TypeCaption : string
override TypeCaption : string

Field Value

Die Beschriftung des Knoten-Typs.

Implements

IRemoteNode..::..TypeCaption

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


TypeDescription Property

[image]

DynamicNodes API
RemoteNode..::..TypeDescription Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Knoten-Typs zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string TypeDescription { get; }
Visual Basic
Public ReadOnly Property TypeDescription As String
    Get
F#
abstract TypeDescription : string
override TypeDescription : string

Field Value

Die Beschreibung des Knoten-Typs.

Implements

IRemoteNode..::..TypeDescription

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


TypeGroup Property

[image]

DynamicNodes API
RemoteNode..::..TypeGroup Property
RemoteNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Gruppe des Knoten-Typs zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string TypeGroup { get; }
Visual Basic
Public ReadOnly Property TypeGroup As String
    Get
F#
abstract TypeGroup : string
override TypeGroup : string

Field Value

Die Gruppe des Knoten-Typs.

Implements

IRemoteNode..::..TypeGroup

See Also

RemoteNode Class
DynamicNode.Ext.Remoting Namespace


RemoteOutPort Class

[image]

DynamicNodes API
RemoteOutPort Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Fernsteuerungs-Proxy für einen Ausgang.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class RemoteOutPort : RemotePortBase,
    IRemoteOutPort, IRemotePort
Visual Basic
Public Class RemoteOutPort _
    Inherits RemotePortBase _
    Implements IRemoteOutPort, IRemotePort
F#
type RemoteOutPort =
    class
        inherit RemotePortBase
        interface IRemoteOutPort
        interface IRemotePort
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Remoting..::..RemotePortBase
DynamicNode.Ext.Remoting..::..RemoteOutPort

See Also

RemoteOutPort Members
DynamicNode.Ext.Remoting Namespace


RemoteOutPort Members

[image] [image]

DynamicNodes API
RemoteOutPort Members
RemoteOutPort Class Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteOutPort type exposes the following members.

Methods

 | Name | Description
Public method | Fire | Gibt die Marke an die verbundenen Eingänge weiter.

Fields

 | Name | Description
Protected field | Port | Der ferngesteuerte Anschluss. (Inherited from RemotePortBase.)

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from RemotePortBase.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from RemotePortBase.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from RemotePortBase.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from RemotePortBase.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from RemotePortBase.)

See Also

RemoteOutPort Class
DynamicNode.Ext.Remoting Namespace


RemoteOutPort Fields

[image] [image]

DynamicNodes API
RemoteOutPort Fields
RemoteOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteOutPort type exposes the following members.

Fields

 | Name | Description
Protected field | Port | Der ferngesteuerte Anschluss. (Inherited from RemotePortBase.)

See Also

RemoteOutPort Class
DynamicNode.Ext.Remoting Namespace


RemoteOutPort Methods

[image] [image]

DynamicNodes API
RemoteOutPort Methods
RemoteOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteOutPort type exposes the following members.

Methods

 | Name | Description
Public method | Fire | Gibt die Marke an die verbundenen Eingänge weiter.

See Also

RemoteOutPort Class
DynamicNode.Ext.Remoting Namespace


Fire Method

[image]

DynamicNodes API
RemoteOutPort..::..Fire Method
RemoteOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Marke an die verbundenen Eingänge weiter.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void Fire()
Visual Basic
Public Sub Fire
F#
abstract Fire : unit -> unit
override Fire : unit -> unit

Implements

IRemoteOutPort..::..Fire()()()()

See Also

RemoteOutPort Class
DynamicNode.Ext.Remoting Namespace


RemoteOutPort Properties

[image] [image]

DynamicNodes API
RemoteOutPort Properties
RemoteOutPort Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteOutPort type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from RemotePortBase.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from RemotePortBase.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from RemotePortBase.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from RemotePortBase.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from RemotePortBase.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from RemotePortBase.)

See Also

RemoteOutPort Class
DynamicNode.Ext.Remoting Namespace


RemotePortBase Class

[image]

DynamicNodes API
RemotePortBase Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für Fernsteuerungs-Proxy-Klassen von Anschlüssen.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public abstract class RemotePortBase : IRemotePort
Visual Basic
Public MustInherit Class RemotePortBase _
    Implements IRemotePort
F#
[<AbstractClassAttribute>]
type RemotePortBase =
    class
        interface IRemotePort
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Remoting..::..RemotePortBase
DynamicNode.Ext.Remoting..::..RemoteInPort
DynamicNode.Ext.Remoting..::..RemoteOutPort

See Also

RemotePortBase Members
DynamicNode.Ext.Remoting Namespace


RemotePortBase Members

[image] [image]

DynamicNodes API
RemotePortBase Members
RemotePortBase Class Constructors Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemotePortBase type exposes the following members.

Constructors

 | Name | Description
Protected method | RemotePortBase | Initialisiert eine neue Instanz von RemotePortBase.

Fields

 | Name | Description
Protected field | Port | Der ferngesteuerte Anschluss.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück.
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück.
Public property | Id | Gibt die ID des Anschlusses zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist.
Public property | Name | Gibt den Namen des Anschlusses zurück.
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück.
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück.

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


RemotePortBase Constructor

[image]

DynamicNodes API
RemotePortBase Constructor
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RemotePortBase.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
protected RemotePortBase(
    IPort port
)
Visual Basic
Protected Sub New ( _
    port As IPort _
)
F#
new :
        port:IPort -> RemotePortBase

Parameters

port
Type: DynamicNode.Core..::..IPort
Ein Anschluss.

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


RemotePortBase Fields

[image] [image]

DynamicNodes API
RemotePortBase Fields
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemotePortBase type exposes the following members.

Fields

 | Name | Description
Protected field | Port | Der ferngesteuerte Anschluss.

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


Port Field

[image]

DynamicNodes API
RemotePortBase..::..Port Field
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der ferngesteuerte Anschluss.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
protected readonly IPort Port
Visual Basic
Protected ReadOnly Port As IPort
F#
val Port: IPort

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


RemotePortBase Properties

[image] [image]

DynamicNodes API
RemotePortBase Properties
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemotePortBase type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück.
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück.
Public property | Id | Gibt die ID des Anschlusses zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist.
Public property | Name | Gibt den Namen des Anschlusses zurück.
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück.
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück.

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


ConnectionCount Property

[image]

DynamicNodes API
RemotePortBase..::..ConnectionCount Property
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller Verbindungen mit diesem Port zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int ConnectionCount { get; }
Visual Basic
Public ReadOnly Property ConnectionCount As Integer
    Get
F#
abstract ConnectionCount : int
override ConnectionCount : int

Field Value

Die Anzahl der Verbindungen.

Implements

IRemotePort..::..ConnectionCount

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


Description Property

[image]

DynamicNodes API
RemotePortBase..::..Description Property
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung dieses Anschlusses zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
F#
abstract Description : string
override Description : string

Field Value

Die Beschreibung.

Implements

IRemotePort..::..Description

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


Id Property

[image]

DynamicNodes API
RemotePortBase..::..Id Property
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Anschlusses zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
F#
abstract Id : int
override Id : int

Field Value

Die ID.

Implements

IRemotePort..::..Id

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
RemotePortBase..::..IsDisposed Property
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsDisposed { get; }
Visual Basic
Public ReadOnly Property IsDisposed As Boolean
    Get
F#
abstract IsDisposed : bool
override IsDisposed : bool

Field Value

true, wenn das Objekt freigegeben wurde, andernfalls false.

Implements

IRemotePort..::..IsDisposed

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


IsSuperPort Property

[image]

DynamicNodes API
RemotePortBase..::..IsSuperPort Property
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an oder legt fest ob dieser Port ein Super-Port ist.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsSuperPort { get; }
Visual Basic
Public ReadOnly Property IsSuperPort As Boolean
    Get
F#
abstract IsSuperPort : bool
override IsSuperPort : bool

Field Value

true wenn die Instanz ein Super-Port ist, sonst false.

Implements

IRemotePort..::..IsSuperPort

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


Name Property

[image]

DynamicNodes API
RemotePortBase..::..Name Property
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Anschlusses zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
abstract Name : string
override Name : string

Field Value

Der Name.

Implements

IRemotePort..::..Name

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


ReadCopy Property

[image]

DynamicNodes API
RemotePortBase..::..ReadCopy Property
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Lese-Kopie der aktuellen Marke zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public RemoteToken ReadCopy { get; }
Visual Basic
Public ReadOnly Property ReadCopy As RemoteToken
    Get
F#
abstract ReadCopy : RemoteToken
override ReadCopy : RemoteToken

Field Value

Die Lese-Kopie der aktuellen Marke.

Implements

IRemotePort..::..ReadCopy

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


SuperName Property

[image]

DynamicNodes API
RemotePortBase..::..SuperName Property
RemotePortBase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Super-Name für Modul-Anschlüsse zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string SuperName { get; }
Visual Basic
Public ReadOnly Property SuperName As String
    Get
F#
abstract SuperName : string
override SuperName : string

Field Value

Der Super-Name.

Implements

IRemotePort..::..SuperName

See Also

RemotePortBase Class
DynamicNode.Ext.Remoting Namespace


RemoteRuntime Class

[image]

DynamicNodes API
RemoteRuntime Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Fernsteuerungs-Proxy für eine Laufzeitumgebung.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class RemoteRuntime : IRemoteRuntime
Visual Basic
Public Class RemoteRuntime _
    Implements IRemoteRuntime
F#
type RemoteRuntime =
    class
        interface IRemoteRuntime
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Remoting..::..RemoteRuntime

See Also

RemoteRuntime Members
DynamicNode.Ext.Remoting Namespace


RemoteRuntime Members

[image] [image]

DynamicNodes API
RemoteRuntime Members
RemoteRuntime Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteRuntime type exposes the following members.

Constructors

 | Name | Description
Public method | RemoteRuntime | Initialisiert eine neue Instanz von RemoteRuntime.

Properties

 | Name | Description
Public property | CountGraphs | Gibt die Anzahl der Graphen in der Laufzeitumgebung zurück.
Public property | Graphs | Gibt ein Array mit allen Graphen der Laufzeitumgebung zurück.
Public property | Id | Gibt die ID der Laufzeitumgebung zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen der Laufzeitumgebung zurück.

See Also

RemoteRuntime Class
DynamicNode.Ext.Remoting Namespace


RemoteRuntime Constructor

[image]

DynamicNodes API
RemoteRuntime Constructor
RemoteRuntime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RemoteRuntime.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public RemoteRuntime(
    IRuntime runtime
)
Visual Basic
Public Sub New ( _
    runtime As IRuntime _
)
F#
new :
        runtime:IRuntime -> RemoteRuntime

Parameters

runtime
Type: DynamicNode.Core..::..IRuntime
Eine Laufzeitumgebung.

See Also

RemoteRuntime Class
DynamicNode.Ext.Remoting Namespace


RemoteRuntime Properties

[image] [image]

DynamicNodes API
RemoteRuntime Properties
RemoteRuntime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteRuntime type exposes the following members.

Properties

 | Name | Description
Public property | CountGraphs | Gibt die Anzahl der Graphen in der Laufzeitumgebung zurück.
Public property | Graphs | Gibt ein Array mit allen Graphen der Laufzeitumgebung zurück.
Public property | Id | Gibt die ID der Laufzeitumgebung zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen der Laufzeitumgebung zurück.

See Also

RemoteRuntime Class
DynamicNode.Ext.Remoting Namespace


CountGraphs Property

[image]

DynamicNodes API
RemoteRuntime..::..CountGraphs Property
RemoteRuntime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der Graphen in der Laufzeitumgebung zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int CountGraphs { get; }
Visual Basic
Public ReadOnly Property CountGraphs As Integer
    Get
F#
abstract CountGraphs : int
override CountGraphs : int

Field Value

Die Anzahl der Graphen.

Implements

IRemoteRuntime..::..CountGraphs

See Also

RemoteRuntime Class
DynamicNode.Ext.Remoting Namespace


Graphs Property

[image]

DynamicNodes API
RemoteRuntime..::..Graphs Property
RemoteRuntime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Graphen der Laufzeitumgebung zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public IRemoteGraph[] Graphs { get; }
Visual Basic
Public ReadOnly Property Graphs As IRemoteGraph()
    Get
F#
abstract Graphs : IRemoteGraph[]
override Graphs : IRemoteGraph[]

Field Value

Die Graphen.

Implements

IRemoteRuntime..::..Graphs

See Also

RemoteRuntime Class
DynamicNode.Ext.Remoting Namespace


Id Property

[image]

DynamicNodes API
RemoteRuntime..::..Id Property
RemoteRuntime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID der Laufzeitumgebung zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
F#
abstract Id : int
override Id : int

Field Value

Die ID.

Implements

IRemoteRuntime..::..Id

See Also

RemoteRuntime Class
DynamicNode.Ext.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
RemoteRuntime..::..IsDisposed Property
RemoteRuntime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsDisposed { get; }
Visual Basic
Public ReadOnly Property IsDisposed As Boolean
    Get
F#
abstract IsDisposed : bool
override IsDisposed : bool

Field Value

true, wenn das Objekt freigegeben wurde, andernfalls false.

Implements

IRemoteRuntime..::..IsDisposed

See Also

RemoteRuntime Class
DynamicNode.Ext.Remoting Namespace


Name Property

[image]

DynamicNodes API
RemoteRuntime..::..Name Property
RemoteRuntime Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen der Laufzeitumgebung zurück.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
abstract Name : string
override Name : string

Field Value

Der Name.

Implements

IRemoteRuntime..::..Name

See Also

RemoteRuntime Class
DynamicNode.Ext.Remoting Namespace


ServerContext Class

[image]

DynamicNodes API
ServerContext Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Kontext für die Bereitstellung einer Fernsteuerungsschnittstelle.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class ServerContext
Visual Basic
Public Class ServerContext
F#
type ServerContext =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Remoting..::..ServerContext

See Also

ServerContext Members
DynamicNode.Ext.Remoting Namespace


ServerContext Members

[image] [image]

DynamicNodes API
ServerContext Members
ServerContext Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ServerContext type exposes the following members.

Constructors

 | Name | Description
Public method | ServerContext | Initialisiert eine neue Instanz von ServerContext.

Methods

 | Name | Description
Public method | StartServer | Startet den Server.
Public method | StopServer | Stoppt den Server.

See Also

ServerContext Class
DynamicNode.Ext.Remoting Namespace


ServerContext Constructor

[image]

DynamicNodes API
ServerContext Constructor
ServerContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ServerContext.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public ServerContext(
    IApplicationContext appContext,
    IRuntime runtime
)
Visual Basic
Public Sub New ( _
    appContext As IApplicationContext, _
    runtime As IRuntime _
)
F#
new :
        appContext:IApplicationContext *
        runtime:IRuntime -> ServerContext

Parameters

appContext
Type: DynamicNode.Core..::..IApplicationContext
Der ferngesteuerte Anwendungskontext.
runtime
Type: DynamicNode.Core..::..IRuntime
Die ferngesteurte Laufzeitumgebung.

See Also

ServerContext Class
DynamicNode.Ext.Remoting Namespace


ServerContext Methods

[image] [image]

DynamicNodes API
ServerContext Methods
ServerContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ServerContext type exposes the following members.

Methods

 | Name | Description
Public method | StartServer | Startet den Server.
Public method | StopServer | Stoppt den Server.

See Also

ServerContext Class
DynamicNode.Ext.Remoting Namespace


StartServer Method

[image]

DynamicNodes API
ServerContext..::..StartServer Method
ServerContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Startet den Server.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void StartServer()
Visual Basic
Public Sub StartServer
F#
member StartServer : unit -> unit

See Also

ServerContext Class
DynamicNode.Ext.Remoting Namespace


StopServer Method

[image]

DynamicNodes API
ServerContext..::..StopServer Method
ServerContext Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stoppt den Server.

Namespace: DynamicNode.Ext.Remoting
Assembly: DNExtRemoting (in DNExtRemoting.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void StopServer()
Visual Basic
Public Sub StopServer
F#
member StopServer : unit -> unit

See Also

ServerContext Class
DynamicNode.Ext.Remoting Namespace


DynamicNode.Ext.Visual Namespace

[image]

DynamicNodes API
DynamicNode.Ext.Visual Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält neben vielen Typen, welche für grafische Darstellung und Bearbeitung von Graphen verwendet werden können, eine Anzahl an Basisklassen für die Knotenentwicklung mit grafischer Unterstützung.

Wichtige Typen in diesem Namensraum sind die Basisklassen für die Knotenentwicklung VisualNode und ProgressNode, die Erweiterungen der Datenstruktur von Graphen um visuelle Eigenschaften GraphVisualization, NodeVisualization, PortVisualization und Pin, und einige Typen für die Implementierung eines Editor GraphDocument, Painter, Editor und AbstractTool.

Classes

 | Class | Description
Public class | AbstractTool | Die Basis-Klasse für alle Editor-Werkzeuge.
Public class | DefaultNodeFactory | Die Standardimplementierung der Schnittstelle ICustomNodeFactory für die einfache Erzeugung von Knoten anhand einer Drop-Position im Editor.
Public class | DefaultTheme | Die Standard-Implementierung für ITheme.
Public class | DragAndDropDataParseException | Die Ausnahme, die beim Parsen von fehlerhaften Drag&Drop-Daten ausgelöst wird.
Public class | DragAndDropHelper | Bietet Unterstützung für Drag&Drop-Aktionen zur Erzeugung von Knoten.
Public class | Editor | Die Standard-Implementierung der Schnittstelle IEditor.
Public class | EditorControl | Das Steuerelement, welches die Arbeitsfläche für den visuellen Graphen-Editor darstellt.
Public class | EditorDocumentEventArgs | Die Ereignis-Parameter für ein Graphen-bezogenes Ereignis.
Public class | EditorDragEventArgs | Die Ereignis-Parameter für Drag&Drop-Ereignisse mit Editor-Koordinaten.
Public class | EditorMouseEventArgs | Die Ereignis-Parameter für Mausereignisse mit Editor-Koordinaten.
Public class | EditorNodeEventArgs | Die Ereignis-Parameter für die Änderung der Knotenauswahl.
Public class | EditorNodeSelectionEventArgs | Die Ereignis-Parameter für die Änderung der Knotenauswahl.
Public class | EditorPortEventArgs | Die Ereignis-Parameter für die Veränderung der Portauswahl.
Public class | ExtendedUserControl | Erweitert die Klasse UserControl um KeyPreview-Fähigkeit.
Public class | GraphDocument | Die Standard-Implementierung von IGraphDocument.
Public class | GraphPaintEventArgs | Ereignisdaten für PaintOverlay.
Public class | GraphVisualization | Erweitert ein Graph um die Eigenschaften für eine grafische Darstellung.
Public class | NoBackgroundPanel | Ein Panel welches keinen Hintergund zeichnet.
Public class | NodeControlPanelExtension | Eine Knoten-Erweiterung, welche der Entwicklungsumgebung ein Steuerelement zur Verfügung stellt, mit dem der Benutzer den Knoten steuern kann.
Public class | NodeCreationException | Die Ausnahme, die beim Erzeugen eines Knotens am Ende einer Drag&Drop-Aktion ausgelöst wird.
Public class | NodeVisualization | Erweitert einen Knoten um Eigenschaften und Fähigkeiten zur grafischen Darstellung.
Public class | Painter | Die Standardimplementierung der Schnittstelle IPainter
Public class | PaintSettings | Sammlung mit Parametern für die grafische Ausgabe.
Public class | Pin | Eine optische Umlenkung für eine Verbindung.
Public class | PortVisualization | Die grafischen Eigenschaften eines Ports.
Public class | ProgressNode | Eine Erweiterung des Standard-Basis-Knotens um die Funktionalität einer Statusanzeige.
Public class | SubGraphControlPanel | Eine Knoten-Steuerung für Sub-Graph-Knoten. Diese Steuerung wurde vom Kern in die visuellen Erweiterungen ausgelagert, damit das DNCore-Assembly keine Verweise auf System.Windows.Forms benötigt.
Public class | SubGraphNodeFactory | Erweiterung von DefaultNodeFactory für die Erzeugung von NSubGraph-Knoten und sofortigem Laden eines Moduls.
Public class | ThreadHelper | Eine Klasse mit statischen Hilfsmethoden für den Thread-sicheren Aufruf von Code-Abschnitten zur Manipulation von GUI-Steuerelementen.
Public class | ToolButtonEventArgs | Die Ereignis-Parameter für das Ereignis ToolButtonClick. Es kapselt das Werkzeug welches aktiviert werden soll und die ToolStrip-Taste mit welcher das Eregnis ausgelöst wurde.
Public class | ViewPortExtension | Eine Knotenerweiterung, welche die Entwicklungsumgebung anweist, einen ViewPort für einen Knoten bereitzustellen. In dem ViewPort wird dann ein Steuerelement dargestellt, welches der Knoten zur Verfügung stellt.
Public class | VisualNode | Ein abstracte Ableitung von Node, die mehr Comfort beim Erstellen von visuellen Knoten bietet.

Interfaces

 | Interface | Description
Public interface | IEditor | Eine Schnittstelle für Graph-Editoren. Ein Graph-Editor wird für ein Graph-Dokument erzeugt um dieses zu bearbeiten. Der Editor ist der Übergang zwischen den Bildschirm-Koordinaten des Editor-Streuerelements und den Arbeitsflächen-Koordinaten des Datenmodells in den Graph-, Knoten- und Anschluss-Visualisierungen.
Public interface | IEditorTool | Die Schnittstelle für Editor-Werkzeuge. Editor-Werkzeuge können die Ereignisse eines Graph-Dokuments konsumieren und das Datenmodell daraufhin bearbeiten.
Public interface | IGraphDocument | Das Daten-Modell für einen Graph-Editor.
Public interface | IPainter | Ein Objekt, welches diese Schnittstelle implementiert, kann ein Graph zeichnen.
Public interface | IPaintProperties | Eine Schnittstelle, die Zeichenressourcen für den Arbeitsbereich anbietet.
Public interface | ITheme | Ein Interface, welches von Klassen implementiert werden muss, die eine grafische Ausgabe für ein DynamicNode-Graph zur Verfügung stellen wollen.

Delegates

 | Delegate | Description
Public delegate | GenericDelegate<(Of <(<'T>)>)> | Ein generisches Delegate mit einem T Parameter für die Verwendung mit ThreadHelper.
Public delegate | MultiGenericDelegate<(Of <(<'T>)>)> | Ein generisches Delegate mit beliebigen Parametern vom Typ T für die Verwendung mit ThreadHelper.
Public delegate | NodeCreationCallback | Ein Callback-Delegate welches aufgerufen wird wenn ein Knoten erfolgreich erstellt wurde.
Public delegate | NodePaintHandler | Ein Handler für das Zeichnen eines Knotens.

Enumerations

 | Enumeration | Description
Public enumeration | ConnectionStyle | Die verschiedenen Stile für die Darstellung von Verbindungen.
Public enumeration | NodeShaddowStyle | Die verschiedenen Stile für den Knotenschatten.
Public enumeration | PinPositionMode | Die Positions-Modi für einen Pin
Public enumeration | PortOrientation | Die grafische Ausrichtung eines Ports relativ zum Knoten.
Public enumeration | PortStyle | Die verschiedenen Stile für die Darstellung von Anschlüssen.
Public enumeration | ThemeColor | Die Kennzeichnungen der verschiedenen Stilfarben für die Graphendarstellung.
Public enumeration | ThemeDimension | Die Kennzeichnungen für die verschiedenen Größen der Graphendarstellung.
Public enumeration | ThemeFont | Die Kennzeichnungen der verschiedenen Fonts für die Graphendarstellung.
Public enumeration | ThemePalette | Eine Aufzählung der Farbpaletten der Graphendarstellung.
Public enumeration | WorkspaceBackgroundStyle | Die verschiedenen Stile für den Hintergrund der Arbeitsfläche.


AbstractTool Class

[image]

DynamicNodes API
AbstractTool Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basis-Klasse für alle Editor-Werkzeuge.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public abstract class AbstractTool : IEditorTool
Visual Basic
Public MustInherit Class AbstractTool _
    Implements IEditorTool
F#
[<AbstractClassAttribute>]
type AbstractTool =
    class
        interface IEditorTool
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..AbstractTool

See Also

AbstractTool Members
DynamicNode.Ext.Visual Namespace


AbstractTool Members

[image] [image]

DynamicNodes API
AbstractTool Members
AbstractTool Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractTool type exposes the following members.

Constructors

 | Name | Description
Protected method | AbstractTool | Initializes a new instance of the AbstractTool class

Methods

 | Name | Description
Public method | Activate | Aktiviert das Werkzeug. Dabei können verschiedene Ereignisse vom Editor-Steuerelement gebunden werden.
Public method | Deactivate | Deaktiviert das Werkzeug. Dabei müssen die gebundenen Ereignisse wieder freigegeben werden.
Public method | GetNewInstance | Erzeugt eine neue Instanz des Werkzeugs.
Protected method | GraphDocument_MouseDoubleClick | Verarbeitet das MouseDoubleClick-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseDown | Verarbeitet das MouseDown-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseEnter | Verarbeitet das MouseEnter-Ereignis das Graph-Dokuments.
Protected method | GraphDocument_MouseLeave | Verarbeitet das MouseLeave-Ereignis das Graph-Dokuments.
Protected method | GraphDocument_MouseMove | Verarbeitet das MouseMove-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseNodeEnter | Verarbeitet das MouseNodeEnter-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseNodeLeave | Verarbeitet das MouseNodeLeave-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MousePortEnter | Verarbeitet das MousePortEnter-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MousePortLeave | Verarbeitet das MousePortLeave-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseUp | Verarbeitet das MouseUp-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseWheel | Verarbeitet das MouseWheel-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_NodeHelp | Verarbeitet das NodeHelp-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_NodeSelect | Verarbeitet das NodeSelect-Ereignis des Graph-Dokuments.
Protected method | Painter_PaintOverlay | Verarbeitet das PaintOverlay-Ereignis des Editorzeichners.

Fields

 | Name | Description
Protected field | doc | Der Graph-Dokument, auf dem das Werkzeug arbeitet.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung des Werkzeugs zurück.
Public property | Description | Gibt die Beschreibung des Werkzeugs zurück.
Public property | Icon | Gibt das Icon des Werkzeugs zurück.
Public property | ToolCursor | Gibt den Cursor des Werkzeugs zurück.

Events

 | Name | Description
Public event | ToolCursorChanged | Tritt auf wenn sich der Cursor des Werkzeugs geändert hat.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


AbstractTool Constructor

[image]

DynamicNodes API
AbstractTool Constructor
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the AbstractTool class

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected AbstractTool()
Visual Basic
Protected Sub New
F#
new : unit -> AbstractTool

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


AbstractTool Fields

[image] [image]

DynamicNodes API
AbstractTool Fields
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractTool type exposes the following members.

Fields

 | Name | Description
Protected field | doc | Der Graph-Dokument, auf dem das Werkzeug arbeitet.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


doc Field

[image]

DynamicNodes API
AbstractTool..::..doc Field
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Graph-Dokument, auf dem das Werkzeug arbeitet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected IGraphDocument doc
Visual Basic
Protected doc As IGraphDocument
F#
val mutable doc: IGraphDocument

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


AbstractTool Methods

[image] [image]

DynamicNodes API
AbstractTool Methods
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractTool type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert das Werkzeug. Dabei können verschiedene Ereignisse vom Editor-Steuerelement gebunden werden.
Public method | Deactivate | Deaktiviert das Werkzeug. Dabei müssen die gebundenen Ereignisse wieder freigegeben werden.
Public method | GetNewInstance | Erzeugt eine neue Instanz des Werkzeugs.
Protected method | GraphDocument_MouseDoubleClick | Verarbeitet das MouseDoubleClick-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseDown | Verarbeitet das MouseDown-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseEnter | Verarbeitet das MouseEnter-Ereignis das Graph-Dokuments.
Protected method | GraphDocument_MouseLeave | Verarbeitet das MouseLeave-Ereignis das Graph-Dokuments.
Protected method | GraphDocument_MouseMove | Verarbeitet das MouseMove-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseNodeEnter | Verarbeitet das MouseNodeEnter-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseNodeLeave | Verarbeitet das MouseNodeLeave-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MousePortEnter | Verarbeitet das MousePortEnter-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MousePortLeave | Verarbeitet das MousePortLeave-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseUp | Verarbeitet das MouseUp-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_MouseWheel | Verarbeitet das MouseWheel-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_NodeHelp | Verarbeitet das NodeHelp-Ereignis des Graph-Dokuments.
Protected method | GraphDocument_NodeSelect | Verarbeitet das NodeSelect-Ereignis des Graph-Dokuments.
Protected method | Painter_PaintOverlay | Verarbeitet das PaintOverlay-Ereignis des Editorzeichners.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


Activate Method

[image]

DynamicNodes API
AbstractTool..::..Activate Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert das Werkzeug. Dabei können verschiedene Ereignisse vom Editor-Steuerelement gebunden werden.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void Activate(
    IGraphDocument document
)
Visual Basic
Public Overridable Sub Activate ( _
    document As IGraphDocument _
)
F#
abstract Activate :
        document:IGraphDocument -> unit
override Activate :
        document:IGraphDocument -> unit

Parameters

document
Type: DynamicNode.Ext.Visual..::..IGraphDocument
Der Graph-Dokument.

Implements

IEditorTool..::..Activate(IGraphDocument)

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


Deactivate Method

[image]

DynamicNodes API
AbstractTool..::..Deactivate Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Deaktiviert das Werkzeug. Dabei müssen die gebundenen Ereignisse wieder freigegeben werden.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void Deactivate()
Visual Basic
Public Overridable Sub Deactivate
F#
abstract Deactivate : unit -> unit
override Deactivate : unit -> unit

Implements

IEditorTool..::..Deactivate()()()()

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GetNewInstance Method

[image]

DynamicNodes API
AbstractTool..::..GetNewInstance Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine neue Instanz des Werkzeugs.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public abstract IEditorTool GetNewInstance()
Visual Basic
Public MustOverride Function GetNewInstance As IEditorTool
F#
abstract GetNewInstance : unit -> IEditorTool

Return Value

Eine neue Instanz des Werkzeugs.

Implements

IEditorTool..::..GetNewInstance()()()()

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MouseDoubleClick Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MouseDoubleClick Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MouseDoubleClick-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MouseDoubleClick(
    Object sender,
    EditorMouseEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MouseDoubleClick ( _
    sender As Object, _
    e As EditorMouseEventArgs _
)
F#
abstract GraphDocument_MouseDoubleClick :
        sender:Object *
        e:EditorMouseEventArgs -> unit
override GraphDocument_MouseDoubleClick :
        sender:Object *
        e:EditorMouseEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MouseDown Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MouseDown Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MouseDown-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MouseDown(
    Object sender,
    EditorMouseEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MouseDown ( _
    sender As Object, _
    e As EditorMouseEventArgs _
)
F#
abstract GraphDocument_MouseDown :
        sender:Object *
        e:EditorMouseEventArgs -> unit
override GraphDocument_MouseDown :
        sender:Object *
        e:EditorMouseEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MouseEnter Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MouseEnter Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MouseEnter-Ereignis das Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MouseEnter(
    Object sender,
    EventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MouseEnter ( _
    sender As Object, _
    e As EventArgs _
)
F#
abstract GraphDocument_MouseEnter :
        sender:Object *
        e:EventArgs -> unit
override GraphDocument_MouseEnter :
        sender:Object *
        e:EventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: System..::..EventArgs
Eine EventArgs-Instanz.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MouseLeave Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MouseLeave Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MouseLeave-Ereignis das Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MouseLeave(
    Object sender,
    EventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MouseLeave ( _
    sender As Object, _
    e As EventArgs _
)
F#
abstract GraphDocument_MouseLeave :
        sender:Object *
        e:EventArgs -> unit
override GraphDocument_MouseLeave :
        sender:Object *
        e:EventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: System..::..EventArgs
Eine EventArgs-Instanz.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MouseMove Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MouseMove Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MouseMove-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MouseMove(
    Object sender,
    EditorMouseEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MouseMove ( _
    sender As Object, _
    e As EditorMouseEventArgs _
)
F#
abstract GraphDocument_MouseMove :
        sender:Object *
        e:EditorMouseEventArgs -> unit
override GraphDocument_MouseMove :
        sender:Object *
        e:EditorMouseEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MouseNodeEnter Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MouseNodeEnter Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MouseNodeEnter-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MouseNodeEnter(
    Object sender,
    EditorNodeEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MouseNodeEnter ( _
    sender As Object, _
    e As EditorNodeEventArgs _
)
F#
abstract GraphDocument_MouseNodeEnter :
        sender:Object *
        e:EditorNodeEventArgs -> unit
override GraphDocument_MouseNodeEnter :
        sender:Object *
        e:EditorNodeEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MouseNodeLeave Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MouseNodeLeave Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MouseNodeLeave-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MouseNodeLeave(
    Object sender,
    EditorNodeEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MouseNodeLeave ( _
    sender As Object, _
    e As EditorNodeEventArgs _
)
F#
abstract GraphDocument_MouseNodeLeave :
        sender:Object *
        e:EditorNodeEventArgs -> unit
override GraphDocument_MouseNodeLeave :
        sender:Object *
        e:EditorNodeEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MousePortEnter Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MousePortEnter Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MousePortEnter-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MousePortEnter(
    Object sender,
    EditorPortEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MousePortEnter ( _
    sender As Object, _
    e As EditorPortEventArgs _
)
F#
abstract GraphDocument_MousePortEnter :
        sender:Object *
        e:EditorPortEventArgs -> unit
override GraphDocument_MousePortEnter :
        sender:Object *
        e:EditorPortEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorPortEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MousePortLeave Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MousePortLeave Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MousePortLeave-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MousePortLeave(
    Object sender,
    EditorPortEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MousePortLeave ( _
    sender As Object, _
    e As EditorPortEventArgs _
)
F#
abstract GraphDocument_MousePortLeave :
        sender:Object *
        e:EditorPortEventArgs -> unit
override GraphDocument_MousePortLeave :
        sender:Object *
        e:EditorPortEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorPortEventArgs
Eine EditorPortEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MouseUp Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MouseUp Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MouseUp-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MouseUp(
    Object sender,
    EditorMouseEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MouseUp ( _
    sender As Object, _
    e As EditorMouseEventArgs _
)
F#
abstract GraphDocument_MouseUp :
        sender:Object *
        e:EditorMouseEventArgs -> unit
override GraphDocument_MouseUp :
        sender:Object *
        e:EditorMouseEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_MouseWheel Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_MouseWheel Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das MouseWheel-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_MouseWheel(
    Object sender,
    EditorMouseEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_MouseWheel ( _
    sender As Object, _
    e As EditorMouseEventArgs _
)
F#
abstract GraphDocument_MouseWheel :
        sender:Object *
        e:EditorMouseEventArgs -> unit
override GraphDocument_MouseWheel :
        sender:Object *
        e:EditorMouseEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_NodeHelp Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_NodeHelp Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das NodeHelp-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_NodeHelp(
    Object sender,
    EditorNodeEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_NodeHelp ( _
    sender As Object, _
    e As EditorNodeEventArgs _
)
F#
abstract GraphDocument_NodeHelp :
        sender:Object *
        e:EditorNodeEventArgs -> unit
override GraphDocument_NodeHelp :
        sender:Object *
        e:EditorNodeEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


GraphDocument_NodeSelect Method

[image]

DynamicNodes API
AbstractTool..::..GraphDocument_NodeSelect Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das NodeSelect-Ereignis des Graph-Dokuments.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void GraphDocument_NodeSelect(
    Object sender,
    EditorNodeSelectionEventArgs e
)
Visual Basic
Protected Overridable Sub GraphDocument_NodeSelect ( _
    sender As Object, _
    e As EditorNodeSelectionEventArgs _
)
F#
abstract GraphDocument_NodeSelect :
        sender:Object *
        e:EditorNodeSelectionEventArgs -> unit
override GraphDocument_NodeSelect :
        sender:Object *
        e:EditorNodeSelectionEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..EditorNodeSelectionEventArgs
Eine EditorNodeSelectionEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


Painter_PaintOverlay Method

[image]

DynamicNodes API
AbstractTool..::..Painter_PaintOverlay Method
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verarbeitet das PaintOverlay-Ereignis des Editorzeichners.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void Painter_PaintOverlay(
    Object sender,
    GraphPaintEventArgs e
)
Visual Basic
Protected Overridable Sub Painter_PaintOverlay ( _
    sender As Object, _
    e As GraphPaintEventArgs _
)
F#
abstract Painter_PaintOverlay :
        sender:Object *
        e:GraphPaintEventArgs -> unit
override Painter_PaintOverlay :
        sender:Object *
        e:GraphPaintEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Ursprung des Ereignisses.
e
Type: DynamicNode.Ext.Visual..::..GraphPaintEventArgs
Eine GraphPaintEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


AbstractTool Properties

[image] [image]

DynamicNodes API
AbstractTool Properties
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractTool type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung des Werkzeugs zurück.
Public property | Description | Gibt die Beschreibung des Werkzeugs zurück.
Public property | Icon | Gibt das Icon des Werkzeugs zurück.
Public property | ToolCursor | Gibt den Cursor des Werkzeugs zurück.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


Caption Property

[image]

DynamicNodes API
AbstractTool..::..Caption Property
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung des Werkzeugs zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public abstract string Caption { get; }
Visual Basic
Public MustOverride ReadOnly Property Caption As String
    Get
F#
abstract Caption : string

Field Value

Die Beschriftung.

Implements

IEditorTool..::..Caption

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


Description Property

[image]

DynamicNodes API
AbstractTool..::..Description Property
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Werkzeugs zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public abstract string Description { get; }
Visual Basic
Public MustOverride ReadOnly Property Description As String
    Get
F#
abstract Description : string

Field Value

Die Beschreibung.

Implements

IEditorTool..::..Description

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


Icon Property

[image]

DynamicNodes API
AbstractTool..::..Icon Property
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Icon des Werkzeugs zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public abstract Image Icon { get; }
Visual Basic
Public MustOverride ReadOnly Property Icon As Image
    Get
F#
abstract Icon : Image

Field Value

Das Icon.

Implements

IEditorTool..::..Icon

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


ToolCursor Property

[image]

DynamicNodes API
AbstractTool..::..ToolCursor Property
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Cursor des Werkzeugs zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Cursor ToolCursor { get; set; }
Visual Basic
Public Property ToolCursor As Cursor
    Get
    Set
F#
abstract ToolCursor : Cursor with get, set
override ToolCursor : Cursor with get, set

Implements

IEditorTool..::..ToolCursor

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


AbstractTool Events

[image] [image]

DynamicNodes API
AbstractTool Events
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractTool type exposes the following members.

Events

 | Name | Description
Public event | ToolCursorChanged | Tritt auf wenn sich der Cursor des Werkzeugs geändert hat.

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


ToolCursorChanged Event

[image]

DynamicNodes API
AbstractTool..::..ToolCursorChanged Event
AbstractTool Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn sich der Cursor des Werkzeugs geändert hat.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler ToolCursorChanged
Visual Basic
Public Event ToolCursorChanged As EventHandler
F#
abstract ToolCursorChanged : IEvent<EventHandler,
    EventArgs>
override ToolCursorChanged : IEvent<EventHandler,
    EventArgs>

Implements

IEditorTool..::..ToolCursorChanged

See Also

AbstractTool Class
DynamicNode.Ext.Visual Namespace


ConnectionStyle Enumeration

[image]

DynamicNodes API
ConnectionStyle Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die verschiedenen Stile für die Darstellung von Verbindungen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public enum ConnectionStyle
Visual Basic
Public Enumeration ConnectionStyle
F#
type ConnectionStyle

Members

Member name | Description
Linear |
Rectangular |
BezierCurve |

See Also

DynamicNode.Ext.Visual Namespace


DefaultNodeFactory Class

[image]

DynamicNodes API
DefaultNodeFactory Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardimplementierung der Schnittstelle ICustomNodeFactory für die einfache Erzeugung von Knoten anhand einer Drop-Position im Editor.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class DefaultNodeFactory : ICustomNodeFactory
Visual Basic
Public Class DefaultNodeFactory _
    Implements ICustomNodeFactory
F#
type DefaultNodeFactory =
    class
        interface ICustomNodeFactory
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..DefaultNodeFactory
DynamicNode.Ext.Visual..::..SubGraphNodeFactory

See Also

DefaultNodeFactory Members
DynamicNode.Ext.Visual Namespace


DefaultNodeFactory Members

[image] [image]

DynamicNodes API
DefaultNodeFactory Members
DefaultNodeFactory Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DefaultNodeFactory type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultNodeFactory | Initialisiert eine neue Instanz von DefaultNodeFactory.

Methods

 | Name | Description
Public method | CreateNode | Erzeugt einen neuen Knoten.
Public method | GetVariations | Gibt alle möglichen Variationen für diese Factory zurück.

Properties

 | Name | Description
Public property | DefaultFactory | Gibt die Standard-Knoten-Factory zurück, die von der Laufzeitumgebung verwendet wird.
Public property | NodeType | Gibt den Knotentyp zurück, den diese Factory erzeugen kann.

See Also

DefaultNodeFactory Class
DynamicNode.Ext.Visual Namespace


DefaultNodeFactory Constructor

[image]

DynamicNodes API
DefaultNodeFactory Constructor
DefaultNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von DefaultNodeFactory.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public DefaultNodeFactory(
    Type nodeType,
    NodeFactory defaultFactory
)
Visual Basic
Public Sub New ( _
    nodeType As Type, _
    defaultFactory As NodeFactory _
)
F#
new :
        nodeType:Type *
        defaultFactory:NodeFactory -> DefaultNodeFactory

Parameters

nodeType
Type: System..::..Type
Der Type des zu erzeugenden Knotens.
defaultFactory
Type: DynamicNode.Core..::..NodeFactory
Die Standard-Knoten-Factory, die von der Laufzeitumgebung verwendet wird.

See Also

DefaultNodeFactory Class
DynamicNode.Ext.Visual Namespace


DefaultNodeFactory Methods

[image] [image]

DynamicNodes API
DefaultNodeFactory Methods
DefaultNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DefaultNodeFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateNode | Erzeugt einen neuen Knoten.
Public method | GetVariations | Gibt alle möglichen Variationen für diese Factory zurück.

See Also

DefaultNodeFactory Class
DynamicNode.Ext.Visual Namespace


CreateNode Method

[image]

DynamicNodes API
DefaultNodeFactory..::..CreateNode Method
DefaultNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt einen neuen Knoten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual INode CreateNode(
    CustomNodeFactoryVariation variation
)
Visual Basic
Public Overridable Function CreateNode ( _
    variation As CustomNodeFactoryVariation _
) As INode
F#
abstract CreateNode :
        variation:CustomNodeFactoryVariation -> INode
override CreateNode :
        variation:CustomNodeFactoryVariation -> INode

Parameters

variation
Type: DynamicNode.Core..::..CustomNodeFactoryVariation
Eine Factory-Variation.

Return Value

Der erzeugte Knoten.

Implements

ICustomNodeFactory..::..CreateNode(CustomNodeFactoryVariation)

See Also

DefaultNodeFactory Class
DynamicNode.Ext.Visual Namespace


GetVariations Method

[image]

DynamicNodes API
DefaultNodeFactory..::..GetVariations Method
DefaultNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle möglichen Variationen für diese Factory zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual IEnumerable<CustomNodeFactoryVariation> GetVariations()
Visual Basic
Public Overridable Function GetVariations As IEnumerable(Of CustomNodeFactoryVariation)
F#
abstract GetVariations : unit -> IEnumerable<CustomNodeFactoryVariation>
override GetVariations : unit -> IEnumerable<CustomNodeFactoryVariation>

Return Value

[Missing <returns> documentation for "M:DynamicNode.Ext.Visual.DefaultNodeFactory.GetVariations"]

Implements

ICustomNodeFactory..::..GetVariations()()()()

See Also

DefaultNodeFactory Class
DynamicNode.Ext.Visual Namespace


DefaultNodeFactory Properties

[image] [image]

DynamicNodes API
DefaultNodeFactory Properties
DefaultNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DefaultNodeFactory type exposes the following members.

Properties

 | Name | Description
Public property | DefaultFactory | Gibt die Standard-Knoten-Factory zurück, die von der Laufzeitumgebung verwendet wird.
Public property | NodeType | Gibt den Knotentyp zurück, den diese Factory erzeugen kann.

See Also

DefaultNodeFactory Class
DynamicNode.Ext.Visual Namespace


DefaultFactory Property

[image]

DynamicNodes API
DefaultNodeFactory..::..DefaultFactory Property
DefaultNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Standard-Knoten-Factory zurück, die von der Laufzeitumgebung verwendet wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NodeFactory DefaultFactory { get; private set; }
Visual Basic
Public Property DefaultFactory As NodeFactory
    Get
    Private Set
F#
member DefaultFactory : NodeFactory with get, private set

Field Value

Die Standard-Knoten-Factory.

See Also

DefaultNodeFactory Class
DynamicNode.Ext.Visual Namespace


NodeType Property

[image]

DynamicNodes API
DefaultNodeFactory..::..NodeType Property
DefaultNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Knotentyp zurück, den diese Factory erzeugen kann.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Type NodeType { get; private set; }
Visual Basic
Public Property NodeType As Type
    Get
    Private Set
F#
member NodeType : Type with get, private set

Field Value

The type of the node.

See Also

DefaultNodeFactory Class
DynamicNode.Ext.Visual Namespace


DefaultTheme Class

[image]

DynamicNodes API
DefaultTheme Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standard-Implementierung für ITheme.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class DefaultTheme : ITheme,
    IDisposable
Visual Basic
Public Class DefaultTheme _
    Implements ITheme, IDisposable
F#
type DefaultTheme =
    class
        interface ITheme
        interface IDisposable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..DefaultTheme

See Also

DefaultTheme Members
DynamicNode.Ext.Visual Namespace


DefaultTheme Members

[image] [image]

DynamicNodes API
DefaultTheme Members
DefaultTheme Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DefaultTheme type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultTheme | Initialisiert eine DefaultTheme-Instanz.

Methods

 | Name | Description
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.
Protected method | Draw3DBorder | Zeichnet einen 3D-Rahmen.
Public method | DrawBackground | Zeichnet den Hintergrund der Arbeitsfläche.
Public method | DrawConnection(Graphics, PortVisualization, PortVisualization, Boolean) | Zeichnet eine Verbindung.
Public method | DrawConnection(Graphics, PortVisualization, Single, Single) | Zeichnet eine unfertige Verbindung.
Public method | DrawNode | Zeichnet einen Knoten.
Public method | DrawNodeCustomArea | Zeichnet den benutzerdefinierten Bereich eines Knotens.
Public method | DrawPin | Zeichnet einen Pin.
Public method | DrawPort | Zeichnet einen Port.
Public method | DrawSelectionRectangle | Zeichnet ein Auswahlrechteck.
Protected method | Finalize | Gibt Ressourcen frei wenn das DefaultTheme-Objekt von der Garbage-Collection eingesammelt wird. (Overrides Object..::..Finalize()()()().)

Properties

 | Name | Description
Public property | PaintSettings | Liest oder schreibt die Einstellungen für die Darstellung.

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


DefaultTheme Constructor

[image]

DynamicNodes API
DefaultTheme Constructor
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine DefaultTheme-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public DefaultTheme()
Visual Basic
Public Sub New
F#
new : unit -> DefaultTheme

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


DefaultTheme Methods

[image] [image]

DynamicNodes API
DefaultTheme Methods
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DefaultTheme type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.
Protected method | Draw3DBorder | Zeichnet einen 3D-Rahmen.
Public method | DrawBackground | Zeichnet den Hintergrund der Arbeitsfläche.
Public method | DrawConnection(Graphics, PortVisualization, PortVisualization, Boolean) | Zeichnet eine Verbindung.
Public method | DrawConnection(Graphics, PortVisualization, Single, Single) | Zeichnet eine unfertige Verbindung.
Public method | DrawNode | Zeichnet einen Knoten.
Public method | DrawNodeCustomArea | Zeichnet den benutzerdefinierten Bereich eines Knotens.
Public method | DrawPin | Zeichnet einen Pin.
Public method | DrawPort | Zeichnet einen Port.
Public method | DrawSelectionRectangle | Zeichnet ein Auswahlrechteck.
Protected method | Finalize | Gibt Ressourcen frei wenn das DefaultTheme-Objekt von der Garbage-Collection eingesammelt wird. (Overrides Object..::..Finalize()()()().)

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


Dispose Method

[image]

DynamicNodes API
DefaultTheme..::..Dispose Method
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
F#
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposable..::..Dispose()()()()

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


Draw3DBorder Method

[image]

DynamicNodes API
DefaultTheme..::..Draw3DBorder Method
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet einen 3D-Rahmen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void Draw3DBorder(
    Graphics g,
    RectangleF r,
    Color back,
    Color c1,
    Color c2,
    float bw
)
Visual Basic
Protected Overridable Sub Draw3DBorder ( _
    g As Graphics, _
    r As RectangleF, _
    back As Color, _
    c1 As Color, _
    c2 As Color, _
    bw As Single _
)
F#
abstract Draw3DBorder :
        g:Graphics *
        r:RectangleF *
        back:Color *
        c1:Color *
        c2:Color *
        bw:float32 -> unit
override Draw3DBorder :
        g:Graphics *
        r:RectangleF *
        back:Color *
        c1:Color *
        c2:Color *
        bw:float32 -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
r
Type: System.Drawing..::..RectangleF
Ein Rechteck für den Rahmen.
back
Type: System.Drawing..::..Color
Die Farbe des Hintergrundes.
c1
Type: System.Drawing..::..Color
Die Highlightfarbe.
c2
Type: System.Drawing..::..Color
Die Schattenfarbe
bw
Type: System..::..Single
Die Rahmenstärke

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


DrawBackground Method

[image]

DynamicNodes API
DefaultTheme..::..DrawBackground Method
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet den Hintergrund der Arbeitsfläche.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void DrawBackground(
    Graphics g
)
Visual Basic
Public Overridable Sub DrawBackground ( _
    g As Graphics _
)
F#
abstract DrawBackground :
        g:Graphics -> unit
override DrawBackground :
        g:Graphics -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.

Implements

ITheme..::..DrawBackground(Graphics)

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


DrawConnection Method

[image] [image]

DynamicNodes API
DefaultTheme..::..DrawConnection Method
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | DrawConnection(Graphics, PortVisualization, PortVisualization, Boolean) | Zeichnet eine Verbindung.
Public method | DrawConnection(Graphics, PortVisualization, Single, Single) | Zeichnet eine unfertige Verbindung.

See Also

DefaultTheme Class
DefaultTheme Members
DynamicNode.Ext.Visual Namespace


DrawConnection Method (Graphics, PortVisualization, PortVisualization, Boolean)

[image]

DynamicNodes API
DefaultTheme..::..DrawConnection Method (Graphics, PortVisualization, PortVisualization, Boolean)
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet eine Verbindung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void DrawConnection(
    Graphics g,
    PortVisualization iPVis,
    PortVisualization oPVis,
    bool selected
)
Visual Basic
Public Overridable Sub DrawConnection ( _
    g As Graphics, _
    iPVis As PortVisualization, _
    oPVis As PortVisualization, _
    selected As Boolean _
)
F#
abstract DrawConnection :
        g:Graphics *
        iPVis:PortVisualization *
        oPVis:PortVisualization *
        selected:bool -> unit
override DrawConnection :
        g:Graphics *
        iPVis:PortVisualization *
        oPVis:PortVisualization *
        selected:bool -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
iPVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Eingangs-Port-Visualisierung.
oPVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Ausgangs-Port-Visualisierung.
selected
Type: System..::..Boolean
Wenn true, wird die Verbindung farblich hervorgehoben.

Implements

ITheme..::..DrawConnection(Graphics, PortVisualization, PortVisualization, Boolean)

See Also

DefaultTheme Class
DrawConnection Overload
DynamicNode.Ext.Visual Namespace


DrawConnection Method (Graphics, PortVisualization, Single, Single)

[image]

DynamicNodes API
DefaultTheme..::..DrawConnection Method (Graphics, PortVisualization, Single, Single)
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet eine unfertige Verbindung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void DrawConnection(
    Graphics g,
    PortVisualization pVis,
    float x,
    float y
)
Visual Basic
Public Overridable Sub DrawConnection ( _
    g As Graphics, _
    pVis As PortVisualization, _
    x As Single, _
    y As Single _
)
F#
abstract DrawConnection :
        g:Graphics *
        pVis:PortVisualization *
        x:float32 *
        y:float32 -> unit
override DrawConnection :
        g:Graphics *
        pVis:PortVisualization *
        x:float32 *
        y:float32 -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
pVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Port-Visualisierung.
x
Type: System..::..Single
Die WorkspaceX-Koordinate des offenen Endes.
y
Type: System..::..Single
Die WorkspaceY-Koordinate des offenen Endes.

Implements

ITheme..::..DrawConnection(Graphics, PortVisualization, Single, Single)

See Also

DefaultTheme Class
DrawConnection Overload
DynamicNode.Ext.Visual Namespace


DrawNode Method

[image]

DynamicNodes API
DefaultTheme..::..DrawNode Method
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet einen Knoten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void DrawNode(
    Graphics g,
    NodeVisualization nodeVis,
    bool selected,
    bool secondarySelected
)
Visual Basic
Public Overridable Sub DrawNode ( _
    g As Graphics, _
    nodeVis As NodeVisualization, _
    selected As Boolean, _
    secondarySelected As Boolean _
)
F#
abstract DrawNode :
        g:Graphics *
        nodeVis:NodeVisualization *
        selected:bool *
        secondarySelected:bool -> unit
override DrawNode :
        g:Graphics *
        nodeVis:NodeVisualization *
        selected:bool *
        secondarySelected:bool -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
nodeVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.
selected
Type: System..::..Boolean
Wenn true wird der Knoten als "ausgewählt" gezeichnet.
secondarySelected
Type: System..::..Boolean
Wenn true wird der Knoten als "in der ausgewählten Gruppe" gezeichnet.

Implements

ITheme..::..DrawNode(Graphics, NodeVisualization, Boolean, Boolean)

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


DrawNodeCustomArea Method

[image]

DynamicNodes API
DefaultTheme..::..DrawNodeCustomArea Method
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet den benutzerdefinierten Bereich eines Knotens.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void DrawNodeCustomArea(
    Graphics g,
    NodeVisualization nodeVis
)
Visual Basic
Public Overridable Sub DrawNodeCustomArea ( _
    g As Graphics, _
    nodeVis As NodeVisualization _
)
F#
abstract DrawNodeCustomArea :
        g:Graphics *
        nodeVis:NodeVisualization -> unit
override DrawNodeCustomArea :
        g:Graphics *
        nodeVis:NodeVisualization -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
nodeVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Der Knoten-Visualisierer.

Implements

ITheme..::..DrawNodeCustomArea(Graphics, NodeVisualization)

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


DrawPin Method

[image]

DynamicNodes API
DefaultTheme..::..DrawPin Method
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet einen Pin.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void DrawPin(
    Graphics g,
    Pin pin,
    bool selected
)
Visual Basic
Public Overridable Sub DrawPin ( _
    g As Graphics, _
    pin As Pin, _
    selected As Boolean _
)
F#
abstract DrawPin :
        g:Graphics *
        pin:Pin *
        selected:bool -> unit
override DrawPin :
        g:Graphics *
        pin:Pin *
        selected:bool -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
pin
Type: DynamicNode.Ext.Visual..::..Pin
Der Pin.
selected
Type: System..::..Boolean
Wenn true, wird der Pin farblich hervorgehoben.

Implements

ITheme..::..DrawPin(Graphics, Pin, Boolean)

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


DrawPort Method

[image]

DynamicNodes API
DefaultTheme..::..DrawPort Method
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet einen Port.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void DrawPort(
    Graphics g,
    PortVisualization portVis,
    bool disabled
)
Visual Basic
Public Overridable Sub DrawPort ( _
    g As Graphics, _
    portVis As PortVisualization, _
    disabled As Boolean _
)
F#
abstract DrawPort :
        g:Graphics *
        portVis:PortVisualization *
        disabled:bool -> unit
override DrawPort :
        g:Graphics *
        portVis:PortVisualization *
        disabled:bool -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
portVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Port-Visualisierung.
disabled
Type: System..::..Boolean
Wenn true, wird der Port als "nicht verfügbar" gezeichnet.

Implements

ITheme..::..DrawPort(Graphics, PortVisualization, Boolean)

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


DrawSelectionRectangle Method

[image]

DynamicNodes API
DefaultTheme..::..DrawSelectionRectangle Method
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet ein Auswahlrechteck.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void DrawSelectionRectangle(
    Graphics g,
    RectangleF rect
)
Visual Basic
Public Sub DrawSelectionRectangle ( _
    g As Graphics, _
    rect As RectangleF _
)
F#
abstract DrawSelectionRectangle :
        g:Graphics *
        rect:RectangleF -> unit
override DrawSelectionRectangle :
        g:Graphics *
        rect:RectangleF -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
rect
Type: System.Drawing..::..RectangleF
Das Rechteck.

Implements

ITheme..::..DrawSelectionRectangle(Graphics, RectangleF)

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


Finalize Method

[image]

DynamicNodes API
DefaultTheme..::..Finalize Method
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt Ressourcen frei wenn das DefaultTheme-Objekt von der Garbage-Collection eingesammelt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
F#
abstract Finalize : unit -> unit
override Finalize : unit -> unit

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


DefaultTheme Properties

[image] [image]

DynamicNodes API
DefaultTheme Properties
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DefaultTheme type exposes the following members.

Properties

 | Name | Description
Public property | PaintSettings | Liest oder schreibt die Einstellungen für die Darstellung.

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


PaintSettings Property

[image]

DynamicNodes API
DefaultTheme..::..PaintSettings Property
DefaultTheme Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die Einstellungen für die Darstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PaintSettings PaintSettings { get; set; }
Visual Basic
Public Property PaintSettings As PaintSettings
    Get
    Set
F#
abstract PaintSettings : PaintSettings with get, set
override PaintSettings : PaintSettings with get, set

Implements

ITheme..::..PaintSettings

See Also

DefaultTheme Class
DynamicNode.Ext.Visual Namespace


DragAndDropDataParseException Class

[image]

DynamicNodes API
DragAndDropDataParseException Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ausnahme, die beim Parsen von fehlerhaften Drag&Drop-Daten ausgelöst wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class DragAndDropDataParseException : Exception
Visual Basic
Public Class DragAndDropDataParseException _
    Inherits Exception
F#
type DragAndDropDataParseException =
    class
        inherit Exception
    end

Inheritance Hierarchy

System..::..Object
System..::..Exception
DynamicNode.Ext.Visual..::..DragAndDropDataParseException

See Also

DragAndDropDataParseException Members
DynamicNode.Ext.Visual Namespace


DragAndDropDataParseException Members

[image] [image]

DynamicNodes API
DragAndDropDataParseException Members
DragAndDropDataParseException Class Constructors See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DragAndDropDataParseException type exposes the following members.

Constructors

 | Name | Description
Public method | DragAndDropDataParseException | Initialisiert eine neue Instanz von DragAndDropDataParseException mit einer beschreibenden Fehlermeldung.

See Also

DragAndDropDataParseException Class
DynamicNode.Ext.Visual Namespace


DragAndDropDataParseException Constructor

[image]

DynamicNodes API
DragAndDropDataParseException Constructor
DragAndDropDataParseException Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von DragAndDropDataParseException mit einer beschreibenden Fehlermeldung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public DragAndDropDataParseException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
F#
new :
        message:string -> DragAndDropDataParseException

Parameters

message
Type: System..::..String
Die Meldung, in der der Fehler beschrieben wird.

See Also

DragAndDropDataParseException Class
DynamicNode.Ext.Visual Namespace


DragAndDropHelper Class

[image]

DynamicNodes API
DragAndDropHelper Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bietet Unterstützung für Drag&Drop-Aktionen zur Erzeugung von Knoten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public static class DragAndDropHelper
Visual Basic
Public NotInheritable Class DragAndDropHelper
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DragAndDropHelper =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..DragAndDropHelper

See Also

DragAndDropHelper Members
DynamicNode.Ext.Visual Namespace


DragAndDropHelper Members

[image] [image]

DynamicNodes API
DragAndDropHelper Members
DragAndDropHelper Class Methods Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DragAndDropHelper type exposes the following members.

Methods

Name | Description
EndDragAndDrop | Schließt eine Drag&Drop-Aktion ab und erzeugt wenn möglich einen neuen Knoten durch Aufruf der Factory die in den Drag&Drop-Daten angeben ist.
StartDragAndDrop | Erzeugt eine Zeichenfolge, mit der eine Drag&Drop-Aktion für das Erzeugen eines Knotens realisiert werden kann.

Fields

Name | Description
DRAG_DROP_ID | Alle mit StartDragAndDrop(ICustomNodeFactory) erzeugten Drag&Drop-Daten beginnen mit dieser Zeichenkette gefolgt von einem Zeilenumbruch.

See Also

DragAndDropHelper Class
DynamicNode.Ext.Visual Namespace


DragAndDropHelper Fields

[image] [image]

DynamicNodes API
DragAndDropHelper Fields
DragAndDropHelper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DragAndDropHelper type exposes the following members.

Fields

Name | Description
DRAG_DROP_ID | Alle mit StartDragAndDrop(ICustomNodeFactory) erzeugten Drag&Drop-Daten beginnen mit dieser Zeichenkette gefolgt von einem Zeilenumbruch.

See Also

DragAndDropHelper Class
DynamicNode.Ext.Visual Namespace


DRAG_DROP_ID Field

[image]

DynamicNodes API
DragAndDropHelper..::..DRAG_DROP_ID Field
DragAndDropHelper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Alle mit StartDragAndDrop(ICustomNodeFactory) erzeugten Drag&Drop-Daten beginnen mit dieser Zeichenkette gefolgt von einem Zeilenumbruch.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public const string DRAG_DROP_ID
Visual Basic
Public Const DRAG_DROP_ID As String
F#
static val mutable DRAG_DROP_ID: string

See Also

DragAndDropHelper Class
DynamicNode.Ext.Visual Namespace


DragAndDropHelper Methods

[image] [image]

DynamicNodes API
DragAndDropHelper Methods
DragAndDropHelper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DragAndDropHelper type exposes the following members.

Methods

Name | Description
EndDragAndDrop | Schließt eine Drag&Drop-Aktion ab und erzeugt wenn möglich einen neuen Knoten durch Aufruf der Factory die in den Drag&Drop-Daten angeben ist.
StartDragAndDrop | Erzeugt eine Zeichenfolge, mit der eine Drag&Drop-Aktion für das Erzeugen eines Knotens realisiert werden kann.

See Also

DragAndDropHelper Class
DynamicNode.Ext.Visual Namespace


EndDragAndDrop Method

[image]

DynamicNodes API
DragAndDropHelper..::..EndDragAndDrop Method
DragAndDropHelper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schließt eine Drag&Drop-Aktion ab und erzeugt wenn möglich einen neuen Knoten durch Aufruf der Factory die in den Drag&Drop-Daten angeben ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public static void EndDragAndDrop(
    IDataObject data,
    NodeCreationCallback callback,
    Object dropInfo
)
Visual Basic
Public Shared Sub EndDragAndDrop ( _
    data As IDataObject, _
    callback As NodeCreationCallback, _
    dropInfo As Object _
)
F#
static member EndDragAndDrop :
        data:IDataObject *
        callback:NodeCreationCallback *
        dropInfo:Object -> unit

Parameters

data
Type: System.Windows.Forms..::..IDataObject
Die Drag&Drop-Daten.
callback
Type: DynamicNode.Ext.Visual..::..NodeCreationCallback
Das Delegate, das aufgerufen wird, wenn die Knotenerstellung abgeschlossen ist.
dropInfo
Type: System..::..Object
Zusätzliche Informationen über den Abschluss der Drag&Drop-Aktion.

Exceptions

Exception | Condition
DynamicNode.Ext.Visual..::..DragAndDropDataParseException | Wird ausgelöst, wenn die Drag&Drop-Daten ungültig sind.
System..::..InvalidOperationException | Wird ausgelöst, wenn das in den Drag&Drop-Daten übergebene Factory-Ticket ungültig ist.
DynamicNode.Ext.Visual..::..NodeCreationException | Wird ausgelöst, wenn beim Aufruf der Knoten-Factory eine Ausnahme auftritt.

See Also

DragAndDropHelper Class
DynamicNode.Ext.Visual Namespace
DragAndDropHelper..::..StartDragAndDrop(ICustomNodeFactory)


StartDragAndDrop Method

[image]

DynamicNodes API
DragAndDropHelper..::..StartDragAndDrop Method
DragAndDropHelper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine Zeichenfolge, mit der eine Drag&Drop-Aktion für das Erzeugen eines Knotens realisiert werden kann.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public static string StartDragAndDrop(
    ICustomNodeFactory factory
)
Visual Basic
Public Shared Function StartDragAndDrop ( _
    factory As ICustomNodeFactory _
) As String
F#
static member StartDragAndDrop :
        factory:ICustomNodeFactory -> string

Parameters

factory
Type: DynamicNode.Core..::..ICustomNodeFactory
Die Knoten-Factory welche die Knotenerzeugung nach Abschluss der Drag&Drop-Aktion übernehmen soll.

Return Value

Eine Zeichenfolge die als Daten mit einer Drag&Drop-Aktion übergeben werden können.

See Also

DragAndDropHelper Class
DynamicNode.Ext.Visual Namespace
DragAndDropHelper..::..EndDragAndDrop(IDataObject, NodeCreationCallback, Object)


Editor Class

[image]

DynamicNodes API
Editor Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standard-Implementierung der Schnittstelle IEditor.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class Editor : IEditor
Visual Basic
Public Class Editor _
    Implements IEditor
F#
type Editor =
    class
        interface IEditor
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..Editor

See Also

Editor Members
DynamicNode.Ext.Visual Namespace


Editor Members

[image] [image]

DynamicNodes API
Editor Members
Editor Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Editor type exposes the following members.

Constructors

 | Name | Description
Public method | Editor | Initialisiert eine Editor-Instanz.

Methods

 | Name | Description
Public method | GetNodeByMouse | Gibt einen Knoten anhand von Cursor-Koordinaten zurück.
Public method | PixelToWorkspace(Point) | Wandelt einen Punkt von der GUI aus Pixel in einen Punkt auf der Arbeitsfläche um.
Public method | PixelToWorkspace(Rectangle) | Wandelt ein Rechteck von der GUI aus Pixel in ein Rechteck auf der Arbeitsfläche um.
Public method | PixelToWorkspaceX | Wandelt die WorkspaceX-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.
Public method | PixelToWorkspaceY | Wandelt die WorkspaceY-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.
Public method | RegisterTools | Registriert mehrere Werkzeuge.
Public method | ResizeView | Berechnet die Größe der Ausgabefläche neu.
Public method | WorkspaceToPixel(PointF) | Wandelt einen Punkt auf der Arbeitsfläche in einen Punkt in Pixel für die GUI um.
Public method | WorkspaceToPixel(RectangleF) | Wandelt ein lokales Rechteck auf der Arbeitsfläche in ein Rechteck in Pixel für die GUI um.
Public method | WorkspaceToPixelX | Wandelt die lokale WorkspaceX-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.
Public method | WorkspaceToPixelY | Wandelt die lokale WorkspaceY-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.

Properties

 | Name | Description
Public property | Control | Liest oder schreibt das Editor-Steuerelement.
Public property | CurrentTool | Liest oder schreibt das aktuelle Werkzeug.
Public property | GraphDocument | Liest oder schreibt die IGraphDocument-Instanz.
Public property | Painter | Liest oder schreibt den Painter.

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


Editor Constructor

[image]

DynamicNodes API
Editor Constructor
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Editor-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Editor(
    EditorControl control,
    PaintSettings ps
)
Visual Basic
Public Sub New ( _
    control As EditorControl, _
    ps As PaintSettings _
)
F#
new :
        control:EditorControl *
        ps:PaintSettings -> Editor

Parameters

control
Type: DynamicNode.Ext.Visual..::..EditorControl
Das Editor-Steuerelement.
ps
Type: DynamicNode.Ext.Visual..::..PaintSettings
Das visuelle Schema.

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


Editor Methods

[image] [image]

DynamicNodes API
Editor Methods
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Editor type exposes the following members.

Methods

 | Name | Description
Public method | GetNodeByMouse | Gibt einen Knoten anhand von Cursor-Koordinaten zurück.
Public method | PixelToWorkspace(Point) | Wandelt einen Punkt von der GUI aus Pixel in einen Punkt auf der Arbeitsfläche um.
Public method | PixelToWorkspace(Rectangle) | Wandelt ein Rechteck von der GUI aus Pixel in ein Rechteck auf der Arbeitsfläche um.
Public method | PixelToWorkspaceX | Wandelt die WorkspaceX-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.
Public method | PixelToWorkspaceY | Wandelt die WorkspaceY-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.
Public method | RegisterTools | Registriert mehrere Werkzeuge.
Public method | ResizeView | Berechnet die Größe der Ausgabefläche neu.
Public method | WorkspaceToPixel(PointF) | Wandelt einen Punkt auf der Arbeitsfläche in einen Punkt in Pixel für die GUI um.
Public method | WorkspaceToPixel(RectangleF) | Wandelt ein lokales Rechteck auf der Arbeitsfläche in ein Rechteck in Pixel für die GUI um.
Public method | WorkspaceToPixelX | Wandelt die lokale WorkspaceX-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.
Public method | WorkspaceToPixelY | Wandelt die lokale WorkspaceY-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


GetNodeByMouse Method

[image]

DynamicNodes API
Editor..::..GetNodeByMouse Method
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Knoten anhand von Cursor-Koordinaten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public INode GetNodeByMouse(
    int x,
    int y,
    bool border
)
Visual Basic
Public Function GetNodeByMouse ( _
    x As Integer, _
    y As Integer, _
    border As Boolean _
) As INode
F#
abstract GetNodeByMouse :
        x:int *
        y:int *
        border:bool -> INode
override GetNodeByMouse :
        x:int *
        y:int *
        border:bool -> INode

Parameters

x
Type: System..::..Int32
Die WorkspaceX-Koordinate.
y
Type: System..::..Int32
Die WorkspaceX-Koordinate.
border
Type: System..::..Boolean
Wenn true wird der Randbereich der Knoten, in dem sich die Ports befinden, bei der Prüfung berücksichtigt.

Return Value

Ein Knoten, oder null, wenn die Koordinaten in keinem Knoten lagen.

Implements

IEditor..::..GetNodeByMouse(Int32, Int32, Boolean)

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


PixelToWorkspace Method

[image] [image]

DynamicNodes API
Editor..::..PixelToWorkspace Method
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | PixelToWorkspace(Point) | Wandelt einen Punkt von der GUI aus Pixel in einen Punkt auf der Arbeitsfläche um.
Public method | PixelToWorkspace(Rectangle) | Wandelt ein Rechteck von der GUI aus Pixel in ein Rechteck auf der Arbeitsfläche um.

See Also

Editor Class
Editor Members
DynamicNode.Ext.Visual Namespace


PixelToWorkspace Method (Point)

[image]

DynamicNodes API
Editor..::..PixelToWorkspace Method (Point)
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt einen Punkt von der GUI aus Pixel in einen Punkt auf der Arbeitsfläche um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PointF PixelToWorkspace(
    Point p
)
Visual Basic
Public Function PixelToWorkspace ( _
    p As Point _
) As PointF
F#
abstract PixelToWorkspace :
        p:Point -> PointF
override PixelToWorkspace :
        p:Point -> PointF

Parameters

p
Type: System.Drawing..::..Point
Der Punkt in Pixel von der GUI.

Return Value

Der Punkt auf der Arbeitsfläche.

Implements

IEditor..::..PixelToWorkspace(Point)

See Also

Editor Class
PixelToWorkspace Overload
DynamicNode.Ext.Visual Namespace


PixelToWorkspace Method (Rectangle)

[image]

DynamicNodes API
Editor..::..PixelToWorkspace Method (Rectangle)
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt ein Rechteck von der GUI aus Pixel in ein Rechteck auf der Arbeitsfläche um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public RectangleF PixelToWorkspace(
    Rectangle r
)
Visual Basic
Public Function PixelToWorkspace ( _
    r As Rectangle _
) As RectangleF
F#
abstract PixelToWorkspace :
        r:Rectangle -> RectangleF
override PixelToWorkspace :
        r:Rectangle -> RectangleF

Parameters

r
Type: System.Drawing..::..Rectangle
Das Rechteck in Pixel von der GUI.

Return Value

Das Rechteck auf der Arbeitsfläche.

Implements

IEditor..::..PixelToWorkspace(Rectangle)

See Also

Editor Class
PixelToWorkspace Overload
DynamicNode.Ext.Visual Namespace


PixelToWorkspaceX Method

[image]

DynamicNodes API
Editor..::..PixelToWorkspaceX Method
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt die WorkspaceX-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float PixelToWorkspaceX(
    int x
)
Visual Basic
Public Function PixelToWorkspaceX ( _
    x As Integer _
) As Single
F#
abstract PixelToWorkspaceX :
        x:int -> float32
override PixelToWorkspaceX :
        x:int -> float32

Parameters

x
Type: System..::..Int32
Die WorkspaceX-Koordinate.

Return Value

Die lokale WorkspaceX-Koordinate.

Implements

IEditor..::..PixelToWorkspaceX(Int32)

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


PixelToWorkspaceY Method

[image]

DynamicNodes API
Editor..::..PixelToWorkspaceY Method
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt die WorkspaceY-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float PixelToWorkspaceY(
    int y
)
Visual Basic
Public Function PixelToWorkspaceY ( _
    y As Integer _
) As Single
F#
abstract PixelToWorkspaceY :
        y:int -> float32
override PixelToWorkspaceY :
        y:int -> float32

Parameters

y
Type: System..::..Int32
Die WorkspaceY-Koordinate.

Return Value

Die lokale WorkspaceY-Koordinate.

Implements

IEditor..::..PixelToWorkspaceY(Int32)

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


RegisterTools Method

[image]

DynamicNodes API
Editor..::..RegisterTools Method
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert mehrere Werkzeuge.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void RegisterTools(
    params IEditorTool[] tools
)
Visual Basic
Public Sub RegisterTools ( _
    ParamArray tools As IEditorTool() _
)
F#
abstract RegisterTools :
        tools:IEditorTool[] -> unit
override RegisterTools :
        tools:IEditorTool[] -> unit

Parameters

tools
Type: array< DynamicNode.Ext.Visual..::..IEditorTool >[]()[][]
Mehrere Werkzeuge.

Implements

IEditor..::..RegisterTools(array<IEditorTool>[]()[][])

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


ResizeView Method

[image]

DynamicNodes API
Editor..::..ResizeView Method
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet die Größe der Ausgabefläche neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void ResizeView()
Visual Basic
Public Sub ResizeView
F#
abstract ResizeView : unit -> unit
override ResizeView : unit -> unit

Implements

IEditor..::..ResizeView()()()()

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


WorkspaceToPixel Method

[image] [image]

DynamicNodes API
Editor..::..WorkspaceToPixel Method
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | WorkspaceToPixel(PointF) | Wandelt einen Punkt auf der Arbeitsfläche in einen Punkt in Pixel für die GUI um.
Public method | WorkspaceToPixel(RectangleF) | Wandelt ein lokales Rechteck auf der Arbeitsfläche in ein Rechteck in Pixel für die GUI um.

See Also

Editor Class
Editor Members
DynamicNode.Ext.Visual Namespace


WorkspaceToPixel Method (PointF)

[image]

DynamicNodes API
Editor..::..WorkspaceToPixel Method (PointF)
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt einen Punkt auf der Arbeitsfläche in einen Punkt in Pixel für die GUI um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Point WorkspaceToPixel(
    PointF p
)
Visual Basic
Public Function WorkspaceToPixel ( _
    p As PointF _
) As Point
F#
abstract WorkspaceToPixel :
        p:PointF -> Point
override WorkspaceToPixel :
        p:PointF -> Point

Parameters

p
Type: System.Drawing..::..PointF
Der Punkt auf der Arbeitsfläche.

Return Value

Der Punkt in Pixel für die GUI.

Implements

IEditor..::..WorkspaceToPixel(PointF)

See Also

Editor Class
WorkspaceToPixel Overload
DynamicNode.Ext.Visual Namespace


WorkspaceToPixel Method (RectangleF)

[image]

DynamicNodes API
Editor..::..WorkspaceToPixel Method (RectangleF)
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt ein lokales Rechteck auf der Arbeitsfläche in ein Rechteck in Pixel für die GUI um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Rectangle WorkspaceToPixel(
    RectangleF r
)
Visual Basic
Public Function WorkspaceToPixel ( _
    r As RectangleF _
) As Rectangle
F#
abstract WorkspaceToPixel :
        r:RectangleF -> Rectangle
override WorkspaceToPixel :
        r:RectangleF -> Rectangle

Parameters

r
Type: System.Drawing..::..RectangleF
Das Rechteck auf der Arbeitsfläche.

Return Value

Das Rechteck in Pixel für die GUI.

Implements

IEditor..::..WorkspaceToPixel(RectangleF)

See Also

Editor Class
WorkspaceToPixel Overload
DynamicNode.Ext.Visual Namespace


WorkspaceToPixelX Method

[image]

DynamicNodes API
Editor..::..WorkspaceToPixelX Method
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt die lokale WorkspaceX-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public int WorkspaceToPixelX(
    float x
)
Visual Basic
Public Function WorkspaceToPixelX ( _
    x As Single _
) As Integer
F#
abstract WorkspaceToPixelX :
        x:float32 -> int
override WorkspaceToPixelX :
        x:float32 -> int

Parameters

x
Type: System..::..Single
Die lokale WorkspaceX-Koordinate.

Return Value

Die GUI-WorkspaceX-Koordinate.

Implements

IEditor..::..WorkspaceToPixelX(Single)

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


WorkspaceToPixelY Method

[image]

DynamicNodes API
Editor..::..WorkspaceToPixelY Method
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt die lokale WorkspaceY-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public int WorkspaceToPixelY(
    float y
)
Visual Basic
Public Function WorkspaceToPixelY ( _
    y As Single _
) As Integer
F#
abstract WorkspaceToPixelY :
        y:float32 -> int
override WorkspaceToPixelY :
        y:float32 -> int

Parameters

y
Type: System..::..Single
Die lokale WorkspaceY-Koordinate.

Return Value

Die GUI-WorkspaceY-Koordinate.

Implements

IEditor..::..WorkspaceToPixelY(Single)

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


Editor Properties

[image] [image]

DynamicNodes API
Editor Properties
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Editor type exposes the following members.

Properties

 | Name | Description
Public property | Control | Liest oder schreibt das Editor-Steuerelement.
Public property | CurrentTool | Liest oder schreibt das aktuelle Werkzeug.
Public property | GraphDocument | Liest oder schreibt die IGraphDocument-Instanz.
Public property | Painter | Liest oder schreibt den Painter.

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


Control Property

[image]

DynamicNodes API
Editor..::..Control Property
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt das Editor-Steuerelement.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public EditorControl Control { get; }
Visual Basic
Public ReadOnly Property Control As EditorControl
    Get
F#
abstract Control : EditorControl
override Control : EditorControl

Field Value

Das Editor-Steuerelement.

Implements

IEditor..::..Control

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


CurrentTool Property

[image]

DynamicNodes API
Editor..::..CurrentTool Property
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt das aktuelle Werkzeug.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IEditorTool CurrentTool { get; set; }
Visual Basic
Public Property CurrentTool As IEditorTool
    Get
    Set
F#
abstract CurrentTool : IEditorTool with get, set
override CurrentTool : IEditorTool with get, set

Field Value

Das aktuelle Werkzeug.

Implements

IEditor..::..CurrentTool

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


GraphDocument Property

[image]

DynamicNodes API
Editor..::..GraphDocument Property
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die IGraphDocument-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IGraphDocument GraphDocument { get; internal set; }
Visual Basic
Public Property GraphDocument As IGraphDocument
    Get
    Friend Set
F#
abstract GraphDocument : IGraphDocument with get, internal set
override GraphDocument : IGraphDocument with get, internal set

Field Value

Das Daten-Modell.

Implements

IEditor..::..GraphDocument

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


Painter Property

[image]

DynamicNodes API
Editor..::..Painter Property
Editor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Painter.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IPainter Painter { get; }
Visual Basic
Public ReadOnly Property Painter As IPainter
    Get
F#
abstract Painter : IPainter
override Painter : IPainter

Field Value

Der Painter.

Implements

IEditor..::..Painter

See Also

Editor Class
DynamicNode.Ext.Visual Namespace


EditorControl Class

[image]

DynamicNodes API
EditorControl Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Steuerelement, welches die Arbeitsfläche für den visuellen Graphen-Editor darstellt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class EditorControl : ExtendedUserControl
Visual Basic
Public Class EditorControl _
    Inherits ExtendedUserControl
F#
type EditorControl =
    class
        inherit ExtendedUserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Visual..::..ExtendedUserControl
DynamicNode.Ext.Visual..::..EditorControl

See Also

EditorControl Members
DynamicNode.Ext.Visual Namespace


EditorControl Members

[image] [image]

DynamicNodes API
EditorControl Members
EditorControl Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorControl type exposes the following members.

Constructors

 | Name | Description
Public method | EditorControl | Initialisiert eine EditorControl-Instanz.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnExtPreviewKeyDown | Löst das Ereignis ExtPreviewKeyDown aus. (Inherited from ExtendedUserControl.)
Protected method | OnExtPreviewKeyUp | Löst das Ereignis ExtPreviewKeyUp aus. (Inherited from ExtendedUserControl.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from ExtendedUserControl.)
Public method | RegisterUserToolButtons | Registriert ein Werkzeug bei diesem Editor-Steuerelement. Das Editor-Steuerelement zeigt daraufhin eine Taste mit dem Icon des Werkzeugs an, mit welcher das Werkzeug aktiviert werden kann.
Public method | ScrollWorkspace | Verschiebt die Arbeitsfläche soweit möglich um die gegebenen Anzahl von Pixeln in X- und Y-Richtung.
Public method | SelectUserToolButton | Markiert einen Werkzeug-Button als ausgewählt.

Properties

 | Name | Description
Public property | KeyPreview | Liest oder schreibt einen Wert der angibt ob KeyUp- und KeyDown-Ereignisse von untergeordneten Controls abgefangen werden sollen. (Inherited from ExtendedUserControl.)
Public property | MaxOffsetX | Liest oder schreibt den maximalen Offset des horizontalen Scrollbalkens.
Public property | MaxOffsetY | Liest oder schreibt den maximalen Offset des vertikalen Scrollbalkens.
Public property | OffsetX | Gibt den Offset des horizontalen Scrollbalkens zurück.
Public property | OffsetY | Gitb den Offset des vertikalen Scrollbalkens zurück.
Public property | Painter | Liest oder schreibt den Painter.
Public property | ViewControl | Gibt das Panel zurück, auf welchem unmittelbar die grafische Ausgabe des Graphen erfolgt.
Public property | Zoom | Liest oder schreibt den Wert der Zoom-Steuerung. Ein Wert von 1.0 entspricht 100%.

Events

 | Name | Description
Public event | ExtPreviewKeyDown | Tritt auf, wenn KeyPreview gleich true ist, eine Taste gedrückt wird und dieses oder ein untergeordnetes Steuerelement den Eingabefokus hat. (Inherited from ExtendedUserControl.)
Public event | ExtPreviewKeyUp | Tritt auf, wenn KeyPreview gleich true ist, eine Taste losgelassen wird und dieses oder ein untergeordnetes Steuerelement den Eingabefokus hat. (Inherited from ExtendedUserControl.)
Public event | ToolButtonClick | Wird ausgelöst, wenn eine Werkzeug-Taste angeklickt wird. Das sender-Objekt ist die verknüpfte IEditorTool-Instanz.
Public event | ViewDragDrop | Wird ausgelöst, wenn ein DragDrop im Arbeitsbereich auftritt.
Public event | ViewDragEnter | Wird ausgelöst, wenn ein DragEnter im Arbeitsbereich auftritt.
Public event | ViewMouseClick | Wird ausgelöst, wenn ein MouseClick im Arbeitsbereich auftritt.
Public event | ViewMouseDoubleClick | Wird ausgelöst, wenn ein MouseDoubleClick im Arbeitsbereich auftritt.
Public event | ViewMouseDown | Wird ausgelöst, wenn ein MouseDown im Arbeitsbereich auftritt.
Public event | ViewMouseEnter | Wird ausgelöst, wenn ein MouseEnter im Arbeitsbereich auftritt.
Public event | ViewMouseHover | Wird ausgelöst, wenn ein MouseHover im Arbeitsbereich auftritt.
Public event | ViewMouseLeave | Wird ausgelöst, wenn ein MouseLeave im Arbeitsbereich auftritt.
Public event | ViewMouseMove | Wird ausgelöst, wenn ein MouseMove im Arbeitsbereich auftritt.
Public event | ViewMouseUp | Wird ausgelöst, wenn ein MouseUp im Arbeitsbereich auftritt.
Public event | ViewMouseWheel | Wird ausgelöst, wenn ein MouseWheel im Arbeitsbereich auftritt.
Public event | ViewPaint | Wird ausgelöst, wenn ein Paint im Arbeitsbereich auftritt.
Public event | ViewSizeChanged | Wird ausgelöst, wenn ein SizeChanged im Arbeitsbereich auftritt.
Public event | ViewZoomChanged | Wird ausgelöst, wenn der Benutzer über die Benutzerschnittstelle des Editors eine neue Zoom-Stufe einstellt.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


EditorControl Constructor

[image]

DynamicNodes API
EditorControl Constructor
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine EditorControl-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public EditorControl()
Visual Basic
Public Sub New
F#
new : unit -> EditorControl

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


EditorControl Methods

[image] [image]

DynamicNodes API
EditorControl Methods
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorControl type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnExtPreviewKeyDown | Löst das Ereignis ExtPreviewKeyDown aus. (Inherited from ExtendedUserControl.)
Protected method | OnExtPreviewKeyUp | Löst das Ereignis ExtPreviewKeyUp aus. (Inherited from ExtendedUserControl.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from ExtendedUserControl.)
Public method | RegisterUserToolButtons | Registriert ein Werkzeug bei diesem Editor-Steuerelement. Das Editor-Steuerelement zeigt daraufhin eine Taste mit dem Icon des Werkzeugs an, mit welcher das Werkzeug aktiviert werden kann.
Public method | ScrollWorkspace | Verschiebt die Arbeitsfläche soweit möglich um die gegebenen Anzahl von Pixeln in X- und Y-Richtung.
Public method | SelectUserToolButton | Markiert einen Werkzeug-Button als ausgewählt.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


Dispose Method

[image]

DynamicNodes API
EditorControl..::..Dispose Method
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


RegisterUserToolButtons Method

[image]

DynamicNodes API
EditorControl..::..RegisterUserToolButtons Method
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert ein Werkzeug bei diesem Editor-Steuerelement. Das Editor-Steuerelement zeigt daraufhin eine Taste mit dem Icon des Werkzeugs an, mit welcher das Werkzeug aktiviert werden kann.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void RegisterUserToolButtons(
    params IEditorTool[] tools
)
Visual Basic
Public Sub RegisterUserToolButtons ( _
    ParamArray tools As IEditorTool() _
)
F#
member RegisterUserToolButtons :
        tools:IEditorTool[] -> unit

Parameters

tools
Type: array< DynamicNode.Ext.Visual..::..IEditorTool >[]()[][]
Ein Editor-Werkzeug.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ScrollWorkspace Method

[image]

DynamicNodes API
EditorControl..::..ScrollWorkspace Method
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verschiebt die Arbeitsfläche soweit möglich um die gegebenen Anzahl von Pixeln in X- und Y-Richtung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void ScrollWorkspace(
    int x,
    int y
)
Visual Basic
Public Sub ScrollWorkspace ( _
    x As Integer, _
    y As Integer _
)
F#
member ScrollWorkspace :
        x:int *
        y:int -> unit

Parameters

x
Type: System..::..Int32
Die Verschiebung der Arbeitsfläche in X-Richtung.
y
Type: System..::..Int32
Die Verschiebung der Arbeitsfläche in Y-Richtung.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


SelectUserToolButton Method

[image]

DynamicNodes API
EditorControl..::..SelectUserToolButton Method
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Markiert einen Werkzeug-Button als ausgewählt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void SelectUserToolButton(
    IEditorTool tool
)
Visual Basic
Public Sub SelectUserToolButton ( _
    tool As IEditorTool _
)
F#
member SelectUserToolButton :
        tool:IEditorTool -> unit

Parameters

tool
Type: DynamicNode.Ext.Visual..::..IEditorTool
Ein Werkzeug.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


EditorControl Properties

[image] [image]

DynamicNodes API
EditorControl Properties
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorControl type exposes the following members.

Properties

 | Name | Description
Public property | KeyPreview | Liest oder schreibt einen Wert der angibt ob KeyUp- und KeyDown-Ereignisse von untergeordneten Controls abgefangen werden sollen. (Inherited from ExtendedUserControl.)
Public property | MaxOffsetX | Liest oder schreibt den maximalen Offset des horizontalen Scrollbalkens.
Public property | MaxOffsetY | Liest oder schreibt den maximalen Offset des vertikalen Scrollbalkens.
Public property | OffsetX | Gibt den Offset des horizontalen Scrollbalkens zurück.
Public property | OffsetY | Gitb den Offset des vertikalen Scrollbalkens zurück.
Public property | Painter | Liest oder schreibt den Painter.
Public property | ViewControl | Gibt das Panel zurück, auf welchem unmittelbar die grafische Ausgabe des Graphen erfolgt.
Public property | Zoom | Liest oder schreibt den Wert der Zoom-Steuerung. Ein Wert von 1.0 entspricht 100%.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


MaxOffsetX Property

[image]

DynamicNodes API
EditorControl..::..MaxOffsetX Property
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den maximalen Offset des horizontalen Scrollbalkens.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public int MaxOffsetX { get; set; }
Visual Basic
Public Property MaxOffsetX As Integer
    Get
    Set
F#
member MaxOffsetX : int with get, set

Field Value

Der maximale horizontale Offset.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


MaxOffsetY Property

[image]

DynamicNodes API
EditorControl..::..MaxOffsetY Property
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den maximalen Offset des vertikalen Scrollbalkens.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public int MaxOffsetY { get; set; }
Visual Basic
Public Property MaxOffsetY As Integer
    Get
    Set
F#
member MaxOffsetY : int with get, set

Field Value

Der maximale vertikale Offset.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


OffsetX Property

[image]

DynamicNodes API
EditorControl..::..OffsetX Property
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Offset des horizontalen Scrollbalkens zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public int OffsetX { get; set; }
Visual Basic
Public Property OffsetX As Integer
    Get
    Set
F#
member OffsetX : int with get, set

Field Value

Der Offset des horizontalen Scrollbalkens.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


OffsetY Property

[image]

DynamicNodes API
EditorControl..::..OffsetY Property
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gitb den Offset des vertikalen Scrollbalkens zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public int OffsetY { get; set; }
Visual Basic
Public Property OffsetY As Integer
    Get
    Set
F#
member OffsetY : int with get, set

Field Value

Der Offset des vertikalen Scrollbalkens.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


Painter Property

[image]

DynamicNodes API
EditorControl..::..Painter Property
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Painter.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IPainter Painter { get; set; }
Visual Basic
Public Property Painter As IPainter
    Get
    Set
F#
member Painter : IPainter with get, set

Field Value

Der Painter.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewControl Property

[image]

DynamicNodes API
EditorControl..::..ViewControl Property
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Panel zurück, auf welchem unmittelbar die grafische Ausgabe des Graphen erfolgt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Control ViewControl { get; }
Visual Basic
Public ReadOnly Property ViewControl As Control
    Get
F#
member ViewControl : Control

Field Value

Das ViewPanel.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


Zoom Property

[image]

DynamicNodes API
EditorControl..::..Zoom Property
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Wert der Zoom-Steuerung. Ein Wert von 1.0 entspricht 100%.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float Zoom { get; set; }
Visual Basic
Public Property Zoom As Single
    Get
    Set
F#
member Zoom : float32 with get, set

Field Value

Der Wert der Zoom-Steuerung.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


EditorControl Events

[image] [image]

DynamicNodes API
EditorControl Events
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorControl type exposes the following members.

Events

 | Name | Description
Public event | ExtPreviewKeyDown | Tritt auf, wenn KeyPreview gleich true ist, eine Taste gedrückt wird und dieses oder ein untergeordnetes Steuerelement den Eingabefokus hat. (Inherited from ExtendedUserControl.)
Public event | ExtPreviewKeyUp | Tritt auf, wenn KeyPreview gleich true ist, eine Taste losgelassen wird und dieses oder ein untergeordnetes Steuerelement den Eingabefokus hat. (Inherited from ExtendedUserControl.)
Public event | ToolButtonClick | Wird ausgelöst, wenn eine Werkzeug-Taste angeklickt wird. Das sender-Objekt ist die verknüpfte IEditorTool-Instanz.
Public event | ViewDragDrop | Wird ausgelöst, wenn ein DragDrop im Arbeitsbereich auftritt.
Public event | ViewDragEnter | Wird ausgelöst, wenn ein DragEnter im Arbeitsbereich auftritt.
Public event | ViewMouseClick | Wird ausgelöst, wenn ein MouseClick im Arbeitsbereich auftritt.
Public event | ViewMouseDoubleClick | Wird ausgelöst, wenn ein MouseDoubleClick im Arbeitsbereich auftritt.
Public event | ViewMouseDown | Wird ausgelöst, wenn ein MouseDown im Arbeitsbereich auftritt.
Public event | ViewMouseEnter | Wird ausgelöst, wenn ein MouseEnter im Arbeitsbereich auftritt.
Public event | ViewMouseHover | Wird ausgelöst, wenn ein MouseHover im Arbeitsbereich auftritt.
Public event | ViewMouseLeave | Wird ausgelöst, wenn ein MouseLeave im Arbeitsbereich auftritt.
Public event | ViewMouseMove | Wird ausgelöst, wenn ein MouseMove im Arbeitsbereich auftritt.
Public event | ViewMouseUp | Wird ausgelöst, wenn ein MouseUp im Arbeitsbereich auftritt.
Public event | ViewMouseWheel | Wird ausgelöst, wenn ein MouseWheel im Arbeitsbereich auftritt.
Public event | ViewPaint | Wird ausgelöst, wenn ein Paint im Arbeitsbereich auftritt.
Public event | ViewSizeChanged | Wird ausgelöst, wenn ein SizeChanged im Arbeitsbereich auftritt.
Public event | ViewZoomChanged | Wird ausgelöst, wenn der Benutzer über die Benutzerschnittstelle des Editors eine neue Zoom-Stufe einstellt.

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ToolButtonClick Event

[image]

DynamicNodes API
EditorControl..::..ToolButtonClick Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine Werkzeug-Taste angeklickt wird. Das sender-Objekt ist die verknüpfte IEditorTool-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<ToolButtonEventArgs> ToolButtonClick
Visual Basic
Public Event ToolButtonClick As EventHandler(Of ToolButtonEventArgs)
F#
member ToolButtonClick : IEvent<EventHandler<ToolButtonEventArgs>,
    ToolButtonEventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewDragDrop Event

[image]

DynamicNodes API
EditorControl..::..ViewDragDrop Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein DragDrop im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event DragEventHandler ViewDragDrop
Visual Basic
Public Event ViewDragDrop As DragEventHandler
F#
member ViewDragDrop : IEvent<DragEventHandler,
    DragEventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewDragEnter Event

[image]

DynamicNodes API
EditorControl..::..ViewDragEnter Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein DragEnter im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event DragEventHandler ViewDragEnter
Visual Basic
Public Event ViewDragEnter As DragEventHandler
F#
member ViewDragEnter : IEvent<DragEventHandler,
    DragEventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewMouseClick Event

[image]

DynamicNodes API
EditorControl..::..ViewMouseClick Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein MouseClick im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event MouseEventHandler ViewMouseClick
Visual Basic
Public Event ViewMouseClick As MouseEventHandler
F#
member ViewMouseClick : IEvent<MouseEventHandler,
    MouseEventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewMouseDoubleClick Event

[image]

DynamicNodes API
EditorControl..::..ViewMouseDoubleClick Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein MouseDoubleClick im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event MouseEventHandler ViewMouseDoubleClick
Visual Basic
Public Event ViewMouseDoubleClick As MouseEventHandler
F#
member ViewMouseDoubleClick : IEvent<MouseEventHandler,
    MouseEventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewMouseDown Event

[image]

DynamicNodes API
EditorControl..::..ViewMouseDown Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein MouseDown im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event MouseEventHandler ViewMouseDown
Visual Basic
Public Event ViewMouseDown As MouseEventHandler
F#
member ViewMouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewMouseEnter Event

[image]

DynamicNodes API
EditorControl..::..ViewMouseEnter Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein MouseEnter im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler ViewMouseEnter
Visual Basic
Public Event ViewMouseEnter As EventHandler
F#
member ViewMouseEnter : IEvent<EventHandler,
    EventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewMouseHover Event

[image]

DynamicNodes API
EditorControl..::..ViewMouseHover Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein MouseHover im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler ViewMouseHover
Visual Basic
Public Event ViewMouseHover As EventHandler
F#
member ViewMouseHover : IEvent<EventHandler,
    EventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewMouseLeave Event

[image]

DynamicNodes API
EditorControl..::..ViewMouseLeave Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein MouseLeave im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler ViewMouseLeave
Visual Basic
Public Event ViewMouseLeave As EventHandler
F#
member ViewMouseLeave : IEvent<EventHandler,
    EventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewMouseMove Event

[image]

DynamicNodes API
EditorControl..::..ViewMouseMove Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein MouseMove im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event MouseEventHandler ViewMouseMove
Visual Basic
Public Event ViewMouseMove As MouseEventHandler
F#
member ViewMouseMove : IEvent<MouseEventHandler,
    MouseEventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewMouseUp Event

[image]

DynamicNodes API
EditorControl..::..ViewMouseUp Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein MouseUp im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event MouseEventHandler ViewMouseUp
Visual Basic
Public Event ViewMouseUp As MouseEventHandler
F#
member ViewMouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewMouseWheel Event

[image]

DynamicNodes API
EditorControl..::..ViewMouseWheel Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein MouseWheel im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<MouseEventArgs> ViewMouseWheel
Visual Basic
Public Event ViewMouseWheel As EventHandler(Of MouseEventArgs)
F#
member ViewMouseWheel : IEvent<EventHandler<MouseEventArgs>,
    MouseEventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewPaint Event

[image]

DynamicNodes API
EditorControl..::..ViewPaint Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Paint im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event PaintEventHandler ViewPaint
Visual Basic
Public Event ViewPaint As PaintEventHandler
F#
member ViewPaint : IEvent<PaintEventHandler,
    PaintEventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewSizeChanged Event

[image]

DynamicNodes API
EditorControl..::..ViewSizeChanged Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein SizeChanged im Arbeitsbereich auftritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler ViewSizeChanged
Visual Basic
Public Event ViewSizeChanged As EventHandler
F#
member ViewSizeChanged : IEvent<EventHandler,
    EventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


ViewZoomChanged Event

[image]

DynamicNodes API
EditorControl..::..ViewZoomChanged Event
EditorControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Benutzer über die Benutzerschnittstelle des Editors eine neue Zoom-Stufe einstellt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler ViewZoomChanged
Visual Basic
Public Event ViewZoomChanged As EventHandler
F#
member ViewZoomChanged : IEvent<EventHandler,
    EventArgs>

See Also

EditorControl Class
DynamicNode.Ext.Visual Namespace


EditorDocumentEventArgs Class

[image]

DynamicNodes API
EditorDocumentEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignis-Parameter für ein Graphen-bezogenes Ereignis.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class EditorDocumentEventArgs : EventArgs
Visual Basic
Public Class EditorDocumentEventArgs _
    Inherits EventArgs
F#
type EditorDocumentEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Ext.Visual..::..EditorDocumentEventArgs

See Also

EditorDocumentEventArgs Members
DynamicNode.Ext.Visual Namespace


EditorDocumentEventArgs Members

[image] [image]

DynamicNodes API
EditorDocumentEventArgs Members
EditorDocumentEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorDocumentEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EditorDocumentEventArgs | Initialisiert eine EditorDocumentEventArgs-Instanz.

Properties

 | Name | Description
Public property | Document | Gibt das betroffene Dokument oder null zurück.

See Also

EditorDocumentEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorDocumentEventArgs Constructor

[image]

DynamicNodes API
EditorDocumentEventArgs Constructor
EditorDocumentEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine EditorDocumentEventArgs-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public EditorDocumentEventArgs(
    IGraphDocument document
)
Visual Basic
Public Sub New ( _
    document As IGraphDocument _
)
F#
new :
        document:IGraphDocument -> EditorDocumentEventArgs

Parameters

document
Type: DynamicNode.Ext.Visual..::..IGraphDocument
Das ausgewählte Dokument, oder null.

See Also

EditorDocumentEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorDocumentEventArgs Properties

[image] [image]

DynamicNodes API
EditorDocumentEventArgs Properties
EditorDocumentEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorDocumentEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gibt das betroffene Dokument oder null zurück.

See Also

EditorDocumentEventArgs Class
DynamicNode.Ext.Visual Namespace


Document Property

[image]

DynamicNodes API
EditorDocumentEventArgs..::..Document Property
EditorDocumentEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das betroffene Dokument oder null zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IGraphDocument Document { get; }
Visual Basic
Public ReadOnly Property Document As IGraphDocument
    Get
F#
member Document : IGraphDocument

Field Value

Das betroffene Dokument oder null.

See Also

EditorDocumentEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorDragEventArgs Class

[image]

DynamicNodes API
EditorDragEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignis-Parameter für Drag&Drop-Ereignisse mit Editor-Koordinaten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class EditorDragEventArgs : DragEventArgs
Visual Basic
Public Class EditorDragEventArgs _
    Inherits DragEventArgs
F#
type EditorDragEventArgs =
    class
        inherit DragEventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.Windows.Forms..::..DragEventArgs
DynamicNode.Ext.Visual..::..EditorDragEventArgs

See Also

EditorDragEventArgs Members
DynamicNode.Ext.Visual Namespace


EditorDragEventArgs Members

[image] [image]

DynamicNodes API
EditorDragEventArgs Members
EditorDragEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorDragEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EditorDragEventArgs | Initialisiert eine EditorMouseEventArgs-Instanz.

Properties

 | Name | Description
Public property | WorkspaceLocation | Gibt die Position des Maus-Cursors auf der Arbeitsfläche zurück.
Public property | WorkspaceX | Gibt die X-Position des Maus-Cursors auf der Arbeitsfläche zurück.
Public property | WorkspaceY | Gibt die Y-Position des Maus-Cursors auf der Arbeitsfläche zurück.

See Also

EditorDragEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorDragEventArgs Constructor

[image]

DynamicNodes API
EditorDragEventArgs Constructor
EditorDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine EditorMouseEventArgs-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public EditorDragEventArgs(
    DragEventArgs e,
    IEditor editor
)
Visual Basic
Public Sub New ( _
    e As DragEventArgs, _
    editor As IEditor _
)
F#
new :
        e:DragEventArgs *
        editor:IEditor -> EditorDragEventArgs

Parameters

e
Type: System.Windows.Forms..::..DragEventArgs
Die MouseEventArgs-Instanz enthält die original Maus-Ereignisdaten.
editor
Type: DynamicNode.Ext.Visual..::..IEditor
Ein Editor, der die Koordinaten transformiert.

See Also

EditorDragEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorDragEventArgs Properties

[image] [image]

DynamicNodes API
EditorDragEventArgs Properties
EditorDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorDragEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | WorkspaceLocation | Gibt die Position des Maus-Cursors auf der Arbeitsfläche zurück.
Public property | WorkspaceX | Gibt die X-Position des Maus-Cursors auf der Arbeitsfläche zurück.
Public property | WorkspaceY | Gibt die Y-Position des Maus-Cursors auf der Arbeitsfläche zurück.

See Also

EditorDragEventArgs Class
DynamicNode.Ext.Visual Namespace


WorkspaceLocation Property

[image]

DynamicNodes API
EditorDragEventArgs..::..WorkspaceLocation Property
EditorDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Position des Maus-Cursors auf der Arbeitsfläche zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PointF WorkspaceLocation { get; }
Visual Basic
Public ReadOnly Property WorkspaceLocation As PointF
    Get
F#
member WorkspaceLocation : PointF

Field Value

Die Cursor-Position auf der Arbeitsfläche.

See Also

EditorDragEventArgs Class
DynamicNode.Ext.Visual Namespace


WorkspaceX Property

[image]

DynamicNodes API
EditorDragEventArgs..::..WorkspaceX Property
EditorDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die X-Position des Maus-Cursors auf der Arbeitsfläche zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float WorkspaceX { get; }
Visual Basic
Public ReadOnly Property WorkspaceX As Single
    Get
F#
member WorkspaceX : float32

Field Value

Die X-Cursor-Position auf der Arbeitsfläche.

See Also

EditorDragEventArgs Class
DynamicNode.Ext.Visual Namespace


WorkspaceY Property

[image]

DynamicNodes API
EditorDragEventArgs..::..WorkspaceY Property
EditorDragEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Y-Position des Maus-Cursors auf der Arbeitsfläche zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float WorkspaceY { get; }
Visual Basic
Public ReadOnly Property WorkspaceY As Single
    Get
F#
member WorkspaceY : float32

Field Value

Die Y-Cursor-Position auf der Arbeitsfläche.

See Also

EditorDragEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorMouseEventArgs Class

[image]

DynamicNodes API
EditorMouseEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignis-Parameter für Mausereignisse mit Editor-Koordinaten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class EditorMouseEventArgs : MouseEventArgs
Visual Basic
Public Class EditorMouseEventArgs _
    Inherits MouseEventArgs
F#
type EditorMouseEventArgs =
    class
        inherit MouseEventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.Windows.Forms..::..MouseEventArgs
DynamicNode.Ext.Visual..::..EditorMouseEventArgs

See Also

EditorMouseEventArgs Members
DynamicNode.Ext.Visual Namespace


EditorMouseEventArgs Members

[image] [image]

DynamicNodes API
EditorMouseEventArgs Members
EditorMouseEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorMouseEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EditorMouseEventArgs | Initialisiert eine EditorMouseEventArgs-Instanz.

Properties

 | Name | Description
Public property | Node | Gibt den Knoten zurück, welcher unter dem Cursor liegt.
Public property | Pin | Gibt den Pin zurück, welcher unter dem Cursor liegt.
Public property | Port | Gibt den Anschluss zurück, welcher unter dem Cursor liegt.
Public property | WorkspaceLocation | Gibt die Position des Maus-Cursors auf der Arbeitsfläche zurück.
Public property | WorkspaceX | Gibt die X-Position des Maus-Cursors auf der Arbeitsfläche zurück.
Public property | WorkspaceY | Gibt die Y-Position des Maus-Cursors auf der Arbeitsfläche zurück.

See Also

EditorMouseEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorMouseEventArgs Constructor

[image]

DynamicNodes API
EditorMouseEventArgs Constructor
EditorMouseEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine EditorMouseEventArgs-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public EditorMouseEventArgs(
    MouseEventArgs e,
    IEditor editor
)
Visual Basic
Public Sub New ( _
    e As MouseEventArgs, _
    editor As IEditor _
)
F#
new :
        e:MouseEventArgs *
        editor:IEditor -> EditorMouseEventArgs

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
Die MouseEventArgs-Instanz enthält die original Maus-Ereignisdaten.
editor
Type: DynamicNode.Ext.Visual..::..IEditor
Ein Editor, der die Koordinaten transformiert.

See Also

EditorMouseEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorMouseEventArgs Properties

[image] [image]

DynamicNodes API
EditorMouseEventArgs Properties
EditorMouseEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorMouseEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Node | Gibt den Knoten zurück, welcher unter dem Cursor liegt.
Public property | Pin | Gibt den Pin zurück, welcher unter dem Cursor liegt.
Public property | Port | Gibt den Anschluss zurück, welcher unter dem Cursor liegt.
Public property | WorkspaceLocation | Gibt die Position des Maus-Cursors auf der Arbeitsfläche zurück.
Public property | WorkspaceX | Gibt die X-Position des Maus-Cursors auf der Arbeitsfläche zurück.
Public property | WorkspaceY | Gibt die Y-Position des Maus-Cursors auf der Arbeitsfläche zurück.

See Also

EditorMouseEventArgs Class
DynamicNode.Ext.Visual Namespace


Node Property

[image]

DynamicNodes API
EditorMouseEventArgs..::..Node Property
EditorMouseEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Knoten zurück, welcher unter dem Cursor liegt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public INode Node { get; }
Visual Basic
Public ReadOnly Property Node As INode
    Get
F#
member Node : INode

Field Value

Der Knoten unter dem Cursor oder null, wenn kein Knoten unter dem Cursor liegt.

See Also

EditorMouseEventArgs Class
DynamicNode.Ext.Visual Namespace


Pin Property

[image]

DynamicNodes API
EditorMouseEventArgs..::..Pin Property
EditorMouseEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Pin zurück, welcher unter dem Cursor liegt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Pin Pin { get; }
Visual Basic
Public ReadOnly Property Pin As Pin
    Get
F#
member Pin : Pin

Field Value

Der Pin unter dem Cursor oder null, wenn kein Pin unter dem Cursor liegt.

See Also

EditorMouseEventArgs Class
DynamicNode.Ext.Visual Namespace


Port Property

[image]

DynamicNodes API
EditorMouseEventArgs..::..Port Property
EditorMouseEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Anschluss zurück, welcher unter dem Cursor liegt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IPort Port { get; }
Visual Basic
Public ReadOnly Property Port As IPort
    Get
F#
member Port : IPort

Field Value

Der Anschluss unter dem Cursor oder null, wenn kein Anschluss unter dem Cursor liegt.

See Also

EditorMouseEventArgs Class
DynamicNode.Ext.Visual Namespace


WorkspaceLocation Property

[image]

DynamicNodes API
EditorMouseEventArgs..::..WorkspaceLocation Property
EditorMouseEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Position des Maus-Cursors auf der Arbeitsfläche zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PointF WorkspaceLocation { get; }
Visual Basic
Public ReadOnly Property WorkspaceLocation As PointF
    Get
F#
member WorkspaceLocation : PointF

Field Value

Die Cursor-Position auf der Arbeitsfläche.

See Also

EditorMouseEventArgs Class
DynamicNode.Ext.Visual Namespace


WorkspaceX Property

[image]

DynamicNodes API
EditorMouseEventArgs..::..WorkspaceX Property
EditorMouseEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die X-Position des Maus-Cursors auf der Arbeitsfläche zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float WorkspaceX { get; }
Visual Basic
Public ReadOnly Property WorkspaceX As Single
    Get
F#
member WorkspaceX : float32

Field Value

Die X-Cursor-Position auf der Arbeitsfläche.

See Also

EditorMouseEventArgs Class
DynamicNode.Ext.Visual Namespace


WorkspaceY Property

[image]

DynamicNodes API
EditorMouseEventArgs..::..WorkspaceY Property
EditorMouseEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Y-Position des Maus-Cursors auf der Arbeitsfläche zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float WorkspaceY { get; }
Visual Basic
Public ReadOnly Property WorkspaceY As Single
    Get
F#
member WorkspaceY : float32

Field Value

Die Y-Cursor-Position auf der Arbeitsfläche.

See Also

EditorMouseEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorNodeEventArgs Class

[image]

DynamicNodes API
EditorNodeEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignis-Parameter für die Änderung der Knotenauswahl.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class EditorNodeEventArgs : EventArgs
Visual Basic
Public Class EditorNodeEventArgs _
    Inherits EventArgs
F#
type EditorNodeEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Ext.Visual..::..EditorNodeEventArgs

See Also

EditorNodeEventArgs Members
DynamicNode.Ext.Visual Namespace


EditorNodeEventArgs Members

[image] [image]

DynamicNodes API
EditorNodeEventArgs Members
EditorNodeEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorNodeEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EditorNodeEventArgs | Initialisiert eine EditorNodeSelectionEventArgs-Instanz.

Properties

 | Name | Description
Public property | Node | Gibt den primär ausgewählten Knoten oder null zurück.

See Also

EditorNodeEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorNodeEventArgs Constructor

[image]

DynamicNodes API
EditorNodeEventArgs Constructor
EditorNodeEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine EditorNodeSelectionEventArgs-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public EditorNodeEventArgs(
    INode node
)
Visual Basic
Public Sub New ( _
    node As INode _
)
F#
new :
        node:INode -> EditorNodeEventArgs

Parameters

node
Type: DynamicNode.Core..::..INode
Der primär ausgewählte Knoten, oder null.

See Also

EditorNodeEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorNodeEventArgs Properties

[image] [image]

DynamicNodes API
EditorNodeEventArgs Properties
EditorNodeEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorNodeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Node | Gibt den primär ausgewählten Knoten oder null zurück.

See Also

EditorNodeEventArgs Class
DynamicNode.Ext.Visual Namespace


Node Property

[image]

DynamicNodes API
EditorNodeEventArgs..::..Node Property
EditorNodeEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den primär ausgewählten Knoten oder null zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public INode Node { get; }
Visual Basic
Public ReadOnly Property Node As INode
    Get
F#
member Node : INode

Field Value

Der primär ausgewählte Knoten oder null.

See Also

EditorNodeEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorNodeSelectionEventArgs Class

[image]

DynamicNodes API
EditorNodeSelectionEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignis-Parameter für die Änderung der Knotenauswahl.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class EditorNodeSelectionEventArgs : EventArgs
Visual Basic
Public Class EditorNodeSelectionEventArgs _
    Inherits EventArgs
F#
type EditorNodeSelectionEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Ext.Visual..::..EditorNodeSelectionEventArgs

See Also

EditorNodeSelectionEventArgs Members
DynamicNode.Ext.Visual Namespace


EditorNodeSelectionEventArgs Members

[image] [image]

DynamicNodes API
EditorNodeSelectionEventArgs Members
EditorNodeSelectionEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorNodeSelectionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EditorNodeSelectionEventArgs | Initialisiert eine EditorNodeSelectionEventArgs-Instanz.

Properties

 | Name | Description
Public property | Node | Gibt den primär ausgewählten Knoten oder null zurück.
Public property | NodeSet | Gibt ein Array mit allen ausgewählten Knoten zurück.

See Also

EditorNodeSelectionEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorNodeSelectionEventArgs Constructor

[image]

DynamicNodes API
EditorNodeSelectionEventArgs Constructor
EditorNodeSelectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine EditorNodeSelectionEventArgs-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public EditorNodeSelectionEventArgs(
    INode node,
    INode[] nodeset
)
Visual Basic
Public Sub New ( _
    node As INode, _
    nodeset As INode() _
)
F#
new :
        node:INode *
        nodeset:INode[] -> EditorNodeSelectionEventArgs

Parameters

node
Type: DynamicNode.Core..::..INode
Der primär ausgewählte Knoten, oder null.
nodeset
Type: array< DynamicNode.Core..::..INode >[]()[][]
Eine Auswahl mit allen Knoten.

See Also

EditorNodeSelectionEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorNodeSelectionEventArgs Properties

[image] [image]

DynamicNodes API
EditorNodeSelectionEventArgs Properties
EditorNodeSelectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorNodeSelectionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Node | Gibt den primär ausgewählten Knoten oder null zurück.
Public property | NodeSet | Gibt ein Array mit allen ausgewählten Knoten zurück.

See Also

EditorNodeSelectionEventArgs Class
DynamicNode.Ext.Visual Namespace


Node Property

[image]

DynamicNodes API
EditorNodeSelectionEventArgs..::..Node Property
EditorNodeSelectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den primär ausgewählten Knoten oder null zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public INode Node { get; }
Visual Basic
Public ReadOnly Property Node As INode
    Get
F#
member Node : INode

Field Value

Der primär ausgewählte Knoten oder null.

See Also

EditorNodeSelectionEventArgs Class
DynamicNode.Ext.Visual Namespace


NodeSet Property

[image]

DynamicNodes API
EditorNodeSelectionEventArgs..::..NodeSet Property
EditorNodeSelectionEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen ausgewählten Knoten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public INode[] NodeSet { get; }
Visual Basic
Public ReadOnly Property NodeSet As INode()
    Get
F#
member NodeSet : INode[]

See Also

EditorNodeSelectionEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorPortEventArgs Class

[image]

DynamicNodes API
EditorPortEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignis-Parameter für die Veränderung der Portauswahl.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class EditorPortEventArgs : EventArgs
Visual Basic
Public Class EditorPortEventArgs _
    Inherits EventArgs
F#
type EditorPortEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Ext.Visual..::..EditorPortEventArgs

See Also

EditorPortEventArgs Members
DynamicNode.Ext.Visual Namespace


EditorPortEventArgs Members

[image] [image]

DynamicNodes API
EditorPortEventArgs Members
EditorPortEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorPortEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EditorPortEventArgs | Initialisiert eine EditorPortEventArgs-Instanz.

Properties

 | Name | Description
Public property | Port | Gibt den ausgewählte Port, oder null zurück.

See Also

EditorPortEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorPortEventArgs Constructor

[image]

DynamicNodes API
EditorPortEventArgs Constructor
EditorPortEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine EditorPortEventArgs-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public EditorPortEventArgs(
    IPort port
)
Visual Basic
Public Sub New ( _
    port As IPort _
)
F#
new :
        port:IPort -> EditorPortEventArgs

Parameters

port
Type: DynamicNode.Core..::..IPort
Der ausgewählte Port, oder null.

See Also

EditorPortEventArgs Class
DynamicNode.Ext.Visual Namespace


EditorPortEventArgs Properties

[image] [image]

DynamicNodes API
EditorPortEventArgs Properties
EditorPortEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The EditorPortEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Port | Gibt den ausgewählte Port, oder null zurück.

See Also

EditorPortEventArgs Class
DynamicNode.Ext.Visual Namespace


Port Property

[image]

DynamicNodes API
EditorPortEventArgs..::..Port Property
EditorPortEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den ausgewählte Port, oder null zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IPort Port { get; }
Visual Basic
Public ReadOnly Property Port As IPort
    Get
F#
member Port : IPort

Field Value

Dern ausgewählten Port, oder null.

See Also

EditorPortEventArgs Class
DynamicNode.Ext.Visual Namespace


ExtendedUserControl Class

[image]

DynamicNodes API
ExtendedUserControl Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erweitert die Klasse UserControl um KeyPreview-Fähigkeit.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class ExtendedUserControl : UserControl
Visual Basic
Public Class ExtendedUserControl _
    Inherits UserControl
F#
type ExtendedUserControl =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Visual..::..ExtendedUserControl
DynamicNode.Ext.Visual..::..EditorControl

See Also

ExtendedUserControl Members
DynamicNode.Ext.Visual Namespace


ExtendedUserControl Members

[image] [image]

DynamicNodes API
ExtendedUserControl Members
ExtendedUserControl Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ExtendedUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | ExtendedUserControl | Initializes a new instance of the ExtendedUserControl class

Methods

 | Name | Description
Protected method | OnExtPreviewKeyDown | Löst das Ereignis ExtPreviewKeyDown aus.
Protected method | OnExtPreviewKeyUp | Löst das Ereignis ExtPreviewKeyUp aus.
Protected method | ProcessKeyPreview | Previews a keyboard message. (Overrides Control..::..ProcessKeyPreview(Message%).)

Properties

 | Name | Description
Public property | KeyPreview | Liest oder schreibt einen Wert der angibt ob KeyUp- und KeyDown-Ereignisse von untergeordneten Controls abgefangen werden sollen.

Events

 | Name | Description
Public event | ExtPreviewKeyDown | Tritt auf, wenn KeyPreview gleich true ist, eine Taste gedrückt wird und dieses oder ein untergeordnetes Steuerelement den Eingabefokus hat.
Public event | ExtPreviewKeyUp | Tritt auf, wenn KeyPreview gleich true ist, eine Taste losgelassen wird und dieses oder ein untergeordnetes Steuerelement den Eingabefokus hat.

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


ExtendedUserControl Constructor

[image]

DynamicNodes API
ExtendedUserControl Constructor
ExtendedUserControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the ExtendedUserControl class

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public ExtendedUserControl()
Visual Basic
Public Sub New
F#
new : unit -> ExtendedUserControl

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


ExtendedUserControl Methods

[image] [image]

DynamicNodes API
ExtendedUserControl Methods
ExtendedUserControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ExtendedUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | OnExtPreviewKeyDown | Löst das Ereignis ExtPreviewKeyDown aus.
Protected method | OnExtPreviewKeyUp | Löst das Ereignis ExtPreviewKeyUp aus.
Protected method | ProcessKeyPreview | Previews a keyboard message. (Overrides Control..::..ProcessKeyPreview(Message%).)

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


OnExtPreviewKeyDown Method

[image]

DynamicNodes API
ExtendedUserControl..::..OnExtPreviewKeyDown Method
ExtendedUserControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis ExtPreviewKeyDown aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected void OnExtPreviewKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Sub OnExtPreviewKeyDown ( _
    e As KeyEventArgs _
)
F#
member OnExtPreviewKeyDown :
        e:KeyEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
Eine Instanz von KeyEventArgs, welche die Ereignisparameter enthält.

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


OnExtPreviewKeyUp Method

[image]

DynamicNodes API
ExtendedUserControl..::..OnExtPreviewKeyUp Method
ExtendedUserControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis ExtPreviewKeyUp aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected void OnExtPreviewKeyUp(
    KeyEventArgs e
)
Visual Basic
Protected Sub OnExtPreviewKeyUp ( _
    e As KeyEventArgs _
)
F#
member OnExtPreviewKeyUp :
        e:KeyEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
Eine Instanz von KeyEventArgs, welche die Ereignisparameter enthält.

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


ProcessKeyPreview Method

[image]

DynamicNodes API
ExtendedUserControl..::..ProcessKeyPreview Method
ExtendedUserControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Previews a keyboard message.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override bool ProcessKeyPreview(
    ref Message m
)
Visual Basic
Protected Overrides Function ProcessKeyPreview ( _
    ByRef m As Message _
) As Boolean
F#
abstract ProcessKeyPreview :
        m:Message byref -> bool
override ProcessKeyPreview :
        m:Message byref -> bool

Parameters

m
Type: System.Windows.Forms..::..Message %
A Message, passed by reference, that represents the window message to process.

Return Value

true if the message was processed by the control; otherwise, false.

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


ExtendedUserControl Properties

[image] [image]

DynamicNodes API
ExtendedUserControl Properties
ExtendedUserControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ExtendedUserControl type exposes the following members.

Properties

 | Name | Description
Public property | KeyPreview | Liest oder schreibt einen Wert der angibt ob KeyUp- und KeyDown-Ereignisse von untergeordneten Controls abgefangen werden sollen.

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


KeyPreview Property

[image]

DynamicNodes API
ExtendedUserControl..::..KeyPreview Property
ExtendedUserControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert der angibt ob KeyUp- und KeyDown-Ereignisse von untergeordneten Controls abgefangen werden sollen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool KeyPreview { get; set; }
Visual Basic
Public Property KeyPreview As Boolean
    Get
    Set
F#
member KeyPreview : bool with get, set

Field Value

true wenn Tastatur-Ereignisse von Kind-Steuerelementen abgefangen werden sollen, sonst false.

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


ExtendedUserControl Events

[image] [image]

DynamicNodes API
ExtendedUserControl Events
ExtendedUserControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ExtendedUserControl type exposes the following members.

Events

 | Name | Description
Public event | ExtPreviewKeyDown | Tritt auf, wenn KeyPreview gleich true ist, eine Taste gedrückt wird und dieses oder ein untergeordnetes Steuerelement den Eingabefokus hat.
Public event | ExtPreviewKeyUp | Tritt auf, wenn KeyPreview gleich true ist, eine Taste losgelassen wird und dieses oder ein untergeordnetes Steuerelement den Eingabefokus hat.

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


ExtPreviewKeyDown Event

[image]

DynamicNodes API
ExtendedUserControl..::..ExtPreviewKeyDown Event
ExtendedUserControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn KeyPreview gleich true ist, eine Taste gedrückt wird und dieses oder ein untergeordnetes Steuerelement den Eingabefokus hat.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event KeyEventHandler ExtPreviewKeyDown
Visual Basic
Public Event ExtPreviewKeyDown As KeyEventHandler
F#
member ExtPreviewKeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


ExtPreviewKeyUp Event

[image]

DynamicNodes API
ExtendedUserControl..::..ExtPreviewKeyUp Event
ExtendedUserControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn KeyPreview gleich true ist, eine Taste losgelassen wird und dieses oder ein untergeordnetes Steuerelement den Eingabefokus hat.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event KeyEventHandler ExtPreviewKeyUp
Visual Basic
Public Event ExtPreviewKeyUp As KeyEventHandler
F#
member ExtPreviewKeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>

See Also

ExtendedUserControl Class
DynamicNode.Ext.Visual Namespace


GenericDelegate(T) Delegate

[image]

DynamicNodes API
GenericDelegate<(Of <(<'T>)>)> Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein generisches Delegate mit einem T Parameter für die Verwendung mit ThreadHelper.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public delegate void GenericDelegate<T>(
    T v
)
Visual Basic
Public Delegate Sub GenericDelegate(Of T) ( _
    v As T _
)
F#
type GenericDelegate =
    delegate of
        v:'T -> unit

Parameters

v
Type: T
Ein Objekt vom Typ T.

Type Parameters

T
Der Datentyp des generischen Delegates.

See Also

DynamicNode.Ext.Visual Namespace


GraphDocument Class

[image]

DynamicNodes API
GraphDocument Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standard-Implementierung von IGraphDocument.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class GraphDocument : IGraphDocument,
    IDisposable
Visual Basic
Public Class GraphDocument _
    Implements IGraphDocument, IDisposable
F#
type GraphDocument =
    class
        interface IGraphDocument
        interface IDisposable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..GraphDocument
DynamicNode.WinApp..::..Document

See Also

GraphDocument Members
DynamicNode.Ext.Visual Namespace


GraphDocument Members

[image] [image]

DynamicNodes API
GraphDocument Members
GraphDocument Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphDocument type exposes the following members.

Constructors

 | Name | Description
Public method | GraphDocument | Initialisiert eine GraphDocument-Instanz.

Methods

 | Name | Description
Public method | BeginConnectingProcess | Startet den visuellen Verbindungs-Prozess und wählt den übergebenen Anschluss aus.
Public method | BeginVisualSelectionProcess | Startet den visuellen Auswahl-Prozess.
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.
Public method | EndConnectingProcess | Ends the connecting process.
Public method | EndVisualSelectionProcess | Benachrichtigt das Graph-Dokument über das Ende des Auswahlprozesses.
Public method | ExtendNodeSelection(INode) | Fügt einen Knoten der Knotenauswahl hinzu.
Public method | ExtendNodeSelection(IEnumerable<(Of <<'(INode>)>>)) | Fügt mehrere Knoten der Knotenauswahl hinzu.
Protected method | Finalize | Gibt nicht verwaltete Resourcen frei und/oder führt weitere Aufräumarbeiten durch bevor das GraphDocument-Objekt durch den Garbage Collector aufgelöst wird. (Overrides Object..::..Finalize()()()().)
Public method | GetGraphVis | Gibt die Visualieirung für der Graph zurück.
Public method | GetNodeByMouse | Gibt einen Knoten anhand von Workspace-Koordinaten zurück.
Public method | GetPinByMouse | Gibt einen Pin anhand von Workspace-Koordinaten zurück.
Public method | GetPortByMouse | Gibt einen Port anhand von Workspace-Koordinaten zurück.
Public method | HitTest | Prüft mit Hilfe von Editor-Koordinaten ob sich ein Objekt unter dem Cursor befindet.
Public method | IsNodeSecondarySelected | Gibt einen Wert zurück, der angibt, ob der übergebene Knoten sekundär markiert ist.
Public method | OnGraphProperties | Löst das Ereignis NodeProperties aus.
Public method | OnMouseClick | Löst das Ereignis MouseClick aus.
Public method | OnMouseDoubleClick | Löst das Ereignis MouseDoubleClick aus.
Public method | OnMouseDown | Löst das Ereignis MouseDown aus.
Public method | OnMouseEnter | Löst das Ereignis MouseEnter aus.
Public method | OnMouseHover | Löst das Ereignis MouseHover aus.
Public method | OnMouseLeave | Löst das Ereignis MouseLeave aus.
Public method | OnMouseMove | Löst das Ereignis MouseMove aus.
Public method | OnMouseNodeEnter | Löst das Ereignis MouseNodeEnter aus.
Public method | OnMouseNodeLeave | Löst das Ereignis MouseNodeLeave aus.
Public method | OnMousePortEnter | Löst das Ereignis MousePortEnter aus.
Public method | OnMousePortLeave | Löst das Ereignis MousePortLeave aus.
Public method | OnMouseUp | Löst das Ereignis MouseUp aus.
Public method | OnMouseWheel | Löst das Ereignis MouseWheel aus.
Public method | OnNodeHelp | Löst das Ereignis NodeHelp aus.
Public method | OnNodeProperties | Löst das Ereignis NodeProperties aus.
Public method | OnNodeSelect | Löst das Ereignis NodeSelect aus.
Public method | OnPortProperties | Löst das Ereignis PortProperties aus.
Public method | OnShowSubGraph | Löst das Ereignis ShowSubGraph aus.
Public method | ReduceNodeSelection | Entfernt einen Knoten aus der Knotenauswahl.
Public method | Repaint | Zeichnet das Graph-Dokument neu.
Public method | SelectNothing | Löscht die aktuelle Auswahl.
Public method | WhileConnectingProcess | Benachrichtigt der Graph-Dokument über die Cursor-Bewegung während des Verbindungsprozesses.
Public method | WhileVisualSelectionProcess | Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Auswahlprozesses.

Properties

 | Name | Description
Public property | AutoRepaint | Liest oder schreibt einen Wert, der angibt ob die Arbeitsfläche bei Änderungen des Graphen automatisch neu gezeichnet werden soll.
Public property | Editor | Liest oder schreibt den Eitor.
Public property | Graph | Liest der Graph, welches dargestellt werden soll.
Public property | IsConnectingInProgress | Gibt einen Wert zurück, der angibt, ob ein Verbindungsprozess aktiv ist.
Public property | IsMouseOverDocument | Gibt einen Wert zurück, der angibt ob der Cursor sich zur Zeit über dem Dokument befindet.
Public property | IsPinVisible | Gibt einen Wert zurück, der angibt ob die Pins der Verbindungen sichtbar sind oder nicht.
Public property | Runtime | Gibt die Laufzeitumgebung zurück in der der Graph ausgeführt wird.
Public property | SecondarySelectedNodes | Gibt eine Auflistung mit allen sekundär markierten Knoten zurück.
Public property | SecondarySelectedNodesCount | Gibt die Anzahl aller sekundär markierten Knoten einschließlich des primär markierten Knotens zurück.
Public property | SelectedNode | Gibt den ausgewählten Knoten zurück oder legt ihn fest.
Public property | SelectedPin | Liest oder schreibt den ausgewählten Pin.
Public property | SelectedPort | Liest oder schreibt den ausgewählten Port.

Events

 | Name | Description
Public event | Disposing | Wird ausgelöst, wenn das Dokument zerstört wird.
Public event | GraphProperties | Wird ausgelöst, wenn für einen Graphen der Eigenschaftsdialog angefordert wurde.
Public event | MouseClick | Wird ausgelöst, wenn ein Klick ausgeführt wurde.
Public event | MouseDoubleClick | Wird ausgelöst, wenn die Doppel-Klick ausgeführt wurde.
Public event | MouseDown | Wird ausgelöst, wenn eine Maustaste gedrückt wird.
Public event | MouseEnter | Wird ausgelöst, wenn der Cursor den Editor betritt.
Public event | MouseHover | Wird ausgelöst, wenn der Cursor über der Arbeitsfläche verweilt.
Public event | MouseLeave | Wird ausgelöst, wenn der Cursor den Editor verlässt.
Public event | MouseMove | Wird ausgelöst, wenn der Cursor bewegt wird.
Public event | MouseNodeEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Knotens hinien bewegt wird.
Public event | MouseNodeLeave | Wird ausgelöst, wenn der Cursor den Bereich eines Knotens verlässt.
Public event | MousePortEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Ports hineinbewegt wird.
Public event | MousePortLeave | Wird ausgelöst, wenn der Cursor aus dem Bereich eines Ports herrausbewegt wird.
Public event | MouseUp | Wird ausgelöst, wenn eine Maustaste losgelassen wird.
Public event | MouseWheel | Wird ausgelöst, wenn das Mausrad gedreht wird.
Public event | NodeHelp | Wird ausgelöst, wenn für einen Knoten Hilfe angefordert wird.
Public event | NodeProperties | Wird ausgelöst, wenn für einen Knoten der Eigenschaftsdialog angefordert wurde.
Public event | NodeSelect | Wird ausgelöst, wenn ein Knoten ausgewählt wird.
Public event | PortProperties | Wird ausgelöst, wenn für einen Port der Eigenschaftsdialog angefordert wurde.
Public event | ShowSubGraph | Wird ausgelöst, wenn ein Sub-Graph-Knoten den gekapselten Graphen anzeigen möchte.

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


GraphDocument Constructor

[image]

DynamicNodes API
GraphDocument Constructor
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine GraphDocument-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public GraphDocument(
    IGraph graph
)
Visual Basic
Public Sub New ( _
    graph As IGraph _
)
F#
new :
        graph:IGraph -> GraphDocument

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Der Graph.

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


GraphDocument Methods

[image] [image]

DynamicNodes API
GraphDocument Methods
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphDocument type exposes the following members.

Methods

 | Name | Description
Public method | BeginConnectingProcess | Startet den visuellen Verbindungs-Prozess und wählt den übergebenen Anschluss aus.
Public method | BeginVisualSelectionProcess | Startet den visuellen Auswahl-Prozess.
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.
Public method | EndConnectingProcess | Ends the connecting process.
Public method | EndVisualSelectionProcess | Benachrichtigt das Graph-Dokument über das Ende des Auswahlprozesses.
Public method | ExtendNodeSelection(INode) | Fügt einen Knoten der Knotenauswahl hinzu.
Public method | ExtendNodeSelection(IEnumerable<(Of <<'(INode>)>>)) | Fügt mehrere Knoten der Knotenauswahl hinzu.
Protected method | Finalize | Gibt nicht verwaltete Resourcen frei und/oder führt weitere Aufräumarbeiten durch bevor das GraphDocument-Objekt durch den Garbage Collector aufgelöst wird. (Overrides Object..::..Finalize()()()().)
Public method | GetGraphVis | Gibt die Visualieirung für der Graph zurück.
Public method | GetNodeByMouse | Gibt einen Knoten anhand von Workspace-Koordinaten zurück.
Public method | GetPinByMouse | Gibt einen Pin anhand von Workspace-Koordinaten zurück.
Public method | GetPortByMouse | Gibt einen Port anhand von Workspace-Koordinaten zurück.
Public method | HitTest | Prüft mit Hilfe von Editor-Koordinaten ob sich ein Objekt unter dem Cursor befindet.
Public method | IsNodeSecondarySelected | Gibt einen Wert zurück, der angibt, ob der übergebene Knoten sekundär markiert ist.
Public method | OnGraphProperties | Löst das Ereignis NodeProperties aus.
Public method | OnMouseClick | Löst das Ereignis MouseClick aus.
Public method | OnMouseDoubleClick | Löst das Ereignis MouseDoubleClick aus.
Public method | OnMouseDown | Löst das Ereignis MouseDown aus.
Public method | OnMouseEnter | Löst das Ereignis MouseEnter aus.
Public method | OnMouseHover | Löst das Ereignis MouseHover aus.
Public method | OnMouseLeave | Löst das Ereignis MouseLeave aus.
Public method | OnMouseMove | Löst das Ereignis MouseMove aus.
Public method | OnMouseNodeEnter | Löst das Ereignis MouseNodeEnter aus.
Public method | OnMouseNodeLeave | Löst das Ereignis MouseNodeLeave aus.
Public method | OnMousePortEnter | Löst das Ereignis MousePortEnter aus.
Public method | OnMousePortLeave | Löst das Ereignis MousePortLeave aus.
Public method | OnMouseUp | Löst das Ereignis MouseUp aus.
Public method | OnMouseWheel | Löst das Ereignis MouseWheel aus.
Public method | OnNodeHelp | Löst das Ereignis NodeHelp aus.
Public method | OnNodeProperties | Löst das Ereignis NodeProperties aus.
Public method | OnNodeSelect | Löst das Ereignis NodeSelect aus.
Public method | OnPortProperties | Löst das Ereignis PortProperties aus.
Public method | OnShowSubGraph | Löst das Ereignis ShowSubGraph aus.
Public method | ReduceNodeSelection | Entfernt einen Knoten aus der Knotenauswahl.
Public method | Repaint | Zeichnet das Graph-Dokument neu.
Public method | SelectNothing | Löscht die aktuelle Auswahl.
Public method | WhileConnectingProcess | Benachrichtigt der Graph-Dokument über die Cursor-Bewegung während des Verbindungsprozesses.
Public method | WhileVisualSelectionProcess | Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Auswahlprozesses.

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


BeginConnectingProcess Method

[image]

DynamicNodes API
GraphDocument..::..BeginConnectingProcess Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Startet den visuellen Verbindungs-Prozess und wählt den übergebenen Anschluss aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void BeginConnectingProcess(
    IPort p
)
Visual Basic
Public Sub BeginConnectingProcess ( _
    p As IPort _
)
F#
abstract BeginConnectingProcess :
        p:IPort -> unit
override BeginConnectingProcess :
        p:IPort -> unit

Parameters

p
Type: DynamicNode.Core..::..IPort
Der Port mit dem die Verbindung beginnt.

Implements

IGraphDocument..::..BeginConnectingProcess(IPort)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


BeginVisualSelectionProcess Method

[image]

DynamicNodes API
GraphDocument..::..BeginVisualSelectionProcess Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Startet den visuellen Auswahl-Prozess.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void BeginVisualSelectionProcess(
    float x,
    float y
)
Visual Basic
Public Sub BeginVisualSelectionProcess ( _
    x As Single, _
    y As Single _
)
F#
abstract BeginVisualSelectionProcess :
        x:float32 *
        y:float32 -> unit
override BeginVisualSelectionProcess :
        x:float32 *
        y:float32 -> unit

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.

Implements

IGraphDocument..::..BeginVisualSelectionProcess(Single, Single)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


Dispose Method

[image]

DynamicNodes API
GraphDocument..::..Dispose Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void Dispose()
Visual Basic
Public Overridable Sub Dispose
F#
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposable..::..Dispose()()()()

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


EndConnectingProcess Method

[image]

DynamicNodes API
GraphDocument..::..EndConnectingProcess Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ends the connecting process.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void EndConnectingProcess(
    IPort n
)
Visual Basic
Public Sub EndConnectingProcess ( _
    n As IPort _
)
F#
abstract EndConnectingProcess :
        n:IPort -> unit
override EndConnectingProcess :
        n:IPort -> unit

Parameters

n
Type: DynamicNode.Core..::..IPort
The n.

Implements

IGraphDocument..::..EndConnectingProcess(IPort)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


EndVisualSelectionProcess Method

[image]

DynamicNodes API
GraphDocument..::..EndVisualSelectionProcess Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Benachrichtigt das Graph-Dokument über das Ende des Auswahlprozesses.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void EndVisualSelectionProcess()
Visual Basic
Public Sub EndVisualSelectionProcess
F#
abstract EndVisualSelectionProcess : unit -> unit
override EndVisualSelectionProcess : unit -> unit

Implements

IGraphDocument..::..EndVisualSelectionProcess()()()()

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


ExtendNodeSelection Method

[image] [image]

DynamicNodes API
GraphDocument..::..ExtendNodeSelection Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ExtendNodeSelection(INode) | Fügt einen Knoten der Knotenauswahl hinzu.
Public method | ExtendNodeSelection(IEnumerable<(Of <<'(INode>)>>)) | Fügt mehrere Knoten der Knotenauswahl hinzu.

See Also

GraphDocument Class
GraphDocument Members
DynamicNode.Ext.Visual Namespace


ExtendNodeSelection Method (INode)

[image]

DynamicNodes API
GraphDocument..::..ExtendNodeSelection Method (INode)
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt einen Knoten der Knotenauswahl hinzu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void ExtendNodeSelection(
    INode node
)
Visual Basic
Public Sub ExtendNodeSelection ( _
    node As INode _
)
F#
abstract ExtendNodeSelection :
        node:INode -> unit
override ExtendNodeSelection :
        node:INode -> unit

Parameters

node
Type: DynamicNode.Core..::..INode
Der Knoten.

Implements

IGraphDocument..::..ExtendNodeSelection(INode)

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für nodenull übergeben wurde.

See Also

GraphDocument Class
ExtendNodeSelection Overload
DynamicNode.Ext.Visual Namespace


ExtendNodeSelection Method (IEnumerable(INode))

[image]

DynamicNodes API
GraphDocument..::..ExtendNodeSelection Method (IEnumerable<(Of <(<'INode>)>)>)
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt mehrere Knoten der Knotenauswahl hinzu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void ExtendNodeSelection(
    IEnumerable<INode> nodes
)
Visual Basic
Public Sub ExtendNodeSelection ( _
    nodes As IEnumerable(Of INode) _
)
F#
abstract ExtendNodeSelection :
        nodes:IEnumerable<INode> -> unit
override ExtendNodeSelection :
        nodes:IEnumerable<INode> -> unit

Parameters

nodes
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' INode >)>)>
Die Auflistung der Knoten.

Implements

IGraphDocument..::..ExtendNodeSelection(IEnumerable<(Of <<'(INode>)>>))

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für nodesnull übergeben wurde.

See Also

GraphDocument Class
ExtendNodeSelection Overload
DynamicNode.Ext.Visual Namespace


Finalize Method

[image]

DynamicNodes API
GraphDocument..::..Finalize Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt nicht verwaltete Resourcen frei und/oder führt weitere Aufräumarbeiten durch bevor das GraphDocument-Objekt durch den Garbage Collector aufgelöst wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
F#
abstract Finalize : unit -> unit
override Finalize : unit -> unit

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


GetGraphVis Method

[image]

DynamicNodes API
GraphDocument..::..GetGraphVis Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Visualieirung für der Graph zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public GraphVisualization GetGraphVis()
Visual Basic
Public Function GetGraphVis As GraphVisualization
F#
abstract GetGraphVis : unit -> GraphVisualization
override GetGraphVis : unit -> GraphVisualization

Return Value

Die Visualisierung für der Graph oder null, wenn an der Graph keine Visualisierung angefügt ist.

Implements

IGraphDocument..::..GetGraphVis()()()()

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


GetNodeByMouse Method

[image]

DynamicNodes API
GraphDocument..::..GetNodeByMouse Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Knoten anhand von Workspace-Koordinaten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public INode GetNodeByMouse(
    float x,
    float y,
    bool border
)
Visual Basic
Public Function GetNodeByMouse ( _
    x As Single, _
    y As Single, _
    border As Boolean _
) As INode
F#
abstract GetNodeByMouse :
        x:float32 *
        y:float32 *
        border:bool -> INode
override GetNodeByMouse :
        x:float32 *
        y:float32 *
        border:bool -> INode

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceX-Koordinate.
border
Type: System..::..Boolean
Wenn true wird der Randbereich der Knoten, in dem sich die Ports befinden, bei der Prüfung berücksichtigt.

Return Value

Ein Knoten, oder null, wenn die Koordinaten in keinem Knoten lagen.

Implements

IGraphDocument..::..GetNodeByMouse(Single, Single, Boolean)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


GetPinByMouse Method

[image]

DynamicNodes API
GraphDocument..::..GetPinByMouse Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Pin anhand von Workspace-Koordinaten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Pin GetPinByMouse(
    float x,
    float y
)
Visual Basic
Public Function GetPinByMouse ( _
    x As Single, _
    y As Single _
) As Pin
F#
abstract GetPinByMouse :
        x:float32 *
        y:float32 -> Pin
override GetPinByMouse :
        x:float32 *
        y:float32 -> Pin

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceX-Koordinate.

Return Value

Ein Pin, oder null, wenn die Koordinaten in keinem Pin liegen.

Implements

IGraphDocument..::..GetPinByMouse(Single, Single)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


GetPortByMouse Method

[image]

DynamicNodes API
GraphDocument..::..GetPortByMouse Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Port anhand von Workspace-Koordinaten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IPort GetPortByMouse(
    float x,
    float y
)
Visual Basic
Public Function GetPortByMouse ( _
    x As Single, _
    y As Single _
) As IPort
F#
abstract GetPortByMouse :
        x:float32 *
        y:float32 -> IPort
override GetPortByMouse :
        x:float32 *
        y:float32 -> IPort

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceX-Koordinate.

Return Value

Ein Port, oder null, wenn die Koordinaten in keinem Port liegen.

Implements

IGraphDocument..::..GetPortByMouse(Single, Single)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


HitTest Method

[image]

DynamicNodes API
GraphDocument..::..HitTest Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft mit Hilfe von Editor-Koordinaten ob sich ein Objekt unter dem Cursor befindet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void HitTest(
    float x,
    float y,
    out INode node,
    out IPort port,
    out Pin pin
)
Visual Basic
Public Sub HitTest ( _
    x As Single, _
    y As Single, _
    <OutAttribute> ByRef node As INode, _
    <OutAttribute> ByRef port As IPort, _
    <OutAttribute> ByRef pin As Pin _
)
F#
abstract HitTest :
        x:float32 *
        y:float32 *
        node:INode byref *
        port:IPort byref *
        pin:Pin byref -> unit
override HitTest :
        x:float32 *
        y:float32 *
        node:INode byref *
        port:IPort byref *
        pin:Pin byref -> unit

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.
node
Type: DynamicNode.Core..::..INode %
Ein Knoten oder null.
port
Type: DynamicNode.Core..::..IPort %
Ein Port oder null.
pin
Type: DynamicNode.Ext.Visual..::..Pin %
Ein Pin oder null.

Implements

IGraphDocument..::..HitTest(Single, Single, INode%, IPort%, Pin%)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


IsNodeSecondarySelected Method

[image]

DynamicNodes API
GraphDocument..::..IsNodeSecondarySelected Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob der übergebene Knoten sekundär markiert ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsNodeSecondarySelected(
    INode node
)
Visual Basic
Public Function IsNodeSecondarySelected ( _
    node As INode _
) As Boolean
F#
abstract IsNodeSecondarySelected :
        node:INode -> bool
override IsNodeSecondarySelected :
        node:INode -> bool

Parameters

node
Type: DynamicNode.Core..::..INode
Der zu überprüfende Knoten.

Return Value

true wenn node sekundär markiert ist, sonst false.

Implements

IGraphDocument..::..IsNodeSecondarySelected(INode)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnGraphProperties Method

[image]

DynamicNodes API
GraphDocument..::..OnGraphProperties Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis NodeProperties aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnGraphProperties(
    EditorDocumentEventArgs e
)
Visual Basic
Public Sub OnGraphProperties ( _
    e As EditorDocumentEventArgs _
)
F#
abstract OnGraphProperties :
        e:EditorDocumentEventArgs -> unit
override OnGraphProperties :
        e:EditorDocumentEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorDocumentEventArgs
Eine EditorNodeSelectionEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnGraphProperties(EditorDocumentEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseClick Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseClick Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseClick aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseClick(
    EditorMouseEventArgs e
)
Visual Basic
Public Sub OnMouseClick ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseClick :
        e:EditorMouseEventArgs -> unit
override OnMouseClick :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnMouseClick(EditorMouseEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseDoubleClick Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseDoubleClick Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseDoubleClick aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseDoubleClick(
    EditorMouseEventArgs e
)
Visual Basic
Public Sub OnMouseDoubleClick ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseDoubleClick :
        e:EditorMouseEventArgs -> unit
override OnMouseDoubleClick :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnMouseDoubleClick(EditorMouseEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseDown Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseDown Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseDown aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseDown(
    EditorMouseEventArgs e
)
Visual Basic
Public Sub OnMouseDown ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseDown :
        e:EditorMouseEventArgs -> unit
override OnMouseDown :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnMouseDown(EditorMouseEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseEnter Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseEnter Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseEnter aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseEnter()
Visual Basic
Public Sub OnMouseEnter
F#
abstract OnMouseEnter : unit -> unit
override OnMouseEnter : unit -> unit

Implements

IGraphDocument..::..OnMouseEnter()()()()

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseHover Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseHover Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseHover aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseHover()
Visual Basic
Public Sub OnMouseHover
F#
abstract OnMouseHover : unit -> unit
override OnMouseHover : unit -> unit

Implements

IGraphDocument..::..OnMouseHover()()()()

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseLeave Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseLeave Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseLeave aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseLeave()
Visual Basic
Public Sub OnMouseLeave
F#
abstract OnMouseLeave : unit -> unit
override OnMouseLeave : unit -> unit

Implements

IGraphDocument..::..OnMouseLeave()()()()

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseMove Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseMove Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseMove aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseMove(
    EditorMouseEventArgs e
)
Visual Basic
Public Sub OnMouseMove ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseMove :
        e:EditorMouseEventArgs -> unit
override OnMouseMove :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnMouseMove(EditorMouseEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseNodeEnter Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseNodeEnter Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseNodeEnter aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseNodeEnter(
    EditorNodeEventArgs e
)
Visual Basic
Public Sub OnMouseNodeEnter ( _
    e As EditorNodeEventArgs _
)
F#
abstract OnMouseNodeEnter :
        e:EditorNodeEventArgs -> unit
override OnMouseNodeEnter :
        e:EditorNodeEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnMouseNodeEnter(EditorNodeEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseNodeLeave Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseNodeLeave Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseNodeLeave aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseNodeLeave(
    EditorNodeEventArgs e
)
Visual Basic
Public Sub OnMouseNodeLeave ( _
    e As EditorNodeEventArgs _
)
F#
abstract OnMouseNodeLeave :
        e:EditorNodeEventArgs -> unit
override OnMouseNodeLeave :
        e:EditorNodeEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnMouseNodeLeave(EditorNodeEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMousePortEnter Method

[image]

DynamicNodes API
GraphDocument..::..OnMousePortEnter Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MousePortEnter aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMousePortEnter(
    EditorPortEventArgs e
)
Visual Basic
Public Sub OnMousePortEnter ( _
    e As EditorPortEventArgs _
)
F#
abstract OnMousePortEnter :
        e:EditorPortEventArgs -> unit
override OnMousePortEnter :
        e:EditorPortEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorPortEventArgs
Eine EditorPortEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnMousePortEnter(EditorPortEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMousePortLeave Method

[image]

DynamicNodes API
GraphDocument..::..OnMousePortLeave Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MousePortLeave aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMousePortLeave(
    EditorPortEventArgs e
)
Visual Basic
Public Sub OnMousePortLeave ( _
    e As EditorPortEventArgs _
)
F#
abstract OnMousePortLeave :
        e:EditorPortEventArgs -> unit
override OnMousePortLeave :
        e:EditorPortEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorPortEventArgs
Eine EditorPortEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnMousePortLeave(EditorPortEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseUp Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseUp Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseUp aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseUp(
    EditorMouseEventArgs e
)
Visual Basic
Public Sub OnMouseUp ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseUp :
        e:EditorMouseEventArgs -> unit
override OnMouseUp :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnMouseUp(EditorMouseEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnMouseWheel Method

[image]

DynamicNodes API
GraphDocument..::..OnMouseWheel Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseWheel aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnMouseWheel(
    EditorMouseEventArgs e
)
Visual Basic
Public Sub OnMouseWheel ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseWheel :
        e:EditorMouseEventArgs -> unit
override OnMouseWheel :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnMouseWheel(EditorMouseEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnNodeHelp Method

[image]

DynamicNodes API
GraphDocument..::..OnNodeHelp Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis NodeHelp aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnNodeHelp(
    EditorNodeEventArgs e
)
Visual Basic
Public Sub OnNodeHelp ( _
    e As EditorNodeEventArgs _
)
F#
abstract OnNodeHelp :
        e:EditorNodeEventArgs -> unit
override OnNodeHelp :
        e:EditorNodeEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnNodeHelp(EditorNodeEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnNodeProperties Method

[image]

DynamicNodes API
GraphDocument..::..OnNodeProperties Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis NodeProperties aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnNodeProperties(
    EditorNodeEventArgs e
)
Visual Basic
Public Sub OnNodeProperties ( _
    e As EditorNodeEventArgs _
)
F#
abstract OnNodeProperties :
        e:EditorNodeEventArgs -> unit
override OnNodeProperties :
        e:EditorNodeEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnNodeProperties(EditorNodeEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnNodeSelect Method

[image]

DynamicNodes API
GraphDocument..::..OnNodeSelect Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis NodeSelect aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnNodeSelect(
    EditorNodeSelectionEventArgs e
)
Visual Basic
Public Sub OnNodeSelect ( _
    e As EditorNodeSelectionEventArgs _
)
F#
abstract OnNodeSelect :
        e:EditorNodeSelectionEventArgs -> unit
override OnNodeSelect :
        e:EditorNodeSelectionEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorNodeSelectionEventArgs
Eine EditorNodeSelectionEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnNodeSelect(EditorNodeSelectionEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnPortProperties Method

[image]

DynamicNodes API
GraphDocument..::..OnPortProperties Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis PortProperties aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnPortProperties(
    EditorPortEventArgs e
)
Visual Basic
Public Sub OnPortProperties ( _
    e As EditorPortEventArgs _
)
F#
abstract OnPortProperties :
        e:EditorPortEventArgs -> unit
override OnPortProperties :
        e:EditorPortEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorPortEventArgs
Eine EditorPortEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnPortProperties(EditorPortEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


OnShowSubGraph Method

[image]

DynamicNodes API
GraphDocument..::..OnShowSubGraph Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis ShowSubGraph aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnShowSubGraph(
    SubGraphEventArgs e
)
Visual Basic
Public Sub OnShowSubGraph ( _
    e As SubGraphEventArgs _
)
F#
abstract OnShowSubGraph :
        e:SubGraphEventArgs -> unit
override OnShowSubGraph :
        e:SubGraphEventArgs -> unit

Parameters

e
Type: DynamicNode.Core..::..SubGraphEventArgs
Eine NodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

Implements

IGraphDocument..::..OnShowSubGraph(SubGraphEventArgs)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


ReduceNodeSelection Method

[image]

DynamicNodes API
GraphDocument..::..ReduceNodeSelection Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt einen Knoten aus der Knotenauswahl.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void ReduceNodeSelection(
    INode node
)
Visual Basic
Public Sub ReduceNodeSelection ( _
    node As INode _
)
F#
abstract ReduceNodeSelection :
        node:INode -> unit
override ReduceNodeSelection :
        node:INode -> unit

Parameters

node
Type: DynamicNode.Core..::..INode
Der Knoten.

Implements

IGraphDocument..::..ReduceNodeSelection(INode)

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für nodenull übergeben wurde.

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


Repaint Method

[image]

DynamicNodes API
GraphDocument..::..Repaint Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet das Graph-Dokument neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void Repaint(
    bool imidiate
)
Visual Basic
Public Sub Repaint ( _
    imidiate As Boolean _
)
F#
abstract Repaint :
        imidiate:bool -> unit
override Repaint :
        imidiate:bool -> unit

Parameters

imidiate
Type: System..::..Boolean
true wenn das Dokument sofort synchron neu gezeichnet werden soll, false wenn das Dokument bei der nächsten Gelegenheit (Leerlauf der Nachrichtenwarteschleife) neu gezeichnet werden soll.

Implements

IGraphDocument..::..Repaint(Boolean)

Remarks

Das Zeichnen des Graph-Dokuments wird verhindert, wenn AutoRepaint auf false gesetzt ist.

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


SelectNothing Method

[image]

DynamicNodes API
GraphDocument..::..SelectNothing Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löscht die aktuelle Auswahl.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void SelectNothing()
Visual Basic
Public Sub SelectNothing
F#
abstract SelectNothing : unit -> unit
override SelectNothing : unit -> unit

Implements

IGraphDocument..::..SelectNothing()()()()

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


WhileConnectingProcess Method

[image]

DynamicNodes API
GraphDocument..::..WhileConnectingProcess Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Benachrichtigt der Graph-Dokument über die Cursor-Bewegung während des Verbindungsprozesses.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void WhileConnectingProcess(
    float x,
    float y,
    IPort portUnderCursor
)
Visual Basic
Public Sub WhileConnectingProcess ( _
    x As Single, _
    y As Single, _
    portUnderCursor As IPort _
)
F#
abstract WhileConnectingProcess :
        x:float32 *
        y:float32 *
        portUnderCursor:IPort -> unit
override WhileConnectingProcess :
        x:float32 *
        y:float32 *
        portUnderCursor:IPort -> unit

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.
portUnderCursor
Type: DynamicNode.Core..::..IPort
Der Port unter dem Cursor oder null.

Implements

IGraphDocument..::..WhileConnectingProcess(Single, Single, IPort)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


WhileVisualSelectionProcess Method

[image]

DynamicNodes API
GraphDocument..::..WhileVisualSelectionProcess Method
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Auswahlprozesses.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void WhileVisualSelectionProcess(
    float x,
    float y
)
Visual Basic
Public Sub WhileVisualSelectionProcess ( _
    x As Single, _
    y As Single _
)
F#
abstract WhileVisualSelectionProcess :
        x:float32 *
        y:float32 -> unit
override WhileVisualSelectionProcess :
        x:float32 *
        y:float32 -> unit

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.

Implements

IGraphDocument..::..WhileVisualSelectionProcess(Single, Single)

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


GraphDocument Properties

[image] [image]

DynamicNodes API
GraphDocument Properties
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphDocument type exposes the following members.

Properties

 | Name | Description
Public property | AutoRepaint | Liest oder schreibt einen Wert, der angibt ob die Arbeitsfläche bei Änderungen des Graphen automatisch neu gezeichnet werden soll.
Public property | Editor | Liest oder schreibt den Eitor.
Public property | Graph | Liest der Graph, welches dargestellt werden soll.
Public property | IsConnectingInProgress | Gibt einen Wert zurück, der angibt, ob ein Verbindungsprozess aktiv ist.
Public property | IsMouseOverDocument | Gibt einen Wert zurück, der angibt ob der Cursor sich zur Zeit über dem Dokument befindet.
Public property | IsPinVisible | Gibt einen Wert zurück, der angibt ob die Pins der Verbindungen sichtbar sind oder nicht.
Public property | Runtime | Gibt die Laufzeitumgebung zurück in der der Graph ausgeführt wird.
Public property | SecondarySelectedNodes | Gibt eine Auflistung mit allen sekundär markierten Knoten zurück.
Public property | SecondarySelectedNodesCount | Gibt die Anzahl aller sekundär markierten Knoten einschließlich des primär markierten Knotens zurück.
Public property | SelectedNode | Gibt den ausgewählten Knoten zurück oder legt ihn fest.
Public property | SelectedPin | Liest oder schreibt den ausgewählten Pin.
Public property | SelectedPort | Liest oder schreibt den ausgewählten Port.

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


AutoRepaint Property

[image]

DynamicNodes API
GraphDocument..::..AutoRepaint Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob die Arbeitsfläche bei Änderungen des Graphen automatisch neu gezeichnet werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool AutoRepaint { get; set; }
Visual Basic
Public Property AutoRepaint As Boolean
    Get
    Set
F#
abstract AutoRepaint : bool with get, set
override AutoRepaint : bool with get, set

Field Value

true wenn die Arbeitsfläche automatisch neu gezeichnet werden soll, sonst false.

Implements

IGraphDocument..::..AutoRepaint

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


Editor Property

[image]

DynamicNodes API
GraphDocument..::..Editor Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Eitor.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IEditor Editor { get; set; }
Visual Basic
Public Property Editor As IEditor
    Get
    Set
F#
abstract Editor : IEditor with get, set
override Editor : IEditor with get, set

Field Value

Der Editor.

Implements

IGraphDocument..::..Editor

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


Graph Property

[image]

DynamicNodes API
GraphDocument..::..Graph Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest der Graph, welches dargestellt werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IGraph Graph { get; }
Visual Basic
Public ReadOnly Property Graph As IGraph
    Get
F#
abstract Graph : IGraph
override Graph : IGraph

Field Value

Der Graph.

Implements

IGraphDocument..::..Graph

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


IsConnectingInProgress Property

[image]

DynamicNodes API
GraphDocument..::..IsConnectingInProgress Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob ein Verbindungsprozess aktiv ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsConnectingInProgress { get; }
Visual Basic
Public ReadOnly Property IsConnectingInProgress As Boolean
    Get
F#
abstract IsConnectingInProgress : bool
override IsConnectingInProgress : bool

Field Value

true wenn ein Verbindungsprozess aktiv ist, sonst false.

Implements

IGraphDocument..::..IsConnectingInProgress

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


IsMouseOverDocument Property

[image]

DynamicNodes API
GraphDocument..::..IsMouseOverDocument Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob der Cursor sich zur Zeit über dem Dokument befindet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsMouseOverDocument { get; private set; }
Visual Basic
Public Property IsMouseOverDocument As Boolean
    Get
    Private Set
F#
abstract IsMouseOverDocument : bool with get, private set
override IsMouseOverDocument : bool with get, private set

Implements

IGraphDocument..::..IsMouseOverDocument

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


IsPinVisible Property

[image]

DynamicNodes API
GraphDocument..::..IsPinVisible Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob die Pins der Verbindungen sichtbar sind oder nicht.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsPinVisible { get; set; }
Visual Basic
Public Property IsPinVisible As Boolean
    Get
    Set
F#
abstract IsPinVisible : bool with get, set
override IsPinVisible : bool with get, set

Field Value

Die Sichtbarkeit der Pins.

Implements

IGraphDocument..::..IsPinVisible

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


Runtime Property

[image]

DynamicNodes API
GraphDocument..::..Runtime Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Laufzeitumgebung zurück in der der Graph ausgeführt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IRuntime Runtime { get; }
Visual Basic
Public ReadOnly Property Runtime As IRuntime
    Get
F#
abstract Runtime : IRuntime
override Runtime : IRuntime

Field Value

Die Laufzeitumgebung.

Implements

IGraphDocument..::..Runtime

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


SecondarySelectedNodes Property

[image]

DynamicNodes API
GraphDocument..::..SecondarySelectedNodes Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Auflistung mit allen sekundär markierten Knoten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IEnumerable<INode> SecondarySelectedNodes { get; }
Visual Basic
Public ReadOnly Property SecondarySelectedNodes As IEnumerable(Of INode)
    Get
F#
abstract SecondarySelectedNodes : IEnumerable<INode>
override SecondarySelectedNodes : IEnumerable<INode>

Implements

IGraphDocument..::..SecondarySelectedNodes

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


SecondarySelectedNodesCount Property

[image]

DynamicNodes API
GraphDocument..::..SecondarySelectedNodesCount Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller sekundär markierten Knoten einschließlich des primär markierten Knotens zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public int SecondarySelectedNodesCount { get; }
Visual Basic
Public ReadOnly Property SecondarySelectedNodesCount As Integer
    Get
F#
abstract SecondarySelectedNodesCount : int
override SecondarySelectedNodesCount : int

Implements

IGraphDocument..::..SecondarySelectedNodesCount

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


SelectedNode Property

[image]

DynamicNodes API
GraphDocument..::..SelectedNode Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den ausgewählten Knoten zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public INode SelectedNode { get; set; }
Visual Basic
Public Property SelectedNode As INode
    Get
    Set
F#
abstract SelectedNode : INode with get, set
override SelectedNode : INode with get, set

Field Value

Der ausgewählte Knoten oder null, wenn kein Knoten ausgewählt ist.

Implements

IGraphDocument..::..SelectedNode

Remarks

Das Ändern dieser Eigenschaft bewirkt kein Neuzeichnen des Dokumentes.

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


SelectedPin Property

[image]

DynamicNodes API
GraphDocument..::..SelectedPin Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den ausgewählten Pin.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Pin SelectedPin { get; set; }
Visual Basic
Public Property SelectedPin As Pin
    Get
    Set
F#
abstract SelectedPin : Pin with get, set
override SelectedPin : Pin with get, set

Field Value

Der ausgewählte Pin oder null, wenn kein Pin ausgewählt ist.

Implements

IGraphDocument..::..SelectedPin

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


SelectedPort Property

[image]

DynamicNodes API
GraphDocument..::..SelectedPort Property
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den ausgewählten Port.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IPort SelectedPort { get; set; }
Visual Basic
Public Property SelectedPort As IPort
    Get
    Set
F#
abstract SelectedPort : IPort with get, set
override SelectedPort : IPort with get, set

Field Value

Der ausgewählte Port oder null, wenn kein Port ausgewählt ist.

Implements

IGraphDocument..::..SelectedPort

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


GraphDocument Events

[image] [image]

DynamicNodes API
GraphDocument Events
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphDocument type exposes the following members.

Events

 | Name | Description
Public event | Disposing | Wird ausgelöst, wenn das Dokument zerstört wird.
Public event | GraphProperties | Wird ausgelöst, wenn für einen Graphen der Eigenschaftsdialog angefordert wurde.
Public event | MouseClick | Wird ausgelöst, wenn ein Klick ausgeführt wurde.
Public event | MouseDoubleClick | Wird ausgelöst, wenn die Doppel-Klick ausgeführt wurde.
Public event | MouseDown | Wird ausgelöst, wenn eine Maustaste gedrückt wird.
Public event | MouseEnter | Wird ausgelöst, wenn der Cursor den Editor betritt.
Public event | MouseHover | Wird ausgelöst, wenn der Cursor über der Arbeitsfläche verweilt.
Public event | MouseLeave | Wird ausgelöst, wenn der Cursor den Editor verlässt.
Public event | MouseMove | Wird ausgelöst, wenn der Cursor bewegt wird.
Public event | MouseNodeEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Knotens hinien bewegt wird.
Public event | MouseNodeLeave | Wird ausgelöst, wenn der Cursor den Bereich eines Knotens verlässt.
Public event | MousePortEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Ports hineinbewegt wird.
Public event | MousePortLeave | Wird ausgelöst, wenn der Cursor aus dem Bereich eines Ports herrausbewegt wird.
Public event | MouseUp | Wird ausgelöst, wenn eine Maustaste losgelassen wird.
Public event | MouseWheel | Wird ausgelöst, wenn das Mausrad gedreht wird.
Public event | NodeHelp | Wird ausgelöst, wenn für einen Knoten Hilfe angefordert wird.
Public event | NodeProperties | Wird ausgelöst, wenn für einen Knoten der Eigenschaftsdialog angefordert wurde.
Public event | NodeSelect | Wird ausgelöst, wenn ein Knoten ausgewählt wird.
Public event | PortProperties | Wird ausgelöst, wenn für einen Port der Eigenschaftsdialog angefordert wurde.
Public event | ShowSubGraph | Wird ausgelöst, wenn ein Sub-Graph-Knoten den gekapselten Graphen anzeigen möchte.

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


Disposing Event

[image]

DynamicNodes API
GraphDocument..::..Disposing Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn das Dokument zerstört wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler Disposing
Visual Basic
Public Event Disposing As EventHandler
F#
abstract Disposing : IEvent<EventHandler,
    EventArgs>
override Disposing : IEvent<EventHandler,
    EventArgs>

Implements

IGraphDocument..::..Disposing

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


GraphProperties Event

[image]

DynamicNodes API
GraphDocument..::..GraphProperties Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn für einen Graphen der Eigenschaftsdialog angefordert wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorDocumentEventArgs> GraphProperties
Visual Basic
Public Event GraphProperties As EventHandler(Of EditorDocumentEventArgs)
F#
abstract GraphProperties : IEvent<EventHandler<EditorDocumentEventArgs>,
    EditorDocumentEventArgs>
override GraphProperties : IEvent<EventHandler<EditorDocumentEventArgs>,
    EditorDocumentEventArgs>

Implements

IGraphDocument..::..GraphProperties

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseClick Event

[image]

DynamicNodes API
GraphDocument..::..MouseClick Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Klick ausgeführt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorMouseEventArgs> MouseClick
Visual Basic
Public Event MouseClick As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseClick : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>
override MouseClick : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

Implements

IGraphDocument..::..MouseClick

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseDoubleClick Event

[image]

DynamicNodes API
GraphDocument..::..MouseDoubleClick Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die Doppel-Klick ausgeführt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorMouseEventArgs> MouseDoubleClick
Visual Basic
Public Event MouseDoubleClick As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseDoubleClick : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>
override MouseDoubleClick : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

Implements

IGraphDocument..::..MouseDoubleClick

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseDown Event

[image]

DynamicNodes API
GraphDocument..::..MouseDown Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine Maustaste gedrückt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorMouseEventArgs> MouseDown
Visual Basic
Public Event MouseDown As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseDown : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>
override MouseDown : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

Implements

IGraphDocument..::..MouseDown

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseEnter Event

[image]

DynamicNodes API
GraphDocument..::..MouseEnter Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor den Editor betritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler MouseEnter
Visual Basic
Public Event MouseEnter As EventHandler
F#
abstract MouseEnter : IEvent<EventHandler,
    EventArgs>
override MouseEnter : IEvent<EventHandler,
    EventArgs>

Implements

IGraphDocument..::..MouseEnter

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseHover Event

[image]

DynamicNodes API
GraphDocument..::..MouseHover Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor über der Arbeitsfläche verweilt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler MouseHover
Visual Basic
Public Event MouseHover As EventHandler
F#
abstract MouseHover : IEvent<EventHandler,
    EventArgs>
override MouseHover : IEvent<EventHandler,
    EventArgs>

Implements

IGraphDocument..::..MouseHover

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseLeave Event

[image]

DynamicNodes API
GraphDocument..::..MouseLeave Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor den Editor verlässt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler MouseLeave
Visual Basic
Public Event MouseLeave As EventHandler
F#
abstract MouseLeave : IEvent<EventHandler,
    EventArgs>
override MouseLeave : IEvent<EventHandler,
    EventArgs>

Implements

IGraphDocument..::..MouseLeave

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseMove Event

[image]

DynamicNodes API
GraphDocument..::..MouseMove Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor bewegt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorMouseEventArgs> MouseMove
Visual Basic
Public Event MouseMove As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseMove : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>
override MouseMove : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

Implements

IGraphDocument..::..MouseMove

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseNodeEnter Event

[image]

DynamicNodes API
GraphDocument..::..MouseNodeEnter Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor in den Bereich eines Knotens hinien bewegt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorNodeEventArgs> MouseNodeEnter
Visual Basic
Public Event MouseNodeEnter As EventHandler(Of EditorNodeEventArgs)
F#
abstract MouseNodeEnter : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>
override MouseNodeEnter : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>

Implements

IGraphDocument..::..MouseNodeEnter

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseNodeLeave Event

[image]

DynamicNodes API
GraphDocument..::..MouseNodeLeave Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor den Bereich eines Knotens verlässt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorNodeEventArgs> MouseNodeLeave
Visual Basic
Public Event MouseNodeLeave As EventHandler(Of EditorNodeEventArgs)
F#
abstract MouseNodeLeave : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>
override MouseNodeLeave : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>

Implements

IGraphDocument..::..MouseNodeLeave

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MousePortEnter Event

[image]

DynamicNodes API
GraphDocument..::..MousePortEnter Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor in den Bereich eines Ports hineinbewegt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorPortEventArgs> MousePortEnter
Visual Basic
Public Event MousePortEnter As EventHandler(Of EditorPortEventArgs)
F#
abstract MousePortEnter : IEvent<EventHandler<EditorPortEventArgs>,
    EditorPortEventArgs>
override MousePortEnter : IEvent<EventHandler<EditorPortEventArgs>,
    EditorPortEventArgs>

Implements

IGraphDocument..::..MousePortEnter

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MousePortLeave Event

[image]

DynamicNodes API
GraphDocument..::..MousePortLeave Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor aus dem Bereich eines Ports herrausbewegt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorPortEventArgs> MousePortLeave
Visual Basic
Public Event MousePortLeave As EventHandler(Of EditorPortEventArgs)
F#
abstract MousePortLeave : IEvent<EventHandler<EditorPortEventArgs>,
    EditorPortEventArgs>
override MousePortLeave : IEvent<EventHandler<EditorPortEventArgs>,
    EditorPortEventArgs>

Implements

IGraphDocument..::..MousePortLeave

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseUp Event

[image]

DynamicNodes API
GraphDocument..::..MouseUp Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine Maustaste losgelassen wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorMouseEventArgs> MouseUp
Visual Basic
Public Event MouseUp As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseUp : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>
override MouseUp : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

Implements

IGraphDocument..::..MouseUp

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


MouseWheel Event

[image]

DynamicNodes API
GraphDocument..::..MouseWheel Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn das Mausrad gedreht wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorMouseEventArgs> MouseWheel
Visual Basic
Public Event MouseWheel As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseWheel : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>
override MouseWheel : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

Implements

IGraphDocument..::..MouseWheel

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


NodeHelp Event

[image]

DynamicNodes API
GraphDocument..::..NodeHelp Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn für einen Knoten Hilfe angefordert wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorNodeEventArgs> NodeHelp
Visual Basic
Public Event NodeHelp As EventHandler(Of EditorNodeEventArgs)
F#
abstract NodeHelp : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>
override NodeHelp : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>

Implements

IGraphDocument..::..NodeHelp

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


NodeProperties Event

[image]

DynamicNodes API
GraphDocument..::..NodeProperties Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn für einen Knoten der Eigenschaftsdialog angefordert wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorNodeEventArgs> NodeProperties
Visual Basic
Public Event NodeProperties As EventHandler(Of EditorNodeEventArgs)
F#
abstract NodeProperties : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>
override NodeProperties : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>

Implements

IGraphDocument..::..NodeProperties

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


NodeSelect Event

[image]

DynamicNodes API
GraphDocument..::..NodeSelect Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Knoten ausgewählt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorNodeSelectionEventArgs> NodeSelect
Visual Basic
Public Event NodeSelect As EventHandler(Of EditorNodeSelectionEventArgs)
F#
abstract NodeSelect : IEvent<EventHandler<EditorNodeSelectionEventArgs>,
    EditorNodeSelectionEventArgs>
override NodeSelect : IEvent<EventHandler<EditorNodeSelectionEventArgs>,
    EditorNodeSelectionEventArgs>

Implements

IGraphDocument..::..NodeSelect

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


PortProperties Event

[image]

DynamicNodes API
GraphDocument..::..PortProperties Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn für einen Port der Eigenschaftsdialog angefordert wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<EditorPortEventArgs> PortProperties
Visual Basic
Public Event PortProperties As EventHandler(Of EditorPortEventArgs)
F#
abstract PortProperties : IEvent<EventHandler<EditorPortEventArgs>,
    EditorPortEventArgs>
override PortProperties : IEvent<EventHandler<EditorPortEventArgs>,
    EditorPortEventArgs>

Implements

IGraphDocument..::..PortProperties

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


ShowSubGraph Event

[image]

DynamicNodes API
GraphDocument..::..ShowSubGraph Event
GraphDocument Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Sub-Graph-Knoten den gekapselten Graphen anzeigen möchte.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<SubGraphEventArgs> ShowSubGraph
Visual Basic
Public Event ShowSubGraph As EventHandler(Of SubGraphEventArgs)
F#
abstract ShowSubGraph : IEvent<EventHandler<SubGraphEventArgs>,
    SubGraphEventArgs>
override ShowSubGraph : IEvent<EventHandler<SubGraphEventArgs>,
    SubGraphEventArgs>

Implements

IGraphDocument..::..ShowSubGraph

See Also

GraphDocument Class
DynamicNode.Ext.Visual Namespace


GraphPaintEventArgs Class

[image]

DynamicNodes API
GraphPaintEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ereignisdaten für PaintOverlay.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class GraphPaintEventArgs : EventArgs
Visual Basic
Public Class GraphPaintEventArgs _
    Inherits EventArgs
F#
type GraphPaintEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Ext.Visual..::..GraphPaintEventArgs

See Also

GraphPaintEventArgs Members
DynamicNode.Ext.Visual Namespace


GraphPaintEventArgs Members

[image] [image]

DynamicNodes API
GraphPaintEventArgs Members
GraphPaintEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphPaintEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GraphPaintEventArgs | Initialisiert eine neue Instanz der Klasse GraphPaintEventArgs.

Properties

 | Name | Description
Public property | Graphics | Gibt den Grafikkontext für den Zeichenvorgang zurück.

See Also

GraphPaintEventArgs Class
DynamicNode.Ext.Visual Namespace


GraphPaintEventArgs Constructor

[image]

DynamicNodes API
GraphPaintEventArgs Constructor
GraphPaintEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse GraphPaintEventArgs.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public GraphPaintEventArgs(
    Graphics graphics
)
Visual Basic
Public Sub New ( _
    graphics As Graphics _
)
F#
new :
        graphics:Graphics -> GraphPaintEventArgs

Parameters

graphics
Type: System.Drawing..::..Graphics
Der Grafikkontext für das Zeichnen.

See Also

GraphPaintEventArgs Class
DynamicNode.Ext.Visual Namespace


GraphPaintEventArgs Properties

[image] [image]

DynamicNodes API
GraphPaintEventArgs Properties
GraphPaintEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphPaintEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Graphics | Gibt den Grafikkontext für den Zeichenvorgang zurück.

See Also

GraphPaintEventArgs Class
DynamicNode.Ext.Visual Namespace


Graphics Property

[image]

DynamicNodes API
GraphPaintEventArgs..::..Graphics Property
GraphPaintEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Grafikkontext für den Zeichenvorgang zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Graphics Graphics { get; private set; }
Visual Basic
Public Property Graphics As Graphics
    Get
    Private Set
F#
member Graphics : Graphics with get, private set

See Also

GraphPaintEventArgs Class
DynamicNode.Ext.Visual Namespace


GraphVisualization Class

[image]

DynamicNodes API
GraphVisualization Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erweitert ein Graph um die Eigenschaften für eine grafische Darstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class GraphVisualization : IExtension<IGraph>,
    IStorable
Visual Basic
Public Class GraphVisualization _
    Implements IExtension(Of IGraph), IStorable
F#
type GraphVisualization =
    class
        interface IExtension<IGraph>
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..GraphVisualization

See Also

GraphVisualization Members
DynamicNode.Ext.Visual Namespace


GraphVisualization Members

[image] [image]

DynamicNodes API
GraphVisualization Members
GraphVisualization Class Constructors Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphVisualization type exposes the following members.

Constructors

 | Name | Description
Public method | GraphVisualization | Initialisiert eine neue Instanz der Klasse GraphVisualization.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Graph angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Graph entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | BeforeStoring | Wird aufgerufen, bevor die Erweiterung gespeichert wird.
Public method | GetBoundingBox | Gibt ein Rechteck zurück, dass alle Knoten im Graph einschließt.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID der Graph-Visualisierung. Da diese Erweiterung nur ein mal je Graph angefügt werden kann, ist diese ID immer die gleiche.

Properties

 | Name | Description
Public property | GraphDocument | Liest oder schreibt der Graph-Dokument.
Public property | Id | Gibt eine Graphweit eindeutige ID zurück.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | PaintProperties | Gibt eine Sammlung mit Zeichenressourcen zurück.

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


GraphVisualization Constructor

[image]

DynamicNodes API
GraphVisualization Constructor
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse GraphVisualization.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public GraphVisualization(
    PaintSettings ps
)
Visual Basic
Public Sub New ( _
    ps As PaintSettings _
)
F#
new :
        ps:PaintSettings -> GraphVisualization

Parameters

ps
Type: DynamicNode.Ext.Visual..::..PaintSettings
Das visuelle Schema.

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


GraphVisualization Fields

[image] [image]

DynamicNodes API
GraphVisualization Fields
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphVisualization type exposes the following members.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID der Graph-Visualisierung. Da diese Erweiterung nur ein mal je Graph angefügt werden kann, ist diese ID immer die gleiche.

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


EXT_ID Field

[image]

DynamicNodes API
GraphVisualization..::..EXT_ID Field
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID der Graph-Visualisierung.
Da diese Erweiterung nur ein mal je Graph angefügt werden kann, ist diese ID immer die gleiche.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


GraphVisualization Methods

[image] [image]

DynamicNodes API
GraphVisualization Methods
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphVisualization type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Graph angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Graph entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | BeforeStoring | Wird aufgerufen, bevor die Erweiterung gespeichert wird.
Public method | GetBoundingBox | Gibt ein Rechteck zurück, dass alle Knoten im Graph einschließt.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


AfterAttaching Method

[image]

DynamicNodes API
GraphVisualization..::..AfterAttaching Method
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Graph angefügt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterAttaching(
    IGraph g
)
Visual Basic
Public Sub AfterAttaching ( _
    g As IGraph _
)
F#
abstract AfterAttaching :
        g:IGraph -> unit
override AfterAttaching :
        g:IGraph -> unit

Parameters

g
Type: DynamicNode.Core..::..IGraph
Der Graph

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


AfterDetaching Method

[image]

DynamicNodes API
GraphVisualization..::..AfterDetaching Method
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Graph entfernt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterDetaching(
    IGraph g
)
Visual Basic
Public Sub AfterDetaching ( _
    g As IGraph _
)
F#
abstract AfterDetaching :
        g:IGraph -> unit
override AfterDetaching :
        g:IGraph -> unit

Parameters

g
Type: DynamicNode.Core..::..IGraph
Der Graph

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


AfterRestoring Method

[image]

DynamicNodes API
GraphVisualization..::..AfterRestoring Method
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


BeforeStoring Method

[image]

DynamicNodes API
GraphVisualization..::..BeforeStoring Method
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, bevor die Erweiterung gespeichert wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void BeforeStoring()
Visual Basic
Public Sub BeforeStoring
F#
member BeforeStoring : unit -> unit

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


GetBoundingBox Method

[image]

DynamicNodes API
GraphVisualization..::..GetBoundingBox Method
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Rechteck zurück, dass alle Knoten im Graph einschließt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public RectangleF GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As RectangleF
F#
member GetBoundingBox : unit -> RectangleF

Return Value

Ein Rechteck.

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


OnRestore Method

[image]

DynamicNodes API
GraphVisualization..::..OnRestore Method
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader reader
)
Visual Basic
Public Sub OnRestore ( _
    reader As IPropertyReader _
)
F#
abstract OnRestore :
        reader:IPropertyReader -> unit
override OnRestore :
        reader:IPropertyReader -> unit

Parameters

reader
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschafts-Leser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


OnStore Method

[image]

DynamicNodes API
GraphVisualization..::..OnStore Method
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter writer
)
Visual Basic
Public Sub OnStore ( _
    writer As IPropertyWriter _
)
F#
abstract OnStore :
        writer:IPropertyWriter -> unit
override OnStore :
        writer:IPropertyWriter -> unit

Parameters

writer
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschafts-Writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


GraphVisualization Properties

[image] [image]

DynamicNodes API
GraphVisualization Properties
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphVisualization type exposes the following members.

Properties

 | Name | Description
Public property | GraphDocument | Liest oder schreibt der Graph-Dokument.
Public property | Id | Gibt eine Graphweit eindeutige ID zurück.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | PaintProperties | Gibt eine Sammlung mit Zeichenressourcen zurück.

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


GraphDocument Property

[image]

DynamicNodes API
GraphVisualization..::..GraphDocument Property
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt der Graph-Dokument.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IGraphDocument GraphDocument { get; set; }
Visual Basic
Public Property GraphDocument As IGraphDocument
    Get
    Set
F#
member GraphDocument : IGraphDocument with get, set

Field Value

Der Graph-Dokument.

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


Id Property

[image]

DynamicNodes API
GraphVisualization..::..Id Property
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Graphweit eindeutige ID zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


IsUsingStorage Property

[image]

DynamicNodes API
GraphVisualization..::..IsUsingStorage Property
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


PaintProperties Property

[image]

DynamicNodes API
GraphVisualization..::..PaintProperties Property
GraphVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Sammlung mit Zeichenressourcen zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IPaintProperties PaintProperties { get; }
Visual Basic
Public ReadOnly Property PaintProperties As IPaintProperties
    Get
F#
member PaintProperties : IPaintProperties

Field Value

Eigenschaften zum Zeichnen.

See Also

GraphVisualization Class
DynamicNode.Ext.Visual Namespace


IEditor Interface

[image]

DynamicNodes API
IEditor Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für Graph-Editoren. Ein Graph-Editor wird für ein Graph-Dokument erzeugt um dieses zu bearbeiten. Der Editor ist der Übergang zwischen den Bildschirm-Koordinaten des Editor-Streuerelements und den Arbeitsflächen-Koordinaten des Datenmodells in den Graph-, Knoten- und Anschluss-Visualisierungen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public interface IEditor
Visual Basic
Public Interface IEditor
F#
type IEditor =  interface end

See Also

IEditor Members
DynamicNode.Ext.Visual Namespace


IEditor Members

[image] [image]

DynamicNodes API
IEditor Members
IEditor Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IEditor type exposes the following members.

Methods

 | Name | Description
Public method | GetNodeByMouse | Gibt einen Knoten anhand von Cursor-Koordinaten zurück.
Public method | PixelToWorkspace(Point) | Wandelt einen Punkt von der GUI aus Pixel in einen Punkt auf der Arbeitsfläche um.
Public method | PixelToWorkspace(Rectangle) | Wandelt ein Rechteck von der GUI aus Pixel in ein Rechteck auf der Arbeitsfläche um.
Public method | PixelToWorkspaceX | Wandelt die WorkspaceX-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.
Public method | PixelToWorkspaceY | Wandelt die WorkspaceY-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.
Public method | RegisterTools | Registriert mehrere Werkzeuge.
Public method | ResizeView | Berechnet die Größe der Ausgabefläche neu.
Public method | WorkspaceToPixel(PointF) | Wandelt einen Punkt auf der Arbeitsfläche in einen Punkt in Pixel für die GUI um.
Public method | WorkspaceToPixel(RectangleF) | Wandelt ein lokales Rechteck auf der Arbeitsfläche in ein Rechteck in Pixel für die GUI um.
Public method | WorkspaceToPixelX | Wandelt die lokale WorkspaceX-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.
Public method | WorkspaceToPixelY | Wandelt die lokale WorkspaceY-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.

Properties

 | Name | Description
Public property | Control | Liest oder schreibt das Editor-Steuerelement.
Public property | CurrentTool | Liest oder schreibt das aktuelle Werkzeug.
Public property | GraphDocument | Liest oder schreibt die IGraphDocument-Instanz.
Public property | Painter | Gibt den Painter zurück.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


IEditor Methods

[image] [image]

DynamicNodes API
IEditor Methods
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IEditor type exposes the following members.

Methods

 | Name | Description
Public method | GetNodeByMouse | Gibt einen Knoten anhand von Cursor-Koordinaten zurück.
Public method | PixelToWorkspace(Point) | Wandelt einen Punkt von der GUI aus Pixel in einen Punkt auf der Arbeitsfläche um.
Public method | PixelToWorkspace(Rectangle) | Wandelt ein Rechteck von der GUI aus Pixel in ein Rechteck auf der Arbeitsfläche um.
Public method | PixelToWorkspaceX | Wandelt die WorkspaceX-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.
Public method | PixelToWorkspaceY | Wandelt die WorkspaceY-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.
Public method | RegisterTools | Registriert mehrere Werkzeuge.
Public method | ResizeView | Berechnet die Größe der Ausgabefläche neu.
Public method | WorkspaceToPixel(PointF) | Wandelt einen Punkt auf der Arbeitsfläche in einen Punkt in Pixel für die GUI um.
Public method | WorkspaceToPixel(RectangleF) | Wandelt ein lokales Rechteck auf der Arbeitsfläche in ein Rechteck in Pixel für die GUI um.
Public method | WorkspaceToPixelX | Wandelt die lokale WorkspaceX-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.
Public method | WorkspaceToPixelY | Wandelt die lokale WorkspaceY-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


GetNodeByMouse Method

[image]

DynamicNodes API
IEditor..::..GetNodeByMouse Method
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Knoten anhand von Cursor-Koordinaten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
INode GetNodeByMouse(
    int x,
    int y,
    bool border
)
Visual Basic
Function GetNodeByMouse ( _
    x As Integer, _
    y As Integer, _
    border As Boolean _
) As INode
F#
abstract GetNodeByMouse :
        x:int *
        y:int *
        border:bool -> INode

Parameters

x
Type: System..::..Int32
Die WorkspaceX-Koordinate.
y
Type: System..::..Int32
Die WorkspaceX-Koordinate.
border
Type: System..::..Boolean
Wenn true wird der Randbereich der Knoten, in dem sich die Ports befinden, bei der Prüfung berücksichtigt.

Return Value

Ein Knoten, oder null, wenn die Koordinaten in keinem Knoten lagen.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


PixelToWorkspace Method

[image] [image]

DynamicNodes API
IEditor..::..PixelToWorkspace Method
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | PixelToWorkspace(Point) | Wandelt einen Punkt von der GUI aus Pixel in einen Punkt auf der Arbeitsfläche um.
Public method | PixelToWorkspace(Rectangle) | Wandelt ein Rechteck von der GUI aus Pixel in ein Rechteck auf der Arbeitsfläche um.

See Also

IEditor Interface
IEditor Members
DynamicNode.Ext.Visual Namespace


PixelToWorkspace Method (Point)

[image]

DynamicNodes API
IEditor..::..PixelToWorkspace Method (Point)
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt einen Punkt von der GUI aus Pixel in einen Punkt auf der Arbeitsfläche um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
PointF PixelToWorkspace(
    Point p
)
Visual Basic
Function PixelToWorkspace ( _
    p As Point _
) As PointF
F#
abstract PixelToWorkspace :
        p:Point -> PointF

Parameters

p
Type: System.Drawing..::..Point
Der Punkt in Pixel von der GUI.

Return Value

Der Punkt auf der Arbeitsfläche.

See Also

IEditor Interface
PixelToWorkspace Overload
DynamicNode.Ext.Visual Namespace


PixelToWorkspace Method (Rectangle)

[image]

DynamicNodes API
IEditor..::..PixelToWorkspace Method (Rectangle)
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt ein Rechteck von der GUI aus Pixel in ein Rechteck auf der Arbeitsfläche um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
RectangleF PixelToWorkspace(
    Rectangle r
)
Visual Basic
Function PixelToWorkspace ( _
    r As Rectangle _
) As RectangleF
F#
abstract PixelToWorkspace :
        r:Rectangle -> RectangleF

Parameters

r
Type: System.Drawing..::..Rectangle
Das Rechteck in Pixel von der GUI.

Return Value

Das Rechteck auf der Arbeitsfläche.

See Also

IEditor Interface
PixelToWorkspace Overload
DynamicNode.Ext.Visual Namespace


PixelToWorkspaceX Method

[image]

DynamicNodes API
IEditor..::..PixelToWorkspaceX Method
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt die WorkspaceX-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
float PixelToWorkspaceX(
    int x
)
Visual Basic
Function PixelToWorkspaceX ( _
    x As Integer _
) As Single
F#
abstract PixelToWorkspaceX :
        x:int -> float32

Parameters

x
Type: System..::..Int32
Die GUI-WorkspaceX-Koordinate.

Return Value

Die lokale WorkspaceX-Koordinate.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


PixelToWorkspaceY Method

[image]

DynamicNodes API
IEditor..::..PixelToWorkspaceY Method
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt die WorkspaceY-Cursor-Koordinate der GUI in eine lokale Koordinate der Arbeitsfläche um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
float PixelToWorkspaceY(
    int y
)
Visual Basic
Function PixelToWorkspaceY ( _
    y As Integer _
) As Single
F#
abstract PixelToWorkspaceY :
        y:int -> float32

Parameters

y
Type: System..::..Int32
Die GUI-WorkspaceY-Koordinate.

Return Value

Die lokale WorkspaceY-Koordinate.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


RegisterTools Method

[image]

DynamicNodes API
IEditor..::..RegisterTools Method
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert mehrere Werkzeuge.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void RegisterTools(
    params IEditorTool[] tools
)
Visual Basic
Sub RegisterTools ( _
    ParamArray tools As IEditorTool() _
)
F#
abstract RegisterTools :
        tools:IEditorTool[] -> unit

Parameters

tools
Type: array< DynamicNode.Ext.Visual..::..IEditorTool >[]()[][]
Mehrere Werkzeuge.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


ResizeView Method

[image]

DynamicNodes API
IEditor..::..ResizeView Method
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet die Größe der Ausgabefläche neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void ResizeView()
Visual Basic
Sub ResizeView
F#
abstract ResizeView : unit -> unit

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


WorkspaceToPixel Method

[image] [image]

DynamicNodes API
IEditor..::..WorkspaceToPixel Method
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | WorkspaceToPixel(PointF) | Wandelt einen Punkt auf der Arbeitsfläche in einen Punkt in Pixel für die GUI um.
Public method | WorkspaceToPixel(RectangleF) | Wandelt ein lokales Rechteck auf der Arbeitsfläche in ein Rechteck in Pixel für die GUI um.

See Also

IEditor Interface
IEditor Members
DynamicNode.Ext.Visual Namespace


WorkspaceToPixel Method (PointF)

[image]

DynamicNodes API
IEditor..::..WorkspaceToPixel Method (PointF)
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt einen Punkt auf der Arbeitsfläche in einen Punkt in Pixel für die GUI um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
Point WorkspaceToPixel(
    PointF p
)
Visual Basic
Function WorkspaceToPixel ( _
    p As PointF _
) As Point
F#
abstract WorkspaceToPixel :
        p:PointF -> Point

Parameters

p
Type: System.Drawing..::..PointF
Der Punkt auf der Arbeitsfläche.

Return Value

Der Punkt in Pixel für die GUI.

See Also

IEditor Interface
WorkspaceToPixel Overload
DynamicNode.Ext.Visual Namespace


WorkspaceToPixel Method (RectangleF)

[image]

DynamicNodes API
IEditor..::..WorkspaceToPixel Method (RectangleF)
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt ein lokales Rechteck auf der Arbeitsfläche in ein Rechteck in Pixel für die GUI um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
Rectangle WorkspaceToPixel(
    RectangleF r
)
Visual Basic
Function WorkspaceToPixel ( _
    r As RectangleF _
) As Rectangle
F#
abstract WorkspaceToPixel :
        r:RectangleF -> Rectangle

Parameters

r
Type: System.Drawing..::..RectangleF
Das Rechteck auf der Arbeitsfläche.

Return Value

Das Rechteck in Pixel für die GUI.

See Also

IEditor Interface
WorkspaceToPixel Overload
DynamicNode.Ext.Visual Namespace


WorkspaceToPixelX Method

[image]

DynamicNodes API
IEditor..::..WorkspaceToPixelX Method
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt die lokale WorkspaceX-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
int WorkspaceToPixelX(
    float x
)
Visual Basic
Function WorkspaceToPixelX ( _
    x As Single _
) As Integer
F#
abstract WorkspaceToPixelX :
        x:float32 -> int

Parameters

x
Type: System..::..Single
Die lokale WorkspaceX-Koordinate.

Return Value

Die GUI-WorkspaceX-Koordinate.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


WorkspaceToPixelY Method

[image]

DynamicNodes API
IEditor..::..WorkspaceToPixelY Method
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt die lokale WorkspaceY-Cursor-Koordinate der Arbeitsfläche in Pixel der GUI um.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
int WorkspaceToPixelY(
    float y
)
Visual Basic
Function WorkspaceToPixelY ( _
    y As Single _
) As Integer
F#
abstract WorkspaceToPixelY :
        y:float32 -> int

Parameters

y
Type: System..::..Single
Die lokale WorkspaceY-Koordinate.

Return Value

Die GUI-WorkspaceY-Koordinate.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


IEditor Properties

[image] [image]

DynamicNodes API
IEditor Properties
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IEditor type exposes the following members.

Properties

 | Name | Description
Public property | Control | Liest oder schreibt das Editor-Steuerelement.
Public property | CurrentTool | Liest oder schreibt das aktuelle Werkzeug.
Public property | GraphDocument | Liest oder schreibt die IGraphDocument-Instanz.
Public property | Painter | Gibt den Painter zurück.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


Control Property

[image]

DynamicNodes API
IEditor..::..Control Property
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt das Editor-Steuerelement.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
EditorControl Control { get; }
Visual Basic
ReadOnly Property Control As EditorControl
    Get
F#
abstract Control : EditorControl

Field Value

Das Editor-Steuerelement.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


CurrentTool Property

[image]

DynamicNodes API
IEditor..::..CurrentTool Property
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt das aktuelle Werkzeug.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
IEditorTool CurrentTool { get; set; }
Visual Basic
Property CurrentTool As IEditorTool
    Get
    Set
F#
abstract CurrentTool : IEditorTool with get, set

Field Value

Das aktuelle Werkzeug.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


GraphDocument Property

[image]

DynamicNodes API
IEditor..::..GraphDocument Property
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die IGraphDocument-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
IGraphDocument GraphDocument { get; }
Visual Basic
ReadOnly Property GraphDocument As IGraphDocument
    Get
F#
abstract GraphDocument : IGraphDocument

Field Value

Das Daten-Modell.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


Painter Property

[image]

DynamicNodes API
IEditor..::..Painter Property
IEditor Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Painter zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
IPainter Painter { get; }
Visual Basic
ReadOnly Property Painter As IPainter
    Get
F#
abstract Painter : IPainter

Field Value

Der Painter.

See Also

IEditor Interface
DynamicNode.Ext.Visual Namespace


IEditorTool Interface

[image]

DynamicNodes API
IEditorTool Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für Editor-Werkzeuge. Editor-Werkzeuge können die Ereignisse eines Graph-Dokuments konsumieren und das Datenmodell daraufhin bearbeiten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public interface IEditorTool
Visual Basic
Public Interface IEditorTool
F#
type IEditorTool =  interface end

See Also

IEditorTool Members
DynamicNode.Ext.Visual Namespace


IEditorTool Members

[image] [image]

DynamicNodes API
IEditorTool Members
IEditorTool Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IEditorTool type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert das Werkzeug. Dabei können verschiedene Ereignisse vom Editor-Steuerelement gebunden werden.
Public method | Deactivate | Deaktiviert das Werkzeug. Dabei müssen die gebundenen Ereignisse wieder freigegeben werden.
Public method | GetNewInstance | Erzeugt eine neue Instanz des Werkzeugs.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung des Werkzeugs zurück.
Public property | Description | Gibt die Beschreibung des Werkzeugs zurück.
Public property | Icon | Gibt das Icon des Werkzeugs zurück.
Public property | ToolCursor | Gibt den Cursor des Werkzeugs zurück.

Events

 | Name | Description
Public event | ToolCursorChanged | Tritt auf wenn sich der Cursor des Werkzeugs geändert hat.

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


IEditorTool Methods

[image] [image]

DynamicNodes API
IEditorTool Methods
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IEditorTool type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert das Werkzeug. Dabei können verschiedene Ereignisse vom Editor-Steuerelement gebunden werden.
Public method | Deactivate | Deaktiviert das Werkzeug. Dabei müssen die gebundenen Ereignisse wieder freigegeben werden.
Public method | GetNewInstance | Erzeugt eine neue Instanz des Werkzeugs.

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


Activate Method

[image]

DynamicNodes API
IEditorTool..::..Activate Method
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert das Werkzeug. Dabei können verschiedene Ereignisse vom Editor-Steuerelement gebunden werden.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void Activate(
    IGraphDocument document
)
Visual Basic
Sub Activate ( _
    document As IGraphDocument _
)
F#
abstract Activate :
        document:IGraphDocument -> unit

Parameters

document
Type: DynamicNode.Ext.Visual..::..IGraphDocument
Das Dokument, für welches das Werkzeug aktiviert werden soll.

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


Deactivate Method

[image]

DynamicNodes API
IEditorTool..::..Deactivate Method
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Deaktiviert das Werkzeug. Dabei müssen die gebundenen Ereignisse wieder freigegeben werden.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void Deactivate()
Visual Basic
Sub Deactivate
F#
abstract Deactivate : unit -> unit

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


GetNewInstance Method

[image]

DynamicNodes API
IEditorTool..::..GetNewInstance Method
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine neue Instanz des Werkzeugs.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
IEditorTool GetNewInstance()
Visual Basic
Function GetNewInstance As IEditorTool
F#
abstract GetNewInstance : unit -> IEditorTool

Return Value

Eine neue Instanz des Werkzeugs.

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


IEditorTool Properties

[image] [image]

DynamicNodes API
IEditorTool Properties
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IEditorTool type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung des Werkzeugs zurück.
Public property | Description | Gibt die Beschreibung des Werkzeugs zurück.
Public property | Icon | Gibt das Icon des Werkzeugs zurück.
Public property | ToolCursor | Gibt den Cursor des Werkzeugs zurück.

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


Caption Property

[image]

DynamicNodes API
IEditorTool..::..Caption Property
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung des Werkzeugs zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
string Caption { get; }
Visual Basic
ReadOnly Property Caption As String
    Get
F#
abstract Caption : string

Field Value

Die Beschriftung.

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


Description Property

[image]

DynamicNodes API
IEditorTool..::..Description Property
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Werkzeugs zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
string Description { get; }
Visual Basic
ReadOnly Property Description As String
    Get
F#
abstract Description : string

Field Value

Die Beschreibung.

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


Icon Property

[image]

DynamicNodes API
IEditorTool..::..Icon Property
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Icon des Werkzeugs zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
Image Icon { get; }
Visual Basic
ReadOnly Property Icon As Image
    Get
F#
abstract Icon : Image

Field Value

Das Icon.

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


ToolCursor Property

[image]

DynamicNodes API
IEditorTool..::..ToolCursor Property
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Cursor des Werkzeugs zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
Cursor ToolCursor { get; }
Visual Basic
ReadOnly Property ToolCursor As Cursor
    Get
F#
abstract ToolCursor : Cursor

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


IEditorTool Events

[image] [image]

DynamicNodes API
IEditorTool Events
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IEditorTool type exposes the following members.

Events

 | Name | Description
Public event | ToolCursorChanged | Tritt auf wenn sich der Cursor des Werkzeugs geändert hat.

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


ToolCursorChanged Event

[image]

DynamicNodes API
IEditorTool..::..ToolCursorChanged Event
IEditorTool Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn sich der Cursor des Werkzeugs geändert hat.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler ToolCursorChanged
Visual Basic
Event ToolCursorChanged As EventHandler
F#
abstract ToolCursorChanged : IEvent<EventHandler,
    EventArgs>

See Also

IEditorTool Interface
DynamicNode.Ext.Visual Namespace


IGraphDocument Interface

[image]

DynamicNodes API
IGraphDocument Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Daten-Modell für einen Graph-Editor.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public interface IGraphDocument : IDisposable
Visual Basic
Public Interface IGraphDocument _
    Inherits IDisposable
F#
type IGraphDocument =
    interface
        interface IDisposable
    end

See Also

IGraphDocument Members
DynamicNode.Ext.Visual Namespace


IGraphDocument Members

[image] [image]

DynamicNodes API
IGraphDocument Members
IGraphDocument Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGraphDocument type exposes the following members.

Methods

 | Name | Description
Public method | BeginConnectingProcess | Startet den visuellen Verbindungs-Prozess.
Public method | BeginVisualSelectionProcess | Startet den visuellen Auswahl-Prozess.
Public method | EndConnectingProcess | Beendet den Verbindungs-Prozess.
Public method | EndVisualSelectionProcess | Benachrichtigt das Graph-Dokument über das Ende des Auswahlprozesses.
Public method | ExtendNodeSelection(INode) | Fügt einen Knoten der Knotenauswahl hinzu.
Public method | ExtendNodeSelection(IEnumerable<(Of <<'(INode>)>>)) | Fügt mehrere Knoten der Knotenauswahl hinzu.
Public method | GetGraphVis | Gibt die Visualisierung für des Graphen zurück.
Public method | GetNodeByMouse | Gibt einen Knoten anhand von lokalen (nicht transformierten) Cursor-Koordinaten zurück.
Public method | GetPinByMouse | Gibt einen Pin anhand von Cursor-Koordinaten zurück.
Public method | GetPortByMouse | Gibt einen Port anhand von Cursor-Koordinaten zurück.
Public method | HitTest | Prüft mit Hilfe von Editor-Koordinaten ob sich ein Objekt unter dem Cursor befindet.
Public method | IsNodeSecondarySelected | Gibt einen Wert zurück, der angibt, ob der übergebene Knoten sekundär markiert ist.
Public method | OnGraphProperties | Löst das Ereignis GraphProperties aus.
Public method | OnMouseClick | Löst das Ereignis MouseClick aus.
Public method | OnMouseDoubleClick | Löst das Ereignis MouseDoubleClick aus.
Public method | OnMouseDown | Löst das Ereignis MouseDown aus.
Public method | OnMouseEnter | Löst das Ereignis MouseEnter aus.
Public method | OnMouseHover | Löst das Ereignis MouseHover aus.
Public method | OnMouseLeave | Löst das Ereignis MouseLeave aus.
Public method | OnMouseMove | Löst das Ereignis MouseMove aus.
Public method | OnMouseNodeEnter | Löst das Ereignis MouseNodeEnter aus.
Public method | OnMouseNodeLeave | Löst das Ereignis MouseNodeLeave aus.
Public method | OnMousePortEnter | Löst das Ereignis MousePortEnter aus.
Public method | OnMousePortLeave | Löst das Ereignis MousePortLeave aus.
Public method | OnMouseUp | Löst das Ereignis MouseUp aus.
Public method | OnMouseWheel | Löst das Ereignis MouseWheel aus.
Public method | OnNodeHelp | Löst das Ereignis NodeHelp aus.
Public method | OnNodeProperties | Löst das Ereignis NodeProperties aus.
Public method | OnNodeSelect | Löst das Ereignis NodeSelect aus.
Public method | OnPortProperties | Löst das Ereignis PortProperties aus.
Public method | OnShowSubGraph | Löst das Ereignis ShowSubGraph aus.
Public method | ReduceNodeSelection | Entfernt einen Knoten aus der Knotenauswahl.
Public method | Repaint | Zeichnet das Graph-Dokument neu.
Public method | SelectNothing | Löscht die aktuelle Auswahl.
Public method | WhileConnectingProcess | Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Verbindungsprozesses.
Public method | WhileVisualSelectionProcess | Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Auswahlprozesses.

Properties

 | Name | Description
Public property | AutoRepaint | Liest oder schreibt einen Wert, der angibt ob die Arbeitsfläche bei Änderungen des Graphen automatisch neu gezeichnet werden soll.
Public property | Editor | Liest oder schreibt den Eitor.
Public property | Graph | Gibt der Graph zurück, welches dargestellt werden soll.
Public property | IsConnectingInProgress | Gibt einen Wert zurück, der angibt, ob ein Verbindungsprozess aktiv ist.
Public property | IsMouseOverDocument | Gibt einen Wert zurück, der angibt ob der Cursor sich zur Zeit über dem Dokument befindet.
Public property | IsPinVisible | Gibt einen Wert zurück, der angibt ob die Pins der Verbindungen sichtbar sind oder nicht.
Public property | Runtime | Gibt die Laufzeitumgebung zurück in der der Graph ausgeführt wird.
Public property | SecondarySelectedNodes | Gibt eine Auflistung mit allen sekundär markierten Knoten zurück.
Public property | SecondarySelectedNodesCount | Gibt die Anzahl aller sekundär markierten Knoten einschließlich des primär markierten Knotens zurück.
Public property | SelectedNode | Gibt den ausgewählten Knoten zurück oder legt ihn fest.
Public property | SelectedPin | Liest oder schreibt den ausgewählten Pin.
Public property | SelectedPort | Liest oder schreibt den ausgewählten Port.

Events

 | Name | Description
Public event | Disposing | Wird ausgelöst, wenn das Dokument zerstört wird.
Public event | GraphProperties | Wird ausgelöst, wenn für einen Graphen der Eigenschaftsdialog angefordert wurde.
Public event | MouseClick | Wird ausgelöst, wenn ein Klick ausgeführt wurde.
Public event | MouseDoubleClick | Wird ausgelöst, wenn ein Doppel-Klick ausgeführt wurde.
Public event | MouseDown | Wird ausgelöst, wenn eine Maustaste gedrückt wird.
Public event | MouseEnter | Wird ausgelöst, wenn der Cursor den Editor betritt.
Public event | MouseHover | Wird ausgelöst, wenn der Cursor über der Arbeitsfläche verweilt.
Public event | MouseLeave | Wird ausgelöst, wenn der Cursor den Editor verlässt.
Public event | MouseMove | Wird ausgelöst, wenn der Cursor bewegt wird.
Public event | MouseNodeEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Knotens hinien bewegt wird.
Public event | MouseNodeLeave | Wird ausgelöst, wenn der Cursor den Bereich eines Knotens verlässt.
Public event | MousePortEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Ports hineinbewegt wird.
Public event | MousePortLeave | Wird ausgelöst, wenn der Cursor aus dem Bereich eines Ports herrausbewegt wird.
Public event | MouseUp | Wird ausgelöst, wenn eine Maustaste losgelassen wird.
Public event | MouseWheel | Wird ausgelöst, wenn das Mausrad gedreht wird.
Public event | NodeHelp | Wird ausgelöst, wenn für einen Knoten Hilfe angefordert wird.
Public event | NodeProperties | Wird ausgelöst, wenn für einen Knoten den Eigenschaftsdialog anfordert.
Public event | NodeSelect | Wird ausgelöst, wenn ein Knoten ausgewählt wird.
Public event | PortProperties | Wird ausgelöst, wenn für einen Port den Eigenschaftsdialog anfordert.
Public event | ShowSubGraph | Wird ausgelöst, wenn ein Sub-Graph-Knoten den gekapselten Graphen anzeigen möchte.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


IGraphDocument Methods

[image] [image]

DynamicNodes API
IGraphDocument Methods
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGraphDocument type exposes the following members.

Methods

 | Name | Description
Public method | BeginConnectingProcess | Startet den visuellen Verbindungs-Prozess.
Public method | BeginVisualSelectionProcess | Startet den visuellen Auswahl-Prozess.
Public method | EndConnectingProcess | Beendet den Verbindungs-Prozess.
Public method | EndVisualSelectionProcess | Benachrichtigt das Graph-Dokument über das Ende des Auswahlprozesses.
Public method | ExtendNodeSelection(INode) | Fügt einen Knoten der Knotenauswahl hinzu.
Public method | ExtendNodeSelection(IEnumerable<(Of <<'(INode>)>>)) | Fügt mehrere Knoten der Knotenauswahl hinzu.
Public method | GetGraphVis | Gibt die Visualisierung für des Graphen zurück.
Public method | GetNodeByMouse | Gibt einen Knoten anhand von lokalen (nicht transformierten) Cursor-Koordinaten zurück.
Public method | GetPinByMouse | Gibt einen Pin anhand von Cursor-Koordinaten zurück.
Public method | GetPortByMouse | Gibt einen Port anhand von Cursor-Koordinaten zurück.
Public method | HitTest | Prüft mit Hilfe von Editor-Koordinaten ob sich ein Objekt unter dem Cursor befindet.
Public method | IsNodeSecondarySelected | Gibt einen Wert zurück, der angibt, ob der übergebene Knoten sekundär markiert ist.
Public method | OnGraphProperties | Löst das Ereignis GraphProperties aus.
Public method | OnMouseClick | Löst das Ereignis MouseClick aus.
Public method | OnMouseDoubleClick | Löst das Ereignis MouseDoubleClick aus.
Public method | OnMouseDown | Löst das Ereignis MouseDown aus.
Public method | OnMouseEnter | Löst das Ereignis MouseEnter aus.
Public method | OnMouseHover | Löst das Ereignis MouseHover aus.
Public method | OnMouseLeave | Löst das Ereignis MouseLeave aus.
Public method | OnMouseMove | Löst das Ereignis MouseMove aus.
Public method | OnMouseNodeEnter | Löst das Ereignis MouseNodeEnter aus.
Public method | OnMouseNodeLeave | Löst das Ereignis MouseNodeLeave aus.
Public method | OnMousePortEnter | Löst das Ereignis MousePortEnter aus.
Public method | OnMousePortLeave | Löst das Ereignis MousePortLeave aus.
Public method | OnMouseUp | Löst das Ereignis MouseUp aus.
Public method | OnMouseWheel | Löst das Ereignis MouseWheel aus.
Public method | OnNodeHelp | Löst das Ereignis NodeHelp aus.
Public method | OnNodeProperties | Löst das Ereignis NodeProperties aus.
Public method | OnNodeSelect | Löst das Ereignis NodeSelect aus.
Public method | OnPortProperties | Löst das Ereignis PortProperties aus.
Public method | OnShowSubGraph | Löst das Ereignis ShowSubGraph aus.
Public method | ReduceNodeSelection | Entfernt einen Knoten aus der Knotenauswahl.
Public method | Repaint | Zeichnet das Graph-Dokument neu.
Public method | SelectNothing | Löscht die aktuelle Auswahl.
Public method | WhileConnectingProcess | Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Verbindungsprozesses.
Public method | WhileVisualSelectionProcess | Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Auswahlprozesses.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


BeginConnectingProcess Method

[image]

DynamicNodes API
IGraphDocument..::..BeginConnectingProcess Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Startet den visuellen Verbindungs-Prozess.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void BeginConnectingProcess(
    IPort p
)
Visual Basic
Sub BeginConnectingProcess ( _
    p As IPort _
)
F#
abstract BeginConnectingProcess :
        p:IPort -> unit

Parameters

p
Type: DynamicNode.Core..::..IPort
Der Port mit dem die Verbindung beginnt.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


BeginVisualSelectionProcess Method

[image]

DynamicNodes API
IGraphDocument..::..BeginVisualSelectionProcess Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Startet den visuellen Auswahl-Prozess.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void BeginVisualSelectionProcess(
    float x,
    float y
)
Visual Basic
Sub BeginVisualSelectionProcess ( _
    x As Single, _
    y As Single _
)
F#
abstract BeginVisualSelectionProcess :
        x:float32 *
        y:float32 -> unit

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


EndConnectingProcess Method

[image]

DynamicNodes API
IGraphDocument..::..EndConnectingProcess Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beendet den Verbindungs-Prozess.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void EndConnectingProcess(
    IPort p
)
Visual Basic
Sub EndConnectingProcess ( _
    p As IPort _
)
F#
abstract EndConnectingProcess :
        p:IPort -> unit

Parameters

p
Type: DynamicNode.Core..::..IPort
Der Port mit dem die Verbindung hergestellt werde soll, oder null, wenn der Prozess abgebrochen werden soll.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


EndVisualSelectionProcess Method

[image]

DynamicNodes API
IGraphDocument..::..EndVisualSelectionProcess Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Benachrichtigt das Graph-Dokument über das Ende des Auswahlprozesses.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void EndVisualSelectionProcess()
Visual Basic
Sub EndVisualSelectionProcess
F#
abstract EndVisualSelectionProcess : unit -> unit

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


ExtendNodeSelection Method

[image] [image]

DynamicNodes API
IGraphDocument..::..ExtendNodeSelection Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ExtendNodeSelection(INode) | Fügt einen Knoten der Knotenauswahl hinzu.
Public method | ExtendNodeSelection(IEnumerable<(Of <<'(INode>)>>)) | Fügt mehrere Knoten der Knotenauswahl hinzu.

See Also

IGraphDocument Interface
IGraphDocument Members
DynamicNode.Ext.Visual Namespace


ExtendNodeSelection Method (INode)

[image]

DynamicNodes API
IGraphDocument..::..ExtendNodeSelection Method (INode)
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt einen Knoten der Knotenauswahl hinzu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void ExtendNodeSelection(
    INode node
)
Visual Basic
Sub ExtendNodeSelection ( _
    node As INode _
)
F#
abstract ExtendNodeSelection :
        node:INode -> unit

Parameters

node
Type: DynamicNode.Core..::..INode
Der Knoten.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für nodenull übergeben wurde.

See Also

IGraphDocument Interface
ExtendNodeSelection Overload
DynamicNode.Ext.Visual Namespace


ExtendNodeSelection Method (IEnumerable(INode))

[image]

DynamicNodes API
IGraphDocument..::..ExtendNodeSelection Method (IEnumerable<(Of <(<'INode>)>)>)
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt mehrere Knoten der Knotenauswahl hinzu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void ExtendNodeSelection(
    IEnumerable<INode> nodes
)
Visual Basic
Sub ExtendNodeSelection ( _
    nodes As IEnumerable(Of INode) _
)
F#
abstract ExtendNodeSelection :
        nodes:IEnumerable<INode> -> unit

Parameters

nodes
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' INode >)>)>
Die Auflistung der Knoten.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für nodesnull übergeben wurde.

See Also

IGraphDocument Interface
ExtendNodeSelection Overload
DynamicNode.Ext.Visual Namespace


GetGraphVis Method

[image]

DynamicNodes API
IGraphDocument..::..GetGraphVis Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Visualisierung für des Graphen zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
GraphVisualization GetGraphVis()
Visual Basic
Function GetGraphVis As GraphVisualization
F#
abstract GetGraphVis : unit -> GraphVisualization

Return Value

Die Visualisierung für den Graph oder null, wenn an dem Graph keine Visualisierung angefügt ist.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


GetNodeByMouse Method

[image]

DynamicNodes API
IGraphDocument..::..GetNodeByMouse Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Knoten anhand von lokalen (nicht transformierten) Cursor-Koordinaten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
INode GetNodeByMouse(
    float x,
    float y,
    bool border
)
Visual Basic
Function GetNodeByMouse ( _
    x As Single, _
    y As Single, _
    border As Boolean _
) As INode
F#
abstract GetNodeByMouse :
        x:float32 *
        y:float32 *
        border:bool -> INode

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceX-Koordinate.
border
Type: System..::..Boolean
Wenn true wird der Randbereich der Knoten, in dem sich die Ports befinden, bei der Prüfung berücksichtigt.

Return Value

Ein Knoten, oder null, wenn die Koordinaten in keinem Knoten lagen.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


GetPinByMouse Method

[image]

DynamicNodes API
IGraphDocument..::..GetPinByMouse Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Pin anhand von Cursor-Koordinaten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
Pin GetPinByMouse(
    float x,
    float y
)
Visual Basic
Function GetPinByMouse ( _
    x As Single, _
    y As Single _
) As Pin
F#
abstract GetPinByMouse :
        x:float32 *
        y:float32 -> Pin

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceX-Koordinate.

Return Value

Ein Pin, oder null, wenn die Koordinaten in keinem Pin liegen.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


GetPortByMouse Method

[image]

DynamicNodes API
IGraphDocument..::..GetPortByMouse Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Port anhand von Cursor-Koordinaten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
IPort GetPortByMouse(
    float x,
    float y
)
Visual Basic
Function GetPortByMouse ( _
    x As Single, _
    y As Single _
) As IPort
F#
abstract GetPortByMouse :
        x:float32 *
        y:float32 -> IPort

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceX-Koordinate.

Return Value

Ein Port, oder null, wenn die Koordinaten in keinem Port liegen.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


HitTest Method

[image]

DynamicNodes API
IGraphDocument..::..HitTest Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft mit Hilfe von Editor-Koordinaten ob sich ein Objekt unter dem Cursor befindet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void HitTest(
    float x,
    float y,
    out INode node,
    out IPort port,
    out Pin pin
)
Visual Basic
Sub HitTest ( _
    x As Single, _
    y As Single, _
    <OutAttribute> ByRef node As INode, _
    <OutAttribute> ByRef port As IPort, _
    <OutAttribute> ByRef pin As Pin _
)
F#
abstract HitTest :
        x:float32 *
        y:float32 *
        node:INode byref *
        port:IPort byref *
        pin:Pin byref -> unit

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.
node
Type: DynamicNode.Core..::..INode %
Ein Knoten oder null.
port
Type: DynamicNode.Core..::..IPort %
Ein Port oder null.
pin
Type: DynamicNode.Ext.Visual..::..Pin %
Ein Pin oder null.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


IsNodeSecondarySelected Method

[image]

DynamicNodes API
IGraphDocument..::..IsNodeSecondarySelected Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob der übergebene Knoten sekundär markiert ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
bool IsNodeSecondarySelected(
    INode node
)
Visual Basic
Function IsNodeSecondarySelected ( _
    node As INode _
) As Boolean
F#
abstract IsNodeSecondarySelected :
        node:INode -> bool

Parameters

node
Type: DynamicNode.Core..::..INode
Der zu überprüfende Knoten.

Return Value

true wenn node sekundär markiert ist, sonst false.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für nodenull übergeben wurde.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnGraphProperties Method

[image]

DynamicNodes API
IGraphDocument..::..OnGraphProperties Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis GraphProperties aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnGraphProperties(
    EditorDocumentEventArgs e
)
Visual Basic
Sub OnGraphProperties ( _
    e As EditorDocumentEventArgs _
)
F#
abstract OnGraphProperties :
        e:EditorDocumentEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorDocumentEventArgs
Eine EditorDocumentEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseClick Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseClick Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseClick aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseClick(
    EditorMouseEventArgs e
)
Visual Basic
Sub OnMouseClick ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseClick :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseDoubleClick Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseDoubleClick Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseDoubleClick aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseDoubleClick(
    EditorMouseEventArgs e
)
Visual Basic
Sub OnMouseDoubleClick ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseDoubleClick :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseDown Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseDown Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseDown aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseDown(
    EditorMouseEventArgs e
)
Visual Basic
Sub OnMouseDown ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseDown :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseEnter Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseEnter Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseEnter aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseEnter()
Visual Basic
Sub OnMouseEnter
F#
abstract OnMouseEnter : unit -> unit

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseHover Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseHover Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseHover aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseHover()
Visual Basic
Sub OnMouseHover
F#
abstract OnMouseHover : unit -> unit

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseLeave Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseLeave Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseLeave aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseLeave()
Visual Basic
Sub OnMouseLeave
F#
abstract OnMouseLeave : unit -> unit

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseMove Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseMove Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseMove aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseMove(
    EditorMouseEventArgs e
)
Visual Basic
Sub OnMouseMove ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseMove :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseNodeEnter Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseNodeEnter Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseNodeEnter aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseNodeEnter(
    EditorNodeEventArgs e
)
Visual Basic
Sub OnMouseNodeEnter ( _
    e As EditorNodeEventArgs _
)
F#
abstract OnMouseNodeEnter :
        e:EditorNodeEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseNodeLeave Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseNodeLeave Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseNodeLeave aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseNodeLeave(
    EditorNodeEventArgs e
)
Visual Basic
Sub OnMouseNodeLeave ( _
    e As EditorNodeEventArgs _
)
F#
abstract OnMouseNodeLeave :
        e:EditorNodeEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMousePortEnter Method

[image]

DynamicNodes API
IGraphDocument..::..OnMousePortEnter Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MousePortEnter aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMousePortEnter(
    EditorPortEventArgs e
)
Visual Basic
Sub OnMousePortEnter ( _
    e As EditorPortEventArgs _
)
F#
abstract OnMousePortEnter :
        e:EditorPortEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorPortEventArgs
Eine EditorPortEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMousePortLeave Method

[image]

DynamicNodes API
IGraphDocument..::..OnMousePortLeave Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MousePortLeave aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMousePortLeave(
    EditorPortEventArgs e
)
Visual Basic
Sub OnMousePortLeave ( _
    e As EditorPortEventArgs _
)
F#
abstract OnMousePortLeave :
        e:EditorPortEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorPortEventArgs
Eine EditorPortEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseUp Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseUp Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseUp aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseUp(
    EditorMouseEventArgs e
)
Visual Basic
Sub OnMouseUp ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseUp :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnMouseWheel Method

[image]

DynamicNodes API
IGraphDocument..::..OnMouseWheel Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis MouseWheel aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnMouseWheel(
    EditorMouseEventArgs e
)
Visual Basic
Sub OnMouseWheel ( _
    e As EditorMouseEventArgs _
)
F#
abstract OnMouseWheel :
        e:EditorMouseEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorMouseEventArgs
Eine EditorMouseEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnNodeHelp Method

[image]

DynamicNodes API
IGraphDocument..::..OnNodeHelp Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis NodeHelp aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnNodeHelp(
    EditorNodeEventArgs e
)
Visual Basic
Sub OnNodeHelp ( _
    e As EditorNodeEventArgs _
)
F#
abstract OnNodeHelp :
        e:EditorNodeEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeSelectionEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnNodeProperties Method

[image]

DynamicNodes API
IGraphDocument..::..OnNodeProperties Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis NodeProperties aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnNodeProperties(
    EditorNodeEventArgs e
)
Visual Basic
Sub OnNodeProperties ( _
    e As EditorNodeEventArgs _
)
F#
abstract OnNodeProperties :
        e:EditorNodeEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorNodeEventArgs
Eine EditorNodeSelectionEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnNodeSelect Method

[image]

DynamicNodes API
IGraphDocument..::..OnNodeSelect Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis NodeSelect aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnNodeSelect(
    EditorNodeSelectionEventArgs e
)
Visual Basic
Sub OnNodeSelect ( _
    e As EditorNodeSelectionEventArgs _
)
F#
abstract OnNodeSelect :
        e:EditorNodeSelectionEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorNodeSelectionEventArgs
Eine EditorNodeSelectionEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnPortProperties Method

[image]

DynamicNodes API
IGraphDocument..::..OnPortProperties Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis PortProperties aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnPortProperties(
    EditorPortEventArgs e
)
Visual Basic
Sub OnPortProperties ( _
    e As EditorPortEventArgs _
)
F#
abstract OnPortProperties :
        e:EditorPortEventArgs -> unit

Parameters

e
Type: DynamicNode.Ext.Visual..::..EditorPortEventArgs
Eine EditorPortEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


OnShowSubGraph Method

[image]

DynamicNodes API
IGraphDocument..::..OnShowSubGraph Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis ShowSubGraph aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnShowSubGraph(
    SubGraphEventArgs e
)
Visual Basic
Sub OnShowSubGraph ( _
    e As SubGraphEventArgs _
)
F#
abstract OnShowSubGraph :
        e:SubGraphEventArgs -> unit

Parameters

e
Type: DynamicNode.Core..::..SubGraphEventArgs
Eine NodeEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


ReduceNodeSelection Method

[image]

DynamicNodes API
IGraphDocument..::..ReduceNodeSelection Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt einen Knoten aus der Knotenauswahl.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void ReduceNodeSelection(
    INode node
)
Visual Basic
Sub ReduceNodeSelection ( _
    node As INode _
)
F#
abstract ReduceNodeSelection :
        node:INode -> unit

Parameters

node
Type: DynamicNode.Core..::..INode

[Missing <param name="node"/> documentation for "M:DynamicNode.Ext.Visual.IGraphDocument.ReduceNodeSelection(DynamicNode.Core.INode)"]

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für nodenull übergeben wurde.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


Repaint Method

[image]

DynamicNodes API
IGraphDocument..::..Repaint Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet das Graph-Dokument neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void Repaint(
    bool imidiate
)
Visual Basic
Sub Repaint ( _
    imidiate As Boolean _
)
F#
abstract Repaint :
        imidiate:bool -> unit

Parameters

imidiate
Type: System..::..Boolean
true wenn das Dokument sofort synchron neu gezeichnet werden soll, false wenn das Dokument bei der nächsten Gelegenheit (Leerlauf der Nachrichtenwarteschleife) neu gezeichnet werden soll.

Remarks

Das Zeichnen des Graph-Dokuments wird verhindert, wenn AutoRepaint auf false gesetzt ist.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


SelectNothing Method

[image]

DynamicNodes API
IGraphDocument..::..SelectNothing Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löscht die aktuelle Auswahl.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void SelectNothing()
Visual Basic
Sub SelectNothing
F#
abstract SelectNothing : unit -> unit

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


WhileConnectingProcess Method

[image]

DynamicNodes API
IGraphDocument..::..WhileConnectingProcess Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Verbindungsprozesses.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void WhileConnectingProcess(
    float x,
    float y,
    IPort portUnderCursor
)
Visual Basic
Sub WhileConnectingProcess ( _
    x As Single, _
    y As Single, _
    portUnderCursor As IPort _
)
F#
abstract WhileConnectingProcess :
        x:float32 *
        y:float32 *
        portUnderCursor:IPort -> unit

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.
portUnderCursor
Type: DynamicNode.Core..::..IPort
Der Port unter dem Cursor oder null.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


WhileVisualSelectionProcess Method

[image]

DynamicNodes API
IGraphDocument..::..WhileVisualSelectionProcess Method
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Auswahlprozesses.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void WhileVisualSelectionProcess(
    float x,
    float y
)
Visual Basic
Sub WhileVisualSelectionProcess ( _
    x As Single, _
    y As Single _
)
F#
abstract WhileVisualSelectionProcess :
        x:float32 *
        y:float32 -> unit

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


IGraphDocument Properties

[image] [image]

DynamicNodes API
IGraphDocument Properties
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGraphDocument type exposes the following members.

Properties

 | Name | Description
Public property | AutoRepaint | Liest oder schreibt einen Wert, der angibt ob die Arbeitsfläche bei Änderungen des Graphen automatisch neu gezeichnet werden soll.
Public property | Editor | Liest oder schreibt den Eitor.
Public property | Graph | Gibt der Graph zurück, welches dargestellt werden soll.
Public property | IsConnectingInProgress | Gibt einen Wert zurück, der angibt, ob ein Verbindungsprozess aktiv ist.
Public property | IsMouseOverDocument | Gibt einen Wert zurück, der angibt ob der Cursor sich zur Zeit über dem Dokument befindet.
Public property | IsPinVisible | Gibt einen Wert zurück, der angibt ob die Pins der Verbindungen sichtbar sind oder nicht.
Public property | Runtime | Gibt die Laufzeitumgebung zurück in der der Graph ausgeführt wird.
Public property | SecondarySelectedNodes | Gibt eine Auflistung mit allen sekundär markierten Knoten zurück.
Public property | SecondarySelectedNodesCount | Gibt die Anzahl aller sekundär markierten Knoten einschließlich des primär markierten Knotens zurück.
Public property | SelectedNode | Gibt den ausgewählten Knoten zurück oder legt ihn fest.
Public property | SelectedPin | Liest oder schreibt den ausgewählten Pin.
Public property | SelectedPort | Liest oder schreibt den ausgewählten Port.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


AutoRepaint Property

[image]

DynamicNodes API
IGraphDocument..::..AutoRepaint Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob die Arbeitsfläche bei Änderungen des Graphen automatisch neu gezeichnet werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
bool AutoRepaint { get; set; }
Visual Basic
Property AutoRepaint As Boolean
    Get
    Set
F#
abstract AutoRepaint : bool with get, set

Field Value

true wenn die Arbeitsfläche automatisch neu gezeichnet werden soll, sonst false.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


Editor Property

[image]

DynamicNodes API
IGraphDocument..::..Editor Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Eitor.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
IEditor Editor { get; set; }
Visual Basic
Property Editor As IEditor
    Get
    Set
F#
abstract Editor : IEditor with get, set

Field Value

Der Editor.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


Graph Property

[image]

DynamicNodes API
IGraphDocument..::..Graph Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt der Graph zurück, welches dargestellt werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
IGraph Graph { get; }
Visual Basic
ReadOnly Property Graph As IGraph
    Get
F#
abstract Graph : IGraph

Field Value

Der Graph.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


IsConnectingInProgress Property

[image]

DynamicNodes API
IGraphDocument..::..IsConnectingInProgress Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob ein Verbindungsprozess aktiv ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
bool IsConnectingInProgress { get; }
Visual Basic
ReadOnly Property IsConnectingInProgress As Boolean
    Get
F#
abstract IsConnectingInProgress : bool

Field Value

true wenn ein Verbindungsprozess aktiv ist, sonst false.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


IsMouseOverDocument Property

[image]

DynamicNodes API
IGraphDocument..::..IsMouseOverDocument Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob der Cursor sich zur Zeit über dem Dokument befindet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
bool IsMouseOverDocument { get; }
Visual Basic
ReadOnly Property IsMouseOverDocument As Boolean
    Get
F#
abstract IsMouseOverDocument : bool

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


IsPinVisible Property

[image]

DynamicNodes API
IGraphDocument..::..IsPinVisible Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob die Pins der Verbindungen sichtbar sind oder nicht.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
bool IsPinVisible { get; set; }
Visual Basic
Property IsPinVisible As Boolean
    Get
    Set
F#
abstract IsPinVisible : bool with get, set

Field Value

Die Sichtbarkeit der Pins.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


Runtime Property

[image]

DynamicNodes API
IGraphDocument..::..Runtime Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Laufzeitumgebung zurück in der der Graph ausgeführt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
IRuntime Runtime { get; }
Visual Basic
ReadOnly Property Runtime As IRuntime
    Get
F#
abstract Runtime : IRuntime

Field Value

Die Laufzeitumgebung.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


SecondarySelectedNodes Property

[image]

DynamicNodes API
IGraphDocument..::..SecondarySelectedNodes Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Auflistung mit allen sekundär markierten Knoten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
IEnumerable<INode> SecondarySelectedNodes { get; }
Visual Basic
ReadOnly Property SecondarySelectedNodes As IEnumerable(Of INode)
    Get
F#
abstract SecondarySelectedNodes : IEnumerable<INode>

Remarks

Der ausgewählte Knoten SelectedNode ist automatisch auch sekundär markiert.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


SecondarySelectedNodesCount Property

[image]

DynamicNodes API
IGraphDocument..::..SecondarySelectedNodesCount Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller sekundär markierten Knoten einschließlich des primär markierten Knotens zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
int SecondarySelectedNodesCount { get; }
Visual Basic
ReadOnly Property SecondarySelectedNodesCount As Integer
    Get
F#
abstract SecondarySelectedNodesCount : int

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


SelectedNode Property

[image]

DynamicNodes API
IGraphDocument..::..SelectedNode Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den ausgewählten Knoten zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
INode SelectedNode { get; set; }
Visual Basic
Property SelectedNode As INode
    Get
    Set
F#
abstract SelectedNode : INode with get, set

Field Value

Der ausgewählte Knoten oder null, wenn kein Knoten ausgewählt ist.

Remarks

Das Ändern dieser Eigenschaft bewirkt kein Neuzeichnen des Dokumentes.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


SelectedPin Property

[image]

DynamicNodes API
IGraphDocument..::..SelectedPin Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den ausgewählten Pin.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
Pin SelectedPin { get; set; }
Visual Basic
Property SelectedPin As Pin
    Get
    Set
F#
abstract SelectedPin : Pin with get, set

Field Value

Der ausgewählte Pin oder null, wenn kein Pin ausgewählt ist.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


SelectedPort Property

[image]

DynamicNodes API
IGraphDocument..::..SelectedPort Property
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den ausgewählten Port.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
IPort SelectedPort { get; set; }
Visual Basic
Property SelectedPort As IPort
    Get
    Set
F#
abstract SelectedPort : IPort with get, set

Field Value

Der ausgewählte Port oder null, wenn kein Port ausgewählt ist.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


IGraphDocument Events

[image] [image]

DynamicNodes API
IGraphDocument Events
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGraphDocument type exposes the following members.

Events

 | Name | Description
Public event | Disposing | Wird ausgelöst, wenn das Dokument zerstört wird.
Public event | GraphProperties | Wird ausgelöst, wenn für einen Graphen der Eigenschaftsdialog angefordert wurde.
Public event | MouseClick | Wird ausgelöst, wenn ein Klick ausgeführt wurde.
Public event | MouseDoubleClick | Wird ausgelöst, wenn ein Doppel-Klick ausgeführt wurde.
Public event | MouseDown | Wird ausgelöst, wenn eine Maustaste gedrückt wird.
Public event | MouseEnter | Wird ausgelöst, wenn der Cursor den Editor betritt.
Public event | MouseHover | Wird ausgelöst, wenn der Cursor über der Arbeitsfläche verweilt.
Public event | MouseLeave | Wird ausgelöst, wenn der Cursor den Editor verlässt.
Public event | MouseMove | Wird ausgelöst, wenn der Cursor bewegt wird.
Public event | MouseNodeEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Knotens hinien bewegt wird.
Public event | MouseNodeLeave | Wird ausgelöst, wenn der Cursor den Bereich eines Knotens verlässt.
Public event | MousePortEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Ports hineinbewegt wird.
Public event | MousePortLeave | Wird ausgelöst, wenn der Cursor aus dem Bereich eines Ports herrausbewegt wird.
Public event | MouseUp | Wird ausgelöst, wenn eine Maustaste losgelassen wird.
Public event | MouseWheel | Wird ausgelöst, wenn das Mausrad gedreht wird.
Public event | NodeHelp | Wird ausgelöst, wenn für einen Knoten Hilfe angefordert wird.
Public event | NodeProperties | Wird ausgelöst, wenn für einen Knoten den Eigenschaftsdialog anfordert.
Public event | NodeSelect | Wird ausgelöst, wenn ein Knoten ausgewählt wird.
Public event | PortProperties | Wird ausgelöst, wenn für einen Port den Eigenschaftsdialog anfordert.
Public event | ShowSubGraph | Wird ausgelöst, wenn ein Sub-Graph-Knoten den gekapselten Graphen anzeigen möchte.

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


Disposing Event

[image]

DynamicNodes API
IGraphDocument..::..Disposing Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn das Dokument zerstört wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler Disposing
Visual Basic
Event Disposing As EventHandler
F#
abstract Disposing : IEvent<EventHandler,
    EventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


GraphProperties Event

[image]

DynamicNodes API
IGraphDocument..::..GraphProperties Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn für einen Graphen der Eigenschaftsdialog angefordert wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorDocumentEventArgs> GraphProperties
Visual Basic
Event GraphProperties As EventHandler(Of EditorDocumentEventArgs)
F#
abstract GraphProperties : IEvent<EventHandler<EditorDocumentEventArgs>,
    EditorDocumentEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseClick Event

[image]

DynamicNodes API
IGraphDocument..::..MouseClick Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Klick ausgeführt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorMouseEventArgs> MouseClick
Visual Basic
Event MouseClick As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseClick : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseDoubleClick Event

[image]

DynamicNodes API
IGraphDocument..::..MouseDoubleClick Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Doppel-Klick ausgeführt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorMouseEventArgs> MouseDoubleClick
Visual Basic
Event MouseDoubleClick As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseDoubleClick : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseDown Event

[image]

DynamicNodes API
IGraphDocument..::..MouseDown Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine Maustaste gedrückt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorMouseEventArgs> MouseDown
Visual Basic
Event MouseDown As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseDown : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseEnter Event

[image]

DynamicNodes API
IGraphDocument..::..MouseEnter Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor den Editor betritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler MouseEnter
Visual Basic
Event MouseEnter As EventHandler
F#
abstract MouseEnter : IEvent<EventHandler,
    EventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseHover Event

[image]

DynamicNodes API
IGraphDocument..::..MouseHover Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor über der Arbeitsfläche verweilt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler MouseHover
Visual Basic
Event MouseHover As EventHandler
F#
abstract MouseHover : IEvent<EventHandler,
    EventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseLeave Event

[image]

DynamicNodes API
IGraphDocument..::..MouseLeave Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor den Editor verlässt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler MouseLeave
Visual Basic
Event MouseLeave As EventHandler
F#
abstract MouseLeave : IEvent<EventHandler,
    EventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseMove Event

[image]

DynamicNodes API
IGraphDocument..::..MouseMove Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor bewegt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorMouseEventArgs> MouseMove
Visual Basic
Event MouseMove As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseMove : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseNodeEnter Event

[image]

DynamicNodes API
IGraphDocument..::..MouseNodeEnter Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor in den Bereich eines Knotens hinien bewegt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorNodeEventArgs> MouseNodeEnter
Visual Basic
Event MouseNodeEnter As EventHandler(Of EditorNodeEventArgs)
F#
abstract MouseNodeEnter : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseNodeLeave Event

[image]

DynamicNodes API
IGraphDocument..::..MouseNodeLeave Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor den Bereich eines Knotens verlässt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorNodeEventArgs> MouseNodeLeave
Visual Basic
Event MouseNodeLeave As EventHandler(Of EditorNodeEventArgs)
F#
abstract MouseNodeLeave : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MousePortEnter Event

[image]

DynamicNodes API
IGraphDocument..::..MousePortEnter Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor in den Bereich eines Ports hineinbewegt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorPortEventArgs> MousePortEnter
Visual Basic
Event MousePortEnter As EventHandler(Of EditorPortEventArgs)
F#
abstract MousePortEnter : IEvent<EventHandler<EditorPortEventArgs>,
    EditorPortEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MousePortLeave Event

[image]

DynamicNodes API
IGraphDocument..::..MousePortLeave Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Cursor aus dem Bereich eines Ports herrausbewegt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorPortEventArgs> MousePortLeave
Visual Basic
Event MousePortLeave As EventHandler(Of EditorPortEventArgs)
F#
abstract MousePortLeave : IEvent<EventHandler<EditorPortEventArgs>,
    EditorPortEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseUp Event

[image]

DynamicNodes API
IGraphDocument..::..MouseUp Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine Maustaste losgelassen wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorMouseEventArgs> MouseUp
Visual Basic
Event MouseUp As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseUp : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


MouseWheel Event

[image]

DynamicNodes API
IGraphDocument..::..MouseWheel Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn das Mausrad gedreht wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorMouseEventArgs> MouseWheel
Visual Basic
Event MouseWheel As EventHandler(Of EditorMouseEventArgs)
F#
abstract MouseWheel : IEvent<EventHandler<EditorMouseEventArgs>,
    EditorMouseEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


NodeHelp Event

[image]

DynamicNodes API
IGraphDocument..::..NodeHelp Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn für einen Knoten Hilfe angefordert wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorNodeEventArgs> NodeHelp
Visual Basic
Event NodeHelp As EventHandler(Of EditorNodeEventArgs)
F#
abstract NodeHelp : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


NodeProperties Event

[image]

DynamicNodes API
IGraphDocument..::..NodeProperties Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn für einen Knoten den Eigenschaftsdialog anfordert.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorNodeEventArgs> NodeProperties
Visual Basic
Event NodeProperties As EventHandler(Of EditorNodeEventArgs)
F#
abstract NodeProperties : IEvent<EventHandler<EditorNodeEventArgs>,
    EditorNodeEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


NodeSelect Event

[image]

DynamicNodes API
IGraphDocument..::..NodeSelect Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Knoten ausgewählt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorNodeSelectionEventArgs> NodeSelect
Visual Basic
Event NodeSelect As EventHandler(Of EditorNodeSelectionEventArgs)
F#
abstract NodeSelect : IEvent<EventHandler<EditorNodeSelectionEventArgs>,
    EditorNodeSelectionEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


PortProperties Event

[image]

DynamicNodes API
IGraphDocument..::..PortProperties Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn für einen Port den Eigenschaftsdialog anfordert.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<EditorPortEventArgs> PortProperties
Visual Basic
Event PortProperties As EventHandler(Of EditorPortEventArgs)
F#
abstract PortProperties : IEvent<EventHandler<EditorPortEventArgs>,
    EditorPortEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


ShowSubGraph Event

[image]

DynamicNodes API
IGraphDocument..::..ShowSubGraph Event
IGraphDocument Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Sub-Graph-Knoten den gekapselten Graphen anzeigen möchte.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<SubGraphEventArgs> ShowSubGraph
Visual Basic
Event ShowSubGraph As EventHandler(Of SubGraphEventArgs)
F#
abstract ShowSubGraph : IEvent<EventHandler<SubGraphEventArgs>,
    SubGraphEventArgs>

See Also

IGraphDocument Interface
DynamicNode.Ext.Visual Namespace


IPainter Interface

[image]

DynamicNodes API
IPainter Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Objekt, welches diese Schnittstelle implementiert, kann ein Graph zeichnen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public interface IPainter
Visual Basic
Public Interface IPainter
F#
type IPainter =  interface end

See Also

IPainter Members
DynamicNode.Ext.Visual Namespace


IPainter Members

[image] [image]

DynamicNodes API
IPainter Members
IPainter Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPainter type exposes the following members.

Methods

 | Name | Description
Public method | CreateBitmap | Erzeugt ein Bitmap in der Größe des Graphen und zeichnet den Graphen in der angegeben Skalierung.
Public method | EndAnimation | Beendet die Animation, löscht den Puffer und zeichnet die Arbeitsfläche neu.
Public method | EndAnimationStep | Schließt einen Animationsschritt ab und gibt das Ergebnis aus.
Public method | OnPaint | Der Handler für das Paint-Ereignis des Editor-Steuerelements.
Public method | Paint | Zeichnet die gesamte Ausgabe neu. (mit Invalidate)
Public method | PaintConnection(IPort, IPort) | Zeichnet eine Verbindung während des Verbindungsaufbaus.
Public method | PaintConnection(IPort, Single, Single) | Zeichnet eine Verbindung während des Verbindungsaufbaus.
Public method | PaintNode | Zeichnet einen Knoten neu.
Public method | PaintNodeCustomArea | Zeichnet den benutzerdefinierten Bereich eines Knotens neu.
Public method | PaintSelectionRectangle | Zeichnet ein Auswahlrechteck.
Public method | PrepareAnimation | Speichert den aktuellen Arbeitsflächeninhalt in einem Puffer und bereitet damit eine Animation auf der aktellen Ansicht vor.
Public method | StartAnimationStep | Beginnt einen Animationsschritt.

Properties

 | Name | Description
Public property | GraphVisualization | Gibt die Visualisierung des Graphen zurück, welcher gezeichnet werden soll.
Public property | Theme | Liest oder schreibt den Visualisierungs-Stil.

Events

 | Name | Description
Public event | PaintOverlay | Tritt am Ende des Zeichenvorgangs auf, nachdem die Knoten und Verbindungen gezeichnet wurden.

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


IPainter Methods

[image] [image]

DynamicNodes API
IPainter Methods
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPainter type exposes the following members.

Methods

 | Name | Description
Public method | CreateBitmap | Erzeugt ein Bitmap in der Größe des Graphen und zeichnet den Graphen in der angegeben Skalierung.
Public method | EndAnimation | Beendet die Animation, löscht den Puffer und zeichnet die Arbeitsfläche neu.
Public method | EndAnimationStep | Schließt einen Animationsschritt ab und gibt das Ergebnis aus.
Public method | OnPaint | Der Handler für das Paint-Ereignis des Editor-Steuerelements.
Public method | Paint | Zeichnet die gesamte Ausgabe neu. (mit Invalidate)
Public method | PaintConnection(IPort, IPort) | Zeichnet eine Verbindung während des Verbindungsaufbaus.
Public method | PaintConnection(IPort, Single, Single) | Zeichnet eine Verbindung während des Verbindungsaufbaus.
Public method | PaintNode | Zeichnet einen Knoten neu.
Public method | PaintNodeCustomArea | Zeichnet den benutzerdefinierten Bereich eines Knotens neu.
Public method | PaintSelectionRectangle | Zeichnet ein Auswahlrechteck.
Public method | PrepareAnimation | Speichert den aktuellen Arbeitsflächeninhalt in einem Puffer und bereitet damit eine Animation auf der aktellen Ansicht vor.
Public method | StartAnimationStep | Beginnt einen Animationsschritt.

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


CreateBitmap Method

[image]

DynamicNodes API
IPainter..::..CreateBitmap Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Bitmap in der Größe des Graphen und zeichnet den Graphen in der angegeben Skalierung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
Bitmap CreateBitmap(
    float scale,
    float margin,
    bool paintBackground
)
Visual Basic
Function CreateBitmap ( _
    scale As Single, _
    margin As Single, _
    paintBackground As Boolean _
) As Bitmap
F#
abstract CreateBitmap :
        scale:float32 *
        margin:float32 *
        paintBackground:bool -> Bitmap

Parameters

scale
Type: System..::..Single
Die Skalierung des Graphen. Ein Wert von 1.0 steht für 100% Skalierung.
margin
Type: System..::..Single
Gibt die Breite des umgebenden Rahmens vor der Skalierung an.
paintBackground
Type: System..::..Boolean
Ein Wert der angibt, ob der Hintergrund der Arbeitsfläche gezeichnet werden soll.

Return Value

Ein Bitmap-Objekt mit 32Bit ARGB Farbtiefe.

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


EndAnimation Method

[image]

DynamicNodes API
IPainter..::..EndAnimation Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beendet die Animation, löscht den Puffer und zeichnet die Arbeitsfläche neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void EndAnimation()
Visual Basic
Sub EndAnimation
F#
abstract EndAnimation : unit -> unit

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


EndAnimationStep Method

[image]

DynamicNodes API
IPainter..::..EndAnimationStep Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schließt einen Animationsschritt ab und gibt das Ergebnis aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void EndAnimationStep()
Visual Basic
Sub EndAnimationStep
F#
abstract EndAnimationStep : unit -> unit

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


OnPaint Method

[image]

DynamicNodes API
IPainter..::..OnPaint Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Handler für das Paint-Ereignis des Editor-Steuerelements.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void OnPaint(
    Object sender,
    PaintEventArgs e
)
Visual Basic
Sub OnPaint ( _
    sender As Object, _
    e As PaintEventArgs _
)
F#
abstract OnPaint :
        sender:Object *
        e:PaintEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Auslöser des Ereignisses.
e
Type: System.Windows.Forms..::..PaintEventArgs
Die Ereignis-Parameter.

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


Paint Method

[image]

DynamicNodes API
IPainter..::..Paint Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet die gesamte Ausgabe neu. (mit Invalidate)

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void Paint(
    bool imidiate
)
Visual Basic
Sub Paint ( _
    imidiate As Boolean _
)
F#
abstract Paint :
        imidiate:bool -> unit

Parameters

imidiate
Type: System..::..Boolean
Gibt an, ob das Zeichnen sofort geschehen soll.

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


PaintConnection Method

[image] [image]

DynamicNodes API
IPainter..::..PaintConnection Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | PaintConnection(IPort, IPort) | Zeichnet eine Verbindung während des Verbindungsaufbaus.
Public method | PaintConnection(IPort, Single, Single) | Zeichnet eine Verbindung während des Verbindungsaufbaus.

See Also

IPainter Interface
IPainter Members
DynamicNode.Ext.Visual Namespace


PaintConnection Method (IPort, IPort)

[image]

DynamicNodes API
IPainter..::..PaintConnection Method (IPort, IPort)
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet eine Verbindung während des Verbindungsaufbaus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void PaintConnection(
    IPort p1,
    IPort p2
)
Visual Basic
Sub PaintConnection ( _
    p1 As IPort, _
    p2 As IPort _
)
F#
abstract PaintConnection :
        p1:IPort *
        p2:IPort -> unit

Parameters

p1
Type: DynamicNode.Core..::..IPort
Der Port an dem die Verbindung beginnt.
p2
Type: DynamicNode.Core..::..IPort
Die Port an dem die Verbindung endet.

See Also

IPainter Interface
PaintConnection Overload
DynamicNode.Ext.Visual Namespace


PaintConnection Method (IPort, Single, Single)

[image]

DynamicNodes API
IPainter..::..PaintConnection Method (IPort, Single, Single)
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet eine Verbindung während des Verbindungsaufbaus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void PaintConnection(
    IPort p,
    float x,
    float y
)
Visual Basic
Sub PaintConnection ( _
    p As IPort, _
    x As Single, _
    y As Single _
)
F#
abstract PaintConnection :
        p:IPort *
        x:float32 *
        y:float32 -> unit

Parameters

p
Type: DynamicNode.Core..::..IPort
Der Port an dem die Verbindung beginnt.
x
Type: System..::..Single
Die WorkspaceX-Cursor-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Cursor-Koordinate.

See Also

IPainter Interface
PaintConnection Overload
DynamicNode.Ext.Visual Namespace


PaintNode Method

[image]

DynamicNodes API
IPainter..::..PaintNode Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet einen Knoten neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void PaintNode(
    NodeVisualization nVis
)
Visual Basic
Sub PaintNode ( _
    nVis As NodeVisualization _
)
F#
abstract PaintNode :
        nVis:NodeVisualization -> unit

Parameters

nVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


PaintNodeCustomArea Method

[image]

DynamicNodes API
IPainter..::..PaintNodeCustomArea Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet den benutzerdefinierten Bereich eines Knotens neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void PaintNodeCustomArea(
    NodeVisualization nVis
)
Visual Basic
Sub PaintNodeCustomArea ( _
    nVis As NodeVisualization _
)
F#
abstract PaintNodeCustomArea :
        nVis:NodeVisualization -> unit

Parameters

nVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


PaintSelectionRectangle Method

[image]

DynamicNodes API
IPainter..::..PaintSelectionRectangle Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet ein Auswahlrechteck.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void PaintSelectionRectangle(
    RectangleF rect
)
Visual Basic
Sub PaintSelectionRectangle ( _
    rect As RectangleF _
)
F#
abstract PaintSelectionRectangle :
        rect:RectangleF -> unit

Parameters

rect
Type: System.Drawing..::..RectangleF
Die Lage des Rechtecks

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


PrepareAnimation Method

[image]

DynamicNodes API
IPainter..::..PrepareAnimation Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Speichert den aktuellen Arbeitsflächeninhalt in einem Puffer und bereitet damit eine Animation auf der aktellen Ansicht vor.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void PrepareAnimation()
Visual Basic
Sub PrepareAnimation
F#
abstract PrepareAnimation : unit -> unit

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


StartAnimationStep Method

[image]

DynamicNodes API
IPainter..::..StartAnimationStep Method
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beginnt einen Animationsschritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void StartAnimationStep()
Visual Basic
Sub StartAnimationStep
F#
abstract StartAnimationStep : unit -> unit

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


IPainter Properties

[image] [image]

DynamicNodes API
IPainter Properties
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPainter type exposes the following members.

Properties

 | Name | Description
Public property | GraphVisualization | Gibt die Visualisierung des Graphen zurück, welcher gezeichnet werden soll.
Public property | Theme | Liest oder schreibt den Visualisierungs-Stil.

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


GraphVisualization Property

[image]

DynamicNodes API
IPainter..::..GraphVisualization Property
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Visualisierung des Graphen zurück, welcher gezeichnet werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
GraphVisualization GraphVisualization { get; set; }
Visual Basic
Property GraphVisualization As GraphVisualization
    Get
    Set
F#
abstract GraphVisualization : GraphVisualization with get, set

Field Value

Die Graphenvisualisierung.

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


Theme Property

[image]

DynamicNodes API
IPainter..::..Theme Property
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Visualisierungs-Stil.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
ITheme Theme { get; set; }
Visual Basic
Property Theme As ITheme
    Get
    Set
F#
abstract Theme : ITheme with get, set

Field Value

Der Visualisierungs-Stil (Theme).

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


IPainter Events

[image] [image]

DynamicNodes API
IPainter Events
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPainter type exposes the following members.

Events

 | Name | Description
Public event | PaintOverlay | Tritt am Ende des Zeichenvorgangs auf, nachdem die Knoten und Verbindungen gezeichnet wurden.

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


PaintOverlay Event

[image]

DynamicNodes API
IPainter..::..PaintOverlay Event
IPainter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt am Ende des Zeichenvorgangs auf, nachdem die Knoten und Verbindungen gezeichnet wurden.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
event EventHandler<GraphPaintEventArgs> PaintOverlay
Visual Basic
Event PaintOverlay As EventHandler(Of GraphPaintEventArgs)
F#
abstract PaintOverlay : IEvent<EventHandler<GraphPaintEventArgs>,
    GraphPaintEventArgs>

See Also

IPainter Interface
DynamicNode.Ext.Visual Namespace


IPaintProperties Interface

[image]

DynamicNodes API
IPaintProperties Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle, die Zeichenressourcen für den Arbeitsbereich anbietet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public interface IPaintProperties
Visual Basic
Public Interface IPaintProperties
F#
type IPaintProperties =  interface end

See Also

IPaintProperties Members
DynamicNode.Ext.Visual Namespace


IPaintProperties Members

[image] [image]

DynamicNodes API
IPaintProperties Members
IPaintProperties Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPaintProperties type exposes the following members.

Methods

 | Name | Description
Public method | GetBrush | Gibt für die übergebene ThemeColor ein Brush-Objekt zurück das mit der angegebene Farbe gleichmäßig füllt.
Public method | GetColor | Gibt eine Farbe anhand der übergebenen ThemeColor zurück.
Public method | GetDimension | Gibt eine Größe anhand des übergebenen ThemeDimension zurück.
Public method | GetFont | Gibt einen Font anhand des übergebenen ThemeFont zurück.
Public method | GetPalette | Gibt eine ColorPalette zurück, die einem 8Bit-Paletten-Bitmap zugewiesen werden kann. Dadurch lassen sich Bitmap-Grafiken mit hoher Geschwindigkeit mit den Designfarben der Graphendarstellung zeichnen.

Properties

 | Name | Description
Public property | PortsOnTop | Gibt einen Wert zurück, der angibt ob die Anschlüsse über dem Knoten oder unter dem Knoten gezeichnet werden sollen.

See Also

IPaintProperties Interface
DynamicNode.Ext.Visual Namespace


IPaintProperties Methods

[image] [image]

DynamicNodes API
IPaintProperties Methods
IPaintProperties Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPaintProperties type exposes the following members.

Methods

 | Name | Description
Public method | GetBrush | Gibt für die übergebene ThemeColor ein Brush-Objekt zurück das mit der angegebene Farbe gleichmäßig füllt.
Public method | GetColor | Gibt eine Farbe anhand der übergebenen ThemeColor zurück.
Public method | GetDimension | Gibt eine Größe anhand des übergebenen ThemeDimension zurück.
Public method | GetFont | Gibt einen Font anhand des übergebenen ThemeFont zurück.
Public method | GetPalette | Gibt eine ColorPalette zurück, die einem 8Bit-Paletten-Bitmap zugewiesen werden kann. Dadurch lassen sich Bitmap-Grafiken mit hoher Geschwindigkeit mit den Designfarben der Graphendarstellung zeichnen.

See Also

IPaintProperties Interface
DynamicNode.Ext.Visual Namespace


GetBrush Method

[image]

DynamicNodes API
IPaintProperties..::..GetBrush Method
IPaintProperties Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für die übergebene ThemeColor ein Brush-Objekt zurück das mit der angegebene Farbe gleichmäßig füllt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
Brush GetBrush(
    ThemeColor color
)
Visual Basic
Function GetBrush ( _
    color As ThemeColor _
) As Brush
F#
abstract GetBrush :
        color:ThemeColor -> Brush

Parameters

color
Type: DynamicNode.Ext.Visual..::..ThemeColor
Die Kennzeichnung der Farbe.

Return Value

Ein Brush-Objekt.

Remarks

Der zurückgegebene Pinsel darf nicht mit einem Aufruf von Dispose()()()() entsorgt werden.

See Also

IPaintProperties Interface
DynamicNode.Ext.Visual Namespace


GetColor Method

[image]

DynamicNodes API
IPaintProperties..::..GetColor Method
IPaintProperties Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Farbe anhand der übergebenen ThemeColor zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
Color GetColor(
    ThemeColor color
)
Visual Basic
Function GetColor ( _
    color As ThemeColor _
) As Color
F#
abstract GetColor :
        color:ThemeColor -> Color

Parameters

color
Type: DynamicNode.Ext.Visual..::..ThemeColor
Die Kennzeichnung der Farbe.

Return Value

Eine Color-Struktur mit der angefragten Farbe.

See Also

IPaintProperties Interface
DynamicNode.Ext.Visual Namespace


GetDimension Method

[image]

DynamicNodes API
IPaintProperties..::..GetDimension Method
IPaintProperties Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Größe anhand des übergebenen ThemeDimension zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
float GetDimension(
    ThemeDimension dimension
)
Visual Basic
Function GetDimension ( _
    dimension As ThemeDimension _
) As Single
F#
abstract GetDimension :
        dimension:ThemeDimension -> float32

Parameters

dimension
Type: DynamicNode.Ext.Visual..::..ThemeDimension
Die Kennzeichnung der Größe.

Return Value

Eine Fließkommzahl einfacher Genauigkeit mit der angefragten Größe.

See Also

IPaintProperties Interface
DynamicNode.Ext.Visual Namespace


GetFont Method

[image]

DynamicNodes API
IPaintProperties..::..GetFont Method
IPaintProperties Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Font anhand des übergebenen ThemeFont zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
Font GetFont(
    ThemeFont font
)
Visual Basic
Function GetFont ( _
    font As ThemeFont _
) As Font
F#
abstract GetFont :
        font:ThemeFont -> Font

Parameters

font
Type: DynamicNode.Ext.Visual..::..ThemeFont
Die Kennzeichnung der Schriftart.

Return Value

Ein Font-Objekt mit dem angefragten Font.

See Also

IPaintProperties Interface
DynamicNode.Ext.Visual Namespace


GetPalette Method

[image]

DynamicNodes API
IPaintProperties..::..GetPalette Method
IPaintProperties Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ColorPalette zurück, die einem 8Bit-Paletten-Bitmap zugewiesen werden kann. Dadurch lassen sich Bitmap-Grafiken mit hoher Geschwindigkeit mit den Designfarben der Graphendarstellung zeichnen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
ColorPalette GetPalette(
    ThemePalette palette
)
Visual Basic
Function GetPalette ( _
    palette As ThemePalette _
) As ColorPalette
F#
abstract GetPalette :
        palette:ThemePalette -> ColorPalette

Parameters

palette
Type: DynamicNode.Ext.Visual..::..ThemePalette
Die gewünschte Farbpalette.

Return Value

Das ColorPalette-Objekt mit der Farbpalette.

See Also

IPaintProperties Interface
DynamicNode.Ext.Visual Namespace


IPaintProperties Properties

[image] [image]

DynamicNodes API
IPaintProperties Properties
IPaintProperties Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPaintProperties type exposes the following members.

Properties

 | Name | Description
Public property | PortsOnTop | Gibt einen Wert zurück, der angibt ob die Anschlüsse über dem Knoten oder unter dem Knoten gezeichnet werden sollen.

See Also

IPaintProperties Interface
DynamicNode.Ext.Visual Namespace


PortsOnTop Property

[image]

DynamicNodes API
IPaintProperties..::..PortsOnTop Property
IPaintProperties Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob die Anschlüsse über dem Knoten oder unter dem Knoten gezeichnet werden sollen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
bool PortsOnTop { get; }
Visual Basic
ReadOnly Property PortsOnTop As Boolean
    Get
F#
abstract PortsOnTop : bool

See Also

IPaintProperties Interface
DynamicNode.Ext.Visual Namespace


ITheme Interface

[image]

DynamicNodes API
ITheme Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Interface, welches von Klassen implementiert werden muss, die eine grafische Ausgabe für ein DynamicNode-Graph zur Verfügung stellen wollen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public interface ITheme
Visual Basic
Public Interface ITheme
F#
type ITheme =  interface end

See Also

ITheme Members
DynamicNode.Ext.Visual Namespace


ITheme Members

[image] [image]

DynamicNodes API
ITheme Members
ITheme Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ITheme type exposes the following members.

Methods

 | Name | Description
Public method | DrawBackground | Zeichnet den Hintergrund der Arbeitsfläche.
Public method | DrawConnection(Graphics, PortVisualization, PortVisualization, Boolean) | Zeichnet eine Verbindung.
Public method | DrawConnection(Graphics, PortVisualization, Single, Single) | Zeichnet eine unfertige Verbindung.
Public method | DrawNode | Zeichnet einen Knoten.
Public method | DrawNodeCustomArea | Zeichnet den benutzerdefinierten Bereich eines Knotens.
Public method | DrawPin | Zeichnet einen Pin.
Public method | DrawPort | Zeichnet einen Port.
Public method | DrawSelectionRectangle | Zeichnet ein Auswahlrechteck.

Properties

 | Name | Description
Public property | PaintSettings | Liest oder schreibt die Einstellungen für die Darstellung.

See Also

ITheme Interface
DynamicNode.Ext.Visual Namespace


ITheme Methods

[image] [image]

DynamicNodes API
ITheme Methods
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ITheme type exposes the following members.

Methods

 | Name | Description
Public method | DrawBackground | Zeichnet den Hintergrund der Arbeitsfläche.
Public method | DrawConnection(Graphics, PortVisualization, PortVisualization, Boolean) | Zeichnet eine Verbindung.
Public method | DrawConnection(Graphics, PortVisualization, Single, Single) | Zeichnet eine unfertige Verbindung.
Public method | DrawNode | Zeichnet einen Knoten.
Public method | DrawNodeCustomArea | Zeichnet den benutzerdefinierten Bereich eines Knotens.
Public method | DrawPin | Zeichnet einen Pin.
Public method | DrawPort | Zeichnet einen Port.
Public method | DrawSelectionRectangle | Zeichnet ein Auswahlrechteck.

See Also

ITheme Interface
DynamicNode.Ext.Visual Namespace


DrawBackground Method

[image]

DynamicNodes API
ITheme..::..DrawBackground Method
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet den Hintergrund der Arbeitsfläche.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void DrawBackground(
    Graphics g
)
Visual Basic
Sub DrawBackground ( _
    g As Graphics _
)
F#
abstract DrawBackground :
        g:Graphics -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.

See Also

ITheme Interface
DynamicNode.Ext.Visual Namespace


DrawConnection Method

[image] [image]

DynamicNodes API
ITheme..::..DrawConnection Method
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | DrawConnection(Graphics, PortVisualization, PortVisualization, Boolean) | Zeichnet eine Verbindung.
Public method | DrawConnection(Graphics, PortVisualization, Single, Single) | Zeichnet eine unfertige Verbindung.

See Also

ITheme Interface
ITheme Members
DynamicNode.Ext.Visual Namespace


DrawConnection Method (Graphics, PortVisualization, PortVisualization, Boolean)

[image]

DynamicNodes API
ITheme..::..DrawConnection Method (Graphics, PortVisualization, PortVisualization, Boolean)
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet eine Verbindung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void DrawConnection(
    Graphics g,
    PortVisualization iPVis,
    PortVisualization oPVis,
    bool selected
)
Visual Basic
Sub DrawConnection ( _
    g As Graphics, _
    iPVis As PortVisualization, _
    oPVis As PortVisualization, _
    selected As Boolean _
)
F#
abstract DrawConnection :
        g:Graphics *
        iPVis:PortVisualization *
        oPVis:PortVisualization *
        selected:bool -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
iPVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Eingangs-Port-Visualisierung.
oPVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Ausgangs-Port-Visualisierung.
selected
Type: System..::..Boolean
Wenn true, wird die Verbindung farblich hervorgehoben.

See Also

ITheme Interface
DrawConnection Overload
DynamicNode.Ext.Visual Namespace


DrawConnection Method (Graphics, PortVisualization, Single, Single)

[image]

DynamicNodes API
ITheme..::..DrawConnection Method (Graphics, PortVisualization, Single, Single)
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet eine unfertige Verbindung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void DrawConnection(
    Graphics g,
    PortVisualization pVis,
    float x,
    float y
)
Visual Basic
Sub DrawConnection ( _
    g As Graphics, _
    pVis As PortVisualization, _
    x As Single, _
    y As Single _
)
F#
abstract DrawConnection :
        g:Graphics *
        pVis:PortVisualization *
        x:float32 *
        y:float32 -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
pVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Port-Visualisierung.
x
Type: System..::..Single
Die WorkspaceX-Koordinate des offenen Endes.
y
Type: System..::..Single
Die WorkspaceY-Koordinate des offenen Endes.

See Also

ITheme Interface
DrawConnection Overload
DynamicNode.Ext.Visual Namespace


DrawNode Method

[image]

DynamicNodes API
ITheme..::..DrawNode Method
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet einen Knoten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void DrawNode(
    Graphics g,
    NodeVisualization nodeVis,
    bool selected,
    bool secondarySelected
)
Visual Basic
Sub DrawNode ( _
    g As Graphics, _
    nodeVis As NodeVisualization, _
    selected As Boolean, _
    secondarySelected As Boolean _
)
F#
abstract DrawNode :
        g:Graphics *
        nodeVis:NodeVisualization *
        selected:bool *
        secondarySelected:bool -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
nodeVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Der Knoten-Visualisierer.
selected
Type: System..::..Boolean
Wenn true wird der Knoten als "ausgewählt" gezeichnet.
secondarySelected
Type: System..::..Boolean
Wenn true wird der Knoten als "sekundär ausgewählt" gezeichnet.

See Also

ITheme Interface
DynamicNode.Ext.Visual Namespace


DrawNodeCustomArea Method

[image]

DynamicNodes API
ITheme..::..DrawNodeCustomArea Method
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet den benutzerdefinierten Bereich eines Knotens.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void DrawNodeCustomArea(
    Graphics g,
    NodeVisualization nodeVis
)
Visual Basic
Sub DrawNodeCustomArea ( _
    g As Graphics, _
    nodeVis As NodeVisualization _
)
F#
abstract DrawNodeCustomArea :
        g:Graphics *
        nodeVis:NodeVisualization -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
nodeVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Der Knoten-Visualisierer.

See Also

ITheme Interface
DynamicNode.Ext.Visual Namespace


DrawPin Method

[image]

DynamicNodes API
ITheme..::..DrawPin Method
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet einen Pin.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void DrawPin(
    Graphics g,
    Pin pin,
    bool selected
)
Visual Basic
Sub DrawPin ( _
    g As Graphics, _
    pin As Pin, _
    selected As Boolean _
)
F#
abstract DrawPin :
        g:Graphics *
        pin:Pin *
        selected:bool -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
pin
Type: DynamicNode.Ext.Visual..::..Pin
Der Pin.
selected
Type: System..::..Boolean
Wenn true, wird der Pin farblich hervorgehoben.

See Also

ITheme Interface
DynamicNode.Ext.Visual Namespace


DrawPort Method

[image]

DynamicNodes API
ITheme..::..DrawPort Method
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet einen Port.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void DrawPort(
    Graphics g,
    PortVisualization portVis,
    bool disabled
)
Visual Basic
Sub DrawPort ( _
    g As Graphics, _
    portVis As PortVisualization, _
    disabled As Boolean _
)
F#
abstract DrawPort :
        g:Graphics *
        portVis:PortVisualization *
        disabled:bool -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
portVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Port-Visualisierung.
disabled
Type: System..::..Boolean
Wenn true, wird der Port als "nicht verfügbar" gezeichnet.

See Also

ITheme Interface
DynamicNode.Ext.Visual Namespace


DrawSelectionRectangle Method

[image]

DynamicNodes API
ITheme..::..DrawSelectionRectangle Method
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet ein Auswahlrechteck.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
void DrawSelectionRectangle(
    Graphics g,
    RectangleF rect
)
Visual Basic
Sub DrawSelectionRectangle ( _
    g As Graphics, _
    rect As RectangleF _
)
F#
abstract DrawSelectionRectangle :
        g:Graphics *
        rect:RectangleF -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Ein Graphics-Objekt.
rect
Type: System.Drawing..::..RectangleF
Das Rechteck.

See Also

ITheme Interface
DynamicNode.Ext.Visual Namespace


ITheme Properties

[image] [image]

DynamicNodes API
ITheme Properties
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ITheme type exposes the following members.

Properties

 | Name | Description
Public property | PaintSettings | Liest oder schreibt die Einstellungen für die Darstellung.

See Also

ITheme Interface
DynamicNode.Ext.Visual Namespace


PaintSettings Property

[image]

DynamicNodes API
ITheme..::..PaintSettings Property
ITheme Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die Einstellungen für die Darstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
PaintSettings PaintSettings { get; set; }
Visual Basic
Property PaintSettings As PaintSettings
    Get
    Set
F#
abstract PaintSettings : PaintSettings with get, set

See Also

ITheme Interface
DynamicNode.Ext.Visual Namespace


MultiGenericDelegate(T) Delegate

[image]

DynamicNodes API
MultiGenericDelegate<(Of <(<'T>)>)> Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein generisches Delegate mit beliebigen Parametern vom Typ T für die Verwendung mit ThreadHelper.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public delegate void MultiGenericDelegate<T>(
    params T[] values
)
Visual Basic
Public Delegate Sub MultiGenericDelegate(Of T) ( _
    ParamArray values As T() _
)
F#
type MultiGenericDelegate =
    delegate of
        values:'T[] -> unit

Parameters

values
Type: array<T>[]()[][]
Parameterwerte.

Type Parameters

T
Der Datentyp des generischen Delegates.

See Also

DynamicNode.Ext.Visual Namespace


NoBackgroundPanel Class

[image]

DynamicNodes API
NoBackgroundPanel Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Panel welches keinen Hintergund zeichnet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class NoBackgroundPanel : Control
Visual Basic
Public Class NoBackgroundPanel _
    Inherits Control
F#
type NoBackgroundPanel =
    class
        inherit Control
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
DynamicNode.Ext.Visual..::..NoBackgroundPanel

See Also

NoBackgroundPanel Members
DynamicNode.Ext.Visual Namespace


NoBackgroundPanel Members

[image] [image]

DynamicNodes API
NoBackgroundPanel Members
NoBackgroundPanel Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NoBackgroundPanel type exposes the following members.

Constructors

 | Name | Description
Public method | NoBackgroundPanel | Initialisiert eine neue Instanz der Klasse NoBackgroundPanel.

Methods

 | Name | Description
Protected method | OnMouseDown | Löst das MouseDown-Ereignis aus. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnPaintBackground | Zeichnet den Hintergrund des Steuerelements. (Overrides Control..::..OnPaintBackground(PaintEventArgs).)

See Also

NoBackgroundPanel Class
DynamicNode.Ext.Visual Namespace


NoBackgroundPanel Constructor

[image]

DynamicNodes API
NoBackgroundPanel Constructor
NoBackgroundPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse NoBackgroundPanel.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NoBackgroundPanel()
Visual Basic
Public Sub New
F#
new : unit -> NoBackgroundPanel

See Also

NoBackgroundPanel Class
DynamicNode.Ext.Visual Namespace


NoBackgroundPanel Methods

[image] [image]

DynamicNodes API
NoBackgroundPanel Methods
NoBackgroundPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NoBackgroundPanel type exposes the following members.

Methods

 | Name | Description
Protected method | OnMouseDown | Löst das MouseDown-Ereignis aus. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnPaintBackground | Zeichnet den Hintergrund des Steuerelements. (Overrides Control..::..OnPaintBackground(PaintEventArgs).)

See Also

NoBackgroundPanel Class
DynamicNode.Ext.Visual Namespace


OnMouseDown Method

[image]

DynamicNodes API
NoBackgroundPanel..::..OnMouseDown Method
NoBackgroundPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das MouseDown-Ereignis aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
Eine Instanz von MouseEventArgs, die die Ereignisdaten enthält.

See Also

NoBackgroundPanel Class
DynamicNode.Ext.Visual Namespace


OnPaintBackground Method

[image]

DynamicNodes API
NoBackgroundPanel..::..OnPaintBackground Method
NoBackgroundPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet den Hintergrund des Steuerelements.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs pevent
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    pevent As PaintEventArgs _
)
F#
abstract OnPaintBackground :
        pevent:PaintEventArgs -> unit
override OnPaintBackground :
        pevent:PaintEventArgs -> unit

Parameters

pevent
Type: System.Windows.Forms..::..PaintEventArgs
Eine PaintEventArgs-Klasse mit Informationen zum in Farbe anzuzeigenden Steuerelement.

See Also

NoBackgroundPanel Class
DynamicNode.Ext.Visual Namespace


NodeControlPanelExtension Class

[image]

DynamicNodes API
NodeControlPanelExtension Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Knoten-Erweiterung, welche der Entwicklungsumgebung ein Steuerelement zur Verfügung stellt, mit dem der Benutzer den Knoten steuern kann.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class NodeControlPanelExtension : IExtension<INode>,
    IStorable
Visual Basic
Public Class NodeControlPanelExtension _
    Implements IExtension(Of INode), IStorable
F#
type NodeControlPanelExtension =
    class
        interface IExtension<INode>
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..NodeControlPanelExtension

See Also

NodeControlPanelExtension Members
DynamicNode.Ext.Visual Namespace


NodeControlPanelExtension Members

[image] [image]

DynamicNodes API
NodeControlPanelExtension Members
NodeControlPanelExtension Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeControlPanelExtension type exposes the following members.

Constructors

 | Name | Description
Public method | NodeControlPanelExtension | Initializes a new instance of the NodeControlPanelExtension class

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | OnHide | Wird aufgerufen wenn das Ereignis Hide ausgelöst werden soll.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnShow | Wird aufgerufen wenn das Ereignis Show ausgelöst werden soll.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID der Knotensteuerungserweiterung. Da diese Erweiterung nur ein mal je Knoten angefügt werden kann, ist diese ID immer die gleiche.

Properties

 | Name | Description
Public property | Control | Liest oder schreibt das Steuerelement, mit dem die Steuerung des Knotens möglich ist.
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Events

 | Name | Description
Public event | Hide | Wird ausgelöst, wenn die Knoten-Steuerung ausgeblendet wird,
Public event | Show | Wird ausgelöst wenn die Knoten-Steuerung eingeblendet wird.

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


NodeControlPanelExtension Constructor

[image]

DynamicNodes API
NodeControlPanelExtension Constructor
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the NodeControlPanelExtension class

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NodeControlPanelExtension()
Visual Basic
Public Sub New
F#
new : unit -> NodeControlPanelExtension

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


NodeControlPanelExtension Fields

[image] [image]

DynamicNodes API
NodeControlPanelExtension Fields
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeControlPanelExtension type exposes the following members.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID der Knotensteuerungserweiterung. Da diese Erweiterung nur ein mal je Knoten angefügt werden kann, ist diese ID immer die gleiche.

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


EXT_ID Field

[image]

DynamicNodes API
NodeControlPanelExtension..::..EXT_ID Field
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID der Knotensteuerungserweiterung.
Da diese Erweiterung nur ein mal je Knoten angefügt werden kann, ist diese ID immer die gleiche.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


NodeControlPanelExtension Methods

[image] [image]

DynamicNodes API
NodeControlPanelExtension Methods
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeControlPanelExtension type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | OnHide | Wird aufgerufen wenn das Ereignis Hide ausgelöst werden soll.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnShow | Wird aufgerufen wenn das Ereignis Show ausgelöst werden soll.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


AfterAttaching Method

[image]

DynamicNodes API
NodeControlPanelExtension..::..AfterAttaching Method
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterAttaching(
    INode g
)
Visual Basic
Public Sub AfterAttaching ( _
    g As INode _
)
F#
abstract AfterAttaching :
        g:INode -> unit
override AfterAttaching :
        g:INode -> unit

Parameters

g
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


AfterDetaching Method

[image]

DynamicNodes API
NodeControlPanelExtension..::..AfterDetaching Method
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterDetaching(
    INode o
)
Visual Basic
Public Sub AfterDetaching ( _
    o As INode _
)
F#
abstract AfterDetaching :
        o:INode -> unit
override AfterDetaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


AfterRestoring Method

[image]

DynamicNodes API
NodeControlPanelExtension..::..AfterRestoring Method
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


OnHide Method

[image]

DynamicNodes API
NodeControlPanelExtension..::..OnHide Method
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn das Ereignis Hide ausgelöst werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnHide()
Visual Basic
Public Sub OnHide
F#
member OnHide : unit -> unit

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


OnRestore Method

[image]

DynamicNodes API
NodeControlPanelExtension..::..OnRestore Method
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader reader
)
Visual Basic
Public Sub OnRestore ( _
    reader As IPropertyReader _
)
F#
abstract OnRestore :
        reader:IPropertyReader -> unit
override OnRestore :
        reader:IPropertyReader -> unit

Parameters

reader
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschafts-Leser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


OnShow Method

[image]

DynamicNodes API
NodeControlPanelExtension..::..OnShow Method
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn das Ereignis Show ausgelöst werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnShow()
Visual Basic
Public Sub OnShow
F#
member OnShow : unit -> unit

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


OnStore Method

[image]

DynamicNodes API
NodeControlPanelExtension..::..OnStore Method
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter writer
)
Visual Basic
Public Sub OnStore ( _
    writer As IPropertyWriter _
)
F#
abstract OnStore :
        writer:IPropertyWriter -> unit
override OnStore :
        writer:IPropertyWriter -> unit

Parameters

writer
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschafts-Writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


NodeControlPanelExtension Properties

[image] [image]

DynamicNodes API
NodeControlPanelExtension Properties
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeControlPanelExtension type exposes the following members.

Properties

 | Name | Description
Public property | Control | Liest oder schreibt das Steuerelement, mit dem die Steuerung des Knotens möglich ist.
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


Control Property

[image]

DynamicNodes API
NodeControlPanelExtension..::..Control Property
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt das Steuerelement, mit dem die Steuerung des Knotens möglich ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Control Control { get; set; }
Visual Basic
Public Property Control As Control
    Get
    Set
F#
member Control : Control with get, set

Field Value

Ein Steuerelement.

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


Id Property

[image]

DynamicNodes API
NodeControlPanelExtension..::..Id Property
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ID zurück, welche im Kontext des Objektes zu dem die Erweiterung gehört, eindeutig ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


IsUsingStorage Property

[image]

DynamicNodes API
NodeControlPanelExtension..::..IsUsingStorage Property
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


NodeControlPanelExtension Events

[image] [image]

DynamicNodes API
NodeControlPanelExtension Events
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeControlPanelExtension type exposes the following members.

Events

 | Name | Description
Public event | Hide | Wird ausgelöst, wenn die Knoten-Steuerung ausgeblendet wird,
Public event | Show | Wird ausgelöst wenn die Knoten-Steuerung eingeblendet wird.

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


Hide Event

[image]

DynamicNodes API
NodeControlPanelExtension..::..Hide Event
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die Knoten-Steuerung ausgeblendet wird,

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler Hide
Visual Basic
Public Event Hide As EventHandler
F#
member Hide : IEvent<EventHandler,
    EventArgs>

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


Show Event

[image]

DynamicNodes API
NodeControlPanelExtension..::..Show Event
NodeControlPanelExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst wenn die Knoten-Steuerung eingeblendet wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler Show
Visual Basic
Public Event Show As EventHandler
F#
member Show : IEvent<EventHandler,
    EventArgs>

See Also

NodeControlPanelExtension Class
DynamicNode.Ext.Visual Namespace


NodeCreationCallback Delegate

[image]

DynamicNodes API
NodeCreationCallback Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Callback-Delegate welches aufgerufen wird wenn ein Knoten erfolgreich erstellt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public delegate void NodeCreationCallback(
    INode node,
    Object dropInfo
)
Visual Basic
Public Delegate Sub NodeCreationCallback ( _
    node As INode, _
    dropInfo As Object _
)
F#
type NodeCreationCallback =
    delegate of
        node:INode *
        dropInfo:Object -> unit

Parameters

node
Type: DynamicNode.Core..::..INode
Der erstellte Knoten oder null, wenn kein Knoten erstellt wurde.
dropInfo
Type: System..::..Object
Zusätzliche Informationen vom Abschluss der Drag&Drop-Aktion.

See Also

DynamicNode.Ext.Visual Namespace


NodeCreationException Class

[image]

DynamicNodes API
NodeCreationException Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ausnahme, die beim Erzeugen eines Knotens am Ende einer Drag&Drop-Aktion ausgelöst wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class NodeCreationException : Exception
Visual Basic
Public Class NodeCreationException _
    Inherits Exception
F#
type NodeCreationException =
    class
        inherit Exception
    end

Inheritance Hierarchy

System..::..Object
System..::..Exception
DynamicNode.Ext.Visual..::..NodeCreationException

See Also

NodeCreationException Members
DynamicNode.Ext.Visual Namespace


NodeCreationException Members

[image] [image]

DynamicNodes API
NodeCreationException Members
NodeCreationException Class Constructors See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Constructors

 | Name | Description
Public method | NodeCreationException(String) | Initialisiert eine neue Instanz von NodeCreationException.
Public method | NodeCreationException(String, Exception) | Initialisiert eine neue Instanz von NodeCreationException mit einer beschreibenden Fehlermeldung.

See Also

NodeCreationException Class
DynamicNode.Ext.Visual Namespace


NodeCreationException Constructor

[image] [image]

DynamicNodes API
NodeCreationException Constructor
NodeCreationException Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | NodeCreationException(String) | Initialisiert eine neue Instanz von NodeCreationException.
Public method | NodeCreationException(String, Exception) | Initialisiert eine neue Instanz von NodeCreationException mit einer beschreibenden Fehlermeldung.

See Also

NodeCreationException Class
NodeCreationException Members
DynamicNode.Ext.Visual Namespace


NodeCreationException Constructor (String)

[image]

DynamicNodes API
NodeCreationException Constructor (String)
NodeCreationException Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von NodeCreationException.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NodeCreationException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
F#
new :
        message:string -> NodeCreationException

Parameters

message
Type: System..::..String
Die Meldung, in der der Fehler beschrieben wird.

See Also

NodeCreationException Class
NodeCreationException Overload
DynamicNode.Ext.Visual Namespace


NodeCreationException Constructor (String, Exception)

[image]

DynamicNodes API
NodeCreationException Constructor (String, Exception)
NodeCreationException Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von NodeCreationException mit einer beschreibenden Fehlermeldung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NodeCreationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
F#
new :
        message:string *
        innerException:Exception -> NodeCreationException

Parameters

message
Type: System..::..String
Die Meldung, in der der Fehler beschrieben wird.
innerException
Type: System..::..Exception
Die Ausnahme, die Ursache der aktuellen Ausnahme ist.

See Also

NodeCreationException Class
NodeCreationException Overload
DynamicNode.Ext.Visual Namespace


NodePaintHandler Delegate

[image]

DynamicNodes API
NodePaintHandler Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Handler für das Zeichnen eines Knotens.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public delegate void NodePaintHandler(
    Graphics g,
    NodeVisualization nVis,
    bool selected,
    bool secondarySelected
)
Visual Basic
Public Delegate Sub NodePaintHandler ( _
    g As Graphics, _
    nVis As NodeVisualization, _
    selected As Boolean, _
    secondarySelected As Boolean _
)
F#
type NodePaintHandler =
    delegate of
        g:Graphics *
        nVis:NodeVisualization *
        selected:bool *
        secondarySelected:bool -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Der Gerätekontext zum Zeichnen.
nVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.
selected
Type: System..::..Boolean
Gibt an, ob er Knoten zur Zeit ausgewählt ist oder nicht.
secondarySelected
Type: System..::..Boolean
Gibt an, ob er Knoten zur Zeit sekundär ausgewählt ist oder nicht

See Also

DynamicNode.Ext.Visual Namespace


NodeShaddowStyle Enumeration

[image]

DynamicNodes API
NodeShaddowStyle Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die verschiedenen Stile für den Knotenschatten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public enum NodeShaddowStyle
Visual Basic
Public Enumeration NodeShaddowStyle
F#
type NodeShaddowStyle

Members

Member name | Description
None |
LinearGradient |
LinearRounded |
CastLinear |
CastLinearRounded |

See Also

DynamicNode.Ext.Visual Namespace


NodeVisualization Class

[image]

DynamicNodes API
NodeVisualization Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erweitert einen Knoten um Eigenschaften und Fähigkeiten zur grafischen Darstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class NodeVisualization : IExtension<INode>,
    IStorable
Visual Basic
Public Class NodeVisualization _
    Implements IExtension(Of INode), IStorable
F#
type NodeVisualization =
    class
        interface IExtension<INode>
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..NodeVisualization

See Also

NodeVisualization Members
DynamicNode.Ext.Visual Namespace


NodeVisualization Members

[image] [image]

DynamicNodes API
NodeVisualization Members
NodeVisualization Class Constructors Methods Fields Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeVisualization type exposes the following members.

Constructors

 | Name | Description
Public method | NodeVisualization | Initialisiert eine neue Instanz der Klasse NodeVisualization.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Knoten angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Knoten entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | ArrangePorts | Verteilt die Ports gleichmäßig an den Kanten des Knotens. Dabei wird die Ausrichtung der Ports berücksichtigt.
Public method | CheckForNewPosition | Überprüft ob die neuen Koordinaten zu einer neuen Position des Knotens führen, oder ob sie durch die Rundung auf das Raster keine Änderung bewirken würden.
 | GetFrom | Gibt für einen Knoten die Visualisierung zurück.
Public method | GetPortByMouse | Gibt einen Port anhand von Cursor-Koordinaten zurück, oder null, wenn kein Port dieses Knotens unter dem Cursor liegt.
Public method | GetPortVisualization | Gibt die Visualisierung für einen Port zurück.
Public method | IsMouseInside | Prüft, ob die Cursor-Koordinaten innerhalb des grafischen Ausgabebereichs des Knotens liegen.
 | MeasureString | Berechnet den Platzbedarf einer gerenderten Zeichenkette.
Public method | OnCustomAreaPaint | Wird aufgerufen wenn die benutzerdefiniert Knotenfläche gezeichnet werden soll.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Public method | RepaintCustomArea | Zeichnet die benutzerdefinierte Knotenfläche neu.
Public method | RepaintNode | Zeichnet den gesamten Knoten neu.
Public method | SetPosition | Legt die Position des Knotens fest.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID der Knoten-Visualisierung. Da diese Erweiterung nur ein mal je Knoten angefügt werden kann, ist diese ID immer die gleiche.

Properties

 | Name | Description
Public property | ClientHeight | Die Höhe des benutzerdefinierten Bereichs innerhalb des grafischen Ausgabebereichs des Knotens.
Public property | ClientRectangle | Gibt den benutzerdefinierten Bereich zurück.
Public property | ClientWidth | Die Breite des benutzerdefinierten Bereichs innerhalb des grafischen Ausgabebereichs des Knotens.
Public property | CustomArea | Gibt einen Wert zurück, der angibt ob der benutzerdefinierte Bereich höher als 0 ist.
Public property | Deletable | Liest oder schreibt einen Wert, der angibt ob der Knoten vom Benutzer gelöscht werden darf.
Public property | GraphVisualization | Gibt das GraphVisualization zurück, dem diese Knotenvisualisierung untergeordnet ist.
Public property | Id | Gibt eine knotenweit eindeutige ID zurück.
Public property | IsMovable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten vom Benutzer verschoben werden darf.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | OuterRectangle | Gibt den grafischen Ausgabebereich des Knotens zurück, einschließlich der Randbereiche in denen die Ports angeordnet sind.
Public property | OwnerNode | Gibt den Knoten zurück.
Public property | PaintHandler | Gibt einen Handler für angepasstes Zeichnen des Knotens zurück oder legt ihn fest. Wenn diese Eigenschaft null ist, wird der Knoten im Standard-Style gezeichnet.
Public property | PosX | Die WorkspaceX-Position des Knotens.
Public property | PosY | Die WorkspaceY-Position des Knotens.
Public property | Rectangle | Gibt den grafischen Ausgabebereich des Knotens zurück.
Public property | ShowName | Liest oder schreibt einen Wert, der angibt ob der Name des Knotens angezeigt werden soll.
Public property | UseCaptionWidth | Liest oder schreibt einen Wert, der angibt ob diese NodeVisualization-Instanz die Beschriftungsbreite als Breite für den benutzerdefinierten Bereich verwenden soll.

Events

 | Name | Description
Public event | CustomAreaPaint | Wird ausgelöst, wenn die benutzerdefinierte Fläche des Knotens gezeichnet wird.
Public event | CustomAreaRepaint | Wird ausgelöst, wenn die benutzerdefinierte Fläche des Knotens neu gezeichnet werden soll.
Public event | NodeRepaint | Wird ausgelöst, wenn der gesamte Knoten neu gezeichnet werden soll.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


NodeVisualization Constructor

[image]

DynamicNodes API
NodeVisualization Constructor
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse NodeVisualization.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NodeVisualization(
    GraphVisualization graphVisualization
)
Visual Basic
Public Sub New ( _
    graphVisualization As GraphVisualization _
)
F#
new :
        graphVisualization:GraphVisualization -> NodeVisualization

Parameters

graphVisualization
Type: DynamicNode.Ext.Visual..::..GraphVisualization
The graph visualization.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


NodeVisualization Fields

[image] [image]

DynamicNodes API
NodeVisualization Fields
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeVisualization type exposes the following members.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID der Knoten-Visualisierung. Da diese Erweiterung nur ein mal je Knoten angefügt werden kann, ist diese ID immer die gleiche.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


EXT_ID Field

[image]

DynamicNodes API
NodeVisualization..::..EXT_ID Field
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID der Knoten-Visualisierung.
Da diese Erweiterung nur ein mal je Knoten angefügt werden kann, ist diese ID immer die gleiche.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


NodeVisualization Methods

[image] [image]

DynamicNodes API
NodeVisualization Methods
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeVisualization type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Knoten angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Knoten entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | ArrangePorts | Verteilt die Ports gleichmäßig an den Kanten des Knotens. Dabei wird die Ausrichtung der Ports berücksichtigt.
Public method | CheckForNewPosition | Überprüft ob die neuen Koordinaten zu einer neuen Position des Knotens führen, oder ob sie durch die Rundung auf das Raster keine Änderung bewirken würden.
 | GetFrom | Gibt für einen Knoten die Visualisierung zurück.
Public method | GetPortByMouse | Gibt einen Port anhand von Cursor-Koordinaten zurück, oder null, wenn kein Port dieses Knotens unter dem Cursor liegt.
Public method | GetPortVisualization | Gibt die Visualisierung für einen Port zurück.
Public method | IsMouseInside | Prüft, ob die Cursor-Koordinaten innerhalb des grafischen Ausgabebereichs des Knotens liegen.
 | MeasureString | Berechnet den Platzbedarf einer gerenderten Zeichenkette.
Public method | OnCustomAreaPaint | Wird aufgerufen wenn die benutzerdefiniert Knotenfläche gezeichnet werden soll.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Public method | RepaintCustomArea | Zeichnet die benutzerdefinierte Knotenfläche neu.
Public method | RepaintNode | Zeichnet den gesamten Knoten neu.
Public method | SetPosition | Legt die Position des Knotens fest.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


AfterAttaching Method

[image]

DynamicNodes API
NodeVisualization..::..AfterAttaching Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Knoten angefügt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterAttaching(
    INode o
)
Visual Basic
Public Sub AfterAttaching ( _
    o As INode _
)
F#
abstract AfterAttaching :
        o:INode -> unit
override AfterAttaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Der Knoten

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


AfterDetaching Method

[image]

DynamicNodes API
NodeVisualization..::..AfterDetaching Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Knoten entfernt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterDetaching(
    INode n
)
Visual Basic
Public Sub AfterDetaching ( _
    n As INode _
)
F#
abstract AfterDetaching :
        n:INode -> unit
override AfterDetaching :
        n:INode -> unit

Parameters

n
Type: DynamicNode.Core..::..INode
Der Knoten

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


AfterRestoring Method

[image]

DynamicNodes API
NodeVisualization..::..AfterRestoring Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


ArrangePorts Method

[image]

DynamicNodes API
NodeVisualization..::..ArrangePorts Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verteilt die Ports gleichmäßig an den Kanten des Knotens. Dabei wird die Ausrichtung der Ports berücksichtigt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void ArrangePorts()
Visual Basic
Public Sub ArrangePorts
F#
member ArrangePorts : unit -> unit

Remarks

Sollte in Subroutinen aufgeteilt werden.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace
System.Windows.Forms..::..Orientation


CheckForNewPosition Method

[image]

DynamicNodes API
NodeVisualization..::..CheckForNewPosition Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft ob die neuen Koordinaten zu einer neuen Position des Knotens führen, oder ob sie durch die Rundung auf das Raster keine Änderung bewirken würden.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool CheckForNewPosition(
    float x,
    float y
)
Visual Basic
Public Function CheckForNewPosition ( _
    x As Single, _
    y As Single _
) As Boolean
F#
member CheckForNewPosition :
        x:float32 *
        y:float32 -> bool

Parameters

x
Type: System..::..Single
Die neuen WorkspaceX-Korrdinaten.
y
Type: System..::..Single
Die neuen WorkspaceY-Korrdinaten.

Return Value

true, wenn die neuen Koordinaten zu einer neuen Position führen würden, sonst false.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


GetFrom Method

[image]

DynamicNodes API
NodeVisualization..::..GetFrom Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für einen Knoten die Visualisierung zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public static NodeVisualization GetFrom(
    INode node
)
Visual Basic
Public Shared Function GetFrom ( _
    node As INode _
) As NodeVisualization
F#
static member GetFrom :
        node:INode -> NodeVisualization

Parameters

node
Type: DynamicNode.Core..::..INode
Ein Knoten.

Return Value

Die Visualisierung oder null, wenn keine Visualisierung an den Knoten angefügt wurde.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


GetPortByMouse Method

[image]

DynamicNodes API
NodeVisualization..::..GetPortByMouse Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Port anhand von Cursor-Koordinaten zurück, oder null, wenn kein Port dieses Knotens unter dem Cursor liegt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IPort GetPortByMouse(
    float x,
    float y
)
Visual Basic
Public Function GetPortByMouse ( _
    x As Single, _
    y As Single _
) As IPort
F#
member GetPortByMouse :
        x:float32 *
        y:float32 -> IPort

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.

Return Value

Einen Port oder null.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


GetPortVisualization Method

[image]

DynamicNodes API
NodeVisualization..::..GetPortVisualization Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Visualisierung für einen Port zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PortVisualization GetPortVisualization(
    string portId
)
Visual Basic
Public Function GetPortVisualization ( _
    portId As String _
) As PortVisualization
F#
member GetPortVisualization :
        portId:string -> PortVisualization

Parameters

portId
Type: System..::..String
Die Port-ID.

Return Value

Ein PortVisualization-Objekt.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


IsMouseInside Method

[image]

DynamicNodes API
NodeVisualization..::..IsMouseInside Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob die Cursor-Koordinaten innerhalb des grafischen Ausgabebereichs des Knotens liegen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsMouseInside(
    float x,
    float y,
    bool border
)
Visual Basic
Public Function IsMouseInside ( _
    x As Single, _
    y As Single, _
    border As Boolean _
) As Boolean
F#
member IsMouseInside :
        x:float32 *
        y:float32 *
        border:bool -> bool

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.
border
Type: System..::..Boolean
Wenn true wird der Bereich, in dem die Ports dargestellt werden mitberücksichtigt.

Return Value

true, wenn die Koordinaten innerhalb des grafischen Ausgabebereichs liegen, sonst false.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


MeasureString Method

[image]

DynamicNodes API
NodeVisualization..::..MeasureString Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet den Platzbedarf einer gerenderten Zeichenkette.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public static SizeF MeasureString(
    string text,
    Font font
)
Visual Basic
Public Shared Function MeasureString ( _
    text As String, _
    font As Font _
) As SizeF
F#
static member MeasureString :
        text:string *
        font:Font -> SizeF

Parameters

text
Type: System..::..String
Die Zeichenkette.
font
Type: System.Drawing..::..Font
Der zu verwendende Font.

Return Value

Die Größe der benötigten Zeichenfläche.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


OnCustomAreaPaint Method

[image]

DynamicNodes API
NodeVisualization..::..OnCustomAreaPaint Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn die benutzerdefiniert Knotenfläche gezeichnet werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnCustomAreaPaint(
    Graphics g,
    RectangleF clipR
)
Visual Basic
Public Sub OnCustomAreaPaint ( _
    g As Graphics, _
    clipR As RectangleF _
)
F#
member OnCustomAreaPaint :
        g:Graphics *
        clipR:RectangleF -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Der Grafik-Kontext.
clipR
Type: System.Drawing..::..RectangleF
Das Rechteck in dem gezeichnet wird. (Clip-Region)

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


OnRestore Method

[image]

DynamicNodes API
NodeVisualization..::..OnRestore Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader reader
)
Visual Basic
Public Sub OnRestore ( _
    reader As IPropertyReader _
)
F#
abstract OnRestore :
        reader:IPropertyReader -> unit
override OnRestore :
        reader:IPropertyReader -> unit

Parameters

reader
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschafts-Leser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


OnStore Method

[image]

DynamicNodes API
NodeVisualization..::..OnStore Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter writer
)
Visual Basic
Public Sub OnStore ( _
    writer As IPropertyWriter _
)
F#
abstract OnStore :
        writer:IPropertyWriter -> unit
override OnStore :
        writer:IPropertyWriter -> unit

Parameters

writer
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschafts-Writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


RepaintCustomArea Method

[image]

DynamicNodes API
NodeVisualization..::..RepaintCustomArea Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet die benutzerdefinierte Knotenfläche neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void RepaintCustomArea()
Visual Basic
Public Sub RepaintCustomArea
F#
member RepaintCustomArea : unit -> unit

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


RepaintNode Method

[image]

DynamicNodes API
NodeVisualization..::..RepaintNode Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet den gesamten Knoten neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void RepaintNode()
Visual Basic
Public Sub RepaintNode
F#
member RepaintNode : unit -> unit

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


SetPosition Method

[image]

DynamicNodes API
NodeVisualization..::..SetPosition Method
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Legt die Position des Knotens fest.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void SetPosition(
    float x,
    float y
)
Visual Basic
Public Sub SetPosition ( _
    x As Single, _
    y As Single _
)
F#
member SetPosition :
        x:float32 *
        y:float32 -> unit

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


NodeVisualization Properties

[image] [image]

DynamicNodes API
NodeVisualization Properties
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeVisualization type exposes the following members.

Properties

 | Name | Description
Public property | ClientHeight | Die Höhe des benutzerdefinierten Bereichs innerhalb des grafischen Ausgabebereichs des Knotens.
Public property | ClientRectangle | Gibt den benutzerdefinierten Bereich zurück.
Public property | ClientWidth | Die Breite des benutzerdefinierten Bereichs innerhalb des grafischen Ausgabebereichs des Knotens.
Public property | CustomArea | Gibt einen Wert zurück, der angibt ob der benutzerdefinierte Bereich höher als 0 ist.
Public property | Deletable | Liest oder schreibt einen Wert, der angibt ob der Knoten vom Benutzer gelöscht werden darf.
Public property | GraphVisualization | Gibt das GraphVisualization zurück, dem diese Knotenvisualisierung untergeordnet ist.
Public property | Id | Gibt eine knotenweit eindeutige ID zurück.
Public property | IsMovable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten vom Benutzer verschoben werden darf.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | OuterRectangle | Gibt den grafischen Ausgabebereich des Knotens zurück, einschließlich der Randbereiche in denen die Ports angeordnet sind.
Public property | OwnerNode | Gibt den Knoten zurück.
Public property | PaintHandler | Gibt einen Handler für angepasstes Zeichnen des Knotens zurück oder legt ihn fest. Wenn diese Eigenschaft null ist, wird der Knoten im Standard-Style gezeichnet.
Public property | PosX | Die WorkspaceX-Position des Knotens.
Public property | PosY | Die WorkspaceY-Position des Knotens.
Public property | Rectangle | Gibt den grafischen Ausgabebereich des Knotens zurück.
Public property | ShowName | Liest oder schreibt einen Wert, der angibt ob der Name des Knotens angezeigt werden soll.
Public property | UseCaptionWidth | Liest oder schreibt einen Wert, der angibt ob diese NodeVisualization-Instanz die Beschriftungsbreite als Breite für den benutzerdefinierten Bereich verwenden soll.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


ClientHeight Property

[image]

DynamicNodes API
NodeVisualization..::..ClientHeight Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Höhe des benutzerdefinierten Bereichs innerhalb des grafischen Ausgabebereichs des Knotens.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float ClientHeight { get; set; }
Visual Basic
Public Property ClientHeight As Single
    Get
    Set
F#
member ClientHeight : float32 with get, set

Field Value

Die Höhe des benutzerdefinierten Bereichs.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


ClientRectangle Property

[image]

DynamicNodes API
NodeVisualization..::..ClientRectangle Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den benutzerdefinierten Bereich zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public RectangleF ClientRectangle { get; }
Visual Basic
Public ReadOnly Property ClientRectangle As RectangleF
    Get
F#
member ClientRectangle : RectangleF

Field Value

Der benutzerdefinierte Bereich.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


ClientWidth Property

[image]

DynamicNodes API
NodeVisualization..::..ClientWidth Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Breite des benutzerdefinierten Bereichs innerhalb des grafischen Ausgabebereichs des Knotens.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float ClientWidth { get; set; }
Visual Basic
Public Property ClientWidth As Single
    Get
    Set
F#
member ClientWidth : float32 with get, set

Field Value

Die Breite des benutzerdefinierten Bereichs.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


CustomArea Property

[image]

DynamicNodes API
NodeVisualization..::..CustomArea Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob der benutzerdefinierte Bereich höher als 0 ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool CustomArea { get; }
Visual Basic
Public ReadOnly Property CustomArea As Boolean
    Get
F#
member CustomArea : bool

Field Value

true, wenn der benutzerdefinierte Bereich höher 0 ist, sonst false.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


Deletable Property

[image]

DynamicNodes API
NodeVisualization..::..Deletable Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob der Knoten vom Benutzer gelöscht werden darf.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool Deletable { get; set; }
Visual Basic
Public Property Deletable As Boolean
    Get
    Set
F#
member Deletable : bool with get, set

Field Value

true, wenn der Knoten vom Benutzer gelöscht werden darf, sonst false.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


GraphVisualization Property

[image]

DynamicNodes API
NodeVisualization..::..GraphVisualization Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das GraphVisualization zurück, dem diese Knotenvisualisierung untergeordnet ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public GraphVisualization GraphVisualization { get; private set; }
Visual Basic
Public Property GraphVisualization As GraphVisualization
    Get
    Private Set
F#
member GraphVisualization : GraphVisualization with get, private set

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


Id Property

[image]

DynamicNodes API
NodeVisualization..::..Id Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine knotenweit eindeutige ID zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


IsMovable Property

[image]

DynamicNodes API
NodeVisualization..::..IsMovable Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob dieser Knoten vom Benutzer verschoben werden darf.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsMovable { get; set; }
Visual Basic
Public Property IsMovable As Boolean
    Get
    Set
F#
member IsMovable : bool with get, set

Field Value

true, wenn der Knoten verschoben werden darf, sonst false.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


IsUsingStorage Property

[image]

DynamicNodes API
NodeVisualization..::..IsUsingStorage Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


OuterRectangle Property

[image]

DynamicNodes API
NodeVisualization..::..OuterRectangle Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den grafischen Ausgabebereich des Knotens zurück, einschließlich der Randbereiche in denen die Ports angeordnet sind.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public RectangleF OuterRectangle { get; }
Visual Basic
Public ReadOnly Property OuterRectangle As RectangleF
    Get
F#
member OuterRectangle : RectangleF

Field Value

Der grafische Ausgabebereich mit den Randbereichen, in denen die Ports dargestellt werden.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


OwnerNode Property

[image]

DynamicNodes API
NodeVisualization..::..OwnerNode Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Knoten zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public INode OwnerNode { get; }
Visual Basic
Public ReadOnly Property OwnerNode As INode
    Get
F#
member OwnerNode : INode

Field Value

Der Knoten.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


PaintHandler Property

[image]

DynamicNodes API
NodeVisualization..::..PaintHandler Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Handler für angepasstes Zeichnen des Knotens zurück oder legt ihn fest. Wenn diese Eigenschaft null ist, wird der Knoten im Standard-Style gezeichnet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NodePaintHandler PaintHandler { get; set; }
Visual Basic
Public Property PaintHandler As NodePaintHandler
    Get
    Set
F#
member PaintHandler : NodePaintHandler with get, set

Field Value

Ein Handler für angepasstes Zeichnen des Knotens.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


PosX Property

[image]

DynamicNodes API
NodeVisualization..::..PosX Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die WorkspaceX-Position des Knotens.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float PosX { get; set; }
Visual Basic
Public Property PosX As Single
    Get
    Set
F#
member PosX : float32 with get, set

Field Value

Die WorkspaceX-Position.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


PosY Property

[image]

DynamicNodes API
NodeVisualization..::..PosY Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die WorkspaceY-Position des Knotens.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float PosY { get; set; }
Visual Basic
Public Property PosY As Single
    Get
    Set
F#
member PosY : float32 with get, set

Field Value

Die WorkspaceY-Position.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


Rectangle Property

[image]

DynamicNodes API
NodeVisualization..::..Rectangle Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den grafischen Ausgabebereich des Knotens zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public RectangleF Rectangle { get; }
Visual Basic
Public ReadOnly Property Rectangle As RectangleF
    Get
F#
member Rectangle : RectangleF

Field Value

Der grafische Ausgabebereich.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


ShowName Property

[image]

DynamicNodes API
NodeVisualization..::..ShowName Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob der Name des Knotens angezeigt werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool ShowName { get; set; }
Visual Basic
Public Property ShowName As Boolean
    Get
    Set
F#
member ShowName : bool with get, set

Field Value

true wenn der Name des Knotens angezeigt werden soll; sonst, false.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


UseCaptionWidth Property

[image]

DynamicNodes API
NodeVisualization..::..UseCaptionWidth Property
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob diese NodeVisualization-Instanz die Beschriftungsbreite als Breite für den benutzerdefinierten Bereich verwenden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool UseCaptionWidth { get; set; }
Visual Basic
Public Property UseCaptionWidth As Boolean
    Get
    Set
F#
member UseCaptionWidth : bool with get, set

Field Value

true wenn die Beschriftung als Breite für den benutzerdefinierten Bereich verwendet wird, sonst false.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


NodeVisualization Events

[image] [image]

DynamicNodes API
NodeVisualization Events
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeVisualization type exposes the following members.

Events

 | Name | Description
Public event | CustomAreaPaint | Wird ausgelöst, wenn die benutzerdefinierte Fläche des Knotens gezeichnet wird.
Public event | CustomAreaRepaint | Wird ausgelöst, wenn die benutzerdefinierte Fläche des Knotens neu gezeichnet werden soll.
Public event | NodeRepaint | Wird ausgelöst, wenn der gesamte Knoten neu gezeichnet werden soll.

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


CustomAreaPaint Event

[image]

DynamicNodes API
NodeVisualization..::..CustomAreaPaint Event
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die benutzerdefinierte Fläche des Knotens gezeichnet wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event PaintEventHandler CustomAreaPaint
Visual Basic
Public Event CustomAreaPaint As PaintEventHandler
F#
member CustomAreaPaint : IEvent<PaintEventHandler,
    PaintEventArgs>

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


CustomAreaRepaint Event

[image]

DynamicNodes API
NodeVisualization..::..CustomAreaRepaint Event
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die benutzerdefinierte Fläche des Knotens neu gezeichnet werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler CustomAreaRepaint
Visual Basic
Public Event CustomAreaRepaint As EventHandler
F#
member CustomAreaRepaint : IEvent<EventHandler,
    EventArgs>

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


NodeRepaint Event

[image]

DynamicNodes API
NodeVisualization..::..NodeRepaint Event
NodeVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der gesamte Knoten neu gezeichnet werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler NodeRepaint
Visual Basic
Public Event NodeRepaint As EventHandler
F#
member NodeRepaint : IEvent<EventHandler,
    EventArgs>

See Also

NodeVisualization Class
DynamicNode.Ext.Visual Namespace


Painter Class

[image]

DynamicNodes API
Painter Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardimplementierung der Schnittstelle IPainter

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class Painter : IPainter
Visual Basic
Public Class Painter _
    Implements IPainter
F#
type Painter =
    class
        interface IPainter
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..Painter

See Also

Painter Members
DynamicNode.Ext.Visual Namespace


Painter Members

[image] [image]

DynamicNodes API
Painter Members
Painter Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Painter type exposes the following members.

Constructors

 | Name | Description
Public method | Painter | Initializes a new instance of the Painter class

Methods

 | Name | Description
Public method | CreateBitmap | Erzeugt ein Bitmap in der Größe des Graphen und zeichnet den Graphen in der angegeben Skalierung.
Public method | EndAnimation | Beendet die Animation, löscht den Puffer und zeichnet die Arbeitsfläche neu.
Public method | EndAnimationStep | Schließt einen Animationsschritt ab und gibt das Ergebnis aus.
Public method | OnPaint | Der Handler für das Paint-Ereignis des Editor-Steuerelements.
Public method | Paint | Zeichnet die gesamte Ausgabe neu.
Public method | PaintConnection(IPort, IPort) | Zeichnet eine Verbindung während des Verbindungsaufbaus.
Public method | PaintConnection(IPort, Single, Single) | Zeichnet eine Verbindung während des Verbindungsaufbaus.
Public method | PaintNode | Zeichnet einen Knoten neu.
Public method | PaintNodeCustomArea | Zeichnet den benutzerdefinierten Bereich eines Knotens neu.
Public method | PaintSelectionRectangle | Zeichnet ein Auswahlrechteck.
Public method | PrepareAnimation | Speichert den aktuellen Arbeitsflächeninhalt in einem Puffer und bereitet damit eine Animation auf der aktellen Ansicht vor.
Public method | StartAnimationStep | Beginnt einen Animationsschritt.

Properties

 | Name | Description
Public property | GraphVisualization | Gibt die Visualisierung des Graphen zurück, welcher gezeichnet werden soll.
Public property | Theme | Liest oder schreibt den Visualisierungs-Stil.

Events

 | Name | Description
Public event | PaintOverlay | Tritt am Ende des Zeichenvorgangs auf, nachdem die Knoten und Verbindungen gezeichnet wurden.

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


Painter Constructor

[image]

DynamicNodes API
Painter Constructor
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the Painter class

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Painter()
Visual Basic
Public Sub New
F#
new : unit -> Painter

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


Painter Methods

[image] [image]

DynamicNodes API
Painter Methods
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Painter type exposes the following members.

Methods

 | Name | Description
Public method | CreateBitmap | Erzeugt ein Bitmap in der Größe des Graphen und zeichnet den Graphen in der angegeben Skalierung.
Public method | EndAnimation | Beendet die Animation, löscht den Puffer und zeichnet die Arbeitsfläche neu.
Public method | EndAnimationStep | Schließt einen Animationsschritt ab und gibt das Ergebnis aus.
Public method | OnPaint | Der Handler für das Paint-Ereignis des Editor-Steuerelements.
Public method | Paint | Zeichnet die gesamte Ausgabe neu.
Public method | PaintConnection(IPort, IPort) | Zeichnet eine Verbindung während des Verbindungsaufbaus.
Public method | PaintConnection(IPort, Single, Single) | Zeichnet eine Verbindung während des Verbindungsaufbaus.
Public method | PaintNode | Zeichnet einen Knoten neu.
Public method | PaintNodeCustomArea | Zeichnet den benutzerdefinierten Bereich eines Knotens neu.
Public method | PaintSelectionRectangle | Zeichnet ein Auswahlrechteck.
Public method | PrepareAnimation | Speichert den aktuellen Arbeitsflächeninhalt in einem Puffer und bereitet damit eine Animation auf der aktellen Ansicht vor.
Public method | StartAnimationStep | Beginnt einen Animationsschritt.

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


CreateBitmap Method

[image]

DynamicNodes API
Painter..::..CreateBitmap Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Bitmap in der Größe des Graphen und zeichnet den Graphen in der angegeben Skalierung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Bitmap CreateBitmap(
    float scale,
    float margin,
    bool paintBackground
)
Visual Basic
Public Function CreateBitmap ( _
    scale As Single, _
    margin As Single, _
    paintBackground As Boolean _
) As Bitmap
F#
abstract CreateBitmap :
        scale:float32 *
        margin:float32 *
        paintBackground:bool -> Bitmap
override CreateBitmap :
        scale:float32 *
        margin:float32 *
        paintBackground:bool -> Bitmap

Parameters

scale
Type: System..::..Single
Die Skalierung des Graphen. Ein Wert von 1.0 steht für 100% Skalierung.
margin
Type: System..::..Single
Gibt die Breite des umgebenden Rahmens vor der Skalierung an.
paintBackground
Type: System..::..Boolean
Ein Wert der angibt, ob der Hintergrund der Arbeitsfläche gezeichnet werden soll.

Return Value

Ein Bitmap-Objekt mit 32Bit ARGB Farbtiefe.

Implements

IPainter..::..CreateBitmap(Single, Single, Boolean)

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


EndAnimation Method

[image]

DynamicNodes API
Painter..::..EndAnimation Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beendet die Animation, löscht den Puffer und zeichnet die Arbeitsfläche neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void EndAnimation()
Visual Basic
Public Sub EndAnimation
F#
abstract EndAnimation : unit -> unit
override EndAnimation : unit -> unit

Implements

IPainter..::..EndAnimation()()()()

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


EndAnimationStep Method

[image]

DynamicNodes API
Painter..::..EndAnimationStep Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schließt einen Animationsschritt ab und gibt das Ergebnis aus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void EndAnimationStep()
Visual Basic
Public Sub EndAnimationStep
F#
abstract EndAnimationStep : unit -> unit
override EndAnimationStep : unit -> unit

Implements

IPainter..::..EndAnimationStep()()()()

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


OnPaint Method

[image]

DynamicNodes API
Painter..::..OnPaint Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Handler für das Paint-Ereignis des Editor-Steuerelements.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnPaint(
    Object sender,
    PaintEventArgs e
)
Visual Basic
Public Sub OnPaint ( _
    sender As Object, _
    e As PaintEventArgs _
)
F#
abstract OnPaint :
        sender:Object *
        e:PaintEventArgs -> unit
override OnPaint :
        sender:Object *
        e:PaintEventArgs -> unit

Parameters

sender
Type: System..::..Object
Der Auslöser des Ereignisses.
e
Type: System.Windows.Forms..::..PaintEventArgs
Die Ereignis-Parameter.

Implements

IPainter..::..OnPaint(Object, PaintEventArgs)

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


Paint Method

[image]

DynamicNodes API
Painter..::..Paint Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet die gesamte Ausgabe neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void Paint(
    bool imidiate
)
Visual Basic
Public Sub Paint ( _
    imidiate As Boolean _
)
F#
abstract Paint :
        imidiate:bool -> unit
override Paint :
        imidiate:bool -> unit

Parameters

imidiate
Type: System..::..Boolean
Gibt an, ob das Zeichnen sofort geschehen soll.

Implements

IPainter..::..Paint(Boolean)

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


PaintConnection Method

[image] [image]

DynamicNodes API
Painter..::..PaintConnection Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | PaintConnection(IPort, IPort) | Zeichnet eine Verbindung während des Verbindungsaufbaus.
Public method | PaintConnection(IPort, Single, Single) | Zeichnet eine Verbindung während des Verbindungsaufbaus.

See Also

Painter Class
Painter Members
DynamicNode.Ext.Visual Namespace


PaintConnection Method (IPort, IPort)

[image]

DynamicNodes API
Painter..::..PaintConnection Method (IPort, IPort)
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet eine Verbindung während des Verbindungsaufbaus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void PaintConnection(
    IPort p1,
    IPort p2
)
Visual Basic
Public Sub PaintConnection ( _
    p1 As IPort, _
    p2 As IPort _
)
F#
abstract PaintConnection :
        p1:IPort *
        p2:IPort -> unit
override PaintConnection :
        p1:IPort *
        p2:IPort -> unit

Parameters

p1
Type: DynamicNode.Core..::..IPort
Der Port an dem die Verbindung beginnt.
p2
Type: DynamicNode.Core..::..IPort
Die Port an dem die Verbindung endet.

Implements

IPainter..::..PaintConnection(IPort, IPort)

See Also

Painter Class
PaintConnection Overload
DynamicNode.Ext.Visual Namespace


PaintConnection Method (IPort, Single, Single)

[image]

DynamicNodes API
Painter..::..PaintConnection Method (IPort, Single, Single)
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet eine Verbindung während des Verbindungsaufbaus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void PaintConnection(
    IPort p,
    float x,
    float y
)
Visual Basic
Public Sub PaintConnection ( _
    p As IPort, _
    x As Single, _
    y As Single _
)
F#
abstract PaintConnection :
        p:IPort *
        x:float32 *
        y:float32 -> unit
override PaintConnection :
        p:IPort *
        x:float32 *
        y:float32 -> unit

Parameters

p
Type: DynamicNode.Core..::..IPort
Der Port an dem die Verbindung beginnt.
x
Type: System..::..Single
Die WorkspaceX-Cursor-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Cursor-Koordinate.

Implements

IPainter..::..PaintConnection(IPort, Single, Single)

See Also

Painter Class
PaintConnection Overload
DynamicNode.Ext.Visual Namespace


PaintNode Method

[image]

DynamicNodes API
Painter..::..PaintNode Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet einen Knoten neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void PaintNode(
    NodeVisualization nVis
)
Visual Basic
Public Sub PaintNode ( _
    nVis As NodeVisualization _
)
F#
abstract PaintNode :
        nVis:NodeVisualization -> unit
override PaintNode :
        nVis:NodeVisualization -> unit

Parameters

nVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.

Implements

IPainter..::..PaintNode(NodeVisualization)

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


PaintNodeCustomArea Method

[image]

DynamicNodes API
Painter..::..PaintNodeCustomArea Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet den benutzerdefinierten Bereich eines Knotens neu.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void PaintNodeCustomArea(
    NodeVisualization nVis
)
Visual Basic
Public Sub PaintNodeCustomArea ( _
    nVis As NodeVisualization _
)
F#
abstract PaintNodeCustomArea :
        nVis:NodeVisualization -> unit
override PaintNodeCustomArea :
        nVis:NodeVisualization -> unit

Parameters

nVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.

Implements

IPainter..::..PaintNodeCustomArea(NodeVisualization)

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


PaintSelectionRectangle Method

[image]

DynamicNodes API
Painter..::..PaintSelectionRectangle Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet ein Auswahlrechteck.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void PaintSelectionRectangle(
    RectangleF rect
)
Visual Basic
Public Sub PaintSelectionRectangle ( _
    rect As RectangleF _
)
F#
abstract PaintSelectionRectangle :
        rect:RectangleF -> unit
override PaintSelectionRectangle :
        rect:RectangleF -> unit

Parameters

rect
Type: System.Drawing..::..RectangleF
Die Lage des Rechtecks

Implements

IPainter..::..PaintSelectionRectangle(RectangleF)

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


PrepareAnimation Method

[image]

DynamicNodes API
Painter..::..PrepareAnimation Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Speichert den aktuellen Arbeitsflächeninhalt in einem Puffer und bereitet damit eine Animation auf der aktellen Ansicht vor.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void PrepareAnimation()
Visual Basic
Public Sub PrepareAnimation
F#
abstract PrepareAnimation : unit -> unit
override PrepareAnimation : unit -> unit

Implements

IPainter..::..PrepareAnimation()()()()

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


StartAnimationStep Method

[image]

DynamicNodes API
Painter..::..StartAnimationStep Method
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beginnt einen Animationsschritt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void StartAnimationStep()
Visual Basic
Public Sub StartAnimationStep
F#
abstract StartAnimationStep : unit -> unit
override StartAnimationStep : unit -> unit

Implements

IPainter..::..StartAnimationStep()()()()

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


Painter Properties

[image] [image]

DynamicNodes API
Painter Properties
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Painter type exposes the following members.

Properties

 | Name | Description
Public property | GraphVisualization | Gibt die Visualisierung des Graphen zurück, welcher gezeichnet werden soll.
Public property | Theme | Liest oder schreibt den Visualisierungs-Stil.

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


GraphVisualization Property

[image]

DynamicNodes API
Painter..::..GraphVisualization Property
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Visualisierung des Graphen zurück, welcher gezeichnet werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public GraphVisualization GraphVisualization { get; set; }
Visual Basic
Public Property GraphVisualization As GraphVisualization
    Get
    Set
F#
abstract GraphVisualization : GraphVisualization with get, set
override GraphVisualization : GraphVisualization with get, set

Field Value

Die Graphenvisualisierung.

Implements

IPainter..::..GraphVisualization

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


Theme Property

[image]

DynamicNodes API
Painter..::..Theme Property
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Visualisierungs-Stil.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public ITheme Theme { get; set; }
Visual Basic
Public Property Theme As ITheme
    Get
    Set
F#
abstract Theme : ITheme with get, set
override Theme : ITheme with get, set

Field Value

Der Visualisierungs-Stil (Theme).

Implements

IPainter..::..Theme

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


Painter Events

[image] [image]

DynamicNodes API
Painter Events
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Painter type exposes the following members.

Events

 | Name | Description
Public event | PaintOverlay | Tritt am Ende des Zeichenvorgangs auf, nachdem die Knoten und Verbindungen gezeichnet wurden.

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


PaintOverlay Event

[image]

DynamicNodes API
Painter..::..PaintOverlay Event
Painter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt am Ende des Zeichenvorgangs auf, nachdem die Knoten und Verbindungen gezeichnet wurden.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler<GraphPaintEventArgs> PaintOverlay
Visual Basic
Public Event PaintOverlay As EventHandler(Of GraphPaintEventArgs)
F#
abstract PaintOverlay : IEvent<EventHandler<GraphPaintEventArgs>,
    GraphPaintEventArgs>
override PaintOverlay : IEvent<EventHandler<GraphPaintEventArgs>,
    GraphPaintEventArgs>

Implements

IPainter..::..PaintOverlay

See Also

Painter Class
DynamicNode.Ext.Visual Namespace


PaintSettings Class

[image]

DynamicNodes API
PaintSettings Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sammlung mit Parametern für die grafische Ausgabe.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class PaintSettings : IStorable
Visual Basic
Public Class PaintSettings _
    Implements IStorable
F#
type PaintSettings =
    class
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..PaintSettings

See Also

PaintSettings Members
DynamicNode.Ext.Visual Namespace


PaintSettings Members

[image] [image]

DynamicNodes API
PaintSettings Members
PaintSettings Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PaintSettings type exposes the following members.

Constructors

 | Name | Description
Public method | PaintSettings | Initialisiert eine neue Instanz der Klasse PaintSettings.

Methods

 | Name | Description
Public method | GetColor | Gibt eine Farbe zurück.
Public method | GetDimension | Gibt eine Größe zurück.
Public method | GetFont | Gibt einen Font zurück.
Public method | LoadFromFile | Lädt die Darstellungseinstellungen aus einer XML-Datei.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Public method | SaveToFile | Speichert die Darstellungseinstellungen in eine XML-Datei.
Public method | SetColor | Setzt eine Farbe.
Public method | SetDimension | Setzt eine Größe.
Public method | SetFont | Setzt einen Font.

Properties

 | Name | Description
Public property | ConnectionStyle | Gibt den Stil von Verbindungslininen zurück oder legt ihn fest.
Public property | NodeShaddowStyle | Gibt den Stil des Knotenschattens zurück oder legt ihn fest.
Public property | PortsOnTop | Gibt einen Wert zurück, oder legt ihn fest, der angibt, ob Anschlüsse vor oder hinter den Knoten gezeichnet werden sollen.
Public property | PortStyle | Gibt den Stil von Anschlüssen zurück oder legt ihn fest.
Public property | WorkspaceBackgroundStyle | Gibt den Stil des Arbeitsflächenhintergrundes zurück oder legt ihn fest.

Events

 | Name | Description
Public event | Changed | Wird ausgelöst, wenn eine der Eigenschaften geändert wurde.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


PaintSettings Constructor

[image]

DynamicNodes API
PaintSettings Constructor
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse PaintSettings.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PaintSettings()
Visual Basic
Public Sub New
F#
new : unit -> PaintSettings

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


PaintSettings Methods

[image] [image]

DynamicNodes API
PaintSettings Methods
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PaintSettings type exposes the following members.

Methods

 | Name | Description
Public method | GetColor | Gibt eine Farbe zurück.
Public method | GetDimension | Gibt eine Größe zurück.
Public method | GetFont | Gibt einen Font zurück.
Public method | LoadFromFile | Lädt die Darstellungseinstellungen aus einer XML-Datei.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Public method | SaveToFile | Speichert die Darstellungseinstellungen in eine XML-Datei.
Public method | SetColor | Setzt eine Farbe.
Public method | SetDimension | Setzt eine Größe.
Public method | SetFont | Setzt einen Font.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


GetColor Method

[image]

DynamicNodes API
PaintSettings..::..GetColor Method
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Farbe zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Color GetColor(
    ThemeColor color
)
Visual Basic
Public Function GetColor ( _
    color As ThemeColor _
) As Color
F#
member GetColor :
        color:ThemeColor -> Color

Parameters

color
Type: DynamicNode.Ext.Visual..::..ThemeColor
Die Kennzeichnung der Farbe.

Return Value

Die Farbe

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


GetDimension Method

[image]

DynamicNodes API
PaintSettings..::..GetDimension Method
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Größe zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float GetDimension(
    ThemeDimension dimension
)
Visual Basic
Public Function GetDimension ( _
    dimension As ThemeDimension _
) As Single
F#
member GetDimension :
        dimension:ThemeDimension -> float32

Parameters

dimension
Type: DynamicNode.Ext.Visual..::..ThemeDimension
Die Kennzeichnung der Größe.

Return Value

Die Größe.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


GetFont Method

[image]

DynamicNodes API
PaintSettings..::..GetFont Method
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Font zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Font GetFont(
    ThemeFont font
)
Visual Basic
Public Function GetFont ( _
    font As ThemeFont _
) As Font
F#
member GetFont :
        font:ThemeFont -> Font

Parameters

font
Type: DynamicNode.Ext.Visual..::..ThemeFont
Die Kennzeichnung des Fonts.

Return Value

Der Font.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


LoadFromFile Method

[image]

DynamicNodes API
PaintSettings..::..LoadFromFile Method
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Lädt die Darstellungseinstellungen aus einer XML-Datei.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void LoadFromFile(
    string file
)
Visual Basic
Public Sub LoadFromFile ( _
    file As String _
)
F#
member LoadFromFile :
        file:string -> unit

Parameters

file
Type: System..::..String
Der Dateiname der Quelldatei.

Remarks

Eine geeignete Dateiendung ist z.B. *.dynstyle.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


OnRestore Method

[image]

DynamicNodes API
PaintSettings..::..OnRestore Method
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


OnStore Method

[image]

DynamicNodes API
PaintSettings..::..OnStore Method
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


SaveToFile Method

[image]

DynamicNodes API
PaintSettings..::..SaveToFile Method
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Speichert die Darstellungseinstellungen in eine XML-Datei.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void SaveToFile(
    string file
)
Visual Basic
Public Sub SaveToFile ( _
    file As String _
)
F#
member SaveToFile :
        file:string -> unit

Parameters

file
Type: System..::..String
Der Dateiname der Zieldatei.

Remarks

Eine geeignete Dateiendung ist z.B. *.dynstyle.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


SetColor Method

[image]

DynamicNodes API
PaintSettings..::..SetColor Method
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Setzt eine Farbe.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void SetColor(
    ThemeColor color,
    Color value
)
Visual Basic
Public Sub SetColor ( _
    color As ThemeColor, _
    value As Color _
)
F#
member SetColor :
        color:ThemeColor *
        value:Color -> unit

Parameters

color
Type: DynamicNode.Ext.Visual..::..ThemeColor
Die Kennzeichnung der Farbe.
value
Type: System.Drawing..::..Color
Die neue Farbe.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


SetDimension Method

[image]

DynamicNodes API
PaintSettings..::..SetDimension Method
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Setzt eine Größe.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void SetDimension(
    ThemeDimension dimension,
    float value
)
Visual Basic
Public Sub SetDimension ( _
    dimension As ThemeDimension, _
    value As Single _
)
F#
member SetDimension :
        dimension:ThemeDimension *
        value:float32 -> unit

Parameters

dimension
Type: DynamicNode.Ext.Visual..::..ThemeDimension
Die Kennzeichnung der Größe.
value
Type: System..::..Single
Die Größe.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


SetFont Method

[image]

DynamicNodes API
PaintSettings..::..SetFont Method
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Setzt einen Font.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void SetFont(
    ThemeFont font,
    Font value
)
Visual Basic
Public Sub SetFont ( _
    font As ThemeFont, _
    value As Font _
)
F#
member SetFont :
        font:ThemeFont *
        value:Font -> unit

Parameters

font
Type: DynamicNode.Ext.Visual..::..ThemeFont
Die Kennzeichnung des Fonts.
value
Type: System.Drawing..::..Font
Der neue Font.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


PaintSettings Properties

[image] [image]

DynamicNodes API
PaintSettings Properties
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PaintSettings type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionStyle | Gibt den Stil von Verbindungslininen zurück oder legt ihn fest.
Public property | NodeShaddowStyle | Gibt den Stil des Knotenschattens zurück oder legt ihn fest.
Public property | PortsOnTop | Gibt einen Wert zurück, oder legt ihn fest, der angibt, ob Anschlüsse vor oder hinter den Knoten gezeichnet werden sollen.
Public property | PortStyle | Gibt den Stil von Anschlüssen zurück oder legt ihn fest.
Public property | WorkspaceBackgroundStyle | Gibt den Stil des Arbeitsflächenhintergrundes zurück oder legt ihn fest.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


ConnectionStyle Property

[image]

DynamicNodes API
PaintSettings..::..ConnectionStyle Property
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Stil von Verbindungslininen zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public ConnectionStyle ConnectionStyle { get; set; }
Visual Basic
Public Property ConnectionStyle As ConnectionStyle
    Get
    Set
F#
member ConnectionStyle : ConnectionStyle with get, set

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


NodeShaddowStyle Property

[image]

DynamicNodes API
PaintSettings..::..NodeShaddowStyle Property
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Stil des Knotenschattens zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NodeShaddowStyle NodeShaddowStyle { get; set; }
Visual Basic
Public Property NodeShaddowStyle As NodeShaddowStyle
    Get
    Set
F#
member NodeShaddowStyle : NodeShaddowStyle with get, set

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


PortsOnTop Property

[image]

DynamicNodes API
PaintSettings..::..PortsOnTop Property
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, oder legt ihn fest, der angibt, ob Anschlüsse vor oder hinter den Knoten gezeichnet werden sollen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool PortsOnTop { get; set; }
Visual Basic
Public Property PortsOnTop As Boolean
    Get
    Set
F#
member PortsOnTop : bool with get, set

Field Value

true wenn Anschlüsse vor den Knoten gezeichnet werden sollen, andernfalls false.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


PortStyle Property

[image]

DynamicNodes API
PaintSettings..::..PortStyle Property
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Stil von Anschlüssen zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PortStyle PortStyle { get; set; }
Visual Basic
Public Property PortStyle As PortStyle
    Get
    Set
F#
member PortStyle : PortStyle with get, set

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


WorkspaceBackgroundStyle Property

[image]

DynamicNodes API
PaintSettings..::..WorkspaceBackgroundStyle Property
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Stil des Arbeitsflächenhintergrundes zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public WorkspaceBackgroundStyle WorkspaceBackgroundStyle { get; set; }
Visual Basic
Public Property WorkspaceBackgroundStyle As WorkspaceBackgroundStyle
    Get
    Set
F#
member WorkspaceBackgroundStyle : WorkspaceBackgroundStyle with get, set

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


PaintSettings Events

[image] [image]

DynamicNodes API
PaintSettings Events
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PaintSettings type exposes the following members.

Events

 | Name | Description
Public event | Changed | Wird ausgelöst, wenn eine der Eigenschaften geändert wurde.

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


Changed Event

[image]

DynamicNodes API
PaintSettings..::..Changed Event
PaintSettings Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn eine der Eigenschaften geändert wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler Changed
Visual Basic
Public Event Changed As EventHandler
F#
member Changed : IEvent<EventHandler,
    EventArgs>

See Also

PaintSettings Class
DynamicNode.Ext.Visual Namespace


Pin Class

[image]

DynamicNodes API
Pin Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine optische Umlenkung für eine Verbindung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class Pin : IXmlSerializable
Visual Basic
Public Class Pin _
    Implements IXmlSerializable
F#
type Pin =
    class
        interface IXmlSerializable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..Pin

See Also

Pin Members
DynamicNode.Ext.Visual Namespace


Pin Members

[image] [image]

DynamicNodes API
Pin Members
Pin Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Pin type exposes the following members.

Constructors

 | Name | Description
Public method | Pin(PortVisualization) | Initialisiert eine Pin-Instanz.
Public method | Pin(PortVisualization, Single, Single) | Initialisiert eine Pin-Instanz.
Public method | Pin(PortVisualization, Single, Single, PinPositionMode) | Initialisiert eine Pin-Instanz.

Methods

 | Name | Description
Public method | GetPos | Gibt die Position des Pins zurück.
Public method | GetSchema | Diese Eigenschaft ist reserviert, wenden Sie stattdessen das XmlSchemaProviderAttribute auf die Klasse an.
Public method | IsMouseInside | Prüft, ob die übergebenen Koordinaten innerhalb der grafischen Darstellung des Pins liegen.
Public method | ReadXml | Generiert ein Objekt aus seiner XML-Darstellung.
Public method | WriteXml | Konvertiert ein Objekt in seine XML-Darstellung.

Properties

 | Name | Description
Public property | InPortVisualization | Gibt die Visualisierung für den Eingangsport zurück.
Public property | OutPortVisualization | Gibt die Visualisierung für den Ausgangsport zurück.
Public property | PositionMode | Liest oder schreibt den Positionierungs-Modus.
Public property | PosX | Liest oder schreibt die WorkspaceX-Position des Pins.
Public property | PosY | Liest oder schreibt die WorkspaceY-Position des Pins.
Public property | Radius | Gibt den Radius des Pins zurück.
Public property | RelPosX | Gibt die relative WorkspaceX-Position des Pins zurück.
Public property | RelPosY | Gibt die relative WorkspaceY-Position des Pins zurück.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


Pin Constructor

[image] [image]

DynamicNodes API
Pin Constructor
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Pin(PortVisualization) | Initialisiert eine Pin-Instanz.
Public method | Pin(PortVisualization, Single, Single) | Initialisiert eine Pin-Instanz.
Public method | Pin(PortVisualization, Single, Single, PinPositionMode) | Initialisiert eine Pin-Instanz.

See Also

Pin Class
Pin Members
DynamicNode.Ext.Visual Namespace


Pin Constructor (PortVisualization)

[image]

DynamicNodes API
Pin Constructor (PortVisualization)
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Pin-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Pin(
    PortVisualization iPVis
)
Visual Basic
Public Sub New ( _
    iPVis As PortVisualization _
)
F#
new :
        iPVis:PortVisualization -> Pin

Parameters

iPVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Visualisierung des Eingangs, wessen Verbindung umgelenkt wird.

See Also

Pin Class
Pin Overload
DynamicNode.Ext.Visual Namespace


Pin Constructor (PortVisualization, Single, Single)

[image]

DynamicNodes API
Pin Constructor (PortVisualization, Single, Single)
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Pin-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Pin(
    PortVisualization iPVis,
    float posX,
    float posY
)
Visual Basic
Public Sub New ( _
    iPVis As PortVisualization, _
    posX As Single, _
    posY As Single _
)
F#
new :
        iPVis:PortVisualization *
        posX:float32 *
        posY:float32 -> Pin

Parameters

iPVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Visualisierung des Eingangs, wessen Verbindung umgelenkt wird.
posX
Type: System..::..Single
Die WorkspaceX-Position.
posY
Type: System..::..Single
Die WorkspaceY-Position.

See Also

Pin Class
Pin Overload
DynamicNode.Ext.Visual Namespace


Pin Constructor (PortVisualization, Single, Single, PinPositionMode)

[image]

DynamicNodes API
Pin Constructor (PortVisualization, Single, Single, PinPositionMode)
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Pin-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Pin(
    PortVisualization iPVis,
    float posX,
    float posY,
    PinPositionMode posMode
)
Visual Basic
Public Sub New ( _
    iPVis As PortVisualization, _
    posX As Single, _
    posY As Single, _
    posMode As PinPositionMode _
)
F#
new :
        iPVis:PortVisualization *
        posX:float32 *
        posY:float32 *
        posMode:PinPositionMode -> Pin

Parameters

iPVis
Type: DynamicNode.Ext.Visual..::..PortVisualization
Die Visualisierung des Eingangs-Ports, dessen Verbindung umgelenkt wird.
posX
Type: System..::..Single
Die WorkspaceX-Position.
posY
Type: System..::..Single
Die WorkspaceY-Position.
posMode
Type: DynamicNode.Ext.Visual..::..PinPositionMode
Der Positionierungs-Modus.

See Also

Pin Class
Pin Overload
DynamicNode.Ext.Visual Namespace


Pin Methods

[image] [image]

DynamicNodes API
Pin Methods
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Pin type exposes the following members.

Methods

 | Name | Description
Public method | GetPos | Gibt die Position des Pins zurück.
Public method | GetSchema | Diese Eigenschaft ist reserviert, wenden Sie stattdessen das XmlSchemaProviderAttribute auf die Klasse an.
Public method | IsMouseInside | Prüft, ob die übergebenen Koordinaten innerhalb der grafischen Darstellung des Pins liegen.
Public method | ReadXml | Generiert ein Objekt aus seiner XML-Darstellung.
Public method | WriteXml | Konvertiert ein Objekt in seine XML-Darstellung.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


GetPos Method

[image]

DynamicNodes API
Pin..::..GetPos Method
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Position des Pins zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PointF GetPos()
Visual Basic
Public Function GetPos As PointF
F#
member GetPos : unit -> PointF

Return Value

Die Position des Pins.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


GetSchema Method

[image]

DynamicNodes API
Pin..::..GetSchema Method
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Diese Eigenschaft ist reserviert, wenden Sie stattdessen das XmlSchemaProviderAttribute auf die Klasse an.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema
F#
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Ein XmlSchema zur Beschreibung der XML-Darstellung des Objekts, das von der WriteXml(XmlWriter)-Methode erstellt und von der ReadXml(XmlReader)-Methode verwendet wird.

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


IsMouseInside Method

[image]

DynamicNodes API
Pin..::..IsMouseInside Method
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob die übergebenen Koordinaten innerhalb der grafischen Darstellung des Pins liegen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsMouseInside(
    float x,
    float y
)
Visual Basic
Public Function IsMouseInside ( _
    x As Single, _
    y As Single _
) As Boolean
F#
member IsMouseInside :
        x:float32 *
        y:float32 -> bool

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.

Return Value

true, wenn die Koordinaten innerhalb liegen, sonst false.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


ReadXml Method

[image]

DynamicNodes API
Pin..::..ReadXml Method
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Generiert ein Objekt aus seiner XML-Darstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml ( _
    reader As XmlReader _
)
F#
abstract ReadXml :
        reader:XmlReader -> unit
override ReadXml :
        reader:XmlReader -> unit

Parameters

reader
Type: System.Xml..::..XmlReader
Der XmlReader-Stream, aus dem das Objekt deserialisiert wird.

Implements

IXmlSerializable..::..ReadXml(XmlReader)

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


WriteXml Method

[image]

DynamicNodes API
Pin..::..WriteXml Method
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Konvertiert ein Objekt in seine XML-Darstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml ( _
    writer As XmlWriter _
)
F#
abstract WriteXml :
        writer:XmlWriter -> unit
override WriteXml :
        writer:XmlWriter -> unit

Parameters

writer
Type: System.Xml..::..XmlWriter
Der XmlWriter-Stream, in den das Objekt serialisiert wird.

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


Pin Properties

[image] [image]

DynamicNodes API
Pin Properties
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Pin type exposes the following members.

Properties

 | Name | Description
Public property | InPortVisualization | Gibt die Visualisierung für den Eingangsport zurück.
Public property | OutPortVisualization | Gibt die Visualisierung für den Ausgangsport zurück.
Public property | PositionMode | Liest oder schreibt den Positionierungs-Modus.
Public property | PosX | Liest oder schreibt die WorkspaceX-Position des Pins.
Public property | PosY | Liest oder schreibt die WorkspaceY-Position des Pins.
Public property | Radius | Gibt den Radius des Pins zurück.
Public property | RelPosX | Gibt die relative WorkspaceX-Position des Pins zurück.
Public property | RelPosY | Gibt die relative WorkspaceY-Position des Pins zurück.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


InPortVisualization Property

[image]

DynamicNodes API
Pin..::..InPortVisualization Property
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Visualisierung für den Eingangsport zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PortVisualization InPortVisualization { get; }
Visual Basic
Public ReadOnly Property InPortVisualization As PortVisualization
    Get
F#
member InPortVisualization : PortVisualization

Field Value

Die Visualisierung für den Eingangs-Port.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


OutPortVisualization Property

[image]

DynamicNodes API
Pin..::..OutPortVisualization Property
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Visualisierung für den Ausgangsport zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PortVisualization OutPortVisualization { get; }
Visual Basic
Public ReadOnly Property OutPortVisualization As PortVisualization
    Get
F#
member OutPortVisualization : PortVisualization

Field Value

Die Visualisierung für den Ausgangs-Port.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


PositionMode Property

[image]

DynamicNodes API
Pin..::..PositionMode Property
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Positionierungs-Modus.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PinPositionMode PositionMode { get; set; }
Visual Basic
Public Property PositionMode As PinPositionMode
    Get
    Set
F#
member PositionMode : PinPositionMode with get, set

Field Value

Der Positionierungs-Modus.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


PosX Property

[image]

DynamicNodes API
Pin..::..PosX Property
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die WorkspaceX-Position des Pins.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float PosX { get; set; }
Visual Basic
Public Property PosX As Single
    Get
    Set
F#
member PosX : float32 with get, set

Field Value

Die WorkspaceX-Position.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


PosY Property

[image]

DynamicNodes API
Pin..::..PosY Property
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die WorkspaceY-Position des Pins.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float PosY { get; set; }
Visual Basic
Public Property PosY As Single
    Get
    Set
F#
member PosY : float32 with get, set

Field Value

Die WorkspaceY-Position.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


Radius Property

[image]

DynamicNodes API
Pin..::..Radius Property
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Radius des Pins zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float Radius { get; }
Visual Basic
Public ReadOnly Property Radius As Single
    Get
F#
member Radius : float32

Field Value

Der Radius des Pins.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


RelPosX Property

[image]

DynamicNodes API
Pin..::..RelPosX Property
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die relative WorkspaceX-Position des Pins zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float RelPosX { get; set; }
Visual Basic
Public Property RelPosX As Single
    Get
    Set
F#
member RelPosX : float32 with get, set

Field Value

Die relative WorkspaceX-Position.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


RelPosY Property

[image]

DynamicNodes API
Pin..::..RelPosY Property
Pin Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die relative WorkspaceY-Position des Pins zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float RelPosY { get; set; }
Visual Basic
Public Property RelPosY As Single
    Get
    Set
F#
member RelPosY : float32 with get, set

Field Value

Die relative WorkspaceY-Position.

See Also

Pin Class
DynamicNode.Ext.Visual Namespace


PinPositionMode Enumeration

[image]

DynamicNodes API
PinPositionMode Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Positions-Modi für einen Pin

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public enum PinPositionMode
Visual Basic
Public Enumeration PinPositionMode
F#
type PinPositionMode

Members

Member name | Description
ABSOLUTE |
INPORT |
OUTPORT |

See Also

DynamicNode.Ext.Visual Namespace


PortOrientation Enumeration

[image]

DynamicNodes API
PortOrientation Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die grafische Ausrichtung eines Ports relativ zum Knoten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public enum PortOrientation
Visual Basic
Public Enumeration PortOrientation
F#
type PortOrientation

Members

Member name | Description
TOP |
BOTTOM |
LEFT |
RIGHT |

Remarks

Diese Werte werden von PortVisualization interpretiert, um die Position der Ports automatisch festzulegen.

See Also

DynamicNode.Ext.Visual Namespace


PortStyle Enumeration

[image]

DynamicNodes API
PortStyle Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die verschiedenen Stile für die Darstellung von Anschlüssen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public enum PortStyle
Visual Basic
Public Enumeration PortStyle
F#
type PortStyle

Members

Member name | Description
Square |
Disk |
Rounded |

See Also

DynamicNode.Ext.Visual Namespace


PortVisualization Class

[image]

DynamicNodes API
PortVisualization Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die grafischen Eigenschaften eines Ports.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class PortVisualization : IExtension<IPort>,
    IStorable, IXmlSerializable
Visual Basic
Public Class PortVisualization _
    Implements IExtension(Of IPort), IStorable,  _
    IXmlSerializable
F#
type PortVisualization =
    class
        interface IExtension<IPort>
        interface IStorable
        interface IXmlSerializable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..PortVisualization

See Also

PortVisualization Members
DynamicNode.Ext.Visual Namespace


PortVisualization Members

[image] [image]

DynamicNodes API
PortVisualization Members
PortVisualization Class Constructors Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PortVisualization type exposes the following members.

Constructors

 | Name | Description
Public method | PortVisualization()()()() | Initialisiert eine PortVisualization-Instanz.
Public method | PortVisualization(PortOrientation, Int32) | Initialisiert eine PortVisualization-Instanz.

Methods

 | Name | Description
Public method | AddPin | Fügt einen Pin auf der Augangs-Port-Seite in die Verbindunglinie ein.
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Port angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Port entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | GetConnectedOutPortVisualization | Gibt die Port-Visualisierung des verbundenen Ausgangsports zurück, wenn der diese Visualisierung zu einem Eingangsport gehört und eine Verbindung existiert.
 | GetFrom | Gibt für einen Port die Visualisierung zurück.
Public method | GetPin | Gibt einen Pin zurück.
Public method | GetPinByMouse | Gibt eine Pin anhand von Cursor-Koordinaten zurück, oder null, wenn sich kein Pin unter dem Cursor befindet.
Public method | GetSchema | Diese Eigenschaft ist reserviert, wenden Sie stattdessen das XmlSchemaProviderAttribute auf die Klasse an.
Public method | IsMouseInside | Prüft, ob die lokalen Koordinaten innerhalb des Ports liegen.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Public method | ReadXml | Generiert ein Objekt aus seiner XML-Darstellung.
Public method | RemoveAllPins | Entfernt alle Pins aus der Verbindunglinie.
Public method | RemovePin | Entfernt einen Pin aus der Verbindunglinie.
Public method | WriteXml | Konvertiert ein Objekt in seine XML-Darstellung.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID der Port-Visualisierung. Da diese Erweiterung nur ein mal je Port angefügt werden kann, ist diese ID immer die gleiche.

Properties

 | Name | Description
Public property | Id | Gibt eine portweit eindeutige ID zurück.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | NodeVisualization | Gibt, wenn vorhanden, die Knoten-Visualisierung des Knotens zurück, zu dem der Port dieser Visualisierung gehört.
Public property | Orientation | Gibt die Ausrichtung des Anschlusses zurück, oder legt sie fest.
Public property | OwnerPort | Gibt den Port zurück.
Public property | PinCount | Gibt die Anzahl der Pins zurück.
Public property | Pins | Eine schreibgeschützte Liste mit allen Pins.
Public property | PosX | Gibt die absolute WorkspaceX-Position zurück.
Public property | PosY | Gibt die absolute WorkspaceY-Position zurück.
Public property | Radius | Gibt die halbe Seitenlänge des Darstellungsbereichs dieses Ports zurück..
Public property | Rectangle | Gibt ein Rechteckzurück, welches den Darstellungsbereich des Ports einschließt.
Public property | RelPosX | Liest oder schreibt die relative WorkspaceX-Position des Ports zum Knoten.
Public property | RelPosY | Liest oder schreibt die relative WorkspaceY-Position des Ports zum Knoten.
Public property | SortIndex | Liest oder schreibt den Sortier-Index, mit dessen Hilfe die Reihenfolge der Anschlüsse an den vier Seiten bestimmt wird.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


PortVisualization Constructor

[image] [image]

DynamicNodes API
PortVisualization Constructor
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | PortVisualization()()()() | Initialisiert eine PortVisualization-Instanz.
Public method | PortVisualization(PortOrientation, Int32) | Initialisiert eine PortVisualization-Instanz.

See Also

PortVisualization Class
PortVisualization Members
DynamicNode.Ext.Visual Namespace


PortVisualization Constructor

[image]

DynamicNodes API
PortVisualization Constructor
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine PortVisualization-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PortVisualization()
Visual Basic
Public Sub New
F#
new : unit -> PortVisualization

See Also

PortVisualization Class
PortVisualization Overload
DynamicNode.Ext.Visual Namespace


PortVisualization Constructor (PortOrientation, Int32)

[image]

DynamicNodes API
PortVisualization Constructor (PortOrientation, Int32)
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine PortVisualization-Instanz.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PortVisualization(
    PortOrientation orientation,
    int sortIndex
)
Visual Basic
Public Sub New ( _
    orientation As PortOrientation, _
    sortIndex As Integer _
)
F#
new :
        orientation:PortOrientation *
        sortIndex:int -> PortVisualization

Parameters

orientation
Type: DynamicNode.Ext.Visual..::..PortOrientation
Die Ausrichtung des visualisierten Anschlusses.
sortIndex
Type: System..::..Int32
Der Sortier-Index des Anschlusses für die Reihenfolge der Anordnung an den Knoten-Kanten.

See Also

PortVisualization Class
PortVisualization Overload
DynamicNode.Ext.Visual Namespace


PortVisualization Fields

[image] [image]

DynamicNodes API
PortVisualization Fields
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PortVisualization type exposes the following members.

Fields

Name | Description
EXT_ID | Die Erweiterungs-ID der Port-Visualisierung. Da diese Erweiterung nur ein mal je Port angefügt werden kann, ist diese ID immer die gleiche.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


EXT_ID Field

[image]

DynamicNodes API
PortVisualization..::..EXT_ID Field
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Erweiterungs-ID der Port-Visualisierung.
Da diese Erweiterung nur ein mal je Port angefügt werden kann, ist diese ID immer die gleiche.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public const string EXT_ID
Visual Basic
Public Const EXT_ID As String
F#
static val mutable EXT_ID: string

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


PortVisualization Methods

[image] [image]

DynamicNodes API
PortVisualization Methods
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PortVisualization type exposes the following members.

Methods

 | Name | Description
Public method | AddPin | Fügt einen Pin auf der Augangs-Port-Seite in die Verbindunglinie ein.
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Port angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Port entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | GetConnectedOutPortVisualization | Gibt die Port-Visualisierung des verbundenen Ausgangsports zurück, wenn der diese Visualisierung zu einem Eingangsport gehört und eine Verbindung existiert.
 | GetFrom | Gibt für einen Port die Visualisierung zurück.
Public method | GetPin | Gibt einen Pin zurück.
Public method | GetPinByMouse | Gibt eine Pin anhand von Cursor-Koordinaten zurück, oder null, wenn sich kein Pin unter dem Cursor befindet.
Public method | GetSchema | Diese Eigenschaft ist reserviert, wenden Sie stattdessen das XmlSchemaProviderAttribute auf die Klasse an.
Public method | IsMouseInside | Prüft, ob die lokalen Koordinaten innerhalb des Ports liegen.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Public method | ReadXml | Generiert ein Objekt aus seiner XML-Darstellung.
Public method | RemoveAllPins | Entfernt alle Pins aus der Verbindunglinie.
Public method | RemovePin | Entfernt einen Pin aus der Verbindunglinie.
Public method | WriteXml | Konvertiert ein Objekt in seine XML-Darstellung.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


AddPin Method

[image]

DynamicNodes API
PortVisualization..::..AddPin Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt einen Pin auf der Augangs-Port-Seite in die Verbindunglinie ein.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AddPin(
    Pin pin
)
Visual Basic
Public Sub AddPin ( _
    pin As Pin _
)
F#
member AddPin :
        pin:Pin -> unit

Parameters

pin
Type: DynamicNode.Ext.Visual..::..Pin
Ein Pin.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


AfterAttaching Method

[image]

DynamicNodes API
PortVisualization..::..AfterAttaching Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Port angefügt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterAttaching(
    IPort g
)
Visual Basic
Public Sub AfterAttaching ( _
    g As IPort _
)
F#
abstract AfterAttaching :
        g:IPort -> unit
override AfterAttaching :
        g:IPort -> unit

Parameters

g
Type: DynamicNode.Core..::..IPort
Der Port

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


AfterDetaching Method

[image]

DynamicNodes API
PortVisualization..::..AfterDetaching Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Port entfernt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterDetaching(
    IPort p
)
Visual Basic
Public Sub AfterDetaching ( _
    p As IPort _
)
F#
abstract AfterDetaching :
        p:IPort -> unit
override AfterDetaching :
        p:IPort -> unit

Parameters

p
Type: DynamicNode.Core..::..IPort
Der Port

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


AfterRestoring Method

[image]

DynamicNodes API
PortVisualization..::..AfterRestoring Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


GetConnectedOutPortVisualization Method

[image]

DynamicNodes API
PortVisualization..::..GetConnectedOutPortVisualization Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Port-Visualisierung des verbundenen Ausgangsports zurück, wenn der diese Visualisierung zu einem Eingangsport gehört und eine Verbindung existiert.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PortVisualization GetConnectedOutPortVisualization()
Visual Basic
Public Function GetConnectedOutPortVisualization As PortVisualization
F#
member GetConnectedOutPortVisualization : unit -> PortVisualization

Return Value

Eine Port-Visualisierung oder null.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


GetFrom Method

[image]

DynamicNodes API
PortVisualization..::..GetFrom Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für einen Port die Visualisierung zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public static PortVisualization GetFrom(
    IPort port
)
Visual Basic
Public Shared Function GetFrom ( _
    port As IPort _
) As PortVisualization
F#
static member GetFrom :
        port:IPort -> PortVisualization

Parameters

port
Type: DynamicNode.Core..::..IPort
Ein Port.

Return Value

Die Visualisierung oder null, wenn keine Visualisierung an den Knoten angefügt wurde.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


GetPin Method

[image]

DynamicNodes API
PortVisualization..::..GetPin Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Pin zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Pin GetPin(
    int index
)
Visual Basic
Public Function GetPin ( _
    index As Integer _
) As Pin
F#
member GetPin :
        index:int -> Pin

Parameters

index
Type: System..::..Int32
Der Index. (0 >= index > PinCount)

Return Value

Einen Pin mit dem Index index.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


GetPinByMouse Method

[image]

DynamicNodes API
PortVisualization..::..GetPinByMouse Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Pin anhand von Cursor-Koordinaten zurück, oder null, wenn sich kein Pin unter dem Cursor befindet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Pin GetPinByMouse(
    float x,
    float y
)
Visual Basic
Public Function GetPinByMouse ( _
    x As Single, _
    y As Single _
) As Pin
F#
member GetPinByMouse :
        x:float32 *
        y:float32 -> Pin

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.

Return Value

Den ersten Pin, welcher sich unter den übergebenen Koordinaten befindet, oder null, wenn die übergebenen Koordinaten ausserhalb aller Pins dieses Anschlusses liegen.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


GetSchema Method

[image]

DynamicNodes API
PortVisualization..::..GetSchema Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Diese Eigenschaft ist reserviert, wenden Sie stattdessen das XmlSchemaProviderAttribute auf die Klasse an.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema
F#
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Ein XmlSchema zur Beschreibung der XML-Darstellung des Objekts, das von der WriteXml(XmlWriter)-Methode erstellt und von der ReadXml(XmlReader)-Methode verwendet wird.

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


IsMouseInside Method

[image]

DynamicNodes API
PortVisualization..::..IsMouseInside Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob die lokalen Koordinaten innerhalb des Ports liegen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsMouseInside(
    float x,
    float y
)
Visual Basic
Public Function IsMouseInside ( _
    x As Single, _
    y As Single _
) As Boolean
F#
member IsMouseInside :
        x:float32 *
        y:float32 -> bool

Parameters

x
Type: System..::..Single
Die WorkspaceX-Koordinate.
y
Type: System..::..Single
Die WorkspaceY-Koordinate.

Return Value

true, wenn die übergebenen Koordinaten innerhalb des Ports liegen, sonst false.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


OnRestore Method

[image]

DynamicNodes API
PortVisualization..::..OnRestore Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschafts-Leser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


OnStore Method

[image]

DynamicNodes API
PortVisualization..::..OnStore Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschafts-Writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


ReadXml Method

[image]

DynamicNodes API
PortVisualization..::..ReadXml Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Generiert ein Objekt aus seiner XML-Darstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml ( _
    reader As XmlReader _
)
F#
abstract ReadXml :
        reader:XmlReader -> unit
override ReadXml :
        reader:XmlReader -> unit

Parameters

reader
Type: System.Xml..::..XmlReader
Der XmlReader-Stream, aus dem das Objekt deserialisiert wird.

Implements

IXmlSerializable..::..ReadXml(XmlReader)

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


RemoveAllPins Method

[image]

DynamicNodes API
PortVisualization..::..RemoveAllPins Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt alle Pins aus der Verbindunglinie.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void RemoveAllPins()
Visual Basic
Public Sub RemoveAllPins
F#
member RemoveAllPins : unit -> unit

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


RemovePin Method

[image]

DynamicNodes API
PortVisualization..::..RemovePin Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt einen Pin aus der Verbindunglinie.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void RemovePin(
    Pin pin
)
Visual Basic
Public Sub RemovePin ( _
    pin As Pin _
)
F#
member RemovePin :
        pin:Pin -> unit

Parameters

pin
Type: DynamicNode.Ext.Visual..::..Pin
Der Pin.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


WriteXml Method

[image]

DynamicNodes API
PortVisualization..::..WriteXml Method
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Konvertiert ein Objekt in seine XML-Darstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml ( _
    writer As XmlWriter _
)
F#
abstract WriteXml :
        writer:XmlWriter -> unit
override WriteXml :
        writer:XmlWriter -> unit

Parameters

writer
Type: System.Xml..::..XmlWriter
Der XmlWriter-Stream, in den das Objekt serialisiert wird.

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


PortVisualization Properties

[image] [image]

DynamicNodes API
PortVisualization Properties
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PortVisualization type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt eine portweit eindeutige ID zurück.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | NodeVisualization | Gibt, wenn vorhanden, die Knoten-Visualisierung des Knotens zurück, zu dem der Port dieser Visualisierung gehört.
Public property | Orientation | Gibt die Ausrichtung des Anschlusses zurück, oder legt sie fest.
Public property | OwnerPort | Gibt den Port zurück.
Public property | PinCount | Gibt die Anzahl der Pins zurück.
Public property | Pins | Eine schreibgeschützte Liste mit allen Pins.
Public property | PosX | Gibt die absolute WorkspaceX-Position zurück.
Public property | PosY | Gibt die absolute WorkspaceY-Position zurück.
Public property | Radius | Gibt die halbe Seitenlänge des Darstellungsbereichs dieses Ports zurück..
Public property | Rectangle | Gibt ein Rechteckzurück, welches den Darstellungsbereich des Ports einschließt.
Public property | RelPosX | Liest oder schreibt die relative WorkspaceX-Position des Ports zum Knoten.
Public property | RelPosY | Liest oder schreibt die relative WorkspaceY-Position des Ports zum Knoten.
Public property | SortIndex | Liest oder schreibt den Sortier-Index, mit dessen Hilfe die Reihenfolge der Anschlüsse an den vier Seiten bestimmt wird.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


Id Property

[image]

DynamicNodes API
PortVisualization..::..Id Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine portweit eindeutige ID zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


IsUsingStorage Property

[image]

DynamicNodes API
PortVisualization..::..IsUsingStorage Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


NodeVisualization Property

[image]

DynamicNodes API
PortVisualization..::..NodeVisualization Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt, wenn vorhanden, die Knoten-Visualisierung des Knotens zurück, zu dem der Port dieser Visualisierung gehört.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NodeVisualization NodeVisualization { get; }
Visual Basic
Public ReadOnly Property NodeVisualization As NodeVisualization
    Get
F#
member NodeVisualization : NodeVisualization

Field Value

Die Knoten-Visualsierung.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


Orientation Property

[image]

DynamicNodes API
PortVisualization..::..Orientation Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ausrichtung des Anschlusses zurück, oder legt sie fest.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public PortOrientation Orientation { get; set; }
Visual Basic
Public Property Orientation As PortOrientation
    Get
    Set
F#
member Orientation : PortOrientation with get, set

Field Value

Die Ausrichtung des Anschlusses.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


OwnerPort Property

[image]

DynamicNodes API
PortVisualization..::..OwnerPort Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Port zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IPort OwnerPort { get; }
Visual Basic
Public ReadOnly Property OwnerPort As IPort
    Get
F#
member OwnerPort : IPort

Field Value

Der Port.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


PinCount Property

[image]

DynamicNodes API
PortVisualization..::..PinCount Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der Pins zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public int PinCount { get; }
Visual Basic
Public ReadOnly Property PinCount As Integer
    Get
F#
member PinCount : int

Field Value

Die Anzahl der Pins.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


Pins Property

[image]

DynamicNodes API
PortVisualization..::..Pins Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine schreibgeschützte Liste mit allen Pins.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IList<Pin> Pins { get; }
Visual Basic
Public ReadOnly Property Pins As IList(Of Pin)
    Get
F#
member Pins : IList<Pin>

Field Value

Alle Pins.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


PosX Property

[image]

DynamicNodes API
PortVisualization..::..PosX Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die absolute WorkspaceX-Position zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float PosX { get; }
Visual Basic
Public ReadOnly Property PosX As Single
    Get
F#
member PosX : float32

Field Value

Die WorkspaceX-Position.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


PosY Property

[image]

DynamicNodes API
PortVisualization..::..PosY Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die absolute WorkspaceY-Position zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float PosY { get; }
Visual Basic
Public ReadOnly Property PosY As Single
    Get
F#
member PosY : float32

Field Value

Die WorkspaceY-Position.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


Radius Property

[image]

DynamicNodes API
PortVisualization..::..Radius Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die halbe Seitenlänge des Darstellungsbereichs dieses Ports zurück..

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float Radius { get; }
Visual Basic
Public ReadOnly Property Radius As Single
    Get
F#
member Radius : float32

Field Value

Der Radius des Darstellungsbereichs.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


Rectangle Property

[image]

DynamicNodes API
PortVisualization..::..Rectangle Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Rechteckzurück, welches den Darstellungsbereich des Ports einschließt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public RectangleF Rectangle { get; }
Visual Basic
Public ReadOnly Property Rectangle As RectangleF
    Get
F#
member Rectangle : RectangleF

Return Value

Der Darstellungsbereich des Ports.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


RelPosX Property

[image]

DynamicNodes API
PortVisualization..::..RelPosX Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die relative WorkspaceX-Position des Ports zum Knoten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float RelPosX { get; set; }
Visual Basic
Public Property RelPosX As Single
    Get
    Set
F#
member RelPosX : float32 with get, set

Field Value

Die relative WorkspaceX-Position.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


RelPosY Property

[image]

DynamicNodes API
PortVisualization..::..RelPosY Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die relative WorkspaceY-Position des Ports zum Knoten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float RelPosY { get; set; }
Visual Basic
Public Property RelPosY As Single
    Get
    Set
F#
member RelPosY : float32 with get, set

Field Value

Die relative WorkspaceY-Position.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


SortIndex Property

[image]

DynamicNodes API
PortVisualization..::..SortIndex Property
PortVisualization Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt den Sortier-Index, mit dessen Hilfe die Reihenfolge der Anschlüsse an den vier Seiten bestimmt wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public int SortIndex { get; set; }
Visual Basic
Public Property SortIndex As Integer
    Get
    Set
F#
member SortIndex : int with get, set

Field Value

Der Sortier-Index des Anschlusses.

See Also

PortVisualization Class
DynamicNode.Ext.Visual Namespace


ProgressNode Class

[image]

DynamicNodes API
ProgressNode Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Erweiterung des Standard-Basis-Knotens um die Funktionalität einer Statusanzeige.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public abstract class ProgressNode : StreamNode
Visual Basic
Public MustInherit Class ProgressNode _
    Inherits StreamNode
F#
[<AbstractClassAttribute>]
type ProgressNode =
    class
        inherit StreamNode
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core..::..StreamNode
DynamicNode.Ext.Visual..::..ProgressNode

See Also

ProgressNode Members
DynamicNode.Ext.Visual Namespace


ProgressNode Members

[image] [image]

DynamicNodes API
ProgressNode Members
ProgressNode Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ProgressNode type exposes the following members.

Constructors

 | Name | Description
Protected method | ProgressNode | Initialisiert eine neue Instanz der Klasse ProgressNode.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..BeforeUseExtension(String).)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Progress | Liest oder Schreibt den Fortschritt als Single-Fließkommazahl zwischen 0 und 1.
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

ProgressNode Class
DynamicNode.Ext.Visual Namespace


ProgressNode Constructor

[image]

DynamicNodes API
ProgressNode Constructor
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse ProgressNode.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected ProgressNode()
Visual Basic
Protected Sub New
F#
new : unit -> ProgressNode

See Also

ProgressNode Class
DynamicNode.Ext.Visual Namespace


ProgressNode Methods

[image] [image]

DynamicNodes API
ProgressNode Methods
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ProgressNode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..BeforeUseExtension(String).)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)

See Also

ProgressNode Class
DynamicNode.Ext.Visual Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
ProgressNode..::..BeforeUseExtension Method
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..BeforeUseExtension(String).)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

ProgressNode Class
ProgressNode Members
DynamicNode.Ext.Visual Namespace


BeforeUseExtension Method (String)

[image]

DynamicNodes API
ProgressNode..::..BeforeUseExtension Method (String)
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override void BeforeUseExtension(
    string id
)
Visual Basic
Protected Overrides Sub BeforeUseExtension ( _
    id As String _
)
F#
abstract BeforeUseExtension :
        id:string -> unit
override BeforeUseExtension :
        id:string -> unit

Parameters

id
Type: System..::..String
Die ID der Knotenerweiterung, die benutzt werden soll.

See Also

ProgressNode Class
BeforeUseExtension Overload
DynamicNode.Ext.Visual Namespace


Duplicate Method

[image] [image]

DynamicNodes API
ProgressNode..::..Duplicate Method
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

ProgressNode Class
ProgressNode Members
DynamicNode.Ext.Visual Namespace


InitVisualization Method

[image]

DynamicNodes API
ProgressNode..::..InitVisualization Method
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die Knoten-Visualisierung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void InitVisualization(
    NodeVisualization nVis
)
Visual Basic
Protected Overridable Sub InitVisualization ( _
    nVis As NodeVisualization _
)
F#
abstract InitVisualization :
        nVis:NodeVisualization -> unit
override InitVisualization :
        nVis:NodeVisualization -> unit

Parameters

nVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.

See Also

ProgressNode Class
DynamicNode.Ext.Visual Namespace


RegisterStreamInPorts Method

[image] [image]

DynamicNodes API
ProgressNode..::..RegisterStreamInPorts Method
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)

See Also

ProgressNode Class
ProgressNode Members
DynamicNode.Ext.Visual Namespace


TraceError Method

[image] [image]

DynamicNodes API
ProgressNode..::..TraceError Method
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ProgressNode Class
ProgressNode Members
DynamicNode.Ext.Visual Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
ProgressNode..::..TraceInfo Method
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ProgressNode Class
ProgressNode Members
DynamicNode.Ext.Visual Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
ProgressNode..::..TraceVerbose Method
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ProgressNode Class
ProgressNode Members
DynamicNode.Ext.Visual Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
ProgressNode..::..TraceVerboseData Method
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ProgressNode Class
ProgressNode Members
DynamicNode.Ext.Visual Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
ProgressNode..::..TraceWarning Method
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ProgressNode Class
ProgressNode Members
DynamicNode.Ext.Visual Namespace


Work Method

[image] [image]

DynamicNodes API
ProgressNode..::..Work Method
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)

See Also

ProgressNode Class
ProgressNode Members
DynamicNode.Ext.Visual Namespace


ProgressNode Properties

[image] [image]

DynamicNodes API
ProgressNode Properties
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ProgressNode type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Progress | Liest oder Schreibt den Fortschritt als Single-Fließkommazahl zwischen 0 und 1.
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

ProgressNode Class
DynamicNode.Ext.Visual Namespace


Item Property

[image] [image]

DynamicNodes API
ProgressNode..::..Item Property
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

ProgressNode Class
ProgressNode Members
DynamicNode.Ext.Visual Namespace


Progress Property

[image]

DynamicNodes API
ProgressNode..::..Progress Property
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder Schreibt den Fortschritt als Single-Fließkommazahl zwischen 0 und 1.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public float Progress { get; set; }
Visual Basic
Public Property Progress As Single
    Get
    Set
F#
member Progress : float32 with get, set

Field Value

Der Fortschritt.

See Also

ProgressNode Class
DynamicNode.Ext.Visual Namespace


ProgressNode Events

[image] [image]

DynamicNodes API
ProgressNode Events
ProgressNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ProgressNode type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

ProgressNode Class
DynamicNode.Ext.Visual Namespace


SubGraphControlPanel Class

[image]

DynamicNodes API
SubGraphControlPanel Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Knoten-Steuerung für Sub-Graph-Knoten. Diese Steuerung wurde vom Kern in die visuellen Erweiterungen ausgelagert, damit das DNCore-Assembly keine Verweise auf System.Windows.Forms benötigt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class SubGraphControlPanel : UserControl
Visual Basic
Public Class SubGraphControlPanel _
    Inherits UserControl
F#
type SubGraphControlPanel =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Visual..::..SubGraphControlPanel

See Also

SubGraphControlPanel Members
DynamicNode.Ext.Visual Namespace


SubGraphControlPanel Members

[image] [image]

DynamicNodes API
SubGraphControlPanel Members
SubGraphControlPanel Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SubGraphControlPanel type exposes the following members.

Constructors

 | Name | Description
Public method | SubGraphControlPanel | Initialisiert eine neue Instanz der Klasse SubGraphControlPanel.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

SubGraphControlPanel Class
DynamicNode.Ext.Visual Namespace


SubGraphControlPanel Constructor

[image]

DynamicNodes API
SubGraphControlPanel Constructor
SubGraphControlPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse SubGraphControlPanel.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public SubGraphControlPanel(
    NSubGraph subGraphNode
)
Visual Basic
Public Sub New ( _
    subGraphNode As NSubGraph _
)
F#
new :
        subGraphNode:NSubGraph -> SubGraphControlPanel

Parameters

subGraphNode
Type: DynamicNode.Core.Nodes..::..NSubGraph
Ein Sub-Graph-Knoten.

See Also

SubGraphControlPanel Class
DynamicNode.Ext.Visual Namespace


SubGraphControlPanel Methods

[image] [image]

DynamicNodes API
SubGraphControlPanel Methods
SubGraphControlPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SubGraphControlPanel type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

SubGraphControlPanel Class
DynamicNode.Ext.Visual Namespace


Dispose Method

[image]

DynamicNodes API
SubGraphControlPanel..::..Dispose Method
SubGraphControlPanel Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

SubGraphControlPanel Class
DynamicNode.Ext.Visual Namespace


SubGraphNodeFactory Class

[image]

DynamicNodes API
SubGraphNodeFactory Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erweiterung von DefaultNodeFactory für die Erzeugung von NSubGraph-Knoten und sofortigem Laden eines Moduls.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class SubGraphNodeFactory : DefaultNodeFactory
Visual Basic
Public Class SubGraphNodeFactory _
    Inherits DefaultNodeFactory
F#
type SubGraphNodeFactory =
    class
        inherit DefaultNodeFactory
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..DefaultNodeFactory
DynamicNode.Ext.Visual..::..SubGraphNodeFactory

See Also

SubGraphNodeFactory Members
DynamicNode.Ext.Visual Namespace


SubGraphNodeFactory Members

[image] [image]

DynamicNodes API
SubGraphNodeFactory Members
SubGraphNodeFactory Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SubGraphNodeFactory type exposes the following members.

Constructors

 | Name | Description
Public method | SubGraphNodeFactory | Initialisiert eine neue Instanz der Klasse SubGraphNodeFactory.

Methods

 | Name | Description
Public method | CreateNode | Erzeugt einen neuen Knoten. (Overrides DefaultNodeFactory..::..CreateNode(CustomNodeFactoryVariation).)
Public method | GetVariations | Gibt alle möglichen Variationen für diese Factory zurück. (Inherited from DefaultNodeFactory.)

Properties

 | Name | Description
Public property | DefaultFactory | Gibt die Standard-Knoten-Factory zurück, die von der Laufzeitumgebung verwendet wird. (Inherited from DefaultNodeFactory.)
Public property | ModuleFile | Die Datei in der das Modul gespeichert ist.
Public property | NodeType | Gibt den Knotentyp zurück, den diese Factory erzeugen kann. (Inherited from DefaultNodeFactory.)

See Also

SubGraphNodeFactory Class
DynamicNode.Ext.Visual Namespace


SubGraphNodeFactory Constructor

[image]

DynamicNodes API
SubGraphNodeFactory Constructor
SubGraphNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse SubGraphNodeFactory.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public SubGraphNodeFactory(
    Type nodeType,
    NodeFactory defaultFactory,
    string file
)
Visual Basic
Public Sub New ( _
    nodeType As Type, _
    defaultFactory As NodeFactory, _
    file As String _
)
F#
new :
        nodeType:Type *
        defaultFactory:NodeFactory *
        file:string -> SubGraphNodeFactory

Parameters

nodeType
Type: System..::..Type
Der Type des zu erzeugenden Knotens.
defaultFactory
Type: DynamicNode.Core..::..NodeFactory
Die Standard-Knoten-Factory, die von der Laufzeitumgebung verwendet wird.
file
Type: System..::..String
Die Moduldatei.

See Also

SubGraphNodeFactory Class
DynamicNode.Ext.Visual Namespace


SubGraphNodeFactory Methods

[image] [image]

DynamicNodes API
SubGraphNodeFactory Methods
SubGraphNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SubGraphNodeFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateNode | Erzeugt einen neuen Knoten. (Overrides DefaultNodeFactory..::..CreateNode(CustomNodeFactoryVariation).)
Public method | GetVariations | Gibt alle möglichen Variationen für diese Factory zurück. (Inherited from DefaultNodeFactory.)

See Also

SubGraphNodeFactory Class
DynamicNode.Ext.Visual Namespace


CreateNode Method

[image]

DynamicNodes API
SubGraphNodeFactory..::..CreateNode Method
SubGraphNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt einen neuen Knoten.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public override INode CreateNode(
    CustomNodeFactoryVariation variation
)
Visual Basic
Public Overrides Function CreateNode ( _
    variation As CustomNodeFactoryVariation _
) As INode
F#
abstract CreateNode :
        variation:CustomNodeFactoryVariation -> INode
override CreateNode :
        variation:CustomNodeFactoryVariation -> INode

Parameters

variation
Type: DynamicNode.Core..::..CustomNodeFactoryVariation
Eine Factory-Variation.

Return Value

Der erzeugte Knoten.

Implements

ICustomNodeFactory..::..CreateNode(CustomNodeFactoryVariation)

See Also

SubGraphNodeFactory Class
DynamicNode.Ext.Visual Namespace


SubGraphNodeFactory Properties

[image] [image]

DynamicNodes API
SubGraphNodeFactory Properties
SubGraphNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SubGraphNodeFactory type exposes the following members.

Properties

 | Name | Description
Public property | DefaultFactory | Gibt die Standard-Knoten-Factory zurück, die von der Laufzeitumgebung verwendet wird. (Inherited from DefaultNodeFactory.)
Public property | ModuleFile | Die Datei in der das Modul gespeichert ist.
Public property | NodeType | Gibt den Knotentyp zurück, den diese Factory erzeugen kann. (Inherited from DefaultNodeFactory.)

See Also

SubGraphNodeFactory Class
DynamicNode.Ext.Visual Namespace


ModuleFile Property

[image]

DynamicNodes API
SubGraphNodeFactory..::..ModuleFile Property
SubGraphNodeFactory Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Datei in der das Modul gespeichert ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public string ModuleFile { get; private set; }
Visual Basic
Public Property ModuleFile As String
    Get
    Private Set
F#
member ModuleFile : string with get, private set

See Also

SubGraphNodeFactory Class
DynamicNode.Ext.Visual Namespace


ThemeColor Enumeration

[image]

DynamicNodes API
ThemeColor Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Kennzeichnungen der verschiedenen Stilfarben für die Graphendarstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public enum ThemeColor
Visual Basic
Public Enumeration ThemeColor
F#
type ThemeColor

Members

Member name | Description
WorkspaceBackground1 |
WorkspaceBackground2 |
WorkspaceForeground |
NodeBackground |
NodeForeground |
NodeBorder1 |
NodeBorder2 |
NodeSelection |
NodeSelection2 |
NodeLocked |
CustomAreaBackground |
CustomAreaForeground |
CustomAreaBorder1 |
CustomAreaBorder2 |
NodeProgressBar |
InfoBackground |
InfoForeground |
NodeShaddow |
InPort |
OptionalInPort |
SuperInPortAdornment |
OutPort |
SuperOutPortAdornment |
DisabledPort |
Connection |
SelectedConnection |
Pin |
SelectedPin |
SelectionRectangle |

See Also

DynamicNode.Ext.Visual Namespace


ThemeDimension Enumeration

[image]

DynamicNodes API
ThemeDimension Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Kennzeichnungen für die verschiedenen Größen der Graphendarstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public enum ThemeDimension
Visual Basic
Public Enumeration ThemeDimension
F#
type ThemeDimension

Members

Member name | Description
NodeBorderWidth |
NodeSelectionWidth |
CustomAreaBorderWidth |
ConnectionWidth |
PortDistance |

See Also

DynamicNode.Ext.Visual Namespace


ThemeFont Enumeration

[image]

DynamicNodes API
ThemeFont Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Kennzeichnungen der verschiedenen Fonts für die Graphendarstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public enum ThemeFont
Visual Basic
Public Enumeration ThemeFont
F#
type ThemeFont

Members

Member name | Description
Workspace |
NodeTitle |
CustomArea |
Info |

See Also

DynamicNode.Ext.Visual Namespace


ThemePalette Enumeration

[image]

DynamicNodes API
ThemePalette Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Aufzählung der Farbpaletten der Graphendarstellung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public enum ThemePalette
Visual Basic
Public Enumeration ThemePalette
F#
type ThemePalette

Members

Member name | Description
Workspace |
Node |
CustomArea |
Shaddow |

See Also

DynamicNode.Ext.Visual Namespace


ThreadHelper Class

[image]

DynamicNodes API
ThreadHelper Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Klasse mit statischen Hilfsmethoden für den Thread-sicheren Aufruf von Code-Abschnitten zur Manipulation von GUI-Steuerelementen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public static class ThreadHelper
Visual Basic
Public NotInheritable Class ThreadHelper
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ThreadHelper =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..ThreadHelper

See Also

ThreadHelper Members
DynamicNode.Ext.Visual Namespace


ThreadHelper Members

[image] [image]

DynamicNodes API
ThreadHelper Members
ThreadHelper Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Methods

Name | Description
SaveInvoke(Control, SimpleMethod) | Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen. Diese Methode ruft parameterlose Code-Abschnitte auf.
SaveInvoke<(Of <<'(T>)>>)(Control, GenericDelegate<(Of <<'(T>)>>), T) | Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen. Diese generische Methode ruft Code-Abschnitte mit einem Parameter auf.
SaveInvoke<(Of <<'(T>)>>)(Control, MultiGenericDelegate<(Of <<'(T>)>>), array<T>[]()[][]) | Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen. Diese generische Methode ruft Code-Abschnitte mit mehreren Parametern eines Typs auf.

See Also

ThreadHelper Class
DynamicNode.Ext.Visual Namespace


ThreadHelper Methods

[image] [image]

DynamicNodes API
ThreadHelper Methods
ThreadHelper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Methods

Name | Description
SaveInvoke(Control, SimpleMethod) | Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen. Diese Methode ruft parameterlose Code-Abschnitte auf.
SaveInvoke<(Of <<'(T>)>>)(Control, GenericDelegate<(Of <<'(T>)>>), T) | Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen. Diese generische Methode ruft Code-Abschnitte mit einem Parameter auf.
SaveInvoke<(Of <<'(T>)>>)(Control, MultiGenericDelegate<(Of <<'(T>)>>), array<T>[]()[][]) | Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen. Diese generische Methode ruft Code-Abschnitte mit mehreren Parametern eines Typs auf.

See Also

ThreadHelper Class
DynamicNode.Ext.Visual Namespace


SaveInvoke Method

[image] [image]

DynamicNodes API
ThreadHelper..::..SaveInvoke Method
ThreadHelper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
SaveInvoke(Control, SimpleMethod) | Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen. Diese Methode ruft parameterlose Code-Abschnitte auf.
SaveInvoke<(Of <<'(T>)>>)(Control, GenericDelegate<(Of <<'(T>)>>), T) | Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen. Diese generische Methode ruft Code-Abschnitte mit einem Parameter auf.
SaveInvoke<(Of <<'(T>)>>)(Control, MultiGenericDelegate<(Of <<'(T>)>>), array<T>[]()[][]) | Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen. Diese generische Methode ruft Code-Abschnitte mit mehreren Parametern eines Typs auf.

See Also

ThreadHelper Class
ThreadHelper Members
DynamicNode.Ext.Visual Namespace


SaveInvoke Method (Control, SimpleMethod)

[image]

DynamicNodes API
ThreadHelper..::..SaveInvoke Method (Control, SimpleMethod)
ThreadHelper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen.

Diese Methode ruft parameterlose Code-Abschnitte auf.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public static void SaveInvoke(
    Control c,
    SimpleMethod d
)
Visual Basic
Public Shared Sub SaveInvoke ( _
    c As Control, _
    d As SimpleMethod _
)
F#
static member SaveInvoke :
        c:Control *
        d:SimpleMethod -> unit

Parameters

c
Type: System.Windows.Forms..::..Control
Das Steuerelement welches manipuliert werden soll.
d
Type: DynamicNode.Core..::..SimpleMethod
Ein Delegate, welches den Code-Abschnitt referenziert, in dem die Manipulation stattfindet.

See Also

ThreadHelper Class
SaveInvoke Overload
DynamicNode.Ext.Visual Namespace


SaveInvoke(T) Method (Control, GenericDelegate(T), T)

[image]

DynamicNodes API
ThreadHelper..::..SaveInvoke<(Of <(<'T>)>)> Method (Control, GenericDelegate<(Of <(<'T>)>)>, T)
ThreadHelper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen.

Diese generische Methode ruft Code-Abschnitte mit einem Parameter auf.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public static void SaveInvoke<T>(
    Control c,
    GenericDelegate<T> d,
    T v
)
Visual Basic
Public Shared Sub SaveInvoke(Of T) ( _
    c As Control, _
    d As GenericDelegate(Of T), _
    v As T _
)
F#
static member SaveInvoke :
        c:Control *
        d:GenericDelegate<'T> *
        v:'T -> unit

Parameters

c
Type: System.Windows.Forms..::..Control
Das Steuerelement welches manipuliert werden soll.
d
Type: DynamicNode.Ext.Visual..::..GenericDelegate <(Of <(<'T>)>)>
Ein Delegate, welches den Code-Abschnitt referenziert, in dem die Manipulation stattfindet.
v
Type: T
Der Parameter für den Code-Abschnitt.

Type Parameters

T
Der Typ des Arguments, welche beim Aufruf übergeben werden soll.

See Also

ThreadHelper Class
SaveInvoke Overload
DynamicNode.Ext.Visual Namespace


SaveInvoke(T) Method (Control, MultiGenericDelegate(T), T[])

[image]

DynamicNodes API
ThreadHelper..::..SaveInvoke<(Of <(<'T>)>)> Method (Control, MultiGenericDelegate<(Of <(<'T>)>)>, array<T>[]()[][])
ThreadHelper Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Prüft, ob das übergebene Steuerelement c im aktuellen Thread erzeugt wurde. Falls ja, wird das Delegate d direkt aufgerufen. Sonst wird das Delegate d asynchron im Erzeuger-Thread des Steuerelements aufgerufen.

Diese generische Methode ruft Code-Abschnitte mit mehreren Parametern eines Typs auf.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public static void SaveInvoke<T>(
    Control c,
    MultiGenericDelegate<T> d,
    params T[] values
)
Visual Basic
Public Shared Sub SaveInvoke(Of T) ( _
    c As Control, _
    d As MultiGenericDelegate(Of T), _
    ParamArray values As T() _
)
F#
static member SaveInvoke :
        c:Control *
        d:MultiGenericDelegate<'T> *
        values:'T[] -> unit

Parameters

c
Type: System.Windows.Forms..::..Control
Das Steuerelement welches manipuliert werden soll.
d
Type: DynamicNode.Ext.Visual..::..MultiGenericDelegate <(Of <(<'T>)>)>
Ein Delegate, welches den Code-Abschnitt referenziert, in dem die Manipulation stattfindet.
values
Type: array<T>[]()[][]
Die Objekte als Parameter für den Code-Abschnitt.

Type Parameters

T
Der Typ der Argumente, welche beim Aufruf übergeben werden sollen.

See Also

ThreadHelper Class
SaveInvoke Overload
DynamicNode.Ext.Visual Namespace


ToolButtonEventArgs Class

[image]

DynamicNodes API
ToolButtonEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignis-Parameter für das Ereignis ToolButtonClick. Es kapselt das Werkzeug welches aktiviert werden soll und die ToolStrip-Taste mit welcher das Eregnis ausgelöst wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class ToolButtonEventArgs : EventArgs
Visual Basic
Public Class ToolButtonEventArgs _
    Inherits EventArgs
F#
type ToolButtonEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Ext.Visual..::..ToolButtonEventArgs

See Also

ToolButtonEventArgs Members
DynamicNode.Ext.Visual Namespace


ToolButtonEventArgs Members

[image] [image]

DynamicNodes API
ToolButtonEventArgs Members
ToolButtonEventArgs Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ToolButtonEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ToolButtonEventArgs | Initialisiert eine neue Instanz der Klasse ToolButtonEventArgs.

Properties

 | Name | Description
Public property | Button | Gibt die ToolStrip-Taste zurück, welche das Ereignis ausgelöst hat.
Public property | Tool | Gibt das Werkzeug zurück, welches aktiviert werden soll.

See Also

ToolButtonEventArgs Class
DynamicNode.Ext.Visual Namespace


ToolButtonEventArgs Constructor

[image]

DynamicNodes API
ToolButtonEventArgs Constructor
ToolButtonEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse ToolButtonEventArgs.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public ToolButtonEventArgs(
    ToolStripButton tsb
)
Visual Basic
Public Sub New ( _
    tsb As ToolStripButton _
)
F#
new :
        tsb:ToolStripButton -> ToolButtonEventArgs

Parameters

tsb
Type: System.Windows.Forms..::..ToolStripButton
Die ToolStrip-Taste welche das Ereignis ausgelöst hat.

See Also

ToolButtonEventArgs Class
DynamicNode.Ext.Visual Namespace


ToolButtonEventArgs Properties

[image] [image]

DynamicNodes API
ToolButtonEventArgs Properties
ToolButtonEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ToolButtonEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Button | Gibt die ToolStrip-Taste zurück, welche das Ereignis ausgelöst hat.
Public property | Tool | Gibt das Werkzeug zurück, welches aktiviert werden soll.

See Also

ToolButtonEventArgs Class
DynamicNode.Ext.Visual Namespace


Button Property

[image]

DynamicNodes API
ToolButtonEventArgs..::..Button Property
ToolButtonEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ToolStrip-Taste zurück, welche das Ereignis ausgelöst hat.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public ToolStripButton Button { get; }
Visual Basic
Public ReadOnly Property Button As ToolStripButton
    Get
F#
member Button : ToolStripButton

Field Value

Die ToolStrip-Taste, welche das Eregnis ausgelöst hat.

See Also

ToolButtonEventArgs Class
DynamicNode.Ext.Visual Namespace


Tool Property

[image]

DynamicNodes API
ToolButtonEventArgs..::..Tool Property
ToolButtonEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Werkzeug zurück, welches aktiviert werden soll.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public IEditorTool Tool { get; }
Visual Basic
Public ReadOnly Property Tool As IEditorTool
    Get
F#
member Tool : IEditorTool

Field Value

Das Werkzeug.

See Also

ToolButtonEventArgs Class
DynamicNode.Ext.Visual Namespace


ViewPortExtension Class

[image]

DynamicNodes API
ViewPortExtension Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Knotenerweiterung, welche die Entwicklungsumgebung anweist, einen ViewPort für einen Knoten bereitzustellen. In dem ViewPort wird dann ein Steuerelement dargestellt, welches der Knoten zur Verfügung stellt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class ViewPortExtension : IExtension<INode>,
    IStorable, IXmlSerializable
Visual Basic
Public Class ViewPortExtension _
    Implements IExtension(Of INode), IStorable,  _
    IXmlSerializable
F#
type ViewPortExtension =
    class
        interface IExtension<INode>
        interface IStorable
        interface IXmlSerializable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..ViewPortExtension

See Also

ViewPortExtension Members
DynamicNode.Ext.Visual Namespace


ViewPortExtension Members

[image] [image]

DynamicNodes API
ViewPortExtension Members
ViewPortExtension Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ViewPortExtension type exposes the following members.

Constructors

 | Name | Description
Public method | ViewPortExtension(String, String) | Initialisiert eine neue Instanz der Klasse ViewPortExtension.
Public method | ViewPortExtension(String, String, Icon) | Initialisiert eine neue Instanz der Klasse ViewPortExtension.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | GetSchema | This property is reserved, apply the XmlSchemaProviderAttribute to the class instead.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Public method | ReadXml | Generates an object from its XML representation.
Public method | RestoreFromXmlCache | Deserialisiert ein IXmlSerializable mit Hilfe eines XML-Schnipselts, welcher bei dem letzten Aufruf von OnRestore(IPropertyReader) gelesen wurde.
Public method | StoreToXmlCache | Serialisiert ein IXmlSerializable und puffert den XML-Schnippsel bis OnStore(IPropertyWriter) aufgerufen wird.
Public method | WriteXml | Converts an object into its XML representation.

Properties

 | Name | Description
Public property | Caption | Liest oder schreibt die Beschriftung des ViewPorts.
Public property | Icon | Liest oder schreibt das Icon des ViewPorts.
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes zu dem die Erweitrung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | Node | Gibt den Knoten zurück, zu dem die Erweiterung gehört.
Public property | ViewPortControl | Liest oder schreibt das ViewPort-Steuerelement.
Public property | Visible | Liest oder schreibt einen Wert, der angibt ob der ViewPort ein- oder ausgeblendet ist.

Events

 | Name | Description
Public event | CaptionChanged | Wird ausgelöst, wenn die Beschriftung geändert wurde.
Public event | Detaching | Wird ausgelöst, wenn die Erweiterung vom Knoten abgelöst wurde.
Public event | Hide | Wird ausgelöst, wenn der ViewPort ausgeblendet wird.
Public event | IconChanged | Wird ausgelöst, wenn das Icon geändert wurde.
Public event | Restored | Wird ausgelöst, nachdem die Eigenschaften der Erweiterung wiederhergestellt wurden.
Public event | Show | Wird ausgelöst, wenn der ViewPort geblendet wird.
Public event | Storing | Wird ausgelöst, bevor die Eigenschaften der Erweiterung gespeichert werden.
Public event | ViewPortControlChanged | Wird ausgelöst, sobald das ViewPort-Steuerelement geändert wurde.

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


ViewPortExtension Constructor

[image] [image]

DynamicNodes API
ViewPortExtension Constructor
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ViewPortExtension(String, String) | Initialisiert eine neue Instanz der Klasse ViewPortExtension.
Public method | ViewPortExtension(String, String, Icon) | Initialisiert eine neue Instanz der Klasse ViewPortExtension.

See Also

ViewPortExtension Class
ViewPortExtension Members
DynamicNode.Ext.Visual Namespace


ViewPortExtension Constructor (String, String)

[image]

DynamicNodes API
ViewPortExtension Constructor (String, String)
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse ViewPortExtension.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public ViewPortExtension(
    string localId,
    string caption
)
Visual Basic
Public Sub New ( _
    localId As String, _
    caption As String _
)
F#
new :
        localId:string *
        caption:string -> ViewPortExtension

Parameters

localId
Type: System..::..String
Eine ID zur Unterscheidung verschiedener ViewPorts eines Knotens.
caption
Type: System..::..String
Die Beschriftung des ViewPorts.

See Also

ViewPortExtension Class
ViewPortExtension Overload
DynamicNode.Ext.Visual Namespace


ViewPortExtension Constructor (String, String, Icon)

[image]

DynamicNodes API
ViewPortExtension Constructor (String, String, Icon)
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse ViewPortExtension.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public ViewPortExtension(
    string localId,
    string caption,
    Icon icon
)
Visual Basic
Public Sub New ( _
    localId As String, _
    caption As String, _
    icon As Icon _
)
F#
new :
        localId:string *
        caption:string *
        icon:Icon -> ViewPortExtension

Parameters

localId
Type: System..::..String
Eine ID zur Unterscheidung verschiedener ViewPorts eines Knotens.
caption
Type: System..::..String
Die Beschriftung des ViewPorts.
icon
Type: System.Drawing..::..Icon
Das Icon des ViewPorts.

See Also

ViewPortExtension Class
ViewPortExtension Overload
DynamicNode.Ext.Visual Namespace


ViewPortExtension Methods

[image] [image]

DynamicNodes API
ViewPortExtension Methods
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ViewPortExtension type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | GetSchema | This property is reserved, apply the XmlSchemaProviderAttribute to the class instead.
Public method | OnRestore | Liest die Eigenschaften der Erweiterung.
Public method | OnStore | Sichert die Eigenschaften der Erweiterung.
Public method | ReadXml | Generates an object from its XML representation.
Public method | RestoreFromXmlCache | Deserialisiert ein IXmlSerializable mit Hilfe eines XML-Schnipselts, welcher bei dem letzten Aufruf von OnRestore(IPropertyReader) gelesen wurde.
Public method | StoreToXmlCache | Serialisiert ein IXmlSerializable und puffert den XML-Schnippsel bis OnStore(IPropertyWriter) aufgerufen wird.
Public method | WriteXml | Converts an object into its XML representation.

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


AfterAttaching Method

[image]

DynamicNodes API
ViewPortExtension..::..AfterAttaching Method
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterAttaching(
    INode g
)
Visual Basic
Public Sub AfterAttaching ( _
    g As INode _
)
F#
abstract AfterAttaching :
        g:INode -> unit
override AfterAttaching :
        g:INode -> unit

Parameters

g
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterAttaching(T)

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


AfterDetaching Method

[image]

DynamicNodes API
ViewPortExtension..::..AfterDetaching Method
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterDetaching(
    INode o
)
Visual Basic
Public Sub AfterDetaching ( _
    o As INode _
)
F#
abstract AfterDetaching :
        o:INode -> unit
override AfterDetaching :
        o:INode -> unit

Parameters

o
Type: DynamicNode.Core..::..INode
Das Objekt

Implements

IExtension<(Of <(<'T>)>)>..::..AfterDetaching(T)

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


AfterRestoring Method

[image]

DynamicNodes API
ViewPortExtension..::..AfterRestoring Method
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void AfterRestoring()
Visual Basic
Public Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit
override AfterRestoring : unit -> unit

Implements

IExtension<(Of <(<'T>)>)>..::..AfterRestoring()()()()

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


GetSchema Method

[image]

DynamicNodes API
ViewPortExtension..::..GetSchema Method
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
This property is reserved, apply the XmlSchemaProviderAttribute to the class instead.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema
F#
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

An XmlSchema that describes the XML representation of the object that is produced by the WriteXml(XmlWriter) method and consumed by the ReadXml(XmlReader) method.

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


OnRestore Method

[image]

DynamicNodes API
ViewPortExtension..::..OnRestore Method
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void OnRestore(
    IPropertyReader reader
)
Visual Basic
Public Overridable Sub OnRestore ( _
    reader As IPropertyReader _
)
F#
abstract OnRestore :
        reader:IPropertyReader -> unit
override OnRestore :
        reader:IPropertyReader -> unit

Parameters

reader
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschafts-Leser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


OnStore Method

[image]

DynamicNodes API
ViewPortExtension..::..OnStore Method
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert die Eigenschaften der Erweiterung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public virtual void OnStore(
    IPropertyWriter writer
)
Visual Basic
Public Overridable Sub OnStore ( _
    writer As IPropertyWriter _
)
F#
abstract OnStore :
        writer:IPropertyWriter -> unit
override OnStore :
        writer:IPropertyWriter -> unit

Parameters

writer
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschafts-Writer.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


ReadXml Method

[image]

DynamicNodes API
ViewPortExtension..::..ReadXml Method
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Generates an object from its XML representation.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml ( _
    reader As XmlReader _
)
F#
abstract ReadXml :
        reader:XmlReader -> unit
override ReadXml :
        reader:XmlReader -> unit

Parameters

reader
Type: System.Xml..::..XmlReader
The XmlReader stream from which the object is deserialized.

Implements

IXmlSerializable..::..ReadXml(XmlReader)

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


RestoreFromXmlCache Method

[image]

DynamicNodes API
ViewPortExtension..::..RestoreFromXmlCache Method
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Deserialisiert ein IXmlSerializable mit Hilfe eines XML-Schnipselts, welcher bei dem letzten Aufruf von OnRestore(IPropertyReader) gelesen wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void RestoreFromXmlCache(
    IXmlSerializable o
)
Visual Basic
Public Sub RestoreFromXmlCache ( _
    o As IXmlSerializable _
)
F#
member RestoreFromXmlCache :
        o:IXmlSerializable -> unit

Parameters

o
Type: System.Xml.Serialization..::..IXmlSerializable
Ein serialisierbares Objekt

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


StoreToXmlCache Method

[image]

DynamicNodes API
ViewPortExtension..::..StoreToXmlCache Method
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Serialisiert ein IXmlSerializable und puffert den XML-Schnippsel bis OnStore(IPropertyWriter) aufgerufen wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void StoreToXmlCache(
    IXmlSerializable o
)
Visual Basic
Public Sub StoreToXmlCache ( _
    o As IXmlSerializable _
)
F#
member StoreToXmlCache :
        o:IXmlSerializable -> unit

Parameters

o
Type: System.Xml.Serialization..::..IXmlSerializable
Ein serialisierbares Objekt.

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


WriteXml Method

[image]

DynamicNodes API
ViewPortExtension..::..WriteXml Method
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Converts an object into its XML representation.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml ( _
    writer As XmlWriter _
)
F#
abstract WriteXml :
        writer:XmlWriter -> unit
override WriteXml :
        writer:XmlWriter -> unit

Parameters

writer
Type: System.Xml..::..XmlWriter
The XmlWriter stream to which the object is serialized.

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


ViewPortExtension Properties

[image] [image]

DynamicNodes API
ViewPortExtension Properties
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ViewPortExtension type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Liest oder schreibt die Beschriftung des ViewPorts.
Public property | Icon | Liest oder schreibt das Icon des ViewPorts.
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes zu dem die Erweitrung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.
Public property | Node | Gibt den Knoten zurück, zu dem die Erweiterung gehört.
Public property | ViewPortControl | Liest oder schreibt das ViewPort-Steuerelement.
Public property | Visible | Liest oder schreibt einen Wert, der angibt ob der ViewPort ein- oder ausgeblendet ist.

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


Caption Property

[image]

DynamicNodes API
ViewPortExtension..::..Caption Property
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt die Beschriftung des ViewPorts.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public string Caption { get; set; }
Visual Basic
Public Property Caption As String
    Get
    Set
F#
member Caption : string with get, set

Field Value

Die Beschriftung.

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


Icon Property

[image]

DynamicNodes API
ViewPortExtension..::..Icon Property
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt das Icon des ViewPorts.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Icon Icon { get; set; }
Visual Basic
Public Property Icon As Icon
    Get
    Set
F#
member Icon : Icon with get, set

Field Value

Das Icon.

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


Id Property

[image]

DynamicNodes API
ViewPortExtension..::..Id Property
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ID zurück, welche im Kontext des Objektes zu dem die Erweitrung gehört, eindeutig ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
abstract Id : string
override Id : string

Field Value

Die ID der Erweiterung.

Implements

IExtension<(Of <(<'T>)>)>..::..Id

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


IsUsingStorage Property

[image]

DynamicNodes API
ViewPortExtension..::..IsUsingStorage Property
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool IsUsingStorage { get; }
Visual Basic
Public ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool
override IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

Implements

IExtension<(Of <(<'T>)>)>..::..IsUsingStorage

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


Node Property

[image]

DynamicNodes API
ViewPortExtension..::..Node Property
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Knoten zurück, zu dem die Erweiterung gehört.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public INode Node { get; }
Visual Basic
Public ReadOnly Property Node As INode
    Get
F#
member Node : INode

Field Value

Der erweiterte Knoten.

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


ViewPortControl Property

[image]

DynamicNodes API
ViewPortExtension..::..ViewPortControl Property
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt das ViewPort-Steuerelement.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public Control ViewPortControl { get; set; }
Visual Basic
Public Property ViewPortControl As Control
    Get
    Set
F#
member ViewPortControl : Control with get, set

Field Value

Das ViewPort-Steuerelement.

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


Visible Property

[image]

DynamicNodes API
ViewPortExtension..::..Visible Property
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Wert, der angibt ob der ViewPort ein- oder ausgeblendet ist.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
F#
member Visible : bool with get, set

Field Value

true wenn eingeblendet, sonst false.

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


ViewPortExtension Events

[image] [image]

DynamicNodes API
ViewPortExtension Events
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ViewPortExtension type exposes the following members.

Events

 | Name | Description
Public event | CaptionChanged | Wird ausgelöst, wenn die Beschriftung geändert wurde.
Public event | Detaching | Wird ausgelöst, wenn die Erweiterung vom Knoten abgelöst wurde.
Public event | Hide | Wird ausgelöst, wenn der ViewPort ausgeblendet wird.
Public event | IconChanged | Wird ausgelöst, wenn das Icon geändert wurde.
Public event | Restored | Wird ausgelöst, nachdem die Eigenschaften der Erweiterung wiederhergestellt wurden.
Public event | Show | Wird ausgelöst, wenn der ViewPort geblendet wird.
Public event | Storing | Wird ausgelöst, bevor die Eigenschaften der Erweiterung gespeichert werden.
Public event | ViewPortControlChanged | Wird ausgelöst, sobald das ViewPort-Steuerelement geändert wurde.

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


CaptionChanged Event

[image]

DynamicNodes API
ViewPortExtension..::..CaptionChanged Event
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die Beschriftung geändert wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler CaptionChanged
Visual Basic
Public Event CaptionChanged As EventHandler
F#
member CaptionChanged : IEvent<EventHandler,
    EventArgs>

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


Detaching Event

[image]

DynamicNodes API
ViewPortExtension..::..Detaching Event
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die Erweiterung vom Knoten abgelöst wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler Detaching
Visual Basic
Public Event Detaching As EventHandler
F#
member Detaching : IEvent<EventHandler,
    EventArgs>

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


Hide Event

[image]

DynamicNodes API
ViewPortExtension..::..Hide Event
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der ViewPort ausgeblendet wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler Hide
Visual Basic
Public Event Hide As EventHandler
F#
member Hide : IEvent<EventHandler,
    EventArgs>

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


IconChanged Event

[image]

DynamicNodes API
ViewPortExtension..::..IconChanged Event
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn das Icon geändert wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler IconChanged
Visual Basic
Public Event IconChanged As EventHandler
F#
member IconChanged : IEvent<EventHandler,
    EventArgs>

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


Restored Event

[image]

DynamicNodes API
ViewPortExtension..::..Restored Event
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, nachdem die Eigenschaften der Erweiterung wiederhergestellt wurden.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler Restored
Visual Basic
Public Event Restored As EventHandler
F#
member Restored : IEvent<EventHandler,
    EventArgs>

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


Show Event

[image]

DynamicNodes API
ViewPortExtension..::..Show Event
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der ViewPort geblendet wird.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler Show
Visual Basic
Public Event Show As EventHandler
F#
member Show : IEvent<EventHandler,
    EventArgs>

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


Storing Event

[image]

DynamicNodes API
ViewPortExtension..::..Storing Event
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, bevor die Eigenschaften der Erweiterung gespeichert werden.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler Storing
Visual Basic
Public Event Storing As EventHandler
F#
member Storing : IEvent<EventHandler,
    EventArgs>

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


ViewPortControlChanged Event

[image]

DynamicNodes API
ViewPortExtension..::..ViewPortControlChanged Event
ViewPortExtension Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, sobald das ViewPort-Steuerelement geändert wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler ViewPortControlChanged
Visual Basic
Public Event ViewPortControlChanged As EventHandler
F#
member ViewPortControlChanged : IEvent<EventHandler,
    EventArgs>

See Also

ViewPortExtension Class
DynamicNode.Ext.Visual Namespace


VisualNode Class

[image]

DynamicNodes API
VisualNode Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein abstracte Ableitung von Node, die mehr Comfort beim Erstellen von visuellen Knoten bietet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public abstract class VisualNode : StreamNode
Visual Basic
Public MustInherit Class VisualNode _
    Inherits StreamNode
F#
[<AbstractClassAttribute>]
type VisualNode =
    class
        inherit StreamNode
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<' INode >)>)>
DynamicNode.Model..::..ParentObject <(Of <(<' INode, IPort >)>)>
DynamicNode.Model..::..HierarchyObject <(Of <(<' IGraph, INode, IPort >)>)>
DynamicNode.Core..::..Node
DynamicNode.Core..::..StreamNode
DynamicNode.Ext.Visual..::..VisualNode
DynamicNode.Ext.Cockpit..::..CockpitNode
DynamicNode.Ext.Objects..::..AbstractWrapper

See Also

VisualNode Members
DynamicNode.Ext.Visual Namespace


VisualNode Members

[image] [image]

DynamicNodes API
VisualNode Members
VisualNode Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The VisualNode type exposes the following members.

Constructors

 | Name | Description
Public method | VisualNode | Initialisiert eine neue Instanz der Klasse VisualNode.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..BeforeUseExtension(String).)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung.
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde.
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet.
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück.
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück.
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


VisualNode Constructor

[image]

DynamicNodes API
VisualNode Constructor
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse VisualNode.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public VisualNode(
    bool useVisualization,
    bool useControlPanel
)
Visual Basic
Public Sub New ( _
    useVisualization As Boolean, _
    useControlPanel As Boolean _
)
F#
new :
        useVisualization:bool *
        useControlPanel:bool -> VisualNode

Parameters

useVisualization
Type: System..::..Boolean
Aktiviert die Unterstützung für eine Knoten-Visualisierung.
useControlPanel
Type: System..::..Boolean
Aktiviert die Unterstützung für eine Knoten-Steuerung.

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


VisualNode Methods

[image] [image]

DynamicNodes API
VisualNode Methods
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The VisualNode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen. (Inherited from Node.)
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | AddCommand | Registriert einen Benutzerbefehl für diesen Knoten. (Inherited from Node.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..BeforeUseExtension(String).)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | CompareTo | Vergleicht diesen Knoten mit einem anderen. (Inherited from Node.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAddress | Gibt eine Zeichenfolge zurück, welche den Knoten identifiziert. (Inherited from Node.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | InitControlPanel | Initialisiert die Knoten-Steuerung.
Protected method | InitVisualization | Initialisiert die Knoten-Visualisierung.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | Isolate | Trennt alle Verbindungen zu anderen Knoten. (Inherited from Node.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Protected method | OnAfterActivation | Wird aufgerufen, wenn die Aktivierung des Knotens abgeschlossen wurde. Löst das Ereignis AfterActivation aus. (Inherited from Node.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnBeforeActivation | Wird aufgerufen, bevor der Knoten aktiviert wird. Löst das Ereignis BeforeActivation aus. (Inherited from Node.)
Protected method | OnBeforeReactivation | Wird aufgerufen, wenn der Knoten erneut aktiviert wird. Löst das Ereignis BeforeReactivation aus. (Inherited from Node.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from Node.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from Node.)
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat. (Inherited from Node.)
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat. (Inherited from Node.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnGraphExtensionAttached | Wird aufgerufen wenn dem Graph, zu dem der Knoten gehört eine Erweiterung angefügt wird. (Inherited from Node.)
Public method | OnGraphExtensionDetached | Wird aufgerufen wenn von dem Graph, zu dem der Knoten gehört eine Erweiterung entfernt wurde. (Inherited from Node.)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Public method | OnInitPortDefaults | Wird aufgerufen, wenn der Knoten neu erstellt wird. In dieser Methode sollten die Eingänge mit UpdateToken(Token) ihre Standard-Werte zugewiesen bekommen. Diese Methode wird nicht aufgerufen, wenn OnRestore(IPropertyReader) aufgerufen wird. (Inherited from Node.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public method | OnRestore | Wird aufgerufen wenn der Graph rekonstruiert wird. Wer diese Methode überschreibt muss base.OnRestore(pr) aufrufen. In dieser Methode sollten die Eingänge wenn möglich mit Standard-Werten belegt werden. (Inherited from StreamNode.)
Public method | OnStore | Wird aufgerufen wenn der Graph gespeichert wird. Wer diese Methode überschreibt muss base.OnStore(pr) aufrufen. (Inherited from StreamNode.)
Protected method | OnTokenRejected | Wird aufgerufen, wenn ein Token beim Synchronisieren verworfen wird. (Inherited from StreamNode.)
Protected method | OnTokenSetRejected | Wird aufgerufen, wenn ein TokenSet beim Sortieren verworfen wird. (Inherited from StreamNode.)
Protected method | PaintCustomArea | Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Protected method | SafeRepaintCustomArea | Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde.
Protected method | SafeRepaintNode | Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet.
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToString | Gibt einen String zurück, der den aktuellen Object darstellt. (Inherited from Node.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
VisualNode..::..BeforeUseExtension Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..BeforeUseExtension(String).)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

VisualNode Class
VisualNode Members
DynamicNode.Ext.Visual Namespace


BeforeUseExtension Method (String)

[image]

DynamicNodes API
VisualNode..::..BeforeUseExtension Method (String)
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, bevor versucht wird eine Knotenerweiterung zu benutzen. Diese Methode sollte von einem Konten überschrieben werden, um statische Erweiterungen zu initialisieren.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override void BeforeUseExtension(
    string id
)
Visual Basic
Protected Overrides Sub BeforeUseExtension ( _
    id As String _
)
F#
abstract BeforeUseExtension :
        id:string -> unit
override BeforeUseExtension :
        id:string -> unit

Parameters

id
Type: System..::..String
Die ID der Knotenerweiterung, die benutzt werden soll.

See Also

VisualNode Class
BeforeUseExtension Overload
DynamicNode.Ext.Visual Namespace


Duplicate Method

[image] [image]

DynamicNodes API
VisualNode..::..Duplicate Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Duplicate()()()() | Erstellt eine Kopie eines Knotens im gleichen Graph und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)
Public method | Duplicate(IGraph) | Erstellt eine Kopie eines Knotens und gibt ihn zurück. Dabei werden wenn möglich auch alle statischen Erweiterungen des Knotens und seiner Anschlüsse rekonstruiert. (Inherited from Node.)

See Also

VisualNode Class
VisualNode Members
DynamicNode.Ext.Visual Namespace


InitControlPanel Method

[image]

DynamicNodes API
VisualNode..::..InitControlPanel Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die Knoten-Steuerung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void InitControlPanel(
    NodeControlPanelExtension ctrlPanelExt
)
Visual Basic
Protected Overridable Sub InitControlPanel ( _
    ctrlPanelExt As NodeControlPanelExtension _
)
F#
abstract InitControlPanel :
        ctrlPanelExt:NodeControlPanelExtension -> unit
override InitControlPanel :
        ctrlPanelExt:NodeControlPanelExtension -> unit

Parameters

ctrlPanelExt
Type: DynamicNode.Ext.Visual..::..NodeControlPanelExtension
Die Knoten-Steuerung.

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


InitVisualization Method

[image]

DynamicNodes API
VisualNode..::..InitVisualization Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die Knoten-Visualisierung.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void InitVisualization(
    NodeVisualization nVis
)
Visual Basic
Protected Overridable Sub InitVisualization ( _
    nVis As NodeVisualization _
)
F#
abstract InitVisualization :
        nVis:NodeVisualization -> unit
override InitVisualization :
        nVis:NodeVisualization -> unit

Parameters

nVis
Type: DynamicNode.Ext.Visual..::..NodeVisualization
Die Knoten-Visualisierung.

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


PaintCustomArea Method

[image]

DynamicNodes API
VisualNode..::..PaintCustomArea Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir aufgerufen, um den benutzerdefinierten Bereich des Knotens zu zeichnen.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected virtual void PaintCustomArea(
    Graphics g,
    RectangleF area,
    IPaintProperties pp
)
Visual Basic
Protected Overridable Sub PaintCustomArea ( _
    g As Graphics, _
    area As RectangleF, _
    pp As IPaintProperties _
)
F#
abstract PaintCustomArea :
        g:Graphics *
        area:RectangleF *
        pp:IPaintProperties -> unit
override PaintCustomArea :
        g:Graphics *
        area:RectangleF *
        pp:IPaintProperties -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Der grafische Kontext.
area
Type: System.Drawing..::..RectangleF
Der benutzerdefinierte Bereich.
pp
Type: DynamicNode.Ext.Visual..::..IPaintProperties
Eine Sammlung von Zeichenressourcen.

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


RegisterStreamInPorts Method

[image] [image]

DynamicNodes API
VisualNode..::..RegisterStreamInPorts Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RegisterStreamInPorts(array<String>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird RegisterStreamInPorts nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)
Public method | RegisterStreamInPorts(array<InPort>[]()[][]) | Registriert eine Anzahl von Eingängen für die Synchronisation. Wird diese Methode nicht aufgerufen bevor der Synchronisationsmodus mit SynchronizationMode festgelegt wird, werden alle Eingänge für die Synchronisation verwendet. (Inherited from StreamNode.)

See Also

VisualNode Class
VisualNode Members
DynamicNode.Ext.Visual Namespace


SafeRepaintCustomArea Method

[image]

DynamicNodes API
VisualNode..::..SafeRepaintCustomArea Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet den benutzerdefinierten Bereich neu, wenn eine Knoten-Visualisierung initialisiert wurde.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected void SafeRepaintCustomArea()
Visual Basic
Protected Sub SafeRepaintCustomArea
F#
member SafeRepaintCustomArea : unit -> unit

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


SafeRepaintNode Method

[image]

DynamicNodes API
VisualNode..::..SafeRepaintNode Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet den Knoten neu, wenn eine Knoten-Visualiserung initialisiert wurde. Dabei wird in der Regel die gesamte Arbeitsfläche neu gezeichnet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected void SafeRepaintNode()
Visual Basic
Protected Sub SafeRepaintNode
F#
member SafeRepaintNode : unit -> unit

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


TraceError Method

[image] [image]

DynamicNodes API
VisualNode..::..TraceError Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

VisualNode Class
VisualNode Members
DynamicNode.Ext.Visual Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
VisualNode..::..TraceInfo Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

VisualNode Class
VisualNode Members
DynamicNode.Ext.Visual Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
VisualNode..::..TraceVerbose Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

VisualNode Class
VisualNode Members
DynamicNode.Ext.Visual Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
VisualNode..::..TraceVerboseData Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

VisualNode Class
VisualNode Members
DynamicNode.Ext.Visual Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
VisualNode..::..TraceWarning Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

VisualNode Class
VisualNode Members
DynamicNode.Ext.Visual Namespace


Work Method

[image] [image]

DynamicNodes API
VisualNode..::..Work Method
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Work()()()() | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)
Public method | Work(TokenSet) | Führt die Knoten-Operation durch. Dabei können die Ausgänge mit neuen Tokens belegt werden. (Inherited from StreamNode.)

See Also

VisualNode Class
VisualNode Members
DynamicNode.Ext.Visual Namespace


VisualNode Properties

[image] [image]

DynamicNodes API
VisualNode Properties
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The VisualNode type exposes the following members.

Properties

 | Name | Description
Public property | ActiveThread | Gibt den Thread zurück, in dem der Knoten aktiv ist. Wenn der Knoten nicht aktiv ist, wird null zurück gegeben. (Inherited from Node.)
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Commands | Gibt ein IDictionary mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung. (Inherited from Node.)
Protected property | CustomAreaPicture | Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Graph | Gibt den Graphen zurück zu dem dieser Knoten gehört, oder legt ihn fest. (Inherited from Node.)
Public property | GraphVisualization | Gibt Graphen-Visualisierung zurück.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IndexSortWindow | Liest oder schreibt das Sortierfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | IndexSyncWindow | Liest oder schreibt das Synchronisationsfenster für Token-Indizes. (Inherited from StreamNode.)
Public property | InPorts | Gibt eine schreibgeschützte Sammlung mit allen Eingabe-Ports zurück. (Inherited from Node.)
Public property | IsActivationRequired | Überprüft, ob an einem der Eingänge neue Token anliegen und eine Aktivierung des Knotens erforderlich ist. (Inherited from Node.)
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht. (Inherited from Node.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | IsParallelizable | Liest oder schreibt einen Wert, der angibt ob dieser Knoten parallel ausgeführt werden darf oder nicht. (Inherited from Node.)
Public property | IsSynchronizationModeChangeable | Liest oder schreibt einen Wert der angibt ob der Synchronisationsmodus des Knotens änderbar ist. (Inherited from StreamNode.)
Public property | IsWorkAborted | Liest und schreibt das Abbruch-Flag für die Knoten-Arbeit. (Inherited from Node.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from Node.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from Node.)
Public property | NodeControlPanelExtension | Gibt die Knoten-Steuerung zurück.
Public property | NodeInfo | Gibt das Attribut NodeInfoAttribute für die konkrete Node-Klasse zurück. (Inherited from Node.)
Public property | NodeVisualization | Gibt die Knoten-Visualisierung zurück.
Public property | OutPorts | Gibt eine schreibgeschützte Sammlung mit allen Ausgabe-Ports zurück. (Inherited from Node.)
Public property | Parallelizing | Liest oder schreibt einen Wert, der angibt wie diese Node-Instanz parallelisiert wird. (Inherited from Node.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public property | Reactivate | Liest und schreibt ein Flag, welches angibt dass der Knoten nach abgeschlossener Aktivierung erneut aktiviert werden soll. Dieses Flag wird vor jeder Aktivierung zurückgesetzt und sollte nur während der Ausführung von Work()()()() gesetzt werden. (Inherited from Node.)
Public property | SingleThreadContextId | Liest oder schreibt die ID für den Synchronisierungskontext der verwendet werden soll, falls Parallelizing auf Synchron gesetzt ist. (Inherited from Node.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)
Public property | SynchronizationMode | Gibt den Synchronisation-Modus fest oder gibt ihn zurück. (Inherited from StreamNode.)
Public property | ThreadManager | Gibt den Manager für die Parallelverarbeitung zurück. (Inherited from Node.)
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück. (Inherited from Node.)
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück. (Inherited from Node.)
Protected property | WasReactivated | Gibt true zurück, wenn der Knoten sich in einer Reaktivierungsphase befindet, sonst false (Inherited from Node.)

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


CustomAreaPicture Property

[image]

DynamicNodes API
VisualNode..::..CustomAreaPicture Property
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest und schreibt ein Bild das im benutzerdefinierten Knotenbereich gezeichnet werden soll. Wird dieser Eigenschaft ein Bild zugewiesen, wird die Größe des Knotens an das Bild angepasst und die Beschriftung des Knotens ausgeblendet.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected Bitmap CustomAreaPicture { get; set; }
Visual Basic
Protected Property CustomAreaPicture As Bitmap
    Get
    Set
F#
member CustomAreaPicture : Bitmap with get, set

Remarks

Diese Eigenschaft sollte nur innerhalb von InitVisualization(NodeVisualization) geändert werden.

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


GraphVisualization Property

[image]

DynamicNodes API
VisualNode..::..GraphVisualization Property
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt Graphen-Visualisierung zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public GraphVisualization GraphVisualization { get; }
Visual Basic
Public ReadOnly Property GraphVisualization As GraphVisualization
    Get
F#
member GraphVisualization : GraphVisualization

Field Value

Die Graphen-Visualisierung oder null, wenn der Graph bisher keine besitzt.

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


Item Property

[image] [image]

DynamicNodes API
VisualNode..::..Item Property
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

VisualNode Class
VisualNode Members
DynamicNode.Ext.Visual Namespace


NodeControlPanelExtension Property

[image]

DynamicNodes API
VisualNode..::..NodeControlPanelExtension Property
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Knoten-Steuerung zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NodeControlPanelExtension NodeControlPanelExtension { get; }
Visual Basic
Public ReadOnly Property NodeControlPanelExtension As NodeControlPanelExtension
    Get
F#
member NodeControlPanelExtension : NodeControlPanelExtension

Field Value

Die Knoten-Steuerung oder null, wenn bisher keine initialisiert wurde.

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


NodeVisualization Property

[image]

DynamicNodes API
VisualNode..::..NodeVisualization Property
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Knoten-Visualisierung zurück.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NodeVisualization NodeVisualization { get; }
Visual Basic
Public ReadOnly Property NodeVisualization As NodeVisualization
    Get
F#
member NodeVisualization : NodeVisualization

Field Value

Die Knoten-Visualisierung oder null, wenn bisher keine initialisiert wurde.

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


VisualNode Events

[image] [image]

DynamicNodes API
VisualNode Events
VisualNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The VisualNode type exposes the following members.

Events

 | Name | Description
Public event | AfterActivation | Wird ausgelöst, wenn die Aktivierung endet. (Inherited from Node.)
Public event | BeforeActivation | Wird ausgelöst, bevor der Knoten aktiviert wird. (Inherited from Node.)
Public event | BeforeReactivation | Wird ausgelöst, wenn ein Knoten erneut aktiviert wird. (Inherited from Node.)
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde. (Inherited from HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>.)
Public event | TokenRejected | Tritt auf, wenn beim Synchronisieren Tokens ein Token verworfen wird. Das kann passieren, wenn das IndexSyncWindow zu klein gewählt wurde. (Inherited from StreamNode.)
Public event | TokenSetRejected | Tritt auf, wenn beim Sortieren der synchronisierten TokenSets ein TokenSet verworfen wird. Das kann passieren, wenn das IndexSortWindow zu klein gewählt wurde. (Inherited from StreamNode.)

See Also

VisualNode Class
DynamicNode.Ext.Visual Namespace


WorkspaceBackgroundStyle Enumeration

[image]

DynamicNodes API
WorkspaceBackgroundStyle Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die verschiedenen Stile für den Hintergrund der Arbeitsfläche.

Namespace: DynamicNode.Ext.Visual
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public enum WorkspaceBackgroundStyle
Visual Basic
Public Enumeration WorkspaceBackgroundStyle
F#
type WorkspaceBackgroundStyle

Members

Member name | Description
Plain |
Dots |

See Also

DynamicNode.Ext.Visual Namespace


DynamicNode.Ext.Visual.Controls Namespace

[image]

DynamicNodes API
DynamicNode.Ext.Visual.Controls Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "N:DynamicNode.Ext.Visual.Controls"]

Classes

 | Class | Description
Public class | BooleanParameterControl | Ein Benutzersteuerelement für Wahrheitswerte zur Verwendung in einer Knotensteuerung. Es kann direkt an einen Eingang vom Typ Boolean gebunden werden.
Public class | NumericParameterControl | Ein Benutzersteuerelement für Zahlwerte zur Verwendung in einer Knotensteuerung. Es kann direkt an einen Eingang vom Typ Double gebunden werden.


BooleanParameterControl Class

[image]

DynamicNodes API
BooleanParameterControl Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Benutzersteuerelement für Wahrheitswerte zur Verwendung in einer Knotensteuerung. Es kann direkt an einen Eingang vom Typ Boolean gebunden werden.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class BooleanParameterControl : UserControl
Visual Basic
Public Class BooleanParameterControl _
    Inherits UserControl
F#
type BooleanParameterControl =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Visual.Controls..::..BooleanParameterControl

See Also

BooleanParameterControl Members
DynamicNode.Ext.Visual.Controls Namespace


BooleanParameterControl Members

[image] [image]

DynamicNodes API
BooleanParameterControl Members
BooleanParameterControl Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BooleanParameterControl type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanParameterControl | Initialitisert eine neue Instanz der Klasse BooleanParameterControl.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)

Properties

 | Name | Description
Public property | Caption | Die Beschriftung des gesteuerten Eingangs.
Public property | DefaultValue | Der Standardwert des gesteuerten Eingangs.
Public property | Port | Der Eingang an den das Steuerelement gebunden ist oder null.
Public property | Value | Gibt den aktuellen Wert des Steuerelements zurück oder legt ihn fest.

Events

 | Name | Description
Public event | ValueChanged | Diese Ereignis wird gefeuert, wenn der Wert durch das Steuerelement geändert wurde.

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


BooleanParameterControl Constructor

[image]

DynamicNodes API
BooleanParameterControl Constructor
BooleanParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialitisert eine neue Instanz der Klasse BooleanParameterControl.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public BooleanParameterControl()
Visual Basic
Public Sub New
F#
new : unit -> BooleanParameterControl

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


BooleanParameterControl Methods

[image] [image]

DynamicNodes API
BooleanParameterControl Methods
BooleanParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BooleanParameterControl type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Dispose Method

[image]

DynamicNodes API
BooleanParameterControl..::..Dispose Method
BooleanParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


BooleanParameterControl Properties

[image] [image]

DynamicNodes API
BooleanParameterControl Properties
BooleanParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BooleanParameterControl type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Die Beschriftung des gesteuerten Eingangs.
Public property | DefaultValue | Der Standardwert des gesteuerten Eingangs.
Public property | Port | Der Eingang an den das Steuerelement gebunden ist oder null.
Public property | Value | Gibt den aktuellen Wert des Steuerelements zurück oder legt ihn fest.

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Caption Property

[image]

DynamicNodes API
BooleanParameterControl..::..Caption Property
BooleanParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Beschriftung des gesteuerten Eingangs.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public string Caption { get; set; }
Visual Basic
Public Property Caption As String
    Get
    Set
F#
member Caption : string with get, set

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


DefaultValue Property

[image]

DynamicNodes API
BooleanParameterControl..::..DefaultValue Property
BooleanParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Standardwert des gesteuerten Eingangs.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool DefaultValue { get; set; }
Visual Basic
Public Property DefaultValue As Boolean
    Get
    Set
F#
member DefaultValue : bool with get, set

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Port Property

[image]

DynamicNodes API
BooleanParameterControl..::..Port Property
BooleanParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Eingang an den das Steuerelement gebunden ist oder null.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public InPort Port { get; set; }
Visual Basic
Public Property Port As InPort
    Get
    Set
F#
member Port : InPort with get, set

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Value Property

[image]

DynamicNodes API
BooleanParameterControl..::..Value Property
BooleanParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuellen Wert des Steuerelements zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public bool Value { get; set; }
Visual Basic
Public Property Value As Boolean
    Get
    Set
F#
member Value : bool with get, set

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


BooleanParameterControl Events

[image] [image]

DynamicNodes API
BooleanParameterControl Events
BooleanParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BooleanParameterControl type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Diese Ereignis wird gefeuert, wenn der Wert durch das Steuerelement geändert wurde.

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


ValueChanged Event

[image]

DynamicNodes API
BooleanParameterControl..::..ValueChanged Event
BooleanParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Diese Ereignis wird gefeuert, wenn der Wert durch das Steuerelement geändert wurde.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
F#
member ValueChanged : IEvent<EventHandler,
    EventArgs>

See Also

BooleanParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


NumericParameterControl Class

[image]

DynamicNodes API
NumericParameterControl Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Benutzersteuerelement für Zahlwerte zur Verwendung in einer Knotensteuerung. Es kann direkt an einen Eingang vom Typ Double gebunden werden.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public class NumericParameterControl : UserControl
Visual Basic
Public Class NumericParameterControl _
    Inherits UserControl
F#
type NumericParameterControl =
    class
        inherit UserControl
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.Ext.Visual.Controls..::..NumericParameterControl

See Also

NumericParameterControl Members
DynamicNode.Ext.Visual.Controls Namespace


NumericParameterControl Members

[image] [image]

DynamicNodes API
NumericParameterControl Members
NumericParameterControl Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NumericParameterControl type exposes the following members.

Constructors

 | Name | Description
Public method | NumericParameterControl | Initialisiert eine neue Instanz der Klasse NumericParameterControl.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)

Properties

 | Name | Description
Public property | Caption | Die Beschriftung des gesteuerten Eingangs.
Public property | DefaultValue | Der Standardwert des gesteuerten Eingangs.
Public property | Maximum | Der größte gültige Wert für den Eingang.
Public property | Minimum | Der kleinste gültige Wert für den Eingang.
Public property | Port | Der Eingang an den das Steuerelement gebunden ist oder null.
Public property | Step | Die Schrittweite der Steuerung.
Public property | Value | Gibt den aktuellen Wert des Steuerelements zurück oder legt ihn fest.

Events

 | Name | Description
Public event | ValueChanged | Diese Ereignis wird gefeuert, wenn der Wert durch das Steuerelement geändert wurde.

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


NumericParameterControl Constructor

[image]

DynamicNodes API
NumericParameterControl Constructor
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse NumericParameterControl.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public NumericParameterControl()
Visual Basic
Public Sub New
F#
new : unit -> NumericParameterControl

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


NumericParameterControl Methods

[image] [image]

DynamicNodes API
NumericParameterControl Methods
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NumericParameterControl type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Dispose Method

[image]

DynamicNodes API
NumericParameterControl..::..Dispose Method
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


NumericParameterControl Properties

[image] [image]

DynamicNodes API
NumericParameterControl Properties
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NumericParameterControl type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Die Beschriftung des gesteuerten Eingangs.
Public property | DefaultValue | Der Standardwert des gesteuerten Eingangs.
Public property | Maximum | Der größte gültige Wert für den Eingang.
Public property | Minimum | Der kleinste gültige Wert für den Eingang.
Public property | Port | Der Eingang an den das Steuerelement gebunden ist oder null.
Public property | Step | Die Schrittweite der Steuerung.
Public property | Value | Gibt den aktuellen Wert des Steuerelements zurück oder legt ihn fest.

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Caption Property

[image]

DynamicNodes API
NumericParameterControl..::..Caption Property
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Beschriftung des gesteuerten Eingangs.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public string Caption { get; set; }
Visual Basic
Public Property Caption As String
    Get
    Set
F#
member Caption : string with get, set

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


DefaultValue Property

[image]

DynamicNodes API
NumericParameterControl..::..DefaultValue Property
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Standardwert des gesteuerten Eingangs.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public double DefaultValue { get; set; }
Visual Basic
Public Property DefaultValue As Double
    Get
    Set
F#
member DefaultValue : float with get, set

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Maximum Property

[image]

DynamicNodes API
NumericParameterControl..::..Maximum Property
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der größte gültige Wert für den Eingang.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public double Maximum { get; set; }
Visual Basic
Public Property Maximum As Double
    Get
    Set
F#
member Maximum : float with get, set

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Minimum Property

[image]

DynamicNodes API
NumericParameterControl..::..Minimum Property
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der kleinste gültige Wert für den Eingang.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public double Minimum { get; set; }
Visual Basic
Public Property Minimum As Double
    Get
    Set
F#
member Minimum : float with get, set

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Port Property

[image]

DynamicNodes API
NumericParameterControl..::..Port Property
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Eingang an den das Steuerelement gebunden ist oder null.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public InPort Port { get; set; }
Visual Basic
Public Property Port As InPort
    Get
    Set
F#
member Port : InPort with get, set

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Step Property

[image]

DynamicNodes API
NumericParameterControl..::..Step Property
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schrittweite der Steuerung.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public double Step { get; set; }
Visual Basic
Public Property Step As Double
    Get
    Set
F#
member Step : float with get, set

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


Value Property

[image]

DynamicNodes API
NumericParameterControl..::..Value Property
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuellen Wert des Steuerelements zurück oder legt ihn fest.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public double Value { get; set; }
Visual Basic
Public Property Value As Double
    Get
    Set
F#
member Value : float with get, set

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


NumericParameterControl Events

[image] [image]

DynamicNodes API
NumericParameterControl Events
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NumericParameterControl type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Diese Ereignis wird gefeuert, wenn der Wert durch das Steuerelement geändert wurde.

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


ValueChanged Event

[image]

DynamicNodes API
NumericParameterControl..::..ValueChanged Event
NumericParameterControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Diese Ereignis wird gefeuert, wenn der Wert durch das Steuerelement geändert wurde.

Namespace: DynamicNode.Ext.Visual.Controls
Assembly: DNVisual (in DNVisual.dll) Version: 1.3.4679.19811 (1.3.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
F#
member ValueChanged : IEvent<EventHandler,
    EventArgs>

See Also

NumericParameterControl Class
DynamicNode.Ext.Visual.Controls Namespace


DynamicNode.Model Namespace

[image]

DynamicNodes API
DynamicNode.Model Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält die Schnittstellen und Basisklassen für das Datenmodell der DynamicNodes-Laufzeitumgebung.

Classes

 | Class | Description
Public class | BaseObject | Die Standardimplementierung für BaseObject.
Public class | ChildEventArgs<(Of <(<'TParent, TChild>)>)> | Die Ereignisdaten für das Hinzufügen oder Entfernen von Kindobjekten zu oder aus einem Elternobjekt.
Public class | ChildObject<(Of <(<'TParent, TSelf>)>)> | Die Standardimplementierung für IParent<(Of <(<'TSelf, TChild>)>)>
Public class | ExtensibleObject<(Of <(<'TSelf>)>)> | Ein BaseObject das die Schnittstelle IExtensible<(Of <(<'T>)>)> implementiert.
Public class | HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> | Die Standardimplementierung für Objekte, die sowohl IChild<(Of <(<'TParent, TSelf>)>)>, als auch IParent<(Of <(<'TSelf, TChild>)>)> implementieren sollen.
Public class | ParentObject<(Of <(<'TSelf, TChild>)>)> | Die Standardimplementierung von IParent<(Of <(<'TSelf, TChild>)>)>

Interfaces

 | Interface | Description
Public interface | IBaseObject | Die Basis-Schnittstelle für Objekte in der DynamicNodes-Laufzeitumgebung. Sie ist abgeleitet von IIdentifiable und IStorable.
Public interface | IChild<(Of <(<'TParent, TSelf>)>)> | Die Schnittstelle für Objekte in der DynamicNodes-Laufzeitumgebung, die in einem Elternobjekt (IParent<(Of <(<'TSelf, TChild>)>)>) gesammelt werden können.
Public interface | IExtensible<(Of <(<'T>)>)> | Eine generische Schnittstelle für erweiterbare Objekte.
Public interface | IExtension<(Of <(<'T>)>)> | Die generischen Schnittstelle für Erweiterungen.
Public interface | IIdentifiable | Diese Schnittstelle kann für Klassen verwendet werden, deren Objekte einen Namen und eine ID besitzen.
Public interface | IParent<(Of <(<'TSelf, TChild>)>)> | Die Schnittstelle für Objekte in der DynamicNodes-Laufzeitumgbung, in denen Kindobjekte (IChild<(Of <(<'TParent, TSelf>)>)>) gesammelt werden können.


BaseObject Class

[image]

DynamicNodes API
BaseObject Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardimplementierung für BaseObject.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class BaseObject : IBaseObject, IIdentifiable,
    IStorable
Visual Basic
Public Class BaseObject _
    Implements IBaseObject, IIdentifiable, IStorable
F#
type BaseObject =
    class
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject<(Of <(<'TSelf>)>)>

See Also

BaseObject Members
DynamicNode.Model Namespace


BaseObject Members

[image] [image]

DynamicNodes API
BaseObject Members
BaseObject Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseObject type exposes the following members.

Constructors

 | Name | Description
Public method | BaseObject | Initialisiert eine neue Instanz von BaseObject.

Methods

 | Name | Description
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist.
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist.
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus.
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus.
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus.
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem.
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem.
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem.
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem.
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem.

Properties

 | Name | Description
 | BaseTraceSource | Gibt die Standard-Ablaufverfolgungsquelle für DynamicNode.Model-Objekte zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest.
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück.
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest.
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück.
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück.
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest.
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen.

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde.
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde.
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde.
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde.

See Also

BaseObject Class
DynamicNode.Model Namespace


BaseObject Constructor

[image]

DynamicNodes API
BaseObject Constructor
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von BaseObject.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public BaseObject()
Visual Basic
Public Sub New
F#
new : unit -> BaseObject

See Also

BaseObject Class
DynamicNode.Model Namespace


BaseObject Methods

[image] [image]

DynamicNodes API
BaseObject Methods
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseObject type exposes the following members.

Methods

 | Name | Description
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist.
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist.
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus.
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus.
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus.
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem.
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem.
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem.
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem.
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem.

See Also

BaseObject Class
DynamicNode.Model Namespace


IsDescriptionValid Method

[image]

DynamicNodes API
BaseObject..::..IsDescriptionValid Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob die übergebene Beschreibung erlaubt ist.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual bool IsDescriptionValid(
    string newDescription,
    ref string errorMsg
)
Visual Basic
Protected Overridable Function IsDescriptionValid ( _
    newDescription As String, _
    ByRef errorMsg As String _
) As Boolean
F#
abstract IsDescriptionValid :
        newDescription:string *
        errorMsg:string byref -> bool
override IsDescriptionValid :
        newDescription:string *
        errorMsg:string byref -> bool

Parameters

newDescription
Type: System..::..String
Eine neue Beschreibung.
errorMsg
Type: System..::..String %
Falls false zurückgegeben wird, muss errorMsg eine Erklärung zugewiesen werden.

Return Value

true, wenn die Beschreibung erlaubt ist, sonst false.

See Also

BaseObject Class
DynamicNode.Model Namespace


IsIdValid Method

[image]

DynamicNodes API
BaseObject..::..IsIdValid Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob die übergebene ID erlaubt ist.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual bool IsIdValid(
    int newId,
    ref string errorMsg
)
Visual Basic
Protected Overridable Function IsIdValid ( _
    newId As Integer, _
    ByRef errorMsg As String _
) As Boolean
F#
abstract IsIdValid :
        newId:int *
        errorMsg:string byref -> bool
override IsIdValid :
        newId:int *
        errorMsg:string byref -> bool

Parameters

newId
Type: System..::..Int32
Eine neue ID.
errorMsg
Type: System..::..String %
Falls false zurückgegeben wird, muss errorMsg eine Erklärung zugewiesen werden.

Return Value

true, wenn die ID erlaubt ist, sonst false.

See Also

BaseObject Class
DynamicNode.Model Namespace


IsNameValid Method

[image]

DynamicNodes API
BaseObject..::..IsNameValid Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob der übergebene Name erlaubt ist.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual bool IsNameValid(
    string newName,
    ref string errorMsg
)
Visual Basic
Protected Overridable Function IsNameValid ( _
    newName As String, _
    ByRef errorMsg As String _
) As Boolean
F#
abstract IsNameValid :
        newName:string *
        errorMsg:string byref -> bool
override IsNameValid :
        newName:string *
        errorMsg:string byref -> bool

Parameters

newName
Type: System..::..String
Ein neuer Name.
errorMsg
Type: System..::..String %
Falls false zurückgegeben wird, muss errorMsg eine Erklärung zugewiesen werden.

Return Value

true, wenn der Name erlaubt ist, sonst false.

See Also

BaseObject Class
DynamicNode.Model Namespace


OnDescriptionChanged Method

[image]

DynamicNodes API
BaseObject..::..OnDescriptionChanged Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnDescriptionChanged()
Visual Basic
Protected Overridable Sub OnDescriptionChanged
F#
abstract OnDescriptionChanged : unit -> unit
override OnDescriptionChanged : unit -> unit

Remarks

Wenn diese Methode überschrieben wird, muss in der abgeleiteten Version die Version der Elternklasse mit base.OnDescriptionChanged() aufgerufen werden.

See Also

BaseObject Class
DynamicNode.Model Namespace


OnDirtyChanged Method

[image]

DynamicNodes API
BaseObject..::..OnDirtyChanged Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnDirtyChanged()
Visual Basic
Protected Overridable Sub OnDirtyChanged
F#
abstract OnDirtyChanged : unit -> unit
override OnDirtyChanged : unit -> unit

Remarks

Wenn diese Methode überschrieben wird, muss in der abgeleiteten Version die Version der Elternklasse mit base.OnDirtyChanged() aufgerufen werden.

See Also

BaseObject Class
DynamicNode.Model Namespace


OnIdChanged Method

[image]

DynamicNodes API
BaseObject..::..OnIdChanged Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnIdChanged()
Visual Basic
Protected Overridable Sub OnIdChanged
F#
abstract OnIdChanged : unit -> unit
override OnIdChanged : unit -> unit

Remarks

Wenn diese Methode überschrieben wird, muss in der abgeleiteten Version die Version der Elternklasse mit base.OnIdChanged() aufgerufen werden.

See Also

BaseObject Class
DynamicNode.Model Namespace


OnNameChanged Method

[image]

DynamicNodes API
BaseObject..::..OnNameChanged Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnNameChanged()
Visual Basic
Protected Overridable Sub OnNameChanged
F#
abstract OnNameChanged : unit -> unit
override OnNameChanged : unit -> unit

Remarks

Wenn diese Methode überschrieben wird, muss in der abgeleiteten Version die Version der Elternklasse mit base.OnNameChanged() aufgerufen werden.

See Also

BaseObject Class
DynamicNode.Model Namespace


OnRestore Method

[image]

DynamicNodes API
BaseObject..::..OnRestore Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overridable Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)

See Also

BaseObject Class
DynamicNode.Model Namespace


OnStore Method

[image]

DynamicNodes API
BaseObject..::..OnStore Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public virtual void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overridable Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)

See Also

BaseObject Class
DynamicNode.Model Namespace


TraceError Method

[image] [image]

DynamicNodes API
BaseObject..::..TraceError Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem.
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem.

See Also

BaseObject Class
BaseObject Members
DynamicNode.Model Namespace


TraceError Method (Int32, String)

[image]

DynamicNodes API
BaseObject..::..TraceError Method (Int32, String)
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet einen Fehler an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceError(
    int msgId,
    string text
)
Visual Basic
Public Sub TraceError ( _
    msgId As Integer, _
    text As String _
)
F#
member TraceError :
        msgId:int *
        text:string -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.

See Also

BaseObject Class
TraceError Overload
DynamicNode.Model Namespace


TraceError Method (Int32, String, Exception)

[image]

DynamicNodes API
BaseObject..::..TraceError Method (Int32, String, Exception)
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet einen Fehler an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceError(
    int msgId,
    string text,
    Exception e
)
Visual Basic
Public Sub TraceError ( _
    msgId As Integer, _
    text As String, _
    e As Exception _
)
F#
member TraceError :
        msgId:int *
        text:string *
        e:Exception -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.
e
Type: System..::..Exception
Die ursächliche Ausnahme.

See Also

BaseObject Class
TraceError Overload
DynamicNode.Model Namespace


TraceError Method (Int32, String, Object[])

[image]

DynamicNodes API
BaseObject..::..TraceError Method (Int32, String, array<Object>[]()[][])
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet einen Fehler an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceError(
    int msgId,
    string format,
    params Object[] args
)
Visual Basic
Public Sub TraceError ( _
    msgId As Integer, _
    format As String, _
    ParamArray args As Object() _
)
F#
member TraceError :
        msgId:int *
        format:string *
        args:Object[] -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
format
Type: System..::..String
Eine Format-Zeichenfolge.
args
Type: array< System..::..Object >[]()[][]
Die zu formatierenden Objekte.

See Also

BaseObject Class
TraceError Overload
DynamicNode.Model Namespace


TraceErrorData Method

[image]

DynamicNodes API
BaseObject..::..TraceErrorData Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet Daten über einen Fehler an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceErrorData(
    int msgId,
    params Object[] data
)
Visual Basic
Public Sub TraceErrorData ( _
    msgId As Integer, _
    ParamArray data As Object() _
)
F#
member TraceErrorData :
        msgId:int *
        data:Object[] -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
data
Type: array< System..::..Object >[]()[][]
Die Daten.

See Also

BaseObject Class
DynamicNode.Model Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
BaseObject..::..TraceInfo Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem.

See Also

BaseObject Class
BaseObject Members
DynamicNode.Model Namespace


TraceInfo Method (Int32, String)

[image]

DynamicNodes API
BaseObject..::..TraceInfo Method (Int32, String)
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine informative Meldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceInfo(
    int msgId,
    string text
)
Visual Basic
Public Sub TraceInfo ( _
    msgId As Integer, _
    text As String _
)
F#
member TraceInfo :
        msgId:int *
        text:string -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.

See Also

BaseObject Class
TraceInfo Overload
DynamicNode.Model Namespace


TraceInfo Method (Int32, String, Object[])

[image]

DynamicNodes API
BaseObject..::..TraceInfo Method (Int32, String, array<Object>[]()[][])
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine informative Meldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceInfo(
    int msgId,
    string format,
    params Object[] args
)
Visual Basic
Public Sub TraceInfo ( _
    msgId As Integer, _
    format As String, _
    ParamArray args As Object() _
)
F#
member TraceInfo :
        msgId:int *
        format:string *
        args:Object[] -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
format
Type: System..::..String
Eine Format-Zeichenfolge.
args
Type: array< System..::..Object >[]()[][]
Die zu formatierenden Objekte.

See Also

BaseObject Class
TraceInfo Overload
DynamicNode.Model Namespace


TraceInfoData Method

[image]

DynamicNodes API
BaseObject..::..TraceInfoData Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet informative Daten an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceInfoData(
    int msgId,
    params Object[] data
)
Visual Basic
Public Sub TraceInfoData ( _
    msgId As Integer, _
    ParamArray data As Object() _
)
F#
member TraceInfoData :
        msgId:int *
        data:Object[] -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
data
Type: array< System..::..Object >[]()[][]
Die Daten.

See Also

BaseObject Class
DynamicNode.Model Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
BaseObject..::..TraceVerbose Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem.

See Also

BaseObject Class
BaseObject Members
DynamicNode.Model Namespace


TraceVerbose Method (Int32, String)

[image]

DynamicNodes API
BaseObject..::..TraceVerbose Method (Int32, String)
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Detailmeldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceVerbose(
    int msgId,
    string text
)
Visual Basic
Public Sub TraceVerbose ( _
    msgId As Integer, _
    text As String _
)
F#
member TraceVerbose :
        msgId:int *
        text:string -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.

See Also

BaseObject Class
TraceVerbose Overload
DynamicNode.Model Namespace


TraceVerbose Method (Int32, String, Object[])

[image]

DynamicNodes API
BaseObject..::..TraceVerbose Method (Int32, String, array<Object>[]()[][])
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Detailmeldung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceVerbose(
    int msgId,
    string format,
    params Object[] args
)
Visual Basic
Public Sub TraceVerbose ( _
    msgId As Integer, _
    format As String, _
    ParamArray args As Object() _
)
F#
member TraceVerbose :
        msgId:int *
        format:string *
        args:Object[] -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
format
Type: System..::..String
Eine Format-Zeichenfolge.
args
Type: array< System..::..Object >[]()[][]
Die zu formatierenden Objekte.

See Also

BaseObject Class
TraceVerbose Overload
DynamicNode.Model Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
BaseObject..::..TraceVerboseData Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem.
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem.

See Also

BaseObject Class
BaseObject Members
DynamicNode.Model Namespace


TraceVerboseData Method (Int32, Object)

[image]

DynamicNodes API
BaseObject..::..TraceVerboseData Method (Int32, Object)
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet detailierte Daten an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceVerboseData(
    int msgId,
    Object data
)
Visual Basic
Public Sub TraceVerboseData ( _
    msgId As Integer, _
    data As Object _
)
F#
member TraceVerboseData :
        msgId:int *
        data:Object -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
data
Type: System..::..Object
Die Daten.

See Also

BaseObject Class
TraceVerboseData Overload
DynamicNode.Model Namespace


TraceVerboseData Method (Int32, Object[])

[image]

DynamicNodes API
BaseObject..::..TraceVerboseData Method (Int32, array<Object>[]()[][])
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet detailierte Daten an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceVerboseData(
    int msgId,
    params Object[] data
)
Visual Basic
Public Sub TraceVerboseData ( _
    msgId As Integer, _
    ParamArray data As Object() _
)
F#
member TraceVerboseData :
        msgId:int *
        data:Object[] -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
data
Type: array< System..::..Object >[]()[][]
Die Daten.

See Also

BaseObject Class
TraceVerboseData Overload
DynamicNode.Model Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
BaseObject..::..TraceWarning Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem.
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem.

See Also

BaseObject Class
BaseObject Members
DynamicNode.Model Namespace


TraceWarning Method (Int32, String)

[image]

DynamicNodes API
BaseObject..::..TraceWarning Method (Int32, String)
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Warnung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceWarning(
    int msgId,
    string text
)
Visual Basic
Public Sub TraceWarning ( _
    msgId As Integer, _
    text As String _
)
F#
member TraceWarning :
        msgId:int *
        text:string -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.

See Also

BaseObject Class
TraceWarning Overload
DynamicNode.Model Namespace


TraceWarning Method (Int32, String, Exception)

[image]

DynamicNodes API
BaseObject..::..TraceWarning Method (Int32, String, Exception)
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Warnung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceWarning(
    int msgId,
    string text,
    Exception e
)
Visual Basic
Public Sub TraceWarning ( _
    msgId As Integer, _
    text As String, _
    e As Exception _
)
F#
member TraceWarning :
        msgId:int *
        text:string *
        e:Exception -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
text
Type: System..::..String
Die Meldung.
e
Type: System..::..Exception
Die ursächliche Ausnahme.

See Also

BaseObject Class
TraceWarning Overload
DynamicNode.Model Namespace


TraceWarning Method (Int32, String, Object[])

[image]

DynamicNodes API
BaseObject..::..TraceWarning Method (Int32, String, array<Object>[]()[][])
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet eine Warnung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceWarning(
    int msgId,
    string format,
    params Object[] args
)
Visual Basic
Public Sub TraceWarning ( _
    msgId As Integer, _
    format As String, _
    ParamArray args As Object() _
)
F#
member TraceWarning :
        msgId:int *
        format:string *
        args:Object[] -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
format
Type: System..::..String
Eine Format-Zeichenfolge.
args
Type: array< System..::..Object >[]()[][]
Die zu formatierenden Objekte.

See Also

BaseObject Class
TraceWarning Overload
DynamicNode.Model Namespace


TraceWarningData Method

[image]

DynamicNodes API
BaseObject..::..TraceWarningData Method
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sendet Daten über eine Warnung an das Ablaufverfolgungssystem.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void TraceWarningData(
    int msgId,
    params Object[] data
)
Visual Basic
Public Sub TraceWarningData ( _
    msgId As Integer, _
    ParamArray data As Object() _
)
F#
member TraceWarningData :
        msgId:int *
        data:Object[] -> unit

Parameters

msgId
Type: System..::..Int32
Eine numerische Kennung für die Meldung.
data
Type: array< System..::..Object >[]()[][]
Die Daten.

See Also

BaseObject Class
DynamicNode.Model Namespace


BaseObject Properties

[image] [image]

DynamicNodes API
BaseObject Properties
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseObject type exposes the following members.

Properties

 | Name | Description
 | BaseTraceSource | Gibt die Standard-Ablaufverfolgungsquelle für DynamicNode.Model-Objekte zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest.
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück.
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest.
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest.
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück.
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück.
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest.
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen.

See Also

BaseObject Class
DynamicNode.Model Namespace


BaseTraceSource Property

[image]

DynamicNodes API
BaseObject..::..BaseTraceSource Property
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Standard-Ablaufverfolgungsquelle für DynamicNode.Model-Objekte zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static TraceSource BaseTraceSource { get; }
Visual Basic
Public Shared ReadOnly Property BaseTraceSource As TraceSource
    Get
F#
static member BaseTraceSource : TraceSource

See Also

BaseObject Class
DynamicNode.Model Namespace


Description Property

[image]

DynamicNodes API
BaseObject..::..Description Property
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Objektes zurück, oder legt sie fest.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
F#
abstract Description : string with get, set
override Description : string with get, set

Field Value

Die Beschreibung des Objektes.

Implements

IIdentifiable..::..Description

See Also

BaseObject Class
DynamicNode.Model Namespace


DescriptionDefaultValue Property

[image]

DynamicNodes API
BaseObject..::..DescriptionDefaultValue Property
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standardwert für die Eigenschaft Description zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual string DescriptionDefaultValue { get; }
Visual Basic
Protected Overridable ReadOnly Property DescriptionDefaultValue As String
    Get
F#
abstract DescriptionDefaultValue : string
override DescriptionDefaultValue : string

Field Value

Der Standardwert von Description.

See Also

BaseObject Class
DynamicNode.Model Namespace


Dirty Property

[image]

DynamicNodes API
BaseObject..::..Dirty Property
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool Dirty { get; set; }
Visual Basic
Public Property Dirty As Boolean
    Get
    Set
F#
abstract Dirty : bool with get, set
override Dirty : bool with get, set

Field Value

true, wenn der Zustand von dem letzten gespeicherten Zustand abweicht, sonst false.

Implements

IBaseObject..::..Dirty

See Also

BaseObject Class
DynamicNode.Model Namespace


Id Property

[image]

DynamicNodes API
BaseObject..::..Id Property
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Objektes zurück, oder legt sie fest.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int Id { get; set; }
Visual Basic
Public Property Id As Integer
    Get
    Set
F#
abstract Id : int with get, set
override Id : int with get, set

Field Value

Die ID des Objektes.

Implements

IIdentifiable..::..Id

See Also

BaseObject Class
DynamicNode.Model Namespace


IdDefaultValue Property

[image]

DynamicNodes API
BaseObject..::..IdDefaultValue Property
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standardwert für die Eigenschaft Id zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual int IdDefaultValue { get; }
Visual Basic
Protected Overridable ReadOnly Property IdDefaultValue As Integer
    Get
F#
abstract IdDefaultValue : int
override IdDefaultValue : int

Field Value

Der Standardwert von Id.

See Also

BaseObject Class
DynamicNode.Model Namespace


LocalTrace Property

[image]

DynamicNodes API
BaseObject..::..LocalTrace Property
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual TraceSource LocalTrace { get; }
Visual Basic
Protected Overridable ReadOnly Property LocalTrace As TraceSource
    Get
F#
abstract LocalTrace : TraceSource
override LocalTrace : TraceSource

See Also

BaseObject Class
DynamicNode.Model Namespace


Name Property

[image]

DynamicNodes API
BaseObject..::..Name Property
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Objektes zurück, oder legt ihn fest.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
F#
abstract Name : string with get, set
override Name : string with get, set

Field Value

Der Namen des Objektes.

Implements

IIdentifiable..::..Name

See Also

BaseObject Class
DynamicNode.Model Namespace


NameDefaultValue Property

[image]

DynamicNodes API
BaseObject..::..NameDefaultValue Property
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Standardwert für die Eigenschaft Name zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual string NameDefaultValue { get; }
Visual Basic
Protected Overridable ReadOnly Property NameDefaultValue As String
    Get
F#
abstract NameDefaultValue : string
override NameDefaultValue : string

Field Value

Der Standardwert von Name.

See Also

BaseObject Class
DynamicNode.Model Namespace


StoreIdentification Property

[image]

DynamicNodes API
BaseObject..::..StoreIdentification Property
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected bool StoreIdentification { get; set; }
Visual Basic
Protected Property StoreIdentification As Boolean
    Get
    Set
F#
member StoreIdentification : bool with get, set

Field Value

true wenn die Eigenschaften von IIdentifiable persistiert werden, sonst false.

See Also

BaseObject Class
DynamicNode.Model Namespace


BaseObject Events

[image] [image]

DynamicNodes API
BaseObject Events
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseObject type exposes the following members.

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde.
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde.
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde.
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde.

See Also

BaseObject Class
DynamicNode.Model Namespace


DescriptionChanged Event

[image]

DynamicNodes API
BaseObject..::..DescriptionChanged Event
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn Description geändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler DescriptionChanged
Visual Basic
Public Event DescriptionChanged As EventHandler
F#
abstract DescriptionChanged : IEvent<EventHandler,
    EventArgs>
override DescriptionChanged : IEvent<EventHandler,
    EventArgs>

Implements

IIdentifiable..::..DescriptionChanged

See Also

BaseObject Class
DynamicNode.Model Namespace


DirtyChanged Event

[image]

DynamicNodes API
BaseObject..::..DirtyChanged Event
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn Dirty geändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler DirtyChanged
Visual Basic
Public Event DirtyChanged As EventHandler
F#
abstract DirtyChanged : IEvent<EventHandler,
    EventArgs>
override DirtyChanged : IEvent<EventHandler,
    EventArgs>

Implements

IBaseObject..::..DirtyChanged

See Also

BaseObject Class
DynamicNode.Model Namespace


IdChanged Event

[image]

DynamicNodes API
BaseObject..::..IdChanged Event
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn Id geändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler IdChanged
Visual Basic
Public Event IdChanged As EventHandler
F#
abstract IdChanged : IEvent<EventHandler,
    EventArgs>
override IdChanged : IEvent<EventHandler,
    EventArgs>

Implements

IIdentifiable..::..IdChanged

See Also

BaseObject Class
DynamicNode.Model Namespace


NameChanged Event

[image]

DynamicNodes API
BaseObject..::..NameChanged Event
BaseObject Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn Name geändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler NameChanged
Visual Basic
Public Event NameChanged As EventHandler
F#
abstract NameChanged : IEvent<EventHandler,
    EventArgs>
override NameChanged : IEvent<EventHandler,
    EventArgs>

Implements

IIdentifiable..::..NameChanged

See Also

BaseObject Class
DynamicNode.Model Namespace


ChildEventArgs(TParent, TChild) Class

[image]

DynamicNodes API
ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignisdaten für das Hinzufügen oder Entfernen von Kindobjekten zu oder aus einem Elternobjekt.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class ChildEventArgs<TParent, TChild> : EventArgs
Visual Basic
Public Class ChildEventArgs(Of TParent, TChild) _
    Inherits EventArgs
F#
type ChildEventArgs<'TParent, 'TChild> =
    class
        inherit EventArgs
    end

Type Parameters

TParent
Der Type des Elternobjekts.
TChild
Der Type der Kindobjekte.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Model..::..ChildEventArgs<(Of <(<'TParent, TChild>)>)>

See Also

ChildEventArgs<(Of <(<'TParent, TChild>)>)> Members
DynamicNode.Model Namespace


ChildEventArgs(TParent, TChild) Members

[image] [image]

DynamicNodes API
ChildEventArgs<(Of <(<'TParent, TChild>)>)> Members
ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ChildEventArgs<(Of <(<'TParent, TChild>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ChildEventArgs<(Of <(<'TParent, TChild>)>)> | Initialisiert eine neue Instanz von ChildEventArgs<(Of <(<'TParent, TChild>)>)>.

Properties

 | Name | Description
Public property | Child | Gibt das betroffene Kindobjekt zurück.
Public property | Parent | Gibt das Elternobjekt, dem Kindobjekte hinzugefügt, oder aus dem Kindobjekte entfernt wurden.

See Also

ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class
DynamicNode.Model Namespace


ChildEventArgs(TParent, TChild) Constructor

[image]

DynamicNodes API
ChildEventArgs<(Of <(<'TParent, TChild>)>)> Constructor
ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ChildEventArgs<(Of <(<'TParent, TChild>)>)>.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public ChildEventArgs(
    TParent parent,
    TChild child
)
Visual Basic
Public Sub New ( _
    parent As TParent, _
    child As TChild _
)
F#
new :
        parent:'TParent *
        child:'TChild -> ChildEventArgs

Parameters

parent
Type: TParent
Das betroffene Elternobjekt.
child
Type: TChild
Das betroffene Kindobjekt.

See Also

ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class
DynamicNode.Model Namespace


ChildEventArgs(TParent, TChild) Properties

[image] [image]

DynamicNodes API
ChildEventArgs<(Of <(<'TParent, TChild>)>)> Properties
ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ChildEventArgs<(Of <(<'TParent, TChild>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Child | Gibt das betroffene Kindobjekt zurück.
Public property | Parent | Gibt das Elternobjekt, dem Kindobjekte hinzugefügt, oder aus dem Kindobjekte entfernt wurden.

See Also

ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class
DynamicNode.Model Namespace


Child Property

[image]

DynamicNodes API
ChildEventArgs<(Of <(<'TParent, TChild>)>)>..::..Child Property
ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das betroffene Kindobjekt zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TChild Child { get; private set; }
Visual Basic
Public Property Child As TChild
    Get
    Private Set
F#
member Child : 'TChild with get, private set

Field Value

Das betroffene Kindobjekt.

See Also

ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class
DynamicNode.Model Namespace


Parent Property

[image]

DynamicNodes API
ChildEventArgs<(Of <(<'TParent, TChild>)>)>..::..Parent Property
ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Elternobjekt, dem Kindobjekte hinzugefügt, oder aus dem Kindobjekte entfernt wurden.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TParent Parent { get; private set; }
Visual Basic
Public Property Parent As TParent
    Get
    Private Set
F#
member Parent : 'TParent with get, private set

Field Value

Das betroffene Elternobjekt.

See Also

ChildEventArgs<(Of <(<'TParent, TChild>)>)> Class
DynamicNode.Model Namespace


ChildObject(TParent, TSelf) Class

[image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardimplementierung für IParent<(Of <(<'TSelf, TChild>)>)>

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract class ChildObject<TParent, TSelf> : ExtensibleObject<TSelf>,
    IChild<TParent, TSelf>, IBaseObject, IIdentifiable, IStorable
where TParent : class, IParent<TSelf, TChild>
where TSelf : class, Object, IChild<TParent, TSelf>, IExtensible<TSelf>
Visual Basic
Public MustInherit Class ChildObject(Of TParent As {Class, IParent(Of TSelf, TChild)}, TSelf As {Class, Object, IChild(Of TParent, TSelf), IExtensible(Of TSelf)}) _
    Inherits ExtensibleObject(Of TSelf) _
    Implements IChild(Of TParent, TSelf), IBaseObject,  _
    IIdentifiable, IStorable
F#
[<AbstractClassAttribute>]
type ChildObject<'TParent, 'TSelf when 'TParent : not struct and IParent<'TSelf, 'TChild> when 'TSelf : not struct and Object and IChild<'TParent, 'TSelf> and IExtensible<'TSelf>> =
    class
        inherit ExtensibleObject<'TSelf>
        interface IChild<'TParent, 'TSelf>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
    end

Type Parameters

TParent
Der Type des Elternobjektes, in dem Objekte vom Type TSelf gespeichert werden sollen.
TSelf
Der Type, der von ChildObject<(Of <(<'TParent, TSelf>)>)> abgeleitet wird.

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<'TSelf>)>)>
DynamicNode.Model..::..ChildObject<(Of <(<'TParent, TSelf>)>)>
DynamicNode.Core..::..Port

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Members
DynamicNode.Model Namespace


ChildObject(TParent, TSelf) Members

[image] [image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)> Members
ChildObject<(Of <(<'TParent, TSelf>)>)> Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ChildObject<(Of <(<'TParent, TSelf>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | ChildObject<(Of <(<'TParent, TSelf>)>)> | Initializes a new instance of the ChildObject<(Of <(<'TParent, TSelf>)>)> class

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnDisposing()()()().)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from BaseObject.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from BaseObject.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from BaseObject.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from BaseObject.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde.

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
DynamicNode.Model Namespace


ChildObject(TParent, TSelf) Constructor

[image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)> Constructor
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the ChildObject<(Of <(<'TParent, TSelf>)>)> class

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected ChildObject()
Visual Basic
Protected Sub New
F#
new : unit -> ChildObject

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
DynamicNode.Model Namespace


ChildObject(TParent, TSelf) Methods

[image] [image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)> Methods
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ChildObject<(Of <(<'TParent, TSelf>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnDisposing()()()().)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from BaseObject.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from BaseObject.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
DynamicNode.Model Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..BeforeUseExtension Method
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
ChildObject<(Of <(<'TParent, TSelf>)>)> Members
DynamicNode.Model Namespace


MakeNameUnique Method

[image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..MakeNameUnique Method
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void MakeNameUnique(
    bool forceDefaultName
)
Visual Basic
Public Sub MakeNameUnique ( _
    forceDefaultName As Boolean _
)
F#
abstract MakeNameUnique :
        forceDefaultName:bool -> unit
override MakeNameUnique :
        forceDefaultName:bool -> unit

Parameters

forceDefaultName
Type: System..::..Boolean
Erzwingt dass der Name in den Standardnamen geändert wird, bevor er eindeutig gemacht wird.

Implements

IChild<(Of <(<'TParent, TSelf>)>)>..::..MakeNameUnique(Boolean)

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
DynamicNode.Model Namespace


OnDisposing Method

[image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..OnDisposing Method
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnDisposing()
Visual Basic
Protected Overrides Sub OnDisposing
F#
abstract OnDisposing : unit -> unit
override OnDisposing : unit -> unit

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
DynamicNode.Model Namespace


OnParentChanged Method

[image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..OnParentChanged Method
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnParentChanged()
Visual Basic
Protected Overridable Sub OnParentChanged
F#
abstract OnParentChanged : unit -> unit
override OnParentChanged : unit -> unit

Remarks

Wenn diese Methode überschrieben wird, muss in der abgeleiteten Version die Version der Elternklasse mit base.OnParentChanged() aufgerufen werden.

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
DynamicNode.Model Namespace


TraceError Method

[image] [image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..TraceError Method
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
ChildObject<(Of <(<'TParent, TSelf>)>)> Members
DynamicNode.Model Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..TraceInfo Method
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
ChildObject<(Of <(<'TParent, TSelf>)>)> Members
DynamicNode.Model Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..TraceVerbose Method
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
ChildObject<(Of <(<'TParent, TSelf>)>)> Members
DynamicNode.Model Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..TraceVerboseData Method
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
ChildObject<(Of <(<'TParent, TSelf>)>)> Members
DynamicNode.Model Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..TraceWarning Method
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
ChildObject<(Of <(<'TParent, TSelf>)>)> Members
DynamicNode.Model Namespace


ChildObject(TParent, TSelf) Properties

[image] [image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)> Properties
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ChildObject<(Of <(<'TParent, TSelf>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from BaseObject.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from BaseObject.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
DynamicNode.Model Namespace


Parent Property

[image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..Parent Property
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Elternobjekt zurück oder legt es fest.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TParent Parent { get; set; }
Visual Basic
Public Property Parent As TParent
    Get
    Set
F#
abstract Parent : 'TParent with get, set
override Parent : 'TParent with get, set

Field Value

Das Elternobjekt oder null, wenn sich das Objekt in keinem Elternobjekt befindet.

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
DynamicNode.Model Namespace


ChildObject(TParent, TSelf) Events

[image] [image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)> Events
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ChildObject<(Of <(<'TParent, TSelf>)>)> type exposes the following members.

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde.

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
DynamicNode.Model Namespace


ParentChanged Event

[image]

DynamicNodes API
ChildObject<(Of <(<'TParent, TSelf>)>)>..::..ParentChanged Event
ChildObject<(Of <(<'TParent, TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn Parent geändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler ParentChanged
Visual Basic
Public Event ParentChanged As EventHandler
F#
abstract ParentChanged : IEvent<EventHandler,
    EventArgs>
override ParentChanged : IEvent<EventHandler,
    EventArgs>

Implements

IChild<(Of <(<'TParent, TSelf>)>)>..::..ParentChanged

See Also

ChildObject<(Of <(<'TParent, TSelf>)>)> Class
DynamicNode.Model Namespace


ExtensibleObject(TSelf) Class

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein BaseObject das die Schnittstelle IExtensible<(Of <(<'T>)>)> implementiert.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract class ExtensibleObject<TSelf> : BaseObject,
    IExtensible<TSelf>, IDisposable
where TSelf : class, Object, IExtensible<TSelf>
Visual Basic
Public MustInherit Class ExtensibleObject(Of TSelf As {Class, Object, IExtensible(Of TSelf)}) _
    Inherits BaseObject _
    Implements IExtensible(Of TSelf), IDisposable
F#
[<AbstractClassAttribute>]
type ExtensibleObject<'TSelf when 'TSelf : not struct and Object and IExtensible<'TSelf>> =
    class
        inherit BaseObject
        interface IExtensible<'TSelf>
        interface IDisposable
    end

Type Parameters

TSelf
Der Type, der von ExtensibleObject<(Of <(<'TSelf>)>)> abgeleitet wird.

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject<(Of <(<'TSelf>)>)>
DynamicNode.Model..::..ChildObject<(Of <(<'TParent, TSelf>)>)>
DynamicNode.Model..::..ParentObject<(Of <(<'TSelf, TChild>)>)>

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Members
DynamicNode.Model Namespace


ExtensibleObject(TSelf) Members

[image] [image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)> Members
ExtensibleObject<(Of <(<'TSelf>)>)> Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ExtensibleObject<(Of <(<'TSelf>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | ExtensibleObject<(Of <(<'TSelf>)>)> | Initializes a new instance of the ExtensibleObject<(Of <(<'TSelf>)>)> class

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu.
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen.
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt.
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf.
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Overrides Object..::..Finalize()()()().)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück.
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück.
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück.
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist.
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird.
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird.
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus.
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from BaseObject.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from BaseObject.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde.
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from BaseObject.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from BaseObject.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird.
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


ExtensibleObject(TSelf) Constructor

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)> Constructor
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the ExtensibleObject<(Of <(<'TSelf>)>)> class

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected ExtensibleObject()
Visual Basic
Protected Sub New
F#
new : unit -> ExtensibleObject

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


ExtensibleObject(TSelf) Methods

[image] [image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)> Methods
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ExtensibleObject<(Of <(<'TSelf>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu.
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen.
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt.
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf.
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Overrides Object..::..Finalize()()()().)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück.
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück.
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück.
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück.
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist.
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird.
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird.
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from BaseObject.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus.
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from BaseObject.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from BaseObject.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


AttachExtension Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..AttachExtension Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt dem Objekt eine Erweiterung hinzu.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void AttachExtension(
    IExtension<TSelf> extension
)
Visual Basic
Public Sub AttachExtension ( _
    extension As IExtension(Of TSelf) _
)
F#
abstract AttachExtension :
        extension:IExtension<'TSelf> -> unit
override AttachExtension :
        extension:IExtension<'TSelf> -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' TSelf >)>)>
Eine Erweiterung.

Implements

IExtensible<(Of <(<'T>)>)>..::..AttachExtension(IExtension<(Of <<'(T>)>>))

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn eine Erweiterung mit der gleichen ID existiert.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..BeforeUseExtension Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen.
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
ExtensibleObject<(Of <(<'TSelf>)>)> Members
DynamicNode.Model Namespace


BeforeUseExtension Method (String)

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..BeforeUseExtension Method (String)
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void BeforeUseExtension(
    string extId
)
Visual Basic
Protected Overridable Sub BeforeUseExtension ( _
    extId As String _
)
F#
abstract BeforeUseExtension :
        extId:string -> unit
override BeforeUseExtension :
        extId:string -> unit

Parameters

extId
Type: System..::..String
Die gesuchte Erweiterungs-ID.

Remarks

Diese Methode wird aufgerufen, wenn IsExtensionSupported(String) oder GetExtension(String) aufgerufen wird. Sie wird nicht aufgerufen, wenn IsExtensionLoaded(String) aufgerufen wird.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
BeforeUseExtension Overload
DynamicNode.Model Namespace


BeforeUseExtension Method (Type)

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..BeforeUseExtension Method (Type)
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void BeforeUseExtension(
    Type extType
)
Visual Basic
Protected Overridable Sub BeforeUseExtension ( _
    extType As Type _
)
F#
abstract BeforeUseExtension :
        extType:Type -> unit
override BeforeUseExtension :
        extType:Type -> unit

Parameters

extType
Type: System..::..Type
Der Type der gesuchten Erweiterungen.

Remarks

Diese Methode wird aufgerufen, wenn GetExtensions(Type) augerufen wird.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
BeforeUseExtension Overload
DynamicNode.Model Namespace


DetachExtension Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..DetachExtension Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt eine Erweiterung von dem Objekt.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void DetachExtension(
    IExtension<TSelf> extension
)
Visual Basic
Public Sub DetachExtension ( _
    extension As IExtension(Of TSelf) _
)
F#
abstract DetachExtension :
        extension:IExtension<'TSelf> -> unit
override DetachExtension :
        extension:IExtension<'TSelf> -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' TSelf >)>)>
Eine Erweiterung.

Implements

IExtensible<(Of <(<'T>)>)>..::..DetachExtension(IExtension<(Of <<'(T>)>>))

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


Dispose Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..Dispose Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
F#
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposable..::..Dispose()()()()

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


Finalize Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..Finalize Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
F#
abstract Finalize : unit -> unit
override Finalize : unit -> unit

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


GetAllAttachedExtensions Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..GetAllAttachedExtensions Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle zur Zeit geladenen Erweiterungen zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IEnumerable<IExtension<TSelf>> GetAllAttachedExtensions()
Visual Basic
Public Function GetAllAttachedExtensions As IEnumerable(Of IExtension(Of TSelf))
F#
abstract GetAllAttachedExtensions : unit -> IEnumerable<IExtension<'TSelf>>
override GetAllAttachedExtensions : unit -> IEnumerable<IExtension<'TSelf>>

Return Value

Eine Aufzählung mit allen geladenen Erweiterungen.

Implements

IExtensible<(Of <(<'T>)>)>..::..GetAllAttachedExtensions()()()()

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


GetExtension Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..GetExtension Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine unterstützte Erweiterung anhand ihrer ID zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IExtension<TSelf> GetExtension(
    string extId
)
Visual Basic
Public Function GetExtension ( _
    extId As String _
) As IExtension(Of TSelf)
F#
abstract GetExtension :
        extId:string -> IExtension<'TSelf>
override GetExtension :
        extId:string -> IExtension<'TSelf>

Parameters

extId
Type: System..::..String
Die ID der gesuchten Erweiterung.

Return Value

Die Erweiterung.

Implements

IExtensible<(Of <(<'T>)>)>..::..GetExtension(String)

Remarks

Es wird BeforeUseExtension(String) aufgerufen. Dadurch wird die gesuchte Erweiterung evtl. geladen, falls sie nicht bereits geladen ist.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn null für extId übergeben wurde.
System..::..ArgumentException | Wird geworfen, wenn keine Erweiterung mit der übergebenen ID unterstützt wird.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


GetExtensions Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..GetExtensions Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle Erweiterungen eines Typs zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IEnumerable<IExtension<TSelf>> GetExtensions(
    Type extType
)
Visual Basic
Public Function GetExtensions ( _
    extType As Type _
) As IEnumerable(Of IExtension(Of TSelf))
F#
abstract GetExtensions :
        extType:Type -> IEnumerable<IExtension<'TSelf>>
override GetExtensions :
        extType:Type -> IEnumerable<IExtension<'TSelf>>

Parameters

extType
Type: System..::..Type
Der Datentyp der gesuchten Erweiterungen.

Return Value

Ein Array mit allen Erweiterungen vom Typ extType.

Implements

IExtensible<(Of <(<'T>)>)>..::..GetExtensions(Type)

Remarks

Ruft BeforeUseExtension(Type) auf.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn null für extType übergeben wurde.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


GetLoadedExtension Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..GetLoadedExtension Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine geladene Erweiterung anhand ihrer ID zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IExtension<TSelf> GetLoadedExtension(
    string extId
)
Visual Basic
Public Function GetLoadedExtension ( _
    extId As String _
) As IExtension(Of TSelf)
F#
abstract GetLoadedExtension :
        extId:string -> IExtension<'TSelf>
override GetLoadedExtension :
        extId:string -> IExtension<'TSelf>

Parameters

extId
Type: System..::..String
Die ID der gesuchten Erweiterung.

Return Value

Die Erweiterung.

Implements

IExtensible<(Of <(<'T>)>)>..::..GetLoadedExtension(String)

Remarks

Es werden nur Erweiterungen zurückgegeben, die bereits geladen sind. Es wird nicht BeforeUseExtension(String) aufgerufen, um Erweiterungen nachzuladen.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn null für extId übergeben wurde.
System..::..ArgumentException | Wird geworfen, wenn keine Erweiterung mit der übergebenen ID existiert.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


IsExtensionLoaded Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..IsExtensionLoaded Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob eine Erweiterung geladen ist.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsExtensionLoaded(
    string extId
)
Visual Basic
Public Function IsExtensionLoaded ( _
    extId As String _
) As Boolean
F#
abstract IsExtensionLoaded :
        extId:string -> bool
override IsExtensionLoaded :
        extId:string -> bool

Parameters

extId
Type: System..::..String
Die ID der Erweiterung.

Return Value

true, wenn die Erweiterung geladen ist, sonst false.

Implements

IExtensible<(Of <(<'T>)>)>..::..IsExtensionLoaded(String)

Remarks

Falls false zurückgegeben wird, bedeutet das noch nicht, dass die gesuchte Erweiterung von dem Objekt nicht unterstützt wird. Um die Unterstützung für eine Erweiterung zu ermitteln, dient IsExtensionSupported(String).

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn null für extId übergeben wurde.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


IsExtensionSupported Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..IsExtensionSupported Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsExtensionSupported(
    string extId
)
Visual Basic
Public Function IsExtensionSupported ( _
    extId As String _
) As Boolean
F#
abstract IsExtensionSupported :
        extId:string -> bool
override IsExtensionSupported :
        extId:string -> bool

Parameters

extId
Type: System..::..String
Die ID der Erweiterung.

Return Value

true, wenn die Erweiterung unterstützt wird, sonst false.

Implements

IExtensible<(Of <(<'T>)>)>..::..IsExtensionSupported(String)

Remarks

Es wird BeforeUseExtension(String) aufgerufen. Dadurch wird die gesuchte Erweiterung evtl. geladen, falls sie nicht bereits geladen ist.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn null für extId übergeben wurde.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


OnAttachExtension Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnAttachExtension Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnAttachExtension(
    IExtension<TSelf> extension,
    bool successful
)
Visual Basic
Protected Overridable Sub OnAttachExtension ( _
    extension As IExtension(Of TSelf), _
    successful As Boolean _
)
F#
abstract OnAttachExtension :
        extension:IExtension<'TSelf> *
        successful:bool -> unit
override OnAttachExtension :
        extension:IExtension<'TSelf> *
        successful:bool -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' TSelf >)>)>
Die Erweiterung.
successful
Type: System..::..Boolean
true wenn die Erweiterung erfolgreich registriert werden konnte, andernfalls false.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


OnDetachExtension Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnDetachExtension Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn eine Erweiterung entfernt wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnDetachExtension(
    IExtension<TSelf> extension
)
Visual Basic
Protected Overridable Sub OnDetachExtension ( _
    extension As IExtension(Of TSelf) _
)
F#
abstract OnDetachExtension :
        extension:IExtension<'TSelf> -> unit
override OnDetachExtension :
        extension:IExtension<'TSelf> -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' TSelf >)>)>
Die Erweiterung.

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


OnDisposing Method

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnDisposing Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnDisposing()
Visual Basic
Protected Overridable Sub OnDisposing
F#
abstract OnDisposing : unit -> unit
override OnDisposing : unit -> unit

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


TraceError Method

[image] [image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..TraceError Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
ExtensibleObject<(Of <(<'TSelf>)>)> Members
DynamicNode.Model Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..TraceInfo Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
ExtensibleObject<(Of <(<'TSelf>)>)> Members
DynamicNode.Model Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..TraceVerbose Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
ExtensibleObject<(Of <(<'TSelf>)>)> Members
DynamicNode.Model Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..TraceVerboseData Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
ExtensibleObject<(Of <(<'TSelf>)>)> Members
DynamicNode.Model Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..TraceWarning Method
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
ExtensibleObject<(Of <(<'TSelf>)>)> Members
DynamicNode.Model Namespace


ExtensibleObject(TSelf) Properties

[image] [image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)> Properties
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ExtensibleObject<(Of <(<'TSelf>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde.
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from BaseObject.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from BaseObject.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


IsDisposed Property

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..IsDisposed Property
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool IsDisposed { get; private set; }
Visual Basic
Public Property IsDisposed As Boolean
    Get
    Private Set
F#
abstract IsDisposed : bool with get, private set
override IsDisposed : bool with get, private set

Field Value

true, wenn diese Instanz entsorgt wurde, sonst false.

Implements

IExtensible<(Of <(<'T>)>)>..::..IsDisposed

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


ExtensibleObject(TSelf) Events

[image] [image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)> Events
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ExtensibleObject<(Of <(<'TSelf>)>)> type exposes the following members.

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird.
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


Disposing Event

[image]

DynamicNodes API
ExtensibleObject<(Of <(<'TSelf>)>)>..::..Disposing Event
ExtensibleObject<(Of <(<'TSelf>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn das Objekt entsorgt wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler Disposing
Visual Basic
Public Event Disposing As EventHandler
F#
abstract Disposing : IEvent<EventHandler,
    EventArgs>
override Disposing : IEvent<EventHandler,
    EventArgs>

Implements

IExtensible<(Of <(<'T>)>)>..::..Disposing

See Also

ExtensibleObject<(Of <(<'TSelf>)>)> Class
DynamicNode.Model Namespace


HierarchyObject(TParent, TSelf, TChild) Class

[image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardimplementierung für Objekte, die sowohl IChild<(Of <(<'TParent, TSelf>)>)>, als auch IParent<(Of <(<'TSelf, TChild>)>)> implementieren sollen.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract class HierarchyObject<TParent, TSelf, TChild> : ParentObject<TSelf, TChild>,
    IChild<TParent, TSelf>, IBaseObject, IIdentifiable, IStorable
where TParent : class, IParent<TSelf, TChild>
where TSelf : class, Object, IChild<TParent, TSelf>, IParent<TSelf, TChild>, IExtensible<TSelf>
where TChild : class, Object, IChild<TSelf, TChild>
Visual Basic
Public MustInherit Class HierarchyObject(Of TParent As {Class, IParent(Of TSelf, TChild)}, TSelf As {Class, Object, IChild(Of TParent, TSelf), IParent(Of TSelf, TChild), IExtensible(Of TSelf)}, TChild As {Class, Object, IChild(Of TSelf, TChild)}) _
    Inherits ParentObject(Of TSelf, TChild) _
    Implements IChild(Of TParent, TSelf), IBaseObject,  _
    IIdentifiable, IStorable
F#
[<AbstractClassAttribute>]
type HierarchyObject<'TParent, 'TSelf, 'TChild when 'TParent : not struct and IParent<'TSelf, 'TChild> when 'TSelf : not struct and Object and IChild<'TParent, 'TSelf> and IParent<'TSelf, 'TChild> and IExtensible<'TSelf> when 'TChild : not struct and Object and IChild<'TSelf, 'TChild>> =
    class
        inherit ParentObject<'TSelf, 'TChild>
        interface IChild<'TParent, 'TSelf>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
    end

Type Parameters

TParent
Der Type des Elternobjektes, in dem Objekte vom Type TSelf gespeichert werden sollen.
TSelf
Der Type, der von HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> abgeleitet wird.
TChild
Der Type der Kindobjekte, die in Objekten vom Type TSelf gespeichert werden sollen.

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<'TSelf>)>)>
DynamicNode.Model..::..ParentObject <(Of <(<'TSelf, TChild>)>)>
DynamicNode.Model..::..HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>
DynamicNode.Core..::..Graph
DynamicNode.Core..::..Node

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


HierarchyObject(TParent, TSelf, TChild) Members

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Members
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> | Initializes a new instance of the HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> class

Methods

 | Name | Description
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnDisposing()()()().)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

Properties

 | Name | Description
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from BaseObject.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from BaseObject.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde.

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


HierarchyObject(TParent, TSelf, TChild) Constructor

[image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Constructor
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> class

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected HierarchyObject()
Visual Basic
Protected Sub New
F#
new : unit -> HierarchyObject

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


HierarchyObject(TParent, TSelf, TChild) Methods

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Methods
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist.
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Overrides ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnDisposing()()()().)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Protected method | OnParentChanged | Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..BeforeUseExtension Method
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


MakeNameUnique Method

[image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..MakeNameUnique Method
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void MakeNameUnique(
    bool forceDefaultName
)
Visual Basic
Public Sub MakeNameUnique ( _
    forceDefaultName As Boolean _
)
F#
abstract MakeNameUnique :
        forceDefaultName:bool -> unit
override MakeNameUnique :
        forceDefaultName:bool -> unit

Parameters

forceDefaultName
Type: System..::..Boolean
Erzwingt dass der Name in den Standardnamen geändert wird, bevor er eindeutig gemacht wird.

Implements

IChild<(Of <(<'TParent, TSelf>)>)>..::..MakeNameUnique(Boolean)

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


OnDisposing Method

[image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..OnDisposing Method
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnDisposing()
Visual Basic
Protected Overrides Sub OnDisposing
F#
abstract OnDisposing : unit -> unit
override OnDisposing : unit -> unit

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


OnParentChanged Method

[image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..OnParentChanged Method
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn Parent geändert wurde. Löst das Ereignis ParentChanged aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnParentChanged()
Visual Basic
Protected Overridable Sub OnParentChanged
F#
abstract OnParentChanged : unit -> unit
override OnParentChanged : unit -> unit

Remarks

Wenn diese Methode überschrieben wird, muss in der abgeleiteten Version die Version der Elternklasse mit base.OnParentChanged() aufgerufen werden.

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


TraceError Method

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..TraceError Method
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..TraceInfo Method
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..TraceVerbose Method
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..TraceVerboseData Method
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..TraceWarning Method
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


HierarchyObject(TParent, TSelf, TChild) Properties

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Properties
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> type exposes the following members.

Properties

 | Name | Description
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from BaseObject.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from BaseObject.)
Public property | Parent | Gibt das Elternobjekt zurück, oder legt es fest.
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


Item Property

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..Item Property
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


Parent Property

[image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..Parent Property
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Elternobjekt zurück, oder legt es fest.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TParent Parent { get; set; }
Visual Basic
Public Property Parent As TParent
    Get
    Set
F#
abstract Parent : 'TParent with get, set
override Parent : 'TParent with get, set

Field Value

Das Elternobjekt.

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


HierarchyObject(TParent, TSelf, TChild) Events

[image] [image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Events
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> type exposes the following members.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde. (Inherited from ParentObject<(Of <(<'TSelf, TChild>)>)>.)
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wurde.

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


ParentChanged Event

[image]

DynamicNodes API
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>..::..ParentChanged Event
HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn Parent geändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler ParentChanged
Visual Basic
Public Event ParentChanged As EventHandler
F#
abstract ParentChanged : IEvent<EventHandler,
    EventArgs>
override ParentChanged : IEvent<EventHandler,
    EventArgs>

Implements

IChild<(Of <(<'TParent, TSelf>)>)>..::..ParentChanged

See Also

HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


IBaseObject Interface

[image]

DynamicNodes API
IBaseObject Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basis-Schnittstelle für Objekte in der DynamicNodes-Laufzeitumgebung. Sie ist abgeleitet von IIdentifiable und IStorable.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IBaseObject : IIdentifiable,
    IStorable
Visual Basic
Public Interface IBaseObject _
    Inherits IIdentifiable, IStorable
F#
type IBaseObject =
    interface
        interface IIdentifiable
        interface IStorable
    end

See Also

IBaseObject Members
DynamicNode.Model Namespace


IBaseObject Members

[image] [image]

DynamicNodes API
IBaseObject Members
IBaseObject Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IBaseObject type exposes the following members.

Methods

 | Name | Description
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde.
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde.
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)

See Also

IBaseObject Interface
DynamicNode.Model Namespace


IBaseObject Methods

[image] [image]

DynamicNodes API
IBaseObject Methods
IBaseObject Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IBaseObject type exposes the following members.

Methods

 | Name | Description
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)

See Also

IBaseObject Interface
DynamicNode.Model Namespace


IBaseObject Properties

[image] [image]

DynamicNodes API
IBaseObject Properties
IBaseObject Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IBaseObject type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde.
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)

See Also

IBaseObject Interface
DynamicNode.Model Namespace


Dirty Property

[image]

DynamicNodes API
IBaseObject..::..Dirty Property
IBaseObject Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool Dirty { get; set; }
Visual Basic
Property Dirty As Boolean
    Get
    Set
F#
abstract Dirty : bool with get, set

Field Value

true, wenn der Zustand des Objektes nicht mit dem letzten gespeicherten Zustand übereinstimmt, sonst false.

See Also

IBaseObject Interface
DynamicNode.Model Namespace


IBaseObject Events

[image] [image]

DynamicNodes API
IBaseObject Events
IBaseObject Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IBaseObject type exposes the following members.

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde.
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)

See Also

IBaseObject Interface
DynamicNode.Model Namespace


DirtyChanged Event

[image]

DynamicNodes API
IBaseObject..::..DirtyChanged Event
IBaseObject Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler DirtyChanged
Visual Basic
Event DirtyChanged As EventHandler
F#
abstract DirtyChanged : IEvent<EventHandler,
    EventArgs>

See Also

IBaseObject Interface
DynamicNode.Model Namespace


IChild(TParent, TSelf) Interface

[image]

DynamicNodes API
IChild<(Of <(<'TParent, TSelf>)>)> Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für Objekte in der DynamicNodes-Laufzeitumgebung, die in einem Elternobjekt (IParent<(Of <(<'TSelf, TChild>)>)>) gesammelt werden können.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IChild<TParent, TSelf> : IBaseObject,
    IIdentifiable, IStorable
where TParent : class
where TSelf : class, Object, IChild<TParent, TSelf>
Visual Basic
Public Interface IChild(Of TParent As Class, TSelf As {Class, Object, IChild(Of TParent, TSelf)}) _
    Inherits IBaseObject, IIdentifiable, IStorable
F#
type IChild<'TParent, 'TSelf when 'TParent : not struct when 'TSelf : not struct and Object and IChild<'TParent, 'TSelf>> =
    interface
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
    end

Type Parameters

TParent
Der Type des Elternobjektes, in dem Objekte vom Type TSelf gespeichert werden sollen.
TSelf
Der Type, der diese Schnittstelle implementiert.

See Also

IChild<(Of <(<'TParent, TSelf>)>)> Members
DynamicNode.Model Namespace


IChild(TParent, TSelf) Members

[image] [image]

DynamicNodes API
IChild<(Of <(<'TParent, TSelf>)>)> Members
IChild<(Of <(<'TParent, TSelf>)>)> Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IChild<(Of <(<'TParent, TSelf>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest.

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wird.

See Also

IChild<(Of <(<'TParent, TSelf>)>)> Interface
DynamicNode.Model Namespace


IChild(TParent, TSelf) Methods

[image] [image]

DynamicNodes API
IChild<(Of <(<'TParent, TSelf>)>)> Methods
IChild<(Of <(<'TParent, TSelf>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IChild<(Of <(<'TParent, TSelf>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | MakeNameUnique | Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)

See Also

IChild<(Of <(<'TParent, TSelf>)>)> Interface
DynamicNode.Model Namespace


MakeNameUnique Method

[image]

DynamicNodes API
IChild<(Of <(<'TParent, TSelf>)>)>..::..MakeNameUnique Method
IChild<(Of <(<'TParent, TSelf>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sorgt dafür, dass der Name des Kindobjektes innerhalb seines Elternobjektes eindeutig ist.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void MakeNameUnique(
    bool forceDefaultName
)
Visual Basic
Sub MakeNameUnique ( _
    forceDefaultName As Boolean _
)
F#
abstract MakeNameUnique :
        forceDefaultName:bool -> unit

Parameters

forceDefaultName
Type: System..::..Boolean
Erzwingt dass der Name in den Standardnamen geändert wird, bevor er eindeutig gemacht wird.

See Also

IChild<(Of <(<'TParent, TSelf>)>)> Interface
DynamicNode.Model Namespace


IChild(TParent, TSelf) Properties

[image] [image]

DynamicNodes API
IChild<(Of <(<'TParent, TSelf>)>)> Properties
IChild<(Of <(<'TParent, TSelf>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IChild<(Of <(<'TParent, TSelf>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Parent | Gibt das Elternobjekt zurück oder legt es fest.

See Also

IChild<(Of <(<'TParent, TSelf>)>)> Interface
DynamicNode.Model Namespace


Parent Property

[image]

DynamicNodes API
IChild<(Of <(<'TParent, TSelf>)>)>..::..Parent Property
IChild<(Of <(<'TParent, TSelf>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Elternobjekt zurück oder legt es fest.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
TParent Parent { get; set; }
Visual Basic
Property Parent As TParent
    Get
    Set
F#
abstract Parent : 'TParent with get, set

Field Value

Das Elternobjekt oder null, wenn sich das Objekt in keinem Elternobjekt befindet.

See Also

IChild<(Of <(<'TParent, TSelf>)>)> Interface
DynamicNode.Model Namespace


IChild(TParent, TSelf) Events

[image] [image]

DynamicNodes API
IChild<(Of <(<'TParent, TSelf>)>)> Events
IChild<(Of <(<'TParent, TSelf>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IChild<(Of <(<'TParent, TSelf>)>)> type exposes the following members.

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | ParentChanged | Wird ausgelöst, wenn Parent geändert wird.

See Also

IChild<(Of <(<'TParent, TSelf>)>)> Interface
DynamicNode.Model Namespace


ParentChanged Event

[image]

DynamicNodes API
IChild<(Of <(<'TParent, TSelf>)>)>..::..ParentChanged Event
IChild<(Of <(<'TParent, TSelf>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn Parent geändert wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler ParentChanged
Visual Basic
Event ParentChanged As EventHandler
F#
abstract ParentChanged : IEvent<EventHandler,
    EventArgs>

See Also

IChild<(Of <(<'TParent, TSelf>)>)> Interface
DynamicNode.Model Namespace


IExtensible(T) Interface

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine generische Schnittstelle für erweiterbare Objekte.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IExtensible<T> : IDisposable
Visual Basic
Public Interface IExtensible(Of T) _
    Inherits IDisposable
F#
type IExtensible<'T> =
    interface
        interface IDisposable
    end

Type Parameters

T
Der Typ des zu erweiternden Objekts.

See Also

IExtensible<(Of <(<'T>)>)> Members
DynamicNode.Model Namespace


IExtensible(T) Members

[image] [image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)> Members
IExtensible<(Of <(<'T>)>)> Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IExtensible<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt.
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück.
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück.
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück.
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück.
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist.
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist.

Properties

 | Name | Description
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde.

Events

 | Name | Description
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IExtensible(T) Methods

[image] [image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)> Methods
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IExtensible<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt.
Public method | GetAllAttachedExtensions | Gibt alle Erweiterungen zurück.
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück.
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück.
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück.
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist.
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


AttachExtension Method

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)>..::..AttachExtension Method
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt dem Objekt eine Erweiterung hinzu.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void AttachExtension(
    IExtension<T> extension
)
Visual Basic
Sub AttachExtension ( _
    extension As IExtension(Of T) _
)
F#
abstract AttachExtension :
        extension:IExtension<'T> -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' T >)>)>
Eine Erweiterung.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn eine Erweiterung mit der gleichen ID existiert.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


DetachExtension Method

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)>..::..DetachExtension Method
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt eine Erweiterung von dem Objekt.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void DetachExtension(
    IExtension<T> extension
)
Visual Basic
Sub DetachExtension ( _
    extension As IExtension(Of T) _
)
F#
abstract DetachExtension :
        extension:IExtension<'T> -> unit

Parameters

extension
Type: DynamicNode.Model..::..IExtension <(Of <(<' T >)>)>
Eine Erweiterung.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


GetAllAttachedExtensions Method

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)>..::..GetAllAttachedExtensions Method
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle Erweiterungen zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IEnumerable<IExtension<T>> GetAllAttachedExtensions()
Visual Basic
Function GetAllAttachedExtensions As IEnumerable(Of IExtension(Of T))
F#
abstract GetAllAttachedExtensions : unit -> IEnumerable<IExtension<'T>>

Return Value

Eine Aufzählung mit allen Erweiterungen.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


GetExtension Method

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)>..::..GetExtension Method
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine unterstützte Erweiterung anhand ihrer ID zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IExtension<T> GetExtension(
    string extId
)
Visual Basic
Function GetExtension ( _
    extId As String _
) As IExtension(Of T)
F#
abstract GetExtension :
        extId:string -> IExtension<'T>

Parameters

extId
Type: System..::..String
Die ID der gesuchten Erweiterung.

Return Value

Die Erweiterung.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn keine Erweiterung mit der übergebenen ID unterstützt wird.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


GetExtensions Method

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)>..::..GetExtensions Method
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle Erweiterungen eines Typs zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IEnumerable<IExtension<T>> GetExtensions(
    Type extType
)
Visual Basic
Function GetExtensions ( _
    extType As Type _
) As IEnumerable(Of IExtension(Of T))
F#
abstract GetExtensions :
        extType:Type -> IEnumerable<IExtension<'T>>

Parameters

extType
Type: System..::..Type
Der Datentyp der gesuchten Erweiterungen.

Return Value

Ein Array mit allen Erweiterungen vom Typ extType.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


GetLoadedExtension Method

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)>..::..GetLoadedExtension Method
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine geladene Erweiterung anhand ihrer ID zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IExtension<T> GetLoadedExtension(
    string extId
)
Visual Basic
Function GetLoadedExtension ( _
    extId As String _
) As IExtension(Of T)
F#
abstract GetLoadedExtension :
        extId:string -> IExtension<'T>

Parameters

extId
Type: System..::..String
Die ID der gesuchten Erweiterung.

Return Value

Die Erweiterung.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn null für extId übergeben wurde.
System..::..ArgumentException | Wird geworfen, wenn keine Erweiterung mit der übergebenen ID existiert.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IsExtensionLoaded Method

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)>..::..IsExtensionLoaded Method
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob eine Erweiterung geladen ist.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsExtensionLoaded(
    string extId
)
Visual Basic
Function IsExtensionLoaded ( _
    extId As String _
) As Boolean
F#
abstract IsExtensionLoaded :
        extId:string -> bool

Parameters

extId
Type: System..::..String
Die ID der Erweiterung.

Return Value

true, wenn die Erweiterung geladen ist, sonst false.

Remarks

Falls false zurückgegeben wird, bedeutet das noch nicht, dass die gesuchte Erweiterung von dem Objekt nicht unterstützt wird. Um die Unterstützung für eine Erweiterung zu ermitteln, dient IsExtensionSupported(String).

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IsExtensionSupported Method

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)>..::..IsExtensionSupported Method
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ermittelt ob eine Erweiterung unterstützt wird und lädt sie nach, falls sie zur Zeit nicht geladen ist.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsExtensionSupported(
    string extId
)
Visual Basic
Function IsExtensionSupported ( _
    extId As String _
) As Boolean
F#
abstract IsExtensionSupported :
        extId:string -> bool

Parameters

extId
Type: System..::..String
Die ID der Erweiterung.

Return Value

true, wenn die Erweiterung unterstützt wird, sonst false.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IExtensible(T) Properties

[image] [image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)> Properties
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IExtensible<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IsDisposed Property

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)>..::..IsDisposed Property
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsDisposed { get; }
Visual Basic
ReadOnly Property IsDisposed As Boolean
    Get
F#
abstract IsDisposed : bool

Field Value

true, wenn diese Instanz entsorgt wurde, sonst false.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IExtensible(T) Events

[image] [image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)> Events
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IExtensible<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird.

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


Disposing Event

[image]

DynamicNodes API
IExtensible<(Of <(<'T>)>)>..::..Disposing Event
IExtensible<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn das Objekt entsorgt wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler Disposing
Visual Basic
Event Disposing As EventHandler
F#
abstract Disposing : IEvent<EventHandler,
    EventArgs>

See Also

IExtensible<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IExtension(T) Interface

[image]

DynamicNodes API
IExtension<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die generischen Schnittstelle für Erweiterungen.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IExtension<T> : IStorable
Visual Basic
Public Interface IExtension(Of T) _
    Inherits IStorable
F#
type IExtension<'T> =
    interface
        interface IStorable
    end

Type Parameters

T
Die Klasse der Objekte, welche erweitert werden sollen.

See Also

IExtension<(Of <(<'T>)>)> Members
DynamicNode.Model Namespace


IExtension(T) Members

[image] [image]

DynamicNodes API
IExtension<(Of <(<'T>)>)> Members
IExtension<(Of <(<'T>)>)> Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IExtension<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

See Also

IExtension<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IExtension(T) Methods

[image] [image]

DynamicNodes API
IExtension<(Of <(<'T>)>)> Methods
IExtension<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IExtension<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AfterAttaching | Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.
Public method | AfterDetaching | Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.
Public method | AfterRestoring | Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)

See Also

IExtension<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


AfterAttaching Method

[image]

DynamicNodes API
IExtension<(Of <(<'T>)>)>..::..AfterAttaching Method
IExtension<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung einem Objekt angefügt wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void AfterAttaching(
    T g
)
Visual Basic
Sub AfterAttaching ( _
    g As T _
)
F#
abstract AfterAttaching :
        g:'T -> unit

Parameters

g
Type: T
Das Objekt

See Also

IExtension<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


AfterDetaching Method

[image]

DynamicNodes API
IExtension<(Of <(<'T>)>)>..::..AfterDetaching Method
IExtension<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen nachdem die Erweiterung von einem Objekt entfernt wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void AfterDetaching(
    T o
)
Visual Basic
Sub AfterDetaching ( _
    o As T _
)
F#
abstract AfterDetaching :
        o:'T -> unit

Parameters

o
Type: T
Das Objekt

See Also

IExtension<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


AfterRestoring Method

[image]

DynamicNodes API
IExtension<(Of <(<'T>)>)>..::..AfterRestoring Method
IExtension<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, nachdem die Erweiterung wieder hergestellt wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void AfterRestoring()
Visual Basic
Sub AfterRestoring
F#
abstract AfterRestoring : unit -> unit

See Also

IExtension<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IExtension(T) Properties

[image] [image]

DynamicNodes API
IExtension<(Of <(<'T>)>)> Properties
IExtension<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IExtension<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.
Public property | IsUsingStorage | Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

See Also

IExtension<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


Id Property

[image]

DynamicNodes API
IExtension<(Of <(<'T>)>)>..::..Id Property
IExtension<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine ID zurück, welche im Kontext des Objektes, zu dem die Erweiterung gehört, eindeutig ist.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string Id { get; }
Visual Basic
ReadOnly Property Id As String
    Get
F#
abstract Id : string

Field Value

Die ID der Erweiterung.

See Also

IExtension<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IsUsingStorage Property

[image]

DynamicNodes API
IExtension<(Of <(<'T>)>)>..::..IsUsingStorage Property
IExtension<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob die Erweiterung einen Eigenschaftsspeicher benutzt.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool IsUsingStorage { get; }
Visual Basic
ReadOnly Property IsUsingStorage As Boolean
    Get
F#
abstract IsUsingStorage : bool

Field Value

true wenn Eigenschaften gespeichert werden sollen, sonst false.

See Also

IExtension<(Of <(<'T>)>)> Interface
DynamicNode.Model Namespace


IIdentifiable Interface

[image]

DynamicNodes API
IIdentifiable Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Diese Schnittstelle kann für Klassen verwendet werden, deren Objekte einen Namen und eine ID besitzen.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IIdentifiable
Visual Basic
Public Interface IIdentifiable
F#
type IIdentifiable =  interface end

See Also

IIdentifiable Members
DynamicNode.Model Namespace


IIdentifiable Members

[image] [image]

DynamicNodes API
IIdentifiable Members
IIdentifiable Interface Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IIdentifiable type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest.
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest.
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest.

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde.
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde.
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde.

See Also

IIdentifiable Interface
DynamicNode.Model Namespace


IIdentifiable Properties

[image] [image]

DynamicNodes API
IIdentifiable Properties
IIdentifiable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IIdentifiable type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest.
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest.
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest.

See Also

IIdentifiable Interface
DynamicNode.Model Namespace


Description Property

[image]

DynamicNodes API
IIdentifiable..::..Description Property
IIdentifiable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Objektes zurück oder legt sie fest.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string Description { get; set; }
Visual Basic
Property Description As String
    Get
    Set
F#
abstract Description : string with get, set

Field Value

Die Beschreibung des Objektes.

See Also

IIdentifiable Interface
DynamicNode.Model Namespace


Id Property

[image]

DynamicNodes API
IIdentifiable..::..Id Property
IIdentifiable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Objektes zurück oder legt sie fest.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
int Id { get; set; }
Visual Basic
Property Id As Integer
    Get
    Set
F#
abstract Id : int with get, set

Field Value

Die ID des Objektes.

See Also

IIdentifiable Interface
DynamicNode.Model Namespace


Name Property

[image]

DynamicNodes API
IIdentifiable..::..Name Property
IIdentifiable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Objektes zurück oder legt sie fest.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string Name { get; set; }
Visual Basic
Property Name As String
    Get
    Set
F#
abstract Name : string with get, set

Field Value

Der Name des Objektes.

See Also

IIdentifiable Interface
DynamicNode.Model Namespace


IIdentifiable Events

[image] [image]

DynamicNodes API
IIdentifiable Events
IIdentifiable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IIdentifiable type exposes the following members.

Events

 | Name | Description
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde.
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde.
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde.

See Also

IIdentifiable Interface
DynamicNode.Model Namespace


DescriptionChanged Event

[image]

DynamicNodes API
IIdentifiable..::..DescriptionChanged Event
IIdentifiable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler DescriptionChanged
Visual Basic
Event DescriptionChanged As EventHandler
F#
abstract DescriptionChanged : IEvent<EventHandler,
    EventArgs>

See Also

IIdentifiable Interface
DynamicNode.Model Namespace


IdChanged Event

[image]

DynamicNodes API
IIdentifiable..::..IdChanged Event
IIdentifiable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn die ID des Objektes geändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler IdChanged
Visual Basic
Event IdChanged As EventHandler
F#
abstract IdChanged : IEvent<EventHandler,
    EventArgs>

See Also

IIdentifiable Interface
DynamicNode.Model Namespace


NameChanged Event

[image]

DynamicNodes API
IIdentifiable..::..NameChanged Event
IIdentifiable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Name des Objektes geändert wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler NameChanged
Visual Basic
Event NameChanged As EventHandler
F#
abstract NameChanged : IEvent<EventHandler,
    EventArgs>

See Also

IIdentifiable Interface
DynamicNode.Model Namespace


IParent(TSelf, TChild) Interface

[image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)> Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für Objekte in der DynamicNodes-Laufzeitumgbung, in denen Kindobjekte (IChild<(Of <(<'TParent, TSelf>)>)>) gesammelt werden können.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IParent<TSelf, TChild> : IBaseObject,
    IIdentifiable, IStorable
where TSelf : class, Object, IParent<TSelf, TChild>
where TChild : class
Visual Basic
Public Interface IParent(Of TSelf As {Class, Object, IParent(Of TSelf, TChild)}, TChild As Class) _
    Inherits IBaseObject, IIdentifiable, IStorable
F#
type IParent<'TSelf, 'TChild when 'TSelf : not struct and Object and IParent<'TSelf, 'TChild> when 'TChild : not struct> =
    interface
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
    end

Type Parameters

TSelf
Der Type, der diese Schnittstelle implementiert.
TChild
Der Type der Kindobjekte, die in Objekten vom Type TSelf gespeichert werden sollen.

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


IParent(TSelf, TChild) Members

[image] [image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)> Members
IParent<(Of <(<'TSelf, TChild>)>)> Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IParent<(Of <(<'TSelf, TChild>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt.
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt.
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück.
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück.

Properties

 | Name | Description
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Item | Gibt ein Kindobjekt anhand seines Name zurück.
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde.
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde.
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


IParent(TSelf, TChild) Methods

[image] [image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)> Methods
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IParent<(Of <(<'TSelf, TChild>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt.
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt.
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück.
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind.
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Inherited from IStorable.)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Inherited from IStorable.)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück.

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


ContainsChildWithId Method

[image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)>..::..ContainsChildWithId Method
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool ContainsChildWithId(
    int id
)
Visual Basic
Function ContainsChildWithId ( _
    id As Integer _
) As Boolean
F#
abstract ContainsChildWithId :
        id:int -> bool

Parameters

id
Type: System..::..Int32
Die gesuchte ID.

Return Value

true, falls das Elternobjekt ein Kindobjekt mit der ID id besitzt, sonst false.

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


ContainsChildWithName Method

[image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)>..::..ContainsChildWithName Method
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool ContainsChildWithName(
    string name
)
Visual Basic
Function ContainsChildWithName ( _
    name As String _
) As Boolean
F#
abstract ContainsChildWithName :
        name:string -> bool

Parameters

name
Type: System..::..String
Der gesuchte Name.

Return Value

true, falls das Elternobjekt ein Kindobjekt mit dem Namen name besitzt, sonst false.

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


CountChildrenByType Method

[image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)>..::..CountChildrenByType Method
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
int CountChildrenByType(
    Type filterType
)
Visual Basic
Function CountChildrenByType ( _
    filterType As Type _
) As Integer
F#
abstract CountChildrenByType :
        filterType:Type -> int

Parameters

filterType
Type: System..::..Type

[Missing <param name="filterType"/> documentation for "M:DynamicNode.Model.IParent`2.CountChildrenByType(System.Type)"]

Return Value

Die Anzahl aller Kindelemente vom Type filterType.

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


GetChildrenByType(T) Method

[image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)>..::..GetChildrenByType<(Of <(<'T>)>)> Method
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
IEnumerable<T> GetChildrenByType<T>()
where T : TChild
Visual Basic
Function GetChildrenByType(Of T As TChild) As IEnumerable(Of T)
F#
abstract GetChildrenByType : unit -> IEnumerable<'T>  when 'T : 'TChild

Type Parameters

T
Der Type der gesuchten Kindobjekt.

Return Value

Eine Aufzählung mit Kindelementen, die einem bestimmten Type entsprechen.

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


ToArray Method

[image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)>..::..ToArray Method
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Kindobjekten zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
TChild[] ToArray()
Visual Basic
Function ToArray As TChild()
F#
abstract ToArray : unit -> 'TChild[]

Return Value

Ein Array mit allen Kindobjekten.

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


IParent(TSelf, TChild) Properties

[image] [image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)> Properties
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IParent<(Of <(<'TSelf, TChild>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Dirty | Gibt einen Wert zurück, oder legt diesen fest, der angibt, ob dieses Objekt seid der letzten Speicherung verändert wurde. (Inherited from IBaseObject.)
Public property | Id | Gibt die ID des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)
Public property | Item | Gibt ein Kindobjekt anhand seines Name zurück.
Public property | Name | Gibt den Namen des Objektes zurück oder legt sie fest. (Inherited from IIdentifiable.)

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


Children Property

[image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)>..::..Children Property
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Sammlung mit allen Kindobjekten zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
ICollection<TChild> Children { get; }
Visual Basic
ReadOnly Property Children As ICollection(Of TChild)
    Get
F#
abstract Children : ICollection<'TChild>

Field Value

Eine ICollection<(Of <(<'T>)>)> mit allen Kindobjekten.

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


Item Property

[image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)>..::..Item Property
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Kindobjekt anhand seines Name zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
TChild this[
    string name
] { get; }
Visual Basic
ReadOnly Default Property Item ( _
    name As String _
) As TChild
    Get
F#
abstract Item : 'TChild

Parameters

name
Type: System..::..String
Der Name des gesuchten Kindobjektes.

Return Value

Das gesuchte Kindobjekt oder null.

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


IParent(TSelf, TChild) Events

[image] [image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)> Events
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IParent<(Of <(<'TSelf, TChild>)>)> type exposes the following members.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde.
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde.
Public event | DescriptionChanged | Wird ausgelöst, wenn die Beschreibung des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | DirtyChanged | Wird ausgelöst, wenn die Eigenschaft Dirty geändert wurde. (Inherited from IBaseObject.)
Public event | IdChanged | Wird ausgelöst, wenn die ID des Objektes geändert wurde. (Inherited from IIdentifiable.)
Public event | NameChanged | Wird ausgelöst, wenn der Name des Objektes geändert wurde. (Inherited from IIdentifiable.)

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


ChildAdded Event

[image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)>..::..ChildAdded Event
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn diesem Objekt ein Kindelement hinzugefügt wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler<ChildEventArgs<TSelf, TChild>> ChildAdded
Visual Basic
Event ChildAdded As EventHandler(Of ChildEventArgs(Of TSelf, TChild))
F#
abstract ChildAdded : IEvent<EventHandler<ChildEventArgs<'TSelf, 'TChild>>,
    ChildEventArgs<'TSelf, 'TChild>>

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


ChildRemoved Event

[image]

DynamicNodes API
IParent<(Of <(<'TSelf, TChild>)>)>..::..ChildRemoved Event
IParent<(Of <(<'TSelf, TChild>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
event EventHandler<ChildEventArgs<TSelf, TChild>> ChildRemoved
Visual Basic
Event ChildRemoved As EventHandler(Of ChildEventArgs(Of TSelf, TChild))
F#
abstract ChildRemoved : IEvent<EventHandler<ChildEventArgs<'TSelf, 'TChild>>,
    ChildEventArgs<'TSelf, 'TChild>>

See Also

IParent<(Of <(<'TSelf, TChild>)>)> Interface
DynamicNode.Model Namespace


ParentObject(TSelf, TChild) Class

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Standardimplementierung von IParent<(Of <(<'TSelf, TChild>)>)>

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public abstract class ParentObject<TSelf, TChild> : ExtensibleObject<TSelf>,
    IParent<TSelf, TChild>, IBaseObject, IIdentifiable, IStorable
where TSelf : class, IParent<TSelf, TChild>, IExtensible<TSelf>
where TChild : class, IChild<TParent, TSelf>
Visual Basic
Public MustInherit Class ParentObject(Of TSelf As {Class, IParent(Of TSelf, TChild), IExtensible(Of TSelf)}, TChild As {Class, IChild(Of TParent, TSelf)}) _
    Inherits ExtensibleObject(Of TSelf) _
    Implements IParent(Of TSelf, TChild), IBaseObject,  _
    IIdentifiable, IStorable
F#
[<AbstractClassAttribute>]
type ParentObject<'TSelf, 'TChild when 'TSelf : not struct and IParent<'TSelf, 'TChild> and IExtensible<'TSelf> when 'TChild : not struct and IChild<'TParent, 'TSelf>> =
    class
        inherit ExtensibleObject<'TSelf>
        interface IParent<'TSelf, 'TChild>
        interface IBaseObject
        interface IIdentifiable
        interface IStorable
    end

Type Parameters

TSelf
Der Type, der von ParentObject<(Of <(<'TSelf, TChild>)>)> abgeleitet wird.
TChild
Der Type der Kindobjekte, die in Objekten vom Type TSelf gespeichert werden sollen.

Inheritance Hierarchy

System..::..Object
DynamicNode.Model..::..BaseObject
DynamicNode.Model..::..ExtensibleObject <(Of <(<'TSelf>)>)>
DynamicNode.Model..::..ParentObject<(Of <(<'TSelf, TChild>)>)>
DynamicNode.Core..::..Runtime
DynamicNode.Model..::..HierarchyObject<(Of <(<'TParent, TSelf, TChild>)>)>

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


ParentObject(TSelf, TChild) Members

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)> Members
ParentObject<(Of <(<'TSelf, TChild>)>)> Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ParentObject<(Of <(<'TSelf, TChild>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | ParentObject<(Of <(<'TSelf, TChild>)>)> | Initialisiert eine neue Instanz von ParentObject<(Of <(<'TSelf, TChild>)>)>.

Methods

 | Name | Description
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu.
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben.
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben.
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt.
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt.
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind.
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt.
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Overrides BaseObject..::..OnDirtyChanged()()()().)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnDisposing()()()().)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Overrides BaseObject..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Overrides BaseObject..::..OnStore(IPropertyWriter).)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück.
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

Properties

 | Name | Description
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll.
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück.
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück.
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from BaseObject.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from BaseObject.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde.
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde.
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


ParentObject(TSelf, TChild) Constructor

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)> Constructor
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ParentObject<(Of <(<'TSelf, TChild>)>)>.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected ParentObject()
Visual Basic
Protected Sub New
F#
new : unit -> ParentObject

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


ParentObject(TSelf, TChild) Methods

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)> Methods
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ParentObject<(Of <(<'TSelf, TChild>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | AddChildWithId | Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu.
Public method | AttachExtension | Fügt dem Objekt eine Erweiterung hinzu. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeAddChild | Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben.
Protected method | BeforeRemoveChild | Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben.
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | ContainsChildWithId | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt.
Public method | ContainsChildWithName | Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt.
Public method | CountChildrenByType | Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück.
Public method | DetachExtension | Entfernt eine Erweiterung von dem Objekt. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | Dispose | Gibt Ressourcen frei, die von diesem Objekt verwendet werden. Ruft OnDisposing()()()() auf. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor ExtensibleObject<(Of <(<'TSelf>)>)> vom Garbage-Collector aus dem Speicher entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetAllAttachedExtensions | Gibt alle zur Zeit geladenen Erweiterungen zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetChildrenByType<(Of <<'(T>)>>) | Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind.
Public method | GetExtension | Gibt eine unterstützte Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetExtensions | Gibt alle Erweiterungen eines Typs zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | GetLoadedExtension | Gibt eine geladene Erweiterung anhand ihrer ID zurück. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsDescriptionValid | Prüft ob die übergebene Beschreibung erlaubt ist. (Inherited from BaseObject.)
Public method | IsExtensionLoaded | Überprüft, ob eine Erweiterung geladen ist. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public method | IsExtensionSupported | Ermittelt ob eine Erweiterung von dem Objekt unterstützt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | IsIdValid | Prüft ob die übergebene ID erlaubt ist. (Inherited from BaseObject.)
Protected method | IsNameValid | Prüft ob der übergebene Name erlaubt ist. (Inherited from BaseObject.)
Protected method | OnAttachExtension | Wird aufgerufen, wenn eine Erweiterung hinzugefügt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnChildAdded | Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt.
Protected method | OnChildRemoved | Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus.
Protected method | OnDescriptionChanged | Wird aufgerufen, wenn Description geändert wurde. Löst das Ereignis DescriptionChanged aus. (Inherited from BaseObject.)
Protected method | OnDetachExtension | Wird aufgerufen, wenn eine Erweiterung entfernt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | OnDirtyChanged | Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus. (Overrides BaseObject..::..OnDirtyChanged()()()().)
Protected method | OnDisposing | Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus. (Overrides ExtensibleObject<(Of <(<'TSelf>)>)>..::..OnDisposing()()()().)
Protected method | OnIdChanged | Wird aufgerufen, wenn Id geändert wurde. Löst das Ereignis IdChanged aus. (Inherited from BaseObject.)
Protected method | OnNameChanged | Wird aufgerufen, wenn Name geändert wurde. Löst das Ereignis NameChanged aus. (Inherited from BaseObject.)
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird. (Overrides BaseObject..::..OnRestore(IPropertyReader).)
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird. (Overrides BaseObject..::..OnStore(IPropertyWriter).)
Public method | ToArray | Gibt ein Array mit allen Kindobjekten zurück.
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceErrorData | Sendet Daten über einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfoData | Sendet informative Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarningData | Sendet Daten über eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


AddChildWithId Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..AddChildWithId Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt ein Kindobjekt ein und weist ihm die übergebene ID zu.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected void AddChildWithId(
    TChild childToAdd,
    int id
)
Visual Basic
Protected Sub AddChildWithId ( _
    childToAdd As TChild, _
    id As Integer _
)
F#
member AddChildWithId :
        childToAdd:'TChild *
        id:int -> unit

Parameters

childToAdd
Type: TChild
Ein neues Kindobjekt.
id
Type: System..::..Int32
Die ID, welche das Kindobjekt bekommen soll.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


BeforeAddChild Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..BeforeAddChild Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, bevor ein Kindobjekt diesem Elternobjekt hinzugefügt wird. Diese Methode kann überschrieben werden um neue Kindobjekte anzupassen, oder das Hinzufügen zu verbieten. Um das Hinzufügen zu verbieten muss die Methode false zurückgeben.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual bool BeforeAddChild(
    TChild childToAdd
)
Visual Basic
Protected Overridable Function BeforeAddChild ( _
    childToAdd As TChild _
) As Boolean
F#
abstract BeforeAddChild :
        childToAdd:'TChild -> bool
override BeforeAddChild :
        childToAdd:'TChild -> bool

Parameters

childToAdd
Type: TChild
Das neue Kindobjekt.

Return Value

true, wenn das Kindobjekt hinzugefügt werden darf, sonst false.

Remarks

Die Standardimplementierung aktualisiert die ID von Kindobjekten, falls AutoChildId gleich true ist und gibt immer true zurück.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


BeforeRemoveChild Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..BeforeRemoveChild Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, bevor ein Kindobjekt aus diesem Elternobjekt entfernt wird. Diese Methode kann überschrieben werden um Kindobjekte anzupassen die entfernt werden, oder das Entfernen zu verweigern. Um das Entfernen zu verweigern muss die Methode false zurückgeben.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual bool BeforeRemoveChild(
    TChild childToRemove
)
Visual Basic
Protected Overridable Function BeforeRemoveChild ( _
    childToRemove As TChild _
) As Boolean
F#
abstract BeforeRemoveChild :
        childToRemove:'TChild -> bool
override BeforeRemoveChild :
        childToRemove:'TChild -> bool

Parameters

childToRemove
Type: TChild
Das zu entfernende Kindobjekt.

Return Value

true, wenn das Kindobjekt entfernt werden darf, sonst false.

Remarks

Die Standardimplementierung setzt die ID von Kindobjekten auf -1 wenn AutoChildId gleich true ist und gibt immer true zurück.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


BeforeUseExtension Method

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..BeforeUseExtension Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | BeforeUseExtension(String) | Wird aufgerufen, wenn nach einer Erweiterung mit der ID extId gesucht wird. Diese Methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Protected method | BeforeUseExtension(Type) | Wird aufgerufen, wenn nach Erweitrungen vom Type extType gesucht wird. Diese methode kann überschrieben werden um spätes Initialisieren von Erweiterungen zu ermöglichen. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
ParentObject<(Of <(<'TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


ContainsChildWithId Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..ContainsChildWithId Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob dieses Elternobjekt ein Kindobjekt mit der übergebenen ID id besitzt.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool ContainsChildWithId(
    int id
)
Visual Basic
Public Function ContainsChildWithId ( _
    id As Integer _
) As Boolean
F#
abstract ContainsChildWithId :
        id:int -> bool
override ContainsChildWithId :
        id:int -> bool

Parameters

id
Type: System..::..Int32
Die gesuchte ID.

Return Value

true, falls das Elternobjekt ein Kindobjekt mit der ID id besitzt, sonst false.

Implements

IParent<(Of <(<'TSelf, TChild>)>)>..::..ContainsChildWithId(Int32)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


ContainsChildWithName Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..ContainsChildWithName Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob dieses Elternobjekt ein Kindobjekt mit dem übergebenen Namen name besitzt.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool ContainsChildWithName(
    string name
)
Visual Basic
Public Function ContainsChildWithName ( _
    name As String _
) As Boolean
F#
abstract ContainsChildWithName :
        name:string -> bool
override ContainsChildWithName :
        name:string -> bool

Parameters

name
Type: System..::..String
Der gesuchte Name.

Return Value

true, falls das Elternobjekt ein Kindobjekt mit dem Namen name besitzt, sonst false.

Implements

IParent<(Of <(<'TSelf, TChild>)>)>..::..ContainsChildWithName(String)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


CountChildrenByType Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..CountChildrenByType Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller Kindlemente von einem bestimmten Type zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int CountChildrenByType(
    Type filterType
)
Visual Basic
Public Function CountChildrenByType ( _
    filterType As Type _
) As Integer
F#
abstract CountChildrenByType :
        filterType:Type -> int
override CountChildrenByType :
        filterType:Type -> int

Parameters

filterType
Type: System..::..Type

[Missing <param name="filterType"/> documentation for "M:DynamicNode.Model.ParentObject`2.CountChildrenByType(System.Type)"]

Return Value

Die Anzahl aller Kindelemente vom Type filterType.

Implements

IParent<(Of <(<'TSelf, TChild>)>)>..::..CountChildrenByType(Type)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


GetChildrenByType(T) Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..GetChildrenByType<(Of <(<'T>)>)> Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt alle Kindelemente zurück, die vom Type T oder von ihm abgeleitet sind.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IEnumerable<T> GetChildrenByType<T>()
where T : TChild
Visual Basic
Public Function GetChildrenByType(Of T As TChild) As IEnumerable(Of T)
F#
abstract GetChildrenByType : unit -> IEnumerable<'T>  when 'T : 'TChild
override GetChildrenByType : unit -> IEnumerable<'T>  when 'T : 'TChild

Type Parameters

T
Der Type der gesuchten Kindobjekt.

Return Value

Eine Aufzählung mit Kindelementen, die einem bestimmten Type entsprechen.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


OnChildAdded Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildAdded Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde. Löst das Ereignis ChildAdded aus. Bei dem hinzugefügten Kindobjekt wird Parent mit einer Referenz auf dieses Elternobjekt belegt.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnChildAdded(
    TChild childToAdd
)
Visual Basic
Protected Overridable Sub OnChildAdded ( _
    childToAdd As TChild _
)
F#
abstract OnChildAdded :
        childToAdd:'TChild -> unit
override OnChildAdded :
        childToAdd:'TChild -> unit

Parameters

childToAdd
Type: TChild
Das hinzugefügte Kindobjekt.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


OnChildRemoved Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnChildRemoved Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn ein Kindobjekt aus diesem Elternobjekt entfernt wurde. Löst das Ereignis ChildRemoved aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected virtual void OnChildRemoved(
    TChild childToRemove
)
Visual Basic
Protected Overridable Sub OnChildRemoved ( _
    childToRemove As TChild _
)
F#
abstract OnChildRemoved :
        childToRemove:'TChild -> unit
override OnChildRemoved :
        childToRemove:'TChild -> unit

Parameters

childToRemove
Type: TChild
Die entfernten Kindobjekte.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


OnDirtyChanged Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnDirtyChanged Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn Dirty geändert wurde. Löst das Ereignis DirtyChanged aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnDirtyChanged()
Visual Basic
Protected Overrides Sub OnDirtyChanged
F#
abstract OnDirtyChanged : unit -> unit
override OnDirtyChanged : unit -> unit

Remarks

Wenn diese Methode überschrieben wird, muss in der abgeleiteten Version die Version der Elternklasse mit base.OnDirtyChanged() aufgerufen werden.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


OnDisposing Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnDisposing Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt entsorgt wird. Löst das Ereignis Disposing aus.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected override void OnDisposing()
Visual Basic
Protected Overrides Sub OnDisposing
F#
abstract OnDisposing : unit -> unit
override OnDisposing : unit -> unit

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


OnRestore Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnRestore Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnRestore(
    IPropertyReader pr
)
Visual Basic
Public Overrides Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit
override OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

Implements

IStorable..::..OnRestore(IPropertyReader)
IStorable..::..OnRestore(IPropertyReader)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


OnStore Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..OnStore Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public override void OnStore(
    IPropertyWriter pw
)
Visual Basic
Public Overrides Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit
override OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

Implements

IStorable..::..OnStore(IPropertyWriter)
IStorable..::..OnStore(IPropertyWriter)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


ToArray Method

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..ToArray Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Kindobjekten zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TChild[] ToArray()
Visual Basic
Public Function ToArray As TChild()
F#
abstract ToArray : unit -> 'TChild[]
override ToArray : unit -> 'TChild[]

Return Value

Ein Array mit allen Kindobjekten.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


TraceError Method

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..TraceError Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceError(Int32, String) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, Exception) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceError(Int32, String, array<Object>[]()[][]) | Sendet einen Fehler an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
ParentObject<(Of <(<'TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


TraceInfo Method

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..TraceInfo Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceInfo(Int32, String) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceInfo(Int32, String, array<Object>[]()[][]) | Sendet eine informative Meldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
ParentObject<(Of <(<'TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


TraceVerbose Method

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..TraceVerbose Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerbose(Int32, String) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerbose(Int32, String, array<Object>[]()[][]) | Sendet eine Detailmeldung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
ParentObject<(Of <(<'TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


TraceVerboseData Method

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..TraceVerboseData Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceVerboseData(Int32, Object) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceVerboseData(Int32, array<Object>[]()[][]) | Sendet detailierte Daten an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
ParentObject<(Of <(<'TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


TraceWarning Method

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..TraceWarning Method
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | TraceWarning(Int32, String) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, Exception) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)
Public method | TraceWarning(Int32, String, array<Object>[]()[][]) | Sendet eine Warnung an das Ablaufverfolgungssystem. (Inherited from BaseObject.)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
ParentObject<(Of <(<'TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


ParentObject(TSelf, TChild) Properties

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)> Properties
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ParentObject<(Of <(<'TSelf, TChild>)>)> type exposes the following members.

Properties

 | Name | Description
Protected property | AutoChildId | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll.
Public property | Children | Gibt eine Sammlung mit allen Kindobjekten zurück.
Public property | Description | Gibt die Beschreibung des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | DescriptionDefaultValue | Gibt den Standardwert für die Eigenschaft Description zurück. (Inherited from BaseObject.)
Public property | Dirty | Gibt einen Wert zurück, der angibt, ob der Zustand des Objektes dem letzten gespeicherten Zustand entspricht, oder legt ihn fest. (Inherited from BaseObject.)
Public property | Id | Gibt die ID des Objektes zurück, oder legt sie fest. (Inherited from BaseObject.)
Protected property | IdDefaultValue | Gibt den Standardwert für die Eigenschaft Id zurück. (Inherited from BaseObject.)
Public property | IsDisposed | Gibt einen Wert zurück der angibt ob Dispose()()()() aufgerufen wurde. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück.
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück.
Protected property | LocalTrace | Gibt die Ablaufverfolgungsquelle für die aktuelle Instanz zurück. (Inherited from BaseObject.)
Public property | Name | Gibt den Namen des Objektes zurück, oder legt ihn fest. (Inherited from BaseObject.)
Protected property | NameDefaultValue | Gibt den Standardwert für die Eigenschaft Name zurück. (Inherited from BaseObject.)
Protected property | StoreIdentification | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Eigenschaften von IIdentifiable beim Aufruf von OnStore(IPropertyWriter) gespeichert und beim Aufrauf von OnRestore(IPropertyReader) wiederhergestellt werden sollen. (Inherited from BaseObject.)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


AutoChildId Property

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..AutoChildId Property
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ID von Kindelementen beim Hinzufügen automatisch aktualisiert werden soll.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
protected bool AutoChildId { get; set; }
Visual Basic
Protected Property AutoChildId As Boolean
    Get
    Set
F#
member AutoChildId : bool with get, set

Field Value

true wenn die ID der Kindelemente automatisch, aktualisiert werden soll, sonst false.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


Children Property

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..Children Property
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Sammlung mit allen Kindobjekten zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public ICollection<TChild> Children { get; }
Visual Basic
Public ReadOnly Property Children As ICollection(Of TChild)
    Get
F#
abstract Children : ICollection<'TChild>
override Children : ICollection<'TChild>

Field Value

Eine ICollection<(Of <(<'T>)>)> mit allen Kindobjekten.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


Item Property

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..Item Property
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gibt ein Kindobjekt anhand seiner Id zurück.
Public property | Item[([( String])]) | Gibt ein Kindobjekt anhand seines Name zurück.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
ParentObject<(Of <(<'TSelf, TChild>)>)> Members
DynamicNode.Model Namespace


Item Property (Int32)

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..Item Property (Int32)
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Kindobjekt anhand seiner Id zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TChild this[
    int id
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    id As Integer _
) As TChild
    Get
F#
member Item : 'TChild

Parameters

id
Type: System..::..Int32
Die ID des gesuchten Kindobjektes.

Return Value

Das gesuchte Kindobjekt oder null.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
Item Overload
DynamicNode.Model Namespace


Item Property (String)

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..Item Property (String)
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Kindobjekt anhand seines Name zurück.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public TChild this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As TChild
    Get
F#
abstract Item : 'TChild
override Item : 'TChild

Parameters

name
Type: System..::..String
Der Name des gesuchten Kindobjektes.

Return Value

Das gesuchte Kindobjekt oder null.

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
Item Overload
DynamicNode.Model Namespace


ParentObject(TSelf, TChild) Events

[image] [image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)> Events
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ParentObject<(Of <(<'TSelf, TChild>)>)> type exposes the following members.

Events

 | Name | Description
Public event | ChildAdded | Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde.
Public event | ChildRemoved | Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde.
Public event | DescriptionChanged | Wird ausgelöst, wenn Description geändert wurde. (Inherited from BaseObject.)
Public event | DirtyChanged | Wird ausgelöst, wenn Dirty geändert wurde. (Inherited from BaseObject.)
Public event | Disposing | Wird ausgelöst, wenn das Objekt entsorgt wird. (Inherited from ExtensibleObject<(Of <(<'TSelf>)>)>.)
Public event | IdChanged | Wird ausgelöst, wenn Id geändert wurde. (Inherited from BaseObject.)
Public event | NameChanged | Wird ausgelöst, wenn Name geändert wurde. (Inherited from BaseObject.)

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


ChildAdded Event

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..ChildAdded Event
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Kindobjekt zu diesem Elternobjekt hinzugefügt wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<ChildEventArgs<TSelf, TChild>> ChildAdded
Visual Basic
Public Event ChildAdded As EventHandler(Of ChildEventArgs(Of TSelf, TChild))
F#
abstract ChildAdded : IEvent<EventHandler<ChildEventArgs<'TSelf, 'TChild>>,
    ChildEventArgs<'TSelf, 'TChild>>
override ChildAdded : IEvent<EventHandler<ChildEventArgs<'TSelf, 'TChild>>,
    ChildEventArgs<'TSelf, 'TChild>>

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


ChildRemoved Event

[image]

DynamicNodes API
ParentObject<(Of <(<'TSelf, TChild>)>)>..::..ChildRemoved Event
ParentObject<(Of <(<'TSelf, TChild>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn aus diesem Objekt ein Kindelement entfernt wurde.

Namespace: DynamicNode.Model
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public event EventHandler<ChildEventArgs<TSelf, TChild>> ChildRemoved
Visual Basic
Public Event ChildRemoved As EventHandler(Of ChildEventArgs(Of TSelf, TChild))
F#
abstract ChildRemoved : IEvent<EventHandler<ChildEventArgs<'TSelf, 'TChild>>,
    ChildEventArgs<'TSelf, 'TChild>>
override ChildRemoved : IEvent<EventHandler<ChildEventArgs<'TSelf, 'TChild>>,
    ChildEventArgs<'TSelf, 'TChild>>

See Also

ParentObject<(Of <(<'TSelf, TChild>)>)> Class
DynamicNode.Model Namespace


DynamicNode.Persistence Namespace

[image]

DynamicNodes API
DynamicNode.Persistence Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält Typen mit allgemeinen Persistenz-Mechanismen für das DynamicNodes-System.

Classes

 | Class | Description
Public class | SettingsManager | Kann mehrere Einstellungsgruppen verwalten und in einem Ordner als XML-Dateien speichern.
Public class | Xml | Eine statische Klasse mit Hilfsfunktionen für das Arbeiten mit XML und XPath.
Public class | XmlPropertyReader | Implementiert IPropertyReader für die Transformation von XML in Eigenschaften.
Public class | XmlPropertyStorage | Implementiert IPropertyStorage für die Speicherung von Eigenschaften in XML.
Public class | XmlPropertyWriter | Implementiert IPropertyWriter für die Transformation von Eigenschaften in XML.

Structures

 | Structure | Description
Public structure | PropertyWrapper | Kapselt eine Eigenschaft mit Name, Wert und XML-Flag.

Interfaces

 | Interface | Description
Public interface | IPropertyReader | Eine Schnittstelle für Objekte, die einzelne Eigenschaften sichern können.
Public interface | IPropertyStorage | Die Schnittstelle für einen Eigenschaftsspeicher
Public interface | IPropertyWriter | Eine Schnittstelle für Objekte, die einzelne Eigenschaften wiederherstellen können.
Public interface | IStorable | Diese Schnittstelle stellt die Möglichkeit bereit ein Objekt mit einem IPropertyReader und einem IPropertyWriter zu persistieren.


IPropertyReader Interface

[image]

DynamicNodes API
IPropertyReader Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für Objekte, die einzelne Eigenschaften sichern können.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IPropertyReader
Visual Basic
Public Interface IPropertyReader
F#
type IPropertyReader =  interface end

See Also

IPropertyReader Members
DynamicNode.Persistence Namespace


IPropertyReader Members

[image] [image]

DynamicNodes API
IPropertyReader Members
IPropertyReader Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPropertyReader type exposes the following members.

Methods

 | Name | Description
Public method | ContainsProperty | Gibt einen Wahrheitswert zurück, der angibt ob eine benannte Eigenschaft existiert, oder nicht.
Public method | ReadPropertyAsBoolean | Liest eine Eigenschaft als bool.
Public method | ReadPropertyAsByte | Liest eine Eigenschaft als byte.
Public method | ReadPropertyAsDecimal | Liest eine Eigenschaft als decimal.
Public method | ReadPropertyAsDouble | Liest eine Eigenschaft als double.
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert.
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert.
Public method | ReadPropertyAsInt16 | Liest eine Eigenschaft als short.
Public method | ReadPropertyAsInt32 | Liest eine Eigenschaft als int.
Public method | ReadPropertyAsInt64 | Liest eine Eigenschaft als long.
Public method | ReadPropertyAsObject | Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt.
Public method | ReadPropertyAsSingle | Liest eine Eigenschaft als float.
Public method | ReadPropertyAsString | Liest eine Eigenschaft als string.
Public method | ReadPropertyRaw | Liest eine Eigenschaft als XML-Schnipsel.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


IPropertyReader Methods

[image] [image]

DynamicNodes API
IPropertyReader Methods
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPropertyReader type exposes the following members.

Methods

 | Name | Description
Public method | ContainsProperty | Gibt einen Wahrheitswert zurück, der angibt ob eine benannte Eigenschaft existiert, oder nicht.
Public method | ReadPropertyAsBoolean | Liest eine Eigenschaft als bool.
Public method | ReadPropertyAsByte | Liest eine Eigenschaft als byte.
Public method | ReadPropertyAsDecimal | Liest eine Eigenschaft als decimal.
Public method | ReadPropertyAsDouble | Liest eine Eigenschaft als double.
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert.
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert.
Public method | ReadPropertyAsInt16 | Liest eine Eigenschaft als short.
Public method | ReadPropertyAsInt32 | Liest eine Eigenschaft als int.
Public method | ReadPropertyAsInt64 | Liest eine Eigenschaft als long.
Public method | ReadPropertyAsObject | Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt.
Public method | ReadPropertyAsSingle | Liest eine Eigenschaft als float.
Public method | ReadPropertyAsString | Liest eine Eigenschaft als string.
Public method | ReadPropertyRaw | Liest eine Eigenschaft als XML-Schnipsel.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ContainsProperty Method

[image]

DynamicNodes API
IPropertyReader..::..ContainsProperty Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wahrheitswert zurück, der angibt ob eine benannte Eigenschaft existiert, oder nicht.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool ContainsProperty(
    string name
)
Visual Basic
Function ContainsProperty ( _
    name As String _
) As Boolean
F#
abstract ContainsProperty :
        name:string -> bool

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.

Return Value

true, wenn eine Eigenschaft mit dem Name graphName existiert, sonst false.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyAsBoolean Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsBoolean Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als bool.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
bool ReadPropertyAsBoolean(
    string name,
    bool def
)
Visual Basic
Function ReadPropertyAsBoolean ( _
    name As String, _
    def As Boolean _
) As Boolean
F#
abstract ReadPropertyAsBoolean :
        name:string *
        def:bool -> bool

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Boolean
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyAsByte Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsByte Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als byte.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
byte ReadPropertyAsByte(
    string name,
    byte def
)
Visual Basic
Function ReadPropertyAsByte ( _
    name As String, _
    def As Byte _
) As Byte
F#
abstract ReadPropertyAsByte :
        name:string *
        def:byte -> byte

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Byte
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyAsDecimal Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsDecimal Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als decimal.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
decimal ReadPropertyAsDecimal(
    string name,
    decimal def
)
Visual Basic
Function ReadPropertyAsDecimal ( _
    name As String, _
    def As Decimal _
) As Decimal
F#
abstract ReadPropertyAsDecimal :
        name:string *
        def:decimal -> decimal

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Decimal
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyAsDouble Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsDouble Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als double.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
double ReadPropertyAsDouble(
    string name,
    double def
)
Visual Basic
Function ReadPropertyAsDouble ( _
    name As String, _
    def As Double _
) As Double
F#
abstract ReadPropertyAsDouble :
        name:string *
        def:float -> float

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Double
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyAsEnum Method

[image] [image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsEnum Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert.
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert.

See Also

IPropertyReader Interface
IPropertyReader Members
DynamicNode.Persistence Namespace


ReadPropertyAsEnum(T) Method (String, T)

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsEnum<(Of <(<'T>)>)> Method (String, T)
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als einen Aufzählungswert.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
T ReadPropertyAsEnum<T>(
    string name,
    T def
)
Visual Basic
Function ReadPropertyAsEnum(Of T) ( _
    name As String, _
    def As T _
) As T
F#
abstract ReadPropertyAsEnum :
        name:string *
        def:'T -> 'T

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: T
Der Standardwert.

Type Parameters

T
Der Typ der Aufzählung.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
ReadPropertyAsEnum Overload
DynamicNode.Persistence Namespace


ReadPropertyAsEnum Method (String, Enum, Type)

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsEnum Method (String, Enum, Type)
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als einen Enum-Wert.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
Enum ReadPropertyAsEnum(
    string name,
    Enum def,
    Type enumType
)
Visual Basic
Function ReadPropertyAsEnum ( _
    name As String, _
    def As Enum, _
    enumType As Type _
) As Enum
F#
abstract ReadPropertyAsEnum :
        name:string *
        def:Enum *
        enumType:Type -> Enum

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Enum
Der Standardwert.
enumType
Type: System..::..Type
Das Type-Objekt des Enum.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
ReadPropertyAsEnum Overload
DynamicNode.Persistence Namespace


ReadPropertyAsInt16 Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsInt16 Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als short.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
short ReadPropertyAsInt16(
    string name,
    short def
)
Visual Basic
Function ReadPropertyAsInt16 ( _
    name As String, _
    def As Short _
) As Short
F#
abstract ReadPropertyAsInt16 :
        name:string *
        def:int16 -> int16

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Int16
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyAsInt32 Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsInt32 Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als int.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
int ReadPropertyAsInt32(
    string name,
    int def
)
Visual Basic
Function ReadPropertyAsInt32 ( _
    name As String, _
    def As Integer _
) As Integer
F#
abstract ReadPropertyAsInt32 :
        name:string *
        def:int -> int

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Int32
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyAsInt64 Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsInt64 Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als long.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
long ReadPropertyAsInt64(
    string name,
    long def
)
Visual Basic
Function ReadPropertyAsInt64 ( _
    name As String, _
    def As Long _
) As Long
F#
abstract ReadPropertyAsInt64 :
        name:string *
        def:int64 -> int64

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Int64
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyAsObject Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsObject Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void ReadPropertyAsObject(
    string name,
    IXmlSerializable value
)
Visual Basic
Sub ReadPropertyAsObject ( _
    name As String, _
    value As IXmlSerializable _
)
F#
abstract ReadPropertyAsObject :
        name:string *
        value:IXmlSerializable -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System.Xml.Serialization..::..IXmlSerializable
Das in XML serialisierbare Objekt.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyAsSingle Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsSingle Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als float.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
float ReadPropertyAsSingle(
    string name,
    float def
)
Visual Basic
Function ReadPropertyAsSingle ( _
    name As String, _
    def As Single _
) As Single
F#
abstract ReadPropertyAsSingle :
        name:string *
        def:float32 -> float32

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Single
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyAsString Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyAsString Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als string.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string ReadPropertyAsString(
    string name,
    string def
)
Visual Basic
Function ReadPropertyAsString ( _
    name As String, _
    def As String _
) As String
F#
abstract ReadPropertyAsString :
        name:string *
        def:string -> string

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..String
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


ReadPropertyRaw Method

[image]

DynamicNodes API
IPropertyReader..::..ReadPropertyRaw Method
IPropertyReader Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als XML-Schnipsel.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
string ReadPropertyRaw(
    string name,
    string def
)
Visual Basic
Function ReadPropertyRaw ( _
    name As String, _
    def As String _
) As String
F#
abstract ReadPropertyRaw :
        name:string *
        def:string -> string

Parameters

name
Type: System..::..String
Der Name der Eiugenschaft.
def
Type: System..::..String
Ein Standardwert.

Return Value

Eine Zeichenkette, welche den kompletten Inhalt des XML-Elements für die Eigenschaft name enthält.

See Also

IPropertyReader Interface
DynamicNode.Persistence Namespace


IPropertyStorage Interface

[image]

DynamicNodes API
IPropertyStorage Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für einen Eigenschaftsspeicher

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IPropertyStorage : IPropertyReader,
    IPropertyWriter
Visual Basic
Public Interface IPropertyStorage _
    Inherits IPropertyReader, IPropertyWriter
F#
type IPropertyStorage =
    interface
        interface IPropertyReader
        interface IPropertyWriter
    end

See Also

IPropertyStorage Members
DynamicNode.Persistence Namespace


IPropertyStorage Members

[image] [image]

DynamicNodes API
IPropertyStorage Members
IPropertyStorage Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPropertyStorage type exposes the following members.

Methods

 | Name | Description
Public method | ContainsProperty | Gibt einen Wahrheitswert zurück, der angibt ob eine benannte Eigenschaft existiert, oder nicht. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsBoolean | Liest eine Eigenschaft als bool. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsByte | Liest eine Eigenschaft als byte. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsDecimal | Liest eine Eigenschaft als decimal. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsDouble | Liest eine Eigenschaft als double. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsInt16 | Liest eine Eigenschaft als short. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsInt32 | Liest eine Eigenschaft als int. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsInt64 | Liest eine Eigenschaft als long. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsObject | Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsSingle | Liest eine Eigenschaft als float. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsString | Liest eine Eigenschaft als string. (Inherited from IPropertyReader.)
Public method | ReadPropertyRaw | Liest eine Eigenschaft als XML-Schnipsel. (Inherited from IPropertyReader.)
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WritePropertyEnum | Schreibt eine Enum-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WritePropertyObject | Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts. (Inherited from IPropertyWriter.)
Public method | WritePropertyRaw | Schreibt einen XML-Schnipsel unverändert als Eigenschaft. (Inherited from IPropertyWriter.)

See Also

IPropertyStorage Interface
DynamicNode.Persistence Namespace


IPropertyStorage Methods

[image] [image]

DynamicNodes API
IPropertyStorage Methods
IPropertyStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPropertyStorage type exposes the following members.

Methods

 | Name | Description
Public method | ContainsProperty | Gibt einen Wahrheitswert zurück, der angibt ob eine benannte Eigenschaft existiert, oder nicht. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsBoolean | Liest eine Eigenschaft als bool. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsByte | Liest eine Eigenschaft als byte. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsDecimal | Liest eine Eigenschaft als decimal. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsDouble | Liest eine Eigenschaft als double. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsInt16 | Liest eine Eigenschaft als short. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsInt32 | Liest eine Eigenschaft als int. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsInt64 | Liest eine Eigenschaft als long. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsObject | Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsSingle | Liest eine Eigenschaft als float. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsString | Liest eine Eigenschaft als string. (Inherited from IPropertyReader.)
Public method | ReadPropertyRaw | Liest eine Eigenschaft als XML-Schnipsel. (Inherited from IPropertyReader.)
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WritePropertyEnum | Schreibt eine Enum-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WritePropertyObject | Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts. (Inherited from IPropertyWriter.)
Public method | WritePropertyRaw | Schreibt einen XML-Schnipsel unverändert als Eigenschaft. (Inherited from IPropertyWriter.)

See Also

IPropertyStorage Interface
DynamicNode.Persistence Namespace


ReadPropertyAsEnum Method

[image] [image]

DynamicNodes API
IPropertyStorage..::..ReadPropertyAsEnum Method
IPropertyStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert. (Inherited from IPropertyReader.)
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert. (Inherited from IPropertyReader.)

See Also

IPropertyStorage Interface
IPropertyStorage Members
DynamicNode.Persistence Namespace


WriteProperty Method

[image] [image]

DynamicNodes API
IPropertyStorage..::..WriteProperty Method
IPropertyStorage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft. (Inherited from IPropertyWriter.)
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft. (Inherited from IPropertyWriter.)

See Also

IPropertyStorage Interface
IPropertyStorage Members
DynamicNode.Persistence Namespace


IPropertyWriter Interface

[image]

DynamicNodes API
IPropertyWriter Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für Objekte, die einzelne Eigenschaften wiederherstellen können.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IPropertyWriter
Visual Basic
Public Interface IPropertyWriter
F#
type IPropertyWriter =  interface end

See Also

IPropertyWriter Members
DynamicNode.Persistence Namespace


IPropertyWriter Members

[image] [image]

DynamicNodes API
IPropertyWriter Members
IPropertyWriter Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPropertyWriter type exposes the following members.

Methods

 | Name | Description
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft.
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft.
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft.
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft.
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft.
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft.
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft.
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft.
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft.
Public method | WritePropertyEnum | Schreibt eine Enum-Eigenschaft.
Public method | WritePropertyObject | Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts.
Public method | WritePropertyRaw | Schreibt einen XML-Schnipsel unverändert als Eigenschaft.

See Also

IPropertyWriter Interface
DynamicNode.Persistence Namespace


IPropertyWriter Methods

[image] [image]

DynamicNodes API
IPropertyWriter Methods
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IPropertyWriter type exposes the following members.

Methods

 | Name | Description
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft.
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft.
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft.
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft.
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft.
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft.
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft.
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft.
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft.
Public method | WritePropertyEnum | Schreibt eine Enum-Eigenschaft.
Public method | WritePropertyObject | Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts.
Public method | WritePropertyRaw | Schreibt einen XML-Schnipsel unverändert als Eigenschaft.

See Also

IPropertyWriter Interface
DynamicNode.Persistence Namespace


WriteProperty Method

[image] [image]

DynamicNodes API
IPropertyWriter..::..WriteProperty Method
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft.
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft.
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft.
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft.
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft.
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft.
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft.
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft.
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft.

See Also

IPropertyWriter Interface
IPropertyWriter Members
DynamicNode.Persistence Namespace


WriteProperty Method (String, Boolean)

[image]

DynamicNodes API
IPropertyWriter..::..WriteProperty Method (String, Boolean)
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine bool-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WriteProperty(
    string name,
    bool value
)
Visual Basic
Sub WriteProperty ( _
    name As String, _
    value As Boolean _
)
F#
abstract WriteProperty :
        name:string *
        value:bool -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Boolean
Der Wert der Eigenschaft.

See Also

IPropertyWriter Interface
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Byte)

[image]

DynamicNodes API
IPropertyWriter..::..WriteProperty Method (String, Byte)
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine byte-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WriteProperty(
    string name,
    byte value
)
Visual Basic
Sub WriteProperty ( _
    name As String, _
    value As Byte _
)
F#
abstract WriteProperty :
        name:string *
        value:byte -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Byte
Der Wert der Eigenschaft.

See Also

IPropertyWriter Interface
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Decimal)

[image]

DynamicNodes API
IPropertyWriter..::..WriteProperty Method (String, Decimal)
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine decimal-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WriteProperty(
    string name,
    decimal value
)
Visual Basic
Sub WriteProperty ( _
    name As String, _
    value As Decimal _
)
F#
abstract WriteProperty :
        name:string *
        value:decimal -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Decimal
Der Wert der Eigenschaft.

See Also

IPropertyWriter Interface
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Double)

[image]

DynamicNodes API
IPropertyWriter..::..WriteProperty Method (String, Double)
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine double-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WriteProperty(
    string name,
    double value
)
Visual Basic
Sub WriteProperty ( _
    name As String, _
    value As Double _
)
F#
abstract WriteProperty :
        name:string *
        value:float -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Double
Der Wert der Eigenschaft.

See Also

IPropertyWriter Interface
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Int16)

[image]

DynamicNodes API
IPropertyWriter..::..WriteProperty Method (String, Int16)
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine short-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WriteProperty(
    string name,
    short value
)
Visual Basic
Sub WriteProperty ( _
    name As String, _
    value As Short _
)
F#
abstract WriteProperty :
        name:string *
        value:int16 -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Int16
Der Wert der Eigenschaft.

See Also

IPropertyWriter Interface
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Int32)

[image]

DynamicNodes API
IPropertyWriter..::..WriteProperty Method (String, Int32)
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine int-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WriteProperty(
    string name,
    int value
)
Visual Basic
Sub WriteProperty ( _
    name As String, _
    value As Integer _
)
F#
abstract WriteProperty :
        name:string *
        value:int -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Int32
Der Wert der Eigenschaft.

See Also

IPropertyWriter Interface
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Int64)

[image]

DynamicNodes API
IPropertyWriter..::..WriteProperty Method (String, Int64)
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine long-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WriteProperty(
    string name,
    long value
)
Visual Basic
Sub WriteProperty ( _
    name As String, _
    value As Long _
)
F#
abstract WriteProperty :
        name:string *
        value:int64 -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Int64
Der Wert der Eigenschaft.

See Also

IPropertyWriter Interface
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Single)

[image]

DynamicNodes API
IPropertyWriter..::..WriteProperty Method (String, Single)
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine float-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WriteProperty(
    string name,
    float value
)
Visual Basic
Sub WriteProperty ( _
    name As String, _
    value As Single _
)
F#
abstract WriteProperty :
        name:string *
        value:float32 -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Single
Der Wert der Eigenschaft.

See Also

IPropertyWriter Interface
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, String)

[image]

DynamicNodes API
IPropertyWriter..::..WriteProperty Method (String, String)
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine string-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WriteProperty(
    string name,
    string value
)
Visual Basic
Sub WriteProperty ( _
    name As String, _
    value As String _
)
F#
abstract WriteProperty :
        name:string *
        value:string -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..String
Der Wert der Eigenschaft.

See Also

IPropertyWriter Interface
WriteProperty Overload
DynamicNode.Persistence Namespace


WritePropertyEnum Method

[image]

DynamicNodes API
IPropertyWriter..::..WritePropertyEnum Method
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine Enum-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WritePropertyEnum(
    string name,
    Object value
)
Visual Basic
Sub WritePropertyEnum ( _
    name As String, _
    value As Object _
)
F#
abstract WritePropertyEnum :
        name:string *
        value:Object -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Object
Der Wert der Eigenschaft.

See Also

IPropertyWriter Interface
DynamicNode.Persistence Namespace


WritePropertyObject Method

[image]

DynamicNodes API
IPropertyWriter..::..WritePropertyObject Method
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WritePropertyObject(
    string name,
    IXmlSerializable value
)
Visual Basic
Sub WritePropertyObject ( _
    name As String, _
    value As IXmlSerializable _
)
F#
abstract WritePropertyObject :
        name:string *
        value:IXmlSerializable -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System.Xml.Serialization..::..IXmlSerializable
Das in XML serialisierbare Objekt.

See Also

IPropertyWriter Interface
DynamicNode.Persistence Namespace


WritePropertyRaw Method

[image]

DynamicNodes API
IPropertyWriter..::..WritePropertyRaw Method
IPropertyWriter Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt einen XML-Schnipsel unverändert als Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void WritePropertyRaw(
    string name,
    string xml
)
Visual Basic
Sub WritePropertyRaw ( _
    name As String, _
    xml As String _
)
F#
abstract WritePropertyRaw :
        name:string *
        xml:string -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
xml
Type: System..::..String
Der XML-Schnipsel.

See Also

IPropertyWriter Interface
DynamicNode.Persistence Namespace


IStorable Interface

[image]

DynamicNodes API
IStorable Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Diese Schnittstelle stellt die Möglichkeit bereit ein Objekt mit einem IPropertyReader und einem IPropertyWriter zu persistieren.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public interface IStorable
Visual Basic
Public Interface IStorable
F#
type IStorable =  interface end

See Also

IStorable Members
DynamicNode.Persistence Namespace


IStorable Members

[image] [image]

DynamicNodes API
IStorable Members
IStorable Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IStorable type exposes the following members.

Methods

 | Name | Description
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.

See Also

IStorable Interface
DynamicNode.Persistence Namespace


IStorable Methods

[image] [image]

DynamicNodes API
IStorable Methods
IStorable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IStorable type exposes the following members.

Methods

 | Name | Description
Public method | OnRestore | Wird aufgerufe, wenn das Objekt wieder hergestellt wird.
Public method | OnStore | Wird aufgerufen, wenn das Objekt gespeichert wird.

See Also

IStorable Interface
DynamicNode.Persistence Namespace


OnRestore Method

[image]

DynamicNodes API
IStorable..::..OnRestore Method
IStorable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufe, wenn das Objekt wieder hergestellt wird.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void OnRestore(
    IPropertyReader pr
)
Visual Basic
Sub OnRestore ( _
    pr As IPropertyReader _
)
F#
abstract OnRestore :
        pr:IPropertyReader -> unit

Parameters

pr
Type: DynamicNode.Persistence..::..IPropertyReader
Ein Eigenschaftsleser.

See Also

IStorable Interface
DynamicNode.Persistence Namespace


OnStore Method

[image]

DynamicNodes API
IStorable..::..OnStore Method
IStorable Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn das Objekt gespeichert wird.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
void OnStore(
    IPropertyWriter pw
)
Visual Basic
Sub OnStore ( _
    pw As IPropertyWriter _
)
F#
abstract OnStore :
        pw:IPropertyWriter -> unit

Parameters

pw
Type: DynamicNode.Persistence..::..IPropertyWriter
Ein Eigenschaftsspeicher.

See Also

IStorable Interface
DynamicNode.Persistence Namespace


PropertyWrapper Structure

[image]

DynamicNodes API
PropertyWrapper Structure
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Kapselt eine Eigenschaft mit Name, Wert und XML-Flag.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public struct PropertyWrapper
Visual Basic
Public Structure PropertyWrapper
F#
[<SealedAttribute>]
type PropertyWrapper =  struct end

See Also

PropertyWrapper Members
DynamicNode.Persistence Namespace


PropertyWrapper Members

[image] [image]

DynamicNodes API
PropertyWrapper Members
PropertyWrapper Structure Constructors Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PropertyWrapper type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyWrapper | Initialisiert eine Instanz der Struktur PropertyWrapper.

Fields

 | Name | Description
Public field | name | Der Name der Eigenschaft
Public field | value | Der XSD-konform kodierte Wert der Eigenschaft
Public field | xml | Gibt an ob value ein XML-Schnipsel ist

See Also

PropertyWrapper Structure
DynamicNode.Persistence Namespace


PropertyWrapper Constructor

[image]

DynamicNodes API
PropertyWrapper Constructor
PropertyWrapper Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Instanz der Struktur PropertyWrapper.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public PropertyWrapper(
    string name,
    string value,
    bool xml
)
Visual Basic
Public Sub New ( _
    name As String, _
    value As String, _
    xml As Boolean _
)
F#
new :
        name:string *
        value:string *
        xml:bool -> PropertyWrapper

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..String
Der Wert der Eigenschaft als XSD-konformer String.
xml
Type: System..::..Boolean
true wenn der Wert ein XML-Schnippsel ist, sonst false.

See Also

PropertyWrapper Structure
DynamicNode.Persistence Namespace


PropertyWrapper Fields

[image] [image]

DynamicNodes API
PropertyWrapper Fields
PropertyWrapper Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PropertyWrapper type exposes the following members.

Fields

 | Name | Description
Public field | name | Der Name der Eigenschaft
Public field | value | Der XSD-konform kodierte Wert der Eigenschaft
Public field | xml | Gibt an ob value ein XML-Schnipsel ist

See Also

PropertyWrapper Structure
DynamicNode.Persistence Namespace


name Field

[image]

DynamicNodes API
PropertyWrapper..::..name Field
PropertyWrapper Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Name der Eigenschaft

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public readonly string name
Visual Basic
Public ReadOnly name As String
F#
val name: string

See Also

PropertyWrapper Structure
DynamicNode.Persistence Namespace


value Field

[image]

DynamicNodes API
PropertyWrapper..::..value Field
PropertyWrapper Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der XSD-konform kodierte Wert der Eigenschaft

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public readonly string value
Visual Basic
Public ReadOnly value As String
F#
val value: string

See Also

PropertyWrapper Structure
DynamicNode.Persistence Namespace


xml Field

[image]

DynamicNodes API
PropertyWrapper..::..xml Field
PropertyWrapper Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an ob value ein XML-Schnipsel ist

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public readonly bool xml
Visual Basic
Public ReadOnly xml As Boolean
F#
val xml: bool

See Also

PropertyWrapper Structure
DynamicNode.Persistence Namespace


SettingsManager Class

[image]

DynamicNodes API
SettingsManager Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Kann mehrere Einstellungsgruppen verwalten und in einem Ordner als XML-Dateien speichern.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class SettingsManager
Visual Basic
Public Class SettingsManager
F#
type SettingsManager =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Persistence..::..SettingsManager

See Also

SettingsManager Members
DynamicNode.Persistence Namespace


SettingsManager Members

[image] [image]

DynamicNodes API
SettingsManager Members
SettingsManager Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SettingsManager type exposes the following members.

Constructors

 | Name | Description
Public method | SettingsManager | Initialisiert eine neue Instanz von SettingsManager.

Methods

 | Name | Description
Public method | ContainsGroup | Überprüft, ob eine Einstellungsgruppe registriert ist.
Public method | GetReader | Gibt einen Eigenschaftsleser für die angegebene Gruppe zurück.
Public method | GetStorage | Gibt einen Eigenschaftsspeicher für die angegebene Gruppe zurück.
Public method | GetWriter | Gibt einen Eigenschaftsschreiber für die angegebene Gruppe zurück. Alle bereits existierenden Einträge in der Gruppe werden gelöscht.
Public method | ReadAllGroups | Liest alle Einstellungen aus den XML-Dateien.
Public method | RegisterGroup | Registriert eine Einstellungsgruppe. Jede Einstellungsgruppe wird als Datei im Einstellungsverzeichnis gespeichert.
Public method | WriteAllGroups | Sichert alle Einstellungen in XML-Dateien.

See Also

SettingsManager Class
DynamicNode.Persistence Namespace


SettingsManager Constructor

[image]

DynamicNodes API
SettingsManager Constructor
SettingsManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von SettingsManager.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public SettingsManager(
    string settingsPath
)
Visual Basic
Public Sub New ( _
    settingsPath As String _
)
F#
new :
        settingsPath:string -> SettingsManager

Parameters

settingsPath
Type: System..::..String
Das Einstellungsverzeichnis.

See Also

SettingsManager Class
DynamicNode.Persistence Namespace


SettingsManager Methods

[image] [image]

DynamicNodes API
SettingsManager Methods
SettingsManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SettingsManager type exposes the following members.

Methods

 | Name | Description
Public method | ContainsGroup | Überprüft, ob eine Einstellungsgruppe registriert ist.
Public method | GetReader | Gibt einen Eigenschaftsleser für die angegebene Gruppe zurück.
Public method | GetStorage | Gibt einen Eigenschaftsspeicher für die angegebene Gruppe zurück.
Public method | GetWriter | Gibt einen Eigenschaftsschreiber für die angegebene Gruppe zurück. Alle bereits existierenden Einträge in der Gruppe werden gelöscht.
Public method | ReadAllGroups | Liest alle Einstellungen aus den XML-Dateien.
Public method | RegisterGroup | Registriert eine Einstellungsgruppe. Jede Einstellungsgruppe wird als Datei im Einstellungsverzeichnis gespeichert.
Public method | WriteAllGroups | Sichert alle Einstellungen in XML-Dateien.

See Also

SettingsManager Class
DynamicNode.Persistence Namespace


ContainsGroup Method

[image]

DynamicNodes API
SettingsManager..::..ContainsGroup Method
SettingsManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Überprüft, ob eine Einstellungsgruppe registriert ist.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool ContainsGroup(
    string name
)
Visual Basic
Public Function ContainsGroup ( _
    name As String _
) As Boolean
F#
member ContainsGroup :
        name:string -> bool

Parameters

name
Type: System..::..String
Der Name der Einstellungsgruppe.

Return Value

true, wenn die Einstellungsgruppe bereits registriert ist, sonst false.

See Also

SettingsManager Class
DynamicNode.Persistence Namespace


GetReader Method

[image]

DynamicNodes API
SettingsManager..::..GetReader Method
SettingsManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Eigenschaftsleser für die angegebene Gruppe zurück.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IPropertyReader GetReader(
    string groupName
)
Visual Basic
Public Function GetReader ( _
    groupName As String _
) As IPropertyReader
F#
member GetReader :
        groupName:string -> IPropertyReader

Parameters

groupName
Type: System..::..String
Der Name der Einstellungsgruppe.

Return Value

Einen Einstellungsleser.

See Also

SettingsManager Class
DynamicNode.Persistence Namespace


GetStorage Method

[image]

DynamicNodes API
SettingsManager..::..GetStorage Method
SettingsManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Eigenschaftsspeicher für die angegebene Gruppe zurück.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IPropertyStorage GetStorage(
    string groupName
)
Visual Basic
Public Function GetStorage ( _
    groupName As String _
) As IPropertyStorage
F#
member GetStorage :
        groupName:string -> IPropertyStorage

Parameters

groupName
Type: System..::..String
Der Name der Einstellungsgruppe.

Return Value

Einen Eigenschaftsspeicher.

See Also

SettingsManager Class
DynamicNode.Persistence Namespace


GetWriter Method

[image]

DynamicNodes API
SettingsManager..::..GetWriter Method
SettingsManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Eigenschaftsschreiber für die angegebene Gruppe zurück. Alle bereits existierenden Einträge in der Gruppe werden gelöscht.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IPropertyWriter GetWriter(
    string groupName
)
Visual Basic
Public Function GetWriter ( _
    groupName As String _
) As IPropertyWriter
F#
member GetWriter :
        groupName:string -> IPropertyWriter

Parameters

groupName
Type: System..::..String
Der Name der Einstellungsgruppe.

Return Value

Einen Eigenschaftsschreiber.

See Also

SettingsManager Class
DynamicNode.Persistence Namespace


ReadAllGroups Method

[image]

DynamicNodes API
SettingsManager..::..ReadAllGroups Method
SettingsManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest alle Einstellungen aus den XML-Dateien.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ReadAllGroups()
Visual Basic
Public Sub ReadAllGroups
F#
member ReadAllGroups : unit -> unit

See Also

SettingsManager Class
DynamicNode.Persistence Namespace


RegisterGroup Method

[image]

DynamicNodes API
SettingsManager..::..RegisterGroup Method
SettingsManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert eine Einstellungsgruppe. Jede Einstellungsgruppe wird als Datei im Einstellungsverzeichnis gespeichert.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void RegisterGroup(
    string name
)
Visual Basic
Public Sub RegisterGroup ( _
    name As String _
)
F#
member RegisterGroup :
        name:string -> unit

Parameters

name
Type: System..::..String
Der Name der Einstellungsgruppe.

See Also

SettingsManager Class
DynamicNode.Persistence Namespace


WriteAllGroups Method

[image]

DynamicNodes API
SettingsManager..::..WriteAllGroups Method
SettingsManager Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Sichert alle Einstellungen in XML-Dateien.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteAllGroups()
Visual Basic
Public Sub WriteAllGroups
F#
member WriteAllGroups : unit -> unit

See Also

SettingsManager Class
DynamicNode.Persistence Namespace


Xml Class

[image]

DynamicNodes API
Xml Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine statische Klasse mit Hilfsfunktionen für das Arbeiten mit XML und XPath.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static class Xml
Visual Basic
Public NotInheritable Class Xml
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Xml =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Persistence..::..Xml

See Also

Xml Members
DynamicNode.Persistence Namespace


Xml Members

[image] [image]

DynamicNodes API
Xml Members
Xml Class Methods Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Xml type exposes the following members.

Methods

Name | Description
Attr | Schreibt ein Attribut für ein gerade geöffnetes XML-Element.
El | Schreibt einen öffnenden und einen schließenden Tag für ein XML-Element.
EndEl | Schreibt einen schließenden Tag für das letzte offene Element.
Init | Initialisiert die XML-Tools.
Select | Wählt Knoten mit einer XPath-Expression aus einem XPathNavigator aus.
SelectElement | Wählt ein einzelnes XML-Element mit einem XPath-Ausdruck aus.
SelectElements | Wählt eine Menge von XML-Elementen mit einem XPath-Ausdruck aus.
SelectSingle | Wählt einen einzelnen Knoten mit einer XPath-Expression aus einem XPathNaviagtor aus.
SelectString | Wählt eine einzelne Zeichenkette mit einem XPath-Ausdruck aus.
SelectStrings | Wählt eine Menge von Zeichenketten mit einem XPath-Ausdruck aus.
StartEl | Schreibt einen öffnenden Tag für ein XML-Element.
Value(XmlWriter, Boolean) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, DateTime) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Decimal) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Double) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Enum) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Int32) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Int64) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Object) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Single) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, String) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, IXmlSerializable) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Fields

Name | Description
NamespaceManager | Der Manager für DynamicNodes-XML-Namensräume.
NS | Standard Namensraum
NS_d | Namensraum für Beschreibungsdokumente
NS_hc | Namensraum für das Inhaltsverzeichnis der Hilfe
Schemas | Die Liste aller registrierten Schemata.

See Also

Xml Class
DynamicNode.Persistence Namespace


Xml Fields

[image] [image]

DynamicNodes API
Xml Fields
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Xml type exposes the following members.

Fields

Name | Description
NamespaceManager | Der Manager für DynamicNodes-XML-Namensräume.
NS | Standard Namensraum
NS_d | Namensraum für Beschreibungsdokumente
NS_hc | Namensraum für das Inhaltsverzeichnis der Hilfe
Schemas | Die Liste aller registrierten Schemata.

See Also

Xml Class
DynamicNode.Persistence Namespace


NamespaceManager Field

[image]

DynamicNodes API
Xml..::..NamespaceManager Field
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Manager für DynamicNodes-XML-Namensräume.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static readonly XmlNamespaceManager NamespaceManager
Visual Basic
Public Shared ReadOnly NamespaceManager As XmlNamespaceManager
F#
static val NamespaceManager: XmlNamespaceManager

See Also

Xml Class
DynamicNode.Persistence Namespace


NS Field

[image]

DynamicNodes API
Xml..::..NS Field
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Standard Namensraum

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static readonly string NS
Visual Basic
Public Shared ReadOnly NS As String
F#
static val NS: string

See Also

Xml Class
DynamicNode.Persistence Namespace


NS_d Field

[image]

DynamicNodes API
Xml..::..NS_d Field
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Namensraum für Beschreibungsdokumente

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static readonly string NS_d
Visual Basic
Public Shared ReadOnly NS_d As String
F#
static val NS_d: string

See Also

Xml Class
DynamicNode.Persistence Namespace


NS_hc Field

[image]

DynamicNodes API
Xml..::..NS_hc Field
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Namensraum für das Inhaltsverzeichnis der Hilfe

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static readonly string NS_hc
Visual Basic
Public Shared ReadOnly NS_hc As String
F#
static val NS_hc: string

See Also

Xml Class
DynamicNode.Persistence Namespace


Schemas Field

[image]

DynamicNodes API
Xml..::..Schemas Field
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Liste aller registrierten Schemata.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static readonly XmlSchemaSet Schemas
Visual Basic
Public Shared ReadOnly Schemas As XmlSchemaSet
F#
static val Schemas: XmlSchemaSet

See Also

Xml Class
DynamicNode.Persistence Namespace


Xml Methods

[image] [image]

DynamicNodes API
Xml Methods
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Xml type exposes the following members.

Methods

Name | Description
Attr | Schreibt ein Attribut für ein gerade geöffnetes XML-Element.
El | Schreibt einen öffnenden und einen schließenden Tag für ein XML-Element.
EndEl | Schreibt einen schließenden Tag für das letzte offene Element.
Init | Initialisiert die XML-Tools.
Select | Wählt Knoten mit einer XPath-Expression aus einem XPathNavigator aus.
SelectElement | Wählt ein einzelnes XML-Element mit einem XPath-Ausdruck aus.
SelectElements | Wählt eine Menge von XML-Elementen mit einem XPath-Ausdruck aus.
SelectSingle | Wählt einen einzelnen Knoten mit einer XPath-Expression aus einem XPathNaviagtor aus.
SelectString | Wählt eine einzelne Zeichenkette mit einem XPath-Ausdruck aus.
SelectStrings | Wählt eine Menge von Zeichenketten mit einem XPath-Ausdruck aus.
StartEl | Schreibt einen öffnenden Tag für ein XML-Element.
Value(XmlWriter, Boolean) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, DateTime) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Decimal) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Double) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Enum) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Int32) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Int64) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Object) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Single) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, String) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, IXmlSerializable) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

See Also

Xml Class
DynamicNode.Persistence Namespace


Attr Method

[image]

DynamicNodes API
Xml..::..Attr Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt ein Attribut für ein gerade geöffnetes XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Attr(
    XmlWriter w,
    string name,
    Object value
)
Visual Basic
Public Shared Sub Attr ( _
    w As XmlWriter, _
    name As String, _
    value As Object _
)
F#
static member Attr :
        w:XmlWriter *
        name:string *
        value:Object -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Ein XmlWriter.
name
Type: System..::..String
Der Name des Attributes.
value
Type: System..::..Object
Der Wert des Attributes.

See Also

Xml Class
DynamicNode.Persistence Namespace


El Method

[image]

DynamicNodes API
Xml..::..El Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt einen öffnenden und einen schließenden Tag für ein XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void El(
    XmlWriter w,
    string name,
    Object value
)
Visual Basic
Public Shared Sub El ( _
    w As XmlWriter, _
    name As String, _
    value As Object _
)
F#
static member El :
        w:XmlWriter *
        name:string *
        value:Object -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Ein XmlWriter.
name
Type: System..::..String
Der Name des Elements.
value
Type: System..::..Object
Der Wert den das Element enthalten soll.

See Also

Xml Class
DynamicNode.Persistence Namespace


EndEl Method

[image]

DynamicNodes API
Xml..::..EndEl Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt einen schließenden Tag für das letzte offene Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void EndEl(
    XmlWriter w
)
Visual Basic
Public Shared Sub EndEl ( _
    w As XmlWriter _
)
F#
static member EndEl :
        w:XmlWriter -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Ein XmlWriter.

See Also

Xml Class
DynamicNode.Persistence Namespace


Init Method

[image]

DynamicNodes API
Xml..::..Init Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die XML-Tools.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Init()
Visual Basic
Public Shared Sub Init
F#
static member Init : unit -> unit

See Also

Xml Class
DynamicNode.Persistence Namespace


Select Method

[image]

DynamicNodes API
Xml..::..Select Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wählt Knoten mit einer XPath-Expression aus einem XPathNavigator aus.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static XPathNodeIterator Select(
    XPathNavigator nav,
    string exp
)
Visual Basic
Public Shared Function Select ( _
    nav As XPathNavigator, _
    exp As String _
) As XPathNodeIterator
F#
static member Select :
        nav:XPathNavigator *
        exp:string -> XPathNodeIterator

Parameters

nav
Type: System.Xml.XPath..::..XPathNavigator
Der Eltern Navigator.
exp
Type: System..::..String
Die XPath-Expression.

Return Value

Die Auflistung aller zu der Expression passenden Knoten.

See Also

Xml Class
DynamicNode.Persistence Namespace


SelectElement Method

[image]

DynamicNodes API
Xml..::..SelectElement Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wählt ein einzelnes XML-Element mit einem XPath-Ausdruck aus.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static XmlElement SelectElement(
    XmlNode node,
    string path
)
Visual Basic
Public Shared Function SelectElement ( _
    node As XmlNode, _
    path As String _
) As XmlElement
F#
static member SelectElement :
        node:XmlNode *
        path:string -> XmlElement

Parameters

node
Type: System.Xml..::..XmlNode
Der Knoten der durchsucht werden soll.
path
Type: System..::..String
Der XPath-Ausdruck.

Return Value

Ein XmlElement oder null.

See Also

Xml Class
DynamicNode.Persistence Namespace


SelectElements Method

[image]

DynamicNodes API
Xml..::..SelectElements Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wählt eine Menge von XML-Elementen mit einem XPath-Ausdruck aus.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static IEnumerable<XmlElement> SelectElements(
    XmlNode node,
    string path
)
Visual Basic
Public Shared Function SelectElements ( _
    node As XmlNode, _
    path As String _
) As IEnumerable(Of XmlElement)
F#
static member SelectElements :
        node:XmlNode *
        path:string -> IEnumerable<XmlElement>

Parameters

node
Type: System.Xml..::..XmlNode
Der Knoten der durchsucht werden soll.
path
Type: System..::..String
Der XPath-Ausdruck.

Return Value

Eine Auflistung mit allen gefundenen XML-Elementen.

See Also

Xml Class
DynamicNode.Persistence Namespace


SelectSingle Method

[image]

DynamicNodes API
Xml..::..SelectSingle Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wählt einen einzelnen Knoten mit einer XPath-Expression aus einem XPathNaviagtor aus.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static XPathNavigator SelectSingle(
    XPathNavigator nav,
    string exp
)
Visual Basic
Public Shared Function SelectSingle ( _
    nav As XPathNavigator, _
    exp As String _
) As XPathNavigator
F#
static member SelectSingle :
        nav:XPathNavigator *
        exp:string -> XPathNavigator

Parameters

nav
Type: System.Xml.XPath..::..XPathNavigator
Der Eltern Navigator.
exp
Type: System..::..String
Die XPath-Expression.

Return Value

Dem XPathNavigator des passenden Knoten oder null.

See Also

Xml Class
DynamicNode.Persistence Namespace


SelectString Method

[image]

DynamicNodes API
Xml..::..SelectString Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wählt eine einzelne Zeichenkette mit einem XPath-Ausdruck aus.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static string SelectString(
    XmlNode node,
    string path
)
Visual Basic
Public Shared Function SelectString ( _
    node As XmlNode, _
    path As String _
) As String
F#
static member SelectString :
        node:XmlNode *
        path:string -> string

Parameters

node
Type: System.Xml..::..XmlNode
Der Knoten der durchsucht werden soll.
path
Type: System..::..String
Der XPath-Ausdruck.

Return Value

Ein String oder null.

See Also

Xml Class
DynamicNode.Persistence Namespace


SelectStrings Method

[image]

DynamicNodes API
Xml..::..SelectStrings Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wählt eine Menge von Zeichenketten mit einem XPath-Ausdruck aus.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static IEnumerable<string> SelectStrings(
    XmlNode node,
    string path
)
Visual Basic
Public Shared Function SelectStrings ( _
    node As XmlNode, _
    path As String _
) As IEnumerable(Of String)
F#
static member SelectStrings :
        node:XmlNode *
        path:string -> IEnumerable<string>

Parameters

node
Type: System.Xml..::..XmlNode
Der Knoten der durchsucht werden soll.
path
Type: System..::..String
Der XPath-Ausdruck.

Return Value

Eine Auflistung mit allen gefundenen Zeichenketten.

See Also

Xml Class
DynamicNode.Persistence Namespace


StartEl Method

[image]

DynamicNodes API
Xml..::..StartEl Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt einen öffnenden Tag für ein XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void StartEl(
    XmlWriter w,
    string name
)
Visual Basic
Public Shared Sub StartEl ( _
    w As XmlWriter, _
    name As String _
)
F#
static member StartEl :
        w:XmlWriter *
        name:string -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Ein XmlWriter.
name
Type: System..::..String
Der Name des Elements.

See Also

Xml Class
DynamicNode.Persistence Namespace


Value Method

[image] [image]

DynamicNodes API
Xml..::..Value Method
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Value(XmlWriter, Boolean) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, DateTime) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Decimal) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Double) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Enum) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Int32) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Int64) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Object) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, Single) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, String) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.
Value(XmlWriter, IXmlSerializable) | Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

See Also

Xml Class
Xml Members
DynamicNode.Persistence Namespace


Value Method (XmlWriter, Boolean)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, Boolean)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    bool value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As Boolean _
)
F#
static member Value :
        w:XmlWriter *
        value:bool -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System..::..Boolean
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


Value Method (XmlWriter, DateTime)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, DateTime)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    DateTime value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As DateTime _
)
F#
static member Value :
        w:XmlWriter *
        value:DateTime -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System..::..DateTime
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


Value Method (XmlWriter, Decimal)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, Decimal)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    decimal value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As Decimal _
)
F#
static member Value :
        w:XmlWriter *
        value:decimal -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System..::..Decimal
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


Value Method (XmlWriter, Double)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, Double)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    double value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As Double _
)
F#
static member Value :
        w:XmlWriter *
        value:float -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System..::..Double
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


Value Method (XmlWriter, Enum)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, Enum)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    Enum value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As Enum _
)
F#
static member Value :
        w:XmlWriter *
        value:Enum -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System..::..Enum
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


Value Method (XmlWriter, Int32)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, Int32)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    int value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As Integer _
)
F#
static member Value :
        w:XmlWriter *
        value:int -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System..::..Int32
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


Value Method (XmlWriter, Int64)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, Int64)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    long value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As Long _
)
F#
static member Value :
        w:XmlWriter *
        value:int64 -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System..::..Int64
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


Value Method (XmlWriter, Object)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, Object)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    Object value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As Object _
)
F#
static member Value :
        w:XmlWriter *
        value:Object -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System..::..Object
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


Value Method (XmlWriter, Single)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, Single)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    float value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As Single _
)
F#
static member Value :
        w:XmlWriter *
        value:float32 -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System..::..Single
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


Value Method (XmlWriter, String)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, String)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    string value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As String _
)
F#
static member Value :
        w:XmlWriter *
        value:string -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System..::..String
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


Value Method (XmlWriter, IXmlSerializable)

[image]

DynamicNodes API
Xml..::..Value Method (XmlWriter, IXmlSerializable)
Xml Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt den Wert als Zeichenkette in das aktuelle XML-Element.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public static void Value(
    XmlWriter w,
    IXmlSerializable value
)
Visual Basic
Public Shared Sub Value ( _
    w As XmlWriter, _
    value As IXmlSerializable _
)
F#
static member Value :
        w:XmlWriter *
        value:IXmlSerializable -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Der XML-Writer.
value
Type: System.Xml.Serialization..::..IXmlSerializable
Der Wert.

See Also

Xml Class
Value Overload
DynamicNode.Persistence Namespace


XmlPropertyReader Class

[image]

DynamicNodes API
XmlPropertyReader Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Implementiert IPropertyReader für die Transformation von XML in Eigenschaften.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class XmlPropertyReader : IPropertyReader
Visual Basic
Public Class XmlPropertyReader _
    Implements IPropertyReader
F#
type XmlPropertyReader =
    class
        interface IPropertyReader
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Persistence..::..XmlPropertyReader

See Also

XmlPropertyReader Members
DynamicNode.Persistence Namespace


XmlPropertyReader Members

[image] [image]

DynamicNodes API
XmlPropertyReader Members
XmlPropertyReader Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlPropertyReader type exposes the following members.

Constructors

 | Name | Description
Public method | XmlPropertyReader()()()() | Initialisiert eine neue Instanz der Klasse XmlPropertyReader.
Public method | XmlPropertyReader(IDictionary<(Of <<'(String, PropertyWrapper>)>>)) | Initialisiert eine neue Instanz der Klasse XmlPropertyReader mit Hilfe von Standardwerten.

Methods

 | Name | Description
Public method | ContainsProperty | Prüft ob die übergebene graphName contains property.
Public method | ReadFromXml(XmlElement) | Liest Eigenschaften aus einer XML-Quelle.
Public method | ReadFromXml(XPathNavigator) | Obsolete. Liest Eigenschaften aus einer XML-Quelle.
Public method | ReadPropertyAsBoolean | Liest eine Eigenschaft als bool.
Public method | ReadPropertyAsByte | Liest eine Eigenschaft als byte.
Public method | ReadPropertyAsDecimal | Liest eine Eigenschaft als decimal.
Public method | ReadPropertyAsDouble | Liest eine Eigenschaft als double.
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert.
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert.
Public method | ReadPropertyAsInt16 | Liest eine Eigenschaft als short.
Public method | ReadPropertyAsInt32 | Liest eine Eigenschaft als int.
Public method | ReadPropertyAsInt64 | Liest eine Eigenschaft als long.
Public method | ReadPropertyAsObject | Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt.
Public method | ReadPropertyAsSingle | Liest eine Eigenschaft als float.
Public method | ReadPropertyAsString | Liest eine Eigenschaft als string.
Public method | ReadPropertyRaw | Liest eine Eigenschaft als XML-Schnipsel.

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


XmlPropertyReader Constructor

[image] [image]

DynamicNodes API
XmlPropertyReader Constructor
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | XmlPropertyReader()()()() | Initialisiert eine neue Instanz der Klasse XmlPropertyReader.
Public method | XmlPropertyReader(IDictionary<(Of <<'(String, PropertyWrapper>)>>)) | Initialisiert eine neue Instanz der Klasse XmlPropertyReader mit Hilfe von Standardwerten.

See Also

XmlPropertyReader Class
XmlPropertyReader Members
DynamicNode.Persistence Namespace


XmlPropertyReader Constructor

[image]

DynamicNodes API
XmlPropertyReader Constructor
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse XmlPropertyReader.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public XmlPropertyReader()
Visual Basic
Public Sub New
F#
new : unit -> XmlPropertyReader

See Also

XmlPropertyReader Class
XmlPropertyReader Overload
DynamicNode.Persistence Namespace


XmlPropertyReader Constructor (IDictionary(String, PropertyWrapper))

[image]

DynamicNodes API
XmlPropertyReader Constructor (IDictionary<(Of <(<'String, PropertyWrapper>)>)>)
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse XmlPropertyReader mit Hilfe von Standardwerten.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public XmlPropertyReader(
    IDictionary<string, PropertyWrapper> props
)
Visual Basic
Public Sub New ( _
    props As IDictionary(Of String, PropertyWrapper) _
)
F#
new :
        props:IDictionary<string, PropertyWrapper> -> XmlPropertyReader

Parameters

props
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, PropertyWrapper >)>)>
Eine Wörterbuch mit Standardwerten.

See Also

XmlPropertyReader Class
XmlPropertyReader Overload
DynamicNode.Persistence Namespace


XmlPropertyReader Methods

[image] [image]

DynamicNodes API
XmlPropertyReader Methods
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlPropertyReader type exposes the following members.

Methods

 | Name | Description
Public method | ContainsProperty | Prüft ob die übergebene graphName contains property.
Public method | ReadFromXml(XmlElement) | Liest Eigenschaften aus einer XML-Quelle.
Public method | ReadFromXml(XPathNavigator) | Obsolete. Liest Eigenschaften aus einer XML-Quelle.
Public method | ReadPropertyAsBoolean | Liest eine Eigenschaft als bool.
Public method | ReadPropertyAsByte | Liest eine Eigenschaft als byte.
Public method | ReadPropertyAsDecimal | Liest eine Eigenschaft als decimal.
Public method | ReadPropertyAsDouble | Liest eine Eigenschaft als double.
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert.
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert.
Public method | ReadPropertyAsInt16 | Liest eine Eigenschaft als short.
Public method | ReadPropertyAsInt32 | Liest eine Eigenschaft als int.
Public method | ReadPropertyAsInt64 | Liest eine Eigenschaft als long.
Public method | ReadPropertyAsObject | Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt.
Public method | ReadPropertyAsSingle | Liest eine Eigenschaft als float.
Public method | ReadPropertyAsString | Liest eine Eigenschaft als string.
Public method | ReadPropertyRaw | Liest eine Eigenschaft als XML-Schnipsel.

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ContainsProperty Method

[image]

DynamicNodes API
XmlPropertyReader..::..ContainsProperty Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob die übergebene graphName contains property.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool ContainsProperty(
    string name
)
Visual Basic
Public Function ContainsProperty ( _
    name As String _
) As Boolean
F#
abstract ContainsProperty :
        name:string -> bool
override ContainsProperty :
        name:string -> bool

Parameters

name
Type: System..::..String
The graphName.

Return Value

true wenn die übergebene graphName contains property, sonst false.

Implements

IPropertyReader..::..ContainsProperty(String)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadFromXml Method

[image] [image]

DynamicNodes API
XmlPropertyReader..::..ReadFromXml Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ReadFromXml(XmlElement) | Liest Eigenschaften aus einer XML-Quelle.
Public method | ReadFromXml(XPathNavigator) | Obsolete. Liest Eigenschaften aus einer XML-Quelle.

See Also

XmlPropertyReader Class
XmlPropertyReader Members
DynamicNode.Persistence Namespace


ReadFromXml Method (XmlElement)

[image]

DynamicNodes API
XmlPropertyReader..::..ReadFromXml Method (XmlElement)
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest Eigenschaften aus einer XML-Quelle.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ReadFromXml(
    XmlElement e
)
Visual Basic
Public Sub ReadFromXml ( _
    e As XmlElement _
)
F#
member ReadFromXml :
        e:XmlElement -> unit

Parameters

e
Type: System.Xml..::..XmlElement
Das XML-Element welches die Property-Elemente als Kinder besitzt.

See Also

XmlPropertyReader Class
ReadFromXml Overload
DynamicNode.Persistence Namespace


ReadFromXml Method (XPathNavigator)

[image]

DynamicNodes API
XmlPropertyReader..::..ReadFromXml Method (XPathNavigator)
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest Eigenschaften aus einer XML-Quelle.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
[ObsoleteAttribute]
public void ReadFromXml(
    XPathNavigator nav
)
Visual Basic
<ObsoleteAttribute> _
Public Sub ReadFromXml ( _
    nav As XPathNavigator _
)
F#
[<ObsoleteAttribute>]
member ReadFromXml :
        nav:XPathNavigator -> unit

Parameters

nav
Type: System.Xml.XPath..::..XPathNavigator
Der XPath-Navigator des XML-Elements wechlches die property-Elemente als Kinder besitzt.

See Also

XmlPropertyReader Class
ReadFromXml Overload
DynamicNode.Persistence Namespace


ReadPropertyAsBoolean Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsBoolean Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als bool.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool ReadPropertyAsBoolean(
    string name,
    bool def
)
Visual Basic
Public Function ReadPropertyAsBoolean ( _
    name As String, _
    def As Boolean _
) As Boolean
F#
abstract ReadPropertyAsBoolean :
        name:string *
        def:bool -> bool
override ReadPropertyAsBoolean :
        name:string *
        def:bool -> bool

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Boolean
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsBoolean(String, Boolean)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadPropertyAsByte Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsByte Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als byte.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public byte ReadPropertyAsByte(
    string name,
    byte def
)
Visual Basic
Public Function ReadPropertyAsByte ( _
    name As String, _
    def As Byte _
) As Byte
F#
abstract ReadPropertyAsByte :
        name:string *
        def:byte -> byte
override ReadPropertyAsByte :
        name:string *
        def:byte -> byte

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Byte
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsByte(String, Byte)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadPropertyAsDecimal Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsDecimal Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als decimal.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public decimal ReadPropertyAsDecimal(
    string name,
    decimal def
)
Visual Basic
Public Function ReadPropertyAsDecimal ( _
    name As String, _
    def As Decimal _
) As Decimal
F#
abstract ReadPropertyAsDecimal :
        name:string *
        def:decimal -> decimal
override ReadPropertyAsDecimal :
        name:string *
        def:decimal -> decimal

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Decimal
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsDecimal(String, Decimal)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadPropertyAsDouble Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsDouble Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als double.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public double ReadPropertyAsDouble(
    string name,
    double def
)
Visual Basic
Public Function ReadPropertyAsDouble ( _
    name As String, _
    def As Double _
) As Double
F#
abstract ReadPropertyAsDouble :
        name:string *
        def:float -> float
override ReadPropertyAsDouble :
        name:string *
        def:float -> float

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Double
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsDouble(String, Double)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadPropertyAsEnum Method

[image] [image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsEnum Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert.
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert.

See Also

XmlPropertyReader Class
XmlPropertyReader Members
DynamicNode.Persistence Namespace


ReadPropertyAsEnum(T) Method (String, T)

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsEnum<(Of <(<'T>)>)> Method (String, T)
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als einen Aufzählungswert.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public T ReadPropertyAsEnum<T>(
    string name,
    T def
)
Visual Basic
Public Function ReadPropertyAsEnum(Of T) ( _
    name As String, _
    def As T _
) As T
F#
abstract ReadPropertyAsEnum :
        name:string *
        def:'T -> 'T
override ReadPropertyAsEnum :
        name:string *
        def:'T -> 'T

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: T
Der Standardwert.

Type Parameters

T
Der Typ der Aufzählung.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

XmlPropertyReader Class
ReadPropertyAsEnum Overload
DynamicNode.Persistence Namespace


ReadPropertyAsEnum Method (String, Enum, Type)

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsEnum Method (String, Enum, Type)
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als einen Enum-Wert.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Enum ReadPropertyAsEnum(
    string name,
    Enum def,
    Type enumType
)
Visual Basic
Public Function ReadPropertyAsEnum ( _
    name As String, _
    def As Enum, _
    enumType As Type _
) As Enum
F#
abstract ReadPropertyAsEnum :
        name:string *
        def:Enum *
        enumType:Type -> Enum
override ReadPropertyAsEnum :
        name:string *
        def:Enum *
        enumType:Type -> Enum

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Enum
Der Standardwert.
enumType
Type: System..::..Type
Das Type-Objekt des Enum.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsEnum(String, Enum, Type)

See Also

XmlPropertyReader Class
ReadPropertyAsEnum Overload
DynamicNode.Persistence Namespace


ReadPropertyAsInt16 Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsInt16 Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als short.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public short ReadPropertyAsInt16(
    string name,
    short def
)
Visual Basic
Public Function ReadPropertyAsInt16 ( _
    name As String, _
    def As Short _
) As Short
F#
abstract ReadPropertyAsInt16 :
        name:string *
        def:int16 -> int16
override ReadPropertyAsInt16 :
        name:string *
        def:int16 -> int16

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Int16
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsInt16(String, Int16)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadPropertyAsInt32 Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsInt32 Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als int.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int ReadPropertyAsInt32(
    string name,
    int def
)
Visual Basic
Public Function ReadPropertyAsInt32 ( _
    name As String, _
    def As Integer _
) As Integer
F#
abstract ReadPropertyAsInt32 :
        name:string *
        def:int -> int
override ReadPropertyAsInt32 :
        name:string *
        def:int -> int

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Int32
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsInt32(String, Int32)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadPropertyAsInt64 Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsInt64 Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als long.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public long ReadPropertyAsInt64(
    string name,
    long def
)
Visual Basic
Public Function ReadPropertyAsInt64 ( _
    name As String, _
    def As Long _
) As Long
F#
abstract ReadPropertyAsInt64 :
        name:string *
        def:int64 -> int64
override ReadPropertyAsInt64 :
        name:string *
        def:int64 -> int64

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Int64
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsInt64(String, Int64)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadPropertyAsObject Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsObject Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ReadPropertyAsObject(
    string name,
    IXmlSerializable value
)
Visual Basic
Public Sub ReadPropertyAsObject ( _
    name As String, _
    value As IXmlSerializable _
)
F#
abstract ReadPropertyAsObject :
        name:string *
        value:IXmlSerializable -> unit
override ReadPropertyAsObject :
        name:string *
        value:IXmlSerializable -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System.Xml.Serialization..::..IXmlSerializable
Das in XML serialisierbare Objekt.

Implements

IPropertyReader..::..ReadPropertyAsObject(String, IXmlSerializable)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadPropertyAsSingle Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsSingle Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als float.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public float ReadPropertyAsSingle(
    string name,
    float def
)
Visual Basic
Public Function ReadPropertyAsSingle ( _
    name As String, _
    def As Single _
) As Single
F#
abstract ReadPropertyAsSingle :
        name:string *
        def:float32 -> float32
override ReadPropertyAsSingle :
        name:string *
        def:float32 -> float32

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Single
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsSingle(String, Single)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadPropertyAsString Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyAsString Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als string.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string ReadPropertyAsString(
    string name,
    string def
)
Visual Basic
Public Function ReadPropertyAsString ( _
    name As String, _
    def As String _
) As String
F#
abstract ReadPropertyAsString :
        name:string *
        def:string -> string
override ReadPropertyAsString :
        name:string *
        def:string -> string

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..String
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsString(String, String)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


ReadPropertyRaw Method

[image]

DynamicNodes API
XmlPropertyReader..::..ReadPropertyRaw Method
XmlPropertyReader Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als XML-Schnipsel.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string ReadPropertyRaw(
    string name,
    string def
)
Visual Basic
Public Function ReadPropertyRaw ( _
    name As String, _
    def As String _
) As String
F#
abstract ReadPropertyRaw :
        name:string *
        def:string -> string
override ReadPropertyRaw :
        name:string *
        def:string -> string

Parameters

name
Type: System..::..String
Der Name der Eiugenschaft.
def
Type: System..::..String
Ein Standardwert.

Return Value

Eine Zeichenkette, welche den kompletten Inhalt des XML-Elements für die Eigenschaft name enthält.

Implements

IPropertyReader..::..ReadPropertyRaw(String, String)

See Also

XmlPropertyReader Class
DynamicNode.Persistence Namespace


XmlPropertyStorage Class

[image]

DynamicNodes API
XmlPropertyStorage Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Implementiert IPropertyStorage für die Speicherung von Eigenschaften in XML.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class XmlPropertyStorage : IPropertyStorage,
    IPropertyReader, IPropertyWriter
Visual Basic
Public Class XmlPropertyStorage _
    Implements IPropertyStorage, IPropertyReader, IPropertyWriter
F#
type XmlPropertyStorage =
    class
        interface IPropertyStorage
        interface IPropertyReader
        interface IPropertyWriter
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Persistence..::..XmlPropertyStorage

See Also

XmlPropertyStorage Members
DynamicNode.Persistence Namespace


XmlPropertyStorage Members

[image] [image]

DynamicNodes API
XmlPropertyStorage Members
XmlPropertyStorage Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlPropertyStorage type exposes the following members.

Constructors

 | Name | Description
Public method | XmlPropertyStorage()()()() | Initialisiert eine neue Instanz der Klasse XmlPropertyStorage.
Public method | XmlPropertyStorage(IDictionary<(Of <<'(String, PropertyWrapper>)>>)) | Initialisiert eine neue Instanz der Klasse XmlPropertyStorage mit Standardwerten.

Methods

 | Name | Description
Public method | ContainsProperty | Prüft ob die übergebene graphName contains property.
Public method | ReadFromXml | Liest Eigenschaften aus einer XML-Quelle.
Public method | ReadPropertyAsBoolean | Liest eine Eigenschaft als bool.
Public method | ReadPropertyAsByte | Liest eine Eigenschaft als byte.
Public method | ReadPropertyAsDecimal | Liest eine Eigenschaft als decimal.
Public method | ReadPropertyAsDouble | Liest eine Eigenschaft als double.
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert.
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert.
Public method | ReadPropertyAsInt16 | Liest eine Eigenschaft als short.
Public method | ReadPropertyAsInt32 | Liest eine Eigenschaft als int.
Public method | ReadPropertyAsInt64 | Liest eine Eigenschaft als long.
Public method | ReadPropertyAsObject | Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt.
Public method | ReadPropertyAsSingle | Liest eine Eigenschaft als float.
Public method | ReadPropertyAsString | Liest eine Eigenschaft als string.
Public method | ReadPropertyRaw | Liest eine Eigenschaft als XML-Schnipsel.
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft.
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft.
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft.
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft.
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft.
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft.
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft.
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft.
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft.
Public method | WritePropertyEnum | Schreibt eine Enum-Eigenschaft.
Public method | WritePropertyObject | Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts.
Public method | WritePropertyRaw | Schreibt einen XML-Schnipsel unverändert als Eigenschaft.
Public method | WriteToXml | Schreibt alle Eigenschaften als XML.

Properties

 | Name | Description
Public property | Properties | Gibt die

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


XmlPropertyStorage Constructor

[image] [image]

DynamicNodes API
XmlPropertyStorage Constructor
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | XmlPropertyStorage()()()() | Initialisiert eine neue Instanz der Klasse XmlPropertyStorage.
Public method | XmlPropertyStorage(IDictionary<(Of <<'(String, PropertyWrapper>)>>)) | Initialisiert eine neue Instanz der Klasse XmlPropertyStorage mit Standardwerten.

See Also

XmlPropertyStorage Class
XmlPropertyStorage Members
DynamicNode.Persistence Namespace


XmlPropertyStorage Constructor

[image]

DynamicNodes API
XmlPropertyStorage Constructor
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse XmlPropertyStorage.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public XmlPropertyStorage()
Visual Basic
Public Sub New
F#
new : unit -> XmlPropertyStorage

See Also

XmlPropertyStorage Class
XmlPropertyStorage Overload
DynamicNode.Persistence Namespace


XmlPropertyStorage Constructor (IDictionary(String, PropertyWrapper))

[image]

DynamicNodes API
XmlPropertyStorage Constructor (IDictionary<(Of <(<'String, PropertyWrapper>)>)>)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse XmlPropertyStorage mit Standardwerten.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public XmlPropertyStorage(
    IDictionary<string, PropertyWrapper> props
)
Visual Basic
Public Sub New ( _
    props As IDictionary(Of String, PropertyWrapper) _
)
F#
new :
        props:IDictionary<string, PropertyWrapper> -> XmlPropertyStorage

Parameters

props
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, PropertyWrapper >)>)>
Ein Wörterbuch mit Standardwerten.

See Also

XmlPropertyStorage Class
XmlPropertyStorage Overload
DynamicNode.Persistence Namespace


XmlPropertyStorage Methods

[image] [image]

DynamicNodes API
XmlPropertyStorage Methods
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlPropertyStorage type exposes the following members.

Methods

 | Name | Description
Public method | ContainsProperty | Prüft ob die übergebene graphName contains property.
Public method | ReadFromXml | Liest Eigenschaften aus einer XML-Quelle.
Public method | ReadPropertyAsBoolean | Liest eine Eigenschaft als bool.
Public method | ReadPropertyAsByte | Liest eine Eigenschaft als byte.
Public method | ReadPropertyAsDecimal | Liest eine Eigenschaft als decimal.
Public method | ReadPropertyAsDouble | Liest eine Eigenschaft als double.
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert.
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert.
Public method | ReadPropertyAsInt16 | Liest eine Eigenschaft als short.
Public method | ReadPropertyAsInt32 | Liest eine Eigenschaft als int.
Public method | ReadPropertyAsInt64 | Liest eine Eigenschaft als long.
Public method | ReadPropertyAsObject | Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt.
Public method | ReadPropertyAsSingle | Liest eine Eigenschaft als float.
Public method | ReadPropertyAsString | Liest eine Eigenschaft als string.
Public method | ReadPropertyRaw | Liest eine Eigenschaft als XML-Schnipsel.
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft.
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft.
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft.
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft.
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft.
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft.
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft.
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft.
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft.
Public method | WritePropertyEnum | Schreibt eine Enum-Eigenschaft.
Public method | WritePropertyObject | Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts.
Public method | WritePropertyRaw | Schreibt einen XML-Schnipsel unverändert als Eigenschaft.
Public method | WriteToXml | Schreibt alle Eigenschaften als XML.

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ContainsProperty Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ContainsProperty Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob die übergebene graphName contains property.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool ContainsProperty(
    string name
)
Visual Basic
Public Function ContainsProperty ( _
    name As String _
) As Boolean
F#
abstract ContainsProperty :
        name:string -> bool
override ContainsProperty :
        name:string -> bool

Parameters

name
Type: System..::..String
The graphName.

Return Value

true wenn die übergebene graphName contains property, sonst false.

Implements

IPropertyReader..::..ContainsProperty(String)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadFromXml Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadFromXml Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest Eigenschaften aus einer XML-Quelle.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ReadFromXml(
    XPathNavigator nav
)
Visual Basic
Public Sub ReadFromXml ( _
    nav As XPathNavigator _
)
F#
member ReadFromXml :
        nav:XPathNavigator -> unit

Parameters

nav
Type: System.Xml.XPath..::..XPathNavigator
Der XPath-Navigator des XML-Elements wechlches die property-Elemente als Kinder besitzt.

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyAsBoolean Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsBoolean Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als bool.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public bool ReadPropertyAsBoolean(
    string name,
    bool def
)
Visual Basic
Public Function ReadPropertyAsBoolean ( _
    name As String, _
    def As Boolean _
) As Boolean
F#
abstract ReadPropertyAsBoolean :
        name:string *
        def:bool -> bool
override ReadPropertyAsBoolean :
        name:string *
        def:bool -> bool

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Boolean
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsBoolean(String, Boolean)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyAsByte Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsByte Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als byte.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public byte ReadPropertyAsByte(
    string name,
    byte def
)
Visual Basic
Public Function ReadPropertyAsByte ( _
    name As String, _
    def As Byte _
) As Byte
F#
abstract ReadPropertyAsByte :
        name:string *
        def:byte -> byte
override ReadPropertyAsByte :
        name:string *
        def:byte -> byte

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Byte
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsByte(String, Byte)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyAsDecimal Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsDecimal Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als decimal.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public decimal ReadPropertyAsDecimal(
    string name,
    decimal def
)
Visual Basic
Public Function ReadPropertyAsDecimal ( _
    name As String, _
    def As Decimal _
) As Decimal
F#
abstract ReadPropertyAsDecimal :
        name:string *
        def:decimal -> decimal
override ReadPropertyAsDecimal :
        name:string *
        def:decimal -> decimal

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Decimal
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsDecimal(String, Decimal)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyAsDouble Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsDouble Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als double.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public double ReadPropertyAsDouble(
    string name,
    double def
)
Visual Basic
Public Function ReadPropertyAsDouble ( _
    name As String, _
    def As Double _
) As Double
F#
abstract ReadPropertyAsDouble :
        name:string *
        def:float -> float
override ReadPropertyAsDouble :
        name:string *
        def:float -> float

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Double
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsDouble(String, Double)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyAsEnum Method

[image] [image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsEnum Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ReadPropertyAsEnum<(Of <<'(T>)>>)(String, T) | Liest eine Eigenschaft als einen Aufzählungswert.
Public method | ReadPropertyAsEnum(String, Enum, Type) | Liest eine Eigenschaft als einen Enum-Wert.

See Also

XmlPropertyStorage Class
XmlPropertyStorage Members
DynamicNode.Persistence Namespace


ReadPropertyAsEnum(T) Method (String, T)

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsEnum<(Of <(<'T>)>)> Method (String, T)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als einen Aufzählungswert.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public T ReadPropertyAsEnum<T>(
    string name,
    T def
)
Visual Basic
Public Function ReadPropertyAsEnum(Of T) ( _
    name As String, _
    def As T _
) As T
F#
abstract ReadPropertyAsEnum :
        name:string *
        def:'T -> 'T
override ReadPropertyAsEnum :
        name:string *
        def:'T -> 'T

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: T
Der Standardwert.

Type Parameters

T
Der Typ der Aufzählung.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

See Also

XmlPropertyStorage Class
ReadPropertyAsEnum Overload
DynamicNode.Persistence Namespace


ReadPropertyAsEnum Method (String, Enum, Type)

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsEnum Method (String, Enum, Type)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als einen Enum-Wert.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public Enum ReadPropertyAsEnum(
    string name,
    Enum def,
    Type enumType
)
Visual Basic
Public Function ReadPropertyAsEnum ( _
    name As String, _
    def As Enum, _
    enumType As Type _
) As Enum
F#
abstract ReadPropertyAsEnum :
        name:string *
        def:Enum *
        enumType:Type -> Enum
override ReadPropertyAsEnum :
        name:string *
        def:Enum *
        enumType:Type -> Enum

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Enum
Der Standardwert.
enumType
Type: System..::..Type
Das Type-Objekt des Enum.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsEnum(String, Enum, Type)

See Also

XmlPropertyStorage Class
ReadPropertyAsEnum Overload
DynamicNode.Persistence Namespace


ReadPropertyAsInt16 Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsInt16 Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als short.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public short ReadPropertyAsInt16(
    string name,
    short def
)
Visual Basic
Public Function ReadPropertyAsInt16 ( _
    name As String, _
    def As Short _
) As Short
F#
abstract ReadPropertyAsInt16 :
        name:string *
        def:int16 -> int16
override ReadPropertyAsInt16 :
        name:string *
        def:int16 -> int16

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Int16
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsInt16(String, Int16)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyAsInt32 Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsInt32 Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als int.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public int ReadPropertyAsInt32(
    string name,
    int def
)
Visual Basic
Public Function ReadPropertyAsInt32 ( _
    name As String, _
    def As Integer _
) As Integer
F#
abstract ReadPropertyAsInt32 :
        name:string *
        def:int -> int
override ReadPropertyAsInt32 :
        name:string *
        def:int -> int

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Int32
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsInt32(String, Int32)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyAsInt64 Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsInt64 Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als long.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public long ReadPropertyAsInt64(
    string name,
    long def
)
Visual Basic
Public Function ReadPropertyAsInt64 ( _
    name As String, _
    def As Long _
) As Long
F#
abstract ReadPropertyAsInt64 :
        name:string *
        def:int64 -> int64
override ReadPropertyAsInt64 :
        name:string *
        def:int64 -> int64

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Int64
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsInt64(String, Int64)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyAsObject Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsObject Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest den Inhalt einer Eigenschaft als XML und deserialisiert damit das übergebene Objekt.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void ReadPropertyAsObject(
    string name,
    IXmlSerializable value
)
Visual Basic
Public Sub ReadPropertyAsObject ( _
    name As String, _
    value As IXmlSerializable _
)
F#
abstract ReadPropertyAsObject :
        name:string *
        value:IXmlSerializable -> unit
override ReadPropertyAsObject :
        name:string *
        value:IXmlSerializable -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System.Xml.Serialization..::..IXmlSerializable
Das in XML serialisierbare Objekt.

Implements

IPropertyReader..::..ReadPropertyAsObject(String, IXmlSerializable)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyAsSingle Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsSingle Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als float.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public float ReadPropertyAsSingle(
    string name,
    float def
)
Visual Basic
Public Function ReadPropertyAsSingle ( _
    name As String, _
    def As Single _
) As Single
F#
abstract ReadPropertyAsSingle :
        name:string *
        def:float32 -> float32
override ReadPropertyAsSingle :
        name:string *
        def:float32 -> float32

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..Single
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsSingle(String, Single)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyAsString Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyAsString Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als string.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string ReadPropertyAsString(
    string name,
    string def
)
Visual Basic
Public Function ReadPropertyAsString ( _
    name As String, _
    def As String _
) As String
F#
abstract ReadPropertyAsString :
        name:string *
        def:string -> string
override ReadPropertyAsString :
        name:string *
        def:string -> string

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
def
Type: System..::..String
Der Standardwert.

Return Value

Wenn eine Eigenschaft mit dem übergebenen Namen existiert der gelesene Wert, sonst der Standardwert.

Implements

IPropertyReader..::..ReadPropertyAsString(String, String)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


ReadPropertyRaw Method

[image]

DynamicNodes API
XmlPropertyStorage..::..ReadPropertyRaw Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest eine Eigenschaft als XML-Schnipsel.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public string ReadPropertyRaw(
    string name,
    string def
)
Visual Basic
Public Function ReadPropertyRaw ( _
    name As String, _
    def As String _
) As String
F#
abstract ReadPropertyRaw :
        name:string *
        def:string -> string
override ReadPropertyRaw :
        name:string *
        def:string -> string

Parameters

name
Type: System..::..String
Der Name der Eiugenschaft.
def
Type: System..::..String
Ein Standardwert.

Return Value

Eine Zeichenkette, welche den kompletten Inhalt des XML-Elements für die Eigenschaft name enthält.

Implements

IPropertyReader..::..ReadPropertyRaw(String, String)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


WriteProperty Method

[image] [image]

DynamicNodes API
XmlPropertyStorage..::..WriteProperty Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft.
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft.
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft.
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft.
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft.
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft.
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft.
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft.
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft.

See Also

XmlPropertyStorage Class
XmlPropertyStorage Members
DynamicNode.Persistence Namespace


WriteProperty Method (String, Boolean)

[image]

DynamicNodes API
XmlPropertyStorage..::..WriteProperty Method (String, Boolean)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine bool-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    bool value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Boolean _
)
F#
abstract WriteProperty :
        name:string *
        value:bool -> unit
override WriteProperty :
        name:string *
        value:bool -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Boolean
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Boolean)

See Also

XmlPropertyStorage Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Byte)

[image]

DynamicNodes API
XmlPropertyStorage..::..WriteProperty Method (String, Byte)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine byte-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    byte value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Byte _
)
F#
abstract WriteProperty :
        name:string *
        value:byte -> unit
override WriteProperty :
        name:string *
        value:byte -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Byte
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Byte)

See Also

XmlPropertyStorage Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Decimal)

[image]

DynamicNodes API
XmlPropertyStorage..::..WriteProperty Method (String, Decimal)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine decimal-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    decimal value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Decimal _
)
F#
abstract WriteProperty :
        name:string *
        value:decimal -> unit
override WriteProperty :
        name:string *
        value:decimal -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Decimal
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Decimal)

See Also

XmlPropertyStorage Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Double)

[image]

DynamicNodes API
XmlPropertyStorage..::..WriteProperty Method (String, Double)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine double-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    double value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Double _
)
F#
abstract WriteProperty :
        name:string *
        value:float -> unit
override WriteProperty :
        name:string *
        value:float -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Double
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Double)

See Also

XmlPropertyStorage Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Int16)

[image]

DynamicNodes API
XmlPropertyStorage..::..WriteProperty Method (String, Int16)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine short-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    short value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Short _
)
F#
abstract WriteProperty :
        name:string *
        value:int16 -> unit
override WriteProperty :
        name:string *
        value:int16 -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Int16
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Int16)

See Also

XmlPropertyStorage Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Int32)

[image]

DynamicNodes API
XmlPropertyStorage..::..WriteProperty Method (String, Int32)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine int-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    int value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Integer _
)
F#
abstract WriteProperty :
        name:string *
        value:int -> unit
override WriteProperty :
        name:string *
        value:int -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Int32
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Int32)

See Also

XmlPropertyStorage Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Int64)

[image]

DynamicNodes API
XmlPropertyStorage..::..WriteProperty Method (String, Int64)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine long-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    long value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Long _
)
F#
abstract WriteProperty :
        name:string *
        value:int64 -> unit
override WriteProperty :
        name:string *
        value:int64 -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Int64
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Int64)

See Also

XmlPropertyStorage Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Single)

[image]

DynamicNodes API
XmlPropertyStorage..::..WriteProperty Method (String, Single)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine float-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    float value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Single _
)
F#
abstract WriteProperty :
        name:string *
        value:float32 -> unit
override WriteProperty :
        name:string *
        value:float32 -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Single
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Single)

See Also

XmlPropertyStorage Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, String)

[image]

DynamicNodes API
XmlPropertyStorage..::..WriteProperty Method (String, String)
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine string-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    string value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As String _
)
F#
abstract WriteProperty :
        name:string *
        value:string -> unit
override WriteProperty :
        name:string *
        value:string -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..String
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, String)

See Also

XmlPropertyStorage Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WritePropertyEnum Method

[image]

DynamicNodes API
XmlPropertyStorage..::..WritePropertyEnum Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine Enum-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WritePropertyEnum(
    string name,
    Object value
)
Visual Basic
Public Sub WritePropertyEnum ( _
    name As String, _
    value As Object _
)
F#
abstract WritePropertyEnum :
        name:string *
        value:Object -> unit
override WritePropertyEnum :
        name:string *
        value:Object -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Object
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WritePropertyEnum(String, Object)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


WritePropertyObject Method

[image]

DynamicNodes API
XmlPropertyStorage..::..WritePropertyObject Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WritePropertyObject(
    string name,
    IXmlSerializable value
)
Visual Basic
Public Sub WritePropertyObject ( _
    name As String, _
    value As IXmlSerializable _
)
F#
abstract WritePropertyObject :
        name:string *
        value:IXmlSerializable -> unit
override WritePropertyObject :
        name:string *
        value:IXmlSerializable -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System.Xml.Serialization..::..IXmlSerializable
Das in XML serialisierbare Objekt.

Implements

IPropertyWriter..::..WritePropertyObject(String, IXmlSerializable)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


WritePropertyRaw Method

[image]

DynamicNodes API
XmlPropertyStorage..::..WritePropertyRaw Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt einen XML-Schnipsel unverändert als Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WritePropertyRaw(
    string name,
    string xml
)
Visual Basic
Public Sub WritePropertyRaw ( _
    name As String, _
    xml As String _
)
F#
abstract WritePropertyRaw :
        name:string *
        xml:string -> unit
override WritePropertyRaw :
        name:string *
        xml:string -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
xml
Type: System..::..String
Der XML-Schnipsel.

Implements

IPropertyWriter..::..WritePropertyRaw(String, String)

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


WriteToXml Method

[image]

DynamicNodes API
XmlPropertyStorage..::..WriteToXml Method
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt alle Eigenschaften als XML.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteToXml(
    XmlWriter w
)
Visual Basic
Public Sub WriteToXml ( _
    w As XmlWriter _
)
F#
member WriteToXml :
        w:XmlWriter -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Ein XmlWriter.

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


XmlPropertyStorage Properties

[image] [image]

DynamicNodes API
XmlPropertyStorage Properties
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlPropertyStorage type exposes the following members.

Properties

 | Name | Description
Public property | Properties | Gibt die

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


Properties Property

[image]

DynamicNodes API
XmlPropertyStorage..::..Properties Property
XmlPropertyStorage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IDictionary<string, PropertyWrapper> Properties { get; }
Visual Basic
Public ReadOnly Property Properties As IDictionary(Of String, PropertyWrapper)
    Get
F#
member Properties : IDictionary<string, PropertyWrapper>

Field Value

The properties.

See Also

XmlPropertyStorage Class
DynamicNode.Persistence Namespace


XmlPropertyWriter Class

[image]

DynamicNodes API
XmlPropertyWriter Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Implementiert IPropertyWriter für die Transformation von Eigenschaften in XML.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public class XmlPropertyWriter : IPropertyWriter
Visual Basic
Public Class XmlPropertyWriter _
    Implements IPropertyWriter
F#
type XmlPropertyWriter =
    class
        interface IPropertyWriter
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Persistence..::..XmlPropertyWriter

See Also

XmlPropertyWriter Members
DynamicNode.Persistence Namespace


XmlPropertyWriter Members

[image] [image]

DynamicNodes API
XmlPropertyWriter Members
XmlPropertyWriter Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlPropertyWriter type exposes the following members.

Constructors

 | Name | Description
Public method | XmlPropertyWriter()()()() | Initialisiert eine neue Instanz der Klasse XmlPropertyWriter.
Public method | XmlPropertyWriter(IDictionary<(Of <<'(String, PropertyWrapper>)>>)) | Initialisiert eine neue Instanz der Klasse XmlPropertyWriter.

Methods

 | Name | Description
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft.
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft.
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft.
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft.
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft.
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft.
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft.
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft.
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft.
Public method | WritePropertyEnum | Schreibt eine Enum-Eigenschaft.
Public method | WritePropertyObject | Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts.
Public method | WritePropertyRaw | Schreibt einen XML-Schnipsel unverändert als Eigenschaft.
Public method | WriteToXml | Schreibt alle Eigenschaften als XML.

Properties

 | Name | Description
Public property | Properties | Gibt die

See Also

XmlPropertyWriter Class
DynamicNode.Persistence Namespace


XmlPropertyWriter Constructor

[image] [image]

DynamicNodes API
XmlPropertyWriter Constructor
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | XmlPropertyWriter()()()() | Initialisiert eine neue Instanz der Klasse XmlPropertyWriter.
Public method | XmlPropertyWriter(IDictionary<(Of <<'(String, PropertyWrapper>)>>)) | Initialisiert eine neue Instanz der Klasse XmlPropertyWriter.

See Also

XmlPropertyWriter Class
XmlPropertyWriter Members
DynamicNode.Persistence Namespace


XmlPropertyWriter Constructor

[image]

DynamicNodes API
XmlPropertyWriter Constructor
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse XmlPropertyWriter.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public XmlPropertyWriter()
Visual Basic
Public Sub New
F#
new : unit -> XmlPropertyWriter

See Also

XmlPropertyWriter Class
XmlPropertyWriter Overload
DynamicNode.Persistence Namespace


XmlPropertyWriter Constructor (IDictionary(String, PropertyWrapper))

[image]

DynamicNodes API
XmlPropertyWriter Constructor (IDictionary<(Of <(<'String, PropertyWrapper>)>)>)
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse XmlPropertyWriter.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public XmlPropertyWriter(
    IDictionary<string, PropertyWrapper> props
)
Visual Basic
Public Sub New ( _
    props As IDictionary(Of String, PropertyWrapper) _
)
F#
new :
        props:IDictionary<string, PropertyWrapper> -> XmlPropertyWriter

Parameters

props
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, PropertyWrapper >)>)>
Ein Wörterbuch mit Eigenschaften.

See Also

XmlPropertyWriter Class
XmlPropertyWriter Overload
DynamicNode.Persistence Namespace


XmlPropertyWriter Methods

[image] [image]

DynamicNodes API
XmlPropertyWriter Methods
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlPropertyWriter type exposes the following members.

Methods

 | Name | Description
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft.
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft.
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft.
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft.
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft.
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft.
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft.
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft.
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft.
Public method | WritePropertyEnum | Schreibt eine Enum-Eigenschaft.
Public method | WritePropertyObject | Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts.
Public method | WritePropertyRaw | Schreibt einen XML-Schnipsel unverändert als Eigenschaft.
Public method | WriteToXml | Schreibt alle Eigenschaften als XML.

See Also

XmlPropertyWriter Class
DynamicNode.Persistence Namespace


WriteProperty Method

[image] [image]

DynamicNodes API
XmlPropertyWriter..::..WriteProperty Method
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | WriteProperty(String, Boolean) | Schreibt eine bool-Eigenschaft.
Public method | WriteProperty(String, Byte) | Schreibt eine byte-Eigenschaft.
Public method | WriteProperty(String, Decimal) | Schreibt eine decimal-Eigenschaft.
Public method | WriteProperty(String, Double) | Schreibt eine double-Eigenschaft.
Public method | WriteProperty(String, Int16) | Schreibt eine short-Eigenschaft.
Public method | WriteProperty(String, Int32) | Schreibt eine int-Eigenschaft.
Public method | WriteProperty(String, Int64) | Schreibt eine long-Eigenschaft.
Public method | WriteProperty(String, Single) | Schreibt eine float-Eigenschaft.
Public method | WriteProperty(String, String) | Schreibt eine string-Eigenschaft.

See Also

XmlPropertyWriter Class
XmlPropertyWriter Members
DynamicNode.Persistence Namespace


WriteProperty Method (String, Boolean)

[image]

DynamicNodes API
XmlPropertyWriter..::..WriteProperty Method (String, Boolean)
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine bool-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    bool value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Boolean _
)
F#
abstract WriteProperty :
        name:string *
        value:bool -> unit
override WriteProperty :
        name:string *
        value:bool -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Boolean
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Boolean)

See Also

XmlPropertyWriter Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Byte)

[image]

DynamicNodes API
XmlPropertyWriter..::..WriteProperty Method (String, Byte)
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine byte-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    byte value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Byte _
)
F#
abstract WriteProperty :
        name:string *
        value:byte -> unit
override WriteProperty :
        name:string *
        value:byte -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Byte
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Byte)

See Also

XmlPropertyWriter Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Decimal)

[image]

DynamicNodes API
XmlPropertyWriter..::..WriteProperty Method (String, Decimal)
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine decimal-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    decimal value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Decimal _
)
F#
abstract WriteProperty :
        name:string *
        value:decimal -> unit
override WriteProperty :
        name:string *
        value:decimal -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Decimal
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Decimal)

See Also

XmlPropertyWriter Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Double)

[image]

DynamicNodes API
XmlPropertyWriter..::..WriteProperty Method (String, Double)
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine double-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    double value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Double _
)
F#
abstract WriteProperty :
        name:string *
        value:float -> unit
override WriteProperty :
        name:string *
        value:float -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Double
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Double)

See Also

XmlPropertyWriter Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Int16)

[image]

DynamicNodes API
XmlPropertyWriter..::..WriteProperty Method (String, Int16)
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine short-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    short value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Short _
)
F#
abstract WriteProperty :
        name:string *
        value:int16 -> unit
override WriteProperty :
        name:string *
        value:int16 -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Int16
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Int16)

See Also

XmlPropertyWriter Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Int32)

[image]

DynamicNodes API
XmlPropertyWriter..::..WriteProperty Method (String, Int32)
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine int-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    int value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Integer _
)
F#
abstract WriteProperty :
        name:string *
        value:int -> unit
override WriteProperty :
        name:string *
        value:int -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Int32
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Int32)

See Also

XmlPropertyWriter Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Int64)

[image]

DynamicNodes API
XmlPropertyWriter..::..WriteProperty Method (String, Int64)
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine long-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    long value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Long _
)
F#
abstract WriteProperty :
        name:string *
        value:int64 -> unit
override WriteProperty :
        name:string *
        value:int64 -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Int64
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Int64)

See Also

XmlPropertyWriter Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, Single)

[image]

DynamicNodes API
XmlPropertyWriter..::..WriteProperty Method (String, Single)
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine float-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    float value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As Single _
)
F#
abstract WriteProperty :
        name:string *
        value:float32 -> unit
override WriteProperty :
        name:string *
        value:float32 -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Single
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, Single)

See Also

XmlPropertyWriter Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WriteProperty Method (String, String)

[image]

DynamicNodes API
XmlPropertyWriter..::..WriteProperty Method (String, String)
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine string-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteProperty(
    string name,
    string value
)
Visual Basic
Public Sub WriteProperty ( _
    name As String, _
    value As String _
)
F#
abstract WriteProperty :
        name:string *
        value:string -> unit
override WriteProperty :
        name:string *
        value:string -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..String
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WriteProperty(String, String)

See Also

XmlPropertyWriter Class
WriteProperty Overload
DynamicNode.Persistence Namespace


WritePropertyEnum Method

[image]

DynamicNodes API
XmlPropertyWriter..::..WritePropertyEnum Method
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine Enum-Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WritePropertyEnum(
    string name,
    Object value
)
Visual Basic
Public Sub WritePropertyEnum ( _
    name As String, _
    value As Object _
)
F#
abstract WritePropertyEnum :
        name:string *
        value:Object -> unit
override WritePropertyEnum :
        name:string *
        value:Object -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System..::..Object
Der Wert der Eigenschaft.

Implements

IPropertyWriter..::..WritePropertyEnum(String, Object)

See Also

XmlPropertyWriter Class
DynamicNode.Persistence Namespace


WritePropertyObject Method

[image]

DynamicNodes API
XmlPropertyWriter..::..WritePropertyObject Method
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt eine Eigenschaft mit der Serialisierung eines in XML serialisierbaren Objekts.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WritePropertyObject(
    string name,
    IXmlSerializable value
)
Visual Basic
Public Sub WritePropertyObject ( _
    name As String, _
    value As IXmlSerializable _
)
F#
abstract WritePropertyObject :
        name:string *
        value:IXmlSerializable -> unit
override WritePropertyObject :
        name:string *
        value:IXmlSerializable -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
value
Type: System.Xml.Serialization..::..IXmlSerializable
Das in XML serialisierbare Objekt.

Implements

IPropertyWriter..::..WritePropertyObject(String, IXmlSerializable)

See Also

XmlPropertyWriter Class
DynamicNode.Persistence Namespace


WritePropertyRaw Method

[image]

DynamicNodes API
XmlPropertyWriter..::..WritePropertyRaw Method
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt einen XML-Schnipsel unverändert als Eigenschaft.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WritePropertyRaw(
    string name,
    string xml
)
Visual Basic
Public Sub WritePropertyRaw ( _
    name As String, _
    xml As String _
)
F#
abstract WritePropertyRaw :
        name:string *
        xml:string -> unit
override WritePropertyRaw :
        name:string *
        xml:string -> unit

Parameters

name
Type: System..::..String
Der Name der Eigenschaft.
xml
Type: System..::..String
Der XML-Schnipsel.

Implements

IPropertyWriter..::..WritePropertyRaw(String, String)

See Also

XmlPropertyWriter Class
DynamicNode.Persistence Namespace


WriteToXml Method

[image]

DynamicNodes API
XmlPropertyWriter..::..WriteToXml Method
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schreibt alle Eigenschaften als XML.

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public void WriteToXml(
    XmlWriter w
)
Visual Basic
Public Sub WriteToXml ( _
    w As XmlWriter _
)
F#
member WriteToXml :
        w:XmlWriter -> unit

Parameters

w
Type: System.Xml..::..XmlWriter
Ein XmlWriter.

See Also

XmlPropertyWriter Class
DynamicNode.Persistence Namespace


XmlPropertyWriter Properties

[image] [image]

DynamicNodes API
XmlPropertyWriter Properties
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XmlPropertyWriter type exposes the following members.

Properties

 | Name | Description
Public property | Properties | Gibt die

See Also

XmlPropertyWriter Class
DynamicNode.Persistence Namespace


Properties Property

[image]

DynamicNodes API
XmlPropertyWriter..::..Properties Property
XmlPropertyWriter Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die

Namespace: DynamicNode.Persistence
Assembly: DNCore (in DNCore.dll) Version: 1.4.4679.19807 (1.4.0.0)

Syntax

C#
public IDictionary<string, PropertyWrapper> Properties { get; }
Visual Basic
Public ReadOnly Property Properties As IDictionary(Of String, PropertyWrapper)
    Get
F#
member Properties : IDictionary<string, PropertyWrapper>

Field Value

The properties.

See Also

XmlPropertyWriter Class
DynamicNode.Persistence Namespace


DynamicNode.Remoting Namespace

[image]

DynamicNodes API
DynamicNode.Remoting Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält Schnittstellen und Typen für die Fernsteuerung einer DynamicNodes-Laufzeitumgebung über eine Netzwerkverbindung.

Eine wichtige Klasse in diesem Namensraum ist die Server-Klasse, welche für eine Remote-Verbindung als Einsteigsklasse registriert werden kann. DynamicNodesServer

Classes

 | Class | Description
Public class | ApplicationContextService | Das Fernsteuer-Objekt für eine DynamicNodes-Anwendung. Dabei kann es sich um eine Entwicklungsumgebung oder einen Anwendungsserver handeln.
Public class | DynamicNodesServer | Das Einstiegsobjekt für die Fernsteuerung einer DynamicNodes-Laufzeitumgebung.
Public class | GraphService | Das Fernsteuererungs-Objekt für einen Graphen.
Public class | InPortService | Das Fernsteuer-Objekt für einen Eingang.
Public class | NodeService | Das Fernsteuerungs-Objekt für einen Knoten.
Public class | OutPortService | Das Fernsteuer-Objekt für einen Ausgang.
Public class | PortService | Das Fernsteuer-Objekt für einen Anschluss.
Public class | RuntimeService | Das Fernsteuerungs-Objekt für eine Laufzeitumgebung.

Structures

 | Structure | Description
Public structure | RemoteToken | Eine Marke die für die Fernsteuerung geeignet ist.

Interfaces

 | Interface | Description
Public interface | IRemoteApplicationContext | Die Schnittstelle für eine ferngesteuerte DynamicNodes-Anwendung. Dabei kann es sich um eine Entwicklungsumgebung oder um einen Anwendungs-Server handeln.
Public interface | IRemoteGraph | Die Schnittstelle für einen ferngesteuerten Graphen.
Public interface | IRemoteInPort | Die Schnittstelle für einen ferngesteuerten Eingang.
Public interface | IRemoteNode | Die Schnittstelle für einen ferngesteuerten Knoten.
Public interface | IRemoteOutPort | Die Schnittstelle für einen ferngesteuerten Ausgang.
Public interface | IRemotePort | Die Schnittstelle für einen ferngesteuerten Anschluss.
Public interface | IRemoteRuntime | Die Schnittstelle für eine ferngesteuerte Laufzeitumgebung.

Enumerations

 | Enumeration | Description
Public enumeration | RemoteTokenState | Der Status einer ferngesteuerten Marke.


ApplicationContextService Class

[image]

DynamicNodes API
ApplicationContextService Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Fernsteuer-Objekt für eine DynamicNodes-Anwendung. Dabei kann es sich um eine Entwicklungsumgebung oder einen Anwendungsserver handeln.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class ApplicationContextService : MarshalByRefObject
Visual Basic
Public Class ApplicationContextService _
    Inherits MarshalByRefObject
F#
type ApplicationContextService =
    class
        inherit MarshalByRefObject
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
DynamicNode.Remoting..::..ApplicationContextService

See Also

ApplicationContextService Members
DynamicNode.Remoting Namespace


ApplicationContextService Members

[image] [image]

DynamicNodes API
ApplicationContextService Members
ApplicationContextService Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ApplicationContextService type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationContextService | Initialisiert eine neue Instanz von ApplicationContextService.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein Script in der DynamicNodes-Anwendung aus.

See Also

ApplicationContextService Class
DynamicNode.Remoting Namespace


ApplicationContextService Constructor

[image]

DynamicNodes API
ApplicationContextService Constructor
ApplicationContextService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ApplicationContextService.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public ApplicationContextService(
    IRemoteApplicationContext appContext
)
Visual Basic
Public Sub New ( _
    appContext As IRemoteApplicationContext _
)
F#
new :
        appContext:IRemoteApplicationContext -> ApplicationContextService

Parameters

appContext
Type: DynamicNode.Remoting..::..IRemoteApplicationContext
Der fernsteuerbare Anwendungskontext.

See Also

ApplicationContextService Class
DynamicNode.Remoting Namespace


ApplicationContextService Methods

[image] [image]

DynamicNodes API
ApplicationContextService Methods
ApplicationContextService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ApplicationContextService type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein Script in der DynamicNodes-Anwendung aus.

See Also

ApplicationContextService Class
DynamicNode.Remoting Namespace


ExecuteScript Method

[image]

DynamicNodes API
ApplicationContextService..::..ExecuteScript Method
ApplicationContextService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt ein Script in der DynamicNodes-Anwendung aus.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string ExecuteScript(
    string script
)
Visual Basic
Public Function ExecuteScript ( _
    script As String _
) As String
F#
member ExecuteScript :
        script:string -> string

Parameters

script
Type: System..::..String
Der Quelltext des Scripts.

Return Value

[Missing <returns> documentation for "M:DynamicNode.Remoting.ApplicationContextService.ExecuteScript(System.String)"]

See Also

ApplicationContextService Class
DynamicNode.Remoting Namespace


DynamicNodesServer Class

[image]

DynamicNodes API
DynamicNodesServer Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Einstiegsobjekt für die Fernsteuerung einer DynamicNodes-Laufzeitumgebung.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class DynamicNodesServer : MarshalByRefObject
Visual Basic
Public Class DynamicNodesServer _
    Inherits MarshalByRefObject
F#
type DynamicNodesServer =
    class
        inherit MarshalByRefObject
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
DynamicNode.Remoting..::..DynamicNodesServer

See Also

DynamicNodesServer Members
DynamicNode.Remoting Namespace


DynamicNodesServer Members

[image] [image]

DynamicNodes API
DynamicNodesServer Members
DynamicNodesServer Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DynamicNodesServer type exposes the following members.

Constructors

 | Name | Description
Public method | DynamicNodesServer | Initializes a new instance of the DynamicNodesServer class

Methods

 | Name | Description
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Overrides MarshalByRefObject..::..InitializeLifetimeService()()()().)
 | InitServer | Initialisiert den Fernsteuerungs-Server mit einer fernsteuerbaren Laufzeitumgebung.

Properties

 | Name | Description
Public property | ApplicationContext | Gibt den Anwendungskontextn zurück.
 | ApplicationContextService | Gibt den Fernsteuerungs-Proxy der Anwendung zurück.
Public property | Runtime | Gibt die Laufzeitumgebung zurück.
 | RuntimeService | Gibt den Fernsteuerungs-Proxy der Standard-Laufzeitumgebung zurück.

See Also

DynamicNodesServer Class
DynamicNode.Remoting Namespace


DynamicNodesServer Constructor

[image]

DynamicNodes API
DynamicNodesServer Constructor
DynamicNodesServer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the DynamicNodesServer class

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public DynamicNodesServer()
Visual Basic
Public Sub New
F#
new : unit -> DynamicNodesServer

See Also

DynamicNodesServer Class
DynamicNode.Remoting Namespace


DynamicNodesServer Methods

[image] [image]

DynamicNodes API
DynamicNodesServer Methods
DynamicNodesServer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DynamicNodesServer type exposes the following members.

Methods

 | Name | Description
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Overrides MarshalByRefObject..::..InitializeLifetimeService()()()().)
 | InitServer | Initialisiert den Fernsteuerungs-Server mit einer fernsteuerbaren Laufzeitumgebung.

See Also

DynamicNodesServer Class
DynamicNode.Remoting Namespace


InitializeLifetimeService Method

[image]

DynamicNodes API
DynamicNodesServer..::..InitializeLifetimeService Method
DynamicNodesServer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Obtains a lifetime service object to control the lifetime policy for this instance.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public override Object InitializeLifetimeService()
Visual Basic
Public Overrides Function InitializeLifetimeService As Object
F#
abstract InitializeLifetimeService : unit -> Object
override InitializeLifetimeService : unit -> Object

Return Value

An object of type ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the LeaseManagerPollTime property.

Exceptions

Exception | Condition
System.Security..::..SecurityException | The immediate caller does not have infrastructure permission.

See Also

DynamicNodesServer Class
DynamicNode.Remoting Namespace


InitServer Method

[image]

DynamicNodes API
DynamicNodesServer..::..InitServer Method
DynamicNodesServer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert den Fernsteuerungs-Server mit einer fernsteuerbaren Laufzeitumgebung.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public static void InitServer(
    IRemoteApplicationContext remoteAppContext,
    IRemoteRuntime remoteRuntime
)
Visual Basic
Public Shared Sub InitServer ( _
    remoteAppContext As IRemoteApplicationContext, _
    remoteRuntime As IRemoteRuntime _
)
F#
static member InitServer :
        remoteAppContext:IRemoteApplicationContext *
        remoteRuntime:IRemoteRuntime -> unit

Parameters

remoteAppContext
Type: DynamicNode.Remoting..::..IRemoteApplicationContext
Der fernsteuerbare Anwendungskontext.
remoteRuntime
Type: DynamicNode.Remoting..::..IRemoteRuntime
Die fernsteuerbare Laufzeitumgebung.

See Also

DynamicNodesServer Class
DynamicNode.Remoting Namespace


DynamicNodesServer Properties

[image] [image]

DynamicNodes API
DynamicNodesServer Properties
DynamicNodesServer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DynamicNodesServer type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationContext | Gibt den Anwendungskontextn zurück.
 | ApplicationContextService | Gibt den Fernsteuerungs-Proxy der Anwendung zurück.
Public property | Runtime | Gibt die Laufzeitumgebung zurück.
 | RuntimeService | Gibt den Fernsteuerungs-Proxy der Standard-Laufzeitumgebung zurück.

See Also

DynamicNodesServer Class
DynamicNode.Remoting Namespace


ApplicationContext Property

[image]

DynamicNodes API
DynamicNodesServer..::..ApplicationContext Property
DynamicNodesServer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Anwendungskontextn zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public ApplicationContextService ApplicationContext { get; }
Visual Basic
Public ReadOnly Property ApplicationContext As ApplicationContextService
    Get
F#
member ApplicationContext : ApplicationContextService

Field Value

Der Anwendungskontext.

See Also

DynamicNodesServer Class
DynamicNode.Remoting Namespace


ApplicationContextService Property

[image]

DynamicNodes API
DynamicNodesServer..::..ApplicationContextService Property
DynamicNodesServer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Fernsteuerungs-Proxy der Anwendung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public static ApplicationContextService ApplicationContextService { get; private set; }
Visual Basic
Public Shared Property ApplicationContextService As ApplicationContextService
    Get
    Private Set
F#
static member ApplicationContextService : ApplicationContextService with get, private set

Field Value

Der Fernsteuerungs-Proxy für die Anwendung.

See Also

DynamicNodesServer Class
DynamicNode.Remoting Namespace


Runtime Property

[image]

DynamicNodes API
DynamicNodesServer..::..Runtime Property
DynamicNodesServer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Laufzeitumgebung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public RuntimeService Runtime { get; }
Visual Basic
Public ReadOnly Property Runtime As RuntimeService
    Get
F#
member Runtime : RuntimeService

Field Value

Die Laufzeitumgebung.

See Also

DynamicNodesServer Class
DynamicNode.Remoting Namespace


RuntimeService Property

[image]

DynamicNodes API
DynamicNodesServer..::..RuntimeService Property
DynamicNodesServer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Fernsteuerungs-Proxy der Standard-Laufzeitumgebung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public static RuntimeService RuntimeService { get; private set; }
Visual Basic
Public Shared Property RuntimeService As RuntimeService
    Get
    Private Set
F#
static member RuntimeService : RuntimeService with get, private set

Field Value

Der Fernsteuerungs-Proxy für die Standard-Laufzeitumgebung.

See Also

DynamicNodesServer Class
DynamicNode.Remoting Namespace


GraphService Class

[image]

DynamicNodes API
GraphService Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Fernsteuererungs-Objekt für einen Graphen.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class GraphService : MarshalByRefObject
Visual Basic
Public Class GraphService _
    Inherits MarshalByRefObject
F#
type GraphService =
    class
        inherit MarshalByRefObject
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
DynamicNode.Remoting..::..GraphService

See Also

GraphService Members
DynamicNode.Remoting Namespace


GraphService Members

[image] [image]

DynamicNodes API
GraphService Members
GraphService Class Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphService type exposes the following members.

Methods

 | Name | Description
Public method | ActivateNodes | Aktiviert alle Knoten im Graphen.

Properties

 | Name | Description
Public property | Description | Gibt eine Beschreibung des Graphen zurück.
Public property | GraphStateFlags | Gibt ein Wörterbuch mit den Flags des Graphen zurück. Graphen-Flags werden durch Knoten der Klasse DynamicNode.Core.Nodes.NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens. Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.
Public property | Id | Gibt die ID des Graphen zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob der verknüpfte Graph freigegeben wurde.
Public property | Name | Gibt den Namen des Graphen zurück.
Public property | Nodes | Gibt die Knoten des Graphen als Array zurück.

See Also

GraphService Class
DynamicNode.Remoting Namespace


GraphService Methods

[image] [image]

DynamicNodes API
GraphService Methods
GraphService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphService type exposes the following members.

Methods

 | Name | Description
Public method | ActivateNodes | Aktiviert alle Knoten im Graphen.

See Also

GraphService Class
DynamicNode.Remoting Namespace


ActivateNodes Method

[image]

DynamicNodes API
GraphService..::..ActivateNodes Method
GraphService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert alle Knoten im Graphen.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void ActivateNodes()
Visual Basic
Public Sub ActivateNodes
F#
member ActivateNodes : unit -> unit

See Also

GraphService Class
DynamicNode.Remoting Namespace


GraphService Properties

[image] [image]

DynamicNodes API
GraphService Properties
GraphService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GraphService type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gibt eine Beschreibung des Graphen zurück.
Public property | GraphStateFlags | Gibt ein Wörterbuch mit den Flags des Graphen zurück. Graphen-Flags werden durch Knoten der Klasse DynamicNode.Core.Nodes.NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens. Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.
Public property | Id | Gibt die ID des Graphen zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob der verknüpfte Graph freigegeben wurde.
Public property | Name | Gibt den Namen des Graphen zurück.
Public property | Nodes | Gibt die Knoten des Graphen als Array zurück.

See Also

GraphService Class
DynamicNode.Remoting Namespace


Description Property

[image]

DynamicNodes API
GraphService..::..Description Property
GraphService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Beschreibung des Graphen zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
F#
member Description : string

Field Value

Die Beschreibung.

See Also

GraphService Class
DynamicNode.Remoting Namespace


GraphStateFlags Property

[image]

DynamicNodes API
GraphService..::..GraphStateFlags Property
GraphService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Gibt ein Wörterbuch mit den Flags des Graphen zurück.

Graphen-Flags werden durch Knoten der Klasse DynamicNode.Core.Nodes.NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens.

Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public IDictionary<string, RemoteTokenState> GraphStateFlags { get; }
Visual Basic
Public ReadOnly Property GraphStateFlags As IDictionary(Of String, RemoteTokenState)
    Get
F#
member GraphStateFlags : IDictionary<string, RemoteTokenState>

Field Value

Die Flags des Graphen.

See Also

GraphService Class
DynamicNode.Remoting Namespace


Id Property

[image]

DynamicNodes API
GraphService..::..Id Property
GraphService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Graphen zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
F#
member Id : int

Field Value

Die ID.

See Also

GraphService Class
DynamicNode.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
GraphService..::..IsDisposed Property
GraphService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob der verknüpfte Graph freigegeben wurde.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsDisposed { get; }
Visual Basic
Public ReadOnly Property IsDisposed As Boolean
    Get
F#
member IsDisposed : bool

Field Value

true, wenn der verknüpfte Graph freigegeben wurde, andernfalls false.

See Also

GraphService Class
DynamicNode.Remoting Namespace


Name Property

[image]

DynamicNodes API
GraphService..::..Name Property
GraphService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Graphen zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
member Name : string

Field Value

Der Name.

See Also

GraphService Class
DynamicNode.Remoting Namespace


Nodes Property

[image]

DynamicNodes API
GraphService..::..Nodes Property
GraphService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Knoten des Graphen als Array zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public NodeService[] Nodes { get; }
Visual Basic
Public ReadOnly Property Nodes As NodeService()
    Get
F#
member Nodes : NodeService[]

Field Value

Die Knoten des Graphen.

See Also

GraphService Class
DynamicNode.Remoting Namespace


InPortService Class

[image]

DynamicNodes API
InPortService Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Fernsteuer-Objekt für einen Eingang.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class InPortService : PortService
Visual Basic
Public Class InPortService _
    Inherits PortService
F#
type InPortService =
    class
        inherit PortService
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
DynamicNode.Remoting..::..PortService
DynamicNode.Remoting..::..InPortService

See Also

InPortService Members
DynamicNode.Remoting Namespace


InPortService Members

[image] [image]

DynamicNodes API
InPortService Members
InPortService Class Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortService type exposes the following members.

Fields

 | Name | Description
Protected field | port | Der ferngesteuerte Anschluss. (Inherited from PortService.)

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from PortService.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from PortService.)
Public property | HasQueue | Gibt einen Wert zurück, der angibt ob diese Instanz eine Queue besitzt.
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from PortService.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from PortService.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from PortService.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from PortService.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from PortService.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from PortService.)

See Also

InPortService Class
DynamicNode.Remoting Namespace


InPortService Fields

[image] [image]

DynamicNodes API
InPortService Fields
InPortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortService type exposes the following members.

Fields

 | Name | Description
Protected field | port | Der ferngesteuerte Anschluss. (Inherited from PortService.)

See Also

InPortService Class
DynamicNode.Remoting Namespace


InPortService Properties

[image] [image]

DynamicNodes API
InPortService Properties
InPortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InPortService type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from PortService.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from PortService.)
Public property | HasQueue | Gibt einen Wert zurück, der angibt ob diese Instanz eine Queue besitzt.
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from PortService.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from PortService.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from PortService.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from PortService.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from PortService.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from PortService.)

See Also

InPortService Class
DynamicNode.Remoting Namespace


HasQueue Property

[image]

DynamicNodes API
InPortService..::..HasQueue Property
InPortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob diese Instanz eine Queue besitzt.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool HasQueue { get; }
Visual Basic
Public ReadOnly Property HasQueue As Boolean
    Get
F#
member HasQueue : bool

Field Value

true wenn diese Instanz eine Queue besitzt, sonst false.

See Also

InPortService Class
DynamicNode.Remoting Namespace


IRemoteApplicationContext Interface

[image]

DynamicNodes API
IRemoteApplicationContext Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für eine ferngesteuerte DynamicNodes-Anwendung. Dabei kann es sich um eine Entwicklungsumgebung oder um einen Anwendungs-Server handeln.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public interface IRemoteApplicationContext
Visual Basic
Public Interface IRemoteApplicationContext
F#
type IRemoteApplicationContext =  interface end

See Also

IRemoteApplicationContext Members
DynamicNode.Remoting Namespace


IRemoteApplicationContext Members

[image] [image]

DynamicNodes API
IRemoteApplicationContext Members
IRemoteApplicationContext Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteApplicationContext type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein Script in der DynamicNodes-Anwendung aus.

See Also

IRemoteApplicationContext Interface
DynamicNode.Remoting Namespace


IRemoteApplicationContext Methods

[image] [image]

DynamicNodes API
IRemoteApplicationContext Methods
IRemoteApplicationContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteApplicationContext type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteScript | Führt ein Script in der DynamicNodes-Anwendung aus.

See Also

IRemoteApplicationContext Interface
DynamicNode.Remoting Namespace


ExecuteScript Method

[image]

DynamicNodes API
IRemoteApplicationContext..::..ExecuteScript Method
IRemoteApplicationContext Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt ein Script in der DynamicNodes-Anwendung aus.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string ExecuteScript(
    string script
)
Visual Basic
Function ExecuteScript ( _
    script As String _
) As String
F#
abstract ExecuteScript :
        script:string -> string

Parameters

script
Type: System..::..String
Der Quelltext des Scripts.

Return Value

Die Ausgabe.

See Also

IRemoteApplicationContext Interface
DynamicNode.Remoting Namespace


IRemoteGraph Interface

[image]

DynamicNodes API
IRemoteGraph Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für einen ferngesteuerten Graphen.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public interface IRemoteGraph
Visual Basic
Public Interface IRemoteGraph
F#
type IRemoteGraph =  interface end

See Also

IRemoteGraph Members
DynamicNode.Remoting Namespace


IRemoteGraph Members

[image] [image]

DynamicNodes API
IRemoteGraph Members
IRemoteGraph Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteGraph type exposes the following members.

Methods

 | Name | Description
Public method | ActivateNodes | Aktiviert alle Knoten im Graphen.

Properties

 | Name | Description
Public property | Description | Gibt eine Beschreibung des Graphen zurück.
Public property | GraphStateFlags | Gibt ein Wörterbuch mit den Flags des Graphen zurück. Graphen-Flags werden durch Knoten der Klasse DynamicNode.Core.Nodes.NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens. Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.
Public property | Id | Gibt die ID des Graphen zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen des Graphen zurück.
Public property | Nodes | Gibt die Knoten des Graphen als Array zurück.

See Also

IRemoteGraph Interface
DynamicNode.Remoting Namespace


IRemoteGraph Methods

[image] [image]

DynamicNodes API
IRemoteGraph Methods
IRemoteGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteGraph type exposes the following members.

Methods

 | Name | Description
Public method | ActivateNodes | Aktiviert alle Knoten im Graphen.

See Also

IRemoteGraph Interface
DynamicNode.Remoting Namespace


ActivateNodes Method

[image]

DynamicNodes API
IRemoteGraph..::..ActivateNodes Method
IRemoteGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert alle Knoten im Graphen.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
void ActivateNodes()
Visual Basic
Sub ActivateNodes
F#
abstract ActivateNodes : unit -> unit

See Also

IRemoteGraph Interface
DynamicNode.Remoting Namespace


IRemoteGraph Properties

[image] [image]

DynamicNodes API
IRemoteGraph Properties
IRemoteGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteGraph type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gibt eine Beschreibung des Graphen zurück.
Public property | GraphStateFlags | Gibt ein Wörterbuch mit den Flags des Graphen zurück. Graphen-Flags werden durch Knoten der Klasse DynamicNode.Core.Nodes.NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens. Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.
Public property | Id | Gibt die ID des Graphen zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen des Graphen zurück.
Public property | Nodes | Gibt die Knoten des Graphen als Array zurück.

See Also

IRemoteGraph Interface
DynamicNode.Remoting Namespace


Description Property

[image]

DynamicNodes API
IRemoteGraph..::..Description Property
IRemoteGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Beschreibung des Graphen zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string Description { get; }
Visual Basic
ReadOnly Property Description As String
    Get
F#
abstract Description : string

Field Value

Die Beschreibung.

See Also

IRemoteGraph Interface
DynamicNode.Remoting Namespace


GraphStateFlags Property

[image]

DynamicNodes API
IRemoteGraph..::..GraphStateFlags Property
IRemoteGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Gibt ein Wörterbuch mit den Flags des Graphen zurück.

Graphen-Flags werden durch Knoten der Klasse DynamicNode.Core.Nodes.NFlag im Graphen definiert, besitzen einen eindeutigen Namen und einen Zustand. Der Zustand entspricht dem Token-Status der Lesekopie am Eingang "flag" des entsprechenden Flag-Knotens.

Mit Hilfe von Flags können Zustände des Datenfluss-Graphen nach außen sichtbar gemacht werden.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
IDictionary<string, RemoteTokenState> GraphStateFlags { get; }
Visual Basic
ReadOnly Property GraphStateFlags As IDictionary(Of String, RemoteTokenState)
    Get
F#
abstract GraphStateFlags : IDictionary<string, RemoteTokenState>

Field Value

Die Flags des Graphen.

See Also

IRemoteGraph Interface
DynamicNode.Remoting Namespace


Id Property

[image]

DynamicNodes API
IRemoteGraph..::..Id Property
IRemoteGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Graphen zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
int Id { get; }
Visual Basic
ReadOnly Property Id As Integer
    Get
F#
abstract Id : int

Field Value

Die ID.

See Also

IRemoteGraph Interface
DynamicNode.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
IRemoteGraph..::..IsDisposed Property
IRemoteGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
bool IsDisposed { get; }
Visual Basic
ReadOnly Property IsDisposed As Boolean
    Get
F#
abstract IsDisposed : bool

Field Value

true, wenn das Objekt freigegeben wurde, andernfalls false.

See Also

IRemoteGraph Interface
DynamicNode.Remoting Namespace


Name Property

[image]

DynamicNodes API
IRemoteGraph..::..Name Property
IRemoteGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Graphen zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
F#
abstract Name : string

Field Value

Der Name.

See Also

IRemoteGraph Interface
DynamicNode.Remoting Namespace


Nodes Property

[image]

DynamicNodes API
IRemoteGraph..::..Nodes Property
IRemoteGraph Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Knoten des Graphen als Array zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
IRemoteNode[] Nodes { get; }
Visual Basic
ReadOnly Property Nodes As IRemoteNode()
    Get
F#
abstract Nodes : IRemoteNode[]

Field Value

Die Knoten des Graphen.

See Also

IRemoteGraph Interface
DynamicNode.Remoting Namespace


IRemoteInPort Interface

[image]

DynamicNodes API
IRemoteInPort Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für einen ferngesteuerten Eingang.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public interface IRemoteInPort : IRemotePort
Visual Basic
Public Interface IRemoteInPort _
    Inherits IRemotePort
F#
type IRemoteInPort =
    interface
        interface IRemotePort
    end

See Also

IRemoteInPort Members
DynamicNode.Remoting Namespace


IRemoteInPort Members

[image] [image]

DynamicNodes API
IRemoteInPort Members
IRemoteInPort Interface Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteInPort type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from IRemotePort.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from IRemotePort.)
Public property | HasQueue | Gibt einen Wert zurück, der angibt ob diese Instanz eine Queue besitzt.
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from IRemotePort.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from IRemotePort.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from IRemotePort.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from IRemotePort.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from IRemotePort.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from IRemotePort.)

See Also

IRemoteInPort Interface
DynamicNode.Remoting Namespace


IRemoteInPort Properties

[image] [image]

DynamicNodes API
IRemoteInPort Properties
IRemoteInPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteInPort type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from IRemotePort.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from IRemotePort.)
Public property | HasQueue | Gibt einen Wert zurück, der angibt ob diese Instanz eine Queue besitzt.
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from IRemotePort.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from IRemotePort.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from IRemotePort.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from IRemotePort.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from IRemotePort.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from IRemotePort.)

See Also

IRemoteInPort Interface
DynamicNode.Remoting Namespace


HasQueue Property

[image]

DynamicNodes API
IRemoteInPort..::..HasQueue Property
IRemoteInPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob diese Instanz eine Queue besitzt.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
bool HasQueue { get; }
Visual Basic
ReadOnly Property HasQueue As Boolean
    Get
F#
abstract HasQueue : bool

Field Value

true wenn diese Instanz eine Queue besitzt, sonst false.

See Also

IRemoteInPort Interface
DynamicNode.Remoting Namespace


IRemoteNode Interface

[image]

DynamicNodes API
IRemoteNode Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für einen ferngesteuerten Knoten.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public interface IRemoteNode
Visual Basic
Public Interface IRemoteNode
F#
type IRemoteNode =  interface end

See Also

IRemoteNode Members
DynamicNode.Remoting Namespace


IRemoteNode Members

[image] [image]

DynamicNodes API
IRemoteNode Members
IRemoteNode Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteNode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen.
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Properties

 | Name | Description
Public property | Commands | Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.
Public property | Description | Gibt eine Beschreibung des Knoten zurück.
Public property | Id | Gibt die ID des Knoten zurück.
Public property | InPorts | Gibt ein Array mit allen Eingängen des Knotens zurück.
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen des Knoten zurück.
Public property | OutPorts | Gibt ein Array mit allen Ausgängen des Knotens zurück.
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück.
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


IRemoteNode Methods

[image] [image]

DynamicNodes API
IRemoteNode Methods
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteNode type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten von außen.
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


Activate Method

[image]

DynamicNodes API
IRemoteNode..::..Activate Method
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert den Knoten von außen.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
void Activate()
Visual Basic
Sub Activate
F#
abstract Activate : unit -> unit

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


OnCommand Method

[image]

DynamicNodes API
IRemoteNode..::..OnCommand Method
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
void OnCommand(
    string command
)
Visual Basic
Sub OnCommand ( _
    command As String _
)
F#
abstract OnCommand :
        command:string -> unit

Parameters

command
Type: System..::..String
Der Befehls-Code des Benutzerbefehls.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


OnDefaultCommand Method

[image]

DynamicNodes API
IRemoteNode..::..OnDefaultCommand Method
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
void OnDefaultCommand()
Visual Basic
Sub OnDefaultCommand
F#
abstract OnDefaultCommand : unit -> unit

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


IRemoteNode Properties

[image] [image]

DynamicNodes API
IRemoteNode Properties
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteNode type exposes the following members.

Properties

 | Name | Description
Public property | Commands | Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.
Public property | Description | Gibt eine Beschreibung des Knoten zurück.
Public property | Id | Gibt die ID des Knoten zurück.
Public property | InPorts | Gibt ein Array mit allen Eingängen des Knotens zurück.
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen des Knoten zurück.
Public property | OutPorts | Gibt ein Array mit allen Ausgängen des Knotens zurück.
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück.
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


Commands Property

[image]

DynamicNodes API
IRemoteNode..::..Commands Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
IDictionary<string, string> Commands { get; }
Visual Basic
ReadOnly Property Commands As IDictionary(Of String, String)
    Get
F#
abstract Commands : IDictionary<string, string>

Field Value

Die Benutzerbefehle.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


Description Property

[image]

DynamicNodes API
IRemoteNode..::..Description Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Beschreibung des Knoten zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string Description { get; }
Visual Basic
ReadOnly Property Description As String
    Get
F#
abstract Description : string

Field Value

Die Beschreibung.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


Id Property

[image]

DynamicNodes API
IRemoteNode..::..Id Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Knoten zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
int Id { get; }
Visual Basic
ReadOnly Property Id As Integer
    Get
F#
abstract Id : int

Field Value

Die ID.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


InPorts Property

[image]

DynamicNodes API
IRemoteNode..::..InPorts Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Eingängen des Knotens zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
IRemoteInPort[] InPorts { get; }
Visual Basic
ReadOnly Property InPorts As IRemoteInPort()
    Get
F#
abstract InPorts : IRemoteInPort[]

Field Value

Die Eingänge.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


IsActive Property

[image]

DynamicNodes API
IRemoteNode..::..IsActive Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
bool IsActive { get; }
Visual Basic
ReadOnly Property IsActive As Boolean
    Get
F#
abstract IsActive : bool

Field Value

true, wenn dieser Knoten aktiv ist, sonst false.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
IRemoteNode..::..IsDisposed Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
bool IsDisposed { get; }
Visual Basic
ReadOnly Property IsDisposed As Boolean
    Get
F#
abstract IsDisposed : bool

Field Value

true, wenn das Objekt freigegeben wurde, andernfalls false.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


Name Property

[image]

DynamicNodes API
IRemoteNode..::..Name Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Knoten zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
F#
abstract Name : string

Field Value

Der Name.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


OutPorts Property

[image]

DynamicNodes API
IRemoteNode..::..OutPorts Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Ausgängen des Knotens zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
IRemoteOutPort[] OutPorts { get; }
Visual Basic
ReadOnly Property OutPorts As IRemoteOutPort()
    Get
F#
abstract OutPorts : IRemoteOutPort[]

Field Value

Die Ausgänge.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


TypeCaption Property

[image]

DynamicNodes API
IRemoteNode..::..TypeCaption Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung des Knoten-Typs zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string TypeCaption { get; }
Visual Basic
ReadOnly Property TypeCaption As String
    Get
F#
abstract TypeCaption : string

Field Value

Die Beschriftung des Knoten-Typs.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


TypeDescription Property

[image]

DynamicNodes API
IRemoteNode..::..TypeDescription Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Knoten-Typs zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string TypeDescription { get; }
Visual Basic
ReadOnly Property TypeDescription As String
    Get
F#
abstract TypeDescription : string

Field Value

Die Beschreibung des Knoten-Typs.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


TypeGroup Property

[image]

DynamicNodes API
IRemoteNode..::..TypeGroup Property
IRemoteNode Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Gruppe des Knoten-Typs zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string TypeGroup { get; }
Visual Basic
ReadOnly Property TypeGroup As String
    Get
F#
abstract TypeGroup : string

Field Value

Die Gruppe des Knoten-Typs.

See Also

IRemoteNode Interface
DynamicNode.Remoting Namespace


IRemoteOutPort Interface

[image]

DynamicNodes API
IRemoteOutPort Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für einen ferngesteuerten Ausgang.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public interface IRemoteOutPort : IRemotePort
Visual Basic
Public Interface IRemoteOutPort _
    Inherits IRemotePort
F#
type IRemoteOutPort =
    interface
        interface IRemotePort
    end

See Also

IRemoteOutPort Members
DynamicNode.Remoting Namespace


IRemoteOutPort Members

[image] [image]

DynamicNodes API
IRemoteOutPort Members
IRemoteOutPort Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteOutPort type exposes the following members.

Methods

 | Name | Description
Public method | Fire | Gibt die Marke an die verbundenen Eingänge weiter.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from IRemotePort.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from IRemotePort.)
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from IRemotePort.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from IRemotePort.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from IRemotePort.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from IRemotePort.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from IRemotePort.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from IRemotePort.)

See Also

IRemoteOutPort Interface
DynamicNode.Remoting Namespace


IRemoteOutPort Methods

[image] [image]

DynamicNodes API
IRemoteOutPort Methods
IRemoteOutPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteOutPort type exposes the following members.

Methods

 | Name | Description
Public method | Fire | Gibt die Marke an die verbundenen Eingänge weiter.

See Also

IRemoteOutPort Interface
DynamicNode.Remoting Namespace


Fire Method

[image]

DynamicNodes API
IRemoteOutPort..::..Fire Method
IRemoteOutPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Marke an die verbundenen Eingänge weiter.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
void Fire()
Visual Basic
Sub Fire
F#
abstract Fire : unit -> unit

See Also

IRemoteOutPort Interface
DynamicNode.Remoting Namespace


IRemoteOutPort Properties

[image] [image]

DynamicNodes API
IRemoteOutPort Properties
IRemoteOutPort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteOutPort type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from IRemotePort.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from IRemotePort.)
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from IRemotePort.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from IRemotePort.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from IRemotePort.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from IRemotePort.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from IRemotePort.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from IRemotePort.)

See Also

IRemoteOutPort Interface
DynamicNode.Remoting Namespace


IRemotePort Interface

[image]

DynamicNodes API
IRemotePort Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für einen ferngesteuerten Anschluss.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public interface IRemotePort
Visual Basic
Public Interface IRemotePort
F#
type IRemotePort =  interface end

See Also

IRemotePort Members
DynamicNode.Remoting Namespace


IRemotePort Members

[image] [image]

DynamicNodes API
IRemotePort Members
IRemotePort Interface Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemotePort type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück.
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück.
Public property | Id | Gibt die ID des Anschlusses zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist.
Public property | Name | Gibt den Namen des Anschlusses zurück.
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück.
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück.

See Also

IRemotePort Interface
DynamicNode.Remoting Namespace


IRemotePort Properties

[image] [image]

DynamicNodes API
IRemotePort Properties
IRemotePort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemotePort type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück.
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück.
Public property | Id | Gibt die ID des Anschlusses zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist.
Public property | Name | Gibt den Namen des Anschlusses zurück.
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück.
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück.

See Also

IRemotePort Interface
DynamicNode.Remoting Namespace


ConnectionCount Property

[image]

DynamicNodes API
IRemotePort..::..ConnectionCount Property
IRemotePort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller Verbindungen mit diesem Port zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
int ConnectionCount { get; }
Visual Basic
ReadOnly Property ConnectionCount As Integer
    Get
F#
abstract ConnectionCount : int

Field Value

Die Anzahl der Verbindungen.

See Also

IRemotePort Interface
DynamicNode.Remoting Namespace


Description Property

[image]

DynamicNodes API
IRemotePort..::..Description Property
IRemotePort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung dieses Anschlusses zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string Description { get; }
Visual Basic
ReadOnly Property Description As String
    Get
F#
abstract Description : string

Field Value

Die Beschreibung.

See Also

IRemotePort Interface
DynamicNode.Remoting Namespace


Id Property

[image]

DynamicNodes API
IRemotePort..::..Id Property
IRemotePort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Anschlusses zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
int Id { get; }
Visual Basic
ReadOnly Property Id As Integer
    Get
F#
abstract Id : int

Field Value

Die ID.

See Also

IRemotePort Interface
DynamicNode.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
IRemotePort..::..IsDisposed Property
IRemotePort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
bool IsDisposed { get; }
Visual Basic
ReadOnly Property IsDisposed As Boolean
    Get
F#
abstract IsDisposed : bool

Field Value

true, wenn das Objekt freigegeben wurde, andernfalls false.

See Also

IRemotePort Interface
DynamicNode.Remoting Namespace


IsSuperPort Property

[image]

DynamicNodes API
IRemotePort..::..IsSuperPort Property
IRemotePort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an oder legt fest ob dieser Port ein Super-Port ist.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
bool IsSuperPort { get; }
Visual Basic
ReadOnly Property IsSuperPort As Boolean
    Get
F#
abstract IsSuperPort : bool

Field Value

true wenn die Instanz ein Super-Port ist, sonst false.

See Also

IRemotePort Interface
DynamicNode.Remoting Namespace


Name Property

[image]

DynamicNodes API
IRemotePort..::..Name Property
IRemotePort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Anschlusses zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
F#
abstract Name : string

Field Value

Der Name.

See Also

IRemotePort Interface
DynamicNode.Remoting Namespace


ReadCopy Property

[image]

DynamicNodes API
IRemotePort..::..ReadCopy Property
IRemotePort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Lese-Kopie der aktuellen Marke zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
RemoteToken ReadCopy { get; }
Visual Basic
ReadOnly Property ReadCopy As RemoteToken
    Get
F#
abstract ReadCopy : RemoteToken

Field Value

Die Lese-Kopie der aktuellen Marke.

See Also

IRemotePort Interface
DynamicNode.Remoting Namespace


SuperName Property

[image]

DynamicNodes API
IRemotePort..::..SuperName Property
IRemotePort Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Super-Name für Modul-Anschlüsse zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string SuperName { get; }
Visual Basic
ReadOnly Property SuperName As String
    Get
F#
abstract SuperName : string

Field Value

Der Super-Name.

See Also

IRemotePort Interface
DynamicNode.Remoting Namespace


IRemoteRuntime Interface

[image]

DynamicNodes API
IRemoteRuntime Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle für eine ferngesteuerte Laufzeitumgebung.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public interface IRemoteRuntime
Visual Basic
Public Interface IRemoteRuntime
F#
type IRemoteRuntime =  interface end

See Also

IRemoteRuntime Members
DynamicNode.Remoting Namespace


IRemoteRuntime Members

[image] [image]

DynamicNodes API
IRemoteRuntime Members
IRemoteRuntime Interface Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteRuntime type exposes the following members.

Properties

 | Name | Description
Public property | CountGraphs | Gibt die Anzahl der Graphen in der Laufzeitumgebung zurück.
Public property | Graphs | Gibt ein Array mit allen Graphen der Laufzeitumgebung zurück.
Public property | Id | Gibt die ID der Laufzeitumgebung zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen der Laufzeitumgebung zurück.

See Also

IRemoteRuntime Interface
DynamicNode.Remoting Namespace


IRemoteRuntime Properties

[image] [image]

DynamicNodes API
IRemoteRuntime Properties
IRemoteRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRemoteRuntime type exposes the following members.

Properties

 | Name | Description
Public property | CountGraphs | Gibt die Anzahl der Graphen in der Laufzeitumgebung zurück.
Public property | Graphs | Gibt ein Array mit allen Graphen der Laufzeitumgebung zurück.
Public property | Id | Gibt die ID der Laufzeitumgebung zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | Name | Gibt den Namen der Laufzeitumgebung zurück.

See Also

IRemoteRuntime Interface
DynamicNode.Remoting Namespace


CountGraphs Property

[image]

DynamicNodes API
IRemoteRuntime..::..CountGraphs Property
IRemoteRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der Graphen in der Laufzeitumgebung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
int CountGraphs { get; }
Visual Basic
ReadOnly Property CountGraphs As Integer
    Get
F#
abstract CountGraphs : int

Field Value

Die Anzahl der Graphen.

See Also

IRemoteRuntime Interface
DynamicNode.Remoting Namespace


Graphs Property

[image]

DynamicNodes API
IRemoteRuntime..::..Graphs Property
IRemoteRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Graphen der Laufzeitumgebung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
IRemoteGraph[] Graphs { get; }
Visual Basic
ReadOnly Property Graphs As IRemoteGraph()
    Get
F#
abstract Graphs : IRemoteGraph[]

Field Value

Die Graphen.

See Also

IRemoteRuntime Interface
DynamicNode.Remoting Namespace


Id Property

[image]

DynamicNodes API
IRemoteRuntime..::..Id Property
IRemoteRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID der Laufzeitumgebung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
int Id { get; }
Visual Basic
ReadOnly Property Id As Integer
    Get
F#
abstract Id : int

Field Value

Die ID.

See Also

IRemoteRuntime Interface
DynamicNode.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
IRemoteRuntime..::..IsDisposed Property
IRemoteRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
bool IsDisposed { get; }
Visual Basic
ReadOnly Property IsDisposed As Boolean
    Get
F#
abstract IsDisposed : bool

Field Value

true, wenn das Objekt freigegeben wurde, andernfalls false.

See Also

IRemoteRuntime Interface
DynamicNode.Remoting Namespace


Name Property

[image]

DynamicNodes API
IRemoteRuntime..::..Name Property
IRemoteRuntime Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen der Laufzeitumgebung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
F#
abstract Name : string

Field Value

Der Name.

See Also

IRemoteRuntime Interface
DynamicNode.Remoting Namespace


NodeService Class

[image]

DynamicNodes API
NodeService Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Fernsteuerungs-Objekt für einen Knoten.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class NodeService : MarshalByRefObject
Visual Basic
Public Class NodeService _
    Inherits MarshalByRefObject
F#
type NodeService =
    class
        inherit MarshalByRefObject
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
DynamicNode.Remoting..::..NodeService

See Also

NodeService Members
DynamicNode.Remoting Namespace


NodeService Members

[image] [image]

DynamicNodes API
NodeService Members
NodeService Class Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeService type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten.
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Properties

 | Name | Description
Public property | Commands | Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.
Public property | Description | Gibt eine Beschreibung des Knoten zurück.
Public property | Id | Gibt die ID des Knoten zurück.
Public property | InPorts | Gibt ein Array mit allen Eingängen des Knotens zurück.
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob der verknüpfte Knoten freigegeben wurde.
Public property | Name | Gibt den Namen des Knoten zurück.
Public property | OutPorts | Gibt ein Array mit allen Ausgängen des Knotens zurück.
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück.
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück.

See Also

NodeService Class
DynamicNode.Remoting Namespace


NodeService Methods

[image] [image]

DynamicNodes API
NodeService Methods
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeService type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Aktiviert den Knoten.
Public method | OnCommand | Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.
Public method | OnDefaultCommand | Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

See Also

NodeService Class
DynamicNode.Remoting Namespace


Activate Method

[image]

DynamicNodes API
NodeService..::..Activate Method
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Aktiviert den Knoten.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void Activate()
Visual Basic
Public Sub Activate
F#
member Activate : unit -> unit

See Also

NodeService Class
DynamicNode.Remoting Namespace


OnCommand Method

[image]

DynamicNodes API
NodeService..::..OnCommand Method
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen wenn der Benutzer einen Benutzerbefehl aufgerufen hat.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void OnCommand(
    string command
)
Visual Basic
Public Sub OnCommand ( _
    command As String _
)
F#
member OnCommand :
        command:string -> unit

Parameters

command
Type: System..::..String
Der Befehls-Code des Benutzerbefehls.

See Also

NodeService Class
DynamicNode.Remoting Namespace


OnDefaultCommand Method

[image]

DynamicNodes API
NodeService..::..OnDefaultCommand Method
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird aufgerufen, wenn der Benutzer den Standardbefehl des Knotens aufgerufen hat.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void OnDefaultCommand()
Visual Basic
Public Sub OnDefaultCommand
F#
member OnDefaultCommand : unit -> unit

See Also

NodeService Class
DynamicNode.Remoting Namespace


NodeService Properties

[image] [image]

DynamicNodes API
NodeService Properties
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The NodeService type exposes the following members.

Properties

 | Name | Description
Public property | Commands | Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.
Public property | Description | Gibt eine Beschreibung des Knoten zurück.
Public property | Id | Gibt die ID des Knoten zurück.
Public property | InPorts | Gibt ein Array mit allen Eingängen des Knotens zurück.
Public property | IsActive | Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob der verknüpfte Knoten freigegeben wurde.
Public property | Name | Gibt den Namen des Knoten zurück.
Public property | OutPorts | Gibt ein Array mit allen Ausgängen des Knotens zurück.
Public property | TypeCaption | Gibt die Beschriftung des Knoten-Typs zurück.
Public property | TypeDescription | Gibt die Beschreibung des Knoten-Typs zurück.
Public property | TypeGroup | Gibt die Gruppe des Knoten-Typs zurück.

See Also

NodeService Class
DynamicNode.Remoting Namespace


Commands Property

[image]

DynamicNodes API
NodeService..::..Commands Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein IDictionary<(Of <(<'TKey, TValue>)>)> mit allen Benutzerbefehlen für diesen Knoten zurück. Der Schlüssel-Eintrag ist der Befehls-Code und der zweite Eintrag ist die Beschriftung.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public IDictionary<string, string> Commands { get; }
Visual Basic
Public ReadOnly Property Commands As IDictionary(Of String, String)
    Get
F#
member Commands : IDictionary<string, string>

Field Value

Die Benutzerbefehle.

See Also

NodeService Class
DynamicNode.Remoting Namespace


Description Property

[image]

DynamicNodes API
NodeService..::..Description Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Beschreibung des Knoten zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
F#
member Description : string

Field Value

Die Beschreibung.

See Also

NodeService Class
DynamicNode.Remoting Namespace


Id Property

[image]

DynamicNodes API
NodeService..::..Id Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Knoten zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
F#
member Id : int

Field Value

Die ID.

See Also

NodeService Class
DynamicNode.Remoting Namespace


InPorts Property

[image]

DynamicNodes API
NodeService..::..InPorts Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Eingängen des Knotens zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public InPortService[] InPorts { get; }
Visual Basic
Public ReadOnly Property InPorts As InPortService()
    Get
F#
member InPorts : InPortService[]

Field Value

Die Eingänge.

See Also

NodeService Class
DynamicNode.Remoting Namespace


IsActive Property

[image]

DynamicNodes API
NodeService..::..IsActive Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wahrheitswert zurück, welcher angibt ob der Knoten aktiv ist oder nicht.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As Boolean
    Get
F#
member IsActive : bool

Field Value

true, wenn dieser Knoten aktiv ist, sonst false.

See Also

NodeService Class
DynamicNode.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
NodeService..::..IsDisposed Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob der verknüpfte Knoten freigegeben wurde.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsDisposed { get; }
Visual Basic
Public ReadOnly Property IsDisposed As Boolean
    Get
F#
member IsDisposed : bool

Field Value

true, wenn der verknüpfte Knoten freigegeben wurde, andernfalls false.

See Also

NodeService Class
DynamicNode.Remoting Namespace


Name Property

[image]

DynamicNodes API
NodeService..::..Name Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Knoten zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
member Name : string

Field Value

Der Name.

See Also

NodeService Class
DynamicNode.Remoting Namespace


OutPorts Property

[image]

DynamicNodes API
NodeService..::..OutPorts Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Ausgängen des Knotens zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public OutPortService[] OutPorts { get; }
Visual Basic
Public ReadOnly Property OutPorts As OutPortService()
    Get
F#
member OutPorts : OutPortService[]

Field Value

Die Ausgänge.

See Also

NodeService Class
DynamicNode.Remoting Namespace


TypeCaption Property

[image]

DynamicNodes API
NodeService..::..TypeCaption Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung des Knoten-Typs zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string TypeCaption { get; }
Visual Basic
Public ReadOnly Property TypeCaption As String
    Get
F#
member TypeCaption : string

Field Value

Die Beschriftung des Knoten-Typs.

See Also

NodeService Class
DynamicNode.Remoting Namespace


TypeDescription Property

[image]

DynamicNodes API
NodeService..::..TypeDescription Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung des Knoten-Typs zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string TypeDescription { get; }
Visual Basic
Public ReadOnly Property TypeDescription As String
    Get
F#
member TypeDescription : string

Field Value

Die Beschreibung des Knoten-Typs.

See Also

NodeService Class
DynamicNode.Remoting Namespace


TypeGroup Property

[image]

DynamicNodes API
NodeService..::..TypeGroup Property
NodeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Gruppe des Knoten-Typs zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string TypeGroup { get; }
Visual Basic
Public ReadOnly Property TypeGroup As String
    Get
F#
member TypeGroup : string

Field Value

Die Gruppe des Knoten-Typs.

See Also

NodeService Class
DynamicNode.Remoting Namespace


OutPortService Class

[image]

DynamicNodes API
OutPortService Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Fernsteuer-Objekt für einen Ausgang.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class OutPortService : PortService
Visual Basic
Public Class OutPortService _
    Inherits PortService
F#
type OutPortService =
    class
        inherit PortService
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
DynamicNode.Remoting..::..PortService
DynamicNode.Remoting..::..OutPortService

See Also

OutPortService Members
DynamicNode.Remoting Namespace


OutPortService Members

[image] [image]

DynamicNodes API
OutPortService Members
OutPortService Class Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortService type exposes the following members.

Methods

 | Name | Description
Public method | Fire | Gibt die Marke an die verbundenen Eingänge weiter.

Fields

 | Name | Description
Protected field | port | Der ferngesteuerte Anschluss. (Inherited from PortService.)

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from PortService.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from PortService.)
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from PortService.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from PortService.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from PortService.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from PortService.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from PortService.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from PortService.)

See Also

OutPortService Class
DynamicNode.Remoting Namespace


OutPortService Fields

[image] [image]

DynamicNodes API
OutPortService Fields
OutPortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortService type exposes the following members.

Fields

 | Name | Description
Protected field | port | Der ferngesteuerte Anschluss. (Inherited from PortService.)

See Also

OutPortService Class
DynamicNode.Remoting Namespace


OutPortService Methods

[image] [image]

DynamicNodes API
OutPortService Methods
OutPortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortService type exposes the following members.

Methods

 | Name | Description
Public method | Fire | Gibt die Marke an die verbundenen Eingänge weiter.

See Also

OutPortService Class
DynamicNode.Remoting Namespace


Fire Method

[image]

DynamicNodes API
OutPortService..::..Fire Method
OutPortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Marke an die verbundenen Eingänge weiter.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public void Fire()
Visual Basic
Public Sub Fire
F#
member Fire : unit -> unit

See Also

OutPortService Class
DynamicNode.Remoting Namespace


OutPortService Properties

[image] [image]

DynamicNodes API
OutPortService Properties
OutPortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The OutPortService type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück. (Inherited from PortService.)
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück. (Inherited from PortService.)
Public property | Id | Gibt die ID des Anschlusses zurück. (Inherited from PortService.)
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde. (Inherited from PortService.)
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist. (Inherited from PortService.)
Public property | Name | Gibt den Namen des Anschlusses zurück. (Inherited from PortService.)
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück. (Inherited from PortService.)
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück. (Inherited from PortService.)

See Also

OutPortService Class
DynamicNode.Remoting Namespace


PortService Class

[image]

DynamicNodes API
PortService Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Fernsteuer-Objekt für einen Anschluss.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class PortService : MarshalByRefObject
Visual Basic
Public Class PortService _
    Inherits MarshalByRefObject
F#
type PortService =
    class
        inherit MarshalByRefObject
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
DynamicNode.Remoting..::..PortService
DynamicNode.Remoting..::..InPortService
DynamicNode.Remoting..::..OutPortService

See Also

PortService Members
DynamicNode.Remoting Namespace


PortService Members

[image] [image]

DynamicNodes API
PortService Members
PortService Class Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PortService type exposes the following members.

Fields

 | Name | Description
Protected field | port | Der ferngesteuerte Anschluss.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück.
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück.
Public property | Id | Gibt die ID des Anschlusses zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist.
Public property | Name | Gibt den Namen des Anschlusses zurück.
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück.
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück.

See Also

PortService Class
DynamicNode.Remoting Namespace


PortService Fields

[image] [image]

DynamicNodes API
PortService Fields
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PortService type exposes the following members.

Fields

 | Name | Description
Protected field | port | Der ferngesteuerte Anschluss.

See Also

PortService Class
DynamicNode.Remoting Namespace


port Field

[image]

DynamicNodes API
PortService..::..port Field
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der ferngesteuerte Anschluss.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
protected readonly IRemotePort port
Visual Basic
Protected ReadOnly port As IRemotePort
F#
val port: IRemotePort

See Also

PortService Class
DynamicNode.Remoting Namespace


PortService Properties

[image] [image]

DynamicNodes API
PortService Properties
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PortService type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionCount | Gibt die Anzahl aller Verbindungen mit diesem Port zurück.
Public property | Description | Gibt die Beschreibung dieses Anschlusses zurück.
Public property | Id | Gibt die ID des Anschlusses zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.
Public property | IsSuperPort | Gibt an oder legt fest ob dieser Port ein Super-Port ist.
Public property | Name | Gibt den Namen des Anschlusses zurück.
Public property | ReadCopy | Gibt die Lese-Kopie der aktuellen Marke zurück.
Public property | SuperName | Gibt den Super-Name für Modul-Anschlüsse zurück.

See Also

PortService Class
DynamicNode.Remoting Namespace


ConnectionCount Property

[image]

DynamicNodes API
PortService..::..ConnectionCount Property
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl aller Verbindungen mit diesem Port zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int ConnectionCount { get; }
Visual Basic
Public ReadOnly Property ConnectionCount As Integer
    Get
F#
member ConnectionCount : int

Field Value

Die Anzahl der Verbindungen.

See Also

PortService Class
DynamicNode.Remoting Namespace


Description Property

[image]

DynamicNodes API
PortService..::..Description Property
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung dieses Anschlusses zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
F#
member Description : string

Field Value

Die Beschreibung.

See Also

PortService Class
DynamicNode.Remoting Namespace


Id Property

[image]

DynamicNodes API
PortService..::..Id Property
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Anschlusses zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
F#
member Id : int

Field Value

Die ID.

See Also

PortService Class
DynamicNode.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
PortService..::..IsDisposed Property
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob das Objekt freigegeben wurde.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsDisposed { get; }
Visual Basic
Public ReadOnly Property IsDisposed As Boolean
    Get
F#
member IsDisposed : bool

Field Value

true, wenn das Objekt freigegeben wurde, andernfalls false.

See Also

PortService Class
DynamicNode.Remoting Namespace


IsSuperPort Property

[image]

DynamicNodes API
PortService..::..IsSuperPort Property
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an oder legt fest ob dieser Port ein Super-Port ist.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsSuperPort { get; }
Visual Basic
Public ReadOnly Property IsSuperPort As Boolean
    Get
F#
member IsSuperPort : bool

Field Value

true wenn die Instanz ein Super-Port ist, sonst false.

See Also

PortService Class
DynamicNode.Remoting Namespace


Name Property

[image]

DynamicNodes API
PortService..::..Name Property
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Anschlusses zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
member Name : string

Field Value

Der Name.

See Also

PortService Class
DynamicNode.Remoting Namespace


ReadCopy Property

[image]

DynamicNodes API
PortService..::..ReadCopy Property
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Lese-Kopie der aktuellen Marke zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public RemoteToken ReadCopy { get; }
Visual Basic
Public ReadOnly Property ReadCopy As RemoteToken
    Get
F#
member ReadCopy : RemoteToken

Field Value

Die Lese-Kopie der aktuellen Marke.

See Also

PortService Class
DynamicNode.Remoting Namespace


SuperName Property

[image]

DynamicNodes API
PortService..::..SuperName Property
PortService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Super-Name für Modul-Anschlüsse zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string SuperName { get; }
Visual Basic
Public ReadOnly Property SuperName As String
    Get
F#
member SuperName : string

Field Value

Der Super-Name.

See Also

PortService Class
DynamicNode.Remoting Namespace


RemoteToken Structure

[image]

DynamicNodes API
RemoteToken Structure
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Marke die für die Fernsteuerung geeignet ist.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public struct RemoteToken
Visual Basic
<SerializableAttribute> _
Public Structure RemoteToken
F#
[<SealedAttribute>]
[<SerializableAttribute>]
type RemoteToken =  struct end

See Also

RemoteToken Members
DynamicNode.Remoting Namespace


RemoteToken Members

[image] [image]

DynamicNodes API
RemoteToken Members
RemoteToken Structure Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteToken type exposes the following members.

Constructors

 | Name | Description
Public method | RemoteToken | Initialisiert eine neue Instanz von RemoteToken.

Properties

 | Name | Description
Public property | State | Gibt den Status der Marke zurück.
Public property | StreamIndex | Gibt den Index der Marke im Datenstrom zurück.
Public property | StreamName | Gibt den Namen des Datenstroms oder null zurück.

See Also

RemoteToken Structure
DynamicNode.Remoting Namespace


RemoteToken Constructor

[image]

DynamicNodes API
RemoteToken Constructor
RemoteToken Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RemoteToken.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public RemoteToken(
    RemoteTokenState state,
    string streamName,
    long streamIndex
)
Visual Basic
Public Sub New ( _
    state As RemoteTokenState, _
    streamName As String, _
    streamIndex As Long _
)
F#
new :
        state:RemoteTokenState *
        streamName:string *
        streamIndex:int64 -> RemoteToken

Parameters

state
Type: DynamicNode.Remoting..::..RemoteTokenState
Der Markenzustand.
streamName
Type: System..::..String
Der Name des Datenstroms.
streamIndex
Type: System..::..Int64
Die Index-Nummer im Datenstrom.

See Also

RemoteToken Structure
DynamicNode.Remoting Namespace


RemoteToken Properties

[image] [image]

DynamicNodes API
RemoteToken Properties
RemoteToken Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RemoteToken type exposes the following members.

Properties

 | Name | Description
Public property | State | Gibt den Status der Marke zurück.
Public property | StreamIndex | Gibt den Index der Marke im Datenstrom zurück.
Public property | StreamName | Gibt den Namen des Datenstroms oder null zurück.

See Also

RemoteToken Structure
DynamicNode.Remoting Namespace


State Property

[image]

DynamicNodes API
RemoteToken..::..State Property
RemoteToken Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Status der Marke zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public RemoteTokenState State { get; }
Visual Basic
Public ReadOnly Property State As RemoteTokenState
    Get
F#
member State : RemoteTokenState

Field Value

Der Status der Marke.

See Also

RemoteToken Structure
DynamicNode.Remoting Namespace


StreamIndex Property

[image]

DynamicNodes API
RemoteToken..::..StreamIndex Property
RemoteToken Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Index der Marke im Datenstrom zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public long StreamIndex { get; }
Visual Basic
Public ReadOnly Property StreamIndex As Long
    Get
F#
member StreamIndex : int64

Field Value

Der Index der Marke im Datenstrom.

See Also

RemoteToken Structure
DynamicNode.Remoting Namespace


StreamName Property

[image]

DynamicNodes API
RemoteToken..::..StreamName Property
RemoteToken Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Datenstroms oder null zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string StreamName { get; }
Visual Basic
Public ReadOnly Property StreamName As String
    Get
F#
member StreamName : string

Field Value

Der Name des Datenstroms oder null.

See Also

RemoteToken Structure
DynamicNode.Remoting Namespace


RemoteTokenState Enumeration

[image]

DynamicNodes API
RemoteTokenState Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Status einer ferngesteuerten Marke.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public enum RemoteTokenState
Visual Basic
<SerializableAttribute> _
Public Enumeration RemoteTokenState
F#
[<SerializableAttribute>]
type RemoteTokenState

Members

Member name | Description
Valid |
Invalid |
NotSet |

See Also

DynamicNode.Remoting Namespace


RuntimeService Class

[image]

DynamicNodes API
RuntimeService Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Fernsteuerungs-Objekt für eine Laufzeitumgebung.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public class RuntimeService : MarshalByRefObject
Visual Basic
Public Class RuntimeService _
    Inherits MarshalByRefObject
F#
type RuntimeService =
    class
        inherit MarshalByRefObject
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
DynamicNode.Remoting..::..RuntimeService

See Also

RuntimeService Members
DynamicNode.Remoting Namespace


RuntimeService Members

[image] [image]

DynamicNodes API
RuntimeService Members
RuntimeService Class Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RuntimeService type exposes the following members.

Properties

 | Name | Description
Public property | CountGraphs | Gibt die Anzahl der Graphen in der Laufzeitumgebung zurück.
Public property | Graphs | Gibt ein Array mit allen Graphen der Laufzeitumgebung zurück.
Public property | Id | Gibt die ID der Laufzeitumgebung zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob die verknüpfte Laufzeitumgebung freigegeben wurde.
Public property | Name | Gibt den Namen der Laufzeitumgebung zurück.

See Also

RuntimeService Class
DynamicNode.Remoting Namespace


RuntimeService Properties

[image] [image]

DynamicNodes API
RuntimeService Properties
RuntimeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RuntimeService type exposes the following members.

Properties

 | Name | Description
Public property | CountGraphs | Gibt die Anzahl der Graphen in der Laufzeitumgebung zurück.
Public property | Graphs | Gibt ein Array mit allen Graphen der Laufzeitumgebung zurück.
Public property | Id | Gibt die ID der Laufzeitumgebung zurück.
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob die verknüpfte Laufzeitumgebung freigegeben wurde.
Public property | Name | Gibt den Namen der Laufzeitumgebung zurück.

See Also

RuntimeService Class
DynamicNode.Remoting Namespace


CountGraphs Property

[image]

DynamicNodes API
RuntimeService..::..CountGraphs Property
RuntimeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der Graphen in der Laufzeitumgebung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int CountGraphs { get; }
Visual Basic
Public ReadOnly Property CountGraphs As Integer
    Get
F#
member CountGraphs : int

Field Value

Die Anzahl der Graphen.

See Also

RuntimeService Class
DynamicNode.Remoting Namespace


Graphs Property

[image]

DynamicNodes API
RuntimeService..::..Graphs Property
RuntimeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Graphen der Laufzeitumgebung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public GraphService[] Graphs { get; }
Visual Basic
Public ReadOnly Property Graphs As GraphService()
    Get
F#
member Graphs : GraphService[]

Field Value

Die Graphen.

See Also

RuntimeService Class
DynamicNode.Remoting Namespace


Id Property

[image]

DynamicNodes API
RuntimeService..::..Id Property
RuntimeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID der Laufzeitumgebung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
F#
member Id : int

Field Value

Die ID.

See Also

RuntimeService Class
DynamicNode.Remoting Namespace


IsDisposed Property

[image]

DynamicNodes API
RuntimeService..::..IsDisposed Property
RuntimeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft einen Wert ab, der angibt, ob die verknüpfte Laufzeitumgebung freigegeben wurde.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public bool IsDisposed { get; }
Visual Basic
Public ReadOnly Property IsDisposed As Boolean
    Get
F#
member IsDisposed : bool

Field Value

true, wenn die verknüpfte Laufzeitumgebung freigegeben wurde, andernfalls false.

See Also

RuntimeService Class
DynamicNode.Remoting Namespace


Name Property

[image]

DynamicNodes API
RuntimeService..::..Name Property
RuntimeService Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen der Laufzeitumgebung zurück.

Namespace: DynamicNode.Remoting
Assembly: DNRemoteContract (in DNRemoteContract.dll) Version: 1.0.4679.19834 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
F#
member Name : string

Field Value

Der Name.

See Also

RuntimeService Class
DynamicNode.Remoting Namespace


DynamicNode.Test Namespace

[image]

DynamicNodes API
DynamicNode.Test Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält Typen für eine Testumgebung für Knotentypen.

Die wichtigsten Typen in diesem Namensraum sind TestBench und ITestCase.

Classes

 | Class | Description
Public class | TestBench | Eine Klasse die eine Testumgebung für das Testen von Knotenimplementierungen bereitstellt.
Public class | TestEventArgs | Die Ereignis-Argument-Klasse für Test-Ereignisse.

Interfaces

 | Interface | Description
Public interface | INodeInstanceTestCase | Die Schnittstelle der Testfälle für instanziierte Knoten.
Public interface | INodeTypeTestCase | Die Schnittstelle der Testfälle für Knoten-Typen.
Public interface | ITestCase | Die Basis-Schnittstelle für Testfälle.

Enumerations

 | Enumeration | Description
Public enumeration | TestEventTyp | Die Typen von Ereignissen, die beim Testen eines Knoten auftreten können.


INodeInstanceTestCase Interface

[image]

DynamicNodes API
INodeInstanceTestCase Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle der Testfälle für instanziierte Knoten.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public interface INodeInstanceTestCase : ITestCase
Visual Basic
Public Interface INodeInstanceTestCase _
    Inherits ITestCase
F#
type INodeInstanceTestCase =
    interface
        interface ITestCase
    end

See Also

INodeInstanceTestCase Members
DynamicNode.Test Namespace


INodeInstanceTestCase Members

[image] [image]

DynamicNodes API
INodeInstanceTestCase Members
INodeInstanceTestCase Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INodeInstanceTestCase type exposes the following members.

Methods

 | Name | Description
Public method | Test | Testet den übergebenen Knoten.

Properties

 | Name | Description
Public property | NeedVisualInitialized | Prüft, ob der Testfall einen initialisierten Knoten mit grafischer Ausgabe benötigt.
Public property | TestCaseName | Gibt den Namen des Tests zurück. (Inherited from ITestCase.)

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn innerhalb des Testfalls eine Nachricht ausgegeben wird. (Inherited from ITestCase.)

See Also

INodeInstanceTestCase Interface
DynamicNode.Test Namespace


INodeInstanceTestCase Methods

[image] [image]

DynamicNodes API
INodeInstanceTestCase Methods
INodeInstanceTestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INodeInstanceTestCase type exposes the following members.

Methods

 | Name | Description
Public method | Test | Testet den übergebenen Knoten.

See Also

INodeInstanceTestCase Interface
DynamicNode.Test Namespace


Test Method

[image]

DynamicNodes API
INodeInstanceTestCase..::..Test Method
INodeInstanceTestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Testet den übergebenen Knoten.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
bool Test(
    TestBench bench,
    INode node
)
Visual Basic
Function Test ( _
    bench As TestBench, _
    node As INode _
) As Boolean
F#
abstract Test :
        bench:TestBench *
        node:INode -> bool

Parameters

bench
Type: DynamicNode.Test..::..TestBench
Die Testumgebung.
node
Type: DynamicNode.Core..::..INode
Der Knoten.

Return Value

true, wenn der Test vollständig bestanden wurde.

See Also

INodeInstanceTestCase Interface
DynamicNode.Test Namespace


INodeInstanceTestCase Properties

[image] [image]

DynamicNodes API
INodeInstanceTestCase Properties
INodeInstanceTestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INodeInstanceTestCase type exposes the following members.

Properties

 | Name | Description
Public property | NeedVisualInitialized | Prüft, ob der Testfall einen initialisierten Knoten mit grafischer Ausgabe benötigt.
Public property | TestCaseName | Gibt den Namen des Tests zurück. (Inherited from ITestCase.)

See Also

INodeInstanceTestCase Interface
DynamicNode.Test Namespace


NeedVisualInitialized Property

[image]

DynamicNodes API
INodeInstanceTestCase..::..NeedVisualInitialized Property
INodeInstanceTestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob der Testfall einen initialisierten Knoten mit grafischer Ausgabe benötigt.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
bool NeedVisualInitialized { get; }
Visual Basic
ReadOnly Property NeedVisualInitialized As Boolean
    Get
F#
abstract NeedVisualInitialized : bool

Field Value

true zurück, wenn der Knoten mit grafischer Ausgabe initialisiert sein muss, damit dieser Testfall durchgeführt werden kann.

See Also

INodeInstanceTestCase Interface
DynamicNode.Test Namespace


INodeInstanceTestCase Events

[image] [image]

DynamicNodes API
INodeInstanceTestCase Events
INodeInstanceTestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INodeInstanceTestCase type exposes the following members.

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn innerhalb des Testfalls eine Nachricht ausgegeben wird. (Inherited from ITestCase.)

See Also

INodeInstanceTestCase Interface
DynamicNode.Test Namespace


INodeTypeTestCase Interface

[image]

DynamicNodes API
INodeTypeTestCase Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle der Testfälle für Knoten-Typen.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public interface INodeTypeTestCase : ITestCase
Visual Basic
Public Interface INodeTypeTestCase _
    Inherits ITestCase
F#
type INodeTypeTestCase =
    interface
        interface ITestCase
    end

See Also

INodeTypeTestCase Members
DynamicNode.Test Namespace


INodeTypeTestCase Members

[image] [image]

DynamicNodes API
INodeTypeTestCase Members
INodeTypeTestCase Interface Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INodeTypeTestCase type exposes the following members.

Methods

 | Name | Description
Public method | Test | Testet den übergebenen Knoten.

Properties

 | Name | Description
Public property | TestCaseName | Gibt den Namen des Tests zurück. (Inherited from ITestCase.)

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn innerhalb des Testfalls eine Nachricht ausgegeben wird. (Inherited from ITestCase.)

See Also

INodeTypeTestCase Interface
DynamicNode.Test Namespace


INodeTypeTestCase Methods

[image] [image]

DynamicNodes API
INodeTypeTestCase Methods
INodeTypeTestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INodeTypeTestCase type exposes the following members.

Methods

 | Name | Description
Public method | Test | Testet den übergebenen Knoten.

See Also

INodeTypeTestCase Interface
DynamicNode.Test Namespace


Test Method

[image]

DynamicNodes API
INodeTypeTestCase..::..Test Method
INodeTypeTestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Testet den übergebenen Knoten.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
bool Test(
    TestBench bench,
    Type nodeType
)
Visual Basic
Function Test ( _
    bench As TestBench, _
    nodeType As Type _
) As Boolean
F#
abstract Test :
        bench:TestBench *
        nodeType:Type -> bool

Parameters

bench
Type: DynamicNode.Test..::..TestBench
Die Testumgebung.
nodeType
Type: System..::..Type
Der Knoten.

Return Value

true, wenn der Test vollständig bestanden wurde.

See Also

INodeTypeTestCase Interface
DynamicNode.Test Namespace


INodeTypeTestCase Properties

[image] [image]

DynamicNodes API
INodeTypeTestCase Properties
INodeTypeTestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INodeTypeTestCase type exposes the following members.

Properties

 | Name | Description
Public property | TestCaseName | Gibt den Namen des Tests zurück. (Inherited from ITestCase.)

See Also

INodeTypeTestCase Interface
DynamicNode.Test Namespace


INodeTypeTestCase Events

[image] [image]

DynamicNodes API
INodeTypeTestCase Events
INodeTypeTestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The INodeTypeTestCase type exposes the following members.

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn innerhalb des Testfalls eine Nachricht ausgegeben wird. (Inherited from ITestCase.)

See Also

INodeTypeTestCase Interface
DynamicNode.Test Namespace


ITestCase Interface

[image]

DynamicNodes API
ITestCase Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basis-Schnittstelle für Testfälle.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public interface ITestCase
Visual Basic
Public Interface ITestCase
F#
type ITestCase =  interface end

See Also

ITestCase Members
DynamicNode.Test Namespace


ITestCase Members

[image] [image]

DynamicNodes API
ITestCase Members
ITestCase Interface Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ITestCase type exposes the following members.

Properties

 | Name | Description
Public property | TestCaseName | Gibt den Namen des Tests zurück.

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn innerhalb des Testfalls eine Nachricht ausgegeben wird.

See Also

ITestCase Interface
DynamicNode.Test Namespace


ITestCase Properties

[image] [image]

DynamicNodes API
ITestCase Properties
ITestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ITestCase type exposes the following members.

Properties

 | Name | Description
Public property | TestCaseName | Gibt den Namen des Tests zurück.

See Also

ITestCase Interface
DynamicNode.Test Namespace


TestCaseName Property

[image]

DynamicNodes API
ITestCase..::..TestCaseName Property
ITestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Tests zurück.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
string TestCaseName { get; }
Visual Basic
ReadOnly Property TestCaseName As String
    Get
F#
abstract TestCaseName : string

Field Value

Der Name des Testfalls.

See Also

ITestCase Interface
DynamicNode.Test Namespace


ITestCase Events

[image] [image]

DynamicNodes API
ITestCase Events
ITestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ITestCase type exposes the following members.

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn innerhalb des Testfalls eine Nachricht ausgegeben wird.

See Also

ITestCase Interface
DynamicNode.Test Namespace


TestEvent Event

[image]

DynamicNodes API
ITestCase..::..TestEvent Event
ITestCase Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn innerhalb des Testfalls eine Nachricht ausgegeben wird.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
event EventHandler<TestEventArgs> TestEvent
Visual Basic
Event TestEvent As EventHandler(Of TestEventArgs)
F#
abstract TestEvent : IEvent<EventHandler<TestEventArgs>,
    TestEventArgs>

See Also

ITestCase Interface
DynamicNode.Test Namespace


TestBench Class

[image]

DynamicNodes API
TestBench Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Klasse die eine Testumgebung für das Testen von Knotenimplementierungen bereitstellt.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public class TestBench : IDisposable
Visual Basic
Public Class TestBench _
    Implements IDisposable
F#
type TestBench =
    class
        interface IDisposable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Test..::..TestBench

See Also

TestBench Members
DynamicNode.Test Namespace


TestBench Members

[image] [image]

DynamicNodes API
TestBench Members
TestBench Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TestBench type exposes the following members.

Constructors

 | Name | Description
Public method | TestBench | Initialisiert eine TestBench-Instanz.

Methods

 | Name | Description
Public method | AddDefaultTestCases | Fügt alle Standard-Testfälle aus dem Assembly DNTesting zur Testumgebung hinzu.
Public method | AddTestCase(INodeInstanceTestCase) | Fügt der Testumgebung einen benutzerdefinierten Testfall für Knoteninstanzen hinzu.
Public method | AddTestCase(INodeTypeTestCase) | Fügt der Testumgebung einen benutzerdefinierten Testfall für Knotentypen hinzu.
Public method | ClearTestCases | Entfernt alle Testfälle aus der Testumgebung.
Public method | CreateNode | Erzeugt eine fertig initialisierte Instanz für den übergebenen Knotentyp.
Public method | Dispose | Entsorgt die Testumgebung. Dabei wird auch die gekapselte Laufzeitumgebung entsorgt.
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor TestBench vom Garbage-Collector aus dem Speicher entfernt wird. (Overrides Object..::..Finalize()()()().)
Public method | Garbage | Zerstört einen Knoten und gibt seine Ressourcen frei.
Public method | Init | Initialisiert eine Knoten-Instanz.
Public method | RemoveTestCase | Entfernt einen Testfall aus der Testumgebung.
Public method | Test | Führt die Basis-Tests und alle registrierten Testfälle für den übergebenen Knotentyp durch.

Properties

 | Name | Description
Public property | CountInstanceTestCases | Gibt die Anzahl der registrierten Instanz-Testfälle zurück.
Public property | CountTypeTestCases | Gibt die Anzahl der registrierten Typen-Testfälle zurück.
Public property | Graph | Gibt ein IGraph-Objekt ohne grafischer Ausgabe zurück.
Public property | IsDisposed | Gibt einen Wert zurück, der angibt, ob diese Instanz entsorgt wurde.
Public property | Runtime | Gibt den Kern der Testumgebung zurück.
Public property | VisualGraph | Gibt ein IGraph-Objekt mit grafischer Ausgabe zurück.
Public property | VisualTestPanel | Gibt ein Panel zum Testen von grafischer Ausgabe zurück.

Events

 | Name | Description
Public event | TestFinished | Wird ausgelöst, wenn der Test eines Knotens abgeschlossen ist.
Public event | TestMessage | Wir ausgelöst, wenn während des Tests eine Meldung ausgegeben wird.
Public event | TestStart | Wird ausgelöst, wenn der Test eines Knotens beginnt.

See Also

TestBench Class
DynamicNode.Test Namespace


TestBench Constructor

[image]

DynamicNodes API
TestBench Constructor
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine TestBench-Instanz.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public TestBench(
    string basePath,
    string userPath,
    Panel visualTestPanel
)
Visual Basic
Public Sub New ( _
    basePath As String, _
    userPath As String, _
    visualTestPanel As Panel _
)
F#
new :
        basePath:string *
        userPath:string *
        visualTestPanel:Panel -> TestBench

Parameters

basePath
Type: System..::..String
Der Basis-Pfad der DynamicNodes-Installation.
userPath
Type: System..::..String
Der Benutzer-Pfad.
visualTestPanel
Type: System.Windows.Forms..::..Panel
Ein Panel, auf dem visuelle Tests durchgeführt werden können.

See Also

TestBench Class
DynamicNode.Test Namespace


TestBench Methods

[image] [image]

DynamicNodes API
TestBench Methods
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TestBench type exposes the following members.

Methods

 | Name | Description
Public method | AddDefaultTestCases | Fügt alle Standard-Testfälle aus dem Assembly DNTesting zur Testumgebung hinzu.
Public method | AddTestCase(INodeInstanceTestCase) | Fügt der Testumgebung einen benutzerdefinierten Testfall für Knoteninstanzen hinzu.
Public method | AddTestCase(INodeTypeTestCase) | Fügt der Testumgebung einen benutzerdefinierten Testfall für Knotentypen hinzu.
Public method | ClearTestCases | Entfernt alle Testfälle aus der Testumgebung.
Public method | CreateNode | Erzeugt eine fertig initialisierte Instanz für den übergebenen Knotentyp.
Public method | Dispose | Entsorgt die Testumgebung. Dabei wird auch die gekapselte Laufzeitumgebung entsorgt.
Protected method | Finalize | Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor TestBench vom Garbage-Collector aus dem Speicher entfernt wird. (Overrides Object..::..Finalize()()()().)
Public method | Garbage | Zerstört einen Knoten und gibt seine Ressourcen frei.
Public method | Init | Initialisiert eine Knoten-Instanz.
Public method | RemoveTestCase | Entfernt einen Testfall aus der Testumgebung.
Public method | Test | Führt die Basis-Tests und alle registrierten Testfälle für den übergebenen Knotentyp durch.

See Also

TestBench Class
DynamicNode.Test Namespace


AddDefaultTestCases Method

[image]

DynamicNodes API
TestBench..::..AddDefaultTestCases Method
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt alle Standard-Testfälle aus dem Assembly DNTesting zur Testumgebung hinzu.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public void AddDefaultTestCases()
Visual Basic
Public Sub AddDefaultTestCases
F#
member AddDefaultTestCases : unit -> unit

See Also

TestBench Class
DynamicNode.Test Namespace


AddTestCase Method

[image] [image]

DynamicNodes API
TestBench..::..AddTestCase Method
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | AddTestCase(INodeInstanceTestCase) | Fügt der Testumgebung einen benutzerdefinierten Testfall für Knoteninstanzen hinzu.
Public method | AddTestCase(INodeTypeTestCase) | Fügt der Testumgebung einen benutzerdefinierten Testfall für Knotentypen hinzu.

See Also

TestBench Class
TestBench Members
DynamicNode.Test Namespace


AddTestCase Method (INodeInstanceTestCase)

[image]

DynamicNodes API
TestBench..::..AddTestCase Method (INodeInstanceTestCase)
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt der Testumgebung einen benutzerdefinierten Testfall für Knoteninstanzen hinzu.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public void AddTestCase(
    INodeInstanceTestCase testCase
)
Visual Basic
Public Sub AddTestCase ( _
    testCase As INodeInstanceTestCase _
)
F#
member AddTestCase :
        testCase:INodeInstanceTestCase -> unit

Parameters

testCase
Type: DynamicNode.Test..::..INodeInstanceTestCase
Ein benutzerdefinierte Testfall.

See Also

TestBench Class
AddTestCase Overload
DynamicNode.Test Namespace


AddTestCase Method (INodeTypeTestCase)

[image]

DynamicNodes API
TestBench..::..AddTestCase Method (INodeTypeTestCase)
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Fügt der Testumgebung einen benutzerdefinierten Testfall für Knotentypen hinzu.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public void AddTestCase(
    INodeTypeTestCase testCase
)
Visual Basic
Public Sub AddTestCase ( _
    testCase As INodeTypeTestCase _
)
F#
member AddTestCase :
        testCase:INodeTypeTestCase -> unit

Parameters

testCase
Type: DynamicNode.Test..::..INodeTypeTestCase
Ein benutzerdefinierte Testfall.

See Also

TestBench Class
AddTestCase Overload
DynamicNode.Test Namespace


ClearTestCases Method

[image]

DynamicNodes API
TestBench..::..ClearTestCases Method
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt alle Testfälle aus der Testumgebung.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public void ClearTestCases()
Visual Basic
Public Sub ClearTestCases
F#
member ClearTestCases : unit -> unit

See Also

TestBench Class
DynamicNode.Test Namespace


CreateNode Method

[image]

DynamicNodes API
TestBench..::..CreateNode Method
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine fertig initialisierte Instanz für den übergebenen Knotentyp.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public INode CreateNode(
    Type nodeType
)
Visual Basic
Public Function CreateNode ( _
    nodeType As Type _
) As INode
F#
member CreateNode :
        nodeType:Type -> INode

Parameters

nodeType
Type: System..::..Type
Der Knotentyp.

Return Value

Eine Instanz des Knotentyps.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wenn der Knotentyp nicht instanziiert werden kann.

See Also

TestBench Class
DynamicNode.Test Namespace


Dispose Method

[image]

DynamicNodes API
TestBench..::..Dispose Method
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entsorgt die Testumgebung. Dabei wird auch die gekapselte Laufzeitumgebung entsorgt.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
F#
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposable..::..Dispose()()()()

See Also

TestBench Class
DynamicNode.Test Namespace


Finalize Method

[image]

DynamicNodes API
TestBench..::..Finalize Method
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt unverwaltete Ressourcen frei und führt andere Aufräumarbeiten aus, bevor TestBench vom Garbage-Collector aus dem Speicher entfernt wird.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
F#
abstract Finalize : unit -> unit
override Finalize : unit -> unit

See Also

TestBench Class
DynamicNode.Test Namespace


Garbage Method

[image]

DynamicNodes API
TestBench..::..Garbage Method
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zerstört einen Knoten und gibt seine Ressourcen frei.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public INode Garbage(
    INode n
)
Visual Basic
Public Function Garbage ( _
    n As INode _
) As INode
F#
member Garbage :
        n:INode -> INode

Parameters

n
Type: DynamicNode.Core..::..INode
Der Knoten.

Return Value

null

See Also

TestBench Class
DynamicNode.Test Namespace


Init Method

[image]

DynamicNodes API
TestBench..::..Init Method
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Knoten-Instanz.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public void Init(
    INode n,
    bool visual
)
Visual Basic
Public Sub Init ( _
    n As INode, _
    visual As Boolean _
)
F#
member Init :
        n:INode *
        visual:bool -> unit

Parameters

n
Type: DynamicNode.Core..::..INode
Der Knoten.
visual
Type: System..::..Boolean
Gibt an, ob die visuellen Erweiterungen initialisiert werden sollen.

See Also

TestBench Class
DynamicNode.Test Namespace


RemoveTestCase Method

[image]

DynamicNodes API
TestBench..::..RemoveTestCase Method
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Entfernt einen Testfall aus der Testumgebung.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public void RemoveTestCase(
    ITestCase testCase
)
Visual Basic
Public Sub RemoveTestCase ( _
    testCase As ITestCase _
)
F#
member RemoveTestCase :
        testCase:ITestCase -> unit

Parameters

testCase
Type: DynamicNode.Test..::..ITestCase
Ein Testfall.

See Also

TestBench Class
DynamicNode.Test Namespace


Test Method

[image]

DynamicNodes API
TestBench..::..Test Method
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt die Basis-Tests und alle registrierten Testfälle für den übergebenen Knotentyp durch.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public void Test(
    Type nodeType
)
Visual Basic
Public Sub Test ( _
    nodeType As Type _
)
F#
member Test :
        nodeType:Type -> unit

Parameters

nodeType
Type: System..::..Type
Der zu testende Knotentyp.

See Also

TestBench Class
DynamicNode.Test Namespace


TestBench Properties

[image] [image]

DynamicNodes API
TestBench Properties
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TestBench type exposes the following members.

Properties

 | Name | Description
Public property | CountInstanceTestCases | Gibt die Anzahl der registrierten Instanz-Testfälle zurück.
Public property | CountTypeTestCases | Gibt die Anzahl der registrierten Typen-Testfälle zurück.
Public property | Graph | Gibt ein IGraph-Objekt ohne grafischer Ausgabe zurück.
Public property | IsDisposed | Gibt einen Wert zurück, der angibt, ob diese Instanz entsorgt wurde.
Public property | Runtime | Gibt den Kern der Testumgebung zurück.
Public property | VisualGraph | Gibt ein IGraph-Objekt mit grafischer Ausgabe zurück.
Public property | VisualTestPanel | Gibt ein Panel zum Testen von grafischer Ausgabe zurück.

See Also

TestBench Class
DynamicNode.Test Namespace


CountInstanceTestCases Property

[image]

DynamicNodes API
TestBench..::..CountInstanceTestCases Property
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der registrierten Instanz-Testfälle zurück.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public int CountInstanceTestCases { get; }
Visual Basic
Public ReadOnly Property CountInstanceTestCases As Integer
    Get
F#
member CountInstanceTestCases : int

Field Value

Die Anzahl der Instanz-Testfälle.

See Also

TestBench Class
DynamicNode.Test Namespace


CountTypeTestCases Property

[image]

DynamicNodes API
TestBench..::..CountTypeTestCases Property
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der registrierten Typen-Testfälle zurück.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public int CountTypeTestCases { get; }
Visual Basic
Public ReadOnly Property CountTypeTestCases As Integer
    Get
F#
member CountTypeTestCases : int

Field Value

Die Anzahl der Typen-Testfälle.

See Also

TestBench Class
DynamicNode.Test Namespace


Graph Property

[image]

DynamicNodes API
TestBench..::..Graph Property
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein IGraph-Objekt ohne grafischer Ausgabe zurück.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public IGraph Graph { get; }
Visual Basic
Public ReadOnly Property Graph As IGraph
    Get
F#
member Graph : IGraph

Field Value

Ein Graph ohne grafische Ausgabe.

See Also

TestBench Class
DynamicNode.Test Namespace


IsDisposed Property

[image]

DynamicNodes API
TestBench..::..IsDisposed Property
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob diese Instanz entsorgt wurde.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public bool IsDisposed { get; private set; }
Visual Basic
Public Property IsDisposed As Boolean
    Get
    Private Set
F#
member IsDisposed : bool with get, private set

Field Value

true, wenn diese Instanz entsorgt wurde, sonst false.

See Also

TestBench Class
DynamicNode.Test Namespace


Runtime Property

[image]

DynamicNodes API
TestBench..::..Runtime Property
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Kern der Testumgebung zurück.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public IRuntime Runtime { get; }
Visual Basic
Public ReadOnly Property Runtime As IRuntime
    Get
F#
member Runtime : IRuntime

Field Value

Der Kern der Testumgebung.

See Also

TestBench Class
DynamicNode.Test Namespace


VisualGraph Property

[image]

DynamicNodes API
TestBench..::..VisualGraph Property
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein IGraph-Objekt mit grafischer Ausgabe zurück.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public IGraph VisualGraph { get; }
Visual Basic
Public ReadOnly Property VisualGraph As IGraph
    Get
F#
member VisualGraph : IGraph

Field Value

Ein Graph mit grafischer Ausgabe.

See Also

TestBench Class
DynamicNode.Test Namespace


VisualTestPanel Property

[image]

DynamicNodes API
TestBench..::..VisualTestPanel Property
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Panel zum Testen von grafischer Ausgabe zurück.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public Panel VisualTestPanel { get; }
Visual Basic
Public ReadOnly Property VisualTestPanel As Panel
    Get
F#
member VisualTestPanel : Panel

Field Value

Ein Test-Panel für grafische Ausgaben.

See Also

TestBench Class
DynamicNode.Test Namespace


TestBench Events

[image] [image]

DynamicNodes API
TestBench Events
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TestBench type exposes the following members.

Events

 | Name | Description
Public event | TestFinished | Wird ausgelöst, wenn der Test eines Knotens abgeschlossen ist.
Public event | TestMessage | Wir ausgelöst, wenn während des Tests eine Meldung ausgegeben wird.
Public event | TestStart | Wird ausgelöst, wenn der Test eines Knotens beginnt.

See Also

TestBench Class
DynamicNode.Test Namespace


TestFinished Event

[image]

DynamicNodes API
TestBench..::..TestFinished Event
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Test eines Knotens abgeschlossen ist.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public event EventHandler<TestEventArgs> TestFinished
Visual Basic
Public Event TestFinished As EventHandler(Of TestEventArgs)
F#
member TestFinished : IEvent<EventHandler<TestEventArgs>,
    TestEventArgs>

See Also

TestBench Class
DynamicNode.Test Namespace


TestMessage Event

[image]

DynamicNodes API
TestBench..::..TestMessage Event
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wir ausgelöst, wenn während des Tests eine Meldung ausgegeben wird.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public event EventHandler<TestEventArgs> TestMessage
Visual Basic
Public Event TestMessage As EventHandler(Of TestEventArgs)
F#
member TestMessage : IEvent<EventHandler<TestEventArgs>,
    TestEventArgs>

See Also

TestBench Class
DynamicNode.Test Namespace


TestStart Event

[image]

DynamicNodes API
TestBench..::..TestStart Event
TestBench Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn der Test eines Knotens beginnt.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public event EventHandler<TestEventArgs> TestStart
Visual Basic
Public Event TestStart As EventHandler(Of TestEventArgs)
F#
member TestStart : IEvent<EventHandler<TestEventArgs>,
    TestEventArgs>

See Also

TestBench Class
DynamicNode.Test Namespace


TestEventArgs Class

[image]

DynamicNodes API
TestEventArgs Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Ereignis-Argument-Klasse für Test-Ereignisse.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public class TestEventArgs : EventArgs
Visual Basic
Public Class TestEventArgs _
    Inherits EventArgs
F#
type TestEventArgs =
    class
        inherit EventArgs
    end

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
DynamicNode.Test..::..TestEventArgs

See Also

TestEventArgs Members
DynamicNode.Test Namespace


TestEventArgs Members

[image] [image]

DynamicNodes API
TestEventArgs Members
TestEventArgs Class Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TestEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | EventType | Gibt den Ereignistyp zurück.
Public property | Exception | Gibt die Ausnahme zurück, welche diese Nachricht ausgelöst hat, oder null, wenn keine Ausnahme die Ursache war.
Public property | Message | Gibt die Ereignisnachricht zurück.
Public property | NodeType | Gibt den Knotentyp oder null zurück, bei dessen Test das Ereignis ausgelöst wurde.
Public property | TestName | Gibt den Namen des Tests zurück, welcher das Eregnis ausgelöst hat.

See Also

TestEventArgs Class
DynamicNode.Test Namespace


TestEventArgs Properties

[image] [image]

DynamicNodes API
TestEventArgs Properties
TestEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TestEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | EventType | Gibt den Ereignistyp zurück.
Public property | Exception | Gibt die Ausnahme zurück, welche diese Nachricht ausgelöst hat, oder null, wenn keine Ausnahme die Ursache war.
Public property | Message | Gibt die Ereignisnachricht zurück.
Public property | NodeType | Gibt den Knotentyp oder null zurück, bei dessen Test das Ereignis ausgelöst wurde.
Public property | TestName | Gibt den Namen des Tests zurück, welcher das Eregnis ausgelöst hat.

See Also

TestEventArgs Class
DynamicNode.Test Namespace


EventType Property

[image]

DynamicNodes API
TestEventArgs..::..EventType Property
TestEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Ereignistyp zurück.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public TestEventTyp EventType { get; }
Visual Basic
Public ReadOnly Property EventType As TestEventTyp
    Get
F#
member EventType : TestEventTyp

Field Value

Der Ereignistyp.

See Also

TestEventArgs Class
DynamicNode.Test Namespace


Exception Property

[image]

DynamicNodes API
TestEventArgs..::..Exception Property
TestEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ausnahme zurück, welche diese Nachricht ausgelöst hat, oder null, wenn keine Ausnahme die Ursache war.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public Exception Exception { get; }
Visual Basic
Public ReadOnly Property Exception As Exception
    Get
F#
member Exception : Exception

Field Value

Die Ausnahme oder null.

See Also

TestEventArgs Class
DynamicNode.Test Namespace


Message Property

[image]

DynamicNodes API
TestEventArgs..::..Message Property
TestEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Ereignisnachricht zurück.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get
F#
member Message : string

Field Value

Die Ereignisnachricht.

See Also

TestEventArgs Class
DynamicNode.Test Namespace


NodeType Property

[image]

DynamicNodes API
TestEventArgs..::..NodeType Property
TestEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Knotentyp oder null zurück, bei dessen Test das Ereignis ausgelöst wurde.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public Type NodeType { get; }
Visual Basic
Public ReadOnly Property NodeType As Type
    Get
F#
member NodeType : Type

Field Value

Der getestete Knotentyp oder null.

See Also

TestEventArgs Class
DynamicNode.Test Namespace


TestName Property

[image]

DynamicNodes API
TestEventArgs..::..TestName Property
TestEventArgs Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Tests zurück, welcher das Eregnis ausgelöst hat.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public string TestName { get; }
Visual Basic
Public ReadOnly Property TestName As String
    Get
F#
member TestName : string

Field Value

Der Name des Tests.

See Also

TestEventArgs Class
DynamicNode.Test Namespace


TestEventTyp Enumeration

[image]

DynamicNodes API
TestEventTyp Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Typen von Ereignissen, die beim Testen eines Knoten auftreten können.

Namespace: DynamicNode.Test
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public enum TestEventTyp
Visual Basic
Public Enumeration TestEventTyp
F#
type TestEventTyp

Members

Member name | Description
Info |
Warning |
Error |

See Also

DynamicNode.Test Namespace


DynamicNode.Test.Cases Namespace

[image]

DynamicNodes API
DynamicNode.Test.Cases Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält eine Anzahl von Testfällen für die Knoten-Typen-Testumgebung von DynamicNodes.

Classes

 | Class | Description
Public class | BaseInstanceTestCase | Basisklasse für Instanz-Testfälle.
Public class | BaseTestCase | Eine Basisklasse für Testfälle, welche einigen Komfort für das Melden von Ereignissen bietet.
Public class | BaseTypeTestCase | Basisklasse für Typen-Testfälle.


BaseInstanceTestCase Class

[image]

DynamicNodes API
BaseInstanceTestCase Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Basisklasse für Instanz-Testfälle.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public abstract class BaseInstanceTestCase : BaseTestCase,
    INodeInstanceTestCase, ITestCase
Visual Basic
Public MustInherit Class BaseInstanceTestCase _
    Inherits BaseTestCase _
    Implements INodeInstanceTestCase, ITestCase
F#
[<AbstractClassAttribute>]
type BaseInstanceTestCase =
    class
        inherit BaseTestCase
        interface INodeInstanceTestCase
        interface ITestCase
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Test.Cases..::..BaseTestCase
DynamicNode.Test.Cases..::..BaseInstanceTestCase

See Also

BaseInstanceTestCase Members
DynamicNode.Test.Cases Namespace


BaseInstanceTestCase Members

[image] [image]

DynamicNodes API
BaseInstanceTestCase Members
BaseInstanceTestCase Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseInstanceTestCase type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseInstanceTestCase | Initialisiert die Testfall-Eigenschaften.

Methods

 | Name | Description
Protected method | BuildTestEventArgs | Formatiert eine Test-Nachricht. (Overrides BaseTestCase..::..BuildTestEventArgs(String, TestEventTyp, String, Exception).)
Protected method | Err(String) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)
Protected method | Err(String, Exception) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)
Protected method | Info(String) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)
Protected method | Info(String, Exception) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)
Protected method | OnTestEvent | Löst das Ereignis TestEvent aus. (Inherited from BaseTestCase.)
Protected method | Test()()()() | Muss vom konkreten Testfall überschrieben werden. Die zu testende Knoteninstanz ist Node, die Testumgebung ist TestBench.
Public method | Test(TestBench, INode) | Testet den übergebenen Knoten.
Protected method | Warn(String) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)
Protected method | Warn(String, Exception) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)

Properties

 | Name | Description
Public property | NeedVisualInitialized | Prüft, ob der Testfall einen initialisierten Knoten mit grafischer Ausgabe benötigt.
Public property | Node | Gibt den aktuell zu testenden Knoten zurück.
Public property | TestBench | Gibt die Testumgebung zurück.
Public property | TestCaseName | Gibt den Namen des Tests zurück. (Inherited from BaseTestCase.)

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn ein Ereignis beim Testen auftritt. (Inherited from BaseTestCase.)

See Also

BaseInstanceTestCase Class
DynamicNode.Test.Cases Namespace


BaseInstanceTestCase Constructor

[image]

DynamicNodes API
BaseInstanceTestCase Constructor
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert die Testfall-Eigenschaften.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected BaseInstanceTestCase(
    string name,
    bool needVisualInit
)
Visual Basic
Protected Sub New ( _
    name As String, _
    needVisualInit As Boolean _
)
F#
new :
        name:string *
        needVisualInit:bool -> BaseInstanceTestCase

Parameters

name
Type: System..::..String
Der Name des Testfalls.
needVisualInit
Type: System..::..Boolean
true wenn der Testfall einen grafisch initialisierten Knoten benötigt.

See Also

BaseInstanceTestCase Class
DynamicNode.Test.Cases Namespace


BaseInstanceTestCase Methods

[image] [image]

DynamicNodes API
BaseInstanceTestCase Methods
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseInstanceTestCase type exposes the following members.

Methods

 | Name | Description
Protected method | BuildTestEventArgs | Formatiert eine Test-Nachricht. (Overrides BaseTestCase..::..BuildTestEventArgs(String, TestEventTyp, String, Exception).)
Protected method | Err(String) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)
Protected method | Err(String, Exception) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)
Protected method | Info(String) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)
Protected method | Info(String, Exception) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)
Protected method | OnTestEvent | Löst das Ereignis TestEvent aus. (Inherited from BaseTestCase.)
Protected method | Test()()()() | Muss vom konkreten Testfall überschrieben werden. Die zu testende Knoteninstanz ist Node, die Testumgebung ist TestBench.
Public method | Test(TestBench, INode) | Testet den übergebenen Knoten.
Protected method | Warn(String) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)
Protected method | Warn(String, Exception) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)

See Also

BaseInstanceTestCase Class
DynamicNode.Test.Cases Namespace


BuildTestEventArgs Method

[image]

DynamicNodes API
BaseInstanceTestCase..::..BuildTestEventArgs Method
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Formatiert eine Test-Nachricht.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected override TestEventArgs BuildTestEventArgs(
    string name,
    TestEventTyp typ,
    string msg,
    Exception e
)
Visual Basic
Protected Overrides Function BuildTestEventArgs ( _
    name As String, _
    typ As TestEventTyp, _
    msg As String, _
    e As Exception _
) As TestEventArgs
F#
abstract BuildTestEventArgs :
        name:string *
        typ:TestEventTyp *
        msg:string *
        e:Exception -> TestEventArgs
override BuildTestEventArgs :
        name:string *
        typ:TestEventTyp *
        msg:string *
        e:Exception -> TestEventArgs

Parameters

name
Type: System..::..String
Der Name des Testfalles.
typ
Type: DynamicNode.Test..::..TestEventTyp
Der Nachrichtentyp.
msg
Type: System..::..String
Der Nachrichtentext.
e
Type: System..::..Exception
Eine Ausnahme oder null.

Return Value

Eine TestEventArgs-Instanz.

See Also

BaseInstanceTestCase Class
DynamicNode.Test.Cases Namespace


Err Method

[image] [image]

DynamicNodes API
BaseInstanceTestCase..::..Err Method
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Err(String) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)
Protected method | Err(String, Exception) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)

See Also

BaseInstanceTestCase Class
BaseInstanceTestCase Members
DynamicNode.Test.Cases Namespace


Info Method

[image] [image]

DynamicNodes API
BaseInstanceTestCase..::..Info Method
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Info(String) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)
Protected method | Info(String, Exception) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)

See Also

BaseInstanceTestCase Class
BaseInstanceTestCase Members
DynamicNode.Test.Cases Namespace


Test Method

[image] [image]

DynamicNodes API
BaseInstanceTestCase..::..Test Method
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Test()()()() | Muss vom konkreten Testfall überschrieben werden. Die zu testende Knoteninstanz ist Node, die Testumgebung ist TestBench.
Public method | Test(TestBench, INode) | Testet den übergebenen Knoten.

See Also

BaseInstanceTestCase Class
BaseInstanceTestCase Members
DynamicNode.Test.Cases Namespace


Test Method

[image]

DynamicNodes API
BaseInstanceTestCase..::..Test Method
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Muss vom konkreten Testfall überschrieben werden. Die zu testende Knoteninstanz ist Node, die Testumgebung ist TestBench.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected abstract bool Test()
Visual Basic
Protected MustOverride Function Test As Boolean
F#
abstract Test : unit -> bool

Return Value

true, wenn der Test vollständig bestanden wurde.

See Also

BaseInstanceTestCase Class
Test Overload
DynamicNode.Test.Cases Namespace


Test Method (TestBench, INode)

[image]

DynamicNodes API
BaseInstanceTestCase..::..Test Method (TestBench, INode)
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Testet den übergebenen Knoten.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public bool Test(
    TestBench bench,
    INode node
)
Visual Basic
Public Function Test ( _
    bench As TestBench, _
    node As INode _
) As Boolean
F#
abstract Test :
        bench:TestBench *
        node:INode -> bool
override Test :
        bench:TestBench *
        node:INode -> bool

Parameters

bench
Type: DynamicNode.Test..::..TestBench
Die Testumgebung.
node
Type: DynamicNode.Core..::..INode
Der Knoten.

Return Value

true, wenn der Test vollständig bestanden wurde.

Implements

INodeInstanceTestCase..::..Test(TestBench, INode)

See Also

BaseInstanceTestCase Class
Test Overload
DynamicNode.Test.Cases Namespace


Warn Method

[image] [image]

DynamicNodes API
BaseInstanceTestCase..::..Warn Method
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Warn(String) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)
Protected method | Warn(String, Exception) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)

See Also

BaseInstanceTestCase Class
BaseInstanceTestCase Members
DynamicNode.Test.Cases Namespace


BaseInstanceTestCase Properties

[image] [image]

DynamicNodes API
BaseInstanceTestCase Properties
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseInstanceTestCase type exposes the following members.

Properties

 | Name | Description
Public property | NeedVisualInitialized | Prüft, ob der Testfall einen initialisierten Knoten mit grafischer Ausgabe benötigt.
Public property | Node | Gibt den aktuell zu testenden Knoten zurück.
Public property | TestBench | Gibt die Testumgebung zurück.
Public property | TestCaseName | Gibt den Namen des Tests zurück. (Inherited from BaseTestCase.)

See Also

BaseInstanceTestCase Class
DynamicNode.Test.Cases Namespace


NeedVisualInitialized Property

[image]

DynamicNodes API
BaseInstanceTestCase..::..NeedVisualInitialized Property
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft, ob der Testfall einen initialisierten Knoten mit grafischer Ausgabe benötigt.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public bool NeedVisualInitialized { get; }
Visual Basic
Public ReadOnly Property NeedVisualInitialized As Boolean
    Get
F#
abstract NeedVisualInitialized : bool
override NeedVisualInitialized : bool

Field Value

true zurück, wenn der Knoten mit grafischer Ausgabe initialisiert sein muss, damit dieser Testfall durchgeführt werden kann.

Implements

INodeInstanceTestCase..::..NeedVisualInitialized

See Also

BaseInstanceTestCase Class
DynamicNode.Test.Cases Namespace


Node Property

[image]

DynamicNodes API
BaseInstanceTestCase..::..Node Property
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den aktuell zu testenden Knoten zurück.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public INode Node { get; }
Visual Basic
Public ReadOnly Property Node As INode
    Get
F#
member Node : INode

Field Value

Der aktuelle Knoten.

See Also

BaseInstanceTestCase Class
DynamicNode.Test.Cases Namespace


TestBench Property

[image]

DynamicNodes API
BaseInstanceTestCase..::..TestBench Property
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Testumgebung zurück.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public TestBench TestBench { get; }
Visual Basic
Public ReadOnly Property TestBench As TestBench
    Get
F#
member TestBench : TestBench

Field Value

Die Testumgebung.

See Also

BaseInstanceTestCase Class
DynamicNode.Test.Cases Namespace


BaseInstanceTestCase Events

[image] [image]

DynamicNodes API
BaseInstanceTestCase Events
BaseInstanceTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseInstanceTestCase type exposes the following members.

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn ein Ereignis beim Testen auftritt. (Inherited from BaseTestCase.)

See Also

BaseInstanceTestCase Class
DynamicNode.Test.Cases Namespace


BaseTestCase Class

[image]

DynamicNodes API
BaseTestCase Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Basisklasse für Testfälle, welche einigen Komfort für das Melden von Ereignissen bietet.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public abstract class BaseTestCase : ITestCase
Visual Basic
Public MustInherit Class BaseTestCase _
    Implements ITestCase
F#
[<AbstractClassAttribute>]
type BaseTestCase =
    class
        interface ITestCase
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Test.Cases..::..BaseTestCase
DynamicNode.Test.Cases..::..BaseInstanceTestCase
DynamicNode.Test.Cases..::..BaseTypeTestCase

See Also

BaseTestCase Members
DynamicNode.Test.Cases Namespace


BaseTestCase Members

[image] [image]

DynamicNodes API
BaseTestCase Members
BaseTestCase Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseTestCase type exposes the following members.

Constructors

 | Name | Description
Public method | BaseTestCase | Initialisiert eine neue Instanz der Klasse BaseTestCase.

Methods

 | Name | Description
Protected method | BuildTestEventArgs | Muss überschrieben werden.
Protected method | Err(String) | Löst ein Test-Ereignis vom Typ "Fehler" aus.
Protected method | Err(String, Exception) | Löst ein Test-Ereignis vom Typ "Fehler" aus.
Protected method | Info(String) | Löst ein Test-Ereignis vom Typ "Information" aus.
Protected method | Info(String, Exception) | Löst ein Test-Ereignis vom Typ "Information" aus.
Protected method | OnTestEvent | Löst das Ereignis TestEvent aus.
Protected method | Warn(String) | Löst ein Test-Ereignis vom Typ "Warnung" aus.
Protected method | Warn(String, Exception) | Löst ein Test-Ereignis vom Typ "Warnung" aus.

Properties

 | Name | Description
Public property | TestCaseName | Gibt den Namen des Tests zurück.

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn ein Ereignis beim Testen auftritt.

See Also

BaseTestCase Class
DynamicNode.Test.Cases Namespace


BaseTestCase Constructor

[image]

DynamicNodes API
BaseTestCase Constructor
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse BaseTestCase.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public BaseTestCase(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
F#
new :
        name:string -> BaseTestCase

Parameters

name
Type: System..::..String
Der Name des Testfalls.

See Also

BaseTestCase Class
DynamicNode.Test.Cases Namespace


BaseTestCase Methods

[image] [image]

DynamicNodes API
BaseTestCase Methods
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseTestCase type exposes the following members.

Methods

 | Name | Description
Protected method | BuildTestEventArgs | Muss überschrieben werden.
Protected method | Err(String) | Löst ein Test-Ereignis vom Typ "Fehler" aus.
Protected method | Err(String, Exception) | Löst ein Test-Ereignis vom Typ "Fehler" aus.
Protected method | Info(String) | Löst ein Test-Ereignis vom Typ "Information" aus.
Protected method | Info(String, Exception) | Löst ein Test-Ereignis vom Typ "Information" aus.
Protected method | OnTestEvent | Löst das Ereignis TestEvent aus.
Protected method | Warn(String) | Löst ein Test-Ereignis vom Typ "Warnung" aus.
Protected method | Warn(String, Exception) | Löst ein Test-Ereignis vom Typ "Warnung" aus.

See Also

BaseTestCase Class
DynamicNode.Test.Cases Namespace


BuildTestEventArgs Method

[image]

DynamicNodes API
BaseTestCase..::..BuildTestEventArgs Method
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Muss überschrieben werden.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected abstract TestEventArgs BuildTestEventArgs(
    string name,
    TestEventTyp typ,
    string msg,
    Exception e
)
Visual Basic
Protected MustOverride Function BuildTestEventArgs ( _
    name As String, _
    typ As TestEventTyp, _
    msg As String, _
    e As Exception _
) As TestEventArgs
F#
abstract BuildTestEventArgs :
        name:string *
        typ:TestEventTyp *
        msg:string *
        e:Exception -> TestEventArgs

Parameters

name
Type: System..::..String
Der Name des Testfalles.
typ
Type: DynamicNode.Test..::..TestEventTyp
Der Nachrichtentyp.
msg
Type: System..::..String
Der Nachrichtentext.
e
Type: System..::..Exception
Eine Ausnahme oder null.

Return Value

Eine TestEventArgs-Instanz.

See Also

BaseTestCase Class
DynamicNode.Test.Cases Namespace


Err Method

[image] [image]

DynamicNodes API
BaseTestCase..::..Err Method
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Err(String) | Löst ein Test-Ereignis vom Typ "Fehler" aus.
Protected method | Err(String, Exception) | Löst ein Test-Ereignis vom Typ "Fehler" aus.

See Also

BaseTestCase Class
BaseTestCase Members
DynamicNode.Test.Cases Namespace


Err Method (String)

[image]

DynamicNodes API
BaseTestCase..::..Err Method (String)
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst ein Test-Ereignis vom Typ "Fehler" aus.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected void Err(
    string msg
)
Visual Basic
Protected Sub Err ( _
    msg As String _
)
F#
member Err :
        msg:string -> unit

Parameters

msg
Type: System..::..String
Eine Nachricht.

See Also

BaseTestCase Class
Err Overload
DynamicNode.Test.Cases Namespace


Err Method (String, Exception)

[image]

DynamicNodes API
BaseTestCase..::..Err Method (String, Exception)
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst ein Test-Ereignis vom Typ "Fehler" aus.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected void Err(
    string msg,
    Exception e
)
Visual Basic
Protected Sub Err ( _
    msg As String, _
    e As Exception _
)
F#
member Err :
        msg:string *
        e:Exception -> unit

Parameters

msg
Type: System..::..String
Eine Nachricht.
e
Type: System..::..Exception
Die auslösende Ausnahme des Ereignisses.

See Also

BaseTestCase Class
Err Overload
DynamicNode.Test.Cases Namespace


Info Method

[image] [image]

DynamicNodes API
BaseTestCase..::..Info Method
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Info(String) | Löst ein Test-Ereignis vom Typ "Information" aus.
Protected method | Info(String, Exception) | Löst ein Test-Ereignis vom Typ "Information" aus.

See Also

BaseTestCase Class
BaseTestCase Members
DynamicNode.Test.Cases Namespace


Info Method (String)

[image]

DynamicNodes API
BaseTestCase..::..Info Method (String)
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst ein Test-Ereignis vom Typ "Information" aus.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected void Info(
    string msg
)
Visual Basic
Protected Sub Info ( _
    msg As String _
)
F#
member Info :
        msg:string -> unit

Parameters

msg
Type: System..::..String
Eine Nachricht.

See Also

BaseTestCase Class
Info Overload
DynamicNode.Test.Cases Namespace


Info Method (String, Exception)

[image]

DynamicNodes API
BaseTestCase..::..Info Method (String, Exception)
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst ein Test-Ereignis vom Typ "Information" aus.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected void Info(
    string msg,
    Exception e
)
Visual Basic
Protected Sub Info ( _
    msg As String, _
    e As Exception _
)
F#
member Info :
        msg:string *
        e:Exception -> unit

Parameters

msg
Type: System..::..String
Eine Nachricht.
e
Type: System..::..Exception
Die auslösende Ausnahme des Ereignisses.

See Also

BaseTestCase Class
Info Overload
DynamicNode.Test.Cases Namespace


OnTestEvent Method

[image]

DynamicNodes API
BaseTestCase..::..OnTestEvent Method
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis TestEvent aus.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected void OnTestEvent(
    TestEventArgs args
)
Visual Basic
Protected Sub OnTestEvent ( _
    args As TestEventArgs _
)
F#
member OnTestEvent :
        args:TestEventArgs -> unit

Parameters

args
Type: DynamicNode.Test..::..TestEventArgs
Eine TestEventArgs-Instanz, welche die Ereignis-Parameter enthält.

See Also

BaseTestCase Class
DynamicNode.Test.Cases Namespace


Warn Method

[image] [image]

DynamicNodes API
BaseTestCase..::..Warn Method
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Warn(String) | Löst ein Test-Ereignis vom Typ "Warnung" aus.
Protected method | Warn(String, Exception) | Löst ein Test-Ereignis vom Typ "Warnung" aus.

See Also

BaseTestCase Class
BaseTestCase Members
DynamicNode.Test.Cases Namespace


Warn Method (String)

[image]

DynamicNodes API
BaseTestCase..::..Warn Method (String)
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst ein Test-Ereignis vom Typ "Warnung" aus.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected void Warn(
    string msg
)
Visual Basic
Protected Sub Warn ( _
    msg As String _
)
F#
member Warn :
        msg:string -> unit

Parameters

msg
Type: System..::..String
Eine Nachricht.

See Also

BaseTestCase Class
Warn Overload
DynamicNode.Test.Cases Namespace


Warn Method (String, Exception)

[image]

DynamicNodes API
BaseTestCase..::..Warn Method (String, Exception)
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst ein Test-Ereignis vom Typ "Warnung" aus.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected void Warn(
    string msg,
    Exception e
)
Visual Basic
Protected Sub Warn ( _
    msg As String, _
    e As Exception _
)
F#
member Warn :
        msg:string *
        e:Exception -> unit

Parameters

msg
Type: System..::..String
Eine Nachricht.
e
Type: System..::..Exception
Die auslösende Ausnahme des Ereignisses.

See Also

BaseTestCase Class
Warn Overload
DynamicNode.Test.Cases Namespace


BaseTestCase Properties

[image] [image]

DynamicNodes API
BaseTestCase Properties
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseTestCase type exposes the following members.

Properties

 | Name | Description
Public property | TestCaseName | Gibt den Namen des Tests zurück.

See Also

BaseTestCase Class
DynamicNode.Test.Cases Namespace


TestCaseName Property

[image]

DynamicNodes API
BaseTestCase..::..TestCaseName Property
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Tests zurück.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public string TestCaseName { get; }
Visual Basic
Public ReadOnly Property TestCaseName As String
    Get
F#
abstract TestCaseName : string
override TestCaseName : string

Field Value

Der Name des Testfalls.

Implements

ITestCase..::..TestCaseName

See Also

BaseTestCase Class
DynamicNode.Test.Cases Namespace


BaseTestCase Events

[image] [image]

DynamicNodes API
BaseTestCase Events
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseTestCase type exposes the following members.

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn ein Ereignis beim Testen auftritt.

See Also

BaseTestCase Class
DynamicNode.Test.Cases Namespace


TestEvent Event

[image]

DynamicNodes API
BaseTestCase..::..TestEvent Event
BaseTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wird ausgelöst, wenn ein Ereignis beim Testen auftritt.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public event EventHandler<TestEventArgs> TestEvent
Visual Basic
Public Event TestEvent As EventHandler(Of TestEventArgs)
F#
abstract TestEvent : IEvent<EventHandler<TestEventArgs>,
    TestEventArgs>
override TestEvent : IEvent<EventHandler<TestEventArgs>,
    TestEventArgs>

Implements

ITestCase..::..TestEvent

See Also

BaseTestCase Class
DynamicNode.Test.Cases Namespace


BaseTypeTestCase Class

[image]

DynamicNodes API
BaseTypeTestCase Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Basisklasse für Typen-Testfälle.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public abstract class BaseTypeTestCase : BaseTestCase,
    INodeTypeTestCase, ITestCase
Visual Basic
Public MustInherit Class BaseTypeTestCase _
    Inherits BaseTestCase _
    Implements INodeTypeTestCase, ITestCase
F#
[<AbstractClassAttribute>]
type BaseTypeTestCase =
    class
        inherit BaseTestCase
        interface INodeTypeTestCase
        interface ITestCase
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Test.Cases..::..BaseTestCase
DynamicNode.Test.Cases..::..BaseTypeTestCase

See Also

BaseTypeTestCase Members
DynamicNode.Test.Cases Namespace


BaseTypeTestCase Members

[image] [image]

DynamicNodes API
BaseTypeTestCase Members
BaseTypeTestCase Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseTypeTestCase type exposes the following members.

Constructors

 | Name | Description
Public method | BaseTypeTestCase | Initialisiert eine neue Instanz der Klasse BaseTypeTestCase.

Methods

 | Name | Description
Protected method | BuildTestEventArgs | Formatiert eine Test-Nachricht. (Overrides BaseTestCase..::..BuildTestEventArgs(String, TestEventTyp, String, Exception).)
Protected method | Err(String) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)
Protected method | Err(String, Exception) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)
Protected method | Info(String) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)
Protected method | Info(String, Exception) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)
Protected method | OnTestEvent | Löst das Ereignis TestEvent aus. (Inherited from BaseTestCase.)
Protected method | Test()()()() | Muss vom konkreten Testfall überschrieben werden. Die zu testende Knotenklasse ist NodeType, die Testumgebung ist TestBench.
Public method | Test(TestBench, Type) | Testet den übergebenen Knoten.
Protected method | Warn(String) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)
Protected method | Warn(String, Exception) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)

Properties

 | Name | Description
Public property | NodeType | Gibt die aktuell zu testende Knotenklasse zurück.
Public property | TestBench | Gibt die Testumgebung zurück.
Public property | TestCaseName | Gibt den Namen des Tests zurück. (Inherited from BaseTestCase.)

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn ein Ereignis beim Testen auftritt. (Inherited from BaseTestCase.)

See Also

BaseTypeTestCase Class
DynamicNode.Test.Cases Namespace


BaseTypeTestCase Constructor

[image]

DynamicNodes API
BaseTypeTestCase Constructor
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse BaseTypeTestCase.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public BaseTypeTestCase(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
F#
new :
        name:string -> BaseTypeTestCase

Parameters

name
Type: System..::..String
Der Name des Testfalls.

See Also

BaseTypeTestCase Class
DynamicNode.Test.Cases Namespace


BaseTypeTestCase Methods

[image] [image]

DynamicNodes API
BaseTypeTestCase Methods
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseTypeTestCase type exposes the following members.

Methods

 | Name | Description
Protected method | BuildTestEventArgs | Formatiert eine Test-Nachricht. (Overrides BaseTestCase..::..BuildTestEventArgs(String, TestEventTyp, String, Exception).)
Protected method | Err(String) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)
Protected method | Err(String, Exception) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)
Protected method | Info(String) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)
Protected method | Info(String, Exception) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)
Protected method | OnTestEvent | Löst das Ereignis TestEvent aus. (Inherited from BaseTestCase.)
Protected method | Test()()()() | Muss vom konkreten Testfall überschrieben werden. Die zu testende Knotenklasse ist NodeType, die Testumgebung ist TestBench.
Public method | Test(TestBench, Type) | Testet den übergebenen Knoten.
Protected method | Warn(String) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)
Protected method | Warn(String, Exception) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)

See Also

BaseTypeTestCase Class
DynamicNode.Test.Cases Namespace


BuildTestEventArgs Method

[image]

DynamicNodes API
BaseTypeTestCase..::..BuildTestEventArgs Method
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Formatiert eine Test-Nachricht.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected override TestEventArgs BuildTestEventArgs(
    string name,
    TestEventTyp typ,
    string msg,
    Exception e
)
Visual Basic
Protected Overrides Function BuildTestEventArgs ( _
    name As String, _
    typ As TestEventTyp, _
    msg As String, _
    e As Exception _
) As TestEventArgs
F#
abstract BuildTestEventArgs :
        name:string *
        typ:TestEventTyp *
        msg:string *
        e:Exception -> TestEventArgs
override BuildTestEventArgs :
        name:string *
        typ:TestEventTyp *
        msg:string *
        e:Exception -> TestEventArgs

Parameters

name
Type: System..::..String
Der Name des Testfalles.
typ
Type: DynamicNode.Test..::..TestEventTyp
Der Nachrichtentyp.
msg
Type: System..::..String
Der Nachrichtentext.
e
Type: System..::..Exception
Eine Ausnahme oder null.

Return Value

Eine TestEventArgs-Instanz.

See Also

BaseTypeTestCase Class
DynamicNode.Test.Cases Namespace


Err Method

[image] [image]

DynamicNodes API
BaseTypeTestCase..::..Err Method
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Err(String) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)
Protected method | Err(String, Exception) | Löst ein Test-Ereignis vom Typ "Fehler" aus. (Inherited from BaseTestCase.)

See Also

BaseTypeTestCase Class
BaseTypeTestCase Members
DynamicNode.Test.Cases Namespace


Info Method

[image] [image]

DynamicNodes API
BaseTypeTestCase..::..Info Method
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Info(String) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)
Protected method | Info(String, Exception) | Löst ein Test-Ereignis vom Typ "Information" aus. (Inherited from BaseTestCase.)

See Also

BaseTypeTestCase Class
BaseTypeTestCase Members
DynamicNode.Test.Cases Namespace


Test Method

[image] [image]

DynamicNodes API
BaseTypeTestCase..::..Test Method
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Test()()()() | Muss vom konkreten Testfall überschrieben werden. Die zu testende Knotenklasse ist NodeType, die Testumgebung ist TestBench.
Public method | Test(TestBench, Type) | Testet den übergebenen Knoten.

See Also

BaseTypeTestCase Class
BaseTypeTestCase Members
DynamicNode.Test.Cases Namespace


Test Method

[image]

DynamicNodes API
BaseTypeTestCase..::..Test Method
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Muss vom konkreten Testfall überschrieben werden. Die zu testende Knotenklasse ist NodeType, die Testumgebung ist TestBench.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
protected abstract bool Test()
Visual Basic
Protected MustOverride Function Test As Boolean
F#
abstract Test : unit -> bool

Return Value

true, wenn der Test vollständig bestanden wurde.

See Also

BaseTypeTestCase Class
Test Overload
DynamicNode.Test.Cases Namespace


Test Method (TestBench, Type)

[image]

DynamicNodes API
BaseTypeTestCase..::..Test Method (TestBench, Type)
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Testet den übergebenen Knoten.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public bool Test(
    TestBench bench,
    Type nodeType
)
Visual Basic
Public Function Test ( _
    bench As TestBench, _
    nodeType As Type _
) As Boolean
F#
abstract Test :
        bench:TestBench *
        nodeType:Type -> bool
override Test :
        bench:TestBench *
        nodeType:Type -> bool

Parameters

bench
Type: DynamicNode.Test..::..TestBench
Die Testumgebung.
nodeType
Type: System..::..Type
Der Knoten.

Return Value

true, wenn der Test vollständig bestanden wurde.

Implements

INodeTypeTestCase..::..Test(TestBench, Type)

See Also

BaseTypeTestCase Class
Test Overload
DynamicNode.Test.Cases Namespace


Warn Method

[image] [image]

DynamicNodes API
BaseTypeTestCase..::..Warn Method
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | Warn(String) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)
Protected method | Warn(String, Exception) | Löst ein Test-Ereignis vom Typ "Warnung" aus. (Inherited from BaseTestCase.)

See Also

BaseTypeTestCase Class
BaseTypeTestCase Members
DynamicNode.Test.Cases Namespace


BaseTypeTestCase Properties

[image] [image]

DynamicNodes API
BaseTypeTestCase Properties
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseTypeTestCase type exposes the following members.

Properties

 | Name | Description
Public property | NodeType | Gibt die aktuell zu testende Knotenklasse zurück.
Public property | TestBench | Gibt die Testumgebung zurück.
Public property | TestCaseName | Gibt den Namen des Tests zurück. (Inherited from BaseTestCase.)

See Also

BaseTypeTestCase Class
DynamicNode.Test.Cases Namespace


NodeType Property

[image]

DynamicNodes API
BaseTypeTestCase..::..NodeType Property
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die aktuell zu testende Knotenklasse zurück.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public Type NodeType { get; }
Visual Basic
Public ReadOnly Property NodeType As Type
    Get
F#
member NodeType : Type

Field Value

Der aktuelle Knotenklasse.

See Also

BaseTypeTestCase Class
DynamicNode.Test.Cases Namespace


TestBench Property

[image]

DynamicNodes API
BaseTypeTestCase..::..TestBench Property
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Testumgebung zurück.

Namespace: DynamicNode.Test.Cases
Assembly: DNTesting (in DNTesting.dll) Version: 1.0.4679.19832 (1.0.0.0)

Syntax

C#
public TestBench TestBench { get; }
Visual Basic
Public ReadOnly Property TestBench As TestBench
    Get
F#
member TestBench : TestBench

Field Value

Die Testumgebung.

See Also

BaseTypeTestCase Class
DynamicNode.Test.Cases Namespace


BaseTypeTestCase Events

[image] [image]

DynamicNodes API
BaseTypeTestCase Events
BaseTypeTestCase Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The BaseTypeTestCase type exposes the following members.

Events

 | Name | Description
Public event | TestEvent | Wird ausgelöst, wenn ein Ereignis beim Testen auftritt. (Inherited from BaseTestCase.)

See Also

BaseTypeTestCase Class
DynamicNode.Test.Cases Namespace


DynamicNode.Tools.Mathematics Namespace

[image]

DynamicNodes API
DynamicNode.Tools.Mathematics Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "N:DynamicNode.Tools.Mathematics"]

Classes

 | Class | Description
Public class | GaussianDistribution | Eine Sammlung von Funktionen im Zusammenhang mit der Normalverteilung.
Public class | LinearAlgebra | Eine statische Klasse mit Methoden zu Berechnungen aus der linearen Algbra.


GaussianDistribution Class

[image]

DynamicNodes API
GaussianDistribution Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Sammlung von Funktionen im Zusammenhang mit der Normalverteilung.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static class GaussianDistribution
Visual Basic
Public NotInheritable Class GaussianDistribution
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GaussianDistribution =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Tools.Mathematics..::..GaussianDistribution

See Also

GaussianDistribution Members
DynamicNode.Tools.Mathematics Namespace


GaussianDistribution Members

[image] [image]

DynamicNodes API
GaussianDistribution Members
GaussianDistribution Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GaussianDistribution type exposes the following members.

Methods

Name | Description
BellCurve | Gibt die Verteilungswerte der Gaussschen Glockenkurve zurück.
BuildDoubleKernel | Berechnet einen 1-dimensionalen Gauss-Glocken-Kernel.
BuildDoubleKernel2D | Berechnet einen 2-dimensionalen Gauss-Glocken-Kernel.
BuildSingleKernel | Berechnet einen 1-dimensionalen Gauss-Glocken-Kernel.
BuildSingleKernel2D | Berechnet einen 2-dimensionalen Gauss-Glocken-Kernel.

See Also

GaussianDistribution Class
DynamicNode.Tools.Mathematics Namespace


GaussianDistribution Methods

[image] [image]

DynamicNodes API
GaussianDistribution Methods
GaussianDistribution Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GaussianDistribution type exposes the following members.

Methods

Name | Description
BellCurve | Gibt die Verteilungswerte der Gaussschen Glockenkurve zurück.
BuildDoubleKernel | Berechnet einen 1-dimensionalen Gauss-Glocken-Kernel.
BuildDoubleKernel2D | Berechnet einen 2-dimensionalen Gauss-Glocken-Kernel.
BuildSingleKernel | Berechnet einen 1-dimensionalen Gauss-Glocken-Kernel.
BuildSingleKernel2D | Berechnet einen 2-dimensionalen Gauss-Glocken-Kernel.

See Also

GaussianDistribution Class
DynamicNode.Tools.Mathematics Namespace


BellCurve Method

[image]

DynamicNodes API
GaussianDistribution..::..BellCurve Method
GaussianDistribution Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Verteilungswerte der Gaussschen Glockenkurve zurück.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static double BellCurve(
    double x
)
Visual Basic
Public Shared Function BellCurve ( _
    x As Double _
) As Double
F#
static member BellCurve :
        x:float -> float

Parameters

x
Type: System..::..Double
X.

Return Value

Y

See Also

GaussianDistribution Class
DynamicNode.Tools.Mathematics Namespace


BuildDoubleKernel Method

[image]

DynamicNodes API
GaussianDistribution..::..BuildDoubleKernel Method
GaussianDistribution Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet einen 1-dimensionalen Gauss-Glocken-Kernel.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static double[] BuildDoubleKernel(
    double s
)
Visual Basic
Public Shared Function BuildDoubleKernel ( _
    s As Double _
) As Double()
F#
static member BuildDoubleKernel :
        s:float -> float[]

Parameters

s
Type: System..::..Double
Die Ausbreitung des Kernels. Ein Wert von 1.0 erzeugt die Standardnormalverteilung mit einer Kernelgröße von 7.

Return Value

Ein Double-Array mit dem Kernel.

See Also

GaussianDistribution Class
DynamicNode.Tools.Mathematics Namespace


BuildDoubleKernel2D Method

[image]

DynamicNodes API
GaussianDistribution..::..BuildDoubleKernel2D Method
GaussianDistribution Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet einen 2-dimensionalen Gauss-Glocken-Kernel.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static double[,] BuildDoubleKernel2D(
    double s
)
Visual Basic
Public Shared Function BuildDoubleKernel2D ( _
    s As Double _
) As Double(,)
F#
static member BuildDoubleKernel2D :
        s:float -> float[,]

Parameters

s
Type: System..::..Double
Die Ausbreitung des Kernels. Ein Wert von 1.0 erzeugt die Standardnormalverteilung mit einer Kernelgröße von 7x7.

Return Value

Ein 2D-Double-Array mit dem Kernel.

See Also

GaussianDistribution Class
DynamicNode.Tools.Mathematics Namespace


BuildSingleKernel Method

[image]

DynamicNodes API
GaussianDistribution..::..BuildSingleKernel Method
GaussianDistribution Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet einen 1-dimensionalen Gauss-Glocken-Kernel.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float[] BuildSingleKernel(
    float s
)
Visual Basic
Public Shared Function BuildSingleKernel ( _
    s As Single _
) As Single()
F#
static member BuildSingleKernel :
        s:float32 -> float32[]

Parameters

s
Type: System..::..Single
Die Ausbreitung des Kernels. Ein Wert von 1.0f erzeugt die Standardnormalverteilung mit einer Kernelgröße von 7.

Return Value

Ein Single-Array mit dem Kernel.

See Also

GaussianDistribution Class
DynamicNode.Tools.Mathematics Namespace


BuildSingleKernel2D Method

[image]

DynamicNodes API
GaussianDistribution..::..BuildSingleKernel2D Method
GaussianDistribution Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet einen 2-dimensionalen Gauss-Glocken-Kernel.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float[,] BuildSingleKernel2D(
    float s
)
Visual Basic
Public Shared Function BuildSingleKernel2D ( _
    s As Single _
) As Single(,)
F#
static member BuildSingleKernel2D :
        s:float32 -> float32[,]

Parameters

s
Type: System..::..Single
Die Ausbreitung des Kernels. Ein Wert von 1.0 erzeugt die Standardnormalverteilung mit einer Kernelgröße von 7x7.

Return Value

Ein 2D-Double-Array mit dem Kernel.

See Also

GaussianDistribution Class
DynamicNode.Tools.Mathematics Namespace


LinearAlgebra Class

[image]

DynamicNodes API
LinearAlgebra Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine statische Klasse mit Methoden zu Berechnungen aus der linearen Algbra.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static class LinearAlgebra
Visual Basic
Public NotInheritable Class LinearAlgebra
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LinearAlgebra =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Tools.Mathematics..::..LinearAlgebra

See Also

LinearAlgebra Members
DynamicNode.Tools.Mathematics Namespace


LinearAlgebra Members

[image] [image]

DynamicNodes API
LinearAlgebra Members
LinearAlgebra Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Methods

Name | Description
Det(array<Double,2>[,](,)[,][,]) | Ermittelt die Determinate für eine Matrix.
Det(array<Single,2>[,](,)[,][,]) | Ermittelt die Determinate für eine Matrix.
Invert(array<Double,2>[,](,)[,][,]) | Berechnet die Inverse für eine Matrix.
Invert(array<Single,2>[,](,)[,][,]) | Berechnet die Inverse für eine Matrix.
Multiply(array<Double,2>[,](,)[,][,], array<Double,2>[,](,)[,][,]) | Führt eine Matrixmultiplikation zwischen zwei Matrizen durch.
Multiply(array<Double,2>[,](,)[,][,], array<Double>[]()[][]) | Führt eine Multiplikation zwischen einer Matrix und einem Spalten-Vektor durch.
Multiply(array<Double>[]()[][], array<Double,2>[,](,)[,][,]) | Führt eine Multiplikation zwischen einem Zeilen-Vektor und einer Matrix durch.
Multiply(array<Single,2>[,](,)[,][,], array<Single,2>[,](,)[,][,]) | Führt eine Matrixmultiplikation zwischen zwei Matrizen durch.
Multiply(array<Single,2>[,](,)[,][,], array<Single>[]()[][]) | Führt eine Multiplikation zwischen einer Matrix und einem Vektor durch.
Multiply(array<Single>[]()[][], array<Single,2>[,](,)[,][,]) | Führt eine Multiplikation zwischen einem Zeilen-Vektor und einer Matrix durch.
MultiplyPointwise(array<Double,2>[,](,)[,][,], array<Double,2>[,](,)[,][,]) | Führt eine Elementweise Multiplikation zwischen zwei Matrizen durch.
MultiplyPointwise(array<Single,2>[,](,)[,][,], array<Single,2>[,](,)[,][,]) | Führt eine Elementweise Multiplikation zwischen zwei Matrizen durch.

See Also

LinearAlgebra Class
DynamicNode.Tools.Mathematics Namespace


LinearAlgebra Methods

[image] [image]

DynamicNodes API
LinearAlgebra Methods
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Methods

Name | Description
Det(array<Double,2>[,](,)[,][,]) | Ermittelt die Determinate für eine Matrix.
Det(array<Single,2>[,](,)[,][,]) | Ermittelt die Determinate für eine Matrix.
Invert(array<Double,2>[,](,)[,][,]) | Berechnet die Inverse für eine Matrix.
Invert(array<Single,2>[,](,)[,][,]) | Berechnet die Inverse für eine Matrix.
Multiply(array<Double,2>[,](,)[,][,], array<Double,2>[,](,)[,][,]) | Führt eine Matrixmultiplikation zwischen zwei Matrizen durch.
Multiply(array<Double,2>[,](,)[,][,], array<Double>[]()[][]) | Führt eine Multiplikation zwischen einer Matrix und einem Spalten-Vektor durch.
Multiply(array<Double>[]()[][], array<Double,2>[,](,)[,][,]) | Führt eine Multiplikation zwischen einem Zeilen-Vektor und einer Matrix durch.
Multiply(array<Single,2>[,](,)[,][,], array<Single,2>[,](,)[,][,]) | Führt eine Matrixmultiplikation zwischen zwei Matrizen durch.
Multiply(array<Single,2>[,](,)[,][,], array<Single>[]()[][]) | Führt eine Multiplikation zwischen einer Matrix und einem Vektor durch.
Multiply(array<Single>[]()[][], array<Single,2>[,](,)[,][,]) | Führt eine Multiplikation zwischen einem Zeilen-Vektor und einer Matrix durch.
MultiplyPointwise(array<Double,2>[,](,)[,][,], array<Double,2>[,](,)[,][,]) | Führt eine Elementweise Multiplikation zwischen zwei Matrizen durch.
MultiplyPointwise(array<Single,2>[,](,)[,][,], array<Single,2>[,](,)[,][,]) | Führt eine Elementweise Multiplikation zwischen zwei Matrizen durch.

See Also

LinearAlgebra Class
DynamicNode.Tools.Mathematics Namespace


Det Method

[image] [image]

DynamicNodes API
LinearAlgebra..::..Det Method
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Det(array<Double,2>[,](,)[,][,]) | Ermittelt die Determinate für eine Matrix.
Det(array<Single,2>[,](,)[,][,]) | Ermittelt die Determinate für eine Matrix.

See Also

LinearAlgebra Class
LinearAlgebra Members
DynamicNode.Tools.Mathematics Namespace


Det Method (Double[,])

[image]

DynamicNodes API
LinearAlgebra..::..Det Method (array<Double,2>[,](,)[,][,])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ermittelt die Determinate für eine Matrix.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static double Det(
    double[,] m
)
Visual Basic
Public Shared Function Det ( _
    m As Double(,) _
) As Double
F#
static member Det :
        m:float[,] -> float

Parameters

m
Type: array< System..::..Double ,2>[,](,)[,][,]
Die Matrix.

Return Value

Die Determinante.

Exceptions

Exception | Condition
System..::..NotSupportedException | Wird geworfen, wenn die Größe der Matrix nicht unterstützt wird.

See Also

LinearAlgebra Class
Det Overload
DynamicNode.Tools.Mathematics Namespace


Det Method (Single[,])

[image]

DynamicNodes API
LinearAlgebra..::..Det Method (array<Single,2>[,](,)[,][,])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ermittelt die Determinate für eine Matrix.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float Det(
    float[,] m
)
Visual Basic
Public Shared Function Det ( _
    m As Single(,) _
) As Single
F#
static member Det :
        m:float32[,] -> float32

Parameters

m
Type: array< System..::..Single ,2>[,](,)[,][,]
Die Matrix.

Return Value

Die Determinante.

Exceptions

Exception | Condition
System..::..NotSupportedException | Wird geworfen, wenn die Größe der Matrix nicht unterstützt wird.

See Also

LinearAlgebra Class
Det Overload
DynamicNode.Tools.Mathematics Namespace


Invert Method

[image] [image]

DynamicNodes API
LinearAlgebra..::..Invert Method
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Invert(array<Double,2>[,](,)[,][,]) | Berechnet die Inverse für eine Matrix.
Invert(array<Single,2>[,](,)[,][,]) | Berechnet die Inverse für eine Matrix.

See Also

LinearAlgebra Class
LinearAlgebra Members
DynamicNode.Tools.Mathematics Namespace


Invert Method (Double[,])

[image]

DynamicNodes API
LinearAlgebra..::..Invert Method (array<Double,2>[,](,)[,][,])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet die Inverse für eine Matrix.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static double[,] Invert(
    double[,] m
)
Visual Basic
Public Shared Function Invert ( _
    m As Double(,) _
) As Double(,)
F#
static member Invert :
        m:float[,] -> float[,]

Parameters

m
Type: array< System..::..Double ,2>[,](,)[,][,]
Die Matrix.

Return Value

Die invertierte Matrix.

Exceptions

Exception | Condition
System..::..NotSupportedException | Wird geworfen, wenn die Größe der Matrix nicht unterstützt wird.
System..::..ArgumentException | Wird geworfen, wenn die übergebene Matrix nicht invertierbar ist.

See Also

LinearAlgebra Class
Invert Overload
DynamicNode.Tools.Mathematics Namespace


Invert Method (Single[,])

[image]

DynamicNodes API
LinearAlgebra..::..Invert Method (array<Single,2>[,](,)[,][,])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet die Inverse für eine Matrix.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float[,] Invert(
    float[,] m
)
Visual Basic
Public Shared Function Invert ( _
    m As Single(,) _
) As Single(,)
F#
static member Invert :
        m:float32[,] -> float32[,]

Parameters

m
Type: array< System..::..Single ,2>[,](,)[,][,]
Die Matrix.

Return Value

Die invertierte Matrix.

Exceptions

Exception | Condition
System..::..NotSupportedException | Wird geworfen, wenn die Größe der Matrix nicht unterstützt wird.
System..::..ArgumentException | Wird geworfen, wenn die übergebene Matrix nicht invertierbar ist.

See Also

LinearAlgebra Class
Invert Overload
DynamicNode.Tools.Mathematics Namespace


Multiply Method

[image] [image]

DynamicNodes API
LinearAlgebra..::..Multiply Method
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Multiply(array<Double,2>[,](,)[,][,], array<Double,2>[,](,)[,][,]) | Führt eine Matrixmultiplikation zwischen zwei Matrizen durch.
Multiply(array<Double,2>[,](,)[,][,], array<Double>[]()[][]) | Führt eine Multiplikation zwischen einer Matrix und einem Spalten-Vektor durch.
Multiply(array<Double>[]()[][], array<Double,2>[,](,)[,][,]) | Führt eine Multiplikation zwischen einem Zeilen-Vektor und einer Matrix durch.
Multiply(array<Single,2>[,](,)[,][,], array<Single,2>[,](,)[,][,]) | Führt eine Matrixmultiplikation zwischen zwei Matrizen durch.
Multiply(array<Single,2>[,](,)[,][,], array<Single>[]()[][]) | Führt eine Multiplikation zwischen einer Matrix und einem Vektor durch.
Multiply(array<Single>[]()[][], array<Single,2>[,](,)[,][,]) | Führt eine Multiplikation zwischen einem Zeilen-Vektor und einer Matrix durch.

See Also

LinearAlgebra Class
LinearAlgebra Members
DynamicNode.Tools.Mathematics Namespace


Multiply Method (Double[,], Double[,])

[image]

DynamicNodes API
LinearAlgebra..::..Multiply Method (array<Double,2>[,](,)[,][,], array<Double,2>[,](,)[,][,])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Matrixmultiplikation zwischen zwei Matrizen durch.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static double[,] Multiply(
    double[,] a,
    double[,] b
)
Visual Basic
Public Shared Function Multiply ( _
    a As Double(,), _
    b As Double(,) _
) As Double(,)
F#
static member Multiply :
        a:float[,] *
        b:float[,] -> float[,]

Parameters

a
Type: array< System..::..Double ,2>[,](,)[,][,]
Die Matrix 1.
b
Type: array< System..::..Double ,2>[,](,)[,][,]
Die Matrix 2.

Return Value

Die Ergebnismatrix.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn die Dimensionen der Matrizen nicht kompatibel sind.

See Also

LinearAlgebra Class
Multiply Overload
DynamicNode.Tools.Mathematics Namespace


Multiply Method (Double[,], Double[])

[image]

DynamicNodes API
LinearAlgebra..::..Multiply Method (array<Double,2>[,](,)[,][,], array<Double>[]()[][])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Multiplikation zwischen einer Matrix und einem Spalten-Vektor durch.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static double[] Multiply(
    double[,] m,
    double[] v
)
Visual Basic
Public Shared Function Multiply ( _
    m As Double(,), _
    v As Double() _
) As Double()
F#
static member Multiply :
        m:float[,] *
        v:float[] -> float[]

Parameters

m
Type: array< System..::..Double ,2>[,](,)[,][,]
Die Matrix.
v
Type: array< System..::..Double >[]()[][]
Der Spalten-Vektor.

Return Value

Der Ergebnisvektor.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn die Dimensionen der Matrix nicht zu der Länge des Vektors passen.

See Also

LinearAlgebra Class
Multiply Overload
DynamicNode.Tools.Mathematics Namespace


Multiply Method (Double[], Double[,])

[image]

DynamicNodes API
LinearAlgebra..::..Multiply Method (array<Double>[]()[][], array<Double,2>[,](,)[,][,])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Multiplikation zwischen einem Zeilen-Vektor und einer Matrix durch.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static double[] Multiply(
    double[] v,
    double[,] m
)
Visual Basic
Public Shared Function Multiply ( _
    v As Double(), _
    m As Double(,) _
) As Double()
F#
static member Multiply :
        v:float[] *
        m:float[,] -> float[]

Parameters

v
Type: array< System..::..Double >[]()[][]
Der Zeilen-Vektor.
m
Type: array< System..::..Double ,2>[,](,)[,][,]
Die Matrix.

Return Value

Der Ergebnisvektor.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn die Dimensionen der Matrix nicht zu der Länge des Vektors passen.

See Also

LinearAlgebra Class
Multiply Overload
DynamicNode.Tools.Mathematics Namespace


Multiply Method (Single[,], Single[,])

[image]

DynamicNodes API
LinearAlgebra..::..Multiply Method (array<Single,2>[,](,)[,][,], array<Single,2>[,](,)[,][,])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Matrixmultiplikation zwischen zwei Matrizen durch.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float[,] Multiply(
    float[,] a,
    float[,] b
)
Visual Basic
Public Shared Function Multiply ( _
    a As Single(,), _
    b As Single(,) _
) As Single(,)
F#
static member Multiply :
        a:float32[,] *
        b:float32[,] -> float32[,]

Parameters

a
Type: array< System..::..Single ,2>[,](,)[,][,]
Die Matrix 1.
b
Type: array< System..::..Single ,2>[,](,)[,][,]
Die Matrix 2.

Return Value

Die Ergebnismatrix.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn die Dimensionen der Matrizen nicht kompatibel sind.

See Also

LinearAlgebra Class
Multiply Overload
DynamicNode.Tools.Mathematics Namespace


Multiply Method (Single[,], Single[])

[image]

DynamicNodes API
LinearAlgebra..::..Multiply Method (array<Single,2>[,](,)[,][,], array<Single>[]()[][])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Multiplikation zwischen einer Matrix und einem Vektor durch.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float[] Multiply(
    float[,] m,
    float[] v
)
Visual Basic
Public Shared Function Multiply ( _
    m As Single(,), _
    v As Single() _
) As Single()
F#
static member Multiply :
        m:float32[,] *
        v:float32[] -> float32[]

Parameters

m
Type: array< System..::..Single ,2>[,](,)[,][,]
Die Matrix.
v
Type: array< System..::..Single >[]()[][]
Der Vektor.

Return Value

Der Ergebnisvektor.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn die Dimensionen der Matrix nicht zu der Länge des Vektors passen.

See Also

LinearAlgebra Class
Multiply Overload
DynamicNode.Tools.Mathematics Namespace


Multiply Method (Single[], Single[,])

[image]

DynamicNodes API
LinearAlgebra..::..Multiply Method (array<Single>[]()[][], array<Single,2>[,](,)[,][,])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Multiplikation zwischen einem Zeilen-Vektor und einer Matrix durch.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float[] Multiply(
    float[] v,
    float[,] m
)
Visual Basic
Public Shared Function Multiply ( _
    v As Single(), _
    m As Single(,) _
) As Single()
F#
static member Multiply :
        v:float32[] *
        m:float32[,] -> float32[]

Parameters

v
Type: array< System..::..Single >[]()[][]
Der Zeilen-Vektor.
m
Type: array< System..::..Single ,2>[,](,)[,][,]
Die Matrix.

Return Value

Der Ergebnisvektor.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn die Dimensionen der Matrix nicht zu der Länge des Vektors passen.

See Also

LinearAlgebra Class
Multiply Overload
DynamicNode.Tools.Mathematics Namespace


MultiplyPointwise Method

[image] [image]

DynamicNodes API
LinearAlgebra..::..MultiplyPointwise Method
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
MultiplyPointwise(array<Double,2>[,](,)[,][,], array<Double,2>[,](,)[,][,]) | Führt eine Elementweise Multiplikation zwischen zwei Matrizen durch.
MultiplyPointwise(array<Single,2>[,](,)[,][,], array<Single,2>[,](,)[,][,]) | Führt eine Elementweise Multiplikation zwischen zwei Matrizen durch.

See Also

LinearAlgebra Class
LinearAlgebra Members
DynamicNode.Tools.Mathematics Namespace


MultiplyPointwise Method (Double[,], Double[,])

[image]

DynamicNodes API
LinearAlgebra..::..MultiplyPointwise Method (array<Double,2>[,](,)[,][,], array<Double,2>[,](,)[,][,])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Elementweise Multiplikation zwischen zwei Matrizen durch.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static double[,] MultiplyPointwise(
    double[,] a,
    double[,] b
)
Visual Basic
Public Shared Function MultiplyPointwise ( _
    a As Double(,), _
    b As Double(,) _
) As Double(,)
F#
static member MultiplyPointwise :
        a:float[,] *
        b:float[,] -> float[,]

Parameters

a
Type: array< System..::..Double ,2>[,](,)[,][,]
Die Matrix 1.
b
Type: array< System..::..Double ,2>[,](,)[,][,]
Die Matrix 2.

Return Value

Die Ergebnismatrix.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn die Dimensionen der Matrizen nicht kompatibel sind.

See Also

LinearAlgebra Class
MultiplyPointwise Overload
DynamicNode.Tools.Mathematics Namespace


MultiplyPointwise Method (Single[,], Single[,])

[image]

DynamicNodes API
LinearAlgebra..::..MultiplyPointwise Method (array<Single,2>[,](,)[,][,], array<Single,2>[,](,)[,][,])
LinearAlgebra Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine Elementweise Multiplikation zwischen zwei Matrizen durch.

Namespace: DynamicNode.Tools.Mathematics
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float[,] MultiplyPointwise(
    float[,] a,
    float[,] b
)
Visual Basic
Public Shared Function MultiplyPointwise ( _
    a As Single(,), _
    b As Single(,) _
) As Single(,)
F#
static member MultiplyPointwise :
        a:float32[,] *
        b:float32[,] -> float32[,]

Parameters

a
Type: array< System..::..Single ,2>[,](,)[,][,]
Die Matrix 1.
b
Type: array< System..::..Single ,2>[,](,)[,][,]
Die Matrix 2.

Return Value

Die Ergebnismatrix.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn die Dimensionen der Matrizen nicht kompatibel sind.

See Also

LinearAlgebra Class
MultiplyPointwise Overload
DynamicNode.Tools.Mathematics Namespace


DynamicNode.Types.Base Namespace

[image]

DynamicNodes API
DynamicNode.Types.Base Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält ein Anzahl von Datentypen für die Datenverarbeitung in Flussgraphen. Dazu gehören u.a. mathematische Konstrukte wie Vektoren, Matrizen und Tupel.

Classes

 | Class | Description
Public class | Matrix<(Of <(<'T>)>)> | Eine generische, zweidimensionale (rechteckige) Datenstruktur. Schreibzugriff ist nur über das öffentliche Feld data möglich.
Public class | Matrix3D<(Of <(<'T>)>)> | Eine generische, dreidimensionale (quaderförmige) Datenstruktur. Schreibzugriff ist nur über das öffentliche Feld data möglich.
Public class | MDOTools | Eine Sammlung von nützlichen Funktionen für MDOs.
Public class | NumericTools | Eine Sammlung von nützlichen Funktionen für numerische MDOs.
Public class | Scalar<(Of <(<'T>)>)> | Ein generischer Skalar.
Public class | Tupel<(Of <(<'T>)>)> | Bildet eine kleine sortierte Menge von Objekten.
Public class | Vector<(Of <(<'T>)>)> | Eine generische, zweidimensionale (rechteckige) Datenstruktur. Schreibzugriff ist nur über das öffentliche Feld data möglich.

Interfaces

 | Interface | Description
Public interface | IFixSizeStruct | Die Basis-Schnittstelle für mathemathische Strukturen fester Größe
Public interface | IMatrix | Eine Schnittstelle für 2-dimensionale Objekte.
Public interface | IMatrix<(Of <(<'T>)>)> | Eine generische Schnittstelle für 2-dimensionale Objekte.
Public interface | IMatrix3D | Eine Schnittstelle für 3-dimensionale Objekte.
Public interface | IMatrix3D<(Of <(<'T>)>)> | Eine generische Schnittstelle für 3-dimensionale Objekte.
Public interface | IMDO | Eine Schnittstelle für multidimensionale Objekte (MDO).
Public interface | IMDO<(Of <(<'T>)>)> | Eine generische Schnittstelle für multidimensionale Objekte (MDO).
Public interface | IScalar | Eine Schnittstelle für 0-dimensionale Objekte.
Public interface | IScalar<(Of <(<'T>)>)> | Eine generische Schnittstelle für 0-dimensionale Objekte.
Public interface | IVector | Eine Schnittstelle für 1-dimensionale Objekte.
Public interface | IVector<(Of <(<'T>)>)> | Eine generische Schnittstelle für 1-dimensionale Objekte.


IFixSizeStruct Interface

[image]

DynamicNodes API
IFixSizeStruct Interface
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basis-Schnittstelle für mathemathische Strukturen fester Größe

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IFixSizeStruct
Visual Basic
Public Interface IFixSizeStruct
F#
type IFixSizeStruct =  interface end

See Also

DynamicNode.Types.Base Namespace


IMatrix Interface

[image]

DynamicNodes API
IMatrix Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für 2-dimensionale Objekte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IMatrix : IFixSizeStruct
Visual Basic
Public Interface IMatrix _
    Inherits IFixSizeStruct
F#
type IMatrix =
    interface
        interface IFixSizeStruct
    end

See Also

IMatrix Members
DynamicNode.Types.Base Namespace


IMatrix Members

[image] [image]

DynamicNodes API
IMatrix Members
IMatrix Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix type exposes the following members.

Methods

 | Name | Description
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab.

Properties

 | Name | Description
Public property | Height | Ruft die Höhe der Matrix ab.
Public property | Width | Ruft die Breite der Matrix ab.

See Also

IMatrix Interface
DynamicNode.Types.Base Namespace


IMatrix Methods

[image] [image]

DynamicNodes API
IMatrix Methods
IMatrix Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix type exposes the following members.

Methods

 | Name | Description
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab.

See Also

IMatrix Interface
DynamicNode.Types.Base Namespace


GetValueAsObject Method

[image]

DynamicNodes API
IMatrix..::..GetValueAsObject Method
IMatrix Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes als Objekt ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
Object GetValueAsObject(
    int x,
    int y
)
Visual Basic
Function GetValueAsObject ( _
    x As Integer, _
    y As Integer _
) As Object
F#
abstract GetValueAsObject :
        x:int *
        y:int -> Object

Parameters

x
Type: System..::..Int32
Die X-Adresse des Feldes ( 0 <= x < Width)
y
Type: System..::..Int32
Die Y-Adresse des Feldes ( 0 <= y < Height)

Return Value

Den Wert eines Feldes

See Also

IMatrix Interface
DynamicNode.Types.Base Namespace


IMatrix Properties

[image] [image]

DynamicNodes API
IMatrix Properties
IMatrix Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix type exposes the following members.

Properties

 | Name | Description
Public property | Height | Ruft die Höhe der Matrix ab.
Public property | Width | Ruft die Breite der Matrix ab.

See Also

IMatrix Interface
DynamicNode.Types.Base Namespace


Height Property

[image]

DynamicNodes API
IMatrix..::..Height Property
IMatrix Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Höhe der Matrix ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
int Height { get; }
Visual Basic
ReadOnly Property Height As Integer
    Get
F#
abstract Height : int

Return Value

Eine Ganzzahl größer gleich 0

See Also

IMatrix Interface
DynamicNode.Types.Base Namespace


Width Property

[image]

DynamicNodes API
IMatrix..::..Width Property
IMatrix Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Breite der Matrix ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
int Width { get; }
Visual Basic
ReadOnly Property Width As Integer
    Get
F#
abstract Width : int

Return Value

Eine Ganzzahl größer gleich 0

See Also

IMatrix Interface
DynamicNode.Types.Base Namespace


IMatrix(T) Interface

[image]

DynamicNodes API
IMatrix<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine generische Schnittstelle für 2-dimensionale Objekte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IMatrix<T> : IMatrix,
    IFixSizeStruct
Visual Basic
Public Interface IMatrix(Of T) _
    Inherits IMatrix, IFixSizeStruct
F#
type IMatrix<'T> =
    interface
        interface IMatrix
        interface IFixSizeStruct
    end

Type Parameters

T
Der Datentyp.

See Also

IMatrix<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


IMatrix(T) Members

[image] [image]

DynamicNodes API
IMatrix<(Of <(<'T>)>)> Members
IMatrix<(Of <(<'T>)>)> Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab. (Inherited from IMatrix.)

Properties

 | Name | Description
Public property | Height | Ruft die Höhe der Matrix ab. (Inherited from IMatrix.)
Public property | Width | Ruft die Breite der Matrix ab. (Inherited from IMatrix.)

See Also

IMatrix<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IMatrix(T) Methods

[image] [image]

DynamicNodes API
IMatrix<(Of <(<'T>)>)> Methods
IMatrix<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab. (Inherited from IMatrix.)

See Also

IMatrix<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


GetValue Method

[image]

DynamicNodes API
IMatrix<(Of <(<'T>)>)>..::..GetValue Method
IMatrix<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
T GetValue(
    int x,
    int y
)
Visual Basic
Function GetValue ( _
    x As Integer, _
    y As Integer _
) As T
F#
abstract GetValue :
        x:int *
        y:int -> 'T

Parameters

x
Type: System..::..Int32
Die X-Adresse des Feldes ( 0 <= x < Width)
y
Type: System..::..Int32
Die Y-Adresse des Feldes ( 0 <= y < Height)

Return Value

Den Wert eines Feldes

See Also

IMatrix<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IMatrix(T) Properties

[image] [image]

DynamicNodes API
IMatrix<(Of <(<'T>)>)> Properties
IMatrix<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Height | Ruft die Höhe der Matrix ab. (Inherited from IMatrix.)
Public property | Width | Ruft die Breite der Matrix ab. (Inherited from IMatrix.)

See Also

IMatrix<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IMatrix3D Interface

[image]

DynamicNodes API
IMatrix3D Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für 3-dimensionale Objekte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IMatrix3D : IFixSizeStruct
Visual Basic
Public Interface IMatrix3D _
    Inherits IFixSizeStruct
F#
type IMatrix3D =
    interface
        interface IFixSizeStruct
    end

See Also

IMatrix3D Members
DynamicNode.Types.Base Namespace


IMatrix3D Members

[image] [image]

DynamicNodes API
IMatrix3D Members
IMatrix3D Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix3D type exposes the following members.

Methods

 | Name | Description
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab.

Properties

 | Name | Description
Public property | Depth | Ruft die Tiefe der 3D-Matrix ab.
Public property | Height | Ruft die Höhe der 3D-Matrix ab.
Public property | Width | Ruft die Breite der 3D-Matrix ab.

See Also

IMatrix3D Interface
DynamicNode.Types.Base Namespace


IMatrix3D Methods

[image] [image]

DynamicNodes API
IMatrix3D Methods
IMatrix3D Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix3D type exposes the following members.

Methods

 | Name | Description
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab.

See Also

IMatrix3D Interface
DynamicNode.Types.Base Namespace


GetValueAsObject Method

[image]

DynamicNodes API
IMatrix3D..::..GetValueAsObject Method
IMatrix3D Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes als Objekt ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
Object GetValueAsObject(
    int x,
    int y,
    int z
)
Visual Basic
Function GetValueAsObject ( _
    x As Integer, _
    y As Integer, _
    z As Integer _
) As Object
F#
abstract GetValueAsObject :
        x:int *
        y:int *
        z:int -> Object

Parameters

x
Type: System..::..Int32
Die X-Adresse des Feldes ( 0 <= x < Width)
y
Type: System..::..Int32
Die Y-Adresse des Feldes ( 0 <= y < Height)
z
Type: System..::..Int32
Die Z-Adresse des Feldes ( 0 <= z < Depth)

Return Value

Den Wert eines Feldes

See Also

IMatrix3D Interface
DynamicNode.Types.Base Namespace


IMatrix3D Properties

[image] [image]

DynamicNodes API
IMatrix3D Properties
IMatrix3D Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix3D type exposes the following members.

Properties

 | Name | Description
Public property | Depth | Ruft die Tiefe der 3D-Matrix ab.
Public property | Height | Ruft die Höhe der 3D-Matrix ab.
Public property | Width | Ruft die Breite der 3D-Matrix ab.

See Also

IMatrix3D Interface
DynamicNode.Types.Base Namespace


Depth Property

[image]

DynamicNodes API
IMatrix3D..::..Depth Property
IMatrix3D Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Tiefe der 3D-Matrix ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
int Depth { get; }
Visual Basic
ReadOnly Property Depth As Integer
    Get
F#
abstract Depth : int

Return Value

Eine Ganzzahl größer gleich 0

See Also

IMatrix3D Interface
DynamicNode.Types.Base Namespace


Height Property

[image]

DynamicNodes API
IMatrix3D..::..Height Property
IMatrix3D Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Höhe der 3D-Matrix ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
int Height { get; }
Visual Basic
ReadOnly Property Height As Integer
    Get
F#
abstract Height : int

Return Value

Eine Ganzzahl größer gleich 0

See Also

IMatrix3D Interface
DynamicNode.Types.Base Namespace


Width Property

[image]

DynamicNodes API
IMatrix3D..::..Width Property
IMatrix3D Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Breite der 3D-Matrix ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
int Width { get; }
Visual Basic
ReadOnly Property Width As Integer
    Get
F#
abstract Width : int

Return Value

Eine Ganzzahl größer gleich 0

See Also

IMatrix3D Interface
DynamicNode.Types.Base Namespace


IMatrix3D(T) Interface

[image]

DynamicNodes API
IMatrix3D<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine generische Schnittstelle für 3-dimensionale Objekte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IMatrix3D<T> : IMatrix3D,
    IFixSizeStruct
Visual Basic
Public Interface IMatrix3D(Of T) _
    Inherits IMatrix3D, IFixSizeStruct
F#
type IMatrix3D<'T> =
    interface
        interface IMatrix3D
        interface IFixSizeStruct
    end

Type Parameters

T
Der Datentyp.

See Also

IMatrix3D<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


IMatrix3D(T) Members

[image] [image]

DynamicNodes API
IMatrix3D<(Of <(<'T>)>)> Members
IMatrix3D<(Of <(<'T>)>)> Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix3D<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab. (Inherited from IMatrix3D.)

Properties

 | Name | Description
Public property | Depth | Ruft die Tiefe der 3D-Matrix ab. (Inherited from IMatrix3D.)
Public property | Height | Ruft die Höhe der 3D-Matrix ab. (Inherited from IMatrix3D.)
Public property | Width | Ruft die Breite der 3D-Matrix ab. (Inherited from IMatrix3D.)

See Also

IMatrix3D<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IMatrix3D(T) Methods

[image] [image]

DynamicNodes API
IMatrix3D<(Of <(<'T>)>)> Methods
IMatrix3D<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix3D<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab. (Inherited from IMatrix3D.)

See Also

IMatrix3D<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


GetValue Method

[image]

DynamicNodes API
IMatrix3D<(Of <(<'T>)>)>..::..GetValue Method
IMatrix3D<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
T GetValue(
    int x,
    int y,
    int z
)
Visual Basic
Function GetValue ( _
    x As Integer, _
    y As Integer, _
    z As Integer _
) As T
F#
abstract GetValue :
        x:int *
        y:int *
        z:int -> 'T

Parameters

x
Type: System..::..Int32
Die X-Adresse des Feldes ( 0 <= x < Width)
y
Type: System..::..Int32
Die Y-Adresse des Feldes ( 0 <= y < Height)
z
Type: System..::..Int32
Die Z-Adresse des Feldes ( 0 <= z < Depth)

Return Value

Den Wert eines Feldes

See Also

IMatrix3D<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IMatrix3D(T) Properties

[image] [image]

DynamicNodes API
IMatrix3D<(Of <(<'T>)>)> Properties
IMatrix3D<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMatrix3D<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Depth | Ruft die Tiefe der 3D-Matrix ab. (Inherited from IMatrix3D.)
Public property | Height | Ruft die Höhe der 3D-Matrix ab. (Inherited from IMatrix3D.)
Public property | Width | Ruft die Breite der 3D-Matrix ab. (Inherited from IMatrix3D.)

See Also

IMatrix3D<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IMDO Interface

[image]

DynamicNodes API
IMDO Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für multidimensionale Objekte (MDO).

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IMDO
Visual Basic
Public Interface IMDO
F#
type IMDO =  interface end

See Also

IMDO Members
DynamicNode.Types.Base Namespace


IMDO Members

[image] [image]

DynamicNodes API
IMDO Members
IMDO Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMDO type exposes the following members.

Methods

 | Name | Description
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück
Public method | GetValueAsObject | Gibt den Wert eines Feldes als Objekt zurück.

Properties

 | Name | Description
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück

See Also

IMDO Interface
DynamicNode.Types.Base Namespace


IMDO Methods

[image] [image]

DynamicNodes API
IMDO Methods
IMDO Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMDO type exposes the following members.

Methods

 | Name | Description
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück
Public method | GetValueAsObject | Gibt den Wert eines Feldes als Objekt zurück.

See Also

IMDO Interface
DynamicNode.Types.Base Namespace


GetSize Method

[image]

DynamicNodes API
IMDO..::..GetSize Method
IMDO Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Größe des Objektes in einer Dimension zurück

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
int GetSize(
    int dimension
)
Visual Basic
Function GetSize ( _
    dimension As Integer _
) As Integer
F#
abstract GetSize :
        dimension:int -> int

Parameters

dimension
Type: System..::..Int32
Die Dimension (> 0), deren Größe abgefragt werden soll.

Return Value

Eine positive Ganzzahl

See Also

IMDO Interface
DynamicNode.Types.Base Namespace


GetValueAsObject Method

[image]

DynamicNodes API
IMDO..::..GetValueAsObject Method
IMDO Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert eines Feldes als Objekt zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
Object GetValueAsObject(
    params int[] addr
)
Visual Basic
Function GetValueAsObject ( _
    ParamArray addr As Integer() _
) As Object
F#
abstract GetValueAsObject :
        addr:int[] -> Object

Parameters

addr
Type: array< System..::..Int32 >[]()[][]

Die Adresse des Feldes, wobei jedes Element von addr die Position in einer Dimension angibt.

Ist der übergebene Adressen-Vektor länger als die Anzahl der Dimensionen, können die überschüssigen Adressfelder ignoriert werden.

Ist der übergebene Adress-Vektor kürzer als die Anzahl der Dimensionen, wird für die fehlenden Felder die Adresse 0 angenommen.

Überschreitet die Adresse einer oder mehrerer Dimensionen eine Index-Grenze, muss dennoch ein gültiger Wert zurückgegeben werden.

Return Value

Der Wert eines Feldes

See Also

IMDO Interface
DynamicNode.Types.Base Namespace


IMDO Properties

[image] [image]

DynamicNodes API
IMDO Properties
IMDO Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMDO type exposes the following members.

Properties

 | Name | Description
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück

See Also

IMDO Interface
DynamicNode.Types.Base Namespace


DimensionCount Property

[image]

DynamicNodes API
IMDO..::..DimensionCount Property
IMDO Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der verwendeten Dimensionen zurück

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
int DimensionCount { get; }
Visual Basic
ReadOnly Property DimensionCount As Integer
    Get
F#
abstract DimensionCount : int

Field Value

Die Anzahl der Dimensionen.

See Also

IMDO Interface
DynamicNode.Types.Base Namespace


IMDO(T) Interface

[image]

DynamicNodes API
IMDO<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine generische Schnittstelle für multidimensionale Objekte (MDO).

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IMDO<T> : IMDO
Visual Basic
Public Interface IMDO(Of T) _
    Inherits IMDO
F#
type IMDO<'T> =
    interface
        interface IMDO
    end

Type Parameters

T
Der Datentyp der Objektfelder

See Also

IMDO<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


IMDO(T) Members

[image] [image]

DynamicNodes API
IMDO<(Of <(<'T>)>)> Members
IMDO<(Of <(<'T>)>)> Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMDO<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück (Inherited from IMDO.)
Public method | GetValue | Gibt den Wert eines Feldes zurück.
Public method | GetValueAsObject | Gibt den Wert eines Feldes als Objekt zurück. (Inherited from IMDO.)

Properties

 | Name | Description
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück (Inherited from IMDO.)

See Also

IMDO<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IMDO(T) Methods

[image] [image]

DynamicNodes API
IMDO<(Of <(<'T>)>)> Methods
IMDO<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMDO<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück (Inherited from IMDO.)
Public method | GetValue | Gibt den Wert eines Feldes zurück.
Public method | GetValueAsObject | Gibt den Wert eines Feldes als Objekt zurück. (Inherited from IMDO.)

See Also

IMDO<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


GetValue Method

[image]

DynamicNodes API
IMDO<(Of <(<'T>)>)>..::..GetValue Method
IMDO<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert eines Feldes zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
T GetValue(
    params int[] addr
)
Visual Basic
Function GetValue ( _
    ParamArray addr As Integer() _
) As T
F#
abstract GetValue :
        addr:int[] -> 'T

Parameters

addr
Type: array< System..::..Int32 >[]()[][]

Die Adresse des Feldes, wobei jedes Element von addr die Position in einer Dimension angibt.

Ist der übergebene Adressen-Vektor länger als die Anzahl der Dimensionen, können die überschüssigen Adressfelder ignoriert werden.

Ist der übergebene Adress-Vektor kürzer als die Anzahl der Dimensionen, wird für die fehlenden Felder die Adresse 0 angenommen.

Überschreitet die Adresse einer oder mehrerer Dimensionen eine Index-Grenze, muss dennoch ein gültiger Wert zurückgegeben werden.

Return Value

Der Wert eines Feldes

See Also

IMDO<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IMDO(T) Properties

[image] [image]

DynamicNodes API
IMDO<(Of <(<'T>)>)> Properties
IMDO<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IMDO<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück (Inherited from IMDO.)

See Also

IMDO<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IScalar Interface

[image]

DynamicNodes API
IScalar Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für 0-dimensionale Objekte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IScalar : IFixSizeStruct
Visual Basic
Public Interface IScalar _
    Inherits IFixSizeStruct
F#
type IScalar =
    interface
        interface IFixSizeStruct
    end

See Also

IScalar Members
DynamicNode.Types.Base Namespace


IScalar Members

[image] [image]

DynamicNodes API
IScalar Members
IScalar Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IScalar type exposes the following members.

Methods

 | Name | Description
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab.

See Also

IScalar Interface
DynamicNode.Types.Base Namespace


IScalar Methods

[image] [image]

DynamicNodes API
IScalar Methods
IScalar Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IScalar type exposes the following members.

Methods

 | Name | Description
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab.

See Also

IScalar Interface
DynamicNode.Types.Base Namespace


GetValueAsObject Method

[image]

DynamicNodes API
IScalar..::..GetValueAsObject Method
IScalar Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes als Objekt ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
Object GetValueAsObject()
Visual Basic
Function GetValueAsObject As Object
F#
abstract GetValueAsObject : unit -> Object

Return Value

Den Wert eines Feldes

See Also

IScalar Interface
DynamicNode.Types.Base Namespace


IScalar(T) Interface

[image]

DynamicNodes API
IScalar<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine generische Schnittstelle für 0-dimensionale Objekte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IScalar<T> : IScalar,
    IFixSizeStruct
Visual Basic
Public Interface IScalar(Of T) _
    Inherits IScalar, IFixSizeStruct
F#
type IScalar<'T> =
    interface
        interface IScalar
        interface IFixSizeStruct
    end

Type Parameters

T
Der Datentyp.

See Also

IScalar<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


IScalar(T) Members

[image] [image]

DynamicNodes API
IScalar<(Of <(<'T>)>)> Members
IScalar<(Of <(<'T>)>)> Interface Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IScalar<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab. (Inherited from IScalar.)

See Also

IScalar<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IScalar(T) Methods

[image] [image]

DynamicNodes API
IScalar<(Of <(<'T>)>)> Methods
IScalar<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IScalar<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab. (Inherited from IScalar.)

See Also

IScalar<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


GetValue Method

[image]

DynamicNodes API
IScalar<(Of <(<'T>)>)>..::..GetValue Method
IScalar<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
T GetValue()
Visual Basic
Function GetValue As T
F#
abstract GetValue : unit -> 'T

Return Value

Den Wert eines Feldes

See Also

IScalar<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IVector Interface

[image]

DynamicNodes API
IVector Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für 1-dimensionale Objekte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IVector : IFixSizeStruct
Visual Basic
Public Interface IVector _
    Inherits IFixSizeStruct
F#
type IVector =
    interface
        interface IFixSizeStruct
    end

See Also

IVector Members
DynamicNode.Types.Base Namespace


IVector Members

[image] [image]

DynamicNodes API
IVector Members
IVector Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IVector type exposes the following members.

Methods

 | Name | Description
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab.

Properties

 | Name | Description
Public property | Length | Ruft die Länge des Vektors ab.

See Also

IVector Interface
DynamicNode.Types.Base Namespace


IVector Methods

[image] [image]

DynamicNodes API
IVector Methods
IVector Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IVector type exposes the following members.

Methods

 | Name | Description
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab.

See Also

IVector Interface
DynamicNode.Types.Base Namespace


GetValueAsObject Method

[image]

DynamicNodes API
IVector..::..GetValueAsObject Method
IVector Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes als Objekt ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
Object GetValueAsObject(
    int index
)
Visual Basic
Function GetValueAsObject ( _
    index As Integer _
) As Object
F#
abstract GetValueAsObject :
        index:int -> Object

Parameters

index
Type: System..::..Int32
Die Adresse des Feldes ( 0 <= index < Length)

Return Value

Den Wert eines Feldes

See Also

IVector Interface
DynamicNode.Types.Base Namespace


IVector Properties

[image] [image]

DynamicNodes API
IVector Properties
IVector Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IVector type exposes the following members.

Properties

 | Name | Description
Public property | Length | Ruft die Länge des Vektors ab.

See Also

IVector Interface
DynamicNode.Types.Base Namespace


Length Property

[image]

DynamicNodes API
IVector..::..Length Property
IVector Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Länge des Vektors ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
int Length { get; }
Visual Basic
ReadOnly Property Length As Integer
    Get
F#
abstract Length : int

Return Value

Eine Ganzzahl größer gleich 0

See Also

IVector Interface
DynamicNode.Types.Base Namespace


IVector(T) Interface

[image]

DynamicNodes API
IVector<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine generische Schnittstelle für 1-dimensionale Objekte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IVector<T> : IVector,
    IFixSizeStruct
Visual Basic
Public Interface IVector(Of T) _
    Inherits IVector, IFixSizeStruct
F#
type IVector<'T> =
    interface
        interface IVector
        interface IFixSizeStruct
    end

Type Parameters

T
Der Datentyp.

See Also

IVector<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


IVector(T) Members

[image] [image]

DynamicNodes API
IVector<(Of <(<'T>)>)> Members
IVector<(Of <(<'T>)>)> Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IVector<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab. (Inherited from IVector.)

Properties

 | Name | Description
Public property | Length | Ruft die Länge des Vektors ab. (Inherited from IVector.)

See Also

IVector<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IVector(T) Methods

[image] [image]

DynamicNodes API
IVector<(Of <(<'T>)>)> Methods
IVector<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IVector<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject | Ruft den Wert eines Feldes als Objekt ab. (Inherited from IVector.)

See Also

IVector<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


GetValue Method

[image]

DynamicNodes API
IVector<(Of <(<'T>)>)>..::..GetValue Method
IVector<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
T GetValue(
    int index
)
Visual Basic
Function GetValue ( _
    index As Integer _
) As T
F#
abstract GetValue :
        index:int -> 'T

Parameters

index
Type: System..::..Int32
Die Adresse des Feldes ( 0 <= index < Length)

Return Value

Den Wert eines Feldes

See Also

IVector<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


IVector(T) Properties

[image] [image]

DynamicNodes API
IVector<(Of <(<'T>)>)> Properties
IVector<(Of <(<'T>)>)> Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IVector<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Length | Ruft die Länge des Vektors ab. (Inherited from IVector.)

See Also

IVector<(Of <(<'T>)>)> Interface
DynamicNode.Types.Base Namespace


Matrix(T) Class

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine generische, zweidimensionale (rechteckige) Datenstruktur. Schreibzugriff ist nur über das öffentliche Feld data möglich.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class Matrix<T> : IMatrix<T>, IMatrix,
    IFixSizeStruct, IMDO<T>, IMDO, IEnumerable<Vector<T>>,
    IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class Matrix(Of T) _
    Implements IMatrix(Of T), IMatrix, IFixSizeStruct,  _
    IMDO(Of T), IMDO, IEnumerable(Of Vector(Of T)),  _
    IEnumerable
F#
[<SerializableAttribute>]
type Matrix<'T> =
    class
        interface IMatrix<'T>
        interface IMatrix
        interface IFixSizeStruct
        interface IMDO<'T>
        interface IMDO
        interface IEnumerable<Vector<'T>>
        interface IEnumerable
    end

Type Parameters

T
Der elementare Datentyp der Matrix

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Matrix<(Of <(<'T>)>)>

See Also

Matrix<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Matrix(T) Members

[image] [image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Members
Matrix<(Of <(<'T>)>)> Class Constructors Methods Operators Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Matrix<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Matrix<(Of <(<'T>)>)>(array<T,2>[,](,)[,][,]) | Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.
Public method | Matrix<(Of <(<'T>)>)>(Int32, Int32) | Initialisiert eine neue Matrix.
Public method | Matrix<(Of <(<'T>)>)>(array<T,2>[,](,)[,][,], T) | Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.
Public method | Matrix<(Of <(<'T>)>)>(Int32, Int32, Func<(Of <(<'T1, T2, TResult>)>)>) |
Public method | Matrix<(Of <(<'T>)>)>(Int32, Int32, T) | Initialisiert eine neue Matrix.

Methods

 | Name | Description
Public method | Apply |
Public method | ApplyIndexed |
Public method | Copy | Gibt eine Kopie der Matrix zurück.
Public method | CopyCell | Gibt eine Kopie der Zelle (x, y) zurück.
Public method | CopyRegion | Kopiert einen Bereich der Matrix.
Public method | CopyXVector | Gibt eine Kopie der Zeile y dieser Matrix als Vector zurück.
Public method | CopyYVector | Gibt eine Kopie der Spalte x dieser Matrix als Vector zurück.
Public method | Fill | Belegt alle Felder der Matrix mit dem übergebenen Wert.
Public method | FillIndexed |
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.
Public method | GetValue(Int32, Int32) | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.
Public method | GetValueAsObject(Int32, Int32) | Ruft den Wert eines Feldes als Objekt ab.
Public method | Map<(Of <<'(TTarget>)>>) |
Public method | MapIndexed<(Of <<'(TTarget>)>>) |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<T,2>[,](,)[,][,] to Matrix<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung eines 2D-Arrays nach Matrix<(Of <(<'T>)>)> durch.
ImplicitWideningImplicitImplicitImplicit(Matrix<(Of <<'(T>)>>) to array<T,2>[,](,)[,][,]) | Führt eine implizite Umwandlung von Matrix<(Of <(<'T>)>)> in ein 2D-Array durch. Diese Umwandlung ist langsam, weil die Elemente kopiert werden müssen.

Fields

 | Name | Description
Protected field | data | Das verschachtelte Array, welches die Daten der Matrix enthält.
Protected field | defValue | Der Standardwert der Matrix, welcher bei Indexüberschreitungen zurückgegeben wird.
Protected field | height | Die Höhe der Matrix.
Protected field | width | Die Breite der Matrix.

Properties

 | Name | Description
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück
Public property | Height | Ruft die Höhe der Matrix ab.
Public property | Item | Gibt den Wert einer Zelle zurück.
Public property | Width | Ruft die Breite der Matrix ab.

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Matrix(T) Constructor

[image] [image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Constructor
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Matrix<(Of <(<'T>)>)>(array<T,2>[,](,)[,][,]) | Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.
Public method | Matrix<(Of <(<'T>)>)>(Int32, Int32) | Initialisiert eine neue Matrix.
Public method | Matrix<(Of <(<'T>)>)>(array<T,2>[,](,)[,][,], T) | Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.
Public method | Matrix<(Of <(<'T>)>)>(Int32, Int32, Func<(Of <(<'T1, T2, TResult>)>)>) | Initializes a new instance of the Matrix<(Of <(<'T>)>)> class
Public method | Matrix<(Of <(<'T>)>)>(Int32, Int32, T) | Initialisiert eine neue Matrix.

See Also

Matrix<(Of <(<'T>)>)> Class
Matrix<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Matrix(T) Constructor (T[,])

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Constructor (array<T,2>[,](,)[,][,])
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix(
    T[,] data
)
Visual Basic
Public Sub New ( _
    data As T(,) _
)
F#
new :
        data:'T[,] -> Matrix

Parameters

data
Type: array< T ,2>[,](,)[,][,]
Das Array mit den Daten für die Matrix.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für datanull übergeben wird.

See Also

Matrix<(Of <(<'T>)>)> Class
Matrix<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Matrix(T) Constructor (Int32, Int32)

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Constructor (Int32, Int32)
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Matrix.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix(
    int width,
    int height
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer _
)
F#
new :
        width:int *
        height:int -> Matrix

Parameters

width
Type: System..::..Int32
Die Breite der Matrix.
height
Type: System..::..Int32
Die Höhe der Matrix.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width oder height ein Wert kleiner 0 übergeben wird.

See Also

Matrix<(Of <(<'T>)>)> Class
Matrix<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Matrix(T) Constructor (T[,], T)

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Constructor (array<T,2>[,](,)[,][,], T)
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix(
    T[,] data,
    T defValue
)
Visual Basic
Public Sub New ( _
    data As T(,), _
    defValue As T _
)
F#
new :
        data:'T[,] *
        defValue:'T -> Matrix

Parameters

data
Type: array< T ,2>[,](,)[,][,]
Das Array mit den Daten für die Matrix.
defValue
Type: T
Ein Standardwert, der bei Indexüberschreitungen zurückgegeben wird.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für datanull übergeben wird.

See Also

Matrix<(Of <(<'T>)>)> Class
Matrix<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Matrix(T) Constructor (Int32, Int32, Func)

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Constructor (Int32, Int32, Func)
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the Matrix<(Of <(<'T>)>)> class

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix(
    int width,
    int height,
    Func generator
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    generator As Func _
)
F#
new :
        width:int *
        height:int *
        generator:Func -> Matrix

Parameters

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:DynamicNode.Types.Base.Matrix`1.#ctor(System.Int32,System.Int32,System.Func`3)"]

height
Type: System..::..Int32

[Missing <param name="height"/> documentation for "M:DynamicNode.Types.Base.Matrix`1.#ctor(System.Int32,System.Int32,System.Func`3)"]

generator
Type: System..::..Func<(Of <(<'T1, T2, TResult>)>)>

[Missing <param name="generator"/> documentation for "M:DynamicNode.Types.Base.Matrix`1.#ctor(System.Int32,System.Int32,System.Func`3)"]

See Also

Matrix<(Of <(<'T>)>)> Class
Matrix<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Matrix(T) Constructor (Int32, Int32, T)

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Constructor (Int32, Int32, T)
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Matrix.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix(
    int width,
    int height,
    T defValue
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    defValue As T _
)
F#
new :
        width:int *
        height:int *
        defValue:'T -> Matrix

Parameters

width
Type: System..::..Int32
Die Breite der Matrix.
height
Type: System..::..Int32
Die Höhe der Matrix.
defValue
Type: T
Ein Standardwert, der bei Indexüberschreitungen zurückgegeben wird.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width oder height ein Wert kleiner 0 übergeben wird.

See Also

Matrix<(Of <(<'T>)>)> Class
Matrix<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Matrix(T) Fields

[image] [image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Fields
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Matrix<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | data | Das verschachtelte Array, welches die Daten der Matrix enthält.
Protected field | defValue | Der Standardwert der Matrix, welcher bei Indexüberschreitungen zurückgegeben wird.
Protected field | height | Die Höhe der Matrix.
Protected field | width | Die Breite der Matrix.

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


data Field

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..data Field
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das verschachtelte Array, welches die Daten der Matrix enthält.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly T[,] data
Visual Basic
Protected ReadOnly data As T(,)
F#
val data: 'T[,]

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


defValue Field

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..defValue Field
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Standardwert der Matrix, welcher bei Indexüberschreitungen zurückgegeben wird.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly T defValue
Visual Basic
Protected ReadOnly defValue As T
F#
val defValue: 'T

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


height Field

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..height Field
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Höhe der Matrix.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly int height
Visual Basic
Protected ReadOnly height As Integer
F#
val height: int

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


width Field

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..width Field
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Breite der Matrix.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly int width
Visual Basic
Protected ReadOnly width As Integer
F#
val width: int

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Matrix(T) Methods

[image] [image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Methods
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Matrix<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Apply |
Public method | ApplyIndexed |
Public method | Copy | Gibt eine Kopie der Matrix zurück.
Public method | CopyCell | Gibt eine Kopie der Zelle (x, y) zurück.
Public method | CopyRegion | Kopiert einen Bereich der Matrix.
Public method | CopyXVector | Gibt eine Kopie der Zeile y dieser Matrix als Vector zurück.
Public method | CopyYVector | Gibt eine Kopie der Spalte x dieser Matrix als Vector zurück.
Public method | Fill | Belegt alle Felder der Matrix mit dem übergebenen Wert.
Public method | FillIndexed |
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.
Public method | GetValue(Int32, Int32) | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.
Public method | GetValueAsObject(Int32, Int32) | Ruft den Wert eines Feldes als Objekt ab.
Public method | Map<(Of <<'(TTarget>)>>) |
Public method | MapIndexed<(Of <<'(TTarget>)>>) |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Apply Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..Apply Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "M:DynamicNode.Types.Base.Matrix`1.Apply(System.Func`2)"]

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void Apply(
    Func transfer
)
Visual Basic
Public Sub Apply ( _
    transfer As Func _
)
F#
member Apply :
        transfer:Func -> unit

Parameters

transfer
Type: System..::..Func<(Of <(<'T, TResult>)>)>

[Missing <param name="transfer"/> documentation for "M:DynamicNode.Types.Base.Matrix`1.Apply(System.Func`2)"]

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


ApplyIndexed Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..ApplyIndexed Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "M:DynamicNode.Types.Base.Matrix`1.ApplyIndexed(System.Func`4)"]

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void ApplyIndexed(
    Func transfer
)
Visual Basic
Public Sub ApplyIndexed ( _
    transfer As Func _
)
F#
member ApplyIndexed :
        transfer:Func -> unit

Parameters

transfer
Type: System..::..Func<(Of <(<'T1, T2, T3, TResult>)>)>

[Missing <param name="transfer"/> documentation for "M:DynamicNode.Types.Base.Matrix`1.ApplyIndexed(System.Func`4)"]

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Copy Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..Copy Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der Matrix zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<T> Copy()
Visual Basic
Public Function Copy As Matrix(Of T)
F#
member Copy : unit -> Matrix<'T>

Return Value

Eine Kopie der Matrix.

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyCell Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..CopyCell Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der Zelle (x, y) zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Scalar<T> CopyCell(
    int x,
    int y
)
Visual Basic
Public Function CopyCell ( _
    x As Integer, _
    y As Integer _
) As Scalar(Of T)
F#
member CopyCell :
        x:int *
        y:int -> Scalar<'T>

Parameters

x
Type: System..::..Int32
Die Spalte.
y
Type: System..::..Int32
Die Zeile.

Return Value

Einen Skalar aus der Zelle (x, y).

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyRegion Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..CopyRegion Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Kopiert einen Bereich der Matrix.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<T> CopyRegion(
    int regionX,
    int regionY,
    int regionWidth,
    int regionHeight
)
Visual Basic
Public Function CopyRegion ( _
    regionX As Integer, _
    regionY As Integer, _
    regionWidth As Integer, _
    regionHeight As Integer _
) As Matrix(Of T)
F#
member CopyRegion :
        regionX:int *
        regionY:int *
        regionWidth:int *
        regionHeight:int -> Matrix<'T>

Parameters

regionX
Type: System..::..Int32
Die Erste Spalte des zu kopierenden Bereichs.
regionY
Type: System..::..Int32
Die Erste Zeile des zu kopierenden Bereichs.
regionWidth
Type: System..::..Int32
Die Anzahl der zu kopierenden Spalten.
regionHeight
Type: System..::..Int32
Die Anzahl der zu kopierenden Zeilen.

Return Value

Eine Kopie von einem Bereich der Matrix.

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyXVector Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..CopyXVector Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der Zeile y dieser Matrix als Vector zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Vector<T> CopyXVector(
    int y
)
Visual Basic
Public Function CopyXVector ( _
    y As Integer _
) As Vector(Of T)
F#
member CopyXVector :
        y:int -> Vector<'T>

Parameters

y
Type: System..::..Int32
Die Zeile deren Daten kopiert werden sollen.

Return Value

Ein Vector aus der Zeile y.

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyYVector Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..CopyYVector Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der Spalte x dieser Matrix als Vector zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Vector<T> CopyYVector(
    int x
)
Visual Basic
Public Function CopyYVector ( _
    x As Integer _
) As Vector(Of T)
F#
member CopyYVector :
        x:int -> Vector<'T>

Parameters

x
Type: System..::..Int32
Die Spalte deren Daten kopiert werden sollen.

Return Value

Ein Vector aus der Spalte x.

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Fill Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..Fill Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Belegt alle Felder der Matrix mit dem übergebenen Wert.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void Fill(
    T value
)
Visual Basic
Public Sub Fill ( _
    value As T _
)
F#
member Fill :
        value:'T -> unit

Parameters

value
Type: T
Ein Wert.

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


FillIndexed Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..FillIndexed Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "M:DynamicNode.Types.Base.Matrix`1.FillIndexed(System.Func`3)"]

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void FillIndexed(
    Func generator
)
Visual Basic
Public Sub FillIndexed ( _
    generator As Func _
)
F#
member FillIndexed :
        generator:Func -> unit

Parameters

generator
Type: System..::..Func<(Of <(<'T1, T2, TResult>)>)>

[Missing <param name="generator"/> documentation for "M:DynamicNode.Types.Base.Matrix`1.FillIndexed(System.Func`3)"]

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetEnumerator Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..GetEnumerator Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns an enumerator that iterates through the collection.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public IEnumerator<Vector<T>> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of Vector(Of T))
F#
abstract GetEnumerator : unit -> IEnumerator<Vector<'T>>
override GetEnumerator : unit -> IEnumerator<Vector<'T>>

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetSize Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..GetSize Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Größe des Objektes in einer Dimension zurück

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int GetSize(
    int dimension
)
Visual Basic
Public Function GetSize ( _
    dimension As Integer _
) As Integer
F#
abstract GetSize :
        dimension:int -> int
override GetSize :
        dimension:int -> int

Parameters

dimension
Type: System..::..Int32
Die Dimension (> 0), deren Größe abgefragt werden soll.

Return Value

Eine positive Ganzzahl

Implements

IMDO..::..GetSize(Int32)

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetValue Method

[image] [image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..GetValue Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.
Public method | GetValue(Int32, Int32) | Ruft den Wert eines Feldes ab.

See Also

Matrix<(Of <(<'T>)>)> Class
Matrix<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


GetValue Method (Int32[])

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..GetValue Method (array<Int32>[]()[][])
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert eines Feldes zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T GetValue(
    params int[] addr
)
Visual Basic
Public Function GetValue ( _
    ParamArray addr As Integer() _
) As T
F#
abstract GetValue :
        addr:int[] -> 'T
override GetValue :
        addr:int[] -> 'T

Parameters

addr
Type: array< System..::..Int32 >[]()[][]

Die Adresse des Feldes, wobei jedes Element von addr die Position in einer Dimension angibt.

Ist der übergebene Adressen-Vektor länger als die Anzahl der Dimensionen, können die überschüssigen Adressfelder ignoriert werden.

Ist der übergebene Adress-Vektor kürzer als die Anzahl der Dimensionen, wird für die fehlenden Felder die Adresse 0 angenommen.

Überschreitet die Adresse einer oder mehrerer Dimensionen eine Index-Grenze, muss dennoch ein gültiger Wert zurückgegeben werden.

Return Value

Der Wert eines Feldes

See Also

Matrix<(Of <(<'T>)>)> Class
GetValue Overload
DynamicNode.Types.Base Namespace


GetValue Method (Int32, Int32)

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..GetValue Method (Int32, Int32)
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T GetValue(
    int x,
    int y
)
Visual Basic
Public Function GetValue ( _
    x As Integer, _
    y As Integer _
) As T
F#
abstract GetValue :
        x:int *
        y:int -> 'T
override GetValue :
        x:int *
        y:int -> 'T

Parameters

x
Type: System..::..Int32
Die X-Adresse des Feldes ( 0 <= x < Width)
y
Type: System..::..Int32
Die Y-Adresse des Feldes ( 0 <= y < Height)

Return Value

Den Wert eines Feldes

Implements

IMatrix<(Of <(<'T>)>)>..::..GetValue(Int32, Int32)

See Also

Matrix<(Of <(<'T>)>)> Class
GetValue Overload
DynamicNode.Types.Base Namespace


GetValueAsObject Method

[image] [image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..GetValueAsObject Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.
Public method | GetValueAsObject(Int32, Int32) | Ruft den Wert eines Feldes als Objekt ab.

See Also

Matrix<(Of <(<'T>)>)> Class
Matrix<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


GetValueAsObject Method (Int32[])

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..GetValueAsObject Method (array<Int32>[]()[][])
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert eines Feldes als Objekt zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Object GetValueAsObject(
    params int[] addr
)
Visual Basic
Public Function GetValueAsObject ( _
    ParamArray addr As Integer() _
) As Object
F#
abstract GetValueAsObject :
        addr:int[] -> Object
override GetValueAsObject :
        addr:int[] -> Object

Parameters

addr
Type: array< System..::..Int32 >[]()[][]

Die Adresse des Feldes, wobei jedes Element von addr die Position in einer Dimension angibt.

Ist der übergebene Adressen-Vektor länger als die Anzahl der Dimensionen, können die überschüssigen Adressfelder ignoriert werden.

Ist der übergebene Adress-Vektor kürzer als die Anzahl der Dimensionen, wird für die fehlenden Felder die Adresse 0 angenommen.

Überschreitet die Adresse einer oder mehrerer Dimensionen eine Index-Grenze, muss dennoch ein gültiger Wert zurückgegeben werden.

Return Value

Der Wert eines Feldes

Implements

IMDO..::..GetValueAsObject(array<Int32>[]()[][])

See Also

Matrix<(Of <(<'T>)>)> Class
GetValueAsObject Overload
DynamicNode.Types.Base Namespace


GetValueAsObject Method (Int32, Int32)

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..GetValueAsObject Method (Int32, Int32)
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes als Objekt ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Object GetValueAsObject(
    int x,
    int y
)
Visual Basic
Public Function GetValueAsObject ( _
    x As Integer, _
    y As Integer _
) As Object
F#
abstract GetValueAsObject :
        x:int *
        y:int -> Object
override GetValueAsObject :
        x:int *
        y:int -> Object

Parameters

x
Type: System..::..Int32
Die X-Adresse des Feldes ( 0 <= x < Width)
y
Type: System..::..Int32
Die Y-Adresse des Feldes ( 0 <= y < Height)

Return Value

Den Wert eines Feldes

Implements

IMatrix..::..GetValueAsObject(Int32, Int32)

See Also

Matrix<(Of <(<'T>)>)> Class
GetValueAsObject Overload
DynamicNode.Types.Base Namespace


Map(TTarget) Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..Map<(Of <(<'TTarget>)>)> Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "M:DynamicNode.Types.Base.Matrix`1.Map``1(System.Func`2)"]

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<TTarget> Map<TTarget>(
    Func transfer
)
Visual Basic
Public Function Map(Of TTarget) ( _
    transfer As Func _
) As Matrix(Of TTarget)
F#
member Map :
        transfer:Func -> Matrix<'TTarget>

Parameters

transfer
Type: System..::..Func<(Of <(<'T, TResult>)>)>

[Missing <param name="transfer"/> documentation for "M:DynamicNode.Types.Base.Matrix`1.Map``1(System.Func`2)"]

Type Parameters

TTarget

[Missing <typeparam name="TTarget"/> documentation for "M:DynamicNode.Types.Base.Matrix`1.Map``1(System.Func`2)"]

Return Value

[Missing <returns> documentation for "M:DynamicNode.Types.Base.Matrix`1.Map``1(System.Func`2)"]

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


MapIndexed(TTarget) Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..MapIndexed<(Of <(<'TTarget>)>)> Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "M:DynamicNode.Types.Base.Matrix`1.MapIndexed``1(System.Func`4)"]

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<TTarget> MapIndexed<TTarget>(
    Func transfer
)
Visual Basic
Public Function MapIndexed(Of TTarget) ( _
    transfer As Func _
) As Matrix(Of TTarget)
F#
member MapIndexed :
        transfer:Func -> Matrix<'TTarget>

Parameters

transfer
Type: System..::..Func<(Of <(<'T1, T2, T3, TResult>)>)>

[Missing <param name="transfer"/> documentation for "M:DynamicNode.Types.Base.Matrix`1.MapIndexed``1(System.Func`4)"]

Type Parameters

TTarget

[Missing <typeparam name="TTarget"/> documentation for "M:DynamicNode.Types.Base.Matrix`1.MapIndexed``1(System.Func`4)"]

Return Value

[Missing <returns> documentation for "M:DynamicNode.Types.Base.Matrix`1.MapIndexed``1(System.Func`4)"]

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


ToString Method

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..ToString Method
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Matrix(T) Type Conversions

[image] [image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Type Conversions
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<T,2>[,](,)[,][,] to Matrix<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung eines 2D-Arrays nach Matrix<(Of <(<'T>)>)> durch.
ImplicitWideningImplicitImplicitImplicit(Matrix<(Of <<'(T>)>>) to array<T,2>[,](,)[,][,]) | Führt eine implizite Umwandlung von Matrix<(Of <(<'T>)>)> in ein 2D-Array durch. Diese Umwandlung ist langsam, weil die Elemente kopiert werden müssen.

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Implicit Conversion Operators

[image] [image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion Operators
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<T,2>[,](,)[,][,] to Matrix<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung eines 2D-Arrays nach Matrix<(Of <(<'T>)>)> durch.
ImplicitWideningImplicitImplicitImplicit(Matrix<(Of <<'(T>)>>) to array<T,2>[,](,)[,][,]) | Führt eine implizite Umwandlung von Matrix<(Of <(<'T>)>)> in ein 2D-Array durch. Diese Umwandlung ist langsam, weil die Elemente kopiert werden müssen.

See Also

Matrix<(Of <(<'T>)>)> Class
Matrix<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Implicit Conversion (T[,] to Matrix(T))

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion (array<T,2>[,](,)[,][,] to Matrix<(Of <(<'T>)>)>)
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine implizite Umwandlung eines 2D-Arrays nach Matrix<(Of <(<'T>)>)> durch.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static implicit operator Matrix<T> (
    T[,] source
)
Visual Basic
Public Shared Widening Operator CType ( _
    source As T(,) _
) As Matrix(Of T)
F#
F# does not support the declaration of new casting operators.

Parameters

source
Type: array< T ,2>[,](,)[,][,]
Ein 2D-Array.

Return Value

Das Ergebnis der Umwandlung.

See Also

Matrix<(Of <(<'T>)>)> Class
ImplicitWideningImplicitImplicitImplicit Overload
DynamicNode.Types.Base Namespace


Implicit Conversion (Matrix(T) to T[,])

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion (Matrix<(Of <(<'T>)>)> to array<T,2>[,](,)[,][,])
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine implizite Umwandlung von Matrix<(Of <(<'T>)>)> in ein 2D-Array durch. Diese Umwandlung ist langsam, weil die Elemente kopiert werden müssen.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static implicit operator T[,] (
    Matrix<T> source
)
Visual Basic
Public Shared Widening Operator CType ( _
    source As Matrix(Of T) _
) As T(,)
F#
F# does not support the declaration of new casting operators.

Parameters

source
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' T >)>)>
Eine Matrix.

Return Value

Das Ergebnis der Umwandlung.

See Also

Matrix<(Of <(<'T>)>)> Class
ImplicitWideningImplicitImplicitImplicit Overload
DynamicNode.Types.Base Namespace


Matrix(T) Properties

[image] [image]

DynamicNodes API
Matrix<(Of <(<'T>)>)> Properties
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Matrix<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück
Public property | Height | Ruft die Höhe der Matrix ab.
Public property | Item | Gibt den Wert einer Zelle zurück.
Public property | Width | Ruft die Breite der Matrix ab.

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


DimensionCount Property

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..DimensionCount Property
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der verwendeten Dimensionen zurück

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int DimensionCount { get; }
Visual Basic
Public ReadOnly Property DimensionCount As Integer
    Get
F#
abstract DimensionCount : int
override DimensionCount : int

Field Value

Die Anzahl der Dimensionen.

Implements

IMDO..::..DimensionCount

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Height Property

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..Height Property
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Höhe der Matrix ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get
F#
abstract Height : int
override Height : int

Field Value

Return Value

Eine Ganzzahl größer gleich 0

Implements

IMatrix..::..Height

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Item Property

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..Item Property
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert einer Zelle zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T this[
    int x,
    int y
] { get; set; }
Visual Basic
Public Default Property Item ( _
    x As Integer, _
    y As Integer _
) As T
    Get
    Set
F#
member Item : 'T with get, set

Parameters

x
Type: System..::..Int32
Die X-Adresse der Zelle. Sie muss im Intervall von 0 bis width - 1 liegen.
y
Type: System..::..Int32
Die Y-Adresse der Zelle. Sie muss im Intervall von 0 bis height - 1 liegen.

Field Value

Ein Elementarwert.

Return Value

Den Wert der Zelle an der Stelle (x; y).

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Width Property

[image]

DynamicNodes API
Matrix<(Of <(<'T>)>)>..::..Width Property
Matrix<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Breite der Matrix ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get
F#
abstract Width : int
override Width : int

Field Value

Return Value

Eine Ganzzahl größer gleich 0

Implements

IMatrix..::..Width

See Also

Matrix<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Matrix3D(T) Class

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine generische, dreidimensionale (quaderförmige) Datenstruktur. Schreibzugriff ist nur über das öffentliche Feld data möglich.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class Matrix3D<T> : IMatrix3D<T>,
    IMatrix3D, IFixSizeStruct, IMDO<T>, IMDO, IEnumerable<IMatrix<T>>,
    IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class Matrix3D(Of T) _
    Implements IMatrix3D(Of T), IMatrix3D, IFixSizeStruct,  _
    IMDO(Of T), IMDO, IEnumerable(Of IMatrix(Of T)),  _
    IEnumerable
F#
[<SerializableAttribute>]
type Matrix3D<'T> =
    class
        interface IMatrix3D<'T>
        interface IMatrix3D
        interface IFixSizeStruct
        interface IMDO<'T>
        interface IMDO
        interface IEnumerable<IMatrix<'T>>
        interface IEnumerable
    end

Type Parameters

T
Der elementare Datentyp der Matrix

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Matrix3D<(Of <(<'T>)>)>

See Also

Matrix3D<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Matrix3D(T) Members

[image] [image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Members
Matrix3D<(Of <(<'T>)>)> Class Constructors Methods Operators Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Matrix3D<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Matrix3D<(Of <(<'T>)>)>(array<T,3>[,,](,,)[,,][,,]) | Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.
Public method | Matrix3D<(Of <(<'T>)>)>(array<T,3>[,,](,,)[,,][,,], T) | Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.
Public method | Matrix3D<(Of <(<'T>)>)>(Int32, Int32, Int32) | Initialisiert eine neue Matrix.
Public method | Matrix3D<(Of <(<'T>)>)>(Int32, Int32, Int32, T) | Initialisiert eine neue Matrix.

Methods

 | Name | Description
Public method | Apply |
Public method | Copy | Gibt eine Kopie der 3D-Matrix zurück.
Public method | CopyCell | Gibt die Kopie der Zelle (x, y, z) zurück.
Public method | CopyXVector | Gibt eine Kopie der Zeile (y, z) aus der 3D-Matrix zurück.
Public method | CopyXYMatrix | Gibt eine Kopie der X-Y-Ebene z aus der 3D-Matrix zurück.
Public method | CopyXZMatrix | Gibt eine Kopie der X-Z-Ebene y aus der 3D-Matrix zurück.
Public method | CopyYVector | Gibt eine Kopie der Spalte (x, z) aus der 3D-Matrix zurück.
Public method | CopyYZMatrix | Gibt eine Kopie der Y-Z-Ebene x aus der 3D-Matrix zurück.
Public method | CopyZVector | Gibt eine Kopie der Z-Reihe (x, y) aus der 3D-Matrix zurück.
Public method | Fill | Belegt alle Felder der Matrix mit dem übergebenen Wert.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.
Public method | GetValue(Int32, Int32, Int32) | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.
Public method | GetValueAsObject(Int32, Int32, Int32) | Ruft den Wert eines Feldes als Objekt ab.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<T,3>[,,](,,)[,,][,,] to Matrix3D<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung eines 3D-Arrays nach Matrix3D<(Of <(<'T>)>)> durch.
ImplicitWideningImplicitImplicitImplicit(Matrix3D<(Of <<'(T>)>>) to array<T,3>[,,](,,)[,,][,,]) | Führt eine implizite Umwandlung von Matrix3D<(Of <(<'T>)>)> in ein 3D-Array durch. Diese Umwandlung ist langsam, weil die Elemente kopiert werden müssen.

Fields

 | Name | Description
Protected field | data | Das verschachtelte Array, welches die Daten der Matrix enthält.
Protected field | defValue | Der Standardwert der Matrix, welcher bei Indexüberschreitungen zurückgegeben wird.
Protected field | depth | Die Tiefe der Matrix.
Protected field | height | Die Höhe der Matrix.
Protected field | width | Die Breite der Matrix.

Properties

 | Name | Description
Public property | Depth | Ruft die Tiefe des Tensor ab.
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück
Public property | Height | Ruft die Höhe des Tensor ab.
Public property | Item | Gibt den Wert einer Matrizen-Zelle zurück.
Public property | Width | Ruft die Breite des Tensor ab.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Matrix3D(T) Constructor

[image] [image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Constructor
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Matrix3D<(Of <(<'T>)>)>(array<T,3>[,,](,,)[,,][,,]) | Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.
Public method | Matrix3D<(Of <(<'T>)>)>(array<T,3>[,,](,,)[,,][,,], T) | Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.
Public method | Matrix3D<(Of <(<'T>)>)>(Int32, Int32, Int32) | Initialisiert eine neue Matrix.
Public method | Matrix3D<(Of <(<'T>)>)>(Int32, Int32, Int32, T) | Initialisiert eine neue Matrix.

See Also

Matrix3D<(Of <(<'T>)>)> Class
Matrix3D<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Matrix3D(T) Constructor (T[,])

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Constructor (array<T,3>[,](,)[,][,])
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix3D(
    T[,,] data
)
Visual Basic
Public Sub New ( _
    data As T(,,) _
)
F#
new :
        data:'T[,,] -> Matrix3D

Parameters

data
Type: array< T ,3>[,](,)[,][,]
Das Array mit den Daten für die Matrix.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für datanull übergeben wird.

See Also

Matrix3D<(Of <(<'T>)>)> Class
Matrix3D<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Matrix3D(T) Constructor (T[,], T)

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Constructor (array<T,3>[,](,)[,][,], T)
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine Matrix mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix3D(
    T[,,] data,
    T defValue
)
Visual Basic
Public Sub New ( _
    data As T(,,), _
    defValue As T _
)
F#
new :
        data:'T[,,] *
        defValue:'T -> Matrix3D

Parameters

data
Type: array< T ,3>[,](,)[,][,]
Das Array mit den Daten für die Matrix.
defValue
Type: T
Ein Standardwert, der bei Indexüberschreitungen zurückgegeben wird.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für datanull übergeben wird.

See Also

Matrix3D<(Of <(<'T>)>)> Class
Matrix3D<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Matrix3D(T) Constructor (Int32, Int32, Int32)

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Constructor (Int32, Int32, Int32)
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Matrix.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix3D(
    int width,
    int height,
    int depth
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    depth As Integer _
)
F#
new :
        width:int *
        height:int *
        depth:int -> Matrix3D

Parameters

width
Type: System..::..Int32
Die Breite der Matrix.
height
Type: System..::..Int32
Die Höhe der Matrix.
depth
Type: System..::..Int32
Die Tiefe der Matrix.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width, height oder depth ein Wert kleiner 0 übergeben wird.

See Also

Matrix3D<(Of <(<'T>)>)> Class
Matrix3D<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Matrix3D(T) Constructor (Int32, Int32, Int32, T)

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Constructor (Int32, Int32, Int32, T)
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Matrix.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix3D(
    int width,
    int height,
    int depth,
    T defValue
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    depth As Integer, _
    defValue As T _
)
F#
new :
        width:int *
        height:int *
        depth:int *
        defValue:'T -> Matrix3D

Parameters

width
Type: System..::..Int32
Die Breite der Matrix.
height
Type: System..::..Int32
Die Höhe der Matrix.
depth
Type: System..::..Int32
Die Tiefe der Matrix.
defValue
Type: T
Ein Standardwert, der bei Indexüberschreitungen zurückgegeben wird.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width, height oder depth ein Wert kleiner 0 übergeben wird.

See Also

Matrix3D<(Of <(<'T>)>)> Class
Matrix3D<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Matrix3D(T) Fields

[image] [image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Fields
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Matrix3D<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | data | Das verschachtelte Array, welches die Daten der Matrix enthält.
Protected field | defValue | Der Standardwert der Matrix, welcher bei Indexüberschreitungen zurückgegeben wird.
Protected field | depth | Die Tiefe der Matrix.
Protected field | height | Die Höhe der Matrix.
Protected field | width | Die Breite der Matrix.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


data Field

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..data Field
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das verschachtelte Array, welches die Daten der Matrix enthält.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly T[,,] data
Visual Basic
Protected ReadOnly data As T(,,)
F#
val data: 'T[,,]

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


defValue Field

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..defValue Field
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Standardwert der Matrix, welcher bei Indexüberschreitungen zurückgegeben wird.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly T defValue
Visual Basic
Protected ReadOnly defValue As T
F#
val defValue: 'T

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


depth Field

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..depth Field
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Tiefe der Matrix.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly int depth
Visual Basic
Protected ReadOnly depth As Integer
F#
val depth: int

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


height Field

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..height Field
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Höhe der Matrix.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly int height
Visual Basic
Protected ReadOnly height As Integer
F#
val height: int

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


width Field

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..width Field
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Breite der Matrix.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly int width
Visual Basic
Protected ReadOnly width As Integer
F#
val width: int

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Matrix3D(T) Methods

[image] [image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Methods
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Matrix3D<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Apply |
Public method | Copy | Gibt eine Kopie der 3D-Matrix zurück.
Public method | CopyCell | Gibt die Kopie der Zelle (x, y, z) zurück.
Public method | CopyXVector | Gibt eine Kopie der Zeile (y, z) aus der 3D-Matrix zurück.
Public method | CopyXYMatrix | Gibt eine Kopie der X-Y-Ebene z aus der 3D-Matrix zurück.
Public method | CopyXZMatrix | Gibt eine Kopie der X-Z-Ebene y aus der 3D-Matrix zurück.
Public method | CopyYVector | Gibt eine Kopie der Spalte (x, z) aus der 3D-Matrix zurück.
Public method | CopyYZMatrix | Gibt eine Kopie der Y-Z-Ebene x aus der 3D-Matrix zurück.
Public method | CopyZVector | Gibt eine Kopie der Z-Reihe (x, y) aus der 3D-Matrix zurück.
Public method | Fill | Belegt alle Felder der Matrix mit dem übergebenen Wert.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.
Public method | GetValue(Int32, Int32, Int32) | Ruft den Wert eines Feldes ab.
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.
Public method | GetValueAsObject(Int32, Int32, Int32) | Ruft den Wert eines Feldes als Objekt ab.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Apply Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..Apply Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "M:DynamicNode.Types.Base.Matrix3D`1.Apply(System.Func`2)"]

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void Apply(
    Func transfer
)
Visual Basic
Public Sub Apply ( _
    transfer As Func _
)
F#
member Apply :
        transfer:Func -> unit

Parameters

transfer
Type: System..::..Func<(Of <(<'T, TResult>)>)>

[Missing <param name="transfer"/> documentation for "M:DynamicNode.Types.Base.Matrix3D`1.Apply(System.Func`2)"]

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Copy Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..Copy Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der 3D-Matrix zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix3D<T> Copy()
Visual Basic
Public Function Copy As Matrix3D(Of T)
F#
member Copy : unit -> Matrix3D<'T>

Return Value

Eine Kopie der Matrix.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyCell Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..CopyCell Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Kopie der Zelle (x, y, z) zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Scalar<T> CopyCell(
    int x,
    int y,
    int z
)
Visual Basic
Public Function CopyCell ( _
    x As Integer, _
    y As Integer, _
    z As Integer _
) As Scalar(Of T)
F#
member CopyCell :
        x:int *
        y:int *
        z:int -> Scalar<'T>

Parameters

x
Type: System..::..Int32
Der Index der Spalte.
y
Type: System..::..Int32
Der Index der Zeile.
z
Type: System..::..Int32
Der Index der Ebene.

Return Value

Eine Zelle der 3D-Matrix als Skalar.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyXVector Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..CopyXVector Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der Zeile (y, z) aus der 3D-Matrix zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Vector<T> CopyXVector(
    int y,
    int z
)
Visual Basic
Public Function CopyXVector ( _
    y As Integer, _
    z As Integer _
) As Vector(Of T)
F#
member CopyXVector :
        y:int *
        z:int -> Vector<'T>

Parameters

y
Type: System..::..Int32
Der Index der Zeile.
z
Type: System..::..Int32
Der Index der Ebene.

Return Value

Einen X-Vektor (Zeile) der 3D-Matrix.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyXYMatrix Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..CopyXYMatrix Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der X-Y-Ebene z aus der 3D-Matrix zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<T> CopyXYMatrix(
    int z
)
Visual Basic
Public Function CopyXYMatrix ( _
    z As Integer _
) As Matrix(Of T)
F#
member CopyXYMatrix :
        z:int -> Matrix<'T>

Parameters

z
Type: System..::..Int32
Der Index der Ebene.

Return Value

Eine X-Y-Ebene der Matrix.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyXZMatrix Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..CopyXZMatrix Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der X-Z-Ebene y aus der 3D-Matrix zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<T> CopyXZMatrix(
    int y
)
Visual Basic
Public Function CopyXZMatrix ( _
    y As Integer _
) As Matrix(Of T)
F#
member CopyXZMatrix :
        y:int -> Matrix<'T>

Parameters

y
Type: System..::..Int32
Der Index der Zeile.

Return Value

Eine X-Z-Ebene der Matrix.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyYVector Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..CopyYVector Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der Spalte (x, z) aus der 3D-Matrix zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Vector<T> CopyYVector(
    int x,
    int z
)
Visual Basic
Public Function CopyYVector ( _
    x As Integer, _
    z As Integer _
) As Vector(Of T)
F#
member CopyYVector :
        x:int *
        z:int -> Vector<'T>

Parameters

x
Type: System..::..Int32
Der Index der Spalte.
z
Type: System..::..Int32
Der Index der Ebene.

Return Value

Einen Y-Vektor (Spalte) der 3D-Matrix.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyYZMatrix Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..CopyYZMatrix Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der Y-Z-Ebene x aus der 3D-Matrix zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<T> CopyYZMatrix(
    int x
)
Visual Basic
Public Function CopyYZMatrix ( _
    x As Integer _
) As Matrix(Of T)
F#
member CopyYZMatrix :
        x:int -> Matrix<'T>

Parameters

x
Type: System..::..Int32
Der Index der Spalte.

Return Value

Eine Y-Z-Ebene der Matrix.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyZVector Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..CopyZVector Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der Z-Reihe (x, y) aus der 3D-Matrix zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Vector<T> CopyZVector(
    int x,
    int y
)
Visual Basic
Public Function CopyZVector ( _
    x As Integer, _
    y As Integer _
) As Vector(Of T)
F#
member CopyZVector :
        x:int *
        y:int -> Vector<'T>

Parameters

x
Type: System..::..Int32
Der Index der Spalte.
y
Type: System..::..Int32
Der Index der Zeile.

Return Value

Einen Z-Vektor (Z-Reihe) der 3D-Matrix.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Fill Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..Fill Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Belegt alle Felder der Matrix mit dem übergebenen Wert.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void Fill(
    T value
)
Visual Basic
Public Sub Fill ( _
    value As T _
)
F#
member Fill :
        value:'T -> unit

Parameters

value
Type: T
Ein Wert.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetEnumerator Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..GetEnumerator Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns an enumerator that iterates through the collection.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public IEnumerator<IMatrix<T>> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of IMatrix(Of T))
F#
abstract GetEnumerator : unit -> IEnumerator<IMatrix<'T>>
override GetEnumerator : unit -> IEnumerator<IMatrix<'T>>

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetSize Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..GetSize Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Größe des Objektes in einer Dimension zurück

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int GetSize(
    int dimension
)
Visual Basic
Public Function GetSize ( _
    dimension As Integer _
) As Integer
F#
abstract GetSize :
        dimension:int -> int
override GetSize :
        dimension:int -> int

Parameters

dimension
Type: System..::..Int32
Die Dimension (> 0), deren Größe abgefragt werden soll.

Return Value

Eine positive Ganzzahl

Implements

IMDO..::..GetSize(Int32)

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetValue Method

[image] [image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..GetValue Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.
Public method | GetValue(Int32, Int32, Int32) | Ruft den Wert eines Feldes ab.

See Also

Matrix3D<(Of <(<'T>)>)> Class
Matrix3D<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


GetValue Method (Int32[])

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..GetValue Method (array<Int32>[]()[][])
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert eines Feldes zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T GetValue(
    params int[] addr
)
Visual Basic
Public Function GetValue ( _
    ParamArray addr As Integer() _
) As T
F#
abstract GetValue :
        addr:int[] -> 'T
override GetValue :
        addr:int[] -> 'T

Parameters

addr
Type: array< System..::..Int32 >[]()[][]

Die Adresse des Feldes, wobei jedes Element von addr die Position in einer Dimension angibt.

Ist der übergebene Adressen-Vektor länger als die Anzahl der Dimensionen, können die überschüssigen Adressfelder ignoriert werden.

Ist der übergebene Adress-Vektor kürzer als die Anzahl der Dimensionen, wird für die fehlenden Felder die Adresse 0 angenommen.

Überschreitet die Adresse einer oder mehrerer Dimensionen eine Index-Grenze, muss dennoch ein gültiger Wert zurückgegeben werden.

Return Value

Der Wert eines Feldes

See Also

Matrix3D<(Of <(<'T>)>)> Class
GetValue Overload
DynamicNode.Types.Base Namespace


GetValue Method (Int32, Int32, Int32)

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..GetValue Method (Int32, Int32, Int32)
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T GetValue(
    int x,
    int y,
    int z
)
Visual Basic
Public Function GetValue ( _
    x As Integer, _
    y As Integer, _
    z As Integer _
) As T
F#
abstract GetValue :
        x:int *
        y:int *
        z:int -> 'T
override GetValue :
        x:int *
        y:int *
        z:int -> 'T

Parameters

x
Type: System..::..Int32
Die X-Adresse des Feldes ( 0 <= x < Width)
y
Type: System..::..Int32
Die Y-Adresse des Feldes ( 0 <= y < Height)
z
Type: System..::..Int32
Die Z-Adresse des Feldes ( 0 <= z < Depth)

Return Value

Den Wert eines Feldes

Implements

IMatrix3D<(Of <(<'T>)>)>..::..GetValue(Int32, Int32, Int32)

See Also

Matrix3D<(Of <(<'T>)>)> Class
GetValue Overload
DynamicNode.Types.Base Namespace


GetValueAsObject Method

[image] [image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..GetValueAsObject Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.
Public method | GetValueAsObject(Int32, Int32, Int32) | Ruft den Wert eines Feldes als Objekt ab.

See Also

Matrix3D<(Of <(<'T>)>)> Class
Matrix3D<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


GetValueAsObject Method (Int32[])

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..GetValueAsObject Method (array<Int32>[]()[][])
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert eines Feldes als Objekt zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Object GetValueAsObject(
    params int[] addr
)
Visual Basic
Public Function GetValueAsObject ( _
    ParamArray addr As Integer() _
) As Object
F#
abstract GetValueAsObject :
        addr:int[] -> Object
override GetValueAsObject :
        addr:int[] -> Object

Parameters

addr
Type: array< System..::..Int32 >[]()[][]

Die Adresse des Feldes, wobei jedes Element von addr die Position in einer Dimension angibt.

Ist der übergebene Adressen-Vektor länger als die Anzahl der Dimensionen, können die überschüssigen Adressfelder ignoriert werden.

Ist der übergebene Adress-Vektor kürzer als die Anzahl der Dimensionen, wird für die fehlenden Felder die Adresse 0 angenommen.

Überschreitet die Adresse einer oder mehrerer Dimensionen eine Index-Grenze, muss dennoch ein gültiger Wert zurückgegeben werden.

Return Value

Der Wert eines Feldes

Implements

IMDO..::..GetValueAsObject(array<Int32>[]()[][])

See Also

Matrix3D<(Of <(<'T>)>)> Class
GetValueAsObject Overload
DynamicNode.Types.Base Namespace


GetValueAsObject Method (Int32, Int32, Int32)

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..GetValueAsObject Method (Int32, Int32, Int32)
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes als Objekt ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Object GetValueAsObject(
    int x,
    int y,
    int z
)
Visual Basic
Public Function GetValueAsObject ( _
    x As Integer, _
    y As Integer, _
    z As Integer _
) As Object
F#
abstract GetValueAsObject :
        x:int *
        y:int *
        z:int -> Object
override GetValueAsObject :
        x:int *
        y:int *
        z:int -> Object

Parameters

x
Type: System..::..Int32
Die X-Adresse des Feldes ( 0 <= x < Width)
y
Type: System..::..Int32
Die Y-Adresse des Feldes ( 0 <= y < Height)
z
Type: System..::..Int32
Die Z-Adresse des Feldes ( 0 <= z < Depth)

Return Value

Den Wert eines Feldes

Implements

IMatrix3D..::..GetValueAsObject(Int32, Int32, Int32)

See Also

Matrix3D<(Of <(<'T>)>)> Class
GetValueAsObject Overload
DynamicNode.Types.Base Namespace


ToString Method

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..ToString Method
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Matrix3D(T) Type Conversions

[image] [image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Type Conversions
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<T,3>[,,](,,)[,,][,,] to Matrix3D<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung eines 3D-Arrays nach Matrix3D<(Of <(<'T>)>)> durch.
ImplicitWideningImplicitImplicitImplicit(Matrix3D<(Of <<'(T>)>>) to array<T,3>[,,](,,)[,,][,,]) | Führt eine implizite Umwandlung von Matrix3D<(Of <(<'T>)>)> in ein 3D-Array durch. Diese Umwandlung ist langsam, weil die Elemente kopiert werden müssen.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Implicit Conversion Operators

[image] [image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion Operators
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<T,3>[,,](,,)[,,][,,] to Matrix3D<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung eines 3D-Arrays nach Matrix3D<(Of <(<'T>)>)> durch.
ImplicitWideningImplicitImplicitImplicit(Matrix3D<(Of <<'(T>)>>) to array<T,3>[,,](,,)[,,][,,]) | Führt eine implizite Umwandlung von Matrix3D<(Of <(<'T>)>)> in ein 3D-Array durch. Diese Umwandlung ist langsam, weil die Elemente kopiert werden müssen.

See Also

Matrix3D<(Of <(<'T>)>)> Class
Matrix3D<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Implicit Conversion (T[,] to Matrix3D(T))

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion (array<T,3>[,](,)[,][,] to Matrix3D<(Of <(<'T>)>)>)
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine implizite Umwandlung eines 3D-Arrays nach Matrix3D<(Of <(<'T>)>)> durch.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static implicit operator Matrix3D<T> (
    T[,,] source
)
Visual Basic
Public Shared Widening Operator CType ( _
    source As T(,,) _
) As Matrix3D(Of T)
F#
F# does not support the declaration of new casting operators.

Parameters

source
Type: array< T ,3>[,](,)[,][,]
Ein 3D-Array.

Return Value

Das Ergebnis der Umwandlung.

See Also

Matrix3D<(Of <(<'T>)>)> Class
ImplicitWideningImplicitImplicitImplicit Overload
DynamicNode.Types.Base Namespace


Implicit Conversion (Matrix3D(T) to T[,])

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion (Matrix3D<(Of <(<'T>)>)> to array<T,3>[,](,)[,][,])
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine implizite Umwandlung von Matrix3D<(Of <(<'T>)>)> in ein 3D-Array durch. Diese Umwandlung ist langsam, weil die Elemente kopiert werden müssen.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static implicit operator T[,,] (
    Matrix3D<T> source
)
Visual Basic
Public Shared Widening Operator CType ( _
    source As Matrix3D(Of T) _
) As T(,,)
F#
F# does not support the declaration of new casting operators.

Parameters

source
Type: DynamicNode.Types.Base..::..Matrix3D <(Of <(<' T >)>)>
Eine 3D-Matrix.

Return Value

Das Ergebnis der Umwandlung.

See Also

Matrix3D<(Of <(<'T>)>)> Class
ImplicitWideningImplicitImplicitImplicit Overload
DynamicNode.Types.Base Namespace


Matrix3D(T) Properties

[image] [image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)> Properties
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Matrix3D<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Depth | Ruft die Tiefe des Tensor ab.
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück
Public property | Height | Ruft die Höhe des Tensor ab.
Public property | Item | Gibt den Wert einer Matrizen-Zelle zurück.
Public property | Width | Ruft die Breite des Tensor ab.

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Depth Property

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..Depth Property
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Tiefe des Tensor ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Depth { get; }
Visual Basic
Public ReadOnly Property Depth As Integer
    Get
F#
abstract Depth : int
override Depth : int

Field Value

Return Value

Eine Ganzzahl größer gleich 0

Implements

IMatrix3D..::..Depth

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


DimensionCount Property

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..DimensionCount Property
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der verwendeten Dimensionen zurück

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int DimensionCount { get; }
Visual Basic
Public ReadOnly Property DimensionCount As Integer
    Get
F#
abstract DimensionCount : int
override DimensionCount : int

Field Value

Die Anzahl der Dimensionen.

Implements

IMDO..::..DimensionCount

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Height Property

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..Height Property
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Höhe des Tensor ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get
F#
abstract Height : int
override Height : int

Field Value

Return Value

Eine Ganzzahl größer gleich 0

Implements

IMatrix3D..::..Height

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Item Property

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..Item Property
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert einer Matrizen-Zelle zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T this[
    int x,
    int y,
    int z
] { get; set; }
Visual Basic
Public Default Property Item ( _
    x As Integer, _
    y As Integer, _
    z As Integer _
) As T
    Get
    Set
F#
member Item : 'T with get, set

Parameters

x
Type: System..::..Int32
Die X-Adresse der Zelle. Sie muss im Intervall von 0 bis Width - 1 liegen.
y
Type: System..::..Int32
Die Y-Adresse der Zelle. Sie muss im Intervall von 0 bis Height - 1 liegen.
z
Type: System..::..Int32
Die Z-Adresse der Zelle. Sie muss im Intervall von 0 bis Depth - 1 liegen.

Field Value

Ein Elementarwert.

Return Value

Den Wert der Zelle an der Stelle (x; y; z).

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Width Property

[image]

DynamicNodes API
Matrix3D<(Of <(<'T>)>)>..::..Width Property
Matrix3D<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Breite des Tensor ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get
F#
abstract Width : int
override Width : int

Field Value

Return Value

Eine Ganzzahl größer gleich 0

Implements

IMatrix3D..::..Width

See Also

Matrix3D<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


MDOTools Class

[image]

DynamicNodes API
MDOTools Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Sammlung von nützlichen Funktionen für MDOs.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static class MDOTools
Visual Basic
Public NotInheritable Class MDOTools
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MDOTools =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..MDOTools

See Also

MDOTools Members
DynamicNode.Types.Base Namespace


MDOTools Members

[image] [image]

DynamicNodes API
MDOTools Members
MDOTools Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MDOTools type exposes the following members.

Methods

Name | Description
GetSize<(Of <<'(T>)>>) | Ermittelt die mehrdimensionale Größe eines MDO. (Der Dimensionsindex ist anders als bei IMDO{T}.GetSize(int dimension) 0 basiert.)

See Also

MDOTools Class
DynamicNode.Types.Base Namespace


MDOTools Methods

[image] [image]

DynamicNodes API
MDOTools Methods
MDOTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The MDOTools type exposes the following members.

Methods

Name | Description
GetSize<(Of <<'(T>)>>) | Ermittelt die mehrdimensionale Größe eines MDO. (Der Dimensionsindex ist anders als bei IMDO{T}.GetSize(int dimension) 0 basiert.)

See Also

MDOTools Class
DynamicNode.Types.Base Namespace


GetSize(T) Method

[image]

DynamicNodes API
MDOTools..::..GetSize<(Of <(<'T>)>)> Method
MDOTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Ermittelt die mehrdimensionale Größe eines MDO.

(Der Dimensionsindex ist anders als bei IMDO{T}.GetSize(int dimension) 0 basiert.)

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static int[] GetSize<T>(
    IMDO<T> mdo
)
Visual Basic
Public Shared Function GetSize(Of T) ( _
    mdo As IMDO(Of T) _
) As Integer()
F#
static member GetSize :
        mdo:IMDO<'T> -> int[]

Parameters

mdo
Type: DynamicNode.Types.Base..::..IMDO <(Of <(<'T>)>)>
Das MDO, dessen Größe ermitelt werden soll.

Type Parameters

T
Der elementare Datentyp des MDOs.

Return Value

Ein Array mit den Größen der Dimensionen

See Also

MDOTools Class
DynamicNode.Types.Base Namespace


NumericTools Class

[image]

DynamicNodes API
NumericTools Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Sammlung von nützlichen Funktionen für numerische MDOs.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static class NumericTools
Visual Basic
Public NotInheritable Class NumericTools
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NumericTools =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..NumericTools

See Also

NumericTools Members
DynamicNode.Types.Base Namespace


NumericTools Members

[image] [image]

DynamicNodes API
NumericTools Members
NumericTools Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Methods

Name | Description
Max(Matrix<(Of <<'(Byte>)>>)) | Bildet das Maximum aller Werte.
Max<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>)) | Bildet das Maximum aller Werte.
Max<(Of <<'(T>)>>)(Matrix<(Of <<'(T>)>>)) | Bildet das Maximum aller Werte.
Max<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>), Int32, array<Int32>[]()[][]) | Bildet das Maximum in einem durch einen Radius begrenzten Bereich.
Mean(IMDO<(Of <<'(Byte>)>>), Int32, array<Int32>[]()[][]) | Bildet den Mittelwert in einem durch einen Radius begrenzten Bereich.
Mean(Matrix<(Of <<'(Byte>)>>), Int32, Int32, Int32) | Bildet den Mittelwert in einem durch einen Radius begrenzten Bereich.
Median<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>), Int32, array<Int32>[]()[][]) | Bildet den Median in einem durch einen Radius begrenzten Bereich.
Median<(Of <<'(T>)>>)(Matrix<(Of <<'(T>)>>), Int32, Int32, Int32) | Bildet den Median in einem durch einen Radius begrenzten Bereich.
Min(Matrix<(Of <<'(Byte>)>>)) | Bildet das Minimum aller Werte.
Min<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>)) | Bildet das Minimum aller Werte.
Min<(Of <<'(T>)>>)(Matrix<(Of <<'(T>)>>)) | Bildet das Minimum aller Werte.
Min<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>), Int32, array<Int32>[]()[][]) | Bildet das Minimum in einem durch einen Radius begrenzten Bereich.
ScaleDownBy2(Matrix<(Of <<'(Byte>)>>)) | Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.
ScaleDownBy2(Matrix<(Of <<'(Single>)>>)) | Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.
ScaleDownBy2(Matrix<(Of <<'(UInt16>)>>)) | Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.

See Also

NumericTools Class
DynamicNode.Types.Base Namespace


NumericTools Methods

[image] [image]

DynamicNodes API
NumericTools Methods
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Methods

Name | Description
Max(Matrix<(Of <<'(Byte>)>>)) | Bildet das Maximum aller Werte.
Max<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>)) | Bildet das Maximum aller Werte.
Max<(Of <<'(T>)>>)(Matrix<(Of <<'(T>)>>)) | Bildet das Maximum aller Werte.
Max<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>), Int32, array<Int32>[]()[][]) | Bildet das Maximum in einem durch einen Radius begrenzten Bereich.
Mean(IMDO<(Of <<'(Byte>)>>), Int32, array<Int32>[]()[][]) | Bildet den Mittelwert in einem durch einen Radius begrenzten Bereich.
Mean(Matrix<(Of <<'(Byte>)>>), Int32, Int32, Int32) | Bildet den Mittelwert in einem durch einen Radius begrenzten Bereich.
Median<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>), Int32, array<Int32>[]()[][]) | Bildet den Median in einem durch einen Radius begrenzten Bereich.
Median<(Of <<'(T>)>>)(Matrix<(Of <<'(T>)>>), Int32, Int32, Int32) | Bildet den Median in einem durch einen Radius begrenzten Bereich.
Min(Matrix<(Of <<'(Byte>)>>)) | Bildet das Minimum aller Werte.
Min<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>)) | Bildet das Minimum aller Werte.
Min<(Of <<'(T>)>>)(Matrix<(Of <<'(T>)>>)) | Bildet das Minimum aller Werte.
Min<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>), Int32, array<Int32>[]()[][]) | Bildet das Minimum in einem durch einen Radius begrenzten Bereich.
ScaleDownBy2(Matrix<(Of <<'(Byte>)>>)) | Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.
ScaleDownBy2(Matrix<(Of <<'(Single>)>>)) | Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.
ScaleDownBy2(Matrix<(Of <<'(UInt16>)>>)) | Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.

See Also

NumericTools Class
DynamicNode.Types.Base Namespace


Max Method

[image] [image]

DynamicNodes API
NumericTools..::..Max Method
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Max<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>)) | Bildet das Maximum aller Werte.
Max(Matrix<(Of <<'(Byte>)>>)) | Bildet das Maximum aller Werte.
Max<(Of <<'(T>)>>)(Matrix<(Of <<'(T>)>>)) | Bildet das Maximum aller Werte.
Max<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>), Int32, array<Int32>[]()[][]) | Bildet das Maximum in einem durch einen Radius begrenzten Bereich.

See Also

NumericTools Class
NumericTools Members
DynamicNode.Types.Base Namespace


Max(T) Method (IMDO(T))

[image]

DynamicNodes API
NumericTools..::..Max<(Of <(<'T>)>)> Method (IMDO<(Of <(<'T>)>)>)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet das Maximum aller Werte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static T Max<T>(
    IMDO<T> mdo
)
where T : IComparable
Visual Basic
Public Shared Function Max(Of T As IComparable) ( _
    mdo As IMDO(Of T) _
) As T
F#
static member Max :
        mdo:IMDO<'T> -> 'T  when 'T : IComparable

Parameters

mdo
Type: DynamicNode.Types.Base..::..IMDO <(Of <(<'T>)>)>
Das MDO.

Type Parameters

T
Der Datentyp des MDO.

Return Value

Das Maximum.

See Also

NumericTools Class
Max Overload
DynamicNode.Types.Base Namespace


Max Method (Matrix(Byte))

[image]

DynamicNodes API
NumericTools..::..Max Method (Matrix<(Of <(<'Byte>)>)>)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet das Maximum aller Werte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static byte Max(
    Matrix<byte> mat
)
Visual Basic
Public Shared Function Max ( _
    mat As Matrix(Of Byte) _
) As Byte
F#
static member Max :
        mat:Matrix<byte> -> byte

Parameters

mat
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Die Matrix.

Return Value

Das Maximum.

See Also

NumericTools Class
Max Overload
DynamicNode.Types.Base Namespace


Max(T) Method (Matrix(T))

[image]

DynamicNodes API
NumericTools..::..Max<(Of <(<'T>)>)> Method (Matrix<(Of <(<'T>)>)>)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet das Maximum aller Werte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static T Max<T>(
    Matrix<T> mat
)
where T : IComparable
Visual Basic
Public Shared Function Max(Of T As IComparable) ( _
    mat As Matrix(Of T) _
) As T
F#
static member Max :
        mat:Matrix<'T> -> 'T  when 'T : IComparable

Parameters

mat
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<'T>)>)>
Die Matrix.

Type Parameters

T
Der Datentyp der Matrix.

Return Value

Das Maximum.

See Also

NumericTools Class
Max Overload
DynamicNode.Types.Base Namespace


Max(T) Method (IMDO(T), Int32, Int32[])

[image]

DynamicNodes API
NumericTools..::..Max<(Of <(<'T>)>)> Method (IMDO<(Of <(<'T>)>)>, Int32, array<Int32>[]()[][])
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet das Maximum in einem durch einen Radius begrenzten Bereich.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static T Max<T>(
    IMDO<T> mdo,
    int radius,
    params int[] addr
)
where T : IComparable
Visual Basic
Public Shared Function Max(Of T As IComparable) ( _
    mdo As IMDO(Of T), _
    radius As Integer, _
    ParamArray addr As Integer() _
) As T
F#
static member Max :
        mdo:IMDO<'T> *
        radius:int *
        addr:int[] -> 'T  when 'T : IComparable

Parameters

mdo
Type: DynamicNode.Types.Base..::..IMDO <(Of <(<'T>)>)>
Das MDO.
radius
Type: System..::..Int32
Der Radius des Bereichs, dessen Maximum bestimmt werden soll. (Der Radius bezieht sich nicht auf einen Kreis oder eine Kugel etc. sondern auf die halbe Kantenlänge eines Rechtecks, Würfels etc.)
addr
Type: array< System..::..Int32 >[]()[][]
Der Mittelpunkt des Bereichs.

Type Parameters

T
Der Datentyp des MDO.

Return Value

Das Maximum des Bereichs.

See Also

NumericTools Class
Max Overload
DynamicNode.Types.Base Namespace


Mean Method

[image] [image]

DynamicNodes API
NumericTools..::..Mean Method
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Mean(IMDO<(Of <<'(Byte>)>>), Int32, array<Int32>[]()[][]) | Bildet den Mittelwert in einem durch einen Radius begrenzten Bereich.
Mean(Matrix<(Of <<'(Byte>)>>), Int32, Int32, Int32) | Bildet den Mittelwert in einem durch einen Radius begrenzten Bereich.

See Also

NumericTools Class
NumericTools Members
DynamicNode.Types.Base Namespace


Mean Method (IMDO(Byte), Int32, Int32[])

[image]

DynamicNodes API
NumericTools..::..Mean Method (IMDO<(Of <(<'Byte>)>)>, Int32, array<Int32>[]()[][])
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet den Mittelwert in einem durch einen Radius begrenzten Bereich.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static byte Mean(
    IMDO<byte> mdo,
    int radius,
    params int[] addr
)
Visual Basic
Public Shared Function Mean ( _
    mdo As IMDO(Of Byte), _
    radius As Integer, _
    ParamArray addr As Integer() _
) As Byte
F#
static member Mean :
        mdo:IMDO<byte> *
        radius:int *
        addr:int[] -> byte

Parameters

mdo
Type: DynamicNode.Types.Base..::..IMDO <(Of <(<' Byte >)>)>
Das MDO.
radius
Type: System..::..Int32
Der Radius des Bereichs, dessen Maximum bestimmt werden soll. (Der Radius bezieht sich nicht auf einen Kreis oder eine Kugel etc. sondern auf die halbe Kantenlänge eines Rechtecks, Würfels etc.)
addr
Type: array< System..::..Int32 >[]()[][]
Der Mittelpunkt des Bereichs.

Return Value

Der Mittelwert des Bereichs.

See Also

NumericTools Class
Mean Overload
DynamicNode.Types.Base Namespace


Mean Method (Matrix(Byte), Int32, Int32, Int32)

[image]

DynamicNodes API
NumericTools..::..Mean Method (Matrix<(Of <(<'Byte>)>)>, Int32, Int32, Int32)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet den Mittelwert in einem durch einen Radius begrenzten Bereich.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static byte Mean(
    Matrix<byte> source,
    int radius,
    int px,
    int py
)
Visual Basic
Public Shared Function Mean ( _
    source As Matrix(Of Byte), _
    radius As Integer, _
    px As Integer, _
    py As Integer _
) As Byte
F#
static member Mean :
        source:Matrix<byte> *
        radius:int *
        px:int *
        py:int -> byte

Parameters

source
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Die Matrix.
radius
Type: System..::..Int32
Der Radius des Bereichs, dessen Maximum bestimmt werden soll. (Der Radius bezieht sich nicht auf einen Kreis sondern auf die halbe Kantenlänge eines Quadrats.)
px
Type: System..::..Int32
Der horizontale Mittelpunkt des Bereichs.
py
Type: System..::..Int32
Der vertikale Mittelpunkt des Bereichs.

Return Value

Der Mittelwert des Bereichs.

See Also

NumericTools Class
Mean Overload
DynamicNode.Types.Base Namespace


Median Method

[image] [image]

DynamicNodes API
NumericTools..::..Median Method
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Median<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>), Int32, array<Int32>[]()[][]) | Bildet den Median in einem durch einen Radius begrenzten Bereich.
Median<(Of <<'(T>)>>)(Matrix<(Of <<'(T>)>>), Int32, Int32, Int32) | Bildet den Median in einem durch einen Radius begrenzten Bereich.

See Also

NumericTools Class
NumericTools Members
DynamicNode.Types.Base Namespace


Median(T) Method (IMDO(T), Int32, Int32[])

[image]

DynamicNodes API
NumericTools..::..Median<(Of <(<'T>)>)> Method (IMDO<(Of <(<'T>)>)>, Int32, array<Int32>[]()[][])
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet den Median in einem durch einen Radius begrenzten Bereich.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static T Median<T>(
    IMDO<T> mdo,
    int radius,
    params int[] addr
)
where T : IComparable
Visual Basic
Public Shared Function Median(Of T As IComparable) ( _
    mdo As IMDO(Of T), _
    radius As Integer, _
    ParamArray addr As Integer() _
) As T
F#
static member Median :
        mdo:IMDO<'T> *
        radius:int *
        addr:int[] -> 'T  when 'T : IComparable

Parameters

mdo
Type: DynamicNode.Types.Base..::..IMDO <(Of <(<'T>)>)>
Das MDO.
radius
Type: System..::..Int32
Der Radius des Bereichs, dessen Median bestimmt werden soll. (Der Radius bezieht sich nicht auf einen Kreis oder eine Kugel etc. sondern auf die halbe Kantenlänge eines Rechtecks, Würfels etc.)
addr
Type: array< System..::..Int32 >[]()[][]
Der Mittelpunkt des Bereichs.

Type Parameters

T
Der Datentyp des MDO.

Return Value

Den Median des Bereichs.

See Also

NumericTools Class
Median Overload
DynamicNode.Types.Base Namespace


Median(T) Method (Matrix(T), Int32, Int32, Int32)

[image]

DynamicNodes API
NumericTools..::..Median<(Of <(<'T>)>)> Method (Matrix<(Of <(<'T>)>)>, Int32, Int32, Int32)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet den Median in einem durch einen Radius begrenzten Bereich.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static T Median<T>(
    Matrix<T> source,
    int radius,
    int px,
    int py
)
where T : IComparable
Visual Basic
Public Shared Function Median(Of T As IComparable) ( _
    source As Matrix(Of T), _
    radius As Integer, _
    px As Integer, _
    py As Integer _
) As T
F#
static member Median :
        source:Matrix<'T> *
        radius:int *
        px:int *
        py:int -> 'T  when 'T : IComparable

Parameters

source
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<'T>)>)>
Die Matrix.
radius
Type: System..::..Int32
Der Radius des Bereichs, dessen Median bestimmt werden soll. (Der Radius bezieht sich nicht auf einen Kreis sondern auf die halbe Kantenlänge eines Quadrats)
px
Type: System..::..Int32
Der horizontale Mittelpunkt des Bereichs.
py
Type: System..::..Int32
Der vertikale Mittelpunkt des Bereichs.

Type Parameters

T
Der Datentyp der Matrix.

Return Value

Den Median des Bereichs.

See Also

NumericTools Class
Median Overload
DynamicNode.Types.Base Namespace


Min Method

[image] [image]

DynamicNodes API
NumericTools..::..Min Method
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
Min<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>)) | Bildet das Minimum aller Werte.
Min(Matrix<(Of <<'(Byte>)>>)) | Bildet das Minimum aller Werte.
Min<(Of <<'(T>)>>)(Matrix<(Of <<'(T>)>>)) | Bildet das Minimum aller Werte.
Min<(Of <<'(T>)>>)(IMDO<(Of <<'(T>)>>), Int32, array<Int32>[]()[][]) | Bildet das Minimum in einem durch einen Radius begrenzten Bereich.

See Also

NumericTools Class
NumericTools Members
DynamicNode.Types.Base Namespace


Min(T) Method (IMDO(T))

[image]

DynamicNodes API
NumericTools..::..Min<(Of <(<'T>)>)> Method (IMDO<(Of <(<'T>)>)>)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet das Minimum aller Werte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static T Min<T>(
    IMDO<T> mdo
)
where T : IComparable
Visual Basic
Public Shared Function Min(Of T As IComparable) ( _
    mdo As IMDO(Of T) _
) As T
F#
static member Min :
        mdo:IMDO<'T> -> 'T  when 'T : IComparable

Parameters

mdo
Type: DynamicNode.Types.Base..::..IMDO <(Of <(<'T>)>)>
Das MDO.

Type Parameters

T
Der Datentyp des MDO.

Return Value

Das Minimum.

See Also

NumericTools Class
Min Overload
DynamicNode.Types.Base Namespace


Min Method (Matrix(Byte))

[image]

DynamicNodes API
NumericTools..::..Min Method (Matrix<(Of <(<'Byte>)>)>)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet das Minimum aller Werte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static byte Min(
    Matrix<byte> mat
)
Visual Basic
Public Shared Function Min ( _
    mat As Matrix(Of Byte) _
) As Byte
F#
static member Min :
        mat:Matrix<byte> -> byte

Parameters

mat
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Die Matrix.

Return Value

Das Minimum.

See Also

NumericTools Class
Min Overload
DynamicNode.Types.Base Namespace


Min(T) Method (Matrix(T))

[image]

DynamicNodes API
NumericTools..::..Min<(Of <(<'T>)>)> Method (Matrix<(Of <(<'T>)>)>)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet das Minimum aller Werte.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static T Min<T>(
    Matrix<T> mat
)
where T : IComparable
Visual Basic
Public Shared Function Min(Of T As IComparable) ( _
    mat As Matrix(Of T) _
) As T
F#
static member Min :
        mat:Matrix<'T> -> 'T  when 'T : IComparable

Parameters

mat
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<'T>)>)>
Die Matrix.

Type Parameters

T
Der Datentyp der Matrix.

Return Value

Das Minimum.

See Also

NumericTools Class
Min Overload
DynamicNode.Types.Base Namespace


Min(T) Method (IMDO(T), Int32, Int32[])

[image]

DynamicNodes API
NumericTools..::..Min<(Of <(<'T>)>)> Method (IMDO<(Of <(<'T>)>)>, Int32, array<Int32>[]()[][])
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet das Minimum in einem durch einen Radius begrenzten Bereich.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static T Min<T>(
    IMDO<T> mdo,
    int radius,
    params int[] addr
)
where T : IComparable
Visual Basic
Public Shared Function Min(Of T As IComparable) ( _
    mdo As IMDO(Of T), _
    radius As Integer, _
    ParamArray addr As Integer() _
) As T
F#
static member Min :
        mdo:IMDO<'T> *
        radius:int *
        addr:int[] -> 'T  when 'T : IComparable

Parameters

mdo
Type: DynamicNode.Types.Base..::..IMDO <(Of <(<'T>)>)>
Das MDO.
radius
Type: System..::..Int32
Der Radius des Bereichs, dessen Minimum bestimmt werden soll. (Der Radius bezieht sich nicht auf einen Kreis oder eine Kugel etc. sondern auf die halbe Kantenlänge eines Rechtecks, Würfels etc.)
addr
Type: array< System..::..Int32 >[]()[][]
Der Mittelpunkt des Bereichs.

Type Parameters

T
Der Datentyp des MDO.

Return Value

Das Minimum des Bereichs.

See Also

NumericTools Class
Min Overload
DynamicNode.Types.Base Namespace


ScaleDownBy2 Method

[image] [image]

DynamicNodes API
NumericTools..::..ScaleDownBy2 Method
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
ScaleDownBy2(Matrix<(Of <<'(Byte>)>>)) | Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.
ScaleDownBy2(Matrix<(Of <<'(Single>)>>)) | Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.
ScaleDownBy2(Matrix<(Of <<'(UInt16>)>>)) | Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.

See Also

NumericTools Class
NumericTools Members
DynamicNode.Types.Base Namespace


ScaleDownBy2 Method (Matrix(Byte))

[image]

DynamicNodes API
NumericTools..::..ScaleDownBy2 Method (Matrix<(Of <(<'Byte>)>)>)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Matrix<byte> ScaleDownBy2(
    Matrix<byte> source
)
Visual Basic
Public Shared Function ScaleDownBy2 ( _
    source As Matrix(Of Byte) _
) As Matrix(Of Byte)
F#
static member ScaleDownBy2 :
        source:Matrix<byte> -> Matrix<byte>

Parameters

source
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Die Quellmatrix.

Return Value

Die Ergebnismatrix.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für sourcenull übergeben wird.
System..::..ArgumentException | Wird geworfen, wenn die Kantenlänge von source kleiner als 2 ist.

See Also

NumericTools Class
ScaleDownBy2 Overload
DynamicNode.Types.Base Namespace


ScaleDownBy2 Method (Matrix(Single))

[image]

DynamicNodes API
NumericTools..::..ScaleDownBy2 Method (Matrix<(Of <(<'Single>)>)>)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Matrix<float> ScaleDownBy2(
    Matrix<float> source
)
Visual Basic
Public Shared Function ScaleDownBy2 ( _
    source As Matrix(Of Single) _
) As Matrix(Of Single)
F#
static member ScaleDownBy2 :
        source:Matrix<float32> -> Matrix<float32>

Parameters

source
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Die Quellmatrix.

Return Value

Die Ergebnismatrix.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für sourcenull übergeben wird.
System..::..ArgumentException | Wird geworfen, wenn die Kantenlänge von source kleiner als 2 ist.

See Also

NumericTools Class
ScaleDownBy2 Overload
DynamicNode.Types.Base Namespace


ScaleDownBy2 Method (Matrix(UInt16))

[image]

DynamicNodes API
NumericTools..::..ScaleDownBy2 Method (Matrix<(Of <(<'UInt16>)>)>)
NumericTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Berechnet eine Ergebnismatrix, welche die halbe Kantenlänge von der Quellmatrix besitzt.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Matrix<ushort> ScaleDownBy2(
    Matrix<ushort> source
)
Visual Basic
Public Shared Function ScaleDownBy2 ( _
    source As Matrix(Of UShort) _
) As Matrix(Of UShort)
F#
static member ScaleDownBy2 :
        source:Matrix<uint16> -> Matrix<uint16>

Parameters

source
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Die Quellmatrix.

Return Value

Die Ergebnismatrix.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für sourcenull übergeben wird.
System..::..ArgumentException | Wird geworfen, wenn die Kantenlänge von source kleiner als 2 ist.

See Also

NumericTools Class
ScaleDownBy2 Overload
DynamicNode.Types.Base Namespace


Scalar(T) Class

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein generischer Skalar.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class Scalar<T> : IScalar<T>, IScalar,
    IFixSizeStruct, IMDO<T>, IMDO
Visual Basic
<SerializableAttribute> _
Public Class Scalar(Of T) _
    Implements IScalar(Of T), IScalar, IFixSizeStruct,  _
    IMDO(Of T), IMDO
F#
[<SerializableAttribute>]
type Scalar<'T> =
    class
        interface IScalar<'T>
        interface IScalar
        interface IFixSizeStruct
        interface IMDO<'T>
        interface IMDO
    end

Type Parameters

T
Der elementare Datentyp des Skalars

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Scalar<(Of <(<'T>)>)>

See Also

Scalar<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Scalar(T) Members

[image] [image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> Members
Scalar<(Of <(<'T>)>)> Class Constructors Methods Operators Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Scalar<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Scalar<(Of <(<'T>)>)>()()()() | Initialisiert einen neuen Skalar.
Public method | Scalar<(Of <(<'T>)>)>(T) | Initialisiert einen Skalar mit einem existierenden Wert.

Methods

 | Name | Description
Public method | Apply |
Public method | Copy | Gibt eine Kopie des Skalars zurück.
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück
Public method | GetValue()()()() | Gibt den Wert des Skalars zurück.
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.
Public method | GetValueAsObject()()()() | Ruft den Wert eines Feldes als Objekt ab.
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(T to Scalar<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung von einem Wert in einen Scalar<(Of <(<'T>)>)>. Diese Umwandlung ist schnell.
ImplicitWideningImplicitImplicitImplicit(Scalar<(Of <<'(T>)>>) to T) | Führt eine implizite Umwandlung von einem Scalar<(Of <(<'T>)>)> in seinen Wert vom Typ T. Diese Umwandlung ist schnell.

Fields

 | Name | Description
Protected field | value | Der Wert des Skalars.

Properties

 | Name | Description
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück
Public property | Value | Gibt den Wert des Skalars zurück oder legt ihn fest

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Scalar(T) Constructor

[image] [image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> Constructor
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Scalar<(Of <(<'T>)>)>()()()() | Initialisiert einen neuen Skalar.
Public method | Scalar<(Of <(<'T>)>)>(T) | Initialisiert einen Skalar mit einem existierenden Wert.

See Also

Scalar<(Of <(<'T>)>)> Class
Scalar<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Scalar(T) Constructor

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> Constructor
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neuen Skalar.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Scalar()
Visual Basic
Public Sub New
F#
new : unit -> Scalar

See Also

Scalar<(Of <(<'T>)>)> Class
Scalar<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Scalar(T) Constructor (T)

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> Constructor (T)
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen Skalar mit einem existierenden Wert.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Scalar(
    T value
)
Visual Basic
Public Sub New ( _
    value As T _
)
F#
new :
        value:'T -> Scalar

Parameters

value
Type: T
Der initiale Wert des Skalars.

See Also

Scalar<(Of <(<'T>)>)> Class
Scalar<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Scalar(T) Fields

[image] [image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> Fields
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Scalar<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | value | Der Wert des Skalars.

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


value Field

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..value Field
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Wert des Skalars.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected T value
Visual Basic
Protected value As T
F#
val mutable value: 'T

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Scalar(T) Methods

[image] [image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> Methods
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Scalar<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Apply |
Public method | Copy | Gibt eine Kopie des Skalars zurück.
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück
Public method | GetValue()()()() | Gibt den Wert des Skalars zurück.
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.
Public method | GetValueAsObject()()()() | Ruft den Wert eines Feldes als Objekt ab.
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Apply Method

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..Apply Method
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "M:DynamicNode.Types.Base.Scalar`1.Apply(System.Func`2)"]

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void Apply(
    Func transfer
)
Visual Basic
Public Sub Apply ( _
    transfer As Func _
)
F#
member Apply :
        transfer:Func -> unit

Parameters

transfer
Type: System..::..Func<(Of <(<'T, TResult>)>)>

[Missing <param name="transfer"/> documentation for "M:DynamicNode.Types.Base.Scalar`1.Apply(System.Func`2)"]

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Copy Method

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..Copy Method
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie des Skalars zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Scalar<T> Copy()
Visual Basic
Public Function Copy As Scalar(Of T)
F#
member Copy : unit -> Scalar<'T>

Return Value

Eine Kopie des Skalars.

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetSize Method

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..GetSize Method
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Größe des Objektes in einer Dimension zurück

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int GetSize(
    int dimension
)
Visual Basic
Public Function GetSize ( _
    dimension As Integer _
) As Integer
F#
abstract GetSize :
        dimension:int -> int
override GetSize :
        dimension:int -> int

Parameters

dimension
Type: System..::..Int32
Die Dimension (> 0), deren Größe abgefragt werden soll.

Return Value

Eine positive Ganzzahl

Implements

IMDO..::..GetSize(Int32)

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetValue Method

[image] [image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..GetValue Method
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetValue()()()() | Gibt den Wert des Skalars zurück.
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.

See Also

Scalar<(Of <(<'T>)>)> Class
Scalar<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


GetValue Method

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..GetValue Method
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert des Skalars zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T GetValue()
Visual Basic
Public Function GetValue As T
F#
abstract GetValue : unit -> 'T
override GetValue : unit -> 'T

Return Value

Der Wert des Skalars-

Implements

IScalar<(Of <(<'T>)>)>..::..GetValue()()()()

See Also

Scalar<(Of <(<'T>)>)> Class
GetValue Overload
DynamicNode.Types.Base Namespace


GetValue Method (Int32[])

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..GetValue Method (array<Int32>[]()[][])
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert eines Feldes zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T GetValue(
    params int[] addr
)
Visual Basic
Public Function GetValue ( _
    ParamArray addr As Integer() _
) As T
F#
abstract GetValue :
        addr:int[] -> 'T
override GetValue :
        addr:int[] -> 'T

Parameters

addr
Type: array< System..::..Int32 >[]()[][]

Die Adresse des Feldes, wobei jedes Element von addr die Position in einer Dimension angibt.

Ist der übergebene Adressen-Vektor länger als die Anzahl der Dimensionen, können die überschüssigen Adressfelder ignoriert werden.

Ist der übergebene Adress-Vektor kürzer als die Anzahl der Dimensionen, wird für die fehlenden Felder die Adresse 0 angenommen.

Überschreitet die Adresse einer oder mehrerer Dimensionen eine Index-Grenze, muss dennoch ein gültiger Wert zurückgegeben werden.

Return Value

Der Wert eines Feldes

Implements

IMDO<(Of <(<'T>)>)>..::..GetValue(array<Int32>[]()[][])

See Also

Scalar<(Of <(<'T>)>)> Class
GetValue Overload
DynamicNode.Types.Base Namespace


GetValueAsObject Method

[image] [image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..GetValueAsObject Method
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetValueAsObject()()()() | Ruft den Wert eines Feldes als Objekt ab.
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.

See Also

Scalar<(Of <(<'T>)>)> Class
Scalar<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


GetValueAsObject Method

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..GetValueAsObject Method
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes als Objekt ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Object GetValueAsObject()
Visual Basic
Public Function GetValueAsObject As Object
F#
abstract GetValueAsObject : unit -> Object
override GetValueAsObject : unit -> Object

Return Value

Den Wert eines Feldes

Implements

IScalar..::..GetValueAsObject()()()()

See Also

Scalar<(Of <(<'T>)>)> Class
GetValueAsObject Overload
DynamicNode.Types.Base Namespace


GetValueAsObject Method (Int32[])

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..GetValueAsObject Method (array<Int32>[]()[][])
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert eines Feldes als Objekt zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Object GetValueAsObject(
    params int[] addr
)
Visual Basic
Public Function GetValueAsObject ( _
    ParamArray addr As Integer() _
) As Object
F#
abstract GetValueAsObject :
        addr:int[] -> Object
override GetValueAsObject :
        addr:int[] -> Object

Parameters

addr
Type: array< System..::..Int32 >[]()[][]

Die Adresse des Feldes, wobei jedes Element von addr die Position in einer Dimension angibt.

Ist der übergebene Adressen-Vektor länger als die Anzahl der Dimensionen, können die überschüssigen Adressfelder ignoriert werden.

Ist der übergebene Adress-Vektor kürzer als die Anzahl der Dimensionen, wird für die fehlenden Felder die Adresse 0 angenommen.

Überschreitet die Adresse einer oder mehrerer Dimensionen eine Index-Grenze, muss dennoch ein gültiger Wert zurückgegeben werden.

Return Value

Der Wert eines Feldes

Implements

IMDO..::..GetValueAsObject(array<Int32>[]()[][])

See Also

Scalar<(Of <(<'T>)>)> Class
GetValueAsObject Overload
DynamicNode.Types.Base Namespace


ToString Method

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..ToString Method
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Scalar(T) Type Conversions

[image] [image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> Type Conversions
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(T to Scalar<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung von einem Wert in einen Scalar<(Of <(<'T>)>)>. Diese Umwandlung ist schnell.
ImplicitWideningImplicitImplicitImplicit(Scalar<(Of <<'(T>)>>) to T) | Führt eine implizite Umwandlung von einem Scalar<(Of <(<'T>)>)> in seinen Wert vom Typ T. Diese Umwandlung ist schnell.

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Implicit Conversion Operators

[image] [image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion Operators
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(T to Scalar<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung von einem Wert in einen Scalar<(Of <(<'T>)>)>. Diese Umwandlung ist schnell.
ImplicitWideningImplicitImplicitImplicit(Scalar<(Of <<'(T>)>>) to T) | Führt eine implizite Umwandlung von einem Scalar<(Of <(<'T>)>)> in seinen Wert vom Typ T. Diese Umwandlung ist schnell.

See Also

Scalar<(Of <(<'T>)>)> Class
Scalar<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Implicit Conversion (T to Scalar(T))

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion (T to Scalar<(Of <(<'T>)>)>)
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine implizite Umwandlung von einem Wert in einen Scalar<(Of <(<'T>)>)>. Diese Umwandlung ist schnell.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static implicit operator Scalar<T> (
    T source
)
Visual Basic
Public Shared Widening Operator CType ( _
    source As T _
) As Scalar(Of T)
F#
F# does not support the declaration of new casting operators.

Parameters

source
Type: T
Ein Objekt vom Typ T.

Return Value

Das Ergebnis der Umwandlung.

See Also

Scalar<(Of <(<'T>)>)> Class
ImplicitWideningImplicitImplicitImplicit Overload
DynamicNode.Types.Base Namespace


Implicit Conversion (Scalar(T) to T)

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion (Scalar<(Of <(<'T>)>)> to T)
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine implizite Umwandlung von einem Scalar<(Of <(<'T>)>)> in seinen Wert vom Typ T. Diese Umwandlung ist schnell.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static implicit operator T (
    Scalar<T> source
)
Visual Basic
Public Shared Widening Operator CType ( _
    source As Scalar(Of T) _
) As T
F#
F# does not support the declaration of new casting operators.

Parameters

source
Type: DynamicNode.Types.Base..::..Scalar <(Of <(<' T >)>)>
Ein Skalar.

Return Value

Das Ergebnis der Umwandlung.

See Also

Scalar<(Of <(<'T>)>)> Class
ImplicitWideningImplicitImplicitImplicit Overload
DynamicNode.Types.Base Namespace


Scalar(T) Properties

[image] [image]

DynamicNodes API
Scalar<(Of <(<'T>)>)> Properties
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Scalar<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück
Public property | Value | Gibt den Wert des Skalars zurück oder legt ihn fest

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


DimensionCount Property

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..DimensionCount Property
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der verwendeten Dimensionen zurück

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int DimensionCount { get; }
Visual Basic
Public ReadOnly Property DimensionCount As Integer
    Get
F#
abstract DimensionCount : int
override DimensionCount : int

Field Value

Die Anzahl der Dimensionen.

Implements

IMDO..::..DimensionCount

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Value Property

[image]

DynamicNodes API
Scalar<(Of <(<'T>)>)>..::..Value Property
Scalar<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert des Skalars zurück oder legt ihn fest

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T Value { get; set; }
Visual Basic
Public Property Value As T
    Get
    Set
F#
member Value : 'T with get, set

Field Value

Der Wert des Skalars.

Return Value

Den Wert des Skalars.

See Also

Scalar<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Tupel(T) Class

[image]

DynamicNodes API
Tupel<(Of <(<'T>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet eine kleine sortierte Menge von Objekten.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class Tupel<T> : IEnumerable<T>, IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class Tupel(Of T) _
    Implements IEnumerable(Of T), IEnumerable
F#
[<SerializableAttribute>]
type Tupel<'T> =
    class
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
Der Datentyp der gruppierten Objekten.

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Tupel<(Of <(<'T>)>)>
DynamicNode.Types.Imaging..::..LabImage32
DynamicNode.Types.Imaging..::..LCHImage32
DynamicNode.Types.Imaging..::..RGBImage
DynamicNode.Types.Imaging..::..RGBImage16
DynamicNode.Types.Imaging..::..RGBImage32
DynamicNode.Types.Imaging..::..XYZImage32

See Also

Tupel<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Tupel(T) Members

[image] [image]

DynamicNodes API
Tupel<(Of <(<'T>)>)> Members
Tupel<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Tupel<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Tupel<(Of <(<'T>)>)> | Initialisiert eine neue Instanz der Klasse Tupel<(Of <(<'T>)>)>.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Item | Gibt ein Element anhand seines Namens zurück oder legt es fest.

See Also

Tupel<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Tupel(T) Constructor

[image]

DynamicNodes API
Tupel<(Of <(<'T>)>)> Constructor
Tupel<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse Tupel<(Of <(<'T>)>)>.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Tupel(
    params KeyValuePair<string, T>[] elements
)
Visual Basic
Public Sub New ( _
    ParamArray elements As KeyValuePair(Of String, T)() _
)
F#
new :
        elements:KeyValuePair<string, 'T>[] -> Tupel

Parameters

elements
Type: array< System.Collections.Generic..::..KeyValuePair <(Of <(<' String, T >)>)>>[]()[][]
Die benannten Elemente.

See Also

Tupel<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Tupel(T) Methods

[image] [image]

DynamicNodes API
Tupel<(Of <(<'T>)>)> Methods
Tupel<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Tupel<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

Tupel<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetEnumerator Method

[image]

DynamicNodes API
Tupel<(Of <(<'T>)>)>..::..GetEnumerator Method
Tupel<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Enumerator zurück, der die Auflistung durchläuft.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of T)
F#
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Return Value

Ein IEnumerator<(Of <(<'T>)>)>, der zum Durchlaufen der Auflistung verwendet werden kann.

See Also

Tupel<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


ToString Method

[image]

DynamicNodes API
Tupel<(Of <(<'T>)>)>..::..ToString Method
Tupel<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

Tupel<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Tupel(T) Properties

[image] [image]

DynamicNodes API
Tupel<(Of <(<'T>)>)> Properties
Tupel<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Tupel<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gibt ein Element anhand seines Namens zurück oder legt es fest.

See Also

Tupel<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Item Property

[image]

DynamicNodes API
Tupel<(Of <(<'T>)>)>..::..Item Property
Tupel<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Element anhand seines Namens zurück oder legt es fest.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T this[
    string key
] { get; set; }
Visual Basic
Public Default Property Item ( _
    key As String _
) As T
    Get
    Set
F#
member Item : 'T with get, set

Parameters

key
Type: System..::..String

Field Value

Ein benanntes Element.

See Also

Tupel<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Vector(T) Class

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine generische, zweidimensionale (rechteckige) Datenstruktur. Schreibzugriff ist nur über das öffentliche Feld data möglich.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class Vector<T> : IVector<T>, IVector,
    IFixSizeStruct, IMDO<T>, IMDO, IEnumerable<T>, IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class Vector(Of T) _
    Implements IVector(Of T), IVector, IFixSizeStruct,  _
    IMDO(Of T), IMDO, IEnumerable(Of T), IEnumerable
F#
[<SerializableAttribute>]
type Vector<'T> =
    class
        interface IVector<'T>
        interface IVector
        interface IFixSizeStruct
        interface IMDO<'T>
        interface IMDO
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
Der elementare Datentyp der Matrix

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Vector<(Of <(<'T>)>)>

See Also

Vector<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Vector(T) Members

[image] [image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Members
Vector<(Of <(<'T>)>)> Class Constructors Methods Operators Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Vector<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Vector<(Of <(<'T>)>)>(Int32) | Initialisiert einen neuen Vector.
Public method | Vector<(Of <(<'T>)>)>(array<T>[]()[][]) | Initialisiert einen Vector mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.
Public method | Vector<(Of <(<'T>)>)>(Int32, T) | Initialisiert einen neuen Vector.
Public method | Vector<(Of <(<'T>)>)>(array<T>[]()[][], T) | Initialisiert einen Vector mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.

Methods

 | Name | Description
Public method | Apply |
Public method | Copy | Gibt eine Kopie des Vectors zurück.
Public method | CopyCell | Gibt eine Kopie der Zelle x zurück.
Public method | Fill | Belegt alle Felder des Vektors mit dem übergebenen Wert.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück
Public method | GetValue(Int32) | Ruft den Wert eines Feldes ab.
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.
Public method | GetValueAsObject(Int32) | Ruft den Wert eines Feldes als Objekt ab.
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<T>[]()[][] to Vector<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung von einem verschachtelten nach Matrix<(Of <(<'T>)>)> durch. Diese Umwandlung ist schnell.
ImplicitWideningImplicitImplicitImplicit(Vector<(Of <<'(T>)>>) to array<T>[]()[][]) | Führt eine implizite Umwandlung von einer Matrix<(Of <(<'T>)>)> in ein verschachteltes Array durch. Diese Umwandlung ist schnell.

Fields

 | Name | Description
Protected field | data | Das Array, welches die Daten des Vectors enthält.
Protected field | defValue | Der Standardwert des Vectors, welcher bei Indexüberschreitungen zurückgegeben wird.
Protected field | length | Die Länge des Vektors.

Properties

 | Name | Description
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück
Public property | Item | Gibt den Wert einer Vector-Zelle zurück.
Public property | Length | Ruft die Länge des Vektors ab.

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Vector(T) Constructor

[image] [image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Constructor
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Vector<(Of <(<'T>)>)>(Int32) | Initialisiert einen neuen Vector.
Public method | Vector<(Of <(<'T>)>)>(array<T>[]()[][]) | Initialisiert einen Vector mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.
Public method | Vector<(Of <(<'T>)>)>(Int32, T) | Initialisiert einen neuen Vector.
Public method | Vector<(Of <(<'T>)>)>(array<T>[]()[][], T) | Initialisiert einen Vector mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.

See Also

Vector<(Of <(<'T>)>)> Class
Vector<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Vector(T) Constructor (Int32)

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Constructor (Int32)
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neuen Vector.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Vector(
    int length
)
Visual Basic
Public Sub New ( _
    length As Integer _
)
F#
new :
        length:int -> Vector

Parameters

length
Type: System..::..Int32
Die Länge des Vectors.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für length ein Wert kleiner 0 übergeben wird.

See Also

Vector<(Of <(<'T>)>)> Class
Vector<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Vector(T) Constructor (T[])

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Constructor (array<T>[]()[][])
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen Vector mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Vector(
    T[] data
)
Visual Basic
Public Sub New ( _
    data As T() _
)
F#
new :
        data:'T[] -> Vector

Parameters

data
Type: array< T >[]()[][]
Das Array mit den Daten für den Vector.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für datanull übergeben wird.

See Also

Vector<(Of <(<'T>)>)> Class
Vector<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Vector(T) Constructor (Int32, T)

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Constructor (Int32, T)
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neuen Vector.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Vector(
    int length,
    T defValue
)
Visual Basic
Public Sub New ( _
    length As Integer, _
    defValue As T _
)
F#
new :
        length:int *
        defValue:'T -> Vector

Parameters

length
Type: System..::..Int32
Die Länge des Vectors.
defValue
Type: T
Ein Standardwert, der bei Indexüberschreitungen zurückgegeben wird.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für length ein Wert kleiner 0 übergeben wird.

See Also

Vector<(Of <(<'T>)>)> Class
Vector<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Vector(T) Constructor (T[], T)

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Constructor (array<T>[]()[][], T)
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen Vector mit einem existierenden Daten-Array. Das Array wird nicht kopiert sondern direkt verwendet.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Vector(
    T[] data,
    T defValue
)
Visual Basic
Public Sub New ( _
    data As T(), _
    defValue As T _
)
F#
new :
        data:'T[] *
        defValue:'T -> Vector

Parameters

data
Type: array< T >[]()[][]
Das Array mit den Daten für den Vector.
defValue
Type: T
Ein Standardwert, der bei Indexüberschreitungen zurückgegeben wird.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Wird geworfen, wenn für datanull übergeben wird.

See Also

Vector<(Of <(<'T>)>)> Class
Vector<(Of <(<'T>)>)> Overload
DynamicNode.Types.Base Namespace


Vector(T) Fields

[image] [image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Fields
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Vector<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | data | Das Array, welches die Daten des Vectors enthält.
Protected field | defValue | Der Standardwert des Vectors, welcher bei Indexüberschreitungen zurückgegeben wird.
Protected field | length | Die Länge des Vektors.

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


data Field

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..data Field
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Array, welches die Daten des Vectors enthält.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly T[] data
Visual Basic
Protected ReadOnly data As T()
F#
val data: 'T[]

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


defValue Field

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..defValue Field
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Standardwert des Vectors, welcher bei Indexüberschreitungen zurückgegeben wird.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly T defValue
Visual Basic
Protected ReadOnly defValue As T
F#
val defValue: 'T

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


length Field

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..length Field
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Länge des Vektors.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected readonly int length
Visual Basic
Protected ReadOnly length As Integer
F#
val length: int

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Vector(T) Methods

[image] [image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Methods
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Vector<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Apply |
Public method | Copy | Gibt eine Kopie des Vectors zurück.
Public method | CopyCell | Gibt eine Kopie der Zelle x zurück.
Public method | Fill | Belegt alle Felder des Vektors mit dem übergebenen Wert.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetSize | Gibt die Größe des Objektes in einer Dimension zurück
Public method | GetValue(Int32) | Ruft den Wert eines Feldes ab.
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.
Public method | GetValueAsObject(Int32) | Ruft den Wert eines Feldes als Objekt ab.
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Apply Method

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..Apply Method
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "M:DynamicNode.Types.Base.Vector`1.Apply(System.Func`2)"]

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void Apply(
    Func transfer
)
Visual Basic
Public Sub Apply ( _
    transfer As Func _
)
F#
member Apply :
        transfer:Func -> unit

Parameters

transfer
Type: System..::..Func<(Of <(<'T, TResult>)>)>

[Missing <param name="transfer"/> documentation for "M:DynamicNode.Types.Base.Vector`1.Apply(System.Func`2)"]

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Copy Method

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..Copy Method
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie des Vectors zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Vector<T> Copy()
Visual Basic
Public Function Copy As Vector(Of T)
F#
member Copy : unit -> Vector<'T>

Return Value

Eine Kopie des Vectors.

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


CopyCell Method

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..CopyCell Method
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Kopie der Zelle x zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Scalar<T> CopyCell(
    int x
)
Visual Basic
Public Function CopyCell ( _
    x As Integer _
) As Scalar(Of T)
F#
member CopyCell :
        x:int -> Scalar<'T>

Parameters

x
Type: System..::..Int32
The x.

Return Value

Die Kopie einer Zelle als Scalar<(Of <(<'T>)>)>

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Fill Method

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..Fill Method
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Belegt alle Felder des Vektors mit dem übergebenen Wert.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void Fill(
    T value
)
Visual Basic
Public Sub Fill ( _
    value As T _
)
F#
member Fill :
        value:'T -> unit

Parameters

value
Type: T
Ein Wert.

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetEnumerator Method

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..GetEnumerator Method
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns an enumerator that iterates through the collection.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of T)
F#
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetSize Method

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..GetSize Method
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Größe des Objektes in einer Dimension zurück

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int GetSize(
    int dimension
)
Visual Basic
Public Function GetSize ( _
    dimension As Integer _
) As Integer
F#
abstract GetSize :
        dimension:int -> int
override GetSize :
        dimension:int -> int

Parameters

dimension
Type: System..::..Int32
Die Dimension (> 0), deren Größe abgefragt werden soll.

Return Value

Eine positive Ganzzahl

Implements

IMDO..::..GetSize(Int32)

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


GetValue Method

[image] [image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..GetValue Method
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetValue(Int32) | Ruft den Wert eines Feldes ab.
Public method | GetValue(array<Int32>[]()[][]) | Gibt den Wert eines Feldes zurück.

See Also

Vector<(Of <(<'T>)>)> Class
Vector<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


GetValue Method (Int32)

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..GetValue Method (Int32)
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T GetValue(
    int index
)
Visual Basic
Public Function GetValue ( _
    index As Integer _
) As T
F#
abstract GetValue :
        index:int -> 'T
override GetValue :
        index:int -> 'T

Parameters

index
Type: System..::..Int32
Die Adresse des Feldes ( 0 <= index < Length)

Return Value

Den Wert eines Feldes

Implements

IVector<(Of <(<'T>)>)>..::..GetValue(Int32)

See Also

Vector<(Of <(<'T>)>)> Class
GetValue Overload
DynamicNode.Types.Base Namespace


GetValue Method (Int32[])

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..GetValue Method (array<Int32>[]()[][])
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert eines Feldes zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T GetValue(
    params int[] addr
)
Visual Basic
Public Function GetValue ( _
    ParamArray addr As Integer() _
) As T
F#
abstract GetValue :
        addr:int[] -> 'T
override GetValue :
        addr:int[] -> 'T

Parameters

addr
Type: array< System..::..Int32 >[]()[][]

Die Adresse des Feldes, wobei jedes Element von addr die Position in einer Dimension angibt.

Ist der übergebene Adressen-Vektor länger als die Anzahl der Dimensionen, können die überschüssigen Adressfelder ignoriert werden.

Ist der übergebene Adress-Vektor kürzer als die Anzahl der Dimensionen, wird für die fehlenden Felder die Adresse 0 angenommen.

Überschreitet die Adresse einer oder mehrerer Dimensionen eine Index-Grenze, muss dennoch ein gültiger Wert zurückgegeben werden.

Return Value

Der Wert eines Feldes

See Also

Vector<(Of <(<'T>)>)> Class
GetValue Overload
DynamicNode.Types.Base Namespace


GetValueAsObject Method

[image] [image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..GetValueAsObject Method
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GetValueAsObject(Int32) | Ruft den Wert eines Feldes als Objekt ab.
Public method | GetValueAsObject(array<Int32>[]()[][]) | Gibt den Wert eines Feldes als Objekt zurück.

See Also

Vector<(Of <(<'T>)>)> Class
Vector<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


GetValueAsObject Method (Int32)

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..GetValueAsObject Method (Int32)
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft den Wert eines Feldes als Objekt ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Object GetValueAsObject(
    int index
)
Visual Basic
Public Function GetValueAsObject ( _
    index As Integer _
) As Object
F#
abstract GetValueAsObject :
        index:int -> Object
override GetValueAsObject :
        index:int -> Object

Parameters

index
Type: System..::..Int32
Die Adresse des Feldes ( 0 <= index < Length)

Return Value

Den Wert eines Feldes

Implements

IVector..::..GetValueAsObject(Int32)

See Also

Vector<(Of <(<'T>)>)> Class
GetValueAsObject Overload
DynamicNode.Types.Base Namespace


GetValueAsObject Method (Int32[])

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..GetValueAsObject Method (array<Int32>[]()[][])
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert eines Feldes als Objekt zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Object GetValueAsObject(
    params int[] addr
)
Visual Basic
Public Function GetValueAsObject ( _
    ParamArray addr As Integer() _
) As Object
F#
abstract GetValueAsObject :
        addr:int[] -> Object
override GetValueAsObject :
        addr:int[] -> Object

Parameters

addr
Type: array< System..::..Int32 >[]()[][]

Die Adresse des Feldes, wobei jedes Element von addr die Position in einer Dimension angibt.

Ist der übergebene Adressen-Vektor länger als die Anzahl der Dimensionen, können die überschüssigen Adressfelder ignoriert werden.

Ist der übergebene Adress-Vektor kürzer als die Anzahl der Dimensionen, wird für die fehlenden Felder die Adresse 0 angenommen.

Überschreitet die Adresse einer oder mehrerer Dimensionen eine Index-Grenze, muss dennoch ein gültiger Wert zurückgegeben werden.

Return Value

Der Wert eines Feldes

Implements

IMDO..::..GetValueAsObject(array<Int32>[]()[][])

See Also

Vector<(Of <(<'T>)>)> Class
GetValueAsObject Overload
DynamicNode.Types.Base Namespace


ToString Method

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..ToString Method
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Vector(T) Type Conversions

[image] [image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Type Conversions
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<T>[]()[][] to Vector<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung von einem verschachtelten nach Matrix<(Of <(<'T>)>)> durch. Diese Umwandlung ist schnell.
ImplicitWideningImplicitImplicitImplicit(Vector<(Of <<'(T>)>>) to array<T>[]()[][]) | Führt eine implizite Umwandlung von einer Matrix<(Of <(<'T>)>)> in ein verschachteltes Array durch. Diese Umwandlung ist schnell.

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Implicit Conversion Operators

[image] [image]

DynamicNodes API
Vector<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion Operators
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<T>[]()[][] to Vector<(Of <<'(T>)>>)) | Führt eine implizite Umwandlung von einem verschachtelten nach Matrix<(Of <(<'T>)>)> durch. Diese Umwandlung ist schnell.
ImplicitWideningImplicitImplicitImplicit(Vector<(Of <<'(T>)>>) to array<T>[]()[][]) | Führt eine implizite Umwandlung von einer Matrix<(Of <(<'T>)>)> in ein verschachteltes Array durch. Diese Umwandlung ist schnell.

See Also

Vector<(Of <(<'T>)>)> Class
Vector<(Of <(<'T>)>)> Members
DynamicNode.Types.Base Namespace


Implicit Conversion (T[] to Vector(T))

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion (array<T>[]()[][] to Vector<(Of <(<'T>)>)>)
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine implizite Umwandlung von einem verschachtelten nach Matrix<(Of <(<'T>)>)> durch. Diese Umwandlung ist schnell.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static implicit operator Vector<T> (
    T[] source
)
Visual Basic
Public Shared Widening Operator CType ( _
    source As T() _
) As Vector(Of T)
F#
F# does not support the declaration of new casting operators.

Parameters

source
Type: array< T >[]()[][]
Ein verschachteltes Array.

Return Value

Das Ergebnis der Umwandlung.

See Also

Vector<(Of <(<'T>)>)> Class
ImplicitWideningImplicitImplicitImplicit Overload
DynamicNode.Types.Base Namespace


Implicit Conversion (Vector(T) to T[])

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion (Vector<(Of <(<'T>)>)> to array<T>[]()[][])
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt eine implizite Umwandlung von einer Matrix<(Of <(<'T>)>)> in ein verschachteltes Array durch. Diese Umwandlung ist schnell.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static implicit operator T[] (
    Vector<T> source
)
Visual Basic
Public Shared Widening Operator CType ( _
    source As Vector(Of T) _
) As T()
F#
F# does not support the declaration of new casting operators.

Parameters

source
Type: DynamicNode.Types.Base..::..Vector <(Of <(<' T >)>)>
Eine Matrix.

Return Value

Das Ergebnis der Umwandlung.

See Also

Vector<(Of <(<'T>)>)> Class
ImplicitWideningImplicitImplicitImplicit Overload
DynamicNode.Types.Base Namespace


Vector(T) Properties

[image] [image]

DynamicNodes API
Vector<(Of <(<'T>)>)> Properties
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Vector<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | DimensionCount | Gibt die Anzahl der verwendeten Dimensionen zurück
Public property | Item | Gibt den Wert einer Vector-Zelle zurück.
Public property | Length | Ruft die Länge des Vektors ab.

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


DimensionCount Property

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..DimensionCount Property
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Anzahl der verwendeten Dimensionen zurück

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int DimensionCount { get; }
Visual Basic
Public ReadOnly Property DimensionCount As Integer
    Get
F#
abstract DimensionCount : int
override DimensionCount : int

Field Value

Die Anzahl der Dimensionen.

Implements

IMDO..::..DimensionCount

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Item Property

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..Item Property
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Wert einer Vector-Zelle zurück.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public T this[
    int x
] { get; set; }
Visual Basic
Public Default Property Item ( _
    x As Integer _
) As T
    Get
    Set
F#
member Item : 'T with get, set

Parameters

x
Type: System..::..Int32
Die Adresse der Zelle. Sie muss im Intervall von 0 bis length - 1 liegen.

Field Value

Ein Elementarwert.

Return Value

Den Wert der Zelle an der Stelle x.

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


Length Property

[image]

DynamicNodes API
Vector<(Of <(<'T>)>)>..::..Length Property
Vector<(Of <(<'T>)>)> Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ruft die Länge des Vektors ab.

Namespace: DynamicNode.Types.Base
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Length { get; }
Visual Basic
Public ReadOnly Property Length As Integer
    Get
F#
abstract Length : int
override Length : int

Field Value

Return Value

Eine Ganzzahl größer gleich 0

Implements

IVector..::..Length

See Also

Vector<(Of <(<'T>)>)> Class
DynamicNode.Types.Base Namespace


DynamicNode.Types.Imaging Namespace

[image]

DynamicNodes API
DynamicNode.Types.Imaging Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält eine Anzahl von Datentypen für die Bildverarbeitung mit Flussgraphen.

Classes

 | Class | Description
Public class | ARGBImage | Ein spezielles Tupel mit vier Elementen zur Aufnahme von Alpha-, Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp Byte.
Public class | ARGBImage16 | Ein spezielles Tupel mit vier Elementen zur Aufnahme von Alpha-, Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp UInt16.
Public class | ARGBImage32 | Ein spezielles Tupel mit vier Elementen zur Aufnahme von Alpha-, Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp Single.
Public class | ChromaticAdaption | Definiert einen Algorithmus zur chromatischen Anpassung eines Farbsystems an einen abweichenden Weißpunkt.
Public class | ColorTools | Bietet Hilfsmethoden für die Arbeit mit Farben und Bildern.
Public class | GammaCompanding | Diese Klasse repräsentiert eine Gammaverteilung.
Public class | KernelPyramid | Die Kernel-Pyramide berechnet verkleinerte Größen eines Ur-Kernels bis zu 1x1 zur Verfügung. Dabei ist es möglich einen Cache für eine definierte Anzahl von Zwischengrößen zur Optimierung zu verwenden.
Public class | LabImage32 | Ein spezielles Tupel mit drei Elementen zur Aufnahme von L-, a- und b-Kanälen eines geräteunabhängigen Farbbildes mit dem elementaren Datentyp Single.
Public class | LCHImage32 | Ein spezielles Tupel mit drei Elementen zur Aufnahme von L-, C- und H-Kanälen eines geräteunabhängigen LCH(ab)-Farbbildes mit dem elementaren Datentyp Single.
Public class | RgbColorSpace | Repräsentiert einen geräteabhängigen RGB-Farbraum oder einen RGB-Arbeitsfarbraum. Ein RGB-Farbraum setzt sich aus einem Weißpunkt, den xyY-Referenzpunkten von Rot, Grün und Blau und einer Gammaverteilung für die Speicherung in Ganzzahlen (8Bit o. 16Bit) zusammen. Ein RGB-Arbeitsfarbraum kann verwendet werden, um geräteabhängige RGB-Werte (ColorValue_RGB) in geräteunabhängige XYZ-Werte (ColorValue_XYZ) konvertiert werden und umgekehrt.
Public class | RGBImage | Ein spezielles Tupel mit drei Elementen zur Aufnahme von Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp Byte.
Public class | RGBImage16 | Ein spezielles Tupel mit drei Elementen zur Aufnahme von Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp Int16.
Public class | RGBImage32 | Ein spezielles Tupel mit drei Elementen zur Aufnahme von Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp Single.
Public class | SpeedTransfer | Eine Klasse, die eine TransferFunction mit einer Lookup-Tabelle und linearer Interpolation optimiert.
Public class | Whitepoint | Diese Klasse beschreibt einen Weißpunkt als Referenz für ein Farbmodell.
Public class | XYZImage32 | Ein spezielles Tupel mit drei Elementen zur Aufnahme von X-, Y- und Z-Kanälen eines geräteunabhängigen Farbbildes mit dem elementaren Datentyp Single.

Structures

 | Structure | Description
Public structure | ColorValue_Lab | Ein geräteunabhäniger L*a*b*-Farbwert.
Public structure | ColorValue_LCH | Ein geräteunabhäniger LCH(ab)-Farbwert.
Public structure | ColorValue_RGB | Ein geräteabhäniger RGB-Farbwert.
Public structure | ColorValue_xyY | Ein geräteunabhängiger Farbwert im xyY-Farbmodell (Normtafel des CIE-Farbsystems).
Public structure | ColorValue_XYZ | Ein geräteunabhängiger Farbwert im CIE-XYZ-Farbraum.

Interfaces

 | Interface | Description
Public interface | IRGBImage | Eine gemeinsame Schnittstelle für Farbbilder in einem geräteabhängigem RGB-Farbmodell.

Delegates

 | Delegate | Description
Public delegate | GammaTransferFunction | Der Delegat für eine Gamma-Transfer- und eine Gamma-Umkehrfunktion.
Public delegate | TransferFunction | Ein Delegat für Transferfunktionen.

Enumerations

 | Enumeration | Description
Public enumeration | BitDepth | Eine Aufzählung mit typischen Bit-Tiefen für Bilder.
Public enumeration | ChromaticAdaptionMethod | Die verfügbaren Methoden für eine chromatische Anpassung.
Public enumeration | GammaCompandingName | Eine Aufzählung der Namen von standardisierten Gammaverteilungen.
Public enumeration | KernelNormalization | Eine Aufzählung mit Normierungsmethoden für einen Kernel.
Public enumeration | RgbColorSpaceName | Eine Aufzählung mit den Namen der bekannten Farbräumen.
Public enumeration | WhitePointName | Eine Aufzählung der Namen von Standard-Weißpunkten.


ARGBImage Class

[image]

DynamicNodes API
ARGBImage Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein spezielles Tupel mit vier Elementen zur Aufnahme von Alpha-, Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp Byte.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class ARGBImage : RGBImage
Visual Basic
<SerializableAttribute> _
Public Class ARGBImage _
    Inherits RGBImage
F#
[<SerializableAttribute>]
type ARGBImage =
    class
        inherit RGBImage
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Tupel <(Of <(<' Matrix <(Of <(<' Byte >)>)>>)>)>
DynamicNode.Types.Imaging..::..RGBImage
DynamicNode.Types.Imaging..::..ARGBImage

See Also

ARGBImage Members
DynamicNode.Types.Imaging Namespace


ARGBImage Members

[image] [image]

DynamicNodes API
ARGBImage Members
ARGBImage Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ARGBImage type exposes the following members.

Constructors

 | Name | Description
Public method | ARGBImage(Bitmap) | Initialisiert eine neue Instanz von ARGBImage-Klasse mit Hilfe eines Bitmap-Objektes.
Public method | ARGBImage(Int32, Int32, Byte) | Initialisiert eine neue Instanz der ARGBImage-Klasse.
Public method | ARGBImage(Matrix<(Of <<'(Byte>)>>), Matrix<(Of <<'(Byte>)>>), Matrix<(Of <<'(Byte>)>>), Matrix<(Of <<'(Byte>)>>)) | Initialisiert eine neue Instanz von ARGBImage-Klasse mit Hilfe von vier Matrizen für die Farbkanäle.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe. (Overrides RGBImage..::..Initialize(Int32, Int32).)
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides RGBImage..::..ToString()()()().)

Properties

 | Name | Description
Public property | A | Gibt den Transparenz-Kanal zurück.
Public property | B | Gibt den Blau-Kanal zurück. (Inherited from RGBImage.)
Public property | G | Gibt den Grün-Kanal zurück. (Inherited from RGBImage.)
Public property | Height | Gibt die Höhe des Bildes zurück. (Inherited from RGBImage.)
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist. (Overrides RGBImage..::..IsInitialized.)
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest. (Inherited from RGBImage.)
Public property | R | Gibt den Rot-Kanal zurück. (Inherited from RGBImage.)
Public property | Width | Gibt die Breite des Bildes zurück. (Inherited from RGBImage.)

See Also

ARGBImage Class
DynamicNode.Types.Imaging Namespace


ARGBImage Constructor

[image] [image]

DynamicNodes API
ARGBImage Constructor
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ARGBImage(Bitmap) | Initialisiert eine neue Instanz von ARGBImage-Klasse mit Hilfe eines Bitmap-Objektes.
Public method | ARGBImage(Int32, Int32, Byte) | Initialisiert eine neue Instanz der ARGBImage-Klasse.
Public method | ARGBImage(Matrix<(Of <<'(Byte>)>>), Matrix<(Of <<'(Byte>)>>), Matrix<(Of <<'(Byte>)>>), Matrix<(Of <<'(Byte>)>>)) | Initialisiert eine neue Instanz von ARGBImage-Klasse mit Hilfe von vier Matrizen für die Farbkanäle.

See Also

ARGBImage Class
ARGBImage Members
DynamicNode.Types.Imaging Namespace


ARGBImage Constructor (Bitmap)

[image]

DynamicNodes API
ARGBImage Constructor (Bitmap)
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ARGBImage-Klasse mit Hilfe eines Bitmap-Objektes.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ARGBImage(
    Bitmap bitmap
)
Visual Basic
Public Sub New ( _
    bitmap As Bitmap _
)
F#
new :
        bitmap:Bitmap -> ARGBImage

Parameters

bitmap
Type: System.Drawing..::..Bitmap
Ein 32bpp-ARGB-Bitmap-Objekt.

See Also

ARGBImage Class
ARGBImage Overload
DynamicNode.Types.Imaging Namespace


ARGBImage Constructor (Int32, Int32, Byte)

[image]

DynamicNodes API
ARGBImage Constructor (Int32, Int32, Byte)
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der ARGBImage-Klasse.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ARGBImage(
    int width,
    int height,
    byte defValue
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    defValue As Byte _
)
F#
new :
        width:int *
        height:int *
        defValue:byte -> ARGBImage

Parameters

width
Type: System..::..Int32
Die Breite.
height
Type: System..::..Int32
Die Höhe.
defValue
Type: System..::..Byte
Der Standardwert für Indexüberschreitungen.

See Also

ARGBImage Class
ARGBImage Overload
DynamicNode.Types.Imaging Namespace


ARGBImage Constructor (Matrix(Byte), Matrix(Byte), Matrix(Byte), Matrix(Byte))

[image]

DynamicNodes API
ARGBImage Constructor (Matrix<(Of <(<'Byte>)>)>, Matrix<(Of <(<'Byte>)>)>, Matrix<(Of <(<'Byte>)>)>, Matrix<(Of <(<'Byte>)>)>)
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ARGBImage-Klasse mit Hilfe von vier Matrizen für die Farbkanäle.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ARGBImage(
    Matrix<byte> a,
    Matrix<byte> r,
    Matrix<byte> g,
    Matrix<byte> b
)
Visual Basic
Public Sub New ( _
    a As Matrix(Of Byte), _
    r As Matrix(Of Byte), _
    g As Matrix(Of Byte), _
    b As Matrix(Of Byte) _
)
F#
new :
        a:Matrix<byte> *
        r:Matrix<byte> *
        g:Matrix<byte> *
        b:Matrix<byte> -> ARGBImage

Parameters

a
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Der Transparenz-Kanal.
r
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Der Rot-Kanal.
g
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Der Grün-Kanal.
b
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Der Blau-Kanal.

See Also

ARGBImage Class
ARGBImage Overload
DynamicNode.Types.Imaging Namespace


ARGBImage Methods

[image] [image]

DynamicNodes API
ARGBImage Methods
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ARGBImage type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe. (Overrides RGBImage..::..Initialize(Int32, Int32).)
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides RGBImage..::..ToString()()()().)

See Also

ARGBImage Class
DynamicNode.Types.Imaging Namespace


Initialize Method

[image]

DynamicNodes API
ARGBImage..::..Initialize Method
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert das Bild mit der angegebenen Größe.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override void Initialize(
    int width,
    int height
)
Visual Basic
Public Overrides Sub Initialize ( _
    width As Integer, _
    height As Integer _
)
F#
abstract Initialize :
        width:int *
        height:int -> unit
override Initialize :
        width:int *
        height:int -> unit

Parameters

width
Type: System..::..Int32
Die Breite des Bildes
height
Type: System..::..Int32
Die Höhe des Bildes

Implements

IRGBImage..::..Initialize(Int32, Int32)

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width oder height ein Wert kleiner 0 übergeben wird.

See Also

ARGBImage Class
DynamicNode.Types.Imaging Namespace


ToBitmap Method

[image]

DynamicNodes API
ARGBImage..::..ToBitmap Method
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Bitmap-Objekt aus der Matrix.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Bitmap ToBitmap()
Visual Basic
Public Function ToBitmap As Bitmap
F#
member ToBitmap : unit -> Bitmap

Return Value

Ein 32bpp-ARGB-Bitmap-Objekt.

See Also

ARGBImage Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
ARGBImage..::..ToString Method
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

ARGBImage Class
DynamicNode.Types.Imaging Namespace


ARGBImage Properties

[image] [image]

DynamicNodes API
ARGBImage Properties
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ARGBImage type exposes the following members.

Properties

 | Name | Description
Public property | A | Gibt den Transparenz-Kanal zurück.
Public property | B | Gibt den Blau-Kanal zurück. (Inherited from RGBImage.)
Public property | G | Gibt den Grün-Kanal zurück. (Inherited from RGBImage.)
Public property | Height | Gibt die Höhe des Bildes zurück. (Inherited from RGBImage.)
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist. (Overrides RGBImage..::..IsInitialized.)
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest. (Inherited from RGBImage.)
Public property | R | Gibt den Rot-Kanal zurück. (Inherited from RGBImage.)
Public property | Width | Gibt die Breite des Bildes zurück. (Inherited from RGBImage.)

See Also

ARGBImage Class
DynamicNode.Types.Imaging Namespace


A Property

[image]

DynamicNodes API
ARGBImage..::..A Property
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Transparenz-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<byte> A { get; protected set; }
Visual Basic
Public Property A As Matrix(Of Byte)
    Get
    Protected Set
F#
member A : Matrix<byte> with get, set

Field Value

Der Tranzparenz-Kanal.

See Also

ARGBImage Class
DynamicNode.Types.Imaging Namespace


IsInitialized Property

[image]

DynamicNodes API
ARGBImage..::..IsInitialized Property
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override bool IsInitialized { get; }
Visual Basic
Public Overrides ReadOnly Property IsInitialized As Boolean
    Get
F#
abstract IsInitialized : bool
override IsInitialized : bool

Implements

IRGBImage..::..IsInitialized

See Also

ARGBImage Class
DynamicNode.Types.Imaging Namespace


Item Property

[image] [image]

DynamicNodes API
ARGBImage..::..Item Property
ARGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest. (Inherited from RGBImage.)

See Also

ARGBImage Class
ARGBImage Members
DynamicNode.Types.Imaging Namespace


ARGBImage16 Class

[image]

DynamicNodes API
ARGBImage16 Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein spezielles Tupel mit vier Elementen zur Aufnahme von Alpha-, Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp UInt16.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class ARGBImage16 : RGBImage16
Visual Basic
<SerializableAttribute> _
Public Class ARGBImage16 _
    Inherits RGBImage16
F#
[<SerializableAttribute>]
type ARGBImage16 =
    class
        inherit RGBImage16
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Tupel <(Of <(<' Matrix <(Of <(<' UInt16 >)>)>>)>)>
DynamicNode.Types.Imaging..::..RGBImage16
DynamicNode.Types.Imaging..::..ARGBImage16

See Also

ARGBImage16 Members
DynamicNode.Types.Imaging Namespace


ARGBImage16 Members

[image] [image]

DynamicNodes API
ARGBImage16 Members
ARGBImage16 Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ARGBImage16 type exposes the following members.

Constructors

 | Name | Description
Public method | ARGBImage16(Bitmap) | Initialisiert eine neue Instanz von ARGBImage16-Klasse mit Hilfe eines Bitmap-Objektes.
Public method | ARGBImage16(Int32, Int32, UInt16) | Initialisiert eine neue Instanz der ARGBImage-Klasse.
Public method | ARGBImage16(Matrix<(Of <<'(UInt16>)>>), Matrix<(Of <<'(UInt16>)>>), Matrix<(Of <<'(UInt16>)>>), Matrix<(Of <<'(UInt16>)>>)) | Initialisiert eine neue Instanz von ARGBImage16-Klasse mit Hilfe von vier Matrizen für die Farbkanäle.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe. (Overrides RGBImage16..::..Initialize(Int32, Int32).)
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides RGBImage16..::..ToString()()()().)

Properties

 | Name | Description
Public property | A | Gibt den Transparenz-Kanal zurück.
Public property | B | Gibt den Blau-Kanal zurück. (Inherited from RGBImage16.)
Public property | G | Gibt den Grün-Kanal zurück. (Inherited from RGBImage16.)
Public property | Height | Gibt die Höhe des Bildes zurück. (Inherited from RGBImage16.)
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist. (Overrides RGBImage16..::..IsInitialized.)
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest. (Inherited from RGBImage16.)
Public property | R | Gibt den Rot-Kanal zurück. (Inherited from RGBImage16.)
Public property | Width | Gibt die Breite des Bildes zurück. (Inherited from RGBImage16.)

See Also

ARGBImage16 Class
DynamicNode.Types.Imaging Namespace


ARGBImage16 Constructor

[image] [image]

DynamicNodes API
ARGBImage16 Constructor
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ARGBImage16(Bitmap) | Initialisiert eine neue Instanz von ARGBImage16-Klasse mit Hilfe eines Bitmap-Objektes.
Public method | ARGBImage16(Int32, Int32, UInt16) | Initialisiert eine neue Instanz der ARGBImage-Klasse.
Public method | ARGBImage16(Matrix<(Of <<'(UInt16>)>>), Matrix<(Of <<'(UInt16>)>>), Matrix<(Of <<'(UInt16>)>>), Matrix<(Of <<'(UInt16>)>>)) | Initialisiert eine neue Instanz von ARGBImage16-Klasse mit Hilfe von vier Matrizen für die Farbkanäle.

See Also

ARGBImage16 Class
ARGBImage16 Members
DynamicNode.Types.Imaging Namespace


ARGBImage16 Constructor (Bitmap)

[image]

DynamicNodes API
ARGBImage16 Constructor (Bitmap)
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ARGBImage16-Klasse mit Hilfe eines Bitmap-Objektes.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ARGBImage16(
    Bitmap bitmap
)
Visual Basic
Public Sub New ( _
    bitmap As Bitmap _
)
F#
new :
        bitmap:Bitmap -> ARGBImage16

Parameters

bitmap
Type: System.Drawing..::..Bitmap
Ein 32pbb-ARGB-Bitmap-Objekt.

See Also

ARGBImage16 Class
ARGBImage16 Overload
DynamicNode.Types.Imaging Namespace


ARGBImage16 Constructor (Int32, Int32, UInt16)

[image]

DynamicNodes API
ARGBImage16 Constructor (Int32, Int32, UInt16)
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der ARGBImage-Klasse.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ARGBImage16(
    int width,
    int height,
    ushort defValue
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    defValue As UShort _
)
F#
new :
        width:int *
        height:int *
        defValue:uint16 -> ARGBImage16

Parameters

width
Type: System..::..Int32
Die Breite.
height
Type: System..::..Int32
Die Höhe.
defValue
Type: System..::..UInt16
Der Standardwert für Indexüberschreitungen.

See Also

ARGBImage16 Class
ARGBImage16 Overload
DynamicNode.Types.Imaging Namespace


ARGBImage16 Constructor (Matrix(UInt16), Matrix(UInt16), Matrix(UInt16), Matrix(UInt16))

[image]

DynamicNodes API
ARGBImage16 Constructor (Matrix<(Of <(<'UInt16>)>)>, Matrix<(Of <(<'UInt16>)>)>, Matrix<(Of <(<'UInt16>)>)>, Matrix<(Of <(<'UInt16>)>)>)
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ARGBImage16-Klasse mit Hilfe von vier Matrizen für die Farbkanäle.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ARGBImage16(
    Matrix<ushort> a,
    Matrix<ushort> r,
    Matrix<ushort> g,
    Matrix<ushort> b
)
Visual Basic
Public Sub New ( _
    a As Matrix(Of UShort), _
    r As Matrix(Of UShort), _
    g As Matrix(Of UShort), _
    b As Matrix(Of UShort) _
)
F#
new :
        a:Matrix<uint16> *
        r:Matrix<uint16> *
        g:Matrix<uint16> *
        b:Matrix<uint16> -> ARGBImage16

Parameters

a
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Der Transparenz-Kanal.
r
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Der Rot-Kanal.
g
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Der Grün-Kanal.
b
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Der Blau-Kanal.

See Also

ARGBImage16 Class
ARGBImage16 Overload
DynamicNode.Types.Imaging Namespace


ARGBImage16 Methods

[image] [image]

DynamicNodes API
ARGBImage16 Methods
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ARGBImage16 type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe. (Overrides RGBImage16..::..Initialize(Int32, Int32).)
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides RGBImage16..::..ToString()()()().)

See Also

ARGBImage16 Class
DynamicNode.Types.Imaging Namespace


Initialize Method

[image]

DynamicNodes API
ARGBImage16..::..Initialize Method
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert das Bild mit der angegebenen Größe.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override void Initialize(
    int width,
    int height
)
Visual Basic
Public Overrides Sub Initialize ( _
    width As Integer, _
    height As Integer _
)
F#
abstract Initialize :
        width:int *
        height:int -> unit
override Initialize :
        width:int *
        height:int -> unit

Parameters

width
Type: System..::..Int32
Die Breite des Bildes
height
Type: System..::..Int32
Die Höhe des Bildes

Implements

IRGBImage..::..Initialize(Int32, Int32)

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width oder height ein Wert kleiner 0 übergeben wird.

See Also

ARGBImage16 Class
DynamicNode.Types.Imaging Namespace


ToBitmap Method

[image]

DynamicNodes API
ARGBImage16..::..ToBitmap Method
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Bitmap-Objekt aus der Matrix.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Bitmap ToBitmap()
Visual Basic
Public Function ToBitmap As Bitmap
F#
member ToBitmap : unit -> Bitmap

Return Value

Ein 32bpp-ARGB-Bitmap-Objekt.

See Also

ARGBImage16 Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
ARGBImage16..::..ToString Method
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

ARGBImage16 Class
DynamicNode.Types.Imaging Namespace


ARGBImage16 Properties

[image] [image]

DynamicNodes API
ARGBImage16 Properties
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ARGBImage16 type exposes the following members.

Properties

 | Name | Description
Public property | A | Gibt den Transparenz-Kanal zurück.
Public property | B | Gibt den Blau-Kanal zurück. (Inherited from RGBImage16.)
Public property | G | Gibt den Grün-Kanal zurück. (Inherited from RGBImage16.)
Public property | Height | Gibt die Höhe des Bildes zurück. (Inherited from RGBImage16.)
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist. (Overrides RGBImage16..::..IsInitialized.)
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest. (Inherited from RGBImage16.)
Public property | R | Gibt den Rot-Kanal zurück. (Inherited from RGBImage16.)
Public property | Width | Gibt die Breite des Bildes zurück. (Inherited from RGBImage16.)

See Also

ARGBImage16 Class
DynamicNode.Types.Imaging Namespace


A Property

[image]

DynamicNodes API
ARGBImage16..::..A Property
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Transparenz-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<ushort> A { get; protected set; }
Visual Basic
Public Property A As Matrix(Of UShort)
    Get
    Protected Set
F#
member A : Matrix<uint16> with get, set

Field Value

Der Transparenz-Kanal.

See Also

ARGBImage16 Class
DynamicNode.Types.Imaging Namespace


IsInitialized Property

[image]

DynamicNodes API
ARGBImage16..::..IsInitialized Property
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override bool IsInitialized { get; }
Visual Basic
Public Overrides ReadOnly Property IsInitialized As Boolean
    Get
F#
abstract IsInitialized : bool
override IsInitialized : bool

Implements

IRGBImage..::..IsInitialized

See Also

ARGBImage16 Class
DynamicNode.Types.Imaging Namespace


Item Property

[image] [image]

DynamicNodes API
ARGBImage16..::..Item Property
ARGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest. (Inherited from RGBImage16.)

See Also

ARGBImage16 Class
ARGBImage16 Members
DynamicNode.Types.Imaging Namespace


ARGBImage32 Class

[image]

DynamicNodes API
ARGBImage32 Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein spezielles Tupel mit vier Elementen zur Aufnahme von Alpha-, Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp Single.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class ARGBImage32 : RGBImage32
Visual Basic
<SerializableAttribute> _
Public Class ARGBImage32 _
    Inherits RGBImage32
F#
[<SerializableAttribute>]
type ARGBImage32 =
    class
        inherit RGBImage32
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Tupel <(Of <(<' Matrix <(Of <(<' Single >)>)>>)>)>
DynamicNode.Types.Imaging..::..RGBImage32
DynamicNode.Types.Imaging..::..ARGBImage32

See Also

ARGBImage32 Members
DynamicNode.Types.Imaging Namespace


ARGBImage32 Members

[image] [image]

DynamicNodes API
ARGBImage32 Members
ARGBImage32 Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ARGBImage32 type exposes the following members.

Constructors

 | Name | Description
Public method | ARGBImage32(Int32, Int32, Single) | Initialisiert eine neue Instanz der ARGBImage-Klasse.
Public method | ARGBImage32(Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>)) | Initialisiert eine neue Instanz von ARGBImage16-Klasse mit Hilfe von vier Matrizen für die Farbkanäle.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe. (Overrides RGBImage32..::..Initialize(Int32, Int32).)
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides RGBImage32..::..ToString()()()().)

Properties

 | Name | Description
Public property | A | Gibt den Transparenz-Kanal zurück.
Public property | B | Gibt den Blau-Kanal zurück. (Inherited from RGBImage32.)
Public property | G | Gibt den Grün-Kanal zurück. (Inherited from RGBImage32.)
Public property | Height | Gibt die Höhe des Bildes zurück. (Inherited from RGBImage32.)
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist. (Overrides RGBImage32..::..IsInitialized.)
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest. (Inherited from RGBImage32.)
Public property | R | Gibt den Rot-Kanal zurück. (Inherited from RGBImage32.)
Public property | Width | Gibt die Breite des Bildes zurück. (Inherited from RGBImage32.)

See Also

ARGBImage32 Class
DynamicNode.Types.Imaging Namespace


ARGBImage32 Constructor

[image] [image]

DynamicNodes API
ARGBImage32 Constructor
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ARGBImage32(Int32, Int32, Single) | Initialisiert eine neue Instanz der ARGBImage-Klasse.
Public method | ARGBImage32(Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>)) | Initialisiert eine neue Instanz von ARGBImage16-Klasse mit Hilfe von vier Matrizen für die Farbkanäle.

See Also

ARGBImage32 Class
ARGBImage32 Members
DynamicNode.Types.Imaging Namespace


ARGBImage32 Constructor (Int32, Int32, Single)

[image]

DynamicNodes API
ARGBImage32 Constructor (Int32, Int32, Single)
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der ARGBImage-Klasse.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ARGBImage32(
    int width,
    int height,
    float defValue
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    defValue As Single _
)
F#
new :
        width:int *
        height:int *
        defValue:float32 -> ARGBImage32

Parameters

width
Type: System..::..Int32
Die Breite.
height
Type: System..::..Int32
Die Höhe.
defValue
Type: System..::..Single
Der Standardwert für Indexüberschreitungen.

See Also

ARGBImage32 Class
ARGBImage32 Overload
DynamicNode.Types.Imaging Namespace


ARGBImage32 Constructor (Matrix(Single), Matrix(Single), Matrix(Single), Matrix(Single))

[image]

DynamicNodes API
ARGBImage32 Constructor (Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>)
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von ARGBImage16-Klasse mit Hilfe von vier Matrizen für die Farbkanäle.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ARGBImage32(
    Matrix<float> a,
    Matrix<float> r,
    Matrix<float> g,
    Matrix<float> b
)
Visual Basic
Public Sub New ( _
    a As Matrix(Of Single), _
    r As Matrix(Of Single), _
    g As Matrix(Of Single), _
    b As Matrix(Of Single) _
)
F#
new :
        a:Matrix<float32> *
        r:Matrix<float32> *
        g:Matrix<float32> *
        b:Matrix<float32> -> ARGBImage32

Parameters

a
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der Transparenz-Kanal.
r
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der Rot-Kanal.
g
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der Grün-Kanal.
b
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der Blau-Kanal.

See Also

ARGBImage32 Class
ARGBImage32 Overload
DynamicNode.Types.Imaging Namespace


ARGBImage32 Methods

[image] [image]

DynamicNodes API
ARGBImage32 Methods
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ARGBImage32 type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe. (Overrides RGBImage32..::..Initialize(Int32, Int32).)
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides RGBImage32..::..ToString()()()().)

See Also

ARGBImage32 Class
DynamicNode.Types.Imaging Namespace


Initialize Method

[image]

DynamicNodes API
ARGBImage32..::..Initialize Method
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert das Bild mit der angegebenen Größe.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override void Initialize(
    int width,
    int height
)
Visual Basic
Public Overrides Sub Initialize ( _
    width As Integer, _
    height As Integer _
)
F#
abstract Initialize :
        width:int *
        height:int -> unit
override Initialize :
        width:int *
        height:int -> unit

Parameters

width
Type: System..::..Int32
Die Breite des Bildes
height
Type: System..::..Int32
Die Höhe des Bildes

Implements

IRGBImage..::..Initialize(Int32, Int32)

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width oder height ein Wert kleiner 0 übergeben wird.

See Also

ARGBImage32 Class
DynamicNode.Types.Imaging Namespace


ToBitmap Method

[image]

DynamicNodes API
ARGBImage32..::..ToBitmap Method
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Bitmap-Objekt aus der Matrix.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Bitmap ToBitmap()
Visual Basic
Public Function ToBitmap As Bitmap
F#
member ToBitmap : unit -> Bitmap

Return Value

Ein 24bpp RGB-Bitmap-Objekt.

See Also

ARGBImage32 Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
ARGBImage32..::..ToString Method
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

ARGBImage32 Class
DynamicNode.Types.Imaging Namespace


ARGBImage32 Properties

[image] [image]

DynamicNodes API
ARGBImage32 Properties
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ARGBImage32 type exposes the following members.

Properties

 | Name | Description
Public property | A | Gibt den Transparenz-Kanal zurück.
Public property | B | Gibt den Blau-Kanal zurück. (Inherited from RGBImage32.)
Public property | G | Gibt den Grün-Kanal zurück. (Inherited from RGBImage32.)
Public property | Height | Gibt die Höhe des Bildes zurück. (Inherited from RGBImage32.)
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist. (Overrides RGBImage32..::..IsInitialized.)
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest. (Inherited from RGBImage32.)
Public property | R | Gibt den Rot-Kanal zurück. (Inherited from RGBImage32.)
Public property | Width | Gibt die Breite des Bildes zurück. (Inherited from RGBImage32.)

See Also

ARGBImage32 Class
DynamicNode.Types.Imaging Namespace


A Property

[image]

DynamicNodes API
ARGBImage32..::..A Property
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Transparenz-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> A { get; protected set; }
Visual Basic
Public Property A As Matrix(Of Single)
    Get
    Protected Set
F#
member A : Matrix<float32> with get, set

Field Value

Der Transparenz-Kanal.

See Also

ARGBImage32 Class
DynamicNode.Types.Imaging Namespace


IsInitialized Property

[image]

DynamicNodes API
ARGBImage32..::..IsInitialized Property
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override bool IsInitialized { get; }
Visual Basic
Public Overrides ReadOnly Property IsInitialized As Boolean
    Get
F#
abstract IsInitialized : bool
override IsInitialized : bool

Implements

IRGBImage..::..IsInitialized

See Also

ARGBImage32 Class
DynamicNode.Types.Imaging Namespace


Item Property

[image] [image]

DynamicNodes API
ARGBImage32..::..Item Property
ARGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest. (Inherited from RGBImage32.)

See Also

ARGBImage32 Class
ARGBImage32 Members
DynamicNode.Types.Imaging Namespace


BitDepth Enumeration

[image]

DynamicNodes API
BitDepth Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Aufzählung mit typischen Bit-Tiefen für Bilder.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public enum BitDepth
Visual Basic
Public Enumeration BitDepth
F#
type BitDepth

Members

Member name | Description
Low8Bit |
Mid16Bit |
High32BitFloat |

See Also

DynamicNode.Types.Imaging Namespace


ChromaticAdaption Class

[image]

DynamicNodes API
ChromaticAdaption Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Definiert einen Algorithmus zur chromatischen Anpassung eines Farbsystems an einen abweichenden Weißpunkt.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public class ChromaticAdaption
Visual Basic
Public Class ChromaticAdaption
F#
type ChromaticAdaption =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Imaging..::..ChromaticAdaption

See Also

ChromaticAdaption Members
DynamicNode.Types.Imaging Namespace


ChromaticAdaption Members

[image] [image]

DynamicNodes API
ChromaticAdaption Members
ChromaticAdaption Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ChromaticAdaption type exposes the following members.

Constructors

 | Name | Description
Public method | ChromaticAdaption | Initialisiert eine neue Instanz der Klasse ChromaticAdaption.

Methods

 | Name | Description
Public method | Apply | Wandelt geräteunabhängige XYZ-Farbwerte von einem Referenzweiß in ein anderes.

See Also

ChromaticAdaption Class
DynamicNode.Types.Imaging Namespace


ChromaticAdaption Constructor

[image]

DynamicNodes API
ChromaticAdaption Constructor
ChromaticAdaption Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse ChromaticAdaption.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ChromaticAdaption(
    ChromaticAdaptionMethod method,
    Whitepoint from,
    Whitepoint to
)
Visual Basic
Public Sub New ( _
    method As ChromaticAdaptionMethod, _
    from As Whitepoint, _
    to As Whitepoint _
)
F#
new :
        method:ChromaticAdaptionMethod *
        from:Whitepoint *
        to:Whitepoint -> ChromaticAdaption

Parameters

method
Type: DynamicNode.Types.Imaging..::..ChromaticAdaptionMethod
Die Methode, die zur Berechnung verwendet werden soll.
from
Type: DynamicNode.Types.Imaging..::..Whitepoint
Der aktuelle Weißpunkt des Farbsystems.
to
Type: DynamicNode.Types.Imaging..::..Whitepoint
Der Zielweißpunkt.

See Also

ChromaticAdaption Class
DynamicNode.Types.Imaging Namespace


ChromaticAdaption Methods

[image] [image]

DynamicNodes API
ChromaticAdaption Methods
ChromaticAdaption Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ChromaticAdaption type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Wandelt geräteunabhängige XYZ-Farbwerte von einem Referenzweiß in ein anderes.

See Also

ChromaticAdaption Class
DynamicNode.Types.Imaging Namespace


Apply Method

[image]

DynamicNodes API
ChromaticAdaption..::..Apply Method
ChromaticAdaption Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt geräteunabhängige XYZ-Farbwerte von einem Referenzweiß in ein anderes.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_XYZ Apply(
    ColorValue_XYZ v
)
Visual Basic
Public Function Apply ( _
    v As ColorValue_XYZ _
) As ColorValue_XYZ
F#
member Apply :
        v:ColorValue_XYZ -> ColorValue_XYZ

Parameters

v
Type: DynamicNode.Types.Imaging..::..ColorValue_XYZ
Der Farbwert.

Return Value

Den angepassten Farbwert.

See Also

ChromaticAdaption Class
DynamicNode.Types.Imaging Namespace


ChromaticAdaptionMethod Enumeration

[image]

DynamicNodes API
ChromaticAdaptionMethod Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die verfügbaren Methoden für eine chromatische Anpassung.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public enum ChromaticAdaptionMethod
Visual Basic
Public Enumeration ChromaticAdaptionMethod
F#
type ChromaticAdaptionMethod

Members

Member name | Description
XYZ_Scaling |
Bradford |
VonKries |

See Also

DynamicNode.Types.Imaging Namespace


ColorTools Class

[image]

DynamicNodes API
ColorTools Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bietet Hilfsmethoden für die Arbeit mit Farben und Bildern.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static class ColorTools
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class ColorTools
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ColorTools =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Imaging..::..ColorTools

See Also

ColorTools Members
DynamicNode.Types.Imaging Namespace


ColorTools Members

[image] [image]

DynamicNodes API
ColorTools Members
ColorTools Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorTools type exposes the following members.

Methods

Name | Description
BitmapFromMatrix(Matrix<(Of <<'(Byte>)>>)) | Erzeugt ein Graustufen-Bitmap aus einer Byte-Matrix.
BitmapFromMatrix(Matrix<(Of <<'(Single>)>>)) | Erzeugt ein Graustufen-Bitmap aus einer Single-Matrix.
BitmapFromMatrix(Matrix<(Of <<'(UInt16>)>>)) | Erzeugt ein Graustufen-Bitmap aus einer UInt16-Matrix.
BuildMean | Bildet einen Mittelwert für die quadratische Umgebung eines Pixels.
BuildMedian | Bildet einen Median für die quadratische Umgebung eines Pixels.
DrawGradient | Zeichnet einen mehrstufigen Farbverlauf.
GetARGBType | Gibt für die gegebene Genauigkeit einen passenden ARGB-Bildtyp zurück.
GetColorValue(Matrix<(Of <<'(Byte>)>>), Int32, Int32) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.
GetColorValue(Matrix<(Of <<'(Single>)>>), Int32, Int32) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.
GetColorValue(Matrix<(Of <<'(UInt16>)>>), Int32, Int32) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.
GetElementType | Gibt für die gegebene Genauigkeit einen passenden elementaren Datentyp zurück.
GetMatrixType | Gibt für die gegebene Genauigkeit einen passenden Matrix<(Of <(<'T>)>)>-Typ zurück.
GetRGBType | Gibt für die gegebene Genauigkeit einen passenden RGB-Bildtyp zurück.
MatrixFromBitmap | Erzeugt eine Matrix aus einem Graustufen-Bitmap.
SetColorValue(Matrix<(Of <<'(Byte>)>>), Int32, Int32, Single) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.
SetColorValue(Matrix<(Of <<'(Single>)>>), Int32, Int32, Single) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.
SetColorValue(Matrix<(Of <<'(UInt16>)>>), Int32, Int32, Single) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.

See Also

ColorTools Class
DynamicNode.Types.Imaging Namespace


ColorTools Methods

[image] [image]

DynamicNodes API
ColorTools Methods
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorTools type exposes the following members.

Methods

Name | Description
BitmapFromMatrix(Matrix<(Of <<'(Byte>)>>)) | Erzeugt ein Graustufen-Bitmap aus einer Byte-Matrix.
BitmapFromMatrix(Matrix<(Of <<'(Single>)>>)) | Erzeugt ein Graustufen-Bitmap aus einer Single-Matrix.
BitmapFromMatrix(Matrix<(Of <<'(UInt16>)>>)) | Erzeugt ein Graustufen-Bitmap aus einer UInt16-Matrix.
BuildMean | Bildet einen Mittelwert für die quadratische Umgebung eines Pixels.
BuildMedian | Bildet einen Median für die quadratische Umgebung eines Pixels.
DrawGradient | Zeichnet einen mehrstufigen Farbverlauf.
GetARGBType | Gibt für die gegebene Genauigkeit einen passenden ARGB-Bildtyp zurück.
GetColorValue(Matrix<(Of <<'(Byte>)>>), Int32, Int32) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.
GetColorValue(Matrix<(Of <<'(Single>)>>), Int32, Int32) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.
GetColorValue(Matrix<(Of <<'(UInt16>)>>), Int32, Int32) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.
GetElementType | Gibt für die gegebene Genauigkeit einen passenden elementaren Datentyp zurück.
GetMatrixType | Gibt für die gegebene Genauigkeit einen passenden Matrix<(Of <(<'T>)>)>-Typ zurück.
GetRGBType | Gibt für die gegebene Genauigkeit einen passenden RGB-Bildtyp zurück.
MatrixFromBitmap | Erzeugt eine Matrix aus einem Graustufen-Bitmap.
SetColorValue(Matrix<(Of <<'(Byte>)>>), Int32, Int32, Single) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.
SetColorValue(Matrix<(Of <<'(Single>)>>), Int32, Int32, Single) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.
SetColorValue(Matrix<(Of <<'(UInt16>)>>), Int32, Int32, Single) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.

See Also

ColorTools Class
DynamicNode.Types.Imaging Namespace


BitmapFromMatrix Method

[image] [image]

DynamicNodes API
ColorTools..::..BitmapFromMatrix Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
BitmapFromMatrix(Matrix<(Of <<'(Byte>)>>)) | Erzeugt ein Graustufen-Bitmap aus einer Byte-Matrix.
BitmapFromMatrix(Matrix<(Of <<'(Single>)>>)) | Erzeugt ein Graustufen-Bitmap aus einer Single-Matrix.
BitmapFromMatrix(Matrix<(Of <<'(UInt16>)>>)) | Erzeugt ein Graustufen-Bitmap aus einer UInt16-Matrix.

See Also

ColorTools Class
ColorTools Members
DynamicNode.Types.Imaging Namespace


BitmapFromMatrix Method (Matrix(Byte))

[image]

DynamicNodes API
ColorTools..::..BitmapFromMatrix Method (Matrix<(Of <(<'Byte>)>)>)
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Graustufen-Bitmap aus einer Byte-Matrix.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Bitmap BitmapFromMatrix(
    Matrix<byte> mat
)
Visual Basic
Public Shared Function BitmapFromMatrix ( _
    mat As Matrix(Of Byte) _
) As Bitmap
F#
static member BitmapFromMatrix :
        mat:Matrix<byte> -> Bitmap

Parameters

mat
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Eine Matrix.

Return Value

Ein Bitmap-Objekt.

See Also

ColorTools Class
BitmapFromMatrix Overload
DynamicNode.Types.Imaging Namespace


BitmapFromMatrix Method (Matrix(Single))

[image]

DynamicNodes API
ColorTools..::..BitmapFromMatrix Method (Matrix<(Of <(<'Single>)>)>)
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Graustufen-Bitmap aus einer Single-Matrix.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Bitmap BitmapFromMatrix(
    Matrix<float> mat
)
Visual Basic
Public Shared Function BitmapFromMatrix ( _
    mat As Matrix(Of Single) _
) As Bitmap
F#
static member BitmapFromMatrix :
        mat:Matrix<float32> -> Bitmap

Parameters

mat
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Eine Matrix.

Return Value

Ein Bitmap-Objekt.

See Also

ColorTools Class
BitmapFromMatrix Overload
DynamicNode.Types.Imaging Namespace


BitmapFromMatrix Method (Matrix(UInt16))

[image]

DynamicNodes API
ColorTools..::..BitmapFromMatrix Method (Matrix<(Of <(<'UInt16>)>)>)
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Graustufen-Bitmap aus einer UInt16-Matrix.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Bitmap BitmapFromMatrix(
    Matrix<ushort> mat
)
Visual Basic
Public Shared Function BitmapFromMatrix ( _
    mat As Matrix(Of UShort) _
) As Bitmap
F#
static member BitmapFromMatrix :
        mat:Matrix<uint16> -> Bitmap

Parameters

mat
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Eine Matrix.

Return Value

Ein Bitmap-Objekt.

See Also

ColorTools Class
BitmapFromMatrix Overload
DynamicNode.Types.Imaging Namespace


BuildMean Method

[image]

DynamicNodes API
ColorTools..::..BuildMean Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet einen Mittelwert für die quadratische Umgebung eines Pixels.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static byte BuildMean(
    Matrix<byte> bitmap,
    int radius,
    int bmpW,
    int bmpH,
    int x,
    int y
)
Visual Basic
Public Shared Function BuildMean ( _
    bitmap As Matrix(Of Byte), _
    radius As Integer, _
    bmpW As Integer, _
    bmpH As Integer, _
    x As Integer, _
    y As Integer _
) As Byte
F#
static member BuildMean :
        bitmap:Matrix<byte> *
        radius:int *
        bmpW:int *
        bmpH:int *
        x:int *
        y:int -> byte

Parameters

bitmap
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Eine Matrix als Bitmap.
radius
Type: System..::..Int32
Der Radius (halbe Quadratgröße).
bmpW
Type: System..::..Int32
Die Breite des Bitmaps.
bmpH
Type: System..::..Int32
Die Höhe des Bitmaps.
x
Type: System..::..Int32
Die X-Koordinate des Pixels.
y
Type: System..::..Int32
Die Y-Koordinate des Pixels.

Return Value

Den Mittelwert der Umgebung eines Pixels.

See Also

ColorTools Class
DynamicNode.Types.Imaging Namespace


BuildMedian Method

[image]

DynamicNodes API
ColorTools..::..BuildMedian Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Bildet einen Median für die quadratische Umgebung eines Pixels.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float BuildMedian(
    Matrix<byte> bitmap,
    int radius,
    int bmpW,
    int bmpH,
    int x,
    int y
)
Visual Basic
Public Shared Function BuildMedian ( _
    bitmap As Matrix(Of Byte), _
    radius As Integer, _
    bmpW As Integer, _
    bmpH As Integer, _
    x As Integer, _
    y As Integer _
) As Single
F#
static member BuildMedian :
        bitmap:Matrix<byte> *
        radius:int *
        bmpW:int *
        bmpH:int *
        x:int *
        y:int -> float32

Parameters

bitmap
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Eine Matrix als Bitmap.
radius
Type: System..::..Int32
Der Radius (halbe Quadratgröße).
bmpW
Type: System..::..Int32
Die Breite des Bitmaps.
bmpH
Type: System..::..Int32
Die Höhe des Bitmaps.
x
Type: System..::..Int32
Die X-Koordinate des Pixels.
y
Type: System..::..Int32
Die Y-Koordinate des Pixels.

Return Value

Den Median der Umgebung eines Pixels.

See Also

ColorTools Class
DynamicNode.Types.Imaging Namespace


DrawGradient Method

[image]

DynamicNodes API
ColorTools..::..DrawGradient Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeichnet einen mehrstufigen Farbverlauf.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static void DrawGradient(
    Graphics g,
    RectangleF area,
    Color[] colors,
    bool vertical
)
Visual Basic
Public Shared Sub DrawGradient ( _
    g As Graphics, _
    area As RectangleF, _
    colors As Color(), _
    vertical As Boolean _
)
F#
static member DrawGradient :
        g:Graphics *
        area:RectangleF *
        colors:Color[] *
        vertical:bool -> unit

Parameters

g
Type: System.Drawing..::..Graphics
Der Geräte-Kontext.
area
Type: System.Drawing..::..RectangleF
Der Bereich, welcher gefüllt werden soll.
colors
Type: array< System.Drawing..::..Color >[]()[][]
Ein Array mit Farben.
vertical
Type: System..::..Boolean
Ein Wert der angibt, ob der Farbverlauf vertikal oder horizontal gezeichnet werden soll.

See Also

ColorTools Class
DynamicNode.Types.Imaging Namespace


GetARGBType Method

[image]

DynamicNodes API
ColorTools..::..GetARGBType Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für die gegebene Genauigkeit einen passenden ARGB-Bildtyp zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Type GetARGBType(
    BitDepth precision
)
Visual Basic
Public Shared Function GetARGBType ( _
    precision As BitDepth _
) As Type
F#
static member GetARGBType :
        precision:BitDepth -> Type

Parameters

precision
Type: DynamicNode.Types.Imaging..::..BitDepth
Die benötigte Genauigkeit.

Return Value

Ein passender ARGB-Bildtyp.

See Also

ColorTools Class
DynamicNode.Types.Imaging Namespace


GetColorValue Method

[image] [image]

DynamicNodes API
ColorTools..::..GetColorValue Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
GetColorValue(Matrix<(Of <<'(Byte>)>>), Int32, Int32) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.
GetColorValue(Matrix<(Of <<'(Single>)>>), Int32, Int32) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.
GetColorValue(Matrix<(Of <<'(UInt16>)>>), Int32, Int32) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.

See Also

ColorTools Class
ColorTools Members
DynamicNode.Types.Imaging Namespace


GetColorValue Method (Matrix(Byte), Int32, Int32)

[image]

DynamicNodes API
ColorTools..::..GetColorValue Method (Matrix<(Of <(<'Byte>)>)>, Int32, Int32)
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float GetColorValue(
    this Matrix<byte> m,
    int x,
    int y
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetColorValue ( _
    m As Matrix(Of Byte), _
    x As Integer, _
    y As Integer _
) As Single
F#
static member GetColorValue :
        m:Matrix<byte> *
        x:int *
        y:int -> float32

Parameters

m
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Die Byte-Matrix.
x
Type: System..::..Int32
Die Spalte des Matrizenelements.
y
Type: System..::..Int32
Die Zeile des Matrizenelements..

Return Value

Einen Single-Wert zwischen 0 und 1.

See Also

ColorTools Class
GetColorValue Overload
DynamicNode.Types.Imaging Namespace


GetColorValue Method (Matrix(Single), Int32, Int32)

[image]

DynamicNodes API
ColorTools..::..GetColorValue Method (Matrix<(Of <(<'Single>)>)>, Int32, Int32)
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float GetColorValue(
    this Matrix<float> m,
    int x,
    int y
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetColorValue ( _
    m As Matrix(Of Single), _
    x As Integer, _
    y As Integer _
) As Single
F#
static member GetColorValue :
        m:Matrix<float32> *
        x:int *
        y:int -> float32

Parameters

m
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Die Byte-Matrix.
x
Type: System..::..Int32
Die Spalte des Matrizenelements.
y
Type: System..::..Int32
Die Zeile des Matrizenelements..

Return Value

Einen Single-Wert zwischen 0 und 1.

See Also

ColorTools Class
GetColorValue Overload
DynamicNode.Types.Imaging Namespace


GetColorValue Method (Matrix(UInt16), Int32, Int32)

[image]

DynamicNodes API
ColorTools..::..GetColorValue Method (Matrix<(Of <(<'UInt16>)>)>, Int32, Int32)
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement als genormten Single-Wert zwischen 0 und 1 zurückgibt.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float GetColorValue(
    this Matrix<ushort> m,
    int x,
    int y
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetColorValue ( _
    m As Matrix(Of UShort), _
    x As Integer, _
    y As Integer _
) As Single
F#
static member GetColorValue :
        m:Matrix<uint16> *
        x:int *
        y:int -> float32

Parameters

m
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Die Byte-Matrix.
x
Type: System..::..Int32
Die Spalte des Matrizenelements.
y
Type: System..::..Int32
Die Zeile des Matrizenelements..

Return Value

Einen Single-Wert zwischen 0 und 1.

See Also

ColorTools Class
GetColorValue Overload
DynamicNode.Types.Imaging Namespace


GetElementType Method

[image]

DynamicNodes API
ColorTools..::..GetElementType Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für die gegebene Genauigkeit einen passenden elementaren Datentyp zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Type GetElementType(
    BitDepth precision
)
Visual Basic
Public Shared Function GetElementType ( _
    precision As BitDepth _
) As Type
F#
static member GetElementType :
        precision:BitDepth -> Type

Parameters

precision
Type: DynamicNode.Types.Imaging..::..BitDepth
Die benötigte Genauigkeit.

Return Value

Ein passender elementarer Datentyp.

See Also

ColorTools Class
DynamicNode.Types.Imaging Namespace


GetMatrixType Method

[image]

DynamicNodes API
ColorTools..::..GetMatrixType Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für die gegebene Genauigkeit einen passenden Matrix<(Of <(<'T>)>)>-Typ zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Type GetMatrixType(
    BitDepth precision
)
Visual Basic
Public Shared Function GetMatrixType ( _
    precision As BitDepth _
) As Type
F#
static member GetMatrixType :
        precision:BitDepth -> Type

Parameters

precision
Type: DynamicNode.Types.Imaging..::..BitDepth
Die benötigte Genauigkeit.

Return Value

Ein konkreter Matrix<(Of <(<'T>)>)>-Typ.

See Also

ColorTools Class
DynamicNode.Types.Imaging Namespace


GetRGBType Method

[image]

DynamicNodes API
ColorTools..::..GetRGBType Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt für die gegebene Genauigkeit einen passenden RGB-Bildtyp zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Type GetRGBType(
    BitDepth precision
)
Visual Basic
Public Shared Function GetRGBType ( _
    precision As BitDepth _
) As Type
F#
static member GetRGBType :
        precision:BitDepth -> Type

Parameters

precision
Type: DynamicNode.Types.Imaging..::..BitDepth
Die benötigte Genauigkeit.

Return Value

Ein passender RGB-Bildtyp.

See Also

ColorTools Class
DynamicNode.Types.Imaging Namespace


MatrixFromBitmap Method

[image]

DynamicNodes API
ColorTools..::..MatrixFromBitmap Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt eine Matrix aus einem Graustufen-Bitmap.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static Matrix<byte> MatrixFromBitmap(
    Bitmap bmp
)
Visual Basic
Public Shared Function MatrixFromBitmap ( _
    bmp As Bitmap _
) As Matrix(Of Byte)
F#
static member MatrixFromBitmap :
        bmp:Bitmap -> Matrix<byte>

Parameters

bmp
Type: System.Drawing..::..Bitmap
Ein Bitmap.

Return Value

Ein Bitmap-Objekt.

See Also

ColorTools Class
DynamicNode.Types.Imaging Namespace


SetColorValue Method

[image] [image]

DynamicNodes API
ColorTools..::..SetColorValue Method
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

Name | Description
SetColorValue(Matrix<(Of <<'(Byte>)>>), Int32, Int32, Single) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.
SetColorValue(Matrix<(Of <<'(Single>)>>), Int32, Int32, Single) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.
SetColorValue(Matrix<(Of <<'(UInt16>)>>), Int32, Int32, Single) | Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.

See Also

ColorTools Class
ColorTools Members
DynamicNode.Types.Imaging Namespace


SetColorValue Method (Matrix(Byte), Int32, Int32, Single)

[image]

DynamicNodes API
ColorTools..::..SetColorValue Method (Matrix<(Of <(<'Byte>)>)>, Int32, Int32, Single)
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static void SetColorValue(
    this Matrix<byte> m,
    int x,
    int y,
    float value
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetColorValue ( _
    m As Matrix(Of Byte), _
    x As Integer, _
    y As Integer, _
    value As Single _
)
F#
static member SetColorValue :
        m:Matrix<byte> *
        x:int *
        y:int *
        value:float32 -> unit

Parameters

m
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Die Byte-Matrix.
x
Type: System..::..Int32
Die Spalte des Matrizenelements.
y
Type: System..::..Int32
Die Zeile des Matrizenelements..
value
Type: System..::..Single
Der Wert, der auf das Intervall 0..1 begrenzt wird.

See Also

ColorTools Class
SetColorValue Overload
DynamicNode.Types.Imaging Namespace


SetColorValue Method (Matrix(Single), Int32, Int32, Single)

[image]

DynamicNodes API
ColorTools..::..SetColorValue Method (Matrix<(Of <(<'Single>)>)>, Int32, Int32, Single)
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static void SetColorValue(
    this Matrix<float> m,
    int x,
    int y,
    float value
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetColorValue ( _
    m As Matrix(Of Single), _
    x As Integer, _
    y As Integer, _
    value As Single _
)
F#
static member SetColorValue :
        m:Matrix<float32> *
        x:int *
        y:int *
        value:float32 -> unit

Parameters

m
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Die Byte-Matrix.
x
Type: System..::..Int32
Die Spalte des Matrizenelements.
y
Type: System..::..Int32
Die Zeile des Matrizenelements..
value
Type: System..::..Single
Der Wert, der auf das Intervall 0..1 begrenzt wird.

See Also

ColorTools Class
SetColorValue Overload
DynamicNode.Types.Imaging Namespace


SetColorValue Method (Matrix(UInt16), Int32, Int32, Single)

[image]

DynamicNodes API
ColorTools..::..SetColorValue Method (Matrix<(Of <(<'UInt16>)>)>, Int32, Int32, Single)
ColorTools Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erweiterungsmethode für Matrix<(Of <(<'T>)>)> die ein Matrizenelement mit einem genormten Single-Wert zwischen 0 und 1 beschreibt.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static void SetColorValue(
    this Matrix<ushort> m,
    int x,
    int y,
    float value
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetColorValue ( _
    m As Matrix(Of UShort), _
    x As Integer, _
    y As Integer, _
    value As Single _
)
F#
static member SetColorValue :
        m:Matrix<uint16> *
        x:int *
        y:int *
        value:float32 -> unit

Parameters

m
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Die UInt16-Matrix.
x
Type: System..::..Int32
Die Spalte des Matrizenelements.
y
Type: System..::..Int32
Die Zeile des Matrizenelements..
value
Type: System..::..Single
Der Wert, der auf das Intervall 0..1 begrenzt wird.

See Also

ColorTools Class
SetColorValue Overload
DynamicNode.Types.Imaging Namespace


ColorValue_Lab Structure

[image]

DynamicNodes API
ColorValue_Lab Structure
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein geräteunabhäniger L*a*b*-Farbwert.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public struct ColorValue_Lab
Visual Basic
Public Structure ColorValue_Lab
F#
[<SealedAttribute>]
type ColorValue_Lab =  struct end

See Also

ColorValue_Lab Members
DynamicNode.Types.Imaging Namespace


ColorValue_Lab Members

[image] [image]

DynamicNodes API
ColorValue_Lab Members
ColorValue_Lab Structure Constructors Methods Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_Lab type exposes the following members.

Constructors

 | Name | Description
Public method | ColorValue_Lab | Initialisiert eine neue Instanz der Struktur ColorValue_Lab.

Methods

 | Name | Description
Public method | To_LCH | Wandelt den L*a*b*-Farbwert in den LCH(ab)-Farbraum um.
Public method | To_XYZ | Wandelt den L*a*b*-Farbwert in den XYZ-Farbraum um.

Fields

 | Name | Description
Public field | a | Der Grün-Rot-Anteil.
Public field | b | Der Blau-Gelb-Anteil.
Public field | L | Der Helligkeitsanteil.

See Also

ColorValue_Lab Structure
DynamicNode.Types.Imaging Namespace


ColorValue_Lab Constructor

[image]

DynamicNodes API
ColorValue_Lab Constructor
ColorValue_Lab Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur ColorValue_Lab.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_Lab(
    float l,
    float a,
    float b
)
Visual Basic
Public Sub New ( _
    l As Single, _
    a As Single, _
    b As Single _
)
F#
new :
        l:float32 *
        a:float32 *
        b:float32 -> ColorValue_Lab

Parameters

l
Type: System..::..Single
Der Helligkeitsanteil.
a
Type: System..::..Single
Der Grün-Rot-Anteil.
b
Type: System..::..Single
Der Blau-Gelb-Anteil.

See Also

ColorValue_Lab Structure
DynamicNode.Types.Imaging Namespace


ColorValue_Lab Fields

[image] [image]

DynamicNodes API
ColorValue_Lab Fields
ColorValue_Lab Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_Lab type exposes the following members.

Fields

 | Name | Description
Public field | a | Der Grün-Rot-Anteil.
Public field | b | Der Blau-Gelb-Anteil.
Public field | L | Der Helligkeitsanteil.

See Also

ColorValue_Lab Structure
DynamicNode.Types.Imaging Namespace


a Field

[image]

DynamicNodes API
ColorValue_Lab..::..a Field
ColorValue_Lab Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Grün-Rot-Anteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float a
Visual Basic
Public a As Single
F#
val mutable a: float32

See Also

ColorValue_Lab Structure
DynamicNode.Types.Imaging Namespace


b Field

[image]

DynamicNodes API
ColorValue_Lab..::..b Field
ColorValue_Lab Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Blau-Gelb-Anteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float b
Visual Basic
Public b As Single
F#
val mutable b: float32

See Also

ColorValue_Lab Structure
DynamicNode.Types.Imaging Namespace


L Field

[image]

DynamicNodes API
ColorValue_Lab..::..L Field
ColorValue_Lab Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Helligkeitsanteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float L
Visual Basic
Public L As Single
F#
val mutable L: float32

See Also

ColorValue_Lab Structure
DynamicNode.Types.Imaging Namespace


ColorValue_Lab Methods

[image] [image]

DynamicNodes API
ColorValue_Lab Methods
ColorValue_Lab Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_Lab type exposes the following members.

Methods

 | Name | Description
Public method | To_LCH | Wandelt den L*a*b*-Farbwert in den LCH(ab)-Farbraum um.
Public method | To_XYZ | Wandelt den L*a*b*-Farbwert in den XYZ-Farbraum um.

See Also

ColorValue_Lab Structure
DynamicNode.Types.Imaging Namespace


To_LCH Method

[image]

DynamicNodes API
ColorValue_Lab..::..To_LCH Method
ColorValue_Lab Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt den L*a*b*-Farbwert in den LCH(ab)-Farbraum um.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_LCH To_LCH()
Visual Basic
Public Function To_LCH As ColorValue_LCH
F#
member To_LCH : unit -> ColorValue_LCH

Return Value

[Missing <returns> documentation for "M:DynamicNode.Types.Imaging.ColorValue_Lab.To_LCH"]

See Also

ColorValue_Lab Structure
DynamicNode.Types.Imaging Namespace


To_XYZ Method

[image]

DynamicNodes API
ColorValue_Lab..::..To_XYZ Method
ColorValue_Lab Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt den L*a*b*-Farbwert in den XYZ-Farbraum um.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_XYZ To_XYZ(
    Whitepoint w
)
Visual Basic
Public Function To_XYZ ( _
    w As Whitepoint _
) As ColorValue_XYZ
F#
member To_XYZ :
        w:Whitepoint -> ColorValue_XYZ

Parameters

w
Type: DynamicNode.Types.Imaging..::..Whitepoint
Das Referenzweiß des Systems.

Return Value

[Missing <returns> documentation for "M:DynamicNode.Types.Imaging.ColorValue_Lab.To_XYZ(DynamicNode.Types.Imaging.Whitepoint)"]

See Also

ColorValue_Lab Structure
DynamicNode.Types.Imaging Namespace


ColorValue_LCH Structure

[image]

DynamicNodes API
ColorValue_LCH Structure
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein geräteunabhäniger LCH(ab)-Farbwert.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public struct ColorValue_LCH
Visual Basic
Public Structure ColorValue_LCH
F#
[<SealedAttribute>]
type ColorValue_LCH =  struct end

See Also

ColorValue_LCH Members
DynamicNode.Types.Imaging Namespace


ColorValue_LCH Members

[image] [image]

DynamicNodes API
ColorValue_LCH Members
ColorValue_LCH Structure Constructors Methods Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_LCH type exposes the following members.

Constructors

 | Name | Description
Public method | ColorValue_LCH | Initialisiert eine neue Instanz der Struktur ColorValue_Lab.

Methods

 | Name | Description
Public method | To_Lab | Wandelt den LCH(ab)-Farbwert in den L*a*b*-Farbraum um.

Fields

 | Name | Description
Public field | C | Die Farbigkeit bzw. Sättigung (chromaticity).
Public field | H | Der Farbton (hue).
Public field | L | Der Helligkeitsanteil.

See Also

ColorValue_LCH Structure
DynamicNode.Types.Imaging Namespace


ColorValue_LCH Constructor

[image]

DynamicNodes API
ColorValue_LCH Constructor
ColorValue_LCH Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur ColorValue_Lab.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_LCH(
    float l,
    float c,
    float h
)
Visual Basic
Public Sub New ( _
    l As Single, _
    c As Single, _
    h As Single _
)
F#
new :
        l:float32 *
        c:float32 *
        h:float32 -> ColorValue_LCH

Parameters

l
Type: System..::..Single
Der Helligkeitsanteil.
c
Type: System..::..Single
Die Farbigkeit bzw. Sättigung (chromaticity).
h
Type: System..::..Single
Der Farbton (hue).

See Also

ColorValue_LCH Structure
DynamicNode.Types.Imaging Namespace


ColorValue_LCH Fields

[image] [image]

DynamicNodes API
ColorValue_LCH Fields
ColorValue_LCH Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_LCH type exposes the following members.

Fields

 | Name | Description
Public field | C | Die Farbigkeit bzw. Sättigung (chromaticity).
Public field | H | Der Farbton (hue).
Public field | L | Der Helligkeitsanteil.

See Also

ColorValue_LCH Structure
DynamicNode.Types.Imaging Namespace


C Field

[image]

DynamicNodes API
ColorValue_LCH..::..C Field
ColorValue_LCH Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Farbigkeit bzw. Sättigung (chromaticity).

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float C
Visual Basic
Public C As Single
F#
val mutable C: float32

See Also

ColorValue_LCH Structure
DynamicNode.Types.Imaging Namespace


H Field

[image]

DynamicNodes API
ColorValue_LCH..::..H Field
ColorValue_LCH Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Farbton (hue).

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float H
Visual Basic
Public H As Single
F#
val mutable H: float32

See Also

ColorValue_LCH Structure
DynamicNode.Types.Imaging Namespace


L Field

[image]

DynamicNodes API
ColorValue_LCH..::..L Field
ColorValue_LCH Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Helligkeitsanteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float L
Visual Basic
Public L As Single
F#
val mutable L: float32

See Also

ColorValue_LCH Structure
DynamicNode.Types.Imaging Namespace


ColorValue_LCH Methods

[image] [image]

DynamicNodes API
ColorValue_LCH Methods
ColorValue_LCH Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_LCH type exposes the following members.

Methods

 | Name | Description
Public method | To_Lab | Wandelt den LCH(ab)-Farbwert in den L*a*b*-Farbraum um.

See Also

ColorValue_LCH Structure
DynamicNode.Types.Imaging Namespace


To_Lab Method

[image]

DynamicNodes API
ColorValue_LCH..::..To_Lab Method
ColorValue_LCH Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt den LCH(ab)-Farbwert in den L*a*b*-Farbraum um.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_Lab To_Lab()
Visual Basic
Public Function To_Lab As ColorValue_Lab
F#
member To_Lab : unit -> ColorValue_Lab

Return Value

[Missing <returns> documentation for "M:DynamicNode.Types.Imaging.ColorValue_LCH.To_Lab"]

See Also

ColorValue_LCH Structure
DynamicNode.Types.Imaging Namespace


ColorValue_RGB Structure

[image]

DynamicNodes API
ColorValue_RGB Structure
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein geräteabhäniger RGB-Farbwert.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public struct ColorValue_RGB
Visual Basic
Public Structure ColorValue_RGB
F#
[<SealedAttribute>]
type ColorValue_RGB =  struct end

See Also

ColorValue_RGB Members
DynamicNode.Types.Imaging Namespace


ColorValue_RGB Members

[image] [image]

DynamicNodes API
ColorValue_RGB Members
ColorValue_RGB Structure Constructors Methods Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_RGB type exposes the following members.

Constructors

 | Name | Description
Public method | ColorValue_RGB(array<Single>[]()[][]) | Initialisiert eine neue Instanz der Struktur ColorValue_RGB mit einem Array.
Public method | ColorValue_RGB(Byte, Byte, Byte) | Initialisiert eine neue Instanz der Struktur ColorValue_RGB mit Byte-Werten zwischen 0-255. Die Werte werden auf 0-1 normalisiert.
Public method | ColorValue_RGB(Single, Single, Single) | Initialisiert eine neue Instanz der Struktur ColorValue_RGB.
Public method | ColorValue_RGB(UInt16, UInt16, UInt16) | Initialisiert eine neue Instanz der Struktur ColorValue_RGB mit UInt16-Werten zwischen 0-65535. Die Werte werden auf 0-1 normalisiert.

Methods

 | Name | Description
Public method | ToVector | Gibt die Werte von R, G und B als Array zurück.

Fields

 | Name | Description
Public field | B | Der Blauanteil.
Public field | G | Der Grünanteil.
Public field | R | Der Rotanteil.

See Also

ColorValue_RGB Structure
DynamicNode.Types.Imaging Namespace


ColorValue_RGB Constructor

[image] [image]

DynamicNodes API
ColorValue_RGB Constructor
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ColorValue_RGB(array<Single>[]()[][]) | Initialisiert eine neue Instanz der Struktur ColorValue_RGB mit einem Array.
Public method | ColorValue_RGB(Byte, Byte, Byte) | Initialisiert eine neue Instanz der Struktur ColorValue_RGB mit Byte-Werten zwischen 0-255. Die Werte werden auf 0-1 normalisiert.
Public method | ColorValue_RGB(Single, Single, Single) | Initialisiert eine neue Instanz der Struktur ColorValue_RGB.
Public method | ColorValue_RGB(UInt16, UInt16, UInt16) | Initialisiert eine neue Instanz der Struktur ColorValue_RGB mit UInt16-Werten zwischen 0-65535. Die Werte werden auf 0-1 normalisiert.

See Also

ColorValue_RGB Structure
ColorValue_RGB Members
DynamicNode.Types.Imaging Namespace


ColorValue_RGB Constructor (Single[])

[image]

DynamicNodes API
ColorValue_RGB Constructor (array<Single>[]()[][])
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur ColorValue_RGB mit einem Array.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_RGB(
    float[] vector
)
Visual Basic
Public Sub New ( _
    vector As Single() _
)
F#
new :
        vector:float32[] -> ColorValue_RGB

Parameters

vector
Type: array< System..::..Single >[]()[][]
Die Farbwerte in der Reihenfolge R, G, B.

Exceptions

Exception | Condition
System..::..NullReferenceException | Wird geworfen, wenn vectornull ist.
System..::..IndexOutOfRangeException | Wird geworfen, wenn vector weniger als drei Elemente besitzt.

See Also

ColorValue_RGB Structure
ColorValue_RGB Overload
DynamicNode.Types.Imaging Namespace


ColorValue_RGB Constructor (Byte, Byte, Byte)

[image]

DynamicNodes API
ColorValue_RGB Constructor (Byte, Byte, Byte)
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur ColorValue_RGB mit Byte-Werten zwischen 0-255. Die Werte werden auf 0-1 normalisiert.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_RGB(
    byte r,
    byte g,
    byte b
)
Visual Basic
Public Sub New ( _
    r As Byte, _
    g As Byte, _
    b As Byte _
)
F#
new :
        r:byte *
        g:byte *
        b:byte -> ColorValue_RGB

Parameters

r
Type: System..::..Byte
Rot.
g
Type: System..::..Byte
Grün.
b
Type: System..::..Byte
Blau.

See Also

ColorValue_RGB Structure
ColorValue_RGB Overload
DynamicNode.Types.Imaging Namespace


ColorValue_RGB Constructor (Single, Single, Single)

[image]

DynamicNodes API
ColorValue_RGB Constructor (Single, Single, Single)
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur ColorValue_RGB.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_RGB(
    float r,
    float g,
    float b
)
Visual Basic
Public Sub New ( _
    r As Single, _
    g As Single, _
    b As Single _
)
F#
new :
        r:float32 *
        g:float32 *
        b:float32 -> ColorValue_RGB

Parameters

r
Type: System..::..Single
Rot.
g
Type: System..::..Single
Grün.
b
Type: System..::..Single
Blau.

See Also

ColorValue_RGB Structure
ColorValue_RGB Overload
DynamicNode.Types.Imaging Namespace


ColorValue_RGB Constructor (UInt16, UInt16, UInt16)

[image]

DynamicNodes API
ColorValue_RGB Constructor (UInt16, UInt16, UInt16)
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur ColorValue_RGB mit UInt16-Werten zwischen 0-65535. Die Werte werden auf 0-1 normalisiert.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_RGB(
    ushort r,
    ushort g,
    ushort b
)
Visual Basic
Public Sub New ( _
    r As UShort, _
    g As UShort, _
    b As UShort _
)
F#
new :
        r:uint16 *
        g:uint16 *
        b:uint16 -> ColorValue_RGB

Parameters

r
Type: System..::..UInt16
Rot.
g
Type: System..::..UInt16
Grün.
b
Type: System..::..UInt16
Blau.

See Also

ColorValue_RGB Structure
ColorValue_RGB Overload
DynamicNode.Types.Imaging Namespace


ColorValue_RGB Fields

[image] [image]

DynamicNodes API
ColorValue_RGB Fields
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_RGB type exposes the following members.

Fields

 | Name | Description
Public field | B | Der Blauanteil.
Public field | G | Der Grünanteil.
Public field | R | Der Rotanteil.

See Also

ColorValue_RGB Structure
DynamicNode.Types.Imaging Namespace


B Field

[image]

DynamicNodes API
ColorValue_RGB..::..B Field
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Blauanteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float B
Visual Basic
Public B As Single
F#
val mutable B: float32

See Also

ColorValue_RGB Structure
DynamicNode.Types.Imaging Namespace


G Field

[image]

DynamicNodes API
ColorValue_RGB..::..G Field
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Grünanteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float G
Visual Basic
Public G As Single
F#
val mutable G: float32

See Also

ColorValue_RGB Structure
DynamicNode.Types.Imaging Namespace


R Field

[image]

DynamicNodes API
ColorValue_RGB..::..R Field
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Rotanteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float R
Visual Basic
Public R As Single
F#
val mutable R: float32

See Also

ColorValue_RGB Structure
DynamicNode.Types.Imaging Namespace


ColorValue_RGB Methods

[image] [image]

DynamicNodes API
ColorValue_RGB Methods
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_RGB type exposes the following members.

Methods

 | Name | Description
Public method | ToVector | Gibt die Werte von R, G und B als Array zurück.

See Also

ColorValue_RGB Structure
DynamicNode.Types.Imaging Namespace


ToVector Method

[image]

DynamicNodes API
ColorValue_RGB..::..ToVector Method
ColorValue_RGB Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Werte von R, G und B als Array zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float[] ToVector()
Visual Basic
Public Function ToVector As Single()
F#
member ToVector : unit -> float32[]

Return Value

[Missing <returns> documentation for "M:DynamicNode.Types.Imaging.ColorValue_RGB.ToVector"]

See Also

ColorValue_RGB Structure
DynamicNode.Types.Imaging Namespace


ColorValue_xyY Structure

[image]

DynamicNodes API
ColorValue_xyY Structure
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein geräteunabhängiger Farbwert im xyY-Farbmodell (Normtafel des CIE-Farbsystems).

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public struct ColorValue_xyY
Visual Basic
Public Structure ColorValue_xyY
F#
[<SealedAttribute>]
type ColorValue_xyY =  struct end

See Also

ColorValue_xyY Members
DynamicNode.Types.Imaging Namespace


ColorValue_xyY Members

[image] [image]

DynamicNodes API
ColorValue_xyY Members
ColorValue_xyY Structure Constructors Methods Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_xyY type exposes the following members.

Constructors

 | Name | Description
Public method | ColorValue_xyY | Initialisiert eine neue Instanz der Struktur ColorValue_xyY.

Methods

 | Name | Description
Public method | To_XYZ | Wandelt den Farbwert in einen geräteunabhängigen XYZ-Farbwert.

Fields

 | Name | Description
Public field | x | Die x-Koordinate in der Normtafel.
Public field | y | Die y-Koordinate in der Normtafel.
Public field | Y | Der Helligkeitsanteil.

See Also

ColorValue_xyY Structure
DynamicNode.Types.Imaging Namespace


ColorValue_xyY Constructor

[image]

DynamicNodes API
ColorValue_xyY Constructor
ColorValue_xyY Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur ColorValue_xyY.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_xyY(
    float x,
    float y,
    float Y
)
Visual Basic
Public Sub New ( _
    x As Single, _
    y As Single, _
    Y As Single _
)
F#
new :
        x:float32 *
        y:float32 *
        Y:float32 -> ColorValue_xyY

Parameters

x
Type: System..::..Single
Die x-Koordinate.
y
Type: System..::..Single
Die y-Koordinate.
Y
Type: System..::..Single
Der Helligkeitsanteil.

See Also

ColorValue_xyY Structure
DynamicNode.Types.Imaging Namespace


ColorValue_xyY Fields

[image] [image]

DynamicNodes API
ColorValue_xyY Fields
ColorValue_xyY Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_xyY type exposes the following members.

Fields

 | Name | Description
Public field | x | Die x-Koordinate in der Normtafel.
Public field | y | Die y-Koordinate in der Normtafel.
Public field | Y | Der Helligkeitsanteil.

See Also

ColorValue_xyY Structure
DynamicNode.Types.Imaging Namespace


x Field

[image]

DynamicNodes API
ColorValue_xyY..::..x Field
ColorValue_xyY Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die x-Koordinate in der Normtafel.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float x
Visual Basic
Public x As Single
F#
val mutable x: float32

See Also

ColorValue_xyY Structure
DynamicNode.Types.Imaging Namespace


Y Field

[image]

DynamicNodes API
ColorValue_xyY..::..Y Field
ColorValue_xyY Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Helligkeitsanteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float Y
Visual Basic
Public Y As Single
F#
val mutable Y: float32

See Also

ColorValue_xyY Structure
DynamicNode.Types.Imaging Namespace


ColorValue_xyY Methods

[image] [image]

DynamicNodes API
ColorValue_xyY Methods
ColorValue_xyY Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_xyY type exposes the following members.

Methods

 | Name | Description
Public method | To_XYZ | Wandelt den Farbwert in einen geräteunabhängigen XYZ-Farbwert.

See Also

ColorValue_xyY Structure
DynamicNode.Types.Imaging Namespace


To_XYZ Method

[image]

DynamicNodes API
ColorValue_xyY..::..To_XYZ Method
ColorValue_xyY Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt den Farbwert in einen geräteunabhängigen XYZ-Farbwert.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_XYZ To_XYZ()
Visual Basic
Public Function To_XYZ As ColorValue_XYZ
F#
member To_XYZ : unit -> ColorValue_XYZ

Return Value

[Missing <returns> documentation for "M:DynamicNode.Types.Imaging.ColorValue_xyY.To_XYZ"]

See Also

ColorValue_xyY Structure
DynamicNode.Types.Imaging Namespace


ColorValue_XYZ Structure

[image]

DynamicNodes API
ColorValue_XYZ Structure
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein geräteunabhängiger Farbwert im CIE-XYZ-Farbraum.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public struct ColorValue_XYZ
Visual Basic
Public Structure ColorValue_XYZ
F#
[<SealedAttribute>]
type ColorValue_XYZ =  struct end

See Also

ColorValue_XYZ Members
DynamicNode.Types.Imaging Namespace


ColorValue_XYZ Members

[image] [image]

DynamicNodes API
ColorValue_XYZ Members
ColorValue_XYZ Structure Constructors Methods Fields See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_XYZ type exposes the following members.

Constructors

 | Name | Description
Public method | ColorValue_XYZ(array<Single>[]()[][]) | Initialisiert eine neue Instanz der Struktur ColorValue_XYZ mit einem Array.
Public method | ColorValue_XYZ(Single, Single, Single) | Initialisiert eine neue Instanz der Struktur ColorValue_XYZ.

Methods

 | Name | Description
Public method | To_Lab | Wandelt den XYZ-Farbwert in den L*a*b*-Farbraum um.
Public method | To_xyY | Wandelt den XYZ-Farbwert in den xyY-Farbraum um.
Public method | ToVector | Gibt die Werte von X, Y und Z als Array zurück.

Fields

 | Name | Description
Public field | X | Der Rotanteil.
Public field | Y | Der Grünanteil.
Public field | Z | Der Blauanteil.

See Also

ColorValue_XYZ Structure
DynamicNode.Types.Imaging Namespace


ColorValue_XYZ Constructor

[image] [image]

DynamicNodes API
ColorValue_XYZ Constructor
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ColorValue_XYZ(array<Single>[]()[][]) | Initialisiert eine neue Instanz der Struktur ColorValue_XYZ mit einem Array.
Public method | ColorValue_XYZ(Single, Single, Single) | Initialisiert eine neue Instanz der Struktur ColorValue_XYZ.

See Also

ColorValue_XYZ Structure
ColorValue_XYZ Members
DynamicNode.Types.Imaging Namespace


ColorValue_XYZ Constructor (Single[])

[image]

DynamicNodes API
ColorValue_XYZ Constructor (array<Single>[]()[][])
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur ColorValue_XYZ mit einem Array.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_XYZ(
    float[] vector
)
Visual Basic
Public Sub New ( _
    vector As Single() _
)
F#
new :
        vector:float32[] -> ColorValue_XYZ

Parameters

vector
Type: array< System..::..Single >[]()[][]
Die Farbwerte in der Reihenfolge X, Y, Z.

Exceptions

Exception | Condition
System..::..NullReferenceException | Wird geworfen, wenn vectornull ist.
System..::..IndexOutOfRangeException | Wird geworfen, wenn vector weniger als drei Elemente besitzt.

See Also

ColorValue_XYZ Structure
ColorValue_XYZ Overload
DynamicNode.Types.Imaging Namespace


ColorValue_XYZ Constructor (Single, Single, Single)

[image]

DynamicNodes API
ColorValue_XYZ Constructor (Single, Single, Single)
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Struktur ColorValue_XYZ.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_XYZ(
    float x,
    float y,
    float z
)
Visual Basic
Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single _
)
F#
new :
        x:float32 *
        y:float32 *
        z:float32 -> ColorValue_XYZ

Parameters

x
Type: System..::..Single
Rot.
y
Type: System..::..Single
Grün.
z
Type: System..::..Single
Blau.

See Also

ColorValue_XYZ Structure
ColorValue_XYZ Overload
DynamicNode.Types.Imaging Namespace


ColorValue_XYZ Fields

[image] [image]

DynamicNodes API
ColorValue_XYZ Fields
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_XYZ type exposes the following members.

Fields

 | Name | Description
Public field | X | Der Rotanteil.
Public field | Y | Der Grünanteil.
Public field | Z | Der Blauanteil.

See Also

ColorValue_XYZ Structure
DynamicNode.Types.Imaging Namespace


X Field

[image]

DynamicNodes API
ColorValue_XYZ..::..X Field
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Rotanteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float X
Visual Basic
Public X As Single
F#
val mutable X: float32

See Also

ColorValue_XYZ Structure
DynamicNode.Types.Imaging Namespace


Y Field

[image]

DynamicNodes API
ColorValue_XYZ..::..Y Field
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Grünanteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float Y
Visual Basic
Public Y As Single
F#
val mutable Y: float32

See Also

ColorValue_XYZ Structure
DynamicNode.Types.Imaging Namespace


Z Field

[image]

DynamicNodes API
ColorValue_XYZ..::..Z Field
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Blauanteil.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float Z
Visual Basic
Public Z As Single
F#
val mutable Z: float32

See Also

ColorValue_XYZ Structure
DynamicNode.Types.Imaging Namespace


ColorValue_XYZ Methods

[image] [image]

DynamicNodes API
ColorValue_XYZ Methods
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ColorValue_XYZ type exposes the following members.

Methods

 | Name | Description
Public method | To_Lab | Wandelt den XYZ-Farbwert in den L*a*b*-Farbraum um.
Public method | To_xyY | Wandelt den XYZ-Farbwert in den xyY-Farbraum um.
Public method | ToVector | Gibt die Werte von X, Y und Z als Array zurück.

See Also

ColorValue_XYZ Structure
DynamicNode.Types.Imaging Namespace


To_Lab Method

[image]

DynamicNodes API
ColorValue_XYZ..::..To_Lab Method
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt den XYZ-Farbwert in den L*a*b*-Farbraum um.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_Lab To_Lab(
    Whitepoint w
)
Visual Basic
Public Function To_Lab ( _
    w As Whitepoint _
) As ColorValue_Lab
F#
member To_Lab :
        w:Whitepoint -> ColorValue_Lab

Parameters

w
Type: DynamicNode.Types.Imaging..::..Whitepoint
Das Referenzweiß des Systems.

Return Value

[Missing <returns> documentation for "M:DynamicNode.Types.Imaging.ColorValue_XYZ.To_Lab(DynamicNode.Types.Imaging.Whitepoint)"]

See Also

ColorValue_XYZ Structure
DynamicNode.Types.Imaging Namespace


To_xyY Method

[image]

DynamicNodes API
ColorValue_XYZ..::..To_xyY Method
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt den XYZ-Farbwert in den xyY-Farbraum um.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_xyY To_xyY(
    Whitepoint w
)
Visual Basic
Public Function To_xyY ( _
    w As Whitepoint _
) As ColorValue_xyY
F#
member To_xyY :
        w:Whitepoint -> ColorValue_xyY

Parameters

w
Type: DynamicNode.Types.Imaging..::..Whitepoint
Das Referenzweiß des Systems.

Return Value

[Missing <returns> documentation for "M:DynamicNode.Types.Imaging.ColorValue_XYZ.To_xyY(DynamicNode.Types.Imaging.Whitepoint)"]

See Also

ColorValue_XYZ Structure
DynamicNode.Types.Imaging Namespace


ToVector Method

[image]

DynamicNodes API
ColorValue_XYZ..::..ToVector Method
ColorValue_XYZ Structure See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Werte von X, Y und Z als Array zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float[] ToVector()
Visual Basic
Public Function ToVector As Single()
F#
member ToVector : unit -> float32[]

Return Value

[Missing <returns> documentation for "M:DynamicNode.Types.Imaging.ColorValue_XYZ.ToVector"]

See Also

ColorValue_XYZ Structure
DynamicNode.Types.Imaging Namespace


GammaCompanding Class

[image]

DynamicNodes API
GammaCompanding Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Diese Klasse repräsentiert eine Gammaverteilung.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public class GammaCompanding
Visual Basic
Public Class GammaCompanding
F#
type GammaCompanding =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Imaging..::..GammaCompanding

See Also

GammaCompanding Members
DynamicNode.Types.Imaging Namespace


GammaCompanding Members

[image] [image]

DynamicNodes API
GammaCompanding Members
GammaCompanding Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GammaCompanding type exposes the following members.

Constructors

 | Name | Description
Public method | GammaCompanding(String, String, Single) | Initialisiert eine neue Instanz der Klasse GammaCompanding mit einer logarithmischen Verteilung.
Public method | GammaCompanding(String, String, GammaTransferFunction, GammaTransferFunction) | Initialisiert eine neue Instanz der Klasse GammaCompanding.

Methods

 | Name | Description
Public method | Apply | Wendet die Gammaverteilung auf einen linearen RGB-Farbwert an und gibt den nicht linearen Farbwert zurück.
Public method | ApplyInPlace | Wendet die Gammaverteilung auf einen linearen RGB-Farbwert an.
Public method | Reverse | Wendet die Umkehrfunktion der Gammaverteilung auf einen nicht linearen RGB-Farbwert an und gibt den linearen Farbwert zurück.
Public method | ReverseInPlace | Wendet die Umkehrfunktion der Gammaverteilung auf einen nicht linearen RGB-Farbwert an.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)
 | Transfer_1_8 | Die Transferfunktion für eine logarithmische Kurve mit dem Exponenten 1,8.
 | Transfer_1_8_Inv | Die Umkehrfunktion für eine logarithmische Kurve mit dem Exponenten 1,8.
 | Transfer_2_2 | Die Transferfunktion für eine logarithmische Kurve mit dem Exponenten 2,2.
 | Transfer_2_2_Inv | Die Umkehrfunktion für eine logarithmische Kurve mit dem Exponenten 2,2.
 | Transfer_LStar | Die Transferfunktion für die spezifische L*-Gammakurve.
 | Transfer_LStar_Inv | Die Umkehrfunktion für die spezifische L*-Gammakurve.
 | Transfer_sRGB | Die Transferfunktion für die spezifische sRGB-Gammakurve.
 | Transfer_sRGB_Inv | Die Umkehrfunktion für die spezifische sRGB-Gammakurve.
 | TransferIdentity | Die Transferfunktion für eine lineare "Gammakurve".

Properties

 | Name | Description
 | ByName | Gibt ein Dictionary zurück, dass alle standardisierten Gammaverteilungen enthält.
Public property | Description | Eine kurze Beschreibung der Gammaverteilung oder null.
Public property | InverseTransfer | Die Funktion um Gamma-verteilte Werte in lineare Werte zurück zu rechnen.
Public property | Name | Der Name der Gammaverteilung.
Public property | Transfer | Die Funktion zu Anwendung der Gammaverteilung auf lineare Werte.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


GammaCompanding Constructor

[image] [image]

DynamicNodes API
GammaCompanding Constructor
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | GammaCompanding(String, String, Single) | Initialisiert eine neue Instanz der Klasse GammaCompanding mit einer logarithmischen Verteilung.
Public method | GammaCompanding(String, String, GammaTransferFunction, GammaTransferFunction) | Initialisiert eine neue Instanz der Klasse GammaCompanding.

See Also

GammaCompanding Class
GammaCompanding Members
DynamicNode.Types.Imaging Namespace


GammaCompanding Constructor (String, String, Single)

[image]

DynamicNodes API
GammaCompanding Constructor (String, String, Single)
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse GammaCompanding mit einer logarithmischen Verteilung.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public GammaCompanding(
    string name,
    string description,
    float exponent
)
Visual Basic
Public Sub New ( _
    name As String, _
    description As String, _
    exponent As Single _
)
F#
new :
        name:string *
        description:string *
        exponent:float32 -> GammaCompanding

Parameters

name
Type: System..::..String
Der Name der Gammaverteilung.
description
Type: System..::..String
Die Beschreibung der Gammaverteilung oder null.
exponent
Type: System..::..Single
Der Exponent der Verteilung, z.B. 1.8 oder 2.2.

See Also

GammaCompanding Class
GammaCompanding Overload
DynamicNode.Types.Imaging Namespace


GammaCompanding Constructor (String, String, GammaTransferFunction, GammaTransferFunction)

[image]

DynamicNodes API
GammaCompanding Constructor (String, String, GammaTransferFunction, GammaTransferFunction)
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse GammaCompanding.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public GammaCompanding(
    string name,
    string description,
    GammaTransferFunction transfer,
    GammaTransferFunction inverseTransfer
)
Visual Basic
Public Sub New ( _
    name As String, _
    description As String, _
    transfer As GammaTransferFunction, _
    inverseTransfer As GammaTransferFunction _
)
F#
new :
        name:string *
        description:string *
        transfer:GammaTransferFunction *
        inverseTransfer:GammaTransferFunction -> GammaCompanding

Parameters

name
Type: System..::..String
Der Name der Gammaverteilung.
description
Type: System..::..String
Die Beschreibung der Gammaverteilung oder null.
transfer
Type: DynamicNode.Types.Imaging..::..GammaTransferFunction
Die Transferfunktion der Gammaverteilung.
inverseTransfer
Type: DynamicNode.Types.Imaging..::..GammaTransferFunction
Die Umkehrfunktion der Gammaverteilung.

See Also

GammaCompanding Class
GammaCompanding Overload
DynamicNode.Types.Imaging Namespace


GammaCompanding Methods

[image] [image]

DynamicNodes API
GammaCompanding Methods
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GammaCompanding type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Wendet die Gammaverteilung auf einen linearen RGB-Farbwert an und gibt den nicht linearen Farbwert zurück.
Public method | ApplyInPlace | Wendet die Gammaverteilung auf einen linearen RGB-Farbwert an.
Public method | Reverse | Wendet die Umkehrfunktion der Gammaverteilung auf einen nicht linearen RGB-Farbwert an und gibt den linearen Farbwert zurück.
Public method | ReverseInPlace | Wendet die Umkehrfunktion der Gammaverteilung auf einen nicht linearen RGB-Farbwert an.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)
 | Transfer_1_8 | Die Transferfunktion für eine logarithmische Kurve mit dem Exponenten 1,8.
 | Transfer_1_8_Inv | Die Umkehrfunktion für eine logarithmische Kurve mit dem Exponenten 1,8.
 | Transfer_2_2 | Die Transferfunktion für eine logarithmische Kurve mit dem Exponenten 2,2.
 | Transfer_2_2_Inv | Die Umkehrfunktion für eine logarithmische Kurve mit dem Exponenten 2,2.
 | Transfer_LStar | Die Transferfunktion für die spezifische L*-Gammakurve.
 | Transfer_LStar_Inv | Die Umkehrfunktion für die spezifische L*-Gammakurve.
 | Transfer_sRGB | Die Transferfunktion für die spezifische sRGB-Gammakurve.
 | Transfer_sRGB_Inv | Die Umkehrfunktion für die spezifische sRGB-Gammakurve.
 | TransferIdentity | Die Transferfunktion für eine lineare "Gammakurve".

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Apply Method

[image]

DynamicNodes API
GammaCompanding..::..Apply Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wendet die Gammaverteilung auf einen linearen RGB-Farbwert an und gibt den nicht linearen Farbwert zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_RGB Apply(
    ColorValue_RGB rgbLinear
)
Visual Basic
Public Function Apply ( _
    rgbLinear As ColorValue_RGB _
) As ColorValue_RGB
F#
member Apply :
        rgbLinear:ColorValue_RGB -> ColorValue_RGB

Parameters

rgbLinear
Type: DynamicNode.Types.Imaging..::..ColorValue_RGB
Ein linearer RGB-Farbwert.

Return Value

Ein nicht linearer RGB-Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


ApplyInPlace Method

[image]

DynamicNodes API
GammaCompanding..::..ApplyInPlace Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wendet die Gammaverteilung auf einen linearen RGB-Farbwert an.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void ApplyInPlace(
    ref ColorValue_RGB rgb
)
Visual Basic
Public Sub ApplyInPlace ( _
    ByRef rgb As ColorValue_RGB _
)
F#
member ApplyInPlace :
        rgb:ColorValue_RGB byref -> unit

Parameters

rgb
Type: DynamicNode.Types.Imaging..::..ColorValue_RGB %
Ein RGB-Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Reverse Method

[image]

DynamicNodes API
GammaCompanding..::..Reverse Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wendet die Umkehrfunktion der Gammaverteilung auf einen nicht linearen RGB-Farbwert an und gibt den linearen Farbwert zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_RGB Reverse(
    ColorValue_RGB rgbNonLinear
)
Visual Basic
Public Function Reverse ( _
    rgbNonLinear As ColorValue_RGB _
) As ColorValue_RGB
F#
member Reverse :
        rgbNonLinear:ColorValue_RGB -> ColorValue_RGB

Parameters

rgbNonLinear
Type: DynamicNode.Types.Imaging..::..ColorValue_RGB
Ein nicht linearer RGB-Farbwert.

Return Value

Ein linearer RGB-Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


ReverseInPlace Method

[image]

DynamicNodes API
GammaCompanding..::..ReverseInPlace Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wendet die Umkehrfunktion der Gammaverteilung auf einen nicht linearen RGB-Farbwert an.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public void ReverseInPlace(
    ref ColorValue_RGB rgb
)
Visual Basic
Public Sub ReverseInPlace ( _
    ByRef rgb As ColorValue_RGB _
)
F#
member ReverseInPlace :
        rgb:ColorValue_RGB byref -> unit

Parameters

rgb
Type: DynamicNode.Types.Imaging..::..ColorValue_RGB %
Ein RGB-Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
GammaCompanding..::..ToString Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Transfer_1_8 Method

[image]

DynamicNodes API
GammaCompanding..::..Transfer_1_8 Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Transferfunktion für eine logarithmische Kurve mit dem Exponenten 1,8.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float Transfer_1_8(
    float vLinear
)
Visual Basic
Public Shared Function Transfer_1_8 ( _
    vLinear As Single _
) As Single
F#
static member Transfer_1_8 :
        vLinear:float32 -> float32

Parameters

vLinear
Type: System..::..Single
Der lineare Farbwert.

Return Value

Der angepasste Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Transfer_1_8_Inv Method

[image]

DynamicNodes API
GammaCompanding..::..Transfer_1_8_Inv Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Umkehrfunktion für eine logarithmische Kurve mit dem Exponenten 1,8.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float Transfer_1_8_Inv(
    float v
)
Visual Basic
Public Shared Function Transfer_1_8_Inv ( _
    v As Single _
) As Single
F#
static member Transfer_1_8_Inv :
        v:float32 -> float32

Parameters

v
Type: System..::..Single
Der angepasste Farbwert.

Return Value

Der lineare Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Transfer_2_2 Method

[image]

DynamicNodes API
GammaCompanding..::..Transfer_2_2 Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Transferfunktion für eine logarithmische Kurve mit dem Exponenten 2,2.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float Transfer_2_2(
    float vLinear
)
Visual Basic
Public Shared Function Transfer_2_2 ( _
    vLinear As Single _
) As Single
F#
static member Transfer_2_2 :
        vLinear:float32 -> float32

Parameters

vLinear
Type: System..::..Single
Der lineare Farbwert.

Return Value

Der angepasste Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Transfer_2_2_Inv Method

[image]

DynamicNodes API
GammaCompanding..::..Transfer_2_2_Inv Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Umkehrfunktion für eine logarithmische Kurve mit dem Exponenten 2,2.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float Transfer_2_2_Inv(
    float v
)
Visual Basic
Public Shared Function Transfer_2_2_Inv ( _
    v As Single _
) As Single
F#
static member Transfer_2_2_Inv :
        v:float32 -> float32

Parameters

v
Type: System..::..Single
Der angepasste Farbwert.

Return Value

Der lineare Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Transfer_LStar Method

[image]

DynamicNodes API
GammaCompanding..::..Transfer_LStar Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Transferfunktion für die spezifische L*-Gammakurve.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float Transfer_LStar(
    float vLinear
)
Visual Basic
Public Shared Function Transfer_LStar ( _
    vLinear As Single _
) As Single
F#
static member Transfer_LStar :
        vLinear:float32 -> float32

Parameters

vLinear
Type: System..::..Single
Der lineare Farbwert.

Return Value

Der angepasste Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Transfer_LStar_Inv Method

[image]

DynamicNodes API
GammaCompanding..::..Transfer_LStar_Inv Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Umkehrfunktion für die spezifische L*-Gammakurve.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float Transfer_LStar_Inv(
    float v
)
Visual Basic
Public Shared Function Transfer_LStar_Inv ( _
    v As Single _
) As Single
F#
static member Transfer_LStar_Inv :
        v:float32 -> float32

Parameters

v
Type: System..::..Single
Der angepasste Farbwert.

Return Value

Der lineare Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Transfer_sRGB Method

[image]

DynamicNodes API
GammaCompanding..::..Transfer_sRGB Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Transferfunktion für die spezifische sRGB-Gammakurve.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float Transfer_sRGB(
    float vLinear
)
Visual Basic
Public Shared Function Transfer_sRGB ( _
    vLinear As Single _
) As Single
F#
static member Transfer_sRGB :
        vLinear:float32 -> float32

Parameters

vLinear
Type: System..::..Single
Der lineare Farbwert.

Return Value

Der angepasste Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Transfer_sRGB_Inv Method

[image]

DynamicNodes API
GammaCompanding..::..Transfer_sRGB_Inv Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Umkehrfunktion für die spezifische sRGB-Gammakurve.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float Transfer_sRGB_Inv(
    float v
)
Visual Basic
Public Shared Function Transfer_sRGB_Inv ( _
    v As Single _
) As Single
F#
static member Transfer_sRGB_Inv :
        v:float32 -> float32

Parameters

v
Type: System..::..Single
Der angepasste Farbwert.

Return Value

Der lineare Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


TransferIdentity Method

[image]

DynamicNodes API
GammaCompanding..::..TransferIdentity Method
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Transferfunktion für eine lineare "Gammakurve".

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static float TransferIdentity(
    float v
)
Visual Basic
Public Shared Function TransferIdentity ( _
    v As Single _
) As Single
F#
static member TransferIdentity :
        v:float32 -> float32

Parameters

v
Type: System..::..Single
Der zu berechnende Farbwert.

Return Value

Der angepasste Farbwert.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


GammaCompanding Properties

[image] [image]

DynamicNodes API
GammaCompanding Properties
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GammaCompanding type exposes the following members.

Properties

 | Name | Description
 | ByName | Gibt ein Dictionary zurück, dass alle standardisierten Gammaverteilungen enthält.
Public property | Description | Eine kurze Beschreibung der Gammaverteilung oder null.
Public property | InverseTransfer | Die Funktion um Gamma-verteilte Werte in lineare Werte zurück zu rechnen.
Public property | Name | Der Name der Gammaverteilung.
Public property | Transfer | Die Funktion zu Anwendung der Gammaverteilung auf lineare Werte.

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


ByName Property

[image]

DynamicNodes API
GammaCompanding..::..ByName Property
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Dictionary zurück, dass alle standardisierten Gammaverteilungen enthält.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static IDictionary<GammaCompandingName, GammaCompanding> ByName { get; }
Visual Basic
Public Shared ReadOnly Property ByName As IDictionary(Of GammaCompandingName, GammaCompanding)
    Get
F#
static member ByName : IDictionary<GammaCompandingName, GammaCompanding>

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Description Property

[image]

DynamicNodes API
GammaCompanding..::..Description Property
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine kurze Beschreibung der Gammaverteilung oder null.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public string Description { get; private set; }
Visual Basic
Public Property Description As String
    Get
    Private Set
F#
member Description : string with get, private set

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


InverseTransfer Property

[image]

DynamicNodes API
GammaCompanding..::..InverseTransfer Property
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Funktion um Gamma-verteilte Werte in lineare Werte zurück zu rechnen.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public GammaTransferFunction InverseTransfer { get; private set; }
Visual Basic
Public Property InverseTransfer As GammaTransferFunction
    Get
    Private Set
F#
member InverseTransfer : GammaTransferFunction with get, private set

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Name Property

[image]

DynamicNodes API
GammaCompanding..::..Name Property
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Name der Gammaverteilung.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
F#
member Name : string with get, private set

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


Transfer Property

[image]

DynamicNodes API
GammaCompanding..::..Transfer Property
GammaCompanding Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Funktion zu Anwendung der Gammaverteilung auf lineare Werte.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public GammaTransferFunction Transfer { get; private set; }
Visual Basic
Public Property Transfer As GammaTransferFunction
    Get
    Private Set
F#
member Transfer : GammaTransferFunction with get, private set

See Also

GammaCompanding Class
DynamicNode.Types.Imaging Namespace


GammaCompandingName Enumeration

[image]

DynamicNodes API
GammaCompandingName Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Aufzählung der Namen von standardisierten Gammaverteilungen.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public enum GammaCompandingName
Visual Basic
Public Enumeration GammaCompandingName
F#
type GammaCompandingName

Members

Member name | Description
None |
Log_1_8 |
Log_2_2 |
sRGB |
LStar |

See Also

DynamicNode.Types.Imaging Namespace


GammaTransferFunction Delegate

[image]

DynamicNodes API
GammaTransferFunction Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Delegat für eine Gamma-Transfer- und eine Gamma-Umkehrfunktion.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public delegate float GammaTransferFunction(
    float v
)
Visual Basic
Public Delegate Function GammaTransferFunction ( _
    v As Single _
) As Single
F#
type GammaTransferFunction =
    delegate of
        v:float32 -> float32

Parameters

v
Type: System..::..Single
Der zu verarbeitende Wert.

Return Value

Der verarbeitete Wert.

See Also

DynamicNode.Types.Imaging Namespace


IRGBImage Interface

[image]

DynamicNodes API
IRGBImage Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine gemeinsame Schnittstelle für Farbbilder in einem geräteabhängigem RGB-Farbmodell.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public interface IRGBImage
Visual Basic
Public Interface IRGBImage
F#
type IRGBImage =  interface end

See Also

IRGBImage Members
DynamicNode.Types.Imaging Namespace


IRGBImage Members

[image] [image]

DynamicNodes API
IRGBImage Members
IRGBImage Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRGBImage type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe.

Properties

 | Name | Description
Public property | Height | Gibt die Höhe des Bildes zurück.
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.
Public property | Item | Liest oder schreibt einen Farbwert als ColorValue_RGB.
Public property | Width | Gibt die Breite des Bildes zurück.

See Also

IRGBImage Interface
DynamicNode.Types.Imaging Namespace


IRGBImage Methods

[image] [image]

DynamicNodes API
IRGBImage Methods
IRGBImage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRGBImage type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe.

See Also

IRGBImage Interface
DynamicNode.Types.Imaging Namespace


Initialize Method

[image]

DynamicNodes API
IRGBImage..::..Initialize Method
IRGBImage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert das Bild mit der angegebenen Größe.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
void Initialize(
    int width,
    int height
)
Visual Basic
Sub Initialize ( _
    width As Integer, _
    height As Integer _
)
F#
abstract Initialize :
        width:int *
        height:int -> unit

Parameters

width
Type: System..::..Int32
Die Breite des Bildes
height
Type: System..::..Int32
Die Höhe des Bildes

Remarks

Beim Initialisieren werden neue Arrays zur Speicherung der Daten allokiert.

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width oder height ein Wert kleiner 0 übergeben wird.

See Also

IRGBImage Interface
DynamicNode.Types.Imaging Namespace


IRGBImage Properties

[image] [image]

DynamicNodes API
IRGBImage Properties
IRGBImage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IRGBImage type exposes the following members.

Properties

 | Name | Description
Public property | Height | Gibt die Höhe des Bildes zurück.
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.
Public property | Item | Liest oder schreibt einen Farbwert als ColorValue_RGB.
Public property | Width | Gibt die Breite des Bildes zurück.

See Also

IRGBImage Interface
DynamicNode.Types.Imaging Namespace


Height Property

[image]

DynamicNodes API
IRGBImage..::..Height Property
IRGBImage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Höhe des Bildes zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
int Height { get; }
Visual Basic
ReadOnly Property Height As Integer
    Get
F#
abstract Height : int

See Also

IRGBImage Interface
DynamicNode.Types.Imaging Namespace


IsInitialized Property

[image]

DynamicNodes API
IRGBImage..::..IsInitialized Property
IRGBImage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
bool IsInitialized { get; }
Visual Basic
ReadOnly Property IsInitialized As Boolean
    Get
F#
abstract IsInitialized : bool

See Also

IRGBImage Interface
DynamicNode.Types.Imaging Namespace


Item Property

[image]

DynamicNodes API
IRGBImage..::..Item Property
IRGBImage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Liest oder schreibt einen Farbwert als ColorValue_RGB.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
ColorValue_RGB this[
    int x,
    int y
] { get; set; }
Visual Basic
Default Property Item ( _
    x As Integer, _
    y As Integer _
) As ColorValue_RGB
    Get
    Set
F#
abstract Item : ColorValue_RGB with get, set

Parameters

x
Type: System..::..Int32
Die Bildspalte.
y
Type: System..::..Int32
Die Bildzeile.

Return Value

Der Farbwert in einem geräteabhängigen RGB-Farbwert.

See Also

IRGBImage Interface
DynamicNode.Types.Imaging Namespace


Width Property

[image]

DynamicNodes API
IRGBImage..::..Width Property
IRGBImage Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Breite des Bildes zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
int Width { get; }
Visual Basic
ReadOnly Property Width As Integer
    Get
F#
abstract Width : int

See Also

IRGBImage Interface
DynamicNode.Types.Imaging Namespace


KernelNormalization Enumeration

[image]

DynamicNodes API
KernelNormalization Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Aufzählung mit Normierungsmethoden für einen Kernel.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public enum KernelNormalization
Visual Basic
Public Enumeration KernelNormalization
F#
type KernelNormalization

Members

Member name | Description
None |
Max |
Dynamic |
Sum |

See Also

DynamicNode.Types.Imaging Namespace


KernelPyramid Class

[image]

DynamicNodes API
KernelPyramid Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Kernel-Pyramide berechnet verkleinerte Größen eines Ur-Kernels bis zu 1x1 zur Verfügung. Dabei ist es möglich einen Cache für eine definierte Anzahl von Zwischengrößen zur Optimierung zu verwenden.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public class KernelPyramid
Visual Basic
Public Class KernelPyramid
F#
type KernelPyramid =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Imaging..::..KernelPyramid

See Also

KernelPyramid Members
DynamicNode.Types.Imaging Namespace


KernelPyramid Members

[image] [image]

DynamicNodes API
KernelPyramid Members
KernelPyramid Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The KernelPyramid type exposes the following members.

Constructors

 | Name | Description
Public method | KernelPyramid | Initialisiert eine neue Instanz der Klasse KernelPyramid.

Methods

 | Name | Description
Public method | GetKernel | Gibt einen Kernel für die angegebene Skalierung zurück. Falls noch keine Kernel mit der angegebenen Skalierung berechnet wurde oder der Cache deaktiviert ist, wird der Kernel berechnet, andernfalls wird er direkt aus dem Cache aufgerufen.

See Also

KernelPyramid Class
DynamicNode.Types.Imaging Namespace


KernelPyramid Constructor

[image]

DynamicNodes API
KernelPyramid Constructor
KernelPyramid Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse KernelPyramid.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public KernelPyramid(
    Matrix<float> kernel,
    int cacheSize
)
Visual Basic
Public Sub New ( _
    kernel As Matrix(Of Single), _
    cacheSize As Integer _
)
F#
new :
        kernel:Matrix<float32> *
        cacheSize:int -> KernelPyramid

Parameters

kernel
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der Ur-Kernel.
cacheSize
Type: System..::..Int32
Die Größe des Caches zur Zugriffsoptimierung oder 0, wenn kein Cache verwendet werden soll.

See Also

KernelPyramid Class
DynamicNode.Types.Imaging Namespace


KernelPyramid Methods

[image] [image]

DynamicNodes API
KernelPyramid Methods
KernelPyramid Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The KernelPyramid type exposes the following members.

Methods

 | Name | Description
Public method | GetKernel | Gibt einen Kernel für die angegebene Skalierung zurück. Falls noch keine Kernel mit der angegebenen Skalierung berechnet wurde oder der Cache deaktiviert ist, wird der Kernel berechnet, andernfalls wird er direkt aus dem Cache aufgerufen.

See Also

KernelPyramid Class
DynamicNode.Types.Imaging Namespace


GetKernel Method

[image]

DynamicNodes API
KernelPyramid..::..GetKernel Method
KernelPyramid Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Kernel für die angegebene Skalierung zurück. Falls noch keine Kernel mit der angegebenen Skalierung berechnet wurde oder der Cache deaktiviert ist, wird der Kernel berechnet, andernfalls wird er direkt aus dem Cache aufgerufen.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float[,] GetKernel(
    float scale,
    KernelNormalization norm
)
Visual Basic
Public Function GetKernel ( _
    scale As Single, _
    norm As KernelNormalization _
) As Single(,)
F#
member GetKernel :
        scale:float32 *
        norm:KernelNormalization -> float32[,]

Parameters

scale
Type: System..::..Single
Die Skalierung des Kernel zwischen 0 und 1.
norm
Type: DynamicNode.Types.Imaging..::..KernelNormalization
Die Methode für eine Normierung des Kernels.

Return Value

Der skalierte Kernel.

See Also

KernelPyramid Class
DynamicNode.Types.Imaging Namespace


LabImage32 Class

[image]

DynamicNodes API
LabImage32 Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein spezielles Tupel mit drei Elementen zur Aufnahme von L-, a- und b-Kanälen eines geräteunabhängigen Farbbildes mit dem elementaren Datentyp Single.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class LabImage32 : Tupel<Matrix<float>>
Visual Basic
<SerializableAttribute> _
Public Class LabImage32 _
    Inherits Tupel(Of Matrix(Of Single))
F#
[<SerializableAttribute>]
type LabImage32 =
    class
        inherit Tupel<Matrix<float32>>
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Tupel <(Of <(<' Matrix <(Of <(<' Single >)>)>>)>)>
DynamicNode.Types.Imaging..::..LabImage32

See Also

LabImage32 Members
DynamicNode.Types.Imaging Namespace


LabImage32 Members

[image] [image]

DynamicNodes API
LabImage32 Members
LabImage32 Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The LabImage32 type exposes the following members.

Constructors

 | Name | Description
Protected method | LabImage32()()()() | Initialisiert eine neue Instanz von LabImage32.
Public method | LabImage32(Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>)) | Initialisiert eine neue Instanz von LabImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.
Public method | LabImage32(Int32, Int32, Single, Single, Single) | Initialisiert eine neue Instanz der LabImage32-Klasse.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

Properties

 | Name | Description
Public property | a | Gibt den Grün-Kanal zurück.
Public property | b | Gibt den Blau-Kanal zurück.
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den Lab-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | L | Gibt den L-Kanal zurück.

See Also

LabImage32 Class
DynamicNode.Types.Imaging Namespace


LabImage32 Constructor

[image] [image]

DynamicNodes API
LabImage32 Constructor
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | LabImage32()()()() | Initialisiert eine neue Instanz von LabImage32.
Public method | LabImage32(Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>)) | Initialisiert eine neue Instanz von LabImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.
Public method | LabImage32(Int32, Int32, Single, Single, Single) | Initialisiert eine neue Instanz der LabImage32-Klasse.

See Also

LabImage32 Class
LabImage32 Members
DynamicNode.Types.Imaging Namespace


LabImage32 Constructor

[image]

DynamicNodes API
LabImage32 Constructor
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von LabImage32.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected LabImage32()
Visual Basic
Protected Sub New
F#
new : unit -> LabImage32

See Also

LabImage32 Class
LabImage32 Overload
DynamicNode.Types.Imaging Namespace


LabImage32 Constructor (Matrix(Single), Matrix(Single), Matrix(Single))

[image]

DynamicNodes API
LabImage32 Constructor (Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>)
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von LabImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public LabImage32(
    Matrix<float> l,
    Matrix<float> a,
    Matrix<float> b
)
Visual Basic
Public Sub New ( _
    l As Matrix(Of Single), _
    a As Matrix(Of Single), _
    b As Matrix(Of Single) _
)
F#
new :
        l:Matrix<float32> *
        a:Matrix<float32> *
        b:Matrix<float32> -> LabImage32

Parameters

l
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der L-Kanal.
a
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der a-Kanal.
b
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der b-Kanal.

See Also

LabImage32 Class
LabImage32 Overload
DynamicNode.Types.Imaging Namespace


LabImage32 Constructor (Int32, Int32, Single, Single, Single)

[image]

DynamicNodes API
LabImage32 Constructor (Int32, Int32, Single, Single, Single)
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der LabImage32-Klasse.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public LabImage32(
    int width,
    int height,
    float defL,
    float defA,
    float defB
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    defL As Single, _
    defA As Single, _
    defB As Single _
)
F#
new :
        width:int *
        height:int *
        defL:float32 *
        defA:float32 *
        defB:float32 -> LabImage32

Parameters

width
Type: System..::..Int32
Die Breite.
height
Type: System..::..Int32
Die Höhe.
defL
Type: System..::..Single
Der Standardwert für Indexüberschreitungen im L-Kanal.
defA
Type: System..::..Single
Der Standardwert für Indexüberschreitungen im a-Kanal.
defB
Type: System..::..Single
Der Standardwert für Indexüberschreitungen im b-Kanal.

See Also

LabImage32 Class
LabImage32 Overload
DynamicNode.Types.Imaging Namespace


LabImage32 Methods

[image] [image]

DynamicNodes API
LabImage32 Methods
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The LabImage32 type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

See Also

LabImage32 Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
LabImage32..::..ToString Method
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

LabImage32 Class
DynamicNode.Types.Imaging Namespace


LabImage32 Properties

[image] [image]

DynamicNodes API
LabImage32 Properties
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The LabImage32 type exposes the following members.

Properties

 | Name | Description
Public property | a | Gibt den Grün-Kanal zurück.
Public property | b | Gibt den Blau-Kanal zurück.
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den Lab-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | L | Gibt den L-Kanal zurück.

See Also

LabImage32 Class
DynamicNode.Types.Imaging Namespace


a Property

[image]

DynamicNodes API
LabImage32..::..a Property
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Grün-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> a { get; private set; }
Visual Basic
Public Property a As Matrix(Of Single)
    Get
    Private Set
F#
member a : Matrix<float32> with get, private set

Field Value

Der Grün-Kanal.

See Also

LabImage32 Class
DynamicNode.Types.Imaging Namespace


b Property

[image]

DynamicNodes API
LabImage32..::..b Property
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Blau-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> b { get; private set; }
Visual Basic
Public Property b As Matrix(Of Single)
    Get
    Private Set
F#
member b : Matrix<float32> with get, private set

Field Value

Der Blau-Kanal.

See Also

LabImage32 Class
DynamicNode.Types.Imaging Namespace


Item Property

[image] [image]

DynamicNodes API
LabImage32..::..Item Property
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den Lab-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

See Also

LabImage32 Class
LabImage32 Members
DynamicNode.Types.Imaging Namespace


Item Property (Int32, Int32)

[image]

DynamicNodes API
LabImage32..::..Item Property (Int32, Int32)
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Lab-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_Lab this[
    int x,
    int y
] { get; set; }
Visual Basic
Public Default Property Item ( _
    x As Integer, _
    y As Integer _
) As ColorValue_Lab
    Get
    Set
F#
member Item : ColorValue_Lab with get, set

Parameters

x
Type: System..::..Int32
Die X-Koordinate des Pixels.
y
Type: System..::..Int32
Die Y-Koordinate des Pixels.

Return Value

Den Lab-Farbwert des Pixels.

See Also

LabImage32 Class
Item Overload
DynamicNode.Types.Imaging Namespace


L Property

[image]

DynamicNodes API
LabImage32..::..L Property
LabImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den L-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> L { get; private set; }
Visual Basic
Public Property L As Matrix(Of Single)
    Get
    Private Set
F#
member L : Matrix<float32> with get, private set

Field Value

Der L-Kanal.

See Also

LabImage32 Class
DynamicNode.Types.Imaging Namespace


LCHImage32 Class

[image]

DynamicNodes API
LCHImage32 Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein spezielles Tupel mit drei Elementen zur Aufnahme von L-, C- und H-Kanälen eines geräteunabhängigen LCH(ab)-Farbbildes mit dem elementaren Datentyp Single.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class LCHImage32 : Tupel<Matrix<float>>
Visual Basic
<SerializableAttribute> _
Public Class LCHImage32 _
    Inherits Tupel(Of Matrix(Of Single))
F#
[<SerializableAttribute>]
type LCHImage32 =
    class
        inherit Tupel<Matrix<float32>>
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Tupel <(Of <(<' Matrix <(Of <(<' Single >)>)>>)>)>
DynamicNode.Types.Imaging..::..LCHImage32

See Also

LCHImage32 Members
DynamicNode.Types.Imaging Namespace


LCHImage32 Members

[image] [image]

DynamicNodes API
LCHImage32 Members
LCHImage32 Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The LCHImage32 type exposes the following members.

Constructors

 | Name | Description
Protected method | LCHImage32()()()() | Initialisiert eine neue Instanz von LCHImage32.
Public method | LCHImage32(Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>)) | Initialisiert eine neue Instanz von LCHImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.
Public method | LCHImage32(Int32, Int32, Single, Single, Single) | Initialisiert eine neue Instanz der LCHImage32-Klasse.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

Properties

 | Name | Description
Public property | C | Gibt den Farbigkeits-Kanal (Sättingung / chromaticity) zurück.
Public property | H | Gibt den Farbton-Kanal (hue) zurück.
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den LCH(ab)-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | L | Gibt den L-Kanal zurück.

See Also

LCHImage32 Class
DynamicNode.Types.Imaging Namespace


LCHImage32 Constructor

[image] [image]

DynamicNodes API
LCHImage32 Constructor
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | LCHImage32()()()() | Initialisiert eine neue Instanz von LCHImage32.
Public method | LCHImage32(Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>)) | Initialisiert eine neue Instanz von LCHImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.
Public method | LCHImage32(Int32, Int32, Single, Single, Single) | Initialisiert eine neue Instanz der LCHImage32-Klasse.

See Also

LCHImage32 Class
LCHImage32 Members
DynamicNode.Types.Imaging Namespace


LCHImage32 Constructor

[image]

DynamicNodes API
LCHImage32 Constructor
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von LCHImage32.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected LCHImage32()
Visual Basic
Protected Sub New
F#
new : unit -> LCHImage32

See Also

LCHImage32 Class
LCHImage32 Overload
DynamicNode.Types.Imaging Namespace


LCHImage32 Constructor (Matrix(Single), Matrix(Single), Matrix(Single))

[image]

DynamicNodes API
LCHImage32 Constructor (Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>)
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von LCHImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public LCHImage32(
    Matrix<float> l,
    Matrix<float> c,
    Matrix<float> h
)
Visual Basic
Public Sub New ( _
    l As Matrix(Of Single), _
    c As Matrix(Of Single), _
    h As Matrix(Of Single) _
)
F#
new :
        l:Matrix<float32> *
        c:Matrix<float32> *
        h:Matrix<float32> -> LCHImage32

Parameters

l
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der L-Kanal.
c
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der C-Kanal.
h
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der H-Kanal.

See Also

LCHImage32 Class
LCHImage32 Overload
DynamicNode.Types.Imaging Namespace


LCHImage32 Constructor (Int32, Int32, Single, Single, Single)

[image]

DynamicNodes API
LCHImage32 Constructor (Int32, Int32, Single, Single, Single)
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der LCHImage32-Klasse.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public LCHImage32(
    int width,
    int height,
    float defL,
    float defC,
    float defH
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    defL As Single, _
    defC As Single, _
    defH As Single _
)
F#
new :
        width:int *
        height:int *
        defL:float32 *
        defC:float32 *
        defH:float32 -> LCHImage32

Parameters

width
Type: System..::..Int32
Die Breite.
height
Type: System..::..Int32
Die Höhe.
defL
Type: System..::..Single
Der Standardwert für Indexüberschreitungen im L-Kanal.
defC
Type: System..::..Single
Der Standardwert für Indexüberschreitungen im C-Kanal.
defH
Type: System..::..Single
Der Standardwert für Indexüberschreitungen im H-Kanal.

See Also

LCHImage32 Class
LCHImage32 Overload
DynamicNode.Types.Imaging Namespace


LCHImage32 Methods

[image] [image]

DynamicNodes API
LCHImage32 Methods
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The LCHImage32 type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

See Also

LCHImage32 Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
LCHImage32..::..ToString Method
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

LCHImage32 Class
DynamicNode.Types.Imaging Namespace


LCHImage32 Properties

[image] [image]

DynamicNodes API
LCHImage32 Properties
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The LCHImage32 type exposes the following members.

Properties

 | Name | Description
Public property | C | Gibt den Farbigkeits-Kanal (Sättingung / chromaticity) zurück.
Public property | H | Gibt den Farbton-Kanal (hue) zurück.
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den LCH(ab)-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | L | Gibt den L-Kanal zurück.

See Also

LCHImage32 Class
DynamicNode.Types.Imaging Namespace


C Property

[image]

DynamicNodes API
LCHImage32..::..C Property
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Farbigkeits-Kanal (Sättingung / chromaticity) zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> C { get; private set; }
Visual Basic
Public Property C As Matrix(Of Single)
    Get
    Private Set
F#
member C : Matrix<float32> with get, private set

Field Value

Der Farbigkeits-Kanal.

See Also

LCHImage32 Class
DynamicNode.Types.Imaging Namespace


H Property

[image]

DynamicNodes API
LCHImage32..::..H Property
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Farbton-Kanal (hue) zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> H { get; private set; }
Visual Basic
Public Property H As Matrix(Of Single)
    Get
    Private Set
F#
member H : Matrix<float32> with get, private set

Field Value

Der Farbton-Kanal.

See Also

LCHImage32 Class
DynamicNode.Types.Imaging Namespace


Item Property

[image] [image]

DynamicNodes API
LCHImage32..::..Item Property
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den LCH(ab)-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

See Also

LCHImage32 Class
LCHImage32 Members
DynamicNode.Types.Imaging Namespace


Item Property (Int32, Int32)

[image]

DynamicNodes API
LCHImage32..::..Item Property (Int32, Int32)
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den LCH(ab)-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_LCH this[
    int x,
    int y
] { get; set; }
Visual Basic
Public Default Property Item ( _
    x As Integer, _
    y As Integer _
) As ColorValue_LCH
    Get
    Set
F#
member Item : ColorValue_LCH with get, set

Parameters

x
Type: System..::..Int32
Die X-Koordinate des Pixels.
y
Type: System..::..Int32
Die Y-Koordinate des Pixels.

Return Value

Den Lab-Farbwert des Pixels.

See Also

LCHImage32 Class
Item Overload
DynamicNode.Types.Imaging Namespace


L Property

[image]

DynamicNodes API
LCHImage32..::..L Property
LCHImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den L-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> L { get; private set; }
Visual Basic
Public Property L As Matrix(Of Single)
    Get
    Private Set
F#
member L : Matrix<float32> with get, private set

Field Value

Der L-Kanal.

See Also

LCHImage32 Class
DynamicNode.Types.Imaging Namespace


RgbColorSpace Class

[image]

DynamicNodes API
RgbColorSpace Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Repräsentiert einen geräteabhängigen RGB-Farbraum oder einen RGB-Arbeitsfarbraum. Ein RGB-Farbraum setzt sich aus einem Weißpunkt, den xyY-Referenzpunkten von Rot, Grün und Blau und einer Gammaverteilung für die Speicherung in Ganzzahlen (8Bit o. 16Bit) zusammen. Ein RGB-Arbeitsfarbraum kann verwendet werden, um geräteabhängige RGB-Werte (ColorValue_RGB) in geräteunabhängige XYZ-Werte (ColorValue_XYZ) konvertiert werden und umgekehrt.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public class RgbColorSpace
Visual Basic
Public Class RgbColorSpace
F#
type RgbColorSpace =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Imaging..::..RgbColorSpace

See Also

RgbColorSpace Members
DynamicNode.Types.Imaging Namespace


RgbColorSpace Members

[image] [image]

DynamicNodes API
RgbColorSpace Members
RgbColorSpace Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RgbColorSpace type exposes the following members.

Constructors

 | Name | Description
Public method | RgbColorSpace | Initialisiert eine neue Instanz der Klasse RgbColorSpace.

Methods

 | Name | Description
Public method | ConvertRGB2XYZ | Wandelt einen linearen geräteabhängiger RGB-Wert (ColorValue_RGB) in einen geräteunabhängigen XYZ-Wert (ColorValue_XYZ).
Public method | ConvertToWhitepoint | Transformatiert den Farbraum für einen neuen Weißpunkt.
Public method | ConvertXYZ2RGB | Wandelt einen geräteunabhängigen XYZ-Wert (ColorValue_XYZ) in einen linearen geräteabhängiger RGB-Wert (ColorValue_RGB).
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | B | Der Referenzpunkt für Blau.
 | ByName | Ein Dictionary für bekannte Farbräume.
Public property | Description | Eine kurze Beschreibung des Farbraums oder null.
Public property | G | Der Referenzpunkt für Grün.
Public property | Gamma | Die Gammaverteilung für die Speicherung von Farbwerten in Ganzzahlen.
Public property | Name | Der Name des Farbraums.
Public property | R | Der Referenzpunkt für Rot.
Public property | WhitePoint | Der Weißpunkt des Farbraums.

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


RgbColorSpace Constructor

[image]

DynamicNodes API
RgbColorSpace Constructor
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse RgbColorSpace.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RgbColorSpace(
    string name,
    string description,
    Whitepoint whitePoint,
    GammaCompanding gamma,
    ColorValue_xyY r,
    ColorValue_xyY g,
    ColorValue_xyY b
)
Visual Basic
Public Sub New ( _
    name As String, _
    description As String, _
    whitePoint As Whitepoint, _
    gamma As GammaCompanding, _
    r As ColorValue_xyY, _
    g As ColorValue_xyY, _
    b As ColorValue_xyY _
)
F#
new :
        name:string *
        description:string *
        whitePoint:Whitepoint *
        gamma:GammaCompanding *
        r:ColorValue_xyY *
        g:ColorValue_xyY *
        b:ColorValue_xyY -> RgbColorSpace

Parameters

name
Type: System..::..String
Der Name des Farbraums.
description
Type: System..::..String
Eine kurze Beschreibung des Farbraums oder null.
whitePoint
Type: DynamicNode.Types.Imaging..::..Whitepoint
Der Weißpunkt des Frabraums.
gamma
Type: DynamicNode.Types.Imaging..::..GammaCompanding
Die Gammaverteilung für die Speicherung in Ganzahlen.
r
Type: DynamicNode.Types.Imaging..::..ColorValue_xyY
Der Referenzpunkt für Rot.
g
Type: DynamicNode.Types.Imaging..::..ColorValue_xyY
Der Referenzpunkt für Grün.
b
Type: DynamicNode.Types.Imaging..::..ColorValue_xyY
Der Referenzpunkt für Blau.

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


RgbColorSpace Methods

[image] [image]

DynamicNodes API
RgbColorSpace Methods
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RgbColorSpace type exposes the following members.

Methods

 | Name | Description
Public method | ConvertRGB2XYZ | Wandelt einen linearen geräteabhängiger RGB-Wert (ColorValue_RGB) in einen geräteunabhängigen XYZ-Wert (ColorValue_XYZ).
Public method | ConvertToWhitepoint | Transformatiert den Farbraum für einen neuen Weißpunkt.
Public method | ConvertXYZ2RGB | Wandelt einen geräteunabhängigen XYZ-Wert (ColorValue_XYZ) in einen linearen geräteabhängiger RGB-Wert (ColorValue_RGB).
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


ConvertRGB2XYZ Method

[image]

DynamicNodes API
RgbColorSpace..::..ConvertRGB2XYZ Method
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt einen linearen geräteabhängiger RGB-Wert (ColorValue_RGB) in einen geräteunabhängigen XYZ-Wert (ColorValue_XYZ).

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_XYZ ConvertRGB2XYZ(
    ColorValue_RGB rgbLinear
)
Visual Basic
Public Function ConvertRGB2XYZ ( _
    rgbLinear As ColorValue_RGB _
) As ColorValue_XYZ
F#
member ConvertRGB2XYZ :
        rgbLinear:ColorValue_RGB -> ColorValue_XYZ

Parameters

rgbLinear
Type: DynamicNode.Types.Imaging..::..ColorValue_RGB
Ein linearer geräteabhängiger RGB-Wert.

Return Value

Einen geräteunabhängigen XYZ-Wert.

Remarks

Um einen ganzzahligen RGB-Wert (8Bit o. 16Bit) in einen linearen RGB-Wert umzuwandeln, muss der Wertebereich (0-255, 0-65535) zunächst auf 0-1 abgebildet und anschließend die Gammaverteilung des Farbraums (Gamma) für eine Linearisierung verwendet werden.

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


ConvertToWhitepoint Method

[image]

DynamicNodes API
RgbColorSpace..::..ConvertToWhitepoint Method
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Transformatiert den Farbraum für einen neuen Weißpunkt.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RgbColorSpace ConvertToWhitepoint(
    Whitepoint w,
    ChromaticAdaptionMethod method
)
Visual Basic
Public Function ConvertToWhitepoint ( _
    w As Whitepoint, _
    method As ChromaticAdaptionMethod _
) As RgbColorSpace
F#
member ConvertToWhitepoint :
        w:Whitepoint *
        method:ChromaticAdaptionMethod -> RgbColorSpace

Parameters

w
Type: DynamicNode.Types.Imaging..::..Whitepoint
Der neue Weißpunkt.
method
Type: DynamicNode.Types.Imaging..::..ChromaticAdaptionMethod
Die Transformationsmethode. Standardmethode ist 'Bradford'.

Return Value

Den neuen Farbraum.

Remarks

Wenn Farben zwischen geräteabhängigen RGB-Farbräumen und dem geräteunabhängigen XYZ-Farbraum transformiert werden, müssen die Weißpunkte aller geräteabhängigen Farbräume übereinstimmen.

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


ConvertXYZ2RGB Method

[image]

DynamicNodes API
RgbColorSpace..::..ConvertXYZ2RGB Method
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wandelt einen geräteunabhängigen XYZ-Wert (ColorValue_XYZ) in einen linearen geräteabhängiger RGB-Wert (ColorValue_RGB).

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_RGB ConvertXYZ2RGB(
    ColorValue_XYZ xyz
)
Visual Basic
Public Function ConvertXYZ2RGB ( _
    xyz As ColorValue_XYZ _
) As ColorValue_RGB
F#
member ConvertXYZ2RGB :
        xyz:ColorValue_XYZ -> ColorValue_RGB

Parameters

xyz
Type: DynamicNode.Types.Imaging..::..ColorValue_XYZ
Ein geräteunabhängigen XYZ-Wert.

Return Value

Einen linearer geräteabhängiger RGB-Wert.

Remarks

Um einen linearen RGB-Wert für die Speicherung in Ganzzahlen (8Bit o. 16Bit) vorzubereiten, muss er mit Hilfe der Gammaverteilung des Farbraums (Gamma) angepasst werden. Anschließend kann der Wertebereich von 0-1 auf den Wertebereich des Ganzzahligen Datentyps skaliert werden (0-255, 0-65535).

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
RgbColorSpace..::..ToString Method
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


RgbColorSpace Properties

[image] [image]

DynamicNodes API
RgbColorSpace Properties
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RgbColorSpace type exposes the following members.

Properties

 | Name | Description
Public property | B | Der Referenzpunkt für Blau.
 | ByName | Ein Dictionary für bekannte Farbräume.
Public property | Description | Eine kurze Beschreibung des Farbraums oder null.
Public property | G | Der Referenzpunkt für Grün.
Public property | Gamma | Die Gammaverteilung für die Speicherung von Farbwerten in Ganzzahlen.
Public property | Name | Der Name des Farbraums.
Public property | R | Der Referenzpunkt für Rot.
Public property | WhitePoint | Der Weißpunkt des Farbraums.

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


B Property

[image]

DynamicNodes API
RgbColorSpace..::..B Property
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Referenzpunkt für Blau.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_xyY B { get; private set; }
Visual Basic
Public Property B As ColorValue_xyY
    Get
    Private Set
F#
member B : ColorValue_xyY with get, private set

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


ByName Property

[image]

DynamicNodes API
RgbColorSpace..::..ByName Property
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Dictionary für bekannte Farbräume.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static IDictionary<RgbColorSpaceName, RgbColorSpace> ByName { get; }
Visual Basic
Public Shared ReadOnly Property ByName As IDictionary(Of RgbColorSpaceName, RgbColorSpace)
    Get
F#
static member ByName : IDictionary<RgbColorSpaceName, RgbColorSpace>

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


Description Property

[image]

DynamicNodes API
RgbColorSpace..::..Description Property
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine kurze Beschreibung des Farbraums oder null.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public string Description { get; private set; }
Visual Basic
Public Property Description As String
    Get
    Private Set
F#
member Description : string with get, private set

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


G Property

[image]

DynamicNodes API
RgbColorSpace..::..G Property
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Referenzpunkt für Grün.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_xyY G { get; private set; }
Visual Basic
Public Property G As ColorValue_xyY
    Get
    Private Set
F#
member G : ColorValue_xyY with get, private set

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


Gamma Property

[image]

DynamicNodes API
RgbColorSpace..::..Gamma Property
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Gammaverteilung für die Speicherung von Farbwerten in Ganzzahlen.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public GammaCompanding Gamma { get; private set; }
Visual Basic
Public Property Gamma As GammaCompanding
    Get
    Private Set
F#
member Gamma : GammaCompanding with get, private set

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


Name Property

[image]

DynamicNodes API
RgbColorSpace..::..Name Property
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Name des Farbraums.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
F#
member Name : string with get, private set

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


R Property

[image]

DynamicNodes API
RgbColorSpace..::..R Property
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Referenzpunkt für Rot.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_xyY R { get; private set; }
Visual Basic
Public Property R As ColorValue_xyY
    Get
    Private Set
F#
member R : ColorValue_xyY with get, private set

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


WhitePoint Property

[image]

DynamicNodes API
RgbColorSpace..::..WhitePoint Property
RgbColorSpace Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Weißpunkt des Farbraums.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Whitepoint WhitePoint { get; private set; }
Visual Basic
Public Property WhitePoint As Whitepoint
    Get
    Private Set
F#
member WhitePoint : Whitepoint with get, private set

See Also

RgbColorSpace Class
DynamicNode.Types.Imaging Namespace


RgbColorSpaceName Enumeration

[image]

DynamicNodes API
RgbColorSpaceName Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Aufzählung mit den Namen der bekannten Farbräumen.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public enum RgbColorSpaceName
Visual Basic
Public Enumeration RgbColorSpaceName
F#
type RgbColorSpaceName

Members

Member name | Description
Adobe1998 |
Apple |
Best |
Beta |
Bruce |
CIE |
ColorMatch |
Don4 |
ECIv2 |
EktaSpacePS5 |
NTSC |
PAL_SECAM |
ProPhoto |
SMPTE_C |
sRGB |
WideGamut |

See Also

DynamicNode.Types.Imaging Namespace


RGBImage Class

[image]

DynamicNodes API
RGBImage Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein spezielles Tupel mit drei Elementen zur Aufnahme von Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp Byte.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class RGBImage : Tupel<Matrix<byte>>,
    IRGBImage
Visual Basic
<SerializableAttribute> _
Public Class RGBImage _
    Inherits Tupel(Of Matrix(Of Byte)) _
    Implements IRGBImage
F#
[<SerializableAttribute>]
type RGBImage =
    class
        inherit Tupel<Matrix<byte>>
        interface IRGBImage
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Tupel <(Of <(<' Matrix <(Of <(<' Byte >)>)>>)>)>
DynamicNode.Types.Imaging..::..RGBImage
DynamicNode.Types.Imaging..::..ARGBImage

See Also

RGBImage Members
DynamicNode.Types.Imaging Namespace


RGBImage Members

[image] [image]

DynamicNodes API
RGBImage Members
RGBImage Class Constructors Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage type exposes the following members.

Constructors

 | Name | Description
Public method | RGBImage()()()() | Initialisiert eine neue Instanz von RGBImage.
Public method | RGBImage(Bitmap) | Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe eines Bitmap-Objektes.
Public method | RGBImage(Int32, Int32, Byte) | Initialisiert eine neue Instanz der RGBImage-Klasse.
Public method | RGBImage(Matrix<(Of <<'(Byte>)>>), Matrix<(Of <<'(Byte>)>>), Matrix<(Of <<'(Byte>)>>)) | Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe.
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

Fields

Name | Description
COLOR_VALUE_FACTOR | Der Faktor der zur Umrechnung von einem Single-Farbwert auf ein 8Bit-Farbwert verwendet wird.
INV_COLOR_VALUE_FACTOR | Der Faktor der zur Umrechnung von einem 8Bit-Farbwert auf ein Single-Farbwert verwendet wird.

Properties

 | Name | Description
Public property | B | Gibt den Blau-Kanal zurück.
Public property | G | Gibt den Grün-Kanal zurück.
Public property | Height | Gibt die Höhe des Bildes zurück.
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | R | Gibt den Rot-Kanal zurück.
Public property | Width | Gibt die Breite des Bildes zurück.

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


RGBImage Constructor

[image] [image]

DynamicNodes API
RGBImage Constructor
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RGBImage()()()() | Initialisiert eine neue Instanz von RGBImage.
Public method | RGBImage(Bitmap) | Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe eines Bitmap-Objektes.
Public method | RGBImage(Int32, Int32, Byte) | Initialisiert eine neue Instanz der RGBImage-Klasse.
Public method | RGBImage(Matrix<(Of <<'(Byte>)>>), Matrix<(Of <<'(Byte>)>>), Matrix<(Of <<'(Byte>)>>)) | Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

See Also

RGBImage Class
RGBImage Members
DynamicNode.Types.Imaging Namespace


RGBImage Constructor

[image]

DynamicNodes API
RGBImage Constructor
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RGBImage.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage()
Visual Basic
Public Sub New
F#
new : unit -> RGBImage

See Also

RGBImage Class
RGBImage Overload
DynamicNode.Types.Imaging Namespace


RGBImage Constructor (Bitmap)

[image]

DynamicNodes API
RGBImage Constructor (Bitmap)
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe eines Bitmap-Objektes.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage(
    Bitmap bitmap
)
Visual Basic
Public Sub New ( _
    bitmap As Bitmap _
)
F#
new :
        bitmap:Bitmap -> RGBImage

Parameters

bitmap
Type: System.Drawing..::..Bitmap
Ein 24bpp-RGB-Bitmap-Objekt.

See Also

RGBImage Class
RGBImage Overload
DynamicNode.Types.Imaging Namespace


RGBImage Constructor (Int32, Int32, Byte)

[image]

DynamicNodes API
RGBImage Constructor (Int32, Int32, Byte)
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der RGBImage-Klasse.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage(
    int width,
    int height,
    byte defValue
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    defValue As Byte _
)
F#
new :
        width:int *
        height:int *
        defValue:byte -> RGBImage

Parameters

width
Type: System..::..Int32
Die Breite.
height
Type: System..::..Int32
Die Höhe.
defValue
Type: System..::..Byte
Der Standardwert für Indexüberschreitungen.

See Also

RGBImage Class
RGBImage Overload
DynamicNode.Types.Imaging Namespace


RGBImage Constructor (Matrix(Byte), Matrix(Byte), Matrix(Byte))

[image]

DynamicNodes API
RGBImage Constructor (Matrix<(Of <(<'Byte>)>)>, Matrix<(Of <(<'Byte>)>)>, Matrix<(Of <(<'Byte>)>)>)
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage(
    Matrix<byte> r,
    Matrix<byte> g,
    Matrix<byte> b
)
Visual Basic
Public Sub New ( _
    r As Matrix(Of Byte), _
    g As Matrix(Of Byte), _
    b As Matrix(Of Byte) _
)
F#
new :
        r:Matrix<byte> *
        g:Matrix<byte> *
        b:Matrix<byte> -> RGBImage

Parameters

r
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Der Rot-Kanal.
g
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Der Grün-Kanal.
b
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Byte >)>)>
Der Blau-Kanal.

See Also

RGBImage Class
RGBImage Overload
DynamicNode.Types.Imaging Namespace


RGBImage Fields

[image] [image]

DynamicNodes API
RGBImage Fields
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage type exposes the following members.

Fields

Name | Description
COLOR_VALUE_FACTOR | Der Faktor der zur Umrechnung von einem Single-Farbwert auf ein 8Bit-Farbwert verwendet wird.
INV_COLOR_VALUE_FACTOR | Der Faktor der zur Umrechnung von einem 8Bit-Farbwert auf ein Single-Farbwert verwendet wird.

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


COLOR_VALUE_FACTOR Field

[image]

DynamicNodes API
RGBImage..::..COLOR_VALUE_FACTOR Field
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Faktor der zur Umrechnung von einem Single-Farbwert auf ein 8Bit-Farbwert verwendet wird.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public const float COLOR_VALUE_FACTOR
Visual Basic
Public Const COLOR_VALUE_FACTOR As Single
F#
static val mutable COLOR_VALUE_FACTOR: float32

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


INV_COLOR_VALUE_FACTOR Field

[image]

DynamicNodes API
RGBImage..::..INV_COLOR_VALUE_FACTOR Field
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Faktor der zur Umrechnung von einem 8Bit-Farbwert auf ein Single-Farbwert verwendet wird.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public const float INV_COLOR_VALUE_FACTOR
Visual Basic
Public Const INV_COLOR_VALUE_FACTOR As Single
F#
static val mutable INV_COLOR_VALUE_FACTOR: float32

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


RGBImage Methods

[image] [image]

DynamicNodes API
RGBImage Methods
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe.
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


Initialize Method

[image]

DynamicNodes API
RGBImage..::..Initialize Method
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert das Bild mit der angegebenen Größe.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public virtual void Initialize(
    int width,
    int height
)
Visual Basic
Public Overridable Sub Initialize ( _
    width As Integer, _
    height As Integer _
)
F#
abstract Initialize :
        width:int *
        height:int -> unit
override Initialize :
        width:int *
        height:int -> unit

Parameters

width
Type: System..::..Int32
Die Breite des Bildes
height
Type: System..::..Int32
Die Höhe des Bildes

Implements

IRGBImage..::..Initialize(Int32, Int32)

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width oder height ein Wert kleiner 0 übergeben wird.

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


ToBitmap Method

[image]

DynamicNodes API
RGBImage..::..ToBitmap Method
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Bitmap-Objekt aus der Matrix.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Bitmap ToBitmap()
Visual Basic
Public Function ToBitmap As Bitmap
F#
member ToBitmap : unit -> Bitmap

Return Value

Ein 24bpp RGB-Bitmap-Objekt.

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
RGBImage..::..ToString Method
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


RGBImage Properties

[image] [image]

DynamicNodes API
RGBImage Properties
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage type exposes the following members.

Properties

 | Name | Description
Public property | B | Gibt den Blau-Kanal zurück.
Public property | G | Gibt den Grün-Kanal zurück.
Public property | Height | Gibt die Höhe des Bildes zurück.
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | R | Gibt den Rot-Kanal zurück.
Public property | Width | Gibt die Breite des Bildes zurück.

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


B Property

[image]

DynamicNodes API
RGBImage..::..B Property
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Blau-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<byte> B { get; protected set; }
Visual Basic
Public Property B As Matrix(Of Byte)
    Get
    Protected Set
F#
member B : Matrix<byte> with get, set

Field Value

Der Blau-Kanal.

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


G Property

[image]

DynamicNodes API
RGBImage..::..G Property
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Grün-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<byte> G { get; protected set; }
Visual Basic
Public Property G As Matrix(Of Byte)
    Get
    Protected Set
F#
member G : Matrix<byte> with get, set

Field Value

Der Grün-Kanal.

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


Height Property

[image]

DynamicNodes API
RGBImage..::..Height Property
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Höhe des Bildes zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get
F#
abstract Height : int
override Height : int

Implements

IRGBImage..::..Height

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


IsInitialized Property

[image]

DynamicNodes API
RGBImage..::..IsInitialized Property
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public virtual bool IsInitialized { get; }
Visual Basic
Public Overridable ReadOnly Property IsInitialized As Boolean
    Get
F#
abstract IsInitialized : bool
override IsInitialized : bool

Implements

IRGBImage..::..IsInitialized

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


Item Property

[image] [image]

DynamicNodes API
RGBImage..::..Item Property
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

See Also

RGBImage Class
RGBImage Members
DynamicNode.Types.Imaging Namespace


Item Property (Int32, Int32)

[image]

DynamicNodes API
RGBImage..::..Item Property (Int32, Int32)
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_RGB this[
    int x,
    int y
] { get; set; }
Visual Basic
Public Default Property Item ( _
    x As Integer, _
    y As Integer _
) As ColorValue_RGB
    Get
    Set
F#
abstract Item : ColorValue_RGB with get, set
override Item : ColorValue_RGB with get, set

Parameters

x
Type: System..::..Int32
Die X-Koordinate des Pixels.
y
Type: System..::..Int32
Die Y-Koordinate des Pixels.

Return Value

Den RGB-Farbwert des Pixels.

Implements

IRGBImage..::..Item[([( Int32, Int32])])

See Also

RGBImage Class
Item Overload
DynamicNode.Types.Imaging Namespace


R Property

[image]

DynamicNodes API
RGBImage..::..R Property
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Rot-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<byte> R { get; protected set; }
Visual Basic
Public Property R As Matrix(Of Byte)
    Get
    Protected Set
F#
member R : Matrix<byte> with get, set

Field Value

Der Rot-Kanal.

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


Width Property

[image]

DynamicNodes API
RGBImage..::..Width Property
RGBImage Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Breite des Bildes zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get
F#
abstract Width : int
override Width : int

Implements

IRGBImage..::..Width

See Also

RGBImage Class
DynamicNode.Types.Imaging Namespace


RGBImage16 Class

[image]

DynamicNodes API
RGBImage16 Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein spezielles Tupel mit drei Elementen zur Aufnahme von Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp Int16.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class RGBImage16 : Tupel<Matrix<ushort>>,
    IRGBImage
Visual Basic
<SerializableAttribute> _
Public Class RGBImage16 _
    Inherits Tupel(Of Matrix(Of UShort)) _
    Implements IRGBImage
F#
[<SerializableAttribute>]
type RGBImage16 =
    class
        inherit Tupel<Matrix<uint16>>
        interface IRGBImage
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Tupel <(Of <(<' Matrix <(Of <(<' UInt16 >)>)>>)>)>
DynamicNode.Types.Imaging..::..RGBImage16
DynamicNode.Types.Imaging..::..ARGBImage16

See Also

RGBImage16 Members
DynamicNode.Types.Imaging Namespace


RGBImage16 Members

[image] [image]

DynamicNodes API
RGBImage16 Members
RGBImage16 Class Constructors Methods Fields Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage16 type exposes the following members.

Constructors

 | Name | Description
Public method | RGBImage16()()()() | Initialisiert eine neue Instanz von RGBImage16.
Public method | RGBImage16(Bitmap) | Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe eines Bitmap-Objektes.
Public method | RGBImage16(Int32, Int32, UInt16) | Initialisiert eine neue Instanz der RGBImage16-Klasse.
Public method | RGBImage16(Matrix<(Of <<'(UInt16>)>>), Matrix<(Of <<'(UInt16>)>>), Matrix<(Of <<'(UInt16>)>>)) | Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe.
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

Fields

Name | Description
COLOR_VALUE_FACTOR | Der Faktor der zur Umrechnung von einem Single-Farbwert auf ein 16Bit-Farbwert verwendet wird.
INV_COLOR_VALUE_FACTOR | Der Faktor der zur Umrechnung von einem 16Bit-Farbwert auf ein Single-Farbwert verwendet wird.

Properties

 | Name | Description
Public property | B | Gibt den Blau-Kanal zurück.
Public property | G | Gibt den Grün-Kanal zurück.
Public property | Height | Gibt die Höhe des Bildes zurück.
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | R | Gibt den Rot-Kanal zurück.
Public property | Width | Gibt die Breite des Bildes zurück.

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


RGBImage16 Constructor

[image] [image]

DynamicNodes API
RGBImage16 Constructor
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RGBImage16()()()() | Initialisiert eine neue Instanz von RGBImage16.
Public method | RGBImage16(Bitmap) | Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe eines Bitmap-Objektes.
Public method | RGBImage16(Int32, Int32, UInt16) | Initialisiert eine neue Instanz der RGBImage16-Klasse.
Public method | RGBImage16(Matrix<(Of <<'(UInt16>)>>), Matrix<(Of <<'(UInt16>)>>), Matrix<(Of <<'(UInt16>)>>)) | Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

See Also

RGBImage16 Class
RGBImage16 Members
DynamicNode.Types.Imaging Namespace


RGBImage16 Constructor

[image]

DynamicNodes API
RGBImage16 Constructor
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RGBImage16.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage16()
Visual Basic
Public Sub New
F#
new : unit -> RGBImage16

See Also

RGBImage16 Class
RGBImage16 Overload
DynamicNode.Types.Imaging Namespace


RGBImage16 Constructor (Bitmap)

[image]

DynamicNodes API
RGBImage16 Constructor (Bitmap)
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe eines Bitmap-Objektes.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage16(
    Bitmap bitmap
)
Visual Basic
Public Sub New ( _
    bitmap As Bitmap _
)
F#
new :
        bitmap:Bitmap -> RGBImage16

Parameters

bitmap
Type: System.Drawing..::..Bitmap
Ein 24bpp-RGB-Bitmap-Objekt.

See Also

RGBImage16 Class
RGBImage16 Overload
DynamicNode.Types.Imaging Namespace


RGBImage16 Constructor (Int32, Int32, UInt16)

[image]

DynamicNodes API
RGBImage16 Constructor (Int32, Int32, UInt16)
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der RGBImage16-Klasse.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage16(
    int width,
    int height,
    ushort defValue
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    defValue As UShort _
)
F#
new :
        width:int *
        height:int *
        defValue:uint16 -> RGBImage16

Parameters

width
Type: System..::..Int32
Die Breite.
height
Type: System..::..Int32
Die Höhe.
defValue
Type: System..::..UInt16
Der Standardwert für Indexüberschreitungen.

See Also

RGBImage16 Class
RGBImage16 Overload
DynamicNode.Types.Imaging Namespace


RGBImage16 Constructor (Matrix(UInt16), Matrix(UInt16), Matrix(UInt16))

[image]

DynamicNodes API
RGBImage16 Constructor (Matrix<(Of <(<'UInt16>)>)>, Matrix<(Of <(<'UInt16>)>)>, Matrix<(Of <(<'UInt16>)>)>)
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RGBImage-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage16(
    Matrix<ushort> r,
    Matrix<ushort> g,
    Matrix<ushort> b
)
Visual Basic
Public Sub New ( _
    r As Matrix(Of UShort), _
    g As Matrix(Of UShort), _
    b As Matrix(Of UShort) _
)
F#
new :
        r:Matrix<uint16> *
        g:Matrix<uint16> *
        b:Matrix<uint16> -> RGBImage16

Parameters

r
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Der Rot-Kanal.
g
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Der Grün-Kanal.
b
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' UInt16 >)>)>
Der Blau-Kanal.

See Also

RGBImage16 Class
RGBImage16 Overload
DynamicNode.Types.Imaging Namespace


RGBImage16 Fields

[image] [image]

DynamicNodes API
RGBImage16 Fields
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage16 type exposes the following members.

Fields

Name | Description
COLOR_VALUE_FACTOR | Der Faktor der zur Umrechnung von einem Single-Farbwert auf ein 16Bit-Farbwert verwendet wird.
INV_COLOR_VALUE_FACTOR | Der Faktor der zur Umrechnung von einem 16Bit-Farbwert auf ein Single-Farbwert verwendet wird.

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


COLOR_VALUE_FACTOR Field

[image]

DynamicNodes API
RGBImage16..::..COLOR_VALUE_FACTOR Field
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Faktor der zur Umrechnung von einem Single-Farbwert auf ein 16Bit-Farbwert verwendet wird.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public const float COLOR_VALUE_FACTOR
Visual Basic
Public Const COLOR_VALUE_FACTOR As Single
F#
static val mutable COLOR_VALUE_FACTOR: float32

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


INV_COLOR_VALUE_FACTOR Field

[image]

DynamicNodes API
RGBImage16..::..INV_COLOR_VALUE_FACTOR Field
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Faktor der zur Umrechnung von einem 16Bit-Farbwert auf ein Single-Farbwert verwendet wird.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public const float INV_COLOR_VALUE_FACTOR
Visual Basic
Public Const INV_COLOR_VALUE_FACTOR As Single
F#
static val mutable INV_COLOR_VALUE_FACTOR: float32

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


RGBImage16 Methods

[image] [image]

DynamicNodes API
RGBImage16 Methods
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage16 type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe.
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


Initialize Method

[image]

DynamicNodes API
RGBImage16..::..Initialize Method
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert das Bild mit der angegebenen Größe.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public virtual void Initialize(
    int width,
    int height
)
Visual Basic
Public Overridable Sub Initialize ( _
    width As Integer, _
    height As Integer _
)
F#
abstract Initialize :
        width:int *
        height:int -> unit
override Initialize :
        width:int *
        height:int -> unit

Parameters

width
Type: System..::..Int32
Die Breite des Bildes
height
Type: System..::..Int32
Die Höhe des Bildes

Implements

IRGBImage..::..Initialize(Int32, Int32)

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width oder height ein Wert kleiner 0 übergeben wird.

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


ToBitmap Method

[image]

DynamicNodes API
RGBImage16..::..ToBitmap Method
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Bitmap-Objekt aus der Matrix.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Bitmap ToBitmap()
Visual Basic
Public Function ToBitmap As Bitmap
F#
member ToBitmap : unit -> Bitmap

Return Value

Ein 24bpp-RGB-Bitmap-Objekt.

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
RGBImage16..::..ToString Method
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


RGBImage16 Properties

[image] [image]

DynamicNodes API
RGBImage16 Properties
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage16 type exposes the following members.

Properties

 | Name | Description
Public property | B | Gibt den Blau-Kanal zurück.
Public property | G | Gibt den Grün-Kanal zurück.
Public property | Height | Gibt die Höhe des Bildes zurück.
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | R | Gibt den Rot-Kanal zurück.
Public property | Width | Gibt die Breite des Bildes zurück.

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


B Property

[image]

DynamicNodes API
RGBImage16..::..B Property
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Blau-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<ushort> B { get; protected set; }
Visual Basic
Public Property B As Matrix(Of UShort)
    Get
    Protected Set
F#
member B : Matrix<uint16> with get, set

Field Value

Der Blau-Kanal.

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


G Property

[image]

DynamicNodes API
RGBImage16..::..G Property
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Grün-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<ushort> G { get; protected set; }
Visual Basic
Public Property G As Matrix(Of UShort)
    Get
    Protected Set
F#
member G : Matrix<uint16> with get, set

Field Value

Der Grün-Kanal.

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


Height Property

[image]

DynamicNodes API
RGBImage16..::..Height Property
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Höhe des Bildes zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get
F#
abstract Height : int
override Height : int

Implements

IRGBImage..::..Height

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


IsInitialized Property

[image]

DynamicNodes API
RGBImage16..::..IsInitialized Property
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public virtual bool IsInitialized { get; }
Visual Basic
Public Overridable ReadOnly Property IsInitialized As Boolean
    Get
F#
abstract IsInitialized : bool
override IsInitialized : bool

Implements

IRGBImage..::..IsInitialized

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


Item Property

[image] [image]

DynamicNodes API
RGBImage16..::..Item Property
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

See Also

RGBImage16 Class
RGBImage16 Members
DynamicNode.Types.Imaging Namespace


Item Property (Int32, Int32)

[image]

DynamicNodes API
RGBImage16..::..Item Property (Int32, Int32)
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_RGB this[
    int x,
    int y
] { get; set; }
Visual Basic
Public Default Property Item ( _
    x As Integer, _
    y As Integer _
) As ColorValue_RGB
    Get
    Set
F#
abstract Item : ColorValue_RGB with get, set
override Item : ColorValue_RGB with get, set

Parameters

x
Type: System..::..Int32
Die X-Koordinate des Pixels.
y
Type: System..::..Int32
Die Y-Koordinate des Pixels.

Return Value

Den RGB-Farbwert des Pixels.

Implements

IRGBImage..::..Item[([( Int32, Int32])])

See Also

RGBImage16 Class
Item Overload
DynamicNode.Types.Imaging Namespace


R Property

[image]

DynamicNodes API
RGBImage16..::..R Property
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Rot-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<ushort> R { get; protected set; }
Visual Basic
Public Property R As Matrix(Of UShort)
    Get
    Protected Set
F#
member R : Matrix<uint16> with get, set

Field Value

Der Rot-Kanal.

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


Width Property

[image]

DynamicNodes API
RGBImage16..::..Width Property
RGBImage16 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Breite des Bildes zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get
F#
abstract Width : int
override Width : int

Implements

IRGBImage..::..Width

See Also

RGBImage16 Class
DynamicNode.Types.Imaging Namespace


RGBImage32 Class

[image]

DynamicNodes API
RGBImage32 Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein spezielles Tupel mit drei Elementen zur Aufnahme von Rot-, Grün- und Blau-Kanälen eines Bildes mit dem elementaren Datentyp Single.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class RGBImage32 : Tupel<Matrix<float>>,
    IRGBImage
Visual Basic
<SerializableAttribute> _
Public Class RGBImage32 _
    Inherits Tupel(Of Matrix(Of Single)) _
    Implements IRGBImage
F#
[<SerializableAttribute>]
type RGBImage32 =
    class
        inherit Tupel<Matrix<float32>>
        interface IRGBImage
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Tupel <(Of <(<' Matrix <(Of <(<' Single >)>)>>)>)>
DynamicNode.Types.Imaging..::..RGBImage32
DynamicNode.Types.Imaging..::..ARGBImage32

See Also

RGBImage32 Members
DynamicNode.Types.Imaging Namespace


RGBImage32 Members

[image] [image]

DynamicNodes API
RGBImage32 Members
RGBImage32 Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage32 type exposes the following members.

Constructors

 | Name | Description
Public method | RGBImage32()()()() | Initialisiert eine neue Instanz von RGBImage32.
Public method | RGBImage32(Int32, Int32, Single) | Initialisiert eine neue Instanz der RGBImage32-Klasse.
Public method | RGBImage32(Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>)) | Initialisiert eine neue Instanz von RGBImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe.
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

Properties

 | Name | Description
Public property | B | Gibt den Blau-Kanal zurück.
Public property | G | Gibt den Grün-Kanal zurück.
Public property | Height | Gibt die Höhe des Bildes zurück.
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | R | Gibt den Rot-Kanal zurück.
Public property | Width | Gibt die Breite des Bildes zurück.

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


RGBImage32 Constructor

[image] [image]

DynamicNodes API
RGBImage32 Constructor
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | RGBImage32()()()() | Initialisiert eine neue Instanz von RGBImage32.
Public method | RGBImage32(Int32, Int32, Single) | Initialisiert eine neue Instanz der RGBImage32-Klasse.
Public method | RGBImage32(Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>)) | Initialisiert eine neue Instanz von RGBImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

See Also

RGBImage32 Class
RGBImage32 Members
DynamicNode.Types.Imaging Namespace


RGBImage32 Constructor

[image]

DynamicNodes API
RGBImage32 Constructor
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RGBImage32.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage32()
Visual Basic
Public Sub New
F#
new : unit -> RGBImage32

See Also

RGBImage32 Class
RGBImage32 Overload
DynamicNode.Types.Imaging Namespace


RGBImage32 Constructor (Int32, Int32, Single)

[image]

DynamicNodes API
RGBImage32 Constructor (Int32, Int32, Single)
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der RGBImage32-Klasse.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage32(
    int width,
    int heigth,
    float defValue
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    heigth As Integer, _
    defValue As Single _
)
F#
new :
        width:int *
        heigth:int *
        defValue:float32 -> RGBImage32

Parameters

width
Type: System..::..Int32
Die Breite.
heigth
Type: System..::..Int32
Die Höhe.
defValue
Type: System..::..Single
Der Standardwert für Indexüberschreitungen.

See Also

RGBImage32 Class
RGBImage32 Overload
DynamicNode.Types.Imaging Namespace


RGBImage32 Constructor (Matrix(Single), Matrix(Single), Matrix(Single))

[image]

DynamicNodes API
RGBImage32 Constructor (Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>)
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von RGBImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public RGBImage32(
    Matrix<float> r,
    Matrix<float> g,
    Matrix<float> b
)
Visual Basic
Public Sub New ( _
    r As Matrix(Of Single), _
    g As Matrix(Of Single), _
    b As Matrix(Of Single) _
)
F#
new :
        r:Matrix<float32> *
        g:Matrix<float32> *
        b:Matrix<float32> -> RGBImage32

Parameters

r
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der Rot-Kanal.
g
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der Grün-Kanal.
b
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der Blau-Kanal.

See Also

RGBImage32 Class
RGBImage32 Overload
DynamicNode.Types.Imaging Namespace


RGBImage32 Methods

[image] [image]

DynamicNodes API
RGBImage32 Methods
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage32 type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | Initialize | Initialisiert das Bild mit der angegebenen Größe.
Public method | ToBitmap | Erzeugt ein Bitmap-Objekt aus der Matrix.
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


Initialize Method

[image]

DynamicNodes API
RGBImage32..::..Initialize Method
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert das Bild mit der angegebenen Größe.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public virtual void Initialize(
    int width,
    int height
)
Visual Basic
Public Overridable Sub Initialize ( _
    width As Integer, _
    height As Integer _
)
F#
abstract Initialize :
        width:int *
        height:int -> unit
override Initialize :
        width:int *
        height:int -> unit

Parameters

width
Type: System..::..Int32
Die Breite des Bildes
height
Type: System..::..Int32
Die Höhe des Bildes

Implements

IRGBImage..::..Initialize(Int32, Int32)

Exceptions

Exception | Condition
System..::..ArgumentException | Wird geworfen, wenn für width oder height ein Wert kleiner 0 übergeben wird.

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


ToBitmap Method

[image]

DynamicNodes API
RGBImage32..::..ToBitmap Method
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt ein Bitmap-Objekt aus der Matrix.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Bitmap ToBitmap()
Visual Basic
Public Function ToBitmap As Bitmap
F#
member ToBitmap : unit -> Bitmap

Return Value

Ein 24bpp RGB-Bitmap-Objekt.

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
RGBImage32..::..ToString Method
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


RGBImage32 Properties

[image] [image]

DynamicNodes API
RGBImage32 Properties
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The RGBImage32 type exposes the following members.

Properties

 | Name | Description
Public property | B | Gibt den Blau-Kanal zurück.
Public property | G | Gibt den Grün-Kanal zurück.
Public property | Height | Gibt die Höhe des Bildes zurück.
Public property | IsInitialized | Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | R | Gibt den Rot-Kanal zurück.
Public property | Width | Gibt die Breite des Bildes zurück.

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


B Property

[image]

DynamicNodes API
RGBImage32..::..B Property
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Blau-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> B { get; protected set; }
Visual Basic
Public Property B As Matrix(Of Single)
    Get
    Protected Set
F#
member B : Matrix<float32> with get, set

Field Value

Der Blau-Kanal.

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


G Property

[image]

DynamicNodes API
RGBImage32..::..G Property
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Grün-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> G { get; protected set; }
Visual Basic
Public Property G As Matrix(Of Single)
    Get
    Protected Set
F#
member G : Matrix<float32> with get, set

Field Value

Der Grün-Kanal.

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


Height Property

[image]

DynamicNodes API
RGBImage32..::..Height Property
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Höhe des Bildes zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get
F#
abstract Height : int
override Height : int

Implements

IRGBImage..::..Height

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


IsInitialized Property

[image]

DynamicNodes API
RGBImage32..::..IsInitialized Property
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob das Bild initialisiert wurde und mit einem Array zur Speicherung der Daten verknüpft ist.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public virtual bool IsInitialized { get; }
Visual Basic
Public Overridable ReadOnly Property IsInitialized As Boolean
    Get
F#
abstract IsInitialized : bool
override IsInitialized : bool

Implements

IRGBImage..::..IsInitialized

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


Item Property

[image] [image]

DynamicNodes API
RGBImage32..::..Item Property
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

See Also

RGBImage32 Class
RGBImage32 Members
DynamicNode.Types.Imaging Namespace


Item Property (Int32, Int32)

[image]

DynamicNodes API
RGBImage32..::..Item Property (Int32, Int32)
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den RGB-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_RGB this[
    int x,
    int y
] { get; set; }
Visual Basic
Public Default Property Item ( _
    x As Integer, _
    y As Integer _
) As ColorValue_RGB
    Get
    Set
F#
abstract Item : ColorValue_RGB with get, set
override Item : ColorValue_RGB with get, set

Parameters

x
Type: System..::..Int32
Die X-Koordinate des Pixels.
y
Type: System..::..Int32
Die Y-Koordinate des Pixels.

Return Value

Den RGB-Farbwert des Pixels.

Implements

IRGBImage..::..Item[([( Int32, Int32])])

See Also

RGBImage32 Class
Item Overload
DynamicNode.Types.Imaging Namespace


R Property

[image]

DynamicNodes API
RGBImage32..::..R Property
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Rot-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> R { get; protected set; }
Visual Basic
Public Property R As Matrix(Of Single)
    Get
    Protected Set
F#
member R : Matrix<float32> with get, set

Field Value

Der Rot-Kanal.

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


Width Property

[image]

DynamicNodes API
RGBImage32..::..Width Property
RGBImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Breite des Bildes zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get
F#
abstract Width : int
override Width : int

Implements

IRGBImage..::..Width

See Also

RGBImage32 Class
DynamicNode.Types.Imaging Namespace


SpeedTransfer Class

[image]

DynamicNodes API
SpeedTransfer Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Klasse, die eine TransferFunction mit einer Lookup-Tabelle und linearer Interpolation optimiert.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public class SpeedTransfer
Visual Basic
Public Class SpeedTransfer
F#
type SpeedTransfer =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Imaging..::..SpeedTransfer

See Also

SpeedTransfer Members
DynamicNode.Types.Imaging Namespace


SpeedTransfer Members

[image] [image]

DynamicNodes API
SpeedTransfer Members
SpeedTransfer Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SpeedTransfer type exposes the following members.

Constructors

 | Name | Description
Public method | SpeedTransfer | Initializes a new instance of the SpeedTransfer class.

Methods

 | Name | Description
Public method | ApplyTo(Byte) | Wendet die optimierte Transferfunktion auf den Byte Wert v an. Dabei wird der Wertebreich von Byte auf 0.0 bis 1.0 abgebildet.
Public method | ApplyTo(Double) | Wendet die optimierte Transferfunktion auf den Double Wert v an.
Public method | ApplyTo(Single) | Wendet die optimierte Transferfunktion auf den Single Wert v an.
Public method | ApplyTo(UInt16) | Wendet die optimierte Transferfunktion auf den Byte Wert v an. Dabei wird der Wertebreich von Byte auf 0.0 bis 1.0 abgebildet.

Properties

 | Name | Description
Public property | ClipIn | Gibt an, ob Eingangswerte auf den optimierten Bereich zwischen InMinimum und InMaximum beschränkt werden sollen.
Public property | ClipOut | Gibt an, ob Ausgangswerte auf den Bereich zwischen OutMinimum und OutMaximum beschränkt werden sollen.
Public property | InMaximum | Der größte Eingangswert der in die Optimierung eingeschlossen werden soll.
Public property | InMinimum | Der kleinste Eingangswert der in die Optimierung eingeschlossen werden soll.
Public property | OutMaximum | Die obere Grenze für Ergebniswerte, falls ClipOut gleich true ist.
Public property | OutMinimum | Die untere Grenze für Ergebniswerte, falls ClipOut gleich true ist.

See Also

SpeedTransfer Class
DynamicNode.Types.Imaging Namespace


SpeedTransfer Constructor

[image]

DynamicNodes API
SpeedTransfer Constructor
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the SpeedTransfer class.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public SpeedTransfer(
    TransferFunction f,
    int size
)
Visual Basic
Public Sub New ( _
    f As TransferFunction, _
    size As Integer _
)
F#
new :
        f:TransferFunction *
        size:int -> SpeedTransfer

Parameters

f
Type: DynamicNode.Types.Imaging..::..TransferFunction
The f.
size
Type: System..::..Int32
Size of the lookup.

See Also

SpeedTransfer Class
DynamicNode.Types.Imaging Namespace


SpeedTransfer Methods

[image] [image]

DynamicNodes API
SpeedTransfer Methods
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Methods

 | Name | Description
Public method | ApplyTo(Byte) | Wendet die optimierte Transferfunktion auf den Byte Wert v an. Dabei wird der Wertebreich von Byte auf 0.0 bis 1.0 abgebildet.
Public method | ApplyTo(Double) | Wendet die optimierte Transferfunktion auf den Double Wert v an.
Public method | ApplyTo(Single) | Wendet die optimierte Transferfunktion auf den Single Wert v an.
Public method | ApplyTo(UInt16) | Wendet die optimierte Transferfunktion auf den Byte Wert v an. Dabei wird der Wertebreich von Byte auf 0.0 bis 1.0 abgebildet.

See Also

SpeedTransfer Class
DynamicNode.Types.Imaging Namespace


ApplyTo Method

[image] [image]

DynamicNodes API
SpeedTransfer..::..ApplyTo Method
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ApplyTo(Byte) | Wendet die optimierte Transferfunktion auf den Byte Wert v an. Dabei wird der Wertebreich von Byte auf 0.0 bis 1.0 abgebildet.
Public method | ApplyTo(Double) | Wendet die optimierte Transferfunktion auf den Double Wert v an.
Public method | ApplyTo(Single) | Wendet die optimierte Transferfunktion auf den Single Wert v an.
Public method | ApplyTo(UInt16) | Wendet die optimierte Transferfunktion auf den Byte Wert v an. Dabei wird der Wertebreich von Byte auf 0.0 bis 1.0 abgebildet.

See Also

SpeedTransfer Class
SpeedTransfer Members
DynamicNode.Types.Imaging Namespace


ApplyTo Method (Byte)

[image]

DynamicNodes API
SpeedTransfer..::..ApplyTo Method (Byte)
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wendet die optimierte Transferfunktion auf den Byte Wert v an. Dabei wird der Wertebreich von Byte auf 0.0 bis 1.0 abgebildet.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public byte ApplyTo(
    byte v
)
Visual Basic
Public Function ApplyTo ( _
    v As Byte _
) As Byte
F#
member ApplyTo :
        v:byte -> byte

Parameters

v
Type: System..::..Byte
Ein Wert.

Return Value

Der Ergebniswert.

Remarks

ClipOut wird ignoriert und immer auf das Intervall 0-1 beschränkt und anschließend in den Wertebereich von Byte umgerechnet.

See Also

SpeedTransfer Class
ApplyTo Overload
DynamicNode.Types.Imaging Namespace


ApplyTo Method (Double)

[image]

DynamicNodes API
SpeedTransfer..::..ApplyTo Method (Double)
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wendet die optimierte Transferfunktion auf den Double Wert v an.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public double ApplyTo(
    double v
)
Visual Basic
Public Function ApplyTo ( _
    v As Double _
) As Double
F#
member ApplyTo :
        v:float -> float

Parameters

v
Type: System..::..Double
Ein Wert.

Return Value

Der Ergebniswert.

See Also

SpeedTransfer Class
ApplyTo Overload
DynamicNode.Types.Imaging Namespace


ApplyTo Method (Single)

[image]

DynamicNodes API
SpeedTransfer..::..ApplyTo Method (Single)
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wendet die optimierte Transferfunktion auf den Single Wert v an.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public float ApplyTo(
    float v
)
Visual Basic
Public Function ApplyTo ( _
    v As Single _
) As Single
F#
member ApplyTo :
        v:float32 -> float32

Parameters

v
Type: System..::..Single
Ein Wert.

Return Value

Der Ergebniswert.

See Also

SpeedTransfer Class
ApplyTo Overload
DynamicNode.Types.Imaging Namespace


ApplyTo Method (UInt16)

[image]

DynamicNodes API
SpeedTransfer..::..ApplyTo Method (UInt16)
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wendet die optimierte Transferfunktion auf den Byte Wert v an. Dabei wird der Wertebreich von Byte auf 0.0 bis 1.0 abgebildet.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ushort ApplyTo(
    ushort v
)
Visual Basic
Public Function ApplyTo ( _
    v As UShort _
) As UShort
F#
member ApplyTo :
        v:uint16 -> uint16

Parameters

v
Type: System..::..UInt16
Ein Wert.

Return Value

Der Ergebniswert.

Remarks

ClipOut wird ignoriert und immer auf das Intervall 0-1 beschränkt und anschließend in den Wertebereich von Byte umgerechnet.

See Also

SpeedTransfer Class
ApplyTo Overload
DynamicNode.Types.Imaging Namespace


SpeedTransfer Properties

[image] [image]

DynamicNodes API
SpeedTransfer Properties
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The SpeedTransfer type exposes the following members.

Properties

 | Name | Description
Public property | ClipIn | Gibt an, ob Eingangswerte auf den optimierten Bereich zwischen InMinimum und InMaximum beschränkt werden sollen.
Public property | ClipOut | Gibt an, ob Ausgangswerte auf den Bereich zwischen OutMinimum und OutMaximum beschränkt werden sollen.
Public property | InMaximum | Der größte Eingangswert der in die Optimierung eingeschlossen werden soll.
Public property | InMinimum | Der kleinste Eingangswert der in die Optimierung eingeschlossen werden soll.
Public property | OutMaximum | Die obere Grenze für Ergebniswerte, falls ClipOut gleich true ist.
Public property | OutMinimum | Die untere Grenze für Ergebniswerte, falls ClipOut gleich true ist.

See Also

SpeedTransfer Class
DynamicNode.Types.Imaging Namespace


ClipIn Property

[image]

DynamicNodes API
SpeedTransfer..::..ClipIn Property
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob Eingangswerte auf den optimierten Bereich zwischen InMinimum und InMaximum beschränkt werden sollen.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public bool ClipIn { get; set; }
Visual Basic
Public Property ClipIn As Boolean
    Get
    Set
F#
member ClipIn : bool with get, set

See Also

SpeedTransfer Class
DynamicNode.Types.Imaging Namespace


ClipOut Property

[image]

DynamicNodes API
SpeedTransfer..::..ClipOut Property
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt an, ob Ausgangswerte auf den Bereich zwischen OutMinimum und OutMaximum beschränkt werden sollen.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public bool ClipOut { get; set; }
Visual Basic
Public Property ClipOut As Boolean
    Get
    Set
F#
member ClipOut : bool with get, set

See Also

SpeedTransfer Class
DynamicNode.Types.Imaging Namespace


InMaximum Property

[image]

DynamicNodes API
SpeedTransfer..::..InMaximum Property
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der größte Eingangswert der in die Optimierung eingeschlossen werden soll.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public double InMaximum { get; set; }
Visual Basic
Public Property InMaximum As Double
    Get
    Set
F#
member InMaximum : float with get, set

See Also

SpeedTransfer Class
DynamicNode.Types.Imaging Namespace


InMinimum Property

[image]

DynamicNodes API
SpeedTransfer..::..InMinimum Property
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der kleinste Eingangswert der in die Optimierung eingeschlossen werden soll.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public double InMinimum { get; set; }
Visual Basic
Public Property InMinimum As Double
    Get
    Set
F#
member InMinimum : float with get, set

See Also

SpeedTransfer Class
DynamicNode.Types.Imaging Namespace


OutMaximum Property

[image]

DynamicNodes API
SpeedTransfer..::..OutMaximum Property
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die obere Grenze für Ergebniswerte, falls ClipOut gleich true ist.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public double OutMaximum { get; set; }
Visual Basic
Public Property OutMaximum As Double
    Get
    Set
F#
member OutMaximum : float with get, set

See Also

SpeedTransfer Class
DynamicNode.Types.Imaging Namespace


OutMinimum Property

[image]

DynamicNodes API
SpeedTransfer..::..OutMinimum Property
SpeedTransfer Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die untere Grenze für Ergebniswerte, falls ClipOut gleich true ist.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public double OutMinimum { get; set; }
Visual Basic
Public Property OutMinimum As Double
    Get
    Set
F#
member OutMinimum : float with get, set

See Also

SpeedTransfer Class
DynamicNode.Types.Imaging Namespace


TransferFunction Delegate

[image]

DynamicNodes API
TransferFunction Delegate
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Delegat für Transferfunktionen.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public delegate double TransferFunction(
    double v
)
Visual Basic
Public Delegate Function TransferFunction ( _
    v As Double _
) As Double
F#
type TransferFunction =
    delegate of
        v:float -> float

Parameters

v
Type: System..::..Double
Der zu transferierende Wert.

Return Value

Der transferierte Wert.

See Also

DynamicNode.Types.Imaging Namespace


Whitepoint Class

[image]

DynamicNodes API
Whitepoint Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Diese Klasse beschreibt einen Weißpunkt als Referenz für ein Farbmodell.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public class Whitepoint
Visual Basic
Public Class Whitepoint
F#
type Whitepoint =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Imaging..::..Whitepoint

See Also

Whitepoint Members
DynamicNode.Types.Imaging Namespace


Whitepoint Members

[image] [image]

DynamicNodes API
Whitepoint Members
Whitepoint Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Whitepoint type exposes the following members.

Constructors

 | Name | Description
Public method | Whitepoint | Initialisiert eine neue Instanz der Klasse Whitepoint.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
 | ByName | Gibt ein Dictionary mit allen Standard-Weißpunkten zurück.
Public property | Description | Eine kurze Beschreibung des Weißpunkts.
Public property | Name | Der Name des Weißpunkts.
Public property | Value | Der XYZ-Farbwert, der den Weißpunkt definiert.

See Also

Whitepoint Class
DynamicNode.Types.Imaging Namespace


Whitepoint Constructor

[image]

DynamicNodes API
Whitepoint Constructor
Whitepoint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse Whitepoint.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Whitepoint(
    string name,
    string description,
    ColorValue_XYZ value
)
Visual Basic
Public Sub New ( _
    name As String, _
    description As String, _
    value As ColorValue_XYZ _
)
F#
new :
        name:string *
        description:string *
        value:ColorValue_XYZ -> Whitepoint

Parameters

name
Type: System..::..String
Der Name des Weißpunkts.
description
Type: System..::..String
Eine Beschreibung des Weißpunkts.
value
Type: DynamicNode.Types.Imaging..::..ColorValue_XYZ
Der XYZ-Wert der den Weißpunkt definiert.

See Also

Whitepoint Class
DynamicNode.Types.Imaging Namespace


Whitepoint Methods

[image] [image]

DynamicNodes API
Whitepoint Methods
Whitepoint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Whitepoint type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

Whitepoint Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
Whitepoint..::..ToString Method
Whitepoint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

Whitepoint Class
DynamicNode.Types.Imaging Namespace


Whitepoint Properties

[image] [image]

DynamicNodes API
Whitepoint Properties
Whitepoint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Whitepoint type exposes the following members.

Properties

 | Name | Description
 | ByName | Gibt ein Dictionary mit allen Standard-Weißpunkten zurück.
Public property | Description | Eine kurze Beschreibung des Weißpunkts.
Public property | Name | Der Name des Weißpunkts.
Public property | Value | Der XYZ-Farbwert, der den Weißpunkt definiert.

See Also

Whitepoint Class
DynamicNode.Types.Imaging Namespace


ByName Property

[image]

DynamicNodes API
Whitepoint..::..ByName Property
Whitepoint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Dictionary mit allen Standard-Weißpunkten zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public static IDictionary<WhitePointName, Whitepoint> ByName { get; }
Visual Basic
Public Shared ReadOnly Property ByName As IDictionary(Of WhitePointName, Whitepoint)
    Get
F#
static member ByName : IDictionary<WhitePointName, Whitepoint>

See Also

Whitepoint Class
DynamicNode.Types.Imaging Namespace


Description Property

[image]

DynamicNodes API
Whitepoint..::..Description Property
Whitepoint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine kurze Beschreibung des Weißpunkts.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public string Description { get; private set; }
Visual Basic
Public Property Description As String
    Get
    Private Set
F#
member Description : string with get, private set

See Also

Whitepoint Class
DynamicNode.Types.Imaging Namespace


Name Property

[image]

DynamicNodes API
Whitepoint..::..Name Property
Whitepoint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Name des Weißpunkts.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
F#
member Name : string with get, private set

See Also

Whitepoint Class
DynamicNode.Types.Imaging Namespace


Value Property

[image]

DynamicNodes API
Whitepoint..::..Value Property
Whitepoint Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der XYZ-Farbwert, der den Weißpunkt definiert.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_XYZ Value { get; private set; }
Visual Basic
Public Property Value As ColorValue_XYZ
    Get
    Private Set
F#
member Value : ColorValue_XYZ with get, private set

See Also

Whitepoint Class
DynamicNode.Types.Imaging Namespace


WhitePointName Enumeration

[image]

DynamicNodes API
WhitePointName Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Aufzählung der Namen von Standard-Weißpunkten.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public enum WhitePointName
Visual Basic
Public Enumeration WhitePointName
F#
type WhitePointName

Members

Member name | Description
A |
B |
C |
D50 |
D55 |
D65 |
D75 |
E |
F2 |
F7 |
F11 |

See Also

DynamicNode.Types.Imaging Namespace


XYZImage32 Class

[image]

DynamicNodes API
XYZImage32 Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein spezielles Tupel mit drei Elementen zur Aufnahme von X-, Y- und Z-Kanälen eines geräteunabhängigen Farbbildes mit dem elementaren Datentyp Single.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
[SerializableAttribute]
public class XYZImage32 : Tupel<Matrix<float>>
Visual Basic
<SerializableAttribute> _
Public Class XYZImage32 _
    Inherits Tupel(Of Matrix(Of Single))
F#
[<SerializableAttribute>]
type XYZImage32 =
    class
        inherit Tupel<Matrix<float32>>
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Types.Base..::..Tupel <(Of <(<' Matrix <(Of <(<' Single >)>)>>)>)>
DynamicNode.Types.Imaging..::..XYZImage32

See Also

XYZImage32 Members
DynamicNode.Types.Imaging Namespace


XYZImage32 Members

[image] [image]

DynamicNodes API
XYZImage32 Members
XYZImage32 Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XYZImage32 type exposes the following members.

Constructors

 | Name | Description
Protected method | XYZImage32()()()() | Initialisiert eine neue Instanz von XYZImage32.
Public method | XYZImage32(Int32, Int32, Single) | Initialisiert eine neue Instanz der XYZImage32-Klasse.
Public method | XYZImage32(Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>)) | Initialisiert eine neue Instanz von XYZImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

Properties

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den XYZ-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | X | Gibt den X-Kanal zurück.
Public property | Y | Gibt den Y-Kanal zurück.
Public property | Z | Gibt den Z-Kanal zurück.

See Also

XYZImage32 Class
DynamicNode.Types.Imaging Namespace


XYZImage32 Constructor

[image] [image]

DynamicNodes API
XYZImage32 Constructor
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Protected method | XYZImage32()()()() | Initialisiert eine neue Instanz von XYZImage32.
Public method | XYZImage32(Int32, Int32, Single) | Initialisiert eine neue Instanz der XYZImage32-Klasse.
Public method | XYZImage32(Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>), Matrix<(Of <<'(Single>)>>)) | Initialisiert eine neue Instanz von XYZImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

See Also

XYZImage32 Class
XYZImage32 Members
DynamicNode.Types.Imaging Namespace


XYZImage32 Constructor

[image]

DynamicNodes API
XYZImage32 Constructor
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von XYZImage32.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
protected XYZImage32()
Visual Basic
Protected Sub New
F#
new : unit -> XYZImage32

See Also

XYZImage32 Class
XYZImage32 Overload
DynamicNode.Types.Imaging Namespace


XYZImage32 Constructor (Int32, Int32, Single)

[image]

DynamicNodes API
XYZImage32 Constructor (Int32, Int32, Single)
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der XYZImage32-Klasse.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public XYZImage32(
    int width,
    int heigth,
    float defValue
)
Visual Basic
Public Sub New ( _
    width As Integer, _
    heigth As Integer, _
    defValue As Single _
)
F#
new :
        width:int *
        heigth:int *
        defValue:float32 -> XYZImage32

Parameters

width
Type: System..::..Int32
Die Breite.
heigth
Type: System..::..Int32
Die Höhe.
defValue
Type: System..::..Single
Der Standardwert für Indexüberschreitungen.

See Also

XYZImage32 Class
XYZImage32 Overload
DynamicNode.Types.Imaging Namespace


XYZImage32 Constructor (Matrix(Single), Matrix(Single), Matrix(Single))

[image]

DynamicNodes API
XYZImage32 Constructor (Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>, Matrix<(Of <(<'Single>)>)>)
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz von XYZImage32-Klasse mit Hilfe von drei Matrizen für die Farbkanäle.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public XYZImage32(
    Matrix<float> x,
    Matrix<float> y,
    Matrix<float> z
)
Visual Basic
Public Sub New ( _
    x As Matrix(Of Single), _
    y As Matrix(Of Single), _
    z As Matrix(Of Single) _
)
F#
new :
        x:Matrix<float32> *
        y:Matrix<float32> *
        z:Matrix<float32> -> XYZImage32

Parameters

x
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der X-Kanal.
y
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der Y-Kanal.
z
Type: DynamicNode.Types.Base..::..Matrix <(Of <(<' Single >)>)>
Der Z-Kanal.

See Also

XYZImage32 Class
XYZImage32 Overload
DynamicNode.Types.Imaging Namespace


XYZImage32 Methods

[image] [image]

DynamicNodes API
XYZImage32 Methods
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XYZImage32 type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents this instance. (Overrides Tupel<(Of <(<'T>)>)>..::..ToString()()()().)

See Also

XYZImage32 Class
DynamicNode.Types.Imaging Namespace


ToString Method

[image]

DynamicNodes API
XYZImage32..::..ToString Method
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Returns a String that represents this instance.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A String that represents this instance.

See Also

XYZImage32 Class
DynamicNode.Types.Imaging Namespace


XYZImage32 Properties

[image] [image]

DynamicNodes API
XYZImage32 Properties
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The XYZImage32 type exposes the following members.

Properties

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den XYZ-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.
Public property | X | Gibt den X-Kanal zurück.
Public property | Y | Gibt den Y-Kanal zurück.
Public property | Z | Gibt den Z-Kanal zurück.

See Also

XYZImage32 Class
DynamicNode.Types.Imaging Namespace


Item Property

[image] [image]

DynamicNodes API
XYZImage32..::..Item Property
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gibt ein Element anhand seines Namens zurück oder legt es fest. (Inherited from Tupel<(Of <(<'T>)>)>.)
Public property | Item[([( Int32, Int32])]) | Gibt den XYZ-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

See Also

XYZImage32 Class
XYZImage32 Members
DynamicNode.Types.Imaging Namespace


Item Property (Int32, Int32)

[image]

DynamicNodes API
XYZImage32..::..Item Property (Int32, Int32)
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den XYZ-Farbwert des durch x und y definierten Pixel zurück oder legt ihn fest.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public ColorValue_XYZ this[
    int x,
    int y
] { get; set; }
Visual Basic
Public Default Property Item ( _
    x As Integer, _
    y As Integer _
) As ColorValue_XYZ
    Get
    Set
F#
member Item : ColorValue_XYZ with get, set

Parameters

x
Type: System..::..Int32
Die X-Koordinate des Pixels.
y
Type: System..::..Int32
Die Y-Koordinate des Pixels.

Return Value

Den RXY-Farbwert des Pixels.

See Also

XYZImage32 Class
Item Overload
DynamicNode.Types.Imaging Namespace


X Property

[image]

DynamicNodes API
XYZImage32..::..X Property
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den X-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> X { get; private set; }
Visual Basic
Public Property X As Matrix(Of Single)
    Get
    Private Set
F#
member X : Matrix<float32> with get, private set

Field Value

Der X-Kanal.

See Also

XYZImage32 Class
DynamicNode.Types.Imaging Namespace


Y Property

[image]

DynamicNodes API
XYZImage32..::..Y Property
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Y-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> Y { get; private set; }
Visual Basic
Public Property Y As Matrix(Of Single)
    Get
    Private Set
F#
member Y : Matrix<float32> with get, private set

Field Value

Der Y-Kanal.

See Also

XYZImage32 Class
DynamicNode.Types.Imaging Namespace


Z Property

[image]

DynamicNodes API
XYZImage32..::..Z Property
XYZImage32 Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Z-Kanal zurück.

Namespace: DynamicNode.Types.Imaging
Assembly: DataTypesAndTools (in DataTypesAndTools.dll) Version: 1.3.4679.19814 (1.3.0.0)

Syntax

C#
public Matrix<float> Z { get; private set; }
Visual Basic
Public Property Z As Matrix(Of Single)
    Get
    Private Set
F#
member Z : Matrix<float32> with get, private set

Field Value

Der Z-Kanal.

See Also

XYZImage32 Class
DynamicNode.Types.Imaging Namespace


DynamicNode.WinApp Namespace

[image]

DynamicNodes API
DynamicNode.WinApp Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Dieser Namensraum enthält die grafische Entwicklungsumgebung für das DynamicNodes-System.

Die wichtigste Klasse in diesem Namensraum ist das Steuerelement DNApplicationControl. Mit diesem Steuerelement kann die Entwicklungsumgebung in andere Windows-Forms-Projekte eingebunden werden.

Classes

 | Class | Description
Public class | DNApplicationControl | Ein Steuerelement, welches eine vollständige DynamicNodes-Entwicklungsumgebung hostet. Zum Starten der Entwicklungsumgebung muss die Methode BootEnvironment()()()() aufgerufen werden.
Public class | Document | Das Dokument-Objekt, welches den Editor des Graphen verwaltet.
Public class | GUICore | Der Kern der Benutzeroberfläche.
Public class | HelpForm | Das Hilfe-Fenster von DynamicNodes.
Public class | InfoDialog | Das Info-Fenster der DynamicNodes-Umgebung. Es zeigt Versionsstände und Lizenzinformationen an.
Public class | PropertyDialog | Ein Eigenschaftsfenster für beliebige Objekte. Dieses Dialogfenster wird typischerweise mit den Property-Wrapper-Klassen aus dem Namensraum DynamicNode.WinApp.PropertyWrapper verwendet.
Public class | TemplateLibrary | Listet die System- und Benutzervorlagen in einem Baum und stellt Funktionen zur Erzeugung von zugehörigen Oberflächensteuerelementen zur Verfügung.
Public class | TemplateLibrary..::..FolderNode | Ein Knoten in der Vorlagenbibiothek, der ein Verzeichnis repräsentiert.
Public class | TemplateLibrary..::..Node | Die abstrakte Basisklasse für Knoten in der Baumstruktur der Vorlagenbibliothek.
Public class | TemplateLibrary..::..TemplateNode | Ein Knoten in der Vorlagenbibiothek, der eine Vorlage repräsentiert.
Public class | ViewDescriptor | Beschreibt eine Ansicht der Entwicklungsumgebung.

Interfaces

 | Interface | Description
Public interface | IAssetContainer | Die Schnittstelle eines Asset-Containers. Ein Asset-Container ist ein Objekt, welches als Sammelstelle für optionale Komponenten dient.
Public interface | IGuiHost | Eine Schnittstelle für Objekte, welche die GUI der Entwicklungsmgebung bereitstellen. Das kann ein Fenster oder ein Steuerelement sein.

Enumerations

 | Enumeration | Description
Public enumeration | ProjectKind | Eine Aufzählung mit verschiedenen Projekttypen.


DNApplicationControl Class

[image]

DynamicNodes API
DNApplicationControl Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Steuerelement, welches eine vollständige DynamicNodes-Entwicklungsumgebung hostet. Zum Starten der Entwicklungsumgebung muss die Methode BootEnvironment()()()() aufgerufen werden.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public class DNApplicationControl : UserControl,
    IGuiHost, IWin32Window
Visual Basic
Public Class DNApplicationControl _
    Inherits UserControl _
    Implements IGuiHost, IWin32Window
F#
type DNApplicationControl =
    class
        inherit UserControl
        interface IGuiHost
        interface IWin32Window
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
DynamicNode.WinApp..::..DNApplicationControl

See Also

DNApplicationControl Members
DynamicNode.WinApp Namespace


DNApplicationControl Members

[image] [image]

DynamicNodes API
DNApplicationControl Members
DNApplicationControl Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DNApplicationControl type exposes the following members.

Constructors

 | Name | Description
Public method | DNApplicationControl | Initialisiert einen neue Instanz der DNApplicationControl-Klasse.

Methods

 | Name | Description
Public method | BootEnvironment | Startet die Entwicklungsumgebung.
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | ExecuteScript | Führt ein PowerShell-Script in der Entwicklungsumgebung aus.
Public method | OnExitRequest | Löst das Ereignis ExitRequest aus.
Protected method | OnLayout | Löst das Ereignis [E:Layout] aus. (Overrides ContainerControl..::..OnLayout(LayoutEventArgs).)
Public method | RegisterAdditionalNodeLibraries | Registriert zusätzliche Knotenbibliotheken.
Public method | RegisterAdditionalNodeLibraryPaths | Registriert zusätzliche Pfade, die nach Knotenbibliotheken durchsucht werden sollen.

Properties

 | Name | Description
Public property | AllowUserLibs | Gibt einen Wert zurück oder legt ihn fest, der angibt ob Knotenbibliotheken aus dem Arbeitsverzeichnis geladen werden sollen.
Public property | Configuration | Gibt die Konfiguration des DynamicNodes-Systems zurück. Die Konfiguration kann erst abgerufen werden, wenn die Entwicklungsumgebung gestartet wurde.
Public property | Core | Gibt den Kern der Benutzeroberfläche zurück.
Public property | DockPanel | Gibt das DockPanel zurück, welches die Anordnung der Ansichten organisiert.
Public property | Runtime | Gibt die DynamicNodes-Laufzeitumgebung zurück.
Public property | ShowStatusBar | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Statusleiste sichtbar ist oder nicht.
Public property | ShowToolbar | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Symbolleiste sichtbar ist oder nicht.
Public property | StartLog | Gibt einen Wert zurück oder legt ihn fest, der angibt ob eine Protokolldatei der aktuelle Sitzung im Arbeitsverzeichnis angelegt werden soll.
Public property | StartRemoteServer | Gibt einen Wert zurück oder legt ihn fest, der angibt ob ein Server für die Fernsteuerung der Entwicklungsumgebung gestartet werden soll.
Public property | StartShell | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ApplicationCoreShell gestartet werden soll.
Public property | SystemPath | Gibt den Systempfad des DynamicNodes-Systems zurück oder legt ihn fest.
Public property | WorkspacePath | Gibt das Arbeitsverzeichnis des DynamicNodes-Systems zurück oder legt es fest.

Events

 | Name | Description
Public event | ExitRequest | Tritt auf wenn die DynamicNodes-Entwicklungsumgebung das Beenden der Host-Anwendung anfordert. Das kann z.B. durch einen Script-Befehl in der ApplicationCoreShell geschehen.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


DNApplicationControl Constructor

[image]

DynamicNodes API
DNApplicationControl Constructor
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert einen neue Instanz der DNApplicationControl-Klasse.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public DNApplicationControl()
Visual Basic
Public Sub New
F#
new : unit -> DNApplicationControl

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


DNApplicationControl Methods

[image] [image]

DynamicNodes API
DNApplicationControl Methods
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DNApplicationControl type exposes the following members.

Methods

 | Name | Description
Public method | BootEnvironment | Startet die Entwicklungsumgebung.
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | ExecuteScript | Führt ein PowerShell-Script in der Entwicklungsumgebung aus.
Public method | OnExitRequest | Löst das Ereignis ExitRequest aus.
Protected method | OnLayout | Löst das Ereignis [E:Layout] aus. (Overrides ContainerControl..::..OnLayout(LayoutEventArgs).)
Public method | RegisterAdditionalNodeLibraries | Registriert zusätzliche Knotenbibliotheken.
Public method | RegisterAdditionalNodeLibraryPaths | Registriert zusätzliche Pfade, die nach Knotenbibliotheken durchsucht werden sollen.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


BootEnvironment Method

[image]

DynamicNodes API
DNApplicationControl..::..BootEnvironment Method
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Startet die Entwicklungsumgebung.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void BootEnvironment()
Visual Basic
Public Sub BootEnvironment
F#
member BootEnvironment : unit -> unit

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


Dispose Method

[image]

DynamicNodes API
DNApplicationControl..::..Dispose Method
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


ExecuteScript Method

[image]

DynamicNodes API
DNApplicationControl..::..ExecuteScript Method
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt ein PowerShell-Script in der Entwicklungsumgebung aus.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string ExecuteScript(
    string script
)
Visual Basic
Public Function ExecuteScript ( _
    script As String _
) As String
F#
member ExecuteScript :
        script:string -> string

Parameters

script
Type: System..::..String
Der Quelltext des PowerShell-Scripts.

Return Value

Die Ausgabe der PowerShell während der Script-Ausführung.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


OnExitRequest Method

[image]

DynamicNodes API
DNApplicationControl..::..OnExitRequest Method
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis ExitRequest aus.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void OnExitRequest()
Visual Basic
Public Sub OnExitRequest
F#
member OnExitRequest : unit -> unit

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


OnLayout Method

[image]

DynamicNodes API
DNApplicationControl..::..OnLayout Method
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis [E:Layout] aus.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
F#
abstract OnLayout :
        levent:LayoutEventArgs -> unit
override OnLayout :
        levent:LayoutEventArgs -> unit

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
Eine Instanz von LayoutEventArgs, die die Ereignisdaten enthält.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


RegisterAdditionalNodeLibraries Method

[image]

DynamicNodes API
DNApplicationControl..::..RegisterAdditionalNodeLibraries Method
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert zusätzliche Knotenbibliotheken.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void RegisterAdditionalNodeLibraries(
    params string[] additionalLibs
)
Visual Basic
Public Sub RegisterAdditionalNodeLibraries ( _
    ParamArray additionalLibs As String() _
)
F#
member RegisterAdditionalNodeLibraries :
        additionalLibs:string[] -> unit

Parameters

additionalLibs
Type: array< System..::..String >[]()[][]
Die absoluten Pfade zu den zusätzlichen Knotenbibliotheken.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn versucht wird Pfade zu registrieren, aber die Entwicklungsumgebung bereits gestartet wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


RegisterAdditionalNodeLibraryPaths Method

[image]

DynamicNodes API
DNApplicationControl..::..RegisterAdditionalNodeLibraryPaths Method
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert zusätzliche Pfade, die nach Knotenbibliotheken durchsucht werden sollen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void RegisterAdditionalNodeLibraryPaths(
    params string[] additionalLibPaths
)
Visual Basic
Public Sub RegisterAdditionalNodeLibraryPaths ( _
    ParamArray additionalLibPaths As String() _
)
F#
member RegisterAdditionalNodeLibraryPaths :
        additionalLibPaths:string[] -> unit

Parameters

additionalLibPaths
Type: array< System..::..String >[]()[][]
Die absoluten Pfade zu den zusätzlichen Verzeichnissen.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn versucht wird Pfade zu registrieren, aber die Entwicklungsumgebung bereits gestartet wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


DNApplicationControl Properties

[image] [image]

DynamicNodes API
DNApplicationControl Properties
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DNApplicationControl type exposes the following members.

Properties

 | Name | Description
Public property | AllowUserLibs | Gibt einen Wert zurück oder legt ihn fest, der angibt ob Knotenbibliotheken aus dem Arbeitsverzeichnis geladen werden sollen.
Public property | Configuration | Gibt die Konfiguration des DynamicNodes-Systems zurück. Die Konfiguration kann erst abgerufen werden, wenn die Entwicklungsumgebung gestartet wurde.
Public property | Core | Gibt den Kern der Benutzeroberfläche zurück.
Public property | DockPanel | Gibt das DockPanel zurück, welches die Anordnung der Ansichten organisiert.
Public property | Runtime | Gibt die DynamicNodes-Laufzeitumgebung zurück.
Public property | ShowStatusBar | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Statusleiste sichtbar ist oder nicht.
Public property | ShowToolbar | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Symbolleiste sichtbar ist oder nicht.
Public property | StartLog | Gibt einen Wert zurück oder legt ihn fest, der angibt ob eine Protokolldatei der aktuelle Sitzung im Arbeitsverzeichnis angelegt werden soll.
Public property | StartRemoteServer | Gibt einen Wert zurück oder legt ihn fest, der angibt ob ein Server für die Fernsteuerung der Entwicklungsumgebung gestartet werden soll.
Public property | StartShell | Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ApplicationCoreShell gestartet werden soll.
Public property | SystemPath | Gibt den Systempfad des DynamicNodes-Systems zurück oder legt ihn fest.
Public property | WorkspacePath | Gibt das Arbeitsverzeichnis des DynamicNodes-Systems zurück oder legt es fest.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


AllowUserLibs Property

[image]

DynamicNodes API
DNApplicationControl..::..AllowUserLibs Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt ob Knotenbibliotheken aus dem Arbeitsverzeichnis geladen werden sollen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool AllowUserLibs { get; set; }
Visual Basic
Public Property AllowUserLibs As Boolean
    Get
    Set
F#
member AllowUserLibs : bool with get, set

Field Value

true wenn Knotenbibliotheken aus dem Arbeitsverzeichnis geladen werden sollen, sonst false.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn versucht wird einen neuen Wert festzulegen, aber die Entwicklungsumgebung bereits gestartet wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


Configuration Property

[image]

DynamicNodes API
DNApplicationControl..::..Configuration Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Konfiguration des DynamicNodes-Systems zurück. Die Konfiguration kann erst abgerufen werden, wenn die Entwicklungsumgebung gestartet wurde.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IConfiguration Configuration { get; }
Visual Basic
Public ReadOnly Property Configuration As IConfiguration
    Get
F#
member Configuration : IConfiguration

Field Value

Die Konfiguration der Entwicklungsumgebung.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn die Entwicklungsumgebung noch nicht gestartet wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


Core Property

[image]

DynamicNodes API
DNApplicationControl..::..Core Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Kern der Benutzeroberfläche zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public GUICore Core { get; }
Visual Basic
Public ReadOnly Property Core As GUICore
    Get
F#
member Core : GUICore

Field Value

Der Kern der Benutzeroberfläche.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn der Kern der Benutzeroberfläche abgefragt wird, bevor die Entwicklungsumgebung gestartet wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


DockPanel Property

[image]

DynamicNodes API
DNApplicationControl..::..DockPanel Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das DockPanel zurück, welches die Anordnung der Ansichten organisiert.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public DockPanel DockPanel { get; }
Visual Basic
Public ReadOnly Property DockPanel As DockPanel
    Get
F#
abstract DockPanel : DockPanel
override DockPanel : DockPanel

Field Value

Das DockPanel.

Implements

IGuiHost..::..DockPanel

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


Runtime Property

[image]

DynamicNodes API
DNApplicationControl..::..Runtime Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die DynamicNodes-Laufzeitumgebung zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IRuntime Runtime { get; }
Visual Basic
Public ReadOnly Property Runtime As IRuntime
    Get
F#
member Runtime : IRuntime

Field Value

Die Laufzeitumgebung.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn die Laufzeitumgebung abgefragt wird, bevor die Entwicklungsumgebung gestartet wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


ShowStatusBar Property

[image]

DynamicNodes API
DNApplicationControl..::..ShowStatusBar Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Statusleiste sichtbar ist oder nicht.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool ShowStatusBar { get; set; }
Visual Basic
Public Property ShowStatusBar As Boolean
    Get
    Set
F#
member ShowStatusBar : bool with get, set

Field Value

true wenn die Statusleiste sichtbar ist, sonst false.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


ShowToolbar Property

[image]

DynamicNodes API
DNApplicationControl..::..ShowToolbar Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt ob die Symbolleiste sichtbar ist oder nicht.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool ShowToolbar { get; set; }
Visual Basic
Public Property ShowToolbar As Boolean
    Get
    Set
F#
member ShowToolbar : bool with get, set

Field Value

true wenn die Symbolleiste sichtbar ist, sonst false.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


StartLog Property

[image]

DynamicNodes API
DNApplicationControl..::..StartLog Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt ob eine Protokolldatei der aktuelle Sitzung im Arbeitsverzeichnis angelegt werden soll.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool StartLog { get; set; }
Visual Basic
Public Property StartLog As Boolean
    Get
    Set
F#
member StartLog : bool with get, set

Field Value

true wenn eine Protokolldatei geschrieben werden soll, sonst false.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn versucht wird einen neuen Wert festzulegen, aber die Entwicklungsumgebung bereits gestartet wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


StartRemoteServer Property

[image]

DynamicNodes API
DNApplicationControl..::..StartRemoteServer Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt ob ein Server für die Fernsteuerung der Entwicklungsumgebung gestartet werden soll.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool StartRemoteServer { get; set; }
Visual Basic
Public Property StartRemoteServer As Boolean
    Get
    Set
F#
member StartRemoteServer : bool with get, set

Field Value

true wenn der Server für die Fernsteuerung gestartet werden soll, sonst false.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn versucht wird einen neuen Wert festzulegen, aber die Entwicklungsumgebung bereits gestartet wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


StartShell Property

[image]

DynamicNodes API
DNApplicationControl..::..StartShell Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück oder legt ihn fest, der angibt ob die ApplicationCoreShell gestartet werden soll.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool StartShell { get; set; }
Visual Basic
Public Property StartShell As Boolean
    Get
    Set
F#
member StartShell : bool with get, set

Field Value

true wenn [start shell], sonst false.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn versucht wird einen neuen Wert festzulegen, aber die Entwicklungsumgebung bereits gestartet wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


SystemPath Property

[image]

DynamicNodes API
DNApplicationControl..::..SystemPath Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Systempfad des DynamicNodes-Systems zurück oder legt ihn fest.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string SystemPath { get; set; }
Visual Basic
Public Property SystemPath As String
    Get
    Set
F#
member SystemPath : string with get, set

Field Value

Der Systempfad des DynamicNodes-Systems.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn versucht wird einen neuen Wert festzulegen, aber die Entwicklungsumgebung bereits gestartet wurde.
System.IO..::..DirectoryNotFoundException | Wenn geworfen, wenn das übergebene Verzeichnis nicht gefunden wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


WorkspacePath Property

[image]

DynamicNodes API
DNApplicationControl..::..WorkspacePath Property
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das Arbeitsverzeichnis des DynamicNodes-Systems zurück oder legt es fest.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string WorkspacePath { get; set; }
Visual Basic
Public Property WorkspacePath As String
    Get
    Set
F#
member WorkspacePath : string with get, set

Field Value

Das Arbeitsverzeichnis des DynamicNodes-Systems oder null.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Wird geworfen, wenn versucht wird einen neuen Wert festzulegen, aber die Entwicklungsumgebung bereits gestartet wurde.
System.IO..::..DirectoryNotFoundException | Wenn geworfen, wenn das übergebene Verzeichnis nicht gefunden wurde.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


DNApplicationControl Events

[image] [image]

DynamicNodes API
DNApplicationControl Events
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The DNApplicationControl type exposes the following members.

Events

 | Name | Description
Public event | ExitRequest | Tritt auf wenn die DynamicNodes-Entwicklungsumgebung das Beenden der Host-Anwendung anfordert. Das kann z.B. durch einen Script-Befehl in der ApplicationCoreShell geschehen.

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


ExitRequest Event

[image]

DynamicNodes API
DNApplicationControl..::..ExitRequest Event
DNApplicationControl Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn die DynamicNodes-Entwicklungsumgebung das Beenden der Host-Anwendung anfordert. Das kann z.B. durch einen Script-Befehl in der ApplicationCoreShell geschehen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public event EventHandler ExitRequest
Visual Basic
Public Event ExitRequest As EventHandler
F#
member ExitRequest : IEvent<EventHandler,
    EventArgs>

See Also

DNApplicationControl Class
DynamicNode.WinApp Namespace


Document Class

[image]

DynamicNodes API
Document Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Dokument-Objekt, welches den Editor des Graphen verwaltet.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public class Document : GraphDocument
Visual Basic
Public Class Document _
    Inherits GraphDocument
F#
type Document =
    class
        inherit GraphDocument
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.Ext.Visual..::..GraphDocument
DynamicNode.WinApp..::..Document

See Also

Document Members
DynamicNode.WinApp Namespace


Document Members

[image] [image]

DynamicNodes API
Document Members
Document Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Document type exposes the following members.

Constructors

 | Name | Description
Public method | Document | Initialisiert eine neue Document-Instanz.

Methods

 | Name | Description
Public method | BeginConnectingProcess | Startet den visuellen Verbindungs-Prozess und wählt den übergebenen Anschluss aus. (Inherited from GraphDocument.)
Public method | BeginVisualSelectionProcess | Startet den visuellen Auswahl-Prozess. (Inherited from GraphDocument.)
Public method | CloseView | Schließt das Dokument.
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen. (Overrides GraphDocument..::..Dispose()()()().)
Public method | EndConnectingProcess | Ends the connecting process. (Inherited from GraphDocument.)
Public method | EndVisualSelectionProcess | Benachrichtigt das Graph-Dokument über das Ende des Auswahlprozesses. (Inherited from GraphDocument.)
Public method | ExtendNodeSelection(INode) | Fügt einen Knoten der Knotenauswahl hinzu. (Inherited from GraphDocument.)
Public method | ExtendNodeSelection(IEnumerable<(Of <<'(INode>)>>)) | Fügt mehrere Knoten der Knotenauswahl hinzu. (Inherited from GraphDocument.)
Protected method | Finalize | Gibt nicht verwaltete Resourcen frei und/oder führt weitere Aufräumarbeiten durch bevor das GraphDocument-Objekt durch den Garbage Collector aufgelöst wird. (Inherited from GraphDocument.)
Public method | GetGraphVis | Gibt die Visualieirung für der Graph zurück. (Inherited from GraphDocument.)
Public method | GetNodeByMouse | Gibt einen Knoten anhand von Workspace-Koordinaten zurück. (Inherited from GraphDocument.)
Public method | GetPinByMouse | Gibt einen Pin anhand von Workspace-Koordinaten zurück. (Inherited from GraphDocument.)
Public method | GetPortByMouse | Gibt einen Port anhand von Workspace-Koordinaten zurück. (Inherited from GraphDocument.)
Public method | HitTest | Prüft mit Hilfe von Editor-Koordinaten ob sich ein Objekt unter dem Cursor befindet. (Inherited from GraphDocument.)
Public method | IsNodeSecondarySelected | Gibt einen Wert zurück, der angibt, ob der übergebene Knoten sekundär markiert ist. (Inherited from GraphDocument.)
Public method | OnGraphProperties | Löst das Ereignis NodeProperties aus. (Inherited from GraphDocument.)
Public method | OnMouseClick | Löst das Ereignis MouseClick aus. (Inherited from GraphDocument.)
Public method | OnMouseDoubleClick | Löst das Ereignis MouseDoubleClick aus. (Inherited from GraphDocument.)
Public method | OnMouseDown | Löst das Ereignis MouseDown aus. (Inherited from GraphDocument.)
Public method | OnMouseEnter | Löst das Ereignis MouseEnter aus. (Inherited from GraphDocument.)
Public method | OnMouseHover | Löst das Ereignis MouseHover aus. (Inherited from GraphDocument.)
Public method | OnMouseLeave | Löst das Ereignis MouseLeave aus. (Inherited from GraphDocument.)
Public method | OnMouseMove | Löst das Ereignis MouseMove aus. (Inherited from GraphDocument.)
Public method | OnMouseNodeEnter | Löst das Ereignis MouseNodeEnter aus. (Inherited from GraphDocument.)
Public method | OnMouseNodeLeave | Löst das Ereignis MouseNodeLeave aus. (Inherited from GraphDocument.)
Public method | OnMousePortEnter | Löst das Ereignis MousePortEnter aus. (Inherited from GraphDocument.)
Public method | OnMousePortLeave | Löst das Ereignis MousePortLeave aus. (Inherited from GraphDocument.)
Public method | OnMouseUp | Löst das Ereignis MouseUp aus. (Inherited from GraphDocument.)
Public method | OnMouseWheel | Löst das Ereignis MouseWheel aus. (Inherited from GraphDocument.)
Public method | OnNodeHelp | Löst das Ereignis NodeHelp aus. (Inherited from GraphDocument.)
Public method | OnNodeProperties | Löst das Ereignis NodeProperties aus. (Inherited from GraphDocument.)
Public method | OnNodeSelect | Löst das Ereignis NodeSelect aus. (Inherited from GraphDocument.)
Public method | OnPortProperties | Löst das Ereignis PortProperties aus. (Inherited from GraphDocument.)
Protected method | OnSelection | Löst das Ereignis Selected aus.
Public method | OnShowSubGraph | Löst das Ereignis ShowSubGraph aus. (Inherited from GraphDocument.)
Public method | ReduceNodeSelection | Entfernt einen Knoten aus der Knotenauswahl. (Inherited from GraphDocument.)
Public method | Repaint | Zeichnet das Graph-Dokument neu. (Inherited from GraphDocument.)
Public method | Save()()()() | Speichert den Graphen dieses Dokuments. Falls der Graph noch nicht gespeichert wurde wird ein Datei-Speichern-Dialog angezeigt.
Public method | Save(String, Boolean) | Speichert den Graphen in einer Datei.
Public method | SaveAs | Zeigt einen Datei-Speichern-Dialog für das Speichern des Graphen an und speichert den Graphen, falls der Benutzer einen Speicherort bestimmt hat.
Public method | Select | Wählt dieses Dokument aus und bringt es in den Vordergrund.
Public method | SelectNothing | Löscht die aktuelle Auswahl. (Inherited from GraphDocument.)
Public method | ShowView | Zeigt die Ansicht des Dokuments an.
Public method | UseAsTemplate | Trennt das Dokument von der Projektdatei und wandelt das Dokument in eine nicht gespeicherte Vorlage um.
Public method | WhileConnectingProcess | Benachrichtigt der Graph-Dokument über die Cursor-Bewegung während des Verbindungsprozesses. (Inherited from GraphDocument.)
Public method | WhileVisualSelectionProcess | Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Auswahlprozesses. (Inherited from GraphDocument.)

Properties

 | Name | Description
Public property | AutoRepaint | Liest oder schreibt einen Wert, der angibt ob die Arbeitsfläche bei Änderungen des Graphen automatisch neu gezeichnet werden soll. (Inherited from GraphDocument.)
Public property | Caption | Gibt die Beschriftung Dokuments zurück.
Public property | Core | Gibt den Kern der Benutzeroberfläche zurück.
Public property | Editor | Liest oder schreibt den Eitor. (Inherited from GraphDocument.)
Public property | FileName | Gibt den Namen der Datei zurück, in welcher der Graph gespeichert ist, oder null, wenn der Graph nicht gespeichert ist.
Public property | Graph | Liest der Graph, welches dargestellt werden soll. (Inherited from GraphDocument.)
Public property | IsConnectingInProgress | Gibt einen Wert zurück, der angibt, ob ein Verbindungsprozess aktiv ist. (Inherited from GraphDocument.)
Public property | IsMouseOverDocument | Gibt einen Wert zurück, der angibt ob der Cursor sich zur Zeit über dem Dokument befindet. (Inherited from GraphDocument.)
Public property | IsPinVisible | Gibt einen Wert zurück, der angibt ob die Pins der Verbindungen sichtbar sind oder nicht. (Inherited from GraphDocument.)
Public property | IsSubGraph | Gibt einen Wert zurück, der angibt ob dieses Dokument einen Sub-Graphen darstellt.
Public property | Runtime | Gibt die Laufzeitumgebung zurück in der der Graph ausgeführt wird. (Inherited from GraphDocument.)
Public property | SecondarySelectedNodes | Gibt eine Auflistung mit allen sekundär markierten Knoten zurück. (Inherited from GraphDocument.)
Public property | SecondarySelectedNodesCount | Gibt die Anzahl aller sekundär markierten Knoten einschließlich des primär markierten Knotens zurück. (Inherited from GraphDocument.)
Public property | SelectedNode | Gibt den ausgewählten Knoten zurück oder legt ihn fest. (Inherited from GraphDocument.)
Public property | SelectedPin | Liest oder schreibt den ausgewählten Pin. (Inherited from GraphDocument.)
Public property | SelectedPort | Liest oder schreibt den ausgewählten Port. (Inherited from GraphDocument.)

Events

 | Name | Description
Public event | Disposing | Wird ausgelöst, wenn das Dokument zerstört wird. (Inherited from GraphDocument.)
Public event | GraphProperties | Wird ausgelöst, wenn für einen Graphen der Eigenschaftsdialog angefordert wurde. (Inherited from GraphDocument.)
Public event | MouseClick | Wird ausgelöst, wenn ein Klick ausgeführt wurde. (Inherited from GraphDocument.)
Public event | MouseDoubleClick | Wird ausgelöst, wenn die Doppel-Klick ausgeführt wurde. (Inherited from GraphDocument.)
Public event | MouseDown | Wird ausgelöst, wenn eine Maustaste gedrückt wird. (Inherited from GraphDocument.)
Public event | MouseEnter | Wird ausgelöst, wenn der Cursor den Editor betritt. (Inherited from GraphDocument.)
Public event | MouseHover | Wird ausgelöst, wenn der Cursor über der Arbeitsfläche verweilt. (Inherited from GraphDocument.)
Public event | MouseLeave | Wird ausgelöst, wenn der Cursor den Editor verlässt. (Inherited from GraphDocument.)
Public event | MouseMove | Wird ausgelöst, wenn der Cursor bewegt wird. (Inherited from GraphDocument.)
Public event | MouseNodeEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Knotens hinien bewegt wird. (Inherited from GraphDocument.)
Public event | MouseNodeLeave | Wird ausgelöst, wenn der Cursor den Bereich eines Knotens verlässt. (Inherited from GraphDocument.)
Public event | MousePortEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Ports hineinbewegt wird. (Inherited from GraphDocument.)
Public event | MousePortLeave | Wird ausgelöst, wenn der Cursor aus dem Bereich eines Ports herrausbewegt wird. (Inherited from GraphDocument.)
Public event | MouseUp | Wird ausgelöst, wenn eine Maustaste losgelassen wird. (Inherited from GraphDocument.)
Public event | MouseWheel | Wird ausgelöst, wenn das Mausrad gedreht wird. (Inherited from GraphDocument.)
Public event | NodeHelp | Wird ausgelöst, wenn für einen Knoten Hilfe angefordert wird. (Inherited from GraphDocument.)
Public event | NodeProperties | Wird ausgelöst, wenn für einen Knoten der Eigenschaftsdialog angefordert wurde. (Inherited from GraphDocument.)
Public event | NodeSelect | Wird ausgelöst, wenn ein Knoten ausgewählt wird. (Inherited from GraphDocument.)
Public event | PortProperties | Wird ausgelöst, wenn für einen Port der Eigenschaftsdialog angefordert wurde. (Inherited from GraphDocument.)
Public event | Selected | Tritt auf wenn dieses Dokument ausgewählt bzw. in den Vordergrund geholt wird.
Public event | ShowSubGraph | Wird ausgelöst, wenn ein Sub-Graph-Knoten den gekapselten Graphen anzeigen möchte. (Inherited from GraphDocument.)

See Also

Document Class
DynamicNode.WinApp Namespace


Document Constructor

[image]

DynamicNodes API
Document Constructor
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Document-Instanz.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public Document(
    GUICore core,
    IGraph graph,
    PaintSettings ps
)
Visual Basic
Public Sub New ( _
    core As GUICore, _
    graph As IGraph, _
    ps As PaintSettings _
)
F#
new :
        core:GUICore *
        graph:IGraph *
        ps:PaintSettings -> Document

Parameters

core
Type: DynamicNode.WinApp..::..GUICore
Der Kern der Benutzeroberfläche.
graph
Type: DynamicNode.Core..::..IGraph
Der Graph, welcher durch das Dokument dargestellt wird.
ps
Type: DynamicNode.Ext.Visual..::..PaintSettings
Die Einstellungen für die grafische Darstellung.

See Also

Document Class
DynamicNode.WinApp Namespace


Document Methods

[image] [image]

DynamicNodes API
Document Methods
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Document type exposes the following members.

Methods

 | Name | Description
Public method | BeginConnectingProcess | Startet den visuellen Verbindungs-Prozess und wählt den übergebenen Anschluss aus. (Inherited from GraphDocument.)
Public method | BeginVisualSelectionProcess | Startet den visuellen Auswahl-Prozess. (Inherited from GraphDocument.)
Public method | CloseView | Schließt das Dokument.
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen. (Overrides GraphDocument..::..Dispose()()()().)
Public method | EndConnectingProcess | Ends the connecting process. (Inherited from GraphDocument.)
Public method | EndVisualSelectionProcess | Benachrichtigt das Graph-Dokument über das Ende des Auswahlprozesses. (Inherited from GraphDocument.)
Public method | ExtendNodeSelection(INode) | Fügt einen Knoten der Knotenauswahl hinzu. (Inherited from GraphDocument.)
Public method | ExtendNodeSelection(IEnumerable<(Of <<'(INode>)>>)) | Fügt mehrere Knoten der Knotenauswahl hinzu. (Inherited from GraphDocument.)
Protected method | Finalize | Gibt nicht verwaltete Resourcen frei und/oder führt weitere Aufräumarbeiten durch bevor das GraphDocument-Objekt durch den Garbage Collector aufgelöst wird. (Inherited from GraphDocument.)
Public method | GetGraphVis | Gibt die Visualieirung für der Graph zurück. (Inherited from GraphDocument.)
Public method | GetNodeByMouse | Gibt einen Knoten anhand von Workspace-Koordinaten zurück. (Inherited from GraphDocument.)
Public method | GetPinByMouse | Gibt einen Pin anhand von Workspace-Koordinaten zurück. (Inherited from GraphDocument.)
Public method | GetPortByMouse | Gibt einen Port anhand von Workspace-Koordinaten zurück. (Inherited from GraphDocument.)
Public method | HitTest | Prüft mit Hilfe von Editor-Koordinaten ob sich ein Objekt unter dem Cursor befindet. (Inherited from GraphDocument.)
Public method | IsNodeSecondarySelected | Gibt einen Wert zurück, der angibt, ob der übergebene Knoten sekundär markiert ist. (Inherited from GraphDocument.)
Public method | OnGraphProperties | Löst das Ereignis NodeProperties aus. (Inherited from GraphDocument.)
Public method | OnMouseClick | Löst das Ereignis MouseClick aus. (Inherited from GraphDocument.)
Public method | OnMouseDoubleClick | Löst das Ereignis MouseDoubleClick aus. (Inherited from GraphDocument.)
Public method | OnMouseDown | Löst das Ereignis MouseDown aus. (Inherited from GraphDocument.)
Public method | OnMouseEnter | Löst das Ereignis MouseEnter aus. (Inherited from GraphDocument.)
Public method | OnMouseHover | Löst das Ereignis MouseHover aus. (Inherited from GraphDocument.)
Public method | OnMouseLeave | Löst das Ereignis MouseLeave aus. (Inherited from GraphDocument.)
Public method | OnMouseMove | Löst das Ereignis MouseMove aus. (Inherited from GraphDocument.)
Public method | OnMouseNodeEnter | Löst das Ereignis MouseNodeEnter aus. (Inherited from GraphDocument.)
Public method | OnMouseNodeLeave | Löst das Ereignis MouseNodeLeave aus. (Inherited from GraphDocument.)
Public method | OnMousePortEnter | Löst das Ereignis MousePortEnter aus. (Inherited from GraphDocument.)
Public method | OnMousePortLeave | Löst das Ereignis MousePortLeave aus. (Inherited from GraphDocument.)
Public method | OnMouseUp | Löst das Ereignis MouseUp aus. (Inherited from GraphDocument.)
Public method | OnMouseWheel | Löst das Ereignis MouseWheel aus. (Inherited from GraphDocument.)
Public method | OnNodeHelp | Löst das Ereignis NodeHelp aus. (Inherited from GraphDocument.)
Public method | OnNodeProperties | Löst das Ereignis NodeProperties aus. (Inherited from GraphDocument.)
Public method | OnNodeSelect | Löst das Ereignis NodeSelect aus. (Inherited from GraphDocument.)
Public method | OnPortProperties | Löst das Ereignis PortProperties aus. (Inherited from GraphDocument.)
Protected method | OnSelection | Löst das Ereignis Selected aus.
Public method | OnShowSubGraph | Löst das Ereignis ShowSubGraph aus. (Inherited from GraphDocument.)
Public method | ReduceNodeSelection | Entfernt einen Knoten aus der Knotenauswahl. (Inherited from GraphDocument.)
Public method | Repaint | Zeichnet das Graph-Dokument neu. (Inherited from GraphDocument.)
Public method | Save()()()() | Speichert den Graphen dieses Dokuments. Falls der Graph noch nicht gespeichert wurde wird ein Datei-Speichern-Dialog angezeigt.
Public method | Save(String, Boolean) | Speichert den Graphen in einer Datei.
Public method | SaveAs | Zeigt einen Datei-Speichern-Dialog für das Speichern des Graphen an und speichert den Graphen, falls der Benutzer einen Speicherort bestimmt hat.
Public method | Select | Wählt dieses Dokument aus und bringt es in den Vordergrund.
Public method | SelectNothing | Löscht die aktuelle Auswahl. (Inherited from GraphDocument.)
Public method | ShowView | Zeigt die Ansicht des Dokuments an.
Public method | UseAsTemplate | Trennt das Dokument von der Projektdatei und wandelt das Dokument in eine nicht gespeicherte Vorlage um.
Public method | WhileConnectingProcess | Benachrichtigt der Graph-Dokument über die Cursor-Bewegung während des Verbindungsprozesses. (Inherited from GraphDocument.)
Public method | WhileVisualSelectionProcess | Benachrichtigt das Graph-Dokument über die Cursor-Bewegung während des Auswahlprozesses. (Inherited from GraphDocument.)

See Also

Document Class
DynamicNode.WinApp Namespace


CloseView Method

[image]

DynamicNodes API
Document..::..CloseView Method
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schließt das Dokument.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void CloseView()
Visual Basic
Public Sub CloseView
F#
member CloseView : unit -> unit

See Also

Document Class
DynamicNode.WinApp Namespace


Dispose Method

[image]

DynamicNodes API
Document..::..Dispose Method
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public override void Dispose()
Visual Basic
Public Overrides Sub Dispose
F#
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposable..::..Dispose()()()()

See Also

Document Class
DynamicNode.WinApp Namespace


ExtendNodeSelection Method

[image] [image]

DynamicNodes API
Document..::..ExtendNodeSelection Method
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | ExtendNodeSelection(INode) | Fügt einen Knoten der Knotenauswahl hinzu. (Inherited from GraphDocument.)
Public method | ExtendNodeSelection(IEnumerable<(Of <<'(INode>)>>)) | Fügt mehrere Knoten der Knotenauswahl hinzu. (Inherited from GraphDocument.)

See Also

Document Class
Document Members
DynamicNode.WinApp Namespace


OnSelection Method

[image]

DynamicNodes API
Document..::..OnSelection Method
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis Selected aus.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
protected void OnSelection()
Visual Basic
Protected Sub OnSelection
F#
member OnSelection : unit -> unit

See Also

Document Class
DynamicNode.WinApp Namespace


Save Method

[image] [image]

DynamicNodes API
Document..::..Save Method
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Save()()()() | Speichert den Graphen dieses Dokuments. Falls der Graph noch nicht gespeichert wurde wird ein Datei-Speichern-Dialog angezeigt.
Public method | Save(String, Boolean) | Speichert den Graphen in einer Datei.

See Also

Document Class
Document Members
DynamicNode.WinApp Namespace


Save Method

[image]

DynamicNodes API
Document..::..Save Method
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Speichert den Graphen dieses Dokuments. Falls der Graph noch nicht gespeichert wurde wird ein Datei-Speichern-Dialog angezeigt.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void Save()
Visual Basic
Public Sub Save
F#
member Save : unit -> unit

See Also

Document Class
Save Overload
DynamicNode.WinApp Namespace


Save Method (String, Boolean)

[image]

DynamicNodes API
Document..::..Save Method (String, Boolean)
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Speichert den Graphen in einer Datei.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void Save(
    string file,
    bool updateDocFileName
)
Visual Basic
Public Sub Save ( _
    file As String, _
    updateDocFileName As Boolean _
)
F#
member Save :
        file:string *
        updateDocFileName:bool -> unit

Parameters

file
Type: System..::..String
Der Dateiname.
updateDocFileName
Type: System..::..Boolean
Wenn true, wird FileName aktualisiert.

See Also

Document Class
Save Overload
DynamicNode.WinApp Namespace


SaveAs Method

[image]

DynamicNodes API
Document..::..SaveAs Method
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeigt einen Datei-Speichern-Dialog für das Speichern des Graphen an und speichert den Graphen, falls der Benutzer einen Speicherort bestimmt hat.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool SaveAs(
    ProjectKind kind
)
Visual Basic
Public Function SaveAs ( _
    kind As ProjectKind _
) As Boolean
F#
member SaveAs :
        kind:ProjectKind -> bool

Parameters

kind
Type: DynamicNode.WinApp..::..ProjectKind

[Missing <param name="kind"/> documentation for "M:DynamicNode.WinApp.Document.SaveAs(DynamicNode.WinApp.ProjectKind)"]

Return Value

[Missing <returns> documentation for "M:DynamicNode.WinApp.Document.SaveAs(DynamicNode.WinApp.ProjectKind)"]

See Also

Document Class
DynamicNode.WinApp Namespace


Select Method

[image]

DynamicNodes API
Document..::..Select Method
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Wählt dieses Dokument aus und bringt es in den Vordergrund.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
F#
member Select : unit -> unit

See Also

Document Class
DynamicNode.WinApp Namespace


ShowView Method

[image]

DynamicNodes API
Document..::..ShowView Method
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeigt die Ansicht des Dokuments an.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void ShowView(
    IGuiHost host
)
Visual Basic
Public Sub ShowView ( _
    host As IGuiHost _
)
F#
member ShowView :
        host:IGuiHost -> unit

Parameters

host
Type: DynamicNode.WinApp..::..IGuiHost
Der Host der Benutzeroberfläche.

See Also

Document Class
DynamicNode.WinApp Namespace


UseAsTemplate Method

[image]

DynamicNodes API
Document..::..UseAsTemplate Method
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Trennt das Dokument von der Projektdatei und wandelt das Dokument in eine nicht gespeicherte Vorlage um.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void UseAsTemplate()
Visual Basic
Public Sub UseAsTemplate
F#
member UseAsTemplate : unit -> unit

See Also

Document Class
DynamicNode.WinApp Namespace


Document Properties

[image] [image]

DynamicNodes API
Document Properties
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Document type exposes the following members.

Properties

 | Name | Description
Public property | AutoRepaint | Liest oder schreibt einen Wert, der angibt ob die Arbeitsfläche bei Änderungen des Graphen automatisch neu gezeichnet werden soll. (Inherited from GraphDocument.)
Public property | Caption | Gibt die Beschriftung Dokuments zurück.
Public property | Core | Gibt den Kern der Benutzeroberfläche zurück.
Public property | Editor | Liest oder schreibt den Eitor. (Inherited from GraphDocument.)
Public property | FileName | Gibt den Namen der Datei zurück, in welcher der Graph gespeichert ist, oder null, wenn der Graph nicht gespeichert ist.
Public property | Graph | Liest der Graph, welches dargestellt werden soll. (Inherited from GraphDocument.)
Public property | IsConnectingInProgress | Gibt einen Wert zurück, der angibt, ob ein Verbindungsprozess aktiv ist. (Inherited from GraphDocument.)
Public property | IsMouseOverDocument | Gibt einen Wert zurück, der angibt ob der Cursor sich zur Zeit über dem Dokument befindet. (Inherited from GraphDocument.)
Public property | IsPinVisible | Gibt einen Wert zurück, der angibt ob die Pins der Verbindungen sichtbar sind oder nicht. (Inherited from GraphDocument.)
Public property | IsSubGraph | Gibt einen Wert zurück, der angibt ob dieses Dokument einen Sub-Graphen darstellt.
Public property | Runtime | Gibt die Laufzeitumgebung zurück in der der Graph ausgeführt wird. (Inherited from GraphDocument.)
Public property | SecondarySelectedNodes | Gibt eine Auflistung mit allen sekundär markierten Knoten zurück. (Inherited from GraphDocument.)
Public property | SecondarySelectedNodesCount | Gibt die Anzahl aller sekundär markierten Knoten einschließlich des primär markierten Knotens zurück. (Inherited from GraphDocument.)
Public property | SelectedNode | Gibt den ausgewählten Knoten zurück oder legt ihn fest. (Inherited from GraphDocument.)
Public property | SelectedPin | Liest oder schreibt den ausgewählten Pin. (Inherited from GraphDocument.)
Public property | SelectedPort | Liest oder schreibt den ausgewählten Port. (Inherited from GraphDocument.)

See Also

Document Class
DynamicNode.WinApp Namespace


Caption Property

[image]

DynamicNodes API
Document..::..Caption Property
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung Dokuments zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string Caption { get; }
Visual Basic
Public ReadOnly Property Caption As String
    Get
F#
member Caption : string

Field Value

Die Beschriftung.

See Also

Document Class
DynamicNode.WinApp Namespace


Core Property

[image]

DynamicNodes API
Document..::..Core Property
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Kern der Benutzeroberfläche zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public GUICore Core { get; }
Visual Basic
Public ReadOnly Property Core As GUICore
    Get
F#
member Core : GUICore

Field Value

Der Kern der Benutzeroberfläche.

See Also

Document Class
DynamicNode.WinApp Namespace


FileName Property

[image]

DynamicNodes API
Document..::..FileName Property
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen der Datei zurück, in welcher der Graph gespeichert ist, oder null, wenn der Graph nicht gespeichert ist.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string FileName { get; internal set; }
Visual Basic
Public Property FileName As String
    Get
    Friend Set
F#
member FileName : string with get, internal set

Field Value

Der Name der Datei, in welcher der Graph gespeichert ist oder null.

See Also

Document Class
DynamicNode.WinApp Namespace


IsSubGraph Property

[image]

DynamicNodes API
Document..::..IsSubGraph Property
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob dieses Dokument einen Sub-Graphen darstellt.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool IsSubGraph { get; internal set; }
Visual Basic
Public Property IsSubGraph As Boolean
    Get
    Friend Set
F#
member IsSubGraph : bool with get, internal set

Field Value

true wenn dieses Dokument einen Sub-Graphen darstellt, sonst false.

See Also

Document Class
DynamicNode.WinApp Namespace


Document Events

[image] [image]

DynamicNodes API
Document Events
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The Document type exposes the following members.

Events

 | Name | Description
Public event | Disposing | Wird ausgelöst, wenn das Dokument zerstört wird. (Inherited from GraphDocument.)
Public event | GraphProperties | Wird ausgelöst, wenn für einen Graphen der Eigenschaftsdialog angefordert wurde. (Inherited from GraphDocument.)
Public event | MouseClick | Wird ausgelöst, wenn ein Klick ausgeführt wurde. (Inherited from GraphDocument.)
Public event | MouseDoubleClick | Wird ausgelöst, wenn die Doppel-Klick ausgeführt wurde. (Inherited from GraphDocument.)
Public event | MouseDown | Wird ausgelöst, wenn eine Maustaste gedrückt wird. (Inherited from GraphDocument.)
Public event | MouseEnter | Wird ausgelöst, wenn der Cursor den Editor betritt. (Inherited from GraphDocument.)
Public event | MouseHover | Wird ausgelöst, wenn der Cursor über der Arbeitsfläche verweilt. (Inherited from GraphDocument.)
Public event | MouseLeave | Wird ausgelöst, wenn der Cursor den Editor verlässt. (Inherited from GraphDocument.)
Public event | MouseMove | Wird ausgelöst, wenn der Cursor bewegt wird. (Inherited from GraphDocument.)
Public event | MouseNodeEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Knotens hinien bewegt wird. (Inherited from GraphDocument.)
Public event | MouseNodeLeave | Wird ausgelöst, wenn der Cursor den Bereich eines Knotens verlässt. (Inherited from GraphDocument.)
Public event | MousePortEnter | Wird ausgelöst, wenn der Cursor in den Bereich eines Ports hineinbewegt wird. (Inherited from GraphDocument.)
Public event | MousePortLeave | Wird ausgelöst, wenn der Cursor aus dem Bereich eines Ports herrausbewegt wird. (Inherited from GraphDocument.)
Public event | MouseUp | Wird ausgelöst, wenn eine Maustaste losgelassen wird. (Inherited from GraphDocument.)
Public event | MouseWheel | Wird ausgelöst, wenn das Mausrad gedreht wird. (Inherited from GraphDocument.)
Public event | NodeHelp | Wird ausgelöst, wenn für einen Knoten Hilfe angefordert wird. (Inherited from GraphDocument.)
Public event | NodeProperties | Wird ausgelöst, wenn für einen Knoten der Eigenschaftsdialog angefordert wurde. (Inherited from GraphDocument.)
Public event | NodeSelect | Wird ausgelöst, wenn ein Knoten ausgewählt wird. (Inherited from GraphDocument.)
Public event | PortProperties | Wird ausgelöst, wenn für einen Port der Eigenschaftsdialog angefordert wurde. (Inherited from GraphDocument.)
Public event | Selected | Tritt auf wenn dieses Dokument ausgewählt bzw. in den Vordergrund geholt wird.
Public event | ShowSubGraph | Wird ausgelöst, wenn ein Sub-Graph-Knoten den gekapselten Graphen anzeigen möchte. (Inherited from GraphDocument.)

See Also

Document Class
DynamicNode.WinApp Namespace


Selected Event

[image]

DynamicNodes API
Document..::..Selected Event
Document Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn dieses Dokument ausgewählt bzw. in den Vordergrund geholt wird.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public event EventHandler Selected
Visual Basic
Public Event Selected As EventHandler
F#
member Selected : IEvent<EventHandler,
    EventArgs>

See Also

Document Class
DynamicNode.WinApp Namespace


GUICore Class

[image]

DynamicNodes API
GUICore Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Kern der Benutzeroberfläche.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public class GUICore : IDisposable, IAssetContainer
Visual Basic
Public Class GUICore _
    Implements IDisposable, IAssetContainer
F#
type GUICore =
    class
        interface IDisposable
        interface IAssetContainer
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.WinApp..::..GUICore

See Also

GUICore Members
DynamicNode.WinApp Namespace


GUICore Members

[image] [image]

DynamicNodes API
GUICore Members
GUICore Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GUICore type exposes the following members.

Constructors

 | Name | Description
Public method | GUICore | Initialisiert eine GUICore-Instanz.

Methods

 | Name | Description
Public method | Close(Document) | Versucht einen Grphane zu schließen. Der Benutzer erhält die Möglichkeit den Vorgang abzubrechen, falls der Graph geändert wurde.
Public method | Close(Document, Boolean) | Schließt einen Graph.
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.
Public method | GetAsset<(Of <<'(T>)>>) | Gibt ein Asset vom Type des Typen-Parameters T zurück.
Public method | GetDocumentByGraph | Gibt ein Graph-Dokument anhand eines Graphen zurück.
Public method | GetView | Gibt eine Ansicht bei ihrer ID zurück.
Public method | GetViewDescriptor | Gibt eine Ansichtsbeschreibung anhand der View-ID zurück.
Public method | HasAsset<(Of <<'(T>)>>) | Prüft ob das Asset vom Type T existiert.
Public method | NewDocument | Erzeugt einen neuen Graph.
Public method | Open()()()() | Öffnet einen Graphen oder einen Sub-Graphen.
Public method | Open(String) | Öffnet einen Graphen mittels eines Dateinamens.
Public method | RegisterAsset<(Of <<'(T>)>>) | Registriert ein Asset.
Public method | RestoreViewStates | Stellt die Aufteilung der Benutzeroberfläche und die Positionen der Ansichten aus der dafür vorgesehenen Konfigurationsdatei wieder her.
Public method | ShowPropertyDialog | Zeigt den Eigenschafts-Dialog für ein übergebenes Objekt an.
Public method | StoreViewStates | Speichert die Aufteilung der Benutzeroberfläche und die Positionen der Ansichten in der dafür vorgesehenen Konfigurationsdatei.

Properties

 | Name | Description
Public property | Assets | Gibt ein Verzeichnis mit allen Assets der Benutzeroberfläche zurück.
Public property | CommandLoader | Gibt den Loader für Erweiterungen der Benutzeroberfläche zurück.
Public property | CurrentDoc | Gibt das aktuelle Graph-Dokument zurück, oder legt es fest.
Public property | Documents | Gibt ein Array mit allen geöffneten Projekten zurück.
Public property | GuiHost | Gibt den Host der Benutzeroberfläche zurück. Das kann ein Fenster oder ein Steuerelement sein.
Public property | PaintSettings | Gibt die Einstellungen für die grafische Darstellung der Graphen im Editor zurück.
Public property | PropertyStorage | Gibt den Konfigurationsspeicher der Benutzeroberfläche zurück.
Public property | Runtime | Gibt die Laufzeitumgebung zurück.
Public property | SystemStyleFiles | Gibt ein Array mit den Dateinamen der Systemstyles zurück.
Public property | TemplateLibrary | Gibt die Vorlagenbibliothek zurück.
Public property | Tools | Gibt ein Array mit allen Werkzeugen zurück.
Public property | ViewDescriptors | Gibt eine Aufzählung mit allen Ansichtsbeschreibungen zurück.

Events

 | Name | Description
Public event | CurrentDocument | Tritt auf wenn ein Graph-Dokument ausgewählt wird.

See Also

GUICore Class
DynamicNode.WinApp Namespace


GUICore Constructor

[image]

DynamicNodes API
GUICore Constructor
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine GUICore-Instanz.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public GUICore(
    IRuntime runtime,
    IPropertyStorage ps,
    IEnumerable<KeyValuePair<Type, Object>> initialAssets
)
Visual Basic
Public Sub New ( _
    runtime As IRuntime, _
    ps As IPropertyStorage, _
    initialAssets As IEnumerable(Of KeyValuePair(Of Type, Object)) _
)
F#
new :
        runtime:IRuntime *
        ps:IPropertyStorage *
        initialAssets:IEnumerable<KeyValuePair<Type, Object>> -> GUICore

Parameters

runtime
Type: DynamicNode.Core..::..IRuntime
Die Laufzeitumgebung.
ps
Type: DynamicNode.Persistence..::..IPropertyStorage
Ein Eigenschaftsspeicher.
initialAssets
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Type, Object >)>)>>)>)>
Optionale Komponenten.

See Also

GUICore Class
DynamicNode.WinApp Namespace


GUICore Methods

[image] [image]

DynamicNodes API
GUICore Methods
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GUICore type exposes the following members.

Methods

 | Name | Description
Public method | Close(Document) | Versucht einen Grphane zu schließen. Der Benutzer erhält die Möglichkeit den Vorgang abzubrechen, falls der Graph geändert wurde.
Public method | Close(Document, Boolean) | Schließt einen Graph.
Public method | Dispose | Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.
Public method | GetAsset<(Of <<'(T>)>>) | Gibt ein Asset vom Type des Typen-Parameters T zurück.
Public method | GetDocumentByGraph | Gibt ein Graph-Dokument anhand eines Graphen zurück.
Public method | GetView | Gibt eine Ansicht bei ihrer ID zurück.
Public method | GetViewDescriptor | Gibt eine Ansichtsbeschreibung anhand der View-ID zurück.
Public method | HasAsset<(Of <<'(T>)>>) | Prüft ob das Asset vom Type T existiert.
Public method | NewDocument | Erzeugt einen neuen Graph.
Public method | Open()()()() | Öffnet einen Graphen oder einen Sub-Graphen.
Public method | Open(String) | Öffnet einen Graphen mittels eines Dateinamens.
Public method | RegisterAsset<(Of <<'(T>)>>) | Registriert ein Asset.
Public method | RestoreViewStates | Stellt die Aufteilung der Benutzeroberfläche und die Positionen der Ansichten aus der dafür vorgesehenen Konfigurationsdatei wieder her.
Public method | ShowPropertyDialog | Zeigt den Eigenschafts-Dialog für ein übergebenes Objekt an.
Public method | StoreViewStates | Speichert die Aufteilung der Benutzeroberfläche und die Positionen der Ansichten in der dafür vorgesehenen Konfigurationsdatei.

See Also

GUICore Class
DynamicNode.WinApp Namespace


Close Method

[image] [image]

DynamicNodes API
GUICore..::..Close Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Close(Document) | Versucht einen Grphane zu schließen. Der Benutzer erhält die Möglichkeit den Vorgang abzubrechen, falls der Graph geändert wurde.
Public method | Close(Document, Boolean) | Schließt einen Graph.

See Also

GUICore Class
GUICore Members
DynamicNode.WinApp Namespace


Close Method (Document)

[image]

DynamicNodes API
GUICore..::..Close Method (Document)
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Versucht einen Grphane zu schließen. Der Benutzer erhält die Möglichkeit den Vorgang abzubrechen, falls der Graph geändert wurde.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool Close(
    Document doc
)
Visual Basic
Public Function Close ( _
    doc As Document _
) As Boolean
F#
member Close :
        doc:Document -> bool

Parameters

doc
Type: DynamicNode.WinApp..::..Document
Das Graph-Dokument.

Return Value

true, wenn das Graphen-Dokument geschlossen wurde.

See Also

GUICore Class
Close Overload
DynamicNode.WinApp Namespace


Close Method (Document, Boolean)

[image]

DynamicNodes API
GUICore..::..Close Method (Document, Boolean)
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Schließt einen Graph.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool Close(
    Document doc,
    bool interactive
)
Visual Basic
Public Function Close ( _
    doc As Document, _
    interactive As Boolean _
) As Boolean
F#
member Close :
        doc:Document *
        interactive:bool -> bool

Parameters

doc
Type: DynamicNode.WinApp..::..Document
Das Graph-Dokument.
interactive
Type: System..::..Boolean
true, wenn der Benutzer gefragt werden soll, ob geänderte Graphen gespeichert werden sollen. false wenn alle Änderungen verworfen werden sollen.

Return Value

true, wenn das Graphen-Dokument geschlossen wurde.

Remarks

Wird für interactivefalse übergeben, wird immer true zurückgegeben.

See Also

GUICore Class
Close Overload
DynamicNode.WinApp Namespace


Dispose Method

[image]

DynamicNodes API
GUICore..::..Dispose Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Führt anwendungsspezifische Aufgaben durch, die mit der Freigabe, der Zurückgabe oder dem Zurücksetzen von nicht verwalteten Ressourcen zusammenhängen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
F#
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposable..::..Dispose()()()()

See Also

GUICore Class
DynamicNode.WinApp Namespace


GetAsset(T) Method

[image]

DynamicNodes API
GUICore..::..GetAsset<(Of <(<'T>)>)> Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Asset vom Type des Typen-Parameters T zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public T GetAsset<T>()
Visual Basic
Public Function GetAsset(Of T) As T
F#
abstract GetAsset : unit -> 'T
override GetAsset : unit -> 'T

Type Parameters

T
Der Type des gesuchten Assets.

Return Value

Das Asset.

Exceptions

Exception | Condition
System.Collections.Generic..::..KeyNotFoundException | Wird geworfen, wenn das gesuchte Asset nicht registriert ist.

See Also

GUICore Class
DynamicNode.WinApp Namespace


GetDocumentByGraph Method

[image]

DynamicNodes API
GUICore..::..GetDocumentByGraph Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Graph-Dokument anhand eines Graphen zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public Document GetDocumentByGraph(
    IGraph graph
)
Visual Basic
Public Function GetDocumentByGraph ( _
    graph As IGraph _
) As Document
F#
member GetDocumentByGraph :
        graph:IGraph -> Document

Parameters

graph
Type: DynamicNode.Core..::..IGraph
Ein Graph.

Return Value

Eine Document-Instanz.

See Also

GUICore Class
DynamicNode.WinApp Namespace


GetView Method

[image]

DynamicNodes API
GUICore..::..GetView Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Ansicht bei ihrer ID zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public AbstractView GetView(
    string id
)
Visual Basic
Public Function GetView ( _
    id As String _
) As AbstractView
F#
member GetView :
        id:string -> AbstractView

Parameters

id
Type: System..::..String
Die View-ID.

Return Value

[Missing <returns> documentation for "M:DynamicNode.WinApp.GUICore.GetView(System.String)"]

See Also

GUICore Class
DynamicNode.WinApp Namespace


GetViewDescriptor Method

[image]

DynamicNodes API
GUICore..::..GetViewDescriptor Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Ansichtsbeschreibung anhand der View-ID zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public ViewDescriptor GetViewDescriptor(
    string id
)
Visual Basic
Public Function GetViewDescriptor ( _
    id As String _
) As ViewDescriptor
F#
member GetViewDescriptor :
        id:string -> ViewDescriptor

Parameters

id
Type: System..::..String
Die View-ID.

Return Value

[Missing <returns> documentation for "M:DynamicNode.WinApp.GUICore.GetViewDescriptor(System.String)"]

See Also

GUICore Class
DynamicNode.WinApp Namespace


HasAsset(T) Method

[image]

DynamicNodes API
GUICore..::..HasAsset<(Of <(<'T>)>)> Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob das Asset vom Type T existiert.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool HasAsset<T>()
Visual Basic
Public Function HasAsset(Of T) As Boolean
F#
abstract HasAsset : unit -> bool
override HasAsset : unit -> bool

Type Parameters

T
Der Type des gesuchten Assets.

Return Value

true, wenn das Asset von dem angegebenen Type existiert, sonst false.

Implements

IAssetContainer..::..HasAsset<(Of <<'(T>)>>)()()()()

See Also

GUICore Class
DynamicNode.WinApp Namespace


NewDocument Method

[image]

DynamicNodes API
GUICore..::..NewDocument Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Erzeugt einen neuen Graph.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public Document NewDocument()
Visual Basic
Public Function NewDocument As Document
F#
member NewDocument : unit -> Document

Return Value

[Missing <returns> documentation for "M:DynamicNode.WinApp.GUICore.NewDocument"]

See Also

GUICore Class
DynamicNode.WinApp Namespace


Open Method

[image] [image]

DynamicNodes API
GUICore..::..Open Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Open()()()() | Öffnet einen Graphen oder einen Sub-Graphen.
Public method | Open(String) | Öffnet einen Graphen mittels eines Dateinamens.

See Also

GUICore Class
GUICore Members
DynamicNode.WinApp Namespace


Open Method

[image]

DynamicNodes API
GUICore..::..Open Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Öffnet einen Graphen oder einen Sub-Graphen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public Document Open()
Visual Basic
Public Function Open As Document
F#
member Open : unit -> Document

Return Value

[Missing <returns> documentation for "M:DynamicNode.WinApp.GUICore.Open"]

See Also

GUICore Class
Open Overload
DynamicNode.WinApp Namespace


Open Method (String)

[image]

DynamicNodes API
GUICore..::..Open Method (String)
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Öffnet einen Graphen mittels eines Dateinamens.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public Document Open(
    string file
)
Visual Basic
Public Function Open ( _
    file As String _
) As Document
F#
member Open :
        file:string -> Document

Parameters

file
Type: System..::..String
Der absolute Dateipfad.

Return Value

[Missing <returns> documentation for "M:DynamicNode.WinApp.GUICore.Open(System.String)"]

See Also

GUICore Class
Open Overload
DynamicNode.WinApp Namespace


RegisterAsset(T) Method

[image]

DynamicNodes API
GUICore..::..RegisterAsset<(Of <(<'T>)>)> Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert ein Asset.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void RegisterAsset<T>(
    T asset
)
Visual Basic
Public Sub RegisterAsset(Of T) ( _
    asset As T _
)
F#
abstract RegisterAsset :
        asset:'T -> unit
override RegisterAsset :
        asset:'T -> unit

Parameters

asset
Type: T
Das Asset.

Type Parameters

T
Der Type des Assets.

Implements

IAssetContainer..::..RegisterAsset<(Of <<'(T>)>>)(T)

See Also

GUICore Class
DynamicNode.WinApp Namespace


RestoreViewStates Method

[image]

DynamicNodes API
GUICore..::..RestoreViewStates Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt die Aufteilung der Benutzeroberfläche und die Positionen der Ansichten aus der dafür vorgesehenen Konfigurationsdatei wieder her.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void RestoreViewStates()
Visual Basic
Public Sub RestoreViewStates
F#
member RestoreViewStates : unit -> unit

See Also

GUICore Class
DynamicNode.WinApp Namespace


ShowPropertyDialog Method

[image]

DynamicNodes API
GUICore..::..ShowPropertyDialog Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeigt den Eigenschafts-Dialog für ein übergebenes Objekt an.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void ShowPropertyDialog(
    Object obj
)
Visual Basic
Public Sub ShowPropertyDialog ( _
    obj As Object _
)
F#
member ShowPropertyDialog :
        obj:Object -> unit

Parameters

obj
Type: System..::..Object
Das Objekt, dessen Eigenschaften angezeigt werden sollen.

See Also

GUICore Class
DynamicNode.WinApp Namespace


StoreViewStates Method

[image]

DynamicNodes API
GUICore..::..StoreViewStates Method
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Speichert die Aufteilung der Benutzeroberfläche und die Positionen der Ansichten in der dafür vorgesehenen Konfigurationsdatei.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void StoreViewStates()
Visual Basic
Public Sub StoreViewStates
F#
member StoreViewStates : unit -> unit

See Also

GUICore Class
DynamicNode.WinApp Namespace


GUICore Properties

[image] [image]

DynamicNodes API
GUICore Properties
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GUICore type exposes the following members.

Properties

 | Name | Description
Public property | Assets | Gibt ein Verzeichnis mit allen Assets der Benutzeroberfläche zurück.
Public property | CommandLoader | Gibt den Loader für Erweiterungen der Benutzeroberfläche zurück.
Public property | CurrentDoc | Gibt das aktuelle Graph-Dokument zurück, oder legt es fest.
Public property | Documents | Gibt ein Array mit allen geöffneten Projekten zurück.
Public property | GuiHost | Gibt den Host der Benutzeroberfläche zurück. Das kann ein Fenster oder ein Steuerelement sein.
Public property | PaintSettings | Gibt die Einstellungen für die grafische Darstellung der Graphen im Editor zurück.
Public property | PropertyStorage | Gibt den Konfigurationsspeicher der Benutzeroberfläche zurück.
Public property | Runtime | Gibt die Laufzeitumgebung zurück.
Public property | SystemStyleFiles | Gibt ein Array mit den Dateinamen der Systemstyles zurück.
Public property | TemplateLibrary | Gibt die Vorlagenbibliothek zurück.
Public property | Tools | Gibt ein Array mit allen Werkzeugen zurück.
Public property | ViewDescriptors | Gibt eine Aufzählung mit allen Ansichtsbeschreibungen zurück.

See Also

GUICore Class
DynamicNode.WinApp Namespace


Assets Property

[image]

DynamicNodes API
GUICore..::..Assets Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Verzeichnis mit allen Assets der Benutzeroberfläche zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IDictionary<Type, Object> Assets { get; }
Visual Basic
Public ReadOnly Property Assets As IDictionary(Of Type, Object)
    Get
F#
abstract Assets : IDictionary<Type, Object>
override Assets : IDictionary<Type, Object>

Field Value

Das Verzeichnis der Benutzeroberflächen-Assets.

Implements

IAssetContainer..::..Assets

See Also

GUICore Class
DynamicNode.WinApp Namespace


CommandLoader Property

[image]

DynamicNodes API
GUICore..::..CommandLoader Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Loader für Erweiterungen der Benutzeroberfläche zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public CommandLoader<GUICore> CommandLoader { get; }
Visual Basic
Public ReadOnly Property CommandLoader As CommandLoader(Of GUICore)
    Get
F#
member CommandLoader : CommandLoader<GUICore>

Field Value

Der Loader für die Erweiterungen der Benutzeroberfläche.

See Also

GUICore Class
DynamicNode.WinApp Namespace


CurrentDoc Property

[image]

DynamicNodes API
GUICore..::..CurrentDoc Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das aktuelle Graph-Dokument zurück, oder legt es fest.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public Document CurrentDoc { get; set; }
Visual Basic
Public Property CurrentDoc As Document
    Get
    Set
F#
member CurrentDoc : Document with get, set

Field Value

Das aktuelle Graph-Dokument.

See Also

GUICore Class
DynamicNode.WinApp Namespace


Documents Property

[image]

DynamicNodes API
GUICore..::..Documents Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen geöffneten Projekten zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public Document[] Documents { get; }
Visual Basic
Public ReadOnly Property Documents As Document()
    Get
F#
member Documents : Document[]

Field Value

Alle geöffneten Projekte

See Also

GUICore Class
DynamicNode.WinApp Namespace


GuiHost Property

[image]

DynamicNodes API
GUICore..::..GuiHost Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Host der Benutzeroberfläche zurück. Das kann ein Fenster oder ein Steuerelement sein.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IGuiHost GuiHost { get; internal set; }
Visual Basic
Public Property GuiHost As IGuiHost
    Get
    Friend Set
F#
member GuiHost : IGuiHost with get, internal set

Field Value

Der Host der Benutzeroberfläche.

See Also

GUICore Class
DynamicNode.WinApp Namespace


PaintSettings Property

[image]

DynamicNodes API
GUICore..::..PaintSettings Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Einstellungen für die grafische Darstellung der Graphen im Editor zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public PaintSettings PaintSettings { get; }
Visual Basic
Public ReadOnly Property PaintSettings As PaintSettings
    Get
F#
member PaintSettings : PaintSettings

Field Value

Die Einstellungen für die Darstellung der Graphen.

See Also

GUICore Class
DynamicNode.WinApp Namespace


PropertyStorage Property

[image]

DynamicNodes API
GUICore..::..PropertyStorage Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Konfigurationsspeicher der Benutzeroberfläche zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IPropertyStorage PropertyStorage { get; }
Visual Basic
Public ReadOnly Property PropertyStorage As IPropertyStorage
    Get
F#
member PropertyStorage : IPropertyStorage

Field Value

Der Konfigurationsspeicher der Benutzeroberfläche.

See Also

GUICore Class
DynamicNode.WinApp Namespace


Runtime Property

[image]

DynamicNodes API
GUICore..::..Runtime Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Laufzeitumgebung zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IRuntime Runtime { get; }
Visual Basic
Public ReadOnly Property Runtime As IRuntime
    Get
F#
member Runtime : IRuntime

Field Value

Die Laufzeitumgebung.

See Also

GUICore Class
DynamicNode.WinApp Namespace


SystemStyleFiles Property

[image]

DynamicNodes API
GUICore..::..SystemStyleFiles Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit den Dateinamen der Systemstyles zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string[] SystemStyleFiles { get; }
Visual Basic
Public ReadOnly Property SystemStyleFiles As String()
    Get
F#
member SystemStyleFiles : string[]

See Also

GUICore Class
DynamicNode.WinApp Namespace


TemplateLibrary Property

[image]

DynamicNodes API
GUICore..::..TemplateLibrary Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Vorlagenbibliothek zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public TemplateLibrary TemplateLibrary { get; }
Visual Basic
Public ReadOnly Property TemplateLibrary As TemplateLibrary
    Get
F#
member TemplateLibrary : TemplateLibrary

Field Value

Die Vorlagenbibliothek.

See Also

GUICore Class
DynamicNode.WinApp Namespace


Tools Property

[image]

DynamicNodes API
GUICore..::..Tools Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Array mit allen Werkzeugen zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IEditorTool[] Tools { get; }
Visual Basic
Public ReadOnly Property Tools As IEditorTool()
    Get
F#
member Tools : IEditorTool[]

Field Value

Alle Werkzeuge.

See Also

GUICore Class
DynamicNode.WinApp Namespace


ViewDescriptors Property

[image]

DynamicNodes API
GUICore..::..ViewDescriptors Property
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen Ansichtsbeschreibungen zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IEnumerable<ViewDescriptor> ViewDescriptors { get; }
Visual Basic
Public ReadOnly Property ViewDescriptors As IEnumerable(Of ViewDescriptor)
    Get
F#
member ViewDescriptors : IEnumerable<ViewDescriptor>

Field Value

Alle Ansichtsbeschreibungen.

See Also

GUICore Class
DynamicNode.WinApp Namespace


GUICore Events

[image] [image]

DynamicNodes API
GUICore Events
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GUICore type exposes the following members.

Events

 | Name | Description
Public event | CurrentDocument | Tritt auf wenn ein Graph-Dokument ausgewählt wird.

See Also

GUICore Class
DynamicNode.WinApp Namespace


CurrentDocument Event

[image]

DynamicNodes API
GUICore..::..CurrentDocument Event
GUICore Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf wenn ein Graph-Dokument ausgewählt wird.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public event EventHandler CurrentDocument
Visual Basic
Public Event CurrentDocument As EventHandler
F#
member CurrentDocument : IEvent<EventHandler,
    EventArgs>

See Also

GUICore Class
DynamicNode.WinApp Namespace


HelpForm Class

[image]

DynamicNodes API
HelpForm Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Hilfe-Fenster von DynamicNodes.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public class HelpForm : Form
Visual Basic
Public Class HelpForm _
    Inherits Form
F#
type HelpForm =
    class
        inherit Form
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
DynamicNode.WinApp..::..HelpForm

See Also

HelpForm Members
DynamicNode.WinApp Namespace


HelpForm Members

[image] [image]

DynamicNodes API
HelpForm Members
HelpForm Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The HelpForm type exposes the following members.

Constructors

 | Name | Description
Public method | HelpForm | Initialisiert eine neue HelpForm-Instanz.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

HelpForm Class
DynamicNode.WinApp Namespace


HelpForm Constructor

[image]

DynamicNodes API
HelpForm Constructor
HelpForm Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue HelpForm-Instanz.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public HelpForm(
    IPropertyStorage ps
)
Visual Basic
Public Sub New ( _
    ps As IPropertyStorage _
)
F#
new :
        ps:IPropertyStorage -> HelpForm

Parameters

ps
Type: DynamicNode.Persistence..::..IPropertyStorage
Der Eigenschaftsspeicher der Benutzeroberfläche.

See Also

HelpForm Class
DynamicNode.WinApp Namespace


HelpForm Methods

[image] [image]

DynamicNodes API
HelpForm Methods
HelpForm Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The HelpForm type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

HelpForm Class
DynamicNode.WinApp Namespace


Dispose Method

[image]

DynamicNodes API
HelpForm..::..Dispose Method
HelpForm Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Clean up any resources being used.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

HelpForm Class
DynamicNode.WinApp Namespace


IAssetContainer Interface

[image]

DynamicNodes API
IAssetContainer Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Schnittstelle eines Asset-Containers. Ein Asset-Container ist ein Objekt, welches als Sammelstelle für optionale Komponenten dient.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public interface IAssetContainer
Visual Basic
Public Interface IAssetContainer
F#
type IAssetContainer =  interface end

See Also

IAssetContainer Members
DynamicNode.WinApp Namespace


IAssetContainer Members

[image] [image]

DynamicNodes API
IAssetContainer Members
IAssetContainer Interface Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IAssetContainer type exposes the following members.

Methods

 | Name | Description
Public method | GetAsset<(Of <<'(T>)>>) | Gibt ein Asset vom Type des Typen-Parameters T zurück.
Public method | HasAsset<(Of <<'(T>)>>) | Prüft ob das Asset vom Type T existiert.
Public method | RegisterAsset<(Of <<'(T>)>>) | Registriert ein Asset.

Properties

 | Name | Description
Public property | Assets | Gibt ein Verzeichnis mit allen Assets der Benutzeroberfläche zurück.

See Also

IAssetContainer Interface
DynamicNode.WinApp Namespace


IAssetContainer Methods

[image] [image]

DynamicNodes API
IAssetContainer Methods
IAssetContainer Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IAssetContainer type exposes the following members.

Methods

 | Name | Description
Public method | GetAsset<(Of <<'(T>)>>) | Gibt ein Asset vom Type des Typen-Parameters T zurück.
Public method | HasAsset<(Of <<'(T>)>>) | Prüft ob das Asset vom Type T existiert.
Public method | RegisterAsset<(Of <<'(T>)>>) | Registriert ein Asset.

See Also

IAssetContainer Interface
DynamicNode.WinApp Namespace


GetAsset(T) Method

[image]

DynamicNodes API
IAssetContainer..::..GetAsset<(Of <(<'T>)>)> Method
IAssetContainer Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Asset vom Type des Typen-Parameters T zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
T GetAsset<T>()
Visual Basic
Function GetAsset(Of T) As T
F#
abstract GetAsset : unit -> 'T

Type Parameters

T
Der Type des gesuchten Assets.

Return Value

Das Asset oder null, wenn das Asset nicht registriert ist.

See Also

IAssetContainer Interface
DynamicNode.WinApp Namespace


HasAsset(T) Method

[image]

DynamicNodes API
IAssetContainer..::..HasAsset<(Of <(<'T>)>)> Method
IAssetContainer Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob das Asset vom Type T existiert.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
bool HasAsset<T>()
Visual Basic
Function HasAsset(Of T) As Boolean
F#
abstract HasAsset : unit -> bool

Type Parameters

T
Der Type des gesuchten Assets.

Return Value

true, wenn das Asset von dem angegebenen Type existiert, sonst false.

See Also

IAssetContainer Interface
DynamicNode.WinApp Namespace


RegisterAsset(T) Method

[image]

DynamicNodes API
IAssetContainer..::..RegisterAsset<(Of <(<'T>)>)> Method
IAssetContainer Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Registriert ein Asset.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
void RegisterAsset<T>(
    T asset
)
Visual Basic
Sub RegisterAsset(Of T) ( _
    asset As T _
)
F#
abstract RegisterAsset :
        asset:'T -> unit

Parameters

asset
Type: T
Das Asset.

Type Parameters

T
Der Type des Assets.

See Also

IAssetContainer Interface
DynamicNode.WinApp Namespace


IAssetContainer Properties

[image] [image]

DynamicNodes API
IAssetContainer Properties
IAssetContainer Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IAssetContainer type exposes the following members.

Properties

 | Name | Description
Public property | Assets | Gibt ein Verzeichnis mit allen Assets der Benutzeroberfläche zurück.

See Also

IAssetContainer Interface
DynamicNode.WinApp Namespace


Assets Property

[image]

DynamicNodes API
IAssetContainer..::..Assets Property
IAssetContainer Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Verzeichnis mit allen Assets der Benutzeroberfläche zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
IDictionary<Type, Object> Assets { get; }
Visual Basic
ReadOnly Property Assets As IDictionary(Of Type, Object)
    Get
F#
abstract Assets : IDictionary<Type, Object>

Field Value

Das Verzeichnis der Benutzeroberflächen-Assets.

See Also

IAssetContainer Interface
DynamicNode.WinApp Namespace


IGuiHost Interface

[image]

DynamicNodes API
IGuiHost Interface
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Schnittstelle für Objekte, welche die GUI der Entwicklungsmgebung bereitstellen. Das kann ein Fenster oder ein Steuerelement sein.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public interface IGuiHost : IWin32Window
Visual Basic
Public Interface IGuiHost _
    Inherits IWin32Window
F#
type IGuiHost =
    interface
        interface IWin32Window
    end

See Also

IGuiHost Members
DynamicNode.WinApp Namespace


IGuiHost Members

[image] [image]

DynamicNodes API
IGuiHost Members
IGuiHost Interface Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGuiHost type exposes the following members.

Properties

 | Name | Description
Public property | DockPanel | Gibt das DockPanel zurück, welches die Anordnung der Ansichten organisiert.

See Also

IGuiHost Interface
DynamicNode.WinApp Namespace


IGuiHost Properties

[image] [image]

DynamicNodes API
IGuiHost Properties
IGuiHost Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The IGuiHost type exposes the following members.

Properties

 | Name | Description
Public property | DockPanel | Gibt das DockPanel zurück, welches die Anordnung der Ansichten organisiert.

See Also

IGuiHost Interface
DynamicNode.WinApp Namespace


DockPanel Property

[image]

DynamicNodes API
IGuiHost..::..DockPanel Property
IGuiHost Interface See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt das DockPanel zurück, welches die Anordnung der Ansichten organisiert.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
DockPanel DockPanel { get; }
Visual Basic
ReadOnly Property DockPanel As DockPanel
    Get
F#
abstract DockPanel : DockPanel

Field Value

Das DockPanel.

See Also

IGuiHost Interface
DynamicNode.WinApp Namespace


InfoDialog Class

[image]

DynamicNodes API
InfoDialog Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Das Info-Fenster der DynamicNodes-Umgebung. Es zeigt Versionsstände und Lizenzinformationen an.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public class InfoDialog : Form
Visual Basic
Public Class InfoDialog _
    Inherits Form
F#
type InfoDialog =
    class
        inherit Form
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
DynamicNode.WinApp..::..InfoDialog

See Also

InfoDialog Members
DynamicNode.WinApp Namespace


InfoDialog Members

[image] [image]

DynamicNodes API
InfoDialog Members
InfoDialog Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InfoDialog type exposes the following members.

Constructors

 | Name | Description
Public method | InfoDialog | Initialisiert eine neue Instanz der InfoDialog-Klasse.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

InfoDialog Class
DynamicNode.WinApp Namespace


InfoDialog Constructor

[image]

DynamicNodes API
InfoDialog Constructor
InfoDialog Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der InfoDialog-Klasse.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public InfoDialog()
Visual Basic
Public Sub New
F#
new : unit -> InfoDialog

See Also

InfoDialog Class
DynamicNode.WinApp Namespace


InfoDialog Methods

[image] [image]

DynamicNodes API
InfoDialog Methods
InfoDialog Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The InfoDialog type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

InfoDialog Class
DynamicNode.WinApp Namespace


Dispose Method

[image]

DynamicNodes API
InfoDialog..::..Dispose Method
InfoDialog Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Clean up any resources being used.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

InfoDialog Class
DynamicNode.WinApp Namespace


ProjectKind Enumeration

[image]

DynamicNodes API
ProjectKind Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Eine Aufzählung mit verschiedenen Projekttypen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public enum ProjectKind
Visual Basic
Public Enumeration ProjectKind
F#
type ProjectKind

Members

Member name | Description
Project |
WorkspaceTemplate |
WorkspaceModule |
SystemTemplate |
SystemModule |

See Also

DynamicNode.WinApp Namespace


PropertyDialog Class

[image]

DynamicNodes API
PropertyDialog Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Eigenschaftsfenster für beliebige Objekte. Dieses Dialogfenster wird typischerweise mit den Property-Wrapper-Klassen aus dem Namensraum DynamicNode.WinApp.PropertyWrapper verwendet.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public class PropertyDialog : Form
Visual Basic
Public Class PropertyDialog _
    Inherits Form
F#
type PropertyDialog =
    class
        inherit Form
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
DynamicNode.WinApp..::..PropertyDialog

See Also

PropertyDialog Members
DynamicNode.WinApp Namespace


PropertyDialog Members

[image] [image]

DynamicNodes API
PropertyDialog Members
PropertyDialog Class Constructors Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PropertyDialog type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyDialog | Initialisert eine neue Instanz der PropertyDialog-Klasse.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides Form..::..Dispose(Boolean).)
Public method | ShowFor | Zeigt das Eigenschaftsfenster für ein gegebenes Objekt an.

See Also

PropertyDialog Class
DynamicNode.WinApp Namespace


PropertyDialog Constructor

[image]

DynamicNodes API
PropertyDialog Constructor
PropertyDialog Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisert eine neue Instanz der PropertyDialog-Klasse.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public PropertyDialog()
Visual Basic
Public Sub New
F#
new : unit -> PropertyDialog

See Also

PropertyDialog Class
DynamicNode.WinApp Namespace


PropertyDialog Methods

[image] [image]

DynamicNodes API
PropertyDialog Methods
PropertyDialog Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The PropertyDialog type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Verwendete Ressourcen bereinigen. (Overrides Form..::..Dispose(Boolean).)
Public method | ShowFor | Zeigt das Eigenschaftsfenster für ein gegebenes Objekt an.

See Also

PropertyDialog Class
DynamicNode.WinApp Namespace


Dispose Method

[image]

DynamicNodes API
PropertyDialog..::..Dispose Method
PropertyDialog Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Verwendete Ressourcen bereinigen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

PropertyDialog Class
DynamicNode.WinApp Namespace


ShowFor Method

[image]

DynamicNodes API
PropertyDialog..::..ShowFor Method
PropertyDialog Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Zeigt das Eigenschaftsfenster für ein gegebenes Objekt an.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void ShowFor(
    IWin32Window win,
    Object obj
)
Visual Basic
Public Sub ShowFor ( _
    win As IWin32Window, _
    obj As Object _
)
F#
member ShowFor :
        win:IWin32Window *
        obj:Object -> unit

Parameters

win
Type: System.Windows.Forms..::..IWin32Window
Ein Elternfenster.
obj
Type: System..::..Object
Das Objekt, dessen Eigenschaften angezeigt werden sollen.

See Also

PropertyDialog Class
DynamicNode.WinApp Namespace


TemplateLibrary Class

[image]

DynamicNodes API
TemplateLibrary Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Listet die System- und Benutzervorlagen in einem Baum und stellt Funktionen zur Erzeugung von zugehörigen Oberflächensteuerelementen zur Verfügung.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public class TemplateLibrary
Visual Basic
Public Class TemplateLibrary
F#
type TemplateLibrary =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.WinApp..::..TemplateLibrary

See Also

TemplateLibrary Members
DynamicNode.WinApp Namespace


TemplateLibrary Members

[image] [image]

DynamicNodes API
TemplateLibrary Members
TemplateLibrary Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TemplateLibrary type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateLibrary | Initialisiert eine neue Instanz der Klasse TemplateLibrary.

Properties

 | Name | Description
Public property | SystemRoot | Der Wurzelknoten der Systemvorlagen.
Public property | UserRoot | Der Wurzelknoten der Benutzervorlagen.

See Also

TemplateLibrary Class
DynamicNode.WinApp Namespace


TemplateLibrary Constructor

[image]

DynamicNodes API
TemplateLibrary Constructor
TemplateLibrary Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse TemplateLibrary.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public TemplateLibrary(
    GUICore core
)
Visual Basic
Public Sub New ( _
    core As GUICore _
)
F#
new :
        core:GUICore -> TemplateLibrary

Parameters

core
Type: DynamicNode.WinApp..::..GUICore
Der Kern der Benutzeroberfläche.

See Also

TemplateLibrary Class
DynamicNode.WinApp Namespace


TemplateLibrary Properties

[image] [image]

DynamicNodes API
TemplateLibrary Properties
TemplateLibrary Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TemplateLibrary type exposes the following members.

Properties

 | Name | Description
Public property | SystemRoot | Der Wurzelknoten der Systemvorlagen.
Public property | UserRoot | Der Wurzelknoten der Benutzervorlagen.

See Also

TemplateLibrary Class
DynamicNode.WinApp Namespace


SystemRoot Property

[image]

DynamicNodes API
TemplateLibrary..::..SystemRoot Property
TemplateLibrary Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Wurzelknoten der Systemvorlagen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public TemplateLibrary..::..FolderNode SystemRoot { get; private set; }
Visual Basic
Public Property SystemRoot As TemplateLibrary..::..FolderNode
    Get
    Private Set
F#
member SystemRoot : TemplateLibrary..::..FolderNode with get, private set

See Also

TemplateLibrary Class
DynamicNode.WinApp Namespace


UserRoot Property

[image]

DynamicNodes API
TemplateLibrary..::..UserRoot Property
TemplateLibrary Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Der Wurzelknoten der Benutzervorlagen.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public TemplateLibrary..::..FolderNode UserRoot { get; private set; }
Visual Basic
Public Property UserRoot As TemplateLibrary..::..FolderNode
    Get
    Private Set
F#
member UserRoot : TemplateLibrary..::..FolderNode with get, private set

See Also

TemplateLibrary Class
DynamicNode.WinApp Namespace


TemplateLibrary.FolderNode Class

[image]

DynamicNodes API
TemplateLibrary..::..FolderNode Class
TemplateLibrary Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Knoten in der Vorlagenbibiothek, der ein Verzeichnis repräsentiert.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public class FolderNode : TemplateLibrary..::..Node, IEnumerable<TemplateLibrary..::..Node>,
    IEnumerable
Visual Basic
Public Class FolderNode _
    Inherits TemplateLibrary..::..Node _
    Implements IEnumerable(Of TemplateLibrary..::..Node), IEnumerable
F#
type FolderNode =
    class
        inherit TemplateLibrary..::..Node
        interface IEnumerable<TemplateLibrary..::..Node>
        interface IEnumerable
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.WinApp..::..TemplateLibrary..::..Node
DynamicNode.WinApp..::..TemplateLibrary..::..FolderNode

See Also

TemplateLibrary..::..FolderNode Members
DynamicNode.WinApp Namespace


TemplateLibrary.FolderNode Members

[image] [image]

DynamicNodes API
TemplateLibrary..::..FolderNode Members
TemplateLibrary..::..FolderNode Class Constructors Methods Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Listet die System- und Benutzervorlagen in einem Baum und stellt Funktionen zur Erzeugung von zugehörigen Oberflächensteuerelementen zur Verfügung.

The TemplateLibrary..::..FolderNode type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateLibrary..::..FolderNode | Initialisiert eine neue Instanz der Klasse TemplateLibrary..::..FolderNode.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft.
Public method | Update | Synchronisiert den Inhalt des Verzeichnisknotens mit dem Dateisystem.

Properties

 | Name | Description
Public property | FullPath | Gibt den absoluten Pfad des Knotenelements zurück. (Inherited from TemplateLibrary..::..Node.)
Public property | HasSubFolders | Gibt einen Wert zurück, der angibt, ob dieses Verzeichnis Unterverzeichnisse enthält.
Public property | HasTemplates | Gibt einen Wert zurück, der angibt, ob dieses Verzeichnis Vorlagen enthält.
Public property | IsEmpty | Gibt einen Wert zurück, der angibt, ob dieses Verzeichnis leer ist.
Public property | Name | Gibt den Namen des Knotens zurück. (Inherited from TemplateLibrary..::..Node.)
Public property | SubFolders | Gibt eine Aufzählung mit allen Unterverzeichnissen zurück.
Public property | Templates | Gibt eine Aufzählung mit allen Vorlagen in diesem Verzeichnis zurück.

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


TemplateLibrary.FolderNode Constructor

[image]

DynamicNodes API
TemplateLibrary..::..FolderNode Constructor
TemplateLibrary..::..FolderNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse TemplateLibrary..::..FolderNode.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public FolderNode(
    string fullPath
)
Visual Basic
Public Sub New ( _
    fullPath As String _
)
F#
new :
        fullPath:string -> FolderNode

Parameters

fullPath
Type: System..::..String
Der absolute Pfad des Verzeichnisses.

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


TemplateLibrary.FolderNode Methods

[image] [image]

DynamicNodes API
TemplateLibrary..::..FolderNode Methods
TemplateLibrary..::..FolderNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TemplateLibrary..::..FolderNode type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Gibt einen Enumerator zurück, der die Auflistung durchläuft.
Public method | Update | Synchronisiert den Inhalt des Verzeichnisknotens mit dem Dateisystem.

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


GetEnumerator Method

[image]

DynamicNodes API
TemplateLibrary..::..FolderNode..::..GetEnumerator Method
TemplateLibrary..::..FolderNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Enumerator zurück, der die Auflistung durchläuft.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IEnumerator<TemplateLibrary..::..Node> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of TemplateLibrary..::..Node)
F#
abstract GetEnumerator : unit -> IEnumerator<TemplateLibrary..::..Node>
override GetEnumerator : unit -> IEnumerator<TemplateLibrary..::..Node>

Return Value

Ein IEnumerator<(Of <(<'T>)>)>, der zum Durchlaufen der Auflistung verwendet werden kann.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


Update Method

[image]

DynamicNodes API
TemplateLibrary..::..FolderNode..::..Update Method
TemplateLibrary..::..FolderNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Synchronisiert den Inhalt des Verzeichnisknotens mit dem Dateisystem.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public void Update()
Visual Basic
Public Sub Update
F#
member Update : unit -> unit

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


TemplateLibrary.FolderNode Properties

[image] [image]

DynamicNodes API
TemplateLibrary..::..FolderNode Properties
TemplateLibrary..::..FolderNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TemplateLibrary..::..FolderNode type exposes the following members.

Properties

 | Name | Description
Public property | FullPath | Gibt den absoluten Pfad des Knotenelements zurück. (Inherited from TemplateLibrary..::..Node.)
Public property | HasSubFolders | Gibt einen Wert zurück, der angibt, ob dieses Verzeichnis Unterverzeichnisse enthält.
Public property | HasTemplates | Gibt einen Wert zurück, der angibt, ob dieses Verzeichnis Vorlagen enthält.
Public property | IsEmpty | Gibt einen Wert zurück, der angibt, ob dieses Verzeichnis leer ist.
Public property | Name | Gibt den Namen des Knotens zurück. (Inherited from TemplateLibrary..::..Node.)
Public property | SubFolders | Gibt eine Aufzählung mit allen Unterverzeichnissen zurück.
Public property | Templates | Gibt eine Aufzählung mit allen Vorlagen in diesem Verzeichnis zurück.

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


HasSubFolders Property

[image]

DynamicNodes API
TemplateLibrary..::..FolderNode..::..HasSubFolders Property
TemplateLibrary..::..FolderNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob dieses Verzeichnis Unterverzeichnisse enthält.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool HasSubFolders { get; }
Visual Basic
Public ReadOnly Property HasSubFolders As Boolean
    Get
F#
member HasSubFolders : bool

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


HasTemplates Property

[image]

DynamicNodes API
TemplateLibrary..::..FolderNode..::..HasTemplates Property
TemplateLibrary..::..FolderNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob dieses Verzeichnis Vorlagen enthält.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool HasTemplates { get; }
Visual Basic
Public ReadOnly Property HasTemplates As Boolean
    Get
F#
member HasTemplates : bool

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


IsEmpty Property

[image]

DynamicNodes API
TemplateLibrary..::..FolderNode..::..IsEmpty Property
TemplateLibrary..::..FolderNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt, ob dieses Verzeichnis leer ist.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
F#
member IsEmpty : bool

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


SubFolders Property

[image]

DynamicNodes API
TemplateLibrary..::..FolderNode..::..SubFolders Property
TemplateLibrary..::..FolderNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen Unterverzeichnissen zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IEnumerable<TemplateLibrary..::..FolderNode> SubFolders { get; }
Visual Basic
Public ReadOnly Property SubFolders As IEnumerable(Of TemplateLibrary..::..FolderNode)
    Get
F#
member SubFolders : IEnumerable<TemplateLibrary..::..FolderNode>

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


Templates Property

[image]

DynamicNodes API
TemplateLibrary..::..FolderNode..::..Templates Property
TemplateLibrary..::..FolderNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt eine Aufzählung mit allen Vorlagen in diesem Verzeichnis zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public IEnumerable<TemplateLibrary..::..TemplateNode> Templates { get; }
Visual Basic
Public ReadOnly Property Templates As IEnumerable(Of TemplateLibrary..::..TemplateNode)
    Get
F#
member Templates : IEnumerable<TemplateLibrary..::..TemplateNode>

See Also

TemplateLibrary..::..FolderNode Class
DynamicNode.WinApp Namespace


TemplateLibrary.Node Class

[image]

DynamicNodes API
TemplateLibrary..::..Node Class
TemplateLibrary Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die abstrakte Basisklasse für Knoten in der Baumstruktur der Vorlagenbibliothek.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public abstract class Node
Visual Basic
Public MustInherit Class Node
F#
[<AbstractClassAttribute>]
type Node =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.WinApp..::..TemplateLibrary..::..Node
DynamicNode.WinApp..::..TemplateLibrary..::..FolderNode
DynamicNode.WinApp..::..TemplateLibrary..::..TemplateNode

See Also

TemplateLibrary..::..Node Members
DynamicNode.WinApp Namespace


TemplateLibrary.Node Members

[image] [image]

DynamicNodes API
TemplateLibrary..::..Node Members
TemplateLibrary..::..Node Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Listet die System- und Benutzervorlagen in einem Baum und stellt Funktionen zur Erzeugung von zugehörigen Oberflächensteuerelementen zur Verfügung.

The TemplateLibrary..::..Node type exposes the following members.

Constructors

 | Name | Description
Protected method | TemplateLibrary..::..Node | Initializes a new instance of the TemplateLibrary..::..Node class

Properties

 | Name | Description
Public property | FullPath | Gibt den absoluten Pfad des Knotenelements zurück.
Public property | Name | Gibt den Namen des Knotens zurück.

See Also

TemplateLibrary..::..Node Class
DynamicNode.WinApp Namespace


TemplateLibrary.Node Constructor

[image]

DynamicNodes API
TemplateLibrary..::..Node Constructor
TemplateLibrary..::..Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initializes a new instance of the TemplateLibrary..::..Node class

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
protected Node()
Visual Basic
Protected Sub New
F#
new : unit -> Node

See Also

TemplateLibrary..::..Node Class
DynamicNode.WinApp Namespace


TemplateLibrary.Node Properties

[image] [image]

DynamicNodes API
TemplateLibrary..::..Node Properties
TemplateLibrary..::..Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TemplateLibrary..::..Node type exposes the following members.

Properties

 | Name | Description
Public property | FullPath | Gibt den absoluten Pfad des Knotenelements zurück.
Public property | Name | Gibt den Namen des Knotens zurück.

See Also

TemplateLibrary..::..Node Class
DynamicNode.WinApp Namespace


FullPath Property

[image]

DynamicNodes API
TemplateLibrary..::..Node..::..FullPath Property
TemplateLibrary..::..Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den absoluten Pfad des Knotenelements zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string FullPath { get; protected set; }
Visual Basic
Public Property FullPath As String
    Get
    Protected Set
F#
member FullPath : string with get, set

Field Value

Der absolute Pfads des Knotenelements.

See Also

TemplateLibrary..::..Node Class
DynamicNode.WinApp Namespace


Name Property

[image]

DynamicNodes API
TemplateLibrary..::..Node..::..Name Property
TemplateLibrary..::..Node Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt den Namen des Knotens zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
F#
member Name : string with get, set

Field Value

Der Name des Knotens.

See Also

TemplateLibrary..::..Node Class
DynamicNode.WinApp Namespace


TemplateLibrary.TemplateNode Class

[image]

DynamicNodes API
TemplateLibrary..::..TemplateNode Class
TemplateLibrary Class Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Ein Knoten in der Vorlagenbibiothek, der eine Vorlage repräsentiert.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public class TemplateNode : TemplateLibrary..::..Node
Visual Basic
Public Class TemplateNode _
    Inherits TemplateLibrary..::..Node
F#
type TemplateNode =
    class
        inherit TemplateLibrary..::..Node
    end

Inheritance Hierarchy

System..::..Object
DynamicNode.WinApp..::..TemplateLibrary..::..Node
DynamicNode.WinApp..::..TemplateLibrary..::..TemplateNode

See Also

TemplateLibrary..::..TemplateNode Members
DynamicNode.WinApp Namespace


TemplateLibrary.TemplateNode Members

[image] [image]

DynamicNodes API
TemplateLibrary..::..TemplateNode Members
TemplateLibrary..::..TemplateNode Class Constructors Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Listet die System- und Benutzervorlagen in einem Baum und stellt Funktionen zur Erzeugung von zugehörigen Oberflächensteuerelementen zur Verfügung.

The TemplateLibrary..::..TemplateNode type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateLibrary..::..TemplateNode | Initialisiert eine neue Instanz der Klasse TemplateLibrary..::..TemplateNode.

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung der Vorlage zurück.
Public property | FullPath | Gibt den absoluten Pfad des Knotenelements zurück. (Inherited from TemplateLibrary..::..Node.)
Public property | Name | Gibt den Namen des Knotens zurück. (Inherited from TemplateLibrary..::..Node.)
Public property | Version | Gibt die Dateiversion der Vorlage zurück.

See Also

TemplateLibrary..::..TemplateNode Class
DynamicNode.WinApp Namespace


TemplateLibrary.TemplateNode Constructor

[image]

DynamicNodes API
TemplateLibrary..::..TemplateNode Constructor
TemplateLibrary..::..TemplateNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue Instanz der Klasse TemplateLibrary..::..TemplateNode.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public TemplateNode(
    string fullPath
)
Visual Basic
Public Sub New ( _
    fullPath As String _
)
F#
new :
        fullPath:string -> TemplateNode

Parameters

fullPath
Type: System..::..String
Der absolute Pfad der Vorlage.

See Also

TemplateLibrary..::..TemplateNode Class
DynamicNode.WinApp Namespace


TemplateLibrary.TemplateNode Properties

[image] [image]

DynamicNodes API
TemplateLibrary..::..TemplateNode Properties
TemplateLibrary..::..TemplateNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The TemplateLibrary..::..TemplateNode type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gibt die Beschreibung der Vorlage zurück.
Public property | FullPath | Gibt den absoluten Pfad des Knotenelements zurück. (Inherited from TemplateLibrary..::..Node.)
Public property | Name | Gibt den Namen des Knotens zurück. (Inherited from TemplateLibrary..::..Node.)
Public property | Version | Gibt die Dateiversion der Vorlage zurück.

See Also

TemplateLibrary..::..TemplateNode Class
DynamicNode.WinApp Namespace


Description Property

[image]

DynamicNodes API
TemplateLibrary..::..TemplateNode..::..Description Property
TemplateLibrary..::..TemplateNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschreibung der Vorlage zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string Description { get; private set; }
Visual Basic
Public Property Description As String
    Get
    Private Set
F#
member Description : string with get, private set

See Also

TemplateLibrary..::..TemplateNode Class
DynamicNode.WinApp Namespace


Version Property

[image]

DynamicNodes API
TemplateLibrary..::..TemplateNode..::..Version Property
TemplateLibrary..::..TemplateNode Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Dateiversion der Vorlage zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public float Version { get; set; }
Visual Basic
Public Property Version As Single
    Get
    Set
F#
member Version : float32 with get, set

See Also

TemplateLibrary..::..TemplateNode Class
DynamicNode.WinApp Namespace


ViewDescriptor Class

[image]

DynamicNodes API
ViewDescriptor Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Beschreibt eine Ansicht der Entwicklungsumgebung.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public class ViewDescriptor
Visual Basic
Public Class ViewDescriptor
F#
type ViewDescriptor =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.WinApp..::..ViewDescriptor

See Also

ViewDescriptor Members
DynamicNode.WinApp Namespace


ViewDescriptor Members

[image] [image]

DynamicNodes API
ViewDescriptor Members
ViewDescriptor Class Properties See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ViewDescriptor type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung der Ansicht zurück.
Public property | Id | Gibt die ID der Ansicht zurück.
Public property | Shortcut | Gibt ein Tastaturkürzel zum Ausfruf der Ansicht zurück.
Public property | SortIndex | Gibt einen Sortierindex für die Auflistung mehrerer Ansichten in einer Liste zurück. Dieser Index ist z.B. nützlich, wenn die Ansichten in einem Menü angezeigt werden.
Public property | WithAutoUI | Gibt einen Wert zurück, der angibt ob für diese Ansicht automatisch eine Benutzerschnittstelle zum Ein- und Ausblenden erzeugt werden soll. Dazu gehört z.B. ein Eintrag in einem Ansichts-Menü.

See Also

ViewDescriptor Class
DynamicNode.WinApp Namespace


ViewDescriptor Properties

[image] [image]

DynamicNodes API
ViewDescriptor Properties
ViewDescriptor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The ViewDescriptor type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Gibt die Beschriftung der Ansicht zurück.
Public property | Id | Gibt die ID der Ansicht zurück.
Public property | Shortcut | Gibt ein Tastaturkürzel zum Ausfruf der Ansicht zurück.
Public property | SortIndex | Gibt einen Sortierindex für die Auflistung mehrerer Ansichten in einer Liste zurück. Dieser Index ist z.B. nützlich, wenn die Ansichten in einem Menü angezeigt werden.
Public property | WithAutoUI | Gibt einen Wert zurück, der angibt ob für diese Ansicht automatisch eine Benutzerschnittstelle zum Ein- und Ausblenden erzeugt werden soll. Dazu gehört z.B. ein Eintrag in einem Ansichts-Menü.

See Also

ViewDescriptor Class
DynamicNode.WinApp Namespace


Caption Property

[image]

DynamicNodes API
ViewDescriptor..::..Caption Property
ViewDescriptor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Beschriftung der Ansicht zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string Caption { get; }
Visual Basic
Public ReadOnly Property Caption As String
    Get
F#
member Caption : string

Field Value

Die Beschriftung der Ansicht.

See Also

ViewDescriptor Class
DynamicNode.WinApp Namespace


Id Property

[image]

DynamicNodes API
ViewDescriptor..::..Id Property
ViewDescriptor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID der Ansicht zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
F#
member Id : string

Field Value

Die ID der Ansicht.

See Also

ViewDescriptor Class
DynamicNode.WinApp Namespace


Shortcut Property

[image]

DynamicNodes API
ViewDescriptor..::..Shortcut Property
ViewDescriptor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt ein Tastaturkürzel zum Ausfruf der Ansicht zurück.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public Keys Shortcut { get; }
Visual Basic
Public ReadOnly Property Shortcut As Keys
    Get
F#
member Shortcut : Keys

Field Value

Ein Tastaturkürzel zum Aufruf der Ansicht.

See Also

ViewDescriptor Class
DynamicNode.WinApp Namespace


SortIndex Property

[image]

DynamicNodes API
ViewDescriptor..::..SortIndex Property
ViewDescriptor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Sortierindex für die Auflistung mehrerer Ansichten in einer Liste zurück. Dieser Index ist z.B. nützlich, wenn die Ansichten in einem Menü angezeigt werden.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public int SortIndex { get; }
Visual Basic
Public ReadOnly Property SortIndex As Integer
    Get
F#
member SortIndex : int

Field Value

Der Sortierindex der Ansicht.

See Also

ViewDescriptor Class
DynamicNode.WinApp Namespace


WithAutoUI Property

[image]

DynamicNodes API
ViewDescriptor..::..WithAutoUI Property
ViewDescriptor Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt einen Wert zurück, der angibt ob für diese Ansicht automatisch eine Benutzerschnittstelle zum Ein- und Ausblenden erzeugt werden soll. Dazu gehört z.B. ein Eintrag in einem Ansichts-Menü.

Namespace: DynamicNode.WinApp
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public bool WithAutoUI { get; }
Visual Basic
Public ReadOnly Property WithAutoUI As Boolean
    Get
F#
member WithAutoUI : bool

Field Value

true wenn für diese Ansicht automatisch eine Benutzerschnittstelle zum Ein- und Ausblenden erzeugt werden soll, sonst false.

See Also

ViewDescriptor Class
DynamicNode.WinApp Namespace


DynamicNode.WinApp.Tools Namespace

[image]

DynamicNodes API
DynamicNode.WinApp.Tools Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "N:DynamicNode.WinApp.Tools"]

Classes

 | Class | Description
Public class | GuiExtensions | Stellt Befehls-Handler für Befehle der Benutzeroberfläche bereit


GuiExtensions Class

[image]

DynamicNodes API
GuiExtensions Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Stellt Befehls-Handler für Befehle der Benutzeroberfläche bereit

Namespace: DynamicNode.WinApp.Tools
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public static class GuiExtensions
Visual Basic
Public NotInheritable Class GuiExtensions
F#
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GuiExtensions =  class end

Inheritance Hierarchy

System..::..Object
DynamicNode.WinApp.Tools..::..GuiExtensions

See Also

GuiExtensions Members
DynamicNode.WinApp.Tools Namespace


GuiExtensions Members

[image] [image]

DynamicNodes API
GuiExtensions Members
GuiExtensions Class Methods See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GuiExtensions type exposes the following members.

Methods

Name | Description
NodeDuplicate | Dupliziert einen Knoten.
NodeIsolate | Trennt alle Verbindunge zu einem Knoten.
NodeIsolateCheck | Prüft ob ein Knoten isoliert werden kann.

See Also

GuiExtensions Class
DynamicNode.WinApp.Tools Namespace


GuiExtensions Methods

[image] [image]

DynamicNodes API
GuiExtensions Methods
GuiExtensions Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The GuiExtensions type exposes the following members.

Methods

Name | Description
NodeDuplicate | Dupliziert einen Knoten.
NodeIsolate | Trennt alle Verbindunge zu einem Knoten.
NodeIsolateCheck | Prüft ob ein Knoten isoliert werden kann.

See Also

GuiExtensions Class
DynamicNode.WinApp.Tools Namespace


NodeDuplicate Method

[image]

DynamicNodes API
GuiExtensions..::..NodeDuplicate Method
GuiExtensions Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Dupliziert einen Knoten.

Namespace: DynamicNode.WinApp.Tools
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public static void NodeDuplicate(
    GUICore core,
    INode node
)
Visual Basic
Public Shared Sub NodeDuplicate ( _
    core As GUICore, _
    node As INode _
)
F#
static member NodeDuplicate :
        core:GUICore *
        node:INode -> unit

Parameters

core
Type: DynamicNode.WinApp..::..GUICore
Der Anwendungskern.
node
Type: DynamicNode.Core..::..INode
Der ausgewählte Knoten.

See Also

GuiExtensions Class
DynamicNode.WinApp.Tools Namespace


NodeIsolate Method

[image]

DynamicNodes API
GuiExtensions..::..NodeIsolate Method
GuiExtensions Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Trennt alle Verbindunge zu einem Knoten.

Namespace: DynamicNode.WinApp.Tools
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public static void NodeIsolate(
    GUICore core,
    INode node
)
Visual Basic
Public Shared Sub NodeIsolate ( _
    core As GUICore, _
    node As INode _
)
F#
static member NodeIsolate :
        core:GUICore *
        node:INode -> unit

Parameters

core
Type: DynamicNode.WinApp..::..GUICore
Der Anwendungskern.
node
Type: DynamicNode.Core..::..INode
Der ausgewählte Knoten.

See Also

GuiExtensions Class
DynamicNode.WinApp.Tools Namespace


NodeIsolateCheck Method

[image]

DynamicNodes API
GuiExtensions..::..NodeIsolateCheck Method
GuiExtensions Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Prüft ob ein Knoten isoliert werden kann.

Namespace: DynamicNode.WinApp.Tools
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public static void NodeIsolateCheck(
    GUICore core,
    INode node,
    ConditionResult result
)
Visual Basic
Public Shared Sub NodeIsolateCheck ( _
    core As GUICore, _
    node As INode, _
    result As ConditionResult _
)
F#
static member NodeIsolateCheck :
        core:GUICore *
        node:INode *
        result:ConditionResult -> unit

Parameters

core
Type: DynamicNode.WinApp..::..GUICore
Der Anwendungskern.
node
Type: DynamicNode.Core..::..INode
Der ausgewählte Knoten.
result
Type: DynamicNode.Ext.Gui..::..ConditionResult
Der Container für das Ergebnis.

See Also

GuiExtensions Class
DynamicNode.WinApp.Tools Namespace


DynamicNode.WinApp.Views Namespace

[image]

DynamicNodes API
DynamicNode.WinApp.Views Namespace
Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

[Missing <summary> documentation for "N:DynamicNode.WinApp.Views"]

Classes

 | Class | Description
Public class | AbstractView | Die Basisklasse für Ansichtsfenster in der Entwicklungsumgebung.

Enumerations

 | Enumeration | Description
Public enumeration | ViewPosition | Die verschiedenen Positionen, die ein Ansichtsfenster einnehmen kann.


AbstractView Class

[image]

DynamicNodes API
AbstractView Class
Members See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die Basisklasse für Ansichtsfenster in der Entwicklungsumgebung.

Namespace: DynamicNode.WinApp.Views
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public abstract class AbstractView : DockContent
Visual Basic
Public MustInherit Class AbstractView _
    Inherits DockContent
F#
[<AbstractClassAttribute>]
type AbstractView =
    class
        inherit DockContent
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
DockContent
DynamicNode.WinApp.Views..::..AbstractView

See Also

AbstractView Members
DynamicNode.WinApp.Views Namespace


AbstractView Members

[image] [image]

DynamicNodes API
AbstractView Members
AbstractView Class Constructors Methods Properties Events See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractView type exposes the following members.

Constructors

 | Name | Description
Protected method | AbstractView | Initialisiert eine neue AbstractView-Instanz.

Methods

 | Name | Description
Public method | Activate | (Inherited from DockContent.)
Public method | DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
Public method | DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)
Public method | FloatAt | (Inherited from DockContent.)
Protected method | GetPersistString | (Inherited from DockContent.)
Public method | Hide | (Inherited from DockContent.)
Public method | IsDockStateValid | (Inherited from DockContent.)
Protected method | OnDockStateChanged | (Inherited from DockContent.)
Protected method | OnViewPositionChanged | Löst das Ereignis ViewPositionChanged aus.
Public method | Show()()()() | (Inherited from DockContent.)
Public method | Show(DockPanel) | (Inherited from DockContent.)
Public method | Show(DockPanel, DockState) | (Inherited from DockContent.)
Public method | Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Public method | Show(DockPane, IDockContent) | (Inherited from DockContent.)
Public method | Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

Properties

 | Name | Description
Public property | AllowEndUserDocking | (Inherited from DockContent.)
Public property | AutoHidePortion | (Inherited from DockContent.)
Public property | CloseButton | (Inherited from DockContent.)
Public property | DockAreas | (Inherited from DockContent.)
Public property | DockHandler | (Inherited from DockContent.)
Public property | DockPanel | (Inherited from DockContent.)
Public property | DockState | (Inherited from DockContent.)
Public property | FloatPane | (Inherited from DockContent.)
Public property | HideOnClose | (Inherited from DockContent.)
Public property | IsActivated | (Inherited from DockContent.)
Public property | IsFloat | (Inherited from DockContent.)
Public property | IsHidden | (Inherited from DockContent.)
Public property | Pane | (Inherited from DockContent.)
Public property | PanelPane | (Inherited from DockContent.)
Public property | ShowHint | (Inherited from DockContent.)
Public property | TabPageContextMenu | (Inherited from DockContent.)
Public property | TabPageContextMenuStrip | (Inherited from DockContent.)
Public property | TabText | (Inherited from DockContent.)
Public property | ToolTipText | (Inherited from DockContent.)
Public property | ViewId | Gibt die ID des Ansihctsfensters zurück.
Public property | ViewPosition | Gibt die Position des Ansichtsfensters zurück oder legt sie fest.
Public property | VisibleState | (Inherited from DockContent.)

Events

 | Name | Description
Public event | DockStateChanged | (Inherited from DockContent.)
Public event | ViewPositionChanged | Tritt auf, wenn die Position der Ansicht geändert wurde.

See Also

AbstractView Class
DynamicNode.WinApp.Views Namespace


AbstractView Constructor

[image]

DynamicNodes API
AbstractView Constructor
AbstractView Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Initialisiert eine neue AbstractView-Instanz.

Namespace: DynamicNode.WinApp.Views
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
protected AbstractView(
    ViewPosition initPos
)
Visual Basic
Protected Sub New ( _
    initPos As ViewPosition _
)
F#
new :
        initPos:ViewPosition -> AbstractView

Parameters

initPos
Type: DynamicNode.WinApp.Views..::..ViewPosition
Die anfängliche Position der Ansicht.

See Also

AbstractView Class
DynamicNode.WinApp.Views Namespace


AbstractView Methods

[image] [image]

DynamicNodes API
AbstractView Methods
AbstractView Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractView type exposes the following members.

Methods

 | Name | Description
Public method | Activate | (Inherited from DockContent.)
Public method | DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
Public method | DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)
Public method | FloatAt | (Inherited from DockContent.)
Protected method | GetPersistString | (Inherited from DockContent.)
Public method | Hide | (Inherited from DockContent.)
Public method | IsDockStateValid | (Inherited from DockContent.)
Protected method | OnDockStateChanged | (Inherited from DockContent.)
Protected method | OnViewPositionChanged | Löst das Ereignis ViewPositionChanged aus.
Public method | Show()()()() | (Inherited from DockContent.)
Public method | Show(DockPanel) | (Inherited from DockContent.)
Public method | Show(DockPanel, DockState) | (Inherited from DockContent.)
Public method | Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Public method | Show(DockPane, IDockContent) | (Inherited from DockContent.)
Public method | Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

AbstractView Class
DynamicNode.WinApp.Views Namespace


DockTo Method

[image] [image]

DynamicNodes API
AbstractView..::..DockTo Method
AbstractView Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
Public method | DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

AbstractView Class
AbstractView Members
DynamicNode.WinApp.Views Namespace


OnViewPositionChanged Method

[image]

DynamicNodes API
AbstractView..::..OnViewPositionChanged Method
AbstractView Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Löst das Ereignis ViewPositionChanged aus.

Namespace: DynamicNode.WinApp.Views
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
protected virtual void OnViewPositionChanged()
Visual Basic
Protected Overridable Sub OnViewPositionChanged
F#
abstract OnViewPositionChanged : unit -> unit
override OnViewPositionChanged : unit -> unit

See Also

AbstractView Class
DynamicNode.WinApp.Views Namespace


Show Method

[image] [image]

DynamicNodes API
AbstractView..::..Show Method
AbstractView Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

Overload List

 | Name | Description
Public method | Show()()()() | (Inherited from DockContent.)
Public method | Show(DockPanel) | (Inherited from DockContent.)
Public method | Show(DockPanel, DockState) | (Inherited from DockContent.)
Public method | Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Public method | Show(DockPane, IDockContent) | (Inherited from DockContent.)
Public method | Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

AbstractView Class
AbstractView Members
DynamicNode.WinApp.Views Namespace


AbstractView Properties

[image] [image]

DynamicNodes API
AbstractView Properties
AbstractView Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractView type exposes the following members.

Properties

 | Name | Description
Public property | AllowEndUserDocking | (Inherited from DockContent.)
Public property | AutoHidePortion | (Inherited from DockContent.)
Public property | CloseButton | (Inherited from DockContent.)
Public property | DockAreas | (Inherited from DockContent.)
Public property | DockHandler | (Inherited from DockContent.)
Public property | DockPanel | (Inherited from DockContent.)
Public property | DockState | (Inherited from DockContent.)
Public property | FloatPane | (Inherited from DockContent.)
Public property | HideOnClose | (Inherited from DockContent.)
Public property | IsActivated | (Inherited from DockContent.)
Public property | IsFloat | (Inherited from DockContent.)
Public property | IsHidden | (Inherited from DockContent.)
Public property | Pane | (Inherited from DockContent.)
Public property | PanelPane | (Inherited from DockContent.)
Public property | ShowHint | (Inherited from DockContent.)
Public property | TabPageContextMenu | (Inherited from DockContent.)
Public property | TabPageContextMenuStrip | (Inherited from DockContent.)
Public property | TabText | (Inherited from DockContent.)
Public property | ToolTipText | (Inherited from DockContent.)
Public property | ViewId | Gibt die ID des Ansihctsfensters zurück.
Public property | ViewPosition | Gibt die Position des Ansichtsfensters zurück oder legt sie fest.
Public property | VisibleState | (Inherited from DockContent.)

See Also

AbstractView Class
DynamicNode.WinApp.Views Namespace


ViewId Property

[image]

DynamicNodes API
AbstractView..::..ViewId Property
AbstractView Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die ID des Ansihctsfensters zurück.

Namespace: DynamicNode.WinApp.Views
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public abstract string ViewId { get; }
Visual Basic
Public MustOverride ReadOnly Property ViewId As String
    Get
F#
abstract ViewId : string

Field Value

Die ID des Ansichtsfensters.

See Also

AbstractView Class
DynamicNode.WinApp.Views Namespace


ViewPosition Property

[image]

DynamicNodes API
AbstractView..::..ViewPosition Property
AbstractView Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Gibt die Position des Ansichtsfensters zurück oder legt sie fest.

Namespace: DynamicNode.WinApp.Views
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public ViewPosition ViewPosition { get; set; }
Visual Basic
Public Property ViewPosition As ViewPosition
    Get
    Set
F#
member ViewPosition : ViewPosition with get, set

Field Value

Die Position des Ansichtsfensters.

See Also

AbstractView Class
DynamicNode.WinApp.Views Namespace


AbstractView Events

[image] [image]

DynamicNodes API
AbstractView Events
AbstractView Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]

The AbstractView type exposes the following members.

Events

 | Name | Description
Public event | DockStateChanged | (Inherited from DockContent.)
Public event | ViewPositionChanged | Tritt auf, wenn die Position der Ansicht geändert wurde.

See Also

AbstractView Class
DynamicNode.WinApp.Views Namespace


ViewPositionChanged Event

[image]

DynamicNodes API
AbstractView..::..ViewPositionChanged Event
AbstractView Class See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Tritt auf, wenn die Position der Ansicht geändert wurde.

Namespace: DynamicNode.WinApp.Views
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public event EventHandler ViewPositionChanged
Visual Basic
Public Event ViewPositionChanged As EventHandler
F#
member ViewPositionChanged : IEvent<EventHandler,
    EventArgs>

See Also

AbstractView Class
DynamicNode.WinApp.Views Namespace


ViewPosition Enumeration

[image]

DynamicNodes API
ViewPosition Enumeration
See Also Send Feedback
[Diese Dokumentation ist noch nicht fertig und kann sich bis zur entgültigen Version noch ändern.]
Die verschiedenen Positionen, die ein Ansichtsfenster einnehmen kann.

Namespace: DynamicNode.WinApp.Views
Assembly: DNWinApp (in DNWinApp.exe) Version: 1.4.4679.19840 (1.4.0.0)

Syntax

C#
public enum ViewPosition
Visual Basic
Public Enumeration ViewPosition
F#
type ViewPosition

Members

Member name | Description
Document |
Top |
TopAutoHide |
Right |
RightAutoHide |
Bottom |
BottomAutoHide |
Left |
LeftAutoHide |
Floating |
Hidden |
Unknown |

See Also

DynamicNode.WinApp.Views Namespace